Where to Start

Virtual Radar Server Source Documentation
Where to Start

When you're looking for stuff I would start by looking for the interface in VirtualRadar.Interface. All of the interfaces are in there and so is all of the documentation. Most of the implementations can be found within VirtualRadar.Library, following the same namespace as the interface (but with 'Library' replacing 'Interface') with the exception of the the Database interfaces, which are implemented in VirtualRadar.Database.dll, the View interfaces (VirtualRadar.WinForms.dll), the WebServer interfaces (VirtualRadar.WebServer.dll) and the WebSite interfaces (VirtualRadar.WebSite.dll).

When browsing the documentation I would start with VirtualRadar.Interface and then go from there.

The program uses loose coupling quite a lot, which means that instances of classes are rarely created using new. A library is used to create instances instead - for more details about this see InterfaceFactory and Factory

© 2010 onwards, Andrew Whewell

Send comments on this topic to andrew@virtualradarserver.co.uk


Plugin Development

Plugin Development

Plugins are .NET 3.5 DLLs that can be loaded and executed by Virtual Radar Server. They can hook VRS events to add to existing behaviour or they can override VRS objects to create new behaviour.

It is recommended that you have a look at InterfaceFactory to familiarise yourself with the class factory mechanism used by Virtual Radar Server to create objects and the VirtualRadar.Interface namespaces (there are several below VirtualRadar.Interface) to see the interfaces that are declared by Virtual Radar Server.

You may also want to look at ISingletonT to familiarise yourself with the mechanism used to access singleton instances of objects and IBackgroundThreadExceptionCatcher to review the interface that objects, including plugins, can implement to pass exceptions raised on background threads up to the GUI thread for reporting and logging.

Overview and Lifetime

Plugins are .NET DLLs that are copied into their own folder within Virtual Radar Server's Plugins folder. The root Plugins folder is created by the Virtual Radar Server installer. Each plugin has one public class that implements IPlugin.

Each plugin DLL must have a filename that starts with VirtualRadar.Plugin. - so for example, VirtualRadar.Plugin.Example.dll is a valid filename for a plugin whereas Example.dll or VirtualRadar.PluginExample.dll are not.

A manifest file, whose filename is the same as the DLL but with an extension of XML (see PluginManifest), must be present in the same folder as the plugin DLL. The manifest file can be used to restrict the loading of the plugin to certain versions of Virtual Radar Server. This can be especially important if your plugin replaces standard implementations of interfaces as the interfaces are likely to change from one release of Virtual Radar Server to another, particularly in the early part of the application's lifetime.

When Virtual Radar Server first starts up it looks in all of the folders below its Plugins folder. If it finds a file that matches the naming convention above then it loads it and looks for the single public class that implements IPlugin. It then creates a single instance of that class and calls methods on it over the lifetime of the application.

The first method that is called is RegisterImplementations(IClassFactory). This is called just after the program has registered its own implementations of all of the interfaces in VirtualRadar.Interface.dll. It is at this point that the plugin can replace the standard implementations of interfaces with its own classes. At this point the program will not have created any of the objects except for the ILog singleton object, so if the plugin replaces an implementation with its own then that implementation will be used by the main application. The GUI does not exist when this function is called so the method should not make any GUI calls.

The next method that is called is Startup(PluginStartupParameters). This is called on a background thread while the splash screen is on display so the method should not make any GUI calls. It is called after the application has created and initialised all of the singletons and main objects used by the application. By this point the program is potentially processing messages coming in from BaseStation and requests coming from browsers, but without showing anying on screen. The plugin can load its own configuration here (see IPluginSettingsStorage) and begin doing some useful work here.

Once Virtual Radar Server has finished initialising itself and has started the GUI it then calls GuiThreadStartup. This is called on the main GUI thread but before the GUI is shown to the user. You can use this method to do any initialisation that must be performed on the GUI thread, or to start your own modeless display. Please don't create a modal display, it will block access to the Virtual Radar Server GUI.

If your plugin class implements IBackgroundThreadExceptionCatcher then the splash screen will hook your class up to the standard mechanism for logging and reporting exceptions on your background thread via the GUI thread.

The user can bring up a list of running plugins at any time to view their status and optionally configure them. If the plugin indicates that it has an options screen then ShowWinFormsOptionsUI will be called whenever the user wants to configure the plugin.

Finally when the user closes the main screen the program calls Shutdown to give the plugin a chance to clean up after itself before the program quits. By this point the BaseStation listener will have stopped receiving messages but many of the other objects will still be active and waiting to be disposed. You will be called on a background thread so you should not make any GUI calls.

Development Environment

You must have Visual Studio 2010 installed so that you can compile the plugin. The free Express version will be fine.

When you add the project remember that the DLL that it builds must be start with VirtualRadar.Plugin..

The plugin must target .NET Framework 3.5 (the full profile, not the client profile).

The project must link to InterfaceFactory.dll and VirtualRadar.Interface.dll. You can link to the versions of these files that ship with Virtual Radar Server, you do not have to build your own copies.

As a post-build step you may want to copy the plugin DLL and the XML manifest file into the appropriate folder within the Plugins folder for your Virtual Radar Server installation. It is probably alright to just set the build folder to be your plugin's folder but when you ship the product remember not to ship any libraries that are shipped with Virtual Radar Server that might also have been copied into your plugin folder by the compiler.

Virtual Radar Server runs as a 32-bit application, even on 64-bit systems. If you are using third-party libraries and have a choice of 32-bit or 64-bit then use the 32-bit flavour.

If you want to use the SQLite ADO.Net data adapter or the IQueryable Toolkit then always link to the versions that ship with Virtual Radar Server and do not ship your own versions.

Localisation

Prior to 1.1.0 plugins could not make use of VRS's text translation mechanism, they were responsible for doing their own translations. This has now changed.

All of the UI text for a plugin should be put into a single RESX file. The name of the file isn't important but for the sake of the example we'll call it PluginStrings.resx. Each string is identified with a key, e.g. the key for the text "Click OK to continue" might be ClickOK. When Visual Studio compiles the RESX file it will create a class named after the RESX file with all of the keys as string properties. You can refer to these properties directly from within the code of your plugin - e.g.:

Copy
...
MessageBox.Show(PluginStrings.ClickOK, PluginStrings.OperationFinished);
...

To localise the text for forms and UI elements you will need to add a reference to the VirtualRadar.Localistion library. The library contains the Localiser class, which contains methods that can look for RESX keys in the text of controls and replace the keys with the translated text at runtime. Most of these methods will look for string keys within :: delimiters. Any text within a pair of :: will be considered to be a key in the RESX file, anything outside of the :: will be left alone.

So for example, assume your PluginStrings.resx file has the following entries:

Copy
EnterAirport = "Please enter airport name"
Generate = "Generate File"
GenerateFile = "Generate Airport File"

The form has a title whose text is "::GenerateFile::", a label whose text is "::EnterAirport:::", and a button whose text is "::Generate::". Note that EnterAirport has three colons after it - the last colon is not a part of the key identifier and will be left in the label text after translation.

In the load event for the form you create an instance of the Localiser class and ask it to translate all of the text on the form (don't put the call to the Localiser into the constructor, Visual Studio will try to run it when you edit your form in the designer):

Copy
protected override void OnLoad(EventArgs e)
{
    var localiser = new Localiser(typeof(PluginStrings));
    localiser.Form(this);
}

After the Form method has been called the title will be "Generate Airport File", the label will be "Please enter airport name:" and the button will be "Generate Airport File".

To supply translations for the text you create another RESX file which has the same name as the English RESX file but with the ISO code for the region and language appended. For example, the French translation for PluginStrings.resx would be called PluginStrings.fr-FR.resx, the German file would be PluginStrings.de-DE.resx and so on.

The RESX file should contain the same keys as the English file. If any keys are present in the English file but missing from the translated file then the English text will be used. Any keys present in the translated file but not present in the English file will be inaccessible to the plugin.

The English RESX file will be compiled into the plugin DLL but the translation RESX files are not. They are compiled into DLLs that are named after the plugin and are compiled into directories named after the region / language code. For example, if you have French and Russian versions of your RESX files and your plugin DLL is called PluginExample.dll then after compilation you will have two sub-folders under the build folder, one called fr-FR and the other ru-RU, and within each you will have a DLL called PluginExample.resources.dll that contains all of the translated RESX files.

When you install the plugin the translation DLLs must go into the language folders directly underneath the Virtual Radar application folder. They do not live under the plugin folder. The language folders contain translation DLLs for Virtual Radar Server and all of the plugins so it is important that you choose a name for your plugin DLL that will not clash with other plugins or with Virtual Radar Server itself.

The program can be started with the command-line parameter '-culture:xx-YY' to switch the GUI thread's culture over to another country for testing. For example, starting the program with '-culture:de-DE' will start the program with the German culture active.

Installation

Virtual Radar Server uses InnoSetup for its installer but it's up to you how you package the plugin. At the very minimum you will need to install two files on the end-user's system - the DLL and the XML manifest file. These must go into the folder VRS-APPLICATION-FOLDER\Plugins\NAME-OF-YOUR-PLUGIN. The name of your plugin's folder can be anything you like. It can contain more than one plugin if you like. It's entirely up to you.

If you have localised resource DLLS then they must go into the folder VRS-APPLICATION-FOLDER\XX-YY where XX-YY is the culture name. They do not go into your plugin's folder.

Any third party libraries that you depend upon, and which are not already shipped with Virtual Radar Server, should go into the same folder as your plugin.

Here is an example InnoSetup install script for one of the Virtual Radar Server plugin installers. The script uses relative paths, it is in a folder which is a sibling of the plugin project's folder:

Copy
#define Plugin "{app}\Plugins\BaseStationDatabaseWriter"

[Setup]
AppName=Database Writer VRS Plugin
AppVerName=Database Writer VRS Plugin 1.0.0
DefaultDirName={pf}\VirtualRadar
DefaultGroupName=Virtual Radar
InfoBeforeFile=VersionHistory.rtf
LicenseFile=License.txt
MinVersion=5.0,5.01.2600sp2
OutputBaseFileName=DatabaseWriterPluginSetup

[Messages]
WizardInfoBefore=Version History
InfoBeforeLabel=What has changed?

[Files]
; License
Source: "..\LICENSE.txt"; DestDir: "{#Plugin}"; Flags: ignoreversion;

; Application files
Source: "..\VirtualRadar.Plugin.BaseStationDatabaseWriter\bin\x86\Release\VirtualRadar.Plugin.BaseStationDatabaseWriter.dll"; DestDir: "{#Plugin}"; Flags: ignoreversion;

; Manifest file
Source: "..\VirtualRadar.Plugin.BaseStationDatabaseWriter\VirtualRadar.Plugin.BaseStationDatabaseWriter.xml"; DestDir: "{#Plugin}"; Flags: ignoreversion;

; Resource files - note that .NET expects these to be in a folder directly below the application startup folder, not in our plugins folder
Source: "..\VirtualRadar.Plugin.BaseStationDatabaseWriter\bin\x86\Release\de-DE\VirtualRadar.Plugin.BaseStationDatabaseWriter.resources.dll"; DestDir: "{app}\de-DE"; Flags: ignoreversion;
Further Questions

I hope that I've covered enough to get you started on writing a plugin but if there are any areas that are unclear, or if you find that the application as it stands does not give you enough leeway to do what you want, then please feel free to get in touch. I can be reached via the website, the forum or at the feedback email address at the bottom of this page.


How To Receive Aircraft Transmissions

How To Receive Aircraft Transmissions

Virtual Radar Server can listen to several different formats of aircraft message data. In the code they are referred to as:

  • Sbs3 - Kinetic's format for transmitting the Mode-S / ADS-B bytes received from the aircraft via an SBS-3 receiver.

  • Port30003 - Kinetic's de-facto standard for transmitting aircraft data from BaseStation. Many other programs can output this format.

  • Beast - this format encompasses the three AVR text-based message formats for Mode-S / ADS-B bytes (one each for with parity, without parity and with MLAT timestamps) and the Beast's binary format.

At the time of writing it can listen to feeds over a network connection or a serial port connection.

The interface for the object that receives these messages is IListener. In principle there could be many listeners running simultaneously but in practise the application only creates one. The single listener is created by the singleton object IAutoConfigListener. This object creates a listener and then applies configuration settings to it. When the user changes the configuration the object automatically applies the new settings to the listener.

The listener does not have any code to listen to a data feed, nor does it have any code to extract messages out of the feed. It is given classes that can do these jobs. IListenerProviders can read bytes from a connection to the feed (ITcpListenerProvider listens to network connections, ISerialListenerProvider listens to serial port connections) and IMessageBytesExtractors can extract raw (i.e. Mode-S) or Port30003 messages from the bytes received from the feed (ISbs3MessageBytesExtractor decodes SBS-3 format feeds, IPort30003MessageBytesExtractor decodes Port30003 format feeds and IBeastMessageBytesExtractor decodes the AVR and Beast binary format feeds).

The listener has a number of events that it can raise once a message is received. All of these events are raised on a background thread so that a slow message handler cannot cause delays in the listener. The same background thread is used for all background events so the events are guaranteed to be received in the same order for all messages.

IListener Message Flow

Virtual Radar Server creates an IAutoConfigListener when the application starts up and the IBaseStationAircraftList listens to it for information about the aircraft that it is tracking. Your plugin can use the same listener to pick up aircraft messages at any stage in the message processing pipeline, from raw bytes to cooked BaseStationMessage.

Obtain a reference to the listener

  • IAutoConfigListener is a singleton object. You can get a reference to it by calling the Interface Factory. The listener that it is controlling is exposed via its Listener property:

    Copy
    public void Startup(PluginStartupParameters parameters)
{
    var listener = Factory.Singleton.Resolve<IAutoConfigListener>().Singleton.Listener;
}

Hook the events

  • The listener can raise one of four events when a message is received ( RawBytesReceived, ModeSBytesReceived, ModeSMessageReceived and Port30003MessageReceived ).

    Copy
    public void Startup(PluginStartupParameters parameters)
{
    // See above for instructions on initialising the listener variable

    listener.Port30003MessageReceived += Listener_Port30003MessageReceived;
}

Do some work on receipt of a message

  • Now all you need is the event handler. When you do your work bear in mind that you are always running on a non-GUI thread. You cannot make any GUI calls when a message is received.

    Copy
    private void Listener_Port30003MessageReceived(object sender, BaseStationMessageEventArgs args)
{
    BaseStationMessage message = args.Message;

    // Do something with the message from the aircraft...
}
See Also

Other Resources

Dealing with exceptions in plugins


How To Add Web Site Content

How To Add Web Site Content

The IWebServer interface wraps a web server that raises an event called RequestReceived whenever a web browser connects and requests some content. To add your own content you need to hook this event and respond whenever any requests arrive for content you want to expose.

The IWebServer that Virtual Radar Server uses is wrapped in another interface, IAutoConfigWebServer. This is a singleton object that automatically applies the configuration settings to the web server. You would usually want to hook events raised by the IWebServer that the auto-config object exposes.

Obtain a reference to an IWebServer

  • This is as simple as getting hold of the singleton IAutoConfigWebServer and referencing its WebServer property.

    Copy
    using VirtualRadar.Interface.WebServer;

public void Startup(PluginStartupParameters parameters)
{
    var webServer = Factory.Singleton.Resolve<IAutoConfigWebServer>().Singleton.WebServer;
}

Hook the web server's RequestReceived event

  • There are actually three RequestReceived events: BeforeRequestReceived, RequestReceived and AfterRequestReceived. Virtual Radar Server hooks RequestReceived. If you hook BeforeRequestReceived then you will see requests before the built-in web site and if you hook AfterRequestReceived you see them afterwards.

    Normally you would use BeforeRequestReceived if you wanted to change the default web site in some way, usually by processing a request for a page before the standard website had a chance to.

    You would use AfterRequestReceived to add new content onto the site in such a way that you cannot accidentally conflict with the standard site. You can check to see whether the standard site has already handled the request before you attempt to fulfill it yourself.

    Copy
    public void Startup(PluginStartupParameters parameters)
{
    var webServer = Factory.Singleton.Resolve<IAutoConfigWebServer>().Singleton.WebServer;
    webServer.AfterRequestReceived += WebServer_AfterRequestReceived;
}

Serve content on receipt of a request

  • When a request comes in from the browser the web server passes a RequestReceivedEventArgs object to the event handlers. The Handled property indicates whether another event handler has already served content for the request - if one has then you should always ignore the event. Bear in mind that even though Virtual Radar Server may not be using the event you're hooking other plugins could be, so you need to play nicely with them.

    The RequestReceivedEventArgs carries a number of read-only properties that tell you about the request that was received. It also has a property called Response that you can use to send a response back to the browser.

    The response generally needs a few properties setting up and it only exposes a stream on which to send the response. The IResponder interface simplifies filling out response objects for you.

    The response object includes the MimeType property. There is a class in VirtualRadar.Interface.WebServer called MimeType that exposes some common mime types for you to use.

    The RequestReceivedEventArgs object also has a Classification property that you should fill in for successful requests. It is used by the connection logger, content is classified according to the ContentClassification enum. If you don't classify your content then it appears in the logs as "Other" content. No attempt is made by the server to infer the classification from the MIME type.

    The example event handler here will listen for an unhandled request for the page /HelloWorld.html. When that request comes in it will send a small HTML page back to the browser. To access the page from a web browser on the same machine as Virtual Radar Server you would enter the address http://127.0.0.1/VirtualRadar/HelloWorld.html. When we look at the page requested by the browser we ignore the case entered, so 'HelloWorld.html' and 'HELLOWORLD.HTML' would both work.

    Copy
    private void WebServer_AfterRequestReceived(object sender, RequestReceivedEventArgs args)
{
    if(!args.Handled && args.PathAndFile.Equals("/HelloWorld.html", StringComparison.OrdinalIgnoreCase)) {
        var responder = Factory.Singleton.Resolve<IResponder>();
        responder.SendText(args.Response, "<html><body>Hello World!</body></html>", Encoding.UTF8, MimeType.Html);
        args.Classification = ContentClassification.Html;
        args.Handled = true;
    }
}
See Also

Other Resources

Dealing with exceptions in plugins


Dealing With Exceptions in Plugins

Dealing With Exceptions in Plugins

As a general rule if an exception is left unhandled by a plugin then it will eventually be displayed to the user and logged by the unhandled exception handler. In some cases where the plugin is guaranteed to be the only consumer of an event this is acceptable, but in most cases letting an exception go unhandled could cause problems for the other objects that are listening to the event. They may not see the event.

There are a few ways of dealing with this problem, which are outlined here.

ThreadAbort Exception Handling

Many event handlers in Virtual Radar Server are called on background threads. Those threads could be aborted, particular during the disposal of the objects that are raising the events. When a thread aborts it always raises a ThreadAbortException. Generally it is alright to catch this exception - the framework will throw another when your catch block quits so that the shutdown of the thread continues - but they are a routine occurrence so they are not worth reporting or logging.

The code examples on the page will just show a catch of every exception but if you find that you are reporting or logging ThreadAbort exceptions then you may want to add an empty catch block for them so that they're excluded.

Copy
// This is the normal catch-all pattern:
try {
    // Do some work here...
} catch(Exception ex) {
    // Deal with the exception here rather than let it bubble up to the unhandled exception handler
}

// And this is the same pattern but with ThreadAbort exceptions ignored. You cannot swallow ThreadAborts,
// another will be thrown automatically once you are out of the catch block:
try {
    // Do some work here...
} catch(ThreadAbort) {
} catch(Exception ex) {
    // Deal with the exception here rather than let it bubble up to the unhandled exception handler
}
Display and log the exception

If you just want to catch the exception and then pass it on to the default exception handler, which will display it to the user and log it, then you can implement IBackgroundThreadExceptionCatcher.

Copy
public class MyPlugin : IPlugin, IBackgroundThreadExceptionCatcher
{
    public event EventHandler<EventArgs<Exception>> ExceptionCaught;

    protected virtual void OnExceptionCaught(EventArgs<Exception> args)
    {
        if(ExceptionCaught != null) ExceptionCaught(this, args);
    }

    private void BaseStationMessageRelay_MessageReceived(object sender, BaseStationMessageEventArgs args)
    {
        try {
            // Do your processing here...
        } catch(Exception ex) {
            OnExceptionCaught(new EventArgs<Exception>(ex));
        }
    }
}

Your plugin doesn't have to do anything else. Before the splash screen calls your Startup method it will hook the ExceptionCaught event and the handler will take your exception and move it up to the GUI thread to be displayed to the user and logged.

Just log the exception

Alternatively you might want to just log the exception and not display it to the user. You can do this by obtaining a reference to the ILog singleton.

Copy
private void BaseStationMessageRelay_MessageReceived(object sender, BaseStationMessageEventArgs args)
{
    try {
        // Do your processing here...
    } catch(Exception ex) {
        var log = Factory.Singleton.Resolve<ILog>().Singleton;
        log.WriteLine("Exception caught by my plugin: {0}", ex.ToString());
    }
}
Display exception details in the status

Regardless of whether you show the exception to the user or just log it it can also be useful to display information about the exception on your plugin's status so that if the user is looking at the plugin screen they'll be informed that something is going wrong. All plugins must implement two properties, Status and StatusDescription, and they must implement an event called StatusChanged that gets raised when either of those two properties is changed. The plugins screen displays these properties and hooks the event so that it knows when to update the display.

Copy
public class MyPlugin : IPlugin
{
    public string Status { get; private set; }

    public string StatusDescription { get; private set; }

    public event EventHandler StatusChanged;

    protected virtual void OnStatusChanged(EventArgs args)
    {
        if(StatusChanged != null) StatusChanged(this, args);
    }

    private void BaseStationMessageRelay_MessageReceived(object sender, BaseStationMessageEventArgs args)
    {
        try {
            // Do your processing here...
        } catch(Exception ex) {
            // ...
            StatusDescription = String.Format("Exception caught: {0}", ex.Message);
            OnStatusChanged(EventArgs.Empty);
        }
    }
}
Rate limiting

Some events, such as the MessageReceived event from an IBaseStationListener, can be raised hundreds of times a second. If exceptions could potentially be thrown on each of those events then you can end up spamming the user interface or filling the log with exception messages.

There are a couple of approaches to solving this problem. The first is that when an exception takes place you stop processing future messages, usually by having the plugin clearing a configurable 'Enabled' option that the user can go in and switch back on.

Another approach would be to limit the rate at which you display exceptions. You always display the first one and then if any further exceptions are caught within the next minute or so you throw them away. Once the timeout has elapsed you display or log the next exception raised. This has the advantage of not swamping the user with exceptions but does mean that information carried by the exceptions that get swallowed is lost, which may make it harder to diagnose the cause of the exceptions on a user's site.

Copy
public class MyPlugin : IPlugin
{
    private DateTime _LastExceptionShown;

    private void BaseStationMessageRelay_MessageReceived(object sender, BaseStationMessageEventArgs args)
    {
        try {
            // Do your processing here...
        } catch(Exception ex) {
            // ...
            var now = DateTime.UtcNow;
            if(_LastExceptionShown.AddMinutes(1) <= now) {
                _LastExceptionShown = now;
                // Do something with the exception here
            }
        }
    }
}

In the example above we don't have to worry about multi-threading issues because that event handler, while it is called on a background thread, is called serially. You get called with the first message, you return, you get the next message, you return and so on. However if you have another event handler attached to some other object that raises events on another thread (e.g. an IWebServer) and both event handlers are using the same variable to control when they swallow exceptions then you will need a little bit of extra code so that you don't end up with two exceptions being shown.

Copy
public class MyPlugin : IPlugin
{
    private DateTime _LastExceptionShown;

    private object _LastExceptionShownLock = new object();

    private void BaseStationMessageRelay_MessageReceived(object sender, BaseStationMessageEventArgs args)
    {
        try {
            // Do your processing here...
        } catch(Exception ex) {
            // ...
            var now = DateTime.UtcNow;
            bool processException = false;
            lock(_LastExceptionShownLock) {
                processException = _LastExceptionShown.AddMinutes(1) <= now;
                if(processException) _LastExceptionShown = now;
            }

            if(processException) {
                // Do something with the exception here
            }
        }
    }
}


Command-line Parameters

Command-line Parameters

The application can be started with from the command-line by just running VirtualRadar.exe. When it is started in this way you can use command-line switches to alter the behaviour of the program. All switches take the form of either -switch or -switch:value. Note that there is no space around the colon separating the switch name from the value. Switches are not case sensitive.

Switches
Switches
Switch | Description
-culture:name | Changes the regional settings for the application to the culture specified. The name is the name of a culture, e.g. 'en-GB' for British English, 'de-DE' for German, 'fr-FR' for French and so on. This is intended for use by plugin developers who want to test their localisation settings. The application will normally pick up the correct culture from Windows settings.
-workingFolder:directory | Tells the program to use a specific configuration folder. Usually the application only allows one instance to run and that one instance stores its configuration files in %localappdata%\VirtualRadar. This switch forces the program to run from an arbitrary configuration file folder and allows multiple instances of the application to run. It is intended for those occasions where multiple servers are to be run from the same machine, most people will never need to use this switch.
See Also

Other Resources

Microsoft's list of supported culture names


Dapper Namespace

Dapper Namespace

[Missing <summary> documentation for "N:Dapper"]

Classes
 | Class | Description
Public class | CustomPropertyTypeMap | Implements custom property mapping by user provided criteria (usually presence of some custom attribute with column to member mapping)
Public class | DbString | This class represents a SQL string, it can be used if you need to denote your parameter is a Char vs VarChar vs nVarChar vs nChar
Public class | DefaultTypeMap | Represents default type mapping strategy used by Dapper
Public class | DynamicParameters | A bag of parameters that can be passed to the Dapper Query and Execute methods
Public class | ExplicitConstructorAttribute | Tell Dapper to use an explicit constructor, passing nulls or 0s for all parameters
Public class | FeatureSupport | Handles variances in features per DBMS
Public class | SimpleMemberMap | Represents simple member map for one of target parameter or property or field to source DataReader column
Public class | SqlMapper | Dapper, a light weight object mapper for ADO.NET
Public class | SqlMapperGridReader | The grid reader provides interfaces for reading multiple result sets from a Dapper query
Public class | SqlMapperIdentity | Identity of a cached query in Dapper, used for extensibility
Public class | SqlMapperTypeHandlerT | Base-class for simple type-handlers
Public class | SqlMapperTypeHandlerCacheT | Obsolete. Not intended for direct usage
Public class | SqlMapperUdtTypeHandler | A type handler for data-types that are supported by the underlying provider, but which need a well-known UdtTypeName to be specified
Structures
 | Structure | Description
Public structure | CommandDefinition | Represents the key aspects of a sql operation
Interfaces
 | Interface | Description
Public interface | IWrappedDataReader | Describes a reader that controls the lifetime of both a command and a reader, exposing the downstream command/reader as properties.
Public interface | SqlMapperICustomQueryParameter | Implement this interface to pass an arbitrary db specific parameter to Dapper
Public interface | SqlMapperIDynamicParameters | Implement this interface to pass an arbitrary db specific set of parameters to Dapper
Public interface | SqlMapperIMemberMap | Implements this interface to provide custom member mapping
Public interface | SqlMapperIParameterCallbacks | Extends IDynamicParameters with facilities for executing callbacks after commands have completed
Public interface | SqlMapperIParameterLookup | Extends IDynamicParameters providing by-name lookup of parameter values
Public interface | SqlMapperITypeHandler | Implement this interface to perform custom type-based parameter handling and value parsing
Public interface | SqlMapperITypeMap | Implement this interface to change default mapping of reader columns to type members
Enumerations
 | Enumeration | Description
Public enumeration | CommandFlags | Additional state flags that control command behaviour


CommandDefinition Structure

CommandDefinition Structure
Represents the key aspects of a sql operation

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct CommandDefinition
Public Structure CommandDefinition
public value class CommandDefinition
[<SealedAttribute>]
type CommandDefinition =  struct end

The CommandDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | CommandDefinition | Initialize the command definition
Top
Properties
 | Name | Description
Public property | Buffered | Should data be buffered before returning?
Public property | CommandText | The command (sql or a stored-procedure name) to execute
Public property | CommandTimeout | The effective timeout for the command
Public property | CommandType | The type of command that the command-text represents
Public property | Flags | Additional state flags against this command
Public property | Parameters | The parameters associated with the command
Public property | Pipelined | Can async queries be pipelined?
Public property | Transaction | The active transaction for the command
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Dapper Namespace


CommandDefinition Constructor

CommandDefinition Constructor
Initialize the command definition

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CommandDefinition(
    string commandText,
    Object parameters = null,
    IDbTransaction transaction = null,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null,
    CommandFlags flags = CommandFlags.Buffered
)
Public Sub New (
    commandText As String,
    Optional parameters As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing,
    Optional flags As CommandFlags = CommandFlags.Buffered
)
public:
CommandDefinition(
    String^ commandText,
    Object^ parameters = nullptr,
    IDbTransaction^ transaction = nullptr,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr,
    CommandFlags flags = CommandFlags::Buffered
)
new :
        commandText : string *
        ?parameters : Object *
        ?transaction : IDbTransaction *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType> *
        ?flags : CommandFlags
(* Defaults:
        let _parameters = defaultArg parameters null
        let _transaction = defaultArg transaction null
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
        let _flags = defaultArg flags CommandFlags.Buffered
*)
-> CommandDefinition

Parameters

commandText
Type: SystemString
parameters (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType
flags (Optional)
Type: DapperCommandFlags
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition Properties

CommandDefinition Properties

The CommandDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Buffered | Should data be buffered before returning?
Public property | CommandText | The command (sql or a stored-procedure name) to execute
Public property | CommandTimeout | The effective timeout for the command
Public property | CommandType | The type of command that the command-text represents
Public property | Flags | Additional state flags against this command
Public property | Parameters | The parameters associated with the command
Public property | Pipelined | Can async queries be pipelined?
Public property | Transaction | The active transaction for the command
Top
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.Buffered Property

CommandDefinitionBuffered Property
Should data be buffered before returning?

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Buffered { get; }
Public ReadOnly Property Buffered As Boolean
    Get
public:
property bool Buffered {
    bool get ();
}
member Buffered : bool with get

Property Value

Type: Boolean
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.CommandText Property

CommandDefinitionCommandText Property
The command (sql or a stored-procedure name) to execute

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CommandText { get; }
Public ReadOnly Property CommandText As String
    Get
public:
property String^ CommandText {
    String^ get ();
}
member CommandText : string with get

Property Value

Type: String
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.CommandTimeout Property

CommandDefinitionCommandTimeout Property
The effective timeout for the command

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> CommandTimeout { get; }
Public ReadOnly Property CommandTimeout As Nullable(Of Integer)
    Get
public:
property Nullable<int> CommandTimeout {
    Nullable<int> get ();
}
member CommandTimeout : Nullable<int> with get

Property Value

Type: Nullable Int32
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.CommandType Property

CommandDefinitionCommandType Property
The type of command that the command-text represents

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<CommandType> CommandType { get; }
Public ReadOnly Property CommandType As Nullable(Of CommandType)
    Get
public:
property Nullable<CommandType> CommandType {
    Nullable<CommandType> get ();
}
member CommandType : Nullable<CommandType> with get

Property Value

Type: Nullable CommandType
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.Flags Property

CommandDefinitionFlags Property
Additional state flags against this command

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CommandFlags Flags { get; }
Public ReadOnly Property Flags As CommandFlags
    Get
public:
property CommandFlags Flags {
    CommandFlags get ();
}
member Flags : CommandFlags with get

Property Value

Type: CommandFlags
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.Parameters Property

CommandDefinitionParameters Property
The parameters associated with the command

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Parameters { get; }
Public ReadOnly Property Parameters As Object
    Get
public:
property Object^ Parameters {
    Object^ get ();
}
member Parameters : Object with get

Property Value

Type: Object
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.Pipelined Property

CommandDefinitionPipelined Property
Can async queries be pipelined?

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Pipelined { get; }
Public ReadOnly Property Pipelined As Boolean
    Get
public:
property bool Pipelined {
    bool get ();
}
member Pipelined : bool with get

Property Value

Type: Boolean
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition.Transaction Property

CommandDefinitionTransaction Property
The active transaction for the command

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDbTransaction Transaction { get; }
Public ReadOnly Property Transaction As IDbTransaction
    Get
public:
property IDbTransaction^ Transaction {
    IDbTransaction^ get ();
}
member Transaction : IDbTransaction with get

Property Value

Type: IDbTransaction
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandDefinition Methods

CommandDefinition Methods

The CommandDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

CommandDefinition Structure
Dapper Namespace


CommandFlags Enumeration

CommandFlags Enumeration
Additional state flags that control command behaviour

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum CommandFlags
<FlagsAttribute>
Public Enumeration CommandFlags
[FlagsAttribute]
public enum class CommandFlags
[<FlagsAttribute>]
type CommandFlags
Members
Member name | Value | Description
None | 0 | No additional flags
Buffered | 1 | Should data be buffered before returning?
Pipelined | 2 | Can async queries be pipelined?
NoCache | 4 | Should the plan cache be bypassed?
See Also

Reference

Dapper Namespace


CustomPropertyTypeMap Class

CustomPropertyTypeMap Class
Implements custom property mapping by user provided criteria (usually presence of some custom attribute with column to member mapping)
Inheritance Hierarchy
SystemObject
DapperCustomPropertyTypeMap

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CustomPropertyTypeMap : SqlMapperITypeMap
Public NotInheritable Class CustomPropertyTypeMap
    Implements SqlMapperITypeMap
public ref class CustomPropertyTypeMap sealed : SqlMapperITypeMap
[<SealedAttribute>]
type CustomPropertyTypeMap =
    class
        interface SqlMapperITypeMap
    end

The CustomPropertyTypeMap type exposes the following members.

Constructors
 | Name | Description
Public method | CustomPropertyTypeMap | Creates custom property mapping
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindConstructor | Always returns default constructor
Public method | FindExplicitConstructor | Always returns null
Public method | GetConstructorParameter | Not implemented as far as default constructor used for all cases
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | Returns property based on selector strategy
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


CustomPropertyTypeMap Constructor

CustomPropertyTypeMap Constructor
Creates custom property mapping

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomPropertyTypeMap(
    Type type,
    Func<Type, string, PropertyInfo> propertySelector
)
Public Sub New (
    type As Type,
    propertySelector As Func(Of Type, String, PropertyInfo)
)
public:
CustomPropertyTypeMap(
    Type^ type,
    Func<Type^, String^, PropertyInfo^>^ propertySelector
)
new :
        type : Type *
        propertySelector : Func<Type, string, PropertyInfo> -> CustomPropertyTypeMap

Parameters

type
Type: SystemType
Target entity type
propertySelector
Type: SystemFunc Type, String, PropertyInfo
Property selector based on target type and DataReader column name
See Also

Reference

CustomPropertyTypeMap Class
Dapper Namespace


CustomPropertyTypeMap Methods

CustomPropertyTypeMap Methods

The CustomPropertyTypeMap type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindConstructor | Always returns default constructor
Public method | FindExplicitConstructor | Always returns null
Public method | GetConstructorParameter | Not implemented as far as default constructor used for all cases
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | Returns property based on selector strategy
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomPropertyTypeMap Class
Dapper Namespace


CustomPropertyTypeMap.FindConstructor Method

CustomPropertyTypeMapFindConstructor Method
Always returns default constructor

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConstructorInfo FindConstructor(
    string[] names,
    Type[] types
)
Public Function FindConstructor (
    names As String(),
    types As Type()
) As ConstructorInfo
public:
virtual ConstructorInfo^ FindConstructor(
    array<String^>^ names,
    array<Type^>^ types
) sealed
abstract FindConstructor :
        names : string[] *
        types : Type[] -> ConstructorInfo
override FindConstructor :
        names : string[] *
        types : Type[] -> ConstructorInfo

Parameters

names
Type: SystemString
DataReader column names
types
Type: SystemType
DataReader column types

Return Value

Type: ConstructorInfo
Default constructor

Implements

SqlMapperITypeMapFindConstructor(String, Type)
See Also

Reference

CustomPropertyTypeMap Class
Dapper Namespace


CustomPropertyTypeMap.FindExplicitConstructor Method

CustomPropertyTypeMapFindExplicitConstructor Method
Always returns null

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConstructorInfo FindExplicitConstructor()
Public Function FindExplicitConstructor As ConstructorInfo
public:
virtual ConstructorInfo^ FindExplicitConstructor() sealed
abstract FindExplicitConstructor : unit -> ConstructorInfo
override FindExplicitConstructor : unit -> ConstructorInfo

Return Value

Type: ConstructorInfo

Implements

SqlMapperITypeMapFindExplicitConstructor
See Also

Reference

CustomPropertyTypeMap Class
Dapper Namespace


CustomPropertyTypeMap.GetConstructorParameter Method

CustomPropertyTypeMapGetConstructorParameter Method
Not implemented as far as default constructor used for all cases

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlMapperIMemberMap GetConstructorParameter(
    ConstructorInfo constructor,
    string columnName
)
Public Function GetConstructorParameter (
    constructor As ConstructorInfo,
    columnName As String
) As SqlMapperIMemberMap
public:
virtual SqlMapperIMemberMap^ GetConstructorParameter(
    ConstructorInfo^ constructor,
    String^ columnName
) sealed
abstract GetConstructorParameter :
        constructor : ConstructorInfo *
        columnName : string -> SqlMapperIMemberMap
override GetConstructorParameter :
        constructor : ConstructorInfo *
        columnName : string -> SqlMapperIMemberMap

Parameters

constructor
Type: System.ReflectionConstructorInfo
columnName
Type: SystemString

Return Value

Type: SqlMapperIMemberMap

Implements

SqlMapperITypeMapGetConstructorParameter(ConstructorInfo, String)
See Also

Reference

CustomPropertyTypeMap Class
Dapper Namespace


CustomPropertyTypeMap.GetMember Method

CustomPropertyTypeMapGetMember Method
Returns property based on selector strategy

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlMapperIMemberMap GetMember(
    string columnName
)
Public Function GetMember (
    columnName As String
) As SqlMapperIMemberMap
public:
virtual SqlMapperIMemberMap^ GetMember(
    String^ columnName
) sealed
abstract GetMember :
        columnName : string -> SqlMapperIMemberMap
override GetMember :
        columnName : string -> SqlMapperIMemberMap

Parameters

columnName
Type: SystemString
DataReader column name

Return Value

Type: SqlMapperIMemberMap
Poperty member map

Implements

SqlMapperITypeMapGetMember(String)
See Also

Reference

CustomPropertyTypeMap Class
Dapper Namespace


DbString Class

DbString Class
This class represents a SQL string, it can be used if you need to denote your parameter is a Char vs VarChar vs nVarChar vs nChar
Inheritance Hierarchy
SystemObject
DapperDbString

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DbString : SqlMapperICustomQueryParameter
Public NotInheritable Class DbString
    Implements SqlMapperICustomQueryParameter
public ref class DbString sealed : SqlMapperICustomQueryParameter
[<SealedAttribute>]
type DbString =
    class
        interface SqlMapperICustomQueryParameter
    end

The DbString type exposes the following members.

Constructors
 | Name | Description
Public method | DbString | Create a new DbString
Top
Properties
 | Name | Description
Public property | IsAnsi | Ansi vs Unicode
Public property | IsFixedLength | Fixed length
Public property | Length | Length of the string -1 for max
Public property | Value | The value of the string
Top
Methods
 | Name | Description
Public method | AddParameter | Add the parameter to the command... internal use only
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultLength | A value to set the default value of strings going through Dapper. Default is 4000, any value larger than this field will not have the default value applied.
Top
See Also

Reference

Dapper Namespace


DbString Constructor

DbString Constructor
Create a new DbString

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DbString()
Public Sub New
public:
DbString()
new : unit -> DbString
See Also

Reference

DbString Class
Dapper Namespace


DbString Properties

DbString Properties

The DbString type exposes the following members.

Properties
 | Name | Description
Public property | IsAnsi | Ansi vs Unicode
Public property | IsFixedLength | Fixed length
Public property | Length | Length of the string -1 for max
Public property | Value | The value of the string
Top
See Also

Reference

DbString Class
Dapper Namespace


DbString.IsAnsi Property

DbStringIsAnsi Property
Ansi vs Unicode

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAnsi { get; set; }
Public Property IsAnsi As Boolean
    Get
    Set
public:
property bool IsAnsi {
    bool get ();
    void set (bool value);
}
member IsAnsi : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DbString Class
Dapper Namespace


DbString.IsFixedLength Property

DbStringIsFixedLength Property
Fixed length

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFixedLength { get; set; }
Public Property IsFixedLength As Boolean
    Get
    Set
public:
property bool IsFixedLength {
    bool get ();
    void set (bool value);
}
member IsFixedLength : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DbString Class
Dapper Namespace


DbString.Length Property

DbStringLength Property
Length of the string -1 for max

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Type: Int32
See Also

Reference

DbString Class
Dapper Namespace


DbString.Value Property

DbStringValue Property
The value of the string

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

DbString Class
Dapper Namespace


DbString Methods

DbString Methods

The DbString type exposes the following members.

Methods
 | Name | Description
Public method | AddParameter | Add the parameter to the command... internal use only
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DbString Class
Dapper Namespace


DbString.AddParameter Method

DbStringAddParameter Method
Add the parameter to the command... internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddParameter(
    IDbCommand command,
    string name
)
Public Sub AddParameter (
    command As IDbCommand,
    name As String
)
public:
virtual void AddParameter(
    IDbCommand^ command,
    String^ name
) sealed
abstract AddParameter :
        command : IDbCommand *
        name : string -> unit
override AddParameter :
        command : IDbCommand *
        name : string -> unit

Parameters

command
Type: System.DataIDbCommand
name
Type: SystemString

Implements

SqlMapperICustomQueryParameterAddParameter(IDbCommand, String)
See Also

Reference

DbString Class
Dapper Namespace


DbString Fields

DbString Fields

The DbString type exposes the following members.

Fields
Name | Description
DefaultLength | A value to set the default value of strings going through Dapper. Default is 4000, any value larger than this field will not have the default value applied.
Top
See Also

Reference

DbString Class
Dapper Namespace


DbString.DefaultLength Field

DbStringDefaultLength Field
A value to set the default value of strings going through Dapper. Default is 4000, any value larger than this field will not have the default value applied.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DefaultLength
Public Const DefaultLength As Integer
public:
literal int DefaultLength
static val mutable DefaultLength: int

Field Value

Type: Int32
See Also

Reference

DbString Class
Dapper Namespace


DefaultTypeMap Class

DefaultTypeMap Class
Represents default type mapping strategy used by Dapper
Inheritance Hierarchy
SystemObject
DapperDefaultTypeMap

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DefaultTypeMap : SqlMapperITypeMap
Public NotInheritable Class DefaultTypeMap
    Implements SqlMapperITypeMap
public ref class DefaultTypeMap sealed : SqlMapperITypeMap
[<SealedAttribute>]
type DefaultTypeMap =
    class
        interface SqlMapperITypeMap
    end

The DefaultTypeMap type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultTypeMap | Creates default type map
Top
Properties
Name | Description
MatchNamesWithUnderscores | Should column names like User_Id be allowed to match properties/fields like UserId ?
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindConstructor | Finds best constructor
Public method | FindExplicitConstructor | Returns the constructor, if any, that has the ExplicitConstructorAttribute on it.
Public method | GetConstructorParameter | Gets mapping for constructor parameter
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | Gets member mapping for column
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


DefaultTypeMap Constructor

DefaultTypeMap Constructor
Creates default type map

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefaultTypeMap(
    Type type
)
Public Sub New (
    type As Type
)
public:
DefaultTypeMap(
    Type^ type
)
new :
        type : Type -> DefaultTypeMap

Parameters

type
Type: SystemType
Entity type
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap Properties

DefaultTypeMap Properties

The DefaultTypeMap type exposes the following members.

Properties
Name | Description
MatchNamesWithUnderscores | Should column names like User_Id be allowed to match properties/fields like UserId ?
Top
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap.MatchNamesWithUnderscores Property

DefaultTypeMapMatchNamesWithUnderscores Property
Should column names like User_Id be allowed to match properties/fields like UserId ?

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool MatchNamesWithUnderscores { get; set; }
Public Shared Property MatchNamesWithUnderscores As Boolean
    Get
    Set
public:
static property bool MatchNamesWithUnderscores {
    bool get ();
    void set (bool value);
}
static member MatchNamesWithUnderscores : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap Methods

DefaultTypeMap Methods

The DefaultTypeMap type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindConstructor | Finds best constructor
Public method | FindExplicitConstructor | Returns the constructor, if any, that has the ExplicitConstructorAttribute on it.
Public method | GetConstructorParameter | Gets mapping for constructor parameter
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | Gets member mapping for column
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap.FindConstructor Method

DefaultTypeMapFindConstructor Method
Finds best constructor

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConstructorInfo FindConstructor(
    string[] names,
    Type[] types
)
Public Function FindConstructor (
    names As String(),
    types As Type()
) As ConstructorInfo
public:
virtual ConstructorInfo^ FindConstructor(
    array<String^>^ names,
    array<Type^>^ types
) sealed
abstract FindConstructor :
        names : string[] *
        types : Type[] -> ConstructorInfo
override FindConstructor :
        names : string[] *
        types : Type[] -> ConstructorInfo

Parameters

names
Type: SystemString
DataReader column names
types
Type: SystemType
DataReader column types

Return Value

Type: ConstructorInfo
Matching constructor or default one

Implements

SqlMapperITypeMapFindConstructor(String, Type)
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap.FindExplicitConstructor Method

DefaultTypeMapFindExplicitConstructor Method
Returns the constructor, if any, that has the ExplicitConstructorAttribute on it.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConstructorInfo FindExplicitConstructor()
Public Function FindExplicitConstructor As ConstructorInfo
public:
virtual ConstructorInfo^ FindExplicitConstructor() sealed
abstract FindExplicitConstructor : unit -> ConstructorInfo
override FindExplicitConstructor : unit -> ConstructorInfo

Return Value

Type: ConstructorInfo

Implements

SqlMapperITypeMapFindExplicitConstructor
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap.GetConstructorParameter Method

DefaultTypeMapGetConstructorParameter Method
Gets mapping for constructor parameter

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlMapperIMemberMap GetConstructorParameter(
    ConstructorInfo constructor,
    string columnName
)
Public Function GetConstructorParameter (
    constructor As ConstructorInfo,
    columnName As String
) As SqlMapperIMemberMap
public:
virtual SqlMapperIMemberMap^ GetConstructorParameter(
    ConstructorInfo^ constructor,
    String^ columnName
) sealed
abstract GetConstructorParameter :
        constructor : ConstructorInfo *
        columnName : string -> SqlMapperIMemberMap
override GetConstructorParameter :
        constructor : ConstructorInfo *
        columnName : string -> SqlMapperIMemberMap

Parameters

constructor
Type: System.ReflectionConstructorInfo
Constructor to resolve
columnName
Type: SystemString
DataReader column name

Return Value

Type: SqlMapperIMemberMap
Mapping implementation

Implements

SqlMapperITypeMapGetConstructorParameter(ConstructorInfo, String)
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DefaultTypeMap.GetMember Method

DefaultTypeMapGetMember Method
Gets member mapping for column

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlMapperIMemberMap GetMember(
    string columnName
)
Public Function GetMember (
    columnName As String
) As SqlMapperIMemberMap
public:
virtual SqlMapperIMemberMap^ GetMember(
    String^ columnName
) sealed
abstract GetMember :
        columnName : string -> SqlMapperIMemberMap
override GetMember :
        columnName : string -> SqlMapperIMemberMap

Parameters

columnName
Type: SystemString
DataReader column name

Return Value

Type: SqlMapperIMemberMap
Mapping implementation

Implements

SqlMapperITypeMapGetMember(String)
See Also

Reference

DefaultTypeMap Class
Dapper Namespace


DynamicParameters Class

DynamicParameters Class
A bag of parameters that can be passed to the Dapper Query and Execute methods
Inheritance Hierarchy
SystemObject
DapperDynamicParameters

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DynamicParameters : SqlMapperIDynamicParameters,
    SqlMapperIParameterLookup, SqlMapperIParameterCallbacks
Public Class DynamicParameters
    Implements SqlMapperIDynamicParameters, SqlMapperIParameterLookup, SqlMapperIParameterCallbacks
public ref class DynamicParameters : SqlMapperIDynamicParameters,
    SqlMapperIParameterLookup, SqlMapperIParameterCallbacks
type DynamicParameters =
    class
        interface SqlMapperIDynamicParameters
        interface SqlMapperIParameterLookup
        interface SqlMapperIParameterCallbacks
    end

The DynamicParameters type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicParameters | construct a dynamic parameter bag
Public method | DynamicParameters(Object) | construct a dynamic parameter bag
Top
Properties
 | Name | Description
Public property | ParameterNames | All the names of the param in the bag, use Get to yank them out
Public property | RemoveUnused | If true, the command-text is inspected and only values that are clearly used are included on the connection
Top
Methods
 | Name | Description
Public method | Add(String, Object, NullableDbType, NullableParameterDirection, NullableInt32) | Add a parameter to this dynamic parameter list
Public method | Add(String, Object, NullableDbType, NullableParameterDirection, NullableInt32, NullableByte, NullableByte) | Add a parameter to this dynamic parameter list
Public method | AddDynamicParams | Append a whole object full of params to the dynamic EG: AddDynamicParams(new {A = 1, B = 2}) // will add property A and B to the dynamic
Protected method | AddParameters | Add all the parameters needed to the command just before it executes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetT | Get the value of a parameter
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OutputT | Allows you to automatically populate a target property/field from output parameters. It actually creates an InputOutput parameter, so you can still pass data in.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ReplaceLiterals | Replace all literal tokens with their text form (Defined by SqlMapper.)
Top
See Also

Reference

Dapper Namespace


DynamicParameters Constructor

DynamicParameters Constructor
Overload List
 | Name | Description
Public method | DynamicParameters | construct a dynamic parameter bag
Public method | DynamicParameters(Object) | construct a dynamic parameter bag
Top
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters Constructor

DynamicParameters Constructor
construct a dynamic parameter bag

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicParameters()
Public Sub New
public:
DynamicParameters()
new : unit -> DynamicParameters
See Also

Reference

DynamicParameters Class
DynamicParameters Overload
Dapper Namespace


DynamicParameters Constructor (Object)

DynamicParameters Constructor (Object)
construct a dynamic parameter bag

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicParameters(
    Object template
)
Public Sub New (
    template As Object
)
public:
DynamicParameters(
    Object^ template
)
new :
        template : Object -> DynamicParameters

Parameters

template
Type: SystemObject
can be an anonymous type or a DynamicParameters bag
See Also

Reference

DynamicParameters Class
DynamicParameters Overload
Dapper Namespace


DynamicParameters Properties

DynamicParameters Properties

The DynamicParameters type exposes the following members.

Properties
 | Name | Description
Public property | ParameterNames | All the names of the param in the bag, use Get to yank them out
Public property | RemoveUnused | If true, the command-text is inspected and only values that are clearly used are included on the connection
Top
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.ParameterNames Property

DynamicParametersParameterNames Property
All the names of the param in the bag, use Get to yank them out

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ParameterNames { get; }
Public ReadOnly Property ParameterNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ ParameterNames {
    IEnumerable<String^>^ get ();
}
member ParameterNames : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.RemoveUnused Property

DynamicParametersRemoveUnused Property
If true, the command-text is inspected and only values that are clearly used are included on the connection

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveUnused { get; set; }
Public Property RemoveUnused As Boolean
    Get
    Set
public:
property bool RemoveUnused {
    bool get ();
    void set (bool value);
}
member RemoveUnused : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters Methods

DynamicParameters Methods

The DynamicParameters type exposes the following members.

Methods
 | Name | Description
Public method | Add(String, Object, NullableDbType, NullableParameterDirection, NullableInt32) | Add a parameter to this dynamic parameter list
Public method | Add(String, Object, NullableDbType, NullableParameterDirection, NullableInt32, NullableByte, NullableByte) | Add a parameter to this dynamic parameter list
Public method | AddDynamicParams | Append a whole object full of params to the dynamic EG: AddDynamicParams(new {A = 1, B = 2}) // will add property A and B to the dynamic
Protected method | AddParameters | Add all the parameters needed to the command just before it executes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetT | Get the value of a parameter
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OutputT | Allows you to automatically populate a target property/field from output parameters. It actually creates an InputOutput parameter, so you can still pass data in.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ReplaceLiterals | Replace all literal tokens with their text form (Defined by SqlMapper.)
Top
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.Add Method

DynamicParametersAdd Method
Overload List
 | Name | Description
Public method | Add(String, Object, NullableDbType, NullableParameterDirection, NullableInt32) | Add a parameter to this dynamic parameter list
Public method | Add(String, Object, NullableDbType, NullableParameterDirection, NullableInt32, NullableByte, NullableByte) | Add a parameter to this dynamic parameter list
Top
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.Add Method (String, Object, Nullable(DbType), Nullable(ParameterDirection), Nullable(Int32))

DynamicParametersAdd Method (String, Object, NullableDbType, NullableParameterDirection, NullableInt32)
Add a parameter to this dynamic parameter list

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string name,
    Object value,
    Nullable<DbType> dbType,
    Nullable<ParameterDirection> direction,
    Nullable<int> size
)
Public Sub Add (
    name As String,
    value As Object,
    dbType As Nullable(Of DbType),
    direction As Nullable(Of ParameterDirection),
    size As Nullable(Of Integer)
)
public:
void Add(
    String^ name,
    Object^ value,
    Nullable<DbType> dbType,
    Nullable<ParameterDirection> direction,
    Nullable<int> size
)
member Add :
        name : string *
        value : Object *
        dbType : Nullable<DbType> *
        direction : Nullable<ParameterDirection> *
        size : Nullable<int> -> unit

Parameters

name
Type: SystemString
value
Type: SystemObject
dbType
Type: SystemNullable DbType
direction
Type: SystemNullable ParameterDirection
size
Type: SystemNullable Int32
See Also

Reference

DynamicParameters Class
Add Overload
Dapper Namespace


DynamicParameters.Add Method (String, Object, Nullable(DbType), Nullable(ParameterDirection), Nullable(Int32), Nullable(Byte), Nullable(Byte))

DynamicParametersAdd Method (String, Object, NullableDbType, NullableParameterDirection, NullableInt32, NullableByte, NullableByte)
Add a parameter to this dynamic parameter list

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string name,
    Object value = null,
    Nullable<DbType> dbType = null,
    Nullable<ParameterDirection> direction = null,
    Nullable<int> size = null,
    Nullable<byte> precision = null,
    Nullable<byte> scale = null
)
Public Sub Add (
    name As String,
    Optional value As Object = Nothing,
    Optional dbType As Nullable(Of DbType) = Nothing,
    Optional direction As Nullable(Of ParameterDirection) = Nothing,
    Optional size As Nullable(Of Integer) = Nothing,
    Optional precision As Nullable(Of Byte) = Nothing,
    Optional scale As Nullable(Of Byte) = Nothing
)
public:
void Add(
    String^ name,
    Object^ value = nullptr,
    Nullable<DbType> dbType = nullptr,
    Nullable<ParameterDirection> direction = nullptr,
    Nullable<int> size = nullptr,
    Nullable<unsigned char> precision = nullptr,
    Nullable<unsigned char> scale = nullptr
)
member Add :
        name : string *
        ?value : Object *
        ?dbType : Nullable<DbType> *
        ?direction : Nullable<ParameterDirection> *
        ?size : Nullable<int> *
        ?precision : Nullable<byte> *
        ?scale : Nullable<byte>
(* Defaults:
        let _value = defaultArg value null
        let _dbType = defaultArg dbType null
        let _direction = defaultArg direction null
        let _size = defaultArg size null
        let _precision = defaultArg precision null
        let _scale = defaultArg scale null
*)
-> unit

Parameters

name
Type: SystemString
value (Optional)
Type: SystemObject
dbType (Optional)
Type: SystemNullable DbType
direction (Optional)
Type: SystemNullable ParameterDirection
size (Optional)
Type: SystemNullable Int32
precision (Optional)
Type: SystemNullable Byte
scale (Optional)
Type: SystemNullable Byte
See Also

Reference

DynamicParameters Class
Add Overload
Dapper Namespace


DynamicParameters.AddDynamicParams Method

DynamicParametersAddDynamicParams Method
Append a whole object full of params to the dynamic EG: AddDynamicParams(new {A = 1, B = 2}) // will add property A and B to the dynamic

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddDynamicParams(
    Object param
)
Public Sub AddDynamicParams (
    param As Object
)
public:
void AddDynamicParams(
    Object^ param
)
member AddDynamicParams :
        param : Object -> unit

Parameters

param
Type: SystemObject
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.AddParameters Method

DynamicParametersAddParameters Method
Add all the parameters needed to the command just before it executes

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void AddParameters(
    IDbCommand command,
    SqlMapperIdentity identity
)
Protected Sub AddParameters (
    command As IDbCommand,
    identity As SqlMapperIdentity
)
protected:
void AddParameters(
    IDbCommand^ command,
    SqlMapperIdentity^ identity
)
member AddParameters :
        command : IDbCommand *
        identity : SqlMapperIdentity -> unit

Parameters

command
Type: System.DataIDbCommand
The raw command prior to execution
identity
Type: DapperSqlMapperIdentity
Information about the query
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.Get(T) Method

DynamicParametersGetT Method
Get the value of a parameter

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Get<T>(
    string name
)

Public Function Get(Of T) (
    name As String
) As T
public:
generic<typename T>
T Get(
    String^ name
)
member Get :
        name : string -> 'T

Parameters

name
Type: SystemString

Type Parameters

T

Return Value

Type: T
The value, note DBNull.Value is not returned, instead the value is returned as null
See Also

Reference

DynamicParameters Class
Dapper Namespace


DynamicParameters.Output(T) Method

DynamicParametersOutputT Method
Allows you to automatically populate a target property/field from output parameters. It actually creates an InputOutput parameter, so you can still pass data in.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicParameters Output<T>(
    T target,
    Expression<Func<T, Object>> expression,
    Nullable<DbType> dbType = null,
    Nullable<int> size = null
)

Public Function Output(Of T) (
    target As T,
    expression As Expression(Of Func(Of T, Object)),
    Optional dbType As Nullable(Of DbType) = Nothing,
    Optional size As Nullable(Of Integer) = Nothing
) As DynamicParameters
public:
generic<typename T>
DynamicParameters^ Output(
    T target,
    Expression<Func<T, Object^>^>^ expression,
    Nullable<DbType> dbType = nullptr,
    Nullable<int> size = nullptr
)
member Output :
        target : 'T *
        expression : Expression<Func<'T, Object>> *
        ?dbType : Nullable<DbType> *
        ?size : Nullable<int>
(* Defaults:
        let _dbType = defaultArg dbType null
        let _size = defaultArg size null
*)
-> DynamicParameters

Parameters

target
Type: T
The object whose property/field you wish to populate.
expression
Type: System.Linq.ExpressionsExpression Func T, Object
A MemberExpression targeting a property/field of the target (or descendant thereof.)
dbType (Optional)
Type: SystemNullable DbType
size (Optional)
Type: SystemNullable Int32
The size to set on the parameter. Defaults to 0, or DbString.DefaultLength in case of strings.

Type Parameters

T

Return Value

Type: DynamicParameters
The DynamicParameters instance
See Also

Reference

DynamicParameters Class
Dapper Namespace


ExplicitConstructorAttribute Class

ExplicitConstructorAttribute Class
Tell Dapper to use an explicit constructor, passing nulls or 0s for all parameters
Inheritance Hierarchy
SystemObject
SystemAttribute
DapperExplicitConstructorAttribute

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ExplicitConstructorAttribute : Attribute
Public NotInheritable Class ExplicitConstructorAttribute
    Inherits Attribute
public ref class ExplicitConstructorAttribute sealed : public Attribute
[<SealedAttribute>]
type ExplicitConstructorAttribute =
    class
        inherit Attribute
    end

The ExplicitConstructorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ExplicitConstructorAttribute | Initializes a new instance of the ExplicitConstructorAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


ExplicitConstructorAttribute Constructor

ExplicitConstructorAttribute Constructor
Initializes a new instance of the ExplicitConstructorAttribute class

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExplicitConstructorAttribute()
Public Sub New
public:
ExplicitConstructorAttribute()
new : unit -> ExplicitConstructorAttribute
See Also

Reference

ExplicitConstructorAttribute Class
Dapper Namespace


ExplicitConstructorAttribute Properties

ExplicitConstructorAttribute Properties

The ExplicitConstructorAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ExplicitConstructorAttribute Class
Dapper Namespace


ExplicitConstructorAttribute Methods

ExplicitConstructorAttribute Methods

The ExplicitConstructorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExplicitConstructorAttribute Class
Dapper Namespace


FeatureSupport Class

FeatureSupport Class
Handles variances in features per DBMS
Inheritance Hierarchy
SystemObject
DapperFeatureSupport

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FeatureSupport
Public Class FeatureSupport
public ref class FeatureSupport
type FeatureSupport =  class end

The FeatureSupport type exposes the following members.

Properties
 | Name | Description
Public property | Arrays | True if the db supports array columns e.g. Postgresql
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Get | Gets the feature set based on the passed connection
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


FeatureSupport Properties

FeatureSupport Properties

The FeatureSupport type exposes the following members.

Properties
 | Name | Description
Public property | Arrays | True if the db supports array columns e.g. Postgresql
Top
See Also

Reference

FeatureSupport Class
Dapper Namespace


FeatureSupport.Arrays Property

FeatureSupportArrays Property
True if the db supports array columns e.g. Postgresql

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Arrays { get; }
Public ReadOnly Property Arrays As Boolean
    Get
public:
property bool Arrays {
    bool get ();
}
member Arrays : bool with get

Property Value

Type: Boolean
See Also

Reference

FeatureSupport Class
Dapper Namespace


FeatureSupport Methods

FeatureSupport Methods

The FeatureSupport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Get | Gets the feature set based on the passed connection
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FeatureSupport Class
Dapper Namespace


FeatureSupport.Get Method

FeatureSupportGet Method
Gets the feature set based on the passed connection

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FeatureSupport Get(
    IDbConnection connection
)
Public Shared Function Get (
    connection As IDbConnection
) As FeatureSupport
public:
static FeatureSupport^ Get(
    IDbConnection^ connection
)
static member Get :
        connection : IDbConnection -> FeatureSupport

Parameters

connection
Type: System.DataIDbConnection

Return Value

Type: FeatureSupport
See Also

Reference

FeatureSupport Class
Dapper Namespace


IWrappedDataReader Interface

IWrappedDataReader Interface
Describes a reader that controls the lifetime of both a command and a reader, exposing the downstream command/reader as properties.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWrappedDataReader : IDataReader,
    IDisposable, IDataRecord
Public Interface IWrappedDataReader
    Inherits IDataReader, IDisposable, IDataRecord
public interface class IWrappedDataReader : IDataReader,
    IDisposable, IDataRecord
type IWrappedDataReader =
    interface
        interface IDataReader
        interface IDisposable
        interface IDataRecord
    end

The IWrappedDataReader type exposes the following members.

Properties
 | Name | Description
Public property | Command | Obtain the underlying command
Public property | Depth | Gets a value indicating the depth of nesting for the current row. (Inherited from IDataReader.)
Public property | FieldCount | Gets the number of columns in the current row. (Inherited from IDataRecord.)
Public property | IsClosed | Gets a value indicating whether the data reader is closed. (Inherited from IDataReader.)
Public property | ItemInt32 | Gets the column located at the specified index. (Inherited from IDataRecord.)
Public property | ItemString | Gets the column with the specified name. (Inherited from IDataRecord.)
Public property | Reader | Obtain the underlying reader
Public property | RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement. (Inherited from IDataReader.)
Top
Methods
 | Name | Description
Public method | Close | Closes the IDataReader Object. (Inherited from IDataReader.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetBoolean | Gets the value of the specified column as a Boolean. (Inherited from IDataRecord.)
Public method | GetByte | Gets the 8-bit unsigned integer value of the specified column. (Inherited from IDataRecord.)
Public method | GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. (Inherited from IDataRecord.)
Public method | GetChar | Gets the character value of the specified column. (Inherited from IDataRecord.)
Public method | GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset. (Inherited from IDataRecord.)
Public method | GetData | Returns an IDataReader for the specified column ordinal. (Inherited from IDataRecord.)
Public method | GetDataTypeName | Gets the data type information for the specified field. (Inherited from IDataRecord.)
Public method | GetDateTime | Gets the date and time data value of the specified field. (Inherited from IDataRecord.)
Public method | GetDecimal | Gets the fixed-position numeric value of the specified field. (Inherited from IDataRecord.)
Public method | GetDouble | Gets the double-precision floating point number of the specified field. (Inherited from IDataRecord.)
Public method | GetFieldType | Gets the Type information corresponding to the type of Object that would be returned from GetValue(Int32). (Inherited from IDataRecord.)
Public method | GetFloat | Gets the single-precision floating point number of the specified field. (Inherited from IDataRecord.)
Public method | GetGuid | Returns the GUID value of the specified field. (Inherited from IDataRecord.)
Public method | GetInt16 | Gets the 16-bit signed integer value of the specified field. (Inherited from IDataRecord.)
Public method | GetInt32 | Gets the 32-bit signed integer value of the specified field. (Inherited from IDataRecord.)
Public method | GetInt64 | Gets the 64-bit signed integer value of the specified field. (Inherited from IDataRecord.)
Public method | GetName | Gets the name for the field to find. (Inherited from IDataRecord.)
Public method | GetOrdinal | Return the index of the named field. (Inherited from IDataRecord.)
Public method | GetSchemaTable | Returns a DataTable that describes the column metadata of the IDataReader. (Inherited from IDataReader.)
Public method | GetString | Gets the string value of the specified field. (Inherited from IDataRecord.)
Public method | GetValue | Return the value of the specified field. (Inherited from IDataRecord.)
Public method | GetValues | Populates an array of objects with the column values of the current record. (Inherited from IDataRecord.)
Public method | IsDBNull | Return whether the specified field is set to null. (Inherited from IDataRecord.)
Public method | NextResult | Advances the data reader to the next result, when reading the results of batch SQL statements. (Inherited from IDataReader.)
Public method | Read | Advances the IDataReader to the next record. (Inherited from IDataReader.)
Top
See Also

Reference

Dapper Namespace


IWrappedDataReader Properties

IWrappedDataReader Properties

The IWrappedDataReader type exposes the following members.

Properties
 | Name | Description
Public property | Command | Obtain the underlying command
Public property | Depth | Gets a value indicating the depth of nesting for the current row. (Inherited from IDataReader.)
Public property | FieldCount | Gets the number of columns in the current row. (Inherited from IDataRecord.)
Public property | IsClosed | Gets a value indicating whether the data reader is closed. (Inherited from IDataReader.)
Public property | ItemInt32 | Gets the column located at the specified index. (Inherited from IDataRecord.)
Public property | ItemString | Gets the column with the specified name. (Inherited from IDataRecord.)
Public property | Reader | Obtain the underlying reader
Public property | RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement. (Inherited from IDataReader.)
Top
See Also

Reference

IWrappedDataReader Interface
Dapper Namespace


IWrappedDataReader.Command Property

IWrappedDataReaderCommand Property
Obtain the underlying command

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDbCommand Command { get; }
ReadOnly Property Command As IDbCommand
    Get
property IDbCommand^ Command {
    IDbCommand^ get ();
}
abstract Command : IDbCommand with get

Property Value

Type: IDbCommand
See Also

Reference

IWrappedDataReader Interface
Dapper Namespace


IWrappedDataReader.Reader Property

IWrappedDataReaderReader Property
Obtain the underlying reader

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDataReader Reader { get; }
ReadOnly Property Reader As IDataReader
    Get
property IDataReader^ Reader {
    IDataReader^ get ();
}
abstract Reader : IDataReader with get

Property Value

Type: IDataReader
See Also

Reference

IWrappedDataReader Interface
Dapper Namespace


IWrappedDataReader Methods

IWrappedDataReader Methods

The IWrappedDataReader type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the IDataReader Object. (Inherited from IDataReader.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetBoolean | Gets the value of the specified column as a Boolean. (Inherited from IDataRecord.)
Public method | GetByte | Gets the 8-bit unsigned integer value of the specified column. (Inherited from IDataRecord.)
Public method | GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. (Inherited from IDataRecord.)
Public method | GetChar | Gets the character value of the specified column. (Inherited from IDataRecord.)
Public method | GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset. (Inherited from IDataRecord.)
Public method | GetData | Returns an IDataReader for the specified column ordinal. (Inherited from IDataRecord.)
Public method | GetDataTypeName | Gets the data type information for the specified field. (Inherited from IDataRecord.)
Public method | GetDateTime | Gets the date and time data value of the specified field. (Inherited from IDataRecord.)
Public method | GetDecimal | Gets the fixed-position numeric value of the specified field. (Inherited from IDataRecord.)
Public method | GetDouble | Gets the double-precision floating point number of the specified field. (Inherited from IDataRecord.)
Public method | GetFieldType | Gets the Type information corresponding to the type of Object that would be returned from GetValue(Int32). (Inherited from IDataRecord.)
Public method | GetFloat | Gets the single-precision floating point number of the specified field. (Inherited from IDataRecord.)
Public method | GetGuid | Returns the GUID value of the specified field. (Inherited from IDataRecord.)
Public method | GetInt16 | Gets the 16-bit signed integer value of the specified field. (Inherited from IDataRecord.)
Public method | GetInt32 | Gets the 32-bit signed integer value of the specified field. (Inherited from IDataRecord.)
Public method | GetInt64 | Gets the 64-bit signed integer value of the specified field. (Inherited from IDataRecord.)
Public method | GetName | Gets the name for the field to find. (Inherited from IDataRecord.)
Public method | GetOrdinal | Return the index of the named field. (Inherited from IDataRecord.)
Public method | GetSchemaTable | Returns a DataTable that describes the column metadata of the IDataReader. (Inherited from IDataReader.)
Public method | GetString | Gets the string value of the specified field. (Inherited from IDataRecord.)
Public method | GetValue | Return the value of the specified field. (Inherited from IDataRecord.)
Public method | GetValues | Populates an array of objects with the column values of the current record. (Inherited from IDataRecord.)
Public method | IsDBNull | Return whether the specified field is set to null. (Inherited from IDataRecord.)
Public method | NextResult | Advances the data reader to the next result, when reading the results of batch SQL statements. (Inherited from IDataReader.)
Public method | Read | Advances the IDataReader to the next record. (Inherited from IDataReader.)
Top
See Also

Reference

IWrappedDataReader Interface
Dapper Namespace


SimpleMemberMap Class

SimpleMemberMap Class
Represents simple member map for one of target parameter or property or field to source DataReader column
Inheritance Hierarchy
SystemObject
DapperSimpleMemberMap

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SimpleMemberMap : SqlMapperIMemberMap
Public NotInheritable Class SimpleMemberMap
    Implements SqlMapperIMemberMap
public ref class SimpleMemberMap sealed : SqlMapperIMemberMap
[<SealedAttribute>]
type SimpleMemberMap =
    class
        interface SqlMapperIMemberMap
    end

The SimpleMemberMap type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleMemberMap(String, FieldInfo) | Creates instance for simple field mapping
Public method | SimpleMemberMap(String, ParameterInfo) | Creates instance for simple constructor parameter mapping
Public method | SimpleMemberMap(String, PropertyInfo) | Creates instance for simple property mapping
Top
Properties
 | Name | Description
Public property | ColumnName | DataReader column name
Public property | Field | Target field
Public property | MemberType | Target member type
Public property | Parameter | Target constructor parameter
Public property | Property | Target property
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


SimpleMemberMap Constructor

SimpleMemberMap Constructor
Overload List
 | Name | Description
Public method | SimpleMemberMap(String, FieldInfo) | Creates instance for simple field mapping
Public method | SimpleMemberMap(String, ParameterInfo) | Creates instance for simple constructor parameter mapping
Public method | SimpleMemberMap(String, PropertyInfo) | Creates instance for simple property mapping
Top
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap Constructor (String, FieldInfo)

SimpleMemberMap Constructor (String, FieldInfo)
Creates instance for simple field mapping

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleMemberMap(
    string columnName,
    FieldInfo field
)
Public Sub New (
    columnName As String,
    field As FieldInfo
)
public:
SimpleMemberMap(
    String^ columnName,
    FieldInfo^ field
)
new :
        columnName : string *
        field : FieldInfo -> SimpleMemberMap

Parameters

columnName
Type: SystemString
DataReader column name
field
Type: System.ReflectionFieldInfo
Target property
See Also

Reference

SimpleMemberMap Class
SimpleMemberMap Overload
Dapper Namespace


SimpleMemberMap Constructor (String, ParameterInfo)

SimpleMemberMap Constructor (String, ParameterInfo)
Creates instance for simple constructor parameter mapping

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleMemberMap(
    string columnName,
    ParameterInfo parameter
)
Public Sub New (
    columnName As String,
    parameter As ParameterInfo
)
public:
SimpleMemberMap(
    String^ columnName,
    ParameterInfo^ parameter
)
new :
        columnName : string *
        parameter : ParameterInfo -> SimpleMemberMap

Parameters

columnName
Type: SystemString
DataReader column name
parameter
Type: System.ReflectionParameterInfo
Target constructor parameter
See Also

Reference

SimpleMemberMap Class
SimpleMemberMap Overload
Dapper Namespace


SimpleMemberMap Constructor (String, PropertyInfo)

SimpleMemberMap Constructor (String, PropertyInfo)
Creates instance for simple property mapping

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleMemberMap(
    string columnName,
    PropertyInfo property
)
Public Sub New (
    columnName As String,
    property As PropertyInfo
)
public:
SimpleMemberMap(
    String^ columnName,
    PropertyInfo^ property
)
new :
        columnName : string *
        property : PropertyInfo -> SimpleMemberMap

Parameters

columnName
Type: SystemString
DataReader column name
property
Type: System.ReflectionPropertyInfo
Target property
See Also

Reference

SimpleMemberMap Class
SimpleMemberMap Overload
Dapper Namespace


SimpleMemberMap Properties

SimpleMemberMap Properties

The SimpleMemberMap type exposes the following members.

Properties
 | Name | Description
Public property | ColumnName | DataReader column name
Public property | Field | Target field
Public property | MemberType | Target member type
Public property | Parameter | Target constructor parameter
Public property | Property | Target property
Top
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap.ColumnName Property

SimpleMemberMapColumnName Property
DataReader column name

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ColumnName { get; }
Public ReadOnly Property ColumnName As String
    Get
public:
virtual property String^ ColumnName {
    String^ get () sealed;
}
abstract ColumnName : string with get
override ColumnName : string with get

Property Value

Type: String

Implements

SqlMapperIMemberMapColumnName
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap.Field Property

SimpleMemberMapField Property
Target field

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldInfo Field { get; }
Public ReadOnly Property Field As FieldInfo
    Get
public:
virtual property FieldInfo^ Field {
    FieldInfo^ get () sealed;
}
abstract Field : FieldInfo with get
override Field : FieldInfo with get

Property Value

Type: FieldInfo

Implements

SqlMapperIMemberMapField
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap.MemberType Property

SimpleMemberMapMemberType Property
Target member type

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Type MemberType { get; }
Public ReadOnly Property MemberType As Type
    Get
public:
virtual property Type^ MemberType {
    Type^ get () sealed;
}
abstract MemberType : Type with get
override MemberType : Type with get

Property Value

Type: Type

Implements

SqlMapperIMemberMapMemberType
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap.Parameter Property

SimpleMemberMapParameter Property
Target constructor parameter

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfo Parameter { get; }
Public ReadOnly Property Parameter As ParameterInfo
    Get
public:
virtual property ParameterInfo^ Parameter {
    ParameterInfo^ get () sealed;
}
abstract Parameter : ParameterInfo with get
override Parameter : ParameterInfo with get

Property Value

Type: ParameterInfo

Implements

SqlMapperIMemberMapParameter
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap.Property Property

SimpleMemberMapProperty Property
Target property

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyInfo Property { get; }
Public ReadOnly Property Property As PropertyInfo
    Get
public:
virtual property PropertyInfo^ Property {
    PropertyInfo^ get () sealed;
}
abstract Property : PropertyInfo with get
override Property : PropertyInfo with get

Property Value

Type: PropertyInfo

Implements

SqlMapperIMemberMapProperty
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SimpleMemberMap Methods

SimpleMemberMap Methods

The SimpleMemberMap type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleMemberMap Class
Dapper Namespace


SqlMapper Class

SqlMapper Class
Dapper, a light weight object mapper for ADO.NET
Inheritance Hierarchy
SystemObject
DapperSqlMapper

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SqlMapper
<ExtensionAttribute>
Public NotInheritable Class SqlMapper
[ExtensionAttribute]
public ref class SqlMapper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type SqlMapper =  class end

The SqlMapper type exposes the following members.

Properties
Name | Description
ConnectionStringComparer | How should connection strings be compared for equivalence? Defaults to StringComparer.Ordinal. Providing a custom implementation can be useful for allowing multi-tenancy databases with identical schema to share strategies. Note that usual equivalence rules apply: any equivalent connection strings MUST yield the same hash-code.
Top
Methods
Name | Description
AddTypeHandler(Type, SqlMapperITypeHandler) | Configure the specified type to be processed by a custom handler
AddTypeHandlerT(SqlMapperTypeHandlerT) | Configure the specified type to be processed by a custom handler
AddTypeHandlerImpl | Configure the specified type to be processed by a custom handler
AddTypeMap | Configure the specified type to be mapped to a given db-type
AsListT | Obtains the data as a list; if it is *already* a list, the original object is returned without any duplication; otherwise, ToList() is invoked.
AsTableValuedParameter | Used to pass a DataTable as a TableValuedParameter
CreateParamInfoGenerator | Internal use only
Execute(IDbConnection, CommandDefinition) | Execute parameterized SQL
Execute(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL
ExecuteReader(IDbConnection, CommandDefinition) | Execute parameterized SQL and return an IDataReader
ExecuteReader(IDbConnection, CommandDefinition, CommandBehavior) | Execute parameterized SQL and return an IDataReader
ExecuteReader(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL and return an IDataReader
ExecuteScalar(IDbConnection, CommandDefinition) | Execute parameterized SQL that selects a single value
ExecuteScalar(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL that selects a single value
ExecuteScalarT(IDbConnection, CommandDefinition) | Execute parameterized SQL that selects a single value
ExecuteScalarT(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL that selects a single value
FindOrAddParameter | Obsolete. Internal use only
Format | Obsolete. Convert numeric values to their string form for SQL literal purposes
GetDbType | Obsolete. Get the DbType that maps to a given value
GetTypeDeserializer | Internal use only
GetTypeMap | Gets type-map for the given type
GetTypeName | Fetch the type name associated with a DataTable
PackListParameters | Obsolete. Internal use only
PurgeQueryCache | Purge the query cache
Query(IDbConnection, String, Object) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, Type, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Executes a query, returning the data typed as per the Type suggested
QueryT(IDbConnection, CommandDefinition) | Executes a query, returning the data typed as per T
QueryT(IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Executes a query, returning the data typed as per T
QueryTFirst, TSecond, TReturn(IDbConnection, String, FuncTFirst, TSecond, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Maps a query to objects
QueryTFirst, TSecond, TThird, TReturn(IDbConnection, String, FuncTFirst, TSecond, TThird, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Maps a query to objects
QueryTFirst, TSecond, TThird, TFourth, TReturn(IDbConnection, String, FuncTFirst, TSecond, TThird, TFourth, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Perform a multi mapping query with 4 input parameters
QueryMultiple(IDbConnection, CommandDefinition) | Execute a command that returns multiple result sets, and access each in turn
QueryMultiple(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute a command that returns multiple result sets, and access each in turn
ReadChar | Obsolete. Internal use only
ReadNullableChar | Obsolete. Internal use only
ReplaceLiterals | Replace all literal tokens with their text form
ResetTypeHandlers | Clear the registered type handlers
SetTypeMap | Set custom mapping for type deserializers
SetTypeName | Associate a DataTable with a type name
ThrowDataException | Obsolete. Throws a data exception, only used internally
Top
Events
Name | Description
QueryCachePurged | Called if the query cache is purged via PurgeQueryCache
Top
See Also

Reference

Dapper Namespace


SqlMapper Properties

SqlMapper Properties

The SqlMapper type exposes the following members.

Properties
Name | Description
ConnectionStringComparer | How should connection strings be compared for equivalence? Defaults to StringComparer.Ordinal. Providing a custom implementation can be useful for allowing multi-tenancy databases with identical schema to share strategies. Note that usual equivalence rules apply: any equivalent connection strings MUST yield the same hash-code.
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ConnectionStringComparer Property

SqlMapperConnectionStringComparer Property
How should connection strings be compared for equivalence? Defaults to StringComparer.Ordinal. Providing a custom implementation can be useful for allowing multi-tenancy databases with identical schema to share strategies. Note that usual equivalence rules apply: any equivalent connection strings MUST yield the same hash-code.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEqualityComparer<string> ConnectionStringComparer { get; set; }
Public Shared Property ConnectionStringComparer As IEqualityComparer(Of String)
    Get
    Set
public:
static property IEqualityComparer<String^>^ ConnectionStringComparer {
    IEqualityComparer<String^>^ get ();
    void set (IEqualityComparer<String^>^ value);
}
static member ConnectionStringComparer : IEqualityComparer<string> with get, set

Property Value

Type: IEqualityComparer String
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper Methods

SqlMapper Methods

The SqlMapper type exposes the following members.

Methods
Name | Description
AddTypeHandler(Type, SqlMapperITypeHandler) | Configure the specified type to be processed by a custom handler
AddTypeHandlerT(SqlMapperTypeHandlerT) | Configure the specified type to be processed by a custom handler
AddTypeHandlerImpl | Configure the specified type to be processed by a custom handler
AddTypeMap | Configure the specified type to be mapped to a given db-type
AsListT | Obtains the data as a list; if it is *already* a list, the original object is returned without any duplication; otherwise, ToList() is invoked.
AsTableValuedParameter | Used to pass a DataTable as a TableValuedParameter
CreateParamInfoGenerator | Internal use only
Execute(IDbConnection, CommandDefinition) | Execute parameterized SQL
Execute(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL
ExecuteReader(IDbConnection, CommandDefinition) | Execute parameterized SQL and return an IDataReader
ExecuteReader(IDbConnection, CommandDefinition, CommandBehavior) | Execute parameterized SQL and return an IDataReader
ExecuteReader(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL and return an IDataReader
ExecuteScalar(IDbConnection, CommandDefinition) | Execute parameterized SQL that selects a single value
ExecuteScalar(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL that selects a single value
ExecuteScalarT(IDbConnection, CommandDefinition) | Execute parameterized SQL that selects a single value
ExecuteScalarT(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL that selects a single value
FindOrAddParameter | Obsolete. Internal use only
Format | Obsolete. Convert numeric values to their string form for SQL literal purposes
GetDbType | Obsolete. Get the DbType that maps to a given value
GetTypeDeserializer | Internal use only
GetTypeMap | Gets type-map for the given type
GetTypeName | Fetch the type name associated with a DataTable
PackListParameters | Obsolete. Internal use only
PurgeQueryCache | Purge the query cache
Query(IDbConnection, String, Object) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, Type, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Executes a query, returning the data typed as per the Type suggested
QueryT(IDbConnection, CommandDefinition) | Executes a query, returning the data typed as per T
QueryT(IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Executes a query, returning the data typed as per T
QueryTFirst, TSecond, TReturn(IDbConnection, String, FuncTFirst, TSecond, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Maps a query to objects
QueryTFirst, TSecond, TThird, TReturn(IDbConnection, String, FuncTFirst, TSecond, TThird, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Maps a query to objects
QueryTFirst, TSecond, TThird, TFourth, TReturn(IDbConnection, String, FuncTFirst, TSecond, TThird, TFourth, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Perform a multi mapping query with 4 input parameters
QueryMultiple(IDbConnection, CommandDefinition) | Execute a command that returns multiple result sets, and access each in turn
QueryMultiple(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute a command that returns multiple result sets, and access each in turn
ReadChar | Obsolete. Internal use only
ReadNullableChar | Obsolete. Internal use only
ReplaceLiterals | Replace all literal tokens with their text form
ResetTypeHandlers | Clear the registered type handlers
SetTypeMap | Set custom mapping for type deserializers
SetTypeName | Associate a DataTable with a type name
ThrowDataException | Obsolete. Throws a data exception, only used internally
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.AddTypeHandler Method

SqlMapperAddTypeHandler Method
Overload List
Name | Description
AddTypeHandlerT(SqlMapperTypeHandlerT) | Configure the specified type to be processed by a custom handler
AddTypeHandler(Type, SqlMapperITypeHandler) | Configure the specified type to be processed by a custom handler
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.AddTypeHandler(T) Method (SqlMapper.TypeHandler(T))

SqlMapperAddTypeHandlerT Method (SqlMapperTypeHandlerT)
Configure the specified type to be processed by a custom handler

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTypeHandler<T>(
    SqlMapperTypeHandler<T> handler
)

Public Shared Sub AddTypeHandler(Of T) (
    handler As SqlMapperTypeHandler(Of T)
)
public:
generic<typename T>
static void AddTypeHandler(
    SqlMapperTypeHandler<T>^ handler
)
static member AddTypeHandler :
        handler : SqlMapperTypeHandler<'T> -> unit

Parameters

handler
Type: DapperSqlMapperTypeHandler T

Type Parameters

T
See Also

Reference

SqlMapper Class
AddTypeHandler Overload
Dapper Namespace


SqlMapper.AddTypeHandler Method (Type, SqlMapper.ITypeHandler)

SqlMapperAddTypeHandler Method (Type, SqlMapperITypeHandler)
Configure the specified type to be processed by a custom handler

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTypeHandler(
    Type type,
    SqlMapperITypeHandler handler
)
Public Shared Sub AddTypeHandler (
    type As Type,
    handler As SqlMapperITypeHandler
)
public:
static void AddTypeHandler(
    Type^ type,
    SqlMapperITypeHandler^ handler
)
static member AddTypeHandler :
        type : Type *
        handler : SqlMapperITypeHandler -> unit

Parameters

type
Type: SystemType
handler
Type: DapperSqlMapperITypeHandler
See Also

Reference

SqlMapper Class
AddTypeHandler Overload
Dapper Namespace


SqlMapper.AddTypeHandlerImpl Method

SqlMapperAddTypeHandlerImpl Method
Configure the specified type to be processed by a custom handler

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTypeHandlerImpl(
    Type type,
    SqlMapperITypeHandler handler,
    bool clone
)
Public Shared Sub AddTypeHandlerImpl (
    type As Type,
    handler As SqlMapperITypeHandler,
    clone As Boolean
)
public:
static void AddTypeHandlerImpl(
    Type^ type,
    SqlMapperITypeHandler^ handler,
    bool clone
)
static member AddTypeHandlerImpl :
        type : Type *
        handler : SqlMapperITypeHandler *
        clone : bool -> unit

Parameters

type
Type: SystemType
handler
Type: DapperSqlMapperITypeHandler
clone
Type: SystemBoolean
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.AddTypeMap Method

SqlMapperAddTypeMap Method
Configure the specified type to be mapped to a given db-type

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTypeMap(
    Type type,
    DbType dbType
)
Public Shared Sub AddTypeMap (
    type As Type,
    dbType As DbType
)
public:
static void AddTypeMap(
    Type^ type,
    DbType dbType
)
static member AddTypeMap :
        type : Type *
        dbType : DbType -> unit

Parameters

type
Type: SystemType
dbType
Type: System.DataDbType
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.AsList(T) Method

SqlMapperAsListT Method
Obtains the data as a list; if it is *already* a list, the original object is returned without any duplication; otherwise, ToList() is invoked.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<T> AsList<T>(
    this IEnumerable<T> source
)

<ExtensionAttribute>
Public Shared Function AsList(Of T) (
    source As IEnumerable(Of T)
) As List(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static List<T>^ AsList(
    IEnumerable<T>^ source
)
[<ExtensionAttribute>]
static member AsList :
        source : IEnumerable<'T> -> List<'T>

Parameters

source
Type: System.Collections.GenericIEnumerable T

Type Parameters

T

Return Value

Type: List T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.AsTableValuedParameter Method

SqlMapperAsTableValuedParameter Method
Used to pass a DataTable as a TableValuedParameter

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SqlMapperICustomQueryParameter AsTableValuedParameter(
    this DataTable table,
    string typeName = null
)
<ExtensionAttribute>
Public Shared Function AsTableValuedParameter (
    table As DataTable,
    Optional typeName As String = Nothing
) As SqlMapperICustomQueryParameter
public:
[ExtensionAttribute]
static SqlMapperICustomQueryParameter^ AsTableValuedParameter(
    DataTable^ table,
    String^ typeName = nullptr
)
[<ExtensionAttribute>]
static member AsTableValuedParameter :
        table : DataTable *
        ?typeName : string
(* Defaults:
        let _typeName = defaultArg typeName null
*)
-> SqlMapperICustomQueryParameter

Parameters

table
Type: System.DataDataTable
typeName (Optional)
Type: SystemString

Return Value

Type: SqlMapperICustomQueryParameter

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataTable. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.CreateParamInfoGenerator Method

SqlMapperCreateParamInfoGenerator Method
Internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Action<IDbCommand, Object> CreateParamInfoGenerator(
    SqlMapperIdentity identity,
    bool checkForDuplicates,
    bool removeUnused
)
Public Shared Function CreateParamInfoGenerator (
    identity As SqlMapperIdentity,
    checkForDuplicates As Boolean,
    removeUnused As Boolean
) As Action(Of IDbCommand, Object)
public:
static Action<IDbCommand^, Object^>^ CreateParamInfoGenerator(
    SqlMapperIdentity^ identity,
    bool checkForDuplicates,
    bool removeUnused
)
static member CreateParamInfoGenerator :
        identity : SqlMapperIdentity *
        checkForDuplicates : bool *
        removeUnused : bool -> Action<IDbCommand, Object>

Parameters

identity
Type: DapperSqlMapperIdentity
checkForDuplicates
Type: SystemBoolean
removeUnused
Type: SystemBoolean

Return Value

Type: Action IDbCommand, Object
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.Execute Method

SqlMapperExecute Method
Overload List
Name | Description
Execute(IDbConnection, CommandDefinition) | Execute parameterized SQL
Execute(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.Execute Method (IDbConnection, CommandDefinition)

SqlMapperExecute Method (IDbConnection, CommandDefinition)
Execute parameterized SQL

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Execute(
    this IDbConnection cnn,
    CommandDefinition command
)
<ExtensionAttribute>
Public Shared Function Execute (
    cnn As IDbConnection,
    command As CommandDefinition
) As Integer
public:
[ExtensionAttribute]
static int Execute(
    IDbConnection^ cnn,
    CommandDefinition command
)
[<ExtensionAttribute>]
static member Execute :
        cnn : IDbConnection *
        command : CommandDefinition -> int

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition

Return Value

Type: Int32
Number of rows affected

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Execute Overload
Dapper Namespace


SqlMapper.Execute Method (IDbConnection, String, Object, IDbTransaction, Nullable(Int32), Nullable(CommandType))

SqlMapperExecute Method (IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType)
Execute parameterized SQL

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Execute(
    this IDbConnection cnn,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)
<ExtensionAttribute>
Public Shared Function Execute (
    cnn As IDbConnection,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As Integer
public:
[ExtensionAttribute]
static int Execute(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member Execute :
        cnn : IDbConnection *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> int

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Return Value

Type: Int32
Number of rows affected

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Execute Overload
Dapper Namespace


SqlMapper.ExecuteReader Method

SqlMapperExecuteReader Method
Overload List
Name | Description
ExecuteReader(IDbConnection, CommandDefinition) | Execute parameterized SQL and return an IDataReader
ExecuteReader(IDbConnection, CommandDefinition, CommandBehavior) | Execute parameterized SQL and return an IDataReader
ExecuteReader(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL and return an IDataReader
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ExecuteReader Method (IDbConnection, CommandDefinition)

SqlMapperExecuteReader Method (IDbConnection, CommandDefinition)
Execute parameterized SQL and return an IDataReader

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDataReader ExecuteReader(
    this IDbConnection cnn,
    CommandDefinition command
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    cnn As IDbConnection,
    command As CommandDefinition
) As IDataReader
public:
[ExtensionAttribute]
static IDataReader^ ExecuteReader(
    IDbConnection^ cnn,
    CommandDefinition command
)
[<ExtensionAttribute>]
static member ExecuteReader :
        cnn : IDbConnection *
        command : CommandDefinition -> IDataReader

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition

Return Value

Type: IDataReader
An IDataReader that can be used to iterate over the results of the SQL query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This is typically used when the results of a query are not processed by Dapper, for example, used to fill a DataTable or DataSet.
See Also

Reference

SqlMapper Class
ExecuteReader Overload
Dapper Namespace


SqlMapper.ExecuteReader Method (IDbConnection, CommandDefinition, CommandBehavior)

SqlMapperExecuteReader Method (IDbConnection, CommandDefinition, CommandBehavior)
Execute parameterized SQL and return an IDataReader

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDataReader ExecuteReader(
    this IDbConnection cnn,
    CommandDefinition command,
    CommandBehavior commandBehavior
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    cnn As IDbConnection,
    command As CommandDefinition,
    commandBehavior As CommandBehavior
) As IDataReader
public:
[ExtensionAttribute]
static IDataReader^ ExecuteReader(
    IDbConnection^ cnn,
    CommandDefinition command,
    CommandBehavior commandBehavior
)
[<ExtensionAttribute>]
static member ExecuteReader :
        cnn : IDbConnection *
        command : CommandDefinition *
        commandBehavior : CommandBehavior -> IDataReader

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition
commandBehavior
Type: System.DataCommandBehavior

Return Value

Type: IDataReader
An IDataReader that can be used to iterate over the results of the SQL query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This is typically used when the results of a query are not processed by Dapper, for example, used to fill a DataTable or DataSet.
See Also

Reference

SqlMapper Class
ExecuteReader Overload
Dapper Namespace


SqlMapper.ExecuteReader Method (IDbConnection, String, Object, IDbTransaction, Nullable(Int32), Nullable(CommandType))

SqlMapperExecuteReader Method (IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType)
Execute parameterized SQL and return an IDataReader

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDataReader ExecuteReader(
    this IDbConnection cnn,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    cnn As IDbConnection,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As IDataReader
public:
[ExtensionAttribute]
static IDataReader^ ExecuteReader(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member ExecuteReader :
        cnn : IDbConnection *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> IDataReader

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Return Value

Type: IDataReader
An IDataReader that can be used to iterate over the results of the SQL query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This is typically used when the results of a query are not processed by Dapper, for example, used to fill a DataTable or DataSet.
Examples
Copy
DataTable table = new DataTable("MyTable");
using (var reader = ExecuteReader(cnn, sql, param))
{
    table.Load(reader);
}
See Also

Reference

SqlMapper Class
ExecuteReader Overload
Dapper Namespace


SqlMapper.ExecuteScalar Method

SqlMapperExecuteScalar Method
Overload List
Name | Description
ExecuteScalar(IDbConnection, CommandDefinition) | Execute parameterized SQL that selects a single value
ExecuteScalarT(IDbConnection, CommandDefinition) | Execute parameterized SQL that selects a single value
ExecuteScalar(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL that selects a single value
ExecuteScalarT(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute parameterized SQL that selects a single value
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ExecuteScalar Method (IDbConnection, CommandDefinition)

SqlMapperExecuteScalar Method (IDbConnection, CommandDefinition)
Execute parameterized SQL that selects a single value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ExecuteScalar(
    this IDbConnection cnn,
    CommandDefinition command
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    cnn As IDbConnection,
    command As CommandDefinition
) As Object
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    IDbConnection^ cnn,
    CommandDefinition command
)
[<ExtensionAttribute>]
static member ExecuteScalar :
        cnn : IDbConnection *
        command : CommandDefinition -> Object

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition

Return Value

Type: Object
The first cell selected

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
ExecuteScalar Overload
Dapper Namespace


SqlMapper.ExecuteScalar(T) Method (IDbConnection, CommandDefinition)

SqlMapperExecuteScalarT Method (IDbConnection, CommandDefinition)
Execute parameterized SQL that selects a single value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T ExecuteScalar<T>(
    this IDbConnection cnn,
    CommandDefinition command
)

<ExtensionAttribute>
Public Shared Function ExecuteScalar(Of T) (
    cnn As IDbConnection,
    command As CommandDefinition
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T ExecuteScalar(
    IDbConnection^ cnn,
    CommandDefinition command
)
[<ExtensionAttribute>]
static member ExecuteScalar :
        cnn : IDbConnection *
        command : CommandDefinition -> 'T

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition

Type Parameters

T

Return Value

Type: T
The first cell selected

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
ExecuteScalar Overload
Dapper Namespace


SqlMapper.ExecuteScalar Method (IDbConnection, String, Object, IDbTransaction, Nullable(Int32), Nullable(CommandType))

SqlMapperExecuteScalar Method (IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType)
Execute parameterized SQL that selects a single value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ExecuteScalar(
    this IDbConnection cnn,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    cnn As IDbConnection,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As Object
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member ExecuteScalar :
        cnn : IDbConnection *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> Object

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Return Value

Type: Object
The first cell selected

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
ExecuteScalar Overload
Dapper Namespace


SqlMapper.ExecuteScalar(T) Method (IDbConnection, String, Object, IDbTransaction, Nullable(Int32), Nullable(CommandType))

SqlMapperExecuteScalarT Method (IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType)
Execute parameterized SQL that selects a single value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T ExecuteScalar<T>(
    this IDbConnection cnn,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)

<ExtensionAttribute>
Public Shared Function ExecuteScalar(Of T) (
    cnn As IDbConnection,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T ExecuteScalar(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member ExecuteScalar :
        cnn : IDbConnection *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> 'T

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Type Parameters

T

Return Value

Type: T
The first cell selected

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
ExecuteScalar Overload
Dapper Namespace


SqlMapper.FindOrAddParameter Method

SqlMapperFindOrAddParameter Method

Note: This API is now obsolete.

Internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is for internal usage only", true)]
public static IDbDataParameter FindOrAddParameter(
    IDataParameterCollection parameters,
    IDbCommand command,
    string name
)
<ObsoleteAttribute("This method is for internal usage only", true)>
Public Shared Function FindOrAddParameter (
    parameters As IDataParameterCollection,
    command As IDbCommand,
    name As String
) As IDbDataParameter
public:
[ObsoleteAttribute(L"This method is for internal usage only", true)]
static IDbDataParameter^ FindOrAddParameter(
    IDataParameterCollection^ parameters,
    IDbCommand^ command,
    String^ name
)
[<ObsoleteAttribute("This method is for internal usage only", true)>]
static member FindOrAddParameter :
        parameters : IDataParameterCollection *
        command : IDbCommand *
        name : string -> IDbDataParameter

Parameters

parameters
Type: System.DataIDataParameterCollection
command
Type: System.DataIDbCommand
name
Type: SystemString

Return Value

Type: IDbDataParameter
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.Format Method

SqlMapperFormat Method

Note: This API is now obsolete.

Convert numeric values to their string form for SQL literal purposes

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This is intended for internal usage only")]
public static string Format(
    Object value
)
<ObsoleteAttribute("This is intended for internal usage only")>
Public Shared Function Format (
    value As Object
) As String
public:
[ObsoleteAttribute(L"This is intended for internal usage only")]
static String^ Format(
    Object^ value
)
[<ObsoleteAttribute("This is intended for internal usage only")>]
static member Format :
        value : Object -> string

Parameters

value
Type: SystemObject

Return Value

Type: String
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.GetDbType Method

SqlMapperGetDbType Method

Note: This API is now obsolete.

Get the DbType that maps to a given value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is for internal use only")]
public static DbType GetDbType(
    Object value
)
<ObsoleteAttribute("This method is for internal use only")>
Public Shared Function GetDbType (
    value As Object
) As DbType
public:
[ObsoleteAttribute(L"This method is for internal use only")]
static DbType GetDbType(
    Object^ value
)
[<ObsoleteAttribute("This method is for internal use only")>]
static member GetDbType :
        value : Object -> DbType

Parameters

value
Type: SystemObject

Return Value

Type: DbType
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.GetTypeDeserializer Method

SqlMapperGetTypeDeserializer Method
Internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Func<IDataReader, Object> GetTypeDeserializer(
    Type type,
    IDataReader reader,
    int startBound = 0,
    int length = -1,
    bool returnNullIfFirstMissing = false
)
Public Shared Function GetTypeDeserializer (
    type As Type,
    reader As IDataReader,
    Optional startBound As Integer = 0,
    Optional length As Integer = -1,
    Optional returnNullIfFirstMissing As Boolean = false
) As Func(Of IDataReader, Object)
public:
static Func<IDataReader^, Object^>^ GetTypeDeserializer(
    Type^ type,
    IDataReader^ reader,
    int startBound = 0,
    int length = -1,
    bool returnNullIfFirstMissing = false
)
static member GetTypeDeserializer :
        type : Type *
        reader : IDataReader *
        ?startBound : int *
        ?length : int *
        ?returnNullIfFirstMissing : bool
(* Defaults:
        let _startBound = defaultArg startBound 0
        let _length = defaultArg length -1
        let _returnNullIfFirstMissing = defaultArg returnNullIfFirstMissing false
*)
-> Func<IDataReader, Object>

Parameters

type
Type: SystemType
reader
Type: System.DataIDataReader
startBound (Optional)
Type: SystemInt32
length (Optional)
Type: SystemInt32
returnNullIfFirstMissing (Optional)
Type: SystemBoolean

Return Value

Type: Func IDataReader, Object
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.GetTypeMap Method

SqlMapperGetTypeMap Method
Gets type-map for the given type

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SqlMapperITypeMap GetTypeMap(
    Type type
)
Public Shared Function GetTypeMap (
    type As Type
) As SqlMapperITypeMap
public:
static SqlMapperITypeMap^ GetTypeMap(
    Type^ type
)
static member GetTypeMap :
        type : Type -> SqlMapperITypeMap

Parameters

type
Type: SystemType

Return Value

Type: SqlMapperITypeMap
Type map implementation, DefaultTypeMap instance if no override present
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.GetTypeName Method

SqlMapperGetTypeName Method
Fetch the type name associated with a DataTable

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetTypeName(
    this DataTable table
)
<ExtensionAttribute>
Public Shared Function GetTypeName (
    table As DataTable
) As String
public:
[ExtensionAttribute]
static String^ GetTypeName(
    DataTable^ table
)
[<ExtensionAttribute>]
static member GetTypeName :
        table : DataTable -> string

Parameters

table
Type: System.DataDataTable

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataTable. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.PackListParameters Method

SqlMapperPackListParameters Method

Note: This API is now obsolete.

Internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is for internal usage only", false)]
public static void PackListParameters(
    IDbCommand command,
    string namePrefix,
    Object value
)
<ObsoleteAttribute("This method is for internal usage only", false)>
Public Shared Sub PackListParameters (
    command As IDbCommand,
    namePrefix As String,
    value As Object
)
public:
[ObsoleteAttribute(L"This method is for internal usage only", false)]
static void PackListParameters(
    IDbCommand^ command,
    String^ namePrefix,
    Object^ value
)
[<ObsoleteAttribute("This method is for internal usage only", false)>]
static member PackListParameters :
        command : IDbCommand *
        namePrefix : string *
        value : Object -> unit

Parameters

command
Type: System.DataIDbCommand
namePrefix
Type: SystemString
value
Type: SystemObject
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.PurgeQueryCache Method

SqlMapperPurgeQueryCache Method
Purge the query cache

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void PurgeQueryCache()
Public Shared Sub PurgeQueryCache
public:
static void PurgeQueryCache()
static member PurgeQueryCache : unit -> unit
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.Query Method

SqlMapperQuery Method
Overload List
Name | Description
QueryT(IDbConnection, CommandDefinition) | Executes a query, returning the data typed as per T
Query(IDbConnection, String, Object) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
Query(IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Return a list of dynamic objects, reader is closed after the call
QueryT(IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Executes a query, returning the data typed as per T
Query(IDbConnection, Type, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType) | Executes a query, returning the data typed as per the Type suggested
QueryTFirst, TSecond, TReturn(IDbConnection, String, FuncTFirst, TSecond, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Maps a query to objects
QueryTFirst, TSecond, TThird, TReturn(IDbConnection, String, FuncTFirst, TSecond, TThird, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Maps a query to objects
QueryTFirst, TSecond, TThird, TFourth, TReturn(IDbConnection, String, FuncTFirst, TSecond, TThird, TFourth, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType) | Perform a multi mapping query with 4 input parameters
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.Query(T) Method (IDbConnection, CommandDefinition)

SqlMapperQueryT Method (IDbConnection, CommandDefinition)
Executes a query, returning the data typed as per T

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> Query<T>(
    this IDbConnection cnn,
    CommandDefinition command
)

<ExtensionAttribute>
Public Shared Function Query(Of T) (
    cnn As IDbConnection,
    command As CommandDefinition
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ Query(
    IDbConnection^ cnn,
    CommandDefinition command
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        command : CommandDefinition -> IEnumerable<'T>

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition

Type Parameters

T

Return Value

Type: IEnumerable T
A sequence of data of the supplied type; if a basic type (int, string, etc) is queried then the data from the first column in assumed, otherwise an instance is created per row, and a direct column-name===member-name mapping is assumed (case insensitive).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
the dynamic param may seem a bit odd, but this works around a major usability issue in vs, if it is Object vs completion gets annoying. Eg type new [space] get new object
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query Method (IDbConnection, String, Object)

SqlMapperQuery Method (IDbConnection, String, Object)
Return a list of dynamic objects, reader is closed after the call

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<IDictionary<string, Object>> Query(
    this IDbConnection cnn,
    string sql,
    Object param
)
<ExtensionAttribute>
Public Shared Function Query (
    cnn As IDbConnection,
    sql As String,
    param As Object
) As IEnumerable(Of IDictionary(Of String, Object))
public:
[ExtensionAttribute]
static IEnumerable<IDictionary<String^, Object^>^>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        param : Object -> IEnumerable<IDictionary<string, Object>>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param
Type: SystemObject

Return Value

Type: IEnumerable IDictionary String, Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query Method (IDbConnection, String, Object, IDbTransaction)

SqlMapperQuery Method (IDbConnection, String, Object, IDbTransaction)
Return a list of dynamic objects, reader is closed after the call

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<IDictionary<string, Object>> Query(
    this IDbConnection cnn,
    string sql,
    Object param,
    IDbTransaction transaction
)
<ExtensionAttribute>
Public Shared Function Query (
    cnn As IDbConnection,
    sql As String,
    param As Object,
    transaction As IDbTransaction
) As IEnumerable(Of IDictionary(Of String, Object))
public:
[ExtensionAttribute]
static IEnumerable<IDictionary<String^, Object^>^>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param,
    IDbTransaction^ transaction
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        param : Object *
        transaction : IDbTransaction -> IEnumerable<IDictionary<string, Object>>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param
Type: SystemObject
transaction
Type: System.DataIDbTransaction

Return Value

Type: IEnumerable IDictionary String, Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query Method (IDbConnection, String, Object, Nullable(CommandType))

SqlMapperQuery Method (IDbConnection, String, Object, NullableCommandType)
Return a list of dynamic objects, reader is closed after the call

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<IDictionary<string, Object>> Query(
    this IDbConnection cnn,
    string sql,
    Object param,
    Nullable<CommandType> commandType
)
<ExtensionAttribute>
Public Shared Function Query (
    cnn As IDbConnection,
    sql As String,
    param As Object,
    commandType As Nullable(Of CommandType)
) As IEnumerable(Of IDictionary(Of String, Object))
public:
[ExtensionAttribute]
static IEnumerable<IDictionary<String^, Object^>^>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param,
    Nullable<CommandType> commandType
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        param : Object *
        commandType : Nullable<CommandType> -> IEnumerable<IDictionary<string, Object>>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param
Type: SystemObject
commandType
Type: SystemNullable CommandType

Return Value

Type: IEnumerable IDictionary String, Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query Method (IDbConnection, String, Object, IDbTransaction, Nullable(CommandType))

SqlMapperQuery Method (IDbConnection, String, Object, IDbTransaction, NullableCommandType)
Return a list of dynamic objects, reader is closed after the call

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<IDictionary<string, Object>> Query(
    this IDbConnection cnn,
    string sql,
    Object param,
    IDbTransaction transaction,
    Nullable<CommandType> commandType
)
<ExtensionAttribute>
Public Shared Function Query (
    cnn As IDbConnection,
    sql As String,
    param As Object,
    transaction As IDbTransaction,
    commandType As Nullable(Of CommandType)
) As IEnumerable(Of IDictionary(Of String, Object))
public:
[ExtensionAttribute]
static IEnumerable<IDictionary<String^, Object^>^>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param,
    IDbTransaction^ transaction,
    Nullable<CommandType> commandType
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        param : Object *
        transaction : IDbTransaction *
        commandType : Nullable<CommandType> -> IEnumerable<IDictionary<string, Object>>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param
Type: SystemObject
transaction
Type: System.DataIDbTransaction
commandType
Type: SystemNullable CommandType

Return Value

Type: IEnumerable IDictionary String, Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query Method (IDbConnection, String, Object, IDbTransaction, Boolean, Nullable(Int32), Nullable(CommandType))

SqlMapperQuery Method (IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType)
Return a list of dynamic objects, reader is closed after the call

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<IDictionary<string, Object>> Query(
    this IDbConnection cnn,
    string sql,
    Object param,
    IDbTransaction transaction,
    bool buffered,
    Nullable<int> commandTimeout,
    Nullable<CommandType> commandType
)
<ExtensionAttribute>
Public Shared Function Query (
    cnn As IDbConnection,
    sql As String,
    param As Object,
    transaction As IDbTransaction,
    buffered As Boolean,
    commandTimeout As Nullable(Of Integer),
    commandType As Nullable(Of CommandType)
) As IEnumerable(Of IDictionary(Of String, Object))
public:
[ExtensionAttribute]
static IEnumerable<IDictionary<String^, Object^>^>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param,
    IDbTransaction^ transaction,
    bool buffered,
    Nullable<int> commandTimeout,
    Nullable<CommandType> commandType
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        param : Object *
        transaction : IDbTransaction *
        buffered : bool *
        commandTimeout : Nullable<int> *
        commandType : Nullable<CommandType> -> IEnumerable<IDictionary<string, Object>>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param
Type: SystemObject
transaction
Type: System.DataIDbTransaction
buffered
Type: SystemBoolean
commandTimeout
Type: SystemNullable Int32
commandType
Type: SystemNullable CommandType

Return Value

Type: IEnumerable IDictionary String, Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query(T) Method (IDbConnection, String, Object, IDbTransaction, Boolean, Nullable(Int32), Nullable(CommandType))

SqlMapperQueryT Method (IDbConnection, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType)
Executes a query, returning the data typed as per T

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> Query<T>(
    this IDbConnection cnn,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    bool buffered = true,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)

<ExtensionAttribute>
Public Shared Function Query(Of T) (
    cnn As IDbConnection,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional buffered As Boolean = true,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    bool buffered = true,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?buffered : bool *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _buffered = defaultArg buffered true
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> IEnumerable<'T>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
buffered (Optional)
Type: SystemBoolean
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Type Parameters

T

Return Value

Type: IEnumerable T
A sequence of data of the supplied type; if a basic type (int, string, etc) is queried then the data from the first column in assumed, otherwise an instance is created per row, and a direct column-name===member-name mapping is assumed (case insensitive).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
the dynamic param may seem a bit odd, but this works around a major usability issue in vs, if it is Object vs completion gets annoying. Eg type new [space] get new object
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query Method (IDbConnection, Type, String, Object, IDbTransaction, Boolean, Nullable(Int32), Nullable(CommandType))

SqlMapperQuery Method (IDbConnection, Type, String, Object, IDbTransaction, Boolean, NullableInt32, NullableCommandType)
Executes a query, returning the data typed as per the Type suggested

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Object> Query(
    this IDbConnection cnn,
    Type type,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    bool buffered = true,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)
<ExtensionAttribute>
Public Shared Function Query (
    cnn As IDbConnection,
    type As Type,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional buffered As Boolean = true,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As IEnumerable(Of Object)
public:
[ExtensionAttribute]
static IEnumerable<Object^>^ Query(
    IDbConnection^ cnn,
    Type^ type,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    bool buffered = true,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        type : Type *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?buffered : bool *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _buffered = defaultArg buffered true
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> IEnumerable<Object>

Parameters

cnn
Type: System.DataIDbConnection
type
Type: SystemType
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
buffered (Optional)
Type: SystemBoolean
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Return Value

Type: IEnumerable Object
A sequence of data of the supplied type; if a basic type (int, string, etc) is queried then the data from the first column in assumed, otherwise an instance is created per row, and a direct column-name===member-name mapping is assumed (case insensitive).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query(TFirst, TSecond, TReturn) Method (IDbConnection, String, Func(TFirst, TSecond, TReturn), Object, IDbTransaction, Boolean, String, Nullable(Int32), Nullable(CommandType))

SqlMapperQueryTFirst, TSecond, TReturn Method (IDbConnection, String, FuncTFirst, TSecond, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType)
Maps a query to objects

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<TReturn> Query<TFirst, TSecond, TReturn>(
    this IDbConnection cnn,
    string sql,
    Func<TFirst, TSecond, TReturn> map,
    Object param = null,
    IDbTransaction transaction = null,
    bool buffered = true,
    string splitOn = "Id",
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)

<ExtensionAttribute>
Public Shared Function Query(Of TFirst, TSecond, TReturn) (
    cnn As IDbConnection,
    sql As String,
    map As Func(Of TFirst, TSecond, TReturn),
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional buffered As Boolean = true,
    Optional splitOn As String = "Id",
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As IEnumerable(Of TReturn)
public:
[ExtensionAttribute]
generic<typename TFirst, typename TSecond, typename TReturn>
static IEnumerable<TReturn>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Func<TFirst, TSecond, TReturn>^ map,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    bool buffered = true,
    String^ splitOn = L"Id",
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        map : Func<'TFirst, 'TSecond, 'TReturn> *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?buffered : bool *
        ?splitOn : string *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _buffered = defaultArg buffered true
        let _splitOn = defaultArg splitOn "Id"
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> IEnumerable<'TReturn>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
map
Type: SystemFunc TFirst, TSecond, TReturn
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
buffered (Optional)
Type: SystemBoolean
splitOn (Optional)
Type: SystemString
The Field we should split and read the second object from (default: id)
commandTimeout (Optional)
Type: SystemNullable Int32
Number of seconds before command execution timeout
commandType (Optional)
Type: SystemNullable CommandType
Is it a stored proc or a batch?

Type Parameters

TFirst
The first type in the record set
TSecond
The second type in the record set
TReturn
The return type

Return Value

Type: IEnumerable TReturn

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query(TFirst, TSecond, TThird, TReturn) Method (IDbConnection, String, Func(TFirst, TSecond, TThird, TReturn), Object, IDbTransaction, Boolean, String, Nullable(Int32), Nullable(CommandType))

SqlMapperQueryTFirst, TSecond, TThird, TReturn Method (IDbConnection, String, FuncTFirst, TSecond, TThird, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType)
Maps a query to objects

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<TReturn> Query<TFirst, TSecond, TThird, TReturn>(
    this IDbConnection cnn,
    string sql,
    Func<TFirst, TSecond, TThird, TReturn> map,
    Object param = null,
    IDbTransaction transaction = null,
    bool buffered = true,
    string splitOn = "Id",
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)

<ExtensionAttribute>
Public Shared Function Query(Of TFirst, TSecond, TThird, TReturn) (
    cnn As IDbConnection,
    sql As String,
    map As Func(Of TFirst, TSecond, TThird, TReturn),
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional buffered As Boolean = true,
    Optional splitOn As String = "Id",
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As IEnumerable(Of TReturn)
public:
[ExtensionAttribute]
generic<typename TFirst, typename TSecond, typename TThird, typename TReturn>
static IEnumerable<TReturn>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Func<TFirst, TSecond, TThird, TReturn>^ map,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    bool buffered = true,
    String^ splitOn = L"Id",
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        map : Func<'TFirst, 'TSecond, 'TThird, 'TReturn> *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?buffered : bool *
        ?splitOn : string *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _buffered = defaultArg buffered true
        let _splitOn = defaultArg splitOn "Id"
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> IEnumerable<'TReturn>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
map
Type: SystemFunc TFirst, TSecond, TThird, TReturn
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
buffered (Optional)
Type: SystemBoolean
splitOn (Optional)
Type: SystemString
The Field we should split and read the second object from (default: id)
commandTimeout (Optional)
Type: SystemNullable Int32
Number of seconds before command execution timeout
commandType (Optional)
Type: SystemNullable CommandType

Type Parameters

TFirst
TSecond
TThird
TReturn

Return Value

Type: IEnumerable TReturn

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.Query(TFirst, TSecond, TThird, TFourth, TReturn) Method (IDbConnection, String, Func(TFirst, TSecond, TThird, TFourth, TReturn), Object, IDbTransaction, Boolean, String, Nullable(Int32), Nullable(CommandType))

SqlMapperQueryTFirst, TSecond, TThird, TFourth, TReturn Method (IDbConnection, String, FuncTFirst, TSecond, TThird, TFourth, TReturn, Object, IDbTransaction, Boolean, String, NullableInt32, NullableCommandType)
Perform a multi mapping query with 4 input parameters

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<TReturn> Query<TFirst, TSecond, TThird, TFourth, TReturn>(
    this IDbConnection cnn,
    string sql,
    Func<TFirst, TSecond, TThird, TFourth, TReturn> map,
    Object param = null,
    IDbTransaction transaction = null,
    bool buffered = true,
    string splitOn = "Id",
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)

<ExtensionAttribute>
Public Shared Function Query(Of TFirst, TSecond, TThird, TFourth, TReturn) (
    cnn As IDbConnection,
    sql As String,
    map As Func(Of TFirst, TSecond, TThird, TFourth, TReturn),
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional buffered As Boolean = true,
    Optional splitOn As String = "Id",
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As IEnumerable(Of TReturn)
public:
[ExtensionAttribute]
generic<typename TFirst, typename TSecond, typename TThird, typename TFourth, typename TReturn>
static IEnumerable<TReturn>^ Query(
    IDbConnection^ cnn,
    String^ sql,
    Func<TFirst, TSecond, TThird, TFourth, TReturn>^ map,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    bool buffered = true,
    String^ splitOn = L"Id",
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member Query :
        cnn : IDbConnection *
        sql : string *
        map : Func<'TFirst, 'TSecond, 'TThird, 'TFourth, 'TReturn> *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?buffered : bool *
        ?splitOn : string *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _buffered = defaultArg buffered true
        let _splitOn = defaultArg splitOn "Id"
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> IEnumerable<'TReturn>

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
map
Type: SystemFunc TFirst, TSecond, TThird, TFourth, TReturn
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
buffered (Optional)
Type: SystemBoolean
splitOn (Optional)
Type: SystemString
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Type Parameters

TFirst
TSecond
TThird
TFourth
TReturn

Return Value

Type: IEnumerable TReturn

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Query Overload
Dapper Namespace


SqlMapper.QueryMultiple Method

SqlMapperQueryMultiple Method
Overload List
Name | Description
QueryMultiple(IDbConnection, CommandDefinition) | Execute a command that returns multiple result sets, and access each in turn
QueryMultiple(IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType) | Execute a command that returns multiple result sets, and access each in turn
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.QueryMultiple Method (IDbConnection, CommandDefinition)

SqlMapperQueryMultiple Method (IDbConnection, CommandDefinition)
Execute a command that returns multiple result sets, and access each in turn

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SqlMapperGridReader QueryMultiple(
    this IDbConnection cnn,
    CommandDefinition command
)
<ExtensionAttribute>
Public Shared Function QueryMultiple (
    cnn As IDbConnection,
    command As CommandDefinition
) As SqlMapperGridReader
public:
[ExtensionAttribute]
static SqlMapperGridReader^ QueryMultiple(
    IDbConnection^ cnn,
    CommandDefinition command
)
[<ExtensionAttribute>]
static member QueryMultiple :
        cnn : IDbConnection *
        command : CommandDefinition -> SqlMapperGridReader

Parameters

cnn
Type: System.DataIDbConnection
command
Type: DapperCommandDefinition

Return Value

Type: SqlMapperGridReader

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
QueryMultiple Overload
Dapper Namespace


SqlMapper.QueryMultiple Method (IDbConnection, String, Object, IDbTransaction, Nullable(Int32), Nullable(CommandType))

SqlMapperQueryMultiple Method (IDbConnection, String, Object, IDbTransaction, NullableInt32, NullableCommandType)
Execute a command that returns multiple result sets, and access each in turn

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SqlMapperGridReader QueryMultiple(
    this IDbConnection cnn,
    string sql,
    Object param = null,
    IDbTransaction transaction = null,
    Nullable<int> commandTimeout = null,
    Nullable<CommandType> commandType = null
)
<ExtensionAttribute>
Public Shared Function QueryMultiple (
    cnn As IDbConnection,
    sql As String,
    Optional param As Object = Nothing,
    Optional transaction As IDbTransaction = Nothing,
    Optional commandTimeout As Nullable(Of Integer) = Nothing,
    Optional commandType As Nullable(Of CommandType) = Nothing
) As SqlMapperGridReader
public:
[ExtensionAttribute]
static SqlMapperGridReader^ QueryMultiple(
    IDbConnection^ cnn,
    String^ sql,
    Object^ param = nullptr,
    IDbTransaction^ transaction = nullptr,
    Nullable<int> commandTimeout = nullptr,
    Nullable<CommandType> commandType = nullptr
)
[<ExtensionAttribute>]
static member QueryMultiple :
        cnn : IDbConnection *
        sql : string *
        ?param : Object *
        ?transaction : IDbTransaction *
        ?commandTimeout : Nullable<int> *
        ?commandType : Nullable<CommandType>
(* Defaults:
        let _param = defaultArg param null
        let _transaction = defaultArg transaction null
        let _commandTimeout = defaultArg commandTimeout null
        let _commandType = defaultArg commandType null
*)
-> SqlMapperGridReader

Parameters

cnn
Type: System.DataIDbConnection
sql
Type: SystemString
param (Optional)
Type: SystemObject
transaction (Optional)
Type: System.DataIDbTransaction
commandTimeout (Optional)
Type: SystemNullable Int32
commandType (Optional)
Type: SystemNullable CommandType

Return Value

Type: SqlMapperGridReader

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
QueryMultiple Overload
Dapper Namespace


SqlMapper.ReadChar Method

SqlMapperReadChar Method

Note: This API is now obsolete.

Internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is for internal usage only", false)]
public static char ReadChar(
    Object value
)
<ObsoleteAttribute("This method is for internal usage only", false)>
Public Shared Function ReadChar (
    value As Object
) As Char
public:
[ObsoleteAttribute(L"This method is for internal usage only", false)]
static wchar_t ReadChar(
    Object^ value
)
[<ObsoleteAttribute("This method is for internal usage only", false)>]
static member ReadChar :
        value : Object -> char

Parameters

value
Type: SystemObject

Return Value

Type: Char
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ReadNullableChar Method

SqlMapperReadNullableChar Method

Note: This API is now obsolete.

Internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is for internal usage only", false)]
public static Nullable<char> ReadNullableChar(
    Object value
)
<ObsoleteAttribute("This method is for internal usage only", false)>
Public Shared Function ReadNullableChar (
    value As Object
) As Nullable(Of Char)
public:
[ObsoleteAttribute(L"This method is for internal usage only", false)]
static Nullable<wchar_t> ReadNullableChar(
    Object^ value
)
[<ObsoleteAttribute("This method is for internal usage only", false)>]
static member ReadNullableChar :
        value : Object -> Nullable<char>

Parameters

value
Type: SystemObject

Return Value

Type: Nullable Char
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ReplaceLiterals Method

SqlMapperReplaceLiterals Method
Replace all literal tokens with their text form

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ReplaceLiterals(
    this SqlMapperIParameterLookup parameters,
    IDbCommand command
)
<ExtensionAttribute>
Public Shared Sub ReplaceLiterals (
    parameters As SqlMapperIParameterLookup,
    command As IDbCommand
)
public:
[ExtensionAttribute]
static void ReplaceLiterals(
    SqlMapperIParameterLookup^ parameters,
    IDbCommand^ command
)
[<ExtensionAttribute>]
static member ReplaceLiterals :
        parameters : SqlMapperIParameterLookup *
        command : IDbCommand -> unit

Parameters

parameters
Type: DapperSqlMapperIParameterLookup
command
Type: System.DataIDbCommand

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlMapperIParameterLookup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ResetTypeHandlers Method

SqlMapperResetTypeHandlers Method
Clear the registered type handlers

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ResetTypeHandlers()
Public Shared Sub ResetTypeHandlers
public:
static void ResetTypeHandlers()
static member ResetTypeHandlers : unit -> unit
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.SetTypeMap Method

SqlMapperSetTypeMap Method
Set custom mapping for type deserializers

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetTypeMap(
    Type type,
    SqlMapperITypeMap map
)
Public Shared Sub SetTypeMap (
    type As Type,
    map As SqlMapperITypeMap
)
public:
static void SetTypeMap(
    Type^ type,
    SqlMapperITypeMap^ map
)
static member SetTypeMap :
        type : Type *
        map : SqlMapperITypeMap -> unit

Parameters

type
Type: SystemType
Entity type to override
map
Type: DapperSqlMapperITypeMap
Mapping rules impementation, null to remove custom map
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.SetTypeName Method

SqlMapperSetTypeName Method
Associate a DataTable with a type name

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetTypeName(
    this DataTable table,
    string typeName
)
<ExtensionAttribute>
Public Shared Sub SetTypeName (
    table As DataTable,
    typeName As String
)
public:
[ExtensionAttribute]
static void SetTypeName(
    DataTable^ table,
    String^ typeName
)
[<ExtensionAttribute>]
static member SetTypeName :
        table : DataTable *
        typeName : string -> unit

Parameters

table
Type: System.DataDataTable
typeName
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataTable. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.ThrowDataException Method

SqlMapperThrowDataException Method

Note: This API is now obsolete.

Throws a data exception, only used internally

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Intended for internal use only")]
public static void ThrowDataException(
    Exception ex,
    int index,
    IDataReader reader,
    Object value
)
<ObsoleteAttribute("Intended for internal use only")>
Public Shared Sub ThrowDataException (
    ex As Exception,
    index As Integer,
    reader As IDataReader,
    value As Object
)
public:
[ObsoleteAttribute(L"Intended for internal use only")]
static void ThrowDataException(
    Exception^ ex,
    int index,
    IDataReader^ reader,
    Object^ value
)
[<ObsoleteAttribute("Intended for internal use only")>]
static member ThrowDataException :
        ex : Exception *
        index : int *
        reader : IDataReader *
        value : Object -> unit

Parameters

ex
Type: SystemException
index
Type: SystemInt32
reader
Type: System.DataIDataReader
value
Type: SystemObject
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper Events

SqlMapper Events

The SqlMapper type exposes the following members.

Events
Name | Description
QueryCachePurged | Called if the query cache is purged via PurgeQueryCache
Top
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.QueryCachePurged Event

SqlMapperQueryCachePurged Event
Called if the query cache is purged via PurgeQueryCache

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler QueryCachePurged
Public Shared Event QueryCachePurged As EventHandler
public:
static  event EventHandler^ QueryCachePurged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member QueryCachePurged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SqlMapper Class
Dapper Namespace


SqlMapper.GridReader Class

SqlMapperGridReader Class
The grid reader provides interfaces for reading multiple result sets from a Dapper query
Inheritance Hierarchy
SystemObject
DapperSqlMapperGridReader

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GridReader : IDisposable
Public Class GridReader
    Implements IDisposable
public ref class GridReader : IDisposable
type GridReader =
    class
        interface IDisposable
    end

The SqlMapperGridReader type exposes the following members.

Properties
 | Name | Description
Public property | IsConsumed | Has the underlying reader been consumed?
Top
Methods
 | Name | Description
Public method | Dispose | Dispose the grid, closing and disposing both the underlying reader and command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Type, Boolean) | Read the next grid of results
Public method | ReadT | Read the next grid of results
Public method | ReadT(Boolean) | Read the next grid of results
Public method | ReadTFirst, TSecond, TReturn(FuncTFirst, TSecond, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ReadTFirst, TSecond, TThird, TReturn(FuncTFirst, TSecond, TThird, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ReadTFirst, TSecond, TThird, TFourth, TReturn(FuncTFirst, TSecond, TThird, TFourth, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


GridReader Properties

GridReader Properties

The SqlMapperGridReader type exposes the following members.

Properties
 | Name | Description
Public property | IsConsumed | Has the underlying reader been consumed?
Top
See Also

Reference

SqlMapperGridReader Class
Dapper Namespace


SqlMapper.GridReader.IsConsumed Property

SqlMapperGridReaderIsConsumed Property
Has the underlying reader been consumed?

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConsumed { get; }
Public ReadOnly Property IsConsumed As Boolean
    Get
public:
property bool IsConsumed {
    bool get ();
}
member IsConsumed : bool with get

Property Value

Type: Boolean
See Also

Reference

SqlMapperGridReader Class
Dapper Namespace


GridReader Methods

GridReader Methods

The SqlMapperGridReader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose the grid, closing and disposing both the underlying reader and command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read(Type, Boolean) | Read the next grid of results
Public method | ReadT | Read the next grid of results
Public method | ReadT(Boolean) | Read the next grid of results
Public method | ReadTFirst, TSecond, TReturn(FuncTFirst, TSecond, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ReadTFirst, TSecond, TThird, TReturn(FuncTFirst, TSecond, TThird, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ReadTFirst, TSecond, TThird, TFourth, TReturn(FuncTFirst, TSecond, TThird, TFourth, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlMapperGridReader Class
Dapper Namespace


SqlMapper.GridReader.Dispose Method

SqlMapperGridReaderDispose Method
Dispose the grid, closing and disposing both the underlying reader and command.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SqlMapperGridReader Class
Dapper Namespace


GridReader.Read Method

GridReaderRead Method
Overload List
 | Name | Description
Public method | ReadT | Read the next grid of results
Public method | ReadT(Boolean) | Read the next grid of results
Public method | Read(Type, Boolean) | Read the next grid of results
Public method | ReadTFirst, TSecond, TReturn(FuncTFirst, TSecond, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ReadTFirst, TSecond, TThird, TReturn(FuncTFirst, TSecond, TThird, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Public method | ReadTFirst, TSecond, TThird, TFourth, TReturn(FuncTFirst, TSecond, TThird, TFourth, TReturn, String, Boolean) | Read multiple objects from a single record set on the grid
Top
See Also

Reference

SqlMapperGridReader Class
Dapper Namespace


SqlMapper.GridReader.Read(T) Method

SqlMapperGridReaderReadT Method
Read the next grid of results

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<T> Read<T>()

Public Function Read(Of T) As IEnumerable(Of T)
public:
generic<typename T>
IEnumerable<T>^ Read()
member Read : unit -> IEnumerable<'T>

Type Parameters

T

Return Value

Type: IEnumerable T
See Also

Reference

SqlMapperGridReader Class
Read Overload
Dapper Namespace


SqlMapper.GridReader.Read(T) Method (Boolean)

SqlMapperGridReaderReadT Method (Boolean)
Read the next grid of results

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<T> Read<T>(
    bool buffered = true
)

Public Function Read(Of T) (
    Optional buffered As Boolean = true
) As IEnumerable(Of T)
public:
generic<typename T>
IEnumerable<T>^ Read(
    bool buffered = true
)
member Read :
        ?buffered : bool
(* Defaults:
        let _buffered = defaultArg buffered true
*)
-> IEnumerable<'T>

Parameters

buffered (Optional)
Type: SystemBoolean

Type Parameters

T

Return Value

Type: IEnumerable T
See Also

Reference

SqlMapperGridReader Class
Read Overload
Dapper Namespace


SqlMapper.GridReader.Read Method (Type, Boolean)

SqlMapperGridReaderRead Method (Type, Boolean)
Read the next grid of results

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Object> Read(
    Type type,
    bool buffered = true
)
Public Function Read (
    type As Type,
    Optional buffered As Boolean = true
) As IEnumerable(Of Object)
public:
IEnumerable<Object^>^ Read(
    Type^ type,
    bool buffered = true
)
member Read :
        type : Type *
        ?buffered : bool
(* Defaults:
        let _buffered = defaultArg buffered true
*)
-> IEnumerable<Object>

Parameters

type
Type: SystemType
buffered (Optional)
Type: SystemBoolean

Return Value

Type: IEnumerable Object
See Also

Reference

SqlMapperGridReader Class
Read Overload
Dapper Namespace


SqlMapper.GridReader.Read(TFirst, TSecond, TReturn) Method (Func(TFirst, TSecond, TReturn), String, Boolean)

SqlMapperGridReaderReadTFirst, TSecond, TReturn Method (FuncTFirst, TSecond, TReturn, String, Boolean)
Read multiple objects from a single record set on the grid

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<TReturn> Read<TFirst, TSecond, TReturn>(
    Func<TFirst, TSecond, TReturn> func,
    string splitOn = "id",
    bool buffered = true
)

Public Function Read(Of TFirst, TSecond, TReturn) (
    func As Func(Of TFirst, TSecond, TReturn),
    Optional splitOn As String = "id",
    Optional buffered As Boolean = true
) As IEnumerable(Of TReturn)
public:
generic<typename TFirst, typename TSecond, typename TReturn>
IEnumerable<TReturn>^ Read(
    Func<TFirst, TSecond, TReturn>^ func,
    String^ splitOn = L"id",
    bool buffered = true
)
member Read :
        func : Func<'TFirst, 'TSecond, 'TReturn> *
        ?splitOn : string *
        ?buffered : bool
(* Defaults:
        let _splitOn = defaultArg splitOn "id"
        let _buffered = defaultArg buffered true
*)
-> IEnumerable<'TReturn>

Parameters

func
Type: SystemFunc TFirst, TSecond, TReturn
splitOn (Optional)
Type: SystemString
buffered (Optional)
Type: SystemBoolean

Type Parameters

TFirst
TSecond
TReturn

Return Value

Type: IEnumerable TReturn
See Also

Reference

SqlMapperGridReader Class
Read Overload
Dapper Namespace


SqlMapper.GridReader.Read(TFirst, TSecond, TThird, TReturn) Method (Func(TFirst, TSecond, TThird, TReturn), String, Boolean)

SqlMapperGridReaderReadTFirst, TSecond, TThird, TReturn Method (FuncTFirst, TSecond, TThird, TReturn, String, Boolean)
Read multiple objects from a single record set on the grid

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<TReturn> Read<TFirst, TSecond, TThird, TReturn>(
    Func<TFirst, TSecond, TThird, TReturn> func,
    string splitOn = "id",
    bool buffered = true
)

Public Function Read(Of TFirst, TSecond, TThird, TReturn) (
    func As Func(Of TFirst, TSecond, TThird, TReturn),
    Optional splitOn As String = "id",
    Optional buffered As Boolean = true
) As IEnumerable(Of TReturn)
public:
generic<typename TFirst, typename TSecond, typename TThird, typename TReturn>
IEnumerable<TReturn>^ Read(
    Func<TFirst, TSecond, TThird, TReturn>^ func,
    String^ splitOn = L"id",
    bool buffered = true
)
member Read :
        func : Func<'TFirst, 'TSecond, 'TThird, 'TReturn> *
        ?splitOn : string *
        ?buffered : bool
(* Defaults:
        let _splitOn = defaultArg splitOn "id"
        let _buffered = defaultArg buffered true
*)
-> IEnumerable<'TReturn>

Parameters

func
Type: SystemFunc TFirst, TSecond, TThird, TReturn
splitOn (Optional)
Type: SystemString
buffered (Optional)
Type: SystemBoolean

Type Parameters

TFirst
TSecond
TThird
TReturn

Return Value

Type: IEnumerable TReturn
See Also

Reference

SqlMapperGridReader Class
Read Overload
Dapper Namespace


SqlMapper.GridReader.Read(TFirst, TSecond, TThird, TFourth, TReturn) Method (Func(TFirst, TSecond, TThird, TFourth, TReturn), String, Boolean)

SqlMapperGridReaderReadTFirst, TSecond, TThird, TFourth, TReturn Method (FuncTFirst, TSecond, TThird, TFourth, TReturn, String, Boolean)
Read multiple objects from a single record set on the grid

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<TReturn> Read<TFirst, TSecond, TThird, TFourth, TReturn>(
    Func<TFirst, TSecond, TThird, TFourth, TReturn> func,
    string splitOn = "id",
    bool buffered = true
)

Public Function Read(Of TFirst, TSecond, TThird, TFourth, TReturn) (
    func As Func(Of TFirst, TSecond, TThird, TFourth, TReturn),
    Optional splitOn As String = "id",
    Optional buffered As Boolean = true
) As IEnumerable(Of TReturn)
public:
generic<typename TFirst, typename TSecond, typename TThird, typename TFourth, typename TReturn>
IEnumerable<TReturn>^ Read(
    Func<TFirst, TSecond, TThird, TFourth, TReturn>^ func,
    String^ splitOn = L"id",
    bool buffered = true
)
member Read :
        func : Func<'TFirst, 'TSecond, 'TThird, 'TFourth, 'TReturn> *
        ?splitOn : string *
        ?buffered : bool
(* Defaults:
        let _splitOn = defaultArg splitOn "id"
        let _buffered = defaultArg buffered true
*)
-> IEnumerable<'TReturn>

Parameters

func
Type: SystemFunc TFirst, TSecond, TThird, TFourth, TReturn
splitOn (Optional)
Type: SystemString
buffered (Optional)
Type: SystemBoolean

Type Parameters

TFirst
TSecond
TThird
TFourth
TReturn

Return Value

Type: IEnumerable TReturn
See Also

Reference

SqlMapperGridReader Class
Read Overload
Dapper Namespace


SqlMapper.ICustomQueryParameter Interface

SqlMapperICustomQueryParameter Interface
Implement this interface to pass an arbitrary db specific parameter to Dapper

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICustomQueryParameter
Public Interface ICustomQueryParameter
public interface class ICustomQueryParameter
type ICustomQueryParameter =  interface end

The SqlMapperICustomQueryParameter type exposes the following members.

Methods
 | Name | Description
Public method | AddParameter | Add the parameter needed to the command before it executes
Top
See Also

Reference

Dapper Namespace


ICustomQueryParameter Methods

ICustomQueryParameter Methods

The SqlMapperICustomQueryParameter type exposes the following members.

Methods
 | Name | Description
Public method | AddParameter | Add the parameter needed to the command before it executes
Top
See Also

Reference

SqlMapperICustomQueryParameter Interface
Dapper Namespace


SqlMapper.ICustomQueryParameter.AddParameter Method

SqlMapperICustomQueryParameterAddParameter Method
Add the parameter needed to the command before it executes

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddParameter(
    IDbCommand command,
    string name
)
Sub AddParameter (
    command As IDbCommand,
    name As String
)
void AddParameter(
    IDbCommand^ command,
    String^ name
)
abstract AddParameter :
        command : IDbCommand *
        name : string -> unit

Parameters

command
Type: System.DataIDbCommand
The raw command prior to execution
name
Type: SystemString
Parameter name
See Also

Reference

SqlMapperICustomQueryParameter Interface
Dapper Namespace


SqlMapper.Identity Class

SqlMapperIdentity Class
Identity of a cached query in Dapper, used for extensibility
Inheritance Hierarchy
SystemObject
DapperSqlMapperIdentity

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Identity : IEquatable<SqlMapperIdentity>
Public Class Identity
    Implements IEquatable(Of SqlMapperIdentity)
public ref class Identity : IEquatable<SqlMapperIdentity^>
type Identity =
    class
        interface IEquatable<SqlMapperIdentity>
    end

The SqlMapperIdentity type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SqlMapperIdentity) | Compare 2 Identity objects
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForDynamicParameters | Create an identity for use with DynamicParameters, internal use only
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | commandType | The command type
Public field | connectionString |
Public field | gridIndex |
Public field | hashCode |
Public field | parametersType |
Public field | sql | The sql
Public field | type |
Top
See Also

Reference

Dapper Namespace


Identity Methods

Identity Methods

The SqlMapperIdentity type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SqlMapperIdentity) | Compare 2 Identity objects
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForDynamicParameters | Create an identity for use with DynamicParameters, internal use only
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


Identity.Equals Method

IdentityEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SqlMapperIdentity) | Compare 2 Identity objects
Top
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.Equals Method (Object)

SqlMapperIdentityEquals Method (Object)

[Missing <summary> documentation for "M:Dapper.SqlMapper.Identity.Equals(System.Object)"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

SqlMapperIdentity Class
Equals Overload
Dapper Namespace


SqlMapper.Identity.Equals Method (SqlMapper.Identity)

SqlMapperIdentityEquals Method (SqlMapperIdentity)
Compare 2 Identity objects

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    SqlMapperIdentity other
)
Public Function Equals (
    other As SqlMapperIdentity
) As Boolean
public:
virtual bool Equals(
    SqlMapperIdentity^ other
) sealed
abstract Equals :
        other : SqlMapperIdentity -> bool
override Equals :
        other : SqlMapperIdentity -> bool

Parameters

other
Type: DapperSqlMapperIdentity

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

SqlMapperIdentity Class
Equals Overload
Dapper Namespace


SqlMapper.Identity.ForDynamicParameters Method

SqlMapperIdentityForDynamicParameters Method
Create an identity for use with DynamicParameters, internal use only

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlMapperIdentity ForDynamicParameters(
    Type type
)
Public Function ForDynamicParameters (
    type As Type
) As SqlMapperIdentity
public:
SqlMapperIdentity^ ForDynamicParameters(
    Type^ type
)
member ForDynamicParameters :
        type : Type -> SqlMapperIdentity

Parameters

type
Type: SystemType

Return Value

Type: SqlMapperIdentity
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.GetHashCode Method

SqlMapperIdentityGetHashCode Method

[Missing <summary> documentation for "M:Dapper.SqlMapper.Identity.GetHashCode"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


Identity Fields

Identity Fields

The SqlMapperIdentity type exposes the following members.

Fields
 | Name | Description
Public field | commandType | The command type
Public field | connectionString |
Public field | gridIndex |
Public field | hashCode |
Public field | parametersType |
Public field | sql | The sql
Public field | type |
Top
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.commandType Field

SqlMapperIdentitycommandType Field
The command type

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Nullable<CommandType> commandType
Public ReadOnly commandType As Nullable(Of CommandType)
public:
initonly Nullable<CommandType> commandType
val commandType: Nullable<CommandType>

Field Value

Type: Nullable CommandType
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.connectionString Field

SqlMapperIdentityconnectionString Field

[Missing <summary> documentation for "F:Dapper.SqlMapper.Identity.connectionString"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly string connectionString
Public ReadOnly connectionString As String
public:
initonly String^ connectionString
val connectionString: string

Field Value

Type: String
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.gridIndex Field

SqlMapperIdentitygridIndex Field

[Missing <summary> documentation for "F:Dapper.SqlMapper.Identity.gridIndex"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly int gridIndex
Public ReadOnly gridIndex As Integer
public:
initonly int gridIndex
val gridIndex: int

Field Value

Type: Int32
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.hashCode Field

SqlMapperIdentityhashCode Field

[Missing <summary> documentation for "F:Dapper.SqlMapper.Identity.hashCode"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly int hashCode
Public ReadOnly hashCode As Integer
public:
initonly int hashCode
val hashCode: int

Field Value

Type: Int32
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.parametersType Field

SqlMapperIdentityparametersType Field

[Missing <summary> documentation for "F:Dapper.SqlMapper.Identity.parametersType"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Type parametersType
Public ReadOnly parametersType As Type
public:
initonly Type^ parametersType
val parametersType: Type

Field Value

Type: Type
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.sql Field

SqlMapperIdentitysql Field
The sql

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly string sql
Public ReadOnly sql As String
public:
initonly String^ sql
val sql: string

Field Value

Type: String
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.Identity.type Field

SqlMapperIdentitytype Field

[Missing <summary> documentation for "F:Dapper.SqlMapper.Identity.type"]

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public readonly Type type
Public ReadOnly type As Type
public:
initonly Type^ type
val type: Type

Field Value

Type: Type
See Also

Reference

SqlMapperIdentity Class
Dapper Namespace


SqlMapper.IDynamicParameters Interface

SqlMapperIDynamicParameters Interface
Implement this interface to pass an arbitrary db specific set of parameters to Dapper

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDynamicParameters
Public Interface IDynamicParameters
public interface class IDynamicParameters
type IDynamicParameters =  interface end

The SqlMapperIDynamicParameters type exposes the following members.

Methods
 | Name | Description
Public method | AddParameters | Add all the parameters needed to the command just before it executes
Top
See Also

Reference

Dapper Namespace


IDynamicParameters Methods

IDynamicParameters Methods

The SqlMapperIDynamicParameters type exposes the following members.

Methods
 | Name | Description
Public method | AddParameters | Add all the parameters needed to the command just before it executes
Top
See Also

Reference

SqlMapperIDynamicParameters Interface
Dapper Namespace


SqlMapper.IDynamicParameters.AddParameters Method

SqlMapperIDynamicParametersAddParameters Method
Add all the parameters needed to the command just before it executes

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddParameters(
    IDbCommand command,
    SqlMapperIdentity identity
)
Sub AddParameters (
    command As IDbCommand,
    identity As SqlMapperIdentity
)
void AddParameters(
    IDbCommand^ command,
    SqlMapperIdentity^ identity
)
abstract AddParameters :
        command : IDbCommand *
        identity : SqlMapperIdentity -> unit

Parameters

command
Type: System.DataIDbCommand
The raw command prior to execution
identity
Type: DapperSqlMapperIdentity
Information about the query
See Also

Reference

SqlMapperIDynamicParameters Interface
Dapper Namespace


SqlMapper.IMemberMap Interface

SqlMapperIMemberMap Interface
Implements this interface to provide custom member mapping

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMemberMap
Public Interface IMemberMap
public interface class IMemberMap
type IMemberMap =  interface end

The SqlMapperIMemberMap type exposes the following members.

Properties
 | Name | Description
Public property | ColumnName | Source DataReader column name
Public property | Field | Target field
Public property | MemberType | Target member type
Public property | Parameter | Target constructor parameter
Public property | Property | Target property
Top
See Also

Reference

Dapper Namespace


IMemberMap Properties

IMemberMap Properties

The SqlMapperIMemberMap type exposes the following members.

Properties
 | Name | Description
Public property | ColumnName | Source DataReader column name
Public property | Field | Target field
Public property | MemberType | Target member type
Public property | Parameter | Target constructor parameter
Public property | Property | Target property
Top
See Also

Reference

SqlMapperIMemberMap Interface
Dapper Namespace


SqlMapper.IMemberMap.ColumnName Property

SqlMapperIMemberMapColumnName Property
Source DataReader column name

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ColumnName { get; }
ReadOnly Property ColumnName As String
    Get
property String^ ColumnName {
    String^ get ();
}
abstract ColumnName : string with get

Property Value

Type: String
See Also

Reference

SqlMapperIMemberMap Interface
Dapper Namespace


SqlMapper.IMemberMap.Field Property

SqlMapperIMemberMapField Property
Target field

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
FieldInfo Field { get; }
ReadOnly Property Field As FieldInfo
    Get
property FieldInfo^ Field {
    FieldInfo^ get ();
}
abstract Field : FieldInfo with get

Property Value

Type: FieldInfo
See Also

Reference

SqlMapperIMemberMap Interface
Dapper Namespace


SqlMapper.IMemberMap.MemberType Property

SqlMapperIMemberMapMemberType Property
Target member type

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Type MemberType { get; }
ReadOnly Property MemberType As Type
    Get
property Type^ MemberType {
    Type^ get ();
}
abstract MemberType : Type with get

Property Value

Type: Type
See Also

Reference

SqlMapperIMemberMap Interface
Dapper Namespace


SqlMapper.IMemberMap.Parameter Property

SqlMapperIMemberMapParameter Property
Target constructor parameter

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ParameterInfo Parameter { get; }
ReadOnly Property Parameter As ParameterInfo
    Get
property ParameterInfo^ Parameter {
    ParameterInfo^ get ();
}
abstract Parameter : ParameterInfo with get

Property Value

Type: ParameterInfo
See Also

Reference

SqlMapperIMemberMap Interface
Dapper Namespace


SqlMapper.IMemberMap.Property Property

SqlMapperIMemberMapProperty Property
Target property

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PropertyInfo Property { get; }
ReadOnly Property Property As PropertyInfo
    Get
property PropertyInfo^ Property {
    PropertyInfo^ get ();
}
abstract Property : PropertyInfo with get

Property Value

Type: PropertyInfo
See Also

Reference

SqlMapperIMemberMap Interface
Dapper Namespace


SqlMapper.IParameterCallbacks Interface

SqlMapperIParameterCallbacks Interface
Extends IDynamicParameters with facilities for executing callbacks after commands have completed

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParameterCallbacks : SqlMapperIDynamicParameters
Public Interface IParameterCallbacks
    Inherits SqlMapperIDynamicParameters
public interface class IParameterCallbacks : SqlMapperIDynamicParameters
type IParameterCallbacks =
    interface
        interface SqlMapperIDynamicParameters
    end

The SqlMapperIParameterCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | AddParameters | Add all the parameters needed to the command just before it executes (Inherited from SqlMapperIDynamicParameters.)
Public method | OnCompleted | Invoked when the command has executed
Top
See Also

Reference

Dapper Namespace


IParameterCallbacks Methods

IParameterCallbacks Methods

The SqlMapperIParameterCallbacks type exposes the following members.

Methods
 | Name | Description
Public method | AddParameters | Add all the parameters needed to the command just before it executes (Inherited from SqlMapperIDynamicParameters.)
Public method | OnCompleted | Invoked when the command has executed
Top
See Also

Reference

SqlMapperIParameterCallbacks Interface
Dapper Namespace


SqlMapper.IParameterCallbacks.OnCompleted Method

SqlMapperIParameterCallbacksOnCompleted Method
Invoked when the command has executed

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnCompleted()
Sub OnCompleted
void OnCompleted()
abstract OnCompleted : unit -> unit
See Also

Reference

SqlMapperIParameterCallbacks Interface
Dapper Namespace


SqlMapper.IParameterLookup Interface

SqlMapperIParameterLookup Interface
Extends IDynamicParameters providing by-name lookup of parameter values

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParameterLookup : SqlMapperIDynamicParameters
Public Interface IParameterLookup
    Inherits SqlMapperIDynamicParameters
public interface class IParameterLookup : SqlMapperIDynamicParameters
type IParameterLookup =
    interface
        interface SqlMapperIDynamicParameters
    end

The SqlMapperIParameterLookup type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the value of the specified parameter (return null if not found)
Top
Methods
 | Name | Description
Public method | AddParameters | Add all the parameters needed to the command just before it executes (Inherited from SqlMapperIDynamicParameters.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ReplaceLiterals | Replace all literal tokens with their text form (Defined by SqlMapper.)
Top
See Also

Reference

Dapper Namespace


IParameterLookup Properties

IParameterLookup Properties

The SqlMapperIParameterLookup type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get the value of the specified parameter (return null if not found)
Top
See Also

Reference

SqlMapperIParameterLookup Interface
Dapper Namespace


SqlMapper.IParameterLookup.Item Property

SqlMapperIParameterLookupItem Property
Get the value of the specified parameter (return null if not found)

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As Object
    Get
property Object^ default[String^ name] {
    Object^ get (String^ name);
}
abstract Item : Object with get

Parameters

name
Type: SystemString

Property Value

Type: Object
See Also

Reference

SqlMapperIParameterLookup Interface
Dapper Namespace


IParameterLookup Methods

IParameterLookup Methods

The SqlMapperIParameterLookup type exposes the following members.

Methods
 | Name | Description
Public method | AddParameters | Add all the parameters needed to the command just before it executes (Inherited from SqlMapperIDynamicParameters.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ReplaceLiterals | Replace all literal tokens with their text form (Defined by SqlMapper.)
Top
See Also

Reference

SqlMapperIParameterLookup Interface
Dapper Namespace


SqlMapper.ITypeHandler Interface

SqlMapperITypeHandler Interface
Implement this interface to perform custom type-based parameter handling and value parsing

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITypeHandler
Public Interface ITypeHandler
public interface class ITypeHandler
type ITypeHandler =  interface end

The SqlMapperITypeHandler type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Parse a database value back to a typed value
Public method | SetValue | Assign the value of a parameter before a command executes
Top
See Also

Reference

Dapper Namespace


ITypeHandler Methods

ITypeHandler Methods

The SqlMapperITypeHandler type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Parse a database value back to a typed value
Public method | SetValue | Assign the value of a parameter before a command executes
Top
See Also

Reference

SqlMapperITypeHandler Interface
Dapper Namespace


SqlMapper.ITypeHandler.Parse Method

SqlMapperITypeHandlerParse Method
Parse a database value back to a typed value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Parse(
    Type destinationType,
    Object value
)
Function Parse (
    destinationType As Type,
    value As Object
) As Object
Object^ Parse(
    Type^ destinationType,
    Object^ value
)
abstract Parse :
        destinationType : Type *
        value : Object -> Object

Parameters

destinationType
Type: SystemType
The type to parse to
value
Type: SystemObject
The value from the database

Return Value

Type: Object
The typed value
See Also

Reference

SqlMapperITypeHandler Interface
Dapper Namespace


SqlMapper.ITypeHandler.SetValue Method

SqlMapperITypeHandlerSetValue Method
Assign the value of a parameter before a command executes

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetValue(
    IDbDataParameter parameter,
    Object value
)
Sub SetValue (
    parameter As IDbDataParameter,
    value As Object
)
void SetValue(
    IDbDataParameter^ parameter,
    Object^ value
)
abstract SetValue :
        parameter : IDbDataParameter *
        value : Object -> unit

Parameters

parameter
Type: System.DataIDbDataParameter
The parameter to configure
value
Type: SystemObject
Parameter value
See Also

Reference

SqlMapperITypeHandler Interface
Dapper Namespace


SqlMapper.ITypeMap Interface

SqlMapperITypeMap Interface
Implement this interface to change default mapping of reader columns to type members

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITypeMap
Public Interface ITypeMap
public interface class ITypeMap
type ITypeMap =  interface end

The SqlMapperITypeMap type exposes the following members.

Methods
 | Name | Description
Public method | FindConstructor | Finds best constructor
Public method | FindExplicitConstructor | Returns a constructor which should *always* be used. Parameters will be default values, nulls for reference types and zero'd for value types. Use this class to force object creation away from parameterless constructors you don't control.
Public method | GetConstructorParameter | Gets mapping for constructor parameter
Public method | GetMember | Gets member mapping for column
Top
See Also

Reference

Dapper Namespace


ITypeMap Methods

ITypeMap Methods

The SqlMapperITypeMap type exposes the following members.

Methods
 | Name | Description
Public method | FindConstructor | Finds best constructor
Public method | FindExplicitConstructor | Returns a constructor which should *always* be used. Parameters will be default values, nulls for reference types and zero'd for value types. Use this class to force object creation away from parameterless constructors you don't control.
Public method | GetConstructorParameter | Gets mapping for constructor parameter
Public method | GetMember | Gets member mapping for column
Top
See Also

Reference

SqlMapperITypeMap Interface
Dapper Namespace


SqlMapper.ITypeMap.FindConstructor Method

SqlMapperITypeMapFindConstructor Method
Finds best constructor

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConstructorInfo FindConstructor(
    string[] names,
    Type[] types
)
Function FindConstructor (
    names As String(),
    types As Type()
) As ConstructorInfo
ConstructorInfo^ FindConstructor(
    array<String^>^ names,
    array<Type^>^ types
)
abstract FindConstructor :
        names : string[] *
        types : Type[] -> ConstructorInfo

Parameters

names
Type: SystemString
DataReader column names
types
Type: SystemType
DataReader column types

Return Value

Type: ConstructorInfo
Matching constructor or default one
See Also

Reference

SqlMapperITypeMap Interface
Dapper Namespace


SqlMapper.ITypeMap.FindExplicitConstructor Method

SqlMapperITypeMapFindExplicitConstructor Method
Returns a constructor which should *always* be used. Parameters will be default values, nulls for reference types and zero'd for value types. Use this class to force object creation away from parameterless constructors you don't control.

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConstructorInfo FindExplicitConstructor()
Function FindExplicitConstructor As ConstructorInfo
ConstructorInfo^ FindExplicitConstructor()
abstract FindExplicitConstructor : unit -> ConstructorInfo

Return Value

Type: ConstructorInfo
See Also

Reference

SqlMapperITypeMap Interface
Dapper Namespace


SqlMapper.ITypeMap.GetConstructorParameter Method

SqlMapperITypeMapGetConstructorParameter Method
Gets mapping for constructor parameter

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SqlMapperIMemberMap GetConstructorParameter(
    ConstructorInfo constructor,
    string columnName
)
Function GetConstructorParameter (
    constructor As ConstructorInfo,
    columnName As String
) As SqlMapperIMemberMap
SqlMapperIMemberMap^ GetConstructorParameter(
    ConstructorInfo^ constructor,
    String^ columnName
)
abstract GetConstructorParameter :
        constructor : ConstructorInfo *
        columnName : string -> SqlMapperIMemberMap

Parameters

constructor
Type: System.ReflectionConstructorInfo
Constructor to resolve
columnName
Type: SystemString
DataReader column name

Return Value

Type: SqlMapperIMemberMap
Mapping implementation
See Also

Reference

SqlMapperITypeMap Interface
Dapper Namespace


SqlMapper.ITypeMap.GetMember Method

SqlMapperITypeMapGetMember Method
Gets member mapping for column

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SqlMapperIMemberMap GetMember(
    string columnName
)
Function GetMember (
    columnName As String
) As SqlMapperIMemberMap
SqlMapperIMemberMap^ GetMember(
    String^ columnName
)
abstract GetMember :
        columnName : string -> SqlMapperIMemberMap

Parameters

columnName
Type: SystemString
DataReader column name

Return Value

Type: SqlMapperIMemberMap
Mapping implementation
See Also

Reference

SqlMapperITypeMap Interface
Dapper Namespace


SqlMapper.TypeHandler(T) Class

SqlMapperTypeHandlerT Class
Base-class for simple type-handlers
Inheritance Hierarchy
SystemObject
DapperSqlMapperTypeHandlerT

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class TypeHandler<T> : SqlMapperITypeHandler

Public MustInherit Class TypeHandler(Of T)
    Implements SqlMapperITypeHandler
generic<typename T>
public ref class TypeHandler abstract : SqlMapperITypeHandler
[<AbstractClassAttribute>]
type TypeHandler<'T> =
    class
        interface SqlMapperITypeHandler
    end

Type Parameters

T

The SqlMapperTypeHandlerT type exposes the following members.

Constructors
 | Name | Description
Protected method | SqlMapperTypeHandlerT | Initializes a new instance of the SqlMapperTypeHandlerT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse a database value back to a typed value
Public method | SetValue | Assign the value of a parameter before a command executes
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


SqlMapper.TypeHandler(T) Constructor

SqlMapperTypeHandlerT Constructor
Initializes a new instance of the SqlMapperTypeHandlerT class

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected TypeHandler()
Protected Sub New
protected:
TypeHandler()
new : unit -> TypeHandler
See Also

Reference

SqlMapperTypeHandlerT Class
Dapper Namespace


TypeHandler(T) Methods

TypeHandlerT Methods

The SqlMapperTypeHandlerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse a database value back to a typed value
Public method | SetValue | Assign the value of a parameter before a command executes
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlMapperTypeHandlerT Class
Dapper Namespace


SqlMapper.TypeHandler(T).Parse Method

SqlMapperTypeHandlerTParse Method
Parse a database value back to a typed value

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract T Parse(
    Object value
)
Public MustOverride Function Parse (
    value As Object
) As T
public:
virtual T Parse(
    Object^ value
) abstract
abstract Parse :
        value : Object -> 'T

Parameters

value
Type: SystemObject
The value from the database

Return Value

Type: T
The typed value
See Also

Reference

SqlMapperTypeHandlerT Class
Dapper Namespace


SqlMapper.TypeHandler(T).SetValue Method

SqlMapperTypeHandlerTSetValue Method
Assign the value of a parameter before a command executes

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void SetValue(
    IDbDataParameter parameter,
    T value
)
Public MustOverride Sub SetValue (
    parameter As IDbDataParameter,
    value As T
)
public:
virtual void SetValue(
    IDbDataParameter^ parameter,
    T value
) abstract
abstract SetValue :
        parameter : IDbDataParameter *
        value : 'T -> unit

Parameters

parameter
Type: System.DataIDbDataParameter
The parameter to configure
value
Type: T
Parameter value
See Also

Reference

SqlMapperTypeHandlerT Class
Dapper Namespace


SqlMapper.TypeHandlerCache(T) Class

SqlMapperTypeHandlerCacheT Class

Note: This API is now obsolete.

Not intended for direct usage
Inheritance Hierarchy
SystemObject
DapperSqlMapperTypeHandlerCacheT

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Not intended for direct usage", false)]
public static class TypeHandlerCache<T>

<ObsoleteAttribute("Not intended for direct usage", false)>
Public NotInheritable Class TypeHandlerCache(Of T)
[ObsoleteAttribute(L"Not intended for direct usage", false)]
generic<typename T>
public ref class TypeHandlerCache abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("Not intended for direct usage", false)>]
type TypeHandlerCache<'T> =  class end

Type Parameters

T

The SqlMapperTypeHandlerCacheT type exposes the following members.

Methods
Name | Description
Parse | Obsolete. Not intended for direct usage
SetValue | Obsolete. Not intended for direct usage
Top
See Also

Reference

Dapper Namespace


TypeHandlerCache(T) Methods

TypeHandlerCacheT Methods

The SqlMapperTypeHandlerCacheT generic type exposes the following members.

Methods
Name | Description
Parse | Obsolete. Not intended for direct usage
SetValue | Obsolete. Not intended for direct usage
Top
See Also

Reference

SqlMapperTypeHandlerCacheT Class
Dapper Namespace


SqlMapper.TypeHandlerCache(T).Parse Method

SqlMapperTypeHandlerCacheTParse Method

Note: This API is now obsolete.

Not intended for direct usage

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Not intended for direct usage", true)]
public static T Parse(
    Object value
)
<ObsoleteAttribute("Not intended for direct usage", true)>
Public Shared Function Parse (
    value As Object
) As T
public:
[ObsoleteAttribute(L"Not intended for direct usage", true)]
static T Parse(
    Object^ value
)
[<ObsoleteAttribute("Not intended for direct usage", true)>]
static member Parse :
        value : Object -> 'T

Parameters

value
Type: SystemObject

Return Value

Type: T
See Also

Reference

SqlMapperTypeHandlerCacheT Class
Dapper Namespace


SqlMapper.TypeHandlerCache(T).SetValue Method

SqlMapperTypeHandlerCacheTSetValue Method

Note: This API is now obsolete.

Not intended for direct usage

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Not intended for direct usage", true)]
public static void SetValue(
    IDbDataParameter parameter,
    Object value
)
<ObsoleteAttribute("Not intended for direct usage", true)>
Public Shared Sub SetValue (
    parameter As IDbDataParameter,
    value As Object
)
public:
[ObsoleteAttribute(L"Not intended for direct usage", true)]
static void SetValue(
    IDbDataParameter^ parameter,
    Object^ value
)
[<ObsoleteAttribute("Not intended for direct usage", true)>]
static member SetValue :
        parameter : IDbDataParameter *
        value : Object -> unit

Parameters

parameter
Type: System.DataIDbDataParameter
value
Type: SystemObject
See Also

Reference

SqlMapperTypeHandlerCacheT Class
Dapper Namespace


SqlMapper.UdtTypeHandler Class

SqlMapperUdtTypeHandler Class
A type handler for data-types that are supported by the underlying provider, but which need a well-known UdtTypeName to be specified
Inheritance Hierarchy
SystemObject
DapperSqlMapperUdtTypeHandler

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UdtTypeHandler : SqlMapperITypeHandler
Public Class UdtTypeHandler
    Implements SqlMapperITypeHandler
public ref class UdtTypeHandler : SqlMapperITypeHandler
type UdtTypeHandler =
    class
        interface SqlMapperITypeHandler
    end

The SqlMapperUdtTypeHandler type exposes the following members.

Constructors
 | Name | Description
Public method | SqlMapperUdtTypeHandler | Creates a new instance of UdtTypeHandler with the specified UdtTypeName
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Dapper Namespace


SqlMapper.UdtTypeHandler Constructor

SqlMapperUdtTypeHandler Constructor
Creates a new instance of UdtTypeHandler with the specified UdtTypeName

Namespace: Dapper
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UdtTypeHandler(
    string udtTypeName
)
Public Sub New (
    udtTypeName As String
)
public:
UdtTypeHandler(
    String^ udtTypeName
)
new :
        udtTypeName : string -> UdtTypeHandler

Parameters

udtTypeName
Type: SystemString
See Also

Reference

SqlMapperUdtTypeHandler Class
Dapper Namespace


UdtTypeHandler Methods

UdtTypeHandler Methods

The SqlMapperUdtTypeHandler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlMapperUdtTypeHandler Class
Dapper Namespace


Gui.Wizard Namespace

Gui.Wizard Namespace

[Missing <summary> documentation for "N:Gui.Wizard"]

Classes
 | Class | Description
Public class | Header | Summary description for WizardHeader.
Public class | HeaderDesigner |
Public class | InfoContainer | Summary description for UserControl1.
Public class | InfoContainerDesigner |
Public class | InfoPage | An inherited InfoContainer that contains a Label with the description of the page.
Public class | InfoPageDesigner |
Public class | PageCollection | Summary description for PanelCollection.
Public class | PageEventArgs | Arguments passed to an application when Page is closed in a wizard. The Next page to be displayed can be changed, by the application, by setting the NextPage to a wizardPage which is part of the wizard that generated this event.
Public class | Wizard | A wizard is the control added to a form to provide a step by step functionality. It contains WizardPages in the Pages collection, which are containers for other controls. Only one wizard page is shown at a time in the client are of the wizard.
Public class | WizardDesigner | Summary description for WizardDesigner.
Public class | WizardPage |
Public class | WizardPageDesigner | Summary description for WizardPageDesigner.
Delegates
 | Delegate | Description
Public delegate | PageEventHandler | Delegate definition for handling NextPageEvents


Header Class

Header Class
Summary description for WizardHeader.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Gui.WizardHeader

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Header : UserControl
Public Class Header
    Inherits UserControl
public ref class Header : public UserControl
type Header =
    class
        inherit UserControl
    end

The Header type exposes the following members.

Constructors
 | Name | Description
Public method | Header | Constructor for Header
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Public property | Description | Gets/Sets the
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Image | Gets/Sets the Icon
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Title | Get/Set the title for the wizard page
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Gui.Wizard Namespace


Header Constructor

Header Constructor
Constructor for Header

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Header()
Public Sub New
public:
Header()
new : unit -> Header
See Also

Reference

Header Class
Gui.Wizard Namespace


Header Properties

Header Properties

The Header type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Public property | Description | Gets/Sets the
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Image | Gets/Sets the Icon
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Title | Get/Set the title for the wizard page
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Header Class
Gui.Wizard Namespace


Header.Description Property

HeaderDescription Property
Gets/Sets the

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

Header Class
Gui.Wizard Namespace


Header.Image Property

HeaderImage Property
Gets/Sets the Icon

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

Header Class
Gui.Wizard Namespace


Header.Title Property

HeaderTitle Property
Get/Set the title for the wizard page

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Header Class
Gui.Wizard Namespace


Header Methods

Header Methods

The Header type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

Header Class
Gui.Wizard Namespace


Header.Dispose Method

HeaderDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Top
See Also

Reference

Header Class
Gui.Wizard Namespace


Header.Dispose Method (Boolean)

HeaderDispose Method (Boolean)
Clean up any resources being used.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Header Class
Dispose Overload
Gui.Wizard Namespace


Header Events

Header Events

The Header type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Header Class
Gui.Wizard Namespace


HeaderDesigner Class

HeaderDesigner Class

[Missing <summary> documentation for "T:Gui.Wizard.HeaderDesigner"]

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Gui.WizardHeaderDesigner

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HeaderDesigner : ParentControlDesigner
Public Class HeaderDesigner
    Inherits ParentControlDesigner
public ref class HeaderDesigner : public ParentControlDesigner
type HeaderDesigner =
    class
        inherit ParentControlDesigner
    end

The HeaderDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderDesigner | Initializes a new instance of the HeaderDesigner class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Prevents the grid from being drawn on the Wizard (Overrides ParentControlDesignerDrawGrid.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Drops the BackgroundImage property (Overrides ParentControlDesignerPreFilterProperties(IDictionary).)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

Gui.Wizard Namespace


HeaderDesigner Constructor

HeaderDesigner Constructor
Initializes a new instance of the HeaderDesigner class

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HeaderDesigner()
Public Sub New
public:
HeaderDesigner()
new : unit -> HeaderDesigner
See Also

Reference

HeaderDesigner Class
Gui.Wizard Namespace


HeaderDesigner Properties

HeaderDesigner Properties

The HeaderDesigner type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Prevents the grid from being drawn on the Wizard (Overrides ParentControlDesignerDrawGrid.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
See Also

Reference

HeaderDesigner Class
Gui.Wizard Namespace


HeaderDesigner.DrawGrid Property

HeaderDesignerDrawGrid Property
Prevents the grid from being drawn on the Wizard

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override bool DrawGrid { get; }
Protected Overrides ReadOnly Property DrawGrid As Boolean
    Get
protected:
virtual property bool DrawGrid {
    bool get () override;
}
abstract DrawGrid : bool with get
override DrawGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

HeaderDesigner Class
Gui.Wizard Namespace


HeaderDesigner Methods

HeaderDesigner Methods

The HeaderDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Drops the BackgroundImage property (Overrides ParentControlDesignerPreFilterProperties(IDictionary).)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
See Also

Reference

HeaderDesigner Class
Gui.Wizard Namespace


HeaderDesigner.PreFilterProperties Method

HeaderDesignerPreFilterProperties Method
Drops the BackgroundImage property

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void PreFilterProperties(
    IDictionary properties
)
Protected Overrides Sub PreFilterProperties (
    properties As IDictionary
)
protected:
virtual void PreFilterProperties(
    IDictionary^ properties
) override
abstract PreFilterProperties :
        properties : IDictionary -> unit
override PreFilterProperties :
        properties : IDictionary -> unit

Parameters

properties
Type: System.CollectionsIDictionary
properties to remove BackGroundImage from
See Also

Reference

HeaderDesigner Class
Gui.Wizard Namespace


HeaderDesigner Fields

HeaderDesigner Fields

The HeaderDesigner type exposes the following members.

Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

HeaderDesigner Class
Gui.Wizard Namespace


InfoContainer Class

InfoContainer Class
Summary description for UserControl1.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Gui.WizardInfoContainer
Gui.WizardInfoPage

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InfoContainer : UserControl
Public Class InfoContainer
    Inherits UserControl
public ref class InfoContainer : public UserControl
type InfoContainer =
    class
        inherit UserControl
    end

The InfoContainer type exposes the following members.

Constructors
 | Name | Description
Public method | InfoContainer | Initializes a new instance of the InfoContainer class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Image | Gets/Sets the Icon
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageTitle | Get/Set the title for the info page
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Gui.Wizard Namespace


InfoContainer Constructor

InfoContainer Constructor
Initializes a new instance of the InfoContainer class

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InfoContainer()
Public Sub New
public:
InfoContainer()
new : unit -> InfoContainer
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainer Properties

InfoContainer Properties

The InfoContainer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Image | Gets/Sets the Icon
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageTitle | Get/Set the title for the info page
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainer.Image Property

InfoContainerImage Property
Gets/Sets the Icon

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainer.PageTitle Property

InfoContainerPageTitle Property
Get/Set the title for the info page

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PageTitle { get; set; }
Public Property PageTitle As String
    Get
    Set
public:
property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}
member PageTitle : string with get, set

Property Value

Type: String
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainer Methods

InfoContainer Methods

The InfoContainer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainer.Dispose Method

InfoContainerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Top
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainer.Dispose Method (Boolean)

InfoContainerDispose Method (Boolean)
Clean up any resources being used.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

InfoContainer Class
Dispose Overload
Gui.Wizard Namespace


InfoContainer Events

InfoContainer Events

The InfoContainer type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

InfoContainer Class
Gui.Wizard Namespace


InfoContainerDesigner Class

InfoContainerDesigner Class

[Missing <summary> documentation for "T:Gui.Wizard.InfoContainerDesigner"]

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Gui.WizardInfoContainerDesigner

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InfoContainerDesigner : ParentControlDesigner
Public Class InfoContainerDesigner
    Inherits ParentControlDesigner
public ref class InfoContainerDesigner : public ParentControlDesigner
type InfoContainerDesigner =
    class
        inherit ParentControlDesigner
    end

The InfoContainerDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | InfoContainerDesigner | Initializes a new instance of the InfoContainerDesigner class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Gets or sets a value indicating whether a grid should be drawn on the control for this designer. (Inherited from ParentControlDesigner.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Drops the BackgroundImage property (Overrides ParentControlDesignerPreFilterProperties(IDictionary).)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

Gui.Wizard Namespace


InfoContainerDesigner Constructor

InfoContainerDesigner Constructor
Initializes a new instance of the InfoContainerDesigner class

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InfoContainerDesigner()
Public Sub New
public:
InfoContainerDesigner()
new : unit -> InfoContainerDesigner
See Also

Reference

InfoContainerDesigner Class
Gui.Wizard Namespace


InfoContainerDesigner Properties

InfoContainerDesigner Properties

The InfoContainerDesigner type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Gets or sets a value indicating whether a grid should be drawn on the control for this designer. (Inherited from ParentControlDesigner.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
See Also

Reference

InfoContainerDesigner Class
Gui.Wizard Namespace


InfoContainerDesigner Methods

InfoContainerDesigner Methods

The InfoContainerDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Drops the BackgroundImage property (Overrides ParentControlDesignerPreFilterProperties(IDictionary).)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
See Also

Reference

InfoContainerDesigner Class
Gui.Wizard Namespace


InfoContainerDesigner.PreFilterProperties Method

InfoContainerDesignerPreFilterProperties Method
Drops the BackgroundImage property

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void PreFilterProperties(
    IDictionary properties
)
Protected Overrides Sub PreFilterProperties (
    properties As IDictionary
)
protected:
virtual void PreFilterProperties(
    IDictionary^ properties
) override
abstract PreFilterProperties :
        properties : IDictionary -> unit
override PreFilterProperties :
        properties : IDictionary -> unit

Parameters

properties
Type: System.CollectionsIDictionary
properties to remove BackGroundImage from
See Also

Reference

InfoContainerDesigner Class
Gui.Wizard Namespace


InfoContainerDesigner Fields

InfoContainerDesigner Fields

The InfoContainerDesigner type exposes the following members.

Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

InfoContainerDesigner Class
Gui.Wizard Namespace


InfoPage Class

InfoPage Class
An inherited InfoContainer that contains a Label with the description of the page.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Gui.WizardInfoContainer
Gui.WizardInfoPage

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InfoPage : InfoContainer
Public Class InfoPage
    Inherits InfoContainer
public ref class InfoPage : public InfoContainer
type InfoPage =
    class
        inherit InfoContainer
    end

The InfoPage type exposes the following members.

Constructors
 | Name | Description
Public method | InfoPage | Default Constructor
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Image | Gets/Sets the Icon (Inherited from InfoContainer.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageText | Gets/Sets the text on the info page
Public property | PageTitle | Get/Set the title for the info page (Inherited from InfoContainer.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides InfoContainerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Gui.Wizard Namespace


InfoPage Constructor

InfoPage Constructor
Default Constructor

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InfoPage()
Public Sub New
public:
InfoPage()
new : unit -> InfoPage
See Also

Reference

InfoPage Class
Gui.Wizard Namespace


InfoPage Properties

InfoPage Properties

The InfoPage type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Image | Gets/Sets the Icon (Inherited from InfoContainer.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageText | Gets/Sets the text on the info page
Public property | PageTitle | Get/Set the title for the info page (Inherited from InfoContainer.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

InfoPage Class
Gui.Wizard Namespace


InfoPage.PageText Property

InfoPagePageText Property
Gets/Sets the text on the info page

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PageText { get; set; }
Public Property PageText As String
    Get
    Set
public:
property String^ PageText {
    String^ get ();
    void set (String^ value);
}
member PageText : string with get, set

Property Value

Type: String
See Also

Reference

InfoPage Class
Gui.Wizard Namespace


InfoPage Methods

InfoPage Methods

The InfoPage type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides InfoContainerDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

InfoPage Class
Gui.Wizard Namespace


InfoPage.Dispose Method

InfoPageDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides InfoContainerDispose(Boolean).)
Top
See Also

Reference

InfoPage Class
Gui.Wizard Namespace


InfoPage.Dispose Method (Boolean)

InfoPageDispose Method (Boolean)
Clean up any resources being used.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

InfoPage Class
Dispose Overload
Gui.Wizard Namespace


InfoPage Events

InfoPage Events

The InfoPage type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

InfoPage Class
Gui.Wizard Namespace


InfoPageDesigner Class

InfoPageDesigner Class

[Missing <summary> documentation for "T:Gui.Wizard.InfoPageDesigner"]

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Gui.WizardInfoPageDesigner

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InfoPageDesigner : ParentControlDesigner
Public Class InfoPageDesigner
    Inherits ParentControlDesigner
public ref class InfoPageDesigner : public ParentControlDesigner
type InfoPageDesigner =
    class
        inherit ParentControlDesigner
    end

The InfoPageDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | InfoPageDesigner | Initializes a new instance of the InfoPageDesigner class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Prevents the grid from being drawn on the Wizard (Overrides ParentControlDesignerDrawGrid.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Drops the BackgroundImage property (Overrides ParentControlDesignerPreFilterProperties(IDictionary).)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

Gui.Wizard Namespace


InfoPageDesigner Constructor

InfoPageDesigner Constructor
Initializes a new instance of the InfoPageDesigner class

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InfoPageDesigner()
Public Sub New
public:
InfoPageDesigner()
new : unit -> InfoPageDesigner
See Also

Reference

InfoPageDesigner Class
Gui.Wizard Namespace


InfoPageDesigner Properties

InfoPageDesigner Properties

The InfoPageDesigner type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Prevents the grid from being drawn on the Wizard (Overrides ParentControlDesignerDrawGrid.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Inherited from ComponentDesigner.)
Top
See Also

Reference

InfoPageDesigner Class
Gui.Wizard Namespace


InfoPageDesigner.DrawGrid Property

InfoPageDesignerDrawGrid Property
Prevents the grid from being drawn on the Wizard

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override bool DrawGrid { get; }
Protected Overrides ReadOnly Property DrawGrid As Boolean
    Get
protected:
virtual property bool DrawGrid {
    bool get () override;
}
abstract DrawGrid : bool with get
override DrawGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

InfoPageDesigner Class
Gui.Wizard Namespace


InfoPageDesigner Methods

InfoPageDesigner Methods

The InfoPageDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Drops the BackgroundImage property (Overrides ParentControlDesignerPreFilterProperties(IDictionary).)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
See Also

Reference

InfoPageDesigner Class
Gui.Wizard Namespace


InfoPageDesigner.PreFilterProperties Method

InfoPageDesignerPreFilterProperties Method
Drops the BackgroundImage property

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void PreFilterProperties(
    IDictionary properties
)
Protected Overrides Sub PreFilterProperties (
    properties As IDictionary
)
protected:
virtual void PreFilterProperties(
    IDictionary^ properties
) override
abstract PreFilterProperties :
        properties : IDictionary -> unit
override PreFilterProperties :
        properties : IDictionary -> unit

Parameters

properties
Type: System.CollectionsIDictionary
properties to remove BackGroundImage from
See Also

Reference

InfoPageDesigner Class
Gui.Wizard Namespace


InfoPageDesigner Fields

InfoPageDesigner Fields

The InfoPageDesigner type exposes the following members.

Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

InfoPageDesigner Class
Gui.Wizard Namespace


PageCollection Class

PageCollection Class
Summary description for PanelCollection.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Gui.WizardPageCollection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageCollection : CollectionBase
Public Class PageCollection
    Inherits CollectionBase
public ref class PageCollection : public CollectionBase
type PageCollection =
    class
        inherit CollectionBase
    end

The PageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PageCollection | Constructor requires the wizard that owns this collection
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Finds the Page in the collection
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Parent | Returns the wizard that owns this collection
Top
Methods
 | Name | Description
Public method | Add | Adds a WizardPage into the Collection
Public method | AddRange | Adds an array of pages into the collection. Used by the Studio Designer generated coed
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Detects if a given Page is in the Collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Finds the position of the page in the colleciton
Public method | Insert | Adds a new page at a particular position in the Collection
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Propgate when a external designer modifies the pages (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Propogates when external designers remove items from page (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the given page from the collection
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Gui.Wizard Namespace


PageCollection Constructor

PageCollection Constructor
Constructor requires the wizard that owns this collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageCollection(
    Wizard parent
)
Public Sub New (
    parent As Wizard
)
public:
PageCollection(
    Wizard^ parent
)
new :
        parent : Wizard -> PageCollection

Parameters

parent
Type: Gui.WizardWizard
Wizard
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection Properties

PageCollection Properties

The PageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Protected property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Item | Finds the Page in the collection
Protected property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Public property | Parent | Returns the wizard that owns this collection
Top
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.Item Property

PageCollectionItem Property
Finds the Page in the collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WizardPage this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As WizardPage
    Get
    Set
public:
property WizardPage^ default[int index] {
    WizardPage^ get (int index);
    void set (int index, WizardPage^ value);
}
member Item : WizardPage with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: WizardPage
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.Parent Property

PageCollectionParent Property
Returns the wizard that owns this collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Wizard Parent { get; }
Public ReadOnly Property Parent As Wizard
    Get
public:
property Wizard^ Parent {
    Wizard^ get ();
}
member Parent : Wizard with get

Property Value

Type: Wizard
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection Methods

PageCollection Methods

The PageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a WizardPage into the Collection
Public method | AddRange | Adds an array of pages into the collection. Used by the Studio Designer generated coed
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Detects if a given Page is in the Collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Finds the position of the page in the colleciton
Public method | Insert | Adds a new page at a particular position in the Collection
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnInsertComplete | Propgate when a external designer modifies the pages (Overrides CollectionBaseOnInsertComplete(Int32, Object).)
Protected method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | Propogates when external designers remove items from page (Overrides CollectionBaseOnRemoveComplete(Int32, Object).)
Protected method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
Protected method | OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Public method | Remove | Removes the given page from the collection
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.Add Method

PageCollectionAdd Method
Adds a WizardPage into the Collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Add(
    WizardPage value
)
Public Function Add (
    value As WizardPage
) As Integer
public:
int Add(
    WizardPage^ value
)
member Add :
        value : WizardPage -> int

Parameters

value
Type: Gui.WizardWizardPage
The page to add

Return Value

Type: Int32
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.AddRange Method

PageCollectionAddRange Method
Adds an array of pages into the collection. Used by the Studio Designer generated coed

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddRange(
    WizardPage[] pages
)
Public Sub AddRange (
    pages As WizardPage()
)
public:
void AddRange(
    array<WizardPage^>^ pages
)
member AddRange :
        pages : WizardPage[] -> unit

Parameters

pages
Type: Gui.WizardWizardPage
Array of pages to add
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.Contains Method

PageCollectionContains Method
Detects if a given Page is in the Collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WizardPage value
)
Public Function Contains (
    value As WizardPage
) As Boolean
public:
bool Contains(
    WizardPage^ value
)
member Contains :
        value : WizardPage -> bool

Parameters

value
Type: Gui.WizardWizardPage
Page to find

Return Value

Type: Boolean
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.IndexOf Method

PageCollectionIndexOf Method
Finds the position of the page in the colleciton

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    WizardPage value
)
Public Function IndexOf (
    value As WizardPage
) As Integer
public:
int IndexOf(
    WizardPage^ value
)
member IndexOf :
        value : WizardPage -> int

Parameters

value
Type: Gui.WizardWizardPage
Page to find position of

Return Value

Type: Int32
Index of Page in collection
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.Insert Method

PageCollectionInsert Method
Adds a new page at a particular position in the Collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int index,
    WizardPage value
)
Public Sub Insert (
    index As Integer,
    value As WizardPage
)
public:
void Insert(
    int index,
    WizardPage^ value
)
member Insert :
        index : int *
        value : WizardPage -> unit

Parameters

index
Type: SystemInt32
Position
value
Type: Gui.WizardWizardPage
Page to be added
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.OnInsertComplete Method

PageCollectionOnInsertComplete Method
Propgate when a external designer modifies the pages

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnInsertComplete(
    int index,
    Object value
)
Protected Overrides Sub OnInsertComplete (
    index As Integer,
    value As Object
)
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override
abstract OnInsertComplete :
        index : int *
        value : Object -> unit
override OnInsertComplete :
        index : int *
        value : Object -> unit

Parameters

index
Type: SystemInt32
value
Type: SystemObject
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.OnRemoveComplete Method

PageCollectionOnRemoveComplete Method
Propogates when external designers remove items from page

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnRemoveComplete(
    int index,
    Object value
)
Protected Overrides Sub OnRemoveComplete (
    index As Integer,
    value As Object
)
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override
abstract OnRemoveComplete :
        index : int *
        value : Object -> unit
override OnRemoveComplete :
        index : int *
        value : Object -> unit

Parameters

index
Type: SystemInt32
value
Type: SystemObject
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageCollection.Remove Method

PageCollectionRemove Method
Removes the given page from the collection

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    WizardPage value
)
Public Sub Remove (
    value As WizardPage
)
public:
void Remove(
    WizardPage^ value
)
member Remove :
        value : WizardPage -> unit

Parameters

value
Type: Gui.WizardWizardPage
Page to remove
See Also

Reference

PageCollection Class
Gui.Wizard Namespace


PageEventArgs Class

PageEventArgs Class
Arguments passed to an application when Page is closed in a wizard. The Next page to be displayed can be changed, by the application, by setting the NextPage to a wizardPage which is part of the wizard that generated this event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Gui.WizardPageEventArgs

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageEventArgs : EventArgs
Public Class PageEventArgs
    Inherits EventArgs
public ref class PageEventArgs : public EventArgs
type PageEventArgs =
    class
        inherit EventArgs
    end

The PageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PageEventArgs | Constructs a new event
Top
Properties
 | Name | Description
Public property | Page | Gets/Sets the wizard page that will be displayed next. If you set this it must be to a wizardPage from the wizard.
Public property | PageIndex | Gets the index of the page
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Gui.Wizard Namespace


PageEventArgs Constructor

PageEventArgs Constructor
Constructs a new event

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageEventArgs(
    int index,
    PageCollection pages
)
Public Sub New (
    index As Integer,
    pages As PageCollection
)
public:
PageEventArgs(
    int index,
    PageCollection^ pages
)
new :
        index : int *
        pages : PageCollection -> PageEventArgs

Parameters

index
Type: SystemInt32
The index of the next page in the collection
pages
Type: Gui.WizardPageCollection
Pages in the wizard that are acceptable to be
See Also

Reference

PageEventArgs Class
Gui.Wizard Namespace


PageEventArgs Properties

PageEventArgs Properties

The PageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Page | Gets/Sets the wizard page that will be displayed next. If you set this it must be to a wizardPage from the wizard.
Public property | PageIndex | Gets the index of the page
Top
See Also

Reference

PageEventArgs Class
Gui.Wizard Namespace


PageEventArgs.Page Property

PageEventArgsPage Property
Gets/Sets the wizard page that will be displayed next. If you set this it must be to a wizardPage from the wizard.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WizardPage Page { get; set; }
Public Property Page As WizardPage
    Get
    Set
public:
property WizardPage^ Page {
    WizardPage^ get ();
    void set (WizardPage^ value);
}
member Page : WizardPage with get, set

Property Value

Type: WizardPage
See Also

Reference

PageEventArgs Class
Gui.Wizard Namespace


PageEventArgs.PageIndex Property

PageEventArgsPageIndex Property
Gets the index of the page

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get
public:
property int PageIndex {
    int get ();
}
member PageIndex : int with get

Property Value

Type: Int32
See Also

Reference

PageEventArgs Class
Gui.Wizard Namespace


PageEventArgs Methods

PageEventArgs Methods

The PageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageEventArgs Class
Gui.Wizard Namespace


PageEventHandler Delegate

PageEventHandler Delegate
Delegate definition for handling NextPageEvents

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void PageEventHandler(
    Object sender,
    PageEventArgs e
)
Public Delegate Sub PageEventHandler (
    sender As Object,
    e As PageEventArgs
)
public delegate void PageEventHandler(
    Object^ sender,
    PageEventArgs^ e
)
type PageEventHandler =
    delegate of
        sender : Object *
        e : PageEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Gui.WizardPageEventArgs
See Also

Reference

Gui.Wizard Namespace


Wizard Class

Wizard Class
A wizard is the control added to a form to provide a step by step functionality. It contains WizardPages in the Pages collection, which are containers for other controls. Only one wizard page is shown at a time in the client are of the wizard.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Gui.WizardWizard

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Wizard : UserControl
Public Class Wizard
    Inherits UserControl
public ref class Wizard : public UserControl
type Wizard =
    class
        inherit UserControl
    end

The Wizard type exposes the following members.

Constructors
 | Name | Description
Public method | Wizard | Wizard control with designer support
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackEnabled | Gets/Sets the enabled state of the back button.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelEnabled | Gets/Sets the enabled state of the cancel button.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NextEnabled | Gets/Sets the enabled state of the Next button.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Page | Alternative way of getting/Setiing the current page by using wizardPage objects
Public property | Pages | Returns the collection of Pages in the wizard
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | ActivatePage(Int32) | No documentation supplied.
Protected method | ActivatePage(WizardPage) | No documentation supplied.
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | Back | Closes the current page after a CloseFromBack, then moves to the previous page and calls ShowFromBack
Public method | BackTo | Moves to the page given and calls ShowFromBack
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Next | Closes the current page after a CloseFromNext, then moves to the Next page and calls ShowFromNext
Public method | NextTo | Moves to the page given and calls ShowFromNext
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | No documentation supplied. (Overrides UserControlOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CloseFromCancel | Called when the cancel button is pressed, before the form is closed. Set e.Cancel to true if you do not wish the cancel to close the wizard.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | btnBack | No documentation supplied.
Protected field | btnNext | No documentation supplied.
Protected field | pnlButtons | No documentation supplied.
Top
See Also

Reference

Gui.Wizard Namespace


Wizard Constructor

Wizard Constructor
Wizard control with designer support

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Wizard()
Public Sub New
public:
Wizard()
new : unit -> Wizard
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard Properties

Wizard Properties

The Wizard type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackEnabled | Gets/Sets the enabled state of the back button.
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelEnabled | Gets/Sets the enabled state of the cancel button.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NextEnabled | Gets/Sets the enabled state of the Next button.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Page | Alternative way of getting/Setiing the current page by using wizardPage objects
Public property | Pages | Returns the collection of Pages in the wizard
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.BackEnabled Property

WizardBackEnabled Property
Gets/Sets the enabled state of the back button.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BackEnabled { get; set; }
Public Property BackEnabled As Boolean
    Get
    Set
public:
property bool BackEnabled {
    bool get ();
    void set (bool value);
}
member BackEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.CancelEnabled Property

WizardCancelEnabled Property
Gets/Sets the enabled state of the cancel button.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CancelEnabled { get; set; }
Public Property CancelEnabled As Boolean
    Get
    Set
public:
property bool CancelEnabled {
    bool get ();
    void set (bool value);
}
member CancelEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.NextEnabled Property

WizardNextEnabled Property
Gets/Sets the enabled state of the Next button.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NextEnabled { get; set; }
Public Property NextEnabled As Boolean
    Get
    Set
public:
property bool NextEnabled {
    bool get ();
    void set (bool value);
}
member NextEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.Page Property

WizardPage Property
Alternative way of getting/Setiing the current page by using wizardPage objects

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WizardPage Page { get; }
Public ReadOnly Property Page As WizardPage
    Get
public:
property WizardPage^ Page {
    WizardPage^ get ();
}
member Page : WizardPage with get

Property Value

Type: WizardPage
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.Pages Property

WizardPages Property
Returns the collection of Pages in the wizard

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageCollection Pages { get; }
Public ReadOnly Property Pages As PageCollection
    Get
public:
property PageCollection^ Pages {
    PageCollection^ get ();
}
member Pages : PageCollection with get

Property Value

Type: PageCollection
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard Methods

Wizard Methods

The Wizard type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | ActivatePage(Int32) | No documentation supplied.
Protected method | ActivatePage(WizardPage) | No documentation supplied.
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | Back | Closes the current page after a CloseFromBack, then moves to the previous page and calls ShowFromBack
Public method | BackTo | Moves to the page given and calls ShowFromBack
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Next | Closes the current page after a CloseFromNext, then moves to the Next page and calls ShowFromNext
Public method | NextTo | Moves to the page given and calls ShowFromNext
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | No documentation supplied. (Overrides UserControlOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.ActivatePage Method

WizardActivatePage Method
Overload List
 | Name | Description
Protected method | ActivatePage(Int32) | No documentation supplied.
Protected method | ActivatePage(WizardPage) | No documentation supplied.
Top
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.ActivatePage Method (Int32)

WizardActivatePage Method (Int32)
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected internal void ActivatePage(
    int index
)
Protected Friend Sub ActivatePage (
    index As Integer
)
protected public:
void ActivatePage(
    int index
)
member ActivatePage :
        index : int -> unit

Parameters

index
Type: SystemInt32
See Also

Reference

Wizard Class
ActivatePage Overload
Gui.Wizard Namespace


Wizard.ActivatePage Method (WizardPage)

WizardActivatePage Method (WizardPage)
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected internal void ActivatePage(
    WizardPage page
)
Protected Friend Sub ActivatePage (
    page As WizardPage
)
protected public:
void ActivatePage(
    WizardPage^ page
)
member ActivatePage :
        page : WizardPage -> unit

Parameters

page
Type: Gui.WizardWizardPage
See Also

Reference

Wizard Class
ActivatePage Overload
Gui.Wizard Namespace


Wizard.Back Method

WizardBack Method
Closes the current page after a CloseFromBack, then moves to the previous page and calls ShowFromBack

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Back()
Public Sub Back
public:
void Back()
member Back : unit -> unit
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.BackTo Method

WizardBackTo Method
Moves to the page given and calls ShowFromBack

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BackTo(
    WizardPage page
)
Public Sub BackTo (
    page As WizardPage
)
public:
void BackTo(
    WizardPage^ page
)
member BackTo :
        page : WizardPage -> unit

Parameters

page
Type: Gui.WizardWizardPage
Remarks
Does NOT call CloseFromBack on the current page
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.Dispose Method

WizardDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControlDispose(Boolean).)
Top
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.Dispose Method (Boolean)

WizardDispose Method (Boolean)
Clean up any resources being used.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Wizard Class
Dispose Overload
Gui.Wizard Namespace


Wizard.Next Method

WizardNext Method
Closes the current page after a CloseFromNext, then moves to the Next page and calls ShowFromNext

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Next()
Public Sub Next
public:
void Next()
member Next : unit -> unit
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.NextTo Method

WizardNextTo Method
Moves to the page given and calls ShowFromNext

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void NextTo(
    WizardPage page
)
Public Sub NextTo (
    page As WizardPage
)
public:
void NextTo(
    WizardPage^ page
)
member NextTo :
        page : WizardPage -> unit

Parameters

page
Type: Gui.WizardWizardPage
Remarks
Does NOT call CloseFromNext on the current page
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.OnLoad Method

WizardOnLoad Method
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
protected:
virtual void OnLoad(
    EventArgs^ e
) override
abstract OnLoad :
        e : EventArgs -> unit
override OnLoad :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard Events

Wizard Events

The Wizard type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CloseFromCancel | Called when the cancel button is pressed, before the form is closed. Set e.Cancel to true if you do not wish the cancel to close the wizard.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.CloseFromCancel Event

WizardCloseFromCancel Event
Called when the cancel button is pressed, before the form is closed. Set e.Cancel to true if you do not wish the cancel to close the wizard.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event CancelEventHandler CloseFromCancel
Public Event CloseFromCancel As CancelEventHandler
public:
 event CancelEventHandler^ CloseFromCancel {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}
member CloseFromCancel : IEvent<CancelEventHandler,
    CancelEventArgs>

Value

Type: System.ComponentModelCancelEventHandler
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard Fields

Wizard Fields

The Wizard type exposes the following members.

Fields
 | Name | Description
Protected field | btnBack | No documentation supplied.
Protected field | btnNext | No documentation supplied.
Protected field | pnlButtons | No documentation supplied.
Top
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.btnBack Field

WizardbtnBack Field
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected internal Button btnBack
Protected Friend btnBack As Button
protected public:
Button^ btnBack
val mutable btnBack: Button

Field Value

Type: Button
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.btnNext Field

WizardbtnNext Field
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected internal Button btnNext
Protected Friend btnNext As Button
protected public:
Button^ btnNext
val mutable btnNext: Button

Field Value

Type: Button
See Also

Reference

Wizard Class
Gui.Wizard Namespace


Wizard.pnlButtons Field

WizardpnlButtons Field
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected internal Panel pnlButtons
Protected Friend pnlButtons As Panel
protected public:
Panel^ pnlButtons
val mutable pnlButtons: Panel

Field Value

Type: Panel
See Also

Reference

Wizard Class
Gui.Wizard Namespace


WizardDesigner Class

WizardDesigner Class
Summary description for WizardDesigner.
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Gui.WizardWizardDesigner

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WizardDesigner : ParentControlDesigner
Public Class WizardDesigner
    Inherits ParentControlDesigner
public ref class WizardDesigner : public ParentControlDesigner
type WizardDesigner =
    class
        inherit ParentControlDesigner
    end

The WizardDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | WizardDesigner | Initializes a new instance of the WizardDesigner class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Prevents the grid from being drawn on the Wizard (Overrides ParentControlDesignerDrawGrid.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | No documentation supplied. (Overrides ComponentDesignerVerbs.)
Top
Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(Control) | Simple way to ensure WizardPages only contained here (Overrides ParentControlDesignerCanParent(Control).)
Public method | CanParent(ControlDesigner) | No documentation supplied. (Overrides ParentControlDesignerCanParent(ControlDesigner).)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | No documentation supplied. (Overrides ControlDesignerGetHitTest(Point).)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | No documentation supplied. (Overrides ParentControlDesignerOnPaintAdornments(PaintEventArgs).)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Adjusts the set of properties the component will expose through a TypeDescriptor. (Inherited from ParentControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

Gui.Wizard Namespace


WizardDesigner Constructor

WizardDesigner Constructor
Initializes a new instance of the WizardDesigner class

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WizardDesigner()
Public Sub New
public:
WizardDesigner()
new : unit -> WizardDesigner
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner Properties

WizardDesigner Properties

The WizardDesigner type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Prevents the grid from being drawn on the Wizard (Overrides ParentControlDesignerDrawGrid.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | No documentation supplied. (Overrides ComponentDesignerVerbs.)
Top
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner.DrawGrid Property

WizardDesignerDrawGrid Property
Prevents the grid from being drawn on the Wizard

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override bool DrawGrid { get; }
Protected Overrides ReadOnly Property DrawGrid As Boolean
    Get
protected:
virtual property bool DrawGrid {
    bool get () override;
}
abstract DrawGrid : bool with get
override DrawGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner.Verbs Property

WizardDesignerVerbs Property
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override DesignerVerbCollection Verbs { get; }
Public Overrides ReadOnly Property Verbs As DesignerVerbCollection
    Get
public:
virtual property DesignerVerbCollection^ Verbs {
    DesignerVerbCollection^ get () override;
}
abstract Verbs : DesignerVerbCollection with get
override Verbs : DesignerVerbCollection with get

Property Value

Type: DesignerVerbCollection

Implements

IDesignerVerbs
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner Methods

WizardDesigner Methods

The WizardDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(Control) | Simple way to ensure WizardPages only contained here (Overrides ParentControlDesignerCanParent(Control).)
Public method | CanParent(ControlDesigner) | No documentation supplied. (Overrides ParentControlDesignerCanParent(ControlDesigner).)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | No documentation supplied. (Overrides ControlDesignerGetHitTest(Point).)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | No documentation supplied. (Overrides ParentControlDesignerOnPaintAdornments(PaintEventArgs).)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Adjusts the set of properties the component will expose through a TypeDescriptor. (Inherited from ParentControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner.CanParent Method

WizardDesignerCanParent Method
Overload List
 | Name | Description
Public method | CanParent(Control) | Simple way to ensure WizardPages only contained here (Overrides ParentControlDesignerCanParent(Control).)
Public method | CanParent(ControlDesigner) | No documentation supplied. (Overrides ParentControlDesignerCanParent(ControlDesigner).)
Top
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner.CanParent Method (Control)

WizardDesignerCanParent Method (Control)
Simple way to ensure WizardPages only contained here

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanParent(
    Control control
)
Public Overrides Function CanParent (
    control As Control
) As Boolean
public:
virtual bool CanParent(
    Control^ control
) override
abstract CanParent :
        control : Control -> bool
override CanParent :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl

Return Value

Type: Boolean
See Also

Reference

WizardDesigner Class
CanParent Overload
Gui.Wizard Namespace


WizardDesigner.CanParent Method (ControlDesigner)

WizardDesignerCanParent Method (ControlDesigner)
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanParent(
    ControlDesigner controlDesigner
)
Public Overrides Function CanParent (
    controlDesigner As ControlDesigner
) As Boolean
public:
virtual bool CanParent(
    ControlDesigner^ controlDesigner
) override
abstract CanParent :
        controlDesigner : ControlDesigner -> bool
override CanParent :
        controlDesigner : ControlDesigner -> bool

Parameters

controlDesigner
Type: System.Windows.Forms.DesignControlDesigner

Return Value

Type: Boolean
See Also

Reference

WizardDesigner Class
CanParent Overload
Gui.Wizard Namespace


WizardDesigner.GetHitTest Method

WizardDesignerGetHitTest Method
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override bool GetHitTest(
    Point point
)
Protected Overrides Function GetHitTest (
    point As Point
) As Boolean
protected:
virtual bool GetHitTest(
    Point point
) override
abstract GetHitTest :
        point : Point -> bool
override GetHitTest :
        point : Point -> bool

Parameters

point
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner.OnPaintAdornments Method

WizardDesignerOnPaintAdornments Method
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnPaintAdornments(
    PaintEventArgs pe
)
Protected Overrides Sub OnPaintAdornments (
    pe As PaintEventArgs
)
protected:
virtual void OnPaintAdornments(
    PaintEventArgs^ pe
) override
abstract OnPaintAdornments :
        pe : PaintEventArgs -> unit
override OnPaintAdornments :
        pe : PaintEventArgs -> unit

Parameters

pe
Type: System.Windows.FormsPaintEventArgs
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardDesigner Fields

WizardDesigner Fields

The WizardDesigner type exposes the following members.

Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

WizardDesigner Class
Gui.Wizard Namespace


WizardPage Class

WizardPage Class

[Missing <summary> documentation for "T:Gui.Wizard.WizardPage"]

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Gui.WizardWizardPage

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WizardPage : Panel
Public Class WizardPage
    Inherits Panel
public ref class WizardPage : public Panel
type WizardPage =
    class
        inherit Panel
    end

The WizardPage type exposes the following members.

Constructors
 | Name | Description
Public method | WizardPage | No documentation supplied.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | No documentation supplied. (Overrides ControlBackColor.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFinishPage | No documentation supplied.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | FocusFirstTabIndex | Set the focus to the contained control with a lowest tabIndex
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseFromBack | Fires the CloseFromBack Event
Public method | OnCloseFromNext | Fires the CloseFromNextEvent
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Public method | OnShowFromBack | Fires the showFromBack event
Public method | OnShowFromNext | Fires the showFromNext event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CloseFromBack | Event called before this page is closed when the back button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | CloseFromNext | Event called before this page is closed when the next button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | ShowFromBack | Event called after this page is shown when the back button is pressed.
Public event | ShowFromNext | Event called after this page is shown when the next button is pressed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Gui.Wizard Namespace


WizardPage Constructor

WizardPage Constructor
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WizardPage()
Public Sub New
public:
WizardPage()
new : unit -> WizardPage
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage Properties

WizardPage Properties

The WizardPage type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | No documentation supplied. (Overrides ControlBackColor.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Panel.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Panel.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFinishPage | No documentation supplied.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.BackColor Property

WizardPageBackColor Property
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.IsFinishPage Property

WizardPageIsFinishPage Property
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFinishPage { get; set; }
Public Property IsFinishPage As Boolean
    Get
    Set
public:
property bool IsFinishPage {
    bool get ();
    void set (bool value);
}
member IsFinishPage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage Methods

WizardPage Methods

The WizardPage type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from ScrollableControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | FocusFirstTabIndex | Set the focus to the contained control with a lowest tabIndex
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Public method | OnCloseFromBack | Fires the CloseFromBack Event
Public method | OnCloseFromNext | Fires the CloseFromNextEvent
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from ScrollableControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners. (Inherited from Panel.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Public method | OnShowFromBack | Fires the showFromBack event
Public method | OnShowFromNext | Fires the showFromNext event
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | (Inherited from ScrollableControl.)
Top
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.Dispose Method

WizardPageDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides ControlDispose(Boolean).)
Top
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.Dispose Method (Boolean)

WizardPageDispose Method (Boolean)
Clean up any resources being used.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

WizardPage Class
Dispose Overload
Gui.Wizard Namespace


WizardPage.FocusFirstTabIndex Method

WizardPageFocusFirstTabIndex Method
Set the focus to the contained control with a lowest tabIndex

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FocusFirstTabIndex()
Public Sub FocusFirstTabIndex
public:
void FocusFirstTabIndex()
member FocusFirstTabIndex : unit -> unit
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.OnCloseFromBack Method

WizardPageOnCloseFromBack Method
Fires the CloseFromBack Event

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OnCloseFromBack(
    Wizard wiz
)
Public Function OnCloseFromBack (
    wiz As Wizard
) As Integer
public:
int OnCloseFromBack(
    Wizard^ wiz
)
member OnCloseFromBack :
        wiz : Wizard -> int

Parameters

wiz
Type: Gui.WizardWizard
Wizard to pass into the sender argument

Return Value

Type: Int32
Index of Page that the event handlers would like to see next
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.OnCloseFromNext Method

WizardPageOnCloseFromNext Method
Fires the CloseFromNextEvent

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OnCloseFromNext(
    Wizard wiz
)
Public Function OnCloseFromNext (
    wiz As Wizard
) As Integer
public:
int OnCloseFromNext(
    Wizard^ wiz
)
member OnCloseFromNext :
        wiz : Wizard -> int

Parameters

wiz
Type: Gui.WizardWizard
Sender

Return Value

Type: Int32
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.OnShowFromBack Method

WizardPageOnShowFromBack Method
Fires the showFromBack event

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OnShowFromBack(
    Wizard wiz
)
Public Sub OnShowFromBack (
    wiz As Wizard
)
public:
void OnShowFromBack(
    Wizard^ wiz
)
member OnShowFromBack :
        wiz : Wizard -> unit

Parameters

wiz
Type: Gui.WizardWizard
sender
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.OnShowFromNext Method

WizardPageOnShowFromNext Method
Fires the showFromNext event

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OnShowFromNext(
    Wizard wiz
)
Public Sub OnShowFromNext (
    wiz As Wizard
)
public:
void OnShowFromNext(
    Wizard^ wiz
)
member OnShowFromNext :
        wiz : Wizard -> unit

Parameters

wiz
Type: Gui.WizardWizard
Sender
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage Events

WizardPage Events

The WizardPage type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CloseFromBack | Event called before this page is closed when the back button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | CloseFromNext | Event called before this page is closed when the next button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | ShowFromBack | Event called after this page is shown when the back button is pressed.
Public event | ShowFromNext | Event called after this page is shown when the next button is pressed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.CloseFromBack Event

WizardPageCloseFromBack Event
Event called before this page is closed when the back button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler CloseFromBack
Public Event CloseFromBack As PageEventHandler
public:
 event PageEventHandler^ CloseFromBack {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member CloseFromBack : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Gui.WizardPageEventHandler
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.CloseFromNext Event

WizardPageCloseFromNext Event
Event called before this page is closed when the next button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler CloseFromNext
Public Event CloseFromNext As PageEventHandler
public:
 event PageEventHandler^ CloseFromNext {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member CloseFromNext : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Gui.WizardPageEventHandler
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.ShowFromBack Event

WizardPageShowFromBack Event
Event called after this page is shown when the back button is pressed.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ShowFromBack
Public Event ShowFromBack As EventHandler
public:
 event EventHandler^ ShowFromBack {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ShowFromBack : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPage.ShowFromNext Event

WizardPageShowFromNext Event
Event called after this page is shown when the next button is pressed.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ShowFromNext
Public Event ShowFromNext As EventHandler
public:
 event EventHandler^ ShowFromNext {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ShowFromNext : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WizardPage Class
Gui.Wizard Namespace


WizardPageDesigner Class

WizardPageDesigner Class
Summary description for WizardPageDesigner.
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Gui.WizardWizardPageDesigner

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WizardPageDesigner : ParentControlDesigner
Public Class WizardPageDesigner
    Inherits ParentControlDesigner
public ref class WizardPageDesigner : public ParentControlDesigner
type WizardPageDesigner =
    class
        inherit ParentControlDesigner
    end

The WizardPageDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | WizardPageDesigner | Initializes a new instance of the WizardPageDesigner class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Gets or sets a value indicating whether a grid should be drawn on the control for this designer. (Inherited from ParentControlDesigner.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | No documentation supplied. (Overrides ComponentDesignerVerbs.)
Top
Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Adjusts the set of properties the component will expose through a TypeDescriptor. (Inherited from ParentControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

Gui.Wizard Namespace


WizardPageDesigner Constructor

WizardPageDesigner Constructor
Initializes a new instance of the WizardPageDesigner class

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WizardPageDesigner()
Public Sub New
public:
WizardPageDesigner()
new : unit -> WizardPageDesigner
See Also

Reference

WizardPageDesigner Class
Gui.Wizard Namespace


WizardPageDesigner Properties

WizardPageDesigner Properties

The WizardPageDesigner type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ControlDesigner.)
Public property | ActionLists | Gets the design-time action lists supported by the component associated with the designer. (Inherited from ComponentDesigner.)
Protected property | AllowControlLasso | Gets a value indicating whether selected controls will be re-parented. (Inherited from ParentControlDesigner.)
Protected property | AllowGenericDragBox | Gets a value indicating whether a generic drag box should be drawn when dragging a toolbox item over the designer's surface. (Inherited from ParentControlDesigner.)
Protected property | AllowSetChildIndexOnDrop | Gets a value indicating whether the z-order of dragged controls should be maintained when dropped on a ParentControlDesigner. (Inherited from ParentControlDesigner.)
Public property | AssociatedComponents | Gets the collection of components associated with the component managed by the designer. (Inherited from ControlDesigner.)
Public property | AutoResizeHandles | Gets or sets a value indicating whether resize handle allocation depends on the value of the AutoSize property. (Inherited from ControlDesigner.)
Protected property | BehaviorService | Gets the BehaviorService from the design environment. (Inherited from ControlDesigner.)
Public property | Component | Gets the component this designer is designing. (Inherited from ComponentDesigner.)
Public property | Control | Gets the control that the designer is designing. (Inherited from ControlDesigner.)
Protected property | DefaultControlLocation | Gets the default location for a control added to the designer. (Inherited from ParentControlDesigner.)
Protected property | DrawGrid | Gets or sets a value indicating whether a grid should be drawn on the control for this designer. (Inherited from ParentControlDesigner.)
Protected property | EnableDragRect | Gets a value indicating whether drag rectangles are drawn by the designer. (Inherited from ParentControlDesigner.)
Protected property | GridSize | Gets or sets the size of each square of the grid that is drawn when the designer is in grid draw mode. (Inherited from ParentControlDesigner.)
Protected property | InheritanceAttribute | Gets the InheritanceAttribute of the designer. (Inherited from ControlDesigner.)
Protected property | Inherited | Gets a value indicating whether this component is inherited. (Inherited from ComponentDesigner.)
Protected property | MouseDragTool | Gets a value indicating whether the designer has a valid tool during a drag operation. (Inherited from ParentControlDesigner.)
Protected property | ParentComponent | Gets the parent component for the ControlDesigner. (Inherited from ControlDesigner.)
Public property | ParticipatesWithSnapLines | Gets a value indicating whether the ControlDesigner will allow snapline alignment during a drag operation. (Inherited from ControlDesigner.)
Public property | SelectionRules | Gets the selection rules that indicate the movement capabilities of a component. (Inherited from ControlDesigner.)
Protected property | ShadowProperties | Gets a collection of property values that override user settings. (Inherited from ComponentDesigner.)
Public property | SnapLines | Gets a list of SnapLine objects representing significant alignment points for this control. (Inherited from ParentControlDesigner.)
Public property | Verbs | No documentation supplied. (Overrides ComponentDesignerVerbs.)
Top
See Also

Reference

WizardPageDesigner Class
Gui.Wizard Namespace


WizardPageDesigner.Verbs Property

WizardPageDesignerVerbs Property
No documentation supplied.

Namespace: Gui.Wizard
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override DesignerVerbCollection Verbs { get; }
Public Overrides ReadOnly Property Verbs As DesignerVerbCollection
    Get
public:
virtual property DesignerVerbCollection^ Verbs {
    DesignerVerbCollection^ get () override;
}
abstract Verbs : DesignerVerbCollection with get
override Verbs : DesignerVerbCollection with get

Property Value

Type: DesignerVerbCollection

Implements

IDesignerVerbs
See Also

Reference

WizardPageDesigner Class
Gui.Wizard Namespace


WizardPageDesigner Methods

WizardPageDesigner Methods

The WizardPageDesigner type exposes the following members.

Methods
 | Name | Description
Protected method | AddPaddingSnapLines | Adds padding snaplines. (Inherited from ParentControlDesigner.)
Protected method | BaseWndProc | Processes Windows messages. (Inherited from ControlDesigner.)
Protected method | CanAddComponent | Called when a component is added to the parent container. (Inherited from ParentControlDesigner.)
Public method | CanBeParentedTo | Indicates if this designer's control can be parented by the control of the specified designer. (Inherited from ControlDesigner.)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Public method | CanParent(Control) | Indicates whether the specified control can be a child of the control managed by this designer. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem) | Creates a component or control from the specified tool and adds it to the current design document. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Point) | Creates a component or control from the specified tool and adds it to the current design document at the specified location. (Inherited from ParentControlDesigner.)
Protected method | CreateTool(ToolboxItem, Rectangle) | Creates a component or control from the specified tool and adds it to the current design document within the bounds of the specified rectangle. (Inherited from ParentControlDesigner.)
Protected method | CreateToolCore | Provides core functionality for all the CreateTool(ToolboxItem) methods. (Inherited from ParentControlDesigner.)
Protected method | DefWndProc | Provides default processing for Windows messages. (Inherited from ControlDesigner.)
Protected method | DisplayError | Displays information about the specified exception to the user. (Inherited from ControlDesigner.)
Public method | Dispose | Releases all resources used by the ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ParentControlDesigner, and optionally releases the managed resources. (Inherited from ParentControlDesigner.)
Public method | DoDefaultAction | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location. (Inherited from ComponentDesigner.)
Protected method | EnableDesignMode | Enables design time functionality for a child control. (Inherited from ControlDesigner.)
Protected method | EnableDragDrop | Enables or disables drag-and-drop support for the control being designed. (Inherited from ControlDesigner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Attempts to free resources by calling Dispose(false) before the object is reclaimed by garbage collection. (Inherited from ComponentDesigner.)
Protected method | GetControl | Gets the control from the designer of the specified component. (Inherited from ParentControlDesigner.)
Protected method | GetControlGlyph | Gets a body glyph that represents the bounds of the control. (Inherited from ParentControlDesigner.)
Public method | GetGlyphs | Gets a collection of Glyph objects representing the selection borders and grab handles for a standard control. (Inherited from ParentControlDesigner.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHitTest | Indicates whether a mouse click at the specified point should be handled by the control. (Inherited from ControlDesigner.)
Protected method | GetParentForComponent | Used by deriving classes to determine if it returns the control being designed or some other Container while adding a component to it. (Inherited from ParentControlDesigner.)
Protected method | GetService | Attempts to retrieve the specified type of service from the design mode site of the designer's component. (Inherited from ComponentDesigner.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUpdatedRect | Updates the position of the specified rectangle, adjusting it for grid alignment if grid alignment mode is enabled. (Inherited from ParentControlDesigner.)
Protected method | HookChildControls | Routes messages from the child controls of the specified control to the designer. (Inherited from ControlDesigner.)
Public method | Initialize | Initializes the designer with the specified component. (Inherited from ParentControlDesigner.)
Public method | InitializeExistingComponent | Re-initializes an existing component. (Inherited from ControlDesigner.)
Public method | InitializeNewComponent | (Inherited from ParentControlDesigner.)
Public method | InitializeNonDefault | Obsolete. Initializes the settings for an imported component that is already initialized to settings other than the defaults. (Inherited from ComponentDesigner.)
Public method | InternalControlDesigner | Returns the internal control designer with the specified index in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | InvokeGetInheritanceAttribute | Gets the InheritanceAttribute of the specified ComponentDesigner. (Inherited from ComponentDesigner.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberOfInternalControlDesigners | Returns the number of internal control designers in the ControlDesigner. (Inherited from ControlDesigner.)
Protected method | OnContextMenu | Shows the context menu and provides an opportunity to perform additional processing when the context menu is about to be displayed. (Inherited from ControlDesigner.)
Protected method | OnCreateHandle | Provides an opportunity to perform additional processing immediately after the control handle has been created. (Inherited from ControlDesigner.)
Protected method | OnDragComplete | Called in order to clean up a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnDragDrop | Called when a drag-and-drop object is dropped onto the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragEnter | Called when a drag-and-drop operation enters the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragLeave | Called when a drag-and-drop operation leaves the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnDragOver | Called when a drag-and-drop object is dragged over the control designer view. (Inherited from ParentControlDesigner.)
Protected method | OnGiveFeedback | Receives a call when a drag-and-drop operation is in progress to provide visual cues based on the location of the mouse while a drag operation is in progress. (Inherited from ControlDesigner.)
Protected method | OnMouseDragBegin | Called in response to the left mouse button being pressed and held while over the component. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragEnd | Called at the end of a drag-and-drop operation to complete or cancel the operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseDragMove | Called for each movement of the mouse during a drag-and-drop operation. (Inherited from ParentControlDesigner.)
Protected method | OnMouseEnter | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnMouseHover | Receives a call after the mouse hovers over the control. (Inherited from ControlDesigner.)
Protected method | OnMouseLeave | Receives a call when the mouse first enters the control. (Inherited from ControlDesigner.)
Protected method | OnPaintAdornments | Called when the control that the designer is managing has painted its surface so the designer can paint any additional adornments on top of the control. (Inherited from ParentControlDesigner.)
Public method | OnSetComponentDefaults | Obsolete. Called when the designer is intialized. (Inherited from ControlDesigner.)
Protected method | OnSetCursor | Provides an opportunity to change the current mouse cursor. (Inherited from ParentControlDesigner.)
Protected method | PostFilterAttributes | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterEvents | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PostFilterProperties | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterAttributes | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterEvents | Allows a designer to add to the set of events that it exposes through a TypeDescriptor. (Inherited from ComponentDesigner.)
Protected method | PreFilterProperties | Adjusts the set of properties the component will expose through a TypeDescriptor. (Inherited from ParentControlDesigner.)
Protected method | RaiseComponentChanged | Notifies the IComponentChangeService that this component has been changed. (Inherited from ComponentDesigner.)
Protected method | RaiseComponentChanging | Notifies the IComponentChangeService that this component is about to be changed. (Inherited from ComponentDesigner.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookChildControls | Routes messages for the children of the specified control to each control rather than to a parent designer. (Inherited from ControlDesigner.)
Protected method | WndProc | Processes Windows messages and optionally routes them to the control. (Inherited from ControlDesigner.)
Top
See Also

Reference

WizardPageDesigner Class
Gui.Wizard Namespace


WizardPageDesigner Fields

WizardPageDesigner Fields

The WizardPageDesigner type exposes the following members.

Fields
 | Name | Description
Protected field | accessibilityObj | Specifies the accessibility object for the designer. (Inherited from ControlDesigner.)
Top
See Also

Reference

WizardPageDesigner Class
Gui.Wizard Namespace


InterfaceFactory Namespace

InterfaceFactory Namespace
The namespace for the class factory.
Classes
 | Class | Description
Public class | ClassFactoryException | The exception raised by class factories.
Public class | Factory | A static class that exposes an instance of an IClassFactory that the application can use to register implementations of interfaces and instantiate those implementations later on.
Interfaces
 | Interface | Description
Public interface | IClassFactory | An interface for objects that implement class factory functionality.
Remarks

Virtual Radar Server has been written on the principle that the classes that make up the source are loosely coupled - instead of having direct references to each other they have references to interfaces and they do not know anything about the classes that implement those interfaces.

This library contains a singleton class factory that the executable and all of the libraries have access to. The class factory can be told which classes implement which interfaces, and it can also create instances of those classes for the application to use.

The singleton class factory is held by the public static class Factory. The property Singleton exposes the singleton IClassFactory class factory.

Virtual Radar Server originally used Microsoft's Unity library to register implementations of interfaces. Unity was replaced with this library after there was an issue with a particular object. This issue no longer exists so one day the implementation of IClassFactory may be changed to use Unity again. This should not affect any code that is currently using the class factory.

Examples

This declares an interface and a class that implements it. It shows how the implementation can be registered with the singleton class factory and how to request a new instance of the class that implements the interface.

Normally the interface would be in one library while the implementation (and the registration of the implementation) would be in another. The code that requests a new instance of the implementation could be anywhere within the application.

Copy
// The public interface that the application will use.
public interface IMyInterface
{
    void DoSomeWork();
}

// The private class that implements the interface. Nothing that uses this
// class will know anything about it other than it implements IMyInterface.
class PrivateClass : IMyInterface
{
    public void DoSomeWork() { MessageBox.Show("Doing some work"); }
}

// The call that will tell the singleton class factory that new instances
// of PrivateClass should be created when it is asked for instantiations of
// IMyInterface:
Factory.Singleton.Register<IMyInterface, PrivateClass>();

// The call that can be made anywhere within the application to get an
// implementation of IMyInterface. In this case the singleton class factory
// will create a new instance of PrivateClass and return it:
IMyInterface instance = Factory.Singleton.Resolve<IMyInterface>();
instance.DoSomeWork();


ClassFactoryException Class

ClassFactoryException Class
The exception raised by class factories.
Inheritance Hierarchy
SystemObject
SystemException
InterfaceFactoryClassFactoryException

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ClassFactoryException : Exception
<SerializableAttribute>
Public Class ClassFactoryException
    Inherits Exception
[SerializableAttribute]
public ref class ClassFactoryException : public Exception
[<SerializableAttribute>]
type ClassFactoryException =
    class
        inherit Exception
    end

The ClassFactoryException type exposes the following members.

Constructors
 | Name | Description
Public method | ClassFactoryException | Creates a new object.
Public method | ClassFactoryException(String) | Creates a new object.
Protected method | ClassFactoryException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | ClassFactoryException(String, Exception) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InterfaceFactory Namespace


ClassFactoryException Constructor

ClassFactoryException Constructor
Overload List
 | Name | Description
Public method | ClassFactoryException | Creates a new object.
Public method | ClassFactoryException(String) | Creates a new object.
Protected method | ClassFactoryException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | ClassFactoryException(String, Exception) | Creates a new object.
Top
See Also

Reference

ClassFactoryException Class
InterfaceFactory Namespace


ClassFactoryException Constructor

ClassFactoryException Constructor
Creates a new object.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClassFactoryException()
Public Sub New
public:
ClassFactoryException()
new : unit -> ClassFactoryException
See Also

Reference

ClassFactoryException Class
ClassFactoryException Overload
InterfaceFactory Namespace


ClassFactoryException Constructor (String)

ClassFactoryException Constructor (String)
Creates a new object.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClassFactoryException(
    string message
)
Public Sub New (
    message As String
)
public:
ClassFactoryException(
    String^ message
)
new :
        message : string -> ClassFactoryException

Parameters

message
Type: SystemString
See Also

Reference

ClassFactoryException Class
ClassFactoryException Overload
InterfaceFactory Namespace


ClassFactoryException Constructor (SerializationInfo, StreamingContext)

ClassFactoryException Constructor (SerializationInfo, StreamingContext)
Creates a new object.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ClassFactoryException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ClassFactoryException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ClassFactoryException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ClassFactoryException Class
ClassFactoryException Overload
InterfaceFactory Namespace


ClassFactoryException Constructor (String, Exception)

ClassFactoryException Constructor (String, Exception)
Creates a new object.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClassFactoryException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ClassFactoryException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ClassFactoryException

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

ClassFactoryException Class
ClassFactoryException Overload
InterfaceFactory Namespace


ClassFactoryException Properties

ClassFactoryException Properties

The ClassFactoryException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ClassFactoryException Class
InterfaceFactory Namespace


ClassFactoryException Methods

ClassFactoryException Methods

The ClassFactoryException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ClassFactoryException Class
InterfaceFactory Namespace


ClassFactoryException Events

ClassFactoryException Events

The ClassFactoryException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ClassFactoryException Class
InterfaceFactory Namespace


Factory Class

Factory Class
A static class that exposes an instance of an IClassFactory that the application can use to register implementations of interfaces and instantiate those implementations later on.
Inheritance Hierarchy
SystemObject
InterfaceFactoryFactory

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Factory
Public NotInheritable Class Factory
public ref class Factory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Factory =  class end

The Factory type exposes the following members.

Properties
Name | Description
Singleton | Gets the singleton class factory.
Top
Methods
Name | Description
RestoreSnapshot | Assigns the factory passed across to Singleton.
TakeSnapshot | Returns a copy of the current Singleton. Subsequent type registrations made to Singleton will not affect the copy.
Top
See Also

Reference

InterfaceFactory Namespace


Factory Properties

Factory Properties

The Factory type exposes the following members.

Properties
Name | Description
Singleton | Gets the singleton class factory.
Top
See Also

Reference

Factory Class
InterfaceFactory Namespace


Factory.Singleton Property

FactorySingleton Property
Gets the singleton class factory.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IClassFactory Singleton { get; }
Public Shared ReadOnly Property Singleton As IClassFactory
    Get
public:
static property IClassFactory^ Singleton {
    IClassFactory^ get ();
}
static member Singleton : IClassFactory with get

Property Value

Type: IClassFactory
See Also

Reference

Factory Class
InterfaceFactory Namespace


Factory Methods

Factory Methods

The Factory type exposes the following members.

Methods
Name | Description
RestoreSnapshot | Assigns the factory passed across to Singleton.
TakeSnapshot | Returns a copy of the current Singleton. Subsequent type registrations made to Singleton will not affect the copy.
Top
See Also

Reference

Factory Class
InterfaceFactory Namespace


Factory.RestoreSnapshot Method

FactoryRestoreSnapshot Method
Assigns the factory passed across to Singleton.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RestoreSnapshot(
    IClassFactory previousFactory
)
Public Shared Sub RestoreSnapshot (
    previousFactory As IClassFactory
)
public:
static void RestoreSnapshot(
    IClassFactory^ previousFactory
)
static member RestoreSnapshot :
        previousFactory : IClassFactory -> unit

Parameters

previousFactory
Type: InterfaceFactoryIClassFactory
The snapshot that was taken with TakeSnapshot.
See Also

Reference

Factory Class
InterfaceFactory Namespace


Factory.TakeSnapshot Method

FactoryTakeSnapshot Method
Returns a copy of the current Singleton. Subsequent type registrations made to Singleton will not affect the copy.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IClassFactory TakeSnapshot()
Public Shared Function TakeSnapshot As IClassFactory
public:
static IClassFactory^ TakeSnapshot()
static member TakeSnapshot : unit -> IClassFactory

Return Value

Type: IClassFactory
A copy of the current Singleton.
See Also

Reference

Factory Class
InterfaceFactory Namespace


IClassFactory Interface

IClassFactory Interface
An interface for objects that implement class factory functionality.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IClassFactory
Public Interface IClassFactory
public interface class IClassFactory
type IClassFactory =  interface end

The IClassFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateChildFactory | Returns a copy of the factory.
Public method | Register(Type, Type) | Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.
Public method | RegisterT(FuncT) | Registers a method to call to create new instances of T.
Public method | RegisterTI, TM | Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.
Public method | RegisterInstance(Type, Object) | Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.
Public method | RegisterInstanceTI(TI) | Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.
Public method | Resolve(Type) | Returns an object that implements the interface passed across.
Public method | ResolveT | Returns an object that implements the interface passed across.
Top
See Also

Reference

InterfaceFactory Namespace


IClassFactory Methods

IClassFactory Methods

The IClassFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateChildFactory | Returns a copy of the factory.
Public method | Register(Type, Type) | Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.
Public method | RegisterT(FuncT) | Registers a method to call to create new instances of T.
Public method | RegisterTI, TM | Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.
Public method | RegisterInstance(Type, Object) | Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.
Public method | RegisterInstanceTI(TI) | Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.
Public method | Resolve(Type) | Returns an object that implements the interface passed across.
Public method | ResolveT | Returns an object that implements the interface passed across.
Top
See Also

Reference

IClassFactory Interface
InterfaceFactory Namespace


IClassFactory.CreateChildFactory Method

IClassFactoryCreateChildFactory Method
Returns a copy of the factory.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IClassFactory CreateChildFactory()
Function CreateChildFactory As IClassFactory
IClassFactory^ CreateChildFactory()
abstract CreateChildFactory : unit -> IClassFactory

Return Value

Type: IClassFactory
A copy of the factory with all of the current interface registrations. Changes to the registrations on the copy will not affect the original, and vice versa.
See Also

Reference

IClassFactory Interface
InterfaceFactory Namespace


IClassFactory.Register Method

IClassFactoryRegister Method
Overload List
 | Name | Description
Public method | RegisterTI, TM | Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.
Public method | RegisterT(FuncT) | Registers a method to call to create new instances of T.
Public method | Register(Type, Type) | Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.
Top
See Also

Reference

IClassFactory Interface
InterfaceFactory Namespace


IClassFactory.Register(TI, TM) Method

IClassFactoryRegisterTI, TM Method
Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Register<TI, TM>()

Sub Register(Of TI, TM)
generic<typename TI, typename TM>
void Register()
abstract Register : unit -> unit

Type Parameters

TI
The interface type.
TM
The concrete type that implements TI.
See Also

Reference

IClassFactory Interface
Register Overload
InterfaceFactory Namespace


IClassFactory.Register(T) Method (Func(T))

IClassFactoryRegisterT Method (FuncT)
Registers a method to call to create new instances of T.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Register<T>(
    Func<T> callBack
)

Sub Register(Of T) (
    callBack As Func(Of T)
)
generic<typename T>
void Register(
    Func<T>^ callBack
)
abstract Register :
        callBack : Func<'T> -> unit

Parameters

callBack
Type: SystemFunc T

Type Parameters

T
See Also

Reference

IClassFactory Interface
Register Overload
InterfaceFactory Namespace


IClassFactory.Register Method (Type, Type)

IClassFactoryRegister Method (Type, Type)
Registers an implementation of an interface. A new instance of the implementation will be created for each call to Resolve.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Register(
    Type interfaceType,
    Type implementationType
)
Sub Register (
    interfaceType As Type,
    implementationType As Type
)
void Register(
    Type^ interfaceType,
    Type^ implementationType
)
abstract Register :
        interfaceType : Type *
        implementationType : Type -> unit

Parameters

interfaceType
Type: SystemType
The interface type.
implementationType
Type: SystemType
The concrete type that implements interfaceType.
See Also

Reference

IClassFactory Interface
Register Overload
InterfaceFactory Namespace


IClassFactory.RegisterInstance Method

IClassFactoryRegisterInstance Method
Overload List
 | Name | Description
Public method | RegisterInstanceTI(TI) | Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.
Public method | RegisterInstance(Type, Object) | Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.
Top
See Also

Reference

IClassFactory Interface
InterfaceFactory Namespace


IClassFactory.RegisterInstance(TI) Method (TI)

IClassFactoryRegisterInstanceTI Method (TI)
Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterInstance<TI>(
    TI instance
)

Sub RegisterInstance(Of TI) (
    instance As TI
)
generic<typename TI>
void RegisterInstance(
    TI instance
)
abstract RegisterInstance :
        instance : 'TI -> unit

Parameters

instance
Type: TI
An object whose type implements TI.

Type Parameters

TI
The interface type.
See Also

Reference

IClassFactory Interface
RegisterInstance Overload
InterfaceFactory Namespace


IClassFactory.RegisterInstance Method (Type, Object)

IClassFactoryRegisterInstance Method (Type, Object)
Registers an implementation of an interface. The instance passed across will be returned on each call to Resolve.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterInstance(
    Type interfaceType,
    Object instance
)
Sub RegisterInstance (
    interfaceType As Type,
    instance As Object
)
void RegisterInstance(
    Type^ interfaceType,
    Object^ instance
)
abstract RegisterInstance :
        interfaceType : Type *
        instance : Object -> unit

Parameters

interfaceType
Type: SystemType
The interface type.
instance
Type: SystemObject
An object whose type implements interfaceType.
See Also

Reference

IClassFactory Interface
RegisterInstance Overload
InterfaceFactory Namespace


IClassFactory.Resolve Method

IClassFactoryResolve Method
Overload List
 | Name | Description
Public method | ResolveT | Returns an object that implements the interface passed across.
Public method | Resolve(Type) | Returns an object that implements the interface passed across.
Top
See Also

Reference

IClassFactory Interface
InterfaceFactory Namespace


IClassFactory.Resolve(T) Method

IClassFactoryResolveT Method
Returns an object that implements the interface passed across.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
T Resolve<T>()
where T : class

Function Resolve(Of T As Class) As T
generic<typename T>
where T : ref class
T Resolve()
abstract Resolve : unit -> 'T  when 'T : not struct

Type Parameters

T
The interface that the returned object will implement.

Return Value

Type: T
An object that implements T.
See Also

Reference

IClassFactory Interface
Resolve Overload
InterfaceFactory Namespace


IClassFactory.Resolve Method (Type)

IClassFactoryResolve Method (Type)
Returns an object that implements the interface passed across.

Namespace: InterfaceFactory
Assembly: InterfaceFactory (in InterfaceFactory.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Resolve(
    Type interfaceType
)
Function Resolve (
    interfaceType As Type
) As Object
Object^ Resolve(
    Type^ interfaceType
)
abstract Resolve :
        interfaceType : Type -> Object

Parameters

interfaceType
Type: SystemType
The interface that the returned object will implement.

Return Value

Type: Object
An object that implements interfaceType.
See Also

Reference

IClassFactory Interface
Resolve Overload
InterfaceFactory Namespace


RadioPanelApp Namespace

RadioPanelApp Namespace

[Missing <summary> documentation for "N:RadioPanelApp"]

Classes
 | Class | Description
Public class | RadioSelectionChangedEventArgs | An EventArgs class for radio button selection changed events.
Delegates
 | Delegate | Description
Public delegate | RadioSelectionChangedEventHandler | No documentation supplied.


RadioSelectionChangedEventArgs Class

RadioSelectionChangedEventArgs Class
An EventArgs class for radio button selection changed events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
RadioPanelAppRadioSelectionChangedEventArgs

Namespace: RadioPanelApp
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RadioSelectionChangedEventArgs : EventArgs
Public Class RadioSelectionChangedEventArgs
    Inherits EventArgs
public ref class RadioSelectionChangedEventArgs : public EventArgs
type RadioSelectionChangedEventArgs =
    class
        inherit EventArgs
    end

The RadioSelectionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RadioSelectionChangedEventArgs | No documentation supplied.
Top
Properties
 | Name | Description
Public property | RadioButtonClicked | No documentation supplied.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RadioPanelApp Namespace


RadioSelectionChangedEventArgs Constructor

RadioSelectionChangedEventArgs Constructor
No documentation supplied.

Namespace: RadioPanelApp
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RadioSelectionChangedEventArgs(
    RadioButton rb
)
Public Sub New (
    rb As RadioButton
)
public:
RadioSelectionChangedEventArgs(
    RadioButton^ rb
)
new :
        rb : RadioButton -> RadioSelectionChangedEventArgs

Parameters

rb
Type: System.Windows.FormsRadioButton
See Also

Reference

RadioSelectionChangedEventArgs Class
RadioPanelApp Namespace


RadioSelectionChangedEventArgs Properties

RadioSelectionChangedEventArgs Properties

The RadioSelectionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | RadioButtonClicked | No documentation supplied.
Top
See Also

Reference

RadioSelectionChangedEventArgs Class
RadioPanelApp Namespace


RadioSelectionChangedEventArgs.RadioButtonClicked Property

RadioSelectionChangedEventArgsRadioButtonClicked Property
No documentation supplied.

Namespace: RadioPanelApp
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RadioButton RadioButtonClicked { get; }
Public ReadOnly Property RadioButtonClicked As RadioButton
    Get
public:
property RadioButton^ RadioButtonClicked {
    RadioButton^ get ();
}
member RadioButtonClicked : RadioButton with get

Property Value

Type: RadioButton
See Also

Reference

RadioSelectionChangedEventArgs Class
RadioPanelApp Namespace


RadioSelectionChangedEventArgs Methods

RadioSelectionChangedEventArgs Methods

The RadioSelectionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RadioSelectionChangedEventArgs Class
RadioPanelApp Namespace


RadioSelectionChangedEventHandler Delegate

RadioSelectionChangedEventHandler Delegate
No documentation supplied.

Namespace: RadioPanelApp
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void RadioSelectionChangedEventHandler(
    Object sender,
    RadioSelectionChangedEventArgs e
)
Public Delegate Sub RadioSelectionChangedEventHandler (
    sender As Object,
    e As RadioSelectionChangedEventArgs
)
public delegate void RadioSelectionChangedEventHandler(
    Object^ sender,
    RadioSelectionChangedEventArgs^ e
)
type RadioSelectionChangedEventHandler =
    delegate of
        sender : Object *
        e : RadioSelectionChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: RadioPanelAppRadioSelectionChangedEventArgs
See Also

Reference

RadioPanelApp Namespace


Test.Framework Namespace

Test.Framework Namespace
The namespace for helper objects that can make the life of unit tests a little easier.
Classes
 | Class | Description
Public class | AircraftTestHelper | A set of static methods that help with tests that involve IAircraft.
Public class | ClockMock | A mock implementation of IClock.
 | EventRecorderT | An object that can be hooked to an event to determine that it has been raised and record the parameters passed to the event.
 | ExcelWorksheetData | A class to help when dealing with spreadsheet data-driven tests.
Public class | FeedHelper | A set of helper methods to set up a feed manager with a bunch of feeds that each have a listener.
Public class | RequestReceivedEventArgsHelper | A static class that helps with setting up RequestReceivedEventArgs objects for different conditions.
Public class | SpreadsheetFieldValue | Helps to look up the value associated with a field within a spreadsheet.
Public class | StatisticsHelper | A static class that can help when testing Statistics objects.
Public class | TestUtilities | A collection of static methods that cover common aspects of testing objects.
Remarks

This library does not contain any unit tests, it just contains helper objects and the test files.

Some of the helper objects (e.g. AircraftTestHelper and RequestReceivedEventArgsHelper) are only of interest to Virtual Radar Server tests whereas some of them (e.g. EventRecorderT, ExcelWorksheetData and TestUtilities) may be applicable to unit tests for other projects.


AircraftTestHelper Class

AircraftTestHelper Class
A set of static methods that help with tests that involve IAircraft.
Inheritance Hierarchy
SystemObject
Test.FrameworkAircraftTestHelper

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AircraftTestHelper
Public NotInheritable Class AircraftTestHelper
public ref class AircraftTestHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AircraftTestHelper =  class end

The AircraftTestHelper type exposes the following members.

Methods
Name | Description
GenerateAircraftPropertyValue | Returns a dummy value that can be copied into any of the properties on an IAircraft object.
Top
See Also

Reference

Test.Framework Namespace


AircraftTestHelper Methods

AircraftTestHelper Methods

The AircraftTestHelper type exposes the following members.

Methods
Name | Description
GenerateAircraftPropertyValue | Returns a dummy value that can be copied into any of the properties on an IAircraft object.
Top
See Also

Reference

AircraftTestHelper Class
Test.Framework Namespace


AircraftTestHelper.GenerateAircraftPropertyValue Method

AircraftTestHelperGenerateAircraftPropertyValue Method
Returns a dummy value that can be copied into any of the properties on an IAircraft object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object GenerateAircraftPropertyValue(
    Type propertyType
)
Public Shared Function GenerateAircraftPropertyValue (
    propertyType As Type
) As Object
public:
static Object^ GenerateAircraftPropertyValue(
    Type^ propertyType
)
static member GenerateAircraftPropertyValue :
        propertyType : Type -> Object

Parameters

propertyType
Type: SystemType

Return Value

Type: Object
Remarks
This is really quite an esoteric method - it just generates dummy values to set properties to in tests that are iterating over all of the properties of an IAircraft and don't really mind what the value of the property is, just so long as it has a value. There are only a couple of tests that use this but they're in different test libraries and so this method needed to be in a library common to both.
See Also

Reference

AircraftTestHelper Class
Test.Framework Namespace


ClockMock Class

ClockMock Class
A mock implementation of IClock.
Inheritance Hierarchy
SystemObject
Mock
MockIClock
Test.FrameworkClockMock

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClockMock : Mock<IClock>
Public Class ClockMock
    Inherits Mock(Of IClock)
public ref class ClockMock : public Mock<IClock^>
type ClockMock =
    class
        inherit Mock<IClock>
    end

The ClockMock type exposes the following members.

Constructors
 | Name | Description
Public method | ClockMock | Creates a new object.
Top
Properties
 | Name | Description
Public property | Behavior | (Inherited from Mock.)
Public property | CallBase | (Inherited from Mock.)
Public property | DefaultValue | (Inherited from Mock.)
Public property | LocalNowValue | Gets or sets the value of the LocalNow property.
Public property | Object | (Inherited from MockIClock .)
Public property | UtcNowValue | Gets or sets the value of the UtcNow property.
Top
Methods
 | Name | Description
Public method | AddMilliseconds | Advances UtcNowValue and LocalNowValue by so-many milliseconds.
Public method | As``1 | (Inherited from Mock.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expect(ExpressionActionUTP) | Obsolete. (Inherited from MockIClock .)
Public method | Expect(ExpressionActionUTP) | Obsolete. (Inherited from MockIClock .)
Public method | ExpectGet``1 | Obsolete. (Inherited from MockIClock .)
Public method | ExpectSet``1(ExpressionFuncUTP, UMP) | Obsolete. (Inherited from MockIClock .)
Public method | ExpectSet``1(ExpressionFuncUTP, UMP, UMP) | Obsolete. (Inherited from MockIClock .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnGetObject | (Inherited from MockIClock .)
Public method | Raise(ActionUTP, EventArgs) | (Inherited from MockIClock .)
Public method | Raise(ActionUTP, Object) | (Inherited from MockIClock .)
Public method | SetReturnsDefault``1 | (Inherited from Mock.)
Public method | Setup(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | Setup(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | SetupAllProperties | (Inherited from MockIClock .)
Public method | SetupGet``1 | (Inherited from MockIClock .)
Public method | SetupProperty``1(ExpressionFuncUTP, UMP) | (Inherited from MockIClock .)
Public method | SetupProperty``1(ExpressionFuncUTP, UMP, UMP) | (Inherited from MockIClock .)
Public method | SetupSet``1 | (Inherited from MockIClock .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | (Inherited from Mock.)
Public method | Verify(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, String) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times, String) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, String) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times, String) | (Inherited from MockIClock .)
Public method | VerifyAll | (Inherited from Mock.)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP) | (Inherited from MockIClock .)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP, Times) | (Inherited from MockIClock .)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP, String) | (Inherited from MockIClock .)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP, Times, String) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP, Times) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP, String) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP, Times, String) | (Inherited from MockIClock .)
Public method | When | (Inherited from MockIClock .)
Top
See Also

Reference

Test.Framework Namespace


ClockMock Constructor

ClockMock Constructor
Creates a new object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClockMock()
Public Sub New
public:
ClockMock()
new : unit -> ClockMock
See Also

Reference

ClockMock Class
Test.Framework Namespace


ClockMock Properties

ClockMock Properties

The ClockMock type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | (Inherited from Mock.)
Public property | CallBase | (Inherited from Mock.)
Public property | DefaultValue | (Inherited from Mock.)
Public property | LocalNowValue | Gets or sets the value of the LocalNow property.
Public property | Object | (Inherited from MockIClock .)
Public property | UtcNowValue | Gets or sets the value of the UtcNow property.
Top
See Also

Reference

ClockMock Class
Test.Framework Namespace


ClockMock.LocalNowValue Property

ClockMockLocalNowValue Property
Gets or sets the value of the LocalNow property.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LocalNowValue { get; set; }
Public Property LocalNowValue As DateTime
    Get
    Set
public:
property DateTime LocalNowValue {
    DateTime get ();
    void set (DateTime value);
}
member LocalNowValue : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ClockMock Class
Test.Framework Namespace


ClockMock.UtcNowValue Property

ClockMockUtcNowValue Property
Gets or sets the value of the UtcNow property.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime UtcNowValue { get; set; }
Public Property UtcNowValue As DateTime
    Get
    Set
public:
property DateTime UtcNowValue {
    DateTime get ();
    void set (DateTime value);
}
member UtcNowValue : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ClockMock Class
Test.Framework Namespace


ClockMock Methods

ClockMock Methods

The ClockMock type exposes the following members.

Methods
 | Name | Description
Public method | AddMilliseconds | Advances UtcNowValue and LocalNowValue by so-many milliseconds.
Public method | As``1 | (Inherited from Mock.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expect(ExpressionActionUTP) | Obsolete. (Inherited from MockIClock .)
Public method | Expect(ExpressionActionUTP) | Obsolete. (Inherited from MockIClock .)
Public method | ExpectGet``1 | Obsolete. (Inherited from MockIClock .)
Public method | ExpectSet``1(ExpressionFuncUTP, UMP) | Obsolete. (Inherited from MockIClock .)
Public method | ExpectSet``1(ExpressionFuncUTP, UMP, UMP) | Obsolete. (Inherited from MockIClock .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnGetObject | (Inherited from MockIClock .)
Public method | Raise(ActionUTP, EventArgs) | (Inherited from MockIClock .)
Public method | Raise(ActionUTP, Object) | (Inherited from MockIClock .)
Public method | SetReturnsDefault``1 | (Inherited from Mock.)
Public method | Setup(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | Setup(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | SetupAllProperties | (Inherited from MockIClock .)
Public method | SetupGet``1 | (Inherited from MockIClock .)
Public method | SetupProperty``1(ExpressionFuncUTP, UMP) | (Inherited from MockIClock .)
Public method | SetupProperty``1(ExpressionFuncUTP, UMP, UMP) | (Inherited from MockIClock .)
Public method | SetupSet``1 | (Inherited from MockIClock .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Verify | (Inherited from Mock.)
Public method | Verify(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, String) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times, String) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, String) | (Inherited from MockIClock .)
Public method | Verify(ExpressionActionUTP, Times, String) | (Inherited from MockIClock .)
Public method | VerifyAll | (Inherited from Mock.)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP) | (Inherited from MockIClock .)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP, Times) | (Inherited from MockIClock .)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP, String) | (Inherited from MockIClock .)
Public method | VerifyGet``1(ExpressionFuncUTP, UMP, Times, String) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP, Times) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP, String) | (Inherited from MockIClock .)
Public method | VerifySet(ActionUTP, Times, String) | (Inherited from MockIClock .)
Public method | When | (Inherited from MockIClock .)
Top
See Also

Reference

ClockMock Class
Test.Framework Namespace


ClockMock.AddMilliseconds Method

ClockMockAddMilliseconds Method
Advances UtcNowValue and LocalNowValue by so-many milliseconds.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime AddMilliseconds(
    int milliseconds
)
Public Function AddMilliseconds (
    milliseconds As Integer
) As DateTime
public:
DateTime AddMilliseconds(
    int milliseconds
)
member AddMilliseconds :
        milliseconds : int -> DateTime

Parameters

milliseconds
Type: SystemInt32

Return Value

Type: DateTime
The new UtcNowValue value.
See Also

Reference

ClockMock Class
Test.Framework Namespace


EventRecorder(T) Class

EventRecorderT Class
An object that can be hooked to an event to determine that it has been raised and record the parameters passed to the event.
Inheritance Hierarchy
SystemObject
Test.FrameworkEventRecorderT

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EventRecorder<T>
where T : EventArgs

Public Class EventRecorder(Of T As EventArgs)
generic<typename T>
where T : EventArgs
public ref class EventRecorder
type EventRecorder<'T when 'T : EventArgs> =  class end

Type Parameters

T

The EventRecorderT type exposes the following members.

Constructors
 | Name | Description
Public method | EventRecorderT | Creates a new object.
Top
Properties
 | Name | Description
Public property | AllArgs | Gets a list of every args parameter passed to the event. There will be CallCount entries in the list.
Public property | AllSenders | Gets a list of every sender parameter passed to the event. There will be CallCount entries in the list.
Public property | Args | Gets the args parameter from the last time the event was raised.
Public property | CallCount | Gets the number of times the event has been raised.
Public property | Sender | Gets the sender parameter from the last time the event was raised.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Handler | An event handler matching the EventHandler and/or EventHandler<> delegate that can be attached to an event and record the parameters passed by the code that raises the event.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnEventRaised | Raises EventRaised.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
EventRaised | Raised by Handler(Object, T) whenever the event is raised. Can be used to test the state of objects when the event was raised.
Top
Remarks
This only works with standard events that pass two parameters, a sender object and an args based on EventArgs.
Examples
Copy
public class ObjectUnderTest()
{
    public event EventHandler TheEvent;

    public void RaiseEvent()
    {
        if(TheEvent != null) TheEvent(this, EventArgs.Empty);
    }
}

[TestMethod]
public void Check_That_RaiseEvent_Raises_TheEvent()
{
    var objectUnderTest = new ObjectUnderTest();
    EventRecorder<EventArgs> eventRecorder = new EventRecorder<EventArgs>();

    objectUnderTest.TheEvent += eventRecorder.Handler;
    objectUnderTest.RaiseEvent();

    Assert.AreEqual(1, eventRecorder.CallCount);
    Assert.AreSame(objectUnderTest, eventRecorder.Sender);
    Assert.IsNotNull(eventRecorder.Args);
}
See Also

Reference

Test.Framework Namespace


EventRecorder(T) Constructor

EventRecorderT Constructor
Creates a new object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventRecorder()
Public Sub New
public:
EventRecorder()
new : unit -> EventRecorder
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T) Properties

EventRecorderT Properties

The EventRecorderT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllArgs | Gets a list of every args parameter passed to the event. There will be CallCount entries in the list.
Public property | AllSenders | Gets a list of every sender parameter passed to the event. There will be CallCount entries in the list.
Public property | Args | Gets the args parameter from the last time the event was raised.
Public property | CallCount | Gets the number of times the event has been raised.
Public property | Sender | Gets the sender parameter from the last time the event was raised.
Top
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).AllArgs Property

EventRecorderTAllArgs Property
Gets a list of every args parameter passed to the event. There will be CallCount entries in the list.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<T> AllArgs { get; }
Public ReadOnly Property AllArgs As List(Of T)
    Get
public:
property List<T>^ AllArgs {
    List<T>^ get ();
}
member AllArgs : List<'T> with get

Property Value

Type: List T
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).AllSenders Property

EventRecorderTAllSenders Property
Gets a list of every sender parameter passed to the event. There will be CallCount entries in the list.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<Object> AllSenders { get; }
Public ReadOnly Property AllSenders As List(Of Object)
    Get
public:
property List<Object^>^ AllSenders {
    List<Object^>^ get ();
}
member AllSenders : List<Object> with get

Property Value

Type: List Object
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).Args Property

EventRecorderTArgs Property
Gets the args parameter from the last time the event was raised.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Args { get; }
Public ReadOnly Property Args As T
    Get
public:
property T Args {
    T get ();
}
member Args : 'T with get

Property Value

Type: T
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).CallCount Property

EventRecorderTCallCount Property
Gets the number of times the event has been raised.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CallCount { get; }
Public ReadOnly Property CallCount As Integer
    Get
public:
property int CallCount {
    int get ();
}
member CallCount : int with get

Property Value

Type: Int32
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).Sender Property

EventRecorderTSender Property
Gets the sender parameter from the last time the event was raised.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Sender { get; }
Public ReadOnly Property Sender As Object
    Get
public:
property Object^ Sender {
    Object^ get ();
}
member Sender : Object with get

Property Value

Type: Object
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T) Methods

EventRecorderT Methods

The EventRecorderT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Handler | An event handler matching the EventHandler and/or EventHandler<> delegate that can be attached to an event and record the parameters passed by the code that raises the event.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnEventRaised | Raises EventRaised.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).Handler Method

EventRecorderTHandler Method
An event handler matching the EventHandler and/or EventHandler<> delegate that can be attached to an event and record the parameters passed by the code that raises the event.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Handler(
    Object sender,
    T args
)
Public Overridable Sub Handler (
    sender As Object,
    args As T
)
public:
virtual void Handler(
    Object^ sender,
    T args
)
abstract Handler :
        sender : Object *
        args : 'T -> unit
override Handler :
        sender : Object *
        args : 'T -> unit

Parameters

sender
Type: SystemObject
args
Type: T
Examples
Many of the examples already illustrate this, but just to emphasise that this class needs to be hooked to the event that you want to test, this is how you do it:
Copy
ObservableCollection<int> collection = new ObservableCollection<int>();
EventRecorder<NotifyCollectionChangedEventArgs> eventRecorder = new EventRecorder<NotifyCollectionChangedEventArgs>();

// Change the collection without attaching the event recorder:
collection.Add(987);
Assert.AreEqual(0, eventRecorder.CallCount);

// Change the collection after attaching the event recorder:
collection.CollectionChanged += eventRecorder.Handler;
collection.Add(643);
Assert.AreEqual(1, eventRecorder.CallCount);
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).OnEventRaised Method

EventRecorderTOnEventRaised Method
Raises EventRaised.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnEventRaised(
    T args
)
Protected Overridable Sub OnEventRaised (
    args As T
)
protected:
virtual void OnEventRaised(
    T args
)
abstract OnEventRaised :
        args : 'T -> unit
override OnEventRaised :
        args : 'T -> unit

Parameters

args
Type: T
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T) Events

EventRecorderT Events

The EventRecorderT generic type exposes the following members.

Events
Name | Description
EventRaised | Raised by Handler(Object, T) whenever the event is raised. Can be used to test the state of objects when the event was raised.
Top
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


EventRecorder(T).EventRaised Event

EventRecorderTEventRaised Event
Raised by Handler(Object, T) whenever the event is raised. Can be used to test the state of objects when the event was raised.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<T> EventRaised
Public Event EventRaised As EventHandler(Of T)
public:
 event EventHandler<T>^ EventRaised {
    void add (EventHandler<T>^ value);
    void remove (EventHandler<T>^ value);
}
member EventRaised : IEvent<EventHandler<'T>,
    'T>

Value

Type: SystemEventHandler T
Remarks
The sender passed to the event is the EventRecorder, not the sender of the original event. By the time the event is raised the EventRecorder's Sender property will be set to the sender of the original event.
Examples
This snippet shows how to check the state of an object when the event is raised. In this case it is testing that when some hypothetical object raises CountChanged its Count property is set to 2.
Copy
EventRecorder<SomeArgs> eventRecorder = new EventRecorder<SomeArgs>();
myObject.CountChanged += eventRecorder.Handler;
recorder.EventRaised += (s, a) => { Assert.AreEqual(2, myObject.Count); };

myObject.DoSomeWork();

Assert.AreEqual(1, recorder.CallCount);
Similarly this code will test what happens when an event handler throws an exception during processing:
Copy
EventRecorder<SomeArgs> eventRecorder = new EventRecorder<SomeArgs>();
myObject.CountChanged += eventRecorder.Handler;
recorder.EventRaised += (s, a) => { throw new InvalidOperation(); };

myObject.DoSomeWork();
Finally, this code checks that the sender is the same as the myObject value during processing of the event. Note that the sender passed to the event is the EventRecorder that is raising the event, not the original sender, so the test must use the EventRecorder's Sender property.
Copy
EventRecorder<SomeArgs> eventRecorder = new EventRecorder<SomeArgs>();
myObject.CountChanged += eventRecorder.Handler;
recorder.EventRaised += (s, a) => {
    // This just illustrates that the sender is the EventRecorder and to get the original
    // sender you need to use the appropriate property on the event recorder.
    Assert.AreSame(s, eventRecorder);
    Assert.AreSame(eventRecorder.Sender, myObject);
};
See Also

Reference

EventRecorderT Class
Test.Framework Namespace


ExcelWorksheetData Class

ExcelWorksheetData Class
A class to help when dealing with spreadsheet data-driven tests.
Inheritance Hierarchy
SystemObject
Test.FrameworkExcelWorksheetData

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExcelWorksheetData
Public Class ExcelWorksheetData
public ref class ExcelWorksheetData
type ExcelWorksheetData =  class end

The ExcelWorksheetData type exposes the following members.

Constructors
 | Name | Description
Public method | ExcelWorksheetData | Creates a new object.
Top
Properties
 | Name | Description
Public property | ItemInt32 | Gets a value from the worksheet by column number.
Public property | ItemString | Gets a value from a worksheet by column name.
Top
Methods
 | Name | Description
Public method | ArrayT | Returns the content of the cell at columnName cast to an array.
Public method | Bool(Int32) | Returns the content of the nth cell cast to a bool.
Public method | Bool(String) | Returns the content of the cell at columnName cast to a bool.
Public method | Bool(Int32, Boolean) | Returns the content of the nth cell cast to a bool. If the cell is empty then 'emptyValue' is returned.
Public method | Bool(String, Boolean) | Returns the content of the cell at columnName cast to a bool. If the cell is empty then 'emptyValue' is returned.
Public method | Byte(Byte) | Returns the content of the nth cell cast to a byte.
Public method | Byte(String) | Returns the content of the cell at columnName cast to a byte.
Public method | Byte(Byte, Byte) | Returns the content of the nth cell cast to a byte. If the cell is empty then 'emptyValue' is returned.
Public method | Byte(String, Byte) | Returns the content of the cell at columnName cast to a byte. If the cell is empty then 'emptyValue' is returned.
 | Bytes(Int32) | Returns the content of the nth cell as an array of bytes.
 | Bytes(String) | Returns the content of the cell at columnName as an array of bytes.
Public method | Char(Int32) | Returns the content of the nth cell cast to a char.
Public method | Char(String) | Returns the content of the cell at columnName cast to a char.
Public method | Char(Int32, Char) | Returns the content of the nth cell cast to a char. If the cell is empty then 'emptyValue' is returned.
Public method | Char(String, Char) | Returns the content of the cell at columnName cast to a char. If the cell is empty then 'emptyValue' is returned.
Public method | ColumnExists | Returns true if there is a column with the name passed across.
Public method | ConvertString | Converts the raw value to a value of the type passed across.
Public method | DateTime(Int32) | Returns the content of the nth cell cast to a DateTime.
Public method | DateTime(String) | Returns the content of the cell at columnName cast to a DateTime.
Public method | DateTime(Int32, DateTime) | Returns the content of the nth cell cast to a DateTime. If the cell is empty then 'emptyValue' is returned.
Public method | DateTime(String, DateTime) | Returns the content of the cell at columnName cast to a DateTime. If the cell is empty then 'emptyValue' is returned.
Public method | Decimal(Int32) | Returns the content of the nth cell cast to a decimal.
Public method | Decimal(String) | Returns the content of the cell at columnName cast to a decimal.
Public method | Decimal(Int32, Decimal) | Returns the content of the nth cell cast to a decimal. If the cell is empty then 'emptyValue' is returned.
Public method | Decimal(String, Decimal) | Returns the content of the cell at columnName cast to a decimal. If the cell is empty then 'emptyValue' is returned.
Public method | Double(Int32) | Returns the content of the nth cell cast to a double.
Public method | Double(String) | Returns the content of the cell at columnName cast to a double.
Public method | Double(Int32, Double) | Returns the content of the nth cell cast to a double. If the cell is empty then 'emptyValue' is returned.
Public method | Double(String, Double) | Returns the content of the cell at columnName cast to a double. If the cell is empty then 'emptyValue' is returned.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EString(Int32) | Returns the content of the nth cell as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.
Public method | EString(String) | Returns the content of the cell at columnName as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Float(Int32) | Returns the content of the nth cell cast to a float.
Public method | Float(String) | Returns the content of the cell at columnName cast to a float.
Public method | Float(Int32, Single) | Returns the content of the nth cell cast to a float. If the cell is empty then 'emptyValue' is returned.
Public method | Float(String, Single) | Returns the content of the cell at columnName cast to a float. If the cell is empty then 'emptyValue' is returned.
Public method | GetColumnT(Int32, T) | Returns the content of the column cast to type or a default value if the column has no value.
Public method | GetColumnT(String, T) | Returns the content of the column cast to type or a default value if the column has no value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNullableColumnT(Int32) | Returns the content of the column cast to a nullable of the type or null if the column has no value.
Public method | GetNullableColumnT(String) | Returns the content of the column cast to a nullable of the type or null if the column has no value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Int(Int32) | Returns the content of the nth cell cast to an int.
Public method | Int(String) | Returns the content of the cell at columnName cast to an int.
Public method | Int(Int32, Int32) | Returns the content of the nth cell cast to an int. If the cell is empty then 'emptyValue' is returned.
Public method | Int(String, Int32) | Returns the content of the cell at columnName cast to an int. If the cell is empty then 'emptyValue' is returned.
Public method | Long(Int32) | Returns the content of the nth cell cast to a long.
Public method | Long(String) | Returns the content of the cell at columnName cast to a long.
Public method | Long(Int32, Int64) | Returns the content of the nth cell cast to a long. If the cell is empty then 'emptyValue' is returned.
Public method | Long(String, Int64) | Returns the content of the cell at columnName cast to a long. If the cell is empty then 'emptyValue' is returned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NBool(Int32) | Returns the content of the nth cell cast to a nullable bool.
Public method | NBool(String) | Returns the content of the cell at columnName cast to a nullable bool.
Public method | NByte(Byte) | Returns the content of the nth cell cast to a nullable byte.
Public method | NByte(String) | Returns the content of the cell at columnName cast to a nullable byte.
Public method | NChar(Int32) | Returns the content of the nth cell cast to a nullable char.
Public method | NChar(String) | Returns the content of the cell at columnName cast to a nullable char.
Public method | NDateTime(Int32) | Returns the content of the nth cell cast to a nullable DateTime.
Public method | NDateTime(String) | Returns the content of the cell at columnName cast to a nullable DateTime.
Public method | NDecimal(Int32) | Returns the content of the nth cell cast to a nullable decimal.
Public method | NDecimal(String) | Returns the content of the cell at columnName cast to a nullable decimal.
Public method | NDouble(Int32) | Returns the content of the nth cell cast to a nullable double.
Public method | NDouble(String) | Returns the content of the cell at columnName cast to a nullable double.
Public method | NFloat(Int32) | Returns the content of the nth cell cast to a nullable float.
Public method | NFloat(String) | Returns the content of the cell at columnName cast to a nullable float.
Public method | NInt(Int32) | Returns the content of the nth cell cast to a nullable int.
Public method | NInt(String) | Returns the content of the cell at columnName cast to a nullable int.
Public method | NLong(Int32) | Returns the content of the nth cell cast to a nullable long.
Public method | NLong(String) | Returns the content of the cell at columnName cast to a nullable long.
Public method | NShort(Int16) | Returns the content of the nth cell cast to a nullable short.
Public method | NShort(String) | Returns the content of the cell at columnName cast to a nullable short.
Public method | ParseEnumT(Int32) | Returns the content of the nth cell cast to an enum.
Public method | ParseEnumT(String) | Returns the content of the cell at columnName cast to an enum.
Public method | Short(Int16) | Returns the content of the nth cell cast to an short.
Public method | Short(String) | Returns the content of the cell at columnName cast to an short.
Public method | Short(Int16, Int16) | Returns the content of the nth cell cast to an short. If the cell is empty then 'emptyValue' is returned.
Public method | Short(String, Int16) | Returns the content of the cell at columnName cast to an short. If the cell is empty then 'emptyValue' is returned.
Public method | String(Int32) | Returns the string content of the nth cell.
Public method | String(String) | Returns the string content of the cell at columnName.
Public method | String(Int32, String) | Returns the string content of the nth cell. If the cell is empty then 'emptyValue' is returned.
Public method | String(String, String) | Returns the string content of the cell at columnName. If the cell is empty then 'emptyValue' is returned.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UInt(Int32) | Returns the content of the nth cell cast to a uint.
Public method | UInt(String) | Returns the content of the cell at columnName cast to a uint.
Public method | UInt(Int32, UInt32) | Returns the content of the nth cell cast to a uint. If the cell is empty then 'emptyValue' is returned.
Public method | UInt(String, UInt32) | Returns the content of the cell at columnName cast to a uint. If the cell is empty then 'emptyValue' is returned.
Public method | ULong(Int32) | Returns the content of the nth cell cast to a ulong.
Public method | ULong(String) | Returns the content of the cell at columnName cast to a ulong.
Public method | ULong(Int32, UInt64) | Returns the content of the nth cell cast to a ulong. If the cell is empty then 'emptyValue' is returned.
Public method | ULong(String, UInt64) | Returns the content of the cell at columnName cast to a ulong. If the cell is empty then 'emptyValue' is returned.
Public method | UShort(Int32) | Returns the content of the nth cell cast to a ushort.
Public method | UShort(String) | Returns the content of the cell at columnName cast to a ushort.
Public method | UShort(Int32, UInt16) | Returns the content of the nth cell cast to a ushort. If the cell is empty then 'emptyValue' is returned.
Public method | UShort(String, UInt16) | Returns the content of the cell at columnName cast to a ushort. If the cell is empty then 'emptyValue' is returned.
Top
Remarks

Spreadsheet data-driven tests have the advantage over database data-driven tests in that the source data is very easy to setup. You can use Excel or OpenOffice (saving the spreadsheet as a .XLS file) to create the source data in a worksheet and then tell VSTS to repeatedly run the test for each row in the sheet.

There are a few caveats when working with spreadsheets. The first is that EVERY CELL MUST BE FORMATTED FOR TEXT. If you fail to do this then the ADO.NET data adapter that is reading the spreadsheet will infer the type from the content of the first data row for the cell. If you have a column that contains the heading "Text" on row 1, the data value 42 on row 2 and the data value Hello on row 3 then you will get an exception when row 3 is read because the number on row 2 has fooled the data adapter into thinking ALL of the cells are numbers. So rule one, absolutely definitely never break it, when you start a new worksheet press Ctrl+A to select all cells and then set the format to TEXT.

Once you're past that it gets a lot easier. In your test class you need to declare the public read/write property TestContext of type TestContext. This is a magic property that is filled by VSTS at the start of the test and it will carry the data from the spreadsheet to your test.

To pull data from a worksheet in a test you add this attribute to the test method, replacing SPREADSHEET.XLS with the name of your spreadsheet and WORKSHEET$ with the name of the worksheet to read, suffixed with a dollar sign:

[DataSource("Data Source='SPREADSHEET.XLS';Provider=Microsoft.Jet.OLEDB.4.0;Persist Security Info=False;Extended Properties='Excel 8.0'", "WORKSHEET$")]

You then create an instance of ExcelWorksheetData at the start of the test and use the read methods to pull data in, usually by column name. The read methods are all named after the type that they cast the value to, read methods for nullable value types all start with a capital N. There are special methods for reading strings where you need to be able to return either null or an empty string, methods to parse the names of enum values into the correct type and methods to parse a cell's text into a byte array.

Finally you need to get the spreadsheet copied into the test deployment folder by VSTS so that the test can use it. The easiest way to do this is to create a folder on a test project that contains all of your spreadsheets (Virtual Radar Server has a folder called TestFiles under the Test.Framework project for this) and then edit the test configuration file (in VSTS either double-click LocalTestRun.testrunconfig in Solution Items or use the Test | Edit Test Settings menu entry) and add the sub-folder with the spreadsheet(s) in to the Deployment section.

Examples

This example tests the standard ASCIIEncoding object's GetString method. Assume that we have a spreadsheet called Tests.xls that contains a worksheet called TestData with the following rows and columns (all formatted as TEXT):

Bytes | Text
40 | @
41 | A
61 62 63 | abc

The full code for the test class might be:

Copy
[TestClass]
public class ExampleTest
{
    public TestContext TestContext { get; set; }

    [TestMethod]
    [DataSource("Data Source='Tests.xls';Provider=Microsoft.Jet.OLEDB.4.0;Persist Security Info=False;Extended Properties='Excel 8.0'",
    "TestData$")]
    public void ASCIIEncoding_GetString_Converts_Byte_Arrays_To_Strings()
    {
        var worksheet = new ExcelWorksheetData(TestContext);

        // You could do this in one line, as below, but to make it clearer we will spell it out step-by-step:
        // Assert.AreEqual(worksheet.String("Text"), Encoding.ASCII.GetString(worksheet.ParseBytes("Bytes")));

        byte[] input = worksheet.ParseBytes("Bytes");    // Read string in cell "Bytes" and parse into a byte array
        string expected = worksheet.String("Text");      // Read content of "Text" cell as a string
        string actual = Encoding.ASCII.GetString(input);

        Assert.AreEqual(expected, actual);
    }
}

When you run the test you will get 4 executions (one per row plus one for the overall test). In this case all 4 will pass. If one failed then you would get 3/4 passed, and so on. Double-clicking on the row for the test in TestResults will show a list of results for each row. Add two to the row number to translate from the row number in TestResults to the row number in the spreadsheet (e.g. row number 0 in TestResults corresponds to row 2 in the spreadsheet).

If the intent of a test is not clear from the input and output values listed in the spreadsheet row then you may want to consider adding a 'Comments' column to the spreadsheet and describe in there what it is that you're trying to assert.

See Also

Reference

Test.Framework Namespace


ExcelWorksheetData Constructor

ExcelWorksheetData Constructor
Creates a new object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExcelWorksheetData(
    TestContext testContext
)
Public Sub New (
    testContext As TestContext
)
public:
ExcelWorksheetData(
    TestContext^ testContext
)
new :
        testContext : TestContext -> ExcelWorksheetData

Parameters

testContext
Type: TestContext
Remarks
Use this to expose one row at a time in a normal data-driven test.
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData Properties

ExcelWorksheetData Properties
Properties
 | Name | Description
Public property | ItemInt32 | Gets a value from the worksheet by column number.
Public property | ItemString | Gets a value from a worksheet by column name.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Item Property

ExcelWorksheetDataItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | Gets a value from the worksheet by column number.
Public property | ItemString | Gets a value from a worksheet by column name.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Item Property (Int32)

ExcelWorksheetDataItem Property (Int32)
Gets a value from the worksheet by column number.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string this[
    int ordinal
] { get; }
Public ReadOnly Default Property Item (
    ordinal As Integer
) As String
    Get
public:
property String^ default[int ordinal] {
    String^ get (int ordinal);
}
member Item : string with get

Parameters

ordinal
Type: SystemInt32

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
Item Overload
Test.Framework Namespace


ExcelWorksheetData.Item Property (String)

ExcelWorksheetDataItem Property (String)
Gets a value from a worksheet by column name.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string this[
    string index
] { get; }
Public ReadOnly Default Property Item (
    index As String
) As String
    Get
public:
property String^ default[String^ index] {
    String^ get (String^ index);
}
member Item : string with get

Parameters

index
Type: SystemString

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
Item Overload
Test.Framework Namespace


ExcelWorksheetData Methods

ExcelWorksheetData Methods

The ExcelWorksheetData type exposes the following members.

Methods
 | Name | Description
Public method | ArrayT | Returns the content of the cell at columnName cast to an array.
Public method | Bool(Int32) | Returns the content of the nth cell cast to a bool.
Public method | Bool(String) | Returns the content of the cell at columnName cast to a bool.
Public method | Bool(Int32, Boolean) | Returns the content of the nth cell cast to a bool. If the cell is empty then 'emptyValue' is returned.
Public method | Bool(String, Boolean) | Returns the content of the cell at columnName cast to a bool. If the cell is empty then 'emptyValue' is returned.
Public method | Byte(Byte) | Returns the content of the nth cell cast to a byte.
Public method | Byte(String) | Returns the content of the cell at columnName cast to a byte.
Public method | Byte(Byte, Byte) | Returns the content of the nth cell cast to a byte. If the cell is empty then 'emptyValue' is returned.
Public method | Byte(String, Byte) | Returns the content of the cell at columnName cast to a byte. If the cell is empty then 'emptyValue' is returned.
 | Bytes(Int32) | Returns the content of the nth cell as an array of bytes.
 | Bytes(String) | Returns the content of the cell at columnName as an array of bytes.
Public method | Char(Int32) | Returns the content of the nth cell cast to a char.
Public method | Char(String) | Returns the content of the cell at columnName cast to a char.
Public method | Char(Int32, Char) | Returns the content of the nth cell cast to a char. If the cell is empty then 'emptyValue' is returned.
Public method | Char(String, Char) | Returns the content of the cell at columnName cast to a char. If the cell is empty then 'emptyValue' is returned.
Public method | ColumnExists | Returns true if there is a column with the name passed across.
Public method | ConvertString | Converts the raw value to a value of the type passed across.
Public method | DateTime(Int32) | Returns the content of the nth cell cast to a DateTime.
Public method | DateTime(String) | Returns the content of the cell at columnName cast to a DateTime.
Public method | DateTime(Int32, DateTime) | Returns the content of the nth cell cast to a DateTime. If the cell is empty then 'emptyValue' is returned.
Public method | DateTime(String, DateTime) | Returns the content of the cell at columnName cast to a DateTime. If the cell is empty then 'emptyValue' is returned.
Public method | Decimal(Int32) | Returns the content of the nth cell cast to a decimal.
Public method | Decimal(String) | Returns the content of the cell at columnName cast to a decimal.
Public method | Decimal(Int32, Decimal) | Returns the content of the nth cell cast to a decimal. If the cell is empty then 'emptyValue' is returned.
Public method | Decimal(String, Decimal) | Returns the content of the cell at columnName cast to a decimal. If the cell is empty then 'emptyValue' is returned.
Public method | Double(Int32) | Returns the content of the nth cell cast to a double.
Public method | Double(String) | Returns the content of the cell at columnName cast to a double.
Public method | Double(Int32, Double) | Returns the content of the nth cell cast to a double. If the cell is empty then 'emptyValue' is returned.
Public method | Double(String, Double) | Returns the content of the cell at columnName cast to a double. If the cell is empty then 'emptyValue' is returned.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EString(Int32) | Returns the content of the nth cell as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.
Public method | EString(String) | Returns the content of the cell at columnName as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Float(Int32) | Returns the content of the nth cell cast to a float.
Public method | Float(String) | Returns the content of the cell at columnName cast to a float.
Public method | Float(Int32, Single) | Returns the content of the nth cell cast to a float. If the cell is empty then 'emptyValue' is returned.
Public method | Float(String, Single) | Returns the content of the cell at columnName cast to a float. If the cell is empty then 'emptyValue' is returned.
Public method | GetColumnT(Int32, T) | Returns the content of the column cast to type or a default value if the column has no value.
Public method | GetColumnT(String, T) | Returns the content of the column cast to type or a default value if the column has no value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNullableColumnT(Int32) | Returns the content of the column cast to a nullable of the type or null if the column has no value.
Public method | GetNullableColumnT(String) | Returns the content of the column cast to a nullable of the type or null if the column has no value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Int(Int32) | Returns the content of the nth cell cast to an int.
Public method | Int(String) | Returns the content of the cell at columnName cast to an int.
Public method | Int(Int32, Int32) | Returns the content of the nth cell cast to an int. If the cell is empty then 'emptyValue' is returned.
Public method | Int(String, Int32) | Returns the content of the cell at columnName cast to an int. If the cell is empty then 'emptyValue' is returned.
Public method | Long(Int32) | Returns the content of the nth cell cast to a long.
Public method | Long(String) | Returns the content of the cell at columnName cast to a long.
Public method | Long(Int32, Int64) | Returns the content of the nth cell cast to a long. If the cell is empty then 'emptyValue' is returned.
Public method | Long(String, Int64) | Returns the content of the cell at columnName cast to a long. If the cell is empty then 'emptyValue' is returned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NBool(Int32) | Returns the content of the nth cell cast to a nullable bool.
Public method | NBool(String) | Returns the content of the cell at columnName cast to a nullable bool.
Public method | NByte(Byte) | Returns the content of the nth cell cast to a nullable byte.
Public method | NByte(String) | Returns the content of the cell at columnName cast to a nullable byte.
Public method | NChar(Int32) | Returns the content of the nth cell cast to a nullable char.
Public method | NChar(String) | Returns the content of the cell at columnName cast to a nullable char.
Public method | NDateTime(Int32) | Returns the content of the nth cell cast to a nullable DateTime.
Public method | NDateTime(String) | Returns the content of the cell at columnName cast to a nullable DateTime.
Public method | NDecimal(Int32) | Returns the content of the nth cell cast to a nullable decimal.
Public method | NDecimal(String) | Returns the content of the cell at columnName cast to a nullable decimal.
Public method | NDouble(Int32) | Returns the content of the nth cell cast to a nullable double.
Public method | NDouble(String) | Returns the content of the cell at columnName cast to a nullable double.
Public method | NFloat(Int32) | Returns the content of the nth cell cast to a nullable float.
Public method | NFloat(String) | Returns the content of the cell at columnName cast to a nullable float.
Public method | NInt(Int32) | Returns the content of the nth cell cast to a nullable int.
Public method | NInt(String) | Returns the content of the cell at columnName cast to a nullable int.
Public method | NLong(Int32) | Returns the content of the nth cell cast to a nullable long.
Public method | NLong(String) | Returns the content of the cell at columnName cast to a nullable long.
Public method | NShort(Int16) | Returns the content of the nth cell cast to a nullable short.
Public method | NShort(String) | Returns the content of the cell at columnName cast to a nullable short.
Public method | ParseEnumT(Int32) | Returns the content of the nth cell cast to an enum.
Public method | ParseEnumT(String) | Returns the content of the cell at columnName cast to an enum.
Public method | Short(Int16) | Returns the content of the nth cell cast to an short.
Public method | Short(String) | Returns the content of the cell at columnName cast to an short.
Public method | Short(Int16, Int16) | Returns the content of the nth cell cast to an short. If the cell is empty then 'emptyValue' is returned.
Public method | Short(String, Int16) | Returns the content of the cell at columnName cast to an short. If the cell is empty then 'emptyValue' is returned.
Public method | String(Int32) | Returns the string content of the nth cell.
Public method | String(String) | Returns the string content of the cell at columnName.
Public method | String(Int32, String) | Returns the string content of the nth cell. If the cell is empty then 'emptyValue' is returned.
Public method | String(String, String) | Returns the string content of the cell at columnName. If the cell is empty then 'emptyValue' is returned.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UInt(Int32) | Returns the content of the nth cell cast to a uint.
Public method | UInt(String) | Returns the content of the cell at columnName cast to a uint.
Public method | UInt(Int32, UInt32) | Returns the content of the nth cell cast to a uint. If the cell is empty then 'emptyValue' is returned.
Public method | UInt(String, UInt32) | Returns the content of the cell at columnName cast to a uint. If the cell is empty then 'emptyValue' is returned.
Public method | ULong(Int32) | Returns the content of the nth cell cast to a ulong.
Public method | ULong(String) | Returns the content of the cell at columnName cast to a ulong.
Public method | ULong(Int32, UInt64) | Returns the content of the nth cell cast to a ulong. If the cell is empty then 'emptyValue' is returned.
Public method | ULong(String, UInt64) | Returns the content of the cell at columnName cast to a ulong. If the cell is empty then 'emptyValue' is returned.
Public method | UShort(Int32) | Returns the content of the nth cell cast to a ushort.
Public method | UShort(String) | Returns the content of the cell at columnName cast to a ushort.
Public method | UShort(Int32, UInt16) | Returns the content of the nth cell cast to a ushort. If the cell is empty then 'emptyValue' is returned.
Public method | UShort(String, UInt16) | Returns the content of the cell at columnName cast to a ushort. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Array(T) Method

ExcelWorksheetDataArrayT Method
Returns the content of the cell at columnName cast to an array.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T[] Array<T>(
    string columnName,
    char separator = ','
)

Public Function Array(Of T) (
    columnName As String,
    Optional separator As Char = ","C
) As T()
public:
generic<typename T>
array<T>^ Array(
    String^ columnName,
    wchar_t separator = L','
)
member Array :
        columnName : string *
        ?separator : char
(* Defaults:
        let _separator = defaultArg separator ','
*)
-> 'T[]

Parameters

columnName
Type: SystemString
separator (Optional)
Type: SystemChar

Type Parameters

T

Return Value

Type: T
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Bool Method

ExcelWorksheetDataBool Method
Overload List
 | Name | Description
Public method | Bool(Int32) | Returns the content of the nth cell cast to a bool.
Public method | Bool(String) | Returns the content of the cell at columnName cast to a bool.
Public method | Bool(Int32, Boolean) | Returns the content of the nth cell cast to a bool. If the cell is empty then 'emptyValue' is returned.
Public method | Bool(String, Boolean) | Returns the content of the cell at columnName cast to a bool. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Bool Method (Int32)

ExcelWorksheetDataBool Method (Int32)
Returns the content of the nth cell cast to a bool.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bool(
    int ordinal
)
Public Function Bool (
    ordinal As Integer
) As Boolean
public:
bool Bool(
    int ordinal
)
member Bool :
        ordinal : int -> bool

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

ExcelWorksheetData Class
Bool Overload
Test.Framework Namespace


ExcelWorksheetData.Bool Method (String)

ExcelWorksheetDataBool Method (String)
Returns the content of the cell at columnName cast to a bool.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bool(
    string columnName
)
Public Function Bool (
    columnName As String
) As Boolean
public:
bool Bool(
    String^ columnName
)
member Bool :
        columnName : string -> bool

Parameters

columnName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ExcelWorksheetData Class
Bool Overload
Test.Framework Namespace


ExcelWorksheetData.Bool Method (Int32, Boolean)

ExcelWorksheetDataBool Method (Int32, Boolean)
Returns the content of the nth cell cast to a bool. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bool(
    int ordinal,
    bool emptyValue
)
Public Function Bool (
    ordinal As Integer,
    emptyValue As Boolean
) As Boolean
public:
bool Bool(
    int ordinal,
    bool emptyValue
)
member Bool :
        ordinal : int *
        emptyValue : bool -> bool

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

ExcelWorksheetData Class
Bool Overload
Test.Framework Namespace


ExcelWorksheetData.Bool Method (String, Boolean)

ExcelWorksheetDataBool Method (String, Boolean)
Returns the content of the cell at columnName cast to a bool. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bool(
    string columnName,
    bool emptyValue
)
Public Function Bool (
    columnName As String,
    emptyValue As Boolean
) As Boolean
public:
bool Bool(
    String^ columnName,
    bool emptyValue
)
member Bool :
        columnName : string *
        emptyValue : bool -> bool

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

ExcelWorksheetData Class
Bool Overload
Test.Framework Namespace


ExcelWorksheetData.Byte Method

ExcelWorksheetDataByte Method
Overload List
 | Name | Description
Public method | Byte(Byte) | Returns the content of the nth cell cast to a byte.
Public method | Byte(String) | Returns the content of the cell at columnName cast to a byte.
Public method | Byte(Byte, Byte) | Returns the content of the nth cell cast to a byte. If the cell is empty then 'emptyValue' is returned.
Public method | Byte(String, Byte) | Returns the content of the cell at columnName cast to a byte. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Byte Method (Byte)

ExcelWorksheetDataByte Method (Byte)
Returns the content of the nth cell cast to a byte.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Byte(
    byte ordinal
)
Public Function Byte (
    ordinal As Byte
) As Byte
public:
unsigned char Byte(
    unsigned char ordinal
)
member Byte :
        ordinal : byte -> byte

Parameters

ordinal
Type: SystemByte

Return Value

Type: Byte
See Also

Reference

ExcelWorksheetData Class
Byte Overload
Test.Framework Namespace


ExcelWorksheetData.Byte Method (String)

ExcelWorksheetDataByte Method (String)
Returns the content of the cell at columnName cast to a byte.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Byte(
    string columnName
)
Public Function Byte (
    columnName As String
) As Byte
public:
unsigned char Byte(
    String^ columnName
)
member Byte :
        columnName : string -> byte

Parameters

columnName
Type: SystemString

Return Value

Type: Byte
See Also

Reference

ExcelWorksheetData Class
Byte Overload
Test.Framework Namespace


ExcelWorksheetData.Byte Method (Byte, Byte)

ExcelWorksheetDataByte Method (Byte, Byte)
Returns the content of the nth cell cast to a byte. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Byte(
    byte ordinal,
    byte emptyValue
)
Public Function Byte (
    ordinal As Byte,
    emptyValue As Byte
) As Byte
public:
unsigned char Byte(
    unsigned char ordinal,
    unsigned char emptyValue
)
member Byte :
        ordinal : byte *
        emptyValue : byte -> byte

Parameters

ordinal
Type: SystemByte
emptyValue
Type: SystemByte

Return Value

Type: Byte
See Also

Reference

ExcelWorksheetData Class
Byte Overload
Test.Framework Namespace


ExcelWorksheetData.Byte Method (String, Byte)

ExcelWorksheetDataByte Method (String, Byte)
Returns the content of the cell at columnName cast to a byte. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Byte(
    string columnName,
    byte emptyValue
)
Public Function Byte (
    columnName As String,
    emptyValue As Byte
) As Byte
public:
unsigned char Byte(
    String^ columnName,
    unsigned char emptyValue
)
member Byte :
        columnName : string *
        emptyValue : byte -> byte

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemByte

Return Value

Type: Byte
See Also

Reference

ExcelWorksheetData Class
Byte Overload
Test.Framework Namespace


ExcelWorksheetData.Bytes Method

ExcelWorksheetDataBytes Method
Overload List
Name | Description
Bytes(Int32) | Returns the content of the nth cell as an array of bytes.
Bytes(String) | Returns the content of the cell at columnName as an array of bytes.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Bytes Method (Int32)

ExcelWorksheetDataBytes Method (Int32)
Returns the content of the nth cell as an array of bytes.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes(
    int ordinal
)
Public Function Bytes (
    ordinal As Integer
) As Byte()
public:
array<unsigned char>^ Bytes(
    int ordinal
)
member Bytes :
        ordinal : int -> byte[]

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Byte
Remarks

The bytes must be formatted as a sequence of hex digits with any of these characters between each digit:

  • space
  • tab (although this might be tricky to get into a spreadsheet cell!)
  • comma
  • semi-colon
  • forward-slash
  • dot
Examples
A cell whose content is null would return a null array. A cell whose content is two quotes ("") returns an empty array. A cell whose content was '01 aa.BB/0c' would return a byte[] of length 4 whose contents were 0x01, 0xAA, 0xBB, 0x0C.
See Also

Reference

ExcelWorksheetData Class
Bytes Overload
Test.Framework Namespace


ExcelWorksheetData.Bytes Method (String)

ExcelWorksheetDataBytes Method (String)
Returns the content of the cell at columnName as an array of bytes.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes(
    string columnName
)
Public Function Bytes (
    columnName As String
) As Byte()
public:
array<unsigned char>^ Bytes(
    String^ columnName
)
member Bytes :
        columnName : string -> byte[]

Parameters

columnName
Type: SystemString

Return Value

Type: Byte
Remarks

The bytes must be formatted as a sequence of hex digits with any of these characters between each digit:

  • space
  • tab (although this might be tricky to get into a spreadsheet cell!)
  • comma
  • semi-colon
  • forward-slash
  • dot
Examples
A cell whose content is null would return a null array. A cell whose content is two quotes ("") returns an empty array. A cell whose content was '01 aa.BB/0c' would return a byte[] of length 4 whose contents were 0x01, 0xAA, 0xBB, 0x0C.
See Also

Reference

ExcelWorksheetData Class
Bytes Overload
Test.Framework Namespace


ExcelWorksheetData.Char Method

ExcelWorksheetDataChar Method
Overload List
 | Name | Description
Public method | Char(Int32) | Returns the content of the nth cell cast to a char.
Public method | Char(String) | Returns the content of the cell at columnName cast to a char.
Public method | Char(Int32, Char) | Returns the content of the nth cell cast to a char. If the cell is empty then 'emptyValue' is returned.
Public method | Char(String, Char) | Returns the content of the cell at columnName cast to a char. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Char Method (Int32)

ExcelWorksheetDataChar Method (Int32)
Returns the content of the nth cell cast to a char.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public char Char(
    int ordinal
)
Public Function Char (
    ordinal As Integer
) As Char
public:
wchar_t Char(
    int ordinal
)
member Char :
        ordinal : int -> char

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Char
See Also

Reference

ExcelWorksheetData Class
Char Overload
Test.Framework Namespace


ExcelWorksheetData.Char Method (String)

ExcelWorksheetDataChar Method (String)
Returns the content of the cell at columnName cast to a char.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public char Char(
    string columnName
)
Public Function Char (
    columnName As String
) As Char
public:
wchar_t Char(
    String^ columnName
)
member Char :
        columnName : string -> char

Parameters

columnName
Type: SystemString

Return Value

Type: Char
See Also

Reference

ExcelWorksheetData Class
Char Overload
Test.Framework Namespace


ExcelWorksheetData.Char Method (Int32, Char)

ExcelWorksheetDataChar Method (Int32, Char)
Returns the content of the nth cell cast to a char. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public char Char(
    int ordinal,
    char emptyValue
)
Public Function Char (
    ordinal As Integer,
    emptyValue As Char
) As Char
public:
wchar_t Char(
    int ordinal,
    wchar_t emptyValue
)
member Char :
        ordinal : int *
        emptyValue : char -> char

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemChar

Return Value

Type: Char
See Also

Reference

ExcelWorksheetData Class
Char Overload
Test.Framework Namespace


ExcelWorksheetData.Char Method (String, Char)

ExcelWorksheetDataChar Method (String, Char)
Returns the content of the cell at columnName cast to a char. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public char Char(
    string columnName,
    char emptyValue
)
Public Function Char (
    columnName As String,
    emptyValue As Char
) As Char
public:
wchar_t Char(
    String^ columnName,
    wchar_t emptyValue
)
member Char :
        columnName : string *
        emptyValue : char -> char

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemChar

Return Value

Type: Char
See Also

Reference

ExcelWorksheetData Class
Char Overload
Test.Framework Namespace


ExcelWorksheetData.ColumnExists Method

ExcelWorksheetDataColumnExists Method
Returns true if there is a column with the name passed across.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ColumnExists(
    string columnName
)
Public Function ColumnExists (
    columnName As String
) As Boolean
public:
bool ColumnExists(
    String^ columnName
)
member ColumnExists :
        columnName : string -> bool

Parameters

columnName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.ConvertString Method

ExcelWorksheetDataConvertString Method
Converts the raw value to a value of the type passed across.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object ConvertString(
    string rawValue,
    Type type
)
Public Function ConvertString (
    rawValue As String,
    type As Type
) As Object
public:
Object^ ConvertString(
    String^ rawValue,
    Type^ type
)
member ConvertString :
        rawValue : string *
        type : Type -> Object

Parameters

rawValue
Type: SystemString
type
Type: SystemType

Return Value

Type: Object
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.DateTime Method

ExcelWorksheetDataDateTime Method
Overload List
 | Name | Description
Public method | DateTime(Int32) | Returns the content of the nth cell cast to a DateTime.
Public method | DateTime(String) | Returns the content of the cell at columnName cast to a DateTime.
Public method | DateTime(Int32, DateTime) | Returns the content of the nth cell cast to a DateTime. If the cell is empty then 'emptyValue' is returned.
Public method | DateTime(String, DateTime) | Returns the content of the cell at columnName cast to a DateTime. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.DateTime Method (Int32)

ExcelWorksheetDataDateTime Method (Int32)
Returns the content of the nth cell cast to a DateTime.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime(
    int ordinal
)
Public Function DateTime (
    ordinal As Integer
) As DateTime
public:
DateTime DateTime(
    int ordinal
)
member DateTime :
        ordinal : int -> DateTime

Parameters

ordinal
Type: SystemInt32

Return Value

Type: DateTime
Remarks
The DateTime must be in UK format, i.e. 'dd/mm/yyyy' or 'dd/mm/yyyy hh:mm:ss' or 'dd/mm/yyyy hh:mm:ss.sss'.
See Also

Reference

ExcelWorksheetData Class
DateTime Overload
Test.Framework Namespace


ExcelWorksheetData.DateTime Method (String)

ExcelWorksheetDataDateTime Method (String)
Returns the content of the cell at columnName cast to a DateTime.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime(
    string columnName
)
Public Function DateTime (
    columnName As String
) As DateTime
public:
DateTime DateTime(
    String^ columnName
)
member DateTime :
        columnName : string -> DateTime

Parameters

columnName
Type: SystemString

Return Value

Type: DateTime
Remarks
The DateTime must be in UK format, i.e. 'dd/mm/yyyy' or 'dd/mm/yyyy hh:mm:ss' or 'dd/mm/yyyy hh:mm:ss.sss'.
See Also

Reference

ExcelWorksheetData Class
DateTime Overload
Test.Framework Namespace


ExcelWorksheetData.DateTime Method (Int32, DateTime)

ExcelWorksheetDataDateTime Method (Int32, DateTime)
Returns the content of the nth cell cast to a DateTime. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime(
    int ordinal,
    DateTime emptyValue
)
Public Function DateTime (
    ordinal As Integer,
    emptyValue As DateTime
) As DateTime
public:
DateTime DateTime(
    int ordinal,
    DateTime emptyValue
)
member DateTime :
        ordinal : int *
        emptyValue : DateTime -> DateTime

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemDateTime

Return Value

Type: DateTime
Remarks
The DateTime must be in UK format, i.e. 'dd/mm/yyyy' or 'dd/mm/yyyy hh:mm:ss' or 'dd/mm/yyyy hh:mm:ss.sss'.
See Also

Reference

ExcelWorksheetData Class
DateTime Overload
Test.Framework Namespace


ExcelWorksheetData.DateTime Method (String, DateTime)

ExcelWorksheetDataDateTime Method (String, DateTime)
Returns the content of the cell at columnName cast to a DateTime. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime(
    string columnName,
    DateTime emptyValue
)
Public Function DateTime (
    columnName As String,
    emptyValue As DateTime
) As DateTime
public:
DateTime DateTime(
    String^ columnName,
    DateTime emptyValue
)
member DateTime :
        columnName : string *
        emptyValue : DateTime -> DateTime

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemDateTime

Return Value

Type: DateTime
Remarks
The DateTime must be in UK format, i.e. 'dd/mm/yyyy' or 'dd/mm/yyyy hh:mm:ss' or 'dd/mm/yyyy hh:mm:ss.sss'.
See Also

Reference

ExcelWorksheetData Class
DateTime Overload
Test.Framework Namespace


ExcelWorksheetData.Decimal Method

ExcelWorksheetDataDecimal Method
Overload List
 | Name | Description
Public method | Decimal(Int32) | Returns the content of the nth cell cast to a decimal.
Public method | Decimal(String) | Returns the content of the cell at columnName cast to a decimal.
Public method | Decimal(Int32, Decimal) | Returns the content of the nth cell cast to a decimal. If the cell is empty then 'emptyValue' is returned.
Public method | Decimal(String, Decimal) | Returns the content of the cell at columnName cast to a decimal. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Decimal Method (Int32)

ExcelWorksheetDataDecimal Method (Int32)
Returns the content of the nth cell cast to a decimal.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public decimal Decimal(
    int ordinal
)
Public Function Decimal (
    ordinal As Integer
) As Decimal
public:
Decimal Decimal(
    int ordinal
)
member Decimal :
        ordinal : int -> decimal

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Decimal
See Also

Reference

ExcelWorksheetData Class
Decimal Overload
Test.Framework Namespace


ExcelWorksheetData.Decimal Method (String)

ExcelWorksheetDataDecimal Method (String)
Returns the content of the cell at columnName cast to a decimal.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public decimal Decimal(
    string columnName
)
Public Function Decimal (
    columnName As String
) As Decimal
public:
Decimal Decimal(
    String^ columnName
)
member Decimal :
        columnName : string -> decimal

Parameters

columnName
Type: SystemString

Return Value

Type: Decimal
See Also

Reference

ExcelWorksheetData Class
Decimal Overload
Test.Framework Namespace


ExcelWorksheetData.Decimal Method (Int32, Decimal)

ExcelWorksheetDataDecimal Method (Int32, Decimal)
Returns the content of the nth cell cast to a decimal. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public decimal Decimal(
    int ordinal,
    decimal emptyValue
)
Public Function Decimal (
    ordinal As Integer,
    emptyValue As Decimal
) As Decimal
public:
Decimal Decimal(
    int ordinal,
    Decimal emptyValue
)
member Decimal :
        ordinal : int *
        emptyValue : decimal -> decimal

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemDecimal

Return Value

Type: Decimal
See Also

Reference

ExcelWorksheetData Class
Decimal Overload
Test.Framework Namespace


ExcelWorksheetData.Decimal Method (String, Decimal)

ExcelWorksheetDataDecimal Method (String, Decimal)
Returns the content of the cell at columnName cast to a decimal. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public decimal Decimal(
    string columnName,
    decimal emptyValue
)
Public Function Decimal (
    columnName As String,
    emptyValue As Decimal
) As Decimal
public:
Decimal Decimal(
    String^ columnName,
    Decimal emptyValue
)
member Decimal :
        columnName : string *
        emptyValue : decimal -> decimal

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemDecimal

Return Value

Type: Decimal
See Also

Reference

ExcelWorksheetData Class
Decimal Overload
Test.Framework Namespace


ExcelWorksheetData.Double Method

ExcelWorksheetDataDouble Method
Overload List
 | Name | Description
Public method | Double(Int32) | Returns the content of the nth cell cast to a double.
Public method | Double(String) | Returns the content of the cell at columnName cast to a double.
Public method | Double(Int32, Double) | Returns the content of the nth cell cast to a double. If the cell is empty then 'emptyValue' is returned.
Public method | Double(String, Double) | Returns the content of the cell at columnName cast to a double. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Double Method (Int32)

ExcelWorksheetDataDouble Method (Int32)
Returns the content of the nth cell cast to a double.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Double(
    int ordinal
)
Public Function Double (
    ordinal As Integer
) As Double
public:
double Double(
    int ordinal
)
member Double :
        ordinal : int -> float

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

ExcelWorksheetData Class
Double Overload
Test.Framework Namespace


ExcelWorksheetData.Double Method (String)

ExcelWorksheetDataDouble Method (String)
Returns the content of the cell at columnName cast to a double.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Double(
    string columnName
)
Public Function Double (
    columnName As String
) As Double
public:
double Double(
    String^ columnName
)
member Double :
        columnName : string -> float

Parameters

columnName
Type: SystemString

Return Value

Type: Double
See Also

Reference

ExcelWorksheetData Class
Double Overload
Test.Framework Namespace


ExcelWorksheetData.Double Method (Int32, Double)

ExcelWorksheetDataDouble Method (Int32, Double)
Returns the content of the nth cell cast to a double. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Double(
    int ordinal,
    double emptyValue
)
Public Function Double (
    ordinal As Integer,
    emptyValue As Double
) As Double
public:
double Double(
    int ordinal,
    double emptyValue
)
member Double :
        ordinal : int *
        emptyValue : float -> float

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

ExcelWorksheetData Class
Double Overload
Test.Framework Namespace


ExcelWorksheetData.Double Method (String, Double)

ExcelWorksheetDataDouble Method (String, Double)
Returns the content of the cell at columnName cast to a double. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Double(
    string columnName,
    double emptyValue
)
Public Function Double (
    columnName As String,
    emptyValue As Double
) As Double
public:
double Double(
    String^ columnName,
    double emptyValue
)
member Double :
        columnName : string *
        emptyValue : float -> float

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

ExcelWorksheetData Class
Double Overload
Test.Framework Namespace


ExcelWorksheetData.EString Method

ExcelWorksheetDataEString Method
Overload List
 | Name | Description
Public method | EString(Int32) | Returns the content of the nth cell as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.
Public method | EString(String) | Returns the content of the cell at columnName as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.EString Method (Int32)

ExcelWorksheetDataEString Method (Int32)
Returns the content of the nth cell as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EString(
    int ordinal
)
Public Function EString (
    ordinal As Integer
) As String
public:
String^ EString(
    int ordinal
)
member EString :
        ordinal : int -> string

Parameters

ordinal
Type: SystemInt32

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
EString Overload
Test.Framework Namespace
ExcelWorksheetDataString(Int32)


ExcelWorksheetData.EString Method (String)

ExcelWorksheetDataEString Method (String)
Returns the content of the cell at columnName as a string. If the cell content is "" then String.Empty is returned. If the cell is empty then null is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EString(
    string columnName
)
Public Function EString (
    columnName As String
) As String
public:
String^ EString(
    String^ columnName
)
member EString :
        columnName : string -> string

Parameters

columnName
Type: SystemString

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
EString Overload
Test.Framework Namespace
ExcelWorksheetDataString(String)


ExcelWorksheetData.Float Method

ExcelWorksheetDataFloat Method
Overload List
 | Name | Description
Public method | Float(Int32) | Returns the content of the nth cell cast to a float.
Public method | Float(String) | Returns the content of the cell at columnName cast to a float.
Public method | Float(Int32, Single) | Returns the content of the nth cell cast to a float. If the cell is empty then 'emptyValue' is returned.
Public method | Float(String, Single) | Returns the content of the cell at columnName cast to a float. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Float Method (Int32)

ExcelWorksheetDataFloat Method (Int32)
Returns the content of the nth cell cast to a float.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Float(
    int ordinal
)
Public Function Float (
    ordinal As Integer
) As Single
public:
float Float(
    int ordinal
)
member Float :
        ordinal : int -> float32

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Single
See Also

Reference

ExcelWorksheetData Class
Float Overload
Test.Framework Namespace


ExcelWorksheetData.Float Method (String)

ExcelWorksheetDataFloat Method (String)
Returns the content of the cell at columnName cast to a float.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Float(
    string columnName
)
Public Function Float (
    columnName As String
) As Single
public:
float Float(
    String^ columnName
)
member Float :
        columnName : string -> float32

Parameters

columnName
Type: SystemString

Return Value

Type: Single
See Also

Reference

ExcelWorksheetData Class
Float Overload
Test.Framework Namespace


ExcelWorksheetData.Float Method (Int32, Single)

ExcelWorksheetDataFloat Method (Int32, Single)
Returns the content of the nth cell cast to a float. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Float(
    int ordinal,
    float emptyValue
)
Public Function Float (
    ordinal As Integer,
    emptyValue As Single
) As Single
public:
float Float(
    int ordinal,
    float emptyValue
)
member Float :
        ordinal : int *
        emptyValue : float32 -> float32

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemSingle

Return Value

Type: Single
See Also

Reference

ExcelWorksheetData Class
Float Overload
Test.Framework Namespace


ExcelWorksheetData.Float Method (String, Single)

ExcelWorksheetDataFloat Method (String, Single)
Returns the content of the cell at columnName cast to a float. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Float(
    string columnName,
    float emptyValue
)
Public Function Float (
    columnName As String,
    emptyValue As Single
) As Single
public:
float Float(
    String^ columnName,
    float emptyValue
)
member Float :
        columnName : string *
        emptyValue : float32 -> float32

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemSingle

Return Value

Type: Single
See Also

Reference

ExcelWorksheetData Class
Float Overload
Test.Framework Namespace


ExcelWorksheetData.GetColumn Method

ExcelWorksheetDataGetColumn Method
Overload List
 | Name | Description
Public method | GetColumnT(Int32, T) | Returns the content of the column cast to type or a default value if the column has no value.
Public method | GetColumnT(String, T) | Returns the content of the column cast to type or a default value if the column has no value.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.GetColumn(T) Method (Int32, T)

ExcelWorksheetDataGetColumnT Method (Int32, T)
Returns the content of the column cast to type or a default value if the column has no value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T GetColumn<T>(
    int ordinal,
    T emptyValue
)

Public Function GetColumn(Of T) (
    ordinal As Integer,
    emptyValue As T
) As T
public:
generic<typename T>
T GetColumn(
    int ordinal,
    T emptyValue
)
member GetColumn :
        ordinal : int *
        emptyValue : 'T -> 'T

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

ExcelWorksheetData Class
GetColumn Overload
Test.Framework Namespace


ExcelWorksheetData.GetColumn(T) Method (String, T)

ExcelWorksheetDataGetColumnT Method (String, T)
Returns the content of the column cast to type or a default value if the column has no value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T GetColumn<T>(
    string columnName,
    T emptyValue
)

Public Function GetColumn(Of T) (
    columnName As String,
    emptyValue As T
) As T
public:
generic<typename T>
T GetColumn(
    String^ columnName,
    T emptyValue
)
member GetColumn :
        columnName : string *
        emptyValue : 'T -> 'T

Parameters

columnName
Type: SystemString
emptyValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

ExcelWorksheetData Class
GetColumn Overload
Test.Framework Namespace


ExcelWorksheetData.GetNullableColumn Method

ExcelWorksheetDataGetNullableColumn Method
Overload List
 | Name | Description
Public method | GetNullableColumnT(Int32) | Returns the content of the column cast to a nullable of the type or null if the column has no value.
Public method | GetNullableColumnT(String) | Returns the content of the column cast to a nullable of the type or null if the column has no value.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.GetNullableColumn(T) Method (Int32)

ExcelWorksheetDataGetNullableColumnT Method (Int32)
Returns the content of the column cast to a nullable of the type or null if the column has no value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<T> GetNullableColumn<T>(
    int ordinal
)
where T : struct, new()

Public Function GetNullableColumn(Of T As {Structure, New}) (
    ordinal As Integer
) As Nullable(Of T)
public:
generic<typename T>
where T : value class, gcnew()
Nullable<T> GetNullableColumn(
    int ordinal
)
member GetNullableColumn :
        ordinal : int -> Nullable<'T>  when 'T : struct, new()

Parameters

ordinal
Type: SystemInt32

Type Parameters

T

Return Value

Type: Nullable T
See Also

Reference

ExcelWorksheetData Class
GetNullableColumn Overload
Test.Framework Namespace


ExcelWorksheetData.GetNullableColumn(T) Method (String)

ExcelWorksheetDataGetNullableColumnT Method (String)
Returns the content of the column cast to a nullable of the type or null if the column has no value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<T> GetNullableColumn<T>(
    string columnName
)
where T : struct, new()

Public Function GetNullableColumn(Of T As {Structure, New}) (
    columnName As String
) As Nullable(Of T)
public:
generic<typename T>
where T : value class, gcnew()
Nullable<T> GetNullableColumn(
    String^ columnName
)
member GetNullableColumn :
        columnName : string -> Nullable<'T>  when 'T : struct, new()

Parameters

columnName
Type: SystemString

Type Parameters

T

Return Value

Type: Nullable T
See Also

Reference

ExcelWorksheetData Class
GetNullableColumn Overload
Test.Framework Namespace


ExcelWorksheetData.Int Method

ExcelWorksheetDataInt Method
Overload List
 | Name | Description
Public method | Int(Int32) | Returns the content of the nth cell cast to an int.
Public method | Int(String) | Returns the content of the cell at columnName cast to an int.
Public method | Int(Int32, Int32) | Returns the content of the nth cell cast to an int. If the cell is empty then 'emptyValue' is returned.
Public method | Int(String, Int32) | Returns the content of the cell at columnName cast to an int. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Int Method (Int32)

ExcelWorksheetDataInt Method (Int32)
Returns the content of the nth cell cast to an int.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Int(
    int ordinal
)
Public Function Int (
    ordinal As Integer
) As Integer
public:
int Int(
    int ordinal
)
member Int :
        ordinal : int -> int

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

ExcelWorksheetData Class
Int Overload
Test.Framework Namespace


ExcelWorksheetData.Int Method (String)

ExcelWorksheetDataInt Method (String)
Returns the content of the cell at columnName cast to an int.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Int(
    string columnName
)
Public Function Int (
    columnName As String
) As Integer
public:
int Int(
    String^ columnName
)
member Int :
        columnName : string -> int

Parameters

columnName
Type: SystemString

Return Value

Type: Int32
See Also

Reference

ExcelWorksheetData Class
Int Overload
Test.Framework Namespace


ExcelWorksheetData.Int Method (Int32, Int32)

ExcelWorksheetDataInt Method (Int32, Int32)
Returns the content of the nth cell cast to an int. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Int(
    int ordinal,
    int emptyValue
)
Public Function Int (
    ordinal As Integer,
    emptyValue As Integer
) As Integer
public:
int Int(
    int ordinal,
    int emptyValue
)
member Int :
        ordinal : int *
        emptyValue : int -> int

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

ExcelWorksheetData Class
Int Overload
Test.Framework Namespace


ExcelWorksheetData.Int Method (String, Int32)

ExcelWorksheetDataInt Method (String, Int32)
Returns the content of the cell at columnName cast to an int. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Int(
    string columnName,
    int emptyValue
)
Public Function Int (
    columnName As String,
    emptyValue As Integer
) As Integer
public:
int Int(
    String^ columnName,
    int emptyValue
)
member Int :
        columnName : string *
        emptyValue : int -> int

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

ExcelWorksheetData Class
Int Overload
Test.Framework Namespace


ExcelWorksheetData.Long Method

ExcelWorksheetDataLong Method
Overload List
 | Name | Description
Public method | Long(Int32) | Returns the content of the nth cell cast to a long.
Public method | Long(String) | Returns the content of the cell at columnName cast to a long.
Public method | Long(Int32, Int64) | Returns the content of the nth cell cast to a long. If the cell is empty then 'emptyValue' is returned.
Public method | Long(String, Int64) | Returns the content of the cell at columnName cast to a long. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Long Method (Int32)

ExcelWorksheetDataLong Method (Int32)
Returns the content of the nth cell cast to a long.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Long(
    int ordinal
)
Public Function Long (
    ordinal As Integer
) As Long
public:
long long Long(
    int ordinal
)
member Long :
        ordinal : int -> int64

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Int64
See Also

Reference

ExcelWorksheetData Class
Long Overload
Test.Framework Namespace


ExcelWorksheetData.Long Method (String)

ExcelWorksheetDataLong Method (String)
Returns the content of the cell at columnName cast to a long.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Long(
    string columnName
)
Public Function Long (
    columnName As String
) As Long
public:
long long Long(
    String^ columnName
)
member Long :
        columnName : string -> int64

Parameters

columnName
Type: SystemString

Return Value

Type: Int64
See Also

Reference

ExcelWorksheetData Class
Long Overload
Test.Framework Namespace


ExcelWorksheetData.Long Method (Int32, Int64)

ExcelWorksheetDataLong Method (Int32, Int64)
Returns the content of the nth cell cast to a long. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Long(
    int ordinal,
    long emptyValue
)
Public Function Long (
    ordinal As Integer,
    emptyValue As Long
) As Long
public:
long long Long(
    int ordinal,
    long long emptyValue
)
member Long :
        ordinal : int *
        emptyValue : int64 -> int64

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemInt64

Return Value

Type: Int64
See Also

Reference

ExcelWorksheetData Class
Long Overload
Test.Framework Namespace


ExcelWorksheetData.Long Method (String, Int64)

ExcelWorksheetDataLong Method (String, Int64)
Returns the content of the cell at columnName cast to a long. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Long(
    string columnName,
    long emptyValue
)
Public Function Long (
    columnName As String,
    emptyValue As Long
) As Long
public:
long long Long(
    String^ columnName,
    long long emptyValue
)
member Long :
        columnName : string *
        emptyValue : int64 -> int64

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemInt64

Return Value

Type: Int64
See Also

Reference

ExcelWorksheetData Class
Long Overload
Test.Framework Namespace


ExcelWorksheetData.NBool Method

ExcelWorksheetDataNBool Method
Overload List
 | Name | Description
Public method | NBool(Int32) | Returns the content of the nth cell cast to a nullable bool.
Public method | NBool(String) | Returns the content of the cell at columnName cast to a nullable bool.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NBool Method (Int32)

ExcelWorksheetDataNBool Method (Int32)
Returns the content of the nth cell cast to a nullable bool.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> NBool(
    int ordinal
)
Public Function NBool (
    ordinal As Integer
) As Nullable(Of Boolean)
public:
Nullable<bool> NBool(
    int ordinal
)
member NBool :
        ordinal : int -> Nullable<bool>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Boolean
See Also

Reference

ExcelWorksheetData Class
NBool Overload
Test.Framework Namespace


ExcelWorksheetData.NBool Method (String)

ExcelWorksheetDataNBool Method (String)
Returns the content of the cell at columnName cast to a nullable bool.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> NBool(
    string columnName
)
Public Function NBool (
    columnName As String
) As Nullable(Of Boolean)
public:
Nullable<bool> NBool(
    String^ columnName
)
member NBool :
        columnName : string -> Nullable<bool>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Boolean
See Also

Reference

ExcelWorksheetData Class
NBool Overload
Test.Framework Namespace


ExcelWorksheetData.NByte Method

ExcelWorksheetDataNByte Method
Overload List
 | Name | Description
Public method | NByte(Byte) | Returns the content of the nth cell cast to a nullable byte.
Public method | NByte(String) | Returns the content of the cell at columnName cast to a nullable byte.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NByte Method (Byte)

ExcelWorksheetDataNByte Method (Byte)
Returns the content of the nth cell cast to a nullable byte.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> NByte(
    byte ordinal
)
Public Function NByte (
    ordinal As Byte
) As Nullable(Of Byte)
public:
Nullable<unsigned char> NByte(
    unsigned char ordinal
)
member NByte :
        ordinal : byte -> Nullable<byte>

Parameters

ordinal
Type: SystemByte

Return Value

Type: Nullable Byte
See Also

Reference

ExcelWorksheetData Class
NByte Overload
Test.Framework Namespace


ExcelWorksheetData.NByte Method (String)

ExcelWorksheetDataNByte Method (String)
Returns the content of the cell at columnName cast to a nullable byte.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> NByte(
    string columnName
)
Public Function NByte (
    columnName As String
) As Nullable(Of Byte)
public:
Nullable<unsigned char> NByte(
    String^ columnName
)
member NByte :
        columnName : string -> Nullable<byte>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Byte
See Also

Reference

ExcelWorksheetData Class
NByte Overload
Test.Framework Namespace


ExcelWorksheetData.NChar Method

ExcelWorksheetDataNChar Method
Overload List
 | Name | Description
Public method | NChar(Int32) | Returns the content of the nth cell cast to a nullable char.
Public method | NChar(String) | Returns the content of the cell at columnName cast to a nullable char.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NChar Method (Int32)

ExcelWorksheetDataNChar Method (Int32)
Returns the content of the nth cell cast to a nullable char.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<char> NChar(
    int ordinal
)
Public Function NChar (
    ordinal As Integer
) As Nullable(Of Char)
public:
Nullable<wchar_t> NChar(
    int ordinal
)
member NChar :
        ordinal : int -> Nullable<char>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Char
See Also

Reference

ExcelWorksheetData Class
NChar Overload
Test.Framework Namespace


ExcelWorksheetData.NChar Method (String)

ExcelWorksheetDataNChar Method (String)
Returns the content of the cell at columnName cast to a nullable char.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<char> NChar(
    string columnName
)
Public Function NChar (
    columnName As String
) As Nullable(Of Char)
public:
Nullable<wchar_t> NChar(
    String^ columnName
)
member NChar :
        columnName : string -> Nullable<char>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Char
See Also

Reference

ExcelWorksheetData Class
NChar Overload
Test.Framework Namespace


ExcelWorksheetData.NDateTime Method

ExcelWorksheetDataNDateTime Method
Overload List
 | Name | Description
Public method | NDateTime(Int32) | Returns the content of the nth cell cast to a nullable DateTime.
Public method | NDateTime(String) | Returns the content of the cell at columnName cast to a nullable DateTime.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NDateTime Method (Int32)

ExcelWorksheetDataNDateTime Method (Int32)
Returns the content of the nth cell cast to a nullable DateTime.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> NDateTime(
    int ordinal
)
Public Function NDateTime (
    ordinal As Integer
) As Nullable(Of DateTime)
public:
Nullable<DateTime> NDateTime(
    int ordinal
)
member NDateTime :
        ordinal : int -> Nullable<DateTime>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable DateTime
Remarks
The DateTime must be in UK format, i.e. 'dd/mm/yyyy' or 'dd/mm/yyyy hh:mm:ss' or 'dd/mm/yyyy hh:mm:ss.sss'.
See Also

Reference

ExcelWorksheetData Class
NDateTime Overload
Test.Framework Namespace


ExcelWorksheetData.NDateTime Method (String)

ExcelWorksheetDataNDateTime Method (String)
Returns the content of the cell at columnName cast to a nullable DateTime.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> NDateTime(
    string columnName
)
Public Function NDateTime (
    columnName As String
) As Nullable(Of DateTime)
public:
Nullable<DateTime> NDateTime(
    String^ columnName
)
member NDateTime :
        columnName : string -> Nullable<DateTime>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable DateTime
Remarks
The DateTime must be in UK format, i.e. 'dd/mm/yyyy' or 'dd/mm/yyyy hh:mm:ss' or 'dd/mm/yyyy hh:mm:ss.sss'.
See Also

Reference

ExcelWorksheetData Class
NDateTime Overload
Test.Framework Namespace


ExcelWorksheetData.NDecimal Method

ExcelWorksheetDataNDecimal Method
Overload List
 | Name | Description
Public method | NDecimal(Int32) | Returns the content of the nth cell cast to a nullable decimal.
Public method | NDecimal(String) | Returns the content of the cell at columnName cast to a nullable decimal.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NDecimal Method (Int32)

ExcelWorksheetDataNDecimal Method (Int32)
Returns the content of the nth cell cast to a nullable decimal.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<decimal> NDecimal(
    int ordinal
)
Public Function NDecimal (
    ordinal As Integer
) As Nullable(Of Decimal)
public:
Nullable<Decimal> NDecimal(
    int ordinal
)
member NDecimal :
        ordinal : int -> Nullable<decimal>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Decimal
See Also

Reference

ExcelWorksheetData Class
NDecimal Overload
Test.Framework Namespace


ExcelWorksheetData.NDecimal Method (String)

ExcelWorksheetDataNDecimal Method (String)
Returns the content of the cell at columnName cast to a nullable decimal.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<decimal> NDecimal(
    string columnName
)
Public Function NDecimal (
    columnName As String
) As Nullable(Of Decimal)
public:
Nullable<Decimal> NDecimal(
    String^ columnName
)
member NDecimal :
        columnName : string -> Nullable<decimal>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Decimal
See Also

Reference

ExcelWorksheetData Class
NDecimal Overload
Test.Framework Namespace


ExcelWorksheetData.NDouble Method

ExcelWorksheetDataNDouble Method
Overload List
 | Name | Description
Public method | NDouble(Int32) | Returns the content of the nth cell cast to a nullable double.
Public method | NDouble(String) | Returns the content of the cell at columnName cast to a nullable double.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NDouble Method (Int32)

ExcelWorksheetDataNDouble Method (Int32)
Returns the content of the nth cell cast to a nullable double.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> NDouble(
    int ordinal
)
Public Function NDouble (
    ordinal As Integer
) As Nullable(Of Double)
public:
Nullable<double> NDouble(
    int ordinal
)
member NDouble :
        ordinal : int -> Nullable<float>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Double
See Also

Reference

ExcelWorksheetData Class
NDouble Overload
Test.Framework Namespace


ExcelWorksheetData.NDouble Method (String)

ExcelWorksheetDataNDouble Method (String)
Returns the content of the cell at columnName cast to a nullable double.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> NDouble(
    string columnName
)
Public Function NDouble (
    columnName As String
) As Nullable(Of Double)
public:
Nullable<double> NDouble(
    String^ columnName
)
member NDouble :
        columnName : string -> Nullable<float>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Double
See Also

Reference

ExcelWorksheetData Class
NDouble Overload
Test.Framework Namespace


ExcelWorksheetData.NFloat Method

ExcelWorksheetDataNFloat Method
Overload List
 | Name | Description
Public method | NFloat(Int32) | Returns the content of the nth cell cast to a nullable float.
Public method | NFloat(String) | Returns the content of the cell at columnName cast to a nullable float.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NFloat Method (Int32)

ExcelWorksheetDataNFloat Method (Int32)
Returns the content of the nth cell cast to a nullable float.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> NFloat(
    int ordinal
)
Public Function NFloat (
    ordinal As Integer
) As Nullable(Of Single)
public:
Nullable<float> NFloat(
    int ordinal
)
member NFloat :
        ordinal : int -> Nullable<float32>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Single
See Also

Reference

ExcelWorksheetData Class
NFloat Overload
Test.Framework Namespace


ExcelWorksheetData.NFloat Method (String)

ExcelWorksheetDataNFloat Method (String)
Returns the content of the cell at columnName cast to a nullable float.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> NFloat(
    string columnName
)
Public Function NFloat (
    columnName As String
) As Nullable(Of Single)
public:
Nullable<float> NFloat(
    String^ columnName
)
member NFloat :
        columnName : string -> Nullable<float32>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Single
See Also

Reference

ExcelWorksheetData Class
NFloat Overload
Test.Framework Namespace


ExcelWorksheetData.NInt Method

ExcelWorksheetDataNInt Method
Overload List
 | Name | Description
Public method | NInt(Int32) | Returns the content of the nth cell cast to a nullable int.
Public method | NInt(String) | Returns the content of the cell at columnName cast to a nullable int.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NInt Method (Int32)

ExcelWorksheetDataNInt Method (Int32)
Returns the content of the nth cell cast to a nullable int.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NInt(
    int ordinal
)
Public Function NInt (
    ordinal As Integer
) As Nullable(Of Integer)
public:
Nullable<int> NInt(
    int ordinal
)
member NInt :
        ordinal : int -> Nullable<int>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Int32
See Also

Reference

ExcelWorksheetData Class
NInt Overload
Test.Framework Namespace


ExcelWorksheetData.NInt Method (String)

ExcelWorksheetDataNInt Method (String)
Returns the content of the cell at columnName cast to a nullable int.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NInt(
    string columnName
)
Public Function NInt (
    columnName As String
) As Nullable(Of Integer)
public:
Nullable<int> NInt(
    String^ columnName
)
member NInt :
        columnName : string -> Nullable<int>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Int32
See Also

Reference

ExcelWorksheetData Class
NInt Overload
Test.Framework Namespace


ExcelWorksheetData.NLong Method

ExcelWorksheetDataNLong Method
Overload List
 | Name | Description
Public method | NLong(Int32) | Returns the content of the nth cell cast to a nullable long.
Public method | NLong(String) | Returns the content of the cell at columnName cast to a nullable long.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NLong Method (Int32)

ExcelWorksheetDataNLong Method (Int32)
Returns the content of the nth cell cast to a nullable long.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> NLong(
    int ordinal
)
Public Function NLong (
    ordinal As Integer
) As Nullable(Of Long)
public:
Nullable<long long> NLong(
    int ordinal
)
member NLong :
        ordinal : int -> Nullable<int64>

Parameters

ordinal
Type: SystemInt32

Return Value

Type: Nullable Int64
See Also

Reference

ExcelWorksheetData Class
NLong Overload
Test.Framework Namespace


ExcelWorksheetData.NLong Method (String)

ExcelWorksheetDataNLong Method (String)
Returns the content of the cell at columnName cast to a nullable long.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> NLong(
    string columnName
)
Public Function NLong (
    columnName As String
) As Nullable(Of Long)
public:
Nullable<long long> NLong(
    String^ columnName
)
member NLong :
        columnName : string -> Nullable<int64>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Int64
See Also

Reference

ExcelWorksheetData Class
NLong Overload
Test.Framework Namespace


ExcelWorksheetData.NShort Method

ExcelWorksheetDataNShort Method
Overload List
 | Name | Description
Public method | NShort(Int16) | Returns the content of the nth cell cast to a nullable short.
Public method | NShort(String) | Returns the content of the cell at columnName cast to a nullable short.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.NShort Method (Int16)

ExcelWorksheetDataNShort Method (Int16)
Returns the content of the nth cell cast to a nullable short.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> NShort(
    short ordinal
)
Public Function NShort (
    ordinal As Short
) As Nullable(Of Short)
public:
Nullable<short> NShort(
    short ordinal
)
member NShort :
        ordinal : int16 -> Nullable<int16>

Parameters

ordinal
Type: SystemInt16

Return Value

Type: Nullable Int16
See Also

Reference

ExcelWorksheetData Class
NShort Overload
Test.Framework Namespace


ExcelWorksheetData.NShort Method (String)

ExcelWorksheetDataNShort Method (String)
Returns the content of the cell at columnName cast to a nullable short.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> NShort(
    string columnName
)
Public Function NShort (
    columnName As String
) As Nullable(Of Short)
public:
Nullable<short> NShort(
    String^ columnName
)
member NShort :
        columnName : string -> Nullable<int16>

Parameters

columnName
Type: SystemString

Return Value

Type: Nullable Int16
See Also

Reference

ExcelWorksheetData Class
NShort Overload
Test.Framework Namespace


ExcelWorksheetData.ParseEnum Method

ExcelWorksheetDataParseEnum Method
Overload List
 | Name | Description
Public method | ParseEnumT(Int32) | Returns the content of the nth cell cast to an enum.
Public method | ParseEnumT(String) | Returns the content of the cell at columnName cast to an enum.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.ParseEnum(T) Method (Int32)

ExcelWorksheetDataParseEnumT Method (Int32)
Returns the content of the nth cell cast to an enum.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T ParseEnum<T>(
    int ordinal
)

Public Function ParseEnum(Of T) (
    ordinal As Integer
) As T
public:
generic<typename T>
T ParseEnum(
    int ordinal
)
member ParseEnum :
        ordinal : int -> 'T

Parameters

ordinal
Type: SystemInt32

Type Parameters

T

Return Value

Type: T
See Also

Reference

ExcelWorksheetData Class
ParseEnum Overload
Test.Framework Namespace


ExcelWorksheetData.ParseEnum(T) Method (String)

ExcelWorksheetDataParseEnumT Method (String)
Returns the content of the cell at columnName cast to an enum.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T ParseEnum<T>(
    string columnName
)

Public Function ParseEnum(Of T) (
    columnName As String
) As T
public:
generic<typename T>
T ParseEnum(
    String^ columnName
)
member ParseEnum :
        columnName : string -> 'T

Parameters

columnName
Type: SystemString

Type Parameters

T

Return Value

Type: T
See Also

Reference

ExcelWorksheetData Class
ParseEnum Overload
Test.Framework Namespace


ExcelWorksheetData.Short Method

ExcelWorksheetDataShort Method
Overload List
 | Name | Description
Public method | Short(Int16) | Returns the content of the nth cell cast to an short.
Public method | Short(String) | Returns the content of the cell at columnName cast to an short.
Public method | Short(Int16, Int16) | Returns the content of the nth cell cast to an short. If the cell is empty then 'emptyValue' is returned.
Public method | Short(String, Int16) | Returns the content of the cell at columnName cast to an short. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.Short Method (Int16)

ExcelWorksheetDataShort Method (Int16)
Returns the content of the nth cell cast to an short.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short Short(
    short ordinal
)
Public Function Short (
    ordinal As Short
) As Short
public:
short Short(
    short ordinal
)
member Short :
        ordinal : int16 -> int16

Parameters

ordinal
Type: SystemInt16

Return Value

Type: Int16
See Also

Reference

ExcelWorksheetData Class
Short Overload
Test.Framework Namespace


ExcelWorksheetData.Short Method (String)

ExcelWorksheetDataShort Method (String)
Returns the content of the cell at columnName cast to an short.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short Short(
    string columnName
)
Public Function Short (
    columnName As String
) As Short
public:
short Short(
    String^ columnName
)
member Short :
        columnName : string -> int16

Parameters

columnName
Type: SystemString

Return Value

Type: Int16
See Also

Reference

ExcelWorksheetData Class
Short Overload
Test.Framework Namespace


ExcelWorksheetData.Short Method (Int16, Int16)

ExcelWorksheetDataShort Method (Int16, Int16)
Returns the content of the nth cell cast to an short. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short Short(
    short ordinal,
    short emptyValue
)
Public Function Short (
    ordinal As Short,
    emptyValue As Short
) As Short
public:
short Short(
    short ordinal,
    short emptyValue
)
member Short :
        ordinal : int16 *
        emptyValue : int16 -> int16

Parameters

ordinal
Type: SystemInt16
emptyValue
Type: SystemInt16

Return Value

Type: Int16
See Also

Reference

ExcelWorksheetData Class
Short Overload
Test.Framework Namespace


ExcelWorksheetData.Short Method (String, Int16)

ExcelWorksheetDataShort Method (String, Int16)
Returns the content of the cell at columnName cast to an short. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short Short(
    string columnName,
    short emptyValue
)
Public Function Short (
    columnName As String,
    emptyValue As Short
) As Short
public:
short Short(
    String^ columnName,
    short emptyValue
)
member Short :
        columnName : string *
        emptyValue : int16 -> int16

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemInt16

Return Value

Type: Int16
See Also

Reference

ExcelWorksheetData Class
Short Overload
Test.Framework Namespace


ExcelWorksheetData.String Method

ExcelWorksheetDataString Method
Overload List
 | Name | Description
Public method | String(Int32) | Returns the string content of the nth cell.
Public method | String(String) | Returns the string content of the cell at columnName.
Public method | String(Int32, String) | Returns the string content of the nth cell. If the cell is empty then 'emptyValue' is returned.
Public method | String(String, String) | Returns the string content of the cell at columnName. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.String Method (Int32)

ExcelWorksheetDataString Method (Int32)
Returns the string content of the nth cell.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string String(
    int ordinal
)
Public Function String (
    ordinal As Integer
) As String
public:
String^ String(
    int ordinal
)
member String :
        ordinal : int -> string

Parameters

ordinal
Type: SystemInt32

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
String Overload
Test.Framework Namespace
ExcelWorksheetDataEString(Int32)


ExcelWorksheetData.String Method (String)

ExcelWorksheetDataString Method (String)
Returns the string content of the cell at columnName.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string String(
    string columnName
)
Public Function String (
    columnName As String
) As String
public:
String^ String(
    String^ columnName
)
member String :
        columnName : string -> string

Parameters

columnName
Type: SystemString

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
String Overload
Test.Framework Namespace
ExcelWorksheetDataEString(String)


ExcelWorksheetData.String Method (Int32, String)

ExcelWorksheetDataString Method (Int32, String)
Returns the string content of the nth cell. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string String(
    int ordinal,
    string emptyValue
)
Public Function String (
    ordinal As Integer,
    emptyValue As String
) As String
public:
String^ String(
    int ordinal,
    String^ emptyValue
)
member String :
        ordinal : int *
        emptyValue : string -> string

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemString

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
String Overload
Test.Framework Namespace


ExcelWorksheetData.String Method (String, String)

ExcelWorksheetDataString Method (String, String)
Returns the string content of the cell at columnName. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string String(
    string columnName,
    string emptyValue
)
Public Function String (
    columnName As String,
    emptyValue As String
) As String
public:
String^ String(
    String^ columnName,
    String^ emptyValue
)
member String :
        columnName : string *
        emptyValue : string -> string

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemString

Return Value

Type: String
See Also

Reference

ExcelWorksheetData Class
String Overload
Test.Framework Namespace
ExcelWorksheetDataEString(String)


ExcelWorksheetData.UInt Method

ExcelWorksheetDataUInt Method
Overload List
 | Name | Description
Public method | UInt(Int32) | Returns the content of the nth cell cast to a uint.
Public method | UInt(String) | Returns the content of the cell at columnName cast to a uint.
Public method | UInt(Int32, UInt32) | Returns the content of the nth cell cast to a uint. If the cell is empty then 'emptyValue' is returned.
Public method | UInt(String, UInt32) | Returns the content of the cell at columnName cast to a uint. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.UInt Method (Int32)

ExcelWorksheetDataUInt Method (Int32)
Returns the content of the nth cell cast to a uint.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint UInt(
    int ordinal
)
Public Function UInt (
    ordinal As Integer
) As UInteger
public:
unsigned int UInt(
    int ordinal
)
member UInt :
        ordinal : int -> uint32

Parameters

ordinal
Type: SystemInt32

Return Value

Type: UInt32
See Also

Reference

ExcelWorksheetData Class
UInt Overload
Test.Framework Namespace


ExcelWorksheetData.UInt Method (String)

ExcelWorksheetDataUInt Method (String)
Returns the content of the cell at columnName cast to a uint.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint UInt(
    string columnName
)
Public Function UInt (
    columnName As String
) As UInteger
public:
unsigned int UInt(
    String^ columnName
)
member UInt :
        columnName : string -> uint32

Parameters

columnName
Type: SystemString

Return Value

Type: UInt32
See Also

Reference

ExcelWorksheetData Class
UInt Overload
Test.Framework Namespace


ExcelWorksheetData.UInt Method (Int32, UInt32)

ExcelWorksheetDataUInt Method (Int32, UInt32)
Returns the content of the nth cell cast to a uint. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint UInt(
    int ordinal,
    uint emptyValue
)
Public Function UInt (
    ordinal As Integer,
    emptyValue As UInteger
) As UInteger
public:
unsigned int UInt(
    int ordinal,
    unsigned int emptyValue
)
member UInt :
        ordinal : int *
        emptyValue : uint32 -> uint32

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemUInt32

Return Value

Type: UInt32
See Also

Reference

ExcelWorksheetData Class
UInt Overload
Test.Framework Namespace


ExcelWorksheetData.UInt Method (String, UInt32)

ExcelWorksheetDataUInt Method (String, UInt32)
Returns the content of the cell at columnName cast to a uint. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint UInt(
    string columnName,
    uint emptyValue
)
Public Function UInt (
    columnName As String,
    emptyValue As UInteger
) As UInteger
public:
unsigned int UInt(
    String^ columnName,
    unsigned int emptyValue
)
member UInt :
        columnName : string *
        emptyValue : uint32 -> uint32

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemUInt32

Return Value

Type: UInt32
See Also

Reference

ExcelWorksheetData Class
UInt Overload
Test.Framework Namespace


ExcelWorksheetData.ULong Method

ExcelWorksheetDataULong Method
Overload List
 | Name | Description
Public method | ULong(Int32) | Returns the content of the nth cell cast to a ulong.
Public method | ULong(String) | Returns the content of the cell at columnName cast to a ulong.
Public method | ULong(Int32, UInt64) | Returns the content of the nth cell cast to a ulong. If the cell is empty then 'emptyValue' is returned.
Public method | ULong(String, UInt64) | Returns the content of the cell at columnName cast to a ulong. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.ULong Method (Int32)

ExcelWorksheetDataULong Method (Int32)
Returns the content of the nth cell cast to a ulong.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ULong(
    int ordinal
)
Public Function ULong (
    ordinal As Integer
) As ULong
public:
unsigned long long ULong(
    int ordinal
)
member ULong :
        ordinal : int -> uint64

Parameters

ordinal
Type: SystemInt32

Return Value

Type: UInt64
See Also

Reference

ExcelWorksheetData Class
ULong Overload
Test.Framework Namespace


ExcelWorksheetData.ULong Method (String)

ExcelWorksheetDataULong Method (String)
Returns the content of the cell at columnName cast to a ulong.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ULong(
    string columnName
)
Public Function ULong (
    columnName As String
) As ULong
public:
unsigned long long ULong(
    String^ columnName
)
member ULong :
        columnName : string -> uint64

Parameters

columnName
Type: SystemString

Return Value

Type: UInt64
See Also

Reference

ExcelWorksheetData Class
ULong Overload
Test.Framework Namespace


ExcelWorksheetData.ULong Method (Int32, UInt64)

ExcelWorksheetDataULong Method (Int32, UInt64)
Returns the content of the nth cell cast to a ulong. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ULong(
    int ordinal,
    ulong emptyValue
)
Public Function ULong (
    ordinal As Integer,
    emptyValue As ULong
) As ULong
public:
unsigned long long ULong(
    int ordinal,
    unsigned long long emptyValue
)
member ULong :
        ordinal : int *
        emptyValue : uint64 -> uint64

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemUInt64

Return Value

Type: UInt64
See Also

Reference

ExcelWorksheetData Class
ULong Overload
Test.Framework Namespace


ExcelWorksheetData.ULong Method (String, UInt64)

ExcelWorksheetDataULong Method (String, UInt64)
Returns the content of the cell at columnName cast to a ulong. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ULong(
    string columnName,
    ulong emptyValue
)
Public Function ULong (
    columnName As String,
    emptyValue As ULong
) As ULong
public:
unsigned long long ULong(
    String^ columnName,
    unsigned long long emptyValue
)
member ULong :
        columnName : string *
        emptyValue : uint64 -> uint64

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemUInt64

Return Value

Type: UInt64
See Also

Reference

ExcelWorksheetData Class
ULong Overload
Test.Framework Namespace


ExcelWorksheetData.UShort Method

ExcelWorksheetDataUShort Method
Overload List
 | Name | Description
Public method | UShort(Int32) | Returns the content of the nth cell cast to a ushort.
Public method | UShort(String) | Returns the content of the cell at columnName cast to a ushort.
Public method | UShort(Int32, UInt16) | Returns the content of the nth cell cast to a ushort. If the cell is empty then 'emptyValue' is returned.
Public method | UShort(String, UInt16) | Returns the content of the cell at columnName cast to a ushort. If the cell is empty then 'emptyValue' is returned.
Top
See Also

Reference

ExcelWorksheetData Class
Test.Framework Namespace


ExcelWorksheetData.UShort Method (Int32)

ExcelWorksheetDataUShort Method (Int32)
Returns the content of the nth cell cast to a ushort.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UShort(
    int ordinal
)
Public Function UShort (
    ordinal As Integer
) As UShort
public:
unsigned short UShort(
    int ordinal
)
member UShort :
        ordinal : int -> uint16

Parameters

ordinal
Type: SystemInt32

Return Value

Type: UInt16
See Also

Reference

ExcelWorksheetData Class
UShort Overload
Test.Framework Namespace


ExcelWorksheetData.UShort Method (String)

ExcelWorksheetDataUShort Method (String)
Returns the content of the cell at columnName cast to a ushort.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UShort(
    string columnName
)
Public Function UShort (
    columnName As String
) As UShort
public:
unsigned short UShort(
    String^ columnName
)
member UShort :
        columnName : string -> uint16

Parameters

columnName
Type: SystemString

Return Value

Type: UInt16
See Also

Reference

ExcelWorksheetData Class
UShort Overload
Test.Framework Namespace


ExcelWorksheetData.UShort Method (Int32, UInt16)

ExcelWorksheetDataUShort Method (Int32, UInt16)
Returns the content of the nth cell cast to a ushort. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UShort(
    int ordinal,
    ushort emptyValue
)
Public Function UShort (
    ordinal As Integer,
    emptyValue As UShort
) As UShort
public:
unsigned short UShort(
    int ordinal,
    unsigned short emptyValue
)
member UShort :
        ordinal : int *
        emptyValue : uint16 -> uint16

Parameters

ordinal
Type: SystemInt32
emptyValue
Type: SystemUInt16

Return Value

Type: UInt16
See Also

Reference

ExcelWorksheetData Class
UShort Overload
Test.Framework Namespace


ExcelWorksheetData.UShort Method (String, UInt16)

ExcelWorksheetDataUShort Method (String, UInt16)
Returns the content of the cell at columnName cast to a ushort. If the cell is empty then 'emptyValue' is returned.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort UShort(
    string columnName,
    ushort emptyValue
)
Public Function UShort (
    columnName As String,
    emptyValue As UShort
) As UShort
public:
unsigned short UShort(
    String^ columnName,
    unsigned short emptyValue
)
member UShort :
        columnName : string *
        emptyValue : uint16 -> uint16

Parameters

columnName
Type: SystemString
emptyValue
Type: SystemUInt16

Return Value

Type: UInt16
See Also

Reference

ExcelWorksheetData Class
UShort Overload
Test.Framework Namespace


FeedHelper Class

FeedHelper Class
A set of helper methods to set up a feed manager with a bunch of feeds that each have a listener.
Inheritance Hierarchy
SystemObject
Test.FrameworkFeedHelper

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FeedHelper
Public NotInheritable Class FeedHelper
public ref class FeedHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FeedHelper =  class end

The FeedHelper type exposes the following members.

Methods
Name | Description
AddFeeds(ListMockIFeed, ListMockIListener, Int32) | Populates the IFeed and IListener lists with mocks for a mock IFeedManager.
AddFeeds(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Int32) | Populates the IFeed and IBaseStationAircraftList lists with mocks for a mock IFeedManager.
AddMergedFeeds | Populates the IFeed and IListener lists with mocks for a mock IFeedManager.
CreateMockFeedManager(ListMockIFeed, ListMockIListener, Boolean, Int32) | Creates a mock IFeedManager singleton with a functioning Feeds property and methods, and populates the IFeed and IListener lists with mocks.
CreateMockFeedManager(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Boolean, Int32) | Creates a mock IFeedManager singleton with a functioning Receivers property and methods, and populates the receiver pathway. and IBaseStationAircraftList lists with mocks.
GetFeeds | Returns a list of IFeed objects from a list of mock IFeed objects.
RemoveFeed(ListMockIFeed, ListMockIListener, Int32) | Removes IFeed and IListener mocks for a mock IFeedManager.
RemoveFeed(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Int32) | Removes IFeed and IBaseStationAircraftList mocks for a mock IFeedManager.
SetupTakeSnapshot | A helper method to set up the IBaseStationAircraftList TakeSnaphot method for known values of out longs.
Top
See Also

Reference

Test.Framework Namespace


FeedHelper Methods

FeedHelper Methods

The FeedHelper type exposes the following members.

Methods
Name | Description
AddFeeds(ListMockIFeed, ListMockIListener, Int32) | Populates the IFeed and IListener lists with mocks for a mock IFeedManager.
AddFeeds(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Int32) | Populates the IFeed and IBaseStationAircraftList lists with mocks for a mock IFeedManager.
AddMergedFeeds | Populates the IFeed and IListener lists with mocks for a mock IFeedManager.
CreateMockFeedManager(ListMockIFeed, ListMockIListener, Boolean, Int32) | Creates a mock IFeedManager singleton with a functioning Feeds property and methods, and populates the IFeed and IListener lists with mocks.
CreateMockFeedManager(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Boolean, Int32) | Creates a mock IFeedManager singleton with a functioning Receivers property and methods, and populates the receiver pathway. and IBaseStationAircraftList lists with mocks.
GetFeeds | Returns a list of IFeed objects from a list of mock IFeed objects.
RemoveFeed(ListMockIFeed, ListMockIListener, Int32) | Removes IFeed and IListener mocks for a mock IFeedManager.
RemoveFeed(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Int32) | Removes IFeed and IBaseStationAircraftList mocks for a mock IFeedManager.
SetupTakeSnapshot | A helper method to set up the IBaseStationAircraftList TakeSnaphot method for known values of out longs.
Top
See Also

Reference

FeedHelper Class
Test.Framework Namespace


FeedHelper.AddFeeds Method

FeedHelperAddFeeds Method
Overload List
Name | Description
AddFeeds(ListMockIFeed, ListMockIListener, Int32) | Populates the IFeed and IListener lists with mocks for a mock IFeedManager.
AddFeeds(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Int32) | Populates the IFeed and IBaseStationAircraftList lists with mocks for a mock IFeedManager.
Top
See Also

Reference

FeedHelper Class
Test.Framework Namespace


FeedHelper.AddFeeds Method (List(Mock`1(IFeed)), List(Mock`1(IListener)), Int32[])

FeedHelperAddFeeds Method (ListMock`1IFeed, ListMock`1IListener, Int32)
Populates the IFeed and IListener lists with mocks for a mock IFeedManager.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddFeeds(
    List<Mock<IFeed>> feeds,
    List<Mock<IListener>> listeners,
    params int[] feedIds
)
Public Shared Sub AddFeeds (
    feeds As List(Of Mock(Of IFeed)),
    listeners As List(Of Mock(Of IListener)),
    ParamArray feedIds As Integer()
)
public:
static void AddFeeds(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IListener^>^>^ listeners,
    ... array<int>^ feedIds
)
static member AddFeeds :
        feeds : List<Mock<IFeed>> *
        listeners : List<Mock<IListener>> *
        feedIds : int[] -> unit

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
listeners
Type: System.Collections.GenericList MockIListener
feedIds
Type: SystemInt32
See Also

Reference

FeedHelper Class
AddFeeds Overload
Test.Framework Namespace


FeedHelper.AddFeeds Method (List(Mock`1(IFeed)), List(Mock`1(IBaseStationAircraftList)), List(List(IAircraft)), Int32[])

FeedHelperAddFeeds Method (ListMock`1IFeed, ListMock`1IBaseStationAircraftList, ListListIAircraft, Int32)
Populates the IFeed and IBaseStationAircraftList lists with mocks for a mock IFeedManager.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddFeeds(
    List<Mock<IFeed>> feeds,
    List<Mock<IBaseStationAircraftList>> baseStationAircraftLists,
    List<List<IAircraft>> aircraftLists,
    params int[] feedIds
)
Public Shared Sub AddFeeds (
    feeds As List(Of Mock(Of IFeed)),
    baseStationAircraftLists As List(Of Mock(Of IBaseStationAircraftList)),
    aircraftLists As List(Of List(Of IAircraft)),
    ParamArray feedIds As Integer()
)
public:
static void AddFeeds(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IBaseStationAircraftList^>^>^ baseStationAircraftLists,
    List<List<IAircraft^>^>^ aircraftLists,
    ... array<int>^ feedIds
)
static member AddFeeds :
        feeds : List<Mock<IFeed>> *
        baseStationAircraftLists : List<Mock<IBaseStationAircraftList>> *
        aircraftLists : List<List<IAircraft>> *
        feedIds : int[] -> unit

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
baseStationAircraftLists
Type: System.Collections.GenericList MockIBaseStationAircraftList
aircraftLists
Type: System.Collections.GenericList List IAircraft
feedIds
Type: SystemInt32
See Also

Reference

FeedHelper Class
AddFeeds Overload
Test.Framework Namespace


FeedHelper.AddMergedFeeds Method

FeedHelperAddMergedFeeds Method
Populates the IFeed and IListener lists with mocks for a mock IFeedManager.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddMergedFeeds(
    List<Mock<IFeed>> feeds,
    List<Mock<IMergedFeedListener>> listeners,
    params int[] feedIds
)
Public Shared Sub AddMergedFeeds (
    feeds As List(Of Mock(Of IFeed)),
    listeners As List(Of Mock(Of IMergedFeedListener)),
    ParamArray feedIds As Integer()
)
public:
static void AddMergedFeeds(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IMergedFeedListener^>^>^ listeners,
    ... array<int>^ feedIds
)
static member AddMergedFeeds :
        feeds : List<Mock<IFeed>> *
        listeners : List<Mock<IMergedFeedListener>> *
        feedIds : int[] -> unit

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
listeners
Type: System.Collections.GenericList MockIMergedFeedListener
feedIds
Type: SystemInt32
See Also

Reference

FeedHelper Class
Test.Framework Namespace


FeedHelper.CreateMockFeedManager Method

FeedHelperCreateMockFeedManager Method
Overload List
Name | Description
CreateMockFeedManager(ListMockIFeed, ListMockIListener, Boolean, Int32) | Creates a mock IFeedManager singleton with a functioning Feeds property and methods, and populates the IFeed and IListener lists with mocks.
CreateMockFeedManager(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Boolean, Int32) | Creates a mock IFeedManager singleton with a functioning Receivers property and methods, and populates the receiver pathway. and IBaseStationAircraftList lists with mocks.
Top
See Also

Reference

FeedHelper Class
Test.Framework Namespace


FeedHelper.CreateMockFeedManager Method (List(Mock`1(IFeed)), List(Mock`1(IListener)), Boolean, Int32[])

FeedHelperCreateMockFeedManager Method (ListMock`1IFeed, ListMock`1IListener, Boolean, Int32)
Creates a mock IFeedManager singleton with a functioning Feeds property and methods, and populates the IFeed and IListener lists with mocks.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Mock<IFeedManager> CreateMockFeedManager(
    List<Mock<IFeed>> feeds,
    List<Mock<IListener>> listeners,
    bool useVisibleFeeds,
    params int[] feedIds
)
Public Shared Function CreateMockFeedManager (
    feeds As List(Of Mock(Of IFeed)),
    listeners As List(Of Mock(Of IListener)),
    useVisibleFeeds As Boolean,
    ParamArray feedIds As Integer()
) As Mock(Of IFeedManager)
public:
static Mock<IFeedManager^>^ CreateMockFeedManager(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IListener^>^>^ listeners,
    bool useVisibleFeeds,
    ... array<int>^ feedIds
)
static member CreateMockFeedManager :
        feeds : List<Mock<IFeed>> *
        listeners : List<Mock<IListener>> *
        useVisibleFeeds : bool *
        feedIds : int[] -> Mock<IFeedManager>

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
listeners
Type: System.Collections.GenericList MockIListener
useVisibleFeeds
Type: SystemBoolean
feedIds
Type: SystemInt32

Return Value

Type: MockIFeedManager
See Also

Reference

FeedHelper Class
CreateMockFeedManager Overload
Test.Framework Namespace


FeedHelper.CreateMockFeedManager Method (List(Mock`1(IFeed)), List(Mock`1(IBaseStationAircraftList)), List(List(IAircraft)), Boolean, Int32[])

FeedHelperCreateMockFeedManager Method (ListMock`1IFeed, ListMock`1IBaseStationAircraftList, ListListIAircraft, Boolean, Int32)
Creates a mock IFeedManager singleton with a functioning Receivers property and methods, and populates the receiver pathway. and IBaseStationAircraftList lists with mocks.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Mock<IFeedManager> CreateMockFeedManager(
    List<Mock<IFeed>> feeds,
    List<Mock<IBaseStationAircraftList>> baseStationAircraftLists,
    List<List<IAircraft>> aircraftLists,
    bool useVisibleFeeds,
    params int[] feedIds
)
Public Shared Function CreateMockFeedManager (
    feeds As List(Of Mock(Of IFeed)),
    baseStationAircraftLists As List(Of Mock(Of IBaseStationAircraftList)),
    aircraftLists As List(Of List(Of IAircraft)),
    useVisibleFeeds As Boolean,
    ParamArray feedIds As Integer()
) As Mock(Of IFeedManager)
public:
static Mock<IFeedManager^>^ CreateMockFeedManager(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IBaseStationAircraftList^>^>^ baseStationAircraftLists,
    List<List<IAircraft^>^>^ aircraftLists,
    bool useVisibleFeeds,
    ... array<int>^ feedIds
)
static member CreateMockFeedManager :
        feeds : List<Mock<IFeed>> *
        baseStationAircraftLists : List<Mock<IBaseStationAircraftList>> *
        aircraftLists : List<List<IAircraft>> *
        useVisibleFeeds : bool *
        feedIds : int[] -> Mock<IFeedManager>

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
baseStationAircraftLists
Type: System.Collections.GenericList MockIBaseStationAircraftList
aircraftLists
Type: System.Collections.GenericList List IAircraft
useVisibleFeeds
Type: SystemBoolean
feedIds
Type: SystemInt32

Return Value

Type: MockIFeedManager
See Also

Reference

FeedHelper Class
CreateMockFeedManager Overload
Test.Framework Namespace


FeedHelper.GetFeeds Method

FeedHelperGetFeeds Method
Returns a list of IFeed objects from a list of mock IFeed objects.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<IFeed> GetFeeds(
    List<Mock<IFeed>> feeds
)
Public Shared Function GetFeeds (
    feeds As List(Of Mock(Of IFeed))
) As List(Of IFeed)
public:
static List<IFeed^>^ GetFeeds(
    List<Mock<IFeed^>^>^ feeds
)
static member GetFeeds :
        feeds : List<Mock<IFeed>> -> List<IFeed>

Parameters

feeds
Type: System.Collections.GenericList MockIFeed

Return Value

Type: List IFeed
See Also

Reference

FeedHelper Class
Test.Framework Namespace


FeedHelper.RemoveFeed Method

FeedHelperRemoveFeed Method
Overload List
Name | Description
RemoveFeed(ListMockIFeed, ListMockIListener, Int32) | Removes IFeed and IListener mocks for a mock IFeedManager.
RemoveFeed(ListMockIFeed, ListMockIBaseStationAircraftList, ListListIAircraft, Int32) | Removes IFeed and IBaseStationAircraftList mocks for a mock IFeedManager.
Top
See Also

Reference

FeedHelper Class
Test.Framework Namespace


FeedHelper.RemoveFeed Method (List(Mock`1(IFeed)), List(Mock`1(IListener)), Int32[])

FeedHelperRemoveFeed Method (ListMock`1IFeed, ListMock`1IListener, Int32)
Removes IFeed and IListener mocks for a mock IFeedManager.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveFeed(
    List<Mock<IFeed>> feeds,
    List<Mock<IListener>> listeners,
    params int[] feedIds
)
Public Shared Sub RemoveFeed (
    feeds As List(Of Mock(Of IFeed)),
    listeners As List(Of Mock(Of IListener)),
    ParamArray feedIds As Integer()
)
public:
static void RemoveFeed(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IListener^>^>^ listeners,
    ... array<int>^ feedIds
)
static member RemoveFeed :
        feeds : List<Mock<IFeed>> *
        listeners : List<Mock<IListener>> *
        feedIds : int[] -> unit

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
listeners
Type: System.Collections.GenericList MockIListener
feedIds
Type: SystemInt32
See Also

Reference

FeedHelper Class
RemoveFeed Overload
Test.Framework Namespace


FeedHelper.RemoveFeed Method (List(Mock`1(IFeed)), List(Mock`1(IBaseStationAircraftList)), List(List(IAircraft)), Int32[])

FeedHelperRemoveFeed Method (ListMock`1IFeed, ListMock`1IBaseStationAircraftList, ListListIAircraft, Int32)
Removes IFeed and IBaseStationAircraftList mocks for a mock IFeedManager.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveFeed(
    List<Mock<IFeed>> feeds,
    List<Mock<IBaseStationAircraftList>> baseStationAircraftLists,
    List<List<IAircraft>> aircraftLists,
    params int[] feedIds
)
Public Shared Sub RemoveFeed (
    feeds As List(Of Mock(Of IFeed)),
    baseStationAircraftLists As List(Of Mock(Of IBaseStationAircraftList)),
    aircraftLists As List(Of List(Of IAircraft)),
    ParamArray feedIds As Integer()
)
public:
static void RemoveFeed(
    List<Mock<IFeed^>^>^ feeds,
    List<Mock<IBaseStationAircraftList^>^>^ baseStationAircraftLists,
    List<List<IAircraft^>^>^ aircraftLists,
    ... array<int>^ feedIds
)
static member RemoveFeed :
        feeds : List<Mock<IFeed>> *
        baseStationAircraftLists : List<Mock<IBaseStationAircraftList>> *
        aircraftLists : List<List<IAircraft>> *
        feedIds : int[] -> unit

Parameters

feeds
Type: System.Collections.GenericList MockIFeed
baseStationAircraftLists
Type: System.Collections.GenericList MockIBaseStationAircraftList
aircraftLists
Type: System.Collections.GenericList List IAircraft
feedIds
Type: SystemInt32
See Also

Reference

FeedHelper Class
RemoveFeed Overload
Test.Framework Namespace


FeedHelper.SetupTakeSnapshot Method

FeedHelperSetupTakeSnapshot Method
A helper method to set up the IBaseStationAircraftList TakeSnaphot method for known values of out longs.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetupTakeSnapshot(
    List<Mock<IBaseStationAircraftList>> baseStationAircraftLists,
    List<List<IAircraft>> aircraftLists,
    int index,
    long takeSnapshotOutValue1,
    long takeSnapshotOutValue2
)
Public Shared Sub SetupTakeSnapshot (
    baseStationAircraftLists As List(Of Mock(Of IBaseStationAircraftList)),
    aircraftLists As List(Of List(Of IAircraft)),
    index As Integer,
    takeSnapshotOutValue1 As Long,
    takeSnapshotOutValue2 As Long
)
public:
static void SetupTakeSnapshot(
    List<Mock<IBaseStationAircraftList^>^>^ baseStationAircraftLists,
    List<List<IAircraft^>^>^ aircraftLists,
    int index,
    long long takeSnapshotOutValue1,
    long long takeSnapshotOutValue2
)
static member SetupTakeSnapshot :
        baseStationAircraftLists : List<Mock<IBaseStationAircraftList>> *
        aircraftLists : List<List<IAircraft>> *
        index : int *
        takeSnapshotOutValue1 : int64 *
        takeSnapshotOutValue2 : int64 -> unit

Parameters

baseStationAircraftLists
Type: System.Collections.GenericList MockIBaseStationAircraftList
aircraftLists
Type: System.Collections.GenericList List IAircraft
index
Type: SystemInt32
takeSnapshotOutValue1
Type: SystemInt64
takeSnapshotOutValue2
Type: SystemInt64
See Also

Reference

FeedHelper Class
Test.Framework Namespace


RequestReceivedEventArgsHelper Class

RequestReceivedEventArgsHelper Class
A static class that helps with setting up RequestReceivedEventArgs objects for different conditions.
Inheritance Hierarchy
SystemObject
Test.FrameworkRequestReceivedEventArgsHelper

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RequestReceivedEventArgsHelper
Public NotInheritable Class RequestReceivedEventArgsHelper
public ref class RequestReceivedEventArgsHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RequestReceivedEventArgsHelper =  class end

The RequestReceivedEventArgsHelper type exposes the following members.

Methods
Name | Description
Create | Creates a RequestReceivedEventArgs, attaches the mock request and response objects passed across and sets a few key properties.
SetAndroidUserAgent | Sets a mock IRequest object up with a user agent string from an Android mobile.
SetIPadUserAgent | Sets a mock IRequest object up with a user agent string from an iPad.
SetIPhoneUserAgent | Sets a mock IRequest object up with a user agent string from an iPhone.
SetIPodUserAgent | Sets a mock IRequest object up with a user agent string from an iPod.
Top
See Also

Reference

Test.Framework Namespace


RequestReceivedEventArgsHelper Methods

RequestReceivedEventArgsHelper Methods

The RequestReceivedEventArgsHelper type exposes the following members.

Methods
Name | Description
Create | Creates a RequestReceivedEventArgs, attaches the mock request and response objects passed across and sets a few key properties.
SetAndroidUserAgent | Sets a mock IRequest object up with a user agent string from an Android mobile.
SetIPadUserAgent | Sets a mock IRequest object up with a user agent string from an iPad.
SetIPhoneUserAgent | Sets a mock IRequest object up with a user agent string from an iPhone.
SetIPodUserAgent | Sets a mock IRequest object up with a user agent string from an iPod.
Top
See Also

Reference

RequestReceivedEventArgsHelper Class
Test.Framework Namespace


RequestReceivedEventArgsHelper.Create Method

RequestReceivedEventArgsHelperCreate Method
Creates a RequestReceivedEventArgs, attaches the mock request and response objects passed across and sets a few key properties.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RequestReceivedEventArgs Create(
    Mock<IRequest> request,
    Mock<IResponse> response,
    string pathAndFile,
    bool internetClient = false
)
Public Shared Function Create (
    request As Mock(Of IRequest),
    response As Mock(Of IResponse),
    pathAndFile As String,
    Optional internetClient As Boolean = false
) As RequestReceivedEventArgs
public:
static RequestReceivedEventArgs^ Create(
    Mock<IRequest^>^ request,
    Mock<IResponse^>^ response,
    String^ pathAndFile,
    bool internetClient = false
)
static member Create :
        request : Mock<IRequest> *
        response : Mock<IResponse> *
        pathAndFile : string *
        ?internetClient : bool
(* Defaults:
        let _internetClient = defaultArg internetClient false
*)
-> RequestReceivedEventArgs

Parameters

request
Type: MockIRequest
response
Type: MockIResponse
pathAndFile
Type: SystemString
internetClient (Optional)
Type: SystemBoolean

Return Value

Type: RequestReceivedEventArgs
See Also

Reference

RequestReceivedEventArgsHelper Class
Test.Framework Namespace


RequestReceivedEventArgsHelper.SetAndroidUserAgent Method

RequestReceivedEventArgsHelperSetAndroidUserAgent Method
Sets a mock IRequest object up with a user agent string from an Android mobile.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetAndroidUserAgent(
    Mock<IRequest> request
)
Public Shared Sub SetAndroidUserAgent (
    request As Mock(Of IRequest)
)
public:
static void SetAndroidUserAgent(
    Mock<IRequest^>^ request
)
static member SetAndroidUserAgent :
        request : Mock<IRequest> -> unit

Parameters

request
Type: MockIRequest
See Also

Reference

RequestReceivedEventArgsHelper Class
Test.Framework Namespace


RequestReceivedEventArgsHelper.SetIPadUserAgent Method

RequestReceivedEventArgsHelperSetIPadUserAgent Method
Sets a mock IRequest object up with a user agent string from an iPad.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetIPadUserAgent(
    Mock<IRequest> request
)
Public Shared Sub SetIPadUserAgent (
    request As Mock(Of IRequest)
)
public:
static void SetIPadUserAgent(
    Mock<IRequest^>^ request
)
static member SetIPadUserAgent :
        request : Mock<IRequest> -> unit

Parameters

request
Type: MockIRequest
See Also

Reference

RequestReceivedEventArgsHelper Class
Test.Framework Namespace


RequestReceivedEventArgsHelper.SetIPhoneUserAgent Method

RequestReceivedEventArgsHelperSetIPhoneUserAgent Method
Sets a mock IRequest object up with a user agent string from an iPhone.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetIPhoneUserAgent(
    Mock<IRequest> request
)
Public Shared Sub SetIPhoneUserAgent (
    request As Mock(Of IRequest)
)
public:
static void SetIPhoneUserAgent(
    Mock<IRequest^>^ request
)
static member SetIPhoneUserAgent :
        request : Mock<IRequest> -> unit

Parameters

request
Type: MockIRequest
See Also

Reference

RequestReceivedEventArgsHelper Class
Test.Framework Namespace


RequestReceivedEventArgsHelper.SetIPodUserAgent Method

RequestReceivedEventArgsHelperSetIPodUserAgent Method
Sets a mock IRequest object up with a user agent string from an iPod.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetIPodUserAgent(
    Mock<IRequest> request
)
Public Shared Sub SetIPodUserAgent (
    request As Mock(Of IRequest)
)
public:
static void SetIPodUserAgent(
    Mock<IRequest^>^ request
)
static member SetIPodUserAgent :
        request : Mock<IRequest> -> unit

Parameters

request
Type: MockIRequest
See Also

Reference

RequestReceivedEventArgsHelper Class
Test.Framework Namespace


SpreadsheetFieldValue Class

SpreadsheetFieldValue Class
Helps to look up the value associated with a field within a spreadsheet.
Inheritance Hierarchy
SystemObject
Test.FrameworkSpreadsheetFieldValue

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpreadsheetFieldValue
Public Class SpreadsheetFieldValue
public ref class SpreadsheetFieldValue
type SpreadsheetFieldValue =  class end

The SpreadsheetFieldValue type exposes the following members.

Constructors
 | Name | Description
Public method | SpreadsheetFieldValue | Creates a new object.
Top
Properties
 | Name | Description
Public property | FieldPrefix | Gets or sets the prefix for field name columns - defaults to 'Field'.
Public property | MaxFields | Gets or sets the number of columns to search across for field names and associated values.
Public property | ValuePrefix | Gets or sets the prefix for value columns - defaults to 'Value'.
Public property | Worksheet | Gets or sets the worksheet that field names and values will be extracted from.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByte | Returns the value for the field passed across or null if the field could not be found.
Public method | GetBytes | Returns the value for the field passed across or null if the field could not be found.
Public method | GetEnumT | Returns the value for the field passed across or null if the field could not be found.
Public method | GetEString | Returns the value for the field passed across or null if the field could not be found.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNBool | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNByte | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNDouble | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNFloat | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNInt | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNLong | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNShort | Returns the value for the field passed across or null if the field could not be found.
Public method | GetString | Returns the value for the field passed across or null if the field could not be found.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
For some data-driven tests it can be useful to have a number of columns in the spreadsheet named 'Field1', 'Field2' ... 'Fieldn' which contain the name of a field and an associated set of columns 'Value1', 'Value2' ... 'Valuen' which contain the expected value associated with the field. This class wraps up the code necessary to find an associated value for a given field name.
See Also

Reference

Test.Framework Namespace


SpreadsheetFieldValue Constructor

SpreadsheetFieldValue Constructor
Creates a new object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpreadsheetFieldValue(
    ExcelWorksheetData worksheet,
    int maxFields,
    string fieldPrefix = "Field",
    string valuePrefix = "Value"
)
Public Sub New (
    worksheet As ExcelWorksheetData,
    maxFields As Integer,
    Optional fieldPrefix As String = "Field",
    Optional valuePrefix As String = "Value"
)
public:
SpreadsheetFieldValue(
    ExcelWorksheetData^ worksheet,
    int maxFields,
    String^ fieldPrefix = L"Field",
    String^ valuePrefix = L"Value"
)
new :
        worksheet : ExcelWorksheetData *
        maxFields : int *
        ?fieldPrefix : string *
        ?valuePrefix : string
(* Defaults:
        let _fieldPrefix = defaultArg fieldPrefix "Field"
        let _valuePrefix = defaultArg valuePrefix "Value"
*)
-> SpreadsheetFieldValue

Parameters

worksheet
Type: Test.FrameworkExcelWorksheetData
maxFields
Type: SystemInt32
fieldPrefix (Optional)
Type: SystemString
valuePrefix (Optional)
Type: SystemString
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue Properties

SpreadsheetFieldValue Properties

The SpreadsheetFieldValue type exposes the following members.

Properties
 | Name | Description
Public property | FieldPrefix | Gets or sets the prefix for field name columns - defaults to 'Field'.
Public property | MaxFields | Gets or sets the number of columns to search across for field names and associated values.
Public property | ValuePrefix | Gets or sets the prefix for value columns - defaults to 'Value'.
Public property | Worksheet | Gets or sets the worksheet that field names and values will be extracted from.
Top
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.FieldPrefix Property

SpreadsheetFieldValueFieldPrefix Property
Gets or sets the prefix for field name columns - defaults to 'Field'.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FieldPrefix { get; set; }
Public Property FieldPrefix As String
    Get
    Set
public:
property String^ FieldPrefix {
    String^ get ();
    void set (String^ value);
}
member FieldPrefix : string with get, set

Property Value

Type: String
Remarks
The class searches across all columns whose name starts with this prefix for field names.
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.MaxFields Property

SpreadsheetFieldValueMaxFields Property
Gets or sets the number of columns to search across for field names and associated values.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaxFields { get; set; }
Public Property MaxFields As Integer
    Get
    Set
public:
property int MaxFields {
    int get ();
    void set (int value);
}
member MaxFields : int with get, set

Property Value

Type: Int32
Remarks
The code searches for field names in columns whose name starts with FieldPrefix followed by a digit. The digit starts at 1 and increments up to the MaxFields value, inclusive. So if MaxFields is 3, FieldPrefix is 'Field' and ValuePrefix is 'Value' then the columns Field1, Field2 and Field3 are searched for field names and the associated values are expected to be found in one of Value1, Value2 or Value3.
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.ValuePrefix Property

SpreadsheetFieldValueValuePrefix Property
Gets or sets the prefix for value columns - defaults to 'Value'.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValuePrefix { get; set; }
Public Property ValuePrefix As String
    Get
    Set
public:
property String^ ValuePrefix {
    String^ get ();
    void set (String^ value);
}
member ValuePrefix : string with get, set

Property Value

Type: String
Remarks
The class searches across all columns whose name starts with this prefix for values associated with a field.
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.Worksheet Property

SpreadsheetFieldValueWorksheet Property
Gets or sets the worksheet that field names and values will be extracted from.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExcelWorksheetData Worksheet { get; set; }
Public Property Worksheet As ExcelWorksheetData
    Get
    Set
public:
property ExcelWorksheetData^ Worksheet {
    ExcelWorksheetData^ get ();
    void set (ExcelWorksheetData^ value);
}
member Worksheet : ExcelWorksheetData with get, set

Property Value

Type: ExcelWorksheetData
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue Methods

SpreadsheetFieldValue Methods

The SpreadsheetFieldValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByte | Returns the value for the field passed across or null if the field could not be found.
Public method | GetBytes | Returns the value for the field passed across or null if the field could not be found.
Public method | GetEnumT | Returns the value for the field passed across or null if the field could not be found.
Public method | GetEString | Returns the value for the field passed across or null if the field could not be found.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNBool | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNByte | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNDouble | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNFloat | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNInt | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNLong | Returns the value for the field passed across or null if the field could not be found.
Public method | GetNShort | Returns the value for the field passed across or null if the field could not be found.
Public method | GetString | Returns the value for the field passed across or null if the field could not be found.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetByte Method

SpreadsheetFieldValueGetByte Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte GetByte(
    string fieldName,
    bool isHex = false
)
Public Function GetByte (
    fieldName As String,
    Optional isHex As Boolean = false
) As Byte
public:
unsigned char GetByte(
    String^ fieldName,
    bool isHex = false
)
member GetByte :
        fieldName : string *
        ?isHex : bool
(* Defaults:
        let _isHex = defaultArg isHex false
*)
-> byte

Parameters

fieldName
Type: SystemString
isHex (Optional)
Type: SystemBoolean
True if the cell contains a hex value rather than decimal.

Return Value

Type: Byte
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetBytes Method

SpreadsheetFieldValueGetBytes Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] GetBytes(
    string fieldName
)
Public Function GetBytes (
    fieldName As String
) As Byte()
public:
array<unsigned char>^ GetBytes(
    String^ fieldName
)
member GetBytes :
        fieldName : string -> byte[]

Parameters

fieldName
Type: SystemString

Return Value

Type: Byte
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetEnum(T) Method

SpreadsheetFieldValueGetEnumT Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<T> GetEnum<T>(
    string fieldName
)
where T : struct, new()

Public Function GetEnum(Of T As {Structure, New}) (
    fieldName As String
) As Nullable(Of T)
public:
generic<typename T>
where T : value class, gcnew()
Nullable<T> GetEnum(
    String^ fieldName
)
member GetEnum :
        fieldName : string -> Nullable<'T>  when 'T : struct, new()

Parameters

fieldName
Type: SystemString

Type Parameters

T
The type of the enumeration to cast the result to. Passing a non-enum type here will cause an exception to be thrown when the value cell has non-null content.

Return Value

Type: Nullable T
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetEString Method

SpreadsheetFieldValueGetEString Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetEString(
    string fieldName
)
Public Function GetEString (
    fieldName As String
) As String
public:
String^ GetEString(
    String^ fieldName
)
member GetEString :
        fieldName : string -> string

Parameters

fieldName
Type: SystemString

Return Value

Type: String
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNBool Method

SpreadsheetFieldValueGetNBool Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> GetNBool(
    string fieldName
)
Public Function GetNBool (
    fieldName As String
) As Nullable(Of Boolean)
public:
Nullable<bool> GetNBool(
    String^ fieldName
)
member GetNBool :
        fieldName : string -> Nullable<bool>

Parameters

fieldName
Type: SystemString

Return Value

Type: Nullable Boolean
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNByte Method

SpreadsheetFieldValueGetNByte Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> GetNByte(
    string fieldName,
    bool isHex = false
)
Public Function GetNByte (
    fieldName As String,
    Optional isHex As Boolean = false
) As Nullable(Of Byte)
public:
Nullable<unsigned char> GetNByte(
    String^ fieldName,
    bool isHex = false
)
member GetNByte :
        fieldName : string *
        ?isHex : bool
(* Defaults:
        let _isHex = defaultArg isHex false
*)
-> Nullable<byte>

Parameters

fieldName
Type: SystemString
isHex (Optional)
Type: SystemBoolean
True if the cell contains a hex value rather than decimal.

Return Value

Type: Nullable Byte
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNDouble Method

SpreadsheetFieldValueGetNDouble Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> GetNDouble(
    string fieldName
)
Public Function GetNDouble (
    fieldName As String
) As Nullable(Of Double)
public:
Nullable<double> GetNDouble(
    String^ fieldName
)
member GetNDouble :
        fieldName : string -> Nullable<float>

Parameters

fieldName
Type: SystemString

Return Value

Type: Nullable Double
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNFloat Method

SpreadsheetFieldValueGetNFloat Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> GetNFloat(
    string fieldName
)
Public Function GetNFloat (
    fieldName As String
) As Nullable(Of Single)
public:
Nullable<float> GetNFloat(
    String^ fieldName
)
member GetNFloat :
        fieldName : string -> Nullable<float32>

Parameters

fieldName
Type: SystemString

Return Value

Type: Nullable Single
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNInt Method

SpreadsheetFieldValueGetNInt Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> GetNInt(
    string fieldName,
    bool isHex = false
)
Public Function GetNInt (
    fieldName As String,
    Optional isHex As Boolean = false
) As Nullable(Of Integer)
public:
Nullable<int> GetNInt(
    String^ fieldName,
    bool isHex = false
)
member GetNInt :
        fieldName : string *
        ?isHex : bool
(* Defaults:
        let _isHex = defaultArg isHex false
*)
-> Nullable<int>

Parameters

fieldName
Type: SystemString
isHex (Optional)
Type: SystemBoolean
True if the cell contains a hex value rather than decimal.

Return Value

Type: Nullable Int32
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNLong Method

SpreadsheetFieldValueGetNLong Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> GetNLong(
    string fieldName,
    bool isHex = false
)
Public Function GetNLong (
    fieldName As String,
    Optional isHex As Boolean = false
) As Nullable(Of Long)
public:
Nullable<long long> GetNLong(
    String^ fieldName,
    bool isHex = false
)
member GetNLong :
        fieldName : string *
        ?isHex : bool
(* Defaults:
        let _isHex = defaultArg isHex false
*)
-> Nullable<int64>

Parameters

fieldName
Type: SystemString
isHex (Optional)
Type: SystemBoolean
True if the cell contains a hex value rather than decimal.

Return Value

Type: Nullable Int64
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetNShort Method

SpreadsheetFieldValueGetNShort Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> GetNShort(
    string fieldName,
    bool isHex = false
)
Public Function GetNShort (
    fieldName As String,
    Optional isHex As Boolean = false
) As Nullable(Of Short)
public:
Nullable<short> GetNShort(
    String^ fieldName,
    bool isHex = false
)
member GetNShort :
        fieldName : string *
        ?isHex : bool
(* Defaults:
        let _isHex = defaultArg isHex false
*)
-> Nullable<int16>

Parameters

fieldName
Type: SystemString
isHex (Optional)
Type: SystemBoolean
True if the cell contains a hex value rather than decimal.

Return Value

Type: Nullable Int16
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


SpreadsheetFieldValue.GetString Method

SpreadsheetFieldValueGetString Method
Returns the value for the field passed across or null if the field could not be found.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetString(
    string fieldName
)
Public Function GetString (
    fieldName As String
) As String
public:
String^ GetString(
    String^ fieldName
)
member GetString :
        fieldName : string -> string

Parameters

fieldName
Type: SystemString

Return Value

Type: String
See Also

Reference

SpreadsheetFieldValue Class
Test.Framework Namespace


StatisticsHelper Class

StatisticsHelper Class
A static class that can help when testing Statistics objects.
Inheritance Hierarchy
SystemObject
Test.FrameworkStatisticsHelper

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StatisticsHelper
Public NotInheritable Class StatisticsHelper
public ref class StatisticsHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StatisticsHelper =  class end

The StatisticsHelper type exposes the following members.

Methods
Name | Description
CreateLockableStatistics | Creates a mock IStatistics object.
Top
See Also

Reference

Test.Framework Namespace


StatisticsHelper Methods

StatisticsHelper Methods

The StatisticsHelper type exposes the following members.

Methods
Name | Description
CreateLockableStatistics | Creates a mock IStatistics object.
Top
See Also

Reference

StatisticsHelper Class
Test.Framework Namespace


StatisticsHelper.CreateLockableStatistics Method

StatisticsHelperCreateLockableStatistics Method
Creates a mock IStatistics object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Mock<IStatistics> CreateLockableStatistics()
Public Shared Function CreateLockableStatistics As Mock(Of IStatistics)
public:
static Mock<IStatistics^>^ CreateLockableStatistics()
static member CreateLockableStatistics : unit -> Mock<IStatistics>

Return Value

Type: MockIStatistics
See Also

Reference

StatisticsHelper Class
Test.Framework Namespace


TestUtilities Class

TestUtilities Class
A collection of static methods that cover common aspects of testing objects.
Inheritance Hierarchy
SystemObject
Test.FrameworkTestUtilities

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TestUtilities
Public NotInheritable Class TestUtilities
public ref class TestUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TestUtilities =  class end

The TestUtilities type exposes the following members.

Methods
Name | Description
AssertIsAttribute | Throws an assertion if the type passed across is not sealed and is not based on Attribute.
AssertIsException | Throws an assertion if the type passed across is not an exception type, does not have the correct constructors or is not serialisable.
AssignPropertyValue | Assigns a constant dummy value to a property on an object.
ChangeType | Converts a value from one type to another, as per the standard ChangeType(Object, Type), except that this version can cope with the conversion of NullableT types.
ConvertBitStringToBytes | Converts a string of binary digits (with optional whitespace) to a collection of bytes.
ConvertToBitString(Int32, Int32) | Converts a value to a binary representation of a given length.
ConvertToBitString(Int64, Int32) | Converts a value to a binary representation of a given length.
CreateMockImplementationT | Creates a Moq stub for an object and registers it with the class factory. The instance returned by the method is the one the code under test will always receive when it asks for an instantiation of the interface.
CreateMockInstanceT | Creates a Moq stub for an object but does not register it with the class factory.
CreateMockSingletonT | Creates a Moq mock object for a type that implements ISingletonT.
SequenceEqualT | Returns true if both sequences are null or if the LINQ SequenceEqual method returns true for them, otherwise returns false.
TestProperty(Object, String, Boolean) | Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.
TestProperty(Object, String, Object, Object) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestProperty(Object, String, Object, Object, Boolean) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestPropertyT(T, ExpressionFuncT, Object, Boolean) | Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.
TestPropertyT(T, ExpressionFuncT, Object, Object, Object) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestPropertyT(T, ExpressionFuncT, Object, Object, Object, Boolean) | Asserts that the property passed across starts at a given value and can be changed to another value.
TestSimpleEquals | Tests that an object whose Equals method tests all of its public properties is behaving correctly. Only works with objects that have a simple constructor.
Top
See Also

Reference

Test.Framework Namespace


TestUtilities Methods

TestUtilities Methods

The TestUtilities type exposes the following members.

Methods
Name | Description
AssertIsAttribute | Throws an assertion if the type passed across is not sealed and is not based on Attribute.
AssertIsException | Throws an assertion if the type passed across is not an exception type, does not have the correct constructors or is not serialisable.
AssignPropertyValue | Assigns a constant dummy value to a property on an object.
ChangeType | Converts a value from one type to another, as per the standard ChangeType(Object, Type), except that this version can cope with the conversion of NullableT types.
ConvertBitStringToBytes | Converts a string of binary digits (with optional whitespace) to a collection of bytes.
ConvertToBitString(Int32, Int32) | Converts a value to a binary representation of a given length.
ConvertToBitString(Int64, Int32) | Converts a value to a binary representation of a given length.
CreateMockImplementationT | Creates a Moq stub for an object and registers it with the class factory. The instance returned by the method is the one the code under test will always receive when it asks for an instantiation of the interface.
CreateMockInstanceT | Creates a Moq stub for an object but does not register it with the class factory.
CreateMockSingletonT | Creates a Moq mock object for a type that implements ISingletonT.
SequenceEqualT | Returns true if both sequences are null or if the LINQ SequenceEqual method returns true for them, otherwise returns false.
TestProperty(Object, String, Boolean) | Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.
TestProperty(Object, String, Object, Object) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestProperty(Object, String, Object, Object, Boolean) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestPropertyT(T, ExpressionFuncT, Object, Boolean) | Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.
TestPropertyT(T, ExpressionFuncT, Object, Object, Object) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestPropertyT(T, ExpressionFuncT, Object, Object, Object, Boolean) | Asserts that the property passed across starts at a given value and can be changed to another value.
TestSimpleEquals | Tests that an object whose Equals method tests all of its public properties is behaving correctly. Only works with objects that have a simple constructor.
Top
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.AssertIsAttribute Method

TestUtilitiesAssertIsAttribute Method
Throws an assertion if the type passed across is not sealed and is not based on Attribute.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AssertIsAttribute(
    Type attributeType
)
Public Shared Sub AssertIsAttribute (
    attributeType As Type
)
public:
static void AssertIsAttribute(
    Type^ attributeType
)
static member AssertIsAttribute :
        attributeType : Type -> unit

Parameters

attributeType
Type: SystemType
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.AssertIsException Method

TestUtilitiesAssertIsException Method
Throws an assertion if the type passed across is not an exception type, does not have the correct constructors or is not serialisable.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AssertIsException(
    Type exceptionType
)
Public Shared Sub AssertIsException (
    exceptionType As Type
)
public:
static void AssertIsException(
    Type^ exceptionType
)
static member AssertIsException :
        exceptionType : Type -> unit

Parameters

exceptionType
Type: SystemType
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.AssignPropertyValue Method

TestUtilitiesAssignPropertyValue Method
Assigns a constant dummy value to a property on an object.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AssignPropertyValue(
    Object obj,
    PropertyInfo property,
    bool useValue1
)
Public Shared Sub AssignPropertyValue (
    obj As Object,
    property As PropertyInfo,
    useValue1 As Boolean
)
public:
static void AssignPropertyValue(
    Object^ obj,
    PropertyInfo^ property,
    bool useValue1
)
static member AssignPropertyValue :
        obj : Object *
        property : PropertyInfo *
        useValue1 : bool -> unit

Parameters

obj
Type: SystemObject
The object to assign to.
property
Type: System.ReflectionPropertyInfo
The property to assign.
useValue1
Type: SystemBoolean
True if the first constant value should be assigned, false if the second (different) constant value should be assigned.
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.ChangeType Method

TestUtilitiesChangeType Method
Converts a value from one type to another, as per the standard ChangeType(Object, Type), except that this version can cope with the conversion of NullableT types.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ChangeType(
    Object value,
    Type type,
    IFormatProvider provider
)
Public Shared Function ChangeType (
    value As Object,
    type As Type,
    provider As IFormatProvider
) As Object
public:
static Object^ ChangeType(
    Object^ value,
    Type^ type,
    IFormatProvider^ provider
)
static member ChangeType :
        value : Object *
        type : Type *
        provider : IFormatProvider -> Object

Parameters

value
Type: SystemObject
type
Type: SystemType
provider
Type: SystemIFormatProvider

Return Value

Type: Object
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.ConvertBitStringToBytes Method

TestUtilitiesConvertBitStringToBytes Method
Converts a string of binary digits (with optional whitespace) to a collection of bytes.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<byte> ConvertBitStringToBytes(
    string bits
)
Public Shared Function ConvertBitStringToBytes (
    bits As String
) As List(Of Byte)
public:
static List<unsigned char>^ ConvertBitStringToBytes(
    String^ bits
)
static member ConvertBitStringToBytes :
        bits : string -> List<byte>

Parameters

bits
Type: SystemString

Return Value

Type: List Byte
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.ConvertToBitString Method

TestUtilitiesConvertToBitString Method
Overload List
Name | Description
ConvertToBitString(Int32, Int32) | Converts a value to a binary representation of a given length.
ConvertToBitString(Int64, Int32) | Converts a value to a binary representation of a given length.
Top
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.ConvertToBitString Method (Int32, Int32)

TestUtilitiesConvertToBitString Method (Int32, Int32)
Converts a value to a binary representation of a given length.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConvertToBitString(
    int value,
    int countDigits
)
Public Shared Function ConvertToBitString (
    value As Integer,
    countDigits As Integer
) As String
public:
static String^ ConvertToBitString(
    int value,
    int countDigits
)
static member ConvertToBitString :
        value : int *
        countDigits : int -> string

Parameters

value
Type: SystemInt32
countDigits
Type: SystemInt32

Return Value

Type: String
The value, expressed as a sequence of binary digits, within a string of countDigits length.
See Also

Reference

TestUtilities Class
ConvertToBitString Overload
Test.Framework Namespace


TestUtilities.ConvertToBitString Method (Int64, Int32)

TestUtilitiesConvertToBitString Method (Int64, Int32)
Converts a value to a binary representation of a given length.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConvertToBitString(
    long value,
    int countDigits
)
Public Shared Function ConvertToBitString (
    value As Long,
    countDigits As Integer
) As String
public:
static String^ ConvertToBitString(
    long long value,
    int countDigits
)
static member ConvertToBitString :
        value : int64 *
        countDigits : int -> string

Parameters

value
Type: SystemInt64
countDigits
Type: SystemInt32

Return Value

Type: String
The value, expressed as a sequence of binary digits, within a string of countDigits length.
See Also

Reference

TestUtilities Class
ConvertToBitString Overload
Test.Framework Namespace


TestUtilities.CreateMockImplementation(T) Method

TestUtilitiesCreateMockImplementationT Method
Creates a Moq stub for an object and registers it with the class factory. The instance returned by the method is the one the code under test will always receive when it asks for an instantiation of the interface.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Mock<T> CreateMockImplementation<T>()
where T : class

Public Shared Function CreateMockImplementation(Of T As Class) As Mock(Of T)
public:
generic<typename T>
where T : ref class
static Mock<T>^ CreateMockImplementation()
static member CreateMockImplementation : unit -> Mock<'T>  when 'T : not struct

Type Parameters

T

Return Value

Type: MockT
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.CreateMockInstance(T) Method

TestUtilitiesCreateMockInstanceT Method
Creates a Moq stub for an object but does not register it with the class factory.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Mock<T> CreateMockInstance<T>()
where T : class

Public Shared Function CreateMockInstance(Of T As Class) As Mock(Of T)
public:
generic<typename T>
where T : ref class
static Mock<T>^ CreateMockInstance()
static member CreateMockInstance : unit -> Mock<'T>  when 'T : not struct

Type Parameters

T

Return Value

Type: MockT
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.CreateMockSingleton(T) Method

TestUtilitiesCreateMockSingletonT Method
Creates a Moq mock object for a type that implements ISingletonT.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Mock<T> CreateMockSingleton<T>()
where T : class

Public Shared Function CreateMockSingleton(Of T As Class) As Mock(Of T)
public:
generic<typename T>
where T : ref class
static Mock<T>^ CreateMockSingleton()
static member CreateMockSingleton : unit -> Mock<'T>  when 'T : not struct

Type Parameters

T

Return Value

Type: MockT
Remarks

The application has adopted the idea that singletons are denoted by the ISingletonT interface. This declares a property which returns the same singleton reference regardless of the instance that it's called from. We need to make sure that any tests will pick up the accidental use of a private instance of the class. For example we want to make sure that if the user does this:

Copy
var log = Factory.Singleton.Resolve<ILog>();
log.DoSomething();

instead of this:

Copy
var log = Factory.Singleton.Resolve<ILog>().Singleton;
log.DoSomething();

then the test will throw an exception. We do this by creating a strict mock that only has Singleton setup for it, so any call on it other than to read Singleton will cause the mock to throw an exception and fail the test. This strict mock is then registered with the class factory.

The Singleton property of the strict mock is then set up to return a friendly mock, and it is this mock that gets returned by the method. The test can configure this mock with the correct behaviour and rest assured that the code under test could only get a reference to this mock by asking the class factory to resolve the interface and then reading the Singleton property of the object that the class factory dished up.

See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.SequenceEqual(T) Method

TestUtilitiesSequenceEqualT Method
Returns true if both sequences are null or if the LINQ SequenceEqual method returns true for them, otherwise returns false.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SequenceEqual<T>(
    IEnumerable<T> lhs,
    IEnumerable<T> rhs
)

Public Shared Function SequenceEqual(Of T) (
    lhs As IEnumerable(Of T),
    rhs As IEnumerable(Of T)
) As Boolean
public:
generic<typename T>
static bool SequenceEqual(
    IEnumerable<T>^ lhs,
    IEnumerable<T>^ rhs
)
static member SequenceEqual :
        lhs : IEnumerable<'T> *
        rhs : IEnumerable<'T> -> bool

Parameters

lhs
Type: System.Collections.GenericIEnumerable T
rhs
Type: System.Collections.GenericIEnumerable T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.TestProperty Method

TestUtilitiesTestProperty Method
Overload List
Name | Description
TestProperty(Object, String, Boolean) | Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.
TestPropertyT(T, ExpressionFuncT, Object, Boolean) | Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.
TestProperty(Object, String, Object, Object) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestPropertyT(T, ExpressionFuncT, Object, Object, Object) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestProperty(Object, String, Object, Object, Boolean) | Asserts that a property of an object has a given start value and can be successfuly changed to another value.
TestPropertyT(T, ExpressionFuncT, Object, Object, Object, Boolean) | Asserts that the property passed across starts at a given value and can be changed to another value.
Top
See Also

Reference

TestUtilities Class
Test.Framework Namespace


TestUtilities.TestProperty Method (Object, String, Boolean)

TestUtilitiesTestProperty Method (Object, String, Boolean)
Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestProperty(
    Object obj,
    string propertyName,
    bool startValue
)
Public Shared Sub TestProperty (
    obj As Object,
    propertyName As String,
    startValue As Boolean
)
public:
static void TestProperty(
    Object^ obj,
    String^ propertyName,
    bool startValue
)
static member TestProperty :
        obj : Object *
        propertyName : string *
        startValue : bool -> unit

Parameters

obj
Type: SystemObject
propertyName
Type: SystemString
startValue
Type: SystemBoolean
See Also

Reference

TestUtilities Class
TestProperty Overload
Test.Framework Namespace


TestUtilities.TestProperty(T) Method (T, Expression(Func(T, Object)), Boolean)

TestUtilitiesTestPropertyT Method (T, ExpressionFuncT, Object, Boolean)
Asserts that a bool property of an object has the given start value. Sets the property to the toggled start value and asserts that the toggled value can then be read back from the property.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestProperty<T>(
    T obj,
    Expression<Func<T, Object>> propertyExpression,
    bool startValue
)

Public Shared Sub TestProperty(Of T) (
    obj As T,
    propertyExpression As Expression(Of Func(Of T, Object)),
    startValue As Boolean
)
public:
generic<typename T>
static void TestProperty(
    T obj,
    Expression<Func<T, Object^>^>^ propertyExpression,
    bool startValue
)
static member TestProperty :
        obj : 'T *
        propertyExpression : Expression<Func<'T, Object>> *
        startValue : bool -> unit

Parameters

obj
Type: T
propertyExpression
Type: System.Linq.ExpressionsExpression Func T, Object
startValue
Type: SystemBoolean

Type Parameters

T
See Also

Reference

TestUtilities Class
TestProperty Overload
Test.Framework Namespace


TestUtilities.TestProperty Method (Object, String, Object, Object)

TestUtilitiesTestProperty Method (Object, String, Object, Object)
Asserts that a property of an object has a given start value and can be successfuly changed to another value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestProperty(
    Object obj,
    string propertyName,
    Object startValue,
    Object newValue
)
Public Shared Sub TestProperty (
    obj As Object,
    propertyName As String,
    startValue As Object,
    newValue As Object
)
public:
static void TestProperty(
    Object^ obj,
    String^ propertyName,
    Object^ startValue,
    Object^ newValue
)
static member TestProperty :
        obj : Object *
        propertyName : string *
        startValue : Object *
        newValue : Object -> unit

Parameters

obj
Type: SystemObject
The object under test.
propertyName
Type: SystemString
The name of the property to test.
startValue
Type: SystemObject
The expected starting value of the property.
newValue
Type: SystemObject
The value to write to the property - to pass the property must expose this value once it has been set.
See Also

Reference

TestUtilities Class
TestProperty Overload
Test.Framework Namespace


TestUtilities.TestProperty(T) Method (T, Expression(Func(T, Object)), Object, Object)

TestUtilitiesTestPropertyT Method (T, ExpressionFuncT, Object, Object, Object)
Asserts that a property of an object has a given start value and can be successfuly changed to another value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestProperty<T>(
    T obj,
    Expression<Func<T, Object>> propertyExpression,
    Object startValue,
    Object newValue
)

Public Shared Sub TestProperty(Of T) (
    obj As T,
    propertyExpression As Expression(Of Func(Of T, Object)),
    startValue As Object,
    newValue As Object
)
public:
generic<typename T>
static void TestProperty(
    T obj,
    Expression<Func<T, Object^>^>^ propertyExpression,
    Object^ startValue,
    Object^ newValue
)
static member TestProperty :
        obj : 'T *
        propertyExpression : Expression<Func<'T, Object>> *
        startValue : Object *
        newValue : Object -> unit

Parameters

obj
Type: T
propertyExpression
Type: System.Linq.ExpressionsExpression Func T, Object
startValue
Type: SystemObject
newValue
Type: SystemObject

Type Parameters

T
See Also

Reference

TestUtilities Class
TestProperty Overload
Test.Framework Namespace


TestUtilities.TestProperty Method (Object, String, Object, Object, Boolean)

TestUtilitiesTestProperty Method (Object, String, Object, Object, Boolean)
Asserts that a property of an object has a given start value and can be successfuly changed to another value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestProperty(
    Object obj,
    string propertyName,
    Object startValue,
    Object newValue,
    bool testForEquals
)
Public Shared Sub TestProperty (
    obj As Object,
    propertyName As String,
    startValue As Object,
    newValue As Object,
    testForEquals As Boolean
)
public:
static void TestProperty(
    Object^ obj,
    String^ propertyName,
    Object^ startValue,
    Object^ newValue,
    bool testForEquals
)
static member TestProperty :
        obj : Object *
        propertyName : string *
        startValue : Object *
        newValue : Object *
        testForEquals : bool -> unit

Parameters

obj
Type: SystemObject
The object under test.
propertyName
Type: SystemString
The name of the property to test.
startValue
Type: SystemObject
The expected starting value of the property.
newValue
Type: SystemObject
The value to write to the property - to pass the property must expose this value once it has been set.
testForEquals
Type: SystemBoolean
True if the equality test uses Equals(Object), false if it uses ReferenceEquals(Object, Object). If either the startValue or newValue are value types then this parameter is ignored, the test is always made using Equals(Object).
See Also

Reference

TestUtilities Class
TestProperty Overload
Test.Framework Namespace


TestUtilities.TestProperty(T) Method (T, Expression(Func(T, Object)), Object, Object, Boolean)

TestUtilitiesTestPropertyT Method (T, ExpressionFuncT, Object, Object, Object, Boolean)
Asserts that the property passed across starts at a given value and can be changed to another value.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestProperty<T>(
    T obj,
    Expression<Func<T, Object>> propertyExpression,
    Object startValue,
    Object newValue,
    bool testForEquals
)

Public Shared Sub TestProperty(Of T) (
    obj As T,
    propertyExpression As Expression(Of Func(Of T, Object)),
    startValue As Object,
    newValue As Object,
    testForEquals As Boolean
)
public:
generic<typename T>
static void TestProperty(
    T obj,
    Expression<Func<T, Object^>^>^ propertyExpression,
    Object^ startValue,
    Object^ newValue,
    bool testForEquals
)
static member TestProperty :
        obj : 'T *
        propertyExpression : Expression<Func<'T, Object>> *
        startValue : Object *
        newValue : Object *
        testForEquals : bool -> unit

Parameters

obj
Type: T
propertyExpression
Type: System.Linq.ExpressionsExpression Func T, Object
startValue
Type: SystemObject
newValue
Type: SystemObject
testForEquals
Type: SystemBoolean

Type Parameters

T
See Also

Reference

TestUtilities Class
TestProperty Overload
Test.Framework Namespace


TestUtilities.TestSimpleEquals Method

TestUtilitiesTestSimpleEquals Method
Tests that an object whose Equals method tests all of its public properties is behaving correctly. Only works with objects that have a simple constructor.

Namespace: Test.Framework
Assembly: Test.Framework (in Test.Framework.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void TestSimpleEquals(
    Type type,
    bool expectedEquals
)
Public Shared Sub TestSimpleEquals (
    type As Type,
    expectedEquals As Boolean
)
public:
static void TestSimpleEquals(
    Type^ type,
    bool expectedEquals
)
static member TestSimpleEquals :
        type : Type *
        expectedEquals : bool -> unit

Parameters

type
Type: SystemType
expectedEquals
Type: SystemBoolean
See Also

Reference

TestUtilities Class
Test.Framework Namespace


VirtualRadar.Database Namespace

VirtualRadar.Database Namespace
The namespace holding the standard implementations of the database interfaces.
Classes
 | Class | Description
Public class | Implementations | Initialises the class factory with all the standard implementations in this library.
Public class | SQLiteExecute | A class that can perform some action on a SQLite command repeatedly until the command no longer throws a locked exception.
Remarks
None of the implementations are public, you must use the class factory to access them.


Implementations Class

Implementations Class
Initialises the class factory with all the standard implementations in this library.
Inheritance Hierarchy
SystemObject
VirtualRadar.DatabaseImplementations

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Implementations
Public NotInheritable Class Implementations
public ref class Implementations abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Implementations =  class end

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

VirtualRadar.Database Namespace


Implementations Methods

Implementations Methods

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

Implementations Class
VirtualRadar.Database Namespace


Implementations.Register Method

ImplementationsRegister Method
Initialises the class factory with all the standard implementations in this library.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Register(
    IClassFactory factory
)
Public Shared Sub Register (
    factory As IClassFactory
)
public:
static void Register(
    IClassFactory^ factory
)
static member Register :
        factory : IClassFactory -> unit

Parameters

factory
Type: InterfaceFactoryIClassFactory
See Also

Reference

Implementations Class
VirtualRadar.Database Namespace


SQLiteExecute Class

SQLiteExecute Class
A class that can perform some action on a SQLite command repeatedly until the command no longer throws a locked exception.
Inheritance Hierarchy
SystemObject
VirtualRadar.DatabaseSQLiteExecute

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SQLiteExecute
Public Class SQLiteExecute
public ref class SQLiteExecute
type SQLiteExecute =  class end

The SQLiteExecute type exposes the following members.

Constructors
 | Name | Description
Public method | SQLiteExecute | Creates a new object.
Top
Properties
 | Name | Description
Public property | RetryIfLocked | Gets or sets a value indicating that the action should be retried if the database is locked.
Public property | RetryIfLockedTimeout | Gets or sets the number of milliseconds that must elapse before the code gives up retrying an action that is failing due to a database lock.
Top
Methods
 | Name | Description
Public method | CallActionUntilUnlocked | Calls the action passed across. If the action throws a SQLite locked exception then it retries the action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery | Performs the ExecuteNonQuery operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteReader(IDbCommand) | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteReader(IDbCommand, CommandBehavior) | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteScalar | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Performs the Read operation on a data reader, retrying if the read throws a locked exception.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Database Namespace


SQLiteExecute Constructor

SQLiteExecute Constructor
Creates a new object.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SQLiteExecute()
Public Sub New
public:
SQLiteExecute()
new : unit -> SQLiteExecute
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute Properties

SQLiteExecute Properties

The SQLiteExecute type exposes the following members.

Properties
 | Name | Description
Public property | RetryIfLocked | Gets or sets a value indicating that the action should be retried if the database is locked.
Public property | RetryIfLockedTimeout | Gets or sets the number of milliseconds that must elapse before the code gives up retrying an action that is failing due to a database lock.
Top
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.RetryIfLocked Property

SQLiteExecuteRetryIfLocked Property
Gets or sets a value indicating that the action should be retried if the database is locked.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RetryIfLocked { get; set; }
Public Property RetryIfLocked As Boolean
    Get
    Set
public:
property bool RetryIfLocked {
    bool get ();
    void set (bool value);
}
member RetryIfLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.RetryIfLockedTimeout Property

SQLiteExecuteRetryIfLockedTimeout Property
Gets or sets the number of milliseconds that must elapse before the code gives up retrying an action that is failing due to a database lock.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RetryIfLockedTimeout { get; set; }
Public Property RetryIfLockedTimeout As Integer
    Get
    Set
public:
property int RetryIfLockedTimeout {
    int get ();
    void set (int value);
}
member RetryIfLockedTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute Methods

SQLiteExecute Methods

The SQLiteExecute type exposes the following members.

Methods
 | Name | Description
Public method | CallActionUntilUnlocked | Calls the action passed across. If the action throws a SQLite locked exception then it retries the action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery | Performs the ExecuteNonQuery operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteReader(IDbCommand) | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteReader(IDbCommand, CommandBehavior) | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteScalar | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Performs the Read operation on a data reader, retrying if the read throws a locked exception.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.CallActionUntilUnlocked Method

SQLiteExecuteCallActionUntilUnlocked Method
Calls the action passed across. If the action throws a SQLite locked exception then it retries the action.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CallActionUntilUnlocked(
    Action action
)
Public Sub CallActionUntilUnlocked (
    action As Action
)
public:
void CallActionUntilUnlocked(
    Action^ action
)
member CallActionUntilUnlocked :
        action : Action -> unit

Parameters

action
Type: SystemAction
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.ExecuteNonQuery Method

SQLiteExecuteExecuteNonQuery Method
Performs the ExecuteNonQuery operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ExecuteNonQuery(
    IDbCommand command
)
Public Function ExecuteNonQuery (
    command As IDbCommand
) As Integer
public:
int ExecuteNonQuery(
    IDbCommand^ command
)
member ExecuteNonQuery :
        command : IDbCommand -> int

Parameters

command
Type: System.DataIDbCommand

Return Value

Type: Int32
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.ExecuteReader Method

SQLiteExecuteExecuteReader Method
Overload List
 | Name | Description
Public method | ExecuteReader(IDbCommand) | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Public method | ExecuteReader(IDbCommand, CommandBehavior) | Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.
Top
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.ExecuteReader Method (IDbCommand)

SQLiteExecuteExecuteReader Method (IDbCommand)
Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDataReader ExecuteReader(
    IDbCommand command
)
Public Function ExecuteReader (
    command As IDbCommand
) As IDataReader
public:
IDataReader^ ExecuteReader(
    IDbCommand^ command
)
member ExecuteReader :
        command : IDbCommand -> IDataReader

Parameters

command
Type: System.DataIDbCommand

Return Value

Type: IDataReader
See Also

Reference

SQLiteExecute Class
ExecuteReader Overload
VirtualRadar.Database Namespace


SQLiteExecute.ExecuteReader Method (IDbCommand, CommandBehavior)

SQLiteExecuteExecuteReader Method (IDbCommand, CommandBehavior)
Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDataReader ExecuteReader(
    IDbCommand command,
    CommandBehavior commandBehaviour
)
Public Function ExecuteReader (
    command As IDbCommand,
    commandBehaviour As CommandBehavior
) As IDataReader
public:
IDataReader^ ExecuteReader(
    IDbCommand^ command,
    CommandBehavior commandBehaviour
)
member ExecuteReader :
        command : IDbCommand *
        commandBehaviour : CommandBehavior -> IDataReader

Parameters

command
Type: System.DataIDbCommand
commandBehaviour
Type: System.DataCommandBehavior

Return Value

Type: IDataReader
See Also

Reference

SQLiteExecute Class
ExecuteReader Overload
VirtualRadar.Database Namespace


SQLiteExecute.ExecuteScalar Method

SQLiteExecuteExecuteScalar Method
Performs the ExecuteReader operation on the command, returning the result. Will retry the command if the attempt fails due to a locked database.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object ExecuteScalar(
    IDbCommand command
)
Public Function ExecuteScalar (
    command As IDbCommand
) As Object
public:
Object^ ExecuteScalar(
    IDbCommand^ command
)
member ExecuteScalar :
        command : IDbCommand -> Object

Parameters

command
Type: System.DataIDbCommand

Return Value

Type: Object
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


SQLiteExecute.Read Method

SQLiteExecuteRead Method
Performs the Read operation on a data reader, retrying if the read throws a locked exception.

Namespace: VirtualRadar.Database
Assembly: VirtualRadar.Database (in VirtualRadar.Database.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Read(
    IDataReader reader
)
Public Function Read (
    reader As IDataReader
) As Boolean
public:
bool Read(
    IDataReader^ reader
)
member Read :
        reader : IDataReader -> bool

Parameters

reader
Type: System.DataIDataReader

Return Value

Type: Boolean
See Also

Reference

SQLiteExecute Class
VirtualRadar.Database Namespace


VirtualRadar.Interface Namespace

VirtualRadar.Interface Namespace
The root namespace for the application interfaces.
Classes
 | Class | Description
Public class | AircraftComparerColumn | A list of column names that can be used with the IAircraftComparer. These names are sent to the server from Javascript on the browser, if you change these then you must also change the Javascript.
Public class | AircraftDetail | The DTO returned by IAircraftDetailFetcher.
Public class | AircraftFetcherTKey, TDetail | A base class for fetcher implementations that register an aircraft and then periodically fetch records related to that aircraft.
Protected class | AircraftFetcherTKey, TDetailFetchedDetail | The fetched detail for an aircraft.
Public class | AircraftOnlineLookupDetail | Holds the detail for an aircraft whose details were fetched by IAircraftOnlineLookup.
Public class | AircraftOnlineLookupEventArgs | The event args used by IAircraftOnlineLookup.
Public class | AircraftOnlineLookupLogEntry | Describes an entry in the IAircraftOnlineLookupLog.
Public class | AirportDataThumbnailJson | The JSON object that carries the thumbnail data for an aircraft from www.airport-data.com
Public class | AirportDataThumbnailsJson | The DTO carrying the result of a JSON request for multiple thumbnails from www.airport-data.com.
Public class | AirPressure | An air pressure reading, as downloaded from the SDM site.
Public class | BackgroundThreadQueueT | A class that wraps a queue of objects that one thread pushes onto while a background thread pops and processes them.
Public class | ByteArrayComparable | An implementation of IComparable that returns the comparative order of a byte array.
Public class | Cidr | Represents a Classless Inter-Domain Routing value.
Public class | CidrComparer | Compares Cidr objects for their relative order.
Public class | CollectionHelper | A static class with methods that can help when dealing with collections.
Public class | Coordinate | An immutable object that describes a point where an aircraft was seen and the time at which its position was recorded.
Public class | Crc16 | A utility class that calculates CRC16 checksums.
Public class | Crc16Ccitt | A utility class that calculates CCITT-16 CRC values.
Public class | Crc32ModeS | A class that can calculate CRC32 parity bits that are applied to Mode-S messages.
Public class | Crc64 | A class that can calculate CRC64 checksums on a set of arbitrary bytes.
Public class | CultureSwitcher | A class that switches the current thread to a particular culture when it is created and then restores the original culture when it's disposed.
Public class | CustomConvert | Performs simple custom conversions.
Public class | Describe | A static class that can produce descriptions of objects that implement common interfaces.
Public class | EventArgsT | An EventArgs that exposes a single value as a property.
Public class | EventHandlerUtils | A static class that makes it easier to use weak event handlers.
Public class | EventHelper | Methods that help when handling events.
Public class | EventHelperException | Thrown when an event handler throws an exception in EventHelper.
Public class | ExpiringCollectionTItem | Manages a self-expiring collection of items.
Protected class | ExpiringCollectionTItemCollectionItemT | An instance of a collection item and its associated timestamp.
Public class | ExpiringDictionaryTKey, TValue | Manages a self-expiring dictionary of items.
Public class | ExpiringListT | Manages a self-expiring list of items.
Public class | Filter | Describes a filter.
Public class | FilterBool | An object that carries a bool filter.
Public class | FilterEnumT | Describes a filter against an enum value.
Public class | FilterRangeT | Describes a range filter to apply to a value.
Public class | FilterString | A string filter to apply to a value.
Public class | GreatCircleMaths | A collection of Great Circle math functions, mostly cribbed from http://www.movable-type.co.uk/scripts/latlong.html.
Public class | Hierarchy | Static methods for dealing with hierarchies.
Public class | IListExtensions | Extensions to IList<T> that add some functionality present on List<T> but missing on the interface.
Public class | IPAddressComparer | A class that can compare two IPAddresses for relative order.
Public class | IPAddressHelper | A static class of methods that can help when dealing with IPAddress objects.
Public class | IPEndPointHelper | A static helper class that can make life easier when dealing with IPEndPoint objects.
Public class | JavascriptHelper | A collection of assorted methods that help make dealing with Javascript a bit easier.
Public class | JsonSerialiser | An object that can serialise to JSON.
Public class | OnlineHelpAddress | A class exposing the addresses of online help pages.
Public class | PairT | An immutable generic class that holds a pair of values of the same type. Can be used as a key in a hashtable / dictionary.
Public class | PictureDetail | A class that describes a picture.
Public class | PluginEventArgs | An EventArgs for events that need to refer to an instance of an IPlugin.
Public class | PluginStartupParameters | The class that passes parameters to Startup(PluginStartupParameters).
Public class | PropertyHelper | Utility methods for working with properties.
Public class | QueueRepository | Exposes a collection of every queue running within the program.
Public class | RebroadcastServerConnection | Describes a connection to a rebroadcast server.
Public class | Round | A helper class that can round numbers quickly, but only if they are within certain ranges.
Public class | SpinLock | A class that implements a simple lock that avoids the overhead imposed by using lock().
Public class | SpinLockAcquire | A wrapper class that calls Lock in its constructor and Unlock in its Dispose.
Public class | StreamHelper | A collection of methods that can help when dealing with streams.
Public class | StringDeduplicator | A utility class that can be used to remove duplicates of strings.
Public class | StringWriterWithEncoding | A string writer that lets you set the encoding.
Public class | TimestampedException | Records an exception and the time (at UTC) when it was thrown.
Public class | WaitState | A base class for simple state objects that carry information in BeginXXXXX calls. Holds a wait handle that can be manually signalled in the EndXXXXXX call and waited on in calling thread.
Public class | WeakEventHandlerT, E | The default implementation of IWeakEventHandler.
Public class | WebRequestHelper | A static class that helps with some common tasks when dealing with web requests.
Public class | WebRequestResultT | Describes the request of a request to an Internet-based API.
Interfaces
 | Interface | Description
Public interface | IAccessFilter | The interface for classes that can take an Access list from Settings and use that to decide whether to allow or disallow an incoming connection or request.
Public interface | IAircraft | Describes everything that is known about an aircraft that is being tracked.
Public interface | IAircraftComparer | The interface for objects that can compare two IAircraft for relative sort order.
Public interface | IAircraftDetailFetcher | The interface for a singleton class that periodically fetches all aircraft details from the database.
Public interface | IAircraftList | The interface for objects that can collect together information from the messages transmitted by aircraft, and lookups in various data sources, to maintain a list of aircraft and their current state.
Public interface | IAircraftOnlineLookup | The interface for an object that can batch up lookups of aircraft details from an online source.
Public interface | IAircraftOnlineLookupCache | Caches the results of online aircraft detail lookups.
Public interface | IAircraftOnlineLookupLog | Records the online aircraft detail lookup requests and responses over the past so-many minutes.
Public interface | IAircraftOnlineLookupManager | Brings together the online lookup and the online lookup cache. If you want something from the online aircraft lookup then talk to this object.
Public interface | IAircraftOnlineLookupProvider | The interface that online lookup provider can implement to change where IAircraftOnlineLookup goes to fetch aircraft details.
Public interface | IAircraftPictureManager | The interface for an object that can deal with finding pictures of aircraft.
Public interface | IAircraftSanityChecker | The interface for objects that test the sanity of position reports and altitudes received for aircraft.
Public interface | IAirportDataDotCom | The interface that objects that expose access to the www.airport-data.com API must implement.
Public interface | IAirPressureDownloader | The interface that objects that download air pressure readings has to implement.
Public interface | IAirPressureLookup | The interface for objects that can take a list of air pressures and from that give you the closest air pressure reading for a point on the surface of the earth.
Public interface | IAirPressureManager | The interface that objects that manage the downloading of air pressure readings has to implement.
Public interface | IApplicationInformation | The interface for objects that can expose information about the application.
Public interface | IAudio | The interface for objects that can generate audio.
Public interface | IAutoConfigPictureFolderCache | The interface for a singleton object that can automatically apply the picture folder name from the configuration to an IDirectoryCache.
 | IBackgroundThreadExceptionCatcher | An interface for objects that may be utilising background threads and want to allow exceptions on those threads to bubble up to the GUI thread.
Public interface | IBackgroundWorker | The interface for an object that does some work on a background thread and then quits the thread. The intention is that it is used once and then discarded, it cannot be used twice.
Public interface | IBitStream | The interface for classes that can take an array of bytes and stream bits from that byte array.
Public interface | ICallsignParser | The interface for an object that can parse a callsign.
Public interface | IClock | The interface for an object that abstracts away the clock.
Public interface | IConnectionLogger | The interface for objects that listen to a web server, track connections to it and periodically record details of those connections in a local database.
Public interface | IDirectoryCache | The interface for objects that can cache the filenames in a folder.
Public interface | IDirectoryCacheProvider | The interface for the object that abstracts away the environment for IDirectoryCache implementations.
Public interface | IDirectoryCacheProviderFileInfo | The interface for an object that exposes information about a file.
Public interface | IExceptionReporter | The interface for objects that can report exceptions.
Public interface | IExternalIPAddressService | The interface for objects that find out the external IP address of the user.
Public interface | IExternalIPAddressServiceProvider | The object that abstracts away the environment for tests on IExternalIPAddressService.
Public interface | IHeartbeatService | A service that raises an event on a background thread every so-many minutes.
Public interface | IImageDimensionsFetcher | The interface for an object that can determine the dimensions of an image stored in an image file.
Public interface | IImageFileManager | Manages access to images stored on disk.
 | ILog | The interface for objects that can manage log files for us.
Public interface | ILogProvider | The interface for objects that abstract away the environment for ILog implementations.
Public interface | IMessageBox | The interface for an object that can show a modal message to the user.
Public interface | INewVersionChecker | The interface for objects that can check with the VirtualRadarServer website to see whether a new version is available for download.
Public interface | INewVersionCheckerProvider | The interface for providers that abstract away parts of the environment for testing.
Public interface | IPlugin | Describes the interface for a class that plugin DLLs must implement in order to be loaded by Virtual Radar Server.
Public interface | IPluginManager | The interface for the object that manages plugins on behalf of the program.
Public interface | IPluginManagerProvider | The interface for objects that abstract away the environment for IPluginManager implementations.
Public interface | IQueue | The interface for queues that can be interrogated to find out how many items they are holding.
Public interface | IRuntimeEnvironment | The interface for singleton objects that can tell the program about the environment it's running under.
Public interface | ISimpleAircraftList | The interface for implementations of IAircraftList that can have aircraft created and added to the list by the program rather than from an external source like an instance of BaseStation.
 | ISingletonT | Declares that the interface this is implemented by is intended to be used as a singleton.
Public interface | ISpeechSynthesizerWrapper | The interface for a wrapper around the .NET SpeechSynthesizer class.
Public interface | IStandaloneAircraftOnlineLookupCache | The interface for the standalone aircraft online lookup cache. This is the fallback that is used when no other cache is available. It is registered with a priority of zero.
Public interface | IStatistics | A class that records various statistics.
Public interface | ITimer | The interface for objects that periodically raise an event.
Public interface | IWeakEventHandlerE | The interface for event handlers that can hold a weak reference to a target.
Public interface | IXmlSerialiser | The interface for objects that can serialise objects to XML and deserialise objects from XML.
Delegates
 | Delegate | Description
Public delegate | UnregisterCallbackE | The delegate for a method that will automatically unregister an event handler when the owning object is garbage collected.
Enumerations
 | Enumeration | Description
Public enumeration | AircraftListSource | An enumeration of the different sources that aircraft lists can come from.
Public enumeration | AltitudeType | The different types of altitude and vertical rate decoded by VRS.
Public enumeration | BackgroundThreadQueueMechanism | An enumeration of the different mechanisms that the BackgroundThreadQueue can use.
Public enumeration | Certainty | An enumeration of the different desgrees of certainty the program has regarding the sanity of a value.
Public enumeration | DistanceUnit | An enumeration of the different distance units that the website can display.
Public enumeration | FilterCondition | An enumeration of the different conditions that a value can be filtered on.
Public enumeration | HeightUnit | An enumeration of the different heights that the web site knows about.
Public enumeration | SpeedType | An enumeration of the different types of speed transmitted by a vehicle. This enumeration is duplicated within the Javascript, hence the explicit declarations. Any changes here need copying there.
Public enumeration | SpeedUnit | An enumeration of the different speed units that the web site can deal with.
Public enumeration | TransponderType | An enumeration of the different types of transponder that VRS can decode messages from.
Remarks

The interfaces, enumerations and classes in this namespace are held in VirtualRadar.Interface.dll. Virtual Radar Server is loosely coupled (see the remarks against the InterfaceFactory namespace) and almost all of the classes used by the program are private to the library that they live in. They all implement interfaces and the program uses a singleton class factory in InterfaceFactory to resolve references to interfaces when the need arises.

These interfaces are all declared in this library, VirtualRadar.Interface.dll. The library does not contain any of the implementations. It has almost no references to other projects within Virtual Radar Server, aside from InterfaceFactory. Along with the interfaces for the program it also contains the enumerations, custom EventArgs, Exception and Attribute classes that the interfaces refer to. It also contains one or two public helper classes, usually static classes, that the implementations of the interfaces may find useful.


AircraftComparerColumn Class

AircraftComparerColumn Class
A list of column names that can be used with the IAircraftComparer. These names are sent to the server from Javascript on the browser, if you change these then you must also change the Javascript.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAircraftComparerColumn

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AircraftComparerColumn
Public NotInheritable Class AircraftComparerColumn
public ref class AircraftComparerColumn abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AircraftComparerColumn =  class end

The AircraftComparerColumn type exposes the following members.

Fields
Name | Description
Altitude | The altitude that the aircraft is flying at.
Callsign | The callsign the aircraft is flying under.
Destination | The airport that the aircraft is flying to.
DistanceFromHere | The distance from the browser to the aircraft.
FirstSeen | The time the aircraft was first seen by the server.
FlightsCount | The number of flights recorded for the aircraft in the BaseStation database.
GroundSpeed | The aircraft's ground speed.
Icao24 | The aircraft's unique ICAO24 identifier.
Icao24Country | The country that the aircraft's ICAO24 code is allocated to.
Model | The manufacturer and model of the aircraft.
NumberOfEngines | The number of engines on the aircraft (note that 'C' is a valid number of engines).
Operator | The company or individual operating the aircraft.
OperatorIcao | The ICAO code of the company operating the aircraft.
Origin | The airport where the aircraft began its flight.
Registration | The aircraft's registration.
Species | An indication of the type of vehicle, e.g. helicopter, landplane etc.
Squawk | The squawk code assigned to the aircraft by ATC.
Type | The ICAO8643 type code of the aircraft model.
VerticalRate | The aircraft's rate of ascent or descent.
WakeTurbulenceCategory | The ATC wake turbulence category for the aircraft.
Top
See Also

Reference

VirtualRadar.Interface Namespace


AircraftComparerColumn Fields

AircraftComparerColumn Fields

The AircraftComparerColumn type exposes the following members.

Fields
Name | Description
Altitude | The altitude that the aircraft is flying at.
Callsign | The callsign the aircraft is flying under.
Destination | The airport that the aircraft is flying to.
DistanceFromHere | The distance from the browser to the aircraft.
FirstSeen | The time the aircraft was first seen by the server.
FlightsCount | The number of flights recorded for the aircraft in the BaseStation database.
GroundSpeed | The aircraft's ground speed.
Icao24 | The aircraft's unique ICAO24 identifier.
Icao24Country | The country that the aircraft's ICAO24 code is allocated to.
Model | The manufacturer and model of the aircraft.
NumberOfEngines | The number of engines on the aircraft (note that 'C' is a valid number of engines).
Operator | The company or individual operating the aircraft.
OperatorIcao | The ICAO code of the company operating the aircraft.
Origin | The airport where the aircraft began its flight.
Registration | The aircraft's registration.
Species | An indication of the type of vehicle, e.g. helicopter, landplane etc.
Squawk | The squawk code assigned to the aircraft by ATC.
Type | The ICAO8643 type code of the aircraft model.
VerticalRate | The aircraft's rate of ascent or descent.
WakeTurbulenceCategory | The ATC wake turbulence category for the aircraft.
Top
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Altitude Field

AircraftComparerColumnAltitude Field
The altitude that the aircraft is flying at.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Altitude
Public Const Altitude As String
public:
literal String^ Altitude
static val mutable Altitude: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Callsign Field

AircraftComparerColumnCallsign Field
The callsign the aircraft is flying under.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Callsign
Public Const Callsign As String
public:
literal String^ Callsign
static val mutable Callsign: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Destination Field

AircraftComparerColumnDestination Field
The airport that the aircraft is flying to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Destination
Public Const Destination As String
public:
literal String^ Destination
static val mutable Destination: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.DistanceFromHere Field

AircraftComparerColumnDistanceFromHere Field
The distance from the browser to the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DistanceFromHere
Public Const DistanceFromHere As String
public:
literal String^ DistanceFromHere
static val mutable DistanceFromHere: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.FirstSeen Field

AircraftComparerColumnFirstSeen Field
The time the aircraft was first seen by the server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string FirstSeen
Public Const FirstSeen As String
public:
literal String^ FirstSeen
static val mutable FirstSeen: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.FlightsCount Field

AircraftComparerColumnFlightsCount Field
The number of flights recorded for the aircraft in the BaseStation database.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string FlightsCount
Public Const FlightsCount As String
public:
literal String^ FlightsCount
static val mutable FlightsCount: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.GroundSpeed Field

AircraftComparerColumnGroundSpeed Field
The aircraft's ground speed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string GroundSpeed
Public Const GroundSpeed As String
public:
literal String^ GroundSpeed
static val mutable GroundSpeed: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Icao24 Field

AircraftComparerColumnIcao24 Field
The aircraft's unique ICAO24 identifier.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Icao24
Public Const Icao24 As String
public:
literal String^ Icao24
static val mutable Icao24: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Icao24Country Field

AircraftComparerColumnIcao24Country Field
The country that the aircraft's ICAO24 code is allocated to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Icao24Country
Public Const Icao24Country As String
public:
literal String^ Icao24Country
static val mutable Icao24Country: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Model Field

AircraftComparerColumnModel Field
The manufacturer and model of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Model
Public Const Model As String
public:
literal String^ Model
static val mutable Model: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.NumberOfEngines Field

AircraftComparerColumnNumberOfEngines Field
The number of engines on the aircraft (note that 'C' is a valid number of engines).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string NumberOfEngines
Public Const NumberOfEngines As String
public:
literal String^ NumberOfEngines
static val mutable NumberOfEngines: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Operator Field

AircraftComparerColumnOperator Field
The company or individual operating the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Operator
Public Const Operator As String
public:
literal String^ Operator
static val mutable Operator: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.OperatorIcao Field

AircraftComparerColumnOperatorIcao Field
The ICAO code of the company operating the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string OperatorIcao
Public Const OperatorIcao As String
public:
literal String^ OperatorIcao
static val mutable OperatorIcao: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Origin Field

AircraftComparerColumnOrigin Field
The airport where the aircraft began its flight.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Origin
Public Const Origin As String
public:
literal String^ Origin
static val mutable Origin: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Registration Field

AircraftComparerColumnRegistration Field
The aircraft's registration.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Registration
Public Const Registration As String
public:
literal String^ Registration
static val mutable Registration: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Species Field

AircraftComparerColumnSpecies Field
An indication of the type of vehicle, e.g. helicopter, landplane etc.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Species
Public Const Species As String
public:
literal String^ Species
static val mutable Species: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Squawk Field

AircraftComparerColumnSquawk Field
The squawk code assigned to the aircraft by ATC.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Squawk
Public Const Squawk As String
public:
literal String^ Squawk
static val mutable Squawk: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.Type Field

AircraftComparerColumnType Field
The ICAO8643 type code of the aircraft model.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Type
Public Const Type As String
public:
literal String^ Type
static val mutable Type: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.VerticalRate Field

AircraftComparerColumnVerticalRate Field
The aircraft's rate of ascent or descent.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VerticalRate
Public Const VerticalRate As String
public:
literal String^ VerticalRate
static val mutable VerticalRate: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftComparerColumn.WakeTurbulenceCategory Field

AircraftComparerColumnWakeTurbulenceCategory Field
The ATC wake turbulence category for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string WakeTurbulenceCategory
Public Const WakeTurbulenceCategory As String
public:
literal String^ WakeTurbulenceCategory
static val mutable WakeTurbulenceCategory: string

Field Value

Type: String
See Also

Reference

AircraftComparerColumn Class
VirtualRadar.Interface Namespace


AircraftDetail Class

AircraftDetail Class
The DTO returned by IAircraftDetailFetcher.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAircraftDetail

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftDetail
Public Class AircraftDetail
public ref class AircraftDetail
type AircraftDetail =  class end

The AircraftDetail type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftDetail | Initializes a new instance of the AircraftDetail class
Top
Properties
 | Name | Description
Public property | Aircraft | Gets or sets the database aircraft record. This can be null if no database record has been fetched for the aircraft (yet).
Public property | AircraftType | Gets or sets the information gleaned from the aircraft's type. This can be null if the SDM files aren't in place, or they don't contain information about the type, or if the database record doesn't exist.
Public property | DatabaseRegistration | Gets the registration. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | FlightsCount | Gets or sets the number of flights seen for the aircraft. This is only set once, when the aircraft record is first read. It is never refreshed.
Public property | Icao24 | Gets or sets the ICAO24 for the aircraft. This is always supplied.
Public property | Manufacturer | Gets the manufacturer.
Public property | ModelIcao | Gets the model ICAO. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | ModelName | Gets the model name. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | OnlineAircraft | Gets or sets the results of the aircraft online lookup. This can be null if no lookup has yet been performed.
Public property | OperatorIcao | Gets the operator code. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | OperatorName | Gets the operator name. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | Picture | Gets or sets information about the picture associated with the aircraft. This can be null if no picture has been found for the aircraft (yet).
Public property | Serial | Gets the serial number.
Public property | YearBuilt | Gets the year built.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AircraftDetail Constructor

AircraftDetail Constructor
Initializes a new instance of the AircraftDetail class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftDetail()
Public Sub New
public:
AircraftDetail()
new : unit -> AircraftDetail
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail Properties

AircraftDetail Properties

The AircraftDetail type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets or sets the database aircraft record. This can be null if no database record has been fetched for the aircraft (yet).
Public property | AircraftType | Gets or sets the information gleaned from the aircraft's type. This can be null if the SDM files aren't in place, or they don't contain information about the type, or if the database record doesn't exist.
Public property | DatabaseRegistration | Gets the registration. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | FlightsCount | Gets or sets the number of flights seen for the aircraft. This is only set once, when the aircraft record is first read. It is never refreshed.
Public property | Icao24 | Gets or sets the ICAO24 for the aircraft. This is always supplied.
Public property | Manufacturer | Gets the manufacturer.
Public property | ModelIcao | Gets the model ICAO. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | ModelName | Gets the model name. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | OnlineAircraft | Gets or sets the results of the aircraft online lookup. This can be null if no lookup has yet been performed.
Public property | OperatorIcao | Gets the operator code. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | OperatorName | Gets the operator name. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.
Public property | Picture | Gets or sets information about the picture associated with the aircraft. This can be null if no picture has been found for the aircraft (yet).
Public property | Serial | Gets the serial number.
Public property | YearBuilt | Gets the year built.
Top
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.Aircraft Property

AircraftDetailAircraft Property
Gets or sets the database aircraft record. This can be null if no database record has been fetched for the aircraft (yet).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationAircraft Aircraft { get; set; }
Public Property Aircraft As BaseStationAircraft
    Get
    Set
public:
property BaseStationAircraft^ Aircraft {
    BaseStationAircraft^ get ();
    void set (BaseStationAircraft^ value);
}
member Aircraft : BaseStationAircraft with get, set

Property Value

Type: BaseStationAircraft
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.AircraftType Property

AircraftDetailAircraftType Property
Gets or sets the information gleaned from the aircraft's type. This can be null if the SDM files aren't in place, or they don't contain information about the type, or if the database record doesn't exist.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftType AircraftType { get; set; }
Public Property AircraftType As AircraftType
    Get
    Set
public:
property AircraftType^ AircraftType {
    AircraftType^ get ();
    void set (AircraftType^ value);
}
member AircraftType : AircraftType with get, set

Property Value

Type: AircraftType
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.DatabaseRegistration Property

AircraftDetailDatabaseRegistration Property
Gets the registration. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DatabaseRegistration { get; }
Public ReadOnly Property DatabaseRegistration As String
    Get
public:
property String^ DatabaseRegistration {
    String^ get ();
}
member DatabaseRegistration : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.FlightsCount Property

AircraftDetailFlightsCount Property
Gets or sets the number of flights seen for the aircraft. This is only set once, when the aircraft record is first read. It is never refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlightsCount { get; set; }
Public Property FlightsCount As Integer
    Get
    Set
public:
property int FlightsCount {
    int get ();
    void set (int value);
}
member FlightsCount : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.Icao24 Property

AircraftDetailIcao24 Property
Gets or sets the ICAO24 for the aircraft. This is always supplied.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao24 { get; set; }
Public Property Icao24 As String
    Get
    Set
public:
property String^ Icao24 {
    String^ get ();
    void set (String^ value);
}
member Icao24 : string with get, set

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.Manufacturer Property

AircraftDetailManufacturer Property
Gets the manufacturer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; }
Public ReadOnly Property Manufacturer As String
    Get
public:
property String^ Manufacturer {
    String^ get ();
}
member Manufacturer : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.ModelIcao Property

AircraftDetailModelIcao Property
Gets the model ICAO. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModelIcao { get; }
Public ReadOnly Property ModelIcao As String
    Get
public:
property String^ ModelIcao {
    String^ get ();
}
member ModelIcao : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.ModelName Property

AircraftDetailModelName Property
Gets the model name. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModelName { get; }
Public ReadOnly Property ModelName As String
    Get
public:
property String^ ModelName {
    String^ get ();
}
member ModelName : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.OnlineAircraft Property

AircraftDetailOnlineAircraft Property
Gets or sets the results of the aircraft online lookup. This can be null if no lookup has yet been performed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOnlineLookupDetail OnlineAircraft { get; set; }
Public Property OnlineAircraft As AircraftOnlineLookupDetail
    Get
    Set
public:
property AircraftOnlineLookupDetail^ OnlineAircraft {
    AircraftOnlineLookupDetail^ get ();
    void set (AircraftOnlineLookupDetail^ value);
}
member OnlineAircraft : AircraftOnlineLookupDetail with get, set

Property Value

Type: AircraftOnlineLookupDetail
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.OperatorIcao Property

AircraftDetailOperatorIcao Property
Gets the operator code. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorIcao { get; }
Public ReadOnly Property OperatorIcao As String
    Get
public:
property String^ OperatorIcao {
    String^ get ();
}
member OperatorIcao : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.OperatorName Property

AircraftDetailOperatorName Property
Gets the operator name. If the BaseStation database record is present it takes precedence over the OnlineAircraft record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorName { get; }
Public ReadOnly Property OperatorName As String
    Get
public:
property String^ OperatorName {
    String^ get ();
}
member OperatorName : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.Picture Property

AircraftDetailPicture Property
Gets or sets information about the picture associated with the aircraft. This can be null if no picture has been found for the aircraft (yet).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PictureDetail Picture { get; set; }
Public Property Picture As PictureDetail
    Get
    Set
public:
property PictureDetail^ Picture {
    PictureDetail^ get ();
    void set (PictureDetail^ value);
}
member Picture : PictureDetail with get, set

Property Value

Type: PictureDetail
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.Serial Property

AircraftDetailSerial Property
Gets the serial number.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Serial { get; }
Public ReadOnly Property Serial As String
    Get
public:
property String^ Serial {
    String^ get ();
}
member Serial : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.YearBuilt Property

AircraftDetailYearBuilt Property
Gets the year built.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string YearBuilt { get; }
Public ReadOnly Property YearBuilt As String
    Get
public:
property String^ YearBuilt {
    String^ get ();
}
member YearBuilt : string with get

Property Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail Methods

AircraftDetail Methods

The AircraftDetail type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftDetail.ToString Method

AircraftDetailToString Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AircraftDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail) Class

AircraftFetcherTKey, TDetail Class
A base class for fetcher implementations that register an aircraft and then periodically fetch records related to that aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAircraftFetcherTKey, TDetail

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class AircraftFetcher<TKey, TDetail> : IDisposable
where TDetail : class

Public MustInherit Class AircraftFetcher(Of TKey, TDetail As Class)
    Implements IDisposable
generic<typename TKey, typename TDetail>
where TDetail : ref class
public ref class AircraftFetcher abstract : IDisposable
[<AbstractClassAttribute>]
type AircraftFetcher<'TKey, 'TDetail when 'TDetail : not struct> =
    class
        interface IDisposable
    end

Type Parameters

TKey
The type of key to use when indexing the lookup details.
TDetail
The type of the DTO returned by the fetcher.

The AircraftFetcherTKey, TDetail type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftFetcherTKey, TDetail | Creates a new object.
Top
Properties
 | Name | Description
Protected property | AutomaticDeregisterIntervalMilliseconds | Gets the number of milliseconds that have to pass after the last registration before the aircraft is automatically deregistered.
Protected property | AutomaticRecheckIntervalMilliseconds | Gets the number of milliseconds between automatic refetches of the aircraft data. 0 indicates that automatic refetching is not required.
Protected property | Disposed | Gets a value indicating that the object has been disposed.
Protected property | ForceRefetchOnFastTick | Gets or sets a value that, when set, will force a refresh of all aircraft on the next fast tick.
Top
Methods
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Protected method | DoExtraFastTimerTickWork | Called after the basic fast timer tick work has been completed.
Protected method | DoExtraSlowTimerTickWork | Called after the basic slow timer tick work has been completed.
Protected method | DoFetchAircraft | Fetches the detail for the aircraft, raising any events necessary when a change has been detected.
Protected method | DoFetchManyAircraft | When overridden by a derivee this fetches many aircraft details simultaneously.
Protected method | DoInitialise | Initialises the object. This is called within a lock, do not call Initialise from within this.
Protected method | DoRegisterAircraft | Registers or refreshes the entry for the key passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FauxFetchAircraft | Fakes an aircraft fetch. Some derivees may hook events that pre-fetch the interesting data and they don't want to fetch it again with a call to FetchAircraft, so this applies the same lock as FetchAircraft and calls the action passed across.
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Protected method | GetFetchedDetailUnderLock | Returns the fetched detail for a key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRegisteredAircraft | Returns a copy of the dictionary that holds all of the registered aircraft for which at least one fetch has already been made.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise | Initialises the object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RecheckAll | Refetches all expired records, optionally forcing a refetch of records even if they have not expired.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
There are no unit tests on this class, it is an implementation detail for fetchers that use it. The unit tests must be on the fetchers themselves.
See Also

Reference

VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail) Constructor

AircraftFetcherTKey, TDetail Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftFetcher()
Public Sub New
public:
AircraftFetcher()
new : unit -> AircraftFetcher
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail) Properties

AircraftFetcherTKey, TDetail Properties

The AircraftFetcherTKey, TDetail generic type exposes the following members.

Properties
 | Name | Description
Protected property | AutomaticDeregisterIntervalMilliseconds | Gets the number of milliseconds that have to pass after the last registration before the aircraft is automatically deregistered.
Protected property | AutomaticRecheckIntervalMilliseconds | Gets the number of milliseconds between automatic refetches of the aircraft data. 0 indicates that automatic refetching is not required.
Protected property | Disposed | Gets a value indicating that the object has been disposed.
Protected property | ForceRefetchOnFastTick | Gets or sets a value that, when set, will force a refresh of all aircraft on the next fast tick.
Top
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).AutomaticDeregisterIntervalMilliseconds Property

AircraftFetcherTKey, TDetailAutomaticDeregisterIntervalMilliseconds Property
Gets the number of milliseconds that have to pass after the last registration before the aircraft is automatically deregistered.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract int AutomaticDeregisterIntervalMilliseconds { get; }
Protected MustOverride ReadOnly Property AutomaticDeregisterIntervalMilliseconds As Integer
    Get
protected:
virtual property int AutomaticDeregisterIntervalMilliseconds {
    int get () abstract;
}
abstract AutomaticDeregisterIntervalMilliseconds : int with get

Property Value

Type: Int32
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).AutomaticRecheckIntervalMilliseconds Property

AircraftFetcherTKey, TDetailAutomaticRecheckIntervalMilliseconds Property
Gets the number of milliseconds between automatic refetches of the aircraft data. 0 indicates that automatic refetching is not required.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract int AutomaticRecheckIntervalMilliseconds { get; }
Protected MustOverride ReadOnly Property AutomaticRecheckIntervalMilliseconds As Integer
    Get
protected:
virtual property int AutomaticRecheckIntervalMilliseconds {
    int get () abstract;
}
abstract AutomaticRecheckIntervalMilliseconds : int with get

Property Value

Type: Int32
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).Disposed Property

AircraftFetcherTKey, TDetailDisposed Property
Gets a value indicating that the object has been disposed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool Disposed { get; }
Protected ReadOnly Property Disposed As Boolean
    Get
protected:
property bool Disposed {
    bool get ();
}
member Disposed : bool with get

Property Value

Type: Boolean
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).ForceRefetchOnFastTick Property

AircraftFetcherTKey, TDetailForceRefetchOnFastTick Property
Gets or sets a value that, when set, will force a refresh of all aircraft on the next fast tick.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool ForceRefetchOnFastTick { get; set; }
Protected Property ForceRefetchOnFastTick As Boolean
    Get
    Set
protected:
property bool ForceRefetchOnFastTick {
    bool get ();
    void set (bool value);
}
member ForceRefetchOnFastTick : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail) Methods

AircraftFetcherTKey, TDetail Methods

The AircraftFetcherTKey, TDetail generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Protected method | DoExtraFastTimerTickWork | Called after the basic fast timer tick work has been completed.
Protected method | DoExtraSlowTimerTickWork | Called after the basic slow timer tick work has been completed.
Protected method | DoFetchAircraft | Fetches the detail for the aircraft, raising any events necessary when a change has been detected.
Protected method | DoFetchManyAircraft | When overridden by a derivee this fetches many aircraft details simultaneously.
Protected method | DoInitialise | Initialises the object. This is called within a lock, do not call Initialise from within this.
Protected method | DoRegisterAircraft | Registers or refreshes the entry for the key passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FauxFetchAircraft | Fakes an aircraft fetch. Some derivees may hook events that pre-fetch the interesting data and they don't want to fetch it again with a call to FetchAircraft, so this applies the same lock as FetchAircraft and calls the action passed across.
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Protected method | GetFetchedDetailUnderLock | Returns the fetched detail for a key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRegisteredAircraft | Returns a copy of the dictionary that holds all of the registered aircraft for which at least one fetch has already been made.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialise | Initialises the object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RecheckAll | Refetches all expired records, optionally forcing a refetch of records even if they have not expired.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).Dispose Method

AircraftFetcherTKey, TDetailDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Top
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).Dispose Method

AircraftFetcherTKey, TDetailDispose Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AircraftFetcherTKey, TDetail Class
Dispose Overload
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).Dispose Method (Boolean)

AircraftFetcherTKey, TDetailDispose Method (Boolean)
Disposes of or finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

AircraftFetcherTKey, TDetail Class
Dispose Overload
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).DoExtraFastTimerTickWork Method

AircraftFetcherTKey, TDetailDoExtraFastTimerTickWork Method
Called after the basic fast timer tick work has been completed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoExtraFastTimerTickWork()
Protected Overridable Sub DoExtraFastTimerTickWork
protected:
virtual void DoExtraFastTimerTickWork()
abstract DoExtraFastTimerTickWork : unit -> unit
override DoExtraFastTimerTickWork : unit -> unit
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).DoExtraSlowTimerTickWork Method

AircraftFetcherTKey, TDetailDoExtraSlowTimerTickWork Method
Called after the basic slow timer tick work has been completed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoExtraSlowTimerTickWork()
Protected Overridable Sub DoExtraSlowTimerTickWork
protected:
virtual void DoExtraSlowTimerTickWork()
abstract DoExtraSlowTimerTickWork : unit -> unit
override DoExtraSlowTimerTickWork : unit -> unit
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).DoFetchAircraft Method

AircraftFetcherTKey, TDetailDoFetchAircraft Method
Fetches the detail for the aircraft, raising any events necessary when a change has been detected.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract TDetail DoFetchAircraft(
    AircraftFetcherTKey, TDetailFetchedDetail fetchedDetail
)
Protected MustOverride Function DoFetchAircraft (
    fetchedDetail As AircraftFetcherTKey, TDetailFetchedDetail
) As TDetail
protected:
virtual TDetail DoFetchAircraft(
    AircraftFetcherTKey, TDetailFetchedDetail^ fetchedDetail
) abstract
abstract DoFetchAircraft :
        fetchedDetail : AircraftFetcherTKey, TDetailFetchedDetail -> 'TDetail

Parameters

fetchedDetail
Type: VirtualRadar.InterfaceAircraftFetcherTKey, TDetailFetchedDetail

Return Value

Type: TDetail
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).DoFetchManyAircraft Method

AircraftFetcherTKey, TDetailDoFetchManyAircraft Method
When overridden by a derivee this fetches many aircraft details simultaneously.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual bool DoFetchManyAircraft(
    IEnumerable<AircraftFetcherTKey, TDetailFetchedDetail> fetchedDetails
)
Protected Overridable Function DoFetchManyAircraft (
    fetchedDetails As IEnumerable(Of AircraftFetcherTKey, TDetailFetchedDetail)
) As Boolean
protected:
virtual bool DoFetchManyAircraft(
    IEnumerable<AircraftFetcherTKey, TDetailFetchedDetail^>^ fetchedDetails
)
abstract DoFetchManyAircraft :
        fetchedDetails : IEnumerable<AircraftFetcherTKey, TDetailFetchedDetail> -> bool
override DoFetchManyAircraft :
        fetchedDetails : IEnumerable<AircraftFetcherTKey, TDetailFetchedDetail> -> bool

Parameters

fetchedDetails
Type: System.Collections.GenericIEnumerable AircraftFetcherTKey, TDetailFetchedDetail
The aircraft to fetch.

Return Value

Type: Boolean
False if the derivee does not support fetching many details simultaneously, or if the derivee could not fetch multiple aircraft, in which case each aircraft is fetched individually. True if the derivee fetched all aircraft successfully.
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).DoInitialise Method

AircraftFetcherTKey, TDetailDoInitialise Method
Initialises the object. This is called within a lock, do not call Initialise from within this.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoInitialise()
Protected Overridable Sub DoInitialise
protected:
virtual void DoInitialise()
abstract DoInitialise : unit -> unit
override DoInitialise : unit -> unit
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).DoRegisterAircraft Method

AircraftFetcherTKey, TDetailDoRegisterAircraft Method
Registers or refreshes the entry for the key passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual TDetail DoRegisterAircraft(
    TKey key,
    IAircraft aircraft
)
Protected Overridable Function DoRegisterAircraft (
    key As TKey,
    aircraft As IAircraft
) As TDetail
protected:
virtual TDetail DoRegisterAircraft(
    TKey key,
    IAircraft^ aircraft
)
abstract DoRegisterAircraft :
        key : 'TKey *
        aircraft : IAircraft -> 'TDetail
override DoRegisterAircraft :
        key : 'TKey *
        aircraft : IAircraft -> 'TDetail

Parameters

key
Type: TKey
The key to register. This must be usable within a dictionary.
aircraft
Type: VirtualRadar.InterfaceIAircraft
The aircraft to associate with the key, if any. Pass null if the aircraft is unknown.

Return Value

Type: TDetail
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FauxFetchAircraft Method

AircraftFetcherTKey, TDetailFauxFetchAircraft Method
Fakes an aircraft fetch. Some derivees may hook events that pre-fetch the interesting data and they don't want to fetch it again with a call to FetchAircraft, so this applies the same lock as FetchAircraft and calls the action passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void FauxFetchAircraft(
    TKey key,
    Func<TKey, TDetail, bool, IAircraft, TDetail> fakeFetchAircraft
)
Protected Sub FauxFetchAircraft (
    key As TKey,
    fakeFetchAircraft As Func(Of TKey, TDetail, Boolean, IAircraft, TDetail)
)
protected:
void FauxFetchAircraft(
    TKey key,
    Func<TKey, TDetail, bool, IAircraft^, TDetail>^ fakeFetchAircraft
)
member FauxFetchAircraft :
        key : 'TKey *
        fakeFetchAircraft : Func<'TKey, 'TDetail, bool, IAircraft, 'TDetail> -> unit

Parameters

key
Type: TKey
fakeFetchAircraft
Type: SystemFunc TKey, TDetail, Boolean, IAircraft, TDetail
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).Finalize Method

AircraftFetcherTKey, TDetailFinalize Method
Finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).GetFetchedDetailUnderLock Method

AircraftFetcherTKey, TDetailGetFetchedDetailUnderLock Method
Returns the fetched detail for a key.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected AircraftFetcherTKey, TDetailFetchedDetail GetFetchedDetailUnderLock(
    TKey key
)
Protected Function GetFetchedDetailUnderLock (
    key As TKey
) As AircraftFetcherTKey, TDetailFetchedDetail
protected:
AircraftFetcherTKey, TDetailFetchedDetail^ GetFetchedDetailUnderLock(
    TKey key
)
member GetFetchedDetailUnderLock :
        key : 'TKey -> AircraftFetcherTKey, TDetailFetchedDetail

Parameters

key
Type: TKey

Return Value

Type: AircraftFetcherTKey, TDetailFetchedDetail
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).GetRegisteredAircraft Method

AircraftFetcherTKey, TDetailGetRegisteredAircraft Method
Returns a copy of the dictionary that holds all of the registered aircraft for which at least one fetch has already been made.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual Dictionary<TKey, TDetail> GetRegisteredAircraft()
Protected Overridable Function GetRegisteredAircraft As Dictionary(Of TKey, TDetail)
protected:
virtual Dictionary<TKey, TDetail>^ GetRegisteredAircraft()
abstract GetRegisteredAircraft : unit -> Dictionary<'TKey, 'TDetail>
override GetRegisteredAircraft : unit -> Dictionary<'TKey, 'TDetail>

Return Value

Type: Dictionary TKey, TDetail
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).Initialise Method

AircraftFetcherTKey, TDetailInitialise Method
Initialises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void Initialise()
Protected Sub Initialise
protected:
void Initialise()
member Initialise : unit -> unit
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).RecheckAll Method

AircraftFetcherTKey, TDetailRecheckAll Method
Refetches all expired records, optionally forcing a refetch of records even if they have not expired.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void RecheckAll(
    bool forceRefetch
)
Protected Sub RecheckAll (
    forceRefetch As Boolean
)
protected:
void RecheckAll(
    bool forceRefetch
)
member RecheckAll :
        forceRefetch : bool -> unit

Parameters

forceRefetch
Type: SystemBoolean
True to fetch records that have already been recently fetched, false to only fetch those records that are past the AutomaticRecheckIntervalMilliseconds interval.
See Also

Reference

AircraftFetcherTKey, TDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail Class

AircraftFetcherTKey, TDetailFetchedDetail Class
The fetched detail for an aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAircraftFetcherTKey, TDetailFetchedDetail

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected class FetchedDetail
Protected Class FetchedDetail
protected ref class FetchedDetail
type FetchedDetail =  class end

The AircraftFetcherTKey, TDetailFetchedDetail generic type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftFetcherTKey, TDetailFetchedDetail | Initializes a new instance of the AircraftFetcherTKey, TDetailFetchedDetail class
Top
Properties
 | Name | Description
Public property | Aircraft | Gets or sets the aircraft associated with the key, if known.
Public property | Detail | Gets or sets the detail associated with the key.
Public property | IsFirstFetch | Gets a value indicating that the aircraft's details have not yet been fetched.
Public property | Key | Gets or sets the key for the fetched detail record.
Public property | LastCheckedUtc | Gets or sets the time that the details were last fetched.
Public property | LastRegisteredUtc | Gets or sets the time that the key was last used in a registration call.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail Constructor

AircraftFetcherTKey, TDetailFetchedDetail Constructor
Initializes a new instance of the AircraftFetcherTKey, TDetailFetchedDetail class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FetchedDetail()
Public Sub New
public:
FetchedDetail()
new : unit -> FetchedDetail
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


FetchedDetail Properties

FetchedDetail Properties

The AircraftFetcherTKey, TDetailFetchedDetail type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets or sets the aircraft associated with the key, if known.
Public property | Detail | Gets or sets the detail associated with the key.
Public property | IsFirstFetch | Gets a value indicating that the aircraft's details have not yet been fetched.
Public property | Key | Gets or sets the key for the fetched detail record.
Public property | LastCheckedUtc | Gets or sets the time that the details were last fetched.
Public property | LastRegisteredUtc | Gets or sets the time that the key was last used in a registration call.
Top
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail.Aircraft Property

AircraftFetcherTKey, TDetailFetchedDetailAircraft Property
Gets or sets the aircraft associated with the key, if known.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IAircraft Aircraft { get; set; }
Public Property Aircraft As IAircraft
    Get
    Set
public:
property IAircraft^ Aircraft {
    IAircraft^ get ();
    void set (IAircraft^ value);
}
member Aircraft : IAircraft with get, set

Property Value

Type: IAircraft
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail.Detail Property

AircraftFetcherTKey, TDetailFetchedDetailDetail Property
Gets or sets the detail associated with the key.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TDetail Detail { get; set; }
Public Property Detail As TDetail
    Get
    Set
public:
property TDetail Detail {
    TDetail get ();
    void set (TDetail value);
}
member Detail : 'TDetail with get, set

Property Value

Type: TDetail
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail.IsFirstFetch Property

AircraftFetcherTKey, TDetailFetchedDetailIsFirstFetch Property
Gets a value indicating that the aircraft's details have not yet been fetched.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFirstFetch { get; }
Public ReadOnly Property IsFirstFetch As Boolean
    Get
public:
property bool IsFirstFetch {
    bool get ();
}
member IsFirstFetch : bool with get

Property Value

Type: Boolean
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail.Key Property

AircraftFetcherTKey, TDetailFetchedDetailKey Property
Gets or sets the key for the fetched detail record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TKey Key { get; set; }
Public Property Key As TKey
    Get
    Set
public:
property TKey Key {
    TKey get ();
    void set (TKey value);
}
member Key : 'TKey with get, set

Property Value

Type: TKey
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail.LastCheckedUtc Property

AircraftFetcherTKey, TDetailFetchedDetailLastCheckedUtc Property
Gets or sets the time that the details were last fetched.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastCheckedUtc { get; set; }
Public Property LastCheckedUtc As DateTime
    Get
    Set
public:
property DateTime LastCheckedUtc {
    DateTime get ();
    void set (DateTime value);
}
member LastCheckedUtc : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftFetcher(TKey, TDetail).FetchedDetail.LastRegisteredUtc Property

AircraftFetcherTKey, TDetailFetchedDetailLastRegisteredUtc Property
Gets or sets the time that the key was last used in a registration call.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastRegisteredUtc { get; set; }
Public Property LastRegisteredUtc As DateTime
    Get
    Set
public:
property DateTime LastRegisteredUtc {
    DateTime get ();
    void set (DateTime value);
}
member LastRegisteredUtc : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


FetchedDetail Methods

FetchedDetail Methods

The AircraftFetcherTKey, TDetailFetchedDetail type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftFetcherTKey, TDetailFetchedDetail Class
VirtualRadar.Interface Namespace


AircraftListSource Enumeration

AircraftListSource Enumeration
An enumeration of the different sources that aircraft lists can come from.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AircraftListSource
Public Enumeration AircraftListSource
public enum class AircraftListSource
type AircraftListSource
Members
Member name | Value | Description
BaseStation | 1 | A BaseStation data feed.
FakeAircraftList | 2 | A fake aircraft list generated by the user.
FlightSimulatorX | 3 | A Flight Simulator X SimConnect object.
Remarks
These are sent to the Javascript as integers, try not to change the values.
See Also

Reference

VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail Class

AircraftOnlineLookupDetail Class
Holds the detail for an aircraft whose details were fetched by IAircraftOnlineLookup.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAircraftOnlineLookupDetail

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftOnlineLookupDetail
Public Class AircraftOnlineLookupDetail
public ref class AircraftOnlineLookupDetail
type AircraftOnlineLookupDetail =  class end

The AircraftOnlineLookupDetail type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftOnlineLookupDetail | Initializes a new instance of the AircraftOnlineLookupDetail class
Top
Properties
 | Name | Description
Public property | AircraftDetailId | Gets or sets the cache's identifier for the record. This is not sent by the online service, it is for use by the cache. This is ignored by ContentEquals(AircraftOnlineLookupDetail).
Public property | Country | Gets or sets the aircraft's country of registration.
Public property | CreatedUtc | Gets or sets the date that the cache record was created. This is not sent by the online service, it is for use by the cache. It is not considered by ContentEquals(AircraftOnlineLookupDetail).
Public property | Icao | Gets or sets the aircraft's ICAO.
Public property | Manufacturer | Gets or sets the aircraft's manufacturer.
Public property | Model | Gets or sets the aircraft model.
Public property | ModelIcao | Gets or sets the aircraft model's ICAO 8643 code.
Public property | Operator | Gets or sets the aircraft's operator.
Public property | OperatorIcao | Gets or sets the aircraft's operator ICAO.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | Serial | Gets or sets the aircraft's serial number.
Public property | UpdatedUtc | Gets or sets the date that the cache record was last updated. This is not sent by the online service, it is for use by the cache. It is not considered by ContentEquals(AircraftOnlineLookupDetail).
Public property | YearBuilt | Gets or sets the aircraft's year of manufacture.
Top
Methods
 | Name | Description
Public method | ContentEquals | Returns true if the content (everything excluding AircraftDetailId, CreatedUtc and UpdatedUtc) of the other object passed in is the same as this object's content.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail Constructor

AircraftOnlineLookupDetail Constructor
Initializes a new instance of the AircraftOnlineLookupDetail class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOnlineLookupDetail()
Public Sub New
public:
AircraftOnlineLookupDetail()
new : unit -> AircraftOnlineLookupDetail
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail Properties

AircraftOnlineLookupDetail Properties

The AircraftOnlineLookupDetail type exposes the following members.

Properties
 | Name | Description
Public property | AircraftDetailId | Gets or sets the cache's identifier for the record. This is not sent by the online service, it is for use by the cache. This is ignored by ContentEquals(AircraftOnlineLookupDetail).
Public property | Country | Gets or sets the aircraft's country of registration.
Public property | CreatedUtc | Gets or sets the date that the cache record was created. This is not sent by the online service, it is for use by the cache. It is not considered by ContentEquals(AircraftOnlineLookupDetail).
Public property | Icao | Gets or sets the aircraft's ICAO.
Public property | Manufacturer | Gets or sets the aircraft's manufacturer.
Public property | Model | Gets or sets the aircraft model.
Public property | ModelIcao | Gets or sets the aircraft model's ICAO 8643 code.
Public property | Operator | Gets or sets the aircraft's operator.
Public property | OperatorIcao | Gets or sets the aircraft's operator ICAO.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | Serial | Gets or sets the aircraft's serial number.
Public property | UpdatedUtc | Gets or sets the date that the cache record was last updated. This is not sent by the online service, it is for use by the cache. It is not considered by ContentEquals(AircraftOnlineLookupDetail).
Public property | YearBuilt | Gets or sets the aircraft's year of manufacture.
Top
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.AircraftDetailId Property

AircraftOnlineLookupDetailAircraftDetailId Property
Gets or sets the cache's identifier for the record. This is not sent by the online service, it is for use by the cache. This is ignored by ContentEquals(AircraftOnlineLookupDetail).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long AircraftDetailId { get; set; }
Public Property AircraftDetailId As Long
    Get
    Set
public:
property long long AircraftDetailId {
    long long get ();
    void set (long long value);
}
member AircraftDetailId : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Country Property

AircraftOnlineLookupDetailCountry Property
Gets or sets the aircraft's country of registration.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
member Country : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.CreatedUtc Property

AircraftOnlineLookupDetailCreatedUtc Property
Gets or sets the date that the cache record was created. This is not sent by the online service, it is for use by the cache. It is not considered by ContentEquals(AircraftOnlineLookupDetail).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> CreatedUtc { get; set; }
Public Property CreatedUtc As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreatedUtc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CreatedUtc : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Icao Property

AircraftOnlineLookupDetailIcao Property
Gets or sets the aircraft's ICAO.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao { get; set; }
Public Property Icao As String
    Get
    Set
public:
property String^ Icao {
    String^ get ();
    void set (String^ value);
}
member Icao : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Manufacturer Property

AircraftOnlineLookupDetailManufacturer Property
Gets or sets the aircraft's manufacturer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Model Property

AircraftOnlineLookupDetailModel Property
Gets or sets the aircraft model.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Model { get; set; }
Public Property Model As String
    Get
    Set
public:
property String^ Model {
    String^ get ();
    void set (String^ value);
}
member Model : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.ModelIcao Property

AircraftOnlineLookupDetailModelIcao Property
Gets or sets the aircraft model's ICAO 8643 code.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModelIcao { get; set; }
Public Property ModelIcao As String
    Get
    Set
public:
property String^ ModelIcao {
    String^ get ();
    void set (String^ value);
}
member ModelIcao : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Operator Property

AircraftOnlineLookupDetailOperator Property
Gets or sets the aircraft's operator.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Operator { get; set; }
Public Property Operator As String
    Get
    Set
public:
property String^ Operator {
    String^ get ();
    void set (String^ value);
}
member Operator : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.OperatorIcao Property

AircraftOnlineLookupDetailOperatorIcao Property
Gets or sets the aircraft's operator ICAO.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorIcao { get; set; }
Public Property OperatorIcao As String
    Get
    Set
public:
property String^ OperatorIcao {
    String^ get ();
    void set (String^ value);
}
member OperatorIcao : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Registration Property

AircraftOnlineLookupDetailRegistration Property
Gets or sets the aircraft's registration.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration { get; set; }
Public Property Registration As String
    Get
    Set
public:
property String^ Registration {
    String^ get ();
    void set (String^ value);
}
member Registration : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.Serial Property

AircraftOnlineLookupDetailSerial Property
Gets or sets the aircraft's serial number.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Serial { get; set; }
Public Property Serial As String
    Get
    Set
public:
property String^ Serial {
    String^ get ();
    void set (String^ value);
}
member Serial : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.UpdatedUtc Property

AircraftOnlineLookupDetailUpdatedUtc Property
Gets or sets the date that the cache record was last updated. This is not sent by the online service, it is for use by the cache. It is not considered by ContentEquals(AircraftOnlineLookupDetail).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> UpdatedUtc { get; set; }
Public Property UpdatedUtc As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> UpdatedUtc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member UpdatedUtc : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.YearBuilt Property

AircraftOnlineLookupDetailYearBuilt Property
Gets or sets the aircraft's year of manufacture.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> YearBuilt { get; set; }
Public Property YearBuilt As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> YearBuilt {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member YearBuilt : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail Methods

AircraftOnlineLookupDetail Methods

The AircraftOnlineLookupDetail type exposes the following members.

Methods
 | Name | Description
Public method | ContentEquals | Returns true if the content (everything excluding AircraftDetailId, CreatedUtc and UpdatedUtc) of the other object passed in is the same as this object's content.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupDetail.ContentEquals Method

AircraftOnlineLookupDetailContentEquals Method
Returns true if the content (everything excluding AircraftDetailId, CreatedUtc and UpdatedUtc) of the other object passed in is the same as this object's content.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContentEquals(
    AircraftOnlineLookupDetail other
)
Public Function ContentEquals (
    other As AircraftOnlineLookupDetail
) As Boolean
public:
bool ContentEquals(
    AircraftOnlineLookupDetail^ other
)
member ContentEquals :
        other : AircraftOnlineLookupDetail -> bool

Parameters

other
Type: VirtualRadar.InterfaceAircraftOnlineLookupDetail

Return Value

Type: Boolean
See Also

Reference

AircraftOnlineLookupDetail Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs Class

AircraftOnlineLookupEventArgs Class
The event args used by IAircraftOnlineLookup.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.InterfaceAircraftOnlineLookupEventArgs

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftOnlineLookupEventArgs : EventArgs
Public Class AircraftOnlineLookupEventArgs
    Inherits EventArgs
public ref class AircraftOnlineLookupEventArgs : public EventArgs
type AircraftOnlineLookupEventArgs =
    class
        inherit EventArgs
    end

The AircraftOnlineLookupEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftOnlineLookupEventArgs(AircraftOnlineLookupDetail) | Creates a new object.
Public method | AircraftOnlineLookupEventArgs(IEnumerableAircraftOnlineLookupDetail, IEnumerableString) | Creates a new object.
Top
Properties
 | Name | Description
Public property | AircraftDetails | Gets the details for the aircraft that could be found.
Public property | MissingIcaos | Gets the list of ICAOs for which the online source had no details.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs Constructor

AircraftOnlineLookupEventArgs Constructor
Overload List
 | Name | Description
Public method | AircraftOnlineLookupEventArgs(AircraftOnlineLookupDetail) | Creates a new object.
Public method | AircraftOnlineLookupEventArgs(IEnumerableAircraftOnlineLookupDetail, IEnumerableString) | Creates a new object.
Top
See Also

Reference

AircraftOnlineLookupEventArgs Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs Constructor (AircraftOnlineLookupDetail)

AircraftOnlineLookupEventArgs Constructor (AircraftOnlineLookupDetail)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOnlineLookupEventArgs(
    AircraftOnlineLookupDetail fetchedAircraft
)
Public Sub New (
    fetchedAircraft As AircraftOnlineLookupDetail
)
public:
AircraftOnlineLookupEventArgs(
    AircraftOnlineLookupDetail^ fetchedAircraft
)
new :
        fetchedAircraft : AircraftOnlineLookupDetail -> AircraftOnlineLookupEventArgs

Parameters

fetchedAircraft
Type: VirtualRadar.InterfaceAircraftOnlineLookupDetail
See Also

Reference

AircraftOnlineLookupEventArgs Class
AircraftOnlineLookupEventArgs Overload
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs Constructor (IEnumerable(AircraftOnlineLookupDetail), IEnumerable(String))

AircraftOnlineLookupEventArgs Constructor (IEnumerableAircraftOnlineLookupDetail, IEnumerableString)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOnlineLookupEventArgs(
    IEnumerable<AircraftOnlineLookupDetail> fetchedAircraft,
    IEnumerable<string> missingIcaos
)
Public Sub New (
    fetchedAircraft As IEnumerable(Of AircraftOnlineLookupDetail),
    missingIcaos As IEnumerable(Of String)
)
public:
AircraftOnlineLookupEventArgs(
    IEnumerable<AircraftOnlineLookupDetail^>^ fetchedAircraft,
    IEnumerable<String^>^ missingIcaos
)
new :
        fetchedAircraft : IEnumerable<AircraftOnlineLookupDetail> *
        missingIcaos : IEnumerable<string> -> AircraftOnlineLookupEventArgs

Parameters

fetchedAircraft
Type: System.Collections.GenericIEnumerable AircraftOnlineLookupDetail
missingIcaos
Type: System.Collections.GenericIEnumerable String
See Also

Reference

AircraftOnlineLookupEventArgs Class
AircraftOnlineLookupEventArgs Overload
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs Properties

AircraftOnlineLookupEventArgs Properties

The AircraftOnlineLookupEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AircraftDetails | Gets the details for the aircraft that could be found.
Public property | MissingIcaos | Gets the list of ICAOs for which the online source had no details.
Top
See Also

Reference

AircraftOnlineLookupEventArgs Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs.AircraftDetails Property

AircraftOnlineLookupEventArgsAircraftDetails Property
Gets the details for the aircraft that could be found.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<AircraftOnlineLookupDetail> AircraftDetails { get; }
Public ReadOnly Property AircraftDetails As ReadOnlyCollection(Of AircraftOnlineLookupDetail)
    Get
public:
property ReadOnlyCollection<AircraftOnlineLookupDetail^>^ AircraftDetails {
    ReadOnlyCollection<AircraftOnlineLookupDetail^>^ get ();
}
member AircraftDetails : ReadOnlyCollection<AircraftOnlineLookupDetail> with get

Property Value

Type: ReadOnlyCollection AircraftOnlineLookupDetail
See Also

Reference

AircraftOnlineLookupEventArgs Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs.MissingIcaos Property

AircraftOnlineLookupEventArgsMissingIcaos Property
Gets the list of ICAOs for which the online source had no details.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<string> MissingIcaos { get; }
Public ReadOnly Property MissingIcaos As ReadOnlyCollection(Of String)
    Get
public:
property ReadOnlyCollection<String^>^ MissingIcaos {
    ReadOnlyCollection<String^>^ get ();
}
member MissingIcaos : ReadOnlyCollection<string> with get

Property Value

Type: ReadOnlyCollection String
See Also

Reference

AircraftOnlineLookupEventArgs Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupEventArgs Methods

AircraftOnlineLookupEventArgs Methods

The AircraftOnlineLookupEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftOnlineLookupEventArgs Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry Class

AircraftOnlineLookupLogEntry Class
Describes an entry in the IAircraftOnlineLookupLog.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAircraftOnlineLookupLogEntry

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftOnlineLookupLogEntry
Public Class AircraftOnlineLookupLogEntry
public ref class AircraftOnlineLookupLogEntry
type AircraftOnlineLookupLogEntry =  class end

The AircraftOnlineLookupLogEntry type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftOnlineLookupLogEntry | Initializes a new instance of the AircraftOnlineLookupLogEntry class
Top
Properties
 | Name | Description
Public property | Detail | Gets or sets the aircraft detail record. If this is null then the aircraft could not be found.
Public property | Icao | Gets or sets the ICAO requested.
Public property | ResponseUtc | Gets or sets the date and time of the response.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry Constructor

AircraftOnlineLookupLogEntry Constructor
Initializes a new instance of the AircraftOnlineLookupLogEntry class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOnlineLookupLogEntry()
Public Sub New
public:
AircraftOnlineLookupLogEntry()
new : unit -> AircraftOnlineLookupLogEntry
See Also

Reference

AircraftOnlineLookupLogEntry Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry Properties

AircraftOnlineLookupLogEntry Properties

The AircraftOnlineLookupLogEntry type exposes the following members.

Properties
 | Name | Description
Public property | Detail | Gets or sets the aircraft detail record. If this is null then the aircraft could not be found.
Public property | Icao | Gets or sets the ICAO requested.
Public property | ResponseUtc | Gets or sets the date and time of the response.
Top
See Also

Reference

AircraftOnlineLookupLogEntry Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry.Detail Property

AircraftOnlineLookupLogEntryDetail Property
Gets or sets the aircraft detail record. If this is null then the aircraft could not be found.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOnlineLookupDetail Detail { get; set; }
Public Property Detail As AircraftOnlineLookupDetail
    Get
    Set
public:
property AircraftOnlineLookupDetail^ Detail {
    AircraftOnlineLookupDetail^ get ();
    void set (AircraftOnlineLookupDetail^ value);
}
member Detail : AircraftOnlineLookupDetail with get, set

Property Value

Type: AircraftOnlineLookupDetail
See Also

Reference

AircraftOnlineLookupLogEntry Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry.Icao Property

AircraftOnlineLookupLogEntryIcao Property
Gets or sets the ICAO requested.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao { get; set; }
Public Property Icao As String
    Get
    Set
public:
property String^ Icao {
    String^ get ();
    void set (String^ value);
}
member Icao : string with get, set

Property Value

Type: String
See Also

Reference

AircraftOnlineLookupLogEntry Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry.ResponseUtc Property

AircraftOnlineLookupLogEntryResponseUtc Property
Gets or sets the date and time of the response.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ResponseUtc { get; set; }
Public Property ResponseUtc As DateTime
    Get
    Set
public:
property DateTime ResponseUtc {
    DateTime get ();
    void set (DateTime value);
}
member ResponseUtc : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

AircraftOnlineLookupLogEntry Class
VirtualRadar.Interface Namespace


AircraftOnlineLookupLogEntry Methods

AircraftOnlineLookupLogEntry Methods

The AircraftOnlineLookupLogEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftOnlineLookupLogEntry Class
VirtualRadar.Interface Namespace


AirportDataThumbnailJson Class

AirportDataThumbnailJson Class
The JSON object that carries the thumbnail data for an aircraft from www.airport-data.com
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAirportDataThumbnailJson

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AirportDataThumbnailJson
Public Class AirportDataThumbnailJson
public ref class AirportDataThumbnailJson
type AirportDataThumbnailJson =  class end

The AirportDataThumbnailJson type exposes the following members.

Constructors
 | Name | Description
Public method | AirportDataThumbnailJson | Initializes a new instance of the AirportDataThumbnailJson class
Top
Properties
 | Name | Description
Public property | ImageUrl | Gets or sets the URL of the thumbnail image.
Public property | LinkUrl | Gets or sets the URL of the aircraft's page.
Public property | PhotographerName | Gets or sets the name of the copyright holder.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AirportDataThumbnailJson Constructor

AirportDataThumbnailJson Constructor
Initializes a new instance of the AirportDataThumbnailJson class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirportDataThumbnailJson()
Public Sub New
public:
AirportDataThumbnailJson()
new : unit -> AirportDataThumbnailJson
See Also

Reference

AirportDataThumbnailJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailJson Properties

AirportDataThumbnailJson Properties

The AirportDataThumbnailJson type exposes the following members.

Properties
 | Name | Description
Public property | ImageUrl | Gets or sets the URL of the thumbnail image.
Public property | LinkUrl | Gets or sets the URL of the aircraft's page.
Public property | PhotographerName | Gets or sets the name of the copyright holder.
Top
See Also

Reference

AirportDataThumbnailJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailJson.ImageUrl Property

AirportDataThumbnailJsonImageUrl Property
Gets or sets the URL of the thumbnail image.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageUrl { get; set; }
Public Property ImageUrl As String
    Get
    Set
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}
member ImageUrl : string with get, set

Property Value

Type: String
See Also

Reference

AirportDataThumbnailJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailJson.LinkUrl Property

AirportDataThumbnailJsonLinkUrl Property
Gets or sets the URL of the aircraft's page.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LinkUrl { get; set; }
Public Property LinkUrl As String
    Get
    Set
public:
property String^ LinkUrl {
    String^ get ();
    void set (String^ value);
}
member LinkUrl : string with get, set

Property Value

Type: String
See Also

Reference

AirportDataThumbnailJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailJson.PhotographerName Property

AirportDataThumbnailJsonPhotographerName Property
Gets or sets the name of the copyright holder.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PhotographerName { get; set; }
Public Property PhotographerName As String
    Get
    Set
public:
property String^ PhotographerName {
    String^ get ();
    void set (String^ value);
}
member PhotographerName : string with get, set

Property Value

Type: String
See Also

Reference

AirportDataThumbnailJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailJson Methods

AirportDataThumbnailJson Methods

The AirportDataThumbnailJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AirportDataThumbnailJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailsJson Class

AirportDataThumbnailsJson Class
The DTO carrying the result of a JSON request for multiple thumbnails from www.airport-data.com.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAirportDataThumbnailsJson

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AirportDataThumbnailsJson
Public Class AirportDataThumbnailsJson
public ref class AirportDataThumbnailsJson
type AirportDataThumbnailsJson =  class end

The AirportDataThumbnailsJson type exposes the following members.

Constructors
 | Name | Description
Public method | AirportDataThumbnailsJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | Error | Gets or sets the optional error message returned by the site.
Public property | Status | Gets or sets the status code returned within the body of the result.
Public property | Thumbnails | Gets the list of thumbnails retrieved from the server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


AirportDataThumbnailsJson Constructor

AirportDataThumbnailsJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirportDataThumbnailsJson()
Public Sub New
public:
AirportDataThumbnailsJson()
new : unit -> AirportDataThumbnailsJson
See Also

Reference

AirportDataThumbnailsJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailsJson Properties

AirportDataThumbnailsJson Properties

The AirportDataThumbnailsJson type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets or sets the optional error message returned by the site.
Public property | Status | Gets or sets the status code returned within the body of the result.
Public property | Thumbnails | Gets the list of thumbnails retrieved from the server.
Top
See Also

Reference

AirportDataThumbnailsJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailsJson.Error Property

AirportDataThumbnailsJsonError Property
Gets or sets the optional error message returned by the site.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Error { get; set; }
Public Property Error As String
    Get
    Set
public:
property String^ Error {
    String^ get ();
    void set (String^ value);
}
member Error : string with get, set

Property Value

Type: String
See Also

Reference

AirportDataThumbnailsJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailsJson.Status Property

AirportDataThumbnailsJsonStatus Property
Gets or sets the status code returned within the body of the result.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Status { get; set; }
Public Property Status As Integer
    Get
    Set
public:
property int Status {
    int get ();
    void set (int value);
}
member Status : int with get, set

Property Value

Type: Int32
See Also

Reference

AirportDataThumbnailsJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailsJson.Thumbnails Property

AirportDataThumbnailsJsonThumbnails Property
Gets the list of thumbnails retrieved from the server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<AirportDataThumbnailJson> Thumbnails { get; }
Public ReadOnly Property Thumbnails As List(Of AirportDataThumbnailJson)
    Get
public:
property List<AirportDataThumbnailJson^>^ Thumbnails {
    List<AirportDataThumbnailJson^>^ get ();
}
member Thumbnails : List<AirportDataThumbnailJson> with get

Property Value

Type: List AirportDataThumbnailJson
See Also

Reference

AirportDataThumbnailsJson Class
VirtualRadar.Interface Namespace


AirportDataThumbnailsJson Methods

AirportDataThumbnailsJson Methods

The AirportDataThumbnailsJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AirportDataThumbnailsJson Class
VirtualRadar.Interface Namespace


AirPressure Class

AirPressure Class
An air pressure reading, as downloaded from the SDM site.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceAirPressure

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AirPressure
Public Class AirPressure
public ref class AirPressure
type AirPressure =  class end

The AirPressure type exposes the following members.

Constructors
 | Name | Description
Public method | AirPressure | Initializes a new instance of the AirPressure class
Top
Properties
 | Name | Description
Public property | AgeSeconds | Gets or sets the age of the observation in seconds (from when the fetch occurred).
Public property | Latitude | Gets or sets the latitude where the observation was made.
Public property | Longitude | Gets or sets the longitude where the observation was made.
Public property | PressureInHg | Gets or sets the air pressure in inches of mercury.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GeometricAltitudeToPressureAltitude(NullableInt32) | Takes a geometric altitude and returns the pressure altitude for a given air pressure reading.
 | GeometricAltitudeToPressureAltitude(NullableInt32, Single) | Takes a geometric altitude and air pressure reading and returns the pressure altitude for a given air pressure reading.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InHgToMillibars | Converts pressure settings in inches of mercury to millibars.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillibarsToInHg | Converts pressure settings in millibars to inches of mercury.
Public method | ObservationTimeUtc | Returns the time that the air pressure observation was made.
Public method | PressureAltitudeToGeometricAltitude(NullableInt32) | Takes a pressure altitude and returns the geometric altitude.
 | PressureAltitudeToGeometricAltitude(NullableInt32, Single) | Takes a pressure altitude and pressure setting, and returns the geometric altitude.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
OneMillibarToInHg | The number of inches of mercury in one millibar.
StandardPressureInHg | The standard air pressure value in inches of mercury.
Top
See Also

Reference

VirtualRadar.Interface Namespace


AirPressure Constructor

AirPressure Constructor
Initializes a new instance of the AirPressure class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirPressure()
Public Sub New
public:
AirPressure()
new : unit -> AirPressure
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure Properties

AirPressure Properties

The AirPressure type exposes the following members.

Properties
 | Name | Description
Public property | AgeSeconds | Gets or sets the age of the observation in seconds (from when the fetch occurred).
Public property | Latitude | Gets or sets the latitude where the observation was made.
Public property | Longitude | Gets or sets the longitude where the observation was made.
Public property | PressureInHg | Gets or sets the air pressure in inches of mercury.
Top
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.AgeSeconds Property

AirPressureAgeSeconds Property
Gets or sets the age of the observation in seconds (from when the fetch occurred).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short AgeSeconds { get; set; }
Public Property AgeSeconds As Short
    Get
    Set
public:
property short AgeSeconds {
    short get ();
    void set (short value);
}
member AgeSeconds : int16 with get, set

Property Value

Type: Int16
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.Latitude Property

AirPressureLatitude Property
Gets or sets the latitude where the observation was made.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Latitude { get; set; }
Public Property Latitude As Single
    Get
    Set
public:
property float Latitude {
    float get ();
    void set (float value);
}
member Latitude : float32 with get, set

Property Value

Type: Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.Longitude Property

AirPressureLongitude Property
Gets or sets the longitude where the observation was made.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Longitude { get; set; }
Public Property Longitude As Single
    Get
    Set
public:
property float Longitude {
    float get ();
    void set (float value);
}
member Longitude : float32 with get, set

Property Value

Type: Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.PressureInHg Property

AirPressurePressureInHg Property
Gets or sets the air pressure in inches of mercury.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float PressureInHg { get; set; }
Public Property PressureInHg As Single
    Get
    Set
public:
property float PressureInHg {
    float get ();
    void set (float value);
}
member PressureInHg : float32 with get, set

Property Value

Type: Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure Methods

AirPressure Methods

The AirPressure type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GeometricAltitudeToPressureAltitude(NullableInt32) | Takes a geometric altitude and returns the pressure altitude for a given air pressure reading.
 | GeometricAltitudeToPressureAltitude(NullableInt32, Single) | Takes a geometric altitude and air pressure reading and returns the pressure altitude for a given air pressure reading.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InHgToMillibars | Converts pressure settings in inches of mercury to millibars.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillibarsToInHg | Converts pressure settings in millibars to inches of mercury.
Public method | ObservationTimeUtc | Returns the time that the air pressure observation was made.
Public method | PressureAltitudeToGeometricAltitude(NullableInt32) | Takes a pressure altitude and returns the geometric altitude.
 | PressureAltitudeToGeometricAltitude(NullableInt32, Single) | Takes a pressure altitude and pressure setting, and returns the geometric altitude.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.GeometricAltitudeToPressureAltitude Method

AirPressureGeometricAltitudeToPressureAltitude Method
Overload List
 | Name | Description
Public method | GeometricAltitudeToPressureAltitude(NullableInt32) | Takes a geometric altitude and returns the pressure altitude for a given air pressure reading.
 | GeometricAltitudeToPressureAltitude(NullableInt32, Single) | Takes a geometric altitude and air pressure reading and returns the pressure altitude for a given air pressure reading.
Top
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.GeometricAltitudeToPressureAltitude Method (Nullable(Int32))

AirPressureGeometricAltitudeToPressureAltitude Method (NullableInt32)
Takes a geometric altitude and returns the pressure altitude for a given air pressure reading.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> GeometricAltitudeToPressureAltitude(
    Nullable<int> geometricAltitude
)
Public Function GeometricAltitudeToPressureAltitude (
    geometricAltitude As Nullable(Of Integer)
) As Nullable(Of Integer)
public:
Nullable<int> GeometricAltitudeToPressureAltitude(
    Nullable<int> geometricAltitude
)
member GeometricAltitudeToPressureAltitude :
        geometricAltitude : Nullable<int> -> Nullable<int>

Parameters

geometricAltitude
Type: SystemNullable Int32

Return Value

Type: Nullable Int32
See Also

Reference

AirPressure Class
GeometricAltitudeToPressureAltitude Overload
VirtualRadar.Interface Namespace


AirPressure.GeometricAltitudeToPressureAltitude Method (Nullable(Int32), Single)

AirPressureGeometricAltitudeToPressureAltitude Method (NullableInt32, Single)
Takes a geometric altitude and air pressure reading and returns the pressure altitude for a given air pressure reading.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<int> GeometricAltitudeToPressureAltitude(
    Nullable<int> geometricAltitude,
    float airPressureInHg
)
Public Shared Function GeometricAltitudeToPressureAltitude (
    geometricAltitude As Nullable(Of Integer),
    airPressureInHg As Single
) As Nullable(Of Integer)
public:
static Nullable<int> GeometricAltitudeToPressureAltitude(
    Nullable<int> geometricAltitude,
    float airPressureInHg
)
static member GeometricAltitudeToPressureAltitude :
        geometricAltitude : Nullable<int> *
        airPressureInHg : float32 -> Nullable<int>

Parameters

geometricAltitude
Type: SystemNullable Int32
airPressureInHg
Type: SystemSingle

Return Value

Type: Nullable Int32
See Also

Reference

AirPressure Class
GeometricAltitudeToPressureAltitude Overload
VirtualRadar.Interface Namespace


AirPressure.InHgToMillibars Method

AirPressureInHgToMillibars Method
Converts pressure settings in inches of mercury to millibars.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<float> InHgToMillibars(
    Nullable<float> inHg
)
Public Shared Function InHgToMillibars (
    inHg As Nullable(Of Single)
) As Nullable(Of Single)
public:
static Nullable<float> InHgToMillibars(
    Nullable<float> inHg
)
static member InHgToMillibars :
        inHg : Nullable<float32> -> Nullable<float32>

Parameters

inHg
Type: SystemNullable Single

Return Value

Type: Nullable Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.MillibarsToInHg Method

AirPressureMillibarsToInHg Method
Converts pressure settings in millibars to inches of mercury.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<float> MillibarsToInHg(
    Nullable<float> millibars
)
Public Shared Function MillibarsToInHg (
    millibars As Nullable(Of Single)
) As Nullable(Of Single)
public:
static Nullable<float> MillibarsToInHg(
    Nullable<float> millibars
)
static member MillibarsToInHg :
        millibars : Nullable<float32> -> Nullable<float32>

Parameters

millibars
Type: SystemNullable Single

Return Value

Type: Nullable Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.ObservationTimeUtc Method

AirPressureObservationTimeUtc Method
Returns the time that the air pressure observation was made.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ObservationTimeUtc(
    DateTime fetchTimeUtc
)
Public Function ObservationTimeUtc (
    fetchTimeUtc As DateTime
) As DateTime
public:
DateTime ObservationTimeUtc(
    DateTime fetchTimeUtc
)
member ObservationTimeUtc :
        fetchTimeUtc : DateTime -> DateTime

Parameters

fetchTimeUtc
Type: SystemDateTime

Return Value

Type: DateTime
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.PressureAltitudeToGeometricAltitude Method

AirPressurePressureAltitudeToGeometricAltitude Method
Overload List
 | Name | Description
Public method | PressureAltitudeToGeometricAltitude(NullableInt32) | Takes a pressure altitude and returns the geometric altitude.
 | PressureAltitudeToGeometricAltitude(NullableInt32, Single) | Takes a pressure altitude and pressure setting, and returns the geometric altitude.
Top
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.PressureAltitudeToGeometricAltitude Method (Nullable(Int32))

AirPressurePressureAltitudeToGeometricAltitude Method (NullableInt32)
Takes a pressure altitude and returns the geometric altitude.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> PressureAltitudeToGeometricAltitude(
    Nullable<int> pressureAltitude
)
Public Function PressureAltitudeToGeometricAltitude (
    pressureAltitude As Nullable(Of Integer)
) As Nullable(Of Integer)
public:
Nullable<int> PressureAltitudeToGeometricAltitude(
    Nullable<int> pressureAltitude
)
member PressureAltitudeToGeometricAltitude :
        pressureAltitude : Nullable<int> -> Nullable<int>

Parameters

pressureAltitude
Type: SystemNullable Int32

Return Value

Type: Nullable Int32
See Also

Reference

AirPressure Class
PressureAltitudeToGeometricAltitude Overload
VirtualRadar.Interface Namespace


AirPressure.PressureAltitudeToGeometricAltitude Method (Nullable(Int32), Single)

AirPressurePressureAltitudeToGeometricAltitude Method (NullableInt32, Single)
Takes a pressure altitude and pressure setting, and returns the geometric altitude.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<int> PressureAltitudeToGeometricAltitude(
    Nullable<int> pressureAltitude,
    float airPressureInHg
)
Public Shared Function PressureAltitudeToGeometricAltitude (
    pressureAltitude As Nullable(Of Integer),
    airPressureInHg As Single
) As Nullable(Of Integer)
public:
static Nullable<int> PressureAltitudeToGeometricAltitude(
    Nullable<int> pressureAltitude,
    float airPressureInHg
)
static member PressureAltitudeToGeometricAltitude :
        pressureAltitude : Nullable<int> *
        airPressureInHg : float32 -> Nullable<int>

Parameters

pressureAltitude
Type: SystemNullable Int32
airPressureInHg
Type: SystemSingle

Return Value

Type: Nullable Int32
See Also

Reference

AirPressure Class
PressureAltitudeToGeometricAltitude Overload
VirtualRadar.Interface Namespace


AirPressure Fields

AirPressure Fields

The AirPressure type exposes the following members.

Fields
Name | Description
OneMillibarToInHg | The number of inches of mercury in one millibar.
StandardPressureInHg | The standard air pressure value in inches of mercury.
Top
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.OneMillibarToInHg Field

AirPressureOneMillibarToInHg Field
The number of inches of mercury in one millibar.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly float OneMillibarToInHg
Public Shared ReadOnly OneMillibarToInHg As Single
public:
static initonly float OneMillibarToInHg
static val OneMillibarToInHg: float32

Field Value

Type: Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AirPressure.StandardPressureInHg Field

AirPressureStandardPressureInHg Field
The standard air pressure value in inches of mercury.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly float StandardPressureInHg
Public Shared ReadOnly StandardPressureInHg As Single
public:
static initonly float StandardPressureInHg
static val StandardPressureInHg: float32

Field Value

Type: Single
See Also

Reference

AirPressure Class
VirtualRadar.Interface Namespace


AltitudeType Enumeration

AltitudeType Enumeration
The different types of altitude and vertical rate decoded by VRS.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AltitudeType
Public Enumeration AltitudeType
public enum class AltitudeType
type AltitudeType
Members
Member name | Value | Description
Barometric | 0 | The value is pressure alitude against a settings of 1013.25mb. If the altitude type is unknown (e.g. the aircraft data is coming off a cooked feed) then it defaults to this.
Geometric | 1 | The value is the height above the elipsoid.
See Also

Reference

VirtualRadar.Interface Namespace


BackgroundThreadQueue(T) Class

BackgroundThreadQueueT Class
A class that wraps a queue of objects that one thread pushes onto while a background thread pops and processes them.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceBackgroundThreadQueueT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BackgroundThreadQueue<T> : IQueue,
    IDisposable
where T : class

Public Class BackgroundThreadQueue(Of T As Class)
    Implements IQueue, IDisposable
generic<typename T>
where T : ref class
public ref class BackgroundThreadQueue : IQueue,
    IDisposable
type BackgroundThreadQueue<'T when 'T : not struct> =
    class
        interface IQueue
        interface IDisposable
    end

Type Parameters

T

The BackgroundThreadQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | BackgroundThreadQueueT(String, Int32) | Creates a new object.
Public method | BackgroundThreadQueueT(String, BackgroundThreadQueueMechanism, Int32) | Creates a new object.
Top
Properties
 | Name | Description
Public property | CountDroppedItems | See interface docs.
Public property | CountQueuedItems | See interface docs.
Public property | MaximumParallelThreads | Gets or sets the maximum number of parallel threads used when the mechanism is ThreadPool. Has no effect with other mechanisms, or if the queue has already been started.
Public property | MaxQueuedItems | The maximum number of items allowed in the queue.
Public property | Name | See interface docs.
Public property | PeakQueuedItems | See interface docs.
Top
Methods
 | Name | Description
Public method | Clear | Removes all entries from the queue in a single operation.
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Enqueue | Adds a new item to the queue and signals the background thread that there is something to process.
Public method | EnqueueRange | Adds many items to the queue simultaneously.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartBackgroundThread | Creates and starts the background thread that will pop objects from the queue and process them.
Public method | Stop | Stops processing items. Once the queue has stopped it cannot be restarted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This can be told to force everything onto a single thread by unit tests via the IRuntimeEnvironment interface.
See Also

Reference

VirtualRadar.Interface Namespace


BackgroundThreadQueue(T) Constructor

BackgroundThreadQueueT Constructor
Overload List
 | Name | Description
Public method | BackgroundThreadQueueT(String, Int32) | Creates a new object.
Public method | BackgroundThreadQueueT(String, BackgroundThreadQueueMechanism, Int32) | Creates a new object.
Top
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T) Constructor (String, Int32)

BackgroundThreadQueueT Constructor (String, Int32)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BackgroundThreadQueue(
    string queueName,
    int maxQueuedItems = 2147483647
)
Public Sub New (
    queueName As String,
    Optional maxQueuedItems As Integer = 2147483647
)
public:
BackgroundThreadQueue(
    String^ queueName,
    int maxQueuedItems = 2147483647
)
new :
        queueName : string *
        ?maxQueuedItems : int
(* Defaults:
        let _maxQueuedItems = defaultArg maxQueuedItems 2147483647
*)
-> BackgroundThreadQueue

Parameters

queueName
Type: SystemString
maxQueuedItems (Optional)
Type: SystemInt32
See Also

Reference

BackgroundThreadQueueT Class
BackgroundThreadQueueT Overload
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T) Constructor (String, BackgroundThreadQueueMechanism, Int32)

BackgroundThreadQueueT Constructor (String, BackgroundThreadQueueMechanism, Int32)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BackgroundThreadQueue(
    string queueName,
    BackgroundThreadQueueMechanism mechanism,
    int maxQueuedItems = 2147483647
)
Public Sub New (
    queueName As String,
    mechanism As BackgroundThreadQueueMechanism,
    Optional maxQueuedItems As Integer = 2147483647
)
public:
BackgroundThreadQueue(
    String^ queueName,
    BackgroundThreadQueueMechanism mechanism,
    int maxQueuedItems = 2147483647
)
new :
        queueName : string *
        mechanism : BackgroundThreadQueueMechanism *
        ?maxQueuedItems : int
(* Defaults:
        let _maxQueuedItems = defaultArg maxQueuedItems 2147483647
*)
-> BackgroundThreadQueue

Parameters

queueName
Type: SystemString
mechanism
Type: VirtualRadar.InterfaceBackgroundThreadQueueMechanism
maxQueuedItems (Optional)
Type: SystemInt32
See Also

Reference

BackgroundThreadQueueT Class
BackgroundThreadQueueT Overload
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T) Properties

BackgroundThreadQueueT Properties

The BackgroundThreadQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | CountDroppedItems | See interface docs.
Public property | CountQueuedItems | See interface docs.
Public property | MaximumParallelThreads | Gets or sets the maximum number of parallel threads used when the mechanism is ThreadPool. Has no effect with other mechanisms, or if the queue has already been started.
Public property | MaxQueuedItems | The maximum number of items allowed in the queue.
Public property | Name | See interface docs.
Public property | PeakQueuedItems | See interface docs.
Top
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).CountDroppedItems Property

BackgroundThreadQueueTCountDroppedItems Property
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long CountDroppedItems { get; }
Public ReadOnly Property CountDroppedItems As Long
    Get
public:
virtual property long long CountDroppedItems {
    long long get () sealed;
}
abstract CountDroppedItems : int64 with get
override CountDroppedItems : int64 with get

Property Value

Type: Int64

Implements

IQueueCountDroppedItems
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).CountQueuedItems Property

BackgroundThreadQueueTCountQueuedItems Property
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CountQueuedItems { get; }
Public ReadOnly Property CountQueuedItems As Integer
    Get
public:
virtual property int CountQueuedItems {
    int get () sealed;
}
abstract CountQueuedItems : int with get
override CountQueuedItems : int with get

Property Value

Type: Int32

Implements

IQueueCountQueuedItems
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).MaximumParallelThreads Property

BackgroundThreadQueueTMaximumParallelThreads Property
Gets or sets the maximum number of parallel threads used when the mechanism is ThreadPool. Has no effect with other mechanisms, or if the queue has already been started.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaximumParallelThreads { get; set; }
Public Property MaximumParallelThreads As Integer
    Get
    Set
public:
property int MaximumParallelThreads {
    int get ();
    void set (int value);
}
member MaximumParallelThreads : int with get, set

Property Value

Type: Int32
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).MaxQueuedItems Property

BackgroundThreadQueueTMaxQueuedItems Property
The maximum number of items allowed in the queue.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaxQueuedItems { get; }
Public ReadOnly Property MaxQueuedItems As Integer
    Get
public:
property int MaxQueuedItems {
    int get ();
}
member MaxQueuedItems : int with get

Property Value

Type: Int32
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Name Property

BackgroundThreadQueueTName Property
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IQueueName
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).PeakQueuedItems Property

BackgroundThreadQueueTPeakQueuedItems Property
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PeakQueuedItems { get; }
Public ReadOnly Property PeakQueuedItems As Integer
    Get
public:
virtual property int PeakQueuedItems {
    int get () sealed;
}
abstract PeakQueuedItems : int with get
override PeakQueuedItems : int with get

Property Value

Type: Int32

Implements

IQueuePeakQueuedItems
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T) Methods

BackgroundThreadQueueT Methods

The BackgroundThreadQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all entries from the queue in a single operation.
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Enqueue | Adds a new item to the queue and signals the background thread that there is something to process.
Public method | EnqueueRange | Adds many items to the queue simultaneously.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartBackgroundThread | Creates and starts the background thread that will pop objects from the queue and process them.
Public method | Stop | Stops processing items. Once the queue has stopped it cannot be restarted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Clear Method

BackgroundThreadQueueTClear Method
Removes all entries from the queue in a single operation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Dispose Method

BackgroundThreadQueueTDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Top
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Dispose Method

BackgroundThreadQueueTDispose Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BackgroundThreadQueueT Class
Dispose Overload
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Dispose Method (Boolean)

BackgroundThreadQueueTDispose Method (Boolean)
Disposes of or finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

BackgroundThreadQueueT Class
Dispose Overload
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Enqueue Method

BackgroundThreadQueueTEnqueue Method
Adds a new item to the queue and signals the background thread that there is something to process.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Enqueue(
    T item
)
Public Sub Enqueue (
    item As T
)
public:
void Enqueue(
    T item
)
member Enqueue :
        item : 'T -> unit

Parameters

item
Type: T
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).EnqueueRange Method

BackgroundThreadQueueTEnqueueRange Method
Adds many items to the queue simultaneously.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnqueueRange(
    IEnumerable<T> items
)
Public Sub EnqueueRange (
    items As IEnumerable(Of T)
)
public:
void EnqueueRange(
    IEnumerable<T>^ items
)
member EnqueueRange :
        items : IEnumerable<'T> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerable T
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Finalize Method

BackgroundThreadQueueTFinalize Method
Finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).StartBackgroundThread Method

BackgroundThreadQueueTStartBackgroundThread Method
Creates and starts the background thread that will pop objects from the queue and process them.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartBackgroundThread(
    Action<T> processObject,
    Action<Exception> processException
)
Public Sub StartBackgroundThread (
    processObject As Action(Of T),
    processException As Action(Of Exception)
)
public:
void StartBackgroundThread(
    Action<T>^ processObject,
    Action<Exception^>^ processException
)
member StartBackgroundThread :
        processObject : Action<'T> *
        processException : Action<Exception> -> unit

Parameters

processObject
Type: SystemAction T
A delegate that will be called on a background thread with each object popped from the queue. In ThreadPool mode this can be called in parallel, in all other modes it is called in series.
processException
Type: SystemAction Exception
A delegate called on a background thread with the details of an exception that was caught during processObject's execution. In ThreadPool mode this can be called in parallel, in all other modes it is called in series.
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueue(T).Stop Method

BackgroundThreadQueueTStop Method
Stops processing items. Once the queue has stopped it cannot be restarted.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
void Stop()
member Stop : unit -> unit
See Also

Reference

BackgroundThreadQueueT Class
VirtualRadar.Interface Namespace


BackgroundThreadQueueMechanism Enumeration

BackgroundThreadQueueMechanism Enumeration
An enumeration of the different mechanisms that the BackgroundThreadQueue can use.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BackgroundThreadQueueMechanism
Public Enumeration BackgroundThreadQueueMechanism
public enum class BackgroundThreadQueueMechanism
type BackgroundThreadQueueMechanism
Members
Member name | Value | Description
Queue | 0 | Items are processed one-at-a-time on the background thread. Stopping the queue will clear unprocessed items from the queue. Communication between the calling thread and background thread is via a WaitHandle.
QueueWithNoBlock | 1 | As per Queue but the background thread continuously polls the queue for more entries to process, relinquishing its time slice if there is nothing to process. This is only supported under Windows, when running on Mono this is translated into a Queue.
SingleThread | 2 | Forces all items to be processed on the thread that adds them. This is forced on internally during unit tests.
ThreadPool | 3 | Items are sent to the ThreadPool for processing, so they are processed in parallel. Stopping the queue will not stop processing of items that are queued on the ThreadPool. The creator of the queue can control how many items are processed in parallel.
See Also

Reference

VirtualRadar.Interface Namespace


ByteArrayComparable Class

ByteArrayComparable Class
An implementation of IComparable that returns the comparative order of a byte array.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceByteArrayComparable

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ByteArrayComparable : IComparable,
    IComparable<byte[]>, IComparable<ByteArrayComparable>
Public Class ByteArrayComparable
    Implements IComparable, IComparable(Of Byte()),
    IComparable(Of ByteArrayComparable)
public ref class ByteArrayComparable : IComparable,
    IComparable<array<unsigned char>^>, IComparable<ByteArrayComparable^>
type ByteArrayComparable =
    class
        interface IComparable
        interface IComparable<byte[]>
        interface IComparable<ByteArrayComparable>
    end

The ByteArrayComparable type exposes the following members.

Constructors
 | Name | Description
Public method | ByteArrayComparable | Creates a new object.
Public method | ByteArrayComparable(Byte) | Creates a new object.
Public method | ByteArrayComparable(IPAddress) | Creates a new object.
Public method | ByteArrayComparable(IPEndPoint) | Creates a new object.
Public method | ByteArrayComparable(Cidr) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Array | Gets the byte array that is being compared.
Top
Methods
 | Name | Description
Public method | CompareTo | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


ByteArrayComparable Constructor

ByteArrayComparable Constructor
Overload List
 | Name | Description
Public method | ByteArrayComparable | Creates a new object.
Public method | ByteArrayComparable(Byte) | Creates a new object.
Public method | ByteArrayComparable(IPAddress) | Creates a new object.
Public method | ByteArrayComparable(IPEndPoint) | Creates a new object.
Public method | ByteArrayComparable(Cidr) | Creates a new object.
Top
See Also

Reference

ByteArrayComparable Class
VirtualRadar.Interface Namespace


ByteArrayComparable Constructor

ByteArrayComparable Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ByteArrayComparable()
Public Sub New
public:
ByteArrayComparable()
new : unit -> ByteArrayComparable
See Also

Reference

ByteArrayComparable Class
ByteArrayComparable Overload
VirtualRadar.Interface Namespace


ByteArrayComparable Constructor (Byte[])

ByteArrayComparable Constructor (Byte)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ByteArrayComparable(
    byte[] array
)
Public Sub New (
    array As Byte()
)
public:
ByteArrayComparable(
    array<unsigned char>^ array
)
new :
        array : byte[] -> ByteArrayComparable

Parameters

array
Type: SystemByte
See Also

Reference

ByteArrayComparable Class
ByteArrayComparable Overload
VirtualRadar.Interface Namespace


ByteArrayComparable Constructor (IPAddress)

ByteArrayComparable Constructor (IPAddress)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ByteArrayComparable(
    IPAddress address
)
Public Sub New (
    address As IPAddress
)
public:
ByteArrayComparable(
    IPAddress^ address
)
new :
        address : IPAddress -> ByteArrayComparable

Parameters

address
Type: System.NetIPAddress
See Also

Reference

ByteArrayComparable Class
ByteArrayComparable Overload
VirtualRadar.Interface Namespace


ByteArrayComparable Constructor (IPEndPoint)

ByteArrayComparable Constructor (IPEndPoint)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ByteArrayComparable(
    IPEndPoint endPoint
)
Public Sub New (
    endPoint As IPEndPoint
)
public:
ByteArrayComparable(
    IPEndPoint^ endPoint
)
new :
        endPoint : IPEndPoint -> ByteArrayComparable

Parameters

endPoint
Type: System.NetIPEndPoint
See Also

Reference

ByteArrayComparable Class
ByteArrayComparable Overload
VirtualRadar.Interface Namespace


ByteArrayComparable Constructor (Cidr)

ByteArrayComparable Constructor (Cidr)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ByteArrayComparable(
    Cidr cidr
)
Public Sub New (
    cidr As Cidr
)
public:
ByteArrayComparable(
    Cidr^ cidr
)
new :
        cidr : Cidr -> ByteArrayComparable

Parameters

cidr
Type: VirtualRadar.InterfaceCidr
See Also

Reference

ByteArrayComparable Class
ByteArrayComparable Overload
VirtualRadar.Interface Namespace


ByteArrayComparable Properties

ByteArrayComparable Properties

The ByteArrayComparable type exposes the following members.

Properties
 | Name | Description
Public property | Array | Gets the byte array that is being compared.
Top
See Also

Reference

ByteArrayComparable Class
VirtualRadar.Interface Namespace


ByteArrayComparable.Array Property

ByteArrayComparableArray Property
Gets the byte array that is being compared.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Array { get; }
Public ReadOnly Property Array As Byte()
    Get
public:
property array<unsigned char>^ Array {
    array<unsigned char>^ get ();
}
member Array : byte[] with get

Property Value

Type: Byte
See Also

Reference

ByteArrayComparable Class
VirtualRadar.Interface Namespace


ByteArrayComparable Methods

ByteArrayComparable Methods

The ByteArrayComparable type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ByteArrayComparable Class
VirtualRadar.Interface Namespace


ByteArrayComparable.CompareTo Method

ByteArrayComparableCompareTo Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    byte[] other
)
Public Function CompareTo (
    other As Byte()
) As Integer
public:
virtual int CompareTo(
    array<unsigned char>^ other
) sealed
abstract CompareTo :
        other : byte[] -> int
override CompareTo :
        other : byte[] -> int

Parameters

other
Type: SystemByte

Return Value

Type: Int32

Implements

IComparableTCompareTo(T)
See Also

Reference

ByteArrayComparable Class
VirtualRadar.Interface Namespace


Certainty Enumeration

Certainty Enumeration
An enumeration of the different desgrees of certainty the program has regarding the sanity of a value.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Certainty
Public Enumeration Certainty
public enum class Certainty
type Certainty
Members
Member name | Value | Description
Uncertain | 0 | The program cannot tell whether the value is wrong or right, there isn't enough history to work from.
CertainlyWrong | 1 | The program is certain that the value is wrong, the aircraft could not attain that position without breaking some law of physics.
ProbablyRight | 2 | The program is confident that the aircraft could attain that position without having to break some law of physics.
See Also

Reference

VirtualRadar.Interface Namespace


Cidr Class

Cidr Class
Represents a Classless Inter-Domain Routing value.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCidr

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Cidr
Public Class Cidr
public ref class Cidr
type Cidr =  class end

The Cidr type exposes the following members.

Constructors
 | Name | Description
Public method | Cidr | Creates a new object.
Top
Properties
 | Name | Description
Public property | Address | Gets the IP address.
Public property | BitmaskBits | Gets the number of bits used to construct the bitmask.
Public property | FirstMatchingAddress | Gets the first matching address.
Public property | IPv4Bitmask | Gets the bitmask to use when Address is IPv4.
Public property | LastMatchingAddress | Gets the last matching address.
Public property | MaskedAddress | Gets the Address with the bitmask applied.
Top
Methods
 | Name | Description
Public method | Equals | Returns true if the other object is a CIDR with the same properties as this object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode for the CIDR. Guaranteed to return the same hashcode for two CIDRs that are equal. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Returns true if the address passed across matches the CIDR.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses an address. Throws exceptions if the parse fails.
Public method | ToString | See base docs. (Overrides ObjectToString.)
 | TryParse | Parses an address. Returns false and sets the cidr to null if the parse fails.
Top
Remarks

A CIDR is an IP address and a mask, expressed as a number of bits. The bits indicate the number of 1 bits measured from the high bit down to the low bit - a bitmask of /1 is the high bit (bit 32) set, 2 would be bits 31 & 32 set and so on. If the number of bits isn't specified then 32 is assumed.

The address is masked off to produce a set of high bits from the address. When we want to compare another address we apply the bitmask to the other address as well. If all of the bits match - i.e. an xor of both addresses after masking is 0 - then we have a match. Otherwise the addresses don't match.

It follows that if the number of bits is zero then every address will match the CIDR whereas if the bits are 32 then only one address can match.

See Also

Reference

VirtualRadar.Interface Namespace


Cidr Constructor

Cidr Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Cidr()
Public Sub New
public:
Cidr()
new : unit -> Cidr
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr Properties

Cidr Properties

The Cidr type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the IP address.
Public property | BitmaskBits | Gets the number of bits used to construct the bitmask.
Public property | FirstMatchingAddress | Gets the first matching address.
Public property | IPv4Bitmask | Gets the bitmask to use when Address is IPv4.
Public property | LastMatchingAddress | Gets the last matching address.
Public property | MaskedAddress | Gets the Address with the bitmask applied.
Top
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.Address Property

CidrAddress Property
Gets the IP address.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddress Address { get; }
Public ReadOnly Property Address As IPAddress
    Get
public:
property IPAddress^ Address {
    IPAddress^ get ();
}
member Address : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.BitmaskBits Property

CidrBitmaskBits Property
Gets the number of bits used to construct the bitmask.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BitmaskBits { get; }
Public ReadOnly Property BitmaskBits As Integer
    Get
public:
property int BitmaskBits {
    int get ();
}
member BitmaskBits : int with get

Property Value

Type: Int32
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.FirstMatchingAddress Property

CidrFirstMatchingAddress Property
Gets the first matching address.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddress FirstMatchingAddress { get; }
Public ReadOnly Property FirstMatchingAddress As IPAddress
    Get
public:
property IPAddress^ FirstMatchingAddress {
    IPAddress^ get ();
}
member FirstMatchingAddress : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.IPv4Bitmask Property

CidrIPv4Bitmask Property
Gets the bitmask to use when Address is IPv4.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint IPv4Bitmask { get; }
Public ReadOnly Property IPv4Bitmask As UInteger
    Get
public:
property unsigned int IPv4Bitmask {
    unsigned int get ();
}
member IPv4Bitmask : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.LastMatchingAddress Property

CidrLastMatchingAddress Property
Gets the last matching address.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddress LastMatchingAddress { get; }
Public ReadOnly Property LastMatchingAddress As IPAddress
    Get
public:
property IPAddress^ LastMatchingAddress {
    IPAddress^ get ();
}
member LastMatchingAddress : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.MaskedAddress Property

CidrMaskedAddress Property
Gets the Address with the bitmask applied.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddress MaskedAddress { get; }
Public ReadOnly Property MaskedAddress As IPAddress
    Get
public:
property IPAddress^ MaskedAddress {
    IPAddress^ get ();
}
member MaskedAddress : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr Methods

Cidr Methods

The Cidr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns true if the other object is a CIDR with the same properties as this object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode for the CIDR. Guaranteed to return the same hashcode for two CIDRs that are equal. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Returns true if the address passed across matches the CIDR.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses an address. Throws exceptions if the parse fails.
Public method | ToString | See base docs. (Overrides ObjectToString.)
 | TryParse | Parses an address. Returns false and sets the cidr to null if the parse fails.
Top
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.Equals Method

CidrEquals Method
Returns true if the other object is a CIDR with the same properties as this object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.GetHashCode Method

CidrGetHashCode Method
Returns a hashcode for the CIDR. Guaranteed to return the same hashcode for two CIDRs that are equal.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.Matches Method

CidrMatches Method
Returns true if the address passed across matches the CIDR.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Matches(
    IPAddress address
)
Public Function Matches (
    address As IPAddress
) As Boolean
public:
bool Matches(
    IPAddress^ address
)
member Matches :
        address : IPAddress -> bool

Parameters

address
Type: System.NetIPAddress

Return Value

Type: Boolean
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.Parse Method

CidrParse Method
Parses an address. Throws exceptions if the parse fails.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Cidr Parse(
    string address
)
Public Shared Function Parse (
    address As String
) As Cidr
public:
static Cidr^ Parse(
    String^ address
)
static member Parse :
        address : string -> Cidr

Parameters

address
Type: SystemString

Return Value

Type: Cidr
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.ToString Method

CidrToString Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


Cidr.TryParse Method

CidrTryParse Method
Parses an address. Returns false and sets the cidr to null if the parse fails.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    string address,
    out Cidr cidr
)
Public Shared Function TryParse (
    address As String,
    <OutAttribute> ByRef cidr As Cidr
) As Boolean
public:
static bool TryParse(
    String^ address,
    [OutAttribute] Cidr^% cidr
)
static member TryParse :
        address : string *
        cidr : Cidr byref -> bool

Parameters

address
Type: SystemString
cidr
Type: VirtualRadar.InterfaceCidr

Return Value

Type: Boolean
See Also

Reference

Cidr Class
VirtualRadar.Interface Namespace


CidrComparer Class

CidrComparer Class
Compares Cidr objects for their relative order.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCidrComparer

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CidrComparer : IComparer<Cidr>
Public Class CidrComparer
    Implements IComparer(Of Cidr)
public ref class CidrComparer : IComparer<Cidr^>
type CidrComparer =
    class
        interface IComparer<Cidr>
    end

The CidrComparer type exposes the following members.

Constructors
 | Name | Description
Public method | CidrComparer | Initializes a new instance of the CidrComparer class
Top
Methods
 | Name | Description
Public method | Compare | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The CIDRs are sorted in mask order and then in ascending bit count order.
See Also

Reference

VirtualRadar.Interface Namespace


CidrComparer Constructor

CidrComparer Constructor
Initializes a new instance of the CidrComparer class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CidrComparer()
Public Sub New
public:
CidrComparer()
new : unit -> CidrComparer
See Also

Reference

CidrComparer Class
VirtualRadar.Interface Namespace


CidrComparer Methods

CidrComparer Methods

The CidrComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CidrComparer Class
VirtualRadar.Interface Namespace


CidrComparer.Compare Method

CidrComparerCompare Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    Cidr lhs,
    Cidr rhs
)
Public Function Compare (
    lhs As Cidr,
    rhs As Cidr
) As Integer
public:
virtual int Compare(
    Cidr^ lhs,
    Cidr^ rhs
) sealed
abstract Compare :
        lhs : Cidr *
        rhs : Cidr -> int
override Compare :
        lhs : Cidr *
        rhs : Cidr -> int

Parameters

lhs
Type: VirtualRadar.InterfaceCidr
rhs
Type: VirtualRadar.InterfaceCidr

Return Value

Type: Int32

Implements

IComparerTCompare(T, T)
See Also

Reference

CidrComparer Class
VirtualRadar.Interface Namespace


CollectionHelper Class

CollectionHelper Class
A static class with methods that can help when dealing with collections.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCollectionHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CollectionHelper
Public NotInheritable Class CollectionHelper
public ref class CollectionHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CollectionHelper =  class end

The CollectionHelper type exposes the following members.

Methods
Name | Description
ApplySourceToDestinationTSource, TDest | Generic (and not particularly efficient) method that takes two generic collections, where the generic types are related to each other in some way and each row has something that is unique about it, and applies add, update and delete operations to the destination so that the content matches the source.
OverwriteDestinationWithSourceT | A version of ApplySourceToDestinationTSource, TDest(ICollectionTSource, ICollectionTDest, FuncTSource, TDest, Boolean, FuncTSource, TDest, ActionTSource, TDest) that is suitable for synchronising lists of values. There is no conversion between types and the source and destination must both implement IList. Values are not compared, the destination elements are just overwritten with the source.
ShallowCopyT(HashSetT) | Returns a copy of the hashset passed across.
ShallowCopyT(ListT) | Returns a copy of the list passed across.
ShallowCopyTKey, TValue(DictionaryTKey, TValue) | Returns a copy of the dictionary passed across.
Top
See Also

Reference

VirtualRadar.Interface Namespace


CollectionHelper Methods

CollectionHelper Methods

The CollectionHelper type exposes the following members.

Methods
Name | Description
ApplySourceToDestinationTSource, TDest | Generic (and not particularly efficient) method that takes two generic collections, where the generic types are related to each other in some way and each row has something that is unique about it, and applies add, update and delete operations to the destination so that the content matches the source.
OverwriteDestinationWithSourceT | A version of ApplySourceToDestinationTSource, TDest(ICollectionTSource, ICollectionTDest, FuncTSource, TDest, Boolean, FuncTSource, TDest, ActionTSource, TDest) that is suitable for synchronising lists of values. There is no conversion between types and the source and destination must both implement IList. Values are not compared, the destination elements are just overwritten with the source.
ShallowCopyT(HashSetT) | Returns a copy of the hashset passed across.
ShallowCopyT(ListT) | Returns a copy of the list passed across.
ShallowCopyTKey, TValue(DictionaryTKey, TValue) | Returns a copy of the dictionary passed across.
Top
See Also

Reference

CollectionHelper Class
VirtualRadar.Interface Namespace


CollectionHelper.ApplySourceToDestination(TSource, TDest) Method

CollectionHelperApplySourceToDestinationTSource, TDest Method
Generic (and not particularly efficient) method that takes two generic collections, where the generic types are related to each other in some way and each row has something that is unique about it, and applies add, update and delete operations to the destination so that the content matches the source.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ApplySourceToDestination<TSource, TDest>(
    ICollection<TSource> source,
    ICollection<TDest> destination,
    Func<TSource, TDest, bool> areIdentifiersEqual,
    Func<TSource, TDest> createDestinationRecord,
    Action<TSource, TDest> overwriteDestinationRecord
)

Public Shared Sub ApplySourceToDestination(Of TSource, TDest) (
    source As ICollection(Of TSource),
    destination As ICollection(Of TDest),
    areIdentifiersEqual As Func(Of TSource, TDest, Boolean),
    createDestinationRecord As Func(Of TSource, TDest),
    overwriteDestinationRecord As Action(Of TSource, TDest)
)
public:
generic<typename TSource, typename TDest>
static void ApplySourceToDestination(
    ICollection<TSource>^ source,
    ICollection<TDest>^ destination,
    Func<TSource, TDest, bool>^ areIdentifiersEqual,
    Func<TSource, TDest>^ createDestinationRecord,
    Action<TSource, TDest>^ overwriteDestinationRecord
)
static member ApplySourceToDestination :
        source : ICollection<'TSource> *
        destination : ICollection<'TDest> *
        areIdentifiersEqual : Func<'TSource, 'TDest, bool> *
        createDestinationRecord : Func<'TSource, 'TDest> *
        overwriteDestinationRecord : Action<'TSource, 'TDest> -> unit

Parameters

source
Type: System.Collections.GenericICollection TSource
The source collection.
destination
Type: System.Collections.GenericICollection TDest
The destination collection.
areIdentifiersEqual
Type: SystemFunc TSource, TDest, Boolean
Passed a source and destination record, returns true if they have the same identifier.
createDestinationRecord
Type: SystemFunc TSource, TDest
Creates a new destination record from a source record.
overwriteDestinationRecord
Type: SystemAction TSource, TDest
Overwrites a destination record with values from a source record.

Type Parameters

TSource
TDest
See Also

Reference

CollectionHelper Class
VirtualRadar.Interface Namespace


CollectionHelper.OverwriteDestinationWithSource(T) Method

CollectionHelperOverwriteDestinationWithSourceT Method
A version of ApplySourceToDestinationTSource, TDest(ICollectionTSource, ICollectionTDest, FuncTSource, TDest, Boolean, FuncTSource, TDest, ActionTSource, TDest) that is suitable for synchronising lists of values. There is no conversion between types and the source and destination must both implement IList. Values are not compared, the destination elements are just overwritten with the source.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void OverwriteDestinationWithSource<T>(
    IList<T> source,
    IList<T> destination
)

Public Shared Sub OverwriteDestinationWithSource(Of T) (
    source As IList(Of T),
    destination As IList(Of T)
)
public:
generic<typename T>
static void OverwriteDestinationWithSource(
    IList<T>^ source,
    IList<T>^ destination
)
static member OverwriteDestinationWithSource :
        source : IList<'T> *
        destination : IList<'T> -> unit

Parameters

source
Type: System.Collections.GenericIList T
destination
Type: System.Collections.GenericIList T

Type Parameters

T
See Also

Reference

CollectionHelper Class
VirtualRadar.Interface Namespace


CollectionHelper.ShallowCopy Method

CollectionHelperShallowCopy Method
Overload List
Name | Description
ShallowCopyTKey, TValue(DictionaryTKey, TValue) | Returns a copy of the dictionary passed across.
ShallowCopyT(HashSetT) | Returns a copy of the hashset passed across.
ShallowCopyT(ListT) | Returns a copy of the list passed across.
Top
See Also

Reference

CollectionHelper Class
VirtualRadar.Interface Namespace


CollectionHelper.ShallowCopy(TKey, TValue) Method (Dictionary(TKey, TValue))

CollectionHelperShallowCopyTKey, TValue Method (DictionaryTKey, TValue)
Returns a copy of the dictionary passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<TKey, TValue> ShallowCopy<TKey, TValue>(
    Dictionary<TKey, TValue> dictionary
)

Public Shared Function ShallowCopy(Of TKey, TValue) (
    dictionary As Dictionary(Of TKey, TValue)
) As Dictionary(Of TKey, TValue)
public:
generic<typename TKey, typename TValue>
static Dictionary<TKey, TValue>^ ShallowCopy(
    Dictionary<TKey, TValue>^ dictionary
)
static member ShallowCopy :
        dictionary : Dictionary<'TKey, 'TValue> -> Dictionary<'TKey, 'TValue>

Parameters

dictionary
Type: System.Collections.GenericDictionary TKey, TValue

Type Parameters

TKey
TValue

Return Value

Type: Dictionary TKey, TValue
See Also

Reference

CollectionHelper Class
ShallowCopy Overload
VirtualRadar.Interface Namespace


CollectionHelper.ShallowCopy(T) Method (HashSet(T))

CollectionHelperShallowCopyT Method (HashSetT)
Returns a copy of the hashset passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HashSet<T> ShallowCopy<T>(
    HashSet<T> hashSet
)

Public Shared Function ShallowCopy(Of T) (
    hashSet As HashSet(Of T)
) As HashSet(Of T)
public:
generic<typename T>
static HashSet<T>^ ShallowCopy(
    HashSet<T>^ hashSet
)
static member ShallowCopy :
        hashSet : HashSet<'T> -> HashSet<'T>

Parameters

hashSet
Type: System.Collections.GenericHashSet T

Type Parameters

T

Return Value

Type: HashSet T
See Also

Reference

CollectionHelper Class
ShallowCopy Overload
VirtualRadar.Interface Namespace


CollectionHelper.ShallowCopy(T) Method (List(T))

CollectionHelperShallowCopyT Method (ListT)
Returns a copy of the list passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<T> ShallowCopy<T>(
    List<T> list
)

Public Shared Function ShallowCopy(Of T) (
    list As List(Of T)
) As List(Of T)
public:
generic<typename T>
static List<T>^ ShallowCopy(
    List<T>^ list
)
static member ShallowCopy :
        list : List<'T> -> List<'T>

Parameters

list
Type: System.Collections.GenericList T

Type Parameters

T

Return Value

Type: List T
See Also

Reference

CollectionHelper Class
ShallowCopy Overload
VirtualRadar.Interface Namespace


Coordinate Class

Coordinate Class
An immutable object that describes a point where an aircraft was seen and the time at which its position was recorded.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCoordinate

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class Coordinate
Public NotInheritable Class Coordinate
public ref class Coordinate sealed
[<SealedAttribute>]
type Coordinate =  class end

The Coordinate type exposes the following members.

Constructors
 | Name | Description
Public method | Coordinate(Double, Double) | Creates a new object.
Public method | Coordinate(Int64, Int64, Double, Double, NullableSingle) | Creates a new object.
Public method | Coordinate(Int64, Int64, Double, Double, NullableSingle, NullableInt32, NullableSingle) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Altitude | Gets the altitude of the aircraft.
Public property | DataVersion | Gets the aircraft's DataVersion that was current when the coordinate was recorded.
Public property | GroundSpeed | Gets the ground speed of the aircraft.
Public property | Heading | Gets the direction the aircraft was pointing in.
Public property | Latitude | Gets the latitude that the aircraft was at.
Public property | Longitude | Gets the longitude that the aircraft was at.
Public property | Tick | Gets the time that the aircraft was at this coordinate.
Top
Methods
 | Name | Description
Public method | Equals | Returns true if the other object represents the same coordinate as this one. Two coordinates are equal if their Latitude, Longitude, Altitude and GroundSpeed are equal - the other properties are not considered. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | See base docs. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


Coordinate Constructor

Coordinate Constructor
Overload List
 | Name | Description
Public method | Coordinate(Double, Double) | Creates a new object.
Public method | Coordinate(Int64, Int64, Double, Double, NullableSingle) | Creates a new object.
Public method | Coordinate(Int64, Int64, Double, Double, NullableSingle, NullableInt32, NullableSingle) | Creates a new object.
Top
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate Constructor (Double, Double)

Coordinate Constructor (Double, Double)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Coordinate(
    double latitude,
    double longitude
)
Public Sub New (
    latitude As Double,
    longitude As Double
)
public:
Coordinate(
    double latitude,
    double longitude
)
new :
        latitude : float *
        longitude : float -> Coordinate

Parameters

latitude
Type: SystemDouble
longitude
Type: SystemDouble
See Also

Reference

Coordinate Class
Coordinate Overload
VirtualRadar.Interface Namespace


Coordinate Constructor (Int64, Int64, Double, Double, Nullable(Single))

Coordinate Constructor (Int64, Int64, Double, Double, NullableSingle)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Coordinate(
    long dataVersion,
    long tick,
    double latitude,
    double longitude,
    Nullable<float> heading
)
Public Sub New (
    dataVersion As Long,
    tick As Long,
    latitude As Double,
    longitude As Double,
    heading As Nullable(Of Single)
)
public:
Coordinate(
    long long dataVersion,
    long long tick,
    double latitude,
    double longitude,
    Nullable<float> heading
)
new :
        dataVersion : int64 *
        tick : int64 *
        latitude : float *
        longitude : float *
        heading : Nullable<float32> -> Coordinate

Parameters

dataVersion
Type: SystemInt64
The DataVersion current when the coordinate was recorded.
tick
Type: SystemInt64
The time the coordinate was recorded.
latitude
Type: SystemDouble
The latitude of the aircraft.
longitude
Type: SystemDouble
The longitude of the aircraft.
heading
Type: SystemNullable Single
The heading in degrees from north that the aircraft was pointing in, if known.
See Also

Reference

Coordinate Class
Coordinate Overload
VirtualRadar.Interface Namespace


Coordinate Constructor (Int64, Int64, Double, Double, Nullable(Single), Nullable(Int32), Nullable(Single))

Coordinate Constructor (Int64, Int64, Double, Double, NullableSingle, NullableInt32, NullableSingle)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Coordinate(
    long dataVersion,
    long tick,
    double latitude,
    double longitude,
    Nullable<float> heading,
    Nullable<int> altitude,
    Nullable<float> groundSpeed
)
Public Sub New (
    dataVersion As Long,
    tick As Long,
    latitude As Double,
    longitude As Double,
    heading As Nullable(Of Single),
    altitude As Nullable(Of Integer),
    groundSpeed As Nullable(Of Single)
)
public:
Coordinate(
    long long dataVersion,
    long long tick,
    double latitude,
    double longitude,
    Nullable<float> heading,
    Nullable<int> altitude,
    Nullable<float> groundSpeed
)
new :
        dataVersion : int64 *
        tick : int64 *
        latitude : float *
        longitude : float *
        heading : Nullable<float32> *
        altitude : Nullable<int> *
        groundSpeed : Nullable<float32> -> Coordinate

Parameters

dataVersion
Type: SystemInt64
The DataVersion current when the coordinate was recorded.
tick
Type: SystemInt64
The time the coordinate was recorded.
latitude
Type: SystemDouble
The latitude of the aircraft.
longitude
Type: SystemDouble
The longitude of the aircraft.
heading
Type: SystemNullable Single
The heading in degrees from north that the aircraft was pointing in, if known.
altitude
Type: SystemNullable Int32
The altitude of the aircraft.
groundSpeed
Type: SystemNullable Single
The speed of the aircraft.
See Also

Reference

Coordinate Class
Coordinate Overload
VirtualRadar.Interface Namespace


Coordinate Properties

Coordinate Properties

The Coordinate type exposes the following members.

Properties
 | Name | Description
Public property | Altitude | Gets the altitude of the aircraft.
Public property | DataVersion | Gets the aircraft's DataVersion that was current when the coordinate was recorded.
Public property | GroundSpeed | Gets the ground speed of the aircraft.
Public property | Heading | Gets the direction the aircraft was pointing in.
Public property | Latitude | Gets the latitude that the aircraft was at.
Public property | Longitude | Gets the longitude that the aircraft was at.
Public property | Tick | Gets the time that the aircraft was at this coordinate.
Top
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.Altitude Property

CoordinateAltitude Property
Gets the altitude of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Altitude { get; }
Public ReadOnly Property Altitude As Nullable(Of Integer)
    Get
public:
property Nullable<int> Altitude {
    Nullable<int> get ();
}
member Altitude : Nullable<int> with get

Property Value

Type: Nullable Int32
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.DataVersion Property

CoordinateDataVersion Property
Gets the aircraft's DataVersion that was current when the coordinate was recorded.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DataVersion { get; }
Public ReadOnly Property DataVersion As Long
    Get
public:
property long long DataVersion {
    long long get ();
}
member DataVersion : int64 with get

Property Value

Type: Int64
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.GroundSpeed Property

CoordinateGroundSpeed Property
Gets the ground speed of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> GroundSpeed { get; }
Public ReadOnly Property GroundSpeed As Nullable(Of Single)
    Get
public:
property Nullable<float> GroundSpeed {
    Nullable<float> get ();
}
member GroundSpeed : Nullable<float32> with get

Property Value

Type: Nullable Single
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.Heading Property

CoordinateHeading Property
Gets the direction the aircraft was pointing in.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> Heading { get; }
Public ReadOnly Property Heading As Nullable(Of Single)
    Get
public:
property Nullable<float> Heading {
    Nullable<float> get ();
}
member Heading : Nullable<float32> with get

Property Value

Type: Nullable Single
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.Latitude Property

CoordinateLatitude Property
Gets the latitude that the aircraft was at.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; }
Public ReadOnly Property Latitude As Double
    Get
public:
property double Latitude {
    double get ();
}
member Latitude : float with get

Property Value

Type: Double
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.Longitude Property

CoordinateLongitude Property
Gets the longitude that the aircraft was at.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; }
Public ReadOnly Property Longitude As Double
    Get
public:
property double Longitude {
    double get ();
}
member Longitude : float with get

Property Value

Type: Double
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.Tick Property

CoordinateTick Property
Gets the time that the aircraft was at this coordinate.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Tick { get; }
Public ReadOnly Property Tick As Long
    Get
public:
property long long Tick {
    long long get ();
}
member Tick : int64 with get

Property Value

Type: Int64
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate Methods

Coordinate Methods

The Coordinate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns true if the other object represents the same coordinate as this one. Two coordinates are equal if their Latitude, Longitude, Altitude and GroundSpeed are equal - the other properties are not considered. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | See base docs. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.Equals Method

CoordinateEquals Method
Returns true if the other object represents the same coordinate as this one. Two coordinates are equal if their Latitude, Longitude, Altitude and GroundSpeed are equal - the other properties are not considered.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.GetHashCode Method

CoordinateGetHashCode Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Coordinate.ToString Method

CoordinateToString Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Coordinate Class
VirtualRadar.Interface Namespace


Crc16 Class

Crc16 Class
A utility class that calculates CRC16 checksums.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCrc16

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Crc16
Public Class Crc16
public ref class Crc16
type Crc16 =  class end

The Crc16 type exposes the following members.

Constructors
 | Name | Description
Public method | Crc16 | Creates a new object.
Top
Methods
 | Name | Description
Public method | ComputeChecksum | Calculates the CRC16 checksum for an array of bytes.
Public method | ComputeChecksumBytes | Calculates the CRC16 checksum for an array of bytes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This was copied entirely from the Sanity Free Coding blog: http://sanity-free.com/134/standard_crc_16_in_csharp.html
See Also

Reference

VirtualRadar.Interface Namespace


Crc16 Constructor

Crc16 Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Crc16()
Public Sub New
public:
Crc16()
new : unit -> Crc16
See Also

Reference

Crc16 Class
VirtualRadar.Interface Namespace


Crc16 Methods

Crc16 Methods

The Crc16 type exposes the following members.

Methods
 | Name | Description
Public method | ComputeChecksum | Calculates the CRC16 checksum for an array of bytes.
Public method | ComputeChecksumBytes | Calculates the CRC16 checksum for an array of bytes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Crc16 Class
VirtualRadar.Interface Namespace


Crc16.ComputeChecksum Method

Crc16ComputeChecksum Method
Calculates the CRC16 checksum for an array of bytes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ComputeChecksum(
    byte[] bytes
)
Public Function ComputeChecksum (
    bytes As Byte()
) As UShort
public:
unsigned short ComputeChecksum(
    array<unsigned char>^ bytes
)
member ComputeChecksum :
        bytes : byte[] -> uint16

Parameters

bytes
Type: SystemByte

Return Value

Type: UInt16
The checksum as an unsigned 16-bit value.
See Also

Reference

Crc16 Class
VirtualRadar.Interface Namespace


Crc16.ComputeChecksumBytes Method

Crc16ComputeChecksumBytes Method
Calculates the CRC16 checksum for an array of bytes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytes(
    byte[] bytes
)
Public Function ComputeChecksumBytes (
    bytes As Byte()
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytes(
    array<unsigned char>^ bytes
)
member ComputeChecksumBytes :
        bytes : byte[] -> byte[]

Parameters

bytes
Type: SystemByte

Return Value

Type: Byte
The checksum as an array of bytes.
See Also

Reference

Crc16 Class
VirtualRadar.Interface Namespace


Crc16Ccitt Class

Crc16Ccitt Class
A utility class that calculates CCITT-16 CRC values.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCrc16Ccitt

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Crc16Ccitt
Public Class Crc16Ccitt
public ref class Crc16Ccitt
type Crc16Ccitt =  class end

The Crc16Ccitt type exposes the following members.

Constructors
 | Name | Description
Public method | Crc16Ccitt | Creates a new object.
Top
Methods
 | Name | Description
Public method | ComputeChecksum(Byte) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksum(Byte, Int32, Int32) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumBytes(Byte, Boolean) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumBytes(Byte, Int32, Int32, Boolean) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumDrDobbs | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the Dr. Dobbs algorithm.
Public method | ComputeChecksumDrDobbsBytes | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the Dr. Dobbs algorithm.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
InitialiseToAllOnes | An initial CRC value of all-ones.
InitialiseToZero | An initial CRC value of zero.
Top
Remarks

Two algorithms were found that described themselves as CCITT-16 CRC calculators - the one that is used by Kinetic (and at least four other entities) and the one described in the Dr. Dobbs journal. The Dr. Dobbs one is included for the sake of completeness.

The Kinetic version was copied from the Sanity Free Coding blog - http://sanity-free.org/133/crc_16_ccitt_in_csharp.html. Note that the checksum that Kinetic use on SBS-3 packets is using an initial CRC value of zero. I modified the method that returns a byte array because Kinetic's CRC is sent big-endian and the original was returning it little-endian.

A second implementation of the standard algorithm was found here - http://www.ccsinfo.com/forum/viewtopic.php?t=24977. It purported to be faster than the lookup table version, which is probably true for implementations in hardware or languages that compile straight to assembly but was not found to be the case in testing under C#, it was marginally slower than Sanity Free Coding's implementation.

The Dr. Dobbs version was copied from the Dr. Dobbs journal site - http://www.drdobbs.com/implementing-the-ccitt-cyclical-redundan/199904926. The implementation here has been tested against the expected checksum in the examples listing on that page.

See Also

Reference

VirtualRadar.Interface Namespace


Crc16Ccitt Constructor

Crc16Ccitt Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Crc16Ccitt(
    ushort initialChecksumValue = 65535
)
Public Sub New (
    Optional initialChecksumValue As UShort = 65535
)
public:
Crc16Ccitt(
    unsigned short initialChecksumValue = 65535
)
new :
        ?initialChecksumValue : uint16
(* Defaults:
        let _initialChecksumValue = defaultArg initialChecksumValue 65535
*)
-> Crc16Ccitt

Parameters

initialChecksumValue (Optional)
Type: SystemUInt16
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt Methods

Crc16Ccitt Methods

The Crc16Ccitt type exposes the following members.

Methods
 | Name | Description
Public method | ComputeChecksum(Byte) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksum(Byte, Int32, Int32) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumBytes(Byte, Boolean) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumBytes(Byte, Int32, Int32, Boolean) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumDrDobbs | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the Dr. Dobbs algorithm.
Public method | ComputeChecksumDrDobbsBytes | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the Dr. Dobbs algorithm.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksum Method

Crc16CcittComputeChecksum Method
Overload List
 | Name | Description
Public method | ComputeChecksum(Byte) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksum(Byte, Int32, Int32) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Top
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksum Method (Byte[])

Crc16CcittComputeChecksum Method (Byte)
Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ComputeChecksum(
    byte[] bytes
)
Public Function ComputeChecksum (
    bytes As Byte()
) As UShort
public:
unsigned short ComputeChecksum(
    array<unsigned char>^ bytes
)
member ComputeChecksum :
        bytes : byte[] -> uint16

Parameters

bytes
Type: SystemByte

Return Value

Type: UInt16
See Also

Reference

Crc16Ccitt Class
ComputeChecksum Overload
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksum Method (Byte[], Int32, Int32)

Crc16CcittComputeChecksum Method (Byte, Int32, Int32)
Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ComputeChecksum(
    byte[] bytes,
    int start,
    int length
)
Public Function ComputeChecksum (
    bytes As Byte(),
    start As Integer,
    length As Integer
) As UShort
public:
unsigned short ComputeChecksum(
    array<unsigned char>^ bytes,
    int start,
    int length
)
member ComputeChecksum :
        bytes : byte[] *
        start : int *
        length : int -> uint16

Parameters

bytes
Type: SystemByte
start
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: UInt16
See Also

Reference

Crc16Ccitt Class
ComputeChecksum Overload
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksumBytes Method

Crc16CcittComputeChecksumBytes Method
Overload List
 | Name | Description
Public method | ComputeChecksumBytes(Byte, Boolean) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Public method | ComputeChecksumBytes(Byte, Int32, Int32, Boolean) | Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.
Top
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksumBytes Method (Byte[], Boolean)

Crc16CcittComputeChecksumBytes Method (Byte, Boolean)
Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytes(
    byte[] bytes,
    bool littleEndian = true
)
Public Function ComputeChecksumBytes (
    bytes As Byte(),
    Optional littleEndian As Boolean = true
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytes(
    array<unsigned char>^ bytes,
    bool littleEndian = true
)
member ComputeChecksumBytes :
        bytes : byte[] *
        ?littleEndian : bool
(* Defaults:
        let _littleEndian = defaultArg littleEndian true
*)
-> byte[]

Parameters

bytes
Type: SystemByte
littleEndian (Optional)
Type: SystemBoolean

Return Value

Type: Byte
See Also

Reference

Crc16Ccitt Class
ComputeChecksumBytes Overload
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksumBytes Method (Byte[], Int32, Int32, Boolean)

Crc16CcittComputeChecksumBytes Method (Byte, Int32, Int32, Boolean)
Returns the CRC-16-CCITT checksum for the array of bytes passed across using the standard calculation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytes(
    byte[] bytes,
    int start,
    int length,
    bool littleEndian = true
)
Public Function ComputeChecksumBytes (
    bytes As Byte(),
    start As Integer,
    length As Integer,
    Optional littleEndian As Boolean = true
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytes(
    array<unsigned char>^ bytes,
    int start,
    int length,
    bool littleEndian = true
)
member ComputeChecksumBytes :
        bytes : byte[] *
        start : int *
        length : int *
        ?littleEndian : bool
(* Defaults:
        let _littleEndian = defaultArg littleEndian true
*)
-> byte[]

Parameters

bytes
Type: SystemByte
start
Type: SystemInt32
length
Type: SystemInt32
littleEndian (Optional)
Type: SystemBoolean

Return Value

Type: Byte
See Also

Reference

Crc16Ccitt Class
ComputeChecksumBytes Overload
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksumDrDobbs Method

Crc16CcittComputeChecksumDrDobbs Method
Returns the CRC-16-CCITT checksum for the array of bytes passed across using the Dr. Dobbs algorithm.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ComputeChecksumDrDobbs(
    byte[] bytes
)
Public Function ComputeChecksumDrDobbs (
    bytes As Byte()
) As UShort
public:
unsigned short ComputeChecksumDrDobbs(
    array<unsigned char>^ bytes
)
member ComputeChecksumDrDobbs :
        bytes : byte[] -> uint16

Parameters

bytes
Type: SystemByte

Return Value

Type: UInt16
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt.ComputeChecksumDrDobbsBytes Method

Crc16CcittComputeChecksumDrDobbsBytes Method
Returns the CRC-16-CCITT checksum for the array of bytes passed across using the Dr. Dobbs algorithm.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumDrDobbsBytes(
    byte[] bytes,
    bool littleEndian = true
)
Public Function ComputeChecksumDrDobbsBytes (
    bytes As Byte(),
    Optional littleEndian As Boolean = true
) As Byte()
public:
array<unsigned char>^ ComputeChecksumDrDobbsBytes(
    array<unsigned char>^ bytes,
    bool littleEndian = true
)
member ComputeChecksumDrDobbsBytes :
        bytes : byte[] *
        ?littleEndian : bool
(* Defaults:
        let _littleEndian = defaultArg littleEndian true
*)
-> byte[]

Parameters

bytes
Type: SystemByte
littleEndian (Optional)
Type: SystemBoolean

Return Value

Type: Byte
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt Fields

Crc16Ccitt Fields

The Crc16Ccitt type exposes the following members.

Fields
Name | Description
InitialiseToAllOnes | An initial CRC value of all-ones.
InitialiseToZero | An initial CRC value of zero.
Top
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt.InitialiseToAllOnes Field

Crc16CcittInitialiseToAllOnes Field
An initial CRC value of all-ones.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const ushort InitialiseToAllOnes
Public Const InitialiseToAllOnes As UShort
public:
literal unsigned short InitialiseToAllOnes
static val mutable InitialiseToAllOnes: uint16

Field Value

Type: UInt16
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc16Ccitt.InitialiseToZero Field

Crc16CcittInitialiseToZero Field
An initial CRC value of zero.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const ushort InitialiseToZero
Public Const InitialiseToZero As UShort
public:
literal unsigned short InitialiseToZero
static val mutable InitialiseToZero: uint16

Field Value

Type: UInt16
See Also

Reference

Crc16Ccitt Class
VirtualRadar.Interface Namespace


Crc32ModeS Class

Crc32ModeS Class
A class that can calculate CRC32 parity bits that are applied to Mode-S messages.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCrc32ModeS

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Crc32ModeS
Public Class Crc32ModeS
public ref class Crc32ModeS
type Crc32ModeS =  class end

The Crc32ModeS type exposes the following members.

Constructors
 | Name | Description
Public method | Crc32ModeS | Creates a new object.
Top
Methods
 | Name | Description
Public method | ComputeChecksum | Calculates the parity on the message passed across. Only the first three bytes (big-endian) are applied against Mode-S messages.
Public method | ComputeChecksumBytes | Calculates a four-byte parity on the message passed across. Only the first three bytes are applied against Mode-S messages (when big-endian format is used).
Public method | ComputeChecksumBytesTraditional32 | Calculates the four-byte parity on a 4 byte message using the traditional (slow) method recommended by the Eurocontrol document '022_CRC_calculations_for_Mode_S'.
Public method | ComputeChecksumBytesTraditional88 | Calculates the four-byte parity on an 11 byte message using the traditional (slow) method recommended by the Eurocontrol document '022_CRC_calculations_for_Mode_S'.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Note that the CRC for a message of all zeros is zero.
See Also

Reference

VirtualRadar.Interface Namespace


Crc32ModeS Constructor

Crc32ModeS Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Crc32ModeS()
Public Sub New
public:
Crc32ModeS()
new : unit -> Crc32ModeS
See Also

Reference

Crc32ModeS Class
VirtualRadar.Interface Namespace


Crc32ModeS Methods

Crc32ModeS Methods

The Crc32ModeS type exposes the following members.

Methods
 | Name | Description
Public method | ComputeChecksum | Calculates the parity on the message passed across. Only the first three bytes (big-endian) are applied against Mode-S messages.
Public method | ComputeChecksumBytes | Calculates a four-byte parity on the message passed across. Only the first three bytes are applied against Mode-S messages (when big-endian format is used).
Public method | ComputeChecksumBytesTraditional32 | Calculates the four-byte parity on a 4 byte message using the traditional (slow) method recommended by the Eurocontrol document '022_CRC_calculations_for_Mode_S'.
Public method | ComputeChecksumBytesTraditional88 | Calculates the four-byte parity on an 11 byte message using the traditional (slow) method recommended by the Eurocontrol document '022_CRC_calculations_for_Mode_S'.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Crc32ModeS Class
VirtualRadar.Interface Namespace


Crc32ModeS.ComputeChecksum Method

Crc32ModeSComputeChecksum Method
Calculates the parity on the message passed across. Only the first three bytes (big-endian) are applied against Mode-S messages.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ComputeChecksum(
    byte[] bytes,
    int offset,
    int length
)
Public Function ComputeChecksum (
    bytes As Byte(),
    offset As Integer,
    length As Integer
) As UInteger
public:
unsigned int ComputeChecksum(
    array<unsigned char>^ bytes,
    int offset,
    int length
)
member ComputeChecksum :
        bytes : byte[] *
        offset : int *
        length : int -> uint32

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: UInt32
See Also

Reference

Crc32ModeS Class
VirtualRadar.Interface Namespace


Crc32ModeS.ComputeChecksumBytes Method

Crc32ModeSComputeChecksumBytes Method
Calculates a four-byte parity on the message passed across. Only the first three bytes are applied against Mode-S messages (when big-endian format is used).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytes(
    byte[] bytes,
    int offset,
    int length,
    bool littleEndian = false
)
Public Function ComputeChecksumBytes (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    Optional littleEndian As Boolean = false
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytes(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    bool littleEndian = false
)
member ComputeChecksumBytes :
        bytes : byte[] *
        offset : int *
        length : int *
        ?littleEndian : bool
(* Defaults:
        let _littleEndian = defaultArg littleEndian false
*)
-> byte[]

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
littleEndian (Optional)
Type: SystemBoolean

Return Value

Type: Byte
See Also

Reference

Crc32ModeS Class
VirtualRadar.Interface Namespace


Crc32ModeS.ComputeChecksumBytesTraditional32 Method

Crc32ModeSComputeChecksumBytesTraditional32 Method
Calculates the four-byte parity on a 4 byte message using the traditional (slow) method recommended by the Eurocontrol document '022_CRC_calculations_for_Mode_S'.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytesTraditional32(
    byte[] bytes
)
Public Function ComputeChecksumBytesTraditional32 (
    bytes As Byte()
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytesTraditional32(
    array<unsigned char>^ bytes
)
member ComputeChecksumBytesTraditional32 :
        bytes : byte[] -> byte[]

Parameters

bytes
Type: SystemByte

Return Value

Type: Byte
Remarks
I've put it here for timing comparison tests. Don't use for live code.
See Also

Reference

Crc32ModeS Class
VirtualRadar.Interface Namespace


Crc32ModeS.ComputeChecksumBytesTraditional88 Method

Crc32ModeSComputeChecksumBytesTraditional88 Method
Calculates the four-byte parity on an 11 byte message using the traditional (slow) method recommended by the Eurocontrol document '022_CRC_calculations_for_Mode_S'.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytesTraditional88(
    byte[] bytes
)
Public Function ComputeChecksumBytesTraditional88 (
    bytes As Byte()
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytesTraditional88(
    array<unsigned char>^ bytes
)
member ComputeChecksumBytesTraditional88 :
        bytes : byte[] -> byte[]

Parameters

bytes
Type: SystemByte

Return Value

Type: Byte
Remarks
I've put this here for timing comparison tests. Don't use for live code.
See Also

Reference

Crc32ModeS Class
VirtualRadar.Interface Namespace


Crc64 Class

Crc64 Class
A class that can calculate CRC64 checksums on a set of arbitrary bytes.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCrc64

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Crc64
Public Class Crc64
public ref class Crc64
type Crc64 =  class end

The Crc64 type exposes the following members.

Constructors
 | Name | Description
Public method | Crc64 | Creates a new object.
Top
Methods
 | Name | Description
Public method | ComputeChecksum | Calculates the checksum on the bytes passed across.
Public method | ComputeChecksumBytes | Calculates an eight-byte checksum on the bytes passed across.
Public method | ComputeChecksumString | Calculates the checksum on the bytes passed across and returns it as a string of digit characters of a fixed length.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | _LookupTable | The table of pre-calculated checksum values for all 256 values of a byte.
Top
Remarks
Pretty much lifted straight from the Sanity Free coding blog, but switched around to use a 64-bit polynominal and 64-bit values instead of 32-bit. See http://sanity-free.org/12/crc32_implementation_in_csharp.html for the original 32-bit version.
See Also

Reference

VirtualRadar.Interface Namespace


Crc64 Constructor

Crc64 Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Crc64()
Public Sub New
public:
Crc64()
new : unit -> Crc64
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


Crc64 Methods

Crc64 Methods

The Crc64 type exposes the following members.

Methods
 | Name | Description
Public method | ComputeChecksum | Calculates the checksum on the bytes passed across.
Public method | ComputeChecksumBytes | Calculates an eight-byte checksum on the bytes passed across.
Public method | ComputeChecksumString | Calculates the checksum on the bytes passed across and returns it as a string of digit characters of a fixed length.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


Crc64.ComputeChecksum Method

Crc64ComputeChecksum Method
Calculates the checksum on the bytes passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ComputeChecksum(
    byte[] bytes,
    int offset,
    int length
)
Public Function ComputeChecksum (
    bytes As Byte(),
    offset As Integer,
    length As Integer
) As ULong
public:
unsigned long long ComputeChecksum(
    array<unsigned char>^ bytes,
    int offset,
    int length
)
member ComputeChecksum :
        bytes : byte[] *
        offset : int *
        length : int -> uint64

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: UInt64
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


Crc64.ComputeChecksumBytes Method

Crc64ComputeChecksumBytes Method
Calculates an eight-byte checksum on the bytes passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ComputeChecksumBytes(
    byte[] bytes,
    int offset,
    int length,
    bool littleEndian = false
)
Public Function ComputeChecksumBytes (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    Optional littleEndian As Boolean = false
) As Byte()
public:
array<unsigned char>^ ComputeChecksumBytes(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    bool littleEndian = false
)
member ComputeChecksumBytes :
        bytes : byte[] *
        offset : int *
        length : int *
        ?littleEndian : bool
(* Defaults:
        let _littleEndian = defaultArg littleEndian false
*)
-> byte[]

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
littleEndian (Optional)
Type: SystemBoolean

Return Value

Type: Byte
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


Crc64.ComputeChecksumString Method

Crc64ComputeChecksumString Method
Calculates the checksum on the bytes passed across and returns it as a string of digit characters of a fixed length.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ComputeChecksumString(
    byte[] bytes,
    int offset,
    int length
)
Public Function ComputeChecksumString (
    bytes As Byte(),
    offset As Integer,
    length As Integer
) As String
public:
String^ ComputeChecksumString(
    array<unsigned char>^ bytes,
    int offset,
    int length
)
member ComputeChecksumString :
        bytes : byte[] *
        offset : int *
        length : int -> string

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: String
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


Crc64 Fields

Crc64 Fields

The Crc64 type exposes the following members.

Fields
 | Name | Description
Public field | _LookupTable | The table of pre-calculated checksum values for all 256 values of a byte.
Top
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


Crc64._LookupTable Field

Crc64_LookupTable Field
The table of pre-calculated checksum values for all 256 values of a byte.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong[] _LookupTable
Public _LookupTable As ULong()
public:
array<unsigned long long>^ _LookupTable
val mutable _LookupTable: uint64[]

Field Value

Type: UInt64
See Also

Reference

Crc64 Class
VirtualRadar.Interface Namespace


CultureSwitcher Class

CultureSwitcher Class
A class that switches the current thread to a particular culture when it is created and then restores the original culture when it's disposed.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCultureSwitcher

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CultureSwitcher : IDisposable
Public Class CultureSwitcher
    Implements IDisposable
public ref class CultureSwitcher : IDisposable
type CultureSwitcher =
    class
        interface IDisposable
    end

The CultureSwitcher type exposes the following members.

Constructors
 | Name | Description
Public method | CultureSwitcher | Creates a new object.
Public method | CultureSwitcher(String) | Creates a new object.
Top
Properties
 | Name | Description
Public property | CultureName | Gets the name of the culture currently in force.
 | MainThreadCulture | Gets the main thread's CultureInfo.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes of the object. Resets the culture back to how the constructor found it.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


CultureSwitcher Constructor

CultureSwitcher Constructor
Overload List
 | Name | Description
Public method | CultureSwitcher | Creates a new object.
Public method | CultureSwitcher(String) | Creates a new object.
Top
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CultureSwitcher Constructor

CultureSwitcher Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CultureSwitcher()
Public Sub New
public:
CultureSwitcher()
new : unit -> CultureSwitcher
See Also

Reference

CultureSwitcher Class
CultureSwitcher Overload
VirtualRadar.Interface Namespace


CultureSwitcher Constructor (String)

CultureSwitcher Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CultureSwitcher(
    string culture
)
Public Sub New (
    culture As String
)
public:
CultureSwitcher(
    String^ culture
)
new :
        culture : string -> CultureSwitcher

Parameters

culture
Type: SystemString
The name of the culture (e.g. 'en-GB' or 'de-DE') that the current thread will be set to.
See Also

Reference

CultureSwitcher Class
CultureSwitcher Overload
VirtualRadar.Interface Namespace


CultureSwitcher Properties

CultureSwitcher Properties

The CultureSwitcher type exposes the following members.

Properties
 | Name | Description
Public property | CultureName | Gets the name of the culture currently in force.
 | MainThreadCulture | Gets the main thread's CultureInfo.
Top
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CultureSwitcher.CultureName Property

CultureSwitcherCultureName Property
Gets the name of the culture currently in force.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CultureName { get; }
Public ReadOnly Property CultureName As String
    Get
public:
property String^ CultureName {
    String^ get ();
}
member CultureName : string with get

Property Value

Type: String
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CultureSwitcher.MainThreadCulture Property

CultureSwitcherMainThreadCulture Property
Gets the main thread's CultureInfo.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CultureInfo MainThreadCulture { get; }
Public Shared ReadOnly Property MainThreadCulture As CultureInfo
    Get
public:
static property CultureInfo^ MainThreadCulture {
    CultureInfo^ get ();
}
static member MainThreadCulture : CultureInfo with get

Property Value

Type: CultureInfo
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CultureSwitcher Methods

CultureSwitcher Methods

The CultureSwitcher type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes of the object. Resets the culture back to how the constructor found it.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CultureSwitcher.Dispose Method

CultureSwitcherDispose Method
Overload List
 | Name | Description
Public method | Dispose | Disposes of the object. Resets the culture back to how the constructor found it.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Top
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CultureSwitcher.Dispose Method

CultureSwitcherDispose Method
Disposes of the object. Resets the culture back to how the constructor found it.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CultureSwitcher Class
Dispose Overload
VirtualRadar.Interface Namespace


CultureSwitcher.Dispose Method (Boolean)

CultureSwitcherDispose Method (Boolean)
Disposes of or finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

CultureSwitcher Class
Dispose Overload
VirtualRadar.Interface Namespace


CultureSwitcher.Finalize Method

CultureSwitcherFinalize Method
Finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

CultureSwitcher Class
VirtualRadar.Interface Namespace


CustomConvert Class

CustomConvert Class
Performs simple custom conversions.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceCustomConvert

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CustomConvert
Public NotInheritable Class CustomConvert
public ref class CustomConvert abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CustomConvert =  class end

The CustomConvert type exposes the following members.

Methods
Name | Description
ChangeType | Converts a value from one type to another, as per the standard ChangeType(Object, Type), except that this version can cope with the conversion of NullableT types.
Top
See Also

Reference

VirtualRadar.Interface Namespace


CustomConvert Methods

CustomConvert Methods

The CustomConvert type exposes the following members.

Methods
Name | Description
ChangeType | Converts a value from one type to another, as per the standard ChangeType(Object, Type), except that this version can cope with the conversion of NullableT types.
Top
See Also

Reference

CustomConvert Class
VirtualRadar.Interface Namespace


CustomConvert.ChangeType Method

CustomConvertChangeType Method
Converts a value from one type to another, as per the standard ChangeType(Object, Type), except that this version can cope with the conversion of NullableT types.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ChangeType(
    Object value,
    Type type,
    IFormatProvider provider
)
Public Shared Function ChangeType (
    value As Object,
    type As Type,
    provider As IFormatProvider
) As Object
public:
static Object^ ChangeType(
    Object^ value,
    Type^ type,
    IFormatProvider^ provider
)
static member ChangeType :
        value : Object *
        type : Type *
        provider : IFormatProvider -> Object

Parameters

value
Type: SystemObject
type
Type: SystemType
provider
Type: SystemIFormatProvider

Return Value

Type: Object
See Also

Reference

CustomConvert Class
VirtualRadar.Interface Namespace


Describe Class

Describe Class
A static class that can produce descriptions of objects that implement common interfaces.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceDescribe

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Describe
Public NotInheritable Class Describe
public ref class Describe abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Describe =  class end

The Describe type exposes the following members.

Methods
Name | Description
Airport | Returns a standard description of an airport.
AirportName | Returns a single airport name that is a concatenation of the official airport name and location / city name.
Bytes | Returns a number of bytes formatted as 'n B', 'n KB', 'n MB' etc.
ConnectionStatus | Returns a description of a connection status.
ConnectionType | Returns a description of a connection type.
ConnectorActivityType | Returns a description of a connector activity type.
DefaultAccess | Returns the default access enum formatted as a translated string.
DistanceUnit | Returns a description of a distance unit.
ExceptionMultiLine | Returns a multi-line description of an exception.
ExceptionSingleLineFull | Returns a full (and probably very long) description of an exception on a single line.
Handshake | Returns a description of a serial port handshake.
HeightUnit | Returns a description of a height unit.
IcaoCompliantRegistration | Returns the registration passed across with characters that contravene the ICAO registration rules stripped out or transformed to upper-case as appropriate. Plus and minus are also accepted.
Parity | Returns a description of a parity value.
ProxyType | Returns a description of a proxy type.
RebroadcastSettingsCollection | Returns a description of the collection of RebroadcastSettings passed across.
ReceiverUsage | Returns a translated description of a receiver usage.
SpeedUnit | Returns a description of a speed unit.
StopBits | Returns a description of a number of stop bits.
TimeSpan | Returns the timespan formatted as a number of hours, minutes and seconds.
Top
See Also

Reference

VirtualRadar.Interface Namespace


Describe Methods

Describe Methods

The Describe type exposes the following members.

Methods
Name | Description
Airport | Returns a standard description of an airport.
AirportName | Returns a single airport name that is a concatenation of the official airport name and location / city name.
Bytes | Returns a number of bytes formatted as 'n B', 'n KB', 'n MB' etc.
ConnectionStatus | Returns a description of a connection status.
ConnectionType | Returns a description of a connection type.
ConnectorActivityType | Returns a description of a connector activity type.
DefaultAccess | Returns the default access enum formatted as a translated string.
DistanceUnit | Returns a description of a distance unit.
ExceptionMultiLine | Returns a multi-line description of an exception.
ExceptionSingleLineFull | Returns a full (and probably very long) description of an exception on a single line.
Handshake | Returns a description of a serial port handshake.
HeightUnit | Returns a description of a height unit.
IcaoCompliantRegistration | Returns the registration passed across with characters that contravene the ICAO registration rules stripped out or transformed to upper-case as appropriate. Plus and minus are also accepted.
Parity | Returns a description of a parity value.
ProxyType | Returns a description of a proxy type.
RebroadcastSettingsCollection | Returns a description of the collection of RebroadcastSettings passed across.
ReceiverUsage | Returns a translated description of a receiver usage.
SpeedUnit | Returns a description of a speed unit.
StopBits | Returns a description of a number of stop bits.
TimeSpan | Returns the timespan formatted as a number of hours, minutes and seconds.
Top
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.Airport Method

DescribeAirport Method
Returns a standard description of an airport.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Airport(
    Airport airport,
    bool preferIataAirportCode,
    bool showCode = true,
    bool showName = true,
    bool showCountry = true
)
Public Shared Function Airport (
    airport As Airport,
    preferIataAirportCode As Boolean,
    Optional showCode As Boolean = true,
    Optional showName As Boolean = true,
    Optional showCountry As Boolean = true
) As String
public:
static String^ Airport(
    Airport^ airport,
    bool preferIataAirportCode,
    bool showCode = true,
    bool showName = true,
    bool showCountry = true
)
static member Airport :
        airport : Airport *
        preferIataAirportCode : bool *
        ?showCode : bool *
        ?showName : bool *
        ?showCountry : bool
(* Defaults:
        let _showCode = defaultArg showCode true
        let _showName = defaultArg showName true
        let _showCountry = defaultArg showCountry true
*)
-> string

Parameters

airport
Type: VirtualRadar.Interface.StandingDataAirport
preferIataAirportCode
Type: SystemBoolean
showCode (Optional)
Type: SystemBoolean
showName (Optional)
Type: SystemBoolean
showCountry (Optional)
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.AirportName Method

DescribeAirportName Method
Returns a single airport name that is a concatenation of the official airport name and location / city name.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AirportName(
    string airportName,
    string cityName
)
Public Shared Function AirportName (
    airportName As String,
    cityName As String
) As String
public:
static String^ AirportName(
    String^ airportName,
    String^ cityName
)
static member AirportName :
        airportName : string *
        cityName : string -> string

Parameters

airportName
Type: SystemString
cityName
Type: SystemString

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.Bytes Method

DescribeBytes Method
Returns a number of bytes formatted as 'n B', 'n KB', 'n MB' etc.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Bytes(
    long fullSize
)
Public Shared Function Bytes (
    fullSize As Long
) As String
public:
static String^ Bytes(
    long long fullSize
)
static member Bytes :
        fullSize : int64 -> string

Parameters

fullSize
Type: SystemInt64

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ConnectionStatus Method

DescribeConnectionStatus Method
Returns a description of a connection status.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConnectionStatus(
    ConnectionStatus connectionStatus
)
Public Shared Function ConnectionStatus (
    connectionStatus As ConnectionStatus
) As String
public:
static String^ ConnectionStatus(
    ConnectionStatus connectionStatus
)
static member ConnectionStatus :
        connectionStatus : ConnectionStatus -> string

Parameters

connectionStatus
Type: VirtualRadar.Interface.NetworkConnectionStatus

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ConnectionType Method

DescribeConnectionType Method
Returns a description of a connection type.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConnectionType(
    ConnectionType connectionType
)
Public Shared Function ConnectionType (
    connectionType As ConnectionType
) As String
public:
static String^ ConnectionType(
    ConnectionType connectionType
)
static member ConnectionType :
        connectionType : ConnectionType -> string

Parameters

connectionType
Type: VirtualRadar.Interface.SettingsConnectionType

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ConnectorActivityType Method

DescribeConnectorActivityType Method
Returns a description of a connector activity type.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConnectorActivityType(
    ConnectorActivityType connectorActivityType
)
Public Shared Function ConnectorActivityType (
    connectorActivityType As ConnectorActivityType
) As String
public:
static String^ ConnectorActivityType(
    ConnectorActivityType connectorActivityType
)
static member ConnectorActivityType :
        connectorActivityType : ConnectorActivityType -> string

Parameters

connectorActivityType
Type: VirtualRadar.Interface.NetworkConnectorActivityType

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.DefaultAccess Method

DescribeDefaultAccess Method
Returns the default access enum formatted as a translated string.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultAccess(
    DefaultAccess defaultAccess
)
Public Shared Function DefaultAccess (
    defaultAccess As DefaultAccess
) As String
public:
static String^ DefaultAccess(
    DefaultAccess defaultAccess
)
static member DefaultAccess :
        defaultAccess : DefaultAccess -> string

Parameters

defaultAccess
Type: VirtualRadar.Interface.SettingsDefaultAccess

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.DistanceUnit Method

DescribeDistanceUnit Method
Returns a description of a distance unit.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DistanceUnit(
    DistanceUnit distanceUnit
)
Public Shared Function DistanceUnit (
    distanceUnit As DistanceUnit
) As String
public:
static String^ DistanceUnit(
    DistanceUnit distanceUnit
)
static member DistanceUnit :
        distanceUnit : DistanceUnit -> string

Parameters

distanceUnit
Type: VirtualRadar.InterfaceDistanceUnit

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ExceptionMultiLine Method

DescribeExceptionMultiLine Method
Returns a multi-line description of an exception.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExceptionMultiLine(
    Exception exception,
    string newLine = null
)
Public Shared Function ExceptionMultiLine (
    exception As Exception,
    Optional newLine As String = Nothing
) As String
public:
static String^ ExceptionMultiLine(
    Exception^ exception,
    String^ newLine = nullptr
)
static member ExceptionMultiLine :
        exception : Exception *
        ?newLine : string
(* Defaults:
        let _newLine = defaultArg newLine null
*)
-> string

Parameters

exception
Type: SystemException
newLine (Optional)
Type: SystemString

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ExceptionSingleLineFull Method

DescribeExceptionSingleLineFull Method
Returns a full (and probably very long) description of an exception on a single line.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExceptionSingleLineFull(
    Exception exception
)
Public Shared Function ExceptionSingleLineFull (
    exception As Exception
) As String
public:
static String^ ExceptionSingleLineFull(
    Exception^ exception
)
static member ExceptionSingleLineFull :
        exception : Exception -> string

Parameters

exception
Type: SystemException

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.Handshake Method

DescribeHandshake Method
Returns a description of a serial port handshake.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Handshake(
    Handshake handshake
)
Public Shared Function Handshake (
    handshake As Handshake
) As String
public:
static String^ Handshake(
    Handshake handshake
)
static member Handshake :
        handshake : Handshake -> string

Parameters

handshake
Type: System.IO.PortsHandshake

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.HeightUnit Method

DescribeHeightUnit Method
Returns a description of a height unit.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HeightUnit(
    HeightUnit heightUnit
)
Public Shared Function HeightUnit (
    heightUnit As HeightUnit
) As String
public:
static String^ HeightUnit(
    HeightUnit heightUnit
)
static member HeightUnit :
        heightUnit : HeightUnit -> string

Parameters

heightUnit
Type: VirtualRadar.InterfaceHeightUnit

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.IcaoCompliantRegistration Method

DescribeIcaoCompliantRegistration Method
Returns the registration passed across with characters that contravene the ICAO registration rules stripped out or transformed to upper-case as appropriate. Plus and minus are also accepted.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IcaoCompliantRegistration(
    string registration
)
Public Shared Function IcaoCompliantRegistration (
    registration As String
) As String
public:
static String^ IcaoCompliantRegistration(
    String^ registration
)
static member IcaoCompliantRegistration :
        registration : string -> string

Parameters

registration
Type: SystemString

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.Parity Method

DescribeParity Method
Returns a description of a parity value.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Parity(
    Parity parity
)
Public Shared Function Parity (
    parity As Parity
) As String
public:
static String^ Parity(
    Parity parity
)
static member Parity :
        parity : Parity -> string

Parameters

parity
Type: System.IO.PortsParity

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ProxyType Method

DescribeProxyType Method
Returns a description of a proxy type.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ProxyType(
    ProxyType proxyType
)
Public Shared Function ProxyType (
    proxyType As ProxyType
) As String
public:
static String^ ProxyType(
    ProxyType proxyType
)
static member ProxyType :
        proxyType : ProxyType -> string

Parameters

proxyType
Type: VirtualRadar.Interface.SettingsProxyType

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.RebroadcastSettingsCollection Method

DescribeRebroadcastSettingsCollection Method
Returns a description of the collection of RebroadcastSettings passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string RebroadcastSettingsCollection(
    IList<RebroadcastSettings> settings
)
Public Shared Function RebroadcastSettingsCollection (
    settings As IList(Of RebroadcastSettings)
) As String
public:
static String^ RebroadcastSettingsCollection(
    IList<RebroadcastSettings^>^ settings
)
static member RebroadcastSettingsCollection :
        settings : IList<RebroadcastSettings> -> string

Parameters

settings
Type: System.Collections.GenericIList RebroadcastSettings

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.ReceiverUsage Method

DescribeReceiverUsage Method
Returns a translated description of a receiver usage.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReceiverUsage(
    ReceiverUsage receiverUsage
)
Public Shared Function ReceiverUsage (
    receiverUsage As ReceiverUsage
) As String
public:
static String^ ReceiverUsage(
    ReceiverUsage receiverUsage
)
static member ReceiverUsage :
        receiverUsage : ReceiverUsage -> string

Parameters

receiverUsage
Type: VirtualRadar.Interface.SettingsReceiverUsage

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.SpeedUnit Method

DescribeSpeedUnit Method
Returns a description of a speed unit.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SpeedUnit(
    SpeedUnit speedUnit
)
Public Shared Function SpeedUnit (
    speedUnit As SpeedUnit
) As String
public:
static String^ SpeedUnit(
    SpeedUnit speedUnit
)
static member SpeedUnit :
        speedUnit : SpeedUnit -> string

Parameters

speedUnit
Type: VirtualRadar.InterfaceSpeedUnit

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.StopBits Method

DescribeStopBits Method
Returns a description of a number of stop bits.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StopBits(
    StopBits stopBits
)
Public Shared Function StopBits (
    stopBits As StopBits
) As String
public:
static String^ StopBits(
    StopBits stopBits
)
static member StopBits :
        stopBits : StopBits -> string

Parameters

stopBits
Type: System.IO.PortsStopBits

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


Describe.TimeSpan Method

DescribeTimeSpan Method
Returns the timespan formatted as a number of hours, minutes and seconds.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TimeSpan(
    TimeSpan timeSpan
)
Public Shared Function TimeSpan (
    timeSpan As TimeSpan
) As String
public:
static String^ TimeSpan(
    TimeSpan timeSpan
)
static member TimeSpan :
        timeSpan : TimeSpan -> string

Parameters

timeSpan
Type: SystemTimeSpan

Return Value

Type: String
See Also

Reference

Describe Class
VirtualRadar.Interface Namespace


DistanceUnit Enumeration

DistanceUnit Enumeration
An enumeration of the different distance units that the website can display.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DistanceUnit
Public Enumeration DistanceUnit
public enum class DistanceUnit
type DistanceUnit
Members
Member name | Value | Description
Miles | 0 | Miles.
Kilometres | 1 | Kilometres.
NauticalMiles | 2 | Nautical miles.
Remarks
The names of these enumeration values must exactly match the equivalent names in the Javascript produced by the web site.
See Also

Reference

VirtualRadar.Interface Namespace


EventArgs(T) Class

EventArgsT Class
An EventArgs that exposes a single value as a property.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.InterfaceEventArgsT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EventArgs<T> : EventArgs

Public Class EventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class EventArgs : public EventArgs
type EventArgs<'T> =
    class
        inherit EventArgs
    end

Type Parameters

T

The EventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT | Creates a new object.
Top
Properties
 | Name | Description
Public property | Value | Gets the exposed property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


EventArgs(T) Constructor

EventArgsT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventArgs(
    T value
)
Public Sub New (
    value As T
)
public:
EventArgs(
    T value
)
new :
        value : 'T -> EventArgs

Parameters

value
Type: T
See Also

Reference

EventArgsT Class
VirtualRadar.Interface Namespace


EventArgs(T) Properties

EventArgsT Properties

The EventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the exposed property.
Top
See Also

Reference

EventArgsT Class
VirtualRadar.Interface Namespace


EventArgs(T).Value Property

EventArgsTValue Property
Gets the exposed property.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Value { get; }
Public ReadOnly Property Value As T
    Get
public:
property T Value {
    T get ();
}
member Value : 'T with get

Property Value

Type: T
See Also

Reference

EventArgsT Class
VirtualRadar.Interface Namespace


EventArgs(T) Methods

EventArgsT Methods

The EventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventArgsT Class
VirtualRadar.Interface Namespace


EventHandlerUtils Class

EventHandlerUtils Class
A static class that makes it easier to use weak event handlers.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceEventHandlerUtils

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class EventHandlerUtils
Public NotInheritable Class EventHandlerUtils
public ref class EventHandlerUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EventHandlerUtils =  class end

The EventHandlerUtils type exposes the following members.

Methods
Name | Description
MakeWeakE | Creates a weak event handler for an event.
Top
See Also

Reference

VirtualRadar.Interface Namespace


EventHandlerUtils Methods

EventHandlerUtils Methods

The EventHandlerUtils type exposes the following members.

Methods
Name | Description
MakeWeakE | Creates a weak event handler for an event.
Top
See Also

Reference

EventHandlerUtils Class
VirtualRadar.Interface Namespace


EventHandlerUtils.MakeWeak(E) Method

EventHandlerUtilsMakeWeakE Method
Creates a weak event handler for an event.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EventHandler<E> MakeWeak<E>(
    EventHandler<E> eventHandler,
    UnregisterCallback<E> unregister
)
where E : EventArgs

Public Shared Function MakeWeak(Of E As EventArgs) (
    eventHandler As EventHandler(Of E),
    unregister As UnregisterCallback(Of E)
) As EventHandler(Of E)
public:
generic<typename E>
where E : EventArgs
static EventHandler<E>^ MakeWeak(
    EventHandler<E>^ eventHandler,
    UnregisterCallback<E>^ unregister
)
static member MakeWeak :
        eventHandler : EventHandler<'E> *
        unregister : UnregisterCallback<'E> -> EventHandler<'E>  when 'E : EventArgs

Parameters

eventHandler
Type: SystemEventHandler E
The delegate that will be called when the event is raised.
unregister
Type: VirtualRadar.InterfaceUnregisterCallback E
A delegate that will unregister the event from the event handler when the object is garbage collected.

Type Parameters

E
The type of EventArgs that the event uses.

Return Value

Type: EventHandler E
The event handler for the event.
See Also

Reference

EventHandlerUtils Class
VirtualRadar.Interface Namespace


EventHelper Class

EventHelper Class
Methods that help when handling events.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceEventHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class EventHelper
Public NotInheritable Class EventHelper
public ref class EventHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EventHelper =  class end

The EventHelper type exposes the following members.

Methods
Name | Description
RaiseTEventArgs(Delegate, Object, FuncTEventArgs, ActionException, Boolean) | Raises an event for an event handler.
RaiseTEventArgs(Delegate, Object, TEventArgs, ActionException, Boolean) | Raises an event for an event handler.
RaiseQuicklyTEventArgs(EventHandlerTEventArgs, Object, FuncTEventArgs) | Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.
RaiseQuicklyTEventArgs(EventHandlerTEventArgs, Object, TEventArgs) | Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.
Rethrow | Rethrows an exception without losing stack information.
Top
See Also

Reference

VirtualRadar.Interface Namespace


EventHelper Methods

EventHelper Methods

The EventHelper type exposes the following members.

Methods
Name | Description
RaiseTEventArgs(Delegate, Object, FuncTEventArgs, ActionException, Boolean) | Raises an event for an event handler.
RaiseTEventArgs(Delegate, Object, TEventArgs, ActionException, Boolean) | Raises an event for an event handler.
RaiseQuicklyTEventArgs(EventHandlerTEventArgs, Object, FuncTEventArgs) | Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.
RaiseQuicklyTEventArgs(EventHandlerTEventArgs, Object, TEventArgs) | Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.
Rethrow | Rethrows an exception without losing stack information.
Top
See Also

Reference

EventHelper Class
VirtualRadar.Interface Namespace


EventHelper.Raise Method

EventHelperRaise Method
Overload List
Name | Description
RaiseTEventArgs(Delegate, Object, FuncTEventArgs, ActionException, Boolean) | Raises an event for an event handler.
RaiseTEventArgs(Delegate, Object, TEventArgs, ActionException, Boolean) | Raises an event for an event handler.
Top
See Also

Reference

EventHelper Class
VirtualRadar.Interface Namespace


EventHelper.Raise(TEventArgs) Method (Delegate, Object, Func(TEventArgs), Action(Exception), Boolean)

EventHelperRaiseTEventArgs Method (Delegate, Object, FuncTEventArgs, ActionException, Boolean)
Raises an event for an event handler.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Raise<TEventArgs>(
    Delegate eventHandler,
    Object sender,
    Func<TEventArgs> buildArgsCallback,
    Action<Exception> exceptionCallback = null,
    bool throwEventHelperException = false
)
where TEventArgs : EventArgs

Public Shared Sub Raise(Of TEventArgs As EventArgs) (
    eventHandler As Delegate,
    sender As Object,
    buildArgsCallback As Func(Of TEventArgs),
    Optional exceptionCallback As Action(Of Exception) = Nothing,
    Optional throwEventHelperException As Boolean = false
)
public:
generic<typename TEventArgs>
where TEventArgs : EventArgs
static void Raise(
    Delegate^ eventHandler,
    Object^ sender,
    Func<TEventArgs>^ buildArgsCallback,
    Action<Exception^>^ exceptionCallback = nullptr,
    bool throwEventHelperException = false
)
static member Raise :
        eventHandler : Delegate *
        sender : Object *
        buildArgsCallback : Func<'TEventArgs> *
        ?exceptionCallback : Action<Exception> *
        ?throwEventHelperException : bool
(* Defaults:
        let _exceptionCallback = defaultArg exceptionCallback null
        let _throwEventHelperException = defaultArg throwEventHelperException false
*)
-> unit  when 'TEventArgs : EventArgs

Parameters

eventHandler
Type: SystemDelegate
sender
Type: SystemObject
buildArgsCallback
Type: SystemFunc TEventArgs
exceptionCallback (Optional)
Type: SystemAction Exception
Called whenever an exception is raised. If this is supplied then throwEventHelperException has no effect, all handlers will be called and this function won't let exceptions thrown by the handlers bubble (unless the callback throws an exception, in which case an EventHelperException that wraps the exception(s) will be thrown).
throwEventHelperException (Optional)
Type: SystemBoolean
True if exceptions thrown by event handlers should be wrapped into a single EventHelperException, false if the first exception thrown by an event handler should be rethrown. If this is false then the first event handler that throws an exception will stop all other event handlers from being called.

Type Parameters

TEventArgs
Remarks
Note that this is roughly 6x - 9x slower than a normal event handler call.
See Also

Reference

EventHelper Class
Raise Overload
VirtualRadar.Interface Namespace


EventHelper.Raise(TEventArgs) Method (Delegate, Object, TEventArgs, Action(Exception), Boolean)

EventHelperRaiseTEventArgs Method (Delegate, Object, TEventArgs, ActionException, Boolean)
Raises an event for an event handler.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Raise<TEventArgs>(
    Delegate eventHandler,
    Object sender,
    TEventArgs args = null,
    Action<Exception> exceptionCallback = null,
    bool throwEventHelperException = false
)
where TEventArgs : EventArgs

Public Shared Sub Raise(Of TEventArgs As EventArgs) (
    eventHandler As Delegate,
    sender As Object,
    Optional args As TEventArgs = Nothing,
    Optional exceptionCallback As Action(Of Exception) = Nothing,
    Optional throwEventHelperException As Boolean = false
)
public:
generic<typename TEventArgs>
where TEventArgs : EventArgs
static void Raise(
    Delegate^ eventHandler,
    Object^ sender,
    TEventArgs args = nullptr,
    Action<Exception^>^ exceptionCallback = nullptr,
    bool throwEventHelperException = false
)
static member Raise :
        eventHandler : Delegate *
        sender : Object *
        ?args : 'TEventArgs *
        ?exceptionCallback : Action<Exception> *
        ?throwEventHelperException : bool
(* Defaults:
        let _args = defaultArg args null
        let _exceptionCallback = defaultArg exceptionCallback null
        let _throwEventHelperException = defaultArg throwEventHelperException false
*)
-> unit  when 'TEventArgs : EventArgs

Parameters

eventHandler
Type: SystemDelegate
sender
Type: SystemObject
args (Optional)
Type: TEventArgs
exceptionCallback (Optional)
Type: SystemAction Exception
Called whenever an exception is raised. If this is supplied then throwEventHelperException has no effect, all handlers will be called and this function won't let exceptions thrown by the handlers bubble (unless the callback throws an exception, in which case an EventHelperException that wraps the exception(s) will be thrown).
throwEventHelperException (Optional)
Type: SystemBoolean
True if exceptions thrown by event handlers should be wrapped into a single EventHelperException, false if the first exception thrown by an event handler should be rethrown. If this is false then the first event handler that throws an exception will stop all other event handlers from being called.

Type Parameters

TEventArgs
Remarks
Note that this is roughly 6x - 9x slower than a normal event handler call.
See Also

Reference

EventHelper Class
Raise Overload
VirtualRadar.Interface Namespace


EventHelper.RaiseQuickly Method

EventHelperRaiseQuickly Method
Overload List
Name | Description
RaiseQuicklyTEventArgs(EventHandlerTEventArgs, Object, FuncTEventArgs) | Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.
RaiseQuicklyTEventArgs(EventHandlerTEventArgs, Object, TEventArgs) | Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.
Top
See Also

Reference

EventHelper Class
VirtualRadar.Interface Namespace


EventHelper.RaiseQuickly(TEventArgs) Method (EventHandler(TEventArgs), Object, Func(TEventArgs))

EventHelperRaiseQuicklyTEventArgs Method (EventHandlerTEventArgs, Object, FuncTEventArgs)
Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RaiseQuickly<TEventArgs>(
    EventHandler<TEventArgs> eventHandler,
    Object sender,
    Func<TEventArgs> buildArgsCallback
)
where TEventArgs : EventArgs

Public Shared Sub RaiseQuickly(Of TEventArgs As EventArgs) (
    eventHandler As EventHandler(Of TEventArgs),
    sender As Object,
    buildArgsCallback As Func(Of TEventArgs)
)
public:
generic<typename TEventArgs>
where TEventArgs : EventArgs
static void RaiseQuickly(
    EventHandler<TEventArgs>^ eventHandler,
    Object^ sender,
    Func<TEventArgs>^ buildArgsCallback
)
static member RaiseQuickly :
        eventHandler : EventHandler<'TEventArgs> *
        sender : Object *
        buildArgsCallback : Func<'TEventArgs> -> unit  when 'TEventArgs : EventArgs

Parameters

eventHandler
Type: SystemEventHandler TEventArgs
sender
Type: SystemObject
buildArgsCallback
Type: SystemFunc TEventArgs

Type Parameters

TEventArgs
See Also

Reference

EventHelper Class
RaiseQuickly Overload
VirtualRadar.Interface Namespace


EventHelper.RaiseQuickly(TEventArgs) Method (EventHandler(TEventArgs), Object, TEventArgs)

EventHelperRaiseQuicklyTEventArgs Method (EventHandlerTEventArgs, Object, TEventArgs)
Raises an event for an event handler. This is 6x to 9x faster than the Raise methods but, unlike those methods, if one of the event handlers throws an exception then no further handlers are called.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RaiseQuickly<TEventArgs>(
    EventHandler<TEventArgs> eventHandler,
    Object sender,
    TEventArgs args
)
where TEventArgs : EventArgs

Public Shared Sub RaiseQuickly(Of TEventArgs As EventArgs) (
    eventHandler As EventHandler(Of TEventArgs),
    sender As Object,
    args As TEventArgs
)
public:
generic<typename TEventArgs>
where TEventArgs : EventArgs
static void RaiseQuickly(
    EventHandler<TEventArgs>^ eventHandler,
    Object^ sender,
    TEventArgs args
)
static member RaiseQuickly :
        eventHandler : EventHandler<'TEventArgs> *
        sender : Object *
        args : 'TEventArgs -> unit  when 'TEventArgs : EventArgs

Parameters

eventHandler
Type: SystemEventHandler TEventArgs
sender
Type: SystemObject
args
Type: TEventArgs

Type Parameters

TEventArgs
See Also

Reference

EventHelper Class
RaiseQuickly Overload
VirtualRadar.Interface Namespace


EventHelper.Rethrow Method

EventHelperRethrow Method
Rethrows an exception without losing stack information.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Rethrow(
    Exception ex
)
Public Shared Sub Rethrow (
    ex As Exception
)
public:
static void Rethrow(
    Exception^ ex
)
static member Rethrow :
        ex : Exception -> unit

Parameters

ex
Type: SystemException
Remarks
Copied from http://stackoverflow.com/questions/4555599/how-to-rethrow-the-inner-exception-of-a-targetinvocationexception-without-losing.
See Also

Reference

EventHelper Class
VirtualRadar.Interface Namespace


EventHelperException Class

EventHelperException Class
Thrown when an event handler throws an exception in EventHelper.
Inheritance Hierarchy
SystemObject
SystemException
VirtualRadar.InterfaceEventHelperException

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EventHelperException : Exception
<SerializableAttribute>
Public Class EventHelperException
    Inherits Exception
[SerializableAttribute]
public ref class EventHelperException : public Exception
[<SerializableAttribute>]
type EventHelperException =
    class
        inherit Exception
    end

The EventHelperException type exposes the following members.

Constructors
 | Name | Description
Public method | EventHelperException | Creates a new object.
Public method | EventHelperException(String) | Creates a new object.
Protected method | EventHelperException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | EventHelperException(String, IEnumerableException) | Creates a new object.
Public method | EventHelperException(String, Exception) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HandlerExceptions | Gets a collection of exceptions thrown by handlers.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ExceptionToString.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


EventHelperException Constructor

EventHelperException Constructor
Overload List
 | Name | Description
Public method | EventHelperException | Creates a new object.
Public method | EventHelperException(String) | Creates a new object.
Protected method | EventHelperException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | EventHelperException(String, IEnumerableException) | Creates a new object.
Public method | EventHelperException(String, Exception) | Creates a new object.
Top
See Also

Reference

EventHelperException Class
VirtualRadar.Interface Namespace


EventHelperException Constructor

EventHelperException Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHelperException()
Public Sub New
public:
EventHelperException()
new : unit -> EventHelperException
See Also

Reference

EventHelperException Class
EventHelperException Overload
VirtualRadar.Interface Namespace


EventHelperException Constructor (String)

EventHelperException Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHelperException(
    string message
)
Public Sub New (
    message As String
)
public:
EventHelperException(
    String^ message
)
new :
        message : string -> EventHelperException

Parameters

message
Type: SystemString
See Also

Reference

EventHelperException Class
EventHelperException Overload
VirtualRadar.Interface Namespace


EventHelperException Constructor (SerializationInfo, StreamingContext)

EventHelperException Constructor (SerializationInfo, StreamingContext)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected EventHelperException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
EventHelperException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> EventHelperException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

EventHelperException Class
EventHelperException Overload
VirtualRadar.Interface Namespace


EventHelperException Constructor (String, IEnumerable(Exception))

EventHelperException Constructor (String, IEnumerableException)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHelperException(
    string message,
    IEnumerable<Exception> handlerExceptions
)
Public Sub New (
    message As String,
    handlerExceptions As IEnumerable(Of Exception)
)
public:
EventHelperException(
    String^ message,
    IEnumerable<Exception^>^ handlerExceptions
)
new :
        message : string *
        handlerExceptions : IEnumerable<Exception> -> EventHelperException

Parameters

message
Type: SystemString
handlerExceptions
Type: System.Collections.GenericIEnumerable Exception
See Also

Reference

EventHelperException Class
EventHelperException Overload
VirtualRadar.Interface Namespace


EventHelperException Constructor (String, Exception)

EventHelperException Constructor (String, Exception)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHelperException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
EventHelperException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> EventHelperException

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

EventHelperException Class
EventHelperException Overload
VirtualRadar.Interface Namespace


EventHelperException Properties

EventHelperException Properties

The EventHelperException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HandlerExceptions | Gets a collection of exceptions thrown by handlers.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EventHelperException Class
VirtualRadar.Interface Namespace


EventHelperException.HandlerExceptions Property

EventHelperExceptionHandlerExceptions Property
Gets a collection of exceptions thrown by handlers.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Exception[] HandlerExceptions { get; }
Public ReadOnly Property HandlerExceptions As Exception()
    Get
public:
property array<Exception^>^ HandlerExceptions {
    array<Exception^>^ get ();
}
member HandlerExceptions : Exception[] with get

Property Value

Type: Exception
See Also

Reference

EventHelperException Class
VirtualRadar.Interface Namespace


EventHelperException Methods

EventHelperException Methods

The EventHelperException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ExceptionToString.)
Top
See Also

Reference

EventHelperException Class
VirtualRadar.Interface Namespace


EventHelperException.ToString Method

EventHelperExceptionToString Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

Implements

_ExceptionToString
See Also

Reference

EventHelperException Class
VirtualRadar.Interface Namespace


EventHelperException Events

EventHelperException Events

The EventHelperException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

EventHelperException Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem) Class

ExpiringCollectionTItem Class
Manages a self-expiring collection of items.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceExpiringCollectionTItem
VirtualRadar.InterfaceExpiringDictionaryTKey, TValue
VirtualRadar.InterfaceExpiringListT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ExpiringCollection<TItem> : IDisposable
where TItem : class

Public MustInherit Class ExpiringCollection(Of TItem As Class)
    Implements IDisposable
generic<typename TItem>
where TItem : ref class
public ref class ExpiringCollection abstract : IDisposable
[<AbstractClassAttribute>]
type ExpiringCollection<'TItem when 'TItem : not struct> =
    class
        interface IDisposable
    end

Type Parameters

TItem
The type of item being held by the collection.

The ExpiringCollectionTItem type exposes the following members.

Constructors
 | Name | Description
Public method | ExpiringCollectionTItem | Creates a new object.
Top
Properties
 | Name | Description
Public property | AfterCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called after the check for expired items is made.
Public property | BeforeCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called before the check is made for expired items.
Public property | Count | When overridden by the derivee this returns the current count of items in the collection.
Public property | CountChangedDelegate | Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread.
Public property | ExpireMilliseconds | Gets or sets the minimum number of milliseconds that an item can remain within the list.
Public property | MillisecondsBetweenChecks | Gets or sets the minimum number of milliseconds to wait between checks for expiring items.
Top
Methods
 | Name | Description
Public method | ChangeIntervals | Changes the intervals for the expiration of items and the interval between checks.
Public method | Clear | When overridden by a derivee this clears the collection and unhooks all events.
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Protected method | DoRemoveExpiredItems | When overridden by the derivee this should remove all items that have a timestamp that is less than or equal to the threshold passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookHeartbeat | Hooks the heartbeat event. Must be called from within a lock.
Public method | Lock | Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCountChanged | Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock.
Public method | RemoveExpiredItems | Removes expired items.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookHeartbeat | Unhooks the heartbeat service if hooked. Must be called from within a lock.
Top
Fields
 | Name | Description
Protected field | _Clock | The clock that provides timestamps.
Protected field | _SyncLock | The lock object that controls access to the other fields.
Top
Remarks

When an item is added to this collection it is given a timestamp. The items in the collection are periodically checked, if they have been in the collection for longer than ExpireMilliseconds then they are removed.

This class is disposable. However, Dispose() just clears the collection. Clearing the collection releases all hooks, so it is kind-of permissible to not dispose of these objects - once the last item in the collection expires the class will automatically unhook itself and become eligible for finalising (if there are no strong references to it). However it is better if you can dispose of it when you are finished with it.

See Also

Reference

VirtualRadar.Interface Namespace


ExpiringCollection(TItem) Constructor

ExpiringCollectionTItem Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpiringCollection(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
Public Sub New (
    expireMilliseconds As Integer,
    millisecondsBetweenChecks As Integer
)
public:
ExpiringCollection(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
new :
        expireMilliseconds : int *
        millisecondsBetweenChecks : int -> ExpiringCollection

Parameters

expireMilliseconds
Type: SystemInt32
millisecondsBetweenChecks
Type: SystemInt32
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem) Properties

ExpiringCollectionTItem Properties

The ExpiringCollectionTItem generic type exposes the following members.

Properties
 | Name | Description
Public property | AfterCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called after the check for expired items is made.
Public property | BeforeCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called before the check is made for expired items.
Public property | Count | When overridden by the derivee this returns the current count of items in the collection.
Public property | CountChangedDelegate | Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread.
Public property | ExpireMilliseconds | Gets or sets the minimum number of milliseconds that an item can remain within the list.
Public property | MillisecondsBetweenChecks | Gets or sets the minimum number of milliseconds to wait between checks for expiring items.
Top
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).AfterCheckForExpiredItemsDelegate Property

ExpiringCollectionTItemAfterCheckForExpiredItemsDelegate Property
Gets or sets an optional delegate that is called after the check for expired items is made.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action AfterCheckForExpiredItemsDelegate { get; set; }
Public Property AfterCheckForExpiredItemsDelegate As Action
    Get
    Set
public:
property Action^ AfterCheckForExpiredItemsDelegate {
    Action^ get ();
    void set (Action^ value);
}
member AfterCheckForExpiredItemsDelegate : Action with get, set

Property Value

Type: Action
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).BeforeCheckForExpiredItemsDelegate Property

ExpiringCollectionTItemBeforeCheckForExpiredItemsDelegate Property
Gets or sets an optional delegate that is called before the check is made for expired items.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action BeforeCheckForExpiredItemsDelegate { get; set; }
Public Property BeforeCheckForExpiredItemsDelegate As Action
    Get
    Set
public:
property Action^ BeforeCheckForExpiredItemsDelegate {
    Action^ get ();
    void set (Action^ value);
}
member BeforeCheckForExpiredItemsDelegate : Action with get, set

Property Value

Type: Action
Remarks
The delegate will be called on a background thread. The list is not locked at the time that the delegate is called.
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Count Property

ExpiringCollectionTItemCount Property
When overridden by the derivee this returns the current count of items in the collection.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract long Count { get; }
Public MustOverride ReadOnly Property Count As Long
    Get
public:
virtual property long long Count {
    long long get () abstract;
}
abstract Count : int64 with get

Property Value

Type: Int64
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CountChangedDelegate Property

ExpiringCollectionTItemCountChangedDelegate Property
Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<int> CountChangedDelegate { get; set; }
Public Property CountChangedDelegate As Action(Of Integer)
    Get
    Set
public:
property Action<int>^ CountChangedDelegate {
    Action<int>^ get ();
    void set (Action<int>^ value);
}
member CountChangedDelegate : Action<int> with get, set

Property Value

Type: Action Int32
Remarks

If you set this property to null just before the list calls it then the list may still go through with the call. Your delegate can be called while this property is null.

The intention here is to provide a way for owners of the list to quickly update a counter somewhere when the list count changes. It is not intended for anything more than that. If you modify the list from within the delegate then you will not get recursive calls to the delegate.

See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).ExpireMilliseconds Property

ExpiringCollectionTItemExpireMilliseconds Property
Gets or sets the minimum number of milliseconds that an item can remain within the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ExpireMilliseconds { get; set; }
Public Property ExpireMilliseconds As Integer
    Get
    Set
public:
property int ExpireMilliseconds {
    int get ();
    void set (int value);
}
member ExpireMilliseconds : int with get, set

Property Value

Type: Int32
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).MillisecondsBetweenChecks Property

ExpiringCollectionTItemMillisecondsBetweenChecks Property
Gets or sets the minimum number of milliseconds to wait between checks for expiring items.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MillisecondsBetweenChecks { get; set; }
Public Property MillisecondsBetweenChecks As Integer
    Get
    Set
public:
property int MillisecondsBetweenChecks {
    int get ();
    void set (int value);
}
member MillisecondsBetweenChecks : int with get, set

Property Value

Type: Int32
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem) Methods

ExpiringCollectionTItem Methods

The ExpiringCollectionTItem generic type exposes the following members.

Methods
 | Name | Description
Public method | ChangeIntervals | Changes the intervals for the expiration of items and the interval between checks.
Public method | Clear | When overridden by a derivee this clears the collection and unhooks all events.
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Protected method | DoRemoveExpiredItems | When overridden by the derivee this should remove all items that have a timestamp that is less than or equal to the threshold passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookHeartbeat | Hooks the heartbeat event. Must be called from within a lock.
Public method | Lock | Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCountChanged | Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock.
Public method | RemoveExpiredItems | Removes expired items.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookHeartbeat | Unhooks the heartbeat service if hooked. Must be called from within a lock.
Top
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).ChangeIntervals Method

ExpiringCollectionTItemChangeIntervals Method
Changes the intervals for the expiration of items and the interval between checks.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeIntervals(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
Public Sub ChangeIntervals (
    expireMilliseconds As Integer,
    millisecondsBetweenChecks As Integer
)
public:
void ChangeIntervals(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
member ChangeIntervals :
        expireMilliseconds : int *
        millisecondsBetweenChecks : int -> unit

Parameters

expireMilliseconds
Type: SystemInt32
millisecondsBetweenChecks
Type: SystemInt32
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Clear Method

ExpiringCollectionTItemClear Method
When overridden by a derivee this clears the collection and unhooks all events.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void Clear()
Public MustOverride Sub Clear
public:
virtual void Clear() abstract
abstract Clear : unit -> unit
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Dispose Method

ExpiringCollectionTItemDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Top
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Dispose Method

ExpiringCollectionTItemDispose Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExpiringCollectionTItem Class
Dispose Overload
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Dispose Method (Boolean)

ExpiringCollectionTItemDispose Method (Boolean)
Disposes of or finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

ExpiringCollectionTItem Class
Dispose Overload
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).DoRemoveExpiredItems Method

ExpiringCollectionTItemDoRemoveExpiredItems Method
When overridden by the derivee this should remove all items that have a timestamp that is less than or equal to the threshold passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract void DoRemoveExpiredItems(
    DateTime threshold
)
Protected MustOverride Sub DoRemoveExpiredItems (
    threshold As DateTime
)
protected:
virtual void DoRemoveExpiredItems(
    DateTime threshold
) abstract
abstract DoRemoveExpiredItems :
        threshold : DateTime -> unit

Parameters

threshold
Type: SystemDateTime
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Finalize Method

ExpiringCollectionTItemFinalize Method
Finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).HookHeartbeat Method

ExpiringCollectionTItemHookHeartbeat Method
Hooks the heartbeat event. Must be called from within a lock.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void HookHeartbeat()
Protected Sub HookHeartbeat
protected:
void HookHeartbeat()
member HookHeartbeat : unit -> unit
Remarks
The derivee should call this whenever they add the first item to the collection.
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).Lock Method

ExpiringCollectionTItemLock Method
Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Lock(
    Action action
)
Public Sub Lock (
    action As Action
)
public:
void Lock(
    Action^ action
)
member Lock :
        action : Action -> unit

Parameters

action
Type: SystemAction
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).OnCountChanged Method

ExpiringCollectionTItemOnCountChanged Method
Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCountChanged(
    int newCount
)
Protected Overridable Sub OnCountChanged (
    newCount As Integer
)
protected:
virtual void OnCountChanged(
    int newCount
)
abstract OnCountChanged :
        newCount : int -> unit
override OnCountChanged :
        newCount : int -> unit

Parameters

newCount
Type: SystemInt32
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).RemoveExpiredItems Method

ExpiringCollectionTItemRemoveExpiredItems Method
Removes expired items.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveExpiredItems()
Public Sub RemoveExpiredItems
public:
void RemoveExpiredItems()
member RemoveExpiredItems : unit -> unit
Remarks
This is automatically called on a timer. If you call this manually then it will reset the timer, the next check for expired items will not take place until at least MillisecondsBetweenChecks milliseconds have passed.
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).UnhookHeartbeat Method

ExpiringCollectionTItemUnhookHeartbeat Method
Unhooks the heartbeat service if hooked. Must be called from within a lock.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool UnhookHeartbeat()
Protected Function UnhookHeartbeat As Boolean
protected:
bool UnhookHeartbeat()
member UnhookHeartbeat : unit -> bool

Return Value

Type: Boolean
True if the heartbeat was hooked when the function was called, false otherwise.
Remarks
The derivee should call this whenever they remove the last item from the collection.
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem) Fields

ExpiringCollectionTItem Fields

The ExpiringCollectionTItem generic type exposes the following members.

Fields
 | Name | Description
Protected field | _Clock | The clock that provides timestamps.
Protected field | _SyncLock | The lock object that controls access to the other fields.
Top
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem)._Clock Field

ExpiringCollectionTItem_Clock Field
The clock that provides timestamps.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected IClock _Clock
Protected _Clock As IClock
protected:
IClock^ _Clock
val mutable _Clock: IClock

Field Value

Type: IClock
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem)._SyncLock Field

ExpiringCollectionTItem_SyncLock Field
The lock object that controls access to the other fields.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Object _SyncLock
Protected _SyncLock As Object
protected:
Object^ _SyncLock
val mutable _SyncLock: Object

Field Value

Type: Object
See Also

Reference

ExpiringCollectionTItem Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T) Class

ExpiringCollectionTItemCollectionItemT Class
An instance of a collection item and its associated timestamp.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceExpiringCollectionTItemCollectionItemT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected class CollectionItem<T>
where T : class

Protected Class CollectionItem(Of T As Class)
generic<typename T>
where T : ref class
protected ref class CollectionItem
type CollectionItem<'T when 'T : not struct> =  class end

Type Parameters

T

The ExpiringCollectionTItemCollectionItemT generic type exposes the following members.

Constructors
 | Name | Description
Public method | ExpiringCollectionTItemCollectionItemT | Creates a new object.
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the item in the collection.
Public property | Timestamp | Gets or sets the timestamp associated with the item.
Top
Methods
 | Name | Description
Public method | Equals | Calls Equals on the item. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calls GetHashCode on the item. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Calls ToString on the item. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T) Constructor

ExpiringCollectionTItemCollectionItemT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CollectionItem(
    T item,
    DateTime utcNow
)
Public Sub New (
    item As T,
    utcNow As DateTime
)
public:
CollectionItem(
    T item,
    DateTime utcNow
)
new :
        item : 'T *
        utcNow : DateTime -> CollectionItem

Parameters

item
Type: T
utcNow
Type: SystemDateTime
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


CollectionItem(T) Properties

CollectionItemT Properties

The ExpiringCollectionTItemCollectionItemT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the item in the collection.
Public property | Timestamp | Gets or sets the timestamp associated with the item.
Top
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T).Item Property

ExpiringCollectionTItemCollectionItemTItem Property
Gets or sets the item in the collection.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Item { get; set; }
Public Property Item As T
    Get
    Set
public:
property T Item {
    T get ();
    void set (T value);
}
member Item : 'T with get, set

Property Value

Type: T
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T).Timestamp Property

ExpiringCollectionTItemCollectionItemTTimestamp Property
Gets or sets the timestamp associated with the item.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
member Timestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


CollectionItem(T) Methods

CollectionItemT Methods

The ExpiringCollectionTItemCollectionItemT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Calls Equals on the item. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calls GetHashCode on the item. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Calls ToString on the item. (Overrides ObjectToString.)
Top
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T).Equals Method

ExpiringCollectionTItemCollectionItemTEquals Method
Calls Equals on the item.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T).GetHashCode Method

ExpiringCollectionTItemCollectionItemTGetHashCode Method
Calls GetHashCode on the item.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


ExpiringCollection(TItem).CollectionItem(T).ToString Method

ExpiringCollectionTItemCollectionItemTToString Method
Calls ToString on the item.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ExpiringCollectionTItemCollectionItemT Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue) Class

ExpiringDictionaryTKey, TValue Class
Manages a self-expiring dictionary of items.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceExpiringCollection TValue
VirtualRadar.InterfaceExpiringDictionaryTKey, TValue

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpiringDictionary<TKey, TValue> : ExpiringCollection<TValue>
where TValue : class

Public Class ExpiringDictionary(Of TKey, TValue As Class)
    Inherits ExpiringCollection(Of TValue)
generic<typename TKey, typename TValue>
where TValue : ref class
public ref class ExpiringDictionary : public ExpiringCollection<TValue>
type ExpiringDictionary<'TKey, 'TValue when 'TValue : not struct> =
    class
        inherit ExpiringCollection<'TValue>
    end

Type Parameters

TKey
The type of key being held by the collection.
TValue
The type of value being held by the collection.

The ExpiringDictionaryTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | ExpiringDictionaryTKey, TValue | Creates a new object.
Top
Properties
 | Name | Description
Public property | AfterCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called after the check for expired items is made. (Inherited from ExpiringCollectionTItem.)
Public property | BeforeCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called before the check is made for expired items. (Inherited from ExpiringCollectionTItem.)
Public property | Count | Gets the current count of items in the dictionary. (Overrides ExpiringCollectionTItemCount.)
Public property | CountChangedDelegate | Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread. (Inherited from ExpiringCollectionTItem.)
Public property | ExpireMilliseconds | Gets or sets the minimum number of milliseconds that an item can remain within the list. (Inherited from ExpiringCollectionTItem.)
Public property | GetExpiredItemsDelegate | Gets or sets an optional delegate that returns the collection of the keys of expired items. If this delegate is present then it is always used in preference to the timestamps attached to the item and the Refresh methods will have no effect.
Public property | MillisecondsBetweenChecks | Gets or sets the minimum number of milliseconds to wait between checks for expiring items. (Inherited from ExpiringCollectionTItem.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the dictionary.
Public method | ChangeIntervals | Changes the intervals for the expiration of items and the interval between checks. (Inherited from ExpiringCollectionTItem.)
Public method | Clear | Empties the dictionary. (Overrides ExpiringCollectionTItemClear.)
Public method | Dispose | See interface docs. (Inherited from ExpiringCollectionTItem.)
Protected method | Dispose(Boolean) | Disposes of or finalises the object. (Inherited from ExpiringCollectionTItem.)
Protected method | DoRemoveExpiredItems | See base docs. (Overrides ExpiringCollectionTItemDoRemoveExpiredItems(DateTime).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ExpiringCollectionTItem.)
Public method | Find | Finds the first value that matches the predicate passed across or null if no such value could be found.
Public method | FindAll | Returns a list of all values that match the predicate passed across.
Public method | FindAllAndRefresh | Returns a list of all values that match the predicate passed across. Refreshes the timestamps for all items returned.
Public method | FindAndRefresh | Finds the first value that matches the predicate passed across or null if no such value could be found. Refreshes the timestamp on the value if it could be found.
Public method | GetAndRefreshOrCreate | Returns the item for the key passed across or calls the create method to create a new item and add it to the dictionary. If the item already exists then its timestamp is refreshed.
Public method | GetForKey | Returns the item for the key passed across. Returns null if the key is no longer in the dictionary.
Public method | GetForKeyAndRefresh | Returns the item for the key passed across. Returns null if the key is no longer in the dictionary. Refreshes the item's timestamp.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOrCreate | Returns the item for the key passed across or calls the create method to create a new item and add it to the dictionary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookHeartbeat | Hooks the heartbeat event. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | Lock | Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block. (Inherited from ExpiringCollectionTItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCountChanged | Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | RefreshAll | Refreshes all of the timestamps in the dictionary.
Public method | RemoveExpiredItems | Removes expired items. (Inherited from ExpiringCollectionTItem.)
Public method | RemoveIfExists | Removes the item for the key passed across. Does nothing if the key does not exist.
Public method | Snapshot | Returns a snapshot of all of the key-value pairs in the dictionary.
Public method | SnapshotAndRefresh | Returns a snapshot of all of the key-value pairs in the dictionary and refreshes the timestamps on all of them.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookHeartbeat | Unhooks the heartbeat service if hooked. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | Upsert | Adds or updates an item in the dictionary. If the key is already in use then the value is overwritten but the timestamp is not refreshed.
Public method | UpsertAndRefresh | Adds or updates an item in the dictionary. If the key is already in use then the value is overwritten and the timestamp is refreshed.
Public method | UpsertRange | Adds or updates a range of items. If an item exists then it is updated but its timestamp is not refreshed.
Public method | UpsertRangeAndRefresh | Adds or updates a range of items. If an item exists then it is updated and its timestamp is refreshed.
Top
Fields
 | Name | Description
Protected field | _Clock | The clock that provides timestamps. (Inherited from ExpiringCollectionTItem.)
Protected field | _SyncLock | The lock object that controls access to the other fields. (Inherited from ExpiringCollectionTItem.)
Top
Remarks
When an item is added to this dictionary it is given a timestamp. The items in the dictionary are periodically checked, if they have been in the map for longer than ExpireMilliseconds then they are removed. This class is thread-safe.
See Also

Reference

VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue) Constructor

ExpiringDictionaryTKey, TValue Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpiringDictionary(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
Public Sub New (
    expireMilliseconds As Integer,
    millisecondsBetweenChecks As Integer
)
public:
ExpiringDictionary(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
new :
        expireMilliseconds : int *
        millisecondsBetweenChecks : int -> ExpiringDictionary

Parameters

expireMilliseconds
Type: SystemInt32
millisecondsBetweenChecks
Type: SystemInt32
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue) Properties

ExpiringDictionaryTKey, TValue Properties

The ExpiringDictionaryTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | AfterCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called after the check for expired items is made. (Inherited from ExpiringCollectionTItem.)
Public property | BeforeCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called before the check is made for expired items. (Inherited from ExpiringCollectionTItem.)
Public property | Count | Gets the current count of items in the dictionary. (Overrides ExpiringCollectionTItemCount.)
Public property | CountChangedDelegate | Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread. (Inherited from ExpiringCollectionTItem.)
Public property | ExpireMilliseconds | Gets or sets the minimum number of milliseconds that an item can remain within the list. (Inherited from ExpiringCollectionTItem.)
Public property | GetExpiredItemsDelegate | Gets or sets an optional delegate that returns the collection of the keys of expired items. If this delegate is present then it is always used in preference to the timestamps attached to the item and the Refresh methods will have no effect.
Public property | MillisecondsBetweenChecks | Gets or sets the minimum number of milliseconds to wait between checks for expiring items. (Inherited from ExpiringCollectionTItem.)
Top
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).Count Property

ExpiringDictionaryTKey, TValueCount Property
Gets the current count of items in the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override long Count { get; }
Public Overrides ReadOnly Property Count As Long
    Get
public:
virtual property long long Count {
    long long get () override;
}
abstract Count : int64 with get
override Count : int64 with get

Property Value

Type: Int64
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).GetExpiredItemsDelegate Property

ExpiringDictionaryTKey, TValueGetExpiredItemsDelegate Property
Gets or sets an optional delegate that returns the collection of the keys of expired items. If this delegate is present then it is always used in preference to the timestamps attached to the item and the Refresh methods will have no effect.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<ExpiringDictionary<TKey, TValue>, IEnumerable<TKey>> GetExpiredItemsDelegate { get; set; }
Public Property GetExpiredItemsDelegate As Func(Of ExpiringDictionary(Of TKey, TValue), IEnumerable(Of TKey))
    Get
    Set
public:
property Func<ExpiringDictionary<TKey, TValue>^, IEnumerable<TKey>^>^ GetExpiredItemsDelegate {
    Func<ExpiringDictionary<TKey, TValue>^, IEnumerable<TKey>^>^ get ();
    void set (Func<ExpiringDictionary<TKey, TValue>^, IEnumerable<TKey>^>^ value);
}
member GetExpiredItemsDelegate : Func<ExpiringDictionary<'TKey, 'TValue>, IEnumerable<'TKey>> with get, set

Property Value

Type: Func ExpiringDictionary TKey, TValue , IEnumerable TKey
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue) Methods

ExpiringDictionaryTKey, TValue Methods

The ExpiringDictionaryTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the dictionary.
Public method | ChangeIntervals | Changes the intervals for the expiration of items and the interval between checks. (Inherited from ExpiringCollectionTItem.)
Public method | Clear | Empties the dictionary. (Overrides ExpiringCollectionTItemClear.)
Public method | Dispose | See interface docs. (Inherited from ExpiringCollectionTItem.)
Protected method | Dispose(Boolean) | Disposes of or finalises the object. (Inherited from ExpiringCollectionTItem.)
Protected method | DoRemoveExpiredItems | See base docs. (Overrides ExpiringCollectionTItemDoRemoveExpiredItems(DateTime).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ExpiringCollectionTItem.)
Public method | Find | Finds the first value that matches the predicate passed across or null if no such value could be found.
Public method | FindAll | Returns a list of all values that match the predicate passed across.
Public method | FindAllAndRefresh | Returns a list of all values that match the predicate passed across. Refreshes the timestamps for all items returned.
Public method | FindAndRefresh | Finds the first value that matches the predicate passed across or null if no such value could be found. Refreshes the timestamp on the value if it could be found.
Public method | GetAndRefreshOrCreate | Returns the item for the key passed across or calls the create method to create a new item and add it to the dictionary. If the item already exists then its timestamp is refreshed.
Public method | GetForKey | Returns the item for the key passed across. Returns null if the key is no longer in the dictionary.
Public method | GetForKeyAndRefresh | Returns the item for the key passed across. Returns null if the key is no longer in the dictionary. Refreshes the item's timestamp.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOrCreate | Returns the item for the key passed across or calls the create method to create a new item and add it to the dictionary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookHeartbeat | Hooks the heartbeat event. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | Lock | Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block. (Inherited from ExpiringCollectionTItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCountChanged | Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | RefreshAll | Refreshes all of the timestamps in the dictionary.
Public method | RemoveExpiredItems | Removes expired items. (Inherited from ExpiringCollectionTItem.)
Public method | RemoveIfExists | Removes the item for the key passed across. Does nothing if the key does not exist.
Public method | Snapshot | Returns a snapshot of all of the key-value pairs in the dictionary.
Public method | SnapshotAndRefresh | Returns a snapshot of all of the key-value pairs in the dictionary and refreshes the timestamps on all of them.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookHeartbeat | Unhooks the heartbeat service if hooked. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | Upsert | Adds or updates an item in the dictionary. If the key is already in use then the value is overwritten but the timestamp is not refreshed.
Public method | UpsertAndRefresh | Adds or updates an item in the dictionary. If the key is already in use then the value is overwritten and the timestamp is refreshed.
Public method | UpsertRange | Adds or updates a range of items. If an item exists then it is updated but its timestamp is not refreshed.
Public method | UpsertRangeAndRefresh | Adds or updates a range of items. If an item exists then it is updated and its timestamp is refreshed.
Top
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).Add Method

ExpiringDictionaryTKey, TValueAdd Method
Adds an item to the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
public:
void Add(
    TKey key,
    TValue value
)
member Add :
        key : 'TKey *
        value : 'TValue -> unit

Parameters

key
Type: TKey
value
Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).Clear Method

ExpiringDictionaryTKey, TValueClear Method
Empties the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).DoRemoveExpiredItems Method

ExpiringDictionaryTKey, TValueDoRemoveExpiredItems Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoRemoveExpiredItems(
    DateTime threshold
)
Protected Overrides Sub DoRemoveExpiredItems (
    threshold As DateTime
)
protected:
virtual void DoRemoveExpiredItems(
    DateTime threshold
) override
abstract DoRemoveExpiredItems :
        threshold : DateTime -> unit
override DoRemoveExpiredItems :
        threshold : DateTime -> unit

Parameters

threshold
Type: SystemDateTime
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).Find Method

ExpiringDictionaryTKey, TValueFind Method
Finds the first value that matches the predicate passed across or null if no such value could be found.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue Find(
    Predicate<TValue> match
)
Public Function Find (
    match As Predicate(Of TValue)
) As TValue
public:
TValue Find(
    Predicate<TValue>^ match
)
member Find :
        match : Predicate<'TValue> -> 'TValue

Parameters

match
Type: SystemPredicate TValue

Return Value

Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).FindAll Method

ExpiringDictionaryTKey, TValueFindAll Method
Returns a list of all values that match the predicate passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<TValue> FindAll(
    Predicate<TValue> match
)
Public Function FindAll (
    match As Predicate(Of TValue)
) As List(Of TValue)
public:
List<TValue>^ FindAll(
    Predicate<TValue>^ match
)
member FindAll :
        match : Predicate<'TValue> -> List<'TValue>

Parameters

match
Type: SystemPredicate TValue

Return Value

Type: List TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).FindAllAndRefresh Method

ExpiringDictionaryTKey, TValueFindAllAndRefresh Method
Returns a list of all values that match the predicate passed across. Refreshes the timestamps for all items returned.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<TValue> FindAllAndRefresh(
    Predicate<TValue> match
)
Public Function FindAllAndRefresh (
    match As Predicate(Of TValue)
) As List(Of TValue)
public:
List<TValue>^ FindAllAndRefresh(
    Predicate<TValue>^ match
)
member FindAllAndRefresh :
        match : Predicate<'TValue> -> List<'TValue>

Parameters

match
Type: SystemPredicate TValue

Return Value

Type: List TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).FindAndRefresh Method

ExpiringDictionaryTKey, TValueFindAndRefresh Method
Finds the first value that matches the predicate passed across or null if no such value could be found. Refreshes the timestamp on the value if it could be found.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue FindAndRefresh(
    Predicate<TValue> match
)
Public Function FindAndRefresh (
    match As Predicate(Of TValue)
) As TValue
public:
TValue FindAndRefresh(
    Predicate<TValue>^ match
)
member FindAndRefresh :
        match : Predicate<'TValue> -> 'TValue

Parameters

match
Type: SystemPredicate TValue

Return Value

Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).GetAndRefreshOrCreate Method

ExpiringDictionaryTKey, TValueGetAndRefreshOrCreate Method
Returns the item for the key passed across or calls the create method to create a new item and add it to the dictionary. If the item already exists then its timestamp is refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue GetAndRefreshOrCreate(
    TKey key,
    Func<TKey, TValue> create
)
Public Function GetAndRefreshOrCreate (
    key As TKey,
    create As Func(Of TKey, TValue)
) As TValue
public:
TValue GetAndRefreshOrCreate(
    TKey key,
    Func<TKey, TValue>^ create
)
member GetAndRefreshOrCreate :
        key : 'TKey *
        create : Func<'TKey, 'TValue> -> 'TValue

Parameters

key
Type: TKey
create
Type: SystemFunc TKey, TValue

Return Value

Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).GetForKey Method

ExpiringDictionaryTKey, TValueGetForKey Method
Returns the item for the key passed across. Returns null if the key is no longer in the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue GetForKey(
    TKey key
)
Public Function GetForKey (
    key As TKey
) As TValue
public:
TValue GetForKey(
    TKey key
)
member GetForKey :
        key : 'TKey -> 'TValue

Parameters

key
Type: TKey

Return Value

Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).GetForKeyAndRefresh Method

ExpiringDictionaryTKey, TValueGetForKeyAndRefresh Method
Returns the item for the key passed across. Returns null if the key is no longer in the dictionary. Refreshes the item's timestamp.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue GetForKeyAndRefresh(
    TKey key
)
Public Function GetForKeyAndRefresh (
    key As TKey
) As TValue
public:
TValue GetForKeyAndRefresh(
    TKey key
)
member GetForKeyAndRefresh :
        key : 'TKey -> 'TValue

Parameters

key
Type: TKey

Return Value

Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).GetOrCreate Method

ExpiringDictionaryTKey, TValueGetOrCreate Method
Returns the item for the key passed across or calls the create method to create a new item and add it to the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue GetOrCreate(
    TKey key,
    Func<TKey, TValue> create
)
Public Function GetOrCreate (
    key As TKey,
    create As Func(Of TKey, TValue)
) As TValue
public:
TValue GetOrCreate(
    TKey key,
    Func<TKey, TValue>^ create
)
member GetOrCreate :
        key : 'TKey *
        create : Func<'TKey, 'TValue> -> 'TValue

Parameters

key
Type: TKey
create
Type: SystemFunc TKey, TValue

Return Value

Type: TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).RefreshAll Method

ExpiringDictionaryTKey, TValueRefreshAll Method
Refreshes all of the timestamps in the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RefreshAll()
Public Sub RefreshAll
public:
void RefreshAll()
member RefreshAll : unit -> unit
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).RemoveIfExists Method

ExpiringDictionaryTKey, TValueRemoveIfExists Method
Removes the item for the key passed across. Does nothing if the key does not exist.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveIfExists(
    TKey key
)
Public Sub RemoveIfExists (
    key As TKey
)
public:
void RemoveIfExists(
    TKey key
)
member RemoveIfExists :
        key : 'TKey -> unit

Parameters

key
Type: TKey
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).Snapshot Method

ExpiringDictionaryTKey, TValueSnapshot Method
Returns a snapshot of all of the key-value pairs in the dictionary.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyValuePair<TKey, TValue>[] Snapshot()
Public Function Snapshot As KeyValuePair(Of TKey, TValue)()
public:
array<KeyValuePair<TKey, TValue>>^ Snapshot()
member Snapshot : unit -> KeyValuePair<'TKey, 'TValue>[]

Return Value

Type: KeyValuePair TKey, TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).SnapshotAndRefresh Method

ExpiringDictionaryTKey, TValueSnapshotAndRefresh Method
Returns a snapshot of all of the key-value pairs in the dictionary and refreshes the timestamps on all of them.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyValuePair<TKey, TValue>[] SnapshotAndRefresh()
Public Function SnapshotAndRefresh As KeyValuePair(Of TKey, TValue)()
public:
array<KeyValuePair<TKey, TValue>>^ SnapshotAndRefresh()
member SnapshotAndRefresh : unit -> KeyValuePair<'TKey, 'TValue>[]

Return Value

Type: KeyValuePair TKey, TValue
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).Upsert Method

ExpiringDictionaryTKey, TValueUpsert Method
Adds or updates an item in the dictionary. If the key is already in use then the value is overwritten but the timestamp is not refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Upsert(
    TKey key,
    TValue value
)
Public Function Upsert (
    key As TKey,
    value As TValue
) As Boolean
public:
bool Upsert(
    TKey key,
    TValue value
)
member Upsert :
        key : 'TKey *
        value : 'TValue -> bool

Parameters

key
Type: TKey
value
Type: TValue

Return Value

Type: Boolean
True if the item existed and was updated, false if it had to be added.
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).UpsertAndRefresh Method

ExpiringDictionaryTKey, TValueUpsertAndRefresh Method
Adds or updates an item in the dictionary. If the key is already in use then the value is overwritten and the timestamp is refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UpsertAndRefresh(
    TKey key,
    TValue value
)
Public Function UpsertAndRefresh (
    key As TKey,
    value As TValue
) As Boolean
public:
bool UpsertAndRefresh(
    TKey key,
    TValue value
)
member UpsertAndRefresh :
        key : 'TKey *
        value : 'TValue -> bool

Parameters

key
Type: TKey
value
Type: TValue

Return Value

Type: Boolean
True if the item existed and was updated / refreshed, false if it had to be added.
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).UpsertRange Method

ExpiringDictionaryTKey, TValueUpsertRange Method
Adds or updates a range of items. If an item exists then it is updated but its timestamp is not refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpsertRange(
    IEnumerable<TValue> values,
    Func<TValue, TKey> extractKey
)
Public Sub UpsertRange (
    values As IEnumerable(Of TValue),
    extractKey As Func(Of TValue, TKey)
)
public:
void UpsertRange(
    IEnumerable<TValue>^ values,
    Func<TValue, TKey>^ extractKey
)
member UpsertRange :
        values : IEnumerable<'TValue> *
        extractKey : Func<'TValue, 'TKey> -> unit

Parameters

values
Type: System.Collections.GenericIEnumerable TValue
extractKey
Type: SystemFunc TValue, TKey
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue).UpsertRangeAndRefresh Method

ExpiringDictionaryTKey, TValueUpsertRangeAndRefresh Method
Adds or updates a range of items. If an item exists then it is updated and its timestamp is refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpsertRangeAndRefresh(
    IEnumerable<TValue> values,
    Func<TValue, TKey> extractKey
)
Public Sub UpsertRangeAndRefresh (
    values As IEnumerable(Of TValue),
    extractKey As Func(Of TValue, TKey)
)
public:
void UpsertRangeAndRefresh(
    IEnumerable<TValue>^ values,
    Func<TValue, TKey>^ extractKey
)
member UpsertRangeAndRefresh :
        values : IEnumerable<'TValue> *
        extractKey : Func<'TValue, 'TKey> -> unit

Parameters

values
Type: System.Collections.GenericIEnumerable TValue
extractKey
Type: SystemFunc TValue, TKey
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringDictionary(TKey, TValue) Fields

ExpiringDictionaryTKey, TValue Fields

The ExpiringDictionaryTKey, TValue generic type exposes the following members.

Fields
 | Name | Description
Protected field | _Clock | The clock that provides timestamps. (Inherited from ExpiringCollectionTItem.)
Protected field | _SyncLock | The lock object that controls access to the other fields. (Inherited from ExpiringCollectionTItem.)
Top
See Also

Reference

ExpiringDictionaryTKey, TValue Class
VirtualRadar.Interface Namespace


ExpiringList(T) Class

ExpiringListT Class
Manages a self-expiring list of items.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceExpiringCollection T
VirtualRadar.InterfaceExpiringListT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpiringList<T> : ExpiringCollection<T>
where T : class

Public Class ExpiringList(Of T As Class)
    Inherits ExpiringCollection(Of T)
generic<typename T>
where T : ref class
public ref class ExpiringList : public ExpiringCollection<T>
type ExpiringList<'T when 'T : not struct> =
    class
        inherit ExpiringCollection<'T>
    end

Type Parameters

T

The ExpiringListT type exposes the following members.

Constructors
 | Name | Description
Public method | ExpiringListT | Creates a new object.
Top
Properties
 | Name | Description
Public property | AfterCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called after the check for expired items is made. (Inherited from ExpiringCollectionTItem.)
Public property | BeforeCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called before the check is made for expired items. (Inherited from ExpiringCollectionTItem.)
Public property | Count | Gets the current count of items in the list. (Overrides ExpiringCollectionTItemCount.)
Public property | CountChangedDelegate | Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread. (Inherited from ExpiringCollectionTItem.)
Public property | ExpireMilliseconds | Gets or sets the minimum number of milliseconds that an item can remain within the list. (Inherited from ExpiringCollectionTItem.)
Public property | MillisecondsBetweenChecks | Gets or sets the minimum number of milliseconds to wait between checks for expiring items. (Inherited from ExpiringCollectionTItem.)
Top
Methods
 | Name | Description
Public method | Add | Adds the item to the list.
Public method | AddOrRefresh | Adds the item if it is not already in the list. If it is in the list then its timestamp is refreshed to the current time.
Public method | AddRange | Adds a range of items to the list.
Public method | AddRangeOrRefresh | Adds a range of items to the list. Items that already exist in the list have their timestamps refreshed.
Public method | ChangeIntervals | Changes the intervals for the expiration of items and the interval between checks. (Inherited from ExpiringCollectionTItem.)
Public method | Clear | Empties the list. (Overrides ExpiringCollectionTItemClear.)
Public method | Dispose | See interface docs. (Inherited from ExpiringCollectionTItem.)
Protected method | Dispose(Boolean) | Disposes of or finalises the object. (Inherited from ExpiringCollectionTItem.)
Protected method | DoRemoveExpiredItems | See base docs. (Overrides ExpiringCollectionTItemDoRemoveExpiredItems(DateTime).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ExpiringCollectionTItem.)
Public method | Find | Returns the item that matches the predicate or null if no such item exists.
Public method | FindAll | Returns all of the items that match the predicate or an empty list if no such items exist.
Public method | FindAllAndRefresh | Returns all of the items that match the predicate or an empty list if no such items exist. Refreshes the timestamps for all of the items returned.
Public method | FindAndRefresh | Returns the item that matches the predicate or null if no such item exists. Refreshes the timestamp for the item.
Protected method | FindCollectionItem | Finds the collection item for the item passed across.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookHeartbeat | Hooks the heartbeat event. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | Lock | Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block. (Inherited from ExpiringCollectionTItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCountChanged | Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | RefreshAll | Refreshes the timestamps on every item in the list.
Public method | Remove | Removes the item from the list.
Public method | RemoveExpiredItems | Removes expired items. (Inherited from ExpiringCollectionTItem.)
Public method | RemoveRange | Removes a range of items from the list.
Public method | Snapshot | Returns a clone of the contents of the list.
Public method | SnapshotAndRefresh | Returns a clone of every item in the list. Refreshes the timestamps on every item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookHeartbeat | Unhooks the heartbeat service if hooked. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Top
Fields
 | Name | Description
Protected field | _Clock | The clock that provides timestamps. (Inherited from ExpiringCollectionTItem.)
Protected field | _SyncLock | The lock object that controls access to the other fields. (Inherited from ExpiringCollectionTItem.)
Top
Remarks
When an item is added to this list it is given a timestamp. The items in the list are periodically checked, if they have been in the list for longer than ExpireMilliseconds then they are removed. This class is thread-safe.
See Also

Reference

VirtualRadar.Interface Namespace


ExpiringList(T) Constructor

ExpiringListT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpiringList(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
Public Sub New (
    expireMilliseconds As Integer,
    millisecondsBetweenChecks As Integer
)
public:
ExpiringList(
    int expireMilliseconds,
    int millisecondsBetweenChecks
)
new :
        expireMilliseconds : int *
        millisecondsBetweenChecks : int -> ExpiringList

Parameters

expireMilliseconds
Type: SystemInt32
millisecondsBetweenChecks
Type: SystemInt32
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T) Properties

ExpiringListT Properties

The ExpiringListT generic type exposes the following members.

Properties
 | Name | Description
Public property | AfterCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called after the check for expired items is made. (Inherited from ExpiringCollectionTItem.)
Public property | BeforeCheckForExpiredItemsDelegate | Gets or sets an optional delegate that is called before the check is made for expired items. (Inherited from ExpiringCollectionTItem.)
Public property | Count | Gets the current count of items in the list. (Overrides ExpiringCollectionTItemCount.)
Public property | CountChangedDelegate | Gets or sets an optional delegate that is called when the count changes. The new count is passed to the delegate. The list is locked to the calling thread while the delegate is running. The delegate will occasionally be called on a background thread. (Inherited from ExpiringCollectionTItem.)
Public property | ExpireMilliseconds | Gets or sets the minimum number of milliseconds that an item can remain within the list. (Inherited from ExpiringCollectionTItem.)
Public property | MillisecondsBetweenChecks | Gets or sets the minimum number of milliseconds to wait between checks for expiring items. (Inherited from ExpiringCollectionTItem.)
Top
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).Count Property

ExpiringListTCount Property
Gets the current count of items in the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override long Count { get; }
Public Overrides ReadOnly Property Count As Long
    Get
public:
virtual property long long Count {
    long long get () override;
}
abstract Count : int64 with get
override Count : int64 with get

Property Value

Type: Int64
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T) Methods

ExpiringListT Methods

The ExpiringListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the item to the list.
Public method | AddOrRefresh | Adds the item if it is not already in the list. If it is in the list then its timestamp is refreshed to the current time.
Public method | AddRange | Adds a range of items to the list.
Public method | AddRangeOrRefresh | Adds a range of items to the list. Items that already exist in the list have their timestamps refreshed.
Public method | ChangeIntervals | Changes the intervals for the expiration of items and the interval between checks. (Inherited from ExpiringCollectionTItem.)
Public method | Clear | Empties the list. (Overrides ExpiringCollectionTItemClear.)
Public method | Dispose | See interface docs. (Inherited from ExpiringCollectionTItem.)
Protected method | Dispose(Boolean) | Disposes of or finalises the object. (Inherited from ExpiringCollectionTItem.)
Protected method | DoRemoveExpiredItems | See base docs. (Overrides ExpiringCollectionTItemDoRemoveExpiredItems(DateTime).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ExpiringCollectionTItem.)
Public method | Find | Returns the item that matches the predicate or null if no such item exists.
Public method | FindAll | Returns all of the items that match the predicate or an empty list if no such items exist.
Public method | FindAllAndRefresh | Returns all of the items that match the predicate or an empty list if no such items exist. Refreshes the timestamps for all of the items returned.
Public method | FindAndRefresh | Returns the item that matches the predicate or null if no such item exists. Refreshes the timestamp for the item.
Protected method | FindCollectionItem | Finds the collection item for the item passed across.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookHeartbeat | Hooks the heartbeat event. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | Lock | Calls the action passed across with the list locked. Do not perform an action that will attempt to lock the list from another thread, it will block. (Inherited from ExpiringCollectionTItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCountChanged | Called by the derivee to inform the owner of the collection that the count has changed. Always call this from within a lock. (Inherited from ExpiringCollectionTItem.)
Public method | RefreshAll | Refreshes the timestamps on every item in the list.
Public method | Remove | Removes the item from the list.
Public method | RemoveExpiredItems | Removes expired items. (Inherited from ExpiringCollectionTItem.)
Public method | RemoveRange | Removes a range of items from the list.
Public method | Snapshot | Returns a clone of the contents of the list.
Public method | SnapshotAndRefresh | Returns a clone of every item in the list. Refreshes the timestamps on every item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookHeartbeat | Unhooks the heartbeat service if hooked. Must be called from within a lock. (Inherited from ExpiringCollectionTItem.)
Top
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).Add Method

ExpiringListTAdd Method
Adds the item to the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)
public:
void Add(
    T item
)
member Add :
        item : 'T -> unit

Parameters

item
Type: T

Return Value

Type:
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).AddOrRefresh Method

ExpiringListTAddOrRefresh Method
Adds the item if it is not already in the list. If it is in the list then its timestamp is refreshed to the current time.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddOrRefresh(
    T item
)
Public Function AddOrRefresh (
    item As T
) As Boolean
public:
bool AddOrRefresh(
    T item
)
member AddOrRefresh :
        item : 'T -> bool

Parameters

item
Type: T

Return Value

Type: Boolean
True if the item was already in the list and was just refreshed, false if it had to be added.
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).AddRange Method

ExpiringListTAddRange Method
Adds a range of items to the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddRange(
    IEnumerable<T> items
)
Public Sub AddRange (
    items As IEnumerable(Of T)
)
public:
void AddRange(
    IEnumerable<T>^ items
)
member AddRange :
        items : IEnumerable<'T> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerable T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).AddRangeOrRefresh Method

ExpiringListTAddRangeOrRefresh Method
Adds a range of items to the list. Items that already exist in the list have their timestamps refreshed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddRangeOrRefresh(
    IEnumerable<T> items
)
Public Sub AddRangeOrRefresh (
    items As IEnumerable(Of T)
)
public:
void AddRangeOrRefresh(
    IEnumerable<T>^ items
)
member AddRangeOrRefresh :
        items : IEnumerable<'T> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerable T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).Clear Method

ExpiringListTClear Method
Empties the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).DoRemoveExpiredItems Method

ExpiringListTDoRemoveExpiredItems Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoRemoveExpiredItems(
    DateTime threshold
)
Protected Overrides Sub DoRemoveExpiredItems (
    threshold As DateTime
)
protected:
virtual void DoRemoveExpiredItems(
    DateTime threshold
) override
abstract DoRemoveExpiredItems :
        threshold : DateTime -> unit
override DoRemoveExpiredItems :
        threshold : DateTime -> unit

Parameters

threshold
Type: SystemDateTime
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).Find Method

ExpiringListTFind Method
Returns the item that matches the predicate or null if no such item exists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Find(
    Predicate<T> match
)
Public Function Find (
    match As Predicate(Of T)
) As T
public:
T Find(
    Predicate<T>^ match
)
member Find :
        match : Predicate<'T> -> 'T

Parameters

match
Type: SystemPredicate T

Return Value

Type: T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).FindAll Method

ExpiringListTFindAll Method
Returns all of the items that match the predicate or an empty list if no such items exist.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<T> FindAll(
    Predicate<T> match
)
Public Function FindAll (
    match As Predicate(Of T)
) As List(Of T)
public:
List<T>^ FindAll(
    Predicate<T>^ match
)
member FindAll :
        match : Predicate<'T> -> List<'T>

Parameters

match
Type: SystemPredicate T

Return Value

Type: List T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).FindAllAndRefresh Method

ExpiringListTFindAllAndRefresh Method
Returns all of the items that match the predicate or an empty list if no such items exist. Refreshes the timestamps for all of the items returned.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<T> FindAllAndRefresh(
    Predicate<T> match
)
Public Function FindAllAndRefresh (
    match As Predicate(Of T)
) As List(Of T)
public:
List<T>^ FindAllAndRefresh(
    Predicate<T>^ match
)
member FindAllAndRefresh :
        match : Predicate<'T> -> List<'T>

Parameters

match
Type: SystemPredicate T

Return Value

Type: List T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).FindAndRefresh Method

ExpiringListTFindAndRefresh Method
Returns the item that matches the predicate or null if no such item exists. Refreshes the timestamp for the item.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T FindAndRefresh(
    Predicate<T> match
)
Public Function FindAndRefresh (
    match As Predicate(Of T)
) As T
public:
T FindAndRefresh(
    Predicate<T>^ match
)
member FindAndRefresh :
        match : Predicate<'T> -> 'T

Parameters

match
Type: SystemPredicate T

Return Value

Type: T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).FindCollectionItem Method

ExpiringListTFindCollectionItem Method
Finds the collection item for the item passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ExpiringCollectionTItemCollectionItem<T> FindCollectionItem(
    T item
)
Protected Function FindCollectionItem (
    item As T
) As ExpiringCollectionTItemCollectionItem(Of T)
protected:
ExpiringCollectionTItemCollectionItem<T>^ FindCollectionItem(
    T item
)
member FindCollectionItem :
        item : 'T -> ExpiringCollectionTItemCollectionItem<'T>

Parameters

item
Type: T

Return Value

Type: ExpiringCollectionTItemCollectionItem T
Remarks
This must be called from within a lock.
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).RefreshAll Method

ExpiringListTRefreshAll Method
Refreshes the timestamps on every item in the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RefreshAll()
Public Sub RefreshAll
public:
void RefreshAll()
member RefreshAll : unit -> unit
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).Remove Method

ExpiringListTRemove Method
Removes the item from the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    T item
)
Public Sub Remove (
    item As T
)
public:
void Remove(
    T item
)
member Remove :
        item : 'T -> unit

Parameters

item
Type: T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).RemoveRange Method

ExpiringListTRemoveRange Method
Removes a range of items from the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRange(
    IEnumerable<T> items
)
Public Sub RemoveRange (
    items As IEnumerable(Of T)
)
public:
void RemoveRange(
    IEnumerable<T>^ items
)
member RemoveRange :
        items : IEnumerable<'T> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerable T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).Snapshot Method

ExpiringListTSnapshot Method
Returns a clone of the contents of the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T[] Snapshot()
Public Function Snapshot As T()
public:
array<T>^ Snapshot()
member Snapshot : unit -> 'T[]

Return Value

Type: T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T).SnapshotAndRefresh Method

ExpiringListTSnapshotAndRefresh Method
Returns a clone of every item in the list. Refreshes the timestamps on every item.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T[] SnapshotAndRefresh()
Public Function SnapshotAndRefresh As T()
public:
array<T>^ SnapshotAndRefresh()
member SnapshotAndRefresh : unit -> 'T[]

Return Value

Type: T
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


ExpiringList(T) Fields

ExpiringListT Fields

The ExpiringListT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _Clock | The clock that provides timestamps. (Inherited from ExpiringCollectionTItem.)
Protected field | _SyncLock | The lock object that controls access to the other fields. (Inherited from ExpiringCollectionTItem.)
Top
See Also

Reference

ExpiringListT Class
VirtualRadar.Interface Namespace


Filter Class

Filter Class
Describes a filter.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceFilter
VirtualRadar.InterfaceFilterBool
VirtualRadar.InterfaceFilterEnumT
VirtualRadar.InterfaceFilterRangeT
VirtualRadar.InterfaceFilterString

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Filter
Public Class Filter
public ref class Filter
type Filter =  class end

The Filter type exposes the following members.

Constructors
 | Name | Description
Public method | Filter | Creates a new object.
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft.
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


Filter Constructor

Filter Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Filter()
Public Sub New
public:
Filter()
new : unit -> Filter
See Also

Reference

Filter Class
VirtualRadar.Interface Namespace


Filter Properties

Filter Properties

The Filter type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft.
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed.
Top
See Also

Reference

Filter Class
VirtualRadar.Interface Namespace


Filter.Condition Property

FilterCondition Property
Gets or sets the condition that indicates how the parameters should be tested against an aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterCondition Condition { get; set; }
Public Property Condition As FilterCondition
    Get
    Set
public:
property FilterCondition Condition {
    FilterCondition get ();
    void set (FilterCondition value);
}
member Condition : FilterCondition with get, set

Property Value

Type: FilterCondition
See Also

Reference

Filter Class
VirtualRadar.Interface Namespace


Filter.ReverseCondition Property

FilterReverseCondition Property
Gets or sets a value indicating that the result of the test should be reversed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReverseCondition { get; set; }
Public Property ReverseCondition As Boolean
    Get
    Set
public:
property bool ReverseCondition {
    bool get ();
    void set (bool value);
}
member ReverseCondition : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Filter Class
VirtualRadar.Interface Namespace


Filter Methods

Filter Methods

The Filter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Filter Class
VirtualRadar.Interface Namespace


FilterBool Class

FilterBool Class
An object that carries a bool filter.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceFilter
VirtualRadar.InterfaceFilterBool

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterBool : Filter
Public Class FilterBool
    Inherits Filter
public ref class FilterBool : public Filter
type FilterBool =
    class
        inherit Filter
    end

The FilterBool type exposes the following members.

Constructors
 | Name | Description
Public method | FilterBool | Creates a new object.
Public method | FilterBool(Boolean) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | Value | Gets or sets the value to compare against.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Passes | Returns true if the value passes the filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


FilterBool Constructor

FilterBool Constructor
Overload List
 | Name | Description
Public method | FilterBool | Creates a new object.
Public method | FilterBool(Boolean) | Creates a new object.
Top
See Also

Reference

FilterBool Class
VirtualRadar.Interface Namespace


FilterBool Constructor

FilterBool Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterBool()
Public Sub New
public:
FilterBool()
new : unit -> FilterBool
See Also

Reference

FilterBool Class
FilterBool Overload
VirtualRadar.Interface Namespace


FilterBool Constructor (Boolean)

FilterBool Constructor (Boolean)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterBool(
    bool value
)
Public Sub New (
    value As Boolean
)
public:
FilterBool(
    bool value
)
new :
        value : bool -> FilterBool

Parameters

value
Type: SystemBoolean
See Also

Reference

FilterBool Class
FilterBool Overload
VirtualRadar.Interface Namespace


FilterBool Properties

FilterBool Properties

The FilterBool type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | Value | Gets or sets the value to compare against.
Top
See Also

Reference

FilterBool Class
VirtualRadar.Interface Namespace


FilterBool.Value Property

FilterBoolValue Property
Gets or sets the value to compare against.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Value { get; set; }
Public Property Value As Boolean
    Get
    Set
public:
property bool Value {
    bool get ();
    void set (bool value);
}
member Value : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FilterBool Class
VirtualRadar.Interface Namespace


FilterBool Methods

FilterBool Methods

The FilterBool type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Passes | Returns true if the value passes the filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilterBool Class
VirtualRadar.Interface Namespace


FilterBool.Passes Method

FilterBoolPasses Method
Returns true if the value passes the filter.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Passes(
    Nullable<bool> value
)
Public Function Passes (
    value As Nullable(Of Boolean)
) As Boolean
public:
bool Passes(
    Nullable<bool> value
)
member Passes :
        value : Nullable<bool> -> bool

Parameters

value
Type: SystemNullable Boolean

Return Value

Type: Boolean
See Also

Reference

FilterBool Class
VirtualRadar.Interface Namespace


FilterCondition Enumeration

FilterCondition Enumeration
An enumeration of the different conditions that a value can be filtered on.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FilterCondition
Public Enumeration FilterCondition
public enum class FilterCondition
type FilterCondition
Members
Member name | Value | Description
Invalid | 0 | The filter condition is invalid or missing.
Between | 1 | The value must lie between two inclusive values.
StartsWith | 2 | The value must start with a fixed string.
EndsWith | 3 | The value must end with a fixed string.
Equals | 4 | The value must equal a fixed value.
Contains | 5 | The value must contain a fixed string.
See Also

Reference

VirtualRadar.Interface Namespace


FilterEnum(T) Class

FilterEnumT Class
Describes a filter against an enum value.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceFilter
VirtualRadar.InterfaceFilterEnumT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterEnum<T> : Filter
where T : struct, new(), IComparable

Public Class FilterEnum(Of T As {Structure, New, IComparable})
    Inherits Filter
generic<typename T>
where T : value class, gcnew(), IComparable
public ref class FilterEnum : public Filter
type FilterEnum<'T when 'T : struct, new() and IComparable> =
    class
        inherit Filter
    end

Type Parameters

T

The FilterEnumT type exposes the following members.

Constructors
 | Name | Description
Public method | FilterEnumT | Creates a new object.
Public method | FilterEnumT(T) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | Value | Gets or sets the enum value to compare against a value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Passes | Returns true if the enum value passed across passes the filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


FilterEnum(T) Constructor

FilterEnumT Constructor
Overload List
 | Name | Description
Public method | FilterEnumT | Creates a new object.
Public method | FilterEnumT(T) | Creates a new object.
Top
See Also

Reference

FilterEnumT Class
VirtualRadar.Interface Namespace


FilterEnum(T) Constructor

FilterEnumT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterEnum()
Public Sub New
public:
FilterEnum()
new : unit -> FilterEnum
See Also

Reference

FilterEnumT Class
FilterEnumT Overload
VirtualRadar.Interface Namespace


FilterEnum(T) Constructor (T)

FilterEnumT Constructor (T)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterEnum(
    T value
)
Public Sub New (
    value As T
)
public:
FilterEnum(
    T value
)
new :
        value : 'T -> FilterEnum

Parameters

value
Type: T
See Also

Reference

FilterEnumT Class
FilterEnumT Overload
VirtualRadar.Interface Namespace


FilterEnum(T) Properties

FilterEnumT Properties

The FilterEnumT generic type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | Value | Gets or sets the enum value to compare against a value.
Top
See Also

Reference

FilterEnumT Class
VirtualRadar.Interface Namespace


FilterEnum(T).Value Property

FilterEnumTValue Property
Gets or sets the enum value to compare against a value.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set
public:
property T Value {
    T get ();
    void set (T value);
}
member Value : 'T with get, set

Property Value

Type: T
See Also

Reference

FilterEnumT Class
VirtualRadar.Interface Namespace


FilterEnum(T) Methods

FilterEnumT Methods

The FilterEnumT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Passes | Returns true if the enum value passed across passes the filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilterEnumT Class
VirtualRadar.Interface Namespace


FilterEnum(T).Passes Method

FilterEnumTPasses Method
Returns true if the enum value passed across passes the filter.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Passes(
    Nullable<T> value
)
Public Function Passes (
    value As Nullable(Of T)
) As Boolean
public:
bool Passes(
    Nullable<T> value
)
member Passes :
        value : Nullable<'T> -> bool

Parameters

value
Type: SystemNullable T

Return Value

Type: Boolean
See Also

Reference

FilterEnumT Class
VirtualRadar.Interface Namespace


FilterRange(T) Class

FilterRangeT Class
Describes a range filter to apply to a value.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceFilter
VirtualRadar.InterfaceFilterRangeT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterRange<T> : Filter
where T : struct, new(), IComparable

Public Class FilterRange(Of T As {Structure, New, IComparable})
    Inherits Filter
generic<typename T>
where T : value class, gcnew(), IComparable
public ref class FilterRange : public Filter
type FilterRange<'T when 'T : struct, new() and IComparable> =
    class
        inherit Filter
    end

Type Parameters

T

The FilterRangeT type exposes the following members.

Constructors
 | Name | Description
Public method | FilterRangeT | Creates a new object.
Public method | FilterRangeT(NullableT, NullableT) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | IsValid | Gets a value indicating whether the filter appears to be correctly configured with a valid condition and at least an upper or lower value.
Public property | LowerValue | Gets or sets the lower value in the range. A null indicates that there is no lower limit.
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | UpperValue | Gets or sets the upper value in the range. A null indicates that there is no upper limit.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormaliseRange | If the lower value is larger than the upper value then this swaps them around.
Public method | Passes | Returns true if the value is within the bounds set by the filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


FilterRange(T) Constructor

FilterRangeT Constructor
Overload List
 | Name | Description
Public method | FilterRangeT | Creates a new object.
Public method | FilterRangeT(NullableT, NullableT) | Creates a new object.
Top
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T) Constructor

FilterRangeT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange()
Public Sub New
public:
FilterRange()
new : unit -> FilterRange
See Also

Reference

FilterRangeT Class
FilterRangeT Overload
VirtualRadar.Interface Namespace


FilterRange(T) Constructor (Nullable(T), Nullable(T))

FilterRangeT Constructor (NullableT, NullableT)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange(
    Nullable<T> lowerValue,
    Nullable<T> upperValue
)
Public Sub New (
    lowerValue As Nullable(Of T),
    upperValue As Nullable(Of T)
)
public:
FilterRange(
    Nullable<T> lowerValue,
    Nullable<T> upperValue
)
new :
        lowerValue : Nullable<'T> *
        upperValue : Nullable<'T> -> FilterRange

Parameters

lowerValue
Type: SystemNullable T
upperValue
Type: SystemNullable T
See Also

Reference

FilterRangeT Class
FilterRangeT Overload
VirtualRadar.Interface Namespace


FilterRange(T) Properties

FilterRangeT Properties

The FilterRangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | IsValid | Gets a value indicating whether the filter appears to be correctly configured with a valid condition and at least an upper or lower value.
Public property | LowerValue | Gets or sets the lower value in the range. A null indicates that there is no lower limit.
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | UpperValue | Gets or sets the upper value in the range. A null indicates that there is no upper limit.
Top
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T).IsValid Property

FilterRangeTIsValid Property
Gets a value indicating whether the filter appears to be correctly configured with a valid condition and at least an upper or lower value.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T).LowerValue Property

FilterRangeTLowerValue Property
Gets or sets the lower value in the range. A null indicates that there is no lower limit.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<T> LowerValue { get; set; }
Public Property LowerValue As Nullable(Of T)
    Get
    Set
public:
property Nullable<T> LowerValue {
    Nullable<T> get ();
    void set (Nullable<T> value);
}
member LowerValue : Nullable<'T> with get, set

Property Value

Type: Nullable T
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T).UpperValue Property

FilterRangeTUpperValue Property
Gets or sets the upper value in the range. A null indicates that there is no upper limit.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<T> UpperValue { get; set; }
Public Property UpperValue As Nullable(Of T)
    Get
    Set
public:
property Nullable<T> UpperValue {
    Nullable<T> get ();
    void set (Nullable<T> value);
}
member UpperValue : Nullable<'T> with get, set

Property Value

Type: Nullable T
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T) Methods

FilterRangeT Methods

The FilterRangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormaliseRange | If the lower value is larger than the upper value then this swaps them around.
Public method | Passes | Returns true if the value is within the bounds set by the filter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T).NormaliseRange Method

FilterRangeTNormaliseRange Method
If the lower value is larger than the upper value then this swaps them around.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void NormaliseRange()
Public Sub NormaliseRange
public:
void NormaliseRange()
member NormaliseRange : unit -> unit
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterRange(T).Passes Method

FilterRangeTPasses Method
Returns true if the value is within the bounds set by the filter.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Passes(
    Nullable<T> value
)
Public Function Passes (
    value As Nullable(Of T)
) As Boolean
public:
bool Passes(
    Nullable<T> value
)
member Passes :
        value : Nullable<'T> -> bool

Parameters

value
Type: SystemNullable T

Return Value

Type: Boolean
See Also

Reference

FilterRangeT Class
VirtualRadar.Interface Namespace


FilterString Class

FilterString Class
A string filter to apply to a value.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceFilter
VirtualRadar.InterfaceFilterString

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterString : Filter
Public Class FilterString
    Inherits Filter
public ref class FilterString : public Filter
type FilterString =
    class
        inherit Filter
    end

The FilterString type exposes the following members.

Constructors
 | Name | Description
Public method | FilterString | Creates a new object.
Public method | FilterString(String) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | Value | Gets or sets the text that the value will be filtered against.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Passes(IEnumerableString) | Returns true if any of the values pass the filter. Note that all comparisons are case insensitive.
Public method | Passes(String) | Returns true if the value passes the filter. Note that all comparisons are case insensitive.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUpper | Converts the value to upper-case.
Top
See Also

Reference

VirtualRadar.Interface Namespace


FilterString Constructor

FilterString Constructor
Overload List
 | Name | Description
Public method | FilterString | Creates a new object.
Public method | FilterString(String) | Creates a new object.
Top
See Also

Reference

FilterString Class
VirtualRadar.Interface Namespace


FilterString Constructor

FilterString Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString()
Public Sub New
public:
FilterString()
new : unit -> FilterString
See Also

Reference

FilterString Class
FilterString Overload
VirtualRadar.Interface Namespace


FilterString Constructor (String)

FilterString Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString(
    string value
)
Public Sub New (
    value As String
)
public:
FilterString(
    String^ value
)
new :
        value : string -> FilterString

Parameters

value
Type: SystemString
See Also

Reference

FilterString Class
FilterString Overload
VirtualRadar.Interface Namespace


FilterString Properties

FilterString Properties

The FilterString type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the condition that indicates how the parameters should be tested against an aircraft. (Inherited from Filter.)
Public property | ReverseCondition | Gets or sets a value indicating that the result of the test should be reversed. (Inherited from Filter.)
Public property | Value | Gets or sets the text that the value will be filtered against.
Top
See Also

Reference

FilterString Class
VirtualRadar.Interface Namespace


FilterString.Value Property

FilterStringValue Property
Gets or sets the text that the value will be filtered against.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

FilterString Class
VirtualRadar.Interface Namespace


FilterString Methods

FilterString Methods

The FilterString type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Passes(IEnumerableString) | Returns true if any of the values pass the filter. Note that all comparisons are case insensitive.
Public method | Passes(String) | Returns true if the value passes the filter. Note that all comparisons are case insensitive.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUpper | Converts the value to upper-case.
Top
See Also

Reference

FilterString Class
VirtualRadar.Interface Namespace


FilterString.Passes Method

FilterStringPasses Method
Overload List
 | Name | Description
Public method | Passes(IEnumerableString) | Returns true if any of the values pass the filter. Note that all comparisons are case insensitive.
Public method | Passes(String) | Returns true if the value passes the filter. Note that all comparisons are case insensitive.
Top
See Also

Reference

FilterString Class
VirtualRadar.Interface Namespace


FilterString.Passes Method (IEnumerable(String))

FilterStringPasses Method (IEnumerableString)
Returns true if any of the values pass the filter. Note that all comparisons are case insensitive.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Passes(
    IEnumerable<string> value
)
Public Function Passes (
    value As IEnumerable(Of String)
) As Boolean
public:
bool Passes(
    IEnumerable<String^>^ value
)
member Passes :
        value : IEnumerable<string> -> bool

Parameters

value
Type: System.Collections.GenericIEnumerable String

Return Value

Type: Boolean
See Also

Reference

FilterString Class
Passes Overload
VirtualRadar.Interface Namespace


FilterString.Passes Method (String)

FilterStringPasses Method (String)
Returns true if the value passes the filter. Note that all comparisons are case insensitive.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Passes(
    string value
)
Public Function Passes (
    value As String
) As Boolean
public:
bool Passes(
    String^ value
)
member Passes :
        value : string -> bool

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

FilterString Class
Passes Overload
VirtualRadar.Interface Namespace


FilterString.ToUpper Method

FilterStringToUpper Method
Converts the value to upper-case.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToUpper()
Public Sub ToUpper
public:
void ToUpper()
member ToUpper : unit -> unit
See Also

Reference

FilterString Class
VirtualRadar.Interface Namespace


GreatCircleMaths Class

GreatCircleMaths Class
A collection of Great Circle math functions, mostly cribbed from http://www.movable-type.co.uk/scripts/latlong.html.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceGreatCircleMaths

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GreatCircleMaths
Public NotInheritable Class GreatCircleMaths
public ref class GreatCircleMaths abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GreatCircleMaths =  class end

The GreatCircleMaths type exposes the following members.

Methods
Name | Description
Bearing | Given two points on the earth's surface this calculates either the bearing to take from point A to get to point B. It can optionally take a pre-calculated bearing and return that if the start and end points are the same.
Destination | Given a start coordinate, bearing and distance this calculates the final coordinate.
Distance | Calculates the distance in km between two points on the earth at sea level.
Top
See Also

Reference

VirtualRadar.Interface Namespace


GreatCircleMaths Methods

GreatCircleMaths Methods

The GreatCircleMaths type exposes the following members.

Methods
Name | Description
Bearing | Given two points on the earth's surface this calculates either the bearing to take from point A to get to point B. It can optionally take a pre-calculated bearing and return that if the start and end points are the same.
Destination | Given a start coordinate, bearing and distance this calculates the final coordinate.
Distance | Calculates the distance in km between two points on the earth at sea level.
Top
See Also

Reference

GreatCircleMaths Class
VirtualRadar.Interface Namespace


GreatCircleMaths.Bearing Method

GreatCircleMathsBearing Method
Given two points on the earth's surface this calculates either the bearing to take from point A to get to point B. It can optionally take a pre-calculated bearing and return that if the start and end points are the same.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<double> Bearing(
    Nullable<double> startLatitude,
    Nullable<double> startLongitude,
    Nullable<double> endLatitude,
    Nullable<double> endLongitude,
    Nullable<double> currentTrack,
    bool reverseBearing,
    bool ignoreCurrentTrack
)
Public Shared Function Bearing (
    startLatitude As Nullable(Of Double),
    startLongitude As Nullable(Of Double),
    endLatitude As Nullable(Of Double),
    endLongitude As Nullable(Of Double),
    currentTrack As Nullable(Of Double),
    reverseBearing As Boolean,
    ignoreCurrentTrack As Boolean
) As Nullable(Of Double)
public:
static Nullable<double> Bearing(
    Nullable<double> startLatitude,
    Nullable<double> startLongitude,
    Nullable<double> endLatitude,
    Nullable<double> endLongitude,
    Nullable<double> currentTrack,
    bool reverseBearing,
    bool ignoreCurrentTrack
)
static member Bearing :
        startLatitude : Nullable<float> *
        startLongitude : Nullable<float> *
        endLatitude : Nullable<float> *
        endLongitude : Nullable<float> *
        currentTrack : Nullable<float> *
        reverseBearing : bool *
        ignoreCurrentTrack : bool -> Nullable<float>

Parameters

startLatitude
Type: SystemNullable Double
startLongitude
Type: SystemNullable Double
endLatitude
Type: SystemNullable Double
endLongitude
Type: SystemNullable Double
currentTrack
Type: SystemNullable Double
The brearing to return if ignoreCurrentTrack is false and the start and end points are the same.
reverseBearing
Type: SystemBoolean
True if the bearing should be reversed.
ignoreCurrentTrack
Type: SystemBoolean
True if the bearing should always be calculated and possible shortcuts ignored.

Return Value

Type: Nullable Double
See Also

Reference

GreatCircleMaths Class
VirtualRadar.Interface Namespace


GreatCircleMaths.Destination Method

GreatCircleMathsDestination Method
Given a start coordinate, bearing and distance this calculates the final coordinate.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Destination(
    Nullable<double> startLatitude,
    Nullable<double> startLongitude,
    Nullable<double> bearing,
    Nullable<double> kilometres,
    out Nullable<double> endLatitude,
    out Nullable<double> endLongitude
)
Public Shared Sub Destination (
    startLatitude As Nullable(Of Double),
    startLongitude As Nullable(Of Double),
    bearing As Nullable(Of Double),
    kilometres As Nullable(Of Double),
    <OutAttribute> ByRef endLatitude As Nullable(Of Double),
    <OutAttribute> ByRef endLongitude As Nullable(Of Double)
)
public:
static void Destination(
    Nullable<double> startLatitude,
    Nullable<double> startLongitude,
    Nullable<double> bearing,
    Nullable<double> kilometres,
    [OutAttribute] Nullable<double>% endLatitude,
    [OutAttribute] Nullable<double>% endLongitude
)
static member Destination :
        startLatitude : Nullable<float> *
        startLongitude : Nullable<float> *
        bearing : Nullable<float> *
        kilometres : Nullable<float> *
        endLatitude : Nullable<float> byref *
        endLongitude : Nullable<float> byref -> unit

Parameters

startLatitude
Type: SystemNullable Double
startLongitude
Type: SystemNullable Double
bearing
Type: SystemNullable Double
kilometres
Type: SystemNullable Double
endLatitude
Type: SystemNullable Double
endLongitude
Type: SystemNullable Double
See Also

Reference

GreatCircleMaths Class
VirtualRadar.Interface Namespace


GreatCircleMaths.Distance Method

GreatCircleMathsDistance Method
Calculates the distance in km between two points on the earth at sea level.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<double> Distance(
    Nullable<double> startLatitude,
    Nullable<double> startLongitude,
    Nullable<double> endLatitude,
    Nullable<double> endLongitude
)
Public Shared Function Distance (
    startLatitude As Nullable(Of Double),
    startLongitude As Nullable(Of Double),
    endLatitude As Nullable(Of Double),
    endLongitude As Nullable(Of Double)
) As Nullable(Of Double)
public:
static Nullable<double> Distance(
    Nullable<double> startLatitude,
    Nullable<double> startLongitude,
    Nullable<double> endLatitude,
    Nullable<double> endLongitude
)
static member Distance :
        startLatitude : Nullable<float> *
        startLongitude : Nullable<float> *
        endLatitude : Nullable<float> *
        endLongitude : Nullable<float> -> Nullable<float>

Parameters

startLatitude
Type: SystemNullable Double
startLongitude
Type: SystemNullable Double
endLatitude
Type: SystemNullable Double
endLongitude
Type: SystemNullable Double

Return Value

Type: Nullable Double
See Also

Reference

GreatCircleMaths Class
VirtualRadar.Interface Namespace


HeightUnit Enumeration

HeightUnit Enumeration
An enumeration of the different heights that the web site knows about.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HeightUnit
Public Enumeration HeightUnit
public enum class HeightUnit
type HeightUnit
Members
Member name | Value | Description
Feet | 0 | Feet.
Metres | 1 | Metres.
Remarks
The names of these enumeration values must exactly match the equivalent names in the Javascript produced by the web site.
See Also

Reference

VirtualRadar.Interface Namespace


Hierarchy Class

Hierarchy Class
Static methods for dealing with hierarchies.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceHierarchy

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Hierarchy
Public NotInheritable Class Hierarchy
public ref class Hierarchy abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Hierarchy =  class end

The Hierarchy type exposes the following members.

Methods
Name | Description
FlattenT | Takes the root object in a parent-child object and returns the collection of objects in the hierarchy.
Top
See Also

Reference

VirtualRadar.Interface Namespace


Hierarchy Methods

Hierarchy Methods

The Hierarchy type exposes the following members.

Methods
Name | Description
FlattenT | Takes the root object in a parent-child object and returns the collection of objects in the hierarchy.
Top
See Also

Reference

Hierarchy Class
VirtualRadar.Interface Namespace


Hierarchy.Flatten(T) Method

HierarchyFlattenT Method
Takes the root object in a parent-child object and returns the collection of objects in the hierarchy.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> Flatten<T>(
    T root,
    Func<T, T> getChild
)

Public Shared Function Flatten(Of T) (
    root As T,
    getChild As Func(Of T, T)
) As IEnumerable(Of T)
public:
generic<typename T>
static IEnumerable<T>^ Flatten(
    T root,
    Func<T, T>^ getChild
)
static member Flatten :
        root : 'T *
        getChild : Func<'T, 'T> -> IEnumerable<'T>

Parameters

root
Type: T
getChild
Type: SystemFunc T, T

Type Parameters

T

Return Value

Type: IEnumerable T
See Also

Reference

Hierarchy Class
VirtualRadar.Interface Namespace


IAccessFilter Interface

IAccessFilter Interface
The interface for classes that can take an Access list from Settings and use that to decide whether to allow or disallow an incoming connection or request.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAccessFilter
Public Interface IAccessFilter
public interface class IAccessFilter
type IAccessFilter =  interface end

The IAccessFilter type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets the access last passed to Initialise(Access).
Top
Methods
 | Name | Description
Public method | Allow | Returns true if access from the address passed across should be allowed.
Public method | Initialise | Initialises the filter. Changes to the Access object after this call have no effect on the operation of the filter. Multiple calls are permitted.
Top
Remarks
Implementations must be thread-safe.
See Also

Reference

VirtualRadar.Interface Namespace


IAccessFilter Properties

IAccessFilter Properties

The IAccessFilter type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets the access last passed to Initialise(Access).
Top
See Also

Reference

IAccessFilter Interface
VirtualRadar.Interface Namespace


IAccessFilter.Access Property

IAccessFilterAccess Property
Gets the access last passed to Initialise(Access).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Access Access { get; }
ReadOnly Property Access As Access
    Get
property Access^ Access {
    Access^ get ();
}
abstract Access : Access with get

Property Value

Type: Access
See Also

Reference

IAccessFilter Interface
VirtualRadar.Interface Namespace


IAccessFilter Methods

IAccessFilter Methods

The IAccessFilter type exposes the following members.

Methods
 | Name | Description
Public method | Allow | Returns true if access from the address passed across should be allowed.
Public method | Initialise | Initialises the filter. Changes to the Access object after this call have no effect on the operation of the filter. Multiple calls are permitted.
Top
See Also

Reference

IAccessFilter Interface
VirtualRadar.Interface Namespace


IAccessFilter.Allow Method

IAccessFilterAllow Method
Returns true if access from the address passed across should be allowed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Allow(
    IPAddress address
)
Function Allow (
    address As IPAddress
) As Boolean
bool Allow(
    IPAddress^ address
)
abstract Allow :
        address : IPAddress -> bool

Parameters

address
Type: System.NetIPAddress

Return Value

Type: Boolean
See Also

Reference

IAccessFilter Interface
VirtualRadar.Interface Namespace


IAccessFilter.Initialise Method

IAccessFilterInitialise Method
Initialises the filter. Changes to the Access object after this call have no effect on the operation of the filter. Multiple calls are permitted.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    Access access
)
Sub Initialise (
    access As Access
)
void Initialise(
    Access^ access
)
abstract Initialise :
        access : Access -> unit

Parameters

access
Type: VirtualRadar.Interface.SettingsAccess
See Also

Reference

IAccessFilter Interface
VirtualRadar.Interface Namespace


IAircraft Interface

IAircraft Interface
Describes everything that is known about an aircraft that is being tracked.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraft : ICloneable
Public Interface IAircraft
    Inherits ICloneable
public interface class IAircraft : ICloneable
type IAircraft =
    interface
        interface ICloneable
    end

The IAircraft type exposes the following members.

Properties
 | Name | Description
Public property | AirPressureInHg | Gets or sets the pressure setting for the aircraft. This will be null if air pressure downloads are switched off, or the server is unavailable, or no air pressures have been downloaded yet.
Public property | AirPressureInHgChanged | Gets the DataVersion that was current when AirPressureInHg was last changed.
Public property | AirPressureLookedUpUtc | Gets or sets the time that the air pressure setting was looked up.
Public property | Altitude | Gets or sets the pressure altitde (in feet) that the aircraft last reported. If the aircraft is transmitting geometric altitude and the air pressure is known then this will be the calculated pressure altitude.
Public property | AltitudeChanged | Gets the DataVersion that was current when Altitude was last changed.
Public property | AltitudeType | Gets or sets the type of altitude being transmitted by the aircraft.
Public property | AltitudeTypeChanged | Gets the DataVersion that was current when AltitudeType was last changed.
Public property | Callsign | Gets or sets the ATC callsign of the aircraft.
Public property | CallsignChanged | Gets the DataVersion that was current when Callsign was last changed.
Public property | CallsignIsSuspect | Gets or sets a value indicating that the callsign came from a possible BDS2,0 message instead of an ADS-B message.
Public property | CallsignIsSuspectChanged | Gets the DataVersion that was current when CallsignIsSuspect was last changed.
Public property | ConstructionNumber | Gets or sets the construction number assigned to the aircraft by the manufacturer.
Public property | ConstructionNumberChanged | Gets the DataVersion that was current when ConstructionNumber was last changed.
Public property | CountMessagesReceived | Gets or sets the number of messages received for the aircraft.
Public property | CountMessagesReceivedChanged | Gets the DataVersion that was current when CountMessagesReceived was last changed.
Public property | DataVersion | Gets or sets a value indicating when the data was last changed.
Public property | Destination | Gets or sets a description of the airport where the aircraft's journey is scheduled to end.
Public property | DestinationChanged | Gets the DataVersion that was current when Destination was last changed.
Public property | Emergency | Gets or sets a value indicating that the Squawk represents an emergency code.
Public property | EmergencyChanged | Gets the DataVersion that was current when Emergency was last changed.
Public property | EnginePlacement | Gets or sets an indication of where the engines are mounted on the aircraft.
Public property | EnginePlacementChanged | Gets the DataVersion that was current when EnginePlacement was last changed.
Public property | EngineType | Gets or sets the ICAO 8643 engine type for this type of aircraft.
Public property | EngineTypeChanged | Gets the DataVersion that was current when EngineType was last changed.
Public property | FirstCoordinateChanged | Gets or sets the DataVersion that was current when the coordinates were first started for the aircraft.
Public property | FirstSeen | Gets or sets the time that a message from the aircraft was first received in this session.
Public property | FirstSeenChanged | Gets the DataVersion that was current when FirstSeen was last changed.
Public property | FlightsCount | Gets the number of flights that the aircraft has logged for it in the BaseStation database.
Public property | FlightsCountChanged | Gets the DataVersion that was current when FlightsCount was last changed.
Public property | FullCoordinates | The list of coordinates representing the full track of the aircraft, from when it was first seen until now.
Public property | GeometricAltitude | Gets or sets the geometric altitude, i.e. how far the aircraft is above sea level. If the aircraft is transmitting barometric altitudes and the air pressure is known then this is the calculated geometric altitude.
Public property | GeometricAltitudeChanged | Gets the DataVersion that was current when GeometricAltitude was last changed.
Public property | GroundSpeed | Gets or sets the speed (in knots) that the aircraft last reported.
Public property | GroundSpeedChanged | Gets the DataVersion that was current when GroundSpeed was last changed.
Public property | Icao24 | Gets or sets the aircraft's ICAO identifier.
Public property | Icao24Changed | Gets the DataVersion that was current when Icao24 was last changed.
Public property | Icao24Country | Gets or sets the country that the aircraft's ICAO24 is assigned to.
Public property | Icao24CountryChanged | Gets the DataVersion that was current when Icao24Country was last changed.
Public property | Icao24Invalid | Gets or sets a value indicating that the Icao24 identifier does not comply with ICAO rules or is known to be a duplicate of another aircraft's ICAO.
Public property | Icao24InvalidChanged | Gets the DataVersion that was current when Icao24Invalid was last changed.
Public property | IcaoCompliantRegistration | Gets the Registration with non-compliant characters stripped out.
Public property | IsInteresting | Gets or sets a value indicating that the aircraft is flagged as interesting in BaseStation.
Public property | IsInterestingChanged | Gets the DataVersion that was current when IsInteresting was last changed.
Public property | IsMilitary | Gets or sets a value indicating that the aircraft is probably a military aircraft.
Public property | IsMilitaryChanged | Gets the DataVersion that was current when IsMilitary was last changed.
Public property | IsTisb | Gets or sets a value indicating that the last message received for the aircraft came from a TIS-B source.
Public property | IsTisbChanged | Gets the DataVersion that was current when IsTisb last changed.
Public property | IsTransmittingTrack | Gets or sets a value indicating that the aircraft is transmitting its track, or at least that BaseStation is reporting one for it.
Public property | LastCoordinateChanged | Gets or sets the DataVersion that was current when the last coordinate was added for the aircraft.
Public property | LastModeSUpdate | Gets or sets the time of the last message received from a Mode-S feed for the aircraft.
Public property | LastSatcomUpdate | Gets or sets the time of the last message received from a SatCom feed for the aircraft.
Public property | LastUpdate | Gets or sets the time of the last message received from the aircraft.
Public property | LatestCoordinateTime | Gets or sets the time of the latest coordinate on the lists.
Public property | Latitude | Gets the last reported latitude of the aircraft.
Public property | LatitudeChanged | Gets the DataVersion that was current when Latitude was last changed.
Public property | Longitude | Gets the last reported longitude of the aircraft.
Public property | LongitudeChanged | Gets the DataVersion that was current when Longitude was last changed.
Public property | Manufacturer | Gets or sets the name of the aircraft's maker.
Public property | ManufacturerChanged | Gets the DataVersion that was current when Manufacturer was last changed.
Public property | Model | Gets or sets a description of the model of the aircraft, as assigned by the manufacturer.
Public property | ModelChanged | Gets the DataVersion that was current when Model was last changed.
Public property | NumberOfEngines | Gets or sets the number of engines as per ICAO 8643. Note that this 'number' can include the value C...
Public property | NumberOfEnginesChanged | Gets the DataVersion that was current when NumberOfEngines was last changed.
Public property | OnGround | Gets or sets a value indicating that the vehicle is reporting itself as being on the ground.
Public property | OnGroundChanged | Gets the DataVersion that was current when OnGround was last changed.
Public property | Operator | Gets or sets the name of the company or individual that is operating the aircraft.
Public property | OperatorChanged | Gets the DataVersion that was current when Operator was last changed.
Public property | OperatorIcao | Gets or sets the ICAO code for the aircraft's operator.
Public property | OperatorIcaoChanged | Gets the DataVersion that was current when OperatorIcao was last changed.
Public property | Origin | Gets or sets a description of the airport where the aircraft's journey began.
Public property | OriginChanged | Gets the DataVersion that was current when Origin was last changed.
Public property | PictureFileName | Gets or sets the full path and filename of the aircraft's picture or null if the aircraft has no picture.
Public property | PictureFileNameChanged | Gets the DataVersion that was current when PictureFileName was last changed.
Public property | PictureHeight | Gets or sets the height of the picture in pixels. This will be 0 if the aircraft has no picture.
Public property | PictureHeightChanged | Gets the DataVersion that was current when PictureHeight was last changed.
Public property | PictureWidth | Gets or sets the width of the picture in pixels. This will be 0 if the aircraft has no picture.
Public property | PictureWidthChanged | Gets the DataVersion that was current when PictureWidth was last changed.
Public property | PositionIsMlat | Gets or sets a value indicating that the position was calculated by an MLAT server, or came off an MLAT feed.
Public property | PositionIsMlatChanged | Gets the DataVersion that was current when PositionIsMlat last changed.
Public property | PositionReceiverId | Gets or sets the ID of the receiver that supplied the last position for the aircraft.
Public property | PositionReceiverIdChanged | Gets the UTC date and time that PositionReceiverId last changed.
Public property | PositionTime | Gets the UTC date and time that Latitude and Longitude were last changed.
Public property | PositionTimeChanged | Gets the DataVersion that was current when PositionTime was last changed.
Public property | ReceiverId | Gets or sets the ID of the last receiver to provide a message for this aircraft. Only varies when the aircraft is being fed messages from a merged feed.
Public property | ReceiverIdChanged | Gets the DataVersion that was current when ReceiverId was last changed.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | RegistrationChanged | Gets the DataVersion that was current when Registration was last changed.
Public property | ShortCoordinates | The list of coordinates representing the short track of the aircraft, the locations reported by it for the past so-many seconds.
Public property | SignalLevel | Gets or sets the signal level of the last message applied to the aircraft. This is null if the receiver wasn't passing along signal levels.
Public property | SignalLevelChanged | Gets the DataVersion that was current when SignalLevel was last changed.
Public property | Species | Gets or sets the type of aircraft as recorded in ICAO 8643.
Public property | SpeciesChanged | Gets the DataVersion that was current when Species was last changed.
Public property | SpeedType | Gets or sets the type of speed being transmitted by the aircraft.
Public property | SpeedTypeChanged |
Public property | Squawk | Gets or sets the squawk code transmitted by the aircraft.
Public property | SquawkChanged | Gets the DataVersion that was current when Squawk was last changed.
Public property | Stopovers | Gets or sets a list of scheduled stops for the aircraft.
Public property | StopoversChanged | Gets or sets the DataVersion that was current when Stopovers was last changed.
Public property | TargetAltitude | Gets or sets the altitude (in feet) that the aircraft's autopilot / FMS etc. is set to.
Public property | TargetAltitudeChanged | Gets the DataVersion that was current when TargetAltitude was last changed.
Public property | TargetTrack | Gets or sets the track or heading on the aircraft's autopilot / FMS etc.
Public property | TargetTrackChanged | Gets the DataVersion that was current when TargetTrack was last changed.
Public property | Track | Gets or sets the last reported heading over the ground of the aircraft. If the aircraft is not reporting its track (see IsTransmittingTrack) then the code will calculate one for it. This is in degrees clockwise.
Public property | TrackChanged | Gets the DataVersion that was current when Track was last changed.
Public property | TrackIsHeading | Gets or sets a value indicating that the Track is the heading of the aircraft. If this is false then Track is the ground track, which is the default.
Public property | TrackIsHeadingChanged | Gets the DataVersion that was current when TrackIsHeading was last changed.
Public property | TransponderType | Gets or sets the transponder type used by the aircraft.
Public property | TransponderTypeChanged | Gets the DataVersion that was current when TransponderType was last changed.
Public property | Type | Gets or sets the ICAO8643 type code for the aircraft.
Public property | TypeChanged | Gets the DataVersion that was current when Type was last changed.
Public property | UniqueId | Gets or sets the unique identifier of the aircraft.
Public property | UserTag | Gets the UserTag from the aircraft's database record.
Public property | UserTagChanged | Gets the DataVersion that was current when UserTag was last changed.
Public property | VerticalRate | Gets or sets the last reported rate of ascent or descent (-ve) of the aircraft in feet per minute.
Public property | VerticalRateChanged | Gets the DataVersion that was current when VerticalRate was last changed.
Public property | VerticalRateType | Gets or sets the type of vertical rate being transmitted by the aircraft.
Public property | VerticalRateTypeChanged |
Public property | WakeTurbulenceCategory | Gets or sets the ICAO 8643 ATC wake turbulence category for this type of aircraft.
Public property | WakeTurbulenceCategoryChanged | Gets the DataVersion that was current when WakeTurbulenceCategory was last changed.
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured as a string (it's a string in BaseStation.sqb).
Public property | YearBuiltChanged | Gets the DataVersion that was current when YearBuilt was last changed.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | ResetCoordinates | Removes all coordinates from the aircraft's coordinates lists.
Public method | UpdateCoordinates | Updates the FullCoordinates and ShortCoordinates lists using the current values on the aircraft.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraft Properties

IAircraft Properties

The IAircraft type exposes the following members.

Properties
 | Name | Description
Public property | AirPressureInHg | Gets or sets the pressure setting for the aircraft. This will be null if air pressure downloads are switched off, or the server is unavailable, or no air pressures have been downloaded yet.
Public property | AirPressureInHgChanged | Gets the DataVersion that was current when AirPressureInHg was last changed.
Public property | AirPressureLookedUpUtc | Gets or sets the time that the air pressure setting was looked up.
Public property | Altitude | Gets or sets the pressure altitde (in feet) that the aircraft last reported. If the aircraft is transmitting geometric altitude and the air pressure is known then this will be the calculated pressure altitude.
Public property | AltitudeChanged | Gets the DataVersion that was current when Altitude was last changed.
Public property | AltitudeType | Gets or sets the type of altitude being transmitted by the aircraft.
Public property | AltitudeTypeChanged | Gets the DataVersion that was current when AltitudeType was last changed.
Public property | Callsign | Gets or sets the ATC callsign of the aircraft.
Public property | CallsignChanged | Gets the DataVersion that was current when Callsign was last changed.
Public property | CallsignIsSuspect | Gets or sets a value indicating that the callsign came from a possible BDS2,0 message instead of an ADS-B message.
Public property | CallsignIsSuspectChanged | Gets the DataVersion that was current when CallsignIsSuspect was last changed.
Public property | ConstructionNumber | Gets or sets the construction number assigned to the aircraft by the manufacturer.
Public property | ConstructionNumberChanged | Gets the DataVersion that was current when ConstructionNumber was last changed.
Public property | CountMessagesReceived | Gets or sets the number of messages received for the aircraft.
Public property | CountMessagesReceivedChanged | Gets the DataVersion that was current when CountMessagesReceived was last changed.
Public property | DataVersion | Gets or sets a value indicating when the data was last changed.
Public property | Destination | Gets or sets a description of the airport where the aircraft's journey is scheduled to end.
Public property | DestinationChanged | Gets the DataVersion that was current when Destination was last changed.
Public property | Emergency | Gets or sets a value indicating that the Squawk represents an emergency code.
Public property | EmergencyChanged | Gets the DataVersion that was current when Emergency was last changed.
Public property | EnginePlacement | Gets or sets an indication of where the engines are mounted on the aircraft.
Public property | EnginePlacementChanged | Gets the DataVersion that was current when EnginePlacement was last changed.
Public property | EngineType | Gets or sets the ICAO 8643 engine type for this type of aircraft.
Public property | EngineTypeChanged | Gets the DataVersion that was current when EngineType was last changed.
Public property | FirstCoordinateChanged | Gets or sets the DataVersion that was current when the coordinates were first started for the aircraft.
Public property | FirstSeen | Gets or sets the time that a message from the aircraft was first received in this session.
Public property | FirstSeenChanged | Gets the DataVersion that was current when FirstSeen was last changed.
Public property | FlightsCount | Gets the number of flights that the aircraft has logged for it in the BaseStation database.
Public property | FlightsCountChanged | Gets the DataVersion that was current when FlightsCount was last changed.
Public property | FullCoordinates | The list of coordinates representing the full track of the aircraft, from when it was first seen until now.
Public property | GeometricAltitude | Gets or sets the geometric altitude, i.e. how far the aircraft is above sea level. If the aircraft is transmitting barometric altitudes and the air pressure is known then this is the calculated geometric altitude.
Public property | GeometricAltitudeChanged | Gets the DataVersion that was current when GeometricAltitude was last changed.
Public property | GroundSpeed | Gets or sets the speed (in knots) that the aircraft last reported.
Public property | GroundSpeedChanged | Gets the DataVersion that was current when GroundSpeed was last changed.
Public property | Icao24 | Gets or sets the aircraft's ICAO identifier.
Public property | Icao24Changed | Gets the DataVersion that was current when Icao24 was last changed.
Public property | Icao24Country | Gets or sets the country that the aircraft's ICAO24 is assigned to.
Public property | Icao24CountryChanged | Gets the DataVersion that was current when Icao24Country was last changed.
Public property | Icao24Invalid | Gets or sets a value indicating that the Icao24 identifier does not comply with ICAO rules or is known to be a duplicate of another aircraft's ICAO.
Public property | Icao24InvalidChanged | Gets the DataVersion that was current when Icao24Invalid was last changed.
Public property | IcaoCompliantRegistration | Gets the Registration with non-compliant characters stripped out.
Public property | IsInteresting | Gets or sets a value indicating that the aircraft is flagged as interesting in BaseStation.
Public property | IsInterestingChanged | Gets the DataVersion that was current when IsInteresting was last changed.
Public property | IsMilitary | Gets or sets a value indicating that the aircraft is probably a military aircraft.
Public property | IsMilitaryChanged | Gets the DataVersion that was current when IsMilitary was last changed.
Public property | IsTisb | Gets or sets a value indicating that the last message received for the aircraft came from a TIS-B source.
Public property | IsTisbChanged | Gets the DataVersion that was current when IsTisb last changed.
Public property | IsTransmittingTrack | Gets or sets a value indicating that the aircraft is transmitting its track, or at least that BaseStation is reporting one for it.
Public property | LastCoordinateChanged | Gets or sets the DataVersion that was current when the last coordinate was added for the aircraft.
Public property | LastModeSUpdate | Gets or sets the time of the last message received from a Mode-S feed for the aircraft.
Public property | LastSatcomUpdate | Gets or sets the time of the last message received from a SatCom feed for the aircraft.
Public property | LastUpdate | Gets or sets the time of the last message received from the aircraft.
Public property | LatestCoordinateTime | Gets or sets the time of the latest coordinate on the lists.
Public property | Latitude | Gets the last reported latitude of the aircraft.
Public property | LatitudeChanged | Gets the DataVersion that was current when Latitude was last changed.
Public property | Longitude | Gets the last reported longitude of the aircraft.
Public property | LongitudeChanged | Gets the DataVersion that was current when Longitude was last changed.
Public property | Manufacturer | Gets or sets the name of the aircraft's maker.
Public property | ManufacturerChanged | Gets the DataVersion that was current when Manufacturer was last changed.
Public property | Model | Gets or sets a description of the model of the aircraft, as assigned by the manufacturer.
Public property | ModelChanged | Gets the DataVersion that was current when Model was last changed.
Public property | NumberOfEngines | Gets or sets the number of engines as per ICAO 8643. Note that this 'number' can include the value C...
Public property | NumberOfEnginesChanged | Gets the DataVersion that was current when NumberOfEngines was last changed.
Public property | OnGround | Gets or sets a value indicating that the vehicle is reporting itself as being on the ground.
Public property | OnGroundChanged | Gets the DataVersion that was current when OnGround was last changed.
Public property | Operator | Gets or sets the name of the company or individual that is operating the aircraft.
Public property | OperatorChanged | Gets the DataVersion that was current when Operator was last changed.
Public property | OperatorIcao | Gets or sets the ICAO code for the aircraft's operator.
Public property | OperatorIcaoChanged | Gets the DataVersion that was current when OperatorIcao was last changed.
Public property | Origin | Gets or sets a description of the airport where the aircraft's journey began.
Public property | OriginChanged | Gets the DataVersion that was current when Origin was last changed.
Public property | PictureFileName | Gets or sets the full path and filename of the aircraft's picture or null if the aircraft has no picture.
Public property | PictureFileNameChanged | Gets the DataVersion that was current when PictureFileName was last changed.
Public property | PictureHeight | Gets or sets the height of the picture in pixels. This will be 0 if the aircraft has no picture.
Public property | PictureHeightChanged | Gets the DataVersion that was current when PictureHeight was last changed.
Public property | PictureWidth | Gets or sets the width of the picture in pixels. This will be 0 if the aircraft has no picture.
Public property | PictureWidthChanged | Gets the DataVersion that was current when PictureWidth was last changed.
Public property | PositionIsMlat | Gets or sets a value indicating that the position was calculated by an MLAT server, or came off an MLAT feed.
Public property | PositionIsMlatChanged | Gets the DataVersion that was current when PositionIsMlat last changed.
Public property | PositionReceiverId | Gets or sets the ID of the receiver that supplied the last position for the aircraft.
Public property | PositionReceiverIdChanged | Gets the UTC date and time that PositionReceiverId last changed.
Public property | PositionTime | Gets the UTC date and time that Latitude and Longitude were last changed.
Public property | PositionTimeChanged | Gets the DataVersion that was current when PositionTime was last changed.
Public property | ReceiverId | Gets or sets the ID of the last receiver to provide a message for this aircraft. Only varies when the aircraft is being fed messages from a merged feed.
Public property | ReceiverIdChanged | Gets the DataVersion that was current when ReceiverId was last changed.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | RegistrationChanged | Gets the DataVersion that was current when Registration was last changed.
Public property | ShortCoordinates | The list of coordinates representing the short track of the aircraft, the locations reported by it for the past so-many seconds.
Public property | SignalLevel | Gets or sets the signal level of the last message applied to the aircraft. This is null if the receiver wasn't passing along signal levels.
Public property | SignalLevelChanged | Gets the DataVersion that was current when SignalLevel was last changed.
Public property | Species | Gets or sets the type of aircraft as recorded in ICAO 8643.
Public property | SpeciesChanged | Gets the DataVersion that was current when Species was last changed.
Public property | SpeedType | Gets or sets the type of speed being transmitted by the aircraft.
Public property | SpeedTypeChanged |
Public property | Squawk | Gets or sets the squawk code transmitted by the aircraft.
Public property | SquawkChanged | Gets the DataVersion that was current when Squawk was last changed.
Public property | Stopovers | Gets or sets a list of scheduled stops for the aircraft.
Public property | StopoversChanged | Gets or sets the DataVersion that was current when Stopovers was last changed.
Public property | TargetAltitude | Gets or sets the altitude (in feet) that the aircraft's autopilot / FMS etc. is set to.
Public property | TargetAltitudeChanged | Gets the DataVersion that was current when TargetAltitude was last changed.
Public property | TargetTrack | Gets or sets the track or heading on the aircraft's autopilot / FMS etc.
Public property | TargetTrackChanged | Gets the DataVersion that was current when TargetTrack was last changed.
Public property | Track | Gets or sets the last reported heading over the ground of the aircraft. If the aircraft is not reporting its track (see IsTransmittingTrack) then the code will calculate one for it. This is in degrees clockwise.
Public property | TrackChanged | Gets the DataVersion that was current when Track was last changed.
Public property | TrackIsHeading | Gets or sets a value indicating that the Track is the heading of the aircraft. If this is false then Track is the ground track, which is the default.
Public property | TrackIsHeadingChanged | Gets the DataVersion that was current when TrackIsHeading was last changed.
Public property | TransponderType | Gets or sets the transponder type used by the aircraft.
Public property | TransponderTypeChanged | Gets the DataVersion that was current when TransponderType was last changed.
Public property | Type | Gets or sets the ICAO8643 type code for the aircraft.
Public property | TypeChanged | Gets the DataVersion that was current when Type was last changed.
Public property | UniqueId | Gets or sets the unique identifier of the aircraft.
Public property | UserTag | Gets the UserTag from the aircraft's database record.
Public property | UserTagChanged | Gets the DataVersion that was current when UserTag was last changed.
Public property | VerticalRate | Gets or sets the last reported rate of ascent or descent (-ve) of the aircraft in feet per minute.
Public property | VerticalRateChanged | Gets the DataVersion that was current when VerticalRate was last changed.
Public property | VerticalRateType | Gets or sets the type of vertical rate being transmitted by the aircraft.
Public property | VerticalRateTypeChanged |
Public property | WakeTurbulenceCategory | Gets or sets the ICAO 8643 ATC wake turbulence category for this type of aircraft.
Public property | WakeTurbulenceCategoryChanged | Gets the DataVersion that was current when WakeTurbulenceCategory was last changed.
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured as a string (it's a string in BaseStation.sqb).
Public property | YearBuiltChanged | Gets the DataVersion that was current when YearBuilt was last changed.
Top
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.AirPressureInHg Property

IAircraftAirPressureInHg Property
Gets or sets the pressure setting for the aircraft. This will be null if air pressure downloads are switched off, or the server is unavailable, or no air pressures have been downloaded yet.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<float> AirPressureInHg { get; set; }
Property AirPressureInHg As Nullable(Of Single)
    Get
    Set
property Nullable<float> AirPressureInHg {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
abstract AirPressureInHg : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.AirPressureInHgChanged Property

IAircraftAirPressureInHgChanged Property
Gets the DataVersion that was current when AirPressureInHg was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AirPressureInHgChanged { get; }
ReadOnly Property AirPressureInHgChanged As Long
    Get
property long long AirPressureInHgChanged {
    long long get ();
}
abstract AirPressureInHgChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.AirPressureLookedUpUtc Property

IAircraftAirPressureLookedUpUtc Property
Gets or sets the time that the air pressure setting was looked up.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<DateTime> AirPressureLookedUpUtc { get; set; }
Property AirPressureLookedUpUtc As Nullable(Of DateTime)
    Get
    Set
property Nullable<DateTime> AirPressureLookedUpUtc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
abstract AirPressureLookedUpUtc : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Altitude Property

IAircraftAltitude Property
Gets or sets the pressure altitde (in feet) that the aircraft last reported. If the aircraft is transmitting geometric altitude and the air pressure is known then this will be the calculated pressure altitude.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> Altitude { get; set; }
Property Altitude As Nullable(Of Integer)
    Get
    Set
property Nullable<int> Altitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract Altitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.AltitudeChanged Property

IAircraftAltitudeChanged Property
Gets the DataVersion that was current when Altitude was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AltitudeChanged { get; }
ReadOnly Property AltitudeChanged As Long
    Get
property long long AltitudeChanged {
    long long get ();
}
abstract AltitudeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.AltitudeType Property

IAircraftAltitudeType Property
Gets or sets the type of altitude being transmitted by the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AltitudeType AltitudeType { get; set; }
Property AltitudeType As AltitudeType
    Get
    Set
property AltitudeType AltitudeType {
    AltitudeType get ();
    void set (AltitudeType value);
}
abstract AltitudeType : AltitudeType with get, set

Property Value

Type: AltitudeType
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.AltitudeTypeChanged Property

IAircraftAltitudeTypeChanged Property
Gets the DataVersion that was current when AltitudeType was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AltitudeTypeChanged { get; set; }
Property AltitudeTypeChanged As Long
    Get
    Set
property long long AltitudeTypeChanged {
    long long get ();
    void set (long long value);
}
abstract AltitudeTypeChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Callsign Property

IAircraftCallsign Property
Gets or sets the ATC callsign of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Callsign { get; set; }
Property Callsign As String
    Get
    Set
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
abstract Callsign : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.CallsignChanged Property

IAircraftCallsignChanged Property
Gets the DataVersion that was current when Callsign was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CallsignChanged { get; }
ReadOnly Property CallsignChanged As Long
    Get
property long long CallsignChanged {
    long long get ();
}
abstract CallsignChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.CallsignIsSuspect Property

IAircraftCallsignIsSuspect Property
Gets or sets a value indicating that the callsign came from a possible BDS2,0 message instead of an ADS-B message.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CallsignIsSuspect { get; set; }
Property CallsignIsSuspect As Boolean
    Get
    Set
property bool CallsignIsSuspect {
    bool get ();
    void set (bool value);
}
abstract CallsignIsSuspect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.CallsignIsSuspectChanged Property

IAircraftCallsignIsSuspectChanged Property
Gets the DataVersion that was current when CallsignIsSuspect was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CallsignIsSuspectChanged { get; set; }
Property CallsignIsSuspectChanged As Long
    Get
    Set
property long long CallsignIsSuspectChanged {
    long long get ();
    void set (long long value);
}
abstract CallsignIsSuspectChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ConstructionNumber Property

IAircraftConstructionNumber Property
Gets or sets the construction number assigned to the aircraft by the manufacturer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConstructionNumber { get; set; }
Property ConstructionNumber As String
    Get
    Set
property String^ ConstructionNumber {
    String^ get ();
    void set (String^ value);
}
abstract ConstructionNumber : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ConstructionNumberChanged Property

IAircraftConstructionNumberChanged Property
Gets the DataVersion that was current when ConstructionNumber was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ConstructionNumberChanged { get; }
ReadOnly Property ConstructionNumberChanged As Long
    Get
property long long ConstructionNumberChanged {
    long long get ();
}
abstract ConstructionNumberChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.CountMessagesReceived Property

IAircraftCountMessagesReceived Property
Gets or sets the number of messages received for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CountMessagesReceived { get; set; }
Property CountMessagesReceived As Long
    Get
    Set
property long long CountMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract CountMessagesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.CountMessagesReceivedChanged Property

IAircraftCountMessagesReceivedChanged Property
Gets the DataVersion that was current when CountMessagesReceived was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CountMessagesReceivedChanged { get; }
ReadOnly Property CountMessagesReceivedChanged As Long
    Get
property long long CountMessagesReceivedChanged {
    long long get ();
}
abstract CountMessagesReceivedChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.DataVersion Property

IAircraftDataVersion Property
Gets or sets a value indicating when the data was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long DataVersion { get; set; }
Property DataVersion As Long
    Get
    Set
property long long DataVersion {
    long long get ();
    void set (long long value);
}
abstract DataVersion : int64 with get, set

Property Value

Type: Int64
Remarks
This is set to a counter that is incremented when a message is received. The latest value of the counter is sent to browsers with the aircraft list, and they send that value back when they later ask for an update to the aircraft list. Each property is marked with the DataVersion current as-at the time they were last changed. By comparing the browser's last-known DataVersion against those that the properties have been marked with the code can determine which properties need to be sent to the browser in an update.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Destination Property

IAircraftDestination Property
Gets or sets a description of the airport where the aircraft's journey is scheduled to end.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Destination { get; set; }
Property Destination As String
    Get
    Set
property String^ Destination {
    String^ get ();
    void set (String^ value);
}
abstract Destination : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.DestinationChanged Property

IAircraftDestinationChanged Property
Gets the DataVersion that was current when Destination was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long DestinationChanged { get; }
ReadOnly Property DestinationChanged As Long
    Get
property long long DestinationChanged {
    long long get ();
}
abstract DestinationChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Emergency Property

IAircraftEmergency Property
Gets or sets a value indicating that the Squawk represents an emergency code.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<bool> Emergency { get; set; }
Property Emergency As Nullable(Of Boolean)
    Get
    Set
property Nullable<bool> Emergency {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
abstract Emergency : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.EmergencyChanged Property

IAircraftEmergencyChanged Property
Gets the DataVersion that was current when Emergency was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long EmergencyChanged { get; }
ReadOnly Property EmergencyChanged As Long
    Get
property long long EmergencyChanged {
    long long get ();
}
abstract EmergencyChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.EnginePlacement Property

IAircraftEnginePlacement Property
Gets or sets an indication of where the engines are mounted on the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
EnginePlacement EnginePlacement { get; set; }
Property EnginePlacement As EnginePlacement
    Get
    Set
property EnginePlacement EnginePlacement {
    EnginePlacement get ();
    void set (EnginePlacement value);
}
abstract EnginePlacement : EnginePlacement with get, set

Property Value

Type: EnginePlacement
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.EnginePlacementChanged Property

IAircraftEnginePlacementChanged Property
Gets the DataVersion that was current when EnginePlacement was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long EnginePlacementChanged { get; }
ReadOnly Property EnginePlacementChanged As Long
    Get
property long long EnginePlacementChanged {
    long long get ();
}
abstract EnginePlacementChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.EngineType Property

IAircraftEngineType Property
Gets or sets the ICAO 8643 engine type for this type of aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
EngineType EngineType { get; set; }
Property EngineType As EngineType
    Get
    Set
property EngineType EngineType {
    EngineType get ();
    void set (EngineType value);
}
abstract EngineType : EngineType with get, set

Property Value

Type: EngineType
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.EngineTypeChanged Property

IAircraftEngineTypeChanged Property
Gets the DataVersion that was current when EngineType was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long EngineTypeChanged { get; }
ReadOnly Property EngineTypeChanged As Long
    Get
property long long EngineTypeChanged {
    long long get ();
}
abstract EngineTypeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.FirstCoordinateChanged Property

IAircraftFirstCoordinateChanged Property
Gets or sets the DataVersion that was current when the coordinates were first started for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long FirstCoordinateChanged { get; set; }
Property FirstCoordinateChanged As Long
    Get
    Set
property long long FirstCoordinateChanged {
    long long get ();
    void set (long long value);
}
abstract FirstCoordinateChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.FirstSeen Property

IAircraftFirstSeen Property
Gets or sets the time that a message from the aircraft was first received in this session.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime FirstSeen { get; set; }
Property FirstSeen As DateTime
    Get
    Set
property DateTime FirstSeen {
    DateTime get ();
    void set (DateTime value);
}
abstract FirstSeen : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.FirstSeenChanged Property

IAircraftFirstSeenChanged Property
Gets the DataVersion that was current when FirstSeen was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long FirstSeenChanged { get; }
ReadOnly Property FirstSeenChanged As Long
    Get
property long long FirstSeenChanged {
    long long get ();
}
abstract FirstSeenChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.FlightsCount Property

IAircraftFlightsCount Property
Gets the number of flights that the aircraft has logged for it in the BaseStation database.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int FlightsCount { get; set; }
Property FlightsCount As Integer
    Get
    Set
property int FlightsCount {
    int get ();
    void set (int value);
}
abstract FlightsCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.FlightsCountChanged Property

IAircraftFlightsCountChanged Property
Gets the DataVersion that was current when FlightsCount was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long FlightsCountChanged { get; set; }
Property FlightsCountChanged As Long
    Get
    Set
property long long FlightsCountChanged {
    long long get ();
    void set (long long value);
}
abstract FlightsCountChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.FullCoordinates Property

IAircraftFullCoordinates Property
The list of coordinates representing the full track of the aircraft, from when it was first seen until now.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<Coordinate> FullCoordinates { get; }
ReadOnly Property FullCoordinates As List(Of Coordinate)
    Get
property List<Coordinate^>^ FullCoordinates {
    List<Coordinate^>^ get ();
}
abstract FullCoordinates : List<Coordinate> with get

Property Value

Type: List Coordinate
Remarks
Coordinates are only added to this list when the aircraft changes direction but there is no limit to the number of coordinates held for the aircraft.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.GeometricAltitude Property

IAircraftGeometricAltitude Property
Gets or sets the geometric altitude, i.e. how far the aircraft is above sea level. If the aircraft is transmitting barometric altitudes and the air pressure is known then this is the calculated geometric altitude.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> GeometricAltitude { get; set; }
Property GeometricAltitude As Nullable(Of Integer)
    Get
    Set
property Nullable<int> GeometricAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract GeometricAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.GeometricAltitudeChanged Property

IAircraftGeometricAltitudeChanged Property
Gets the DataVersion that was current when GeometricAltitude was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long GeometricAltitudeChanged { get; }
ReadOnly Property GeometricAltitudeChanged As Long
    Get
property long long GeometricAltitudeChanged {
    long long get ();
}
abstract GeometricAltitudeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.GroundSpeed Property

IAircraftGroundSpeed Property
Gets or sets the speed (in knots) that the aircraft last reported.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<float> GroundSpeed { get; set; }
Property GroundSpeed As Nullable(Of Single)
    Get
    Set
property Nullable<float> GroundSpeed {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
abstract GroundSpeed : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.GroundSpeedChanged Property

IAircraftGroundSpeedChanged Property
Gets the DataVersion that was current when GroundSpeed was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long GroundSpeedChanged { get; }
ReadOnly Property GroundSpeedChanged As Long
    Get
property long long GroundSpeedChanged {
    long long get ();
}
abstract GroundSpeedChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Icao24 Property

IAircraftIcao24 Property
Gets or sets the aircraft's ICAO identifier.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Icao24 { get; set; }
Property Icao24 As String
    Get
    Set
property String^ Icao24 {
    String^ get ();
    void set (String^ value);
}
abstract Icao24 : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Icao24Changed Property

IAircraftIcao24Changed Property
Gets the DataVersion that was current when Icao24 was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long Icao24Changed { get; }
ReadOnly Property Icao24Changed As Long
    Get
property long long Icao24Changed {
    long long get ();
}
abstract Icao24Changed : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Icao24Country Property

IAircraftIcao24Country Property
Gets or sets the country that the aircraft's ICAO24 is assigned to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Icao24Country { get; set; }
Property Icao24Country As String
    Get
    Set
property String^ Icao24Country {
    String^ get ();
    void set (String^ value);
}
abstract Icao24Country : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Icao24CountryChanged Property

IAircraftIcao24CountryChanged Property
Gets the DataVersion that was current when Icao24Country was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long Icao24CountryChanged { get; }
ReadOnly Property Icao24CountryChanged As Long
    Get
property long long Icao24CountryChanged {
    long long get ();
}
abstract Icao24CountryChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Icao24Invalid Property

IAircraftIcao24Invalid Property
Gets or sets a value indicating that the Icao24 identifier does not comply with ICAO rules or is known to be a duplicate of another aircraft's ICAO.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Icao24Invalid { get; set; }
Property Icao24Invalid As Boolean
    Get
    Set
property bool Icao24Invalid {
    bool get ();
    void set (bool value);
}
abstract Icao24Invalid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Icao24InvalidChanged Property

IAircraftIcao24InvalidChanged Property
Gets the DataVersion that was current when Icao24Invalid was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long Icao24InvalidChanged { get; }
ReadOnly Property Icao24InvalidChanged As Long
    Get
property long long Icao24InvalidChanged {
    long long get ();
}
abstract Icao24InvalidChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IcaoCompliantRegistration Property

IAircraftIcaoCompliantRegistration Property
Gets the Registration with non-compliant characters stripped out.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string IcaoCompliantRegistration { get; }
ReadOnly Property IcaoCompliantRegistration As String
    Get
property String^ IcaoCompliantRegistration {
    String^ get ();
}
abstract IcaoCompliantRegistration : string with get

Property Value

Type: String
Remarks
It transpires that some people record non-compliant characters in the database Registration field for the aircraft. This removes all non-compliant characters so that only those permitted by annex 7 of the Convention on International Civil Aviation remain.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsInteresting Property

IAircraftIsInteresting Property
Gets or sets a value indicating that the aircraft is flagged as interesting in BaseStation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsInteresting { get; set; }
Property IsInteresting As Boolean
    Get
    Set
property bool IsInteresting {
    bool get ();
    void set (bool value);
}
abstract IsInteresting : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsInterestingChanged Property

IAircraftIsInterestingChanged Property
Gets the DataVersion that was current when IsInteresting was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long IsInterestingChanged { get; set; }
Property IsInterestingChanged As Long
    Get
    Set
property long long IsInterestingChanged {
    long long get ();
    void set (long long value);
}
abstract IsInterestingChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsMilitary Property

IAircraftIsMilitary Property
Gets or sets a value indicating that the aircraft is probably a military aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMilitary { get; set; }
Property IsMilitary As Boolean
    Get
    Set
property bool IsMilitary {
    bool get ();
    void set (bool value);
}
abstract IsMilitary : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsMilitaryChanged Property

IAircraftIsMilitaryChanged Property
Gets the DataVersion that was current when IsMilitary was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long IsMilitaryChanged { get; }
ReadOnly Property IsMilitaryChanged As Long
    Get
property long long IsMilitaryChanged {
    long long get ();
}
abstract IsMilitaryChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsTisb Property

IAircraftIsTisb Property
Gets or sets a value indicating that the last message received for the aircraft came from a TIS-B source.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsTisb { get; set; }
Property IsTisb As Boolean
    Get
    Set
property bool IsTisb {
    bool get ();
    void set (bool value);
}
abstract IsTisb : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsTisbChanged Property

IAircraftIsTisbChanged Property
Gets the DataVersion that was current when IsTisb last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long IsTisbChanged { get; }
ReadOnly Property IsTisbChanged As Long
    Get
property long long IsTisbChanged {
    long long get ();
}
abstract IsTisbChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.IsTransmittingTrack Property

IAircraftIsTransmittingTrack Property
Gets or sets a value indicating that the aircraft is transmitting its track, or at least that BaseStation is reporting one for it.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsTransmittingTrack { get; set; }
Property IsTransmittingTrack As Boolean
    Get
    Set
property bool IsTransmittingTrack {
    bool get ();
    void set (bool value);
}
abstract IsTransmittingTrack : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LastCoordinateChanged Property

IAircraftLastCoordinateChanged Property
Gets or sets the DataVersion that was current when the last coordinate was added for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long LastCoordinateChanged { get; set; }
Property LastCoordinateChanged As Long
    Get
    Set
property long long LastCoordinateChanged {
    long long get ();
    void set (long long value);
}
abstract LastCoordinateChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LastModeSUpdate Property

IAircraftLastModeSUpdate Property
Gets or sets the time of the last message received from a Mode-S feed for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime LastModeSUpdate { get; set; }
Property LastModeSUpdate As DateTime
    Get
    Set
property DateTime LastModeSUpdate {
    DateTime get ();
    void set (DateTime value);
}
abstract LastModeSUpdate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LastSatcomUpdate Property

IAircraftLastSatcomUpdate Property
Gets or sets the time of the last message received from a SatCom feed for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime LastSatcomUpdate { get; set; }
Property LastSatcomUpdate As DateTime
    Get
    Set
property DateTime LastSatcomUpdate {
    DateTime get ();
    void set (DateTime value);
}
abstract LastSatcomUpdate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LastUpdate Property

IAircraftLastUpdate Property
Gets or sets the time of the last message received from the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime LastUpdate { get; set; }
Property LastUpdate As DateTime
    Get
    Set
property DateTime LastUpdate {
    DateTime get ();
    void set (DateTime value);
}
abstract LastUpdate : DateTime with get, set

Property Value

Type: DateTime
Remarks
This is always set regardless of the type of feed that the aircraft message came in on.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LatestCoordinateTime Property

IAircraftLatestCoordinateTime Property
Gets or sets the time of the latest coordinate on the lists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime LatestCoordinateTime { get; set; }
Property LatestCoordinateTime As DateTime
    Get
    Set
property DateTime LatestCoordinateTime {
    DateTime get ();
    void set (DateTime value);
}
abstract LatestCoordinateTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Latitude Property

IAircraftLatitude Property
Gets the last reported latitude of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<double> Latitude { get; set; }
Property Latitude As Nullable(Of Double)
    Get
    Set
property Nullable<double> Latitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
abstract Latitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LatitudeChanged Property

IAircraftLatitudeChanged Property
Gets the DataVersion that was current when Latitude was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long LatitudeChanged { get; }
ReadOnly Property LatitudeChanged As Long
    Get
property long long LatitudeChanged {
    long long get ();
}
abstract LatitudeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Longitude Property

IAircraftLongitude Property
Gets the last reported longitude of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<double> Longitude { get; set; }
Property Longitude As Nullable(Of Double)
    Get
    Set
property Nullable<double> Longitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
abstract Longitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.LongitudeChanged Property

IAircraftLongitudeChanged Property
Gets the DataVersion that was current when Longitude was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long LongitudeChanged { get; }
ReadOnly Property LongitudeChanged As Long
    Get
property long long LongitudeChanged {
    long long get ();
}
abstract LongitudeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Manufacturer Property

IAircraftManufacturer Property
Gets or sets the name of the aircraft's maker.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Manufacturer { get; set; }
Property Manufacturer As String
    Get
    Set
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
abstract Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ManufacturerChanged Property

IAircraftManufacturerChanged Property
Gets the DataVersion that was current when Manufacturer was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ManufacturerChanged { get; }
ReadOnly Property ManufacturerChanged As Long
    Get
property long long ManufacturerChanged {
    long long get ();
}
abstract ManufacturerChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Model Property

IAircraftModel Property
Gets or sets a description of the model of the aircraft, as assigned by the manufacturer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Model { get; set; }
Property Model As String
    Get
    Set
property String^ Model {
    String^ get ();
    void set (String^ value);
}
abstract Model : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ModelChanged Property

IAircraftModelChanged Property
Gets the DataVersion that was current when Model was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModelChanged { get; }
ReadOnly Property ModelChanged As Long
    Get
property long long ModelChanged {
    long long get ();
}
abstract ModelChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.NumberOfEngines Property

IAircraftNumberOfEngines Property
Gets or sets the number of engines as per ICAO 8643. Note that this 'number' can include the value C...

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string NumberOfEngines { get; set; }
Property NumberOfEngines As String
    Get
    Set
property String^ NumberOfEngines {
    String^ get ();
    void set (String^ value);
}
abstract NumberOfEngines : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.NumberOfEnginesChanged Property

IAircraftNumberOfEnginesChanged Property
Gets the DataVersion that was current when NumberOfEngines was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long NumberOfEnginesChanged { get; }
ReadOnly Property NumberOfEnginesChanged As Long
    Get
property long long NumberOfEnginesChanged {
    long long get ();
}
abstract NumberOfEnginesChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.OnGround Property

IAircraftOnGround Property
Gets or sets a value indicating that the vehicle is reporting itself as being on the ground.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<bool> OnGround { get; set; }
Property OnGround As Nullable(Of Boolean)
    Get
    Set
property Nullable<bool> OnGround {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
abstract OnGround : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.OnGroundChanged Property

IAircraftOnGroundChanged Property
Gets the DataVersion that was current when OnGround was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long OnGroundChanged { get; set; }
Property OnGroundChanged As Long
    Get
    Set
property long long OnGroundChanged {
    long long get ();
    void set (long long value);
}
abstract OnGroundChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Operator Property

IAircraftOperator Property
Gets or sets the name of the company or individual that is operating the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Operator { get; set; }
Property Operator As String
    Get
    Set
property String^ Operator {
    String^ get ();
    void set (String^ value);
}
abstract Operator : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.OperatorChanged Property

IAircraftOperatorChanged Property
Gets the DataVersion that was current when Operator was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long OperatorChanged { get; }
ReadOnly Property OperatorChanged As Long
    Get
property long long OperatorChanged {
    long long get ();
}
abstract OperatorChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.OperatorIcao Property

IAircraftOperatorIcao Property
Gets or sets the ICAO code for the aircraft's operator.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string OperatorIcao { get; set; }
Property OperatorIcao As String
    Get
    Set
property String^ OperatorIcao {
    String^ get ();
    void set (String^ value);
}
abstract OperatorIcao : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.OperatorIcaoChanged Property

IAircraftOperatorIcaoChanged Property
Gets the DataVersion that was current when OperatorIcao was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long OperatorIcaoChanged { get; }
ReadOnly Property OperatorIcaoChanged As Long
    Get
property long long OperatorIcaoChanged {
    long long get ();
}
abstract OperatorIcaoChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Origin Property

IAircraftOrigin Property
Gets or sets a description of the airport where the aircraft's journey began.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Origin { get; set; }
Property Origin As String
    Get
    Set
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
abstract Origin : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.OriginChanged Property

IAircraftOriginChanged Property
Gets the DataVersion that was current when Origin was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long OriginChanged { get; }
ReadOnly Property OriginChanged As Long
    Get
property long long OriginChanged {
    long long get ();
}
abstract OriginChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PictureFileName Property

IAircraftPictureFileName Property
Gets or sets the full path and filename of the aircraft's picture or null if the aircraft has no picture.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string PictureFileName { get; set; }
Property PictureFileName As String
    Get
    Set
property String^ PictureFileName {
    String^ get ();
    void set (String^ value);
}
abstract PictureFileName : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PictureFileNameChanged Property

IAircraftPictureFileNameChanged Property
Gets the DataVersion that was current when PictureFileName was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PictureFileNameChanged { get; }
ReadOnly Property PictureFileNameChanged As Long
    Get
property long long PictureFileNameChanged {
    long long get ();
}
abstract PictureFileNameChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PictureHeight Property

IAircraftPictureHeight Property
Gets or sets the height of the picture in pixels. This will be 0 if the aircraft has no picture.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int PictureHeight { get; set; }
Property PictureHeight As Integer
    Get
    Set
property int PictureHeight {
    int get ();
    void set (int value);
}
abstract PictureHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PictureHeightChanged Property

IAircraftPictureHeightChanged Property
Gets the DataVersion that was current when PictureHeight was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PictureHeightChanged { get; }
ReadOnly Property PictureHeightChanged As Long
    Get
property long long PictureHeightChanged {
    long long get ();
}
abstract PictureHeightChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PictureWidth Property

IAircraftPictureWidth Property
Gets or sets the width of the picture in pixels. This will be 0 if the aircraft has no picture.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int PictureWidth { get; set; }
Property PictureWidth As Integer
    Get
    Set
property int PictureWidth {
    int get ();
    void set (int value);
}
abstract PictureWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PictureWidthChanged Property

IAircraftPictureWidthChanged Property
Gets the DataVersion that was current when PictureWidth was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PictureWidthChanged { get; }
ReadOnly Property PictureWidthChanged As Long
    Get
property long long PictureWidthChanged {
    long long get ();
}
abstract PictureWidthChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PositionIsMlat Property

IAircraftPositionIsMlat Property
Gets or sets a value indicating that the position was calculated by an MLAT server, or came off an MLAT feed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<bool> PositionIsMlat { get; set; }
Property PositionIsMlat As Nullable(Of Boolean)
    Get
    Set
property Nullable<bool> PositionIsMlat {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
abstract PositionIsMlat : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PositionIsMlatChanged Property

IAircraftPositionIsMlatChanged Property
Gets the DataVersion that was current when PositionIsMlat last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PositionIsMlatChanged { get; }
ReadOnly Property PositionIsMlatChanged As Long
    Get
property long long PositionIsMlatChanged {
    long long get ();
}
abstract PositionIsMlatChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PositionReceiverId Property

IAircraftPositionReceiverId Property
Gets or sets the ID of the receiver that supplied the last position for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> PositionReceiverId { get; set; }
Property PositionReceiverId As Nullable(Of Integer)
    Get
    Set
property Nullable<int> PositionReceiverId {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract PositionReceiverId : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PositionReceiverIdChanged Property

IAircraftPositionReceiverIdChanged Property
Gets the UTC date and time that PositionReceiverId last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PositionReceiverIdChanged { get; }
ReadOnly Property PositionReceiverIdChanged As Long
    Get
property long long PositionReceiverIdChanged {
    long long get ();
}
abstract PositionReceiverIdChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PositionTime Property

IAircraftPositionTime Property
Gets the UTC date and time that Latitude and Longitude were last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<DateTime> PositionTime { get; set; }
Property PositionTime As Nullable(Of DateTime)
    Get
    Set
property Nullable<DateTime> PositionTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
abstract PositionTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.PositionTimeChanged Property

IAircraftPositionTimeChanged Property
Gets the DataVersion that was current when PositionTime was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PositionTimeChanged { get; }
ReadOnly Property PositionTimeChanged As Long
    Get
property long long PositionTimeChanged {
    long long get ();
}
abstract PositionTimeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ReceiverId Property

IAircraftReceiverId Property
Gets or sets the ID of the last receiver to provide a message for this aircraft. Only varies when the aircraft is being fed messages from a merged feed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int ReceiverId { get; set; }
Property ReceiverId As Integer
    Get
    Set
property int ReceiverId {
    int get ();
    void set (int value);
}
abstract ReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ReceiverIdChanged Property

IAircraftReceiverIdChanged Property
Gets the DataVersion that was current when ReceiverId was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ReceiverIdChanged { get; }
ReadOnly Property ReceiverIdChanged As Long
    Get
property long long ReceiverIdChanged {
    long long get ();
}
abstract ReceiverIdChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Registration Property

IAircraftRegistration Property
Gets or sets the aircraft's registration.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Registration { get; set; }
Property Registration As String
    Get
    Set
property String^ Registration {
    String^ get ();
    void set (String^ value);
}
abstract Registration : string with get, set

Property Value

Type: String
Remarks
This is whatever is recorded in the database for the registration and may contain non-compliant characters.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.RegistrationChanged Property

IAircraftRegistrationChanged Property
Gets the DataVersion that was current when Registration was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long RegistrationChanged { get; }
ReadOnly Property RegistrationChanged As Long
    Get
property long long RegistrationChanged {
    long long get ();
}
abstract RegistrationChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ShortCoordinates Property

IAircraftShortCoordinates Property
The list of coordinates representing the short track of the aircraft, the locations reported by it for the past so-many seconds.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<Coordinate> ShortCoordinates { get; }
ReadOnly Property ShortCoordinates As List(Of Coordinate)
    Get
property List<Coordinate^>^ ShortCoordinates {
    List<Coordinate^>^ get ();
}
abstract ShortCoordinates : List<Coordinate> with get

Property Value

Type: List Coordinate
Remarks
Coordinates are perpetually added to this list irrespective of the direction the aircraft is taking but coordinates older than the configuration value for the short trail duration are removed as snapshots are taken of the aircraft, or as new coordinates are added.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.SignalLevel Property

IAircraftSignalLevel Property
Gets or sets the signal level of the last message applied to the aircraft. This is null if the receiver wasn't passing along signal levels.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> SignalLevel { get; set; }
Property SignalLevel As Nullable(Of Integer)
    Get
    Set
property Nullable<int> SignalLevel {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract SignalLevel : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.SignalLevelChanged Property

IAircraftSignalLevelChanged Property
Gets the DataVersion that was current when SignalLevel was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long SignalLevelChanged { get; }
ReadOnly Property SignalLevelChanged As Long
    Get
property long long SignalLevelChanged {
    long long get ();
}
abstract SignalLevelChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Species Property

IAircraftSpecies Property
Gets or sets the type of aircraft as recorded in ICAO 8643.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Species Species { get; set; }
Property Species As Species
    Get
    Set
property Species Species {
    Species get ();
    void set (Species value);
}
abstract Species : Species with get, set

Property Value

Type: Species
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.SpeciesChanged Property

IAircraftSpeciesChanged Property
Gets the DataVersion that was current when Species was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long SpeciesChanged { get; }
ReadOnly Property SpeciesChanged As Long
    Get
property long long SpeciesChanged {
    long long get ();
}
abstract SpeciesChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.SpeedType Property

IAircraftSpeedType Property
Gets or sets the type of speed being transmitted by the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SpeedType SpeedType { get; set; }
Property SpeedType As SpeedType
    Get
    Set
property SpeedType SpeedType {
    SpeedType get ();
    void set (SpeedType value);
}
abstract SpeedType : SpeedType with get, set

Property Value

Type: SpeedType
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.SpeedTypeChanged Property

IAircraftSpeedTypeChanged Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.IAircraft.SpeedTypeChanged"]

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long SpeedTypeChanged { get; set; }
Property SpeedTypeChanged As Long
    Get
    Set
property long long SpeedTypeChanged {
    long long get ();
    void set (long long value);
}
abstract SpeedTypeChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Squawk Property

IAircraftSquawk Property
Gets or sets the squawk code transmitted by the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> Squawk { get; set; }
Property Squawk As Nullable(Of Integer)
    Get
    Set
property Nullable<int> Squawk {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract Squawk : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.SquawkChanged Property

IAircraftSquawkChanged Property
Gets the DataVersion that was current when Squawk was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long SquawkChanged { get; }
ReadOnly Property SquawkChanged As Long
    Get
property long long SquawkChanged {
    long long get ();
}
abstract SquawkChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Stopovers Property

IAircraftStopovers Property
Gets or sets a list of scheduled stops for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ICollection<string> Stopovers { get; }
ReadOnly Property Stopovers As ICollection(Of String)
    Get
property ICollection<String^>^ Stopovers {
    ICollection<String^>^ get ();
}
abstract Stopovers : ICollection<string> with get

Property Value

Type: ICollection String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.StopoversChanged Property

IAircraftStopoversChanged Property
Gets or sets the DataVersion that was current when Stopovers was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long StopoversChanged { get; set; }
Property StopoversChanged As Long
    Get
    Set
property long long StopoversChanged {
    long long get ();
    void set (long long value);
}
abstract StopoversChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TargetAltitude Property

IAircraftTargetAltitude Property
Gets or sets the altitude (in feet) that the aircraft's autopilot / FMS etc. is set to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> TargetAltitude { get; set; }
Property TargetAltitude As Nullable(Of Integer)
    Get
    Set
property Nullable<int> TargetAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract TargetAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TargetAltitudeChanged Property

IAircraftTargetAltitudeChanged Property
Gets the DataVersion that was current when TargetAltitude was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TargetAltitudeChanged { get; }
ReadOnly Property TargetAltitudeChanged As Long
    Get
property long long TargetAltitudeChanged {
    long long get ();
}
abstract TargetAltitudeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TargetTrack Property

IAircraftTargetTrack Property
Gets or sets the track or heading on the aircraft's autopilot / FMS etc.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<float> TargetTrack { get; set; }
Property TargetTrack As Nullable(Of Single)
    Get
    Set
property Nullable<float> TargetTrack {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
abstract TargetTrack : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TargetTrackChanged Property

IAircraftTargetTrackChanged Property
Gets the DataVersion that was current when TargetTrack was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TargetTrackChanged { get; }
ReadOnly Property TargetTrackChanged As Long
    Get
property long long TargetTrackChanged {
    long long get ();
}
abstract TargetTrackChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Track Property

IAircraftTrack Property
Gets or sets the last reported heading over the ground of the aircraft. If the aircraft is not reporting its track (see IsTransmittingTrack) then the code will calculate one for it. This is in degrees clockwise.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<float> Track { get; set; }
Property Track As Nullable(Of Single)
    Get
    Set
property Nullable<float> Track {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
abstract Track : Nullable<float32> with get, set

Property Value

Type: Nullable Single
Remarks
Tracks are not calculated until the aircraft has moved a small distance.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TrackChanged Property

IAircraftTrackChanged Property
Gets the DataVersion that was current when Track was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TrackChanged { get; }
ReadOnly Property TrackChanged As Long
    Get
property long long TrackChanged {
    long long get ();
}
abstract TrackChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TrackIsHeading Property

IAircraftTrackIsHeading Property
Gets or sets a value indicating that the Track is the heading of the aircraft. If this is false then Track is the ground track, which is the default.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TrackIsHeading { get; set; }
Property TrackIsHeading As Boolean
    Get
    Set
property bool TrackIsHeading {
    bool get ();
    void set (bool value);
}
abstract TrackIsHeading : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TrackIsHeadingChanged Property

IAircraftTrackIsHeadingChanged Property
Gets the DataVersion that was current when TrackIsHeading was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TrackIsHeadingChanged { get; }
ReadOnly Property TrackIsHeadingChanged As Long
    Get
property long long TrackIsHeadingChanged {
    long long get ();
}
abstract TrackIsHeadingChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TransponderType Property

IAircraftTransponderType Property
Gets or sets the transponder type used by the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TransponderType TransponderType { get; set; }
Property TransponderType As TransponderType
    Get
    Set
property TransponderType TransponderType {
    TransponderType get ();
    void set (TransponderType value);
}
abstract TransponderType : TransponderType with get, set

Property Value

Type: TransponderType
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TransponderTypeChanged Property

IAircraftTransponderTypeChanged Property
Gets the DataVersion that was current when TransponderType was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TransponderTypeChanged { get; }
ReadOnly Property TransponderTypeChanged As Long
    Get
property long long TransponderTypeChanged {
    long long get ();
}
abstract TransponderTypeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.Type Property

IAircraftType Property
Gets or sets the ICAO8643 type code for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Type { get; set; }
Property Type As String
    Get
    Set
property String^ Type {
    String^ get ();
    void set (String^ value);
}
abstract Type : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.TypeChanged Property

IAircraftTypeChanged Property
Gets the DataVersion that was current when Type was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TypeChanged { get; }
ReadOnly Property TypeChanged As Long
    Get
property long long TypeChanged {
    long long get ();
}
abstract TypeChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.UniqueId Property

IAircraftUniqueId Property
Gets or sets the unique identifier of the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int UniqueId { get; set; }
Property UniqueId As Integer
    Get
    Set
property int UniqueId {
    int get ();
    void set (int value);
}
abstract UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.UserTag Property

IAircraftUserTag Property
Gets the UserTag from the aircraft's database record.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserTag { get; set; }
Property UserTag As String
    Get
    Set
property String^ UserTag {
    String^ get ();
    void set (String^ value);
}
abstract UserTag : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.UserTagChanged Property

IAircraftUserTagChanged Property
Gets the DataVersion that was current when UserTag was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long UserTagChanged { get; set; }
Property UserTagChanged As Long
    Get
    Set
property long long UserTagChanged {
    long long get ();
    void set (long long value);
}
abstract UserTagChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.VerticalRate Property

IAircraftVerticalRate Property
Gets or sets the last reported rate of ascent or descent (-ve) of the aircraft in feet per minute.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> VerticalRate { get; set; }
Property VerticalRate As Nullable(Of Integer)
    Get
    Set
property Nullable<int> VerticalRate {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
abstract VerticalRate : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.VerticalRateChanged Property

IAircraftVerticalRateChanged Property
Gets the DataVersion that was current when VerticalRate was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long VerticalRateChanged { get; }
ReadOnly Property VerticalRateChanged As Long
    Get
property long long VerticalRateChanged {
    long long get ();
}
abstract VerticalRateChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.VerticalRateType Property

IAircraftVerticalRateType Property
Gets or sets the type of vertical rate being transmitted by the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AltitudeType VerticalRateType { get; set; }
Property VerticalRateType As AltitudeType
    Get
    Set
property AltitudeType VerticalRateType {
    AltitudeType get ();
    void set (AltitudeType value);
}
abstract VerticalRateType : AltitudeType with get, set

Property Value

Type: AltitudeType
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.VerticalRateTypeChanged Property

IAircraftVerticalRateTypeChanged Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.IAircraft.VerticalRateTypeChanged"]

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long VerticalRateTypeChanged { get; set; }
Property VerticalRateTypeChanged As Long
    Get
    Set
property long long VerticalRateTypeChanged {
    long long get ();
    void set (long long value);
}
abstract VerticalRateTypeChanged : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.WakeTurbulenceCategory Property

IAircraftWakeTurbulenceCategory Property
Gets or sets the ICAO 8643 ATC wake turbulence category for this type of aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
WakeTurbulenceCategory WakeTurbulenceCategory { get; set; }
Property WakeTurbulenceCategory As WakeTurbulenceCategory
    Get
    Set
property WakeTurbulenceCategory WakeTurbulenceCategory {
    WakeTurbulenceCategory get ();
    void set (WakeTurbulenceCategory value);
}
abstract WakeTurbulenceCategory : WakeTurbulenceCategory with get, set

Property Value

Type: WakeTurbulenceCategory
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.WakeTurbulenceCategoryChanged Property

IAircraftWakeTurbulenceCategoryChanged Property
Gets the DataVersion that was current when WakeTurbulenceCategory was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long WakeTurbulenceCategoryChanged { get; }
ReadOnly Property WakeTurbulenceCategoryChanged As Long
    Get
property long long WakeTurbulenceCategoryChanged {
    long long get ();
}
abstract WakeTurbulenceCategoryChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.YearBuilt Property

IAircraftYearBuilt Property
Gets or sets the year the aircraft was manufactured as a string (it's a string in BaseStation.sqb).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string YearBuilt { get; set; }
Property YearBuilt As String
    Get
    Set
property String^ YearBuilt {
    String^ get ();
    void set (String^ value);
}
abstract YearBuilt : string with get, set

Property Value

Type: String
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.YearBuiltChanged Property

IAircraftYearBuiltChanged Property
Gets the DataVersion that was current when YearBuilt was last changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long YearBuiltChanged { get; }
ReadOnly Property YearBuiltChanged As Long
    Get
property long long YearBuiltChanged {
    long long get ();
}
abstract YearBuiltChanged : int64 with get

Property Value

Type: Int64
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft Methods

IAircraft Methods

The IAircraft type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | ResetCoordinates | Removes all coordinates from the aircraft's coordinates lists.
Public method | UpdateCoordinates | Updates the FullCoordinates and ShortCoordinates lists using the current values on the aircraft.
Top
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.ResetCoordinates Method

IAircraftResetCoordinates Method
Removes all coordinates from the aircraft's coordinates lists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCoordinates()
Sub ResetCoordinates
void ResetCoordinates()
abstract ResetCoordinates : unit -> unit
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraft.UpdateCoordinates Method

IAircraftUpdateCoordinates Method
Updates the FullCoordinates and ShortCoordinates lists using the current values on the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateCoordinates(
    DateTime utcNow,
    int shortCoordinateSeconds
)
Sub UpdateCoordinates (
    utcNow As DateTime,
    shortCoordinateSeconds As Integer
)
void UpdateCoordinates(
    DateTime utcNow,
    int shortCoordinateSeconds
)
abstract UpdateCoordinates :
        utcNow : DateTime *
        shortCoordinateSeconds : int -> unit

Parameters

utcNow
Type: SystemDateTime
The UTC time at which the message was processed.
shortCoordinateSeconds
Type: SystemInt32
The number of seconds of short coordinates that are to be maintained. This normally comes from configurations - I don't want to have every aircraft in a 500 aircraft system called when configurations are changed so the responsibility for passing the correct value is shifted to higher up the chain.
Remarks
This is not entirely straight-forward - duplicate points are not written to the lists, the short list has to be kept to a configured number of seconds and intermediate coordinates between two points in the full list are expunged. Further updates less than a second after the last coordinate in the lists are dropped. This is all done in an effort to keep the lists down to a reasonable length.
See Also

Reference

IAircraft Interface
VirtualRadar.Interface Namespace


IAircraftComparer Interface

IAircraftComparer Interface
The interface for objects that can compare two IAircraft for relative sort order.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftComparer : IComparer<IAircraft>
Public Interface IAircraftComparer
    Inherits IComparer(Of IAircraft)
public interface class IAircraftComparer : IComparer<IAircraft^>
type IAircraftComparer =
    interface
        interface IComparer<IAircraft>
    end

The IAircraftComparer type exposes the following members.

Properties
 | Name | Description
Public property | BrowserLocation | Gets or sets the location of the browser, if known.
Public property | PrecalculatedDistances | Gets an optional map of unique aircraft identifiers to their distance from the browser location in kilometres.
Public property | SortBy | Gets a list of key-value pairs where the key is the column to sort by (see AircraftComparerColumn) and the value is a bool indicating whether the sort is ascending (true) or descending (false).
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from IComparer IAircraft .)
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftComparer Properties

IAircraftComparer Properties

The IAircraftComparer type exposes the following members.

Properties
 | Name | Description
Public property | BrowserLocation | Gets or sets the location of the browser, if known.
Public property | PrecalculatedDistances | Gets an optional map of unique aircraft identifiers to their distance from the browser location in kilometres.
Public property | SortBy | Gets a list of key-value pairs where the key is the column to sort by (see AircraftComparerColumn) and the value is a bool indicating whether the sort is ascending (true) or descending (false).
Top
See Also

Reference

IAircraftComparer Interface
VirtualRadar.Interface Namespace


IAircraftComparer.BrowserLocation Property

IAircraftComparerBrowserLocation Property
Gets or sets the location of the browser, if known.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Coordinate BrowserLocation { get; set; }
Property BrowserLocation As Coordinate
    Get
    Set
property Coordinate^ BrowserLocation {
    Coordinate^ get ();
    void set (Coordinate^ value);
}
abstract BrowserLocation : Coordinate with get, set

Property Value

Type: Coordinate
See Also

Reference

IAircraftComparer Interface
VirtualRadar.Interface Namespace


IAircraftComparer.PrecalculatedDistances Property

IAircraftComparerPrecalculatedDistances Property
Gets an optional map of unique aircraft identifiers to their distance from the browser location in kilometres.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<int, Nullable<double>> PrecalculatedDistances { get; }
ReadOnly Property PrecalculatedDistances As IDictionary(Of Integer, Nullable(Of Double))
    Get
property IDictionary<int, Nullable<double>>^ PrecalculatedDistances {
    IDictionary<int, Nullable<double>>^ get ();
}
abstract PrecalculatedDistances : IDictionary<int, Nullable<float>> with get

Property Value

Type: IDictionary Int32, Nullable Double
Remarks
Calculating distances can be expensive. If an aircraft has an entry in this dictionary then it saves the comparer from having to perform the calculation repeatedly for an aircraft.
See Also

Reference

IAircraftComparer Interface
VirtualRadar.Interface Namespace


IAircraftComparer.SortBy Property

IAircraftComparerSortBy Property
Gets a list of key-value pairs where the key is the column to sort by (see AircraftComparerColumn) and the value is a bool indicating whether the sort is ascending (true) or descending (false).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<KeyValuePair<string, bool>> SortBy { get; }
ReadOnly Property SortBy As IList(Of KeyValuePair(Of String, Boolean))
    Get
property IList<KeyValuePair<String^, bool>>^ SortBy {
    IList<KeyValuePair<String^, bool>>^ get ();
}
abstract SortBy : IList<KeyValuePair<string, bool>> with get

Property Value

Type: IList KeyValuePair String, Boolean
See Also

Reference

IAircraftComparer Interface
VirtualRadar.Interface Namespace


IAircraftComparer Methods

IAircraftComparer Methods

The IAircraftComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from IComparer IAircraft .)
Top
See Also

Reference

IAircraftComparer Interface
VirtualRadar.Interface Namespace


IAircraftDetailFetcher Interface

IAircraftDetailFetcher Interface
The interface for a singleton class that periodically fetches all aircraft details from the database.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftDetailFetcher : ISingleton<IAircraftDetailFetcher>
Public Interface IAircraftDetailFetcher
    Inherits ISingleton(Of IAircraftDetailFetcher)
public interface class IAircraftDetailFetcher : ISingleton<IAircraftDetailFetcher^>
type IAircraftDetailFetcher =
    interface
        interface ISingleton<IAircraftDetailFetcher>
    end

The IAircraftDetailFetcher type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | RegisterAircraft | Registers an aircraft as being tracked.
Top
Events
 | Name | Description
Public event | Fetched | Raised when new aircraft details have been fetched for an aircraft.
Top
Remarks

Each aircraft list should call RegisterAircraft(IAircraft) whenever it gets a message from an aircraft. The call will always return quickly, it never triggers a direct interrogation of the database. If no register calls are made within a certain period of time the aircraft is no longer monitored for detail changes.

If an event handler raises an exception then it will be logged and it will not be shown to the user. Event handlers should avoid throwing exceptions.

See Also

Reference

VirtualRadar.Interface Namespace


IAircraftDetailFetcher Properties

IAircraftDetailFetcher Properties

The IAircraftDetailFetcher type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAircraftDetailFetcher Interface
VirtualRadar.Interface Namespace


IAircraftDetailFetcher Methods

IAircraftDetailFetcher Methods

The IAircraftDetailFetcher type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAircraft | Registers an aircraft as being tracked.
Top
See Also

Reference

IAircraftDetailFetcher Interface
VirtualRadar.Interface Namespace


IAircraftDetailFetcher.RegisterAircraft Method

IAircraftDetailFetcherRegisterAircraft Method
Registers an aircraft as being tracked.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftDetail RegisterAircraft(
    IAircraft aircraft
)
Function RegisterAircraft (
    aircraft As IAircraft
) As AircraftDetail
AircraftDetail^ RegisterAircraft(
    IAircraft^ aircraft
)
abstract RegisterAircraft :
        aircraft : IAircraft -> AircraftDetail

Parameters

aircraft
Type: VirtualRadar.InterfaceIAircraft

Return Value

Type: AircraftDetail
The aircraft details if they're already known, or null if this is the first time the aircraft has been added or the aircraft is known to have no details recorded on the database.
Remarks

Each aircraft list should call this function to keep the aircraft monitored for database changes. If the fetcher does not receive a RegisterAircraft call within a couple of minutes then it stops monitoring the aircraft's database record.

If the aircraft has already been registered and its database details never change then objects that make further calls to RegisterAircraft for the aircraft will not see events raised for it. These objects must assume that the return value represents the correct database details for the aircraft.

See Also

Reference

IAircraftDetailFetcher Interface
VirtualRadar.Interface Namespace


IAircraftDetailFetcher Events

IAircraftDetailFetcher Events

The IAircraftDetailFetcher type exposes the following members.

Events
 | Name | Description
Public event | Fetched | Raised when new aircraft details have been fetched for an aircraft.
Top
See Also

Reference

IAircraftDetailFetcher Interface
VirtualRadar.Interface Namespace


IAircraftDetailFetcher.Fetched Event

IAircraftDetailFetcherFetched Event
Raised when new aircraft details have been fetched for an aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<AircraftDetail>> Fetched
Event Fetched As EventHandler(Of EventArgs(Of AircraftDetail))
 event EventHandler<EventArgs<AircraftDetail^>^>^ Fetched {
    void add (EventHandler<EventArgs<AircraftDetail^>^>^ value);
    void remove (EventHandler<EventArgs<AircraftDetail^>^>^ value);
}
abstract Fetched : IEvent<EventHandler<EventArgs<AircraftDetail>>,
    EventArgs<AircraftDetail>>

Value

Type: SystemEventHandler EventArgs AircraftDetail
Remarks
Note that many aircraft lists may be registering aircraft with the fetcher and all of those aircraft can trigger events. Do not assume that only the aircraft that you registered will have events raised for it.
See Also

Reference

IAircraftDetailFetcher Interface
VirtualRadar.Interface Namespace


IAircraftList Interface

IAircraftList Interface
The interface for objects that can collect together information from the messages transmitted by aircraft, and lookups in various data sources, to maintain a list of aircraft and their current state.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftList : IBackgroundThreadExceptionCatcher,
    IDisposable
Public Interface IAircraftList
    Inherits IBackgroundThreadExceptionCatcher, IDisposable
public interface class IAircraftList : IBackgroundThreadExceptionCatcher,
    IDisposable
type IAircraftList =
    interface
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IAircraftList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the total number of aircraft currently being tracked.
Public property | IsTracking | Gets a value indicating that the aircraft list is tracking aircraft.
Public property | Source | Gets a value indicating where the aircraft messages are coming from.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindAircraft | Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft.
Public method | Start | Starts the tracking of aircraft.
Public method | Stop | Stops tracking aircraft.
Public method | TakeSnapshot | Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft.
Top
Events
 | Name | Description
Public event | CountChanged | Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | TrackingStateChanged | Raised when the aircraft list is started or stopped. Could be raised from any thread.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftList Properties

IAircraftList Properties

The IAircraftList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the total number of aircraft currently being tracked.
Public property | IsTracking | Gets a value indicating that the aircraft list is tracking aircraft.
Public property | Source | Gets a value indicating where the aircraft messages are coming from.
Top
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.Count Property

IAircraftListCount Property
Gets the total number of aircraft currently being tracked.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.IsTracking Property

IAircraftListIsTracking Property
Gets a value indicating that the aircraft list is tracking aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsTracking { get; }
ReadOnly Property IsTracking As Boolean
    Get
property bool IsTracking {
    bool get ();
}
abstract IsTracking : bool with get

Property Value

Type: Boolean
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.Source Property

IAircraftListSource Property
Gets a value indicating where the aircraft messages are coming from.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftListSource Source { get; }
ReadOnly Property Source As AircraftListSource
    Get
property AircraftListSource Source {
    AircraftListSource get ();
}
abstract Source : AircraftListSource with get

Property Value

Type: AircraftListSource
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList Methods

IAircraftList Methods

The IAircraftList type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindAircraft | Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft.
Public method | Start | Starts the tracking of aircraft.
Public method | Stop | Stops tracking aircraft.
Public method | TakeSnapshot | Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft.
Top
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.FindAircraft Method

IAircraftListFindAircraft Method
Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IAircraft FindAircraft(
    int uniqueId
)
Function FindAircraft (
    uniqueId As Integer
) As IAircraft
IAircraft^ FindAircraft(
    int uniqueId
)
abstract FindAircraft :
        uniqueId : int -> IAircraft

Parameters

uniqueId
Type: SystemInt32

Return Value

Type: IAircraft
Remarks
Implementations should return a clone of the aircraft object whose properties will remain constant even if the original IAircraft continues to be updated to keep track with the source of aircraft data.
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.Start Method

IAircraftListStart Method
Starts the tracking of aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.Stop Method

IAircraftListStop Method
Stops tracking aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.TakeSnapshot Method

IAircraftListTakeSnapshot Method
Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<IAircraft> TakeSnapshot(
    out long snapshotTimeStamp,
    out long snapshotDataVersion
)
Function TakeSnapshot (
    <OutAttribute> ByRef snapshotTimeStamp As Long,
    <OutAttribute> ByRef snapshotDataVersion As Long
) As List(Of IAircraft)
List<IAircraft^>^ TakeSnapshot(
    [OutAttribute] long long% snapshotTimeStamp,
    [OutAttribute] long long% snapshotDataVersion
)
abstract TakeSnapshot :
        snapshotTimeStamp : int64 byref *
        snapshotDataVersion : int64 byref -> List<IAircraft>

Parameters

snapshotTimeStamp
Type: SystemInt64
snapshotDataVersion
Type: SystemInt64

Return Value

Type: List IAircraft
Remarks
Implementations should return clones of the aircraft objects whose properties will remain constant even if the original IAircraft continues to be updated to keep track with the source of aircraft data.
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList Events

IAircraftList Events

The IAircraftList type exposes the following members.

Events
 | Name | Description
Public event | CountChanged | Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | TrackingStateChanged | Raised when the aircraft list is started or stopped. Could be raised from any thread.
Top
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.CountChanged Event

IAircraftListCountChanged Event
Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CountChanged
Event CountChanged As EventHandler
 event EventHandler^ CountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CountChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftList.TrackingStateChanged Event

IAircraftListTrackingStateChanged Event
Raised when the aircraft list is started or stopped. Could be raised from any thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler TrackingStateChanged
Event TrackingStateChanged As EventHandler
 event EventHandler^ TrackingStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TrackingStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IAircraftList Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup Interface

IAircraftOnlineLookup Interface
The interface for an object that can batch up lookups of aircraft details from an online source.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookup : ISingleton<IAircraftOnlineLookup>
Public Interface IAircraftOnlineLookup
    Inherits ISingleton(Of IAircraftOnlineLookup)
public interface class IAircraftOnlineLookup : ISingleton<IAircraftOnlineLookup^>
type IAircraftOnlineLookup =
    interface
        interface ISingleton<IAircraftOnlineLookup>
    end

The IAircraftOnlineLookup type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the provider that will perform lookups for us.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | InitialiseProvider | Initialises the provider if it has not already been initialised.
Public method | Lookup | Adds the lookup of the requested ICAO to the next batch to be sent.
Public method | LookupMany | Adds the lookup of multiple ICAOs to the next batch to be sent.
Top
Events
 | Name | Description
Public event | AircraftFetched | Raised when the online source replies with the results of a lookup.
Top
Remarks

Implementations are expected to batch up ICAOs and send them off to an online source for lookup. Once the online source replies they raise AircraftFetched with the results.

Implementations must honour the lookup aircraft details setting (BaseStationSettings.LookupAircraftDetailsOnline).

See Also

Reference

VirtualRadar.Interface Namespace


IAircraftOnlineLookup Properties

IAircraftOnlineLookup Properties

The IAircraftOnlineLookup type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the provider that will perform lookups for us.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup.Provider Property

IAircraftOnlineLookupProvider Property
Gets or sets the provider that will perform lookups for us.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IAircraftOnlineLookupProvider Provider { get; set; }
Property Provider As IAircraftOnlineLookupProvider
    Get
    Set
property IAircraftOnlineLookupProvider^ Provider {
    IAircraftOnlineLookupProvider^ get ();
    void set (IAircraftOnlineLookupProvider^ value);
}
abstract Provider : IAircraftOnlineLookupProvider with get, set

Property Value

Type: IAircraftOnlineLookupProvider
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup Methods

IAircraftOnlineLookup Methods

The IAircraftOnlineLookup type exposes the following members.

Methods
 | Name | Description
Public method | InitialiseProvider | Initialises the provider if it has not already been initialised.
Public method | Lookup | Adds the lookup of the requested ICAO to the next batch to be sent.
Public method | LookupMany | Adds the lookup of multiple ICAOs to the next batch to be sent.
Top
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup.InitialiseProvider Method

IAircraftOnlineLookupInitialiseProvider Method
Initialises the provider if it has not already been initialised.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InitialiseProvider()
Sub InitialiseProvider
void InitialiseProvider()
abstract InitialiseProvider : unit -> unit
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup.Lookup Method

IAircraftOnlineLookupLookup Method
Adds the lookup of the requested ICAO to the next batch to be sent.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Lookup(
    string icao
)
Sub Lookup (
    icao As String
)
void Lookup(
    String^ icao
)
abstract Lookup :
        icao : string -> unit

Parameters

icao
Type: SystemString
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup.LookupMany Method

IAircraftOnlineLookupLookupMany Method
Adds the lookup of multiple ICAOs to the next batch to be sent.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void LookupMany(
    IEnumerable<string> icaos
)
Sub LookupMany (
    icaos As IEnumerable(Of String)
)
void LookupMany(
    IEnumerable<String^>^ icaos
)
abstract LookupMany :
        icaos : IEnumerable<string> -> unit

Parameters

icaos
Type: System.Collections.GenericIEnumerable String
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup Events

IAircraftOnlineLookup Events

The IAircraftOnlineLookup type exposes the following members.

Events
 | Name | Description
Public event | AircraftFetched | Raised when the online source replies with the results of a lookup.
Top
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookup.AircraftFetched Event

IAircraftOnlineLookupAircraftFetched Event
Raised when the online source replies with the results of a lookup.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AircraftOnlineLookupEventArgs> AircraftFetched
Event AircraftFetched As EventHandler(Of AircraftOnlineLookupEventArgs)
 event EventHandler<AircraftOnlineLookupEventArgs^>^ AircraftFetched {
    void add (EventHandler<AircraftOnlineLookupEventArgs^>^ value);
    void remove (EventHandler<AircraftOnlineLookupEventArgs^>^ value);
}
abstract AircraftFetched : IEvent<EventHandler<AircraftOnlineLookupEventArgs>,
    AircraftOnlineLookupEventArgs>

Value

Type: SystemEventHandler AircraftOnlineLookupEventArgs
See Also

Reference

IAircraftOnlineLookup Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache Interface

IAircraftOnlineLookupCache Interface
Caches the results of online aircraft detail lookups.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookupCache
Public Interface IAircraftOnlineLookupCache
public interface class IAircraftOnlineLookupCache
type IAircraftOnlineLookupCache =  interface end

The IAircraftOnlineLookupCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a flag indicating that the cache is enabled.
Public property | RefreshOutOfDateAircraft | Gets a value indicating that the aircraft manager should refresh out-of-date aircraft records as well as missing / new aircraft.
Top
Methods
 | Name | Description
Public method | Load | Fetches an aircraft's details from the cache.
Public method | LoadMany | Loads multiple records from the cache simultaneously.
Public method | RecordManyMissing | Records many missing ICAOs.
Public method | RecordMissing | Records an ICAO that has no online details.
Public method | Save | Saves an aircraft's details in the cache.
Public method | SaveMany | Saves multiple records to the cache simultaneously.
Top
Remarks
Once you have created an instance of your cache you should register it with the singleton instance of the IAircraftOnlineLookupManager. Your cache will not be called until it has been registered.
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache Properties

IAircraftOnlineLookupCache Properties

The IAircraftOnlineLookupCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a flag indicating that the cache is enabled.
Public property | RefreshOutOfDateAircraft | Gets a value indicating that the aircraft manager should refresh out-of-date aircraft records as well as missing / new aircraft.
Top
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.Enabled Property

IAircraftOnlineLookupCacheEnabled Property
Gets a flag indicating that the cache is enabled.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

Property Value

Type: Boolean
Remarks
IAircraftOnlineLookupManager checks this before it asks the cache to do something. However, given the multi-threaded nature of things you might be asked to load or save objects after you have disabled yourself. When this happens your cache should behave graciously, even if it does not honour the request.
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.RefreshOutOfDateAircraft Property

IAircraftOnlineLookupCacheRefreshOutOfDateAircraft Property
Gets a value indicating that the aircraft manager should refresh out-of-date aircraft records as well as missing / new aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RefreshOutOfDateAircraft { get; }
ReadOnly Property RefreshOutOfDateAircraft As Boolean
    Get
property bool RefreshOutOfDateAircraft {
    bool get ();
}
abstract RefreshOutOfDateAircraft : bool with get

Property Value

Type: Boolean
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache Methods

IAircraftOnlineLookupCache Methods

The IAircraftOnlineLookupCache type exposes the following members.

Methods
 | Name | Description
Public method | Load | Fetches an aircraft's details from the cache.
Public method | LoadMany | Loads multiple records from the cache simultaneously.
Public method | RecordManyMissing | Records many missing ICAOs.
Public method | RecordMissing | Records an ICAO that has no online details.
Public method | Save | Saves an aircraft's details in the cache.
Public method | SaveMany | Saves multiple records to the cache simultaneously.
Top
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.Load Method

IAircraftOnlineLookupCacheLoad Method
Fetches an aircraft's details from the cache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftOnlineLookupDetail Load(
    string icao,
    BaseStationAircraft baseStationAircraft,
    bool searchedForBaseStationAircraft
)
Function Load (
    icao As String,
    baseStationAircraft As BaseStationAircraft,
    searchedForBaseStationAircraft As Boolean
) As AircraftOnlineLookupDetail
AircraftOnlineLookupDetail^ Load(
    String^ icao,
    BaseStationAircraft^ baseStationAircraft,
    bool searchedForBaseStationAircraft
)
abstract Load :
        icao : string *
        baseStationAircraft : BaseStationAircraft *
        searchedForBaseStationAircraft : bool -> AircraftOnlineLookupDetail

Parameters

icao
Type: SystemString
The ICAO of the aircraft to lookup.
baseStationAircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
If BaseStation.sqb has been searched for an aircraft then this is the record that was returned, otherwise it's null.
searchedForBaseStationAircraft
Type: SystemBoolean
True if baseStationAircraft is the result of a search on BaseStation.sqb, false if the caller didn't search BaseStation.sqb.

Return Value

Type: AircraftOnlineLookupDetail
Null if there are no details for the ICAO in the cache, otherwise returns the cached details.
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.LoadMany Method

IAircraftOnlineLookupCacheLoadMany Method
Loads multiple records from the cache simultaneously.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Dictionary<string, AircraftOnlineLookupDetail> LoadMany(
    IEnumerable<string> icaos,
    IDictionary<string, BaseStationAircraft> baseStationAircraft
)
Function LoadMany (
    icaos As IEnumerable(Of String),
    baseStationAircraft As IDictionary(Of String, BaseStationAircraft)
) As Dictionary(Of String, AircraftOnlineLookupDetail)
Dictionary<String^, AircraftOnlineLookupDetail^>^ LoadMany(
    IEnumerable<String^>^ icaos,
    IDictionary<String^, BaseStationAircraft^>^ baseStationAircraft
)
abstract LoadMany :
        icaos : IEnumerable<string> *
        baseStationAircraft : IDictionary<string, BaseStationAircraft> -> Dictionary<string, AircraftOnlineLookupDetail>

Parameters

icaos
Type: System.Collections.GenericIEnumerable String
baseStationAircraft
Type: System.Collections.GenericIDictionary String, BaseStationAircraft
If BaseStation.sqb has been searched for an aircraft then these are the records that were returned, indexed by upper-case ICAO. Otherwise it's null.

Return Value

Type: Dictionary String, AircraftOnlineLookupDetail
A dictionary of ICAOs to cached records. If there is no record for a particular ICAO in the cache then the dictionary value for the ICAO is null.
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.RecordManyMissing Method

IAircraftOnlineLookupCacheRecordManyMissing Method
Records many missing ICAOs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordManyMissing(
    IEnumerable<string> icaos
)
Sub RecordManyMissing (
    icaos As IEnumerable(Of String)
)
void RecordManyMissing(
    IEnumerable<String^>^ icaos
)
abstract RecordManyMissing :
        icaos : IEnumerable<string> -> unit

Parameters

icaos
Type: System.Collections.GenericIEnumerable String
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.RecordMissing Method

IAircraftOnlineLookupCacheRecordMissing Method
Records an ICAO that has no online details.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordMissing(
    string icao
)
Sub RecordMissing (
    icao As String
)
void RecordMissing(
    String^ icao
)
abstract RecordMissing :
        icao : string -> unit

Parameters

icao
Type: SystemString
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.Save Method

IAircraftOnlineLookupCacheSave Method
Saves an aircraft's details in the cache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save(
    AircraftOnlineLookupDetail lookupDetail
)
Sub Save (
    lookupDetail As AircraftOnlineLookupDetail
)
void Save(
    AircraftOnlineLookupDetail^ lookupDetail
)
abstract Save :
        lookupDetail : AircraftOnlineLookupDetail -> unit

Parameters

lookupDetail
Type: VirtualRadar.InterfaceAircraftOnlineLookupDetail
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupCache.SaveMany Method

IAircraftOnlineLookupCacheSaveMany Method
Saves multiple records to the cache simultaneously.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveMany(
    IEnumerable<AircraftOnlineLookupDetail> lookupDetails
)
Sub SaveMany (
    lookupDetails As IEnumerable(Of AircraftOnlineLookupDetail)
)
void SaveMany(
    IEnumerable<AircraftOnlineLookupDetail^>^ lookupDetails
)
abstract SaveMany :
        lookupDetails : IEnumerable<AircraftOnlineLookupDetail> -> unit

Parameters

lookupDetails
Type: System.Collections.GenericIEnumerable AircraftOnlineLookupDetail
See Also

Reference

IAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog Interface

IAircraftOnlineLookupLog Interface
Records the online aircraft detail lookup requests and responses over the past so-many minutes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookupLog : ISingleton<IAircraftOnlineLookupLog>,
    IDisposable
Public Interface IAircraftOnlineLookupLog
    Inherits ISingleton(Of IAircraftOnlineLookupLog), IDisposable
public interface class IAircraftOnlineLookupLog : ISingleton<IAircraftOnlineLookupLog^>,
    IDisposable
type IAircraftOnlineLookupLog =
    interface
        interface ISingleton<IAircraftOnlineLookupLog>
        interface IDisposable
    end

The IAircraftOnlineLookupLog type exposes the following members.

Properties
 | Name | Description
Public property | LogLengthMinutes | Gets the number of minutes that the log records responses for.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetResponses | Returns the responses from aircraft online lookups over the past LogLengthMinutes minutes.
Public method | Initialise | Initialises the object.
Top
Events
 | Name | Description
Public event | ResponsesChanged | Raised when the list of responses held by the log changes.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog Properties

IAircraftOnlineLookupLog Properties

The IAircraftOnlineLookupLog type exposes the following members.

Properties
 | Name | Description
Public property | LogLengthMinutes | Gets the number of minutes that the log records responses for.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog.LogLengthMinutes Property

IAircraftOnlineLookupLogLogLengthMinutes Property
Gets the number of minutes that the log records responses for.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int LogLengthMinutes { get; }
ReadOnly Property LogLengthMinutes As Integer
    Get
property int LogLengthMinutes {
    int get ();
}
abstract LogLengthMinutes : int with get

Property Value

Type: Int32
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog Methods

IAircraftOnlineLookupLog Methods

The IAircraftOnlineLookupLog type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetResponses | Returns the responses from aircraft online lookups over the past LogLengthMinutes minutes.
Public method | Initialise | Initialises the object.
Top
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog.GetResponses Method

IAircraftOnlineLookupLogGetResponses Method
Returns the responses from aircraft online lookups over the past LogLengthMinutes minutes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftOnlineLookupLogEntry[] GetResponses()
Function GetResponses As AircraftOnlineLookupLogEntry()
array<AircraftOnlineLookupLogEntry^>^ GetResponses()
abstract GetResponses : unit -> AircraftOnlineLookupLogEntry[]

Return Value

Type: AircraftOnlineLookupLogEntry
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog.Initialise Method

IAircraftOnlineLookupLogInitialise Method
Initialises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog Events

IAircraftOnlineLookupLog Events

The IAircraftOnlineLookupLog type exposes the following members.

Events
 | Name | Description
Public event | ResponsesChanged | Raised when the list of responses held by the log changes.
Top
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupLog.ResponsesChanged Event

IAircraftOnlineLookupLogResponsesChanged Event
Raised when the list of responses held by the log changes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ResponsesChanged
Event ResponsesChanged As EventHandler
 event EventHandler^ ResponsesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResponsesChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IAircraftOnlineLookupLog Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager Interface

IAircraftOnlineLookupManager Interface
Brings together the online lookup and the online lookup cache. If you want something from the online aircraft lookup then talk to this object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookupManager : ISingleton<IAircraftOnlineLookupManager>,
    IDisposable
Public Interface IAircraftOnlineLookupManager
    Inherits ISingleton(Of IAircraftOnlineLookupManager), IDisposable
public interface class IAircraftOnlineLookupManager : ISingleton<IAircraftOnlineLookupManager^>,
    IDisposable
type IAircraftOnlineLookupManager =
    interface
        interface ISingleton<IAircraftOnlineLookupManager>
        interface IDisposable
    end

The IAircraftOnlineLookupManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | DeregisterCache | Removes the cache passed across from the manager. Does nothing if the cache has not been registered.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IsCacheObjectRegistered | Returns true if the cache object passed across has already been registered.
Public method | Lookup | Requests a lookup. The details are either fetched from the cache and returned straight away or they are queued for lookup by the online service and AircraftFetched raised once the results are in.
Public method | LookupMany | Requests the lookup of many ICAOs. All ICAOs that are in the cache are returned immediately, the rest are passed to the online lookup service and returned via the AircraftFetched event.
Public method | RecordNeedsRefresh | Returns true if the details passed across indicate that the aircraft that they belong to needs refreshing.
Public method | RegisterCache | Register a cache with the manager.
Top
Events
 | Name | Description
Public event | AircraftFetched | Raised when aircraft details have been looked up or fetched from the cache.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager Properties

IAircraftOnlineLookupManager Properties

The IAircraftOnlineLookupManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager Methods

IAircraftOnlineLookupManager Methods

The IAircraftOnlineLookupManager type exposes the following members.

Methods
 | Name | Description
Public method | DeregisterCache | Removes the cache passed across from the manager. Does nothing if the cache has not been registered.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IsCacheObjectRegistered | Returns true if the cache object passed across has already been registered.
Public method | Lookup | Requests a lookup. The details are either fetched from the cache and returned straight away or they are queued for lookup by the online service and AircraftFetched raised once the results are in.
Public method | LookupMany | Requests the lookup of many ICAOs. All ICAOs that are in the cache are returned immediately, the rest are passed to the online lookup service and returned via the AircraftFetched event.
Public method | RecordNeedsRefresh | Returns true if the details passed across indicate that the aircraft that they belong to needs refreshing.
Public method | RegisterCache | Register a cache with the manager.
Top
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.DeregisterCache Method

IAircraftOnlineLookupManagerDeregisterCache Method
Removes the cache passed across from the manager. Does nothing if the cache has not been registered.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeregisterCache(
    IAircraftOnlineLookupCache cache
)
Sub DeregisterCache (
    cache As IAircraftOnlineLookupCache
)
void DeregisterCache(
    IAircraftOnlineLookupCache^ cache
)
abstract DeregisterCache :
        cache : IAircraftOnlineLookupCache -> unit

Parameters

cache
Type: VirtualRadar.InterfaceIAircraftOnlineLookupCache
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.IsCacheObjectRegistered Method

IAircraftOnlineLookupManagerIsCacheObjectRegistered Method
Returns true if the cache object passed across has already been registered.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCacheObjectRegistered(
    IAircraftOnlineLookupCache cache
)
Function IsCacheObjectRegistered (
    cache As IAircraftOnlineLookupCache
) As Boolean
bool IsCacheObjectRegistered(
    IAircraftOnlineLookupCache^ cache
)
abstract IsCacheObjectRegistered :
        cache : IAircraftOnlineLookupCache -> bool

Parameters

cache
Type: VirtualRadar.InterfaceIAircraftOnlineLookupCache

Return Value

Type: Boolean
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.Lookup Method

IAircraftOnlineLookupManagerLookup Method
Requests a lookup. The details are either fetched from the cache and returned straight away or they are queued for lookup by the online service and AircraftFetched raised once the results are in.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftOnlineLookupDetail Lookup(
    string icao,
    BaseStationAircraft baseStationAircraft,
    bool searchedForBaseStationAircraft
)
Function Lookup (
    icao As String,
    baseStationAircraft As BaseStationAircraft,
    searchedForBaseStationAircraft As Boolean
) As AircraftOnlineLookupDetail
AircraftOnlineLookupDetail^ Lookup(
    String^ icao,
    BaseStationAircraft^ baseStationAircraft,
    bool searchedForBaseStationAircraft
)
abstract Lookup :
        icao : string *
        baseStationAircraft : BaseStationAircraft *
        searchedForBaseStationAircraft : bool -> AircraftOnlineLookupDetail

Parameters

icao
Type: SystemString
baseStationAircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
Passed through to cache. Not used by the manager.
searchedForBaseStationAircraft
Type: SystemBoolean
Passed through to cache. Not used by the manager.

Return Value

Type: AircraftOnlineLookupDetail
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.LookupMany Method

IAircraftOnlineLookupManagerLookupMany Method
Requests the lookup of many ICAOs. All ICAOs that are in the cache are returned immediately, the rest are passed to the online lookup service and returned via the AircraftFetched event.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Dictionary<string, AircraftOnlineLookupDetail> LookupMany(
    IEnumerable<string> icaos,
    IDictionary<string, BaseStationAircraft> baseStationAircraft
)
Function LookupMany (
    icaos As IEnumerable(Of String),
    baseStationAircraft As IDictionary(Of String, BaseStationAircraft)
) As Dictionary(Of String, AircraftOnlineLookupDetail)
Dictionary<String^, AircraftOnlineLookupDetail^>^ LookupMany(
    IEnumerable<String^>^ icaos,
    IDictionary<String^, BaseStationAircraft^>^ baseStationAircraft
)
abstract LookupMany :
        icaos : IEnumerable<string> *
        baseStationAircraft : IDictionary<string, BaseStationAircraft> -> Dictionary<string, AircraftOnlineLookupDetail>

Parameters

icaos
Type: System.Collections.GenericIEnumerable String
baseStationAircraft
Type: System.Collections.GenericIDictionary String, BaseStationAircraft
Passed through to cache. Not used by the manager.

Return Value

Type: Dictionary String, AircraftOnlineLookupDetail
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.RecordNeedsRefresh Method

IAircraftOnlineLookupManagerRecordNeedsRefresh Method
Returns true if the details passed across indicate that the aircraft that they belong to needs refreshing.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RecordNeedsRefresh(
    string registration,
    string manufacturer,
    string model,
    string operatorName,
    DateTime lastUpdatedUtc
)
Function RecordNeedsRefresh (
    registration As String,
    manufacturer As String,
    model As String,
    operatorName As String,
    lastUpdatedUtc As DateTime
) As Boolean
bool RecordNeedsRefresh(
    String^ registration,
    String^ manufacturer,
    String^ model,
    String^ operatorName,
    DateTime lastUpdatedUtc
)
abstract RecordNeedsRefresh :
        registration : string *
        manufacturer : string *
        model : string *
        operatorName : string *
        lastUpdatedUtc : DateTime -> bool

Parameters

registration
Type: SystemString
manufacturer
Type: SystemString
model
Type: SystemString
operatorName
Type: SystemString
lastUpdatedUtc
Type: SystemDateTime

Return Value

Type: Boolean
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.RegisterCache Method

IAircraftOnlineLookupManagerRegisterCache Method
Register a cache with the manager.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterCache(
    IAircraftOnlineLookupCache cache,
    int priority,
    bool letManagerControlLifetime
)
Sub RegisterCache (
    cache As IAircraftOnlineLookupCache,
    priority As Integer,
    letManagerControlLifetime As Boolean
)
void RegisterCache(
    IAircraftOnlineLookupCache^ cache,
    int priority,
    bool letManagerControlLifetime
)
abstract RegisterCache :
        cache : IAircraftOnlineLookupCache *
        priority : int *
        letManagerControlLifetime : bool -> unit

Parameters

cache
Type: VirtualRadar.InterfaceIAircraftOnlineLookupCache
The cache to register.
priority
Type: SystemInt32
The relative priority of the cache. When the manager wants to save a record in the cache it uses higher value priority caches over lower values.
letManagerControlLifetime
Type: SystemBoolean
True if the manager should dispose of the cache when it shuts down, false if something else is looking after the cache's lifetime. Has no effect if the cache does not implement IDisposable.
Remarks

More than one cache can be registered with the manager. By default VRS registers a standalone cache with a priority of zero. This caches aircraft records in the configuration folder. If the database writer plugin is installed then that also registers a cache, this time with a priority of 100 so that it takes precedence over the standalone cache. This means that BaseStation.sqb is used as a cache in preferance to the standalone cache, but if the user does not enable the caching feature of the database writer (which is off by default) then the manager falls back to the standalone cache.

If you are writing a plugin that supplies a cache, and you want the cache to take precedence over the standard VRS caches, then use a priority that is higher than 100. If you want to only be used when the fallback cache is switched off then use a priority lower than 0.

The priority cannot be changed once the cache has been registered.

letManagerControlLifetime determines whether the Dispose method on the cache is called when the manager shuts down, usually when the program is closing. If the cache does not implement IDisposable then it has no effect.

This call does nothing if the cache has already been registered.

See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager Events

IAircraftOnlineLookupManager Events

The IAircraftOnlineLookupManager type exposes the following members.

Events
 | Name | Description
Public event | AircraftFetched | Raised when aircraft details have been looked up or fetched from the cache.
Top
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupManager.AircraftFetched Event

IAircraftOnlineLookupManagerAircraftFetched Event
Raised when aircraft details have been looked up or fetched from the cache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AircraftOnlineLookupEventArgs> AircraftFetched
Event AircraftFetched As EventHandler(Of AircraftOnlineLookupEventArgs)
 event EventHandler<AircraftOnlineLookupEventArgs^>^ AircraftFetched {
    void add (EventHandler<AircraftOnlineLookupEventArgs^>^ value);
    void remove (EventHandler<AircraftOnlineLookupEventArgs^>^ value);
}
abstract AircraftFetched : IEvent<EventHandler<AircraftOnlineLookupEventArgs>,
    AircraftOnlineLookupEventArgs>

Value

Type: SystemEventHandler AircraftOnlineLookupEventArgs
See Also

Reference

IAircraftOnlineLookupManager Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider Interface

IAircraftOnlineLookupProvider Interface
The interface that online lookup provider can implement to change where IAircraftOnlineLookup goes to fetch aircraft details.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookupProvider
Public Interface IAircraftOnlineLookupProvider
public interface class IAircraftOnlineLookupProvider
type IAircraftOnlineLookupProvider =  interface end

The IAircraftOnlineLookupProvider type exposes the following members.

Properties
 | Name | Description
Public property | DataSupplier | Gets a short name for the supplier of aircraft data being used by the provider.
Public property | MaxBatchSize | Gets the largest batch size that the online service can accept.
Public property | MaxSecondsAfterFailedRequest | Gets the maximum number of seconds to wait between failed requests. After each request the lookup waits for an extra MinSecondsBetweenRequests until this limit is reached.
Public property | MinSecondsBetweenRequests | Gets the minimum number of seconds between requests. Do not set this to less than one. This restriction is policed by the code.
Public property | SupplierCredits | Gets a longer string crediting the supplier of aircraft data being used by the provider.
Public property | SupplierWebSiteUrl | Gets the URL of the data supplier's web site.
Top
Methods
 | Name | Description
Public method | DoLookup | Periodically called to fetch aircraft details from the online service.
Public method | InitialiseSupplierDetails | Called when the program wants to know the data supplier details.
Top
Remarks
Do not do anything in the constructor that will take a long time.
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider Properties

IAircraftOnlineLookupProvider Properties

The IAircraftOnlineLookupProvider type exposes the following members.

Properties
 | Name | Description
Public property | DataSupplier | Gets a short name for the supplier of aircraft data being used by the provider.
Public property | MaxBatchSize | Gets the largest batch size that the online service can accept.
Public property | MaxSecondsAfterFailedRequest | Gets the maximum number of seconds to wait between failed requests. After each request the lookup waits for an extra MinSecondsBetweenRequests until this limit is reached.
Public property | MinSecondsBetweenRequests | Gets the minimum number of seconds between requests. Do not set this to less than one. This restriction is policed by the code.
Public property | SupplierCredits | Gets a longer string crediting the supplier of aircraft data being used by the provider.
Public property | SupplierWebSiteUrl | Gets the URL of the data supplier's web site.
Top
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.DataSupplier Property

IAircraftOnlineLookupProviderDataSupplier Property
Gets a short name for the supplier of aircraft data being used by the provider.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DataSupplier { get; }
ReadOnly Property DataSupplier As String
    Get
property String^ DataSupplier {
    String^ get ();
}
abstract DataSupplier : string with get

Property Value

Type: String
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.MaxBatchSize Property

IAircraftOnlineLookupProviderMaxBatchSize Property
Gets the largest batch size that the online service can accept.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxBatchSize { get; }
ReadOnly Property MaxBatchSize As Integer
    Get
property int MaxBatchSize {
    int get ();
}
abstract MaxBatchSize : int with get

Property Value

Type: Int32
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.MaxSecondsAfterFailedRequest Property

IAircraftOnlineLookupProviderMaxSecondsAfterFailedRequest Property
Gets the maximum number of seconds to wait between failed requests. After each request the lookup waits for an extra MinSecondsBetweenRequests until this limit is reached.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxSecondsAfterFailedRequest { get; }
ReadOnly Property MaxSecondsAfterFailedRequest As Integer
    Get
property int MaxSecondsAfterFailedRequest {
    int get ();
}
abstract MaxSecondsAfterFailedRequest : int with get

Property Value

Type: Int32
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.MinSecondsBetweenRequests Property

IAircraftOnlineLookupProviderMinSecondsBetweenRequests Property
Gets the minimum number of seconds between requests. Do not set this to less than one. This restriction is policed by the code.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MinSecondsBetweenRequests { get; }
ReadOnly Property MinSecondsBetweenRequests As Integer
    Get
property int MinSecondsBetweenRequests {
    int get ();
}
abstract MinSecondsBetweenRequests : int with get

Property Value

Type: Int32
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.SupplierCredits Property

IAircraftOnlineLookupProviderSupplierCredits Property
Gets a longer string crediting the supplier of aircraft data being used by the provider.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string SupplierCredits { get; }
ReadOnly Property SupplierCredits As String
    Get
property String^ SupplierCredits {
    String^ get ();
}
abstract SupplierCredits : string with get

Property Value

Type: String
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.SupplierWebSiteUrl Property

IAircraftOnlineLookupProviderSupplierWebSiteUrl Property
Gets the URL of the data supplier's web site.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string SupplierWebSiteUrl { get; }
ReadOnly Property SupplierWebSiteUrl As String
    Get
property String^ SupplierWebSiteUrl {
    String^ get ();
}
abstract SupplierWebSiteUrl : string with get

Property Value

Type: String
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider Methods

IAircraftOnlineLookupProvider Methods

The IAircraftOnlineLookupProvider type exposes the following members.

Methods
 | Name | Description
Public method | DoLookup | Periodically called to fetch aircraft details from the online service.
Public method | InitialiseSupplierDetails | Called when the program wants to know the data supplier details.
Top
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.DoLookup Method

IAircraftOnlineLookupProviderDoLookup Method
Periodically called to fetch aircraft details from the online service.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DoLookup(
    string[] icaos,
    IList<AircraftOnlineLookupDetail> fetchedAircraft,
    IList<string> missingIcaos
)
Function DoLookup (
    icaos As String(),
    fetchedAircraft As IList(Of AircraftOnlineLookupDetail),
    missingIcaos As IList(Of String)
) As Boolean
bool DoLookup(
    array<String^>^ icaos,
    IList<AircraftOnlineLookupDetail^>^ fetchedAircraft,
    IList<String^>^ missingIcaos
)
abstract DoLookup :
        icaos : string[] *
        fetchedAircraft : IList<AircraftOnlineLookupDetail> *
        missingIcaos : IList<string> -> bool

Parameters

icaos
Type: SystemString
A collection of ICAOs to fetch.
fetchedAircraft
Type: System.Collections.GenericIList AircraftOnlineLookupDetail
Add fetched aircraft records to this list.
missingIcaos
Type: System.Collections.GenericIList String
Add ICAOs for aircraft that definitely do not have details to this list.

Return Value

Type: Boolean
True if the lookup was completed without errors, false if the online source appears to be offline or having some problems. Missing ICAOs are not an error.
Remarks

This will be called on a background thread but two calls will never run simultaneously.

If the method allows web exceptions to bubble up then they will not be logged by the caller, it would spam the log when the user is offline, but any other type of exception will be logged. If the method throws an exception then it is always assumed to have failed, i.e. returned false. Try not to let exceptions bubble out after a successful fetch.

If the online source cannot be reached or it returns an error then return false. Do not fill in either of the lists, that way the ICAOs passed across will be presented later for another try. If you mark an ICAO as missing when it is not then it could have ramifications elsewhere.

See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftOnlineLookupProvider.InitialiseSupplierDetails Method

IAircraftOnlineLookupProviderInitialiseSupplierDetails Method
Called when the program wants to know the data supplier details.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InitialiseSupplierDetails()
Sub InitialiseSupplierDetails
void InitialiseSupplierDetails()
abstract InitialiseSupplierDetails : unit -> unit
See Also

Reference

IAircraftOnlineLookupProvider Interface
VirtualRadar.Interface Namespace


IAircraftPictureManager Interface

IAircraftPictureManager Interface
The interface for an object that can deal with finding pictures of aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftPictureManager : ISingleton<IAircraftPictureManager>
Public Interface IAircraftPictureManager
    Inherits ISingleton(Of IAircraftPictureManager)
public interface class IAircraftPictureManager : ISingleton<IAircraftPictureManager^>
type IAircraftPictureManager =
    interface
        interface ISingleton<IAircraftPictureManager>
    end

The IAircraftPictureManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | FindPicture(IDirectoryCache, String, String) | Returns the full path and dimensions of the picture for the aircraft with the ICAO24 and registration passed across or null if no picture exists for the aircraft.
Public method | FindPicture(IDirectoryCache, String, String, PictureDetail) | If existingDetail is not supplied or the file's last update or length has changed then the picture details are fetched and a new detail is returned. If existingDetail is supplied and neither the last update or length have changed then the existingDetail is returned without loading the picture.
Public method | LoadPicture | Loads the aircraft picture with the ICAO24 and registration passed, returning null if the aircraft has no picture. It is the callers responsibility to dispose of the image returned. Note that the image may or may not have been loaded from a file.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftPictureManager Properties

IAircraftPictureManager Properties

The IAircraftPictureManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAircraftPictureManager Interface
VirtualRadar.Interface Namespace


IAircraftPictureManager Methods

IAircraftPictureManager Methods

The IAircraftPictureManager type exposes the following members.

Methods
 | Name | Description
Public method | FindPicture(IDirectoryCache, String, String) | Returns the full path and dimensions of the picture for the aircraft with the ICAO24 and registration passed across or null if no picture exists for the aircraft.
Public method | FindPicture(IDirectoryCache, String, String, PictureDetail) | If existingDetail is not supplied or the file's last update or length has changed then the picture details are fetched and a new detail is returned. If existingDetail is supplied and neither the last update or length have changed then the existingDetail is returned without loading the picture.
Public method | LoadPicture | Loads the aircraft picture with the ICAO24 and registration passed, returning null if the aircraft has no picture. It is the callers responsibility to dispose of the image returned. Note that the image may or may not have been loaded from a file.
Top
See Also

Reference

IAircraftPictureManager Interface
VirtualRadar.Interface Namespace


IAircraftPictureManager.FindPicture Method

IAircraftPictureManagerFindPicture Method
Overload List
 | Name | Description
Public method | FindPicture(IDirectoryCache, String, String) | Returns the full path and dimensions of the picture for the aircraft with the ICAO24 and registration passed across or null if no picture exists for the aircraft.
Public method | FindPicture(IDirectoryCache, String, String, PictureDetail) | If existingDetail is not supplied or the file's last update or length has changed then the picture details are fetched and a new detail is returned. If existingDetail is supplied and neither the last update or length have changed then the existingDetail is returned without loading the picture.
Top
See Also

Reference

IAircraftPictureManager Interface
VirtualRadar.Interface Namespace


IAircraftPictureManager.FindPicture Method (IDirectoryCache, String, String)

IAircraftPictureManagerFindPicture Method (IDirectoryCache, String, String)
Returns the full path and dimensions of the picture for the aircraft with the ICAO24 and registration passed across or null if no picture exists for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PictureDetail FindPicture(
    IDirectoryCache directoryCache,
    string icao24,
    string registration
)
Function FindPicture (
    directoryCache As IDirectoryCache,
    icao24 As String,
    registration As String
) As PictureDetail
PictureDetail^ FindPicture(
    IDirectoryCache^ directoryCache,
    String^ icao24,
    String^ registration
)
abstract FindPicture :
        directoryCache : IDirectoryCache *
        icao24 : string *
        registration : string -> PictureDetail

Parameters

directoryCache
Type: VirtualRadar.InterfaceIDirectoryCache
The directory cache that will be used to look up filenames. Normally IAutoConfigPictureFolderCache's DirectoryCache.
icao24
Type: SystemString
The ICAO24 code of the aircraft.
registration
Type: SystemString
The registration of the aircraft.

Return Value

Type: PictureDetail
See Also

Reference

IAircraftPictureManager Interface
FindPicture Overload
VirtualRadar.Interface Namespace


IAircraftPictureManager.FindPicture Method (IDirectoryCache, String, String, PictureDetail)

IAircraftPictureManagerFindPicture Method (IDirectoryCache, String, String, PictureDetail)
If existingDetail is not supplied or the file's last update or length has changed then the picture details are fetched and a new detail is returned. If existingDetail is supplied and neither the last update or length have changed then the existingDetail is returned without loading the picture.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PictureDetail FindPicture(
    IDirectoryCache directoryCache,
    string icao24,
    string registration,
    PictureDetail existingDetail
)
Function FindPicture (
    directoryCache As IDirectoryCache,
    icao24 As String,
    registration As String,
    existingDetail As PictureDetail
) As PictureDetail
PictureDetail^ FindPicture(
    IDirectoryCache^ directoryCache,
    String^ icao24,
    String^ registration,
    PictureDetail^ existingDetail
)
abstract FindPicture :
        directoryCache : IDirectoryCache *
        icao24 : string *
        registration : string *
        existingDetail : PictureDetail -> PictureDetail

Parameters

directoryCache
Type: VirtualRadar.InterfaceIDirectoryCache
icao24
Type: SystemString
registration
Type: SystemString
existingDetail
Type: VirtualRadar.InterfacePictureDetail

Return Value

Type: PictureDetail
See Also

Reference

IAircraftPictureManager Interface
FindPicture Overload
VirtualRadar.Interface Namespace


IAircraftPictureManager.LoadPicture Method

IAircraftPictureManagerLoadPicture Method
Loads the aircraft picture with the ICAO24 and registration passed, returning null if the aircraft has no picture. It is the callers responsibility to dispose of the image returned. Note that the image may or may not have been loaded from a file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image LoadPicture(
    IDirectoryCache directoryCache,
    string icao24,
    string registration
)
Function LoadPicture (
    directoryCache As IDirectoryCache,
    icao24 As String,
    registration As String
) As Image
Image^ LoadPicture(
    IDirectoryCache^ directoryCache,
    String^ icao24,
    String^ registration
)
abstract LoadPicture :
        directoryCache : IDirectoryCache *
        icao24 : string *
        registration : string -> Image

Parameters

directoryCache
Type: VirtualRadar.InterfaceIDirectoryCache
icao24
Type: SystemString
registration
Type: SystemString

Return Value

Type: Image
See Also

Reference

IAircraftPictureManager Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker Interface

IAircraftSanityChecker Interface
The interface for objects that test the sanity of position reports and altitudes received for aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftSanityChecker : IDisposable
Public Interface IAircraftSanityChecker
    Inherits IDisposable
public interface class IAircraftSanityChecker : IDisposable
type IAircraftSanityChecker =
    interface
        interface IDisposable
    end

The IAircraftSanityChecker type exposes the following members.

Methods
 | Name | Description
Public method | CheckAltitude | Checks the altitude for an aircraft.
Public method | CheckPosition | Checks the position for an ICAO.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FirstGoodAltitude | Returns the first altitude that appears to be in line with the current altitude recorded for the aircraft.
Public method | FirstGoodPosition | Returns the first position that appears to be in line with the current position recorded for the aircraft.
Public method | IsGoodAircraftIcao | Returns true if the string represents a valid ICAO code.
Public method | ResetAircraft | Resets the sanity checks for the aircraft passed across.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAircraftSanityChecker Methods

IAircraftSanityChecker Methods

The IAircraftSanityChecker type exposes the following members.

Methods
 | Name | Description
Public method | CheckAltitude | Checks the altitude for an aircraft.
Public method | CheckPosition | Checks the position for an ICAO.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FirstGoodAltitude | Returns the first altitude that appears to be in line with the current altitude recorded for the aircraft.
Public method | FirstGoodPosition | Returns the first position that appears to be in line with the current position recorded for the aircraft.
Public method | IsGoodAircraftIcao | Returns true if the string represents a valid ICAO code.
Public method | ResetAircraft | Resets the sanity checks for the aircraft passed across.
Top
See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker.CheckAltitude Method

IAircraftSanityCheckerCheckAltitude Method
Checks the altitude for an aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Certainty CheckAltitude(
    int aircraftId,
    DateTime messageReceived,
    int altitude
)
Function CheckAltitude (
    aircraftId As Integer,
    messageReceived As DateTime,
    altitude As Integer
) As Certainty
Certainty CheckAltitude(
    int aircraftId,
    DateTime messageReceived,
    int altitude
)
abstract CheckAltitude :
        aircraftId : int *
        messageReceived : DateTime *
        altitude : int -> Certainty

Parameters

aircraftId
Type: SystemInt32
The unique identifier of the aircraft.
messageReceived
Type: SystemDateTime
The UTC date and time that the message was received.
altitude
Type: SystemInt32
The altitude in feet.

Return Value

Type: Certainty
A value indicating whether the altitude could be correct.
Remarks

The code needs to build up some history before it can determine whether the aircraft could attain the altitude specified without breaking the laws of physics. The first call for an aircraft will always return Uncertain. If the second altitude is compatible with the first then it will return ProbablyRight, otherwise if at least one of them is wrong then more messages may need to be received until the code can start returning Certainty values of ProbablyRight. Whenever this returns CertainlyWrong you should discard the altitude.

Once this method returns CertainlyWrong it will reset and will not return ProbablyRight until a pair of altitudes have been received that seem to be sane.

See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker.CheckPosition Method

IAircraftSanityCheckerCheckPosition Method
Checks the position for an ICAO.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Certainty CheckPosition(
    int aircraftId,
    DateTime messageReceived,
    double latitude,
    double longitude
)
Function CheckPosition (
    aircraftId As Integer,
    messageReceived As DateTime,
    latitude As Double,
    longitude As Double
) As Certainty
Certainty CheckPosition(
    int aircraftId,
    DateTime messageReceived,
    double latitude,
    double longitude
)
abstract CheckPosition :
        aircraftId : int *
        messageReceived : DateTime *
        latitude : float *
        longitude : float -> Certainty

Parameters

aircraftId
Type: SystemInt32
The unique identifier of the aircraft.
messageReceived
Type: SystemDateTime
The UTC date and time that the message was received.
latitude
Type: SystemDouble
The latitude that the aircraft has reported.
longitude
Type: SystemDouble
The longitude that the aircraft has reported.

Return Value

Type: Certainty
A value indicating whether the position could be correct.
Remarks

The code needs to build up some history before it can determine whether the aircraft could reach the position specified without travelling faster than it can. The first call for an aircraft will always return Uncertain. If the second position is compatible with the first then it will return ProbablyRight, otherwise if at least one of them is wrong then more messages may need to be received until the code can start returning Certainty values of ProbablyRight. Whenever this returns CertainlyWrong you should discard the position.

Once this method returns CertainlyWrong it will reset and will not return ProbablyRight until a pair of positions have been received that seem to be sane.

See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker.FirstGoodAltitude Method

IAircraftSanityCheckerFirstGoodAltitude Method
Returns the first altitude that appears to be in line with the current altitude recorded for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> FirstGoodAltitude(
    int aircraftId
)
Function FirstGoodAltitude (
    aircraftId As Integer
) As Nullable(Of Integer)
Nullable<int> FirstGoodAltitude(
    int aircraftId
)
abstract FirstGoodAltitude :
        aircraftId : int -> Nullable<int>

Parameters

aircraftId
Type: SystemInt32

Return Value

Type: Nullable Int32
The first good altitude seen for the aircraft or null if no good altitude currently exists.
Remarks
The sanity checker maintains a history of altitudes that have been received, up to the point where a call to CheckAltitude(Int32, DateTime, Int32) returns a ProbablyRight result. Once an altitude is probably right you can call this method to get the earliest altitude seen that is probably correct when compared to the latest altitude. If the latest altitude is not ProbablyRight then this method returns null. Once two ProbablyRight altitudes are seen in succession the history will be wiped and the function will return null until the aircraft is removed from the history (which happens after roughly 10 minutes regardless of configuration settings).
See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker.FirstGoodPosition Method

IAircraftSanityCheckerFirstGoodPosition Method
Returns the first position that appears to be in line with the current position recorded for the aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
GlobalCoordinate FirstGoodPosition(
    int aircraftId
)
Function FirstGoodPosition (
    aircraftId As Integer
) As GlobalCoordinate
GlobalCoordinate^ FirstGoodPosition(
    int aircraftId
)
abstract FirstGoodPosition :
        aircraftId : int -> GlobalCoordinate

Parameters

aircraftId
Type: SystemInt32

Return Value

Type: GlobalCoordinate
The first good position seen for the aircraft or null if no good position currently exists.
Remarks
The sanity checker maintains a history of positions that have been received, up to the point where a call to CheckPosition(Int32, DateTime, Double, Double) returns a ProbablyRight result. Once a position is probably right you can call this method to get the earliest position seen that is probably correct when compared to the latest position. If the latest position is not ProbablyRight then this method returns null. Once two ProbablyRight positions are seen in succession the history will be wiped and the function will return null until the aircraft is removed from the history (which happens after roughly 10 minutes regardless of configuration settings).
See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker.IsGoodAircraftIcao Method

IAircraftSanityCheckerIsGoodAircraftIcao Method
Returns true if the string represents a valid ICAO code.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsGoodAircraftIcao(
    string icao
)
Function IsGoodAircraftIcao (
    icao As String
) As Boolean
bool IsGoodAircraftIcao(
    String^ icao
)
abstract IsGoodAircraftIcao :
        icao : string -> bool

Parameters

icao
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAircraftSanityChecker.ResetAircraft Method

IAircraftSanityCheckerResetAircraft Method
Resets the sanity checks for the aircraft passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAircraft(
    int aircraftId
)
Sub ResetAircraft (
    aircraftId As Integer
)
void ResetAircraft(
    int aircraftId
)
abstract ResetAircraft :
        aircraftId : int -> unit

Parameters

aircraftId
Type: SystemInt32
Remarks
This resets the state for the aircraft passed across such that the next sanity check will behave as though the checker had never seen the aircraft before.
See Also

Reference

IAircraftSanityChecker Interface
VirtualRadar.Interface Namespace


IAirportDataDotCom Interface

IAirportDataDotCom Interface
The interface that objects that expose access to the www.airport-data.com API must implement.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAirportDataDotCom
Public Interface IAirportDataDotCom
public interface class IAirportDataDotCom
type IAirportDataDotCom =  interface end

The IAirportDataDotCom type exposes the following members.

Methods
 | Name | Description
Public method | GetThumbnails | Requests thumbnail details for a given aircraft.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAirportDataDotCom Methods

IAirportDataDotCom Methods

The IAirportDataDotCom type exposes the following members.

Methods
 | Name | Description
Public method | GetThumbnails | Requests thumbnail details for a given aircraft.
Top
See Also

Reference

IAirportDataDotCom Interface
VirtualRadar.Interface Namespace


IAirportDataDotCom.GetThumbnails Method

IAirportDataDotComGetThumbnails Method
Requests thumbnail details for a given aircraft.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
WebRequestResult<AirportDataThumbnailsJson> GetThumbnails(
    string icao,
    string registration,
    int maxThumbnails
)
Function GetThumbnails (
    icao As String,
    registration As String,
    maxThumbnails As Integer
) As WebRequestResult(Of AirportDataThumbnailsJson)
WebRequestResult<AirportDataThumbnailsJson^>^ GetThumbnails(
    String^ icao,
    String^ registration,
    int maxThumbnails
)
abstract GetThumbnails :
        icao : string *
        registration : string *
        maxThumbnails : int -> WebRequestResult<AirportDataThumbnailsJson>

Parameters

icao
Type: SystemString
registration
Type: SystemString
maxThumbnails
Type: SystemInt32

Return Value

Type: WebRequestResult AirportDataThumbnailsJson
Remarks
This request blocks until either www.airport-data.com returns or until a timeout has expired.
See Also

Reference

IAirportDataDotCom Interface
VirtualRadar.Interface Namespace


IAirPressureDownloader Interface

IAirPressureDownloader Interface
The interface that objects that download air pressure readings has to implement.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAirPressureDownloader
Public Interface IAirPressureDownloader
public interface class IAirPressureDownloader
type IAirPressureDownloader =  interface end

The IAirPressureDownloader type exposes the following members.

Properties
 | Name | Description
Public property | IntervalMinutes | Gets the interval in minutes that the program should wait between downloads.
Top
Methods
 | Name | Description
Public method | Fetch | Fetches a set of pressure readings.
Top
Remarks
Implementations are not expected to be thread-safe.
See Also

Reference

VirtualRadar.Interface Namespace


IAirPressureDownloader Properties

IAirPressureDownloader Properties

The IAirPressureDownloader type exposes the following members.

Properties
 | Name | Description
Public property | IntervalMinutes | Gets the interval in minutes that the program should wait between downloads.
Top
See Also

Reference

IAirPressureDownloader Interface
VirtualRadar.Interface Namespace


IAirPressureDownloader.IntervalMinutes Property

IAirPressureDownloaderIntervalMinutes Property
Gets the interval in minutes that the program should wait between downloads.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int IntervalMinutes { get; }
ReadOnly Property IntervalMinutes As Integer
    Get
property int IntervalMinutes {
    int get ();
}
abstract IntervalMinutes : int with get

Property Value

Type: Int32
See Also

Reference

IAirPressureDownloader Interface
VirtualRadar.Interface Namespace


IAirPressureDownloader Methods

IAirPressureDownloader Methods

The IAirPressureDownloader type exposes the following members.

Methods
 | Name | Description
Public method | Fetch | Fetches a set of pressure readings.
Top
See Also

Reference

IAirPressureDownloader Interface
VirtualRadar.Interface Namespace


IAirPressureDownloader.Fetch Method

IAirPressureDownloaderFetch Method
Fetches a set of pressure readings.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AirPressure[] Fetch()
Function Fetch As AirPressure()
array<AirPressure^>^ Fetch()
abstract Fetch : unit -> AirPressure[]

Return Value

Type: AirPressure
Remarks

The downloader is expected to allow all exceptions to bubble up to the caller. If an exception is thrown then the next call to fetch can be expected before IntervalMinutes has expired.

See Also

Reference

IAirPressureDownloader Interface
VirtualRadar.Interface Namespace


IAirPressureLookup Interface

IAirPressureLookup Interface
The interface for objects that can take a list of air pressures and from that give you the closest air pressure reading for a point on the surface of the earth.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAirPressureLookup : ISingleton<IAirPressureLookup>
Public Interface IAirPressureLookup
    Inherits ISingleton(Of IAirPressureLookup)
public interface class IAirPressureLookup : ISingleton<IAirPressureLookup^>
type IAirPressureLookup =
    interface
        interface ISingleton<IAirPressureLookup>
    end

The IAirPressureLookup type exposes the following members.

Properties
 | Name | Description
Public property | CountAirPressuresLoaded | Gets the number of AirPressure records loaded.
Public property | FetchTimeUtc | Gets the last fetch time passed to LoadAirPressures(IEnumerableAirPressure, DateTime).
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | FindClosest | Returns the closest air pressure reading to a point on the globe. Can return null if no air pressures have been loaded.
Public method | LoadAirPressures | Erases all previously loaded pressures and stores a new set.
Top
Remarks
Implementations must be thread-safe.
See Also

Reference

VirtualRadar.Interface Namespace


IAirPressureLookup Properties

IAirPressureLookup Properties

The IAirPressureLookup type exposes the following members.

Properties
 | Name | Description
Public property | CountAirPressuresLoaded | Gets the number of AirPressure records loaded.
Public property | FetchTimeUtc | Gets the last fetch time passed to LoadAirPressures(IEnumerableAirPressure, DateTime).
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAirPressureLookup Interface
VirtualRadar.Interface Namespace


IAirPressureLookup.CountAirPressuresLoaded Property

IAirPressureLookupCountAirPressuresLoaded Property
Gets the number of AirPressure records loaded.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int CountAirPressuresLoaded { get; }
ReadOnly Property CountAirPressuresLoaded As Integer
    Get
property int CountAirPressuresLoaded {
    int get ();
}
abstract CountAirPressuresLoaded : int with get

Property Value

Type: Int32
See Also

Reference

IAirPressureLookup Interface
VirtualRadar.Interface Namespace


IAirPressureLookup.FetchTimeUtc Property

IAirPressureLookupFetchTimeUtc Property
Gets the last fetch time passed to LoadAirPressures(IEnumerableAirPressure, DateTime).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime FetchTimeUtc { get; }
ReadOnly Property FetchTimeUtc As DateTime
    Get
property DateTime FetchTimeUtc {
    DateTime get ();
}
abstract FetchTimeUtc : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IAirPressureLookup Interface
VirtualRadar.Interface Namespace


IAirPressureLookup Methods

IAirPressureLookup Methods

The IAirPressureLookup type exposes the following members.

Methods
 | Name | Description
Public method | FindClosest | Returns the closest air pressure reading to a point on the globe. Can return null if no air pressures have been loaded.
Public method | LoadAirPressures | Erases all previously loaded pressures and stores a new set.
Top
See Also

Reference

IAirPressureLookup Interface
VirtualRadar.Interface Namespace


IAirPressureLookup.FindClosest Method

IAirPressureLookupFindClosest Method
Returns the closest air pressure reading to a point on the globe. Can return null if no air pressures have been loaded.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AirPressure FindClosest(
    double latitude,
    double longitude
)
Function FindClosest (
    latitude As Double,
    longitude As Double
) As AirPressure
AirPressure^ FindClosest(
    double latitude,
    double longitude
)
abstract FindClosest :
        latitude : float *
        longitude : float -> AirPressure

Parameters

latitude
Type: SystemDouble
longitude
Type: SystemDouble

Return Value

Type: AirPressure
See Also

Reference

IAirPressureLookup Interface
VirtualRadar.Interface Namespace


IAirPressureLookup.LoadAirPressures Method

IAirPressureLookupLoadAirPressures Method
Erases all previously loaded pressures and stores a new set.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadAirPressures(
    IEnumerable<AirPressure> airPressures,
    DateTime fetchTimeUtc
)
Sub LoadAirPressures (
    airPressures As IEnumerable(Of AirPressure),
    fetchTimeUtc As DateTime
)
void LoadAirPressures(
    IEnumerable<AirPressure^>^ airPressures,
    DateTime fetchTimeUtc
)
abstract LoadAirPressures :
        airPressures : IEnumerable<AirPressure> *
        fetchTimeUtc : DateTime -> unit

Parameters

airPressures
Type: System.Collections.GenericIEnumerable AirPressure
fetchTimeUtc
Type: SystemDateTime
See Also

Reference

IAirPressureLookup Interface
VirtualRadar.Interface Namespace


IAirPressureManager Interface

IAirPressureManager Interface
The interface that objects that manage the downloading of air pressure readings has to implement.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAirPressureManager : ISingleton<IAirPressureManager>
Public Interface IAirPressureManager
    Inherits ISingleton(Of IAirPressureManager)
public interface class IAirPressureManager : ISingleton<IAirPressureManager^>
type IAirPressureManager =
    interface
        interface ISingleton<IAirPressureManager>
    end

The IAirPressureManager type exposes the following members.

Properties
 | Name | Description
Public property | Downloader | Gets the downloader that the manager uses to fetch air pressures.
Public property | Enabled | Gets a value indicating that air pressure downloads are enabled.
Public property | Lookup | Gets the IAirPressureLookup that the manager is populating with downloaded air pressures.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Start | Starts downloading air pressures in the background.
Public method | Stop | Stops downloading air pressures in the background.
Top
Events
 | Name | Description
Public event | DownloadCompleted | Raised when a download of air pressures has been completed.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAirPressureManager Properties

IAirPressureManager Properties

The IAirPressureManager type exposes the following members.

Properties
 | Name | Description
Public property | Downloader | Gets the downloader that the manager uses to fetch air pressures.
Public property | Enabled | Gets a value indicating that air pressure downloads are enabled.
Public property | Lookup | Gets the IAirPressureLookup that the manager is populating with downloaded air pressures.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager.Downloader Property

IAirPressureManagerDownloader Property
Gets the downloader that the manager uses to fetch air pressures.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IAirPressureDownloader Downloader { get; }
ReadOnly Property Downloader As IAirPressureDownloader
    Get
property IAirPressureDownloader^ Downloader {
    IAirPressureDownloader^ get ();
}
abstract Downloader : IAirPressureDownloader with get

Property Value

Type: IAirPressureDownloader
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager.Enabled Property

IAirPressureManagerEnabled Property
Gets a value indicating that air pressure downloads are enabled.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

Property Value

Type: Boolean
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager.Lookup Property

IAirPressureManagerLookup Property
Gets the IAirPressureLookup that the manager is populating with downloaded air pressures.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IAirPressureLookup Lookup { get; }
ReadOnly Property Lookup As IAirPressureLookup
    Get
property IAirPressureLookup^ Lookup {
    IAirPressureLookup^ get ();
}
abstract Lookup : IAirPressureLookup with get

Property Value

Type: IAirPressureLookup
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager Methods

IAirPressureManager Methods

The IAirPressureManager type exposes the following members.

Methods
 | Name | Description
Public method | Start | Starts downloading air pressures in the background.
Public method | Stop | Stops downloading air pressures in the background.
Top
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager.Start Method

IAirPressureManagerStart Method
Starts downloading air pressures in the background.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager.Stop Method

IAirPressureManagerStop Method
Stops downloading air pressures in the background.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager Events

IAirPressureManager Events

The IAirPressureManager type exposes the following members.

Events
 | Name | Description
Public event | DownloadCompleted | Raised when a download of air pressures has been completed.
Top
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IAirPressureManager.DownloadCompleted Event

IAirPressureManagerDownloadCompleted Event
Raised when a download of air pressures has been completed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DownloadCompleted
Event DownloadCompleted As EventHandler
 event EventHandler^ DownloadCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DownloadCompleted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IAirPressureManager Interface
VirtualRadar.Interface Namespace


IApplicationInformation Interface

IApplicationInformation Interface
The interface for objects that can expose information about the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IApplicationInformation
Public Interface IApplicationInformation
public interface class IApplicationInformation
type IApplicationInformation =  interface end

The IApplicationInformation type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets the content of the AssemblyTitle attribute for the application.
Public property | BuildDate | Gets the build date of the application.
Public property | Copyright | Gets the copyright attribution text for the application.
Public property | CultureInfo | Gets the culture info that was forced by a command switch on startup or null if the default culture info is to be used.
Public property | Description | Gets a description of the application.
Public property | FullVersion | Gets the full version number (e.g. 1.2.3.4).
Public property | Headless | Gets a value indicating that the program is running without a GUI.
Public property | ProductName | Gets the content of the AssemblyProduct attribute for the application.
Public property | ShortVersion | Gets the short version number (e.g. for 1.2.3.4 it returns '1.2.3').
Public property | Version | Gets full version information about the application.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IApplicationInformation Properties

IApplicationInformation Properties

The IApplicationInformation type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets the content of the AssemblyTitle attribute for the application.
Public property | BuildDate | Gets the build date of the application.
Public property | Copyright | Gets the copyright attribution text for the application.
Public property | CultureInfo | Gets the culture info that was forced by a command switch on startup or null if the default culture info is to be used.
Public property | Description | Gets a description of the application.
Public property | FullVersion | Gets the full version number (e.g. 1.2.3.4).
Public property | Headless | Gets a value indicating that the program is running without a GUI.
Public property | ProductName | Gets the content of the AssemblyProduct attribute for the application.
Public property | ShortVersion | Gets the short version number (e.g. for 1.2.3.4 it returns '1.2.3').
Public property | Version | Gets full version information about the application.
Top
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.ApplicationName Property

IApplicationInformationApplicationName Property
Gets the content of the AssemblyTitle attribute for the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ApplicationName { get; }
ReadOnly Property ApplicationName As String
    Get
property String^ ApplicationName {
    String^ get ();
}
abstract ApplicationName : string with get

Property Value

Type: String
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.BuildDate Property

IApplicationInformationBuildDate Property
Gets the build date of the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime BuildDate { get; }
ReadOnly Property BuildDate As DateTime
    Get
property DateTime BuildDate {
    DateTime get ();
}
abstract BuildDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.Copyright Property

IApplicationInformationCopyright Property
Gets the copyright attribution text for the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Copyright { get; }
ReadOnly Property Copyright As String
    Get
property String^ Copyright {
    String^ get ();
}
abstract Copyright : string with get

Property Value

Type: String
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.CultureInfo Property

IApplicationInformationCultureInfo Property
Gets the culture info that was forced by a command switch on startup or null if the default culture info is to be used.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CultureInfo CultureInfo { get; }
ReadOnly Property CultureInfo As CultureInfo
    Get
property CultureInfo^ CultureInfo {
    CultureInfo^ get ();
}
abstract CultureInfo : CultureInfo with get

Property Value

Type: CultureInfo
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.Description Property

IApplicationInformationDescription Property
Gets a description of the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.FullVersion Property

IApplicationInformationFullVersion Property
Gets the full version number (e.g. 1.2.3.4).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FullVersion { get; }
ReadOnly Property FullVersion As String
    Get
property String^ FullVersion {
    String^ get ();
}
abstract FullVersion : string with get

Property Value

Type: String
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.Headless Property

IApplicationInformationHeadless Property
Gets a value indicating that the program is running without a GUI.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Headless { get; }
ReadOnly Property Headless As Boolean
    Get
property bool Headless {
    bool get ();
}
abstract Headless : bool with get

Property Value

Type: Boolean
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.ProductName Property

IApplicationInformationProductName Property
Gets the content of the AssemblyProduct attribute for the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProductName { get; }
ReadOnly Property ProductName As String
    Get
property String^ ProductName {
    String^ get ();
}
abstract ProductName : string with get

Property Value

Type: String
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.ShortVersion Property

IApplicationInformationShortVersion Property
Gets the short version number (e.g. for 1.2.3.4 it returns '1.2.3').

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ShortVersion { get; }
ReadOnly Property ShortVersion As String
    Get
property String^ ShortVersion {
    String^ get ();
}
abstract ShortVersion : string with get

Property Value

Type: String
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IApplicationInformation.Version Property

IApplicationInformationVersion Property
Gets full version information about the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Version Version { get; }
ReadOnly Property Version As Version
    Get
property Version^ Version {
    Version^ get ();
}
abstract Version : Version with get

Property Value

Type: Version
See Also

Reference

IApplicationInformation Interface
VirtualRadar.Interface Namespace


IAudio Interface

IAudio Interface
The interface for objects that can generate audio.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAudio
Public Interface IAudio
public interface class IAudio
type IAudio =  interface end

The IAudio type exposes the following members.

Properties
 | Name | Description
Public property | IsSupported | Gets a value indicating that the runtime supports audio.
Top
Methods
 | Name | Description
Public method | SpeechToWavBytes | Returns an in-memory WAV file of synthesised speech corresponding to the text passed across.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAudio Properties

IAudio Properties

The IAudio type exposes the following members.

Properties
 | Name | Description
Public property | IsSupported | Gets a value indicating that the runtime supports audio.
Top
See Also

Reference

IAudio Interface
VirtualRadar.Interface Namespace


IAudio.IsSupported Property

IAudioIsSupported Property
Gets a value indicating that the runtime supports audio.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSupported { get; }
ReadOnly Property IsSupported As Boolean
    Get
property bool IsSupported {
    bool get ();
}
abstract IsSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IAudio Interface
VirtualRadar.Interface Namespace


IAudio Methods

IAudio Methods

The IAudio type exposes the following members.

Methods
 | Name | Description
Public method | SpeechToWavBytes | Returns an in-memory WAV file of synthesised speech corresponding to the text passed across.
Top
See Also

Reference

IAudio Interface
VirtualRadar.Interface Namespace


IAudio.SpeechToWavBytes Method

IAudioSpeechToWavBytes Method
Returns an in-memory WAV file of synthesised speech corresponding to the text passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
byte[] SpeechToWavBytes(
    string speechText
)
Function SpeechToWavBytes (
    speechText As String
) As Byte()
array<unsigned char>^ SpeechToWavBytes(
    String^ speechText
)
abstract SpeechToWavBytes :
        speechText : string -> byte[]

Parameters

speechText
Type: SystemString

Return Value

Type: Byte
See Also

Reference

IAudio Interface
VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache Interface

IAutoConfigPictureFolderCache Interface
The interface for a singleton object that can automatically apply the picture folder name from the configuration to an IDirectoryCache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAutoConfigPictureFolderCache : ISingleton<IAutoConfigPictureFolderCache>
Public Interface IAutoConfigPictureFolderCache
    Inherits ISingleton(Of IAutoConfigPictureFolderCache)
public interface class IAutoConfigPictureFolderCache : ISingleton<IAutoConfigPictureFolderCache^>
type IAutoConfigPictureFolderCache =
    interface
        interface ISingleton<IAutoConfigPictureFolderCache>
    end

The IAutoConfigPictureFolderCache type exposes the following members.

Properties
 | Name | Description
Public property | DirectoryCache | Gets the directory cache that is keeping track of files in the picture folder.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Initialise | Creates DirectoryCache and configures it.
Top
Events
 | Name | Description
Public event | CacheConfigurationChanged | Raised when the cache's configuration has been changed.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache Properties

IAutoConfigPictureFolderCache Properties

The IAutoConfigPictureFolderCache type exposes the following members.

Properties
 | Name | Description
Public property | DirectoryCache | Gets the directory cache that is keeping track of files in the picture folder.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAutoConfigPictureFolderCache Interface
VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache.DirectoryCache Property

IAutoConfigPictureFolderCacheDirectoryCache Property
Gets the directory cache that is keeping track of files in the picture folder.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDirectoryCache DirectoryCache { get; }
ReadOnly Property DirectoryCache As IDirectoryCache
    Get
property IDirectoryCache^ DirectoryCache {
    IDirectoryCache^ get ();
}
abstract DirectoryCache : IDirectoryCache with get

Property Value

Type: IDirectoryCache
See Also

Reference

IAutoConfigPictureFolderCache Interface
VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache Methods

IAutoConfigPictureFolderCache Methods

The IAutoConfigPictureFolderCache type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Creates DirectoryCache and configures it.
Top
See Also

Reference

IAutoConfigPictureFolderCache Interface
VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache.Initialise Method

IAutoConfigPictureFolderCacheInitialise Method
Creates DirectoryCache and configures it.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IAutoConfigPictureFolderCache Interface
VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache Events

IAutoConfigPictureFolderCache Events

The IAutoConfigPictureFolderCache type exposes the following members.

Events
 | Name | Description
Public event | CacheConfigurationChanged | Raised when the cache's configuration has been changed.
Top
See Also

Reference

IAutoConfigPictureFolderCache Interface
VirtualRadar.Interface Namespace


IAutoConfigPictureFolderCache.CacheConfigurationChanged Event

IAutoConfigPictureFolderCacheCacheConfigurationChanged Event
Raised when the cache's configuration has been changed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CacheConfigurationChanged
Event CacheConfigurationChanged As EventHandler
 event EventHandler^ CacheConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CacheConfigurationChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IAutoConfigPictureFolderCache Interface
VirtualRadar.Interface Namespace


IBackgroundThreadExceptionCatcher Interface

IBackgroundThreadExceptionCatcher Interface
An interface for objects that may be utilising background threads and want to allow exceptions on those threads to bubble up to the GUI thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundThreadExceptionCatcher
Public Interface IBackgroundThreadExceptionCatcher
public interface class IBackgroundThreadExceptionCatcher
type IBackgroundThreadExceptionCatcher =  interface end

The IBackgroundThreadExceptionCatcher type exposes the following members.

Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this.
Top
Remarks

Many interfaces need to perform tasks on a background thread. In general an exception on a background thread will end up going to the unhandled exception handler, which will log it and show it to the user. However leaving an exception on a background thread unhandled can cause problems, particularly if the exception is raised by an event handler. It may prevent other event handlers from seeing that event.

In many cases the background thread would like to catch exceptions and have them displayed to the user on the GUI thread, or logged by the normal unhandled exception handler, without having to actually get involved in how this might be done.

The idea here is that interfaces whose implementation may involve work on a background thread will include this interface. If the implementation does use background threads then they should catch exceptions raised on those threads and raise an ExceptionCaught event in response. Some other bit of code will then take over and do whatever is necessary to report or log the exception.

Background threads will usually be sent a ThreadAbortException when the thread is shut down - they should not send those through ExceptionCaught.

Examples
Copy
public event EventHandler<EventArgs<Exception>> ExceptionCaught;

protected virtual void OnExceptionCaught(EventArgs<Exception> args)
{
    if(ExceptionCaught != null) ExceptionCaught(this, args);
}

private void BackgroundThreadMethod()
{
    try {
        // Do some work here...
    } catch(ThreadAbortException) {
        // This is raised if the thread is shutting down, you don't need to pass these on to
        // the user. Whatever you do in this catch block it will always end with the framework
        // throwing another ThreadAbort at the end of the catch.
    } catch(Exception ex) {
        OnExceptionCaught(new EventArgs<Exception>(ex));
    }
}
See Also

Reference

VirtualRadar.Interface Namespace


IBackgroundThreadExceptionCatcher Events

IBackgroundThreadExceptionCatcher Events

The IBackgroundThreadExceptionCatcher type exposes the following members.

Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this.
Top
See Also

Reference

IBackgroundThreadExceptionCatcher Interface
VirtualRadar.Interface Namespace


IBackgroundThreadExceptionCatcher.ExceptionCaught Event

IBackgroundThreadExceptionCatcherExceptionCaught Event
Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<Exception>> ExceptionCaught
Event ExceptionCaught As EventHandler(Of EventArgs(Of Exception))
 event EventHandler<EventArgs<Exception^>^>^ ExceptionCaught {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}
abstract ExceptionCaught : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

IBackgroundThreadExceptionCatcher Interface
VirtualRadar.Interface Namespace


IBackgroundWorker Interface

IBackgroundWorker Interface
The interface for an object that does some work on a background thread and then quits the thread. The intention is that it is used once and then discarded, it cannot be used twice.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundWorker
Public Interface IBackgroundWorker
public interface class IBackgroundWorker
type IBackgroundWorker =  interface end

The IBackgroundWorker type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets the state passed to StartWork(Object).
Top
Methods
 | Name | Description
Public method | StartWork | Raises DoWork on a background thread.
Top
Events
 | Name | Description
Public event | DoWork | Raised on the background thread.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IBackgroundWorker Properties

IBackgroundWorker Properties

The IBackgroundWorker type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets the state passed to StartWork(Object).
Top
See Also

Reference

IBackgroundWorker Interface
VirtualRadar.Interface Namespace


IBackgroundWorker.State Property

IBackgroundWorkerState Property
Gets the state passed to StartWork(Object).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object State { get; }
ReadOnly Property State As Object
    Get
property Object^ State {
    Object^ get ();
}
abstract State : Object with get

Property Value

Type: Object
See Also

Reference

IBackgroundWorker Interface
VirtualRadar.Interface Namespace


IBackgroundWorker Methods

IBackgroundWorker Methods

The IBackgroundWorker type exposes the following members.

Methods
 | Name | Description
Public method | StartWork | Raises DoWork on a background thread.
Top
See Also

Reference

IBackgroundWorker Interface
VirtualRadar.Interface Namespace


IBackgroundWorker.StartWork Method

IBackgroundWorkerStartWork Method
Raises DoWork on a background thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartWork(
    Object state
)
Sub StartWork (
    state As Object
)
void StartWork(
    Object^ state
)
abstract StartWork :
        state : Object -> unit

Parameters

state
Type: SystemObject
See Also

Reference

IBackgroundWorker Interface
VirtualRadar.Interface Namespace


IBackgroundWorker Events

IBackgroundWorker Events

The IBackgroundWorker type exposes the following members.

Events
 | Name | Description
Public event | DoWork | Raised on the background thread.
Top
See Also

Reference

IBackgroundWorker Interface
VirtualRadar.Interface Namespace


IBackgroundWorker.DoWork Event

IBackgroundWorkerDoWork Event
Raised on the background thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DoWork
Event DoWork As EventHandler
 event EventHandler^ DoWork {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DoWork : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IBackgroundWorker Interface
VirtualRadar.Interface Namespace


IBitStream Interface

IBitStream Interface
The interface for classes that can take an array of bytes and stream bits from that byte array.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBitStream
Public Interface IBitStream
public interface class IBitStream
type IBitStream =  interface end

The IBitStream type exposes the following members.

Properties
 | Name | Description
Public property | LengthRemaining | Gets the number of bits remaining on the stream.
Top
Methods
 | Name | Description
Public method | Initialise | Initialises the stream with an array of bytes. The read methods will return bits from those bytes.
Public method | ReadBit | Returns the next bit from the stream. A true value indicates that the next bit was set, a false value indicates the next bit was clear.
Public method | ReadByte | Returns up to the next 8 bits from the stream.
Public method | ReadUInt16 | Returns up to the next 16 bits from the stream in big-endian order.
Public method | ReadUInt32 | Returns up to the next 32 bits from the stream in big-endian order.
Public method | ReadUInt64 | Returns up to the next 64 bits from the stream in big-endian order.
Public method | Skip | Skips a number of bits in the stream.
Top
Remarks

An exception is thrown if any operation moves past the end of the stream. Bits can be read across byte boundaries - e.g. if the bytes are 00001111 01010000 then doing a Skip(4) followed by a ReadByte(8) will return 11110101.

Implementations do not need to be thread-safe. If thread-safety is required then it is up to the caller to lock the BitStream.

See Also

Reference

VirtualRadar.Interface Namespace


IBitStream Properties

IBitStream Properties

The IBitStream type exposes the following members.

Properties
 | Name | Description
Public property | LengthRemaining | Gets the number of bits remaining on the stream.
Top
See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.LengthRemaining Property

IBitStreamLengthRemaining Property
Gets the number of bits remaining on the stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int LengthRemaining { get; }
ReadOnly Property LengthRemaining As Integer
    Get
property int LengthRemaining {
    int get ();
}
abstract LengthRemaining : int with get

Property Value

Type: Int32
Remarks

This will decrement as the Read and Skip methods are used.

This property returns 0 when called before Initialise(Byte).

See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream Methods

IBitStream Methods

The IBitStream type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the stream with an array of bytes. The read methods will return bits from those bytes.
Public method | ReadBit | Returns the next bit from the stream. A true value indicates that the next bit was set, a false value indicates the next bit was clear.
Public method | ReadByte | Returns up to the next 8 bits from the stream.
Public method | ReadUInt16 | Returns up to the next 16 bits from the stream in big-endian order.
Public method | ReadUInt32 | Returns up to the next 32 bits from the stream in big-endian order.
Public method | ReadUInt64 | Returns up to the next 64 bits from the stream in big-endian order.
Public method | Skip | Skips a number of bits in the stream.
Top
See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.Initialise Method

IBitStreamInitialise Method
Initialises the stream with an array of bytes. The read methods will return bits from those bytes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    byte[] bytes
)
Sub Initialise (
    bytes As Byte()
)
void Initialise(
    array<unsigned char>^ bytes
)
abstract Initialise :
        bytes : byte[] -> unit

Parameters

bytes
Type: SystemByte
Remarks
Calling this method resets the stream to the start of the array passed across. The intention is that the bitstream can be instantiated once and then re-used many times to read bits from many byte arrays.
See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.ReadBit Method

IBitStreamReadBit Method
Returns the next bit from the stream. A true value indicates that the next bit was set, a false value indicates the next bit was clear.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReadBit()
Function ReadBit As Boolean
bool ReadBit()
abstract ReadBit : unit -> bool

Return Value

Type: Boolean
Remarks
The effect of calling this method before Initialise(Byte) has been called is undefined.
See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.ReadByte Method

IBitStreamReadByte Method
Returns up to the next 8 bits from the stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
byte ReadByte(
    int countBits
)
Function ReadByte (
    countBits As Integer
) As Byte
unsigned char ReadByte(
    int countBits
)
abstract ReadByte :
        countBits : int -> byte

Parameters

countBits
Type: SystemInt32
Cannot be less than 1 or greater than 8.

Return Value

Type: Byte
Remarks

The bits are right-shifted so that the LSB read is the LSB of the return value. For example, if three bits from the stream '101' are read then the resulting byte will be '00000101'.

The effect of calling this method before Initialise(Byte) is undefined.

See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.ReadUInt16 Method

IBitStreamReadUInt16 Method
Returns up to the next 16 bits from the stream in big-endian order.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ushort ReadUInt16(
    int countBits
)
Function ReadUInt16 (
    countBits As Integer
) As UShort
unsigned short ReadUInt16(
    int countBits
)
abstract ReadUInt16 :
        countBits : int -> uint16

Parameters

countBits
Type: SystemInt32
Cannot be less than 1 or greater than 16.

Return Value

Type: UInt16
Remarks

The bits are right-shifted so that the LSB read is the LSB of the return value. For example, if three bits from the stream '101' are read then the resulting word will be '00000000 00000101'.

The effect of calling this method before Initialise(Byte) is undefined.

See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.ReadUInt32 Method

IBitStreamReadUInt32 Method
Returns up to the next 32 bits from the stream in big-endian order.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
uint ReadUInt32(
    int countBits
)
Function ReadUInt32 (
    countBits As Integer
) As UInteger
unsigned int ReadUInt32(
    int countBits
)
abstract ReadUInt32 :
        countBits : int -> uint32

Parameters

countBits
Type: SystemInt32
Cannot be less than 1 or greater than 32.

Return Value

Type: UInt32
Remarks

The bits are right-shifted so that the LSB read is the LSB of the return value. For example, if three bits from the stream '101' are read then the resulting double-word will be '00000000 00000000 00000000 00000101'.

The effect of calling this method before Initialise(Byte) is undefined.

See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.ReadUInt64 Method

IBitStreamReadUInt64 Method
Returns up to the next 64 bits from the stream in big-endian order.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ulong ReadUInt64(
    int countBits
)
Function ReadUInt64 (
    countBits As Integer
) As ULong
unsigned long long ReadUInt64(
    int countBits
)
abstract ReadUInt64 :
        countBits : int -> uint64

Parameters

countBits
Type: SystemInt32
Cannot be less than 1 or greater than 64.

Return Value

Type: UInt64
Remarks

The bits are right-shifted so that the LSB read is the LSB of the return value. For example, if three bits from the stream '101' are read then the resulting quad-word will be '00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000101'.

The effect of calling this method before Initialise(Byte) is undefined.

See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


IBitStream.Skip Method

IBitStreamSkip Method
Skips a number of bits in the stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Skip(
    int countBits
)
Sub Skip (
    countBits As Integer
)
void Skip(
    int countBits
)
abstract Skip :
        countBits : int -> unit

Parameters

countBits
Type: SystemInt32
The number of bits to skip.
Remarks
The effect of calling this method before Initialise(Byte) has been called is undefined.
See Also

Reference

IBitStream Interface
VirtualRadar.Interface Namespace


ICallsignParser Interface

ICallsignParser Interface
The interface for an object that can parse a callsign.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICallsignParser
Public Interface ICallsignParser
public interface class ICallsignParser
type ICallsignParser =  interface end

The ICallsignParser type exposes the following members.

Methods
 | Name | Description
Public method | GetAllAlternateCallsigns | Given a callsign such as 'VRS1', where VRS is an airline whose IATA code is VR, this returns all possible alternate callsigns by introducing leading zeros - e.g. 'VRS1, VRS01, VRS001, VRS0001, VRS00001, VR1, VR01, ..., VR000001'
Public method | GetAllRouteCallsigns | Given a callsign and an optional operator ICAO code this returns all possible callsigns that routes could be stored under, in the order that they should be searched on. This takes into account the behaviour of the VRS route compiler.
Top
See Also

Reference

VirtualRadar.Interface Namespace


ICallsignParser Methods

ICallsignParser Methods

The ICallsignParser type exposes the following members.

Methods
 | Name | Description
Public method | GetAllAlternateCallsigns | Given a callsign such as 'VRS1', where VRS is an airline whose IATA code is VR, this returns all possible alternate callsigns by introducing leading zeros - e.g. 'VRS1, VRS01, VRS001, VRS0001, VRS00001, VR1, VR01, ..., VR000001'
Public method | GetAllRouteCallsigns | Given a callsign and an optional operator ICAO code this returns all possible callsigns that routes could be stored under, in the order that they should be searched on. This takes into account the behaviour of the VRS route compiler.
Top
See Also

Reference

ICallsignParser Interface
VirtualRadar.Interface Namespace


ICallsignParser.GetAllAlternateCallsigns Method

ICallsignParserGetAllAlternateCallsigns Method
Given a callsign such as 'VRS1', where VRS is an airline whose IATA code is VR, this returns all possible alternate callsigns by introducing leading zeros - e.g. 'VRS1, VRS01, VRS001, VRS0001, VRS00001, VR1, VR01, ..., VR000001'

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<string> GetAllAlternateCallsigns(
    string callsign
)
Function GetAllAlternateCallsigns (
    callsign As String
) As List(Of String)
List<String^>^ GetAllAlternateCallsigns(
    String^ callsign
)
abstract GetAllAlternateCallsigns :
        callsign : string -> List<string>

Parameters

callsign
Type: SystemString

Return Value

Type: List String
See Also

Reference

ICallsignParser Interface
VirtualRadar.Interface Namespace


ICallsignParser.GetAllRouteCallsigns Method

ICallsignParserGetAllRouteCallsigns Method
Given a callsign and an optional operator ICAO code this returns all possible callsigns that routes could be stored under, in the order that they should be searched on. This takes into account the behaviour of the VRS route compiler.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<string> GetAllRouteCallsigns(
    string callsign,
    string operatorIcaoCode
)
Function GetAllRouteCallsigns (
    callsign As String,
    operatorIcaoCode As String
) As List(Of String)
List<String^>^ GetAllRouteCallsigns(
    String^ callsign,
    String^ operatorIcaoCode
)
abstract GetAllRouteCallsigns :
        callsign : string *
        operatorIcaoCode : string -> List<string>

Parameters

callsign
Type: SystemString
The callsign transmitted by the aircraft.
operatorIcaoCode
Type: SystemString
The operator ICAO code associated with the aircraft (this usually comes from the database).

Return Value

Type: List String
A list of callsigns. The first entry in the list is always the callsign that was passed in.
See Also

Reference

ICallsignParser Interface
VirtualRadar.Interface Namespace


IClock Interface

IClock Interface
The interface for an object that abstracts away the clock.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IClock
Public Interface IClock
public interface class IClock
type IClock =  interface end

The IClock type exposes the following members.

Properties
 | Name | Description
Public property | LocalNow | Gets the current local date and time.
Public property | UtcNow | Gets the current date and time at UTC.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IClock Properties

IClock Properties

The IClock type exposes the following members.

Properties
 | Name | Description
Public property | LocalNow | Gets the current local date and time.
Public property | UtcNow | Gets the current date and time at UTC.
Top
See Also

Reference

IClock Interface
VirtualRadar.Interface Namespace


IClock.LocalNow Property

IClockLocalNow Property
Gets the current local date and time.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime LocalNow { get; }
ReadOnly Property LocalNow As DateTime
    Get
property DateTime LocalNow {
    DateTime get ();
}
abstract LocalNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IClock Interface
VirtualRadar.Interface Namespace


IClock.UtcNow Property

IClockUtcNow Property
Gets the current date and time at UTC.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UtcNow { get; }
ReadOnly Property UtcNow As DateTime
    Get
property DateTime UtcNow {
    DateTime get ();
}
abstract UtcNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IClock Interface
VirtualRadar.Interface Namespace


IConnectionLogger Interface

IConnectionLogger Interface
The interface for objects that listen to a web server, track connections to it and periodically record details of those connections in a local database.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionLogger : ISingleton<IConnectionLogger>,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface IConnectionLogger
    Inherits ISingleton(Of IConnectionLogger), IBackgroundThreadExceptionCatcher, IDisposable
public interface class IConnectionLogger : ISingleton<IConnectionLogger^>,
    IBackgroundThreadExceptionCatcher, IDisposable
type IConnectionLogger =
    interface
        interface ISingleton<IConnectionLogger>
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IConnectionLogger type exposes the following members.

Properties
 | Name | Description
Public property | LogDatabase | Gets or sets the database object that will store information about connections.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | WebServer | Gets or sets the web server that the logger will record connections to.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Tells the connection logger to begin listening to the web server and recording its connections in the log database.
Top
Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


IConnectionLogger Properties

IConnectionLogger Properties

The IConnectionLogger type exposes the following members.

Properties
 | Name | Description
Public property | LogDatabase | Gets or sets the database object that will store information about connections.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | WebServer | Gets or sets the web server that the logger will record connections to.
Top
See Also

Reference

IConnectionLogger Interface
VirtualRadar.Interface Namespace


IConnectionLogger.LogDatabase Property

IConnectionLoggerLogDatabase Property
Gets or sets the database object that will store information about connections.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ILogDatabase LogDatabase { get; set; }
Property LogDatabase As ILogDatabase
    Get
    Set
property ILogDatabase^ LogDatabase {
    ILogDatabase^ get ();
    void set (ILogDatabase^ value);
}
abstract LogDatabase : ILogDatabase with get, set

Property Value

Type: ILogDatabase
See Also

Reference

IConnectionLogger Interface
VirtualRadar.Interface Namespace


IConnectionLogger.WebServer Property

IConnectionLoggerWebServer Property
Gets or sets the web server that the logger will record connections to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServer WebServer { get; set; }
Property WebServer As IWebServer
    Get
    Set
property IWebServer^ WebServer {
    IWebServer^ get ();
    void set (IWebServer^ value);
}
abstract WebServer : IWebServer with get, set

Property Value

Type: IWebServer
See Also

Reference

IConnectionLogger Interface
VirtualRadar.Interface Namespace


IConnectionLogger Methods

IConnectionLogger Methods

The IConnectionLogger type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Tells the connection logger to begin listening to the web server and recording its connections in the log database.
Top
See Also

Reference

IConnectionLogger Interface
VirtualRadar.Interface Namespace


IConnectionLogger.Start Method

IConnectionLoggerStart Method
Tells the connection logger to begin listening to the web server and recording its connections in the log database.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

IConnectionLogger Interface
VirtualRadar.Interface Namespace


IConnectionLogger Events

IConnectionLogger Events

The IConnectionLogger type exposes the following members.

Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

IConnectionLogger Interface
VirtualRadar.Interface Namespace


IDirectoryCache Interface

IDirectoryCache Interface
The interface for objects that can cache the filenames in a folder.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDirectoryCache : IDisposable
Public Interface IDirectoryCache
    Inherits IDisposable
public interface class IDirectoryCache : IDisposable
type IDirectoryCache =
    interface
        interface IDisposable
    end

The IDirectoryCache type exposes the following members.

Properties
 | Name | Description
Public property | CacheSubFolders | Gets or sets a value indicating that sub-folders under Folder should also be cached.
Public property | Folder | Gets or sets the folder whose content should be cached. Setting a new folder name erases the current cache and forces the caching on a background thread of the filesnames in the new folder.
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Top
Methods
 | Name | Description
Public method | BeginRefresh | Starts an immediate refresh of the cache.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetFullPath | Takes a filename without a directory and returns the full path of the file in the cache.
Public method | SetConfiguration | Assigns both Folder and CacheSubFolders simultaneously. Returns true if the assignment triggered a refresh of the cache.
Top
Events
 | Name | Description
Public event | CacheChanged | Raised on a background after the cache has been modified in some way. It is not raised if the content of the cache did not change.
Top
Remarks

This was written to cache the names of aircraft pictures in an aircraft picture folder. It was found that when the picture folder held several thousand aircraft the lookup times could be painful, so the program now uses this to cache the filenames in the folder.

The .NET FileSystemWatcher object was tested but was found to be unreliable when the aircraft picture folder was a network share, particularly when the network share was hosted on a non-Windows machine. So instead the implementation may employ a polling technique to fetch files. This can introduce the following problems:

  • New files may be reported as missing when they exist.
  • Deleted files may be reported as existing when they don't.

This is not a particular problem for the intended use of the cache as users are unlikely to delete aircraft pictures once they have them and missing a new file isn't the end of the world either. Making these kinds of mistakes will only lead to the possibility of very occasional website picture glitches. However it can make this cache unsuitable for more critical purposes.

The cache can detect the following changes between polls:

  • Files that have been added.
  • Files that have been removed.
  • Files that have been renamed*.
  • Files whose last modified time has changed.

It will not pick up changes to size, create time, access time or case. If the file is renamed but a new file matches the name of a file in the cache, and the renamed file has the same modified time as the cached file, and the old file is replaced with a new file that has the same modified time as the old file, then the rename will not be detected.

See Also

Reference

VirtualRadar.Interface Namespace


IDirectoryCache Properties

IDirectoryCache Properties

The IDirectoryCache type exposes the following members.

Properties
 | Name | Description
Public property | CacheSubFolders | Gets or sets a value indicating that sub-folders under Folder should also be cached.
Public property | Folder | Gets or sets the folder whose content should be cached. Setting a new folder name erases the current cache and forces the caching on a background thread of the filesnames in the new folder.
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Top
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.CacheSubFolders Property

IDirectoryCacheCacheSubFolders Property
Gets or sets a value indicating that sub-folders under Folder should also be cached.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CacheSubFolders { get; set; }
Property CacheSubFolders As Boolean
    Get
    Set
property bool CacheSubFolders {
    bool get ();
    void set (bool value);
}
abstract CacheSubFolders : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.Folder Property

IDirectoryCacheFolder Property
Gets or sets the folder whose content should be cached. Setting a new folder name erases the current cache and forces the caching on a background thread of the filesnames in the new folder.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Folder { get; set; }
Property Folder As String
    Get
    Set
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
abstract Folder : string with get, set

Property Value

Type: String
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.Provider Property

IDirectoryCacheProvider Property
Gets or sets the object that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDirectoryCacheProvider Provider { get; set; }
Property Provider As IDirectoryCacheProvider
    Get
    Set
property IDirectoryCacheProvider^ Provider {
    IDirectoryCacheProvider^ get ();
    void set (IDirectoryCacheProvider^ value);
}
abstract Provider : IDirectoryCacheProvider with get, set

Property Value

Type: IDirectoryCacheProvider
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache Methods

IDirectoryCache Methods

The IDirectoryCache type exposes the following members.

Methods
 | Name | Description
Public method | BeginRefresh | Starts an immediate refresh of the cache.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetFullPath | Takes a filename without a directory and returns the full path of the file in the cache.
Public method | SetConfiguration | Assigns both Folder and CacheSubFolders simultaneously. Returns true if the assignment triggered a refresh of the cache.
Top
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.BeginRefresh Method

IDirectoryCacheBeginRefresh Method
Starts an immediate refresh of the cache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void BeginRefresh()
Sub BeginRefresh
void BeginRefresh()
abstract BeginRefresh : unit -> unit
Remarks
Intended for occasions where a user might want to manually start a reload of the filename cache. May block if the cache is already being refreshed until the first refresh has completed, at which point it will queue a new refresh and return.
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.GetFullPath Method

IDirectoryCacheGetFullPath Method
Takes a filename without a directory and returns the full path of the file in the cache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetFullPath(
    string fileName
)
Function GetFullPath (
    fileName As String
) As String
String^ GetFullPath(
    String^ fileName
)
abstract GetFullPath :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
Remarks
If sub-folder searches are switched on and there is more than one instance of a file with this filename in the folder tree then one of the instances is returned, but it is not defined as to which is returned.
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.SetConfiguration Method

IDirectoryCacheSetConfiguration Method
Assigns both Folder and CacheSubFolders simultaneously. Returns true if the assignment triggered a refresh of the cache.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SetConfiguration(
    string folder,
    bool cacheSubFolders
)
Function SetConfiguration (
    folder As String,
    cacheSubFolders As Boolean
) As Boolean
bool SetConfiguration(
    String^ folder,
    bool cacheSubFolders
)
abstract SetConfiguration :
        folder : string *
        cacheSubFolders : bool -> bool

Parameters

folder
Type: SystemString
cacheSubFolders
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache Events

IDirectoryCache Events

The IDirectoryCache type exposes the following members.

Events
 | Name | Description
Public event | CacheChanged | Raised on a background after the cache has been modified in some way. It is not raised if the content of the cache did not change.
Top
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCache.CacheChanged Event

IDirectoryCacheCacheChanged Event
Raised on a background after the cache has been modified in some way. It is not raised if the content of the cache did not change.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CacheChanged
Event CacheChanged As EventHandler
 event EventHandler^ CacheChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CacheChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDirectoryCache Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProvider Interface

IDirectoryCacheProvider Interface
The interface for the object that abstracts away the environment for IDirectoryCache implementations.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDirectoryCacheProvider
Public Interface IDirectoryCacheProvider
public interface class IDirectoryCacheProvider
type IDirectoryCacheProvider =  interface end

The IDirectoryCacheProvider type exposes the following members.

Methods
 | Name | Description
Public method | FolderExists | Returns true if the folder passed across exists.
Public method | GetFileInfo | Returns the file information about the file passed across or null if the file does not exist.
Public method | GetFilesInFolder | Returns a collection of objects describing files in a folder.
Public method | GetSubFoldersInFolder | Returns a collection of fully pathed sub-folders within the folder.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IDirectoryCacheProvider Methods

IDirectoryCacheProvider Methods

The IDirectoryCacheProvider type exposes the following members.

Methods
 | Name | Description
Public method | FolderExists | Returns true if the folder passed across exists.
Public method | GetFileInfo | Returns the file information about the file passed across or null if the file does not exist.
Public method | GetFilesInFolder | Returns a collection of objects describing files in a folder.
Public method | GetSubFoldersInFolder | Returns a collection of fully pathed sub-folders within the folder.
Top
See Also

Reference

IDirectoryCacheProvider Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProvider.FolderExists Method

IDirectoryCacheProviderFolderExists Method
Returns true if the folder passed across exists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FolderExists(
    string folder
)
Function FolderExists (
    folder As String
) As Boolean
bool FolderExists(
    String^ folder
)
abstract FolderExists :
        folder : string -> bool

Parameters

folder
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IDirectoryCacheProvider Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProvider.GetFileInfo Method

IDirectoryCacheProviderGetFileInfo Method
Returns the file information about the file passed across or null if the file does not exist.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDirectoryCacheProviderFileInfo GetFileInfo(
    string fileName
)
Function GetFileInfo (
    fileName As String
) As IDirectoryCacheProviderFileInfo
IDirectoryCacheProviderFileInfo^ GetFileInfo(
    String^ fileName
)
abstract GetFileInfo :
        fileName : string -> IDirectoryCacheProviderFileInfo

Parameters

fileName
Type: SystemString

Return Value

Type: IDirectoryCacheProviderFileInfo
See Also

Reference

IDirectoryCacheProvider Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProvider.GetFilesInFolder Method

IDirectoryCacheProviderGetFilesInFolder Method
Returns a collection of objects describing files in a folder.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IDirectoryCacheProviderFileInfo> GetFilesInFolder(
    string folder
)
Function GetFilesInFolder (
    folder As String
) As IEnumerable(Of IDirectoryCacheProviderFileInfo)
IEnumerable<IDirectoryCacheProviderFileInfo^>^ GetFilesInFolder(
    String^ folder
)
abstract GetFilesInFolder :
        folder : string -> IEnumerable<IDirectoryCacheProviderFileInfo>

Parameters

folder
Type: SystemString

Return Value

Type: IEnumerable IDirectoryCacheProviderFileInfo
See Also

Reference

IDirectoryCacheProvider Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProvider.GetSubFoldersInFolder Method

IDirectoryCacheProviderGetSubFoldersInFolder Method
Returns a collection of fully pathed sub-folders within the folder.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetSubFoldersInFolder(
    string folder
)
Function GetSubFoldersInFolder (
    folder As String
) As IEnumerable(Of String)
IEnumerable<String^>^ GetSubFoldersInFolder(
    String^ folder
)
abstract GetSubFoldersInFolder :
        folder : string -> IEnumerable<string>

Parameters

folder
Type: SystemString

Return Value

Type: IEnumerable String
See Also

Reference

IDirectoryCacheProvider Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProviderFileInfo Interface

IDirectoryCacheProviderFileInfo Interface
The interface for an object that exposes information about a file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDirectoryCacheProviderFileInfo
Public Interface IDirectoryCacheProviderFileInfo
public interface class IDirectoryCacheProviderFileInfo
type IDirectoryCacheProviderFileInfo =  interface end

The IDirectoryCacheProviderFileInfo type exposes the following members.

Properties
 | Name | Description
Public property | LastWriteTimeUtc | Gets the last time the file was modified.
Public property | Name | Gets the name of the file without the path.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IDirectoryCacheProviderFileInfo Properties

IDirectoryCacheProviderFileInfo Properties

The IDirectoryCacheProviderFileInfo type exposes the following members.

Properties
 | Name | Description
Public property | LastWriteTimeUtc | Gets the last time the file was modified.
Public property | Name | Gets the name of the file without the path.
Top
See Also

Reference

IDirectoryCacheProviderFileInfo Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProviderFileInfo.LastWriteTimeUtc Property

IDirectoryCacheProviderFileInfoLastWriteTimeUtc Property
Gets the last time the file was modified.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime LastWriteTimeUtc { get; set; }
Property LastWriteTimeUtc As DateTime
    Get
    Set
property DateTime LastWriteTimeUtc {
    DateTime get ();
    void set (DateTime value);
}
abstract LastWriteTimeUtc : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IDirectoryCacheProviderFileInfo Interface
VirtualRadar.Interface Namespace


IDirectoryCacheProviderFileInfo.Name Property

IDirectoryCacheProviderFileInfoName Property
Gets the name of the file without the path.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IDirectoryCacheProviderFileInfo Interface
VirtualRadar.Interface Namespace


IExceptionReporter Interface

IExceptionReporter Interface
The interface for objects that can report exceptions.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExceptionReporter
Public Interface IExceptionReporter
public interface class IExceptionReporter
type IExceptionReporter =  interface end

The IExceptionReporter type exposes the following members.

Methods
 | Name | Description
Public method | ShowUnhandledException | Reports the unhandled exception to the user and logs it.
Top
Remarks
Only use this from the main GUI thread.
See Also

Reference

VirtualRadar.Interface Namespace


IExceptionReporter Methods

IExceptionReporter Methods

The IExceptionReporter type exposes the following members.

Methods
 | Name | Description
Public method | ShowUnhandledException | Reports the unhandled exception to the user and logs it.
Top
See Also

Reference

IExceptionReporter Interface
VirtualRadar.Interface Namespace


IExceptionReporter.ShowUnhandledException Method

IExceptionReporterShowUnhandledException Method
Reports the unhandled exception to the user and logs it.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowUnhandledException(
    Exception ex
)
Sub ShowUnhandledException (
    ex As Exception
)
void ShowUnhandledException(
    Exception^ ex
)
abstract ShowUnhandledException :
        ex : Exception -> unit

Parameters

ex
Type: SystemException
See Also

Reference

IExceptionReporter Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService Interface

IExternalIPAddressService Interface
The interface for objects that find out the external IP address of the user.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExternalIPAddressService : ISingleton<IExternalIPAddressService>
Public Interface IExternalIPAddressService
    Inherits ISingleton(Of IExternalIPAddressService)
public interface class IExternalIPAddressService : ISingleton<IExternalIPAddressService^>
type IExternalIPAddressService =
    interface
        interface ISingleton<IExternalIPAddressService>
    end

The IExternalIPAddressService type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the last address fetched by GetExternalIPAddress.
Public property | Provider | Gets or sets the object that isolates the service from the environment.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | GetExternalIPAddress | Returns the external IP address of the application.
Top
Events
 | Name | Description
Public event | AddressUpdated | Raised when the address has been determined by a call to GetExternalIPAddress.
Top
Remarks
The main screen presenter normally uses this to determine the external IP address. If you are writing a plugin and would like to know the public IP address of the computer then hook AddressUpdated on the singleton in your Startup method and it will eventually be called some time after the main screen fires up.
See Also

Reference

VirtualRadar.Interface Namespace


IExternalIPAddressService Properties

IExternalIPAddressService Properties

The IExternalIPAddressService type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the last address fetched by GetExternalIPAddress.
Public property | Provider | Gets or sets the object that isolates the service from the environment.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService.Address Property

IExternalIPAddressServiceAddress Property
Gets the last address fetched by GetExternalIPAddress.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Address { get; }
ReadOnly Property Address As String
    Get
property String^ Address {
    String^ get ();
}
abstract Address : string with get

Property Value

Type: String
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService.Provider Property

IExternalIPAddressServiceProvider Property
Gets or sets the object that isolates the service from the environment.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IExternalIPAddressServiceProvider Provider { get; set; }
Property Provider As IExternalIPAddressServiceProvider
    Get
    Set
property IExternalIPAddressServiceProvider^ Provider {
    IExternalIPAddressServiceProvider^ get ();
    void set (IExternalIPAddressServiceProvider^ value);
}
abstract Provider : IExternalIPAddressServiceProvider with get, set

Property Value

Type: IExternalIPAddressServiceProvider
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService Methods

IExternalIPAddressService Methods

The IExternalIPAddressService type exposes the following members.

Methods
 | Name | Description
Public method | GetExternalIPAddress | Returns the external IP address of the application.
Top
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService.GetExternalIPAddress Method

IExternalIPAddressServiceGetExternalIPAddress Method
Returns the external IP address of the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetExternalIPAddress()
Function GetExternalIPAddress As String
String^ GetExternalIPAddress()
abstract GetExternalIPAddress : unit -> string

Return Value

Type: String
Remarks
This will block until the external IP address is determined and may throw exceptions if the IP address cannot be determined. It would be best not to call this from a GUI thread.
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService Events

IExternalIPAddressService Events

The IExternalIPAddressService type exposes the following members.

Events
 | Name | Description
Public event | AddressUpdated | Raised when the address has been determined by a call to GetExternalIPAddress.
Top
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressService.AddressUpdated Event

IExternalIPAddressServiceAddressUpdated Event
Raised when the address has been determined by a call to GetExternalIPAddress.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<string>> AddressUpdated
Event AddressUpdated As EventHandler(Of EventArgs(Of String))
 event EventHandler<EventArgs<String^>^>^ AddressUpdated {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}
abstract AddressUpdated : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

Value

Type: SystemEventHandler EventArgs String
See Also

Reference

IExternalIPAddressService Interface
VirtualRadar.Interface Namespace


IExternalIPAddressServiceProvider Interface

IExternalIPAddressServiceProvider Interface
The object that abstracts away the environment for tests on IExternalIPAddressService.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExternalIPAddressServiceProvider
Public Interface IExternalIPAddressServiceProvider
public interface class IExternalIPAddressServiceProvider
type IExternalIPAddressServiceProvider =  interface end

The IExternalIPAddressServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | ExternalIpAddress | Returns the computer's public IP address.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IExternalIPAddressServiceProvider Methods

IExternalIPAddressServiceProvider Methods

The IExternalIPAddressServiceProvider type exposes the following members.

Methods
 | Name | Description
Public method | ExternalIpAddress | Returns the computer's public IP address.
Top
See Also

Reference

IExternalIPAddressServiceProvider Interface
VirtualRadar.Interface Namespace


IExternalIPAddressServiceProvider.ExternalIpAddress Method

IExternalIPAddressServiceProviderExternalIpAddress Method
Returns the computer's public IP address.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExternalIpAddress()
Function ExternalIpAddress As String
String^ ExternalIpAddress()
abstract ExternalIpAddress : unit -> string

Return Value

Type: String
See Also

Reference

IExternalIPAddressServiceProvider Interface
VirtualRadar.Interface Namespace


IHeartbeatService Interface

IHeartbeatService Interface
A service that raises an event on a background thread every so-many minutes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IHeartbeatService : ISingleton<IHeartbeatService>,
    IDisposable
Public Interface IHeartbeatService
    Inherits ISingleton(Of IHeartbeatService), IDisposable
public interface class IHeartbeatService : ISingleton<IHeartbeatService^>,
    IDisposable
type IHeartbeatService =
    interface
        interface ISingleton<IHeartbeatService>
        interface IDisposable
    end

The IHeartbeatService type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FastTickNow | Raises FastTick on a background thread.
Public method | SlowTickNow | Raises SlowTick on a background thread.
Public method | Start | Starts the timers.
Top
Events
 | Name | Description
Public event | FastTick | Raised once every second or so.
Public event | SlowTick | Raised once every ten seconds or so.
Top
Remarks

The intention with this is to make it a bit easier to write tests for code that checks for program updates / new versions of files once every day or so. It can get complicated if the code that does the checking is using a real timer or is invoking code on a second thread.

If an object wants to periodically do some work then it hooks either SlowTick or FastTick on the object exposed by the Singleton property. These events are raised on a background thread so the object that hooks them does not have to get involved with maintaining a background thread or with periodically running a method on a background thread. However none of the Tick events are guaranteed to be raised exactly so-many seconds apart so the object that hooks them is expected to keep a track of the time that has elapsed since the last invocation of the event handler and make sure that they don't perform their periodic work before the requisite period of real time has elapsed.

Exceptions raised on the event handlers are currently logged but not pushed up to the GUI.

The Singleton version of the heartbeat service is started by the splash screen and is available to plugins in their Startup method. However if plugins want to maintain use their own instance of the heartbeat service they are welcome to do so - by doing this they can avoid blocking other objects that use the service. However if timely background processing is an issue for a plugin then perhaps the heartbeat service is not the best way of implementing it.

See Also

Reference

VirtualRadar.Interface Namespace


IHeartbeatService Properties

IHeartbeatService Properties

The IHeartbeatService type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService Methods

IHeartbeatService Methods

The IHeartbeatService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FastTickNow | Raises FastTick on a background thread.
Public method | SlowTickNow | Raises SlowTick on a background thread.
Public method | Start | Starts the timers.
Top
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService.FastTickNow Method

IHeartbeatServiceFastTickNow Method
Raises FastTick on a background thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FastTickNow()
Sub FastTickNow
void FastTickNow()
abstract FastTickNow : unit -> unit
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService.SlowTickNow Method

IHeartbeatServiceSlowTickNow Method
Raises SlowTick on a background thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SlowTickNow()
Sub SlowTickNow
void SlowTickNow()
abstract SlowTickNow : unit -> unit
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService.Start Method

IHeartbeatServiceStart Method
Starts the timers.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService Events

IHeartbeatService Events

The IHeartbeatService type exposes the following members.

Events
 | Name | Description
Public event | FastTick | Raised once every second or so.
Public event | SlowTick | Raised once every ten seconds or so.
Top
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService.FastTick Event

IHeartbeatServiceFastTick Event
Raised once every second or so.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FastTick
Event FastTick As EventHandler
 event EventHandler^ FastTick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FastTick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IHeartbeatService.SlowTick Event

IHeartbeatServiceSlowTick Event
Raised once every ten seconds or so.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SlowTick
Event SlowTick As EventHandler
 event EventHandler^ SlowTick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SlowTick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IHeartbeatService Interface
VirtualRadar.Interface Namespace


IImageDimensionsFetcher Interface

IImageDimensionsFetcher Interface
The interface for an object that can determine the dimensions of an image stored in an image file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IImageDimensionsFetcher
Public Interface IImageDimensionsFetcher
public interface class IImageDimensionsFetcher
type IImageDimensionsFetcher =  interface end
Methods
 | Name | Description
Public method | ReadDimensions(Stream) | Reads the dimensions of the image from the stream, hopefully without actually loading the entire file.
Public method | ReadDimensions(String) | Reads the dimensions of the image from the file, hopefully without actually loading the entire file.
Top
Remarks
Implementations must be thread-safe.
See Also

Reference

VirtualRadar.Interface Namespace


IImageDimensionsFetcher Methods

IImageDimensionsFetcher Methods
Methods
 | Name | Description
Public method | ReadDimensions(Stream) | Reads the dimensions of the image from the stream, hopefully without actually loading the entire file.
Public method | ReadDimensions(String) | Reads the dimensions of the image from the file, hopefully without actually loading the entire file.
Top
See Also

Reference

IImageDimensionsFetcher Interface
VirtualRadar.Interface Namespace


IImageDimensionsFetcher.ReadDimensions Method

IImageDimensionsFetcherReadDimensions Method
Overload List
 | Name | Description
Public method | ReadDimensions(Stream) | Reads the dimensions of the image from the stream, hopefully without actually loading the entire file.
Public method | ReadDimensions(String) | Reads the dimensions of the image from the file, hopefully without actually loading the entire file.
Top
See Also

Reference

IImageDimensionsFetcher Interface
VirtualRadar.Interface Namespace


IImageDimensionsFetcher.ReadDimensions Method (Stream)

IImageDimensionsFetcherReadDimensions Method (Stream)
Reads the dimensions of the image from the stream, hopefully without actually loading the entire file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Size ReadDimensions(
    Stream stream
)
Function ReadDimensions (
    stream As Stream
) As Size
Size ReadDimensions(
    Stream^ stream
)
abstract ReadDimensions :
        stream : Stream -> Size

Parameters

stream
Type: System.IOStream
A stream of image bits. The stream must be positionable.

Return Value

Type: Size
See Also

Reference

IImageDimensionsFetcher Interface
ReadDimensions Overload
VirtualRadar.Interface Namespace


IImageDimensionsFetcher.ReadDimensions Method (String)

IImageDimensionsFetcherReadDimensions Method (String)
Reads the dimensions of the image from the file, hopefully without actually loading the entire file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Size ReadDimensions(
    string fileName
)
Function ReadDimensions (
    fileName As String
) As Size
Size ReadDimensions(
    String^ fileName
)
abstract ReadDimensions :
        fileName : string -> Size

Parameters

fileName
Type: SystemString
Full path to the image file. The user must be able to open the file for reading.

Return Value

Type: Size
See Also

Reference

IImageDimensionsFetcher Interface
ReadDimensions Overload
VirtualRadar.Interface Namespace


IImageFileManager Interface

IImageFileManager Interface
Manages access to images stored on disk.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IImageFileManager
Public Interface IImageFileManager
public interface class IImageFileManager
type IImageFileManager =  interface end

The IImageFileManager type exposes the following members.

Methods
 | Name | Description
Public method | ImageFileDimensions | Attempts to figure out the dimensions of an image stored within a file as quickly as possible.
Public method | LoadFromFile | Loads the image stored in the file specified.
Public method | LoadFromWebSite | Loads the image from the web site passed across. If caching is allowed then a clone of the cached image is always returned.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IImageFileManager Methods

IImageFileManager Methods

The IImageFileManager type exposes the following members.

Methods
 | Name | Description
Public method | ImageFileDimensions | Attempts to figure out the dimensions of an image stored within a file as quickly as possible.
Public method | LoadFromFile | Loads the image stored in the file specified.
Public method | LoadFromWebSite | Loads the image from the web site passed across. If caching is allowed then a clone of the cached image is always returned.
Top
See Also

Reference

IImageFileManager Interface
VirtualRadar.Interface Namespace


IImageFileManager.ImageFileDimensions Method

IImageFileManagerImageFileDimensions Method
Attempts to figure out the dimensions of an image stored within a file as quickly as possible.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Size ImageFileDimensions(
    string fileName
)
Function ImageFileDimensions (
    fileName As String
) As Size
Size ImageFileDimensions(
    String^ fileName
)
abstract ImageFileDimensions :
        fileName : string -> Size

Parameters

fileName
Type: SystemString

Return Value

Type: Size
See Also

Reference

IImageFileManager Interface
VirtualRadar.Interface Namespace


IImageFileManager.LoadFromFile Method

IImageFileManagerLoadFromFile Method
Loads the image stored in the file specified.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image LoadFromFile(
    string fileName
)
Function LoadFromFile (
    fileName As String
) As Image
Image^ LoadFromFile(
    String^ fileName
)
abstract LoadFromFile :
        fileName : string -> Image

Parameters

fileName
Type: SystemString

Return Value

Type: Image
See Also

Reference

IImageFileManager Interface
VirtualRadar.Interface Namespace


IImageFileManager.LoadFromWebSite Method

IImageFileManagerLoadFromWebSite Method
Loads the image from the web site passed across. If caching is allowed then a clone of the cached image is always returned.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image LoadFromWebSite(
    IWebSite webSite,
    string webPathAndFileName,
    bool useImageCache
)
Function LoadFromWebSite (
    webSite As IWebSite,
    webPathAndFileName As String,
    useImageCache As Boolean
) As Image
Image^ LoadFromWebSite(
    IWebSite^ webSite,
    String^ webPathAndFileName,
    bool useImageCache
)
abstract LoadFromWebSite :
        webSite : IWebSite *
        webPathAndFileName : string *
        useImageCache : bool -> Image

Parameters

webSite
Type: VirtualRadar.Interface.WebSiteIWebSite
webPathAndFileName
Type: SystemString
useImageCache
Type: SystemBoolean

Return Value

Type: Image
See Also

Reference

IImageFileManager Interface
VirtualRadar.Interface Namespace


IListExtensions Class

IListExtensions Class
Extensions to IList<T> that add some functionality present on List<T> but missing on the interface.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceIListExtensions

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class IListExtensions
<ExtensionAttribute>
Public NotInheritable Class IListExtensions
[ExtensionAttribute]
public ref class IListExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type IListExtensions =  class end

The IListExtensions type exposes the following members.

Methods
Name | Description
AddRangeT | Appends one list to the end of the other.
HasSameContentAs | Returns true if two ILists have the same content.
RemoveAllT | Removes all matching entries from the list.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IListExtensions Methods

IListExtensions Methods

The IListExtensions type exposes the following members.

Methods
Name | Description
AddRangeT | Appends one list to the end of the other.
HasSameContentAs | Returns true if two ILists have the same content.
RemoveAllT | Removes all matching entries from the list.
Top
See Also

Reference

IListExtensions Class
VirtualRadar.Interface Namespace


IListExtensions.AddRange(T) Method

IListExtensionsAddRangeT Method
Appends one list to the end of the other.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddRange<T>(
    this IList<T> list,
    IEnumerable<T> range
)

<ExtensionAttribute>
Public Shared Sub AddRange(Of T) (
    list As IList(Of T),
    range As IEnumerable(Of T)
)
public:
[ExtensionAttribute]
generic<typename T>
static void AddRange(
    IList<T>^ list,
    IEnumerable<T>^ range
)
[<ExtensionAttribute>]
static member AddRange :
        list : IList<'T> *
        range : IEnumerable<'T> -> unit

Parameters

list
Type: System.Collections.GenericIList T
range
Type: System.Collections.GenericIEnumerable T

Type Parameters

T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IListExtensions Class
VirtualRadar.Interface Namespace


IListExtensions.HasSameContentAs Method

IListExtensionsHasSameContentAs Method
Returns true if two ILists have the same content.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasSameContentAs(
    this IList list,
    IList other,
    bool orderMustMatch
)
<ExtensionAttribute>
Public Shared Function HasSameContentAs (
    list As IList,
    other As IList,
    orderMustMatch As Boolean
) As Boolean
public:
[ExtensionAttribute]
static bool HasSameContentAs(
    IList^ list,
    IList^ other,
    bool orderMustMatch
)
[<ExtensionAttribute>]
static member HasSameContentAs :
        list : IList *
        other : IList *
        orderMustMatch : bool -> bool

Parameters

list
Type: System.CollectionsIList
other
Type: System.CollectionsIList
orderMustMatch
Type: SystemBoolean

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IListExtensions Class
VirtualRadar.Interface Namespace


IListExtensions.RemoveAll(T) Method

IListExtensionsRemoveAllT Method
Removes all matching entries from the list.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveAll<T>(
    this IList<T> list,
    Predicate<T> match
)

<ExtensionAttribute>
Public Shared Sub RemoveAll(Of T) (
    list As IList(Of T),
    match As Predicate(Of T)
)
public:
[ExtensionAttribute]
generic<typename T>
static void RemoveAll(
    IList<T>^ list,
    Predicate<T>^ match
)
[<ExtensionAttribute>]
static member RemoveAll :
        list : IList<'T> *
        match : Predicate<'T> -> unit

Parameters

list
Type: System.Collections.GenericIList T
match
Type: SystemPredicate T

Type Parameters

T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IListExtensions Class
VirtualRadar.Interface Namespace


ILog Interface

ILog Interface
The interface for objects that can manage log files for us.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILog : ISingleton<ILog>
Public Interface ILog
    Inherits ISingleton(Of ILog)
public interface class ILog : ISingleton<ILog^>
type ILog =
    interface
        interface ISingleton<ILog>
    end

The ILog type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets the full path and filename of the log file.
Public property | Provider | Gets or sets the provider that abstracts away the environment for the tests.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | GetContent | Returns the content of the log as an array of lines, optionally truncated to the last so-many lines.
Public method | Truncate | Truncates the log file to the last nn kilobytes.
Public method | WriteLine(String) | Writes a line of text to the log file.
Public method | WriteLine(String, Object) | Writes a line of text to the log file.
Top
Remarks
You should only use the Singleton version of this object to write to the program log. Using your own instance will work but it will not be thread-safe whereas the Singleton log is guaranteed to be thread-safe.
Examples
Copy
ILog log = Factory.Singleton.Resolve<ILog>().Singleton;
log.WriteLine("This will be written to the program log");
See Also

Reference

VirtualRadar.Interface Namespace


ILog Properties

ILog Properties

The ILog type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets the full path and filename of the log file.
Public property | Provider | Gets or sets the provider that abstracts away the environment for the tests.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog.FileName Property

ILogFileName Property
Gets the full path and filename of the log file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; }
ReadOnly Property FileName As String
    Get
property String^ FileName {
    String^ get ();
}
abstract FileName : string with get

Property Value

Type: String
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog.Provider Property

ILogProvider Property
Gets or sets the provider that abstracts away the environment for the tests.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ILogProvider Provider { get; set; }
Property Provider As ILogProvider
    Get
    Set
property ILogProvider^ Provider {
    ILogProvider^ get ();
    void set (ILogProvider^ value);
}
abstract Provider : ILogProvider with get, set

Property Value

Type: ILogProvider
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog Methods

ILog Methods

The ILog type exposes the following members.

Methods
 | Name | Description
Public method | GetContent | Returns the content of the log as an array of lines, optionally truncated to the last so-many lines.
Public method | Truncate | Truncates the log file to the last nn kilobytes.
Public method | WriteLine(String) | Writes a line of text to the log file.
Public method | WriteLine(String, Object) | Writes a line of text to the log file.
Top
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog.GetContent Method

ILogGetContent Method
Returns the content of the log as an array of lines, optionally truncated to the last so-many lines.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] GetContent(
    int lines
)
Function GetContent (
    lines As Integer
) As String()
array<String^>^ GetContent(
    int lines
)
abstract GetContent :
        lines : int -> string[]

Parameters

lines
Type: SystemInt32
The number of tail lines to return or 0 to return all of them.

Return Value

Type: String
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog.Truncate Method

ILogTruncate Method
Truncates the log file to the last nn kilobytes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Truncate(
    int kbLength
)
Sub Truncate (
    kbLength As Integer
)
void Truncate(
    int kbLength
)
abstract Truncate :
        kbLength : int -> unit

Parameters

kbLength
Type: SystemInt32
The number of kilobytes to preserve at the end of the file.
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog.WriteLine Method

ILogWriteLine Method
Overload List
 | Name | Description
Public method | WriteLine(String) | Writes a line of text to the log file.
Public method | WriteLine(String, Object) | Writes a line of text to the log file.
Top
See Also

Reference

ILog Interface
VirtualRadar.Interface Namespace


ILog.WriteLine Method (String)

ILogWriteLine Method (String)
Writes a line of text to the log file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void WriteLine(
    string message
)
Sub WriteLine (
    message As String
)
void WriteLine(
    String^ message
)
abstract WriteLine :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

ILog Interface
WriteLine Overload
VirtualRadar.Interface Namespace


ILog.WriteLine Method (String, Object[])

ILogWriteLine Method (String, Object)
Writes a line of text to the log file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void WriteLine(
    string format,
    params Object[] args
)
Sub WriteLine (
    format As String,
    ParamArray args As Object()
)
void WriteLine(
    String^ format,
    ... array<Object^>^ args
)
abstract WriteLine :
        format : string *
        args : Object[] -> unit

Parameters

format
Type: SystemString
args
Type: SystemObject
See Also

Reference

ILog Interface
WriteLine Overload
VirtualRadar.Interface Namespace


ILogProvider Interface

ILogProvider Interface
The interface for objects that abstract away the environment for ILog implementations.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILogProvider
Public Interface ILogProvider
public interface class ILogProvider
type ILogProvider =  interface end

The ILogProvider type exposes the following members.

Properties
 | Name | Description
Public property | CurrentThreadId | Gets the ID number of the current thread.
Top
Methods
 | Name | Description
Public method | AppendAllText | Appends the text to the file passed across. If the file does not exist then it is created.
Public method | CreateFolder | Creates the folder if it doesn't exist.
Public method | FileExists | Returns true if the file described by the fullPath exists.
Public method | FolderExists | Returns true if the folder exists.
Public method | GetTail | Returns the last so-many lines of log, or all of them if < 1 lines are requested.
Public method | TruncateTo | Truncates the file to the last so-many bytes in the original.
Top
See Also

Reference

VirtualRadar.Interface Namespace


ILogProvider Properties

ILogProvider Properties

The ILogProvider type exposes the following members.

Properties
 | Name | Description
Public property | CurrentThreadId | Gets the ID number of the current thread.
Top
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.CurrentThreadId Property

ILogProviderCurrentThreadId Property
Gets the ID number of the current thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int CurrentThreadId { get; }
ReadOnly Property CurrentThreadId As Integer
    Get
property int CurrentThreadId {
    int get ();
}
abstract CurrentThreadId : int with get

Property Value

Type: Int32
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider Methods

ILogProvider Methods

The ILogProvider type exposes the following members.

Methods
 | Name | Description
Public method | AppendAllText | Appends the text to the file passed across. If the file does not exist then it is created.
Public method | CreateFolder | Creates the folder if it doesn't exist.
Public method | FileExists | Returns true if the file described by the fullPath exists.
Public method | FolderExists | Returns true if the folder exists.
Public method | GetTail | Returns the last so-many lines of log, or all of them if < 1 lines are requested.
Public method | TruncateTo | Truncates the file to the last so-many bytes in the original.
Top
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.AppendAllText Method

ILogProviderAppendAllText Method
Appends the text to the file passed across. If the file does not exist then it is created.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AppendAllText(
    string fullPath,
    string text
)
Sub AppendAllText (
    fullPath As String,
    text As String
)
void AppendAllText(
    String^ fullPath,
    String^ text
)
abstract AppendAllText :
        fullPath : string *
        text : string -> unit

Parameters

fullPath
Type: SystemString
text
Type: SystemString
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.CreateFolder Method

ILogProviderCreateFolder Method
Creates the folder if it doesn't exist.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateFolder(
    string folder
)
Sub CreateFolder (
    folder As String
)
void CreateFolder(
    String^ folder
)
abstract CreateFolder :
        folder : string -> unit

Parameters

folder
Type: SystemString
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.FileExists Method

ILogProviderFileExists Method
Returns true if the file described by the fullPath exists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FileExists(
    string fullPath
)
Function FileExists (
    fullPath As String
) As Boolean
bool FileExists(
    String^ fullPath
)
abstract FileExists :
        fullPath : string -> bool

Parameters

fullPath
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.FolderExists Method

ILogProviderFolderExists Method
Returns true if the folder exists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FolderExists(
    string folder
)
Function FolderExists (
    folder As String
) As Boolean
bool FolderExists(
    String^ folder
)
abstract FolderExists :
        folder : string -> bool

Parameters

folder
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.GetTail Method

ILogProviderGetTail Method
Returns the last so-many lines of log, or all of them if < 1 lines are requested.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] GetTail(
    string fullPath,
    int lines
)
Function GetTail (
    fullPath As String,
    lines As Integer
) As String()
array<String^>^ GetTail(
    String^ fullPath,
    int lines
)
abstract GetTail :
        fullPath : string *
        lines : int -> string[]

Parameters

fullPath
Type: SystemString
lines
Type: SystemInt32

Return Value

Type: String
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


ILogProvider.TruncateTo Method

ILogProviderTruncateTo Method
Truncates the file to the last so-many bytes in the original.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TruncateTo(
    string fullPath,
    int bytes
)
Sub TruncateTo (
    fullPath As String,
    bytes As Integer
)
void TruncateTo(
    String^ fullPath,
    int bytes
)
abstract TruncateTo :
        fullPath : string *
        bytes : int -> unit

Parameters

fullPath
Type: SystemString
bytes
Type: SystemInt32
See Also

Reference

ILogProvider Interface
VirtualRadar.Interface Namespace


IMessageBox Interface

IMessageBox Interface
The interface for an object that can show a modal message to the user.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMessageBox
Public Interface IMessageBox
public interface class IMessageBox
type IMessageBox =  interface end
Methods
 | Name | Description
Public method | Show(String) | Shows a message to the user.
Public method | Show(String, String) | Shows a message with a title to the user.
Public method | Show(String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a message with a title and a set of choices to the user. Returns the choice selected by the user.
Top
Remarks
Wraps the WinForms MessageBox static class so that it can be abstracted away in environments that do not have WinForms available to them.
See Also

Reference

VirtualRadar.Interface Namespace


IMessageBox Methods

IMessageBox Methods
Methods
 | Name | Description
Public method | Show(String) | Shows a message to the user.
Public method | Show(String, String) | Shows a message with a title to the user.
Public method | Show(String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a message with a title and a set of choices to the user. Returns the choice selected by the user.
Top
See Also

Reference

IMessageBox Interface
VirtualRadar.Interface Namespace


IMessageBox.Show Method

IMessageBoxShow Method
Overload List
 | Name | Description
Public method | Show(String) | Shows a message to the user.
Public method | Show(String, String) | Shows a message with a title to the user.
Public method | Show(String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a message with a title and a set of choices to the user. Returns the choice selected by the user.
Top
See Also

Reference

IMessageBox Interface
VirtualRadar.Interface Namespace


IMessageBox.Show Method (String)

IMessageBoxShow Method (String)
Shows a message to the user.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Show(
    string message
)
Sub Show (
    message As String
)
void Show(
    String^ message
)
abstract Show :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

IMessageBox Interface
Show Overload
VirtualRadar.Interface Namespace


IMessageBox.Show Method (String, String)

IMessageBoxShow Method (String, String)
Shows a message with a title to the user.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Show(
    string message,
    string title
)
Sub Show (
    message As String,
    title As String
)
void Show(
    String^ message,
    String^ title
)
abstract Show :
        message : string *
        title : string -> unit

Parameters

message
Type: SystemString
title
Type: SystemString
See Also

Reference

IMessageBox Interface
Show Overload
VirtualRadar.Interface Namespace


IMessageBox.Show Method (String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton)

IMessageBoxShow Method (String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton)
Shows a message with a title and a set of choices to the user. Returns the choice selected by the user.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult Show(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Function Show (
    message As String,
    title As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon,
    defaultButton As MessageBoxDefaultButton
) As DialogResult
DialogResult Show(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
abstract Show :
        message : string *
        title : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon *
        defaultButton : MessageBoxDefaultButton -> DialogResult

Parameters

message
Type: SystemString
title
Type: SystemString
buttons
Type: System.Windows.FormsMessageBoxButtons
icon
Type: System.Windows.FormsMessageBoxIcon
defaultButton
Type: System.Windows.FormsMessageBoxDefaultButton

Return Value

Type: DialogResult
See Also

Reference

IMessageBox Interface
Show Overload
VirtualRadar.Interface Namespace


INewVersionChecker Interface

INewVersionChecker Interface
The interface for objects that can check with the VirtualRadarServer website to see whether a new version is available for download.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INewVersionChecker : ISingleton<INewVersionChecker>
Public Interface INewVersionChecker
    Inherits ISingleton(Of INewVersionChecker)
public interface class INewVersionChecker : ISingleton<INewVersionChecker^>
type INewVersionChecker =
    interface
        interface ISingleton<INewVersionChecker>
    end

The INewVersionChecker type exposes the following members.

Properties
 | Name | Description
Public property | DownloadUrl | Gets the URL of the new version of the application.
Public property | IsNewVersionAvailable | Gets a value indicating that a new version is avaiable for download from the website.
Public property | Provider | Gets or sets the provider that abstracts away the environment for testing purposes.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | CheckForNewVersion | Checks to see whether a new version is available, returning true if it is and setting IsNewVersionAvailable.
Top
Events
 | Name | Description
Public event | NewVersionAvailable | Raised when CheckForNewVersion detects that a new version is available for download. It is recommended that you hook the version of this on Singleton and be prepared for it being called on a non-GUI thread.
Top
See Also

Reference

VirtualRadar.Interface Namespace


INewVersionChecker Properties

INewVersionChecker Properties

The INewVersionChecker type exposes the following members.

Properties
 | Name | Description
Public property | DownloadUrl | Gets the URL of the new version of the application.
Public property | IsNewVersionAvailable | Gets a value indicating that a new version is avaiable for download from the website.
Public property | Provider | Gets or sets the provider that abstracts away the environment for testing purposes.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker.DownloadUrl Property

INewVersionCheckerDownloadUrl Property
Gets the URL of the new version of the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DownloadUrl { get; }
ReadOnly Property DownloadUrl As String
    Get
property String^ DownloadUrl {
    String^ get ();
}
abstract DownloadUrl : string with get

Property Value

Type: String
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker.IsNewVersionAvailable Property

INewVersionCheckerIsNewVersionAvailable Property
Gets a value indicating that a new version is avaiable for download from the website.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsNewVersionAvailable { get; }
ReadOnly Property IsNewVersionAvailable As Boolean
    Get
property bool IsNewVersionAvailable {
    bool get ();
}
abstract IsNewVersionAvailable : bool with get

Property Value

Type: Boolean
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker.Provider Property

INewVersionCheckerProvider Property
Gets or sets the provider that abstracts away the environment for testing purposes.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
INewVersionCheckerProvider Provider { get; set; }
Property Provider As INewVersionCheckerProvider
    Get
    Set
property INewVersionCheckerProvider^ Provider {
    INewVersionCheckerProvider^ get ();
    void set (INewVersionCheckerProvider^ value);
}
abstract Provider : INewVersionCheckerProvider with get, set

Property Value

Type: INewVersionCheckerProvider
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker Methods

INewVersionChecker Methods

The INewVersionChecker type exposes the following members.

Methods
 | Name | Description
Public method | CheckForNewVersion | Checks to see whether a new version is available, returning true if it is and setting IsNewVersionAvailable.
Top
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker.CheckForNewVersion Method

INewVersionCheckerCheckForNewVersion Method
Checks to see whether a new version is available, returning true if it is and setting IsNewVersionAvailable.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CheckForNewVersion()
Function CheckForNewVersion As Boolean
bool CheckForNewVersion()
abstract CheckForNewVersion : unit -> bool

Return Value

Type: Boolean
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker Events

INewVersionChecker Events

The INewVersionChecker type exposes the following members.

Events
 | Name | Description
Public event | NewVersionAvailable | Raised when CheckForNewVersion detects that a new version is available for download. It is recommended that you hook the version of this on Singleton and be prepared for it being called on a non-GUI thread.
Top
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionChecker.NewVersionAvailable Event

INewVersionCheckerNewVersionAvailable Event
Raised when CheckForNewVersion detects that a new version is available for download. It is recommended that you hook the version of this on Singleton and be prepared for it being called on a non-GUI thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler NewVersionAvailable
Event NewVersionAvailable As EventHandler
 event EventHandler^ NewVersionAvailable {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract NewVersionAvailable : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INewVersionChecker Interface
VirtualRadar.Interface Namespace


INewVersionCheckerProvider Interface

INewVersionCheckerProvider Interface
The interface for providers that abstract away parts of the environment for testing.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INewVersionCheckerProvider
Public Interface INewVersionCheckerProvider
public interface class INewVersionCheckerProvider
type INewVersionCheckerProvider =  interface end

The INewVersionCheckerProvider type exposes the following members.

Methods
 | Name | Description
Public method | DownloadFileContent | Downloads a file from the Internet and returns its content.
Top
See Also

Reference

VirtualRadar.Interface Namespace


INewVersionCheckerProvider Methods

INewVersionCheckerProvider Methods

The INewVersionCheckerProvider type exposes the following members.

Methods
 | Name | Description
Public method | DownloadFileContent | Downloads a file from the Internet and returns its content.
Top
See Also

Reference

INewVersionCheckerProvider Interface
VirtualRadar.Interface Namespace


INewVersionCheckerProvider.DownloadFileContent Method

INewVersionCheckerProviderDownloadFileContent Method
Downloads a file from the Internet and returns its content.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DownloadFileContent(
    string url
)
Function DownloadFileContent (
    url As String
) As String
String^ DownloadFileContent(
    String^ url
)
abstract DownloadFileContent :
        url : string -> string

Parameters

url
Type: SystemString

Return Value

Type: String
See Also

Reference

INewVersionCheckerProvider Interface
VirtualRadar.Interface Namespace


IPAddressComparer Class

IPAddressComparer Class
A class that can compare two IPAddresses for relative order.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceIPAddressComparer

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IPAddressComparer : IComparer<IPAddress>
Public Class IPAddressComparer
    Implements IComparer(Of IPAddress)
public ref class IPAddressComparer : IComparer<IPAddress^>
type IPAddressComparer =
    class
        interface IComparer<IPAddress>
    end

The IPAddressComparer type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressComparer | Initializes a new instance of the IPAddressComparer class
Top
Properties
Name | Description
Singleton | Gets a singleton instance of IPAddressComparer.
Top
Methods
 | Name | Description
Public method | Compare | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


IPAddressComparer Constructor

IPAddressComparer Constructor
Initializes a new instance of the IPAddressComparer class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddressComparer()
Public Sub New
public:
IPAddressComparer()
new : unit -> IPAddressComparer
See Also

Reference

IPAddressComparer Class
VirtualRadar.Interface Namespace


IPAddressComparer Properties

IPAddressComparer Properties

The IPAddressComparer type exposes the following members.

Properties
Name | Description
Singleton | Gets a singleton instance of IPAddressComparer.
Top
See Also

Reference

IPAddressComparer Class
VirtualRadar.Interface Namespace


IPAddressComparer.Singleton Property

IPAddressComparerSingleton Property
Gets a singleton instance of IPAddressComparer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPAddressComparer Singleton { get; }
Public Shared ReadOnly Property Singleton As IPAddressComparer
    Get
public:
static property IPAddressComparer^ Singleton {
    IPAddressComparer^ get ();
}
static member Singleton : IPAddressComparer with get

Property Value

Type: IPAddressComparer
See Also

Reference

IPAddressComparer Class
VirtualRadar.Interface Namespace


IPAddressComparer Methods

IPAddressComparer Methods

The IPAddressComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IPAddressComparer Class
VirtualRadar.Interface Namespace


IPAddressComparer.Compare Method

IPAddressComparerCompare Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    IPAddress x,
    IPAddress y
)
Public Function Compare (
    x As IPAddress,
    y As IPAddress
) As Integer
public:
virtual int Compare(
    IPAddress^ x,
    IPAddress^ y
) sealed
abstract Compare :
        x : IPAddress *
        y : IPAddress -> int
override Compare :
        x : IPAddress *
        y : IPAddress -> int

Parameters

x
Type: System.NetIPAddress
y
Type: System.NetIPAddress

Return Value

Type: Int32

Implements

IComparerTCompare(T, T)
See Also

Reference

IPAddressComparer Class
VirtualRadar.Interface Namespace


IPAddressHelper Class

IPAddressHelper Class
A static class of methods that can help when dealing with IPAddress objects.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceIPAddressHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class IPAddressHelper
Public NotInheritable Class IPAddressHelper
public ref class IPAddressHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IPAddressHelper =  class end

The IPAddressHelper type exposes the following members.

Methods
Name | Description
IsLinkLocal | Returns true if the IPAddress passed across is a link local address.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IPAddressHelper Methods

IPAddressHelper Methods

The IPAddressHelper type exposes the following members.

Methods
Name | Description
IsLinkLocal | Returns true if the IPAddress passed across is a link local address.
Top
See Also

Reference

IPAddressHelper Class
VirtualRadar.Interface Namespace


IPAddressHelper.IsLinkLocal Method

IPAddressHelperIsLinkLocal Method
Returns true if the IPAddress passed across is a link local address.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLinkLocal(
    IPAddress ipAddress
)
Public Shared Function IsLinkLocal (
    ipAddress As IPAddress
) As Boolean
public:
static bool IsLinkLocal(
    IPAddress^ ipAddress
)
static member IsLinkLocal :
        ipAddress : IPAddress -> bool

Parameters

ipAddress
Type: System.NetIPAddress

Return Value

Type: Boolean
See Also

Reference

IPAddressHelper Class
VirtualRadar.Interface Namespace


IPEndPointHelper Class

IPEndPointHelper Class
A static helper class that can make life easier when dealing with IPEndPoint objects.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceIPEndPointHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class IPEndPointHelper
Public NotInheritable Class IPEndPointHelper
public ref class IPEndPointHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IPEndPointHelper =  class end

The IPEndPointHelper type exposes the following members.

Methods
Name | Description
IsLocalOrLanAddress | Returns true if the endpoint looks like it is on the LAN.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IPEndPointHelper Methods

IPEndPointHelper Methods

The IPEndPointHelper type exposes the following members.

Methods
Name | Description
IsLocalOrLanAddress | Returns true if the endpoint looks like it is on the LAN.
Top
See Also

Reference

IPEndPointHelper Class
VirtualRadar.Interface Namespace


IPEndPointHelper.IsLocalOrLanAddress Method

IPEndPointHelperIsLocalOrLanAddress Method
Returns true if the endpoint looks like it is on the LAN.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLocalOrLanAddress(
    IPEndPoint ipEndPoint
)
Public Shared Function IsLocalOrLanAddress (
    ipEndPoint As IPEndPoint
) As Boolean
public:
static bool IsLocalOrLanAddress(
    IPEndPoint^ ipEndPoint
)
static member IsLocalOrLanAddress :
        ipEndPoint : IPEndPoint -> bool

Parameters

ipEndPoint
Type: System.NetIPEndPoint

Return Value

Type: Boolean
See Also

Reference

IPEndPointHelper Class
VirtualRadar.Interface Namespace


IPlugin Interface

IPlugin Interface
Describes the interface for a class that plugin DLLs must implement in order to be loaded by Virtual Radar Server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPlugin
Public Interface IPlugin
public interface class IPlugin
type IPlugin =  interface end

The IPlugin type exposes the following members.

Properties
 | Name | Description
Public property | HasOptions | Gets a value indicating that the plugin has user-configurable settings.
Public property | Id | Gets the unique identifier of the plugin.
Public property | Name | Gets the name of the plugin. This is only shown to the user, it is otherwise unused by Virtual Radar Server.
Public property | PluginFolder | Gets or sets the folder that the plugin has been installed into.
Public property | Status | Gets a short string describing the state of the plugin (e.g. Disabled, Enabled, Writing to XYZ etc.).
Public property | StatusDescription | Gets a longer string giving more information on Status. If no description is appropriate, i.e. Status already says everything you want to say, then return an empty string or null.
Public property | Version | Gets the version number of the plugin. This is only shown to the user, it is otherwise unused by Virtual Radar Server.
Top
Methods
 | Name | Description
Public method | GuiThreadStartup | Called by VRS on the GUI thread after Startup(PluginStartupParameters) has been called.
Public method | RegisterImplementations | Called by VRS during the early stages of program startup to give the plugin a chance to register its own implementations of the program interfaces. This is called before the UI has been built up, do not make GUI calls from here.
Public method | ShowWinFormsOptionsUI | Called by VRS when the user wants to change the options for the application. This will not be called if HasOptions is false. You must present the options using WinForms. The function will be called on the GUI thread.
Public method | Shutdown | Called by VRS when the program is closing down, before the web server etc. have been destroyed. This may be called on a background thread, do not make GUI calls from within here.
Public method | Startup | Called by VRS towards the end of the splash screen, after the web server etc. have been built up but before the main window is displayed. This is called on a background thread. Do not make any calls that must be made on the GUI thread from here.
Top
Events
 | Name | Description
Public event | StatusChanged | Raised by the plugin whenever Status or StatusChanged has been updated by the plugin.
Top
Remarks

Plugin libraries are loaded by Virtual Radar Server during startup. The program looks for DLLs whose name matches VirtualRadar.Plugin.*.dll in subfolders below the Virtual Radar Server "Plugins" folder. It loads each DLL into the process and then searches for a public class that implements this interface. If it can find one then it instantiates the object implementing the interface and makes calls upon it at various points in the life of the application to give the plugin the opportunity to change the way the program behaves.

See Also

Reference

VirtualRadar.Interface Namespace


IPlugin Properties

IPlugin Properties

The IPlugin type exposes the following members.

Properties
 | Name | Description
Public property | HasOptions | Gets a value indicating that the plugin has user-configurable settings.
Public property | Id | Gets the unique identifier of the plugin.
Public property | Name | Gets the name of the plugin. This is only shown to the user, it is otherwise unused by Virtual Radar Server.
Public property | PluginFolder | Gets or sets the folder that the plugin has been installed into.
Public property | Status | Gets a short string describing the state of the plugin (e.g. Disabled, Enabled, Writing to XYZ etc.).
Public property | StatusDescription | Gets a longer string giving more information on Status. If no description is appropriate, i.e. Status already says everything you want to say, then return an empty string or null.
Public property | Version | Gets the version number of the plugin. This is only shown to the user, it is otherwise unused by Virtual Radar Server.
Top
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.HasOptions Property

IPluginHasOptions Property
Gets a value indicating that the plugin has user-configurable settings.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasOptions { get; }
ReadOnly Property HasOptions As Boolean
    Get
property bool HasOptions {
    bool get ();
}
abstract HasOptions : bool with get

Property Value

Type: Boolean
Remarks
If you return false here then the user will not be shown an Options button against your plugin in Virtual Radar Server's list of plugins and ShowWinFormsOptionsUI will never be called.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.Id Property

IPluginId Property
Gets the unique identifier of the plugin.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Id { get; }
ReadOnly Property Id As String
    Get
property String^ Id {
    String^ get ();
}
abstract Id : string with get

Property Value

Type: String
Remarks

This identifier should be different to that of all other plugins and should remain constant regardless of the version of the plugin or the region that the application is running under. VRS plugins use the name of the plugin DLL as the identifier (e.g. 'VirtualRadar.Plugin.Foobar' for virtualradar.plugin.foobar.dll) but you can use a GUID if you like.

The ID is used by PluginSettings to uniquely identify the settings for a plugin so if you change it across releases of your plugin then you may have problems reading old settings. It is recommended that once you set the identifier for a plugin you never change it.

See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.Name Property

IPluginName Property
Gets the name of the plugin. This is only shown to the user, it is otherwise unused by Virtual Radar Server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.PluginFolder Property

IPluginPluginFolder Property
Gets or sets the folder that the plugin has been installed into.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string PluginFolder { get; set; }
Property PluginFolder As String
    Get
    Set
property String^ PluginFolder {
    String^ get ();
    void set (String^ value);
}
abstract PluginFolder : string with get, set

Property Value

Type: String
Remarks
The plugin should just provide the property - VRS will fill this value in when it loads the plugin. It will not be filled in until after the constructor has finished running so you cannot refer to it from the constructor.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.Status Property

IPluginStatus Property
Gets a short string describing the state of the plugin (e.g. Disabled, Enabled, Writing to XYZ etc.).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Status { get; }
ReadOnly Property Status As String
    Get
property String^ Status {
    String^ get ();
}
abstract Status : string with get

Property Value

Type: String
Remarks
You should raise StatusChanged when you change the value of this property.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.StatusDescription Property

IPluginStatusDescription Property
Gets a longer string giving more information on Status. If no description is appropriate, i.e. Status already says everything you want to say, then return an empty string or null.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string StatusDescription { get; }
ReadOnly Property StatusDescription As String
    Get
property String^ StatusDescription {
    String^ get ();
}
abstract StatusDescription : string with get

Property Value

Type: String
Remarks
You should raise StatusChanged when you change the value of this property.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.Version Property

IPluginVersion Property
Gets the version number of the plugin. This is only shown to the user, it is otherwise unused by Virtual Radar Server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Version { get; }
ReadOnly Property Version As String
    Get
property String^ Version {
    String^ get ();
}
abstract Version : string with get

Property Value

Type: String
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin Methods

IPlugin Methods

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | GuiThreadStartup | Called by VRS on the GUI thread after Startup(PluginStartupParameters) has been called.
Public method | RegisterImplementations | Called by VRS during the early stages of program startup to give the plugin a chance to register its own implementations of the program interfaces. This is called before the UI has been built up, do not make GUI calls from here.
Public method | ShowWinFormsOptionsUI | Called by VRS when the user wants to change the options for the application. This will not be called if HasOptions is false. You must present the options using WinForms. The function will be called on the GUI thread.
Public method | Shutdown | Called by VRS when the program is closing down, before the web server etc. have been destroyed. This may be called on a background thread, do not make GUI calls from within here.
Public method | Startup | Called by VRS towards the end of the splash screen, after the web server etc. have been built up but before the main window is displayed. This is called on a background thread. Do not make any calls that must be made on the GUI thread from here.
Top
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.GuiThreadStartup Method

IPluginGuiThreadStartup Method
Called by VRS on the GUI thread after Startup(PluginStartupParameters) has been called.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GuiThreadStartup()
Sub GuiThreadStartup
void GuiThreadStartup()
abstract GuiThreadStartup : unit -> unit
Remarks

Some plugins may need to perform some startup work on the GUI thread. This method is guaranteed to be called on the GUI thread by the main presenter.

The method is called after the main view has been constructed but before it is shown to the user. At the point where this is called no UI will be visible to the user.

See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.RegisterImplementations Method

IPluginRegisterImplementations Method
Called by VRS during the early stages of program startup to give the plugin a chance to register its own implementations of the program interfaces. This is called before the UI has been built up, do not make GUI calls from here.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterImplementations(
    IClassFactory classFactory
)
Sub RegisterImplementations (
    classFactory As IClassFactory
)
void RegisterImplementations(
    IClassFactory^ classFactory
)
abstract RegisterImplementations :
        classFactory : IClassFactory -> unit

Parameters

classFactory
Type: InterfaceFactoryIClassFactory
Remarks

VRS works by declaring interfaces for all of the important classes in VirtualRadar.Interfaces and then registering implementations of those interfaces with a class factory. Whenever the program wants to obtain an implementation of an interface it calls the class factory.

This method is called after VRS has registered all of its implementations for the interfaces but before any of them have been instantiated. If you want to replace one or more of the standard implementations of the interfaces with your own version then this is the time to do so.

Plugins are loaded in a random order. It is possible that another plugin could override your implementation of a VRS class with its own. Also please note that any exception thrown by this method will result in your plugin being disabled and the class factory reset back to how it was before your plugin made any changes.

See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.ShowWinFormsOptionsUI Method

IPluginShowWinFormsOptionsUI Method
Called by VRS when the user wants to change the options for the application. This will not be called if HasOptions is false. You must present the options using WinForms. The function will be called on the GUI thread.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowWinFormsOptionsUI()
Sub ShowWinFormsOptionsUI
void ShowWinFormsOptionsUI()
abstract ShowWinFormsOptionsUI : unit -> unit
Remarks
See IPluginSettingsStorage for the object to use to load and save your plugin's settings.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.Shutdown Method

IPluginShutdown Method
Called by VRS when the program is closing down, before the web server etc. have been destroyed. This may be called on a background thread, do not make GUI calls from within here.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Shutdown()
Sub Shutdown
void Shutdown()
abstract Shutdown : unit -> unit
Remarks
The plugin should use this method to release any resources that it has held onto for the duration of the program, close any open files, shut down background threads etc.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.Startup Method

IPluginStartup Method
Called by VRS towards the end of the splash screen, after the web server etc. have been built up but before the main window is displayed. This is called on a background thread. Do not make any calls that must be made on the GUI thread from here.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Startup(
    PluginStartupParameters parameters
)
Sub Startup (
    parameters As PluginStartupParameters
)
void Startup(
    PluginStartupParameters^ parameters
)
abstract Startup :
        parameters : PluginStartupParameters -> unit

Parameters

parameters
Type: VirtualRadar.InterfacePluginStartupParameters
Remarks
The plugin should use this method to read its configuration, hook any events that it is interested in and generally start doing some useful work. Any exceptions thrown by this method will be displayed to the user and recorded in the log but will not cause the program to stop, nor will they cause the plugin to be unloaded.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin Events

IPlugin Events

The IPlugin type exposes the following members.

Events
 | Name | Description
Public event | StatusChanged | Raised by the plugin whenever Status or StatusChanged has been updated by the plugin.
Top
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPlugin.StatusChanged Event

IPluginStatusChanged Event
Raised by the plugin whenever Status or StatusChanged has been updated by the plugin.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler StatusChanged
Event StatusChanged As EventHandler
 event EventHandler^ StatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
VRS does not make any assumptions about which thread this is raised on, you can raise it on the GUI thread or a background thread.
See Also

Reference

IPlugin Interface
VirtualRadar.Interface Namespace


IPluginManager Interface

IPluginManager Interface
The interface for the object that manages plugins on behalf of the program.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginManager : ISingleton<IPluginManager>
Public Interface IPluginManager
    Inherits ISingleton(Of IPluginManager)
public interface class IPluginManager : ISingleton<IPluginManager^>
type IPluginManager =
    interface
        interface ISingleton<IPluginManager>
    end

The IPluginManager type exposes the following members.

Properties
 | Name | Description
Public property | IgnoredPlugins | Gets a map of the reason why a plugin was not loaded indexed by the full path and filename of the plugin DLL.
Public property | LoadedPlugins | Gets a list of every plugin that's been loaded into VRS.
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | LoadPlugins | Loads the DLLs in the Plugins folder and calls their RegisterImplementations(IClassFactory) methods.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IPluginManager Properties

IPluginManager Properties

The IPluginManager type exposes the following members.

Properties
 | Name | Description
Public property | IgnoredPlugins | Gets a map of the reason why a plugin was not loaded indexed by the full path and filename of the plugin DLL.
Public property | LoadedPlugins | Gets a list of every plugin that's been loaded into VRS.
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IPluginManager Interface
VirtualRadar.Interface Namespace


IPluginManager.IgnoredPlugins Property

IPluginManagerIgnoredPlugins Property
Gets a map of the reason why a plugin was not loaded indexed by the full path and filename of the plugin DLL.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, string> IgnoredPlugins { get; }
ReadOnly Property IgnoredPlugins As IDictionary(Of String, String)
    Get
property IDictionary<String^, String^>^ IgnoredPlugins {
    IDictionary<String^, String^>^ get ();
}
abstract IgnoredPlugins : IDictionary<string, string> with get

Property Value

Type: IDictionary String, String
See Also

Reference

IPluginManager Interface
VirtualRadar.Interface Namespace


IPluginManager.LoadedPlugins Property

IPluginManagerLoadedPlugins Property
Gets a list of every plugin that's been loaded into VRS.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IPlugin> LoadedPlugins { get; }
ReadOnly Property LoadedPlugins As IList(Of IPlugin)
    Get
property IList<IPlugin^>^ LoadedPlugins {
    IList<IPlugin^>^ get ();
}
abstract LoadedPlugins : IList<IPlugin> with get

Property Value

Type: IList IPlugin
See Also

Reference

IPluginManager Interface
VirtualRadar.Interface Namespace


IPluginManager.Provider Property

IPluginManagerProvider Property
Gets or sets the object that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPluginManagerProvider Provider { get; set; }
Property Provider As IPluginManagerProvider
    Get
    Set
property IPluginManagerProvider^ Provider {
    IPluginManagerProvider^ get ();
    void set (IPluginManagerProvider^ value);
}
abstract Provider : IPluginManagerProvider with get, set

Property Value

Type: IPluginManagerProvider
See Also

Reference

IPluginManager Interface
VirtualRadar.Interface Namespace


IPluginManager Methods

IPluginManager Methods

The IPluginManager type exposes the following members.

Methods
 | Name | Description
Public method | LoadPlugins | Loads the DLLs in the Plugins folder and calls their RegisterImplementations(IClassFactory) methods.
Top
See Also

Reference

IPluginManager Interface
VirtualRadar.Interface Namespace


IPluginManager.LoadPlugins Method

IPluginManagerLoadPlugins Method
Loads the DLLs in the Plugins folder and calls their RegisterImplementations(IClassFactory) methods.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadPlugins()
Sub LoadPlugins
void LoadPlugins()
abstract LoadPlugins : unit -> unit
See Also

Reference

IPluginManager Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider Interface

IPluginManagerProvider Interface
The interface for objects that abstract away the environment for IPluginManager implementations.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginManagerProvider
Public Interface IPluginManagerProvider
public interface class IPluginManagerProvider
type IPluginManagerProvider =  interface end

The IPluginManagerProvider type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationStartupPath | Gets the folder that the program was started from.
Top
Methods
 | Name | Description
Public method | ClassFactoryRestoreSnapshot | Restores the global class factory back to the state it was when a snapshot was taken.
Public method | ClassFactoryTakeSnapshot | Takes a snapshot of the current state of the class factory.
Public method | DirectoryExists | Returns true if the folder exists.
Public method | DirectoryGetDirectories | Returns all of the folders in the folder passed across.
Public method | DirectoryGetFiles | Returns all of the files matching the search pattern in the folder passed across.
Public method | LoadTypes | Returns a collection of every type contained within what *could* be a .NET DLL. Could throw any number of exceptions.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IPluginManagerProvider Properties

IPluginManagerProvider Properties

The IPluginManagerProvider type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationStartupPath | Gets the folder that the program was started from.
Top
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.ApplicationStartupPath Property

IPluginManagerProviderApplicationStartupPath Property
Gets the folder that the program was started from.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ApplicationStartupPath { get; }
ReadOnly Property ApplicationStartupPath As String
    Get
property String^ ApplicationStartupPath {
    String^ get ();
}
abstract ApplicationStartupPath : string with get

Property Value

Type: String
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider Methods

IPluginManagerProvider Methods

The IPluginManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | ClassFactoryRestoreSnapshot | Restores the global class factory back to the state it was when a snapshot was taken.
Public method | ClassFactoryTakeSnapshot | Takes a snapshot of the current state of the class factory.
Public method | DirectoryExists | Returns true if the folder exists.
Public method | DirectoryGetDirectories | Returns all of the folders in the folder passed across.
Public method | DirectoryGetFiles | Returns all of the files matching the search pattern in the folder passed across.
Public method | LoadTypes | Returns a collection of every type contained within what *could* be a .NET DLL. Could throw any number of exceptions.
Top
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.ClassFactoryRestoreSnapshot Method

IPluginManagerProviderClassFactoryRestoreSnapshot Method
Restores the global class factory back to the state it was when a snapshot was taken.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClassFactoryRestoreSnapshot(
    IClassFactory snapshot
)
Sub ClassFactoryRestoreSnapshot (
    snapshot As IClassFactory
)
void ClassFactoryRestoreSnapshot(
    IClassFactory^ snapshot
)
abstract ClassFactoryRestoreSnapshot :
        snapshot : IClassFactory -> unit

Parameters

snapshot
Type: InterfaceFactoryIClassFactory
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.ClassFactoryTakeSnapshot Method

IPluginManagerProviderClassFactoryTakeSnapshot Method
Takes a snapshot of the current state of the class factory.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IClassFactory ClassFactoryTakeSnapshot()
Function ClassFactoryTakeSnapshot As IClassFactory
IClassFactory^ ClassFactoryTakeSnapshot()
abstract ClassFactoryTakeSnapshot : unit -> IClassFactory

Return Value

Type: IClassFactory
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.DirectoryExists Method

IPluginManagerProviderDirectoryExists Method
Returns true if the folder exists.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DirectoryExists(
    string folder
)
Function DirectoryExists (
    folder As String
) As Boolean
bool DirectoryExists(
    String^ folder
)
abstract DirectoryExists :
        folder : string -> bool

Parameters

folder
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.DirectoryGetDirectories Method

IPluginManagerProviderDirectoryGetDirectories Method
Returns all of the folders in the folder passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> DirectoryGetDirectories(
    string folder
)
Function DirectoryGetDirectories (
    folder As String
) As IEnumerable(Of String)
IEnumerable<String^>^ DirectoryGetDirectories(
    String^ folder
)
abstract DirectoryGetDirectories :
        folder : string -> IEnumerable<string>

Parameters

folder
Type: SystemString

Return Value

Type: IEnumerable String
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.DirectoryGetFiles Method

IPluginManagerProviderDirectoryGetFiles Method
Returns all of the files matching the search pattern in the folder passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> DirectoryGetFiles(
    string folder,
    string searchPattern
)
Function DirectoryGetFiles (
    folder As String,
    searchPattern As String
) As IEnumerable(Of String)
IEnumerable<String^>^ DirectoryGetFiles(
    String^ folder,
    String^ searchPattern
)
abstract DirectoryGetFiles :
        folder : string *
        searchPattern : string -> IEnumerable<string>

Parameters

folder
Type: SystemString
searchPattern
Type: SystemString

Return Value

Type: IEnumerable String
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IPluginManagerProvider.LoadTypes Method

IPluginManagerProviderLoadTypes Method
Returns a collection of every type contained within what *could* be a .NET DLL. Could throw any number of exceptions.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<Type> LoadTypes(
    string fullPath
)
Function LoadTypes (
    fullPath As String
) As IEnumerable(Of Type)
IEnumerable<Type^>^ LoadTypes(
    String^ fullPath
)
abstract LoadTypes :
        fullPath : string -> IEnumerable<Type>

Parameters

fullPath
Type: SystemString

Return Value

Type: IEnumerable Type
See Also

Reference

IPluginManagerProvider Interface
VirtualRadar.Interface Namespace


IQueue Interface

IQueue Interface
The interface for queues that can be interrogated to find out how many items they are holding.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IQueue
Public Interface IQueue
public interface class IQueue
type IQueue =  interface end

The IQueue type exposes the following members.

Properties
 | Name | Description
Public property | CountDroppedItems | Gets the total number of items dropped from the queue.
Public property | CountQueuedItems | Gets the number of items in the queue.
Public property | Name | Gets the name of the queue.
Public property | PeakQueuedItems | Gets the largest number of items ever held in the queue.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IQueue Properties

IQueue Properties

The IQueue type exposes the following members.

Properties
 | Name | Description
Public property | CountDroppedItems | Gets the total number of items dropped from the queue.
Public property | CountQueuedItems | Gets the number of items in the queue.
Public property | Name | Gets the name of the queue.
Public property | PeakQueuedItems | Gets the largest number of items ever held in the queue.
Top
See Also

Reference

IQueue Interface
VirtualRadar.Interface Namespace


IQueue.CountDroppedItems Property

IQueueCountDroppedItems Property
Gets the total number of items dropped from the queue.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CountDroppedItems { get; }
ReadOnly Property CountDroppedItems As Long
    Get
property long long CountDroppedItems {
    long long get ();
}
abstract CountDroppedItems : int64 with get

Property Value

Type: Int64
See Also

Reference

IQueue Interface
VirtualRadar.Interface Namespace


IQueue.CountQueuedItems Property

IQueueCountQueuedItems Property
Gets the number of items in the queue.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int CountQueuedItems { get; }
ReadOnly Property CountQueuedItems As Integer
    Get
property int CountQueuedItems {
    int get ();
}
abstract CountQueuedItems : int with get

Property Value

Type: Int32
See Also

Reference

IQueue Interface
VirtualRadar.Interface Namespace


IQueue.Name Property

IQueueName Property
Gets the name of the queue.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IQueue Interface
VirtualRadar.Interface Namespace


IQueue.PeakQueuedItems Property

IQueuePeakQueuedItems Property
Gets the largest number of items ever held in the queue.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int PeakQueuedItems { get; }
ReadOnly Property PeakQueuedItems As Integer
    Get
property int PeakQueuedItems {
    int get ();
}
abstract PeakQueuedItems : int with get

Property Value

Type: Int32
See Also

Reference

IQueue Interface
VirtualRadar.Interface Namespace


IRuntimeEnvironment Interface

IRuntimeEnvironment Interface
The interface for singleton objects that can tell the program about the environment it's running under.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRuntimeEnvironment : ISingleton<IRuntimeEnvironment>
Public Interface IRuntimeEnvironment
    Inherits ISingleton(Of IRuntimeEnvironment)
public interface class IRuntimeEnvironment : ISingleton<IRuntimeEnvironment^>
type IRuntimeEnvironment =
    interface
        interface ISingleton<IRuntimeEnvironment>
    end

The IRuntimeEnvironment type exposes the following members.

Properties
 | Name | Description
Public property | ExecutablePath | Gets the path to the application.
Public property | Is64BitProcess | Gets a value indicating that the program is running as a 64-bit process.
Public property | IsMono | Gets a value indicating that the program is running under Mono.
Public property | IsTest | Gets or sets a value indicating that the application is running under the unit test environment.
Public property | MainThreadCultureInfo | Gets the main thread's culture info.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


IRuntimeEnvironment Properties

IRuntimeEnvironment Properties

The IRuntimeEnvironment type exposes the following members.

Properties
 | Name | Description
Public property | ExecutablePath | Gets the path to the application.
Public property | Is64BitProcess | Gets a value indicating that the program is running as a 64-bit process.
Public property | IsMono | Gets a value indicating that the program is running under Mono.
Public property | IsTest | Gets or sets a value indicating that the application is running under the unit test environment.
Public property | MainThreadCultureInfo | Gets the main thread's culture info.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IRuntimeEnvironment Interface
VirtualRadar.Interface Namespace


IRuntimeEnvironment.ExecutablePath Property

IRuntimeEnvironmentExecutablePath Property
Gets the path to the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExecutablePath { get; }
ReadOnly Property ExecutablePath As String
    Get
property String^ ExecutablePath {
    String^ get ();
}
abstract ExecutablePath : string with get

Property Value

Type: String
See Also

Reference

IRuntimeEnvironment Interface
VirtualRadar.Interface Namespace


IRuntimeEnvironment.Is64BitProcess Property

IRuntimeEnvironmentIs64BitProcess Property
Gets a value indicating that the program is running as a 64-bit process.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Is64BitProcess { get; }
ReadOnly Property Is64BitProcess As Boolean
    Get
property bool Is64BitProcess {
    bool get ();
}
abstract Is64BitProcess : bool with get

Property Value

Type: Boolean
See Also

Reference

IRuntimeEnvironment Interface
VirtualRadar.Interface Namespace


IRuntimeEnvironment.IsMono Property

IRuntimeEnvironmentIsMono Property
Gets a value indicating that the program is running under Mono.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMono { get; }
ReadOnly Property IsMono As Boolean
    Get
property bool IsMono {
    bool get ();
}
abstract IsMono : bool with get

Property Value

Type: Boolean
See Also

Reference

IRuntimeEnvironment Interface
VirtualRadar.Interface Namespace


IRuntimeEnvironment.IsTest Property

IRuntimeEnvironmentIsTest Property
Gets or sets a value indicating that the application is running under the unit test environment.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsTest { get; set; }
Property IsTest As Boolean
    Get
    Set
property bool IsTest {
    bool get ();
    void set (bool value);
}
abstract IsTest : bool with get, set

Property Value

Type: Boolean
Remarks
The default implementation of this property always returns false. Some tests may provide mock implementations that always return true. The intention here is to allow multithreading code to detect when it's running under unit tests and turn itself off, forcing all actions onto a single thread thereby making classes that use multi-threading internally a lot more testable.
See Also

Reference

IRuntimeEnvironment Interface
VirtualRadar.Interface Namespace


IRuntimeEnvironment.MainThreadCultureInfo Property

IRuntimeEnvironmentMainThreadCultureInfo Property
Gets the main thread's culture info.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CultureInfo MainThreadCultureInfo { get; }
ReadOnly Property MainThreadCultureInfo As CultureInfo
    Get
property CultureInfo^ MainThreadCultureInfo {
    CultureInfo^ get ();
}
abstract MainThreadCultureInfo : CultureInfo with get

Property Value

Type: CultureInfo
See Also

Reference

IRuntimeEnvironment Interface
VirtualRadar.Interface Namespace


ISimpleAircraftList Interface

ISimpleAircraftList Interface
The interface for implementations of IAircraftList that can have aircraft created and added to the list by the program rather than from an external source like an instance of BaseStation.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISimpleAircraftList : IAircraftList,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface ISimpleAircraftList
    Inherits IAircraftList, IBackgroundThreadExceptionCatcher, IDisposable
public interface class ISimpleAircraftList : IAircraftList,
    IBackgroundThreadExceptionCatcher, IDisposable
type ISimpleAircraftList =
    interface
        interface IAircraftList
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The ISimpleAircraftList type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets the list of aircraft that will be exposed by the standard aircraft list methods.
Public property | Count | Gets the total number of aircraft currently being tracked. (Inherited from IAircraftList.)
Public property | IsTracking | Gets a value indicating that the aircraft list is tracking aircraft. (Inherited from IAircraftList.)
Public property | ListSyncLock | Gets the object that should be used to lock the Aircraft list before it is modified.
Public property | Source | Gets or sets the aircraft source - overrides the base version which is read-only.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindAircraft | Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Public method | Start | Starts the tracking of aircraft. (Inherited from IAircraftList.)
Public method | Stop | Stops tracking aircraft. (Inherited from IAircraftList.)
Public method | TakeSnapshot | Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Top
Events
 | Name | Description
Public event | CountChanged | Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread. (Inherited from IAircraftList.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | TrackingStateChanged | Raised when the aircraft list is started or stopped. Could be raised from any thread. (Inherited from IAircraftList.)
Top
Remarks
This is used to hold aircraft lists that are generated by the program, such as the flight simulator aircraft list.
See Also

Reference

VirtualRadar.Interface Namespace


ISimpleAircraftList Properties

ISimpleAircraftList Properties

The ISimpleAircraftList type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets the list of aircraft that will be exposed by the standard aircraft list methods.
Public property | Count | Gets the total number of aircraft currently being tracked. (Inherited from IAircraftList.)
Public property | IsTracking | Gets a value indicating that the aircraft list is tracking aircraft. (Inherited from IAircraftList.)
Public property | ListSyncLock | Gets the object that should be used to lock the Aircraft list before it is modified.
Public property | Source | Gets or sets the aircraft source - overrides the base version which is read-only.
Top
See Also

Reference

ISimpleAircraftList Interface
VirtualRadar.Interface Namespace


ISimpleAircraftList.Aircraft Property

ISimpleAircraftListAircraft Property
Gets the list of aircraft that will be exposed by the standard aircraft list methods.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<IAircraft> Aircraft { get; }
ReadOnly Property Aircraft As List(Of IAircraft)
    Get
property List<IAircraft^>^ Aircraft {
    List<IAircraft^>^ get ();
}
abstract Aircraft : List<IAircraft> with get

Property Value

Type: List IAircraft
Remarks
The list will automatically make clones of these aircraft objects when it presents them to the outside world. It will lock each aircraft when making the clone using the IAircraft itself as the sync lock and it will lock the list using the ListSyncLock property.
See Also

Reference

ISimpleAircraftList Interface
VirtualRadar.Interface Namespace


ISimpleAircraftList.ListSyncLock Property

ISimpleAircraftListListSyncLock Property
Gets the object that should be used to lock the Aircraft list before it is modified.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object ListSyncLock { get; }
ReadOnly Property ListSyncLock As Object
    Get
property Object^ ListSyncLock {
    Object^ get ();
}
abstract ListSyncLock : Object with get

Property Value

Type: Object
Remarks
If the list will not be accessed from multiple threads then this can be ignored. Bear in mind that if the list is given to the website or web server then it will be accessed from multiple threads by those.
See Also

Reference

ISimpleAircraftList Interface
VirtualRadar.Interface Namespace


ISimpleAircraftList.Source Property

ISimpleAircraftListSource Property
Gets or sets the aircraft source - overrides the base version which is read-only.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftListSource Source { get; set; }
Property Source As AircraftListSource
    Get
    Set
property AircraftListSource Source {
    AircraftListSource get ();
    void set (AircraftListSource value);
}
abstract Source : AircraftListSource with get, set

Property Value

Type: AircraftListSource

Implements

IAircraftListSource
Remarks
Writes to this are not particularly thread-safe but it is anticipated that it will only be written once when the list is first created and then left alone. This value is sent to the web site but as at the time of writing it is unused, it's just there for diagnostic purposes.
See Also

Reference

ISimpleAircraftList Interface
VirtualRadar.Interface Namespace


ISimpleAircraftList Methods

ISimpleAircraftList Methods

The ISimpleAircraftList type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindAircraft | Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Public method | Start | Starts the tracking of aircraft. (Inherited from IAircraftList.)
Public method | Stop | Stops tracking aircraft. (Inherited from IAircraftList.)
Public method | TakeSnapshot | Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Top
See Also

Reference

ISimpleAircraftList Interface
VirtualRadar.Interface Namespace


ISimpleAircraftList Events

ISimpleAircraftList Events

The ISimpleAircraftList type exposes the following members.

Events
 | Name | Description
Public event | CountChanged | Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread. (Inherited from IAircraftList.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | TrackingStateChanged | Raised when the aircraft list is started or stopped. Could be raised from any thread. (Inherited from IAircraftList.)
Top
See Also

Reference

ISimpleAircraftList Interface
VirtualRadar.Interface Namespace


ISingleton(T) Interface

ISingletonT Interface
Declares that the interface this is implemented by is intended to be used as a singleton.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISingleton<T>

Public Interface ISingleton(Of T)
generic<typename T>
public interface class ISingleton
type ISingleton<'T> =  interface end

Type Parameters

T
The interface of the singleton object.

The ISingletonT type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application.
Top
Remarks

All interfaces that are intended to be used as a singleton (i.e. only one instance of them should be used across the entire application) implement this interface. This has a few advantages - it makes the use of a singleton obvious when reading the code, which hopefully avoids the accidental disposal of a singleton object, and the use of singletons can be detected by the unit tests which can then in turn automatically check that mocks of singleton objects are used correctly.

The drawback with this approach is that you must create an instance of the class before you can access the Singleton property. This instance is unused and so it represents a waste of time and memory. Further you might accidentally use the instance instead of its Singleton, which could produce some hard-to-track-down bugs.

An alternate approach would have been to use the facilities in the class factory to register singleton instances of an interface, which would not need a special interface. This would have worked but presents its own set of problems, the most tricky of all being how you handle singletons that are disposable. If you use the class factory approach then you can't tell whether you getting a unique instance of an object or a singleton instance when you resolve an interface, so you always call Dispose and hope the interface's implementation doesn't do anything until the Dispose call is made during program shutdown. This can complicate the implementation of the interface. Using the ISingleton<> approach you can say that all objects created by the class factory are distinct instances, you can assume that it will not return singletons, and if you ask it for a disposable object you will need to dispose of it when you've finished using it.

Examples
This is the normal pattern for accessing an interface that implements ISingleton:
Copy
ILog log = Factory.Singleton.Resolve<ILog>().Singleton;
log.WriteLine("This will appear in the log");
This is the normal pattern for creating the singleton object in an implementation:
Copy
public interface IMyInterface : ISingleton<IMyInterface>
{
}

class Implementation : IMyInterface
{
    private static readonly IMyInterface _Singleton = new Implementation();
    public IMyInterface Singleton
    {
        get { return _Singleton; }
    }
}
See Also

Reference

VirtualRadar.Interface Namespace


ISingleton(T) Properties

ISingletonT Properties

The ISingletonT generic type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application.
Top
See Also

Reference

ISingletonT Interface
VirtualRadar.Interface Namespace


ISingleton(T).Singleton Property

ISingletonTSingleton Property
Gets the single instance of the class that should be used throughout the application.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
T Singleton { get; }
ReadOnly Property Singleton As T
    Get
property T Singleton {
    T get ();
}
abstract Singleton : 'T with get

Property Value

Type: T
See Also

Reference

ISingletonT Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper Interface

ISpeechSynthesizerWrapper Interface
The interface for a wrapper around the .NET SpeechSynthesizer class.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISpeechSynthesizerWrapper : IDisposable
Public Interface ISpeechSynthesizerWrapper
    Inherits IDisposable
public interface class ISpeechSynthesizerWrapper : IDisposable
type ISpeechSynthesizerWrapper =
    interface
        interface IDisposable
    end

The ISpeechSynthesizerWrapper type exposes the following members.

Properties
 | Name | Description
Public property | DefaultVoiceName | Gets the default voice name.
Public property | Rate | Gets or sets the text-to-speech rate.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInstalledVoiceNames | Returns a collection of the name of every installed voice.
Public method | SelectVoice | Selects a voice by name.
Public method | SetOutputToDefaultAudioDevice | Sends the output to the default audio device.
Public method | SpeakAsync | Converts the text to speech asynchronously.
Top
Remarks
There are two default implementations for this, one that is used when the program runs under .NET and another that is used when the program runs under Mono. Mono does not support the SpeechSynthesizer class and any attempt to instantiate it sends the program into hyperspace, so this just wraps the parts of the .NET class that the application uses.
See Also

Reference

VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper Properties

ISpeechSynthesizerWrapper Properties

The ISpeechSynthesizerWrapper type exposes the following members.

Properties
 | Name | Description
Public property | DefaultVoiceName | Gets the default voice name.
Public property | Rate | Gets or sets the text-to-speech rate.
Top
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper.DefaultVoiceName Property

ISpeechSynthesizerWrapperDefaultVoiceName Property
Gets the default voice name.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DefaultVoiceName { get; }
ReadOnly Property DefaultVoiceName As String
    Get
property String^ DefaultVoiceName {
    String^ get ();
}
abstract DefaultVoiceName : string with get

Property Value

Type: String
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper.Rate Property

ISpeechSynthesizerWrapperRate Property
Gets or sets the text-to-speech rate.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Rate { get; set; }
Property Rate As Integer
    Get
    Set
property int Rate {
    int get ();
    void set (int value);
}
abstract Rate : int with get, set

Property Value

Type: Int32
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper Methods

ISpeechSynthesizerWrapper Methods

The ISpeechSynthesizerWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetInstalledVoiceNames | Returns a collection of the name of every installed voice.
Public method | SelectVoice | Selects a voice by name.
Public method | SetOutputToDefaultAudioDevice | Sends the output to the default audio device.
Public method | SpeakAsync | Converts the text to speech asynchronously.
Top
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper.GetInstalledVoiceNames Method

ISpeechSynthesizerWrapperGetInstalledVoiceNames Method
Returns a collection of the name of every installed voice.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetInstalledVoiceNames()
Function GetInstalledVoiceNames As IEnumerable(Of String)
IEnumerable<String^>^ GetInstalledVoiceNames()
abstract GetInstalledVoiceNames : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper.SelectVoice Method

ISpeechSynthesizerWrapperSelectVoice Method
Selects a voice by name.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectVoice(
    string name
)
Sub SelectVoice (
    name As String
)
void SelectVoice(
    String^ name
)
abstract SelectVoice :
        name : string -> unit

Parameters

name
Type: SystemString
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper.SetOutputToDefaultAudioDevice Method

ISpeechSynthesizerWrapperSetOutputToDefaultAudioDevice Method
Sends the output to the default audio device.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetOutputToDefaultAudioDevice()
Sub SetOutputToDefaultAudioDevice
void SetOutputToDefaultAudioDevice()
abstract SetOutputToDefaultAudioDevice : unit -> unit
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


ISpeechSynthesizerWrapper.SpeakAsync Method

ISpeechSynthesizerWrapperSpeakAsync Method
Converts the text to speech asynchronously.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SpeakAsync(
    string text
)
Sub SpeakAsync (
    text As String
)
void SpeakAsync(
    String^ text
)
abstract SpeakAsync :
        text : string -> unit

Parameters

text
Type: SystemString
See Also

Reference

ISpeechSynthesizerWrapper Interface
VirtualRadar.Interface Namespace


IStandaloneAircraftOnlineLookupCache Interface

IStandaloneAircraftOnlineLookupCache Interface
The interface for the standalone aircraft online lookup cache. This is the fallback that is used when no other cache is available. It is registered with a priority of zero.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStandaloneAircraftOnlineLookupCache : IAircraftOnlineLookupCache
Public Interface IStandaloneAircraftOnlineLookupCache
    Inherits IAircraftOnlineLookupCache
public interface class IStandaloneAircraftOnlineLookupCache : IAircraftOnlineLookupCache
type IStandaloneAircraftOnlineLookupCache =
    interface
        interface IAircraftOnlineLookupCache
    end

The IStandaloneAircraftOnlineLookupCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a flag indicating that the cache is enabled. (Inherited from IAircraftOnlineLookupCache.)
Public property | RefreshOutOfDateAircraft | Gets a value indicating that the aircraft manager should refresh out-of-date aircraft records as well as missing / new aircraft. (Inherited from IAircraftOnlineLookupCache.)
Top
Methods
 | Name | Description
Public method | Load | Fetches an aircraft's details from the cache. (Inherited from IAircraftOnlineLookupCache.)
Public method | LoadMany | Loads multiple records from the cache simultaneously. (Inherited from IAircraftOnlineLookupCache.)
Public method | RecordManyMissing | Records many missing ICAOs. (Inherited from IAircraftOnlineLookupCache.)
Public method | RecordMissing | Records an ICAO that has no online details. (Inherited from IAircraftOnlineLookupCache.)
Public method | Save | Saves an aircraft's details in the cache. (Inherited from IAircraftOnlineLookupCache.)
Public method | SaveMany | Saves multiple records to the cache simultaneously. (Inherited from IAircraftOnlineLookupCache.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


IStandaloneAircraftOnlineLookupCache Properties

IStandaloneAircraftOnlineLookupCache Properties

The IStandaloneAircraftOnlineLookupCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a flag indicating that the cache is enabled. (Inherited from IAircraftOnlineLookupCache.)
Public property | RefreshOutOfDateAircraft | Gets a value indicating that the aircraft manager should refresh out-of-date aircraft records as well as missing / new aircraft. (Inherited from IAircraftOnlineLookupCache.)
Top
See Also

Reference

IStandaloneAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IStandaloneAircraftOnlineLookupCache Methods

IStandaloneAircraftOnlineLookupCache Methods

The IStandaloneAircraftOnlineLookupCache type exposes the following members.

Methods
 | Name | Description
Public method | Load | Fetches an aircraft's details from the cache. (Inherited from IAircraftOnlineLookupCache.)
Public method | LoadMany | Loads multiple records from the cache simultaneously. (Inherited from IAircraftOnlineLookupCache.)
Public method | RecordManyMissing | Records many missing ICAOs. (Inherited from IAircraftOnlineLookupCache.)
Public method | RecordMissing | Records an ICAO that has no online details. (Inherited from IAircraftOnlineLookupCache.)
Public method | Save | Saves an aircraft's details in the cache. (Inherited from IAircraftOnlineLookupCache.)
Public method | SaveMany | Saves multiple records to the cache simultaneously. (Inherited from IAircraftOnlineLookupCache.)
Top
See Also

Reference

IStandaloneAircraftOnlineLookupCache Interface
VirtualRadar.Interface Namespace


IStatistics Interface

IStatistics Interface
A class that records various statistics.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStatistics
Public Interface IStatistics
public interface class IStatistics
type IStatistics =  interface end

The IStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AdsbAircraftTracked | Gets or sets the count of aircraft transmitting ADS-B messages that are being tracked;
Public property | AdsbCount | Gets or sets the count of ADS-B messages decoded.
Public property | AdsbMessageFormatCount | Gets an array, indexable by (int)MessageFormat, recording the count of each ADS-B message format received.
Public property | AdsbPositionsExceededSpeedCheck | Gets or sets the count of positions that were rejected because the vehicle would have to have been travelling unrealistically quickly to reach the position.
Public property | AdsbPositionsOutsideRange | Gets or sets the count of positions that were rejected because they lay outside the range of the receiver.
Public property | AdsbPositionsReset | Gets or sets the count of position resets that have taken place because position fixes for aircraft failed a reasonableness test.
Public property | AdsbRejected | Gets or sets the count of ADS-B messages that were rejected because of bad parity.
Public property | AdsbTypeCount | Gets an array, indexable by (int)AdsbMessage.Type, recording the count of each ADS-B message type received.
Public property | BaseStationBadFormatMessagesReceived | Gets or sets a count of badly formatted BaseStation messages received.
Public property | BaseStationMessagesReceived | Gets or sets a count of BaseStation format messages received.
Public property | BytesReceived | Gets or sets the number of bytes received by the listener.
Public property | ConnectionTimeUtc | Gets or sets the date and time at UTC when the connection to the listener was first established.
Public property | CurrentBufferSize | Gets or sets the size in bytes of the receiver buffers maintained by the listener, either directly or indirectly.
Public property | FailedChecksumMessages | Gets or sets the number of messages that had a bad checksum.
Public property | ModeSDFCount | Gets an array, indexable by (int)DownlinkFormat, recording the count of each Mode-S message type received.
Public property | ModeSLongFrameMessagesReceived | Gets or sets the number of long-frame Mode-S messages seen on the data feed.
Public property | ModeSMessagesReceived | Gets or sets the number of Mode-S messages received from a source of Mode-S data.
Public property | ModeSNotAdsbCount | Gets or sets the count of Mode-S messages that were not carrying an ADS-B payload.
Public property | ModeSShortFrameMessagesReceived | Gets or sets the number of short-frame Mode-S messages seen on the data feed.
Public property | ModeSShortFrameWithoutLongFrameMessagesReceived | Gets or sets the number of short-frame Mode-S messages that were discarded because no prior long-frame message had been received.
Public property | ModeSWithBadParityPIField | Gets or sets the number of Mode-S messages with a PI field that was not zero.
Public property | ModeSWithPIField | Gets or sets the count of Mode-S messages with a PI field.
Top
Methods
 | Name | Description
Public method | Initialise | Prepares the statistics for first use.
Public method | Lock | Calls the delegate within a lock. The delegate must not, under any circumstances, call Lock(ActionIStatistics) or do anything that might call Lock(ActionIStatistics). A deadlock may occur if it does. Does nothing if the statistics have not been initialised.
Public method | ResetConnectionStatistics | Resets connection statistics.
Public method | ResetMessageCounters | Resets all counters associated with listening to a source of messages. Does not reset connection statistics.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IStatistics Properties

IStatistics Properties

The IStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AdsbAircraftTracked | Gets or sets the count of aircraft transmitting ADS-B messages that are being tracked;
Public property | AdsbCount | Gets or sets the count of ADS-B messages decoded.
Public property | AdsbMessageFormatCount | Gets an array, indexable by (int)MessageFormat, recording the count of each ADS-B message format received.
Public property | AdsbPositionsExceededSpeedCheck | Gets or sets the count of positions that were rejected because the vehicle would have to have been travelling unrealistically quickly to reach the position.
Public property | AdsbPositionsOutsideRange | Gets or sets the count of positions that were rejected because they lay outside the range of the receiver.
Public property | AdsbPositionsReset | Gets or sets the count of position resets that have taken place because position fixes for aircraft failed a reasonableness test.
Public property | AdsbRejected | Gets or sets the count of ADS-B messages that were rejected because of bad parity.
Public property | AdsbTypeCount | Gets an array, indexable by (int)AdsbMessage.Type, recording the count of each ADS-B message type received.
Public property | BaseStationBadFormatMessagesReceived | Gets or sets a count of badly formatted BaseStation messages received.
Public property | BaseStationMessagesReceived | Gets or sets a count of BaseStation format messages received.
Public property | BytesReceived | Gets or sets the number of bytes received by the listener.
Public property | ConnectionTimeUtc | Gets or sets the date and time at UTC when the connection to the listener was first established.
Public property | CurrentBufferSize | Gets or sets the size in bytes of the receiver buffers maintained by the listener, either directly or indirectly.
Public property | FailedChecksumMessages | Gets or sets the number of messages that had a bad checksum.
Public property | ModeSDFCount | Gets an array, indexable by (int)DownlinkFormat, recording the count of each Mode-S message type received.
Public property | ModeSLongFrameMessagesReceived | Gets or sets the number of long-frame Mode-S messages seen on the data feed.
Public property | ModeSMessagesReceived | Gets or sets the number of Mode-S messages received from a source of Mode-S data.
Public property | ModeSNotAdsbCount | Gets or sets the count of Mode-S messages that were not carrying an ADS-B payload.
Public property | ModeSShortFrameMessagesReceived | Gets or sets the number of short-frame Mode-S messages seen on the data feed.
Public property | ModeSShortFrameWithoutLongFrameMessagesReceived | Gets or sets the number of short-frame Mode-S messages that were discarded because no prior long-frame message had been received.
Public property | ModeSWithBadParityPIField | Gets or sets the number of Mode-S messages with a PI field that was not zero.
Public property | ModeSWithPIField | Gets or sets the count of Mode-S messages with a PI field.
Top
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbAircraftTracked Property

IStatisticsAdsbAircraftTracked Property
Gets or sets the count of aircraft transmitting ADS-B messages that are being tracked;

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbAircraftTracked { get; set; }
Property AdsbAircraftTracked As Long
    Get
    Set
property long long AdsbAircraftTracked {
    long long get ();
    void set (long long value);
}
abstract AdsbAircraftTracked : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbCount Property

IStatisticsAdsbCount Property
Gets or sets the count of ADS-B messages decoded.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbCount { get; set; }
Property AdsbCount As Long
    Get
    Set
property long long AdsbCount {
    long long get ();
    void set (long long value);
}
abstract AdsbCount : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbMessageFormatCount Property

IStatisticsAdsbMessageFormatCount Property
Gets an array, indexable by (int)MessageFormat, recording the count of each ADS-B message format received.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long[] AdsbMessageFormatCount { get; }
ReadOnly Property AdsbMessageFormatCount As Long()
    Get
property array<long long>^ AdsbMessageFormatCount {
    array<long long>^ get ();
}
abstract AdsbMessageFormatCount : int64[] with get

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbPositionsExceededSpeedCheck Property

IStatisticsAdsbPositionsExceededSpeedCheck Property
Gets or sets the count of positions that were rejected because the vehicle would have to have been travelling unrealistically quickly to reach the position.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbPositionsExceededSpeedCheck { get; set; }
Property AdsbPositionsExceededSpeedCheck As Long
    Get
    Set
property long long AdsbPositionsExceededSpeedCheck {
    long long get ();
    void set (long long value);
}
abstract AdsbPositionsExceededSpeedCheck : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbPositionsOutsideRange Property

IStatisticsAdsbPositionsOutsideRange Property
Gets or sets the count of positions that were rejected because they lay outside the range of the receiver.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbPositionsOutsideRange { get; set; }
Property AdsbPositionsOutsideRange As Long
    Get
    Set
property long long AdsbPositionsOutsideRange {
    long long get ();
    void set (long long value);
}
abstract AdsbPositionsOutsideRange : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbPositionsReset Property

IStatisticsAdsbPositionsReset Property
Gets or sets the count of position resets that have taken place because position fixes for aircraft failed a reasonableness test.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbPositionsReset { get; set; }
Property AdsbPositionsReset As Long
    Get
    Set
property long long AdsbPositionsReset {
    long long get ();
    void set (long long value);
}
abstract AdsbPositionsReset : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbRejected Property

IStatisticsAdsbRejected Property
Gets or sets the count of ADS-B messages that were rejected because of bad parity.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbRejected { get; set; }
Property AdsbRejected As Long
    Get
    Set
property long long AdsbRejected {
    long long get ();
    void set (long long value);
}
abstract AdsbRejected : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.AdsbTypeCount Property

IStatisticsAdsbTypeCount Property
Gets an array, indexable by (int)AdsbMessage.Type, recording the count of each ADS-B message type received.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long[] AdsbTypeCount { get; }
ReadOnly Property AdsbTypeCount As Long()
    Get
property array<long long>^ AdsbTypeCount {
    array<long long>^ get ();
}
abstract AdsbTypeCount : int64[] with get

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.BaseStationBadFormatMessagesReceived Property

IStatisticsBaseStationBadFormatMessagesReceived Property
Gets or sets a count of badly formatted BaseStation messages received.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BaseStationBadFormatMessagesReceived { get; set; }
Property BaseStationBadFormatMessagesReceived As Long
    Get
    Set
property long long BaseStationBadFormatMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract BaseStationBadFormatMessagesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.BaseStationMessagesReceived Property

IStatisticsBaseStationMessagesReceived Property
Gets or sets a count of BaseStation format messages received.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BaseStationMessagesReceived { get; set; }
Property BaseStationMessagesReceived As Long
    Get
    Set
property long long BaseStationMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract BaseStationMessagesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.BytesReceived Property

IStatisticsBytesReceived Property
Gets or sets the number of bytes received by the listener.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BytesReceived { get; set; }
Property BytesReceived As Long
    Get
    Set
property long long BytesReceived {
    long long get ();
    void set (long long value);
}
abstract BytesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ConnectionTimeUtc Property

IStatisticsConnectionTimeUtc Property
Gets or sets the date and time at UTC when the connection to the listener was first established.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<DateTime> ConnectionTimeUtc { get; set; }
Property ConnectionTimeUtc As Nullable(Of DateTime)
    Get
    Set
property Nullable<DateTime> ConnectionTimeUtc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
abstract ConnectionTimeUtc : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.CurrentBufferSize Property

IStatisticsCurrentBufferSize Property
Gets or sets the size in bytes of the receiver buffers maintained by the listener, either directly or indirectly.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CurrentBufferSize { get; set; }
Property CurrentBufferSize As Long
    Get
    Set
property long long CurrentBufferSize {
    long long get ();
    void set (long long value);
}
abstract CurrentBufferSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.FailedChecksumMessages Property

IStatisticsFailedChecksumMessages Property
Gets or sets the number of messages that had a bad checksum.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long FailedChecksumMessages { get; set; }
Property FailedChecksumMessages As Long
    Get
    Set
property long long FailedChecksumMessages {
    long long get ();
    void set (long long value);
}
abstract FailedChecksumMessages : int64 with get, set

Property Value

Type: Int64
Remarks
This will only be of interest with radios that apply a checksum to their messages, e.g. the SBS-3.
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSDFCount Property

IStatisticsModeSDFCount Property
Gets an array, indexable by (int)DownlinkFormat, recording the count of each Mode-S message type received.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long[] ModeSDFCount { get; }
ReadOnly Property ModeSDFCount As Long()
    Get
property array<long long>^ ModeSDFCount {
    array<long long>^ get ();
}
abstract ModeSDFCount : int64[] with get

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSLongFrameMessagesReceived Property

IStatisticsModeSLongFrameMessagesReceived Property
Gets or sets the number of long-frame Mode-S messages seen on the data feed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSLongFrameMessagesReceived { get; set; }
Property ModeSLongFrameMessagesReceived As Long
    Get
    Set
property long long ModeSLongFrameMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract ModeSLongFrameMessagesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSMessagesReceived Property

IStatisticsModeSMessagesReceived Property
Gets or sets the number of Mode-S messages received from a source of Mode-S data.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSMessagesReceived { get; set; }
Property ModeSMessagesReceived As Long
    Get
    Set
property long long ModeSMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract ModeSMessagesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSNotAdsbCount Property

IStatisticsModeSNotAdsbCount Property
Gets or sets the count of Mode-S messages that were not carrying an ADS-B payload.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSNotAdsbCount { get; set; }
Property ModeSNotAdsbCount As Long
    Get
    Set
property long long ModeSNotAdsbCount {
    long long get ();
    void set (long long value);
}
abstract ModeSNotAdsbCount : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSShortFrameMessagesReceived Property

IStatisticsModeSShortFrameMessagesReceived Property
Gets or sets the number of short-frame Mode-S messages seen on the data feed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSShortFrameMessagesReceived { get; set; }
Property ModeSShortFrameMessagesReceived As Long
    Get
    Set
property long long ModeSShortFrameMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract ModeSShortFrameMessagesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSShortFrameWithoutLongFrameMessagesReceived Property

IStatisticsModeSShortFrameWithoutLongFrameMessagesReceived Property
Gets or sets the number of short-frame Mode-S messages that were discarded because no prior long-frame message had been received.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSShortFrameWithoutLongFrameMessagesReceived { get; set; }
Property ModeSShortFrameWithoutLongFrameMessagesReceived As Long
    Get
    Set
property long long ModeSShortFrameWithoutLongFrameMessagesReceived {
    long long get ();
    void set (long long value);
}
abstract ModeSShortFrameWithoutLongFrameMessagesReceived : int64 with get, set

Property Value

Type: Int64
Remarks
It will be normal for this to go up continuously, even on a good feed.
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSWithBadParityPIField Property

IStatisticsModeSWithBadParityPIField Property
Gets or sets the number of Mode-S messages with a PI field that was not zero.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSWithBadParityPIField { get; set; }
Property ModeSWithBadParityPIField As Long
    Get
    Set
property long long ModeSWithBadParityPIField {
    long long get ();
    void set (long long value);
}
abstract ModeSWithBadParityPIField : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ModeSWithPIField Property

IStatisticsModeSWithPIField Property
Gets or sets the count of Mode-S messages with a PI field.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSWithPIField { get; set; }
Property ModeSWithPIField As Long
    Get
    Set
property long long ModeSWithPIField {
    long long get ();
    void set (long long value);
}
abstract ModeSWithPIField : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics Methods

IStatistics Methods

The IStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Prepares the statistics for first use.
Public method | Lock | Calls the delegate within a lock. The delegate must not, under any circumstances, call Lock(ActionIStatistics) or do anything that might call Lock(ActionIStatistics). A deadlock may occur if it does. Does nothing if the statistics have not been initialised.
Public method | ResetConnectionStatistics | Resets connection statistics.
Public method | ResetMessageCounters | Resets all counters associated with listening to a source of messages. Does not reset connection statistics.
Top
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.Initialise Method

IStatisticsInitialise Method
Prepares the statistics for first use.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.Lock Method

IStatisticsLock Method
Calls the delegate within a lock. The delegate must not, under any circumstances, call Lock(ActionIStatistics) or do anything that might call Lock(ActionIStatistics). A deadlock may occur if it does. Does nothing if the statistics have not been initialised.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Lock(
    Action<IStatistics> lockedDelegate
)
Sub Lock (
    lockedDelegate As Action(Of IStatistics)
)
void Lock(
    Action<IStatistics^>^ lockedDelegate
)
abstract Lock :
        lockedDelegate : Action<IStatistics> -> unit

Parameters

lockedDelegate
Type: SystemAction IStatistics
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ResetConnectionStatistics Method

IStatisticsResetConnectionStatistics Method
Resets connection statistics.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetConnectionStatistics()
Sub ResetConnectionStatistics
void ResetConnectionStatistics()
abstract ResetConnectionStatistics : unit -> unit
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


IStatistics.ResetMessageCounters Method

IStatisticsResetMessageCounters Method
Resets all counters associated with listening to a source of messages. Does not reset connection statistics.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetMessageCounters()
Sub ResetMessageCounters
void ResetMessageCounters()
abstract ResetMessageCounters : unit -> unit
See Also

Reference

IStatistics Interface
VirtualRadar.Interface Namespace


ITimer Interface

ITimer Interface
The interface for objects that periodically raise an event.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITimer : IDisposable
Public Interface ITimer
    Inherits IDisposable
public interface class ITimer : IDisposable
type ITimer =
    interface
        interface IDisposable
    end

The ITimer type exposes the following members.

Properties
 | Name | Description
Public property | AutoReset | Gets or sets a value indicating whether the Elapsed event should be raised every time the interval elapses (true) or only once (false).
Public property | Enabled | Gets or sets a value indicating that the Elapsed event should be periodically raised.
Public property | Interval | Gets or sets the interval at which to raise the Elapsed event.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts the timer.
Public method | Stop | Stops the timer.
Top
Events
 | Name | Description
Public event | Elapsed | Raised when the interval elapses.
Top
Remarks
This is just wrapping a standard System.Timers timer. It exists so that objects that rely on timers can be unit tested.
See Also

Reference

VirtualRadar.Interface Namespace


ITimer Properties

ITimer Properties

The ITimer type exposes the following members.

Properties
 | Name | Description
Public property | AutoReset | Gets or sets a value indicating whether the Elapsed event should be raised every time the interval elapses (true) or only once (false).
Public property | Enabled | Gets or sets a value indicating that the Elapsed event should be periodically raised.
Public property | Interval | Gets or sets the interval at which to raise the Elapsed event.
Top
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer.AutoReset Property

ITimerAutoReset Property
Gets or sets a value indicating whether the Elapsed event should be raised every time the interval elapses (true) or only once (false).

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoReset { get; set; }
Property AutoReset As Boolean
    Get
    Set
property bool AutoReset {
    bool get ();
    void set (bool value);
}
abstract AutoReset : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer.Enabled Property

ITimerEnabled Property
Gets or sets a value indicating that the Elapsed event should be periodically raised.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer.Interval Property

ITimerInterval Property
Gets or sets the interval at which to raise the Elapsed event.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double Interval { get; set; }
Property Interval As Double
    Get
    Set
property double Interval {
    double get ();
    void set (double value);
}
abstract Interval : float with get, set

Property Value

Type: Double
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer Methods

ITimer Methods

The ITimer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts the timer.
Public method | Stop | Stops the timer.
Top
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer.Start Method

ITimerStart Method
Starts the timer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer.Stop Method

ITimerStop Method
Stops the timer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
Remarks
Note that the event can still fire while this function is running.
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer Events

ITimer Events

The ITimer type exposes the following members.

Events
 | Name | Description
Public event | Elapsed | Raised when the interval elapses.
Top
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


ITimer.Elapsed Event

ITimerElapsed Event
Raised when the interval elapses.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Elapsed
Event Elapsed As EventHandler
 event EventHandler^ Elapsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Elapsed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ITimer Interface
VirtualRadar.Interface Namespace


IWeakEventHandler(E) Interface

IWeakEventHandlerE Interface
The interface for event handlers that can hold a weak reference to a target.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWeakEventHandler<E>
where E : EventArgs

Public Interface IWeakEventHandler(Of E As EventArgs)
generic<typename E>
where E : EventArgs
public interface class IWeakEventHandler
type IWeakEventHandler<'E when 'E : EventArgs> =  interface end

Type Parameters

E

The IWeakEventHandlerE type exposes the following members.

Properties
 | Name | Description
Public property | Handler | The event handler.
Top
See Also

Reference

VirtualRadar.Interface Namespace


IWeakEventHandler(E) Properties

IWeakEventHandlerE Properties

The IWeakEventHandlerE generic type exposes the following members.

Properties
 | Name | Description
Public property | Handler | The event handler.
Top
See Also

Reference

IWeakEventHandlerE Interface
VirtualRadar.Interface Namespace


IWeakEventHandler(E).Handler Property

IWeakEventHandlerEHandler Property
The event handler.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
EventHandler<E> Handler { get; }
ReadOnly Property Handler As EventHandler(Of E)
    Get
property EventHandler<E>^ Handler {
    EventHandler<E>^ get ();
}
abstract Handler : EventHandler<'E> with get

Property Value

Type: EventHandler E
See Also

Reference

IWeakEventHandlerE Interface
VirtualRadar.Interface Namespace


IXmlSerialiser Interface

IXmlSerialiser Interface
The interface for objects that can serialise objects to XML and deserialise objects from XML.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IXmlSerialiser
Public Interface IXmlSerialiser
public interface class IXmlSerialiser
type IXmlSerialiser =  interface end

The IXmlSerialiser type exposes the following members.

Properties
 | Name | Description
Public property | XmlSerializerCompatible | Gets or sets a value indicating that attempts to serialise objects that can't be deserialised by System.Xml.XmlSerializer will throw an exception. Defaults to true.
Top
Methods
 | Name | Description
Public method | DeserialiseT(Stream) | Deserialises the object from a stream.
Public method | DeserialiseT(TextReader) | Deserialises the object from a text writer.
Public method | Serialise(Object, Stream) | Serialises the object to a stream.
Public method | Serialise(Object, TextWriter) | Serialises the object to a text writer.
Top
Remarks
The implementation of this interface doesn't need to be able to serialise and deserialise everything that XmlSerializer can do, it just needs to be able to do enough to handle the Configuration.xml file. I used to use XmlSerializer to read and write this but then Mono started whining about namespaces, so I needed to work around Mono (again). This is the result. I'm not writing anything else in XML, any new serialisation is going to use JSON. However I can't switch the configuration over to JSON, it would make life hard for people who want to roll back to pre-JSON-configuration versions of VRS.
See Also

Reference

VirtualRadar.Interface Namespace


IXmlSerialiser Properties

IXmlSerialiser Properties

The IXmlSerialiser type exposes the following members.

Properties
 | Name | Description
Public property | XmlSerializerCompatible | Gets or sets a value indicating that attempts to serialise objects that can't be deserialised by System.Xml.XmlSerializer will throw an exception. Defaults to true.
Top
See Also

Reference

IXmlSerialiser Interface
VirtualRadar.Interface Namespace


IXmlSerialiser.XmlSerializerCompatible Property

IXmlSerialiserXmlSerializerCompatible Property
Gets or sets a value indicating that attempts to serialise objects that can't be deserialised by System.Xml.XmlSerializer will throw an exception. Defaults to true.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool XmlSerializerCompatible { get; set; }
Property XmlSerializerCompatible As Boolean
    Get
    Set
property bool XmlSerializerCompatible {
    bool get ();
    void set (bool value);
}
abstract XmlSerializerCompatible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IXmlSerialiser Interface
VirtualRadar.Interface Namespace


IXmlSerialiser Methods

IXmlSerialiser Methods
Methods
 | Name | Description
Public method | DeserialiseT(Stream) | Deserialises the object from a stream.
Public method | DeserialiseT(TextReader) | Deserialises the object from a text writer.
Public method | Serialise(Object, Stream) | Serialises the object to a stream.
Public method | Serialise(Object, TextWriter) | Serialises the object to a text writer.
Top
See Also

Reference

IXmlSerialiser Interface
VirtualRadar.Interface Namespace


IXmlSerialiser.Deserialise Method

IXmlSerialiserDeserialise Method
Overload List
 | Name | Description
Public method | DeserialiseT(Stream) | Deserialises the object from a stream.
Public method | DeserialiseT(TextReader) | Deserialises the object from a text writer.
Top
See Also

Reference

IXmlSerialiser Interface
VirtualRadar.Interface Namespace


IXmlSerialiser.Deserialise(T) Method (Stream)

IXmlSerialiserDeserialiseT Method (Stream)
Deserialises the object from a stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
T Deserialise<T>(
    Stream stream
)
where T : class, new()

Function Deserialise(Of T As {Class, New}) (
    stream As Stream
) As T
generic<typename T>
where T : ref class, gcnew()
T Deserialise(
    Stream^ stream
)
abstract Deserialise :
        stream : Stream -> 'T  when 'T : not struct, new()

Parameters

stream
Type: System.IOStream

Type Parameters

T

Return Value

Type: T
See Also

Reference

IXmlSerialiser Interface
Deserialise Overload
VirtualRadar.Interface Namespace


IXmlSerialiser.Deserialise(T) Method (TextReader)

IXmlSerialiserDeserialiseT Method (TextReader)
Deserialises the object from a text writer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
T Deserialise<T>(
    TextReader textReader
)
where T : class, new()

Function Deserialise(Of T As {Class, New}) (
    textReader As TextReader
) As T
generic<typename T>
where T : ref class, gcnew()
T Deserialise(
    TextReader^ textReader
)
abstract Deserialise :
        textReader : TextReader -> 'T  when 'T : not struct, new()

Parameters

textReader
Type: System.IOTextReader

Type Parameters

T

Return Value

Type: T
See Also

Reference

IXmlSerialiser Interface
Deserialise Overload
VirtualRadar.Interface Namespace


IXmlSerialiser.Serialise Method

IXmlSerialiserSerialise Method
Overload List
 | Name | Description
Public method | Serialise(Object, Stream) | Serialises the object to a stream.
Public method | Serialise(Object, TextWriter) | Serialises the object to a text writer.
Top
See Also

Reference

IXmlSerialiser Interface
VirtualRadar.Interface Namespace


IXmlSerialiser.Serialise Method (Object, Stream)

IXmlSerialiserSerialise Method (Object, Stream)
Serialises the object to a stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Serialise(
    Object obj,
    Stream stream
)
Sub Serialise (
    obj As Object,
    stream As Stream
)
void Serialise(
    Object^ obj,
    Stream^ stream
)
abstract Serialise :
        obj : Object *
        stream : Stream -> unit

Parameters

obj
Type: SystemObject
stream
Type: System.IOStream
See Also

Reference

IXmlSerialiser Interface
Serialise Overload
VirtualRadar.Interface Namespace


IXmlSerialiser.Serialise Method (Object, TextWriter)

IXmlSerialiserSerialise Method (Object, TextWriter)
Serialises the object to a text writer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Serialise(
    Object obj,
    TextWriter textWriter
)
Sub Serialise (
    obj As Object,
    textWriter As TextWriter
)
void Serialise(
    Object^ obj,
    TextWriter^ textWriter
)
abstract Serialise :
        obj : Object *
        textWriter : TextWriter -> unit

Parameters

obj
Type: SystemObject
textWriter
Type: System.IOTextWriter
See Also

Reference

IXmlSerialiser Interface
Serialise Overload
VirtualRadar.Interface Namespace


JavascriptHelper Class

JavascriptHelper Class
A collection of assorted methods that help make dealing with Javascript a bit easier.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceJavascriptHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class JavascriptHelper
Public NotInheritable Class JavascriptHelper
public ref class JavascriptHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JavascriptHelper =  class end
Methods
Name | Description
ToJavascriptTicks(DateTime) | Returns the Javascript ticks that represent the .NET date passed across.
ToJavascriptTicks(Int64) | Returns the Javascript equivalent of the .NET ticks passed across.
Top
See Also

Reference

VirtualRadar.Interface Namespace


JavascriptHelper Methods

JavascriptHelper Methods
Methods
Name | Description
ToJavascriptTicks(DateTime) | Returns the Javascript ticks that represent the .NET date passed across.
ToJavascriptTicks(Int64) | Returns the Javascript equivalent of the .NET ticks passed across.
Top
See Also

Reference

JavascriptHelper Class
VirtualRadar.Interface Namespace


JavascriptHelper.ToJavascriptTicks Method

JavascriptHelperToJavascriptTicks Method
Overload List
Name | Description
ToJavascriptTicks(DateTime) | Returns the Javascript ticks that represent the .NET date passed across.
ToJavascriptTicks(Int64) | Returns the Javascript equivalent of the .NET ticks passed across.
Top
See Also

Reference

JavascriptHelper Class
VirtualRadar.Interface Namespace


JavascriptHelper.ToJavascriptTicks Method (DateTime)

JavascriptHelperToJavascriptTicks Method (DateTime)
Returns the Javascript ticks that represent the .NET date passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static long ToJavascriptTicks(
    DateTime date
)
Public Shared Function ToJavascriptTicks (
    date As DateTime
) As Long
public:
static long long ToJavascriptTicks(
    DateTime date
)
static member ToJavascriptTicks :
        date : DateTime -> int64

Parameters

date
Type: SystemDateTime

Return Value

Type: Int64
See Also

Reference

JavascriptHelper Class
ToJavascriptTicks Overload
VirtualRadar.Interface Namespace


JavascriptHelper.ToJavascriptTicks Method (Int64)

JavascriptHelperToJavascriptTicks Method (Int64)
Returns the Javascript equivalent of the .NET ticks passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static long ToJavascriptTicks(
    long dotNetTicks
)
Public Shared Function ToJavascriptTicks (
    dotNetTicks As Long
) As Long
public:
static long long ToJavascriptTicks(
    long long dotNetTicks
)
static member ToJavascriptTicks :
        dotNetTicks : int64 -> int64

Parameters

dotNetTicks
Type: SystemInt64

Return Value

Type: Int64
See Also

Reference

JavascriptHelper Class
ToJavascriptTicks Overload
VirtualRadar.Interface Namespace


JsonSerialiser Class

JsonSerialiser Class
An object that can serialise to JSON.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceJsonSerialiser

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JsonSerialiser
Public Class JsonSerialiser
public ref class JsonSerialiser
type JsonSerialiser =  class end

The JsonSerialiser type exposes the following members.

Constructors
 | Name | Description
Public method | JsonSerialiser | Initializes a new instance of the JsonSerialiser class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialise | Initialises the serialiser.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteObject | Serialises the object to the stream.
Top
See Also

Reference

VirtualRadar.Interface Namespace


JsonSerialiser Constructor

JsonSerialiser Constructor
Initializes a new instance of the JsonSerialiser class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsonSerialiser()
Public Sub New
public:
JsonSerialiser()
new : unit -> JsonSerialiser
See Also

Reference

JsonSerialiser Class
VirtualRadar.Interface Namespace


JsonSerialiser Methods

JsonSerialiser Methods

The JsonSerialiser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialise | Initialises the serialiser.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteObject | Serialises the object to the stream.
Top
See Also

Reference

JsonSerialiser Class
VirtualRadar.Interface Namespace


JsonSerialiser.Initialise Method

JsonSerialiserInitialise Method
Initialises the serialiser.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise(
    Type type
)
Public Sub Initialise (
    type As Type
)
public:
void Initialise(
    Type^ type
)
member Initialise :
        type : Type -> unit

Parameters

type
Type: SystemType
See Also

Reference

JsonSerialiser Class
VirtualRadar.Interface Namespace


JsonSerialiser.WriteObject Method

JsonSerialiserWriteObject Method
Serialises the object to the stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void WriteObject(
    Stream stream,
    Object obj
)
Public Sub WriteObject (
    stream As Stream,
    obj As Object
)
public:
void WriteObject(
    Stream^ stream,
    Object^ obj
)
member WriteObject :
        stream : Stream *
        obj : Object -> unit

Parameters

stream
Type: System.IOStream
obj
Type: SystemObject
See Also

Reference

JsonSerialiser Class
VirtualRadar.Interface Namespace


OnlineHelpAddress Class

OnlineHelpAddress Class
A class exposing the addresses of online help pages.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceOnlineHelpAddress

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OnlineHelpAddress
Public NotInheritable Class OnlineHelpAddress
public ref class OnlineHelpAddress abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OnlineHelpAddress =  class end

The OnlineHelpAddress type exposes the following members.

Fields
Name | Description
WinFormsAboutDialog | The address of the online help page for the About WinForms dialog.
WinFormsConnectionClientLogDialog | The address of the online help page for the Connection Client Log dialog.
WinFormsConnectionSessionLogDialog | The address of the online help page for the Connection Session Log dialog.
WinFormsFlightSimulatorXDialog | The address of the online help page for the Flight Simulator X dialog.
WinFormsMainDialog | The address of the online help page for the Main dialog.
WinFormsOptionsDialog | The address of the online help page for the Options dialog.
WinFormsRebroadcastOptionsView | The address of the online help page for the Rebroadcast Options dialog.
WinFormsReceiverLocationsView | The address of the online help page for the Receiver Locations dialog.
WinFormsStatisticsDialog | The address of the online help page for the Statistics dialog.
Top
Remarks
The website is configured to redirect from the addresses here to wherever the online help is being stored nowadays.
See Also

Reference

VirtualRadar.Interface Namespace


OnlineHelpAddress Fields

OnlineHelpAddress Fields

The OnlineHelpAddress type exposes the following members.

Fields
Name | Description
WinFormsAboutDialog | The address of the online help page for the About WinForms dialog.
WinFormsConnectionClientLogDialog | The address of the online help page for the Connection Client Log dialog.
WinFormsConnectionSessionLogDialog | The address of the online help page for the Connection Session Log dialog.
WinFormsFlightSimulatorXDialog | The address of the online help page for the Flight Simulator X dialog.
WinFormsMainDialog | The address of the online help page for the Main dialog.
WinFormsOptionsDialog | The address of the online help page for the Options dialog.
WinFormsRebroadcastOptionsView | The address of the online help page for the Rebroadcast Options dialog.
WinFormsReceiverLocationsView | The address of the online help page for the Receiver Locations dialog.
WinFormsStatisticsDialog | The address of the online help page for the Statistics dialog.
Top
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsAboutDialog Field

OnlineHelpAddressWinFormsAboutDialog Field
The address of the online help page for the About WinForms dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsAboutDialog
Public Shared ReadOnly WinFormsAboutDialog As String
public:
static initonly String^ WinFormsAboutDialog
static val WinFormsAboutDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsConnectionClientLogDialog Field

OnlineHelpAddressWinFormsConnectionClientLogDialog Field
The address of the online help page for the Connection Client Log dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsConnectionClientLogDialog
Public Shared ReadOnly WinFormsConnectionClientLogDialog As String
public:
static initonly String^ WinFormsConnectionClientLogDialog
static val WinFormsConnectionClientLogDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsConnectionSessionLogDialog Field

OnlineHelpAddressWinFormsConnectionSessionLogDialog Field
The address of the online help page for the Connection Session Log dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsConnectionSessionLogDialog
Public Shared ReadOnly WinFormsConnectionSessionLogDialog As String
public:
static initonly String^ WinFormsConnectionSessionLogDialog
static val WinFormsConnectionSessionLogDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsFlightSimulatorXDialog Field

OnlineHelpAddressWinFormsFlightSimulatorXDialog Field
The address of the online help page for the Flight Simulator X dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsFlightSimulatorXDialog
Public Shared ReadOnly WinFormsFlightSimulatorXDialog As String
public:
static initonly String^ WinFormsFlightSimulatorXDialog
static val WinFormsFlightSimulatorXDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsMainDialog Field

OnlineHelpAddressWinFormsMainDialog Field
The address of the online help page for the Main dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsMainDialog
Public Shared ReadOnly WinFormsMainDialog As String
public:
static initonly String^ WinFormsMainDialog
static val WinFormsMainDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsOptionsDialog Field

OnlineHelpAddressWinFormsOptionsDialog Field
The address of the online help page for the Options dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsOptionsDialog
Public Shared ReadOnly WinFormsOptionsDialog As String
public:
static initonly String^ WinFormsOptionsDialog
static val WinFormsOptionsDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsRebroadcastOptionsView Field

OnlineHelpAddressWinFormsRebroadcastOptionsView Field
The address of the online help page for the Rebroadcast Options dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsRebroadcastOptionsView
Public Shared ReadOnly WinFormsRebroadcastOptionsView As String
public:
static initonly String^ WinFormsRebroadcastOptionsView
static val WinFormsRebroadcastOptionsView: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsReceiverLocationsView Field

OnlineHelpAddressWinFormsReceiverLocationsView Field
The address of the online help page for the Receiver Locations dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsReceiverLocationsView
Public Shared ReadOnly WinFormsReceiverLocationsView As String
public:
static initonly String^ WinFormsReceiverLocationsView
static val WinFormsReceiverLocationsView: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


OnlineHelpAddress.WinFormsStatisticsDialog Field

OnlineHelpAddressWinFormsStatisticsDialog Field
The address of the online help page for the Statistics dialog.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string WinFormsStatisticsDialog
Public Shared ReadOnly WinFormsStatisticsDialog As String
public:
static initonly String^ WinFormsStatisticsDialog
static val WinFormsStatisticsDialog: string

Field Value

Type: String
See Also

Reference

OnlineHelpAddress Class
VirtualRadar.Interface Namespace


Pair(T) Class

PairT Class
An immutable generic class that holds a pair of values of the same type. Can be used as a key in a hashtable / dictionary.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfacePairT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Pair<T>

Public Class Pair(Of T)
generic<typename T>
public ref class Pair
type Pair<'T> =  class end

Type Parameters

T

The PairT type exposes the following members.

Constructors
 | Name | Description
Public method | PairT | Creates a new object.
Top
Properties
 | Name | Description
Public property | First | Gets the first value in the pair.
Public property | Second | Gets the second value in the pair.
Top
Methods
 | Name | Description
Public method | Equals | Returns true if the object compares as equal to this object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hashcode for the object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


Pair(T) Constructor

PairT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Pair(
    T first,
    T second
)
Public Sub New (
    first As T,
    second As T
)
public:
Pair(
    T first,
    T second
)
new :
        first : 'T *
        second : 'T -> Pair

Parameters

first
Type: T
second
Type: T
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T) Properties

PairT Properties

The PairT generic type exposes the following members.

Properties
 | Name | Description
Public property | First | Gets the first value in the pair.
Public property | Second | Gets the second value in the pair.
Top
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T).First Property

PairTFirst Property
Gets the first value in the pair.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T First { get; }
Public ReadOnly Property First As T
    Get
public:
property T First {
    T get ();
}
member First : 'T with get

Property Value

Type: T
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T).Second Property

PairTSecond Property
Gets the second value in the pair.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Second { get; }
Public ReadOnly Property Second As T
    Get
public:
property T Second {
    T get ();
}
member Second : 'T with get

Property Value

Type: T
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T) Methods

PairT Methods

The PairT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns true if the object compares as equal to this object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hashcode for the object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T).Equals Method

PairTEquals Method
Returns true if the object compares as equal to this object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T).GetHashCode Method

PairTGetHashCode Method
Returns the hashcode for the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


Pair(T).ToString Method

PairTToString Method
Returns a description of the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

PairT Class
VirtualRadar.Interface Namespace


PictureDetail Class

PictureDetail Class
A class that describes a picture.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfacePictureDetail

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PictureDetail
Public Class PictureDetail
public ref class PictureDetail
type PictureDetail =  class end

The PictureDetail type exposes the following members.

Constructors
 | Name | Description
Public method | PictureDetail | Initializes a new instance of the PictureDetail class
Top
Properties
 | Name | Description
Public property | FileName | Gets or sets the full path to the picture.
Public property | Height | Gets or sets the height of the picture in pixels.
Public property | LastModifiedTime | Gets or sets the last modified time of the picture's file.
Public property | Length | Gets or sets the length of the picture's file.
Public property | Width | Gets or sets the width of the picture in pixels.
Top
Methods
 | Name | Description
Public method | Equals | See base docs. Only Equals is overridden, GetHashCode is not - the object is mutable and so it is not suitable for use as a key in dictionaries. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


PictureDetail Constructor

PictureDetail Constructor
Initializes a new instance of the PictureDetail class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PictureDetail()
Public Sub New
public:
PictureDetail()
new : unit -> PictureDetail
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail Properties

PictureDetail Properties

The PictureDetail type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets or sets the full path to the picture.
Public property | Height | Gets or sets the height of the picture in pixels.
Public property | LastModifiedTime | Gets or sets the last modified time of the picture's file.
Public property | Length | Gets or sets the length of the picture's file.
Public property | Width | Gets or sets the width of the picture in pixels.
Top
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail.FileName Property

PictureDetailFileName Property
Gets or sets the full path to the picture.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail.Height Property

PictureDetailHeight Property
Gets or sets the height of the picture in pixels.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
public:
property int Height {
    int get ();
    void set (int value);
}
member Height : int with get, set

Property Value

Type: Int32
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail.LastModifiedTime Property

PictureDetailLastModifiedTime Property
Gets or sets the last modified time of the picture's file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastModifiedTime { get; set; }
Public Property LastModifiedTime As DateTime
    Get
    Set
public:
property DateTime LastModifiedTime {
    DateTime get ();
    void set (DateTime value);
}
member LastModifiedTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail.Length Property

PictureDetailLength Property
Gets or sets the length of the picture's file.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Length { get; set; }
Public Property Length As Long
    Get
    Set
public:
property long long Length {
    long long get ();
    void set (long long value);
}
member Length : int64 with get, set

Property Value

Type: Int64
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail.Width Property

PictureDetailWidth Property
Gets or sets the width of the picture in pixels.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
public:
property int Width {
    int get ();
    void set (int value);
}
member Width : int with get, set

Property Value

Type: Int32
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail Methods

PictureDetail Methods

The PictureDetail type exposes the following members.

Methods
 | Name | Description
Public method | Equals | See base docs. Only Equals is overridden, GetHashCode is not - the object is mutable and so it is not suitable for use as a key in dictionaries. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PictureDetail.Equals Method

PictureDetailEquals Method
See base docs. Only Equals is overridden, GetHashCode is not - the object is mutable and so it is not suitable for use as a key in dictionaries.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

PictureDetail Class
VirtualRadar.Interface Namespace


PluginEventArgs Class

PluginEventArgs Class
An EventArgs for events that need to refer to an instance of an IPlugin.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.InterfacePluginEventArgs

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PluginEventArgs : EventArgs
Public Class PluginEventArgs
    Inherits EventArgs
public ref class PluginEventArgs : public EventArgs
type PluginEventArgs =
    class
        inherit EventArgs
    end

The PluginEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PluginEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | Plugin | Gets the plugin that the event corresponds to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


PluginEventArgs Constructor

PluginEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PluginEventArgs(
    IPlugin plugin
)
Public Sub New (
    plugin As IPlugin
)
public:
PluginEventArgs(
    IPlugin^ plugin
)
new :
        plugin : IPlugin -> PluginEventArgs

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
See Also

Reference

PluginEventArgs Class
VirtualRadar.Interface Namespace


PluginEventArgs Properties

PluginEventArgs Properties

The PluginEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Plugin | Gets the plugin that the event corresponds to.
Top
See Also

Reference

PluginEventArgs Class
VirtualRadar.Interface Namespace


PluginEventArgs.Plugin Property

PluginEventArgsPlugin Property
Gets the plugin that the event corresponds to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPlugin Plugin { get; }
Public ReadOnly Property Plugin As IPlugin
    Get
public:
property IPlugin^ Plugin {
    IPlugin^ get ();
}
member Plugin : IPlugin with get

Property Value

Type: IPlugin
See Also

Reference

PluginEventArgs Class
VirtualRadar.Interface Namespace


PluginEventArgs Methods

PluginEventArgs Methods

The PluginEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PluginEventArgs Class
VirtualRadar.Interface Namespace


PluginStartupParameters Class

PluginStartupParameters Class
The class that passes parameters to Startup(PluginStartupParameters).
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfacePluginStartupParameters

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PluginStartupParameters
Public Class PluginStartupParameters
public ref class PluginStartupParameters
type PluginStartupParameters =  class end

The PluginStartupParameters type exposes the following members.

Constructors
 | Name | Description
Public method | PluginStartupParameters | Creates a new object.
Top
Properties
 | Name | Description
Public property | FlightSimulatorAircraftList | Gets the object that keeps track of the simulated aircraft flying in Flight Simulator X.
Public property | PluginFolder | Gets the folder that the plugin was installed into.
Public property | UPnpManager | Gets the object that is controlling the exposure of the web server via UPnP.
Public property | WebSite | Gets the object that serves up the website pages via VirtualRadar.Interface.WebServer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


PluginStartupParameters Constructor

PluginStartupParameters Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PluginStartupParameters(
    ISimpleAircraftList flightSimulatorAircraftList,
    IUniversalPlugAndPlayManager uPnpManager,
    IWebSite webSite,
    string pluginFolder
)
Public Sub New (
    flightSimulatorAircraftList As ISimpleAircraftList,
    uPnpManager As IUniversalPlugAndPlayManager,
    webSite As IWebSite,
    pluginFolder As String
)
public:
PluginStartupParameters(
    ISimpleAircraftList^ flightSimulatorAircraftList,
    IUniversalPlugAndPlayManager^ uPnpManager,
    IWebSite^ webSite,
    String^ pluginFolder
)
new :
        flightSimulatorAircraftList : ISimpleAircraftList *
        uPnpManager : IUniversalPlugAndPlayManager *
        webSite : IWebSite *
        pluginFolder : string -> PluginStartupParameters

Parameters

flightSimulatorAircraftList
Type: VirtualRadar.InterfaceISimpleAircraftList
uPnpManager
Type: VirtualRadar.Interface.WebServerIUniversalPlugAndPlayManager
webSite
Type: VirtualRadar.Interface.WebSiteIWebSite
pluginFolder
Type: SystemString
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PluginStartupParameters Properties

PluginStartupParameters Properties

The PluginStartupParameters type exposes the following members.

Properties
 | Name | Description
Public property | FlightSimulatorAircraftList | Gets the object that keeps track of the simulated aircraft flying in Flight Simulator X.
Public property | PluginFolder | Gets the folder that the plugin was installed into.
Public property | UPnpManager | Gets the object that is controlling the exposure of the web server via UPnP.
Public property | WebSite | Gets the object that serves up the website pages via VirtualRadar.Interface.WebServer.
Top
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PluginStartupParameters.FlightSimulatorAircraftList Property

PluginStartupParametersFlightSimulatorAircraftList Property
Gets the object that keeps track of the simulated aircraft flying in Flight Simulator X.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISimpleAircraftList FlightSimulatorAircraftList { get; }
Public ReadOnly Property FlightSimulatorAircraftList As ISimpleAircraftList
    Get
public:
property ISimpleAircraftList^ FlightSimulatorAircraftList {
    ISimpleAircraftList^ get ();
}
member FlightSimulatorAircraftList : ISimpleAircraftList with get

Property Value

Type: ISimpleAircraftList
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PluginStartupParameters.PluginFolder Property

PluginStartupParametersPluginFolder Property
Gets the folder that the plugin was installed into.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PluginFolder { get; }
Public ReadOnly Property PluginFolder As String
    Get
public:
property String^ PluginFolder {
    String^ get ();
}
member PluginFolder : string with get

Property Value

Type: String
Remarks
This is the folder under [PROGRAM FILES]\VirtualRadar\Plugins that the plugin has been installed to. So for example, if VRS was installed to c:\Program Files\VirtualRadar and the plugin was installed to c:\ProgramFiles\VirtualRadar\Plugins\MyPlugin then the value of this property would be c:\ProgramFiles\VirtualRadar\Plugins\MyPlugin.
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PluginStartupParameters.UPnpManager Property

PluginStartupParametersUPnpManager Property
Gets the object that is controlling the exposure of the web server via UPnP.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IUniversalPlugAndPlayManager UPnpManager { get; }
Public ReadOnly Property UPnpManager As IUniversalPlugAndPlayManager
    Get
public:
property IUniversalPlugAndPlayManager^ UPnpManager {
    IUniversalPlugAndPlayManager^ get ();
}
member UPnpManager : IUniversalPlugAndPlayManager with get

Property Value

Type: IUniversalPlugAndPlayManager
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PluginStartupParameters.WebSite Property

PluginStartupParametersWebSite Property
Gets the object that serves up the website pages via VirtualRadar.Interface.WebServer.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IWebSite WebSite { get; }
Public ReadOnly Property WebSite As IWebSite
    Get
public:
property IWebSite^ WebSite {
    IWebSite^ get ();
}
member WebSite : IWebSite with get

Property Value

Type: IWebSite
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PluginStartupParameters Methods

PluginStartupParameters Methods

The PluginStartupParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PluginStartupParameters Class
VirtualRadar.Interface Namespace


PropertyHelper Class

PropertyHelper Class
Utility methods for working with properties.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfacePropertyHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PropertyHelper
Public NotInheritable Class PropertyHelper
public ref class PropertyHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PropertyHelper =  class end
Methods
Name | Description
ExtractName(Expression) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
ExtractNameT(ExpressionFuncT, Object) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
ExtractNameT(T, ExpressionFuncT, Object) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
Top
See Also

Reference

VirtualRadar.Interface Namespace


PropertyHelper Methods

PropertyHelper Methods
Methods
Name | Description
ExtractName(Expression) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
ExtractNameT(ExpressionFuncT, Object) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
ExtractNameT(T, ExpressionFuncT, Object) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
Top
See Also

Reference

PropertyHelper Class
VirtualRadar.Interface Namespace


PropertyHelper.ExtractName Method

PropertyHelperExtractName Method
Overload List
Name | Description
ExtractName(Expression) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
ExtractNameT(ExpressionFuncT, Object) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
ExtractNameT(T, ExpressionFuncT, Object) | Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.
Top
See Also

Reference

PropertyHelper Class
VirtualRadar.Interface Namespace


PropertyHelper.ExtractName Method (Expression)

PropertyHelperExtractName Method (Expression)
Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExtractName(
    Expression expression
)
Public Shared Function ExtractName (
    expression As Expression
) As String
public:
static String^ ExtractName(
    Expression^ expression
)
static member ExtractName :
        expression : Expression -> string

Parameters

expression
Type: System.Linq.ExpressionsExpression

Return Value

Type: String
See Also

Reference

PropertyHelper Class
ExtractName Overload
VirtualRadar.Interface Namespace


PropertyHelper.ExtractName(T) Method (Expression(Func(T, Object)))

PropertyHelperExtractNameT Method (ExpressionFuncT, Object)
Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExtractName<T>(
    Expression<Func<T, Object>> selectorExpression
)

Public Shared Function ExtractName(Of T) (
    selectorExpression As Expression(Of Func(Of T, Object))
) As String
public:
generic<typename T>
static String^ ExtractName(
    Expression<Func<T, Object^>^>^ selectorExpression
)
static member ExtractName :
        selectorExpression : Expression<Func<'T, Object>> -> string

Parameters

selectorExpression
Type: System.Linq.ExpressionsExpression Func T, Object

Type Parameters

T

Return Value

Type: String
See Also

Reference

PropertyHelper Class
ExtractName Overload
VirtualRadar.Interface Namespace


PropertyHelper.ExtractName(T) Method (T, Expression(Func(T, Object)))

PropertyHelperExtractNameT Method (T, ExpressionFuncT, Object)
Retrieves the name of a property from the lambda expression passed across. Returns null if the expression refers to anything other than a simple property.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExtractName<T>(
    T unused,
    Expression<Func<T, Object>> selectorExpression
)

Public Shared Function ExtractName(Of T) (
    unused As T,
    selectorExpression As Expression(Of Func(Of T, Object))
) As String
public:
generic<typename T>
static String^ ExtractName(
    T unused,
    Expression<Func<T, Object^>^>^ selectorExpression
)
static member ExtractName :
        unused : 'T *
        selectorExpression : Expression<Func<'T, Object>> -> string

Parameters

unused
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T, Object

Type Parameters

T

Return Value

Type: String
See Also

Reference

PropertyHelper Class
ExtractName Overload
VirtualRadar.Interface Namespace


QueueRepository Class

QueueRepository Class
Exposes a collection of every queue running within the program.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceQueueRepository

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class QueueRepository
Public NotInheritable Class QueueRepository
public ref class QueueRepository abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QueueRepository =  class end

The QueueRepository type exposes the following members.

Methods
Name | Description
AddQueue | Adds a queue to the static list of queues.
GetAllQueues | Returns an array of every queue currently running in the system.
Top
See Also

Reference

VirtualRadar.Interface Namespace


QueueRepository Methods

QueueRepository Methods

The QueueRepository type exposes the following members.

Methods
Name | Description
AddQueue | Adds a queue to the static list of queues.
GetAllQueues | Returns an array of every queue currently running in the system.
Top
See Also

Reference

QueueRepository Class
VirtualRadar.Interface Namespace


QueueRepository.AddQueue Method

QueueRepositoryAddQueue Method
Adds a queue to the static list of queues.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddQueue(
    IQueue queue
)
Public Shared Sub AddQueue (
    queue As IQueue
)
public:
static void AddQueue(
    IQueue^ queue
)
static member AddQueue :
        queue : IQueue -> unit

Parameters

queue
Type: VirtualRadar.InterfaceIQueue
See Also

Reference

QueueRepository Class
VirtualRadar.Interface Namespace


QueueRepository.GetAllQueues Method

QueueRepositoryGetAllQueues Method
Returns an array of every queue currently running in the system.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IQueue[] GetAllQueues()
Public Shared Function GetAllQueues As IQueue()
public:
static array<IQueue^>^ GetAllQueues()
static member GetAllQueues : unit -> IQueue[]

Return Value

Type: IQueue
See Also

Reference

QueueRepository Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection Class

RebroadcastServerConnection Class
Describes a connection to a rebroadcast server.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceRebroadcastServerConnection

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RebroadcastServerConnection : ICloneable
Public Class RebroadcastServerConnection
    Implements ICloneable
public ref class RebroadcastServerConnection : ICloneable
type RebroadcastServerConnection =
    class
        interface ICloneable
    end

The RebroadcastServerConnection type exposes the following members.

Constructors
 | Name | Description
Public method | RebroadcastServerConnection | Initializes a new instance of the RebroadcastServerConnection class
Top
Properties
 | Name | Description
Public property | BytesBuffered | Gets or sets a count of bytes currently buffered and awaiting transmission.
Public property | BytesWritten | Gets or sets a count of bytes sent to the client.
Public property | EndpointIPAddress | Gets or sets the IP address that the client connected from.
Public property | EndpointPort | Gets or sets the port that the client connected from.
Public property | LocalPort | Gets or sets the local port that the rebroadcast server listens to.
Public property | Name | Gets or sets the name of the rebroadcast server.
Public property | RebroadcastServerId | Gets or sets the identifier of the rebroadcast server.
Public property | RemoteAddress | Gets the address held by EndpointIPAddress.
Public property | StaleBytesDiscarded | Gets or sets a count of bytes that were discarded from the buffer because they took too long to send.
Top
Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSameConnection | Returns true if this connection is the same as the other connection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


RebroadcastServerConnection Constructor

RebroadcastServerConnection Constructor
Initializes a new instance of the RebroadcastServerConnection class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastServerConnection()
Public Sub New
public:
RebroadcastServerConnection()
new : unit -> RebroadcastServerConnection
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection Properties

RebroadcastServerConnection Properties

The RebroadcastServerConnection type exposes the following members.

Properties
 | Name | Description
Public property | BytesBuffered | Gets or sets a count of bytes currently buffered and awaiting transmission.
Public property | BytesWritten | Gets or sets a count of bytes sent to the client.
Public property | EndpointIPAddress | Gets or sets the IP address that the client connected from.
Public property | EndpointPort | Gets or sets the port that the client connected from.
Public property | LocalPort | Gets or sets the local port that the rebroadcast server listens to.
Public property | Name | Gets or sets the name of the rebroadcast server.
Public property | RebroadcastServerId | Gets or sets the identifier of the rebroadcast server.
Public property | RemoteAddress | Gets the address held by EndpointIPAddress.
Public property | StaleBytesDiscarded | Gets or sets a count of bytes that were discarded from the buffer because they took too long to send.
Top
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.BytesBuffered Property

RebroadcastServerConnectionBytesBuffered Property
Gets or sets a count of bytes currently buffered and awaiting transmission.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long BytesBuffered { get; set; }
Public Property BytesBuffered As Long
    Get
    Set
public:
property long long BytesBuffered {
    long long get ();
    void set (long long value);
}
member BytesBuffered : int64 with get, set

Property Value

Type: Int64
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.BytesWritten Property

RebroadcastServerConnectionBytesWritten Property
Gets or sets a count of bytes sent to the client.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long BytesWritten { get; set; }
Public Property BytesWritten As Long
    Get
    Set
public:
property long long BytesWritten {
    long long get ();
    void set (long long value);
}
member BytesWritten : int64 with get, set

Property Value

Type: Int64
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.EndpointIPAddress Property

RebroadcastServerConnectionEndpointIPAddress Property
Gets or sets the IP address that the client connected from.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddress EndpointIPAddress { get; set; }
Public Property EndpointIPAddress As IPAddress
    Get
    Set
public:
property IPAddress^ EndpointIPAddress {
    IPAddress^ get ();
    void set (IPAddress^ value);
}
member EndpointIPAddress : IPAddress with get, set

Property Value

Type: IPAddress
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.EndpointPort Property

RebroadcastServerConnectionEndpointPort Property
Gets or sets the port that the client connected from.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndpointPort { get; set; }
Public Property EndpointPort As Integer
    Get
    Set
public:
property int EndpointPort {
    int get ();
    void set (int value);
}
member EndpointPort : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.LocalPort Property

RebroadcastServerConnectionLocalPort Property
Gets or sets the local port that the rebroadcast server listens to.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocalPort { get; set; }
Public Property LocalPort As Integer
    Get
    Set
public:
property int LocalPort {
    int get ();
    void set (int value);
}
member LocalPort : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.Name Property

RebroadcastServerConnectionName Property
Gets or sets the name of the rebroadcast server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.RebroadcastServerId Property

RebroadcastServerConnectionRebroadcastServerId Property
Gets or sets the identifier of the rebroadcast server.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RebroadcastServerId { get; set; }
Public Property RebroadcastServerId As Integer
    Get
    Set
public:
property int RebroadcastServerId {
    int get ();
    void set (int value);
}
member RebroadcastServerId : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.RemoteAddress Property

RebroadcastServerConnectionRemoteAddress Property
Gets the address held by EndpointIPAddress.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RemoteAddress { get; }
Public ReadOnly Property RemoteAddress As String
    Get
public:
property String^ RemoteAddress {
    String^ get ();
}
member RemoteAddress : string with get

Property Value

Type: String
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.StaleBytesDiscarded Property

RebroadcastServerConnectionStaleBytesDiscarded Property
Gets or sets a count of bytes that were discarded from the buffer because they took too long to send.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long StaleBytesDiscarded { get; set; }
Public Property StaleBytesDiscarded As Long
    Get
    Set
public:
property long long StaleBytesDiscarded {
    long long get ();
    void set (long long value);
}
member StaleBytesDiscarded : int64 with get, set

Property Value

Type: Int64
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection Methods

RebroadcastServerConnection Methods

The RebroadcastServerConnection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSameConnection | Returns true if this connection is the same as the other connection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.Clone Method

RebroadcastServerConnectionClone Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.IsSameConnection Method

RebroadcastServerConnectionIsSameConnection Method
Returns true if this connection is the same as the other connection.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSameConnection(
    RebroadcastServerConnection other
)
Public Function IsSameConnection (
    other As RebroadcastServerConnection
) As Boolean
public:
bool IsSameConnection(
    RebroadcastServerConnection^ other
)
member IsSameConnection :
        other : RebroadcastServerConnection -> bool

Parameters

other
Type: VirtualRadar.InterfaceRebroadcastServerConnection

Return Value

Type: Boolean
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


RebroadcastServerConnection.ToString Method

RebroadcastServerConnectionToString Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

RebroadcastServerConnection Class
VirtualRadar.Interface Namespace


Round Class

Round Class
A helper class that can round numbers quickly, but only if they are within certain ranges.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceRound

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Round
Public NotInheritable Class Round
public ref class Round abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Round =  class end

The Round type exposes the following members.

Methods
Name | Description
Coordinate | Rounds coordinates to 6 decimal places quickly.
GroundSpeed | Rounds ground speeds to 1 decimal place quickly.
Track | Rounds tracks to 1 or 0 decimal places quickly.
TrackAltitude | Rounds altitudes for use in tracks.
TrackGroundSpeed | Rounds ground speeds for use in tracks.
TrackHeading | Rounds headings for use on recorded tracks. Rounds to the nearest x degrees, don't use on normal track values!
Top
See Also

Reference

VirtualRadar.Interface Namespace


Round Methods

Round Methods

The Round type exposes the following members.

Methods
Name | Description
Coordinate | Rounds coordinates to 6 decimal places quickly.
GroundSpeed | Rounds ground speeds to 1 decimal place quickly.
Track | Rounds tracks to 1 or 0 decimal places quickly.
TrackAltitude | Rounds altitudes for use in tracks.
TrackGroundSpeed | Rounds ground speeds for use in tracks.
TrackHeading | Rounds headings for use on recorded tracks. Rounds to the nearest x degrees, don't use on normal track values!
Top
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


Round.Coordinate Method

RoundCoordinate Method
Rounds coordinates to 6 decimal places quickly.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<double> Coordinate(
    Nullable<double> coordinate
)
Public Shared Function Coordinate (
    coordinate As Nullable(Of Double)
) As Nullable(Of Double)
public:
static Nullable<double> Coordinate(
    Nullable<double> coordinate
)
static member Coordinate :
        coordinate : Nullable<float> -> Nullable<float>

Parameters

coordinate
Type: SystemNullable Double

Return Value

Type: Nullable Double
Remarks
6 decimals is just enough to resolve movements of 1.3 metres, which is the resolution of surface positions.
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


Round.GroundSpeed Method

RoundGroundSpeed Method
Rounds ground speeds to 1 decimal place quickly.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<float> GroundSpeed(
    Nullable<float> groundSpeed
)
Public Shared Function GroundSpeed (
    groundSpeed As Nullable(Of Single)
) As Nullable(Of Single)
public:
static Nullable<float> GroundSpeed(
    Nullable<float> groundSpeed
)
static member GroundSpeed :
        groundSpeed : Nullable<float32> -> Nullable<float32>

Parameters

groundSpeed
Type: SystemNullable Single

Return Value

Type: Nullable Single
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


Round.Track Method

RoundTrack Method
Rounds tracks to 1 or 0 decimal places quickly.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<float> Track(
    Nullable<float> track,
    bool roundToZeroPlaces = false
)
Public Shared Function Track (
    track As Nullable(Of Single),
    Optional roundToZeroPlaces As Boolean = false
) As Nullable(Of Single)
public:
static Nullable<float> Track(
    Nullable<float> track,
    bool roundToZeroPlaces = false
)
static member Track :
        track : Nullable<float32> *
        ?roundToZeroPlaces : bool
(* Defaults:
        let _roundToZeroPlaces = defaultArg roundToZeroPlaces false
*)
-> Nullable<float32>

Parameters

track
Type: SystemNullable Single
roundToZeroPlaces (Optional)
Type: SystemBoolean

Return Value

Type: Nullable Single
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


Round.TrackAltitude Method

RoundTrackAltitude Method
Rounds altitudes for use in tracks.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<int> TrackAltitude(
    Nullable<int> altitude
)
Public Shared Function TrackAltitude (
    altitude As Nullable(Of Integer)
) As Nullable(Of Integer)
public:
static Nullable<int> TrackAltitude(
    Nullable<int> altitude
)
static member TrackAltitude :
        altitude : Nullable<int> -> Nullable<int>

Parameters

altitude
Type: SystemNullable Int32

Return Value

Type: Nullable Int32
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


Round.TrackGroundSpeed Method

RoundTrackGroundSpeed Method
Rounds ground speeds for use in tracks.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<float> TrackGroundSpeed(
    Nullable<float> speed
)
Public Shared Function TrackGroundSpeed (
    speed As Nullable(Of Single)
) As Nullable(Of Single)
public:
static Nullable<float> TrackGroundSpeed(
    Nullable<float> speed
)
static member TrackGroundSpeed :
        speed : Nullable<float32> -> Nullable<float32>

Parameters

speed
Type: SystemNullable Single

Return Value

Type: Nullable Single
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


Round.TrackHeading Method

RoundTrackHeading Method
Rounds headings for use on recorded tracks. Rounds to the nearest x degrees, don't use on normal track values!

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<float> TrackHeading(
    Nullable<float> track
)
Public Shared Function TrackHeading (
    track As Nullable(Of Single)
) As Nullable(Of Single)
public:
static Nullable<float> TrackHeading(
    Nullable<float> track
)
static member TrackHeading :
        track : Nullable<float32> -> Nullable<float32>

Parameters

track
Type: SystemNullable Single

Return Value

Type: Nullable Single
See Also

Reference

Round Class
VirtualRadar.Interface Namespace


SpeedType Enumeration

SpeedType Enumeration
An enumeration of the different types of speed transmitted by a vehicle. This enumeration is duplicated within the Javascript, hence the explicit declarations. Any changes here need copying there.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpeedType
Public Enumeration SpeedType
public enum class SpeedType
type SpeedType
Members
Member name | Value | Description
GroundSpeed | 0 | The aircraft is transmitting its ground speed.
GroundSpeedReversing | 1 | The vehicle is on the ground and going backwards.
IndicatedAirSpeed | 2 | The aircraft is transmitting its indicated airspeed.
TrueAirSpeed | 3 | The aircraft is transmitting its true airspeed.
See Also

Reference

VirtualRadar.Interface Namespace


SpeedUnit Enumeration

SpeedUnit Enumeration
An enumeration of the different speed units that the web site can deal with.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpeedUnit
Public Enumeration SpeedUnit
public enum class SpeedUnit
type SpeedUnit
Members
Member name | Value | Description
Knots | 0 | Knots.
MilesPerHour | 1 | Miles per hour.
KilometresPerHour | 2 | Kilometres per hour.
Remarks
The names of these enumeration values must exactly match the equivalent names in the Javascript produced by the web site.
See Also

Reference

VirtualRadar.Interface Namespace


SpinLock Class

SpinLock Class
A class that implements a simple lock that avoids the overhead imposed by using lock().
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceSpinLock

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpinLock
Public Class SpinLock
public ref class SpinLock
type SpinLock =  class end

The SpinLock type exposes the following members.

Constructors
 | Name | Description
Public method | SpinLock | Initializes a new instance of the SpinLock class
Top
Methods
 | Name | Description
Public method | AcquireLock | Locks the SpinLock and returns an object that unlocks the SpinLock when it is disposed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Lock | Acquires the lock on the SpinLock, blocking indefinitely until it manages to acquire the lock. Ensure that Unlock is always called after Lock has returned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unlock | Releases the lock on the SpinLock. This will unlock the SpinLock even if Lock was never called - only call this after Lock has returned.
Top
Remarks

You can create one of these objects to share amongst all of your threads and then call Lock to acquire a lock. If the object is already locked then the thread will spin until the lock can be acquired. Every call to Lock must be paired with a call to Unlock, otherwise the lock remains held forever and every other thread will block.

A child class, SpinLockAcquire, exists to wrap the Lock and Unlock within a using statement, ensuring that the lock and unlock operations are always paired but at the expense of creating an object for it.

Unlike the traditional C# lock call a thread can lock itself if it calls Lock twice - care must be taken to avoid double-locks. What you gain in speed you lose in convenience.

See Also

Reference

VirtualRadar.Interface Namespace


SpinLock Constructor

SpinLock Constructor
Initializes a new instance of the SpinLock class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpinLock()
Public Sub New
public:
SpinLock()
new : unit -> SpinLock
See Also

Reference

SpinLock Class
VirtualRadar.Interface Namespace


SpinLock Methods

SpinLock Methods

The SpinLock type exposes the following members.

Methods
 | Name | Description
Public method | AcquireLock | Locks the SpinLock and returns an object that unlocks the SpinLock when it is disposed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Lock | Acquires the lock on the SpinLock, blocking indefinitely until it manages to acquire the lock. Ensure that Unlock is always called after Lock has returned.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unlock | Releases the lock on the SpinLock. This will unlock the SpinLock even if Lock was never called - only call this after Lock has returned.
Top
See Also

Reference

SpinLock Class
VirtualRadar.Interface Namespace


SpinLock.AcquireLock Method

SpinLockAcquireLock Method
Locks the SpinLock and returns an object that unlocks the SpinLock when it is disposed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpinLockAcquire AcquireLock()
Public Function AcquireLock As SpinLockAcquire
public:
SpinLockAcquire^ AcquireLock()
member AcquireLock : unit -> SpinLockAcquire

Return Value

Type: SpinLockAcquire
See Also

Reference

SpinLock Class
VirtualRadar.Interface Namespace


SpinLock.Lock Method

SpinLockLock Method
Acquires the lock on the SpinLock, blocking indefinitely until it manages to acquire the lock. Ensure that Unlock is always called after Lock has returned.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Lock()
Public Sub Lock
public:
void Lock()
member Lock : unit -> unit
See Also

Reference

SpinLock Class
VirtualRadar.Interface Namespace


SpinLock.Unlock Method

SpinLockUnlock Method
Releases the lock on the SpinLock. This will unlock the SpinLock even if Lock was never called - only call this after Lock has returned.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Unlock()
Public Sub Unlock
public:
void Unlock()
member Unlock : unit -> unit
See Also

Reference

SpinLock Class
VirtualRadar.Interface Namespace


SpinLock.Acquire Class

SpinLockAcquire Class
A wrapper class that calls Lock in its constructor and Unlock in its Dispose.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceSpinLockAcquire

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Acquire : IDisposable
Public Class Acquire
    Implements IDisposable
public ref class Acquire : IDisposable
type Acquire =
    class
        interface IDisposable
    end

The SpinLockAcquire type exposes the following members.

Constructors
 | Name | Description
Public method | SpinLockAcquire | Creates a new object, locking the SpinLock passed across.
Top
Methods
 | Name | Description
Public method | Dispose | Releases the lock on SpinLock.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


SpinLock.Acquire Constructor

SpinLockAcquire Constructor
Creates a new object, locking the SpinLock passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Acquire(
    SpinLock spinLock
)
Public Sub New (
    spinLock As SpinLock
)
public:
Acquire(
    SpinLock^ spinLock
)
new :
        spinLock : SpinLock -> Acquire

Parameters

spinLock
Type: VirtualRadar.InterfaceSpinLock
See Also

Reference

SpinLockAcquire Class
VirtualRadar.Interface Namespace


Acquire Methods

Acquire Methods

The SpinLockAcquire type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases the lock on SpinLock.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpinLockAcquire Class
VirtualRadar.Interface Namespace


SpinLock.Acquire.Dispose Method

SpinLockAcquireDispose Method
Releases the lock on SpinLock.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SpinLockAcquire Class
VirtualRadar.Interface Namespace


StreamHelper Class

StreamHelper Class
A collection of methods that can help when dealing with streams.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceStreamHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StreamHelper
Public NotInheritable Class StreamHelper
public ref class StreamHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StreamHelper =  class end

The StreamHelper type exposes the following members.

Methods
Name | Description
CopyStream | Copies the content of the source stream to the destination stream.
Top
See Also

Reference

VirtualRadar.Interface Namespace


StreamHelper Methods

StreamHelper Methods

The StreamHelper type exposes the following members.

Methods
Name | Description
CopyStream | Copies the content of the source stream to the destination stream.
Top
See Also

Reference

StreamHelper Class
VirtualRadar.Interface Namespace


StreamHelper.CopyStream Method

StreamHelperCopyStream Method
Copies the content of the source stream to the destination stream.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static long CopyStream(
    Stream sourceStream,
    Stream destStream,
    int bufferSize = 1024
)
Public Shared Function CopyStream (
    sourceStream As Stream,
    destStream As Stream,
    Optional bufferSize As Integer = 1024
) As Long
public:
static long long CopyStream(
    Stream^ sourceStream,
    Stream^ destStream,
    int bufferSize = 1024
)
static member CopyStream :
        sourceStream : Stream *
        destStream : Stream *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1024
*)
-> int64

Parameters

sourceStream
Type: System.IOStream
destStream
Type: System.IOStream
bufferSize (Optional)
Type: SystemInt32

Return Value

Type: Int64
See Also

Reference

StreamHelper Class
VirtualRadar.Interface Namespace


StringDeduplicator Class

StringDeduplicator Class
A utility class that can be used to remove duplicates of strings.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceStringDeduplicator

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StringDeduplicator
Public Class StringDeduplicator
public ref class StringDeduplicator
type StringDeduplicator =  class end

The StringDeduplicator type exposes the following members.

Constructors
 | Name | Description
Public method | StringDeduplicator | Initializes a new instance of the StringDeduplicator class
Top
Methods
 | Name | Description
Public method | Deduplicate(IListString) | Deduplicates every element in the list passed across.
Public method | Deduplicate(String) | Returns the text passed in. If the text has been seen before then the first instance of the string is returned in place of the instance passed across.
Public method | Deduplicate(String) | Deduplicates every element in the array passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


StringDeduplicator Constructor

StringDeduplicator Constructor
Initializes a new instance of the StringDeduplicator class

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringDeduplicator()
Public Sub New
public:
StringDeduplicator()
new : unit -> StringDeduplicator
See Also

Reference

StringDeduplicator Class
VirtualRadar.Interface Namespace


StringDeduplicator Methods

StringDeduplicator Methods

The StringDeduplicator type exposes the following members.

Methods
 | Name | Description
Public method | Deduplicate(IListString) | Deduplicates every element in the list passed across.
Public method | Deduplicate(String) | Returns the text passed in. If the text has been seen before then the first instance of the string is returned in place of the instance passed across.
Public method | Deduplicate(String) | Deduplicates every element in the array passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringDeduplicator Class
VirtualRadar.Interface Namespace


StringDeduplicator.Deduplicate Method

StringDeduplicatorDeduplicate Method
Overload List
 | Name | Description
Public method | Deduplicate(IListString) | Deduplicates every element in the list passed across.
Public method | Deduplicate(String) | Returns the text passed in. If the text has been seen before then the first instance of the string is returned in place of the instance passed across.
Public method | Deduplicate(String) | Deduplicates every element in the array passed across.
Top
See Also

Reference

StringDeduplicator Class
VirtualRadar.Interface Namespace


StringDeduplicator.Deduplicate Method (IList(String))

StringDeduplicatorDeduplicate Method (IListString)
Deduplicates every element in the list passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Deduplicate(
    IList<string> list
)
Public Sub Deduplicate (
    list As IList(Of String)
)
public:
void Deduplicate(
    IList<String^>^ list
)
member Deduplicate :
        list : IList<string> -> unit

Parameters

list
Type: System.Collections.GenericIList String
See Also

Reference

StringDeduplicator Class
Deduplicate Overload
VirtualRadar.Interface Namespace


StringDeduplicator.Deduplicate Method (String)

StringDeduplicatorDeduplicate Method (String)
Returns the text passed in. If the text has been seen before then the first instance of the string is returned in place of the instance passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Deduplicate(
    string text
)
Public Function Deduplicate (
    text As String
) As String
public:
String^ Deduplicate(
    String^ text
)
member Deduplicate :
        text : string -> string

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

StringDeduplicator Class
Deduplicate Overload
VirtualRadar.Interface Namespace


StringDeduplicator.Deduplicate Method (String[])

StringDeduplicatorDeduplicate Method (String)
Deduplicates every element in the array passed across.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Deduplicate(
    string[] array
)
Public Sub Deduplicate (
    array As String()
)
public:
void Deduplicate(
    array<String^>^ array
)
member Deduplicate :
        array : string[] -> unit

Parameters

array
Type: SystemString
See Also

Reference

StringDeduplicator Class
Deduplicate Overload
VirtualRadar.Interface Namespace


StringWriterWithEncoding Class

StringWriterWithEncoding Class
A string writer that lets you set the encoding.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOTextWriter
System.IOStringWriter
VirtualRadar.InterfaceStringWriterWithEncoding

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StringWriterWithEncoding : StringWriter
Public Class StringWriterWithEncoding
    Inherits StringWriter
public ref class StringWriterWithEncoding : public StringWriter
type StringWriterWithEncoding =
    class
        inherit StringWriter
    end

The StringWriterWithEncoding type exposes the following members.

Constructors
 | Name | Description
Public method | StringWriterWithEncoding(Encoding) | Creates a new object.
Public method | StringWriterWithEncoding(IFormatProvider, Encoding) | Creates a new object.
Public method | StringWriterWithEncoding(StringBuilder, Encoding) | Creates a new object.
Public method | StringWriterWithEncoding(StringBuilder, IFormatProvider, Encoding) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Encoding | See base docs. (Overrides StringWriterEncoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)
Top
Methods
 | Name | Description
Public method | Close | Closes the current StringWriter and the underlying stream. (Inherited from StringWriter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StringWriter and optionally releases the managed resources. (Inherited from StringWriter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetStringBuilder | Returns the underlying StringBuilder. (Inherited from StringWriter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from StringWriter.)
Public method | Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String) | Writes a string to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(Char) | Writes a character array to the text stream. (Inherited from TextWriter.)
Public method | Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Public method | Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
Public method | Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(Char, Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine | Writes a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(Char, Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Top
Fields
 | Name | Description
Protected field | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


StringWriterWithEncoding Constructor

StringWriterWithEncoding Constructor
Overload List
 | Name | Description
Public method | StringWriterWithEncoding(Encoding) | Creates a new object.
Public method | StringWriterWithEncoding(IFormatProvider, Encoding) | Creates a new object.
Public method | StringWriterWithEncoding(StringBuilder, Encoding) | Creates a new object.
Public method | StringWriterWithEncoding(StringBuilder, IFormatProvider, Encoding) | Creates a new object.
Top
See Also

Reference

StringWriterWithEncoding Class
VirtualRadar.Interface Namespace


StringWriterWithEncoding Constructor (Encoding)

StringWriterWithEncoding Constructor (Encoding)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringWriterWithEncoding(
    Encoding encoding
)
Public Sub New (
    encoding As Encoding
)
public:
StringWriterWithEncoding(
    Encoding^ encoding
)
new :
        encoding : Encoding -> StringWriterWithEncoding

Parameters

encoding
Type: System.TextEncoding
See Also

Reference

StringWriterWithEncoding Class
StringWriterWithEncoding Overload
VirtualRadar.Interface Namespace


StringWriterWithEncoding Constructor (IFormatProvider, Encoding)

StringWriterWithEncoding Constructor (IFormatProvider, Encoding)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringWriterWithEncoding(
    IFormatProvider formatProvider,
    Encoding encoding
)
Public Sub New (
    formatProvider As IFormatProvider,
    encoding As Encoding
)
public:
StringWriterWithEncoding(
    IFormatProvider^ formatProvider,
    Encoding^ encoding
)
new :
        formatProvider : IFormatProvider *
        encoding : Encoding -> StringWriterWithEncoding

Parameters

formatProvider
Type: SystemIFormatProvider
encoding
Type: System.TextEncoding
See Also

Reference

StringWriterWithEncoding Class
StringWriterWithEncoding Overload
VirtualRadar.Interface Namespace


StringWriterWithEncoding Constructor (StringBuilder, Encoding)

StringWriterWithEncoding Constructor (StringBuilder, Encoding)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringWriterWithEncoding(
    StringBuilder sb,
    Encoding encoding
)
Public Sub New (
    sb As StringBuilder,
    encoding As Encoding
)
public:
StringWriterWithEncoding(
    StringBuilder^ sb,
    Encoding^ encoding
)
new :
        sb : StringBuilder *
        encoding : Encoding -> StringWriterWithEncoding

Parameters

sb
Type: System.TextStringBuilder
encoding
Type: System.TextEncoding
See Also

Reference

StringWriterWithEncoding Class
StringWriterWithEncoding Overload
VirtualRadar.Interface Namespace


StringWriterWithEncoding Constructor (StringBuilder, IFormatProvider, Encoding)

StringWriterWithEncoding Constructor (StringBuilder, IFormatProvider, Encoding)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringWriterWithEncoding(
    StringBuilder sb,
    IFormatProvider formatProvider,
    Encoding encoding
)
Public Sub New (
    sb As StringBuilder,
    formatProvider As IFormatProvider,
    encoding As Encoding
)
public:
StringWriterWithEncoding(
    StringBuilder^ sb,
    IFormatProvider^ formatProvider,
    Encoding^ encoding
)
new :
        sb : StringBuilder *
        formatProvider : IFormatProvider *
        encoding : Encoding -> StringWriterWithEncoding

Parameters

sb
Type: System.TextStringBuilder
formatProvider
Type: SystemIFormatProvider
encoding
Type: System.TextEncoding
See Also

Reference

StringWriterWithEncoding Class
StringWriterWithEncoding Overload
VirtualRadar.Interface Namespace


StringWriterWithEncoding Properties

StringWriterWithEncoding Properties

The StringWriterWithEncoding type exposes the following members.

Properties
 | Name | Description
Public property | Encoding | See base docs. (Overrides StringWriterEncoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)
Top
See Also

Reference

StringWriterWithEncoding Class
VirtualRadar.Interface Namespace


StringWriterWithEncoding.Encoding Property

StringWriterWithEncodingEncoding Property
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Encoding Encoding { get; }
Public Overrides ReadOnly Property Encoding As Encoding
    Get
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}
abstract Encoding : Encoding with get
override Encoding : Encoding with get

Property Value

Type: Encoding
See Also

Reference

StringWriterWithEncoding Class
VirtualRadar.Interface Namespace


StringWriterWithEncoding Methods

StringWriterWithEncoding Methods

The StringWriterWithEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current StringWriter and the underlying stream. (Inherited from StringWriter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StringWriter and optionally releases the managed resources. (Inherited from StringWriter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetStringBuilder | Returns the underlying StringBuilder. (Inherited from StringWriter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from StringWriter.)
Public method | Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String) | Writes a string to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(Char) | Writes a character array to the text stream. (Inherited from TextWriter.)
Public method | Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Public method | Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
Public method | Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(Char, Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine | Writes a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(Char, Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Top
See Also

Reference

StringWriterWithEncoding Class
VirtualRadar.Interface Namespace


StringWriterWithEncoding Fields

StringWriterWithEncoding Fields

The StringWriterWithEncoding type exposes the following members.

Fields
 | Name | Description
Protected field | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)
Top
See Also

Reference

StringWriterWithEncoding Class
VirtualRadar.Interface Namespace


TimestampedException Class

TimestampedException Class
Records an exception and the time (at UTC) when it was thrown.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceTimestampedException

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TimestampedException
Public Class TimestampedException
public ref class TimestampedException
type TimestampedException =  class end

The TimestampedException type exposes the following members.

Constructors
 | Name | Description
Public method | TimestampedException(Exception) | Creates a new object.
Public method | TimestampedException(DateTime, Exception) | Creates a new object
Top
Properties
 | Name | Description
Public property | Exception | Gets the exception that was thrown.
Public property | TimeUtc | Gets the date and time at UTC when the exception was thrown.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


TimestampedException Constructor

TimestampedException Constructor
Overload List
 | Name | Description
Public method | TimestampedException(Exception) | Creates a new object.
Public method | TimestampedException(DateTime, Exception) | Creates a new object
Top
See Also

Reference

TimestampedException Class
VirtualRadar.Interface Namespace


TimestampedException Constructor (Exception)

TimestampedException Constructor (Exception)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimestampedException(
    Exception exception
)
Public Sub New (
    exception As Exception
)
public:
TimestampedException(
    Exception^ exception
)
new :
        exception : Exception -> TimestampedException

Parameters

exception
Type: SystemException
See Also

Reference

TimestampedException Class
TimestampedException Overload
VirtualRadar.Interface Namespace


TimestampedException Constructor (DateTime, Exception)

TimestampedException Constructor (DateTime, Exception)
Creates a new object

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimestampedException(
    DateTime timeUtc,
    Exception exception
)
Public Sub New (
    timeUtc As DateTime,
    exception As Exception
)
public:
TimestampedException(
    DateTime timeUtc,
    Exception^ exception
)
new :
        timeUtc : DateTime *
        exception : Exception -> TimestampedException

Parameters

timeUtc
Type: SystemDateTime
exception
Type: SystemException
See Also

Reference

TimestampedException Class
TimestampedException Overload
VirtualRadar.Interface Namespace


TimestampedException Properties

TimestampedException Properties

The TimestampedException type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets the exception that was thrown.
Public property | TimeUtc | Gets the date and time at UTC when the exception was thrown.
Top
See Also

Reference

TimestampedException Class
VirtualRadar.Interface Namespace


TimestampedException.Exception Property

TimestampedExceptionException Property
Gets the exception that was thrown.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}
member Exception : Exception with get

Property Value

Type: Exception
See Also

Reference

TimestampedException Class
VirtualRadar.Interface Namespace


TimestampedException.TimeUtc Property

TimestampedExceptionTimeUtc Property
Gets the date and time at UTC when the exception was thrown.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime TimeUtc { get; }
Public ReadOnly Property TimeUtc As DateTime
    Get
public:
property DateTime TimeUtc {
    DateTime get ();
}
member TimeUtc : DateTime with get

Property Value

Type: DateTime
See Also

Reference

TimestampedException Class
VirtualRadar.Interface Namespace


TimestampedException Methods

TimestampedException Methods

The TimestampedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

TimestampedException Class
VirtualRadar.Interface Namespace


TimestampedException.ToString Method

TimestampedExceptionToString Method
See base docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

TimestampedException Class
VirtualRadar.Interface Namespace


TransponderType Enumeration

TransponderType Enumeration
An enumeration of the different types of transponder that VRS can decode messages from.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TransponderType
Public Enumeration TransponderType
public enum class TransponderType
type TransponderType
Members
Member name | Value | Description
Unknown | 0 | The transponder type is not known and no attempt has been made to guess it.
ModeS | 1 | The transponder is sending Mode-S messages with no ADSB content.
Adsb | 2 | The transponder is sending Mode-S messages with ADSB content, but the type of ADSB content cannot be determined. Assume that it's ADSB-0.
Adsb0 | 3 | The transponder is sending Mode-S messages with ADSB-0 content.
Adsb1 | 4 | The transponder is sending Mode-S messages with ADSB-1 content.
Adsb2 | 5 | The transponder is sending Mode-S messages with ADSB-2 content.
See Also

Reference

VirtualRadar.Interface Namespace


UnregisterCallback(E) Delegate

UnregisterCallbackE Delegate
The delegate for a method that will automatically unregister an event handler when the owning object is garbage collected.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UnregisterCallback<E>(
    EventHandler<E> eventHandler
)
where E : EventArgs

Public Delegate Sub UnregisterCallback(Of E As EventArgs) (
    eventHandler As EventHandler(Of E)
)
generic<typename E>
where E : EventArgs
public delegate void UnregisterCallback(
    EventHandler<E>^ eventHandler
)
type UnregisterCallback =
    delegate of
        eventHandler : EventHandler<'E> -> unit

Parameters

eventHandler
Type: SystemEventHandler E

Type Parameters

E
See Also

Reference

VirtualRadar.Interface Namespace


WaitState Class

WaitState Class
A base class for simple state objects that carry information in BeginXXXXX calls. Holds a wait handle that can be manually signalled in the EndXXXXXX call and waited on in calling thread.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceWaitState

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WaitState : IDisposable
Public Class WaitState
    Implements IDisposable
public ref class WaitState : IDisposable
type WaitState =
    class
        interface IDisposable
    end

The WaitState type exposes the following members.

Constructors
 | Name | Description
Public method | WaitState | Creates a new object.
Top
Properties
 | Name | Description
Public property | WaitHandle | Gets a wait handle that can be used to signal the Begin thread that the End thread has completed.
Top
Methods
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


WaitState Constructor

WaitState Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WaitState()
Public Sub New
public:
WaitState()
new : unit -> WaitState
See Also

Reference

WaitState Class
VirtualRadar.Interface Namespace


WaitState Properties

WaitState Properties

The WaitState type exposes the following members.

Properties
 | Name | Description
Public property | WaitHandle | Gets a wait handle that can be used to signal the Begin thread that the End thread has completed.
Top
See Also

Reference

WaitState Class
VirtualRadar.Interface Namespace


WaitState.WaitHandle Property

WaitStateWaitHandle Property
Gets a wait handle that can be used to signal the Begin thread that the End thread has completed.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ManualResetEvent WaitHandle { get; }
Public ReadOnly Property WaitHandle As ManualResetEvent
    Get
public:
property ManualResetEvent^ WaitHandle {
    ManualResetEvent^ get ();
}
member WaitHandle : ManualResetEvent with get

Property Value

Type: ManualResetEvent
Remarks
Note that this will be null after the object has been disposed.
See Also

Reference

WaitState Class
VirtualRadar.Interface Namespace


WaitState Methods

WaitState Methods

The WaitState type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WaitState Class
VirtualRadar.Interface Namespace


WaitState.Dispose Method

WaitStateDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Top
See Also

Reference

WaitState Class
VirtualRadar.Interface Namespace


WaitState.Dispose Method

WaitStateDispose Method
See interface docs.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WaitState Class
Dispose Overload
VirtualRadar.Interface Namespace


WaitState.Dispose Method (Boolean)

WaitStateDispose Method (Boolean)
Disposes of or finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

WaitState Class
Dispose Overload
VirtualRadar.Interface Namespace


WaitState.Finalize Method

WaitStateFinalize Method
Finalises the object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

WaitState Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E) Class

WeakEventHandlerT, E Class
The default implementation of IWeakEventHandler.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceWeakEventHandlerT, E

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WeakEventHandler<T, E> : IWeakEventHandler<E>
where T : class
where E : EventArgs

Public Class WeakEventHandler(Of T As Class, E As EventArgs)
    Implements IWeakEventHandler(Of E)
generic<typename T, typename E>
where T : ref class
where E : EventArgs
public ref class WeakEventHandler : IWeakEventHandler<E>
type WeakEventHandler<'T, 'E when 'T : not struct when 'E : EventArgs> =
    class
        interface IWeakEventHandler<'E>
    end

Type Parameters

T
E

The WeakEventHandlerT, E type exposes the following members.

Constructors
 | Name | Description
Public method | WeakEventHandlerT, E | Creates a new object.
Top
Properties
 | Name | Description
Public property | Handler | Gets the event handler.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the event handler held by the weak target.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(WeakEventHandlerT, E to EventHandlerE) | Gets the weak event handler's event handler.
Top
See Also

Reference

VirtualRadar.Interface Namespace


WeakEventHandler(T, E) Constructor

WeakEventHandlerT, E Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WeakEventHandler(
    EventHandler<E> eventHandler,
    UnregisterCallback<E> unregister
)
Public Sub New (
    eventHandler As EventHandler(Of E),
    unregister As UnregisterCallback(Of E)
)
public:
WeakEventHandler(
    EventHandler<E>^ eventHandler,
    UnregisterCallback<E>^ unregister
)
new :
        eventHandler : EventHandler<'E> *
        unregister : UnregisterCallback<'E> -> WeakEventHandler

Parameters

eventHandler
Type: SystemEventHandler E
unregister
Type: VirtualRadar.InterfaceUnregisterCallback E
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E) Properties

WeakEventHandlerT, E Properties

The WeakEventHandlerT, E generic type exposes the following members.

Properties
 | Name | Description
Public property | Handler | Gets the event handler.
Top
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E).Handler Property

WeakEventHandlerT, EHandler Property
Gets the event handler.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHandler<E> Handler { get; }
Public ReadOnly Property Handler As EventHandler(Of E)
    Get
public:
virtual property EventHandler<E>^ Handler {
    EventHandler<E>^ get () sealed;
}
abstract Handler : EventHandler<'E> with get
override Handler : EventHandler<'E> with get

Property Value

Type: EventHandler E

Implements

IWeakEventHandlerEHandler
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E) Methods

WeakEventHandlerT, E Methods

The WeakEventHandlerT, E generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the event handler held by the weak target.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E).Invoke Method

WeakEventHandlerT, EInvoke Method
Invokes the event handler held by the weak target.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Invoke(
    Object sender,
    E e
)
Public Sub Invoke (
    sender As Object,
    e As E
)
public:
void Invoke(
    Object^ sender,
    E e
)
member Invoke :
        sender : Object *
        e : 'E -> unit

Parameters

sender
Type: SystemObject
e
Type: E
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E) Type Conversions

WeakEventHandlerT, E Type Conversions

The WeakEventHandlerT, E generic type exposes the following members.

Operators
Name | Description
(WeakEventHandlerT, E to EventHandlerE) | Gets the weak event handler's event handler.
Top
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WeakEventHandler(T, E) Implicit Conversion (WeakEventHandler(T, E) to EventHandler(E))

WeakEventHandlerT, E Conversion (WeakEventHandlerT, E to EventHandlerE)
Gets the weak event handler's event handler.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static implicit operator EventHandler<E> (
    WeakEventHandler<T, E> weakEventHandler
)
Public Shared Widening Operator CType (
    weakEventHandler As WeakEventHandler(Of T, E)
) As EventHandler(Of E)
static implicit operator EventHandler<E>^ (
    WeakEventHandler<T, E>^ weakEventHandler
)
F# does not support the declaration of new casting operators.

Parameters

weakEventHandler
Type: VirtualRadar.InterfaceWeakEventHandler T, E

Return Value

Type: EventHandler E
See Also

Reference

WeakEventHandlerT, E Class
VirtualRadar.Interface Namespace


WebRequestHelper Class

WebRequestHelper Class
A static class that helps with some common tasks when dealing with web requests.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceWebRequestHelper

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WebRequestHelper
Public NotInheritable Class WebRequestHelper
public ref class WebRequestHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WebRequestHelper =  class end

The WebRequestHelper type exposes the following members.

Methods
Name | Description
GetResponse | A wrapper around GetResponse that automatically retries when the request fails because of common transitory errors.
GetResponseStream | A wrapper around GetResponseStream that automatically retries when the request fails because of common transitory errors.
Top
Fields
Name | Description
TimeoutMilliseconds | The period of time that requests will be repeated for before it gives up.
Top
See Also

Reference

VirtualRadar.Interface Namespace


WebRequestHelper Methods

WebRequestHelper Methods

The WebRequestHelper type exposes the following members.

Methods
Name | Description
GetResponse | A wrapper around GetResponse that automatically retries when the request fails because of common transitory errors.
GetResponseStream | A wrapper around GetResponseStream that automatically retries when the request fails because of common transitory errors.
Top
See Also

Reference

WebRequestHelper Class
VirtualRadar.Interface Namespace


WebRequestHelper.GetResponse Method

WebRequestHelperGetResponse Method
A wrapper around GetResponse that automatically retries when the request fails because of common transitory errors.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WebResponse GetResponse(
    WebRequest request,
    bool suppressRepeat = false
)
Public Shared Function GetResponse (
    request As WebRequest,
    Optional suppressRepeat As Boolean = false
) As WebResponse
public:
static WebResponse^ GetResponse(
    WebRequest^ request,
    bool suppressRepeat = false
)
static member GetResponse :
        request : WebRequest *
        ?suppressRepeat : bool
(* Defaults:
        let _suppressRepeat = defaultArg suppressRepeat false
*)
-> WebResponse

Parameters

request
Type: System.NetWebRequest
suppressRepeat (Optional)
Type: SystemBoolean

Return Value

Type: WebResponse
See Also

Reference

WebRequestHelper Class
VirtualRadar.Interface Namespace


WebRequestHelper.GetResponseStream Method

WebRequestHelperGetResponseStream Method
A wrapper around GetResponseStream that automatically retries when the request fails because of common transitory errors.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Stream GetResponseStream(
    WebResponse response,
    bool suppressRepeat = false
)
Public Shared Function GetResponseStream (
    response As WebResponse,
    Optional suppressRepeat As Boolean = false
) As Stream
public:
static Stream^ GetResponseStream(
    WebResponse^ response,
    bool suppressRepeat = false
)
static member GetResponseStream :
        response : WebResponse *
        ?suppressRepeat : bool
(* Defaults:
        let _suppressRepeat = defaultArg suppressRepeat false
*)
-> Stream

Parameters

response
Type: System.NetWebResponse
suppressRepeat (Optional)
Type: SystemBoolean

Return Value

Type: Stream
See Also

Reference

WebRequestHelper Class
VirtualRadar.Interface Namespace


WebRequestHelper Fields

WebRequestHelper Fields

The WebRequestHelper type exposes the following members.

Fields
Name | Description
TimeoutMilliseconds | The period of time that requests will be repeated for before it gives up.
Top
See Also

Reference

WebRequestHelper Class
VirtualRadar.Interface Namespace


WebRequestHelper.TimeoutMilliseconds Field

WebRequestHelperTimeoutMilliseconds Field
The period of time that requests will be repeated for before it gives up.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly int TimeoutMilliseconds
Public Shared ReadOnly TimeoutMilliseconds As Integer
public:
static initonly int TimeoutMilliseconds
static val TimeoutMilliseconds: int

Field Value

Type: Int32
See Also

Reference

WebRequestHelper Class
VirtualRadar.Interface Namespace


WebRequestResult(T) Class

WebRequestResultT Class
Describes the request of a request to an Internet-based API.
Inheritance Hierarchy
SystemObject
VirtualRadar.InterfaceWebRequestResultT

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WebRequestResult<T>
where T : class

Public Class WebRequestResult(Of T As Class)
generic<typename T>
where T : ref class
public ref class WebRequestResult
type WebRequestResult<'T when 'T : not struct> =  class end

Type Parameters

T

The WebRequestResultT type exposes the following members.

Constructors
 | Name | Description
Public method | WebRequestResultT | Creates a new object.
Public method | WebRequestResultT(HttpStatusCode) | Creates a new object.
Public method | WebRequestResultT(HttpStatusCode, T) | Creates a new object.
Top
Properties
 | Name | Description
Public property | HttpStatusCode | Gets or sets the status code returned by the request.
Public property | Result | Gets or sets the result of the request.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface Namespace


WebRequestResult(T) Constructor

WebRequestResultT Constructor
Overload List
 | Name | Description
Public method | WebRequestResultT | Creates a new object.
Public method | WebRequestResultT(HttpStatusCode) | Creates a new object.
Public method | WebRequestResultT(HttpStatusCode, T) | Creates a new object.
Top
See Also

Reference

WebRequestResultT Class
VirtualRadar.Interface Namespace


WebRequestResult(T) Constructor

WebRequestResultT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebRequestResult()
Public Sub New
public:
WebRequestResult()
new : unit -> WebRequestResult
See Also

Reference

WebRequestResultT Class
WebRequestResultT Overload
VirtualRadar.Interface Namespace


WebRequestResult(T) Constructor (HttpStatusCode)

WebRequestResultT Constructor (HttpStatusCode)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebRequestResult(
    HttpStatusCode httpStatusCode
)
Public Sub New (
    httpStatusCode As HttpStatusCode
)
public:
WebRequestResult(
    HttpStatusCode httpStatusCode
)
new :
        httpStatusCode : HttpStatusCode -> WebRequestResult

Parameters

httpStatusCode
Type: System.NetHttpStatusCode
See Also

Reference

WebRequestResultT Class
WebRequestResultT Overload
VirtualRadar.Interface Namespace


WebRequestResult(T) Constructor (HttpStatusCode, T)

WebRequestResultT Constructor (HttpStatusCode, T)
Creates a new object.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebRequestResult(
    HttpStatusCode httpStatusCode,
    T result
)
Public Sub New (
    httpStatusCode As HttpStatusCode,
    result As T
)
public:
WebRequestResult(
    HttpStatusCode httpStatusCode,
    T result
)
new :
        httpStatusCode : HttpStatusCode *
        result : 'T -> WebRequestResult

Parameters

httpStatusCode
Type: System.NetHttpStatusCode
result
Type: T
See Also

Reference

WebRequestResultT Class
WebRequestResultT Overload
VirtualRadar.Interface Namespace


WebRequestResult(T) Properties

WebRequestResultT Properties

The WebRequestResultT generic type exposes the following members.

Properties
 | Name | Description
Public property | HttpStatusCode | Gets or sets the status code returned by the request.
Public property | Result | Gets or sets the result of the request.
Top
See Also

Reference

WebRequestResultT Class
VirtualRadar.Interface Namespace


WebRequestResult(T).HttpStatusCode Property

WebRequestResultTHttpStatusCode Property
Gets or sets the status code returned by the request.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HttpStatusCode HttpStatusCode { get; set; }
Public Property HttpStatusCode As HttpStatusCode
    Get
    Set
public:
property HttpStatusCode HttpStatusCode {
    HttpStatusCode get ();
    void set (HttpStatusCode value);
}
member HttpStatusCode : HttpStatusCode with get, set

Property Value

Type: HttpStatusCode
See Also

Reference

WebRequestResultT Class
VirtualRadar.Interface Namespace


WebRequestResult(T).Result Property

WebRequestResultTResult Property
Gets or sets the result of the request.

Namespace: VirtualRadar.Interface
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Result { get; set; }
Public Property Result As T
    Get
    Set
public:
property T Result {
    T get ();
    void set (T value);
}
member Result : 'T with get, set

Property Value

Type: T
See Also

Reference

WebRequestResultT Class
VirtualRadar.Interface Namespace


WebRequestResult(T) Methods

WebRequestResultT Methods

The WebRequestResultT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebRequestResultT Class
VirtualRadar.Interface Namespace


VirtualRadar.Interface.Adsb Namespace

VirtualRadar.Interface.Adsb Namespace
The namespace for all of the interfaces and objects associated with decoding raw ADS-B messages.
Classes
 | Class | Description
Public class | AdsbMessage | Describes the content of an ADS-B message as decoded from the ME field of a DF17 / DF18 CF0,1,6 / DF19 AF0 message.
Public class | AirbornePositionMessage | Describes the content of an ADS-B airborne position message.
Public class | AirborneVelocityMessage | Gets or sets the content of an airborne velocity ADS-B message.
Public class | AircraftOperationalStatusMessage | A class that describes the content of ADS-B Aircraft Operational Status messages.
Public class | AircraftStatusMessage | A class describing the content of the ADS-B aircraft status message.
Public class | CoarseTisbAirbornePosition | Describes the content of a TIS-B coarse airborne position message.
Public class | CompactPositionReportingCoordinate | Describes a Compact Position Reporting coordinate.
Public class | EmergencyStatus | A class that carries information from an aircraft emergency / priority status message.
Public class | GlobalCoordinate | A class describing a coordinate on the surface of the Earth.
Public class | IdentifierAndCategoryMessage | Gets or sets the content of an identifier and category message.
Public class | SurfacePositionMessage | A class describing the content of a surface position message.
Public class | TargetStateAndStatusMessage | A class that holds the content of the Target State and Status messages.
Public class | TargetStateAndStatusVersion1 | Describes the content of an ADS-B version 1 Target State and Status message.
Public class | TargetStateAndStatusVersion2 | A class carrying the content of an ADS-B version 2 target state and status message.
Public class | TcasResolutionAdvisory | A class describing the content of an aircraft status message carrying a TCAS RA broadcast.
Public class | VectorVelocity | The speed and bearing of a vehicle specified as two velocities along the X and Y axis.
Interfaces
 | Interface | Description
Public interface | IAdsbTranslator | The interface that objects that can translate ME message blocks into ADS-B messages must implement.
Public interface | ICompactPositionReporting | The interface for classes that can encode and decode Compact Position Reporting coordinates.
Enumerations
 | Enumeration | Description
Public enumeration | AirborneCapabilityVersion0 | An enumeration of the airborne capability flags for version 0 ADS-B aircraft operational status messages.
Public enumeration | AirborneCapabilityVersion1 | An enumeration of the different airborne capability flags for version 1 ADS-B aircraft operational status messages.
Public enumeration | AirborneCapabilityVersion2 | An enumeration of the aircraft capability flags transmitted in version 2 ADS-B aircraft operational status messages.
Public enumeration | AircraftOperationalStatusType | An enumeration of the different types of aircraft operational status messages.
Public enumeration | AircraftStatusType | An enumeration of the various aircraft status types in aircraft status messages.
Public enumeration | EmergencyState | An enumeration of the different emergency states transmitted in aircraft status and ADS-B version 1 target state and status messages.
Public enumeration | EmitterCategory | An enumeration of the different ADS-B Emitter Categories transmitted across all category sets.
Public enumeration | HorizontalDataSource | An enumeration of the different sources of horizontal data for ADS-B version 1 target state and status messages.
Public enumeration | HorizontalModeIndicator | An enumeration of the different values of HMI that can be transmitted in ADS-B version 1 target state and status messages.
Public enumeration | MessageFormat | An enumeration of the different ADS-B message formats.
Public enumeration | MultipleThreatResolutionAdvisory | An enumeration of flags that indicate the meaning of a TCAS resolution advisory when there are multiple threats and the resolution advisory provides separation below some threats and above other threats.
Public enumeration | OperationalMode | An enumeration of the operational modes transmitted in version 1 and version 2 ADS-B aircraft operational status messages.
Public enumeration | ResolutionAdvisoryComplement | An enumeration of flags recording resolution advisory complements that have been received from other aircraft.
Public enumeration | SingleThreatResolutionAdvisory | An enumeration of flags that indicate the meaning of a TCAS resolution advisory when there is a single threat or the resolution advisory is intended to provide separation in the same direction for all threats.
Public enumeration | SurfaceCapability | An enumeration of the surface capability codes transmitted in version 1 and 2 ADS-B aircraft operational status messages.
Public enumeration | SurveillanceStatus | An enumeration of the different possible surveillance status values in an ADS-B message.
Public enumeration | SystemDesignAssurance | An enumeration of the different System Design Assurance values extracted from operational message fields of version 2 ADS-B messages.
Public enumeration | TargetAltitudeCapability | An enumeration of the different target altitude capability values for ADS-B version 1 target state and status messages.
Public enumeration | TargetStateAndStatusType | An enumeration of the different types of target state and status messages.
Public enumeration | TcasCapabilityMode | An enumeration of the different operational status indicators for TCAS/ACAS systems as transmitted in the ADS-B version 1 target state and status message.
Public enumeration | VelocityType | An enumeration of the different types of velocity message encodings in an ADS-B velocity message.
Public enumeration | VerticalDataSource | An enumeration of the different sources of vertical data in ADS-B version 1 target state and status messages.
Public enumeration | VerticalModeIndicator | An enumeration of the different values of VMI that can be transmitted in ADS-B version 1 target state and status messages.
Remarks


AdsbMessage Class

AdsbMessage Class
Describes the content of an ADS-B message as decoded from the ME field of a DF17 / DF18 CF0,1,6 / DF19 AF0 message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbAdsbMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AdsbMessage
Public Class AdsbMessage
public ref class AdsbMessage
type AdsbMessage =  class end

The AdsbMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AdsbMessage | Creates a new object.
Public method | AdsbMessage(ModeSMessage) | Creates a new object.
Top
Properties
 | Name | Description
Public property | AirbornePosition | Gets or sets the content of an airborne position message.
Public property | AirborneVelocity | Gets or sets the content of an airborne velocity message.
Public property | AircraftOperationalStatus | Gets or sets the content of the aircraft operational status message.
Public property | AircraftStatus | Gets or sets the content of an aircraft status message.
Public property | CoarseTisbAirbornePosition | Gets or sets the content of the TIS-B coarse airborne position message.
Public property | IdentifierAndCategory | Gets or sets the content of an identifer and category message.
Public property | MessageFormat | Gets or sets the format of ADS-B message.
Public property | ModeSMessage | Gets the parent Mode-S message that carried the ADS-B message.
Public property | SurfacePosition | Gets or sets the content of a surface position message.
Public property | TargetStateAndStatus | Gets or sets the content of the target state and status messages (not present in ADS-B version 0).
Public property | TisbIcaoModeAFlag | Gets or sets the value of the ICAO/Mode-A flag for TIS-B fine-format messages.
Public property | Type | Gets or sets the type of the message as described by the first 5 bits.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
Remarks
Unlike Mode-S messages very few fields are transmitted by multiple message types. As some of the messages can carry a lot of unique information the body of the messages have been split into separate classes and this class just carries the common fields and a reference to one message object.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AdsbMessage Constructor

AdsbMessage Constructor
Overload List
 | Name | Description
Public method | AdsbMessage | Creates a new object.
Public method | AdsbMessage(ModeSMessage) | Creates a new object.
Top
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage Constructor

AdsbMessage Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AdsbMessage()
Public Sub New
public:
AdsbMessage()
new : unit -> AdsbMessage
See Also

Reference

AdsbMessage Class
AdsbMessage Overload
VirtualRadar.Interface.Adsb Namespace


AdsbMessage Constructor (ModeSMessage)

AdsbMessage Constructor (ModeSMessage)
Creates a new object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AdsbMessage(
    ModeSMessage modeSMessage
)
Public Sub New (
    modeSMessage As ModeSMessage
)
public:
AdsbMessage(
    ModeSMessage^ modeSMessage
)
new :
        modeSMessage : ModeSMessage -> AdsbMessage

Parameters

modeSMessage
Type: VirtualRadar.Interface.ModeSModeSMessage
See Also

Reference

AdsbMessage Class
AdsbMessage Overload
VirtualRadar.Interface.Adsb Namespace


AdsbMessage Properties

AdsbMessage Properties

The AdsbMessage type exposes the following members.

Properties
 | Name | Description
Public property | AirbornePosition | Gets or sets the content of an airborne position message.
Public property | AirborneVelocity | Gets or sets the content of an airborne velocity message.
Public property | AircraftOperationalStatus | Gets or sets the content of the aircraft operational status message.
Public property | AircraftStatus | Gets or sets the content of an aircraft status message.
Public property | CoarseTisbAirbornePosition | Gets or sets the content of the TIS-B coarse airborne position message.
Public property | IdentifierAndCategory | Gets or sets the content of an identifer and category message.
Public property | MessageFormat | Gets or sets the format of ADS-B message.
Public property | ModeSMessage | Gets the parent Mode-S message that carried the ADS-B message.
Public property | SurfacePosition | Gets or sets the content of a surface position message.
Public property | TargetStateAndStatus | Gets or sets the content of the target state and status messages (not present in ADS-B version 0).
Public property | TisbIcaoModeAFlag | Gets or sets the value of the ICAO/Mode-A flag for TIS-B fine-format messages.
Public property | Type | Gets or sets the type of the message as described by the first 5 bits.
Top
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.AirbornePosition Property

AdsbMessageAirbornePosition Property
Gets or sets the content of an airborne position message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirbornePositionMessage AirbornePosition { get; set; }
Public Property AirbornePosition As AirbornePositionMessage
    Get
    Set
public:
property AirbornePositionMessage^ AirbornePosition {
    AirbornePositionMessage^ get ();
    void set (AirbornePositionMessage^ value);
}
member AirbornePosition : AirbornePositionMessage with get, set

Property Value

Type: AirbornePositionMessage
Remarks
Note that type code 0 messages are considered by the code to be airborne positions, although in principle they can also be transmitted by vehicles on the ground.
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.AirborneVelocity Property

AdsbMessageAirborneVelocity Property
Gets or sets the content of an airborne velocity message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirborneVelocityMessage AirborneVelocity { get; set; }
Public Property AirborneVelocity As AirborneVelocityMessage
    Get
    Set
public:
property AirborneVelocityMessage^ AirborneVelocity {
    AirborneVelocityMessage^ get ();
    void set (AirborneVelocityMessage^ value);
}
member AirborneVelocity : AirborneVelocityMessage with get, set

Property Value

Type: AirborneVelocityMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.AircraftOperationalStatus Property

AdsbMessageAircraftOperationalStatus Property
Gets or sets the content of the aircraft operational status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOperationalStatusMessage AircraftOperationalStatus { get; set; }
Public Property AircraftOperationalStatus As AircraftOperationalStatusMessage
    Get
    Set
public:
property AircraftOperationalStatusMessage^ AircraftOperationalStatus {
    AircraftOperationalStatusMessage^ get ();
    void set (AircraftOperationalStatusMessage^ value);
}
member AircraftOperationalStatus : AircraftOperationalStatusMessage with get, set

Property Value

Type: AircraftOperationalStatusMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.AircraftStatus Property

AdsbMessageAircraftStatus Property
Gets or sets the content of an aircraft status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftStatusMessage AircraftStatus { get; set; }
Public Property AircraftStatus As AircraftStatusMessage
    Get
    Set
public:
property AircraftStatusMessage^ AircraftStatus {
    AircraftStatusMessage^ get ();
    void set (AircraftStatusMessage^ value);
}
member AircraftStatus : AircraftStatusMessage with get, set

Property Value

Type: AircraftStatusMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.CoarseTisbAirbornePosition Property

AdsbMessageCoarseTisbAirbornePosition Property
Gets or sets the content of the TIS-B coarse airborne position message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoarseTisbAirbornePosition CoarseTisbAirbornePosition { get; set; }
Public Property CoarseTisbAirbornePosition As CoarseTisbAirbornePosition
    Get
    Set
public:
property CoarseTisbAirbornePosition^ CoarseTisbAirbornePosition {
    CoarseTisbAirbornePosition^ get ();
    void set (CoarseTisbAirbornePosition^ value);
}
member CoarseTisbAirbornePosition : CoarseTisbAirbornePosition with get, set

Property Value

Type: CoarseTisbAirbornePosition
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.IdentifierAndCategory Property

AdsbMessageIdentifierAndCategory Property
Gets or sets the content of an identifer and category message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IdentifierAndCategoryMessage IdentifierAndCategory { get; set; }
Public Property IdentifierAndCategory As IdentifierAndCategoryMessage
    Get
    Set
public:
property IdentifierAndCategoryMessage^ IdentifierAndCategory {
    IdentifierAndCategoryMessage^ get ();
    void set (IdentifierAndCategoryMessage^ value);
}
member IdentifierAndCategory : IdentifierAndCategoryMessage with get, set

Property Value

Type: IdentifierAndCategoryMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.MessageFormat Property

AdsbMessageMessageFormat Property
Gets or sets the format of ADS-B message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MessageFormat MessageFormat { get; set; }
Public Property MessageFormat As MessageFormat
    Get
    Set
public:
property MessageFormat MessageFormat {
    MessageFormat get ();
    void set (MessageFormat value);
}
member MessageFormat : MessageFormat with get, set

Property Value

Type: MessageFormat
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.ModeSMessage Property

AdsbMessageModeSMessage Property
Gets the parent Mode-S message that carried the ADS-B message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModeSMessage ModeSMessage { get; set; }
Public Property ModeSMessage As ModeSMessage
    Get
    Set
public:
property ModeSMessage^ ModeSMessage {
    ModeSMessage^ get ();
    void set (ModeSMessage^ value);
}
member ModeSMessage : ModeSMessage with get, set

Property Value

Type: ModeSMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.SurfacePosition Property

AdsbMessageSurfacePosition Property
Gets or sets the content of a surface position message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SurfacePositionMessage SurfacePosition { get; set; }
Public Property SurfacePosition As SurfacePositionMessage
    Get
    Set
public:
property SurfacePositionMessage^ SurfacePosition {
    SurfacePositionMessage^ get ();
    void set (SurfacePositionMessage^ value);
}
member SurfacePosition : SurfacePositionMessage with get, set

Property Value

Type: SurfacePositionMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.TargetStateAndStatus Property

AdsbMessageTargetStateAndStatus Property
Gets or sets the content of the target state and status messages (not present in ADS-B version 0).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusMessage TargetStateAndStatus { get; set; }
Public Property TargetStateAndStatus As TargetStateAndStatusMessage
    Get
    Set
public:
property TargetStateAndStatusMessage^ TargetStateAndStatus {
    TargetStateAndStatusMessage^ get ();
    void set (TargetStateAndStatusMessage^ value);
}
member TargetStateAndStatus : TargetStateAndStatusMessage with get, set

Property Value

Type: TargetStateAndStatusMessage
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.TisbIcaoModeAFlag Property

AdsbMessageTisbIcaoModeAFlag Property
Gets or sets the value of the ICAO/Mode-A flag for TIS-B fine-format messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> TisbIcaoModeAFlag { get; set; }
Public Property TisbIcaoModeAFlag As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> TisbIcaoModeAFlag {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member TisbIcaoModeAFlag : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
Remarks
This is only used on TIS-B fine format messages. It is either zero or one for those messages. For all other types of message this value is null.
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.Type Property

AdsbMessageType Property
Gets or sets the type of the message as described by the first 5 bits.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Type { get; set; }
Public Property Type As Byte
    Get
    Set
public:
property unsigned char Type {
    unsigned char get ();
    void set (unsigned char value);
}
member Type : byte with get, set

Property Value

Type: Byte
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage Methods

AdsbMessage Methods

The AdsbMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AdsbMessage.ToString Method

AdsbMessageToString Method
Returns an English description of the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AdsbMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneCapabilityVersion0 Enumeration

AirborneCapabilityVersion0 Enumeration
An enumeration of the airborne capability flags for version 0 ADS-B aircraft operational status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AirborneCapabilityVersion0
<FlagsAttribute>
Public Enumeration AirborneCapabilityVersion0
[FlagsAttribute]
public enum class AirborneCapabilityVersion0
[<FlagsAttribute>]
type AirborneCapabilityVersion0
Members
Member name | Value | Description
HasCockpitDisplayTrafficInformation | 4096 | The aircraft has CDTI.
TcasNotOperational | 8192 | TCAS / ACAS is not operational.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AirborneCapabilityVersion1 Enumeration

AirborneCapabilityVersion1 Enumeration
An enumeration of the different airborne capability flags for version 1 ADS-B aircraft operational status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AirborneCapabilityVersion1
<FlagsAttribute>
Public Enumeration AirborneCapabilityVersion1
[FlagsAttribute]
public enum class AirborneCapabilityVersion1
[<FlagsAttribute>]
type AirborneCapabilityVersion1
Members
Member name | Value | Description
HasMultipleTargetChangeReport | 64 | The aircraft can send messages for multiple TC reports.
HasSingleTargetChangeReport | 128 | The aircraft can send messages for the TC+0 report only.
HasTargetStateReport | 256 | The aircraft can send messages for TS reports.
HasAirReferencedVelocityReport | 512 | The aircraft can send messages for ARV reports.
HasCockpitDisplayTrafficInformation | 4096 | The aircraft has CDTI.
TcasNotOperational | 8192 | TCAS / ACAS is not operational.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AirborneCapabilityVersion2 Enumeration

AirborneCapabilityVersion2 Enumeration
An enumeration of the aircraft capability flags transmitted in version 2 ADS-B aircraft operational status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AirborneCapabilityVersion2
<FlagsAttribute>
Public Enumeration AirborneCapabilityVersion2
[FlagsAttribute]
public enum class AirborneCapabilityVersion2
[<FlagsAttribute>]
type AirborneCapabilityVersion2
Members
Member name | Value | Description
ReservedForAdsr | 16 | Reserved for ADS-R.
HasUniversalAccessTransceiver | 32 | The aircraft has UAT receive capability.
HasMultipleTargetChangeReport | 64 | The aircraft can send messages for multiple TC reports.
HasSingleTargetChangeReport | 128 | The aircraft can send messages for the TC+0 report only.
HasTargetStateReport | 256 | The aircraft can send messages for TS reports.
HasAirReferencedVelocityReport | 512 | The aircraft can send messages for ARV reports.
HasCockpitDisplayTrafficInformation | 4096 | The aircraft has CDTI.
TcasIsOperational | 8192 | TCAS / ACAS is operational (note this is the reverse of the meaning for the same bit in version 0 and 1 messages).
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage Class

AirbornePositionMessage Class
Describes the content of an ADS-B airborne position message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbAirbornePositionMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AirbornePositionMessage
Public Class AirbornePositionMessage
public ref class AirbornePositionMessage
type AirbornePositionMessage =  class end

The AirbornePositionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AirbornePositionMessage | Initializes a new instance of the AirbornePositionMessage class
Top
Properties
 | Name | Description
Public property | BarometricAltitude | Gets or sets the altitude in feet relative to a standard pressure of 1013.25mb / 29.92Hg.
Public property | CompactPosition | Gets or sets the compact position report coordinate from the message.
Public property | GeometricAltitude | Gets or sets the altitude in feet as the height above the elipsoid.
Public property | NicB | Gets or sets the NIC-B Supplement bit from the message. This is either 0x00 or 0x02.
Public property | PositionTimeIsExact | Gets or sets a value indicating that the time at which the horizontal position was recorded is an exact 0.2 second UTC epoch or not.
Public property | SurveillanceStatus | Gets or sets an indication of the meaning of the Mode-A transponder attached to the aircraft.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message content. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage Constructor

AirbornePositionMessage Constructor
Initializes a new instance of the AirbornePositionMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirbornePositionMessage()
Public Sub New
public:
AirbornePositionMessage()
new : unit -> AirbornePositionMessage
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage Properties

AirbornePositionMessage Properties

The AirbornePositionMessage type exposes the following members.

Properties
 | Name | Description
Public property | BarometricAltitude | Gets or sets the altitude in feet relative to a standard pressure of 1013.25mb / 29.92Hg.
Public property | CompactPosition | Gets or sets the compact position report coordinate from the message.
Public property | GeometricAltitude | Gets or sets the altitude in feet as the height above the elipsoid.
Public property | NicB | Gets or sets the NIC-B Supplement bit from the message. This is either 0x00 or 0x02.
Public property | PositionTimeIsExact | Gets or sets a value indicating that the time at which the horizontal position was recorded is an exact 0.2 second UTC epoch or not.
Public property | SurveillanceStatus | Gets or sets an indication of the meaning of the Mode-A transponder attached to the aircraft.
Top
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.BarometricAltitude Property

AirbornePositionMessageBarometricAltitude Property
Gets or sets the altitude in feet relative to a standard pressure of 1013.25mb / 29.92Hg.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> BarometricAltitude { get; set; }
Public Property BarometricAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> BarometricAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member BarometricAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.CompactPosition Property

AirbornePositionMessageCompactPosition Property
Gets or sets the compact position report coordinate from the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompactPositionReportingCoordinate CompactPosition { get; set; }
Public Property CompactPosition As CompactPositionReportingCoordinate
    Get
    Set
public:
property CompactPositionReportingCoordinate^ CompactPosition {
    CompactPositionReportingCoordinate^ get ();
    void set (CompactPositionReportingCoordinate^ value);
}
member CompactPosition : CompactPositionReportingCoordinate with get, set

Property Value

Type: CompactPositionReportingCoordinate
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.GeometricAltitude Property

AirbornePositionMessageGeometricAltitude Property
Gets or sets the altitude in feet as the height above the elipsoid.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> GeometricAltitude { get; set; }
Public Property GeometricAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> GeometricAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member GeometricAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.NicB Property

AirbornePositionMessageNicB Property
Gets or sets the NIC-B Supplement bit from the message. This is either 0x00 or 0x02.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte NicB { get; set; }
Public Property NicB As Byte
    Get
    Set
public:
property unsigned char NicB {
    unsigned char get ();
    void set (unsigned char value);
}
member NicB : byte with get, set

Property Value

Type: Byte
Remarks

Note that the NIC supplement is three bits that are spread over different messages. If this is non-null then the message carries ONE of those bits. Each bit is set to the correct position (i.e. a NIC-A bit would show a value here of 4, NIC-B 2 and NIC-C 1) so something that was building the overall NIC value could OR together the value here with previous NIC bits to eventually arrive at the full NIC supplement.

Note also that these bits were previously assigned different meanings in their respective messages in older versions of the ADS-B transmission. Those older meanings are not represented in this class.

On TIS-B Fine Format messages this byte is not supplied, its position is used by the Icao/ModeA Flag.

See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.PositionTimeIsExact Property

AirbornePositionMessagePositionTimeIsExact Property
Gets or sets a value indicating that the time at which the horizontal position was recorded is an exact 0.2 second UTC epoch or not.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PositionTimeIsExact { get; set; }
Public Property PositionTimeIsExact As Boolean
    Get
    Set
public:
property bool PositionTimeIsExact {
    bool get ();
    void set (bool value);
}
member PositionTimeIsExact : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.SurveillanceStatus Property

AirbornePositionMessageSurveillanceStatus Property
Gets or sets an indication of the meaning of the Mode-A transponder attached to the aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SurveillanceStatus SurveillanceStatus { get; set; }
Public Property SurveillanceStatus As SurveillanceStatus
    Get
    Set
public:
property SurveillanceStatus SurveillanceStatus {
    SurveillanceStatus get ();
    void set (SurveillanceStatus value);
}
member SurveillanceStatus : SurveillanceStatus with get, set

Property Value

Type: SurveillanceStatus
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage Methods

AirbornePositionMessage Methods

The AirbornePositionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message content. (Overrides ObjectToString.)
Top
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirbornePositionMessage.ToString Method

AirbornePositionMessageToString Method
Returns an English description of the message content.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AirbornePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage Class

AirborneVelocityMessage Class
Gets or sets the content of an airborne velocity ADS-B message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbAirborneVelocityMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AirborneVelocityMessage
Public Class AirborneVelocityMessage
public ref class AirborneVelocityMessage
type AirborneVelocityMessage =  class end

The AirborneVelocityMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AirborneVelocityMessage | Initializes a new instance of the AirborneVelocityMessage class
Top
Properties
 | Name | Description
Public property | Airspeed | Gets or sets the aircraft's airspeed in knots.
Public property | AirspeedExceeded | Gets or sets a value indicating that the aircraft's airspeed is higher than the maximum value that ADS-B messages can carry.
Public property | AirspeedIsTrueAirspeed | Gets or sets a value indicating whether the Airspeed property indicates true airspeed or indicated airspeed.
Public property | ChangeOfIntent | Gets or sets a value indicating that the Intent Change flag in a velocity message was set.
Public property | GeometricAltitudeDelta | Gets or sets the difference between geometric and barometric altitude. Positive values indicate geometric altitude is above barometric, negative values indicate geometric altitude is below barometric.
Public property | GeometricAltitudeDeltaExceeded | Gets or sets a value indicating that the difference between the geometric and barometric altitude sources exceeds the maximum value that ADS-B can convey.
Public property | Heading | Gets or sets the aircraft's heading (not its ground track).
Public property | HorizontalVelocityError | Gets or sets the margin for error for the horizontal velocity values.
Public property | VectorVelocity | Gets or sets the velocity and bearing when expressed in an ADS-B message as a pair of speeds along the X/Y axes.
Public property | VelocityType | Gets or sets the type of velocity encoded within the message, specifically whether it is airspeed or ground speed.
Public property | VerticalRate | Gets or sets the vertical rate in feet per minute. Positive values indicate that the vehicle is ascending, negative values indicate the vehicle is descending.
Public property | VerticalRateExceeded | Gets or sets a value indicating that the vertical rate exceeds the highest value that the ADS-B message can convey.
Public property | VerticalRateIsBarometric | Gets or sets a value indicating that the source for the vertical rate is barometric as opposed to geometric.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage Constructor

AirborneVelocityMessage Constructor
Initializes a new instance of the AirborneVelocityMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AirborneVelocityMessage()
Public Sub New
public:
AirborneVelocityMessage()
new : unit -> AirborneVelocityMessage
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage Properties

AirborneVelocityMessage Properties

The AirborneVelocityMessage type exposes the following members.

Properties
 | Name | Description
Public property | Airspeed | Gets or sets the aircraft's airspeed in knots.
Public property | AirspeedExceeded | Gets or sets a value indicating that the aircraft's airspeed is higher than the maximum value that ADS-B messages can carry.
Public property | AirspeedIsTrueAirspeed | Gets or sets a value indicating whether the Airspeed property indicates true airspeed or indicated airspeed.
Public property | ChangeOfIntent | Gets or sets a value indicating that the Intent Change flag in a velocity message was set.
Public property | GeometricAltitudeDelta | Gets or sets the difference between geometric and barometric altitude. Positive values indicate geometric altitude is above barometric, negative values indicate geometric altitude is below barometric.
Public property | GeometricAltitudeDeltaExceeded | Gets or sets a value indicating that the difference between the geometric and barometric altitude sources exceeds the maximum value that ADS-B can convey.
Public property | Heading | Gets or sets the aircraft's heading (not its ground track).
Public property | HorizontalVelocityError | Gets or sets the margin for error for the horizontal velocity values.
Public property | VectorVelocity | Gets or sets the velocity and bearing when expressed in an ADS-B message as a pair of speeds along the X/Y axes.
Public property | VelocityType | Gets or sets the type of velocity encoded within the message, specifically whether it is airspeed or ground speed.
Public property | VerticalRate | Gets or sets the vertical rate in feet per minute. Positive values indicate that the vehicle is ascending, negative values indicate the vehicle is descending.
Public property | VerticalRateExceeded | Gets or sets a value indicating that the vertical rate exceeds the highest value that the ADS-B message can convey.
Public property | VerticalRateIsBarometric | Gets or sets a value indicating that the source for the vertical rate is barometric as opposed to geometric.
Top
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.Airspeed Property

AirborneVelocityMessageAirspeed Property
Gets or sets the aircraft's airspeed in knots.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Airspeed { get; set; }
Public Property Airspeed As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Airspeed {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Airspeed : Nullable<float> with get, set

Property Value

Type: Nullable Double
Remarks
If this value is supplied then Heading will also indicate the heading (although it can be null if the heading is unknown) and VectorVelocity will be null.
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.AirspeedExceeded Property

AirborneVelocityMessageAirspeedExceeded Property
Gets or sets a value indicating that the aircraft's airspeed is higher than the maximum value that ADS-B messages can carry.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AirspeedExceeded { get; set; }
Public Property AirspeedExceeded As Boolean
    Get
    Set
public:
property bool AirspeedExceeded {
    bool get ();
    void set (bool value);
}
member AirspeedExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
If this true then the aircraft's actual airspeed is higher than the value held in Airspeed.
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.AirspeedIsTrueAirspeed Property

AirborneVelocityMessageAirspeedIsTrueAirspeed Property
Gets or sets a value indicating whether the Airspeed property indicates true airspeed or indicated airspeed.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AirspeedIsTrueAirspeed { get; set; }
Public Property AirspeedIsTrueAirspeed As Boolean
    Get
    Set
public:
property bool AirspeedIsTrueAirspeed {
    bool get ();
    void set (bool value);
}
member AirspeedIsTrueAirspeed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.ChangeOfIntent Property

AirborneVelocityMessageChangeOfIntent Property
Gets or sets a value indicating that the Intent Change flag in a velocity message was set.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ChangeOfIntent { get; set; }
Public Property ChangeOfIntent As Boolean
    Get
    Set
public:
property bool ChangeOfIntent {
    bool get ();
    void set (bool value);
}
member ChangeOfIntent : bool with get, set

Property Value

Type: Boolean
Remarks
In Fine Format TIS-B messages this field is not present, it is used to carry the ICAO/Mode-A Flag field. On those messages this value is always false.
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.GeometricAltitudeDelta Property

AirborneVelocityMessageGeometricAltitudeDelta Property
Gets or sets the difference between geometric and barometric altitude. Positive values indicate geometric altitude is above barometric, negative values indicate geometric altitude is below barometric.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> GeometricAltitudeDelta { get; set; }
Public Property GeometricAltitudeDelta As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> GeometricAltitudeDelta {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member GeometricAltitudeDelta : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.GeometricAltitudeDeltaExceeded Property

AirborneVelocityMessageGeometricAltitudeDeltaExceeded Property
Gets or sets a value indicating that the difference between the geometric and barometric altitude sources exceeds the maximum value that ADS-B can convey.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GeometricAltitudeDeltaExceeded { get; set; }
Public Property GeometricAltitudeDeltaExceeded As Boolean
    Get
    Set
public:
property bool GeometricAltitudeDeltaExceeded {
    bool get ();
    void set (bool value);
}
member GeometricAltitudeDeltaExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
If this is true then the difference between the geometric altitude and barometric altitude sources is larger than the value in GeometricAltitudeDelta.
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.Heading Property

AirborneVelocityMessageHeading Property
Gets or sets the aircraft's heading (not its ground track).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Heading { get; set; }
Public Property Heading As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Heading {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Heading : Nullable<float> with get, set

Property Value

Type: Nullable Double
Remarks
If this value is supplied then Airspeed will also indicate the airspeed (although it can be null if the airspeed is unknown) and VectorVelocity will be null.
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.HorizontalVelocityError Property

AirborneVelocityMessageHorizontalVelocityError Property
Gets or sets the margin for error for the horizontal velocity values.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> HorizontalVelocityError { get; set; }
Public Property HorizontalVelocityError As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> HorizontalVelocityError {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member HorizontalVelocityError : Nullable<float32> with get, set

Property Value

Type: Nullable Single
Remarks

Positive values indicate an error that is greater than or equal to the value in metres/second. Negative values indicate a margin for error that is less than the absolute value in metres/second. So a value of 10.0 indicates a margin for error greater than or equal to 10 m/s whereas a value of -10 indicates a margin for error that is less than 10 m/s. Null values indicate that the value was undefined by the documentation.

See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.VectorVelocity Property

AirborneVelocityMessageVectorVelocity Property
Gets or sets the velocity and bearing when expressed in an ADS-B message as a pair of speeds along the X/Y axes.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VectorVelocity VectorVelocity { get; set; }
Public Property VectorVelocity As VectorVelocity
    Get
    Set
public:
property VectorVelocity^ VectorVelocity {
    VectorVelocity^ get ();
    void set (VectorVelocity^ value);
}
member VectorVelocity : VectorVelocity with get, set

Property Value

Type: VectorVelocity
Remarks

At the time of writing this is used when the speed is the ground speed and the bearing the ground track. However you should consult the VelocityType property to confirm that this is not the airspeed and heading.

If this value is supplied then Heading and Airspeed will be null.

See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.VelocityType Property

AirborneVelocityMessageVelocityType Property
Gets or sets the type of velocity encoded within the message, specifically whether it is airspeed or ground speed.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VelocityType VelocityType { get; set; }
Public Property VelocityType As VelocityType
    Get
    Set
public:
property VelocityType VelocityType {
    VelocityType get ();
    void set (VelocityType value);
}
member VelocityType : VelocityType with get, set

Property Value

Type: VelocityType
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.VerticalRate Property

AirborneVelocityMessageVerticalRate Property
Gets or sets the vertical rate in feet per minute. Positive values indicate that the vehicle is ascending, negative values indicate the vehicle is descending.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> VerticalRate { get; set; }
Public Property VerticalRate As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> VerticalRate {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member VerticalRate : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.VerticalRateExceeded Property

AirborneVelocityMessageVerticalRateExceeded Property
Gets or sets a value indicating that the vertical rate exceeds the highest value that the ADS-B message can convey.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VerticalRateExceeded { get; set; }
Public Property VerticalRateExceeded As Boolean
    Get
    Set
public:
property bool VerticalRateExceeded {
    bool get ();
    void set (bool value);
}
member VerticalRateExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
When this is true the actual vertical rate is higher than VerticalRate.
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.VerticalRateIsBarometric Property

AirborneVelocityMessageVerticalRateIsBarometric Property
Gets or sets a value indicating that the source for the vertical rate is barometric as opposed to geometric.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VerticalRateIsBarometric { get; set; }
Public Property VerticalRateIsBarometric As Boolean
    Get
    Set
public:
property bool VerticalRateIsBarometric {
    bool get ();
    void set (bool value);
}
member VerticalRateIsBarometric : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage Methods

AirborneVelocityMessage Methods

The AirborneVelocityMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AirborneVelocityMessage.ToString Method

AirborneVelocityMessageToString Method
Returns an English description of the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AirborneVelocityMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage Class

AircraftOperationalStatusMessage Class
A class that describes the content of ADS-B Aircraft Operational Status messages.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbAircraftOperationalStatusMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftOperationalStatusMessage
Public Class AircraftOperationalStatusMessage
public ref class AircraftOperationalStatusMessage
type AircraftOperationalStatusMessage =  class end

The AircraftOperationalStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftOperationalStatusMessage | Initializes a new instance of the AircraftOperationalStatusMessage class
Top
Properties
 | Name | Description
Public property | AdsbVersion | Gets or sets the ADS-B version that the transmitter is using.
Public property | AirborneCapability | Gets or sets the airborne capability flags. The meaning of the flags depends upon the AdsbVersion.
Public property | AircraftOperationalStatusType | Gets or sets the type of information carried by the message.
Public property | Gva | Gets or sets the geometric vertical accuracy code.
Public property | HorizontalReferenceIsMagneticNorth | Gets or sets a value indicating whether horizontal angles are references against true north (false) or magnetic north (true).
Public property | IsRebroadcast | Gets or sets a value indicating that the message has been rebroadcast by a ground link. It's unlikely that we shall ever see this set.
Public property | LateralAxisGpsOffset | Gets or sets the offset, in metres, of the GPS antenna from the longitudinal centre line of the aircraft. Positive values indicate an offset towards the left wingtip, negative values are an offset towards the right wingtip.
Public property | LongitudinalAxisGpsOffset | Gets or sets the offset, in metres, of the GPS antenna from the nose of the aircraft.
Public property | MaximumLength | Gets or sets the upper-bound length of the vehicle in metres.
Public property | MaximumWidth | Gets or sets the upper-bound width of the vehicle in metres.
Public property | NacP | Gets or sets the navigational accuracy category for positions.
Public property | NicA | Gets or sets the value of the NIC Supplement A field.
Public property | NicBaro | Gets or sets a value indicating the integrity category for barometric altitudes.
Public property | NicC | Gets or sets the value of the NIC Supplement C field.
Public property | OperationalMode | Gets or sets the operational modes that are active on board the aircraft.
Public property | Sil | Gets or sets the source integrity level code.
Public property | SilSupplement | Gets or sets a value indicating whether the reporting SIL probability is based on a per-sample (true) or per-hour (false) probability.
Public property | SurfaceCapability | Gets or sets the surface capability flags.
Public property | SurfacePositionAngleIsTrack | Gets or sets a value indicating whether the track angle in surface position messages is the target heading angle (false) or the track angle (true).
Public property | SystemDesignAssurance | Gets or sets the SDA value extracted from the OperationalMode value in version 2 messages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message content. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage Constructor

AircraftOperationalStatusMessage Constructor
Initializes a new instance of the AircraftOperationalStatusMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOperationalStatusMessage()
Public Sub New
public:
AircraftOperationalStatusMessage()
new : unit -> AircraftOperationalStatusMessage
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage Properties

AircraftOperationalStatusMessage Properties

The AircraftOperationalStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | AdsbVersion | Gets or sets the ADS-B version that the transmitter is using.
Public property | AirborneCapability | Gets or sets the airborne capability flags. The meaning of the flags depends upon the AdsbVersion.
Public property | AircraftOperationalStatusType | Gets or sets the type of information carried by the message.
Public property | Gva | Gets or sets the geometric vertical accuracy code.
Public property | HorizontalReferenceIsMagneticNorth | Gets or sets a value indicating whether horizontal angles are references against true north (false) or magnetic north (true).
Public property | IsRebroadcast | Gets or sets a value indicating that the message has been rebroadcast by a ground link. It's unlikely that we shall ever see this set.
Public property | LateralAxisGpsOffset | Gets or sets the offset, in metres, of the GPS antenna from the longitudinal centre line of the aircraft. Positive values indicate an offset towards the left wingtip, negative values are an offset towards the right wingtip.
Public property | LongitudinalAxisGpsOffset | Gets or sets the offset, in metres, of the GPS antenna from the nose of the aircraft.
Public property | MaximumLength | Gets or sets the upper-bound length of the vehicle in metres.
Public property | MaximumWidth | Gets or sets the upper-bound width of the vehicle in metres.
Public property | NacP | Gets or sets the navigational accuracy category for positions.
Public property | NicA | Gets or sets the value of the NIC Supplement A field.
Public property | NicBaro | Gets or sets a value indicating the integrity category for barometric altitudes.
Public property | NicC | Gets or sets the value of the NIC Supplement C field.
Public property | OperationalMode | Gets or sets the operational modes that are active on board the aircraft.
Public property | Sil | Gets or sets the source integrity level code.
Public property | SilSupplement | Gets or sets a value indicating whether the reporting SIL probability is based on a per-sample (true) or per-hour (false) probability.
Public property | SurfaceCapability | Gets or sets the surface capability flags.
Public property | SurfacePositionAngleIsTrack | Gets or sets a value indicating whether the track angle in surface position messages is the target heading angle (false) or the track angle (true).
Public property | SystemDesignAssurance | Gets or sets the SDA value extracted from the OperationalMode value in version 2 messages.
Top
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.AdsbVersion Property

AircraftOperationalStatusMessageAdsbVersion Property
Gets or sets the ADS-B version that the transmitter is using.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte AdsbVersion { get; set; }
Public Property AdsbVersion As Byte
    Get
    Set
public:
property unsigned char AdsbVersion {
    unsigned char get ();
    void set (unsigned char value);
}
member AdsbVersion : byte with get, set

Property Value

Type: Byte
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.AirborneCapability Property

AircraftOperationalStatusMessageAirborneCapability Property
Gets or sets the airborne capability flags. The meaning of the flags depends upon the AdsbVersion.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<ushort> AirborneCapability { get; set; }
Public Property AirborneCapability As Nullable(Of UShort)
    Get
    Set
public:
property Nullable<unsigned short> AirborneCapability {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}
member AirborneCapability : Nullable<uint16> with get, set

Property Value

Type: Nullable UInt16
Remarks
If AdsbVersion is 0 then the flags are as per the AirborneCapabilityVersion0 flags enumeration. If AdsbVersion is 1 then the flags are as per the AirborneCapabilityVersion1 flags enumeration. If AdsbVersion is 2 then the flags are as per the AirborneCapabilityVersion2 flags enumeration. Otherwise the property will be set to null.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.AircraftOperationalStatusType Property

AircraftOperationalStatusMessageAircraftOperationalStatusType Property
Gets or sets the type of information carried by the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftOperationalStatusType AircraftOperationalStatusType { get; set; }
Public Property AircraftOperationalStatusType As AircraftOperationalStatusType
    Get
    Set
public:
property AircraftOperationalStatusType AircraftOperationalStatusType {
    AircraftOperationalStatusType get ();
    void set (AircraftOperationalStatusType value);
}
member AircraftOperationalStatusType : AircraftOperationalStatusType with get, set

Property Value

Type: AircraftOperationalStatusType
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.Gva Property

AircraftOperationalStatusMessageGva Property
Gets or sets the geometric vertical accuracy code.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> Gva { get; set; }
Public Property Gva As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> Gva {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member Gva : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
Remarks
I don't bother decoding this, it is just the raw value from the message.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.HorizontalReferenceIsMagneticNorth Property

AircraftOperationalStatusMessageHorizontalReferenceIsMagneticNorth Property
Gets or sets a value indicating whether horizontal angles are references against true north (false) or magnetic north (true).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> HorizontalReferenceIsMagneticNorth { get; set; }
Public Property HorizontalReferenceIsMagneticNorth As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> HorizontalReferenceIsMagneticNorth {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member HorizontalReferenceIsMagneticNorth : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.IsRebroadcast Property

AircraftOperationalStatusMessageIsRebroadcast Property
Gets or sets a value indicating that the message has been rebroadcast by a ground link. It's unlikely that we shall ever see this set.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsRebroadcast { get; set; }
Public Property IsRebroadcast As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsRebroadcast {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsRebroadcast : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.LateralAxisGpsOffset Property

AircraftOperationalStatusMessageLateralAxisGpsOffset Property
Gets or sets the offset, in metres, of the GPS antenna from the longitudinal centre line of the aircraft. Positive values indicate an offset towards the left wingtip, negative values are an offset towards the right wingtip.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> LateralAxisGpsOffset { get; set; }
Public Property LateralAxisGpsOffset As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> LateralAxisGpsOffset {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member LateralAxisGpsOffset : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
Remarks
The largest offset that the message can represent is six metres. Offsets over 6m are shown as 6.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.LongitudinalAxisGpsOffset Property

AircraftOperationalStatusMessageLongitudinalAxisGpsOffset Property
Gets or sets the offset, in metres, of the GPS antenna from the nose of the aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> LongitudinalAxisGpsOffset { get; set; }
Public Property LongitudinalAxisGpsOffset As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> LongitudinalAxisGpsOffset {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member LongitudinalAxisGpsOffset : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
Remarks
The largest offset that the message can represent is sixty metres. Offsets over 60m are shown as 60.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.MaximumLength Property

AircraftOperationalStatusMessageMaximumLength Property
Gets or sets the upper-bound length of the vehicle in metres.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> MaximumLength { get; set; }
Public Property MaximumLength As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> MaximumLength {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member MaximumLength : Nullable<float32> with get, set

Property Value

Type: Nullable Single
Remarks
The length of the vehicle is, at most, this many metres - except when it is over 85 metres long or 90 metres wide, in which case this value is set to 85.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.MaximumWidth Property

AircraftOperationalStatusMessageMaximumWidth Property
Gets or sets the upper-bound width of the vehicle in metres.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> MaximumWidth { get; set; }
Public Property MaximumWidth As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> MaximumWidth {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member MaximumWidth : Nullable<float32> with get, set

Property Value

Type: Nullable Single
Remarks
The width of the vehicle is, at most, this many metres - except when it is over 85 metres long or 90 metres wide, in which case this value is set to 90.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.NacP Property

AircraftOperationalStatusMessageNacP Property
Gets or sets the navigational accuracy category for positions.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> NacP { get; set; }
Public Property NacP As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> NacP {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member NacP : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
Remarks
I don't bother decoding this, it is just the raw value from the message.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.NicA Property

AircraftOperationalStatusMessageNicA Property
Gets or sets the value of the NIC Supplement A field.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> NicA { get; set; }
Public Property NicA As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> NicA {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member NicA : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.NicBaro Property

AircraftOperationalStatusMessageNicBaro Property
Gets or sets a value indicating the integrity category for barometric altitudes.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> NicBaro { get; set; }
Public Property NicBaro As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> NicBaro {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member NicBaro : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks

If this is false then the altitude reported in airborne position messages is a Gillham altitude that has not been cross-checked against other sources of pressure altitude.

If this is true then the altitude reported in airborne position messages is either a Gillham altitude that has been cross-checked against other sources and is verified as being consistent or it is not based on a Gillham source of pressure altitude.

See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.NicC Property

AircraftOperationalStatusMessageNicC Property
Gets or sets the value of the NIC Supplement C field.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> NicC { get; set; }
Public Property NicC As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> NicC {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member NicC : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.OperationalMode Property

AircraftOperationalStatusMessageOperationalMode Property
Gets or sets the operational modes that are active on board the aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<OperationalMode> OperationalMode { get; set; }
Public Property OperationalMode As Nullable(Of OperationalMode)
    Get
    Set
public:
property Nullable<OperationalMode> OperationalMode {
    Nullable<OperationalMode> get ();
    void set (Nullable<OperationalMode> value);
}
member OperationalMode : Nullable<OperationalMode> with get, set

Property Value

Type: Nullable OperationalMode
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.Sil Property

AircraftOperationalStatusMessageSil Property
Gets or sets the source integrity level code.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> Sil { get; set; }
Public Property Sil As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> Sil {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member Sil : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
Remarks
I don't bother decoding this, it is just the raw value from the message.
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.SilSupplement Property

AircraftOperationalStatusMessageSilSupplement Property
Gets or sets a value indicating whether the reporting SIL probability is based on a per-sample (true) or per-hour (false) probability.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> SilSupplement { get; set; }
Public Property SilSupplement As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> SilSupplement {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member SilSupplement : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.SurfaceCapability Property

AircraftOperationalStatusMessageSurfaceCapability Property
Gets or sets the surface capability flags.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<SurfaceCapability> SurfaceCapability { get; set; }
Public Property SurfaceCapability As Nullable(Of SurfaceCapability)
    Get
    Set
public:
property Nullable<SurfaceCapability> SurfaceCapability {
    Nullable<SurfaceCapability> get ();
    void set (Nullable<SurfaceCapability> value);
}
member SurfaceCapability : Nullable<SurfaceCapability> with get, set

Property Value

Type: Nullable SurfaceCapability
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.SurfacePositionAngleIsTrack Property

AircraftOperationalStatusMessageSurfacePositionAngleIsTrack Property
Gets or sets a value indicating whether the track angle in surface position messages is the target heading angle (false) or the track angle (true).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> SurfacePositionAngleIsTrack { get; set; }
Public Property SurfacePositionAngleIsTrack As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> SurfacePositionAngleIsTrack {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member SurfacePositionAngleIsTrack : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.SystemDesignAssurance Property

AircraftOperationalStatusMessageSystemDesignAssurance Property
Gets or sets the SDA value extracted from the OperationalMode value in version 2 messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<SystemDesignAssurance> SystemDesignAssurance { get; set; }
Public Property SystemDesignAssurance As Nullable(Of SystemDesignAssurance)
    Get
    Set
public:
property Nullable<SystemDesignAssurance> SystemDesignAssurance {
    Nullable<SystemDesignAssurance> get ();
    void set (Nullable<SystemDesignAssurance> value);
}
member SystemDesignAssurance : Nullable<SystemDesignAssurance> with get, set

Property Value

Type: Nullable SystemDesignAssurance
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage Methods

AircraftOperationalStatusMessage Methods

The AircraftOperationalStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message content. (Overrides ObjectToString.)
Top
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusMessage.ToString Method

AircraftOperationalStatusMessageToString Method
Returns an English description of the message content.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AircraftOperationalStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftOperationalStatusType Enumeration

AircraftOperationalStatusType Enumeration
An enumeration of the different types of aircraft operational status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AircraftOperationalStatusType
Public Enumeration AircraftOperationalStatusType
public enum class AircraftOperationalStatusType
type AircraftOperationalStatusType
Members
Member name | Value | Description
AirborneCapability | 0 | The message carries airborne capability information.
SurfaceCapability | 1 | The message carries surface capability information.
AircraftOperationalStatusType2 | 2 | Reserved.
AircraftOperationalStatusType3 | 3 | Reserved.
AircraftOperationalStatusType4 | 4 | Reserved.
AircraftOperationalStatusType5 | 5 | Reserved.
AircraftOperationalStatusType6 | 6 | Reserved.
AircraftOperationalStatusType7 | 7 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage Class

AircraftStatusMessage Class
A class describing the content of the ADS-B aircraft status message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbAircraftStatusMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftStatusMessage
Public Class AircraftStatusMessage
public ref class AircraftStatusMessage
type AircraftStatusMessage =  class end

The AircraftStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftStatusMessage | Initializes a new instance of the AircraftStatusMessage class
Top
Properties
 | Name | Description
Public property | AircraftStatusType | Gets or sets a value that indicates what type of status message was received.
Public property | EmergencyStatus | Gets or sets the content of an emergency/priority status message.
Public property | TcasResolutionAdvisory | Gets or sets the content of a TCAS RA broadcast message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage Constructor

AircraftStatusMessage Constructor
Initializes a new instance of the AircraftStatusMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftStatusMessage()
Public Sub New
public:
AircraftStatusMessage()
new : unit -> AircraftStatusMessage
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage Properties

AircraftStatusMessage Properties

The AircraftStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | AircraftStatusType | Gets or sets a value that indicates what type of status message was received.
Public property | EmergencyStatus | Gets or sets the content of an emergency/priority status message.
Public property | TcasResolutionAdvisory | Gets or sets the content of a TCAS RA broadcast message.
Top
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage.AircraftStatusType Property

AircraftStatusMessageAircraftStatusType Property
Gets or sets a value that indicates what type of status message was received.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftStatusType AircraftStatusType { get; set; }
Public Property AircraftStatusType As AircraftStatusType
    Get
    Set
public:
property AircraftStatusType AircraftStatusType {
    AircraftStatusType get ();
    void set (AircraftStatusType value);
}
member AircraftStatusType : AircraftStatusType with get, set

Property Value

Type: AircraftStatusType
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage.EmergencyStatus Property

AircraftStatusMessageEmergencyStatus Property
Gets or sets the content of an emergency/priority status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmergencyStatus EmergencyStatus { get; set; }
Public Property EmergencyStatus As EmergencyStatus
    Get
    Set
public:
property EmergencyStatus^ EmergencyStatus {
    EmergencyStatus^ get ();
    void set (EmergencyStatus^ value);
}
member EmergencyStatus : EmergencyStatus with get, set

Property Value

Type: EmergencyStatus
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage.TcasResolutionAdvisory Property

AircraftStatusMessageTcasResolutionAdvisory Property
Gets or sets the content of a TCAS RA broadcast message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TcasResolutionAdvisory TcasResolutionAdvisory { get; set; }
Public Property TcasResolutionAdvisory As TcasResolutionAdvisory
    Get
    Set
public:
property TcasResolutionAdvisory^ TcasResolutionAdvisory {
    TcasResolutionAdvisory^ get ();
    void set (TcasResolutionAdvisory^ value);
}
member TcasResolutionAdvisory : TcasResolutionAdvisory with get, set

Property Value

Type: TcasResolutionAdvisory
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage Methods

AircraftStatusMessage Methods

The AircraftStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusMessage.ToString Method

AircraftStatusMessageToString Method
Returns an English description of the object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AircraftStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


AircraftStatusType Enumeration

AircraftStatusType Enumeration
An enumeration of the various aircraft status types in aircraft status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AircraftStatusType
Public Enumeration AircraftStatusType
public enum class AircraftStatusType
type AircraftStatusType
Members
Member name | Value | Description
AircraftStatusType0 | 0 | Reserved.
EmergencyStatus | 1 | Broadcast of the emergency state.
TcasResolutionAdvisoryBroadcast | 2 | A resolution advisory broadcast by TCAS equipment.
AircraftStatusType3 | 3 | Reserved.
AircraftStatusType4 | 4 | Reserved.
AircraftStatusType5 | 5 | Reserved.
AircraftStatusType6 | 6 | Reserved.
AircraftStatusType7 | 7 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition Class

CoarseTisbAirbornePosition Class
Describes the content of a TIS-B coarse airborne position message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbCoarseTisbAirbornePosition

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CoarseTisbAirbornePosition
Public Class CoarseTisbAirbornePosition
public ref class CoarseTisbAirbornePosition
type CoarseTisbAirbornePosition =  class end

The CoarseTisbAirbornePosition type exposes the following members.

Constructors
 | Name | Description
Public method | CoarseTisbAirbornePosition | Initializes a new instance of the CoarseTisbAirbornePosition class
Top
Properties
 | Name | Description
Public property | BarometricAltitude | Gets or sets the altitude in feet relative to a standard pressure of 1013.25mb / 29.92Hg.
Public property | CompactPosition | Gets or sets the location of the aircraft encoded in a CPR.
Public property | GroundSpeed | Gets or sets the ground speed in knots.
Public property | GroundTrack | Gets or sets the ground track, where 0 is north, 90 east, 180 south and 270 west.
Public property | ServiceVolumeID | Gets or sets the identifier of the TIS-B station that generated the message.
Public property | SurveillanceStatus | Gets the state of the Mode-A transponder.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message content. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition Constructor

CoarseTisbAirbornePosition Constructor
Initializes a new instance of the CoarseTisbAirbornePosition class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoarseTisbAirbornePosition()
Public Sub New
public:
CoarseTisbAirbornePosition()
new : unit -> CoarseTisbAirbornePosition
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition Properties

CoarseTisbAirbornePosition Properties

The CoarseTisbAirbornePosition type exposes the following members.

Properties
 | Name | Description
Public property | BarometricAltitude | Gets or sets the altitude in feet relative to a standard pressure of 1013.25mb / 29.92Hg.
Public property | CompactPosition | Gets or sets the location of the aircraft encoded in a CPR.
Public property | GroundSpeed | Gets or sets the ground speed in knots.
Public property | GroundTrack | Gets or sets the ground track, where 0 is north, 90 east, 180 south and 270 west.
Public property | ServiceVolumeID | Gets or sets the identifier of the TIS-B station that generated the message.
Public property | SurveillanceStatus | Gets the state of the Mode-A transponder.
Top
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.BarometricAltitude Property

CoarseTisbAirbornePositionBarometricAltitude Property
Gets or sets the altitude in feet relative to a standard pressure of 1013.25mb / 29.92Hg.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> BarometricAltitude { get; set; }
Public Property BarometricAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> BarometricAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member BarometricAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.CompactPosition Property

CoarseTisbAirbornePositionCompactPosition Property
Gets or sets the location of the aircraft encoded in a CPR.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompactPositionReportingCoordinate CompactPosition { get; set; }
Public Property CompactPosition As CompactPositionReportingCoordinate
    Get
    Set
public:
property CompactPositionReportingCoordinate^ CompactPosition {
    CompactPositionReportingCoordinate^ get ();
    void set (CompactPositionReportingCoordinate^ value);
}
member CompactPosition : CompactPositionReportingCoordinate with get, set

Property Value

Type: CompactPositionReportingCoordinate
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.GroundSpeed Property

CoarseTisbAirbornePositionGroundSpeed Property
Gets or sets the ground speed in knots.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> GroundSpeed { get; set; }
Public Property GroundSpeed As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> GroundSpeed {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member GroundSpeed : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.GroundTrack Property

CoarseTisbAirbornePositionGroundTrack Property
Gets or sets the ground track, where 0 is north, 90 east, 180 south and 270 west.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> GroundTrack { get; set; }
Public Property GroundTrack As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> GroundTrack {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member GroundTrack : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.ServiceVolumeID Property

CoarseTisbAirbornePositionServiceVolumeID Property
Gets or sets the identifier of the TIS-B station that generated the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte ServiceVolumeID { get; set; }
Public Property ServiceVolumeID As Byte
    Get
    Set
public:
property unsigned char ServiceVolumeID {
    unsigned char get ();
    void set (unsigned char value);
}
member ServiceVolumeID : byte with get, set

Property Value

Type: Byte
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.SurveillanceStatus Property

CoarseTisbAirbornePositionSurveillanceStatus Property
Gets the state of the Mode-A transponder.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SurveillanceStatus SurveillanceStatus { get; set; }
Public Property SurveillanceStatus As SurveillanceStatus
    Get
    Set
public:
property SurveillanceStatus SurveillanceStatus {
    SurveillanceStatus get ();
    void set (SurveillanceStatus value);
}
member SurveillanceStatus : SurveillanceStatus with get, set

Property Value

Type: SurveillanceStatus
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition Methods

CoarseTisbAirbornePosition Methods

The CoarseTisbAirbornePosition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message content. (Overrides ObjectToString.)
Top
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CoarseTisbAirbornePosition.ToString Method

CoarseTisbAirbornePositionToString Method
Returns an English description of the message content.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

CoarseTisbAirbornePosition Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate Class

CompactPositionReportingCoordinate Class
Describes a Compact Position Reporting coordinate.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbCompactPositionReportingCoordinate

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompactPositionReportingCoordinate
Public Class CompactPositionReportingCoordinate
public ref class CompactPositionReportingCoordinate
type CompactPositionReportingCoordinate =  class end

The CompactPositionReportingCoordinate type exposes the following members.

Constructors
 | Name | Description
Public method | CompactPositionReportingCoordinate | Creates a new object.
Public method | CompactPositionReportingCoordinate(Int32, Int32, Boolean, Byte) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Public property | NumberOfBits | Gets or sets the number of bits that the coordinate was encoded in - possible values are 12, 14, 17 or 19.
Public property | OddFormat | Gets or sets a value indicating whether the coordinate is in ODD format (true) or EVEN format (false).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the coordinate. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate Constructor

CompactPositionReportingCoordinate Constructor
Overload List
 | Name | Description
Public method | CompactPositionReportingCoordinate | Creates a new object.
Public method | CompactPositionReportingCoordinate(Int32, Int32, Boolean, Byte) | Creates a new object.
Top
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate Constructor

CompactPositionReportingCoordinate Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompactPositionReportingCoordinate()
Public Sub New
public:
CompactPositionReportingCoordinate()
new : unit -> CompactPositionReportingCoordinate
See Also

Reference

CompactPositionReportingCoordinate Class
CompactPositionReportingCoordinate Overload
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate Constructor (Int32, Int32, Boolean, Byte)

CompactPositionReportingCoordinate Constructor (Int32, Int32, Boolean, Byte)
Creates a new object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompactPositionReportingCoordinate(
    int latitude,
    int longitude,
    bool oddFormat,
    byte numberOfBits
)
Public Sub New (
    latitude As Integer,
    longitude As Integer,
    oddFormat As Boolean,
    numberOfBits As Byte
)
public:
CompactPositionReportingCoordinate(
    int latitude,
    int longitude,
    bool oddFormat,
    unsigned char numberOfBits
)
new :
        latitude : int *
        longitude : int *
        oddFormat : bool *
        numberOfBits : byte -> CompactPositionReportingCoordinate

Parameters

latitude
Type: SystemInt32
longitude
Type: SystemInt32
oddFormat
Type: SystemBoolean
numberOfBits
Type: SystemByte
See Also

Reference

CompactPositionReportingCoordinate Class
CompactPositionReportingCoordinate Overload
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate Properties

CompactPositionReportingCoordinate Properties

The CompactPositionReportingCoordinate type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Public property | NumberOfBits | Gets or sets the number of bits that the coordinate was encoded in - possible values are 12, 14, 17 or 19.
Public property | OddFormat | Gets or sets a value indicating whether the coordinate is in ODD format (true) or EVEN format (false).
Top
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate.Latitude Property

CompactPositionReportingCoordinateLatitude Property
Gets or sets the latitude.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Latitude { get; set; }
Public Property Latitude As Integer
    Get
    Set
public:
property int Latitude {
    int get ();
    void set (int value);
}
member Latitude : int with get, set

Property Value

Type: Int32
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate.Longitude Property

CompactPositionReportingCoordinateLongitude Property
Gets or sets the longitude.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Longitude { get; set; }
Public Property Longitude As Integer
    Get
    Set
public:
property int Longitude {
    int get ();
    void set (int value);
}
member Longitude : int with get, set

Property Value

Type: Int32
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate.NumberOfBits Property

CompactPositionReportingCoordinateNumberOfBits Property
Gets or sets the number of bits that the coordinate was encoded in - possible values are 12, 14, 17 or 19.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte NumberOfBits { get; set; }
Public Property NumberOfBits As Byte
    Get
    Set
public:
property unsigned char NumberOfBits {
    unsigned char get ();
    void set (unsigned char value);
}
member NumberOfBits : byte with get, set

Property Value

Type: Byte
Remarks
This is not necessarily the number of bits used to transmit the coordinate. Surface position messages transmit a 17 bit coordinate but encode to 19 bits, for these the property should be set to 19.
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate.OddFormat Property

CompactPositionReportingCoordinateOddFormat Property
Gets or sets a value indicating whether the coordinate is in ODD format (true) or EVEN format (false).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OddFormat { get; set; }
Public Property OddFormat As Boolean
    Get
    Set
public:
property bool OddFormat {
    bool get ();
    void set (bool value);
}
member OddFormat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate Methods

CompactPositionReportingCoordinate Methods

The CompactPositionReportingCoordinate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the coordinate. (Overrides ObjectToString.)
Top
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


CompactPositionReportingCoordinate.ToString Method

CompactPositionReportingCoordinateToString Method
Returns an English description of the coordinate.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

CompactPositionReportingCoordinate Class
VirtualRadar.Interface.Adsb Namespace


EmergencyState Enumeration

EmergencyState Enumeration
An enumeration of the different emergency states transmitted in aircraft status and ADS-B version 1 target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EmergencyState
Public Enumeration EmergencyState
public enum class EmergencyState
type EmergencyState
Members
Member name | Value | Description
None | 0 | No emergency state is being transmitted.
GeneralEmergency | 1 | General emergency (corresponds with squawk 7700).
Lifeguard | 2 | Lifeguard duty or medical emergency.
MinimumFuel | 3 | Minimum fuel emergency.
NoCommunications | 4 | No radio communications (corresponds with squawk 7600).
UnlawfulInterference | 5 | Unlawful interference (corresponds with squawk 7500).
DownedAircraft | 6 | Downed aircraft (transmitted only in ADS-B messages compliant with version 1 and above).
EmergencyState7 | 7 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


EmergencyStatus Class

EmergencyStatus Class
A class that carries information from an aircraft emergency / priority status message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbEmergencyStatus

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EmergencyStatus
Public Class EmergencyStatus
public ref class EmergencyStatus
type EmergencyStatus =  class end

The EmergencyStatus type exposes the following members.

Constructors
 | Name | Description
Public method | EmergencyStatus | Initializes a new instance of the EmergencyStatus class
Top
Properties
 | Name | Description
Public property | EmergencyState | Gets or sets the type of emergency in an emergency / priority status message.
Public property | Squawk | Gets or sets the squawk code transmitted with the emergency message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


EmergencyStatus Constructor

EmergencyStatus Constructor
Initializes a new instance of the EmergencyStatus class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmergencyStatus()
Public Sub New
public:
EmergencyStatus()
new : unit -> EmergencyStatus
See Also

Reference

EmergencyStatus Class
VirtualRadar.Interface.Adsb Namespace


EmergencyStatus Properties

EmergencyStatus Properties

The EmergencyStatus type exposes the following members.

Properties
 | Name | Description
Public property | EmergencyState | Gets or sets the type of emergency in an emergency / priority status message.
Public property | Squawk | Gets or sets the squawk code transmitted with the emergency message.
Top
See Also

Reference

EmergencyStatus Class
VirtualRadar.Interface.Adsb Namespace


EmergencyStatus.EmergencyState Property

EmergencyStatusEmergencyState Property
Gets or sets the type of emergency in an emergency / priority status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmergencyState EmergencyState { get; set; }
Public Property EmergencyState As EmergencyState
    Get
    Set
public:
property EmergencyState EmergencyState {
    EmergencyState get ();
    void set (EmergencyState value);
}
member EmergencyState : EmergencyState with get, set

Property Value

Type: EmergencyState
See Also

Reference

EmergencyStatus Class
VirtualRadar.Interface.Adsb Namespace


EmergencyStatus.Squawk Property

EmergencyStatusSquawk Property
Gets or sets the squawk code transmitted with the emergency message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> Squawk { get; set; }
Public Property Squawk As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> Squawk {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member Squawk : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
Remarks
This is only present on version 2 ADS-B messages, and then only under some circumstances. If the code sees a Mode-A code of 0000 then it sets this property to null.
See Also

Reference

EmergencyStatus Class
VirtualRadar.Interface.Adsb Namespace


EmergencyStatus Methods

EmergencyStatus Methods

The EmergencyStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

EmergencyStatus Class
VirtualRadar.Interface.Adsb Namespace


EmergencyStatus.ToString Method

EmergencyStatusToString Method
Returns an English description of the object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

EmergencyStatus Class
VirtualRadar.Interface.Adsb Namespace


EmitterCategory Enumeration

EmitterCategory Enumeration
An enumeration of the different ADS-B Emitter Categories transmitted across all category sets.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EmitterCategory
Public Enumeration EmitterCategory
public enum class EmitterCategory
type EmitterCategory
Members
Member name | Value | Description
None | 0 | No ADS-B emitter category transmitted.
LightAircraft | 1 | Light aircraft, usually less than 15,500 lbs maximum takeoff weight.
SmallAircraft | 2 | Small aircraft, usually between 15,500 to 75,000 lbs maximum takeoff weight.
LargeAircraft | 3 | Large aircraft, usually between 75,000 to 300,000 lbs maximum takeoff weight.
HighVortexLargeAircraft | 4 | Large aircraft that generate high vorticies.
HeavyAircraft | 5 | Heavy aircraft, usually with a maximum takeoff weight over 300,000 lbs.
HighPerformanceAircraft | 6 | Aircraft with greater than 5G acceleration and capable of travelling over 400 knots.
Rotorcraft | 7 | Helicopter or other rotorcraft.
Glider | 8 | Glider or sailplane.
LighterThanAir | 9 | Hot-air balloon or other lighter-than-air craft.
Parachutist | 10 | Parachutist or sky diver.
Ultralight | 11 | Ultralight, hang-glider or paraglider.
UnmannedAerialVehicle | 12 | UAV.
SpaceVehicle | 13 | Spacecraft or trans-atmospheric vehicle.
SurfaceEmergencyVehicle | 14 | Emergency surface vehicle.
SurfaceServiceVehicle | 15 | Service surface vehicle.
PointObstacle | 16 | Point obstacle including tethered balloons.
ClusterObstacle | 17 | Cluster obstacle.
LineObstacle | 18 | Line obstacle.
BaseReservedCode | 100 | Reserved codes are at least this value - see remarks for instructions on how to derive the category set and category.
Remarks
Many of the possible categories are reserved for future use. These are encoded using the following formula: value = 100 + category + ((category set - 'A') * 10). E.G. category 6 in set C would have a value of 100 + 6 + (2 * 10) = 126. The reason why a single 'Reserved' enum is not used is because the decoder would be stripping out information carried by the message. If there is a vehicle transmitting a reserved code then I'd like to know what it sent.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate Class

GlobalCoordinate Class
A class describing a coordinate on the surface of the Earth.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbGlobalCoordinate

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GlobalCoordinate
Public Class GlobalCoordinate
public ref class GlobalCoordinate
type GlobalCoordinate =  class end

The GlobalCoordinate type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalCoordinate | Creates a new object.
Public method | GlobalCoordinate(Double, Double) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude of the coordinate.
Public property | Longitude | Gets or sets the longitude of the coordinate.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the coordinate. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate Constructor

GlobalCoordinate Constructor
Overload List
 | Name | Description
Public method | GlobalCoordinate | Creates a new object.
Public method | GlobalCoordinate(Double, Double) | Creates a new object.
Top
See Also

Reference

GlobalCoordinate Class
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate Constructor

GlobalCoordinate Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GlobalCoordinate()
Public Sub New
public:
GlobalCoordinate()
new : unit -> GlobalCoordinate
See Also

Reference

GlobalCoordinate Class
GlobalCoordinate Overload
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate Constructor (Double, Double)

GlobalCoordinate Constructor (Double, Double)
Creates a new object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GlobalCoordinate(
    double latitude,
    double longitude
)
Public Sub New (
    latitude As Double,
    longitude As Double
)
public:
GlobalCoordinate(
    double latitude,
    double longitude
)
new :
        latitude : float *
        longitude : float -> GlobalCoordinate

Parameters

latitude
Type: SystemDouble
longitude
Type: SystemDouble
See Also

Reference

GlobalCoordinate Class
GlobalCoordinate Overload
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate Properties

GlobalCoordinate Properties

The GlobalCoordinate type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude of the coordinate.
Public property | Longitude | Gets or sets the longitude of the coordinate.
Top
See Also

Reference

GlobalCoordinate Class
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate.Latitude Property

GlobalCoordinateLatitude Property
Gets or sets the latitude of the coordinate.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Type: Double
See Also

Reference

GlobalCoordinate Class
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate.Longitude Property

GlobalCoordinateLongitude Property
Gets or sets the longitude of the coordinate.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Type: Double
See Also

Reference

GlobalCoordinate Class
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate Methods

GlobalCoordinate Methods

The GlobalCoordinate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the coordinate. (Overrides ObjectToString.)
Top
See Also

Reference

GlobalCoordinate Class
VirtualRadar.Interface.Adsb Namespace


GlobalCoordinate.ToString Method

GlobalCoordinateToString Method
Returns an English description of the coordinate.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

GlobalCoordinate Class
VirtualRadar.Interface.Adsb Namespace


HorizontalDataSource Enumeration

HorizontalDataSource Enumeration
An enumeration of the different sources of horizontal data for ADS-B version 1 target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HorizontalDataSource
Public Enumeration HorizontalDataSource
public enum class HorizontalDataSource
type HorizontalDataSource
Members
Member name | Value | Description
None | 0 | No valid horizontal target state data is available.
AutopilotControlPanel | 1 | Source is the autopilot control panel selected value, such as from an MCP or FCU.
MaintainingHeading | 2 | Maintaining the current heading or track.
Fms | 3 | Source is from an FMS/RNAV system and the heading is the track angle specified by the leg type.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


HorizontalModeIndicator Enumeration

HorizontalModeIndicator Enumeration
An enumeration of the different values of HMI that can be transmitted in ADS-B version 1 target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HorizontalModeIndicator
Public Enumeration HorizontalModeIndicator
public enum class HorizontalModeIndicator
type HorizontalModeIndicator
Members
Member name | Value | Description
Unknown | 0 | The information is not available.
Acquiring | 1 | The aircraft is turning towards the target heading or track.
Maintaining | 2 | The aircraft is maintaining the target heading or track.
Reserved | 3 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


IAdsbTranslator Interface

IAdsbTranslator Interface
The interface that objects that can translate ME message blocks into ADS-B messages must implement.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAdsbTranslator
Public Interface IAdsbTranslator
public interface class IAdsbTranslator
type IAdsbTranslator =  interface end

The IAdsbTranslator type exposes the following members.

Properties
 | Name | Description
Public property | Statistics | Gets or sets the statistics to update when translating messages.
Top
Methods
 | Name | Description
Public method | Translate | Translates the payload of the ExtendedSquitterMessage property into an ADS-B message.
Top
Remarks
It is expected that implementations of this class will use the ICompactPositionReporting interface to translate CPR coordinates into global coordinates.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


IAdsbTranslator Properties

IAdsbTranslator Properties

The IAdsbTranslator type exposes the following members.

Properties
 | Name | Description
Public property | Statistics | Gets or sets the statistics to update when translating messages.
Top
See Also

Reference

IAdsbTranslator Interface
VirtualRadar.Interface.Adsb Namespace


IAdsbTranslator.Statistics Property

IAdsbTranslatorStatistics Property
Gets or sets the statistics to update when translating messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStatistics Statistics { get; set; }
Property Statistics As IStatistics
    Get
    Set
property IStatistics^ Statistics {
    IStatistics^ get ();
    void set (IStatistics^ value);
}
abstract Statistics : IStatistics with get, set

Property Value

Type: IStatistics
See Also

Reference

IAdsbTranslator Interface
VirtualRadar.Interface.Adsb Namespace


IAdsbTranslator Methods

IAdsbTranslator Methods

The IAdsbTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Translate | Translates the payload of the ExtendedSquitterMessage property into an ADS-B message.
Top
See Also

Reference

IAdsbTranslator Interface
VirtualRadar.Interface.Adsb Namespace


IAdsbTranslator.Translate Method

IAdsbTranslatorTranslate Method
Translates the payload of the ExtendedSquitterMessage property into an ADS-B message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AdsbMessage Translate(
    ModeSMessage modeSMessage
)
Function Translate (
    modeSMessage As ModeSMessage
) As AdsbMessage
AdsbMessage^ Translate(
    ModeSMessage^ modeSMessage
)
abstract Translate :
        modeSMessage : ModeSMessage -> AdsbMessage

Parameters

modeSMessage
Type: VirtualRadar.Interface.ModeSModeSMessage

Return Value

Type: AdsbMessage
Remarks
This method will return null if the Mode-S message does not contain an ADS-B message or if the ADS-B message could not be translated from the Mode-S message. Callers should test for a return of null even if they pass in what appears to be a Mode-S message carrying a valid extended squitter message block.
See Also

Reference

IAdsbTranslator Interface
VirtualRadar.Interface.Adsb Namespace


ICompactPositionReporting Interface

ICompactPositionReporting Interface
The interface for classes that can encode and decode Compact Position Reporting coordinates.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICompactPositionReporting
Public Interface ICompactPositionReporting
public interface class ICompactPositionReporting
type ICompactPositionReporting =  interface end

The ICompactPositionReporting type exposes the following members.

Methods
 | Name | Description
Public method | Encode | Encodes a latitude and longitude to CPR coordinates.
Public method | GlobalDecode | Decodes an early and later CPR coordinate into an unambiguous location on the surface of the globe. May return null if the location cannot be decoded.
Public method | LocalDecode | Decodes a CPR latitude and longitude to an unambiguous latitude and longitude with reference to a known latitude and longitude.
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


ICompactPositionReporting Methods

ICompactPositionReporting Methods

The ICompactPositionReporting type exposes the following members.

Methods
 | Name | Description
Public method | Encode | Encodes a latitude and longitude to CPR coordinates.
Public method | GlobalDecode | Decodes an early and later CPR coordinate into an unambiguous location on the surface of the globe. May return null if the location cannot be decoded.
Public method | LocalDecode | Decodes a CPR latitude and longitude to an unambiguous latitude and longitude with reference to a known latitude and longitude.
Top
See Also

Reference

ICompactPositionReporting Interface
VirtualRadar.Interface.Adsb Namespace


ICompactPositionReporting.Encode Method

ICompactPositionReportingEncode Method
Encodes a latitude and longitude to CPR coordinates.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CompactPositionReportingCoordinate Encode(
    GlobalCoordinate globalCoordinate,
    bool oddFormat,
    byte numberOfBits
)
Function Encode (
    globalCoordinate As GlobalCoordinate,
    oddFormat As Boolean,
    numberOfBits As Byte
) As CompactPositionReportingCoordinate
CompactPositionReportingCoordinate^ Encode(
    GlobalCoordinate^ globalCoordinate,
    bool oddFormat,
    unsigned char numberOfBits
)
abstract Encode :
        globalCoordinate : GlobalCoordinate *
        oddFormat : bool *
        numberOfBits : byte -> CompactPositionReportingCoordinate

Parameters

globalCoordinate
Type: VirtualRadar.Interface.AdsbGlobalCoordinate
The latitude and longitude to encode.
oddFormat
Type: SystemBoolean
True if ODD formatting is required, false if EVEN formatting is required.
numberOfBits
Type: SystemByte
The number of bits to encode to - this can be one of 12, 14, 17 or 19.

Return Value

Type: CompactPositionReportingCoordinate
Remarks
Note that the standard only allows for even encoding when the number of bits is 14. Implementations do not have to police this. VRS does not use this method, implementations only need to supply a full version of this method if they want to pass the unit tests.
See Also

Reference

ICompactPositionReporting Interface
VirtualRadar.Interface.Adsb Namespace


ICompactPositionReporting.GlobalDecode Method

ICompactPositionReportingGlobalDecode Method
Decodes an early and later CPR coordinate into an unambiguous location on the surface of the globe. May return null if the location cannot be decoded.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
GlobalCoordinate GlobalDecode(
    CompactPositionReportingCoordinate earlyCpr,
    CompactPositionReportingCoordinate laterCpr,
    GlobalCoordinate receiverLocation
)
Function GlobalDecode (
    earlyCpr As CompactPositionReportingCoordinate,
    laterCpr As CompactPositionReportingCoordinate,
    receiverLocation As GlobalCoordinate
) As GlobalCoordinate
GlobalCoordinate^ GlobalDecode(
    CompactPositionReportingCoordinate^ earlyCpr,
    CompactPositionReportingCoordinate^ laterCpr,
    GlobalCoordinate^ receiverLocation
)
abstract GlobalDecode :
        earlyCpr : CompactPositionReportingCoordinate *
        laterCpr : CompactPositionReportingCoordinate *
        receiverLocation : GlobalCoordinate -> GlobalCoordinate

Parameters

earlyCpr
Type: VirtualRadar.Interface.AdsbCompactPositionReportingCoordinate
The earlier of the two transmissions.
laterCpr
Type: VirtualRadar.Interface.AdsbCompactPositionReportingCoordinate
The later of the two transmissions. The OddFormat parameter must not be the same as the ealier coordinate's and the number of bits must be identical.
receiverLocation
Type: VirtualRadar.Interface.AdsbGlobalCoordinate
The location of the receiver on the globe. If this is null then 19-bit CPR coordinates will not be decoded, but 17-bit and below still will.

Return Value

Type: GlobalCoordinate
An object describing the location on the surface of the globe or null if the location could not be decoded.
Remarks

Surface position coordinates (19-bit format) always decode to two possible latitudes and four possible longitudes. It is impossible to unambiguously determine which of those eight locations is the correct one, so the one closest to 'receiverLocation' is always chosen. If the receiver location is unknown then null is returned for 19-bit formats. The receiver location is ignored for all other formats.

The spec suggests that two messages are only globally decoded if they arrive within a certain time frame (10 seconds for airborne position messages, 25 to 50 seconds for surface position messages). This method does not police those time frames, it's up to the caller to determine whether two messages are suitable for global decoding. This is important to note. The algorithm does NOT give the right result if the distance between the two locations at which the messages were transmitted is larger than 3 nautical miles (about 5.5km) for 17 bit messages or 0.25 nmi (about 1.38km) for 19 bit messages. I learnt this the hard way when I stared at the code until my eyes bled when a unit test that was decoding 19-bit messages 5km apart was failing. In the test the j value was consistently out by 1. I would recommend following the rules for testing the reasonableness of a globally decoded location as laid out in the ICAO documentation.

See Also

Reference

ICompactPositionReporting Interface
VirtualRadar.Interface.Adsb Namespace


ICompactPositionReporting.LocalDecode Method

ICompactPositionReportingLocalDecode Method
Decodes a CPR latitude and longitude to an unambiguous latitude and longitude with reference to a known latitude and longitude.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
GlobalCoordinate LocalDecode(
    CompactPositionReportingCoordinate cprCoordinate,
    GlobalCoordinate referenceCoordinate
)
Function LocalDecode (
    cprCoordinate As CompactPositionReportingCoordinate,
    referenceCoordinate As GlobalCoordinate
) As GlobalCoordinate
GlobalCoordinate^ LocalDecode(
    CompactPositionReportingCoordinate^ cprCoordinate,
    GlobalCoordinate^ referenceCoordinate
)
abstract LocalDecode :
        cprCoordinate : CompactPositionReportingCoordinate *
        referenceCoordinate : GlobalCoordinate -> GlobalCoordinate

Parameters

cprCoordinate
Type: VirtualRadar.Interface.AdsbCompactPositionReportingCoordinate
The CPR coordinate to decode.
referenceCoordinate
Type: VirtualRadar.Interface.AdsbGlobalCoordinate
The global coordinate that is within 180NM (for messages up to 17 bits) or 45NM (for messages of 19 bits) of the vehicle's location.

Return Value

Type: GlobalCoordinate
See Also

Reference

ICompactPositionReporting Interface
VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage Class

IdentifierAndCategoryMessage Class
Gets or sets the content of an identifier and category message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbIdentifierAndCategoryMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IdentifierAndCategoryMessage
Public Class IdentifierAndCategoryMessage
public ref class IdentifierAndCategoryMessage
type IdentifierAndCategoryMessage =  class end

The IdentifierAndCategoryMessage type exposes the following members.

Constructors
 | Name | Description
Public method | IdentifierAndCategoryMessage | Initializes a new instance of the IdentifierAndCategoryMessage class
Top
Properties
 | Name | Description
Public property | EmitterCategory | Gets or sets the emitter category from the message. Note that reserved values do not have an enum value, they are a plain byte.
Public property | Identification | Gets or sets the identification code transmitted by the vehicle.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage Constructor

IdentifierAndCategoryMessage Constructor
Initializes a new instance of the IdentifierAndCategoryMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IdentifierAndCategoryMessage()
Public Sub New
public:
IdentifierAndCategoryMessage()
new : unit -> IdentifierAndCategoryMessage
See Also

Reference

IdentifierAndCategoryMessage Class
VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage Properties

IdentifierAndCategoryMessage Properties

The IdentifierAndCategoryMessage type exposes the following members.

Properties
 | Name | Description
Public property | EmitterCategory | Gets or sets the emitter category from the message. Note that reserved values do not have an enum value, they are a plain byte.
Public property | Identification | Gets or sets the identification code transmitted by the vehicle.
Top
See Also

Reference

IdentifierAndCategoryMessage Class
VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage.EmitterCategory Property

IdentifierAndCategoryMessageEmitterCategory Property
Gets or sets the emitter category from the message. Note that reserved values do not have an enum value, they are a plain byte.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmitterCategory EmitterCategory { get; set; }
Public Property EmitterCategory As EmitterCategory
    Get
    Set
public:
property EmitterCategory EmitterCategory {
    EmitterCategory get ();
    void set (EmitterCategory value);
}
member EmitterCategory : EmitterCategory with get, set

Property Value

Type: EmitterCategory
See Also

Reference

IdentifierAndCategoryMessage Class
VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage.Identification Property

IdentifierAndCategoryMessageIdentification Property
Gets or sets the identification code transmitted by the vehicle.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Identification { get; set; }
Public Property Identification As String
    Get
    Set
public:
property String^ Identification {
    String^ get ();
    void set (String^ value);
}
member Identification : string with get, set

Property Value

Type: String
Remarks
This is the aircraft identification as filed on the flight plan, or the registration of the aircraft if it is either not flying against a flight plan or the aircraft identification is not known, or a surface vehicle's radio call sign.
See Also

Reference

IdentifierAndCategoryMessage Class
VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage Methods

IdentifierAndCategoryMessage Methods

The IdentifierAndCategoryMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

IdentifierAndCategoryMessage Class
VirtualRadar.Interface.Adsb Namespace


IdentifierAndCategoryMessage.ToString Method

IdentifierAndCategoryMessageToString Method
Returns an English description of the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

IdentifierAndCategoryMessage Class
VirtualRadar.Interface.Adsb Namespace


MessageFormat Enumeration

MessageFormat Enumeration
An enumeration of the different ADS-B message formats.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MessageFormat
Public Enumeration MessageFormat
public enum class MessageFormat
type MessageFormat
Members
Member name | Value | Description
None | 0 | Unknown / unrecognised message format.
NoPositionInformation | 1 | Type 0 - airborne or surface vehicle with no position message.
IdentificationAndCategory | 2 | Types 1-4 - vehicle identification and category messages.
SurfacePosition | 3 | Types 5-8 - surface position message.
AirbornePosition | 4 | Types 9-18 and 20-22 - airborne position message.
AirborneVelocity | 5 | Type 19 - airborne velocity message, ground speed or airspeed.
AircraftStatus | 6 | Type 28 - aircraft status message.
TargetStateAndStatus | 7 | Type 29 - target state and status message (ADS-B versions 1 and 2).
AircraftOperationalStatus | 8 | Type 31 - aircraft operational status message.
CoarseTisbAirbornePosition | 9 | DF18 CA3 - coarse TIS-B airborne position message.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


MultipleThreatResolutionAdvisory Enumeration

MultipleThreatResolutionAdvisory Enumeration
An enumeration of flags that indicate the meaning of a TCAS resolution advisory when there are multiple threats and the resolution advisory provides separation below some threats and above other threats.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MultipleThreatResolutionAdvisory
<FlagsAttribute>
Public Enumeration MultipleThreatResolutionAdvisory
[FlagsAttribute]
public enum class MultipleThreatResolutionAdvisory
[<FlagsAttribute>]
type MultipleThreatResolutionAdvisory
Members
Member name | Value | Description
Reserved1 | 1 | Reserved.
Reserved2 | 2 | Reserved.
Reserved3 | 4 | Reserved.
Reserved4 | 8 | Reserved.
Reserved5 | 16 | Reserved.
Reserved6 | 32 | Reserved.
Reserved7 | 64 | Reserved.
IsSenseReversal | 128 | RA is a sense reversal when set, is not a sense reversal when clear.
RequiresCrossing | 256 | RA requires a crossing when set, does not require a crossing when clear.
RequiresPositiveDescend | 512 | RA requires a positive descend when set, does not require a positive descend when clear.
RequiresCorrectionInDownwardSense | 1024 | RA requires a correction in the downward sense when set, does not require a correction in the downward sense when clear.
RequiresPositiveClimb | 2048 | RA requires a positive climb when set, does not require a positive climb when clear.
RequiresCorrectionInUpwardSense | 4096 | RA requires a correction in the upward sense when set, does not require a correction in the upward sense when clear.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


OperationalMode Enumeration

OperationalMode Enumeration
An enumeration of the operational modes transmitted in version 1 and version 2 ADS-B aircraft operational status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OperationalMode
Public Enumeration OperationalMode
public enum class OperationalMode
type OperationalMode
Members
Member name | Value | Description
HasSingleAntenna | 1024 | The system is operating via a single functioning antenna (version 2 only).
ReceivingAtcServices | 2048 | The aircraft is receiving air traffic control services.
IdentSwitchActive | 4096 | The IDENT switch is active.
TcasResolutionAdvisoryActive | 8192 | A TCAS RA is active.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


ResolutionAdvisoryComplement Enumeration

ResolutionAdvisoryComplement Enumeration
An enumeration of flags recording resolution advisory complements that have been received from other aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ResolutionAdvisoryComplement
<FlagsAttribute>
Public Enumeration ResolutionAdvisoryComplement
[FlagsAttribute]
public enum class ResolutionAdvisoryComplement
[<FlagsAttribute>]
type ResolutionAdvisoryComplement
Members
Member name | Value | Description
DoNotTurnRight | 1 | Do not turn right.
DoNotTurnLeft | 2 | Do not turn left.
DoNotPassAbove | 4 | Do not pass above.
DoNotPassBelow | 8 | Do not pass below.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


SingleThreatResolutionAdvisory Enumeration

SingleThreatResolutionAdvisory Enumeration
An enumeration of flags that indicate the meaning of a TCAS resolution advisory when there is a single threat or the resolution advisory is intended to provide separation in the same direction for all threats.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SingleThreatResolutionAdvisory
<FlagsAttribute>
Public Enumeration SingleThreatResolutionAdvisory
[FlagsAttribute]
public enum class SingleThreatResolutionAdvisory
[<FlagsAttribute>]
type SingleThreatResolutionAdvisory
Members
Member name | Value | Description
Reserved1 | 1 | Reserved.
Reserved2 | 2 | Reserved.
Reserved3 | 4 | Reserved.
Reserved4 | 8 | Reserved.
Reserved5 | 16 | Reserved.
Reserved6 | 32 | Reserved.
Reserved7 | 64 | Reserved.
IsPositive | 128 | RA is positive when set, is vertical speed limit when clear.
IsAltitudeCrossing | 256 | RA is altitude crossing when set, is not altitude crossing when clear.
IsSenseReversal | 512 | RA is a sense reversal when set, is not a sense reversal when clear.
IsIncreasedRate | 1024 | RA is increased rate when set, is not increased rate when clear.
DownwardSense | 2048 | Downward sense RA has been generated when set, upward sense RA has been generated when clear.
IsCorrective | 4096 | RA is corrective when set, is preventive when clear.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


SurfaceCapability Enumeration

SurfaceCapability Enumeration
An enumeration of the surface capability codes transmitted in version 1 and 2 ADS-B aircraft operational status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SurfaceCapability
<FlagsAttribute>
Public Enumeration SurfaceCapability
[FlagsAttribute]
public enum class SurfaceCapability
[<FlagsAttribute>]
type SurfaceCapability
Members
Member name | Value | Description
NicSupplementC | 1 | The NIC Supplement C bit (version 2 only).
NacVelocity0 | 2 | The LSB of the Navigational Accuracy Category for Velocity value (version 2 only).
NacVelocity1 | 4 | The middle bit of the Navigational Accuracy Category for Velocity value (version 2 only).
NacVelocity2 | 8 | The MSB of the Navigational Accuracy Category for Velocity value (version 2 only).
HasUniversalAccessTransceiver | 16 | The aircraft has UAT receive capability (version 2 only).
ClassB2TransmitterIsLowPower | 32 | The surface vehicle transmit power is below 70 watts.
HasCockpitDisplayTrafficInformation | 256 | The aircraft has CDTI.
PositionOffsetApplied | 512 | The position transmitted in surface messages is that of the reference point of the aircraft rather than the antenna.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage Class

SurfacePositionMessage Class
A class describing the content of a surface position message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbSurfacePositionMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SurfacePositionMessage
Public Class SurfacePositionMessage
public ref class SurfacePositionMessage
type SurfacePositionMessage =  class end

The SurfacePositionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SurfacePositionMessage | Initializes a new instance of the SurfacePositionMessage class
Top
Properties
 | Name | Description
Public property | CompactPosition | Gets or sets the compact position report coordinate from the message.
Public property | GroundSpeed | Gets or sets the ground speed of the vehicle in knots.
Public property | GroundSpeedExceeded | Gets or sets a value that indicates the vehicle's ground speed is higher than ADS-B can convey.
Public property | GroundTrack | Gets or sets the ground track of the vehicle, where 0 is north, 90 east, 180 south and 270 west.
Public property | IsReversing | Gets or sets a value indicating that the vehicle is reversing.
Public property | PositionTimeIsExact | Gets or sets a value indicating that the time at which the horizontal position was recorded is an exact 0.2 second UTC epoch or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage Constructor

SurfacePositionMessage Constructor
Initializes a new instance of the SurfacePositionMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SurfacePositionMessage()
Public Sub New
public:
SurfacePositionMessage()
new : unit -> SurfacePositionMessage
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage Properties

SurfacePositionMessage Properties

The SurfacePositionMessage type exposes the following members.

Properties
 | Name | Description
Public property | CompactPosition | Gets or sets the compact position report coordinate from the message.
Public property | GroundSpeed | Gets or sets the ground speed of the vehicle in knots.
Public property | GroundSpeedExceeded | Gets or sets a value that indicates the vehicle's ground speed is higher than ADS-B can convey.
Public property | GroundTrack | Gets or sets the ground track of the vehicle, where 0 is north, 90 east, 180 south and 270 west.
Public property | IsReversing | Gets or sets a value indicating that the vehicle is reversing.
Public property | PositionTimeIsExact | Gets or sets a value indicating that the time at which the horizontal position was recorded is an exact 0.2 second UTC epoch or not.
Top
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.CompactPosition Property

SurfacePositionMessageCompactPosition Property
Gets or sets the compact position report coordinate from the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompactPositionReportingCoordinate CompactPosition { get; set; }
Public Property CompactPosition As CompactPositionReportingCoordinate
    Get
    Set
public:
property CompactPositionReportingCoordinate^ CompactPosition {
    CompactPositionReportingCoordinate^ get ();
    void set (CompactPositionReportingCoordinate^ value);
}
member CompactPosition : CompactPositionReportingCoordinate with get, set

Property Value

Type: CompactPositionReportingCoordinate
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.GroundSpeed Property

SurfacePositionMessageGroundSpeed Property
Gets or sets the ground speed of the vehicle in knots.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> GroundSpeed { get; set; }
Public Property GroundSpeed As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> GroundSpeed {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member GroundSpeed : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.GroundSpeedExceeded Property

SurfacePositionMessageGroundSpeedExceeded Property
Gets or sets a value that indicates the vehicle's ground speed is higher than ADS-B can convey.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GroundSpeedExceeded { get; set; }
Public Property GroundSpeedExceeded As Boolean
    Get
    Set
public:
property bool GroundSpeedExceeded {
    bool get ();
    void set (bool value);
}
member GroundSpeedExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
When this is true the actual speed of the vehicle is higher than the value in GroundSpeed.
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.GroundTrack Property

SurfacePositionMessageGroundTrack Property
Gets or sets the ground track of the vehicle, where 0 is north, 90 east, 180 south and 270 west.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> GroundTrack { get; set; }
Public Property GroundTrack As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> GroundTrack {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member GroundTrack : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.IsReversing Property

SurfacePositionMessageIsReversing Property
Gets or sets a value indicating that the vehicle is reversing.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReversing { get; set; }
Public Property IsReversing As Boolean
    Get
    Set
public:
property bool IsReversing {
    bool get ();
    void set (bool value);
}
member IsReversing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.PositionTimeIsExact Property

SurfacePositionMessagePositionTimeIsExact Property
Gets or sets a value indicating that the time at which the horizontal position was recorded is an exact 0.2 second UTC epoch or not.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PositionTimeIsExact { get; set; }
Public Property PositionTimeIsExact As Boolean
    Get
    Set
public:
property bool PositionTimeIsExact {
    bool get ();
    void set (bool value);
}
member PositionTimeIsExact : bool with get, set

Property Value

Type: Boolean
Remarks
This value is not present on Fine Format TIS-B messages, its position is taken by the ICAO/Mode-A Flag field. On those messages this value will always be false.
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage Methods

SurfacePositionMessage Methods

The SurfacePositionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the message. (Overrides ObjectToString.)
Top
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurfacePositionMessage.ToString Method

SurfacePositionMessageToString Method
Returns an English description of the message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

SurfacePositionMessage Class
VirtualRadar.Interface.Adsb Namespace


SurveillanceStatus Enumeration

SurveillanceStatus Enumeration
An enumeration of the different possible surveillance status values in an ADS-B message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SurveillanceStatus
Public Enumeration SurveillanceStatus
public enum class SurveillanceStatus
type SurveillanceStatus
Members
Member name | Value | Description
NoInformation | 0 | No condition information or no Mode-A transponder attached.
PermanentAlert | 1 | The Mode-A transponder setting corresponds with an emergency code.
TemporaryAlert | 2 | The Mode-A transponder setting has been changed to an identity code that is not an emergency code.
SpecialPositionIdentification | 3 | The Mode-A transponder is transmitting SPI along with the identity code.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


SystemDesignAssurance Enumeration

SystemDesignAssurance Enumeration
An enumeration of the different System Design Assurance values extracted from operational message fields of version 2 ADS-B messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemDesignAssurance
Public Enumeration SystemDesignAssurance
public enum class SystemDesignAssurance
type SystemDesignAssurance
Members
Member name | Value | Description
None | 0 | The probability of an undetected fault causing the transmission of false or misleading position information is > 1x10^3 per flight hour.
AssuranceLevelD | 1 | The probability of an undetected fault causing the transmission of false or misleading position information is <= 1x10^-3 per flight hour.
AssuranceLevelC | 2 | The probability of an undetected fault causing the transmission of false or misleading position information is <= 1x10^-5 per flight hour.
AssuranceLevelB | 3 | The probability of an undetected fault causing the transmission of false or misleading position information is <= 1x10^-7 per flight hour.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TargetAltitudeCapability Enumeration

TargetAltitudeCapability Enumeration
An enumeration of the different target altitude capability values for ADS-B version 1 target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TargetAltitudeCapability
Public Enumeration TargetAltitudeCapability
public enum class TargetAltitudeCapability
type TargetAltitudeCapability
Members
Member name | Value | Description
HoldingAltitude | 0 | Can only report the holding altitude.
HoldingOrAutopilotAltitude | 1 | Can only report the holding altitude or the autopilot selected altitude.
HolidingOrAutopilotOrFmsAltitude | 2 | Can report the holding altitude, autopilot selected altitude or the FMS/RNAV level-off altitude.
Reserved | 3 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage Class

TargetStateAndStatusMessage Class
A class that holds the content of the Target State and Status messages.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbTargetStateAndStatusMessage

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TargetStateAndStatusMessage
Public Class TargetStateAndStatusMessage
public ref class TargetStateAndStatusMessage
type TargetStateAndStatusMessage =  class end

The TargetStateAndStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateAndStatusMessage | Initializes a new instance of the TargetStateAndStatusMessage class
Top
Properties
 | Name | Description
Public property | TargetStateAndStatusType | Gets or sets the type of target state and status message received.
Public property | Version1 | Gets or sets the content of an ADS-B version 1 target state and status message.
Public property | Version2 | Gets or sets the content of an ADS-B version 2 target state and status message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
Remarks
Version 0 of ADS-B does not transmit these messages. The message was added in version 1 and substantially changed for version 2, hence the reason why there are two flavours of class describing the content here.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage Constructor

TargetStateAndStatusMessage Constructor
Initializes a new instance of the TargetStateAndStatusMessage class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusMessage()
Public Sub New
public:
TargetStateAndStatusMessage()
new : unit -> TargetStateAndStatusMessage
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage Properties

TargetStateAndStatusMessage Properties

The TargetStateAndStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | TargetStateAndStatusType | Gets or sets the type of target state and status message received.
Public property | Version1 | Gets or sets the content of an ADS-B version 1 target state and status message.
Public property | Version2 | Gets or sets the content of an ADS-B version 2 target state and status message.
Top
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage.TargetStateAndStatusType Property

TargetStateAndStatusMessageTargetStateAndStatusType Property
Gets or sets the type of target state and status message received.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusType TargetStateAndStatusType { get; set; }
Public Property TargetStateAndStatusType As TargetStateAndStatusType
    Get
    Set
public:
property TargetStateAndStatusType TargetStateAndStatusType {
    TargetStateAndStatusType get ();
    void set (TargetStateAndStatusType value);
}
member TargetStateAndStatusType : TargetStateAndStatusType with get, set

Property Value

Type: TargetStateAndStatusType
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage.Version1 Property

TargetStateAndStatusMessageVersion1 Property
Gets or sets the content of an ADS-B version 1 target state and status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusVersion1 Version1 { get; set; }
Public Property Version1 As TargetStateAndStatusVersion1
    Get
    Set
public:
property TargetStateAndStatusVersion1^ Version1 {
    TargetStateAndStatusVersion1^ get ();
    void set (TargetStateAndStatusVersion1^ value);
}
member Version1 : TargetStateAndStatusVersion1 with get, set

Property Value

Type: TargetStateAndStatusVersion1
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage.Version2 Property

TargetStateAndStatusMessageVersion2 Property
Gets or sets the content of an ADS-B version 2 target state and status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusVersion2 Version2 { get; set; }
Public Property Version2 As TargetStateAndStatusVersion2
    Get
    Set
public:
property TargetStateAndStatusVersion2^ Version2 {
    TargetStateAndStatusVersion2^ get ();
    void set (TargetStateAndStatusVersion2^ value);
}
member Version2 : TargetStateAndStatusVersion2 with get, set

Property Value

Type: TargetStateAndStatusVersion2
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage Methods

TargetStateAndStatusMessage Methods

The TargetStateAndStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusMessage.ToString Method

TargetStateAndStatusMessageToString Method
Returns an English description of the object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

TargetStateAndStatusMessage Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusType Enumeration

TargetStateAndStatusType Enumeration
An enumeration of the different types of target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TargetStateAndStatusType
Public Enumeration TargetStateAndStatusType
public enum class TargetStateAndStatusType
type TargetStateAndStatusType
Members
Member name | Value | Description
Version1 | 0 | The message is an ADS-B version 1 message.
Version2 | 1 | The message is an ADS-B version 2 message.
TargetStateAndStatusType2 | 2 | Reserved.
TargetStateAndStatusType3 | 3 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1 Class

TargetStateAndStatusVersion1 Class
Describes the content of an ADS-B version 1 Target State and Status message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbTargetStateAndStatusVersion1

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TargetStateAndStatusVersion1
Public Class TargetStateAndStatusVersion1
public ref class TargetStateAndStatusVersion1
type TargetStateAndStatusVersion1 =  class end

The TargetStateAndStatusVersion1 type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateAndStatusVersion1 | Initializes a new instance of the TargetStateAndStatusVersion1 class
Top
Properties
 | Name | Description
Public property | AltitudesAreMeanSeaLevel | Gets or sets a value indicating that altitudes are barometric corrected altitudes (mean sea level) or a reference barometric altitude (flight level).
Public property | EmergencyState | Gets or sets the current emergency state for the aircraft.
Public property | HorizontalDataSource | Gets or sets the source of the horizontal state data.
Public property | HorizontalModeIndicator | Gets or sets a value indicating whether the target heading has been reached or whether the aircraft is moving towards it.
Public property | NacP | Gets or sets the navigational accuracy category for position.
Public property | NicBaro | Gets or sets a value indicating the integrity category for barometric altitudes.
Public property | Sil | Gets or sets the surveillance integrity level.
Public property | TargetAltitude | Gets or sets the target altitude in feet.
Public property | TargetAltitudeCapability | Gets or sets a value indicating which target altitudes can be sent by the transponder.
Public property | TargetHeading | Gets or sets the target heading or track angle.
Public property | TargetHeadingIsTrack | Gets or sets a value indicating whether TargetHeading is the track (true) or heading (false) angle.
Public property | TcasCapabilityMode | Gets or sets the current state of the TCAS/ACAS system.
Public property | VerticalDataSource | Gets or sets the source of the vertical state data.
Public property | VerticalModeIndicator | Gets or sets a value indicating whether the target altitude has been reached or whether the aircraft is moving towards it.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1 Constructor

TargetStateAndStatusVersion1 Constructor
Initializes a new instance of the TargetStateAndStatusVersion1 class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusVersion1()
Public Sub New
public:
TargetStateAndStatusVersion1()
new : unit -> TargetStateAndStatusVersion1
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1 Properties

TargetStateAndStatusVersion1 Properties

The TargetStateAndStatusVersion1 type exposes the following members.

Properties
 | Name | Description
Public property | AltitudesAreMeanSeaLevel | Gets or sets a value indicating that altitudes are barometric corrected altitudes (mean sea level) or a reference barometric altitude (flight level).
Public property | EmergencyState | Gets or sets the current emergency state for the aircraft.
Public property | HorizontalDataSource | Gets or sets the source of the horizontal state data.
Public property | HorizontalModeIndicator | Gets or sets a value indicating whether the target heading has been reached or whether the aircraft is moving towards it.
Public property | NacP | Gets or sets the navigational accuracy category for position.
Public property | NicBaro | Gets or sets a value indicating the integrity category for barometric altitudes.
Public property | Sil | Gets or sets the surveillance integrity level.
Public property | TargetAltitude | Gets or sets the target altitude in feet.
Public property | TargetAltitudeCapability | Gets or sets a value indicating which target altitudes can be sent by the transponder.
Public property | TargetHeading | Gets or sets the target heading or track angle.
Public property | TargetHeadingIsTrack | Gets or sets a value indicating whether TargetHeading is the track (true) or heading (false) angle.
Public property | TcasCapabilityMode | Gets or sets the current state of the TCAS/ACAS system.
Public property | VerticalDataSource | Gets or sets the source of the vertical state data.
Public property | VerticalModeIndicator | Gets or sets a value indicating whether the target altitude has been reached or whether the aircraft is moving towards it.
Top
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.AltitudesAreMeanSeaLevel Property

TargetStateAndStatusVersion1AltitudesAreMeanSeaLevel Property
Gets or sets a value indicating that altitudes are barometric corrected altitudes (mean sea level) or a reference barometric altitude (flight level).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AltitudesAreMeanSeaLevel { get; set; }
Public Property AltitudesAreMeanSeaLevel As Boolean
    Get
    Set
public:
property bool AltitudesAreMeanSeaLevel {
    bool get ();
    void set (bool value);
}
member AltitudesAreMeanSeaLevel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.EmergencyState Property

TargetStateAndStatusVersion1EmergencyState Property
Gets or sets the current emergency state for the aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmergencyState EmergencyState { get; set; }
Public Property EmergencyState As EmergencyState
    Get
    Set
public:
property EmergencyState EmergencyState {
    EmergencyState get ();
    void set (EmergencyState value);
}
member EmergencyState : EmergencyState with get, set

Property Value

Type: EmergencyState
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.HorizontalDataSource Property

TargetStateAndStatusVersion1HorizontalDataSource Property
Gets or sets the source of the horizontal state data.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalDataSource HorizontalDataSource { get; set; }
Public Property HorizontalDataSource As HorizontalDataSource
    Get
    Set
public:
property HorizontalDataSource HorizontalDataSource {
    HorizontalDataSource get ();
    void set (HorizontalDataSource value);
}
member HorizontalDataSource : HorizontalDataSource with get, set

Property Value

Type: HorizontalDataSource
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.HorizontalModeIndicator Property

TargetStateAndStatusVersion1HorizontalModeIndicator Property
Gets or sets a value indicating whether the target heading has been reached or whether the aircraft is moving towards it.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalModeIndicator HorizontalModeIndicator { get; set; }
Public Property HorizontalModeIndicator As HorizontalModeIndicator
    Get
    Set
public:
property HorizontalModeIndicator HorizontalModeIndicator {
    HorizontalModeIndicator get ();
    void set (HorizontalModeIndicator value);
}
member HorizontalModeIndicator : HorizontalModeIndicator with get, set

Property Value

Type: HorizontalModeIndicator
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.NacP Property

TargetStateAndStatusVersion1NacP Property
Gets or sets the navigational accuracy category for position.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte NacP { get; set; }
Public Property NacP As Byte
    Get
    Set
public:
property unsigned char NacP {
    unsigned char get ();
    void set (unsigned char value);
}
member NacP : byte with get, set

Property Value

Type: Byte
Remarks
I'm not too interested in these and can't be bothered to type out the enumeration for the different values, or decode them into radii. Something to add in a later version perhaps?
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.NicBaro Property

TargetStateAndStatusVersion1NicBaro Property
Gets or sets a value indicating the integrity category for barometric altitudes.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NicBaro { get; set; }
Public Property NicBaro As Boolean
    Get
    Set
public:
property bool NicBaro {
    bool get ();
    void set (bool value);
}
member NicBaro : bool with get, set

Property Value

Type: Boolean
Remarks

If this is false then the altitude reported in airborne position messages is a Gillham altitude that has not been cross-checked against other sources of pressure altitude.

If this is true then the altitude reported in airborne position messages is either a Gillham altitude that has been cross-checked against other sources and is verified as being consistent or it is not based on a Gillham source of pressure altitude.

See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.Sil Property

TargetStateAndStatusVersion1Sil Property
Gets or sets the surveillance integrity level.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Sil { get; set; }
Public Property Sil As Byte
    Get
    Set
public:
property unsigned char Sil {
    unsigned char get ();
    void set (unsigned char value);
}
member Sil : byte with get, set

Property Value

Type: Byte
Remarks
Another value I don't really care about and haven't translated into radii.
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.TargetAltitude Property

TargetStateAndStatusVersion1TargetAltitude Property
Gets or sets the target altitude in feet.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> TargetAltitude { get; set; }
Public Property TargetAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> TargetAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member TargetAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.TargetAltitudeCapability Property

TargetStateAndStatusVersion1TargetAltitudeCapability Property
Gets or sets a value indicating which target altitudes can be sent by the transponder.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetAltitudeCapability TargetAltitudeCapability { get; set; }
Public Property TargetAltitudeCapability As TargetAltitudeCapability
    Get
    Set
public:
property TargetAltitudeCapability TargetAltitudeCapability {
    TargetAltitudeCapability get ();
    void set (TargetAltitudeCapability value);
}
member TargetAltitudeCapability : TargetAltitudeCapability with get, set

Property Value

Type: TargetAltitudeCapability
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.TargetHeading Property

TargetStateAndStatusVersion1TargetHeading Property
Gets or sets the target heading or track angle.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> TargetHeading { get; set; }
Public Property TargetHeading As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> TargetHeading {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member TargetHeading : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.TargetHeadingIsTrack Property

TargetStateAndStatusVersion1TargetHeadingIsTrack Property
Gets or sets a value indicating whether TargetHeading is the track (true) or heading (false) angle.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetHeadingIsTrack { get; set; }
Public Property TargetHeadingIsTrack As Boolean
    Get
    Set
public:
property bool TargetHeadingIsTrack {
    bool get ();
    void set (bool value);
}
member TargetHeadingIsTrack : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.TcasCapabilityMode Property

TargetStateAndStatusVersion1TcasCapabilityMode Property
Gets or sets the current state of the TCAS/ACAS system.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TcasCapabilityMode TcasCapabilityMode { get; set; }
Public Property TcasCapabilityMode As TcasCapabilityMode
    Get
    Set
public:
property TcasCapabilityMode TcasCapabilityMode {
    TcasCapabilityMode get ();
    void set (TcasCapabilityMode value);
}
member TcasCapabilityMode : TcasCapabilityMode with get, set

Property Value

Type: TcasCapabilityMode
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.VerticalDataSource Property

TargetStateAndStatusVersion1VerticalDataSource Property
Gets or sets the source of the vertical state data.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerticalDataSource VerticalDataSource { get; set; }
Public Property VerticalDataSource As VerticalDataSource
    Get
    Set
public:
property VerticalDataSource VerticalDataSource {
    VerticalDataSource get ();
    void set (VerticalDataSource value);
}
member VerticalDataSource : VerticalDataSource with get, set

Property Value

Type: VerticalDataSource
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.VerticalModeIndicator Property

TargetStateAndStatusVersion1VerticalModeIndicator Property
Gets or sets a value indicating whether the target altitude has been reached or whether the aircraft is moving towards it.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerticalModeIndicator VerticalModeIndicator { get; set; }
Public Property VerticalModeIndicator As VerticalModeIndicator
    Get
    Set
public:
property VerticalModeIndicator VerticalModeIndicator {
    VerticalModeIndicator get ();
    void set (VerticalModeIndicator value);
}
member VerticalModeIndicator : VerticalModeIndicator with get, set

Property Value

Type: VerticalModeIndicator
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1 Methods

TargetStateAndStatusVersion1 Methods

The TargetStateAndStatusVersion1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion1.ToString Method

TargetStateAndStatusVersion1ToString Method
Returns an English description of the object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

TargetStateAndStatusVersion1 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2 Class

TargetStateAndStatusVersion2 Class
A class carrying the content of an ADS-B version 2 target state and status message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbTargetStateAndStatusVersion2

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TargetStateAndStatusVersion2
Public Class TargetStateAndStatusVersion2
public ref class TargetStateAndStatusVersion2
type TargetStateAndStatusVersion2 =  class end

The TargetStateAndStatusVersion2 type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateAndStatusVersion2 | Initializes a new instance of the TargetStateAndStatusVersion2 class
Top
Properties
 | Name | Description
Public property | BarometricPressureSetting | Gets or sets the barometric pressure setting.
Public property | IsAltitudeHoldActive | Gets or sets a value indicating that the autopilot's altitude hold mode is active.
Public property | IsApproachModeActive | Gets or sets a value indicating that the autopilot's approach mode is active.
Public property | IsAutopilotEngaged | Gets or sets a value indicating that the autopilot is flying the aircraft.
Public property | IsLnavEngaged | Gets or sets a value indicating that the autopilot's lateral navigation mode is active.
Public property | IsRebroadcast | Gets or sets a value indicating that the message has been rebroadcast by a ground link.
Public property | IsTcasOperational | Gets or sets a value indicating that the TCAS/ACAS system is operational.
Public property | IsVnavEngaged | Gets or sets a value indicating that the autopilot's vertical navigation mode is active.
Public property | NacP | Gets or sets the navigational accuracy category for position.
Public property | NicBaro | Gets or sets a value indicating the integrity category for barometric altitudes.
Public property | SelectedAltitude | Gets or sets the autopilot / FMS selected altitude in feet.
Public property | SelectedAltitudeIsFms | Gets or sets a value indicating whether the SelectedAltitude is derived from the Flight Management System (true) or the autopilot Mode Control Panel / Flight Control Unit (false).
Public property | SelectedHeading | Gets or sets the autopilot / FMS selected heading in degrees.
Public property | Sil | Gets or sets a value indicating the probability of exceeding the NIC containment radius.
Public property | SilSupplement | Gets or sets a value indicating whether the reporting SIL probability is based on a per-sample (true) or per-hour (false) probability.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2 Constructor

TargetStateAndStatusVersion2 Constructor
Initializes a new instance of the TargetStateAndStatusVersion2 class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateAndStatusVersion2()
Public Sub New
public:
TargetStateAndStatusVersion2()
new : unit -> TargetStateAndStatusVersion2
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2 Properties

TargetStateAndStatusVersion2 Properties

The TargetStateAndStatusVersion2 type exposes the following members.

Properties
 | Name | Description
Public property | BarometricPressureSetting | Gets or sets the barometric pressure setting.
Public property | IsAltitudeHoldActive | Gets or sets a value indicating that the autopilot's altitude hold mode is active.
Public property | IsApproachModeActive | Gets or sets a value indicating that the autopilot's approach mode is active.
Public property | IsAutopilotEngaged | Gets or sets a value indicating that the autopilot is flying the aircraft.
Public property | IsLnavEngaged | Gets or sets a value indicating that the autopilot's lateral navigation mode is active.
Public property | IsRebroadcast | Gets or sets a value indicating that the message has been rebroadcast by a ground link.
Public property | IsTcasOperational | Gets or sets a value indicating that the TCAS/ACAS system is operational.
Public property | IsVnavEngaged | Gets or sets a value indicating that the autopilot's vertical navigation mode is active.
Public property | NacP | Gets or sets the navigational accuracy category for position.
Public property | NicBaro | Gets or sets a value indicating the integrity category for barometric altitudes.
Public property | SelectedAltitude | Gets or sets the autopilot / FMS selected altitude in feet.
Public property | SelectedAltitudeIsFms | Gets or sets a value indicating whether the SelectedAltitude is derived from the Flight Management System (true) or the autopilot Mode Control Panel / Flight Control Unit (false).
Public property | SelectedHeading | Gets or sets the autopilot / FMS selected heading in degrees.
Public property | Sil | Gets or sets a value indicating the probability of exceeding the NIC containment radius.
Public property | SilSupplement | Gets or sets a value indicating whether the reporting SIL probability is based on a per-sample (true) or per-hour (false) probability.
Top
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.BarometricPressureSetting Property

TargetStateAndStatusVersion2BarometricPressureSetting Property
Gets or sets the barometric pressure setting.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> BarometricPressureSetting { get; set; }
Public Property BarometricPressureSetting As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> BarometricPressureSetting {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member BarometricPressureSetting : Nullable<float32> with get, set

Property Value

Type: Nullable Single
Remarks
This is transmitted as the pressure setting minus 800 millibars. The 800 gets added back on before being reported here.
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsAltitudeHoldActive Property

TargetStateAndStatusVersion2IsAltitudeHoldActive Property
Gets or sets a value indicating that the autopilot's altitude hold mode is active.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsAltitudeHoldActive { get; set; }
Public Property IsAltitudeHoldActive As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsAltitudeHoldActive {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsAltitudeHoldActive : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsApproachModeActive Property

TargetStateAndStatusVersion2IsApproachModeActive Property
Gets or sets a value indicating that the autopilot's approach mode is active.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsApproachModeActive { get; set; }
Public Property IsApproachModeActive As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsApproachModeActive {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsApproachModeActive : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsAutopilotEngaged Property

TargetStateAndStatusVersion2IsAutopilotEngaged Property
Gets or sets a value indicating that the autopilot is flying the aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsAutopilotEngaged { get; set; }
Public Property IsAutopilotEngaged As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsAutopilotEngaged {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsAutopilotEngaged : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsLnavEngaged Property

TargetStateAndStatusVersion2IsLnavEngaged Property
Gets or sets a value indicating that the autopilot's lateral navigation mode is active.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsLnavEngaged { get; set; }
Public Property IsLnavEngaged As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsLnavEngaged {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsLnavEngaged : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsRebroadcast Property

TargetStateAndStatusVersion2IsRebroadcast Property
Gets or sets a value indicating that the message has been rebroadcast by a ground link.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRebroadcast { get; set; }
Public Property IsRebroadcast As Boolean
    Get
    Set
public:
property bool IsRebroadcast {
    bool get ();
    void set (bool value);
}
member IsRebroadcast : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsTcasOperational Property

TargetStateAndStatusVersion2IsTcasOperational Property
Gets or sets a value indicating that the TCAS/ACAS system is operational.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTcasOperational { get; set; }
Public Property IsTcasOperational As Boolean
    Get
    Set
public:
property bool IsTcasOperational {
    bool get ();
    void set (bool value);
}
member IsTcasOperational : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.IsVnavEngaged Property

TargetStateAndStatusVersion2IsVnavEngaged Property
Gets or sets a value indicating that the autopilot's vertical navigation mode is active.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsVnavEngaged { get; set; }
Public Property IsVnavEngaged As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsVnavEngaged {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsVnavEngaged : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.NacP Property

TargetStateAndStatusVersion2NacP Property
Gets or sets the navigational accuracy category for position.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte NacP { get; set; }
Public Property NacP As Byte
    Get
    Set
public:
property unsigned char NacP {
    unsigned char get ();
    void set (unsigned char value);
}
member NacP : byte with get, set

Property Value

Type: Byte
Remarks
I'm not too interested in these and can't be bothered to type out the enumeration for the different values, or decode them into radii. Something to add in a later version perhaps?
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.NicBaro Property

TargetStateAndStatusVersion2NicBaro Property
Gets or sets a value indicating the integrity category for barometric altitudes.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NicBaro { get; set; }
Public Property NicBaro As Boolean
    Get
    Set
public:
property bool NicBaro {
    bool get ();
    void set (bool value);
}
member NicBaro : bool with get, set

Property Value

Type: Boolean
Remarks

If this is false then the altitude reported in airborne position messages is a Gillham altitude that has not been cross-checked against other sources of pressure altitude.

If this is true then the altitude reported in airborne position messages is either a Gillham altitude that has been cross-checked against other sources and is verified as being consistent or it is not based on a Gillham source of pressure altitude.

See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.SelectedAltitude Property

TargetStateAndStatusVersion2SelectedAltitude Property
Gets or sets the autopilot / FMS selected altitude in feet.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SelectedAltitude { get; set; }
Public Property SelectedAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SelectedAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SelectedAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.SelectedAltitudeIsFms Property

TargetStateAndStatusVersion2SelectedAltitudeIsFms Property
Gets or sets a value indicating whether the SelectedAltitude is derived from the Flight Management System (true) or the autopilot Mode Control Panel / Flight Control Unit (false).

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectedAltitudeIsFms { get; set; }
Public Property SelectedAltitudeIsFms As Boolean
    Get
    Set
public:
property bool SelectedAltitudeIsFms {
    bool get ();
    void set (bool value);
}
member SelectedAltitudeIsFms : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.SelectedHeading Property

TargetStateAndStatusVersion2SelectedHeading Property
Gets or sets the autopilot / FMS selected heading in degrees.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> SelectedHeading { get; set; }
Public Property SelectedHeading As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> SelectedHeading {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member SelectedHeading : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.Sil Property

TargetStateAndStatusVersion2Sil Property
Gets or sets a value indicating the probability of exceeding the NIC containment radius.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Sil { get; set; }
Public Property Sil As Byte
    Get
    Set
public:
property unsigned char Sil {
    unsigned char get ();
    void set (unsigned char value);
}
member Sil : byte with get, set

Property Value

Type: Byte
Remarks
This is different to the version 1 SIL but I still don't really care about it. I'll translate the values into probabilities in a later version of the program.
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.SilSupplement Property

TargetStateAndStatusVersion2SilSupplement Property
Gets or sets a value indicating whether the reporting SIL probability is based on a per-sample (true) or per-hour (false) probability.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SilSupplement { get; set; }
Public Property SilSupplement As Boolean
    Get
    Set
public:
property bool SilSupplement {
    bool get ();
    void set (bool value);
}
member SilSupplement : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2 Methods

TargetStateAndStatusVersion2 Methods

The TargetStateAndStatusVersion2 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TargetStateAndStatusVersion2.ToString Method

TargetStateAndStatusVersion2ToString Method
Returns an English description of the object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

TargetStateAndStatusVersion2 Class
VirtualRadar.Interface.Adsb Namespace


TcasCapabilityMode Enumeration

TcasCapabilityMode Enumeration
An enumeration of the different operational status indicators for TCAS/ACAS systems as transmitted in the ADS-B version 1 target state and status message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TcasCapabilityMode
Public Enumeration TcasCapabilityMode
public enum class TcasCapabilityMode
type TcasCapabilityMode
Members
Member name | Value | Description
OperationalOrUnknown | 0 | All systems are either operational or their state is unknown.
NotOperational | 1 | TCAS/ACAS is not operational.
NoResolutionAdvisoryActive | 2 | TCAS/ACAS is operational and no RA is active.
ResolutionAdvisoryActive | 3 | TCAS/ACAS is operational and an RA is active.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory Class

TcasResolutionAdvisory Class
A class describing the content of an aircraft status message carrying a TCAS RA broadcast.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbTcasResolutionAdvisory

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TcasResolutionAdvisory
Public Class TcasResolutionAdvisory
public ref class TcasResolutionAdvisory
type TcasResolutionAdvisory =  class end

The TcasResolutionAdvisory type exposes the following members.

Constructors
 | Name | Description
Public method | TcasResolutionAdvisory | Initializes a new instance of the TcasResolutionAdvisory class
Top
Properties
 | Name | Description
Public property | FormattedThreatIcao24 | Gets the ThreatIcao24 value formatted as a string. If ThreatIcao24 is zero then this will be null.
Public property | MultipleThreatEncounter | Gets or sets a value indicating that multiple threats are being processed by TCAS.
Public property | MultipleThreatResolutionAdvisory | Gets or sets the multiple-threat resolution advisory in a TCAS RA broadcast.
Public property | ResolutionAdvisoryComplement | Gets or sets the RAC from a TCAS RA broadcast.
Public property | ResolutionAdvisoryTerminated | Gets or sets a value indicating that the RA has been terminated.
Public property | SingleThreatResolutionAdvisory | Gets or sets the single-threat resolution advisory in a TCAS RA broadcast.
Public property | ThreatAltitude | Gets or sets the altitude of the most recently declared threat to the aircraft.
Public property | ThreatBearing | Gets or sets the bearing, relative to the aircraft, of the threat aircraft.
Public property | ThreatIcao24 | Gets or sets the ICAO24 code of the most recently declared threat to the aircraft, if known.
Public property | ThreatRange | Gets or sets the range from the aircraft to the threat in nautical miles.
Public property | ThreatRangeExceeded | Gets or sets a value indicating that the range to the threat in ThreatRange exceeds the maximum distance that TCAS can represent.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the content of the object. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory Constructor

TcasResolutionAdvisory Constructor
Initializes a new instance of the TcasResolutionAdvisory class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TcasResolutionAdvisory()
Public Sub New
public:
TcasResolutionAdvisory()
new : unit -> TcasResolutionAdvisory
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory Properties

TcasResolutionAdvisory Properties

The TcasResolutionAdvisory type exposes the following members.

Properties
 | Name | Description
Public property | FormattedThreatIcao24 | Gets the ThreatIcao24 value formatted as a string. If ThreatIcao24 is zero then this will be null.
Public property | MultipleThreatEncounter | Gets or sets a value indicating that multiple threats are being processed by TCAS.
Public property | MultipleThreatResolutionAdvisory | Gets or sets the multiple-threat resolution advisory in a TCAS RA broadcast.
Public property | ResolutionAdvisoryComplement | Gets or sets the RAC from a TCAS RA broadcast.
Public property | ResolutionAdvisoryTerminated | Gets or sets a value indicating that the RA has been terminated.
Public property | SingleThreatResolutionAdvisory | Gets or sets the single-threat resolution advisory in a TCAS RA broadcast.
Public property | ThreatAltitude | Gets or sets the altitude of the most recently declared threat to the aircraft.
Public property | ThreatBearing | Gets or sets the bearing, relative to the aircraft, of the threat aircraft.
Public property | ThreatIcao24 | Gets or sets the ICAO24 code of the most recently declared threat to the aircraft, if known.
Public property | ThreatRange | Gets or sets the range from the aircraft to the threat in nautical miles.
Public property | ThreatRangeExceeded | Gets or sets a value indicating that the range to the threat in ThreatRange exceeds the maximum distance that TCAS can represent.
Top
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.FormattedThreatIcao24 Property

TcasResolutionAdvisoryFormattedThreatIcao24 Property
Gets the ThreatIcao24 value formatted as a string. If ThreatIcao24 is zero then this will be null.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FormattedThreatIcao24 { get; }
Public ReadOnly Property FormattedThreatIcao24 As String
    Get
public:
property String^ FormattedThreatIcao24 {
    String^ get ();
}
member FormattedThreatIcao24 : string with get

Property Value

Type: String
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.MultipleThreatEncounter Property

TcasResolutionAdvisoryMultipleThreatEncounter Property
Gets or sets a value indicating that multiple threats are being processed by TCAS.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MultipleThreatEncounter { get; set; }
Public Property MultipleThreatEncounter As Boolean
    Get
    Set
public:
property bool MultipleThreatEncounter {
    bool get ();
    void set (bool value);
}
member MultipleThreatEncounter : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.MultipleThreatResolutionAdvisory Property

TcasResolutionAdvisoryMultipleThreatResolutionAdvisory Property
Gets or sets the multiple-threat resolution advisory in a TCAS RA broadcast.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<MultipleThreatResolutionAdvisory> MultipleThreatResolutionAdvisory { get; set; }
Public Property MultipleThreatResolutionAdvisory As Nullable(Of MultipleThreatResolutionAdvisory)
    Get
    Set
public:
property Nullable<MultipleThreatResolutionAdvisory> MultipleThreatResolutionAdvisory {
    Nullable<MultipleThreatResolutionAdvisory> get ();
    void set (Nullable<MultipleThreatResolutionAdvisory> value);
}
member MultipleThreatResolutionAdvisory : Nullable<MultipleThreatResolutionAdvisory> with get, set

Property Value

Type: Nullable MultipleThreatResolutionAdvisory
Remarks
If this is supplied then SingleThreatResolutionAdvisory will be null.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ResolutionAdvisoryComplement Property

TcasResolutionAdvisoryResolutionAdvisoryComplement Property
Gets or sets the RAC from a TCAS RA broadcast.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResolutionAdvisoryComplement ResolutionAdvisoryComplement { get; set; }
Public Property ResolutionAdvisoryComplement As ResolutionAdvisoryComplement
    Get
    Set
public:
property ResolutionAdvisoryComplement ResolutionAdvisoryComplement {
    ResolutionAdvisoryComplement get ();
    void set (ResolutionAdvisoryComplement value);
}
member ResolutionAdvisoryComplement : ResolutionAdvisoryComplement with get, set

Property Value

Type: ResolutionAdvisoryComplement
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ResolutionAdvisoryTerminated Property

TcasResolutionAdvisoryResolutionAdvisoryTerminated Property
Gets or sets a value indicating that the RA has been terminated.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ResolutionAdvisoryTerminated { get; set; }
Public Property ResolutionAdvisoryTerminated As Boolean
    Get
    Set
public:
property bool ResolutionAdvisoryTerminated {
    bool get ();
    void set (bool value);
}
member ResolutionAdvisoryTerminated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.SingleThreatResolutionAdvisory Property

TcasResolutionAdvisorySingleThreatResolutionAdvisory Property
Gets or sets the single-threat resolution advisory in a TCAS RA broadcast.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<SingleThreatResolutionAdvisory> SingleThreatResolutionAdvisory { get; set; }
Public Property SingleThreatResolutionAdvisory As Nullable(Of SingleThreatResolutionAdvisory)
    Get
    Set
public:
property Nullable<SingleThreatResolutionAdvisory> SingleThreatResolutionAdvisory {
    Nullable<SingleThreatResolutionAdvisory> get ();
    void set (Nullable<SingleThreatResolutionAdvisory> value);
}
member SingleThreatResolutionAdvisory : Nullable<SingleThreatResolutionAdvisory> with get, set

Property Value

Type: Nullable SingleThreatResolutionAdvisory
Remarks
If this is supplied then MultipleThreatResolutionAdvisory will be clear.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ThreatAltitude Property

TcasResolutionAdvisoryThreatAltitude Property
Gets or sets the altitude of the most recently declared threat to the aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ThreatAltitude { get; set; }
Public Property ThreatAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ThreatAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ThreatAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
Remarks
If this is not null then ThreatRange and ThreatBearing will also be supplied (although they may be null if the given value is unknown) and ThreatIcao24 will be null.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ThreatBearing Property

TcasResolutionAdvisoryThreatBearing Property
Gets or sets the bearing, relative to the aircraft, of the threat aircraft.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> ThreatBearing { get; set; }
Public Property ThreatBearing As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> ThreatBearing {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member ThreatBearing : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
Remarks
If this is null then either the bearing to the threat is not known or ThreatIcao24 has been supplied. If it is not null then ThreatIcao24 will be null and ThreatAltitude and ThreatRange will be supplied.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ThreatIcao24 Property

TcasResolutionAdvisoryThreatIcao24 Property
Gets or sets the ICAO24 code of the most recently declared threat to the aircraft, if known.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ThreatIcao24 { get; set; }
Public Property ThreatIcao24 As Integer
    Get
    Set
public:
property int ThreatIcao24 {
    int get ();
    void set (int value);
}
member ThreatIcao24 : int with get, set

Property Value

Type: Int32
Remarks
If this is non-zero then FormattedThreatIcao24 will be set and ThreatAltitude, ThreatRange and ThreatBearing will all be null.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ThreatRange Property

TcasResolutionAdvisoryThreatRange Property
Gets or sets the range from the aircraft to the threat in nautical miles.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> ThreatRange { get; set; }
Public Property ThreatRange As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> ThreatRange {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member ThreatRange : Nullable<float32> with get, set

Property Value

Type: Nullable Single
Remarks
If this is null then either the range to the threat is not known or ThreatIcao24 has been supplied. If it is not null then ThreatIcao24 will be null and ThreatAltitude and ThreatBearing will be supplied.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ThreatRangeExceeded Property

TcasResolutionAdvisoryThreatRangeExceeded Property
Gets or sets a value indicating that the range to the threat in ThreatRange exceeds the maximum distance that TCAS can represent.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ThreatRangeExceeded { get; set; }
Public Property ThreatRangeExceeded As Boolean
    Get
    Set
public:
property bool ThreatRangeExceeded {
    bool get ();
    void set (bool value);
}
member ThreatRangeExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
If this is set then the threat is further away than the value specified in ThreatRange.
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory Methods

TcasResolutionAdvisory Methods

The TcasResolutionAdvisory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the content of the object. (Overrides ObjectToString.)
Top
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


TcasResolutionAdvisory.ToString Method

TcasResolutionAdvisoryToString Method
Returns an English description of the content of the object.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

TcasResolutionAdvisory Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity Class

VectorVelocity Class
The speed and bearing of a vehicle specified as two velocities along the X and Y axis.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.AdsbVectorVelocity

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VectorVelocity
Public Class VectorVelocity
public ref class VectorVelocity
type VectorVelocity =  class end

The VectorVelocity type exposes the following members.

Constructors
 | Name | Description
Public method | VectorVelocity | Initializes a new instance of the VectorVelocity class
Top
Properties
 | Name | Description
Public property | Bearing | Gets the bearing as calculated from the other properties.
Public property | EastWestExceeded | Gets or sets a value indicating that the actual velocity along the east-west axis is higher than the value in EastWestVelocity.
Public property | EastWestVelocity | Gets or sets the velocity in knots in either the east or west direction.
Public property | IsSoutherlyVelocity | Gets or sets a value indicating that the north-south velocity is south.
Public property | IsWesterlyVelocity | Gets or sets a value indicating that the east-west velocity is west.
Public property | NorthSouthExceeded | Gets or sets a value indicating that the actual velocity along the north-south axis is higher than the value in NorthSouthVelocity.
Public property | NorthSouthVelocity | Gets or sets the velocity in knots in either the north or south direction.
Public property | Speed | Gets the speed in knots as calculated from the other properties.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the velocity. (Overrides ObjectToString.)
Top
Remarks

ADS-B allows velocity and heading to be specified in one of two ways. One is an explicit declaration of the heading as a bearing and a velocity. The other is declared as two speeds, one in the east-west direction and the other in the north-south direction, from which the bearing and actual speed can be calculated using trigonometry. This class declares the parameters transmitted for the latter and also carries the code to derive the bearing and speed.

See Also

Reference

VirtualRadar.Interface.Adsb Namespace


VectorVelocity Constructor

VectorVelocity Constructor
Initializes a new instance of the VectorVelocity class

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VectorVelocity()
Public Sub New
public:
VectorVelocity()
new : unit -> VectorVelocity
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity Properties

VectorVelocity Properties

The VectorVelocity type exposes the following members.

Properties
 | Name | Description
Public property | Bearing | Gets the bearing as calculated from the other properties.
Public property | EastWestExceeded | Gets or sets a value indicating that the actual velocity along the east-west axis is higher than the value in EastWestVelocity.
Public property | EastWestVelocity | Gets or sets the velocity in knots in either the east or west direction.
Public property | IsSoutherlyVelocity | Gets or sets a value indicating that the north-south velocity is south.
Public property | IsWesterlyVelocity | Gets or sets a value indicating that the east-west velocity is west.
Public property | NorthSouthExceeded | Gets or sets a value indicating that the actual velocity along the north-south axis is higher than the value in NorthSouthVelocity.
Public property | NorthSouthVelocity | Gets or sets the velocity in knots in either the north or south direction.
Public property | Speed | Gets the speed in knots as calculated from the other properties.
Top
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.Bearing Property

VectorVelocityBearing Property
Gets the bearing as calculated from the other properties.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Bearing { get; }
Public ReadOnly Property Bearing As Nullable(Of Double)
    Get
public:
property Nullable<double> Bearing {
    Nullable<double> get ();
}
member Bearing : Nullable<float> with get

Property Value

Type: Nullable Double
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.EastWestExceeded Property

VectorVelocityEastWestExceeded Property
Gets or sets a value indicating that the actual velocity along the east-west axis is higher than the value in EastWestVelocity.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EastWestExceeded { get; set; }
Public Property EastWestExceeded As Boolean
    Get
    Set
public:
property bool EastWestExceeded {
    bool get ();
    void set (bool value);
}
member EastWestExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
Depending on the message the maximum velocity is either 1021 knots or 4084 knots. If this flag is set then the aircraft was travelling faster than the highest velocity that the message could convey.
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.EastWestVelocity Property

VectorVelocityEastWestVelocity Property
Gets or sets the velocity in knots in either the east or west direction.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> EastWestVelocity { get; set; }
Public Property EastWestVelocity As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> EastWestVelocity {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member EastWestVelocity : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
Remarks
If this is null then the east-west velocity was not transmitted in the velocity message.
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.IsSoutherlyVelocity Property

VectorVelocityIsSoutherlyVelocity Property
Gets or sets a value indicating that the north-south velocity is south.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSoutherlyVelocity { get; set; }
Public Property IsSoutherlyVelocity As Boolean
    Get
    Set
public:
property bool IsSoutherlyVelocity {
    bool get ();
    void set (bool value);
}
member IsSoutherlyVelocity : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.IsWesterlyVelocity Property

VectorVelocityIsWesterlyVelocity Property
Gets or sets a value indicating that the east-west velocity is west.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWesterlyVelocity { get; set; }
Public Property IsWesterlyVelocity As Boolean
    Get
    Set
public:
property bool IsWesterlyVelocity {
    bool get ();
    void set (bool value);
}
member IsWesterlyVelocity : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.NorthSouthExceeded Property

VectorVelocityNorthSouthExceeded Property
Gets or sets a value indicating that the actual velocity along the north-south axis is higher than the value in NorthSouthVelocity.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NorthSouthExceeded { get; set; }
Public Property NorthSouthExceeded As Boolean
    Get
    Set
public:
property bool NorthSouthExceeded {
    bool get ();
    void set (bool value);
}
member NorthSouthExceeded : bool with get, set

Property Value

Type: Boolean
Remarks
Depending on the message the maximum velocity is either 1021 knots or 4084 knots. If this flag is set then the aircraft was travelling faster than the highest velocity that the message could convey.
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.NorthSouthVelocity Property

VectorVelocityNorthSouthVelocity Property
Gets or sets the velocity in knots in either the north or south direction.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> NorthSouthVelocity { get; set; }
Public Property NorthSouthVelocity As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> NorthSouthVelocity {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member NorthSouthVelocity : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
Remarks
If this is null then the north-south velocity was not transmitted in the velocity message.
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.Speed Property

VectorVelocitySpeed Property
Gets the speed in knots as calculated from the other properties.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Speed { get; }
Public ReadOnly Property Speed As Nullable(Of Double)
    Get
public:
property Nullable<double> Speed {
    Nullable<double> get ();
}
member Speed : Nullable<float> with get

Property Value

Type: Nullable Double
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity Methods

VectorVelocity Methods

The VectorVelocity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the velocity. (Overrides ObjectToString.)
Top
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VectorVelocity.ToString Method

VectorVelocityToString Method
Returns an English description of the velocity.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

VectorVelocity Class
VirtualRadar.Interface.Adsb Namespace


VelocityType Enumeration

VelocityType Enumeration
An enumeration of the different types of velocity message encodings in an ADS-B velocity message.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VelocityType
Public Enumeration VelocityType
public enum class VelocityType
type VelocityType
Members
Member name | Value | Description
VelocityType0 | 0 | Reserved.
GroundSpeedSubsonic | 1 | Velocity over ground under normal airspeed conditions.
GroundSpeedSupersonic | 2 | Velocity over ground under supersonic conditions.
AirspeedSubsonic | 3 | Indicated or true airspeed under normal airspeed conditions.
AirspeedSupersonic | 4 | Indicated or true airspeed under supersonic conditions.
VelocityType5 | 5 | Reserved.
VelocityType6 | 6 | Reserved.
VelocityType7 | 7 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


VerticalDataSource Enumeration

VerticalDataSource Enumeration
An enumeration of the different sources of vertical data in ADS-B version 1 target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerticalDataSource
Public Enumeration VerticalDataSource
public enum class VerticalDataSource
type VerticalDataSource
Members
Member name | Value | Description
None | 0 | No valid vertical target state data is available.
AutopilotControlPanel | 1 | Source is the autopilot control panel selected value, such as from an MCP or FCU.
HoldingAltitude | 2 | The holding altitude.
Fms | 3 | Source is from an FMS/RNAV system.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


VerticalModeIndicator Enumeration

VerticalModeIndicator Enumeration
An enumeration of the different values of VMI that can be transmitted in ADS-B version 1 target state and status messages.

Namespace: VirtualRadar.Interface.Adsb
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerticalModeIndicator
Public Enumeration VerticalModeIndicator
public enum class VerticalModeIndicator
type VerticalModeIndicator
Members
Member name | Value | Description
Unknown | 0 | The information is not available.
Acquiring | 1 | The aircraft is climbing or descending towards the target altitude.
Maintaining | 2 | The aircraft is maintaining the target altitude.
Reserved | 3 | Reserved.
See Also

Reference

VirtualRadar.Interface.Adsb Namespace


VirtualRadar.Interface.BaseStation Namespace

VirtualRadar.Interface.BaseStation Namespace
The namespace for all of the interfaces and objects associated with receiving messages from BaseStation and forming a list of IAircraft objects from them.
Classes
 | Class | Description
Public class | BaseStationMessage | An object that carries information about an incoming message from Kinetic's BaseStation application.
Public class | BaseStationMessageEventArgs | Arguments to an event that carries a message from a BaseStation instance.
Public class | BaseStationMessageHelper | A static class containing methods that may be of use when handling BaseStation messages.
Public class | BaseStationSupplementaryMessage | Extra information carried on some BaseStationMessages that is gleaned from raw messages.
Public class | BaseStationTranslatorException | Thrown by objects that translate BaseStation text messages into message objects.
Interfaces
 | Interface | Description
Public interface | IBaseStationAircraftList | An aircraft list that uses a feed of BaseStationMessages as its source of information about aircraft.
Public interface | IBaseStationMessageCompressor | The interface for objects that can compress and decompress BaseStation messages.
Public interface | IBaseStationMessageTranslator | An interface for an object that can translate a string transmitted by BaseStation into a formatted message object.
Public interface | IRawMessageTranslator | The interface for classes that can translate Mode-S and ADS-B messages into BaseStation messages.
Enumerations
 | Enumeration | Description
Public enumeration | BaseStationMessageType | An enumeration of the different types of BaseStation message.
Public enumeration | BaseStationStatusCode | An enumeration of the different status codes that can be transmitted by a StatusChange message.
Public enumeration | BaseStationTransmissionType | An enumeration of the different type of Transmission message types.
Remarks


BaseStationMessage Class

BaseStationMessage Class
An object that carries information about an incoming message from Kinetic's BaseStation application.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.BaseStationBaseStationMessage

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationMessage
Public Class BaseStationMessage
public ref class BaseStationMessage
type BaseStationMessage =  class end

The BaseStationMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationMessage | Initializes a new instance of the BaseStationMessage class
Top
Properties
 | Name | Description
Public property | AircraftId | Gets or sets the identifier of the aircraft in the BaseStation database.
Public property | Altitude | Gets or sets the altitude of the aircraft, if known.
Public property | Callsign | Gets or sets the callsign of the aircraft, if known.
Public property | Emergency | Gets or sets a value indicating that the squawk code is set to a value indicating an emergency.
Public property | FlightId | Gets or sets the identifier of the flight in the BaseStation database.
Public property | GroundSpeed | Gets or sets the speed over the ground of the aircraft, if known.
Public property | Icao24 | Gets or sets the Mode S identifier transmitted by the aircraft.
Public property | IdentActive | Gets or sets a value indicating that the aircraft's transponder ident has been activated.
Public property | IsMlat | Gets or sets a value indicating that the message was generated by an MLAT receiver / server.
Public property | IsTisb | Gets or sets a value indicating that the message was generated by a TIS-B ground station.
Public property | Latitude | Gets or sets the north (+ve) or south (-ve) coordinate for the aircraft.
Public property | Longitude | Gets or sets the east (+ve) or west (-ve) coordinate for the aircraft.
Public property | MessageGenerated | Gets or sets the date and time the message was generated by BaseStation.
Public property | MessageLogged | Gets or sets the date and time that the message was logged by BaseStation.
Public property | MessageNumber | Gets or sets the message number for an archived message. Always zero for live messages.
Public property | MessageType | Gets or sets the type of message.
Public property | OnGround | Gets or sets a value indicating that the vehicle is on the ground.
Public property | ReceiverId | Gets or sets the unique ID of the receiver that picked up the message, if any. 0 if the ID is unknown.
Public property | SessionId | Gets or sets the identifier of the BaseStation session.
Public property | SignalLevel | Gets or sets the signal level, if known, at the time the packet carrying the message was received. If this is null then the receiver did not pass on the signal level.
Public property | Squawk | Gets or sets the squawk code.
Public property | SquawkHasChanged | Gets or sets a value indicating that the squawk code has changed.
Public property | StatusCode | Gets or sets the status change in a StatusChanged message.
Public property | Supplementary | Gets or sets the optional supplementary message object that carries extra information from a raw Mode-S or ADS-B message.
Public property | Track | Gets or sets the direction that the aircraft is heading in, if known.
Public property | TransmissionType | Gets or sets the type of transmission sent in a Transmission message.
Public property | VerticalRate | Gets or sets the speed of ascent or descent.
Top
Methods
 | Name | Description
Public method | CalculateRoughSize | Calculates a rough and far-from-accurate size for the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBaseStationString | Returns the message as parseable BaseStation message text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage Constructor

BaseStationMessage Constructor
Initializes a new instance of the BaseStationMessage class

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationMessage()
Public Sub New
public:
BaseStationMessage()
new : unit -> BaseStationMessage
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage Properties

BaseStationMessage Properties

The BaseStationMessage type exposes the following members.

Properties
 | Name | Description
Public property | AircraftId | Gets or sets the identifier of the aircraft in the BaseStation database.
Public property | Altitude | Gets or sets the altitude of the aircraft, if known.
Public property | Callsign | Gets or sets the callsign of the aircraft, if known.
Public property | Emergency | Gets or sets a value indicating that the squawk code is set to a value indicating an emergency.
Public property | FlightId | Gets or sets the identifier of the flight in the BaseStation database.
Public property | GroundSpeed | Gets or sets the speed over the ground of the aircraft, if known.
Public property | Icao24 | Gets or sets the Mode S identifier transmitted by the aircraft.
Public property | IdentActive | Gets or sets a value indicating that the aircraft's transponder ident has been activated.
Public property | IsMlat | Gets or sets a value indicating that the message was generated by an MLAT receiver / server.
Public property | IsTisb | Gets or sets a value indicating that the message was generated by a TIS-B ground station.
Public property | Latitude | Gets or sets the north (+ve) or south (-ve) coordinate for the aircraft.
Public property | Longitude | Gets or sets the east (+ve) or west (-ve) coordinate for the aircraft.
Public property | MessageGenerated | Gets or sets the date and time the message was generated by BaseStation.
Public property | MessageLogged | Gets or sets the date and time that the message was logged by BaseStation.
Public property | MessageNumber | Gets or sets the message number for an archived message. Always zero for live messages.
Public property | MessageType | Gets or sets the type of message.
Public property | OnGround | Gets or sets a value indicating that the vehicle is on the ground.
Public property | ReceiverId | Gets or sets the unique ID of the receiver that picked up the message, if any. 0 if the ID is unknown.
Public property | SessionId | Gets or sets the identifier of the BaseStation session.
Public property | SignalLevel | Gets or sets the signal level, if known, at the time the packet carrying the message was received. If this is null then the receiver did not pass on the signal level.
Public property | Squawk | Gets or sets the squawk code.
Public property | SquawkHasChanged | Gets or sets a value indicating that the squawk code has changed.
Public property | StatusCode | Gets or sets the status change in a StatusChanged message.
Public property | Supplementary | Gets or sets the optional supplementary message object that carries extra information from a raw Mode-S or ADS-B message.
Public property | Track | Gets or sets the direction that the aircraft is heading in, if known.
Public property | TransmissionType | Gets or sets the type of transmission sent in a Transmission message.
Public property | VerticalRate | Gets or sets the speed of ascent or descent.
Top
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.AircraftId Property

BaseStationMessageAircraftId Property
Gets or sets the identifier of the aircraft in the BaseStation database.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AircraftId { get; set; }
Public Property AircraftId As Integer
    Get
    Set
public:
property int AircraftId {
    int get ();
    void set (int value);
}
member AircraftId : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Altitude Property

BaseStationMessageAltitude Property
Gets or sets the altitude of the aircraft, if known.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Altitude { get; set; }
Public Property Altitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Altitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Altitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Callsign Property

BaseStationMessageCallsign Property
Gets or sets the callsign of the aircraft, if known.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Callsign { get; set; }
Public Property Callsign As String
    Get
    Set
public:
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
member Callsign : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Emergency Property

BaseStationMessageEmergency Property
Gets or sets a value indicating that the squawk code is set to a value indicating an emergency.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> Emergency { get; set; }
Public Property Emergency As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> Emergency {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member Emergency : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.FlightId Property

BaseStationMessageFlightId Property
Gets or sets the identifier of the flight in the BaseStation database.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlightId { get; set; }
Public Property FlightId As Integer
    Get
    Set
public:
property int FlightId {
    int get ();
    void set (int value);
}
member FlightId : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.GroundSpeed Property

BaseStationMessageGroundSpeed Property
Gets or sets the speed over the ground of the aircraft, if known.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> GroundSpeed { get; set; }
Public Property GroundSpeed As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> GroundSpeed {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member GroundSpeed : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Icao24 Property

BaseStationMessageIcao24 Property
Gets or sets the Mode S identifier transmitted by the aircraft.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao24 { get; set; }
Public Property Icao24 As String
    Get
    Set
public:
property String^ Icao24 {
    String^ get ();
    void set (String^ value);
}
member Icao24 : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.IdentActive Property

BaseStationMessageIdentActive Property
Gets or sets a value indicating that the aircraft's transponder ident has been activated.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IdentActive { get; set; }
Public Property IdentActive As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IdentActive {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IdentActive : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.IsMlat Property

BaseStationMessageIsMlat Property
Gets or sets a value indicating that the message was generated by an MLAT receiver / server.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMlat { get; set; }
Public Property IsMlat As Boolean
    Get
    Set
public:
property bool IsMlat {
    bool get ();
    void set (bool value);
}
member IsMlat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.IsTisb Property

BaseStationMessageIsTisb Property
Gets or sets a value indicating that the message was generated by a TIS-B ground station.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTisb { get; set; }
Public Property IsTisb As Boolean
    Get
    Set
public:
property bool IsTisb {
    bool get ();
    void set (bool value);
}
member IsTisb : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Latitude Property

BaseStationMessageLatitude Property
Gets or sets the north (+ve) or south (-ve) coordinate for the aircraft.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Latitude { get; set; }
Public Property Latitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Latitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Latitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Longitude Property

BaseStationMessageLongitude Property
Gets or sets the east (+ve) or west (-ve) coordinate for the aircraft.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Longitude { get; set; }
Public Property Longitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Longitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Longitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.MessageGenerated Property

BaseStationMessageMessageGenerated Property
Gets or sets the date and time the message was generated by BaseStation.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime MessageGenerated { get; set; }
Public Property MessageGenerated As DateTime
    Get
    Set
public:
property DateTime MessageGenerated {
    DateTime get ();
    void set (DateTime value);
}
member MessageGenerated : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.MessageLogged Property

BaseStationMessageMessageLogged Property
Gets or sets the date and time that the message was logged by BaseStation.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime MessageLogged { get; set; }
Public Property MessageLogged As DateTime
    Get
    Set
public:
property DateTime MessageLogged {
    DateTime get ();
    void set (DateTime value);
}
member MessageLogged : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.MessageNumber Property

BaseStationMessageMessageNumber Property
Gets or sets the message number for an archived message. Always zero for live messages.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MessageNumber { get; set; }
Public Property MessageNumber As Integer
    Get
    Set
public:
property int MessageNumber {
    int get ();
    void set (int value);
}
member MessageNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.MessageType Property

BaseStationMessageMessageType Property
Gets or sets the type of message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationMessageType MessageType { get; set; }
Public Property MessageType As BaseStationMessageType
    Get
    Set
public:
property BaseStationMessageType MessageType {
    BaseStationMessageType get ();
    void set (BaseStationMessageType value);
}
member MessageType : BaseStationMessageType with get, set

Property Value

Type: BaseStationMessageType
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.OnGround Property

BaseStationMessageOnGround Property
Gets or sets a value indicating that the vehicle is on the ground.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> OnGround { get; set; }
Public Property OnGround As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> OnGround {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member OnGround : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.ReceiverId Property

BaseStationMessageReceiverId Property
Gets or sets the unique ID of the receiver that picked up the message, if any. 0 if the ID is unknown.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReceiverId { get; set; }
Public Property ReceiverId As Integer
    Get
    Set
public:
property int ReceiverId {
    int get ();
    void set (int value);
}
member ReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.SessionId Property

BaseStationMessageSessionId Property
Gets or sets the identifier of the BaseStation session.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SessionId { get; set; }
Public Property SessionId As Integer
    Get
    Set
public:
property int SessionId {
    int get ();
    void set (int value);
}
member SessionId : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.SignalLevel Property

BaseStationMessageSignalLevel Property
Gets or sets the signal level, if known, at the time the packet carrying the message was received. If this is null then the receiver did not pass on the signal level.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SignalLevel { get; set; }
Public Property SignalLevel As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SignalLevel {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SignalLevel : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Squawk Property

BaseStationMessageSquawk Property
Gets or sets the squawk code.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Squawk { get; set; }
Public Property Squawk As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Squawk {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Squawk : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.SquawkHasChanged Property

BaseStationMessageSquawkHasChanged Property
Gets or sets a value indicating that the squawk code has changed.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> SquawkHasChanged { get; set; }
Public Property SquawkHasChanged As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> SquawkHasChanged {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member SquawkHasChanged : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.StatusCode Property

BaseStationMessageStatusCode Property
Gets or sets the status change in a StatusChanged message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationStatusCode StatusCode { get; set; }
Public Property StatusCode As BaseStationStatusCode
    Get
    Set
public:
property BaseStationStatusCode StatusCode {
    BaseStationStatusCode get ();
    void set (BaseStationStatusCode value);
}
member StatusCode : BaseStationStatusCode with get, set

Property Value

Type: BaseStationStatusCode
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Supplementary Property

BaseStationMessageSupplementary Property
Gets or sets the optional supplementary message object that carries extra information from a raw Mode-S or ADS-B message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationSupplementaryMessage Supplementary { get; set; }
Public Property Supplementary As BaseStationSupplementaryMessage
    Get
    Set
public:
property BaseStationSupplementaryMessage^ Supplementary {
    BaseStationSupplementaryMessage^ get ();
    void set (BaseStationSupplementaryMessage^ value);
}
member Supplementary : BaseStationSupplementaryMessage with get, set

Property Value

Type: BaseStationSupplementaryMessage
Remarks
This can be null, even for a message that has been created by the IRawMessageTranslator.
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.Track Property

BaseStationMessageTrack Property
Gets or sets the direction that the aircraft is heading in, if known.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> Track { get; set; }
Public Property Track As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> Track {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member Track : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.TransmissionType Property

BaseStationMessageTransmissionType Property
Gets or sets the type of transmission sent in a Transmission message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationTransmissionType TransmissionType { get; set; }
Public Property TransmissionType As BaseStationTransmissionType
    Get
    Set
public:
property BaseStationTransmissionType TransmissionType {
    BaseStationTransmissionType get ();
    void set (BaseStationTransmissionType value);
}
member TransmissionType : BaseStationTransmissionType with get, set

Property Value

Type: BaseStationTransmissionType
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.VerticalRate Property

BaseStationMessageVerticalRate Property
Gets or sets the speed of ascent or descent.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> VerticalRate { get; set; }
Public Property VerticalRate As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> VerticalRate {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member VerticalRate : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage Methods

BaseStationMessage Methods

The BaseStationMessage type exposes the following members.

Methods
 | Name | Description
Public method | CalculateRoughSize | Calculates a rough and far-from-accurate size for the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBaseStationString | Returns the message as parseable BaseStation message text.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.CalculateRoughSize Method

BaseStationMessageCalculateRoughSize Method
Calculates a rough and far-from-accurate size for the object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CalculateRoughSize()
Public Function CalculateRoughSize As Integer
public:
int CalculateRoughSize()
member CalculateRoughSize : unit -> int

Return Value

Type: Int32
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessage.ToBaseStationString Method

BaseStationMessageToBaseStationString Method
Returns the message as parseable BaseStation message text.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ToBaseStationString(
    bool emitExtendedBaseStationFormat = false
)
Public Function ToBaseStationString (
    Optional emitExtendedBaseStationFormat As Boolean = false
) As String
public:
String^ ToBaseStationString(
    bool emitExtendedBaseStationFormat = false
)
member ToBaseStationString :
        ?emitExtendedBaseStationFormat : bool
(* Defaults:
        let _emitExtendedBaseStationFormat = defaultArg emitExtendedBaseStationFormat false
*)
-> string

Parameters

emitExtendedBaseStationFormat (Optional)
Type: SystemBoolean
True if MLAT-sourced messages should use a message type of MLAT, false if they should use MSG. Ignored for other message types.

Return Value

Type: String
The properties of the message formatted up as a text string that can be sent to any application that can interpret BaseStation messages.
See Also

Reference

BaseStationMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs Class

BaseStationMessageEventArgs Class
Arguments to an event that carries a message from a BaseStation instance.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.BaseStationBaseStationMessageEventArgs

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationMessageEventArgs : EventArgs
Public Class BaseStationMessageEventArgs
    Inherits EventArgs
public ref class BaseStationMessageEventArgs : public EventArgs
type BaseStationMessageEventArgs =
    class
        inherit EventArgs
    end

The BaseStationMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationMessageEventArgs(BaseStationMessage) | Creates a new object.
Public method | BaseStationMessageEventArgs(BaseStationMessage, Boolean, Boolean) | Creates a new object.
Top
Properties
 | Name | Description
Public property | IsOutOfBand | Gets a value indicating that the message was received on a feed that is not the nominated feed for the aircraft in a merged feed.
Public property | IsSatcomFeed | Gets a value indicating that the message was received on a feed that is flagged as a SatCom feed.
Public property | Message | Gets the message that was transmitted by BaseStation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs Constructor

BaseStationMessageEventArgs Constructor
Overload List
 | Name | Description
Public method | BaseStationMessageEventArgs(BaseStationMessage) | Creates a new object.
Public method | BaseStationMessageEventArgs(BaseStationMessage, Boolean, Boolean) | Creates a new object.
Top
See Also

Reference

BaseStationMessageEventArgs Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs Constructor (BaseStationMessage)

BaseStationMessageEventArgs Constructor (BaseStationMessage)
Creates a new object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationMessageEventArgs(
    BaseStationMessage message
)
Public Sub New (
    message As BaseStationMessage
)
public:
BaseStationMessageEventArgs(
    BaseStationMessage^ message
)
new :
        message : BaseStationMessage -> BaseStationMessageEventArgs

Parameters

message
Type: VirtualRadar.Interface.BaseStationBaseStationMessage
See Also

Reference

BaseStationMessageEventArgs Class
BaseStationMessageEventArgs Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs Constructor (BaseStationMessage, Boolean, Boolean)

BaseStationMessageEventArgs Constructor (BaseStationMessage, Boolean, Boolean)
Creates a new object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationMessageEventArgs(
    BaseStationMessage message,
    bool isOutOfBand,
    bool isSatcomFeed
)
Public Sub New (
    message As BaseStationMessage,
    isOutOfBand As Boolean,
    isSatcomFeed As Boolean
)
public:
BaseStationMessageEventArgs(
    BaseStationMessage^ message,
    bool isOutOfBand,
    bool isSatcomFeed
)
new :
        message : BaseStationMessage *
        isOutOfBand : bool *
        isSatcomFeed : bool -> BaseStationMessageEventArgs

Parameters

message
Type: VirtualRadar.Interface.BaseStationBaseStationMessage
isOutOfBand
Type: SystemBoolean
isSatcomFeed
Type: SystemBoolean
See Also

Reference

BaseStationMessageEventArgs Class
BaseStationMessageEventArgs Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs Properties

BaseStationMessageEventArgs Properties

The BaseStationMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsOutOfBand | Gets a value indicating that the message was received on a feed that is not the nominated feed for the aircraft in a merged feed.
Public property | IsSatcomFeed | Gets a value indicating that the message was received on a feed that is flagged as a SatCom feed.
Public property | Message | Gets the message that was transmitted by BaseStation.
Top
See Also

Reference

BaseStationMessageEventArgs Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs.IsOutOfBand Property

BaseStationMessageEventArgsIsOutOfBand Property
Gets a value indicating that the message was received on a feed that is not the nominated feed for the aircraft in a merged feed.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOutOfBand { get; }
Public ReadOnly Property IsOutOfBand As Boolean
    Get
public:
property bool IsOutOfBand {
    bool get ();
}
member IsOutOfBand : bool with get

Property Value

Type: Boolean
Remarks
At the time of writing this is only set on merged feeds when the message was received from an MLAT source and the aircraft is currently being serviced by a different receiver.
See Also

Reference

BaseStationMessageEventArgs Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs.IsSatcomFeed Property

BaseStationMessageEventArgsIsSatcomFeed Property
Gets a value indicating that the message was received on a feed that is flagged as a SatCom feed.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSatcomFeed { get; }
Public ReadOnly Property IsSatcomFeed As Boolean
    Get
public:
property bool IsSatcomFeed {
    bool get ();
}
member IsSatcomFeed : bool with get

Property Value

Type: Boolean
See Also

Reference

BaseStationMessageEventArgs Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs.Message Property

BaseStationMessageEventArgsMessage Property
Gets the message that was transmitted by BaseStation.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationMessage Message { get; }
Public ReadOnly Property Message As BaseStationMessage
    Get
public:
property BaseStationMessage^ Message {
    BaseStationMessage^ get ();
}
member Message : BaseStationMessage with get

Property Value

Type: BaseStationMessage
See Also

Reference

BaseStationMessageEventArgs Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageEventArgs Methods

BaseStationMessageEventArgs Methods

The BaseStationMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationMessageEventArgs Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper Class

BaseStationMessageHelper Class
A static class containing methods that may be of use when handling BaseStation messages.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.BaseStationBaseStationMessageHelper

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BaseStationMessageHelper
Public NotInheritable Class BaseStationMessageHelper
public ref class BaseStationMessageHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BaseStationMessageHelper =  class end

The BaseStationMessageHelper type exposes the following members.

Methods
Name | Description
ConvertToBaseStationMessageType | Converts from BaseStation text to a message type.
ConvertToBaseStationStatusCode | Converts a string to a BaseStationStatusCode.
ConvertToBaseStationTransmissionType | Converts strings into BaseStationTransmissionType enumeration values.
ConvertToString(BaseStationStatusCode) | Converts a BaseStationStatusCode to a string.
ConvertToString(BaseStationTransmissionType) | Converts BaseStationTransmissionType values into strings.
ConvertToString(BaseStationMessageType, Boolean, Boolean) | Converts from a message type to the expected BaseStation text.
Top
Remarks
When BaseStationMessage was an interface this was used to help with writing implementations of the interface. Now that the interface has gone there is an argument for rolling this stuff into BaseStationMessage.
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper Methods

BaseStationMessageHelper Methods

The BaseStationMessageHelper type exposes the following members.

Methods
Name | Description
ConvertToBaseStationMessageType | Converts from BaseStation text to a message type.
ConvertToBaseStationStatusCode | Converts a string to a BaseStationStatusCode.
ConvertToBaseStationTransmissionType | Converts strings into BaseStationTransmissionType enumeration values.
ConvertToString(BaseStationStatusCode) | Converts a BaseStationStatusCode to a string.
ConvertToString(BaseStationTransmissionType) | Converts BaseStationTransmissionType values into strings.
ConvertToString(BaseStationMessageType, Boolean, Boolean) | Converts from a message type to the expected BaseStation text.
Top
See Also

Reference

BaseStationMessageHelper Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToBaseStationMessageType Method

BaseStationMessageHelperConvertToBaseStationMessageType Method
Converts from BaseStation text to a message type.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BaseStationMessageType ConvertToBaseStationMessageType(
    string text,
    ref bool isMlat
)
Public Shared Function ConvertToBaseStationMessageType (
    text As String,
    ByRef isMlat As Boolean
) As BaseStationMessageType
public:
static BaseStationMessageType ConvertToBaseStationMessageType(
    String^ text,
    bool% isMlat
)
static member ConvertToBaseStationMessageType :
        text : string *
        isMlat : bool byref -> BaseStationMessageType

Parameters

text
Type: SystemString
isMlat
Type: SystemBoolean

Return Value

Type: BaseStationMessageType
See Also

Reference

BaseStationMessageHelper Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToBaseStationStatusCode Method

BaseStationMessageHelperConvertToBaseStationStatusCode Method
Converts a string to a BaseStationStatusCode.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BaseStationStatusCode ConvertToBaseStationStatusCode(
    string text
)
Public Shared Function ConvertToBaseStationStatusCode (
    text As String
) As BaseStationStatusCode
public:
static BaseStationStatusCode ConvertToBaseStationStatusCode(
    String^ text
)
static member ConvertToBaseStationStatusCode :
        text : string -> BaseStationStatusCode

Parameters

text
Type: SystemString

Return Value

Type: BaseStationStatusCode
See Also

Reference

BaseStationMessageHelper Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToBaseStationTransmissionType Method

BaseStationMessageHelperConvertToBaseStationTransmissionType Method
Converts strings into BaseStationTransmissionType enumeration values.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BaseStationTransmissionType ConvertToBaseStationTransmissionType(
    string text
)
Public Shared Function ConvertToBaseStationTransmissionType (
    text As String
) As BaseStationTransmissionType
public:
static BaseStationTransmissionType ConvertToBaseStationTransmissionType(
    String^ text
)
static member ConvertToBaseStationTransmissionType :
        text : string -> BaseStationTransmissionType

Parameters

text
Type: SystemString

Return Value

Type: BaseStationTransmissionType
See Also

Reference

BaseStationMessageHelper Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToString Method

BaseStationMessageHelperConvertToString Method
Overload List
Name | Description
ConvertToString(BaseStationStatusCode) | Converts a BaseStationStatusCode to a string.
ConvertToString(BaseStationTransmissionType) | Converts BaseStationTransmissionType values into strings.
ConvertToString(BaseStationMessageType, Boolean, Boolean) | Converts from a message type to the expected BaseStation text.
Top
See Also

Reference

BaseStationMessageHelper Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToString Method (BaseStationStatusCode)

BaseStationMessageHelperConvertToString Method (BaseStationStatusCode)
Converts a BaseStationStatusCode to a string.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConvertToString(
    BaseStationStatusCode statusCode
)
Public Shared Function ConvertToString (
    statusCode As BaseStationStatusCode
) As String
public:
static String^ ConvertToString(
    BaseStationStatusCode statusCode
)
static member ConvertToString :
        statusCode : BaseStationStatusCode -> string

Parameters

statusCode
Type: VirtualRadar.Interface.BaseStationBaseStationStatusCode

Return Value

Type: String
See Also

Reference

BaseStationMessageHelper Class
ConvertToString Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToString Method (BaseStationTransmissionType)

BaseStationMessageHelperConvertToString Method (BaseStationTransmissionType)
Converts BaseStationTransmissionType values into strings.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConvertToString(
    BaseStationTransmissionType transmissionType
)
Public Shared Function ConvertToString (
    transmissionType As BaseStationTransmissionType
) As String
public:
static String^ ConvertToString(
    BaseStationTransmissionType transmissionType
)
static member ConvertToString :
        transmissionType : BaseStationTransmissionType -> string

Parameters

transmissionType
Type: VirtualRadar.Interface.BaseStationBaseStationTransmissionType

Return Value

Type: String
See Also

Reference

BaseStationMessageHelper Class
ConvertToString Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageHelper.ConvertToString Method (BaseStationMessageType, Boolean, Boolean)

BaseStationMessageHelperConvertToString Method (BaseStationMessageType, Boolean, Boolean)
Converts from a message type to the expected BaseStation text.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConvertToString(
    BaseStationMessageType messageType,
    bool isMlatSourced = false,
    bool useExtendedFormat = false
)
Public Shared Function ConvertToString (
    messageType As BaseStationMessageType,
    Optional isMlatSourced As Boolean = false,
    Optional useExtendedFormat As Boolean = false
) As String
public:
static String^ ConvertToString(
    BaseStationMessageType messageType,
    bool isMlatSourced = false,
    bool useExtendedFormat = false
)
static member ConvertToString :
        messageType : BaseStationMessageType *
        ?isMlatSourced : bool *
        ?useExtendedFormat : bool
(* Defaults:
        let _isMlatSourced = defaultArg isMlatSourced false
        let _useExtendedFormat = defaultArg useExtendedFormat false
*)
-> string

Parameters

messageType
Type: VirtualRadar.Interface.BaseStationBaseStationMessageType
isMlatSourced (Optional)
Type: SystemBoolean
useExtendedFormat (Optional)
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

BaseStationMessageHelper Class
ConvertToString Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationMessageType Enumeration

BaseStationMessageType Enumeration
An enumeration of the different types of BaseStation message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BaseStationMessageType
Public Enumeration BaseStationMessageType
public enum class BaseStationMessageType
type BaseStationMessageType
Members
Member name | Value | Description
Unknown | 0 | The message could not be translated.
Transmission | 1 | A MSG message.
StatusChange | 2 | A STA message.
NewAircraft | 3 | An AIR message.
NewIdentifier | 4 | An ID message.
UserClicked | 5 | A SEL message.
UserDoubleClicked | 6 | A CLK message.
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationStatusCode Enumeration

BaseStationStatusCode Enumeration
An enumeration of the different status codes that can be transmitted by a StatusChange message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BaseStationStatusCode
Public Enumeration BaseStationStatusCode
public enum class BaseStationStatusCode
type BaseStationStatusCode
Members
Member name | Value | Description
None | 0 | The message is not a StatusChange message.
PositionLost | 1 | The aircraft is no longer transmitting its position.
SignalLost | 2 | The aircraft's signal can no longer be picked up.
Remove | 3 | The aircraft has been removed from BaseStation's display.
Delete | 4 | Don't know what the difference is between this and Remove.
OK | 5 | The aircraft's signal is being picked up.
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage Class

BaseStationSupplementaryMessage Class
Extra information carried on some BaseStationMessages that is gleaned from raw messages.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.BaseStationBaseStationSupplementaryMessage

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationSupplementaryMessage
Public Class BaseStationSupplementaryMessage
public ref class BaseStationSupplementaryMessage
type BaseStationSupplementaryMessage =  class end

The BaseStationSupplementaryMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationSupplementaryMessage | Initializes a new instance of the BaseStationSupplementaryMessage class
Top
Properties
 | Name | Description
Public property | AltitudeIsGeometric | Gets or sets a value indicating whether the Altitude is geometric (true) or barometric (false).
Public property | CallsignIsSuspect | Gets or sets a value indicating that the callsign might be wrong.
Public property | PressureSettingInHg | Gets the barometric pressure setting in inches of mercury.
Public property | PressureSettingMb | Gets or sets the barometric pressure setting in millibars. A value of zero indicates that the pressure setting was outside the bounds supported by the message type.
Public property | SpeedType | Gets or sets a value that qualifies the type of speed being reported in the GroundSpeed property.
Public property | TargetAltitude | Gets or sets the target altitude setting from the aircraft's auto-pilot / FMS etc.
Public property | TargetHeading | Gets or sets the target heading from the aircraft's auto-pilot / FMS etc.
Public property | TrackIsHeading | Gets or sets a value indicating whether the Track value is the aircraft's heading (true) or ground track (false).
Public property | TransponderType | Gets or sets a value indicating that the message carries some indication about the type of transponder carried by the aircraft. Note that this is not set for plain Mode-S messages or ADS-B messages which are identical for all versions of ADS-B - it is only set when the message plainly indicates a particular version of ADS-B.
Public property | VerticalRateIsGeometric | Gets or sets a value indicating whether VerticalRate is from a geometric (true) or barometric (false) source.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The BaseStationMessage class only conveys information from port 30003 feeds of data. Raw Mode-S and ADS-B messages can carry interesting bits of information that are not present on the port 30003 feed. The IRawMessageTranslator creates one of these objects and attaches it to the BaseStationMessage to pass that information on, or to qualify values that have been written to BaseStationMessage that are not in the same units that a port 30003 feed is expected to send.
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage Constructor

BaseStationSupplementaryMessage Constructor
Initializes a new instance of the BaseStationSupplementaryMessage class

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationSupplementaryMessage()
Public Sub New
public:
BaseStationSupplementaryMessage()
new : unit -> BaseStationSupplementaryMessage
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage Properties

BaseStationSupplementaryMessage Properties

The BaseStationSupplementaryMessage type exposes the following members.

Properties
 | Name | Description
Public property | AltitudeIsGeometric | Gets or sets a value indicating whether the Altitude is geometric (true) or barometric (false).
Public property | CallsignIsSuspect | Gets or sets a value indicating that the callsign might be wrong.
Public property | PressureSettingInHg | Gets the barometric pressure setting in inches of mercury.
Public property | PressureSettingMb | Gets or sets the barometric pressure setting in millibars. A value of zero indicates that the pressure setting was outside the bounds supported by the message type.
Public property | SpeedType | Gets or sets a value that qualifies the type of speed being reported in the GroundSpeed property.
Public property | TargetAltitude | Gets or sets the target altitude setting from the aircraft's auto-pilot / FMS etc.
Public property | TargetHeading | Gets or sets the target heading from the aircraft's auto-pilot / FMS etc.
Public property | TrackIsHeading | Gets or sets a value indicating whether the Track value is the aircraft's heading (true) or ground track (false).
Public property | TransponderType | Gets or sets a value indicating that the message carries some indication about the type of transponder carried by the aircraft. Note that this is not set for plain Mode-S messages or ADS-B messages which are identical for all versions of ADS-B - it is only set when the message plainly indicates a particular version of ADS-B.
Public property | VerticalRateIsGeometric | Gets or sets a value indicating whether VerticalRate is from a geometric (true) or barometric (false) source.
Top
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.AltitudeIsGeometric Property

BaseStationSupplementaryMessageAltitudeIsGeometric Property
Gets or sets a value indicating whether the Altitude is geometric (true) or barometric (false).

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> AltitudeIsGeometric { get; set; }
Public Property AltitudeIsGeometric As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> AltitudeIsGeometric {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member AltitudeIsGeometric : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks
If there is no supplementary message then the altitude should be assumed to be barometric.
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.CallsignIsSuspect Property

BaseStationSupplementaryMessageCallsignIsSuspect Property
Gets or sets a value indicating that the callsign might be wrong.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> CallsignIsSuspect { get; set; }
Public Property CallsignIsSuspect As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> CallsignIsSuspect {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member CallsignIsSuspect : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks
This is set when the callsign was extracted from a Comm-B message where the first byte of the payload was 0x20, which *could* indicate that it is a BDS2,0 message. Other Comm-B messages might inadvertently set the same, so the callsign could be garbage. Once the raw message translator sees a callsign from an ADS-B message it will ignore further BDS2,0 callsigns from the same aircraft.
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.PressureSettingInHg Property

BaseStationSupplementaryMessagePressureSettingInHg Property
Gets the barometric pressure setting in inches of mercury.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> PressureSettingInHg { get; }
Public ReadOnly Property PressureSettingInHg As Nullable(Of Single)
    Get
public:
property Nullable<float> PressureSettingInHg {
    Nullable<float> get ();
}
member PressureSettingInHg : Nullable<float32> with get

Property Value

Type: Nullable Single
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.PressureSettingMb Property

BaseStationSupplementaryMessagePressureSettingMb Property
Gets or sets the barometric pressure setting in millibars. A value of zero indicates that the pressure setting was outside the bounds supported by the message type.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> PressureSettingMb { get; set; }
Public Property PressureSettingMb As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> PressureSettingMb {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member PressureSettingMb : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.SpeedType Property

BaseStationSupplementaryMessageSpeedType Property
Gets or sets a value that qualifies the type of speed being reported in the GroundSpeed property.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<SpeedType> SpeedType { get; set; }
Public Property SpeedType As Nullable(Of SpeedType)
    Get
    Set
public:
property Nullable<SpeedType> SpeedType {
    Nullable<SpeedType> get ();
    void set (Nullable<SpeedType> value);
}
member SpeedType : Nullable<SpeedType> with get, set

Property Value

Type: Nullable SpeedType
Remarks
If there is no supplementary message then the GroundSpeed should be assumed to be the ground speed.
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.TargetAltitude Property

BaseStationSupplementaryMessageTargetAltitude Property
Gets or sets the target altitude setting from the aircraft's auto-pilot / FMS etc.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> TargetAltitude { get; set; }
Public Property TargetAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> TargetAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member TargetAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.TargetHeading Property

BaseStationSupplementaryMessageTargetHeading Property
Gets or sets the target heading from the aircraft's auto-pilot / FMS etc.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> TargetHeading { get; set; }
Public Property TargetHeading As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> TargetHeading {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member TargetHeading : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.TrackIsHeading Property

BaseStationSupplementaryMessageTrackIsHeading Property
Gets or sets a value indicating whether the Track value is the aircraft's heading (true) or ground track (false).

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> TrackIsHeading { get; set; }
Public Property TrackIsHeading As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> TrackIsHeading {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member TrackIsHeading : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks
If there is no supplementary message then the Track should be assumed to be the ground track.
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.TransponderType Property

BaseStationSupplementaryMessageTransponderType Property
Gets or sets a value indicating that the message carries some indication about the type of transponder carried by the aircraft. Note that this is not set for plain Mode-S messages or ADS-B messages which are identical for all versions of ADS-B - it is only set when the message plainly indicates a particular version of ADS-B.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TransponderType> TransponderType { get; set; }
Public Property TransponderType As Nullable(Of TransponderType)
    Get
    Set
public:
property Nullable<TransponderType> TransponderType {
    Nullable<TransponderType> get ();
    void set (Nullable<TransponderType> value);
}
member TransponderType : Nullable<TransponderType> with get, set

Property Value

Type: Nullable TransponderType
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage.VerticalRateIsGeometric Property

BaseStationSupplementaryMessageVerticalRateIsGeometric Property
Gets or sets a value indicating whether VerticalRate is from a geometric (true) or barometric (false) source.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> VerticalRateIsGeometric { get; set; }
Public Property VerticalRateIsGeometric As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> VerticalRateIsGeometric {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member VerticalRateIsGeometric : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks
If there is no supplementary message then the vertical rate should be assumed to be from a barometric source.
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationSupplementaryMessage Methods

BaseStationSupplementaryMessage Methods

The BaseStationSupplementaryMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationSupplementaryMessage Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Class

BaseStationTranslatorException Class
Thrown by objects that translate BaseStation text messages into message objects.
Inheritance Hierarchy
SystemObject
SystemException
VirtualRadar.Interface.BaseStationBaseStationTranslatorException

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BaseStationTranslatorException : Exception
<SerializableAttribute>
Public Class BaseStationTranslatorException
    Inherits Exception
[SerializableAttribute]
public ref class BaseStationTranslatorException : public Exception
[<SerializableAttribute>]
type BaseStationTranslatorException =
    class
        inherit Exception
    end

The BaseStationTranslatorException type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationTranslatorException | Creates a new object.
Public method | BaseStationTranslatorException(String) | Creates a new object.
Protected method | BaseStationTranslatorException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | BaseStationTranslatorException(String, Exception) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Constructor

BaseStationTranslatorException Constructor
Overload List
 | Name | Description
Public method | BaseStationTranslatorException | Creates a new object.
Public method | BaseStationTranslatorException(String) | Creates a new object.
Protected method | BaseStationTranslatorException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | BaseStationTranslatorException(String, Exception) | Creates a new object.
Top
See Also

Reference

BaseStationTranslatorException Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Constructor

BaseStationTranslatorException Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationTranslatorException()
Public Sub New
public:
BaseStationTranslatorException()
new : unit -> BaseStationTranslatorException
See Also

Reference

BaseStationTranslatorException Class
BaseStationTranslatorException Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Constructor (String)

BaseStationTranslatorException Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationTranslatorException(
    string message
)
Public Sub New (
    message As String
)
public:
BaseStationTranslatorException(
    String^ message
)
new :
        message : string -> BaseStationTranslatorException

Parameters

message
Type: SystemString
See Also

Reference

BaseStationTranslatorException Class
BaseStationTranslatorException Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Constructor (SerializationInfo, StreamingContext)

BaseStationTranslatorException Constructor (SerializationInfo, StreamingContext)
Creates a new object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected BaseStationTranslatorException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
BaseStationTranslatorException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> BaseStationTranslatorException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BaseStationTranslatorException Class
BaseStationTranslatorException Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Constructor (String, Exception)

BaseStationTranslatorException Constructor (String, Exception)
Creates a new object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationTranslatorException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
BaseStationTranslatorException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> BaseStationTranslatorException

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

BaseStationTranslatorException Class
BaseStationTranslatorException Overload
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Properties

BaseStationTranslatorException Properties

The BaseStationTranslatorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

BaseStationTranslatorException Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Methods

BaseStationTranslatorException Methods

The BaseStationTranslatorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

BaseStationTranslatorException Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationTranslatorException Events

BaseStationTranslatorException Events

The BaseStationTranslatorException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

BaseStationTranslatorException Class
VirtualRadar.Interface.BaseStation Namespace


BaseStationTransmissionType Enumeration

BaseStationTransmissionType Enumeration
An enumeration of the different type of Transmission message types.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BaseStationTransmissionType
Public Enumeration BaseStationTransmissionType
public enum class BaseStationTransmissionType
type BaseStationTransmissionType
Members
Member name | Value | Description
None | 0 | The message is not a Transmission message.
IdentificationAndCategory | 1 | A type 1 message.
SurfacePosition | 2 | A type 2 message.
AirbornePosition | 3 | A type 3 message.
AirborneVelocity | 4 | A type 4 message.
SurveillanceAlt | 5 | A type 5 message.
SurveillanceId | 6 | A type 6 message.
AirToAir | 7 | A type 7 message.
AllCallReply | 8 | A type 8 message.
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList Interface

IBaseStationAircraftList Interface
An aircraft list that uses a feed of BaseStationMessages as its source of information about aircraft.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBaseStationAircraftList : IAircraftList,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface IBaseStationAircraftList
    Inherits IAircraftList, IBackgroundThreadExceptionCatcher, IDisposable
public interface class IBaseStationAircraftList : IAircraftList,
    IBackgroundThreadExceptionCatcher, IDisposable
type IBaseStationAircraftList =
    interface
        interface IAircraftList
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IBaseStationAircraftList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the total number of aircraft currently being tracked. (Inherited from IAircraftList.)
Public property | IsTracking | Gets a value indicating that the aircraft list is tracking aircraft. (Inherited from IAircraftList.)
Public property | Listener | Gets or sets the listener that will pick up messages from a source of data and translate them into BaseStationMessages for us.
Public property | PolarPlotter | Gets or sets the object that's keeping polar plots for us. Can be null if the listener that's feeding this list doesn't support polar plots.
Public property | Source | Gets a value indicating where the aircraft messages are coming from. (Inherited from IAircraftList.)
Public property | StandingDataManager | Gets or sets the object that will look up information about aircraft from the standing data files.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindAircraft | Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Public method | Start | Starts the tracking of aircraft. (Inherited from IAircraftList.)
Public method | Stop | Stops tracking aircraft. (Inherited from IAircraftList.)
Public method | TakeSnapshot | Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Top
Events
 | Name | Description
Public event | CountChanged | Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread. (Inherited from IAircraftList.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | TrackingStateChanged | Raised when the aircraft list is started or stopped. Could be raised from any thread. (Inherited from IAircraftList.)
Top
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList Properties

IBaseStationAircraftList Properties

The IBaseStationAircraftList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the total number of aircraft currently being tracked. (Inherited from IAircraftList.)
Public property | IsTracking | Gets a value indicating that the aircraft list is tracking aircraft. (Inherited from IAircraftList.)
Public property | Listener | Gets or sets the listener that will pick up messages from a source of data and translate them into BaseStationMessages for us.
Public property | PolarPlotter | Gets or sets the object that's keeping polar plots for us. Can be null if the listener that's feeding this list doesn't support polar plots.
Public property | Source | Gets a value indicating where the aircraft messages are coming from. (Inherited from IAircraftList.)
Public property | StandingDataManager | Gets or sets the object that will look up information about aircraft from the standing data files.
Top
See Also

Reference

IBaseStationAircraftList Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList.Listener Property

IBaseStationAircraftListListener Property
Gets or sets the listener that will pick up messages from a source of data and translate them into BaseStationMessages for us.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IListener Listener { get; set; }
Property Listener As IListener
    Get
    Set
property IListener^ Listener {
    IListener^ get ();
    void set (IListener^ value);
}
abstract Listener : IListener with get, set

Property Value

Type: IListener
See Also

Reference

IBaseStationAircraftList Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList.PolarPlotter Property

IBaseStationAircraftListPolarPlotter Property
Gets or sets the object that's keeping polar plots for us. Can be null if the listener that's feeding this list doesn't support polar plots.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPolarPlotter PolarPlotter { get; set; }
Property PolarPlotter As IPolarPlotter
    Get
    Set
property IPolarPlotter^ PolarPlotter {
    IPolarPlotter^ get ();
    void set (IPolarPlotter^ value);
}
abstract PolarPlotter : IPolarPlotter with get, set

Property Value

Type: IPolarPlotter
See Also

Reference

IBaseStationAircraftList Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList.StandingDataManager Property

IBaseStationAircraftListStandingDataManager Property
Gets or sets the object that will look up information about aircraft from the standing data files.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStandingDataManager StandingDataManager { get; set; }
Property StandingDataManager As IStandingDataManager
    Get
    Set
property IStandingDataManager^ StandingDataManager {
    IStandingDataManager^ get ();
    void set (IStandingDataManager^ value);
}
abstract StandingDataManager : IStandingDataManager with get, set

Property Value

Type: IStandingDataManager
See Also

Reference

IBaseStationAircraftList Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList Methods

IBaseStationAircraftList Methods

The IBaseStationAircraftList type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindAircraft | Returns details of the aircraft with the unique ID passed across or null if no such aircraft exists. The aircraft returned is a clone of the orignal, it will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Public method | Start | Starts the tracking of aircraft. (Inherited from IAircraftList.)
Public method | Stop | Stops tracking aircraft. (Inherited from IAircraftList.)
Public method | TakeSnapshot | Returns a list of all of the aircraft currently being tracked. The aircraft objects are clones of the originals held by the list, they will not change as further messages are received from the aircraft. (Inherited from IAircraftList.)
Top
See Also

Reference

IBaseStationAircraftList Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationAircraftList Events

IBaseStationAircraftList Events

The IBaseStationAircraftList type exposes the following members.

Events
 | Name | Description
Public event | CountChanged | Raised when the count of aircraft has changed. This could be raised from any thread, it needn't be raised on a GUI thread. (Inherited from IAircraftList.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | TrackingStateChanged | Raised when the aircraft list is started or stopped. Could be raised from any thread. (Inherited from IAircraftList.)
Top
See Also

Reference

IBaseStationAircraftList Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageCompressor Interface

IBaseStationMessageCompressor Interface
The interface for objects that can compress and decompress BaseStation messages.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBaseStationMessageCompressor
Public Interface IBaseStationMessageCompressor
public interface class IBaseStationMessageCompressor
type IBaseStationMessageCompressor =  interface end

The IBaseStationMessageCompressor type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Compresses a message into a small number of bytes.
Public method | Decompress | Converts an encoded array of bytes into a BaseStation message.
Public method | IsCompressedMessage | Returns true if the byte array passed across appears to be a compressed message.
Top
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageCompressor Methods

IBaseStationMessageCompressor Methods

The IBaseStationMessageCompressor type exposes the following members.

Methods
 | Name | Description
Public method | Compress | Compresses a message into a small number of bytes.
Public method | Decompress | Converts an encoded array of bytes into a BaseStation message.
Public method | IsCompressedMessage | Returns true if the byte array passed across appears to be a compressed message.
Top
See Also

Reference

IBaseStationMessageCompressor Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageCompressor.Compress Method

IBaseStationMessageCompressorCompress Method
Compresses a message into a small number of bytes.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
byte[] Compress(
    BaseStationMessage message
)
Function Compress (
    message As BaseStationMessage
) As Byte()
array<unsigned char>^ Compress(
    BaseStationMessage^ message
)
abstract Compress :
        message : BaseStationMessage -> byte[]

Parameters

message
Type: VirtualRadar.Interface.BaseStationBaseStationMessage

Return Value

Type: Byte
See Also

Reference

IBaseStationMessageCompressor Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageCompressor.Decompress Method

IBaseStationMessageCompressorDecompress Method
Converts an encoded array of bytes into a BaseStation message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationMessage Decompress(
    byte[] bytes
)
Function Decompress (
    bytes As Byte()
) As BaseStationMessage
BaseStationMessage^ Decompress(
    array<unsigned char>^ bytes
)
abstract Decompress :
        bytes : byte[] -> BaseStationMessage

Parameters

bytes
Type: SystemByte

Return Value

Type: BaseStationMessage
See Also

Reference

IBaseStationMessageCompressor Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageCompressor.IsCompressedMessage Method

IBaseStationMessageCompressorIsCompressedMessage Method
Returns true if the byte array passed across appears to be a compressed message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCompressedMessage(
    byte[] bytes
)
Function IsCompressedMessage (
    bytes As Byte()
) As Boolean
bool IsCompressedMessage(
    array<unsigned char>^ bytes
)
abstract IsCompressedMessage :
        bytes : byte[] -> bool

Parameters

bytes
Type: SystemByte

Return Value

Type: Boolean
See Also

Reference

IBaseStationMessageCompressor Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageTranslator Interface

IBaseStationMessageTranslator Interface
An interface for an object that can translate a string transmitted by BaseStation into a formatted message object.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBaseStationMessageTranslator
Public Interface IBaseStationMessageTranslator
public interface class IBaseStationMessageTranslator
type IBaseStationMessageTranslator =  interface end

The IBaseStationMessageTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Translate | Translates from a raw message transmitted from BaseStation into a formatted message.
Top
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageTranslator Methods

IBaseStationMessageTranslator Methods

The IBaseStationMessageTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Translate | Translates from a raw message transmitted from BaseStation into a formatted message.
Top
See Also

Reference

IBaseStationMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IBaseStationMessageTranslator.Translate Method

IBaseStationMessageTranslatorTranslate Method
Translates from a raw message transmitted from BaseStation into a formatted message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationMessage Translate(
    string rawMessage,
    Nullable<int> signalLevel
)
Function Translate (
    rawMessage As String,
    signalLevel As Nullable(Of Integer)
) As BaseStationMessage
BaseStationMessage^ Translate(
    String^ rawMessage,
    Nullable<int> signalLevel
)
abstract Translate :
        rawMessage : string *
        signalLevel : Nullable<int> -> BaseStationMessage

Parameters

rawMessage
Type: SystemString
signalLevel
Type: SystemNullable Int32

Return Value

Type: BaseStationMessage
See Also

Reference

IBaseStationMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator Interface

IRawMessageTranslator Interface
The interface for classes that can translate Mode-S and ADS-B messages into BaseStation messages.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRawMessageTranslator : IDisposable
Public Interface IRawMessageTranslator
    Inherits IDisposable
public interface class IRawMessageTranslator : IDisposable
type IRawMessageTranslator =
    interface
        interface IDisposable
    end

The IRawMessageTranslator type exposes the following members.

Properties
 | Name | Description
Public property | AcceptIcaoInNonPICount | Gets or sets the number of times an ICAO has to be seen in a Mode-S message (regardless of whether it carries PI) before it will be accepted. 0 disables the feature.
Public property | AcceptIcaoInNonPIMilliseconds | Gets or sets the number of milliseconds over which AcceptIcaoInNonPICount will be measured.
Public property | AcceptIcaoInPI0Count | Gets or sets the number of times an ICAO has to be seen in a Mode-S message that carries PI, and where PI = 0, before it will be accepted.
Public property | AcceptIcaoInPI0Milliseconds | Gets or sets the number of milliseconds over which AcceptIcaoInPI0Count will be measured.
Public property | GlobalDecodeAirborneThresholdMilliseconds | Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of airborne position.
Public property | GlobalDecodeFastSurfaceThresholdMilliseconds | Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of surface position of a vehicle travelling faster than 25 knots.
Public property | GlobalDecodeSlowSurfaceThresholdMilliseconds | Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of surface position of a vehicle travelling at or below 25 knots.
Public property | IgnoreInvalidCodeBlockInOtherMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that do not have parity.
Public property | IgnoreInvalidCodeBlockInParityMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that have parity.
Public property | IgnoreMilitaryExtendedSquitter | Gets or sets a value indicating that military extended squitter messages are to be ignored.
Public property | LocalDecodeMaxSpeedAirborne | Gets or sets the number of kilometres over 30 seconds that an airborne vehicle can travel before a local decode is deemed to be inaccurate.
Public property | LocalDecodeMaxSpeedSurface | Gets or sets the number of kilometres / 30 seconds that a vehicle on the ground can travel before a local decode is deemed to be inaccurate.
Public property | LocalDecodeMaxSpeedTransition | Gets or sets the number of kilometres / 30 seconds that a vehicle tranisitioning between airborne and surface positions can travel before a local decode is deemed to be inaccurate.
Public property | ReceiverLocation | Gets or sets the location of the receiver.
Public property | ReceiverRangeKilometres | Gets or sets the maximum range of the receiver in kilometres.
Public property | Statistics | Gets or sets the statistics to update when translating messages.
Public property | SuppressCallsignsFromBds20 | Gets or sets a value indicating that callsigns are not to be used if they came from what appeared to be a Mode-S BDS2,0 message.
Public property | SuppressReceiverRangeCheck | Gets or sets a value indicating that decoded locations that are further away than the receiver can see are still allowed through, disabling part of the ICAO reasonableness tests.
Public property | SuppressTisbDecoding | Gets or sets a value indicating whether TIS-B messages should be ignored.
Public property | TrackingTimeoutSeconds | Gets or sets the number of seconds before aircraft that are no longer being received are forgotten about.
Public property | UseLocalDecodeForInitialPosition | Gets or sets a value indicating that local decoding should be used to determine the initial position of an aircraft instead of global decoding of an odd / even frame.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Translate | Translates the Mode-S message, and the optional ADS-B message carried by it, into a BaseStation message.
Top
Events
 | Name | Description
Public event | PositionReset | Raised during the processing of Translate(DateTime, ModeSMessage, AdsbMessage) when it becomes apparent that a previous position established for an aircraft was wrong and it has been reset.
Top
Remarks
Implementations are not guaranteed to be thread-safe.
See Also

Reference

VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator Properties

IRawMessageTranslator Properties

The IRawMessageTranslator type exposes the following members.

Properties
 | Name | Description
Public property | AcceptIcaoInNonPICount | Gets or sets the number of times an ICAO has to be seen in a Mode-S message (regardless of whether it carries PI) before it will be accepted. 0 disables the feature.
Public property | AcceptIcaoInNonPIMilliseconds | Gets or sets the number of milliseconds over which AcceptIcaoInNonPICount will be measured.
Public property | AcceptIcaoInPI0Count | Gets or sets the number of times an ICAO has to be seen in a Mode-S message that carries PI, and where PI = 0, before it will be accepted.
Public property | AcceptIcaoInPI0Milliseconds | Gets or sets the number of milliseconds over which AcceptIcaoInPI0Count will be measured.
Public property | GlobalDecodeAirborneThresholdMilliseconds | Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of airborne position.
Public property | GlobalDecodeFastSurfaceThresholdMilliseconds | Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of surface position of a vehicle travelling faster than 25 knots.
Public property | GlobalDecodeSlowSurfaceThresholdMilliseconds | Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of surface position of a vehicle travelling at or below 25 knots.
Public property | IgnoreInvalidCodeBlockInOtherMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that do not have parity.
Public property | IgnoreInvalidCodeBlockInParityMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that have parity.
Public property | IgnoreMilitaryExtendedSquitter | Gets or sets a value indicating that military extended squitter messages are to be ignored.
Public property | LocalDecodeMaxSpeedAirborne | Gets or sets the number of kilometres over 30 seconds that an airborne vehicle can travel before a local decode is deemed to be inaccurate.
Public property | LocalDecodeMaxSpeedSurface | Gets or sets the number of kilometres / 30 seconds that a vehicle on the ground can travel before a local decode is deemed to be inaccurate.
Public property | LocalDecodeMaxSpeedTransition | Gets or sets the number of kilometres / 30 seconds that a vehicle tranisitioning between airborne and surface positions can travel before a local decode is deemed to be inaccurate.
Public property | ReceiverLocation | Gets or sets the location of the receiver.
Public property | ReceiverRangeKilometres | Gets or sets the maximum range of the receiver in kilometres.
Public property | Statistics | Gets or sets the statistics to update when translating messages.
Public property | SuppressCallsignsFromBds20 | Gets or sets a value indicating that callsigns are not to be used if they came from what appeared to be a Mode-S BDS2,0 message.
Public property | SuppressReceiverRangeCheck | Gets or sets a value indicating that decoded locations that are further away than the receiver can see are still allowed through, disabling part of the ICAO reasonableness tests.
Public property | SuppressTisbDecoding | Gets or sets a value indicating whether TIS-B messages should be ignored.
Public property | TrackingTimeoutSeconds | Gets or sets the number of seconds before aircraft that are no longer being received are forgotten about.
Public property | UseLocalDecodeForInitialPosition | Gets or sets a value indicating that local decoding should be used to determine the initial position of an aircraft instead of global decoding of an odd / even frame.
Top
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.AcceptIcaoInNonPICount Property

IRawMessageTranslatorAcceptIcaoInNonPICount Property
Gets or sets the number of times an ICAO has to be seen in a Mode-S message (regardless of whether it carries PI) before it will be accepted. 0 disables the feature.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int AcceptIcaoInNonPICount { get; set; }
Property AcceptIcaoInNonPICount As Integer
    Get
    Set
property int AcceptIcaoInNonPICount {
    int get ();
    void set (int value);
}
abstract AcceptIcaoInNonPICount : int with get, set

Property Value

Type: Int32
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.AcceptIcaoInNonPIMilliseconds Property

IRawMessageTranslatorAcceptIcaoInNonPIMilliseconds Property
Gets or sets the number of milliseconds over which AcceptIcaoInNonPICount will be measured.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int AcceptIcaoInNonPIMilliseconds { get; set; }
Property AcceptIcaoInNonPIMilliseconds As Integer
    Get
    Set
property int AcceptIcaoInNonPIMilliseconds {
    int get ();
    void set (int value);
}
abstract AcceptIcaoInNonPIMilliseconds : int with get, set

Property Value

Type: Int32
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.AcceptIcaoInPI0Count Property

IRawMessageTranslatorAcceptIcaoInPI0Count Property
Gets or sets the number of times an ICAO has to be seen in a Mode-S message that carries PI, and where PI = 0, before it will be accepted.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int AcceptIcaoInPI0Count { get; set; }
Property AcceptIcaoInPI0Count As Integer
    Get
    Set
property int AcceptIcaoInPI0Count {
    int get ();
    void set (int value);
}
abstract AcceptIcaoInPI0Count : int with get, set

Property Value

Type: Int32
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.AcceptIcaoInPI0Milliseconds Property

IRawMessageTranslatorAcceptIcaoInPI0Milliseconds Property
Gets or sets the number of milliseconds over which AcceptIcaoInPI0Count will be measured.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int AcceptIcaoInPI0Milliseconds { get; set; }
Property AcceptIcaoInPI0Milliseconds As Integer
    Get
    Set
property int AcceptIcaoInPI0Milliseconds {
    int get ();
    void set (int value);
}
abstract AcceptIcaoInPI0Milliseconds : int with get, set

Property Value

Type: Int32
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.GlobalDecodeAirborneThresholdMilliseconds Property

IRawMessageTranslatorGlobalDecodeAirborneThresholdMilliseconds Property
Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of airborne position.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int GlobalDecodeAirborneThresholdMilliseconds { get; set; }
Property GlobalDecodeAirborneThresholdMilliseconds As Integer
    Get
    Set
property int GlobalDecodeAirborneThresholdMilliseconds {
    int get ();
    void set (int value);
}
abstract GlobalDecodeAirborneThresholdMilliseconds : int with get, set

Property Value

Type: Int32
Remarks
This defaults to 10 seconds, as per the ICAO specs.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.GlobalDecodeFastSurfaceThresholdMilliseconds Property

IRawMessageTranslatorGlobalDecodeFastSurfaceThresholdMilliseconds Property
Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of surface position of a vehicle travelling faster than 25 knots.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int GlobalDecodeFastSurfaceThresholdMilliseconds { get; set; }
Property GlobalDecodeFastSurfaceThresholdMilliseconds As Integer
    Get
    Set
property int GlobalDecodeFastSurfaceThresholdMilliseconds {
    int get ();
    void set (int value);
}
abstract GlobalDecodeFastSurfaceThresholdMilliseconds : int with get, set

Property Value

Type: Int32
Remarks
This defaults to 25 seconds, as per the ICAO specs.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.GlobalDecodeSlowSurfaceThresholdMilliseconds Property

IRawMessageTranslatorGlobalDecodeSlowSurfaceThresholdMilliseconds Property
Gets or sets the number of milliseconds that an odd/even pair of CPR coordinates must be received within to be usable for a global decode of surface position of a vehicle travelling at or below 25 knots.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int GlobalDecodeSlowSurfaceThresholdMilliseconds { get; set; }
Property GlobalDecodeSlowSurfaceThresholdMilliseconds As Integer
    Get
    Set
property int GlobalDecodeSlowSurfaceThresholdMilliseconds {
    int get ();
    void set (int value);
}
abstract GlobalDecodeSlowSurfaceThresholdMilliseconds : int with get, set

Property Value

Type: Int32
Remarks
This defaults to 50 seconds, as per the ICAO specs.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.IgnoreInvalidCodeBlockInOtherMessages Property

IRawMessageTranslatorIgnoreInvalidCodeBlockInOtherMessages Property
Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that do not have parity.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreInvalidCodeBlockInOtherMessages { get; set; }
Property IgnoreInvalidCodeBlockInOtherMessages As Boolean
    Get
    Set
property bool IgnoreInvalidCodeBlockInOtherMessages {
    bool get ();
    void set (bool value);
}
abstract IgnoreInvalidCodeBlockInOtherMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.IgnoreInvalidCodeBlockInParityMessages Property

IRawMessageTranslatorIgnoreInvalidCodeBlockInParityMessages Property
Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that have parity.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreInvalidCodeBlockInParityMessages { get; set; }
Property IgnoreInvalidCodeBlockInParityMessages As Boolean
    Get
    Set
property bool IgnoreInvalidCodeBlockInParityMessages {
    bool get ();
    void set (bool value);
}
abstract IgnoreInvalidCodeBlockInParityMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.IgnoreMilitaryExtendedSquitter Property

IRawMessageTranslatorIgnoreMilitaryExtendedSquitter Property
Gets or sets a value indicating that military extended squitter messages are to be ignored.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreMilitaryExtendedSquitter { get; set; }
Property IgnoreMilitaryExtendedSquitter As Boolean
    Get
    Set
property bool IgnoreMilitaryExtendedSquitter {
    bool get ();
    void set (bool value);
}
abstract IgnoreMilitaryExtendedSquitter : bool with get, set

Property Value

Type: Boolean
Remarks
There is some confusion over whether Mode-S DF19 AF0 messages are to be interpreted in the same manner as DF17 messages. By default the code will process them in the same manner, if this flag is set then they will be ignored completely.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.LocalDecodeMaxSpeedAirborne Property

IRawMessageTranslatorLocalDecodeMaxSpeedAirborne Property
Gets or sets the number of kilometres over 30 seconds that an airborne vehicle can travel before a local decode is deemed to be inaccurate.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double LocalDecodeMaxSpeedAirborne { get; set; }
Property LocalDecodeMaxSpeedAirborne As Double
    Get
    Set
property double LocalDecodeMaxSpeedAirborne {
    double get ();
    void set (double value);
}
abstract LocalDecodeMaxSpeedAirborne : float with get, set

Property Value

Type: Double
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.LocalDecodeMaxSpeedSurface Property

IRawMessageTranslatorLocalDecodeMaxSpeedSurface Property
Gets or sets the number of kilometres / 30 seconds that a vehicle on the ground can travel before a local decode is deemed to be inaccurate.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double LocalDecodeMaxSpeedSurface { get; set; }
Property LocalDecodeMaxSpeedSurface As Double
    Get
    Set
property double LocalDecodeMaxSpeedSurface {
    double get ();
    void set (double value);
}
abstract LocalDecodeMaxSpeedSurface : float with get, set

Property Value

Type: Double
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.LocalDecodeMaxSpeedTransition Property

IRawMessageTranslatorLocalDecodeMaxSpeedTransition Property
Gets or sets the number of kilometres / 30 seconds that a vehicle tranisitioning between airborne and surface positions can travel before a local decode is deemed to be inaccurate.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double LocalDecodeMaxSpeedTransition { get; set; }
Property LocalDecodeMaxSpeedTransition As Double
    Get
    Set
property double LocalDecodeMaxSpeedTransition {
    double get ();
    void set (double value);
}
abstract LocalDecodeMaxSpeedTransition : float with get, set

Property Value

Type: Double
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.ReceiverLocation Property

IRawMessageTranslatorReceiverLocation Property
Gets or sets the location of the receiver.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
GlobalCoordinate ReceiverLocation { get; set; }
Property ReceiverLocation As GlobalCoordinate
    Get
    Set
property GlobalCoordinate^ ReceiverLocation {
    GlobalCoordinate^ get ();
    void set (GlobalCoordinate^ value);
}
abstract ReceiverLocation : GlobalCoordinate with get, set

Property Value

Type: GlobalCoordinate
Remarks
If this is null then the Translate(DateTime, ModeSMessage, AdsbMessage) method cannot determine the location of ground vehicles using local CPR decoding.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.ReceiverRangeKilometres Property

IRawMessageTranslatorReceiverRangeKilometres Property
Gets or sets the maximum range of the receiver in kilometres.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int ReceiverRangeKilometres { get; set; }
Property ReceiverRangeKilometres As Integer
    Get
    Set
property int ReceiverRangeKilometres {
    int get ();
    void set (int value);
}
abstract ReceiverRangeKilometres : int with get, set

Property Value

Type: Int32
Remarks
This is used in the reasonableness test applied to decoded locations. It defaults to 650km, which is ~350 nautical miles. This gives a range ~100 nmi past the horizon for receivers at sea level.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.Statistics Property

IRawMessageTranslatorStatistics Property
Gets or sets the statistics to update when translating messages.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStatistics Statistics { get; set; }
Property Statistics As IStatistics
    Get
    Set
property IStatistics^ Statistics {
    IStatistics^ get ();
    void set (IStatistics^ value);
}
abstract Statistics : IStatistics with get, set

Property Value

Type: IStatistics
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.SuppressCallsignsFromBds20 Property

IRawMessageTranslatorSuppressCallsignsFromBds20 Property
Gets or sets a value indicating that callsigns are not to be used if they came from what appeared to be a Mode-S BDS2,0 message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SuppressCallsignsFromBds20 { get; set; }
Property SuppressCallsignsFromBds20 As Boolean
    Get
    Set
property bool SuppressCallsignsFromBds20 {
    bool get ();
    void set (bool value);
}
abstract SuppressCallsignsFromBds20 : bool with get, set

Property Value

Type: Boolean
Remarks
BDS2,0 messages cannot be accurately identified so callsigns that are extracted from them are potentially inaccurate. Most of the time they're correct so they're allowed by default.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.SuppressReceiverRangeCheck Property

IRawMessageTranslatorSuppressReceiverRangeCheck Property
Gets or sets a value indicating that decoded locations that are further away than the receiver can see are still allowed through, disabling part of the ICAO reasonableness tests.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SuppressReceiverRangeCheck { get; set; }
Property SuppressReceiverRangeCheck As Boolean
    Get
    Set
property bool SuppressReceiverRangeCheck {
    bool get ();
    void set (bool value);
}
abstract SuppressReceiverRangeCheck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.SuppressTisbDecoding Property

IRawMessageTranslatorSuppressTisbDecoding Property
Gets or sets a value indicating whether TIS-B messages should be ignored.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SuppressTisbDecoding { get; set; }
Property SuppressTisbDecoding As Boolean
    Get
    Set
property bool SuppressTisbDecoding {
    bool get ();
    void set (bool value);
}
abstract SuppressTisbDecoding : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.TrackingTimeoutSeconds Property

IRawMessageTranslatorTrackingTimeoutSeconds Property
Gets or sets the number of seconds before aircraft that are no longer being received are forgotten about.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int TrackingTimeoutSeconds { get; set; }
Property TrackingTimeoutSeconds As Integer
    Get
    Set
property int TrackingTimeoutSeconds {
    int get ();
    void set (int value);
}
abstract TrackingTimeoutSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.UseLocalDecodeForInitialPosition Property

IRawMessageTranslatorUseLocalDecodeForInitialPosition Property
Gets or sets a value indicating that local decoding should be used to determine the initial position of an aircraft instead of global decoding of an odd / even frame.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseLocalDecodeForInitialPosition { get; set; }
Property UseLocalDecodeForInitialPosition As Boolean
    Get
    Set
property bool UseLocalDecodeForInitialPosition {
    bool get ();
    void set (bool value);
}
abstract UseLocalDecodeForInitialPosition : bool with get, set

Property Value

Type: Boolean
Remarks
If the aircraft is so far away that the local decode produces the wrong position then it will eventually be picked up by the ICAO reasonableness tests (perform another global decode using CPR values not used in the initial decode and confirm that position corresponds). If it fails that test then the position is reset and the next initial fix is forced to be made using a global decode.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator Methods

IRawMessageTranslator Methods

The IRawMessageTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Translate | Translates the Mode-S message, and the optional ADS-B message carried by it, into a BaseStation message.
Top
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.Translate Method

IRawMessageTranslatorTranslate Method
Translates the Mode-S message, and the optional ADS-B message carried by it, into a BaseStation message.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationMessage Translate(
    DateTime messageReceivedUtc,
    ModeSMessage modeSMessage,
    AdsbMessage adsbMessage
)
Function Translate (
    messageReceivedUtc As DateTime,
    modeSMessage As ModeSMessage,
    adsbMessage As AdsbMessage
) As BaseStationMessage
BaseStationMessage^ Translate(
    DateTime messageReceivedUtc,
    ModeSMessage^ modeSMessage,
    AdsbMessage^ adsbMessage
)
abstract Translate :
        messageReceivedUtc : DateTime *
        modeSMessage : ModeSMessage *
        adsbMessage : AdsbMessage -> BaseStationMessage

Parameters

messageReceivedUtc
Type: SystemDateTime
The time that the message was originally received at UTC.
modeSMessage
Type: VirtualRadar.Interface.ModeSModeSMessage
A Mode-S message.
adsbMessage
Type: VirtualRadar.Interface.AdsbAdsbMessage
Either the ADS-B message carried by the Mode-S message or null.

Return Value

Type: BaseStationMessage
A BaseStation message translated from the Mode-S and ADS-B messages, or null if no translation is possible.
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator Events

IRawMessageTranslator Events

The IRawMessageTranslator type exposes the following members.

Events
 | Name | Description
Public event | PositionReset | Raised during the processing of Translate(DateTime, ModeSMessage, AdsbMessage) when it becomes apparent that a previous position established for an aircraft was wrong and it has been reset.
Top
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


IRawMessageTranslator.PositionReset Event

IRawMessageTranslatorPositionReset Event
Raised during the processing of Translate(DateTime, ModeSMessage, AdsbMessage) when it becomes apparent that a previous position established for an aircraft was wrong and it has been reset.

Namespace: VirtualRadar.Interface.BaseStation
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<string>> PositionReset
Event PositionReset As EventHandler(Of EventArgs(Of String))
 event EventHandler<EventArgs<String^>^>^ PositionReset {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}
abstract PositionReset : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

Value

Type: SystemEventHandler EventArgs String
See Also

Reference

IRawMessageTranslator Interface
VirtualRadar.Interface.BaseStation Namespace


VirtualRadar.Interface.Database Namespace

VirtualRadar.Interface.Database Namespace
The namespace for all of the interfaces and objects associated with handling databases.
Classes
 | Class | Description
Public class | BaseStationAircraft | A simple data transfer object that describes a record from the BaseStation database for an aircraft.
Public class | BaseStationAircraftAndFlightsCount | An extension of the BaseStationAircraft object that includes a count of flights.
Public class | BaseStationDBHistory | An object that holds the content of a record from the DBHistory table in the BaseStation database.
Public class | BaseStationDBInfo | A class that holds information from a single record in the DBInfo table of the BaseStation database.
Public class | BaseStationFlight | A simple data transfer object that describes a record in the BaseStation database for a sighting of an aircraft.
Public class | BaseStationLocation | A class that holds the information held within a single record in the Locations table in the BaseStation database.
Public class | BaseStationSession | A class holding information from a single record from the Session table.
Public class | BaseStationSystemEvents | A class that carries the information from a single record in the SystemEvents table from the BaseStation database.
Public class | LogClient | A record in the log database that holds information about an IP address that has been used to connect to the program.
Public class | LogSession | A record from the log database that describes a single session from an IP address.
Public class | SearchBaseStationCriteria | An object that carries search criteria for use in searching the BaseStation database. All string criteria are case insensitive.
Interfaces
 | Interface | Description
Public interface | IAutoConfigBaseStationDatabase | The interface for singleton objects that hold an instance of IBaseStationDatabase and automatically update its configuration when appropriate.
Public interface | IBaseStationDatabase | The interface for objects that can deal with the BaseStation database file for us.
Public interface | IBaseStationDatabaseProvider | The interface for objects that abstract away the environment for the IBaseStationDatabase implementations.
Public interface | ILogDatabase | The interface to the log database.
Public interface | ILogDatabaseProvider | The interface for providers for the ILogDatabase implementations that abstract away the environment for tests.
Public interface | ITransactionable | The interface that should be implemented by database objects that support transactions.
Remarks

The namespace contains classes for dealing with two databases - the BaseStation database of aircraft and flights (see IBaseStationDatabase and IAutoConfigBaseStationDatabase) and the database that Virtual Radar Server maintains of connection information (see ILogDatabase).


BaseStationAircraft Class

BaseStationAircraft Class
A simple data transfer object that describes a record from the BaseStation database for an aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationAircraft
VirtualRadar.Interface.DatabaseBaseStationAircraftAndFlightsCount

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationAircraft
Public Class BaseStationAircraft
public ref class BaseStationAircraft
type BaseStationAircraft =  class end

The BaseStationAircraft type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationAircraft | Initializes a new instance of the BaseStationAircraft class
Top
Properties
 | Name | Description
Public property | AircraftClass | Gets or sets the aircraft's 'class' - can't find out what this field actually is, guessing it's the species? We derive the species from the model ICAO, this is just for the sake of completeness.
Public property | AircraftID | Gets or sets the unique identifier of the aircraft in the database.
Public property | CofACategory | Gets or sets the certificate of airworthiness category.
Public property | CofAExpiry | Gets or sets the date that the certificate of airworthiness expires.
Public property | Country | Gets or sets the country of the operator.
Public property | CurrentRegDate | Gets or sets the date that the aircraft was registered.
Public property | DeRegDate | Gets or sets the date that the plane was taken off the register.
Public property | Engines | Gets or sets a description of the engines on the aircraft.
Public property | FirstCreated | Gets or sets the date and time (UTC) that the record was created.
Public property | FirstRegDate | Gets or sets the date that the aircraft was first placed onto the register.
Public property | GenericName | Gets or sets the generic name for the type of aircraft.
Public property | ICAOTypeCode | Gets or sets the ICAO 8643 type code for the aircraft.
Public property | InfoUrl | Gets or sets the URL of a web page showing more information about the aircraft.
Public property | Interested | Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears.
Public property | LastModified | Gets or sets the date and time (UTC) that the record was last changed.
Public property | Manufacturer | Gets or sets the full name of the aircraft's manufacturer.
Public property | ModeS | Gets or sets the 24-bit Mode-S identifier assigned to the aircraft.
Public property | ModeSCountry | Gets or sets the country of registration.
Public property | MTOW | Gets or sets the maximum takeoff weight of the aircraft.
Public property | OperatorFlagCode | Gets or sets the ICAO code for the aircraft's operator.
Public property | OwnershipStatus | Gets or sets a value describing whether the aircraft is owned outright, leased etc.
Public property | PictureUrl1 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl2 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl3 | Gets or sets the URL of a picture of the aircraft.
Public property | PopularName | Gets or sets the popular name for the type of aircraft.
Public property | PreviousID | Gets or sets the previous Mode-S ID of the aircraft (I think? not sure, never seen this set).
Public property | RegisteredOwners | Gets or sets the operator of the aircraft.
Public property | Registration | Gets or sets the registration of the aircraft.
Public property | SerialNo | Gets or sets the manufacturers serial number assigned to the aircraft.
Public property | Status | Gets or sets a value describing whether the aircraft is in service, mothballed etc.
Public property | TotalHours | Gets or sets the total hours flown by the aircraft.
Public property | Type | Gets or sets a description of the model of the aircraft.
Public property | UserNotes | Gets or sets the user's notes on the aircraft.
Public property | UserString1 | Gets or sets the user string 1 field.
Public property | UserTag | Gets or sets the user tag on the aircraft.
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured.
Top
Methods
 | Name | Description
Public method | Equals | See base docs. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationAircraft Constructor

BaseStationAircraft Constructor
Initializes a new instance of the BaseStationAircraft class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationAircraft()
Public Sub New
public:
BaseStationAircraft()
new : unit -> BaseStationAircraft
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft Properties

BaseStationAircraft Properties

The BaseStationAircraft type exposes the following members.

Properties
 | Name | Description
Public property | AircraftClass | Gets or sets the aircraft's 'class' - can't find out what this field actually is, guessing it's the species? We derive the species from the model ICAO, this is just for the sake of completeness.
Public property | AircraftID | Gets or sets the unique identifier of the aircraft in the database.
Public property | CofACategory | Gets or sets the certificate of airworthiness category.
Public property | CofAExpiry | Gets or sets the date that the certificate of airworthiness expires.
Public property | Country | Gets or sets the country of the operator.
Public property | CurrentRegDate | Gets or sets the date that the aircraft was registered.
Public property | DeRegDate | Gets or sets the date that the plane was taken off the register.
Public property | Engines | Gets or sets a description of the engines on the aircraft.
Public property | FirstCreated | Gets or sets the date and time (UTC) that the record was created.
Public property | FirstRegDate | Gets or sets the date that the aircraft was first placed onto the register.
Public property | GenericName | Gets or sets the generic name for the type of aircraft.
Public property | ICAOTypeCode | Gets or sets the ICAO 8643 type code for the aircraft.
Public property | InfoUrl | Gets or sets the URL of a web page showing more information about the aircraft.
Public property | Interested | Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears.
Public property | LastModified | Gets or sets the date and time (UTC) that the record was last changed.
Public property | Manufacturer | Gets or sets the full name of the aircraft's manufacturer.
Public property | ModeS | Gets or sets the 24-bit Mode-S identifier assigned to the aircraft.
Public property | ModeSCountry | Gets or sets the country of registration.
Public property | MTOW | Gets or sets the maximum takeoff weight of the aircraft.
Public property | OperatorFlagCode | Gets or sets the ICAO code for the aircraft's operator.
Public property | OwnershipStatus | Gets or sets a value describing whether the aircraft is owned outright, leased etc.
Public property | PictureUrl1 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl2 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl3 | Gets or sets the URL of a picture of the aircraft.
Public property | PopularName | Gets or sets the popular name for the type of aircraft.
Public property | PreviousID | Gets or sets the previous Mode-S ID of the aircraft (I think? not sure, never seen this set).
Public property | RegisteredOwners | Gets or sets the operator of the aircraft.
Public property | Registration | Gets or sets the registration of the aircraft.
Public property | SerialNo | Gets or sets the manufacturers serial number assigned to the aircraft.
Public property | Status | Gets or sets a value describing whether the aircraft is in service, mothballed etc.
Public property | TotalHours | Gets or sets the total hours flown by the aircraft.
Public property | Type | Gets or sets a description of the model of the aircraft.
Public property | UserNotes | Gets or sets the user's notes on the aircraft.
Public property | UserString1 | Gets or sets the user string 1 field.
Public property | UserTag | Gets or sets the user tag on the aircraft.
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured.
Top
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.AircraftClass Property

BaseStationAircraftAircraftClass Property
Gets or sets the aircraft's 'class' - can't find out what this field actually is, guessing it's the species? We derive the species from the model ICAO, this is just for the sake of completeness.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AircraftClass { get; set; }
Public Property AircraftClass As String
    Get
    Set
public:
property String^ AircraftClass {
    String^ get ();
    void set (String^ value);
}
member AircraftClass : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.AircraftID Property

BaseStationAircraftAircraftID Property
Gets or sets the unique identifier of the aircraft in the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AircraftID { get; set; }
Public Property AircraftID As Integer
    Get
    Set
public:
property int AircraftID {
    int get ();
    void set (int value);
}
member AircraftID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.CofACategory Property

BaseStationAircraftCofACategory Property
Gets or sets the certificate of airworthiness category.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CofACategory { get; set; }
Public Property CofACategory As String
    Get
    Set
public:
property String^ CofACategory {
    String^ get ();
    void set (String^ value);
}
member CofACategory : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.CofAExpiry Property

BaseStationAircraftCofAExpiry Property
Gets or sets the date that the certificate of airworthiness expires.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CofAExpiry { get; set; }
Public Property CofAExpiry As String
    Get
    Set
public:
property String^ CofAExpiry {
    String^ get ();
    void set (String^ value);
}
member CofAExpiry : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Country Property

BaseStationAircraftCountry Property
Gets or sets the country of the operator.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
member Country : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.CurrentRegDate Property

BaseStationAircraftCurrentRegDate Property
Gets or sets the date that the aircraft was registered.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentRegDate { get; set; }
Public Property CurrentRegDate As String
    Get
    Set
public:
property String^ CurrentRegDate {
    String^ get ();
    void set (String^ value);
}
member CurrentRegDate : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.DeRegDate Property

BaseStationAircraftDeRegDate Property
Gets or sets the date that the plane was taken off the register.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DeRegDate { get; set; }
Public Property DeRegDate As String
    Get
    Set
public:
property String^ DeRegDate {
    String^ get ();
    void set (String^ value);
}
member DeRegDate : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Engines Property

BaseStationAircraftEngines Property
Gets or sets a description of the engines on the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Engines { get; set; }
Public Property Engines As String
    Get
    Set
public:
property String^ Engines {
    String^ get ();
    void set (String^ value);
}
member Engines : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.FirstCreated Property

BaseStationAircraftFirstCreated Property
Gets or sets the date and time (UTC) that the record was created.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime FirstCreated { get; set; }
Public Property FirstCreated As DateTime
    Get
    Set
public:
property DateTime FirstCreated {
    DateTime get ();
    void set (DateTime value);
}
member FirstCreated : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.FirstRegDate Property

BaseStationAircraftFirstRegDate Property
Gets or sets the date that the aircraft was first placed onto the register.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FirstRegDate { get; set; }
Public Property FirstRegDate As String
    Get
    Set
public:
property String^ FirstRegDate {
    String^ get ();
    void set (String^ value);
}
member FirstRegDate : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.GenericName Property

BaseStationAircraftGenericName Property
Gets or sets the generic name for the type of aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GenericName { get; set; }
Public Property GenericName As String
    Get
    Set
public:
property String^ GenericName {
    String^ get ();
    void set (String^ value);
}
member GenericName : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.ICAOTypeCode Property

BaseStationAircraftICAOTypeCode Property
Gets or sets the ICAO 8643 type code for the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ICAOTypeCode { get; set; }
Public Property ICAOTypeCode As String
    Get
    Set
public:
property String^ ICAOTypeCode {
    String^ get ();
    void set (String^ value);
}
member ICAOTypeCode : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.InfoUrl Property

BaseStationAircraftInfoUrl Property
Gets or sets the URL of a web page showing more information about the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InfoUrl { get; set; }
Public Property InfoUrl As String
    Get
    Set
public:
property String^ InfoUrl {
    String^ get ();
    void set (String^ value);
}
member InfoUrl : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Interested Property

BaseStationAircraftInterested Property
Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Interested { get; set; }
Public Property Interested As Boolean
    Get
    Set
public:
property bool Interested {
    bool get ();
    void set (bool value);
}
member Interested : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.LastModified Property

BaseStationAircraftLastModified Property
Gets or sets the date and time (UTC) that the record was last changed.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastModified { get; set; }
Public Property LastModified As DateTime
    Get
    Set
public:
property DateTime LastModified {
    DateTime get ();
    void set (DateTime value);
}
member LastModified : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Manufacturer Property

BaseStationAircraftManufacturer Property
Gets or sets the full name of the aircraft's manufacturer.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.ModeS Property

BaseStationAircraftModeS Property
Gets or sets the 24-bit Mode-S identifier assigned to the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModeS { get; set; }
Public Property ModeS As String
    Get
    Set
public:
property String^ ModeS {
    String^ get ();
    void set (String^ value);
}
member ModeS : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.ModeSCountry Property

BaseStationAircraftModeSCountry Property
Gets or sets the country of registration.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModeSCountry { get; set; }
Public Property ModeSCountry As String
    Get
    Set
public:
property String^ ModeSCountry {
    String^ get ();
    void set (String^ value);
}
member ModeSCountry : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.MTOW Property

BaseStationAircraftMTOW Property
Gets or sets the maximum takeoff weight of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MTOW { get; set; }
Public Property MTOW As String
    Get
    Set
public:
property String^ MTOW {
    String^ get ();
    void set (String^ value);
}
member MTOW : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.OperatorFlagCode Property

BaseStationAircraftOperatorFlagCode Property
Gets or sets the ICAO code for the aircraft's operator.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorFlagCode { get; set; }
Public Property OperatorFlagCode As String
    Get
    Set
public:
property String^ OperatorFlagCode {
    String^ get ();
    void set (String^ value);
}
member OperatorFlagCode : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.OwnershipStatus Property

BaseStationAircraftOwnershipStatus Property
Gets or sets a value describing whether the aircraft is owned outright, leased etc.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OwnershipStatus { get; set; }
Public Property OwnershipStatus As String
    Get
    Set
public:
property String^ OwnershipStatus {
    String^ get ();
    void set (String^ value);
}
member OwnershipStatus : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.PictureUrl1 Property

BaseStationAircraftPictureUrl1 Property
Gets or sets the URL of a picture of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PictureUrl1 { get; set; }
Public Property PictureUrl1 As String
    Get
    Set
public:
property String^ PictureUrl1 {
    String^ get ();
    void set (String^ value);
}
member PictureUrl1 : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.PictureUrl2 Property

BaseStationAircraftPictureUrl2 Property
Gets or sets the URL of a picture of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PictureUrl2 { get; set; }
Public Property PictureUrl2 As String
    Get
    Set
public:
property String^ PictureUrl2 {
    String^ get ();
    void set (String^ value);
}
member PictureUrl2 : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.PictureUrl3 Property

BaseStationAircraftPictureUrl3 Property
Gets or sets the URL of a picture of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PictureUrl3 { get; set; }
Public Property PictureUrl3 As String
    Get
    Set
public:
property String^ PictureUrl3 {
    String^ get ();
    void set (String^ value);
}
member PictureUrl3 : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.PopularName Property

BaseStationAircraftPopularName Property
Gets or sets the popular name for the type of aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PopularName { get; set; }
Public Property PopularName As String
    Get
    Set
public:
property String^ PopularName {
    String^ get ();
    void set (String^ value);
}
member PopularName : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.PreviousID Property

BaseStationAircraftPreviousID Property
Gets or sets the previous Mode-S ID of the aircraft (I think? not sure, never seen this set).

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreviousID { get; set; }
Public Property PreviousID As String
    Get
    Set
public:
property String^ PreviousID {
    String^ get ();
    void set (String^ value);
}
member PreviousID : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.RegisteredOwners Property

BaseStationAircraftRegisteredOwners Property
Gets or sets the operator of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RegisteredOwners { get; set; }
Public Property RegisteredOwners As String
    Get
    Set
public:
property String^ RegisteredOwners {
    String^ get ();
    void set (String^ value);
}
member RegisteredOwners : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Registration Property

BaseStationAircraftRegistration Property
Gets or sets the registration of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration { get; set; }
Public Property Registration As String
    Get
    Set
public:
property String^ Registration {
    String^ get ();
    void set (String^ value);
}
member Registration : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.SerialNo Property

BaseStationAircraftSerialNo Property
Gets or sets the manufacturers serial number assigned to the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SerialNo { get; set; }
Public Property SerialNo As String
    Get
    Set
public:
property String^ SerialNo {
    String^ get ();
    void set (String^ value);
}
member SerialNo : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Status Property

BaseStationAircraftStatus Property
Gets or sets a value describing whether the aircraft is in service, mothballed etc.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.TotalHours Property

BaseStationAircraftTotalHours Property
Gets or sets the total hours flown by the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TotalHours { get; set; }
Public Property TotalHours As String
    Get
    Set
public:
property String^ TotalHours {
    String^ get ();
    void set (String^ value);
}
member TotalHours : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Type Property

BaseStationAircraftType Property
Gets or sets a description of the model of the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.UserNotes Property

BaseStationAircraftUserNotes Property
Gets or sets the user's notes on the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserNotes { get; set; }
Public Property UserNotes As String
    Get
    Set
public:
property String^ UserNotes {
    String^ get ();
    void set (String^ value);
}
member UserNotes : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.UserString1 Property

BaseStationAircraftUserString1 Property
Gets or sets the user string 1 field.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserString1 { get; set; }
Public Property UserString1 As String
    Get
    Set
public:
property String^ UserString1 {
    String^ get ();
    void set (String^ value);
}
member UserString1 : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.UserTag Property

BaseStationAircraftUserTag Property
Gets or sets the user tag on the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserTag { get; set; }
Public Property UserTag As String
    Get
    Set
public:
property String^ UserTag {
    String^ get ();
    void set (String^ value);
}
member UserTag : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.YearBuilt Property

BaseStationAircraftYearBuilt Property
Gets or sets the year the aircraft was manufactured.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string YearBuilt { get; set; }
Public Property YearBuilt As String
    Get
    Set
public:
property String^ YearBuilt {
    String^ get ();
    void set (String^ value);
}
member YearBuilt : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft Methods

BaseStationAircraft Methods

The BaseStationAircraft type exposes the following members.

Methods
 | Name | Description
Public method | Equals | See base docs. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraft.Equals Method

BaseStationAircraftEquals Method
See base docs.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

BaseStationAircraft Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraftAndFlightsCount Class

BaseStationAircraftAndFlightsCount Class
An extension of the BaseStationAircraft object that includes a count of flights.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationAircraft
VirtualRadar.Interface.DatabaseBaseStationAircraftAndFlightsCount

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationAircraftAndFlightsCount : BaseStationAircraft
Public Class BaseStationAircraftAndFlightsCount
    Inherits BaseStationAircraft
public ref class BaseStationAircraftAndFlightsCount : public BaseStationAircraft
type BaseStationAircraftAndFlightsCount =
    class
        inherit BaseStationAircraft
    end

The BaseStationAircraftAndFlightsCount type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationAircraftAndFlightsCount | Initializes a new instance of the BaseStationAircraftAndFlightsCount class
Top
Properties
 | Name | Description
Public property | AircraftClass | Gets or sets the aircraft's 'class' - can't find out what this field actually is, guessing it's the species? We derive the species from the model ICAO, this is just for the sake of completeness. (Inherited from BaseStationAircraft.)
Public property | AircraftID | Gets or sets the unique identifier of the aircraft in the database. (Inherited from BaseStationAircraft.)
Public property | CofACategory | Gets or sets the certificate of airworthiness category. (Inherited from BaseStationAircraft.)
Public property | CofAExpiry | Gets or sets the date that the certificate of airworthiness expires. (Inherited from BaseStationAircraft.)
Public property | Country | Gets or sets the country of the operator. (Inherited from BaseStationAircraft.)
Public property | CurrentRegDate | Gets or sets the date that the aircraft was registered. (Inherited from BaseStationAircraft.)
Public property | DeRegDate | Gets or sets the date that the plane was taken off the register. (Inherited from BaseStationAircraft.)
Public property | Engines | Gets or sets a description of the engines on the aircraft. (Inherited from BaseStationAircraft.)
Public property | FirstCreated | Gets or sets the date and time (UTC) that the record was created. (Inherited from BaseStationAircraft.)
Public property | FirstRegDate | Gets or sets the date that the aircraft was first placed onto the register. (Inherited from BaseStationAircraft.)
Public property | FlightsCount | Gets or sets the number of flight records for the aircraft.
Public property | GenericName | Gets or sets the generic name for the type of aircraft. (Inherited from BaseStationAircraft.)
Public property | ICAOTypeCode | Gets or sets the ICAO 8643 type code for the aircraft. (Inherited from BaseStationAircraft.)
Public property | InfoUrl | Gets or sets the URL of a web page showing more information about the aircraft. (Inherited from BaseStationAircraft.)
Public property | Interested | Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears. (Inherited from BaseStationAircraft.)
Public property | LastModified | Gets or sets the date and time (UTC) that the record was last changed. (Inherited from BaseStationAircraft.)
Public property | Manufacturer | Gets or sets the full name of the aircraft's manufacturer. (Inherited from BaseStationAircraft.)
Public property | ModeS | Gets or sets the 24-bit Mode-S identifier assigned to the aircraft. (Inherited from BaseStationAircraft.)
Public property | ModeSCountry | Gets or sets the country of registration. (Inherited from BaseStationAircraft.)
Public property | MTOW | Gets or sets the maximum takeoff weight of the aircraft. (Inherited from BaseStationAircraft.)
Public property | OperatorFlagCode | Gets or sets the ICAO code for the aircraft's operator. (Inherited from BaseStationAircraft.)
Public property | OwnershipStatus | Gets or sets a value describing whether the aircraft is owned outright, leased etc. (Inherited from BaseStationAircraft.)
Public property | PictureUrl1 | Gets or sets the URL of a picture of the aircraft. (Inherited from BaseStationAircraft.)
Public property | PictureUrl2 | Gets or sets the URL of a picture of the aircraft. (Inherited from BaseStationAircraft.)
Public property | PictureUrl3 | Gets or sets the URL of a picture of the aircraft. (Inherited from BaseStationAircraft.)
Public property | PopularName | Gets or sets the popular name for the type of aircraft. (Inherited from BaseStationAircraft.)
Public property | PreviousID | Gets or sets the previous Mode-S ID of the aircraft (I think? not sure, never seen this set). (Inherited from BaseStationAircraft.)
Public property | RegisteredOwners | Gets or sets the operator of the aircraft. (Inherited from BaseStationAircraft.)
Public property | Registration | Gets or sets the registration of the aircraft. (Inherited from BaseStationAircraft.)
Public property | SerialNo | Gets or sets the manufacturers serial number assigned to the aircraft. (Inherited from BaseStationAircraft.)
Public property | Status | Gets or sets a value describing whether the aircraft is in service, mothballed etc. (Inherited from BaseStationAircraft.)
Public property | TotalHours | Gets or sets the total hours flown by the aircraft. (Inherited from BaseStationAircraft.)
Public property | Type | Gets or sets a description of the model of the aircraft. (Inherited from BaseStationAircraft.)
Public property | UserNotes | Gets or sets the user's notes on the aircraft. (Inherited from BaseStationAircraft.)
Public property | UserString1 | Gets or sets the user string 1 field. (Inherited from BaseStationAircraft.)
Public property | UserTag | Gets or sets the user tag on the aircraft. (Inherited from BaseStationAircraft.)
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured. (Inherited from BaseStationAircraft.)
Top
Methods
 | Name | Description
Public method | Equals | See base docs. (Inherited from BaseStationAircraft.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationAircraftAndFlightsCount Constructor

BaseStationAircraftAndFlightsCount Constructor
Initializes a new instance of the BaseStationAircraftAndFlightsCount class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationAircraftAndFlightsCount()
Public Sub New
public:
BaseStationAircraftAndFlightsCount()
new : unit -> BaseStationAircraftAndFlightsCount
See Also

Reference

BaseStationAircraftAndFlightsCount Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraftAndFlightsCount Properties

BaseStationAircraftAndFlightsCount Properties

The BaseStationAircraftAndFlightsCount type exposes the following members.

Properties
 | Name | Description
Public property | AircraftClass | Gets or sets the aircraft's 'class' - can't find out what this field actually is, guessing it's the species? We derive the species from the model ICAO, this is just for the sake of completeness. (Inherited from BaseStationAircraft.)
Public property | AircraftID | Gets or sets the unique identifier of the aircraft in the database. (Inherited from BaseStationAircraft.)
Public property | CofACategory | Gets or sets the certificate of airworthiness category. (Inherited from BaseStationAircraft.)
Public property | CofAExpiry | Gets or sets the date that the certificate of airworthiness expires. (Inherited from BaseStationAircraft.)
Public property | Country | Gets or sets the country of the operator. (Inherited from BaseStationAircraft.)
Public property | CurrentRegDate | Gets or sets the date that the aircraft was registered. (Inherited from BaseStationAircraft.)
Public property | DeRegDate | Gets or sets the date that the plane was taken off the register. (Inherited from BaseStationAircraft.)
Public property | Engines | Gets or sets a description of the engines on the aircraft. (Inherited from BaseStationAircraft.)
Public property | FirstCreated | Gets or sets the date and time (UTC) that the record was created. (Inherited from BaseStationAircraft.)
Public property | FirstRegDate | Gets or sets the date that the aircraft was first placed onto the register. (Inherited from BaseStationAircraft.)
Public property | FlightsCount | Gets or sets the number of flight records for the aircraft.
Public property | GenericName | Gets or sets the generic name for the type of aircraft. (Inherited from BaseStationAircraft.)
Public property | ICAOTypeCode | Gets or sets the ICAO 8643 type code for the aircraft. (Inherited from BaseStationAircraft.)
Public property | InfoUrl | Gets or sets the URL of a web page showing more information about the aircraft. (Inherited from BaseStationAircraft.)
Public property | Interested | Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears. (Inherited from BaseStationAircraft.)
Public property | LastModified | Gets or sets the date and time (UTC) that the record was last changed. (Inherited from BaseStationAircraft.)
Public property | Manufacturer | Gets or sets the full name of the aircraft's manufacturer. (Inherited from BaseStationAircraft.)
Public property | ModeS | Gets or sets the 24-bit Mode-S identifier assigned to the aircraft. (Inherited from BaseStationAircraft.)
Public property | ModeSCountry | Gets or sets the country of registration. (Inherited from BaseStationAircraft.)
Public property | MTOW | Gets or sets the maximum takeoff weight of the aircraft. (Inherited from BaseStationAircraft.)
Public property | OperatorFlagCode | Gets or sets the ICAO code for the aircraft's operator. (Inherited from BaseStationAircraft.)
Public property | OwnershipStatus | Gets or sets a value describing whether the aircraft is owned outright, leased etc. (Inherited from BaseStationAircraft.)
Public property | PictureUrl1 | Gets or sets the URL of a picture of the aircraft. (Inherited from BaseStationAircraft.)
Public property | PictureUrl2 | Gets or sets the URL of a picture of the aircraft. (Inherited from BaseStationAircraft.)
Public property | PictureUrl3 | Gets or sets the URL of a picture of the aircraft. (Inherited from BaseStationAircraft.)
Public property | PopularName | Gets or sets the popular name for the type of aircraft. (Inherited from BaseStationAircraft.)
Public property | PreviousID | Gets or sets the previous Mode-S ID of the aircraft (I think? not sure, never seen this set). (Inherited from BaseStationAircraft.)
Public property | RegisteredOwners | Gets or sets the operator of the aircraft. (Inherited from BaseStationAircraft.)
Public property | Registration | Gets or sets the registration of the aircraft. (Inherited from BaseStationAircraft.)
Public property | SerialNo | Gets or sets the manufacturers serial number assigned to the aircraft. (Inherited from BaseStationAircraft.)
Public property | Status | Gets or sets a value describing whether the aircraft is in service, mothballed etc. (Inherited from BaseStationAircraft.)
Public property | TotalHours | Gets or sets the total hours flown by the aircraft. (Inherited from BaseStationAircraft.)
Public property | Type | Gets or sets a description of the model of the aircraft. (Inherited from BaseStationAircraft.)
Public property | UserNotes | Gets or sets the user's notes on the aircraft. (Inherited from BaseStationAircraft.)
Public property | UserString1 | Gets or sets the user string 1 field. (Inherited from BaseStationAircraft.)
Public property | UserTag | Gets or sets the user tag on the aircraft. (Inherited from BaseStationAircraft.)
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured. (Inherited from BaseStationAircraft.)
Top
See Also

Reference

BaseStationAircraftAndFlightsCount Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraftAndFlightsCount.FlightsCount Property

BaseStationAircraftAndFlightsCountFlightsCount Property
Gets or sets the number of flight records for the aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlightsCount { get; set; }
Public Property FlightsCount As Integer
    Get
    Set
public:
property int FlightsCount {
    int get ();
    void set (int value);
}
member FlightsCount : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationAircraftAndFlightsCount Class
VirtualRadar.Interface.Database Namespace


BaseStationAircraftAndFlightsCount Methods

BaseStationAircraftAndFlightsCount Methods

The BaseStationAircraftAndFlightsCount type exposes the following members.

Methods
 | Name | Description
Public method | Equals | See base docs. (Inherited from BaseStationAircraft.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationAircraftAndFlightsCount Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory Class

BaseStationDBHistory Class
An object that holds the content of a record from the DBHistory table in the BaseStation database.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationDBHistory

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationDBHistory
Public Class BaseStationDBHistory
public ref class BaseStationDBHistory
type BaseStationDBHistory =  class end

The BaseStationDBHistory type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationDBHistory | Initializes a new instance of the BaseStationDBHistory class
Top
Properties
 | Name | Description
Public property | DBHistoryID | Gets or sets the unique identifier of the record in the database.
Public property | Description | Gets or sets a mandatory 100 character description of the record.
Public property | IsCreationOfDatabaseByBaseStation | Gets a value indicating that this record describes the creation of the database by the official Kinetic BaseStation application.
Public property | IsCreationOfDatabaseByVirtualRadarServer | Gets a value indicating that this record describes the creation of the database by Virtual Radar Server. Note that in normal operation the database will never be created by VRS, the user must install an optional plugin and explicitly enable it to cause this to happen.
Public property | TimeStamp | Gets or sets the time that the record was created or modified.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationDBHistory Constructor

BaseStationDBHistory Constructor
Initializes a new instance of the BaseStationDBHistory class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationDBHistory()
Public Sub New
public:
BaseStationDBHistory()
new : unit -> BaseStationDBHistory
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory Properties

BaseStationDBHistory Properties

The BaseStationDBHistory type exposes the following members.

Properties
 | Name | Description
Public property | DBHistoryID | Gets or sets the unique identifier of the record in the database.
Public property | Description | Gets or sets a mandatory 100 character description of the record.
Public property | IsCreationOfDatabaseByBaseStation | Gets a value indicating that this record describes the creation of the database by the official Kinetic BaseStation application.
Public property | IsCreationOfDatabaseByVirtualRadarServer | Gets a value indicating that this record describes the creation of the database by Virtual Radar Server. Note that in normal operation the database will never be created by VRS, the user must install an optional plugin and explicitly enable it to cause this to happen.
Public property | TimeStamp | Gets or sets the time that the record was created or modified.
Top
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory.DBHistoryID Property

BaseStationDBHistoryDBHistoryID Property
Gets or sets the unique identifier of the record in the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DBHistoryID { get; set; }
Public Property DBHistoryID As Integer
    Get
    Set
public:
property int DBHistoryID {
    int get ();
    void set (int value);
}
member DBHistoryID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory.Description Property

BaseStationDBHistoryDescription Property
Gets or sets a mandatory 100 character description of the record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory.IsCreationOfDatabaseByBaseStation Property

BaseStationDBHistoryIsCreationOfDatabaseByBaseStation Property
Gets a value indicating that this record describes the creation of the database by the official Kinetic BaseStation application.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreationOfDatabaseByBaseStation { get; }
Public ReadOnly Property IsCreationOfDatabaseByBaseStation As Boolean
    Get
public:
property bool IsCreationOfDatabaseByBaseStation {
    bool get ();
}
member IsCreationOfDatabaseByBaseStation : bool with get

Property Value

Type: Boolean
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory.IsCreationOfDatabaseByVirtualRadarServer Property

BaseStationDBHistoryIsCreationOfDatabaseByVirtualRadarServer Property
Gets a value indicating that this record describes the creation of the database by Virtual Radar Server. Note that in normal operation the database will never be created by VRS, the user must install an optional plugin and explicitly enable it to cause this to happen.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreationOfDatabaseByVirtualRadarServer { get; }
Public ReadOnly Property IsCreationOfDatabaseByVirtualRadarServer As Boolean
    Get
public:
property bool IsCreationOfDatabaseByVirtualRadarServer {
    bool get ();
}
member IsCreationOfDatabaseByVirtualRadarServer : bool with get

Property Value

Type: Boolean
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory.TimeStamp Property

BaseStationDBHistoryTimeStamp Property
Gets or sets the time that the record was created or modified.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime TimeStamp { get; set; }
Public Property TimeStamp As DateTime
    Get
    Set
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}
member TimeStamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBHistory Methods

BaseStationDBHistory Methods

The BaseStationDBHistory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationDBHistory Class
VirtualRadar.Interface.Database Namespace


BaseStationDBInfo Class

BaseStationDBInfo Class
A class that holds information from a single record in the DBInfo table of the BaseStation database.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationDBInfo

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationDBInfo
Public Class BaseStationDBInfo
public ref class BaseStationDBInfo
type BaseStationDBInfo =  class end

The BaseStationDBInfo type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationDBInfo | Initializes a new instance of the BaseStationDBInfo class
Top
Properties
 | Name | Description
Public property | CurrentVersion | Gets or sets the version of the tables and indexes in the database.
Public property | OriginalVersion | Gets or sets the version of the database before it was upgraded to CurrentVersion.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationDBInfo Constructor

BaseStationDBInfo Constructor
Initializes a new instance of the BaseStationDBInfo class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationDBInfo()
Public Sub New
public:
BaseStationDBInfo()
new : unit -> BaseStationDBInfo
See Also

Reference

BaseStationDBInfo Class
VirtualRadar.Interface.Database Namespace


BaseStationDBInfo Properties

BaseStationDBInfo Properties

The BaseStationDBInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentVersion | Gets or sets the version of the tables and indexes in the database.
Public property | OriginalVersion | Gets or sets the version of the database before it was upgraded to CurrentVersion.
Top
See Also

Reference

BaseStationDBInfo Class
VirtualRadar.Interface.Database Namespace


BaseStationDBInfo.CurrentVersion Property

BaseStationDBInfoCurrentVersion Property
Gets or sets the version of the tables and indexes in the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentVersion { get; set; }
Public Property CurrentVersion As Integer
    Get
    Set
public:
property int CurrentVersion {
    int get ();
    void set (int value);
}
member CurrentVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationDBInfo Class
VirtualRadar.Interface.Database Namespace


BaseStationDBInfo.OriginalVersion Property

BaseStationDBInfoOriginalVersion Property
Gets or sets the version of the database before it was upgraded to CurrentVersion.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OriginalVersion { get; set; }
Public Property OriginalVersion As Integer
    Get
    Set
public:
property int OriginalVersion {
    int get ();
    void set (int value);
}
member OriginalVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationDBInfo Class
VirtualRadar.Interface.Database Namespace


BaseStationDBInfo Methods

BaseStationDBInfo Methods

The BaseStationDBInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationDBInfo Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight Class

BaseStationFlight Class
A simple data transfer object that describes a record in the BaseStation database for a sighting of an aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationFlight

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationFlight
Public Class BaseStationFlight
public ref class BaseStationFlight
type BaseStationFlight =  class end

The BaseStationFlight type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationFlight | Initializes a new instance of the BaseStationFlight class
Top
Properties
 | Name | Description
Public property | Aircraft | Gets or sets the aircraft that performed the flight. Some IBaseStationDatabase methods may not read the record, in which case this will be null.
Public property | AircraftID | Gets or sets the identifier of the BaseStationAircraft record that corresponds to this flight.
Public property | Callsign | Gets or sets the callsign that the flight was operating under.
Public property | EndTime | Gets or sets the time of the last message received from the aircraft (UTC).
Public property | FirstAltitude | Gets or sets the altitude (in feet) the aircraft was at when the first message was received.
Public property | FirstGroundSpeed | Gets or sets the ground speed (in knots) the aircraft was travelling at when the first message was received.
Public property | FirstIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when the first message was received.
Public property | FirstLat | Gets or sets the latitude that the aircraft was over when the first message was received.
Public property | FirstLon | Gets or sets the longitude that the aircraft was over when the first message was received.
Public property | FirstSquawk | Gets or sets the squawk code that was being transmitted by the aircraft when the first message was received.
Public property | FirstTrack | Gets or sets the track (degrees from north of heading over the ground) that the aircraft was pointing in when the first message was received.
Public property | FirstVerticalRate | Gets or sets the rate of ascent (+ve) or descent (-ve) in feet per second that the aircraft was undertaking when the first message was received.
Public property | FlightID | Gets or sets the unique identifier of the flight record on the database.
Public property | HadAlert | Gets or sets a value indicating whether the aircraft changed squawk during the flight.
Public property | HadEmergency | Gets or sets a value indicating whether the aircraft transmitted an emergency squawk code during the flight.
Public property | HadSpi | Gets or sets a value indicating whether the pilot pressed the IDENT button during the flight.
Public property | LastAltitude | Gets or sets the altitude (in feet) the aircraft was at when the last message was received.
Public property | LastGroundSpeed | Gets or sets the ground speed (in knots) the aircraft was travelling at when the last message was received.
Public property | LastIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when the last message was received.
Public property | LastLat | Gets or sets the latitude that the aircraft was over when the last message was received.
Public property | LastLon | Gets or sets the longitude that the aircraft was over when the last message was received.
Public property | LastSquawk | Gets or sets the squawk code that was being transmitted by the aircraft when the last message was received.
Public property | LastTrack | Gets or sets the track (degrees from north of heading over the ground) that the aircraft was pointing in when the last message was received.
Public property | LastVerticalRate | Gets or sets the rate of ascent (+ve) or descent (-ve) in feet per second that the aircraft was undertaking when the last message was received.
Public property | NumADSBMsgRec | Gets or sets the total number of ADSB messages received during the flight.
Public property | NumAirCallRepMsgRec | Gets or sets the number of all call report messages received during the flight.
Public property | NumAirPosMsgRec | Gets or sets the number of air position messages received during the flight.
Public property | NumAirToAirMsgRec | Gets or sets the number of air to air messages received during the flight.
Public property | NumAirVelMsgRec | Gets or sets the number of air velocity messages received during the flight.
Public property | NumIDMsgRec | Gets or sets the total number of ID messages received during the flight.
Public property | NumModeSMsgRec | Gets or sets the total number of Mode-S messages received during the flight.
Public property | NumPosMsgRec | Gets or sets the total number of messages which contained a position during the flight.
Public property | NumSurAltMsgRec | Gets or sets the number of surface ALT messages received during the flight.
Public property | NumSurIDMsgRec | Gets or sets the number of surface ID messages received during the flight.
Public property | NumSurPosMsgRec | Gets or sets the number of surface position messages received during the flight.
Public property | SessionID | Gets or sets the unique identifier of the BaseStationSession record that was current when the flight was recorded.
Public property | StartTime | Gets or sets the time that the first message was received from the aircraft (UTC).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationFlight Constructor

BaseStationFlight Constructor
Initializes a new instance of the BaseStationFlight class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationFlight()
Public Sub New
public:
BaseStationFlight()
new : unit -> BaseStationFlight
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight Properties

BaseStationFlight Properties

The BaseStationFlight type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets or sets the aircraft that performed the flight. Some IBaseStationDatabase methods may not read the record, in which case this will be null.
Public property | AircraftID | Gets or sets the identifier of the BaseStationAircraft record that corresponds to this flight.
Public property | Callsign | Gets or sets the callsign that the flight was operating under.
Public property | EndTime | Gets or sets the time of the last message received from the aircraft (UTC).
Public property | FirstAltitude | Gets or sets the altitude (in feet) the aircraft was at when the first message was received.
Public property | FirstGroundSpeed | Gets or sets the ground speed (in knots) the aircraft was travelling at when the first message was received.
Public property | FirstIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when the first message was received.
Public property | FirstLat | Gets or sets the latitude that the aircraft was over when the first message was received.
Public property | FirstLon | Gets or sets the longitude that the aircraft was over when the first message was received.
Public property | FirstSquawk | Gets or sets the squawk code that was being transmitted by the aircraft when the first message was received.
Public property | FirstTrack | Gets or sets the track (degrees from north of heading over the ground) that the aircraft was pointing in when the first message was received.
Public property | FirstVerticalRate | Gets or sets the rate of ascent (+ve) or descent (-ve) in feet per second that the aircraft was undertaking when the first message was received.
Public property | FlightID | Gets or sets the unique identifier of the flight record on the database.
Public property | HadAlert | Gets or sets a value indicating whether the aircraft changed squawk during the flight.
Public property | HadEmergency | Gets or sets a value indicating whether the aircraft transmitted an emergency squawk code during the flight.
Public property | HadSpi | Gets or sets a value indicating whether the pilot pressed the IDENT button during the flight.
Public property | LastAltitude | Gets or sets the altitude (in feet) the aircraft was at when the last message was received.
Public property | LastGroundSpeed | Gets or sets the ground speed (in knots) the aircraft was travelling at when the last message was received.
Public property | LastIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when the last message was received.
Public property | LastLat | Gets or sets the latitude that the aircraft was over when the last message was received.
Public property | LastLon | Gets or sets the longitude that the aircraft was over when the last message was received.
Public property | LastSquawk | Gets or sets the squawk code that was being transmitted by the aircraft when the last message was received.
Public property | LastTrack | Gets or sets the track (degrees from north of heading over the ground) that the aircraft was pointing in when the last message was received.
Public property | LastVerticalRate | Gets or sets the rate of ascent (+ve) or descent (-ve) in feet per second that the aircraft was undertaking when the last message was received.
Public property | NumADSBMsgRec | Gets or sets the total number of ADSB messages received during the flight.
Public property | NumAirCallRepMsgRec | Gets or sets the number of all call report messages received during the flight.
Public property | NumAirPosMsgRec | Gets or sets the number of air position messages received during the flight.
Public property | NumAirToAirMsgRec | Gets or sets the number of air to air messages received during the flight.
Public property | NumAirVelMsgRec | Gets or sets the number of air velocity messages received during the flight.
Public property | NumIDMsgRec | Gets or sets the total number of ID messages received during the flight.
Public property | NumModeSMsgRec | Gets or sets the total number of Mode-S messages received during the flight.
Public property | NumPosMsgRec | Gets or sets the total number of messages which contained a position during the flight.
Public property | NumSurAltMsgRec | Gets or sets the number of surface ALT messages received during the flight.
Public property | NumSurIDMsgRec | Gets or sets the number of surface ID messages received during the flight.
Public property | NumSurPosMsgRec | Gets or sets the number of surface position messages received during the flight.
Public property | SessionID | Gets or sets the unique identifier of the BaseStationSession record that was current when the flight was recorded.
Public property | StartTime | Gets or sets the time that the first message was received from the aircraft (UTC).
Top
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.Aircraft Property

BaseStationFlightAircraft Property
Gets or sets the aircraft that performed the flight. Some IBaseStationDatabase methods may not read the record, in which case this will be null.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationAircraft Aircraft { get; set; }
Public Property Aircraft As BaseStationAircraft
    Get
    Set
public:
property BaseStationAircraft^ Aircraft {
    BaseStationAircraft^ get ();
    void set (BaseStationAircraft^ value);
}
member Aircraft : BaseStationAircraft with get, set

Property Value

Type: BaseStationAircraft
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.AircraftID Property

BaseStationFlightAircraftID Property
Gets or sets the identifier of the BaseStationAircraft record that corresponds to this flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AircraftID { get; set; }
Public Property AircraftID As Integer
    Get
    Set
public:
property int AircraftID {
    int get ();
    void set (int value);
}
member AircraftID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.Callsign Property

BaseStationFlightCallsign Property
Gets or sets the callsign that the flight was operating under.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Callsign { get; set; }
Public Property Callsign As String
    Get
    Set
public:
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
member Callsign : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.EndTime Property

BaseStationFlightEndTime Property
Gets or sets the time of the last message received from the aircraft (UTC).

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> EndTime { get; set; }
Public Property EndTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> EndTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member EndTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstAltitude Property

BaseStationFlightFirstAltitude Property
Gets or sets the altitude (in feet) the aircraft was at when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> FirstAltitude { get; set; }
Public Property FirstAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> FirstAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member FirstAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstGroundSpeed Property

BaseStationFlightFirstGroundSpeed Property
Gets or sets the ground speed (in knots) the aircraft was travelling at when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> FirstGroundSpeed { get; set; }
Public Property FirstGroundSpeed As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> FirstGroundSpeed {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member FirstGroundSpeed : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstIsOnGround Property

BaseStationFlightFirstIsOnGround Property
Gets or sets a value indicating whether the aircraft was on the ground when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FirstIsOnGround { get; set; }
Public Property FirstIsOnGround As Boolean
    Get
    Set
public:
property bool FirstIsOnGround {
    bool get ();
    void set (bool value);
}
member FirstIsOnGround : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstLat Property

BaseStationFlightFirstLat Property
Gets or sets the latitude that the aircraft was over when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> FirstLat { get; set; }
Public Property FirstLat As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> FirstLat {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member FirstLat : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstLon Property

BaseStationFlightFirstLon Property
Gets or sets the longitude that the aircraft was over when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> FirstLon { get; set; }
Public Property FirstLon As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> FirstLon {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member FirstLon : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstSquawk Property

BaseStationFlightFirstSquawk Property
Gets or sets the squawk code that was being transmitted by the aircraft when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> FirstSquawk { get; set; }
Public Property FirstSquawk As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> FirstSquawk {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member FirstSquawk : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstTrack Property

BaseStationFlightFirstTrack Property
Gets or sets the track (degrees from north of heading over the ground) that the aircraft was pointing in when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> FirstTrack { get; set; }
Public Property FirstTrack As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> FirstTrack {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member FirstTrack : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FirstVerticalRate Property

BaseStationFlightFirstVerticalRate Property
Gets or sets the rate of ascent (+ve) or descent (-ve) in feet per second that the aircraft was undertaking when the first message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> FirstVerticalRate { get; set; }
Public Property FirstVerticalRate As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> FirstVerticalRate {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member FirstVerticalRate : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.FlightID Property

BaseStationFlightFlightID Property
Gets or sets the unique identifier of the flight record on the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlightID { get; set; }
Public Property FlightID As Integer
    Get
    Set
public:
property int FlightID {
    int get ();
    void set (int value);
}
member FlightID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.HadAlert Property

BaseStationFlightHadAlert Property
Gets or sets a value indicating whether the aircraft changed squawk during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadAlert { get; set; }
Public Property HadAlert As Boolean
    Get
    Set
public:
property bool HadAlert {
    bool get ();
    void set (bool value);
}
member HadAlert : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.HadEmergency Property

BaseStationFlightHadEmergency Property
Gets or sets a value indicating whether the aircraft transmitted an emergency squawk code during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadEmergency { get; set; }
Public Property HadEmergency As Boolean
    Get
    Set
public:
property bool HadEmergency {
    bool get ();
    void set (bool value);
}
member HadEmergency : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.HadSpi Property

BaseStationFlightHadSpi Property
Gets or sets a value indicating whether the pilot pressed the IDENT button during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadSpi { get; set; }
Public Property HadSpi As Boolean
    Get
    Set
public:
property bool HadSpi {
    bool get ();
    void set (bool value);
}
member HadSpi : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastAltitude Property

BaseStationFlightLastAltitude Property
Gets or sets the altitude (in feet) the aircraft was at when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> LastAltitude { get; set; }
Public Property LastAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> LastAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member LastAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastGroundSpeed Property

BaseStationFlightLastGroundSpeed Property
Gets or sets the ground speed (in knots) the aircraft was travelling at when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> LastGroundSpeed { get; set; }
Public Property LastGroundSpeed As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> LastGroundSpeed {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member LastGroundSpeed : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastIsOnGround Property

BaseStationFlightLastIsOnGround Property
Gets or sets a value indicating whether the aircraft was on the ground when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LastIsOnGround { get; set; }
Public Property LastIsOnGround As Boolean
    Get
    Set
public:
property bool LastIsOnGround {
    bool get ();
    void set (bool value);
}
member LastIsOnGround : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastLat Property

BaseStationFlightLastLat Property
Gets or sets the latitude that the aircraft was over when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> LastLat { get; set; }
Public Property LastLat As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> LastLat {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member LastLat : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastLon Property

BaseStationFlightLastLon Property
Gets or sets the longitude that the aircraft was over when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> LastLon { get; set; }
Public Property LastLon As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> LastLon {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member LastLon : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastSquawk Property

BaseStationFlightLastSquawk Property
Gets or sets the squawk code that was being transmitted by the aircraft when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> LastSquawk { get; set; }
Public Property LastSquawk As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> LastSquawk {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member LastSquawk : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastTrack Property

BaseStationFlightLastTrack Property
Gets or sets the track (degrees from north of heading over the ground) that the aircraft was pointing in when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> LastTrack { get; set; }
Public Property LastTrack As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> LastTrack {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member LastTrack : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.LastVerticalRate Property

BaseStationFlightLastVerticalRate Property
Gets or sets the rate of ascent (+ve) or descent (-ve) in feet per second that the aircraft was undertaking when the last message was received.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> LastVerticalRate { get; set; }
Public Property LastVerticalRate As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> LastVerticalRate {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member LastVerticalRate : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumADSBMsgRec Property

BaseStationFlightNumADSBMsgRec Property
Gets or sets the total number of ADSB messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumADSBMsgRec { get; set; }
Public Property NumADSBMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumADSBMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumADSBMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumAirCallRepMsgRec Property

BaseStationFlightNumAirCallRepMsgRec Property
Gets or sets the number of all call report messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumAirCallRepMsgRec { get; set; }
Public Property NumAirCallRepMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumAirCallRepMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumAirCallRepMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumAirPosMsgRec Property

BaseStationFlightNumAirPosMsgRec Property
Gets or sets the number of air position messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumAirPosMsgRec { get; set; }
Public Property NumAirPosMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumAirPosMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumAirPosMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumAirToAirMsgRec Property

BaseStationFlightNumAirToAirMsgRec Property
Gets or sets the number of air to air messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumAirToAirMsgRec { get; set; }
Public Property NumAirToAirMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumAirToAirMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumAirToAirMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumAirVelMsgRec Property

BaseStationFlightNumAirVelMsgRec Property
Gets or sets the number of air velocity messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumAirVelMsgRec { get; set; }
Public Property NumAirVelMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumAirVelMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumAirVelMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumIDMsgRec Property

BaseStationFlightNumIDMsgRec Property
Gets or sets the total number of ID messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumIDMsgRec { get; set; }
Public Property NumIDMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumIDMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumIDMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumModeSMsgRec Property

BaseStationFlightNumModeSMsgRec Property
Gets or sets the total number of Mode-S messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumModeSMsgRec { get; set; }
Public Property NumModeSMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumModeSMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumModeSMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumPosMsgRec Property

BaseStationFlightNumPosMsgRec Property
Gets or sets the total number of messages which contained a position during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumPosMsgRec { get; set; }
Public Property NumPosMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumPosMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumPosMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumSurAltMsgRec Property

BaseStationFlightNumSurAltMsgRec Property
Gets or sets the number of surface ALT messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumSurAltMsgRec { get; set; }
Public Property NumSurAltMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumSurAltMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumSurAltMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumSurIDMsgRec Property

BaseStationFlightNumSurIDMsgRec Property
Gets or sets the number of surface ID messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumSurIDMsgRec { get; set; }
Public Property NumSurIDMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumSurIDMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumSurIDMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.NumSurPosMsgRec Property

BaseStationFlightNumSurPosMsgRec Property
Gets or sets the number of surface position messages received during the flight.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NumSurPosMsgRec { get; set; }
Public Property NumSurPosMsgRec As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NumSurPosMsgRec {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NumSurPosMsgRec : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.SessionID Property

BaseStationFlightSessionID Property
Gets or sets the unique identifier of the BaseStationSession record that was current when the flight was recorded.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SessionID { get; set; }
Public Property SessionID As Integer
    Get
    Set
public:
property int SessionID {
    int get ();
    void set (int value);
}
member SessionID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight.StartTime Property

BaseStationFlightStartTime Property
Gets or sets the time that the first message was received from the aircraft (UTC).

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationFlight Methods

BaseStationFlight Methods

The BaseStationFlight type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationFlight Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation Class

BaseStationLocation Class
A class that holds the information held within a single record in the Locations table in the BaseStation database.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationLocation

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationLocation
Public Class BaseStationLocation
public ref class BaseStationLocation
type BaseStationLocation =  class end

The BaseStationLocation type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationLocation | Initializes a new instance of the BaseStationLocation class
Top
Properties
 | Name | Description
Public property | Altitude | Gets or sets the altitude in feet that the
Public property | Latitude | Gets or sets the latitude part of the user's location.
Public property | LocationID | Gets or sets the unique identifier of the record.
Public property | LocationName | Gets or sets the name of the location assigned by the user. This cannot be null and cannot be longer than 20 characters.
Public property | Longitude | Gets or sets the longitude part of the user's location.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationLocation Constructor

BaseStationLocation Constructor
Initializes a new instance of the BaseStationLocation class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationLocation()
Public Sub New
public:
BaseStationLocation()
new : unit -> BaseStationLocation
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation Properties

BaseStationLocation Properties

The BaseStationLocation type exposes the following members.

Properties
 | Name | Description
Public property | Altitude | Gets or sets the altitude in feet that the
Public property | Latitude | Gets or sets the latitude part of the user's location.
Public property | LocationID | Gets or sets the unique identifier of the record.
Public property | LocationName | Gets or sets the name of the location assigned by the user. This cannot be null and cannot be longer than 20 characters.
Public property | Longitude | Gets or sets the longitude part of the user's location.
Top
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation.Altitude Property

BaseStationLocationAltitude Property
Gets or sets the altitude in feet that the

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Altitude { get; set; }
Public Property Altitude As Double
    Get
    Set
public:
property double Altitude {
    double get ();
    void set (double value);
}
member Altitude : float with get, set

Property Value

Type: Double
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation.Latitude Property

BaseStationLocationLatitude Property
Gets or sets the latitude part of the user's location.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Type: Double
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation.LocationID Property

BaseStationLocationLocationID Property
Gets or sets the unique identifier of the record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocationID { get; set; }
Public Property LocationID As Integer
    Get
    Set
public:
property int LocationID {
    int get ();
    void set (int value);
}
member LocationID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation.LocationName Property

BaseStationLocationLocationName Property
Gets or sets the name of the location assigned by the user. This cannot be null and cannot be longer than 20 characters.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LocationName { get; set; }
Public Property LocationName As String
    Get
    Set
public:
property String^ LocationName {
    String^ get ();
    void set (String^ value);
}
member LocationName : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation.Longitude Property

BaseStationLocationLongitude Property
Gets or sets the longitude part of the user's location.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Type: Double
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationLocation Methods

BaseStationLocation Methods

The BaseStationLocation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationLocation Class
VirtualRadar.Interface.Database Namespace


BaseStationSession Class

BaseStationSession Class
A class holding information from a single record from the Session table.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationSession

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationSession
Public Class BaseStationSession
public ref class BaseStationSession
type BaseStationSession =  class end

The BaseStationSession type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationSession | Initializes a new instance of the BaseStationSession class
Top
Properties
 | Name | Description
Public property | EndTime | Gets or sets the time at UTC when the session ended.
Public property | LocationID | Gets or sets the identifier of the record describing the location at the time the session was running.
Public property | SessionID | Gets or sets the unique identifier of the session record.
Public property | StartTime | Gets or sets the time at UTC when the session began.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationSession Constructor

BaseStationSession Constructor
Initializes a new instance of the BaseStationSession class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationSession()
Public Sub New
public:
BaseStationSession()
new : unit -> BaseStationSession
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSession Properties

BaseStationSession Properties

The BaseStationSession type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Gets or sets the time at UTC when the session ended.
Public property | LocationID | Gets or sets the identifier of the record describing the location at the time the session was running.
Public property | SessionID | Gets or sets the unique identifier of the session record.
Public property | StartTime | Gets or sets the time at UTC when the session began.
Top
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSession.EndTime Property

BaseStationSessionEndTime Property
Gets or sets the time at UTC when the session ended.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> EndTime { get; set; }
Public Property EndTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> EndTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member EndTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSession.LocationID Property

BaseStationSessionLocationID Property
Gets or sets the identifier of the record describing the location at the time the session was running.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocationID { get; set; }
Public Property LocationID As Integer
    Get
    Set
public:
property int LocationID {
    int get ();
    void set (int value);
}
member LocationID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSession.SessionID Property

BaseStationSessionSessionID Property
Gets or sets the unique identifier of the session record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SessionID { get; set; }
Public Property SessionID As Integer
    Get
    Set
public:
property int SessionID {
    int get ();
    void set (int value);
}
member SessionID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSession.StartTime Property

BaseStationSessionStartTime Property
Gets or sets the time at UTC when the session began.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSession Methods

BaseStationSession Methods

The BaseStationSession type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationSession Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents Class

BaseStationSystemEvents Class
A class that carries the information from a single record in the SystemEvents table from the BaseStation database.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseBaseStationSystemEvents

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationSystemEvents
Public Class BaseStationSystemEvents
public ref class BaseStationSystemEvents
type BaseStationSystemEvents =  class end

The BaseStationSystemEvents type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationSystemEvents | Initializes a new instance of the BaseStationSystemEvents class
Top
Properties
 | Name | Description
Public property | App | Gets or sets the name of the application that wrote the record. Cannot be null, maximum of 15 characters.
Public property | Msg | Gets or sets a description of the system event. Cannot be null, maximum of 100 characters.
Public property | SystemEventsID | Gets or sets the unique identifier of the record in the database.
Public property | TimeStamp | Gets or sets the UTC time that the record was written.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents Constructor

BaseStationSystemEvents Constructor
Initializes a new instance of the BaseStationSystemEvents class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationSystemEvents()
Public Sub New
public:
BaseStationSystemEvents()
new : unit -> BaseStationSystemEvents
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents Properties

BaseStationSystemEvents Properties

The BaseStationSystemEvents type exposes the following members.

Properties
 | Name | Description
Public property | App | Gets or sets the name of the application that wrote the record. Cannot be null, maximum of 15 characters.
Public property | Msg | Gets or sets a description of the system event. Cannot be null, maximum of 100 characters.
Public property | SystemEventsID | Gets or sets the unique identifier of the record in the database.
Public property | TimeStamp | Gets or sets the UTC time that the record was written.
Top
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents.App Property

BaseStationSystemEventsApp Property
Gets or sets the name of the application that wrote the record. Cannot be null, maximum of 15 characters.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string App { get; set; }
Public Property App As String
    Get
    Set
public:
property String^ App {
    String^ get ();
    void set (String^ value);
}
member App : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents.Msg Property

BaseStationSystemEventsMsg Property
Gets or sets a description of the system event. Cannot be null, maximum of 100 characters.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Msg { get; set; }
Public Property Msg As String
    Get
    Set
public:
property String^ Msg {
    String^ get ();
    void set (String^ value);
}
member Msg : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents.SystemEventsID Property

BaseStationSystemEventsSystemEventsID Property
Gets or sets the unique identifier of the record in the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SystemEventsID { get; set; }
Public Property SystemEventsID As Integer
    Get
    Set
public:
property int SystemEventsID {
    int get ();
    void set (int value);
}
member SystemEventsID : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents.TimeStamp Property

BaseStationSystemEventsTimeStamp Property
Gets or sets the UTC time that the record was written.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime TimeStamp { get; set; }
Public Property TimeStamp As DateTime
    Get
    Set
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}
member TimeStamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


BaseStationSystemEvents Methods

BaseStationSystemEvents Methods

The BaseStationSystemEvents type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationSystemEvents Class
VirtualRadar.Interface.Database Namespace


IAutoConfigBaseStationDatabase Interface

IAutoConfigBaseStationDatabase Interface
The interface for singleton objects that hold an instance of IBaseStationDatabase and automatically update its configuration when appropriate.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAutoConfigBaseStationDatabase : ISingleton<IAutoConfigBaseStationDatabase>,
    IDisposable
Public Interface IAutoConfigBaseStationDatabase
    Inherits ISingleton(Of IAutoConfigBaseStationDatabase), IDisposable
public interface class IAutoConfigBaseStationDatabase : ISingleton<IAutoConfigBaseStationDatabase^>,
    IDisposable
type IAutoConfigBaseStationDatabase =
    interface
        interface ISingleton<IAutoConfigBaseStationDatabase>
        interface IDisposable
    end

The IAutoConfigBaseStationDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Database | Gets the BaseStation database that this object is updating with configuration changes.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the Database property and hooks events to pick up changes in configuration.
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


IAutoConfigBaseStationDatabase Properties

IAutoConfigBaseStationDatabase Properties

The IAutoConfigBaseStationDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Database | Gets the BaseStation database that this object is updating with configuration changes.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IAutoConfigBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IAutoConfigBaseStationDatabase.Database Property

IAutoConfigBaseStationDatabaseDatabase Property
Gets the BaseStation database that this object is updating with configuration changes.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IBaseStationDatabase Database { get; }
ReadOnly Property Database As IBaseStationDatabase
    Get
property IBaseStationDatabase^ Database {
    IBaseStationDatabase^ get ();
}
abstract Database : IBaseStationDatabase with get

Property Value

Type: IBaseStationDatabase
See Also

Reference

IAutoConfigBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IAutoConfigBaseStationDatabase Methods

IAutoConfigBaseStationDatabase Methods

The IAutoConfigBaseStationDatabase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the Database property and hooks events to pick up changes in configuration.
Top
See Also

Reference

IAutoConfigBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IAutoConfigBaseStationDatabase.Initialise Method

IAutoConfigBaseStationDatabaseInitialise Method
Initialises the Database property and hooks events to pick up changes in configuration.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IAutoConfigBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase Interface

IBaseStationDatabase Interface
The interface for objects that can deal with the BaseStation database file for us.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBaseStationDatabase : ITransactionable,
    IDisposable
Public Interface IBaseStationDatabase
    Inherits ITransactionable, IDisposable
public interface class IBaseStationDatabase : ITransactionable,
    IDisposable
type IBaseStationDatabase =
    interface
        interface ITransactionable
        interface IDisposable
    end

The IBaseStationDatabase type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets or sets the full path and filename of the database. Changing the filename causes the current connection to close, the next operation on the database causes it to open a new connection as per usual.
Public property | IsConnected | Gets a value indicating that there is an open connection to the database.
Public property | LogFileName | Gets or sets the full path and filename of the log.
Public property | MaxParameters | Gets the maximum number of parameters that can be passed to the underlying database engine. Note that calls that accept a variable number of parameters will automatically handle splitting the call into multiple calls on the database unless otherwise noted.
Public property | Provider | Gets or sets the object that abstracts away the environment to help when testing.
Public property | WriteSupportEnabled | Gets or sets a flag indicating that methods that can create or modify the database are enabled. By default this setting is disabled. Changing this setting closes the current connection, the next call to access the database will reopen it.
Top
Methods
 | Name | Description
Public method | AttemptAutoFix | Takes an exception that was thrown from TestConnection and attempts to correct the error that was encountered. If it's likely to have succeeded then returns true.
Public method | CreateDatabaseIfMissing | If the database file is missing or entirely empty then this method creates the file and pre-populates the tables with roughly the same records that BaseStation prepopulates a new database with.
Public method | DeleteAircraft | Deletes an existing aircraft record.
Public method | DeleteFlight | Deletes an existing flight record. Ignores the aircraft record attached to the flight (if any).
Public method | DeleteLocation | Deletes an existing location record.
Public method | DeleteSession | Deletes the record for a session. This automatically deletes all flights associated with the session.
Public method | DeleteSystemEvent | Deletes an existing SystemEvents record.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndTransaction | Ends a transaction. Ending a nested transaction has no effect. (Inherited from ITransactionable.)
Public method | GetAircraftByCode | Returns the first aircraft with the ICAO24 code passed across.
Public method | GetAircraftById | Retrieves an aircraft record by its identifier.
Public method | GetAircraftByRegistration | Returns the first aircraft with the registration passed across.
Public method | GetAllAircraft | Returns every aircraft record in the database.
Public method | GetCountOfFlights | Returns the number of flights that match the criteria passed across.
Public method | GetCountOfFlightsForAircraft | Returns the number of flight records that match the criteria passed across.
Public method | GetDatabaseHistory | Returns all of the records from BaseStation's DBHistory table.
Public method | GetDatabaseVersion | Returns the single DBInfo record in BaseStation's DBInfo table. Note that this has no key.
Public method | GetFlightById | Retrieves a flight record from the database by its ID number. This does not read the associated aircraft record.
Public method | GetFlights | Returns all flights, or a subset of all flights, that match the criteria passed across.
Public method | GetFlightsForAircraft | Returns a list of every flight, or a subset of every flight, that matches the criteria passed across.
Public method | GetLocations | Returns all of the locations from BaseStation's Locations table.
Public method | GetManyAircraftAndFlightsCountByCode | Returns aircraft records and counts of flights for many ICAO24 codes simultaneously.
Public method | GetManyAircraftByCode | Returns aircraft records for many ICAO24 codes simultaneously.
Public method | GetOrInsertAircraftByCode | Fetches an aircraft by its ICAO code. If there is no record for the aircraft then the createNewAircraftFunc method is called to build a new record, and that is inserted.
Public method | GetSessions | Returns all of the sessions from BaseStation's Sessions table.
Public method | GetSystemEvents | Returns the entire content of the SystemEvents table.
Public method | InsertAircraft | Inserts a new aircraft record and fills AircraftID with the identifier of the record.
Public method | InsertFlight | Inserts a new flight record and assigns the unique identifier of the new record to the FlightID property. The AircraftID property must be filled with the identifier of an existing aircraft record.
Public method | InsertLocation | Inserts a new record in the database for the location passed across and sets the LocationID to the identifier of the new record.
Public method | InsertSession | Inserts a record in the Sessions table, setting SessionID to the identifier of the new record.
Public method | InsertSystemEvent | Inserts a new SystemEvents record and sets the SystemEventsID to the identifier of the new record.
Public method | RecordManyMissingAircraft | Does the same as RecordMissingAircraft(String) but for many ICAOs simultaneously.
Public method | RecordMissingAircraft | Records a missing aircraft record.
Public method | RollbackTransaction | Rolls back a transaction. Rolling back a nested transaction rolls back all transactions. (Inherited from ITransactionable.)
Public method | StartTransaction | Begins a new transaction. Nesting transactions is allowed. (Inherited from ITransactionable.)
Public method | TestConnection | Returns true if a connection could be made to FileName, false if it could not. If it could be made then the connection is left open.
Public method | UpdateAircraft | Updates an existing aircraft record.
Public method | UpdateAircraftModeSCountry | Updates the Mode-S country for an aircraft.
Public method | UpdateFlight | Updates an existing flight record. Ignores the aircraft record attached to the flight (if any).
Public method | UpdateLocation | Updates an existing location record.
Public method | UpdateSession | Updates the record for a session.
Public method | UpdateSystemEvent | Updates an existing SystemEvents record.
Public method | UpsertAircraftByCode | Creates or updates an aircraft record.
Public method | UpsertManyAircraftByCodes | Does the same as UpsertAircraftByCode(String, FuncBaseStationAircraft, BaseStationAircraft) but for many ICAOs.
Top
Events
 | Name | Description
Public event | AircraftUpdated | Raised after an aircraft has been updated.
Public event | FileNameChanged | Raised after FileName has changed as the result of a configuration change.
Public event | FileNameChanging | Raised before FileName is changed as the result of a configuration change.
Top
Remarks

The BaseStation database is an SQLite file that Kinetic's BaseStation application creates and maintains. By default the object implementing the interface is in read-only mode, it will not make any changes to the database. In this mode attempts to use the insert / update or delete methods should throw an InvalidOperation exception. If the program sets WriteSupportEnabled then the insert / update and delete methods should allow writes to the database.

Virtual Radar Server never sets WriteSupportEnabled, it will never write to the database. The write methods are only there for the use of plugins.

See Also

Reference

VirtualRadar.Interface.Database Namespace


IBaseStationDatabase Properties

IBaseStationDatabase Properties

The IBaseStationDatabase type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets or sets the full path and filename of the database. Changing the filename causes the current connection to close, the next operation on the database causes it to open a new connection as per usual.
Public property | IsConnected | Gets a value indicating that there is an open connection to the database.
Public property | LogFileName | Gets or sets the full path and filename of the log.
Public property | MaxParameters | Gets the maximum number of parameters that can be passed to the underlying database engine. Note that calls that accept a variable number of parameters will automatically handle splitting the call into multiple calls on the database unless otherwise noted.
Public property | Provider | Gets or sets the object that abstracts away the environment to help when testing.
Public property | WriteSupportEnabled | Gets or sets a flag indicating that methods that can create or modify the database are enabled. By default this setting is disabled. Changing this setting closes the current connection, the next call to access the database will reopen it.
Top
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.FileName Property

IBaseStationDatabaseFileName Property
Gets or sets the full path and filename of the database. Changing the filename causes the current connection to close, the next operation on the database causes it to open a new connection as per usual.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.IsConnected Property

IBaseStationDatabaseIsConnected Property
Gets a value indicating that there is an open connection to the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsConnected { get; }
ReadOnly Property IsConnected As Boolean
    Get
property bool IsConnected {
    bool get ();
}
abstract IsConnected : bool with get

Property Value

Type: Boolean
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.LogFileName Property

IBaseStationDatabaseLogFileName Property
Gets or sets the full path and filename of the log.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string LogFileName { get; set; }
Property LogFileName As String
    Get
    Set
property String^ LogFileName {
    String^ get ();
    void set (String^ value);
}
abstract LogFileName : string with get, set

Property Value

Type: String
Remarks
This is not used by the application as it has an impact on performance but some plugins may use it to trace database calls. The implementation may leave the file open and locked while the object is alive. Logging may not be supported by all implementations.
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.MaxParameters Property

IBaseStationDatabaseMaxParameters Property
Gets the maximum number of parameters that can be passed to the underlying database engine. Note that calls that accept a variable number of parameters will automatically handle splitting the call into multiple calls on the database unless otherwise noted.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxParameters { get; }
ReadOnly Property MaxParameters As Integer
    Get
property int MaxParameters {
    int get ();
}
abstract MaxParameters : int with get

Property Value

Type: Int32
Remarks
Ideally this would be read from the database engine but, in the case of SQLite, it's not so easy to get at the maximum number of parameters using just the ADO.NET provider. So this could be a bit arbitrary.
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.Provider Property

IBaseStationDatabaseProvider Property
Gets or sets the object that abstracts away the environment to help when testing.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IBaseStationDatabaseProvider Provider { get; set; }
Property Provider As IBaseStationDatabaseProvider
    Get
    Set
property IBaseStationDatabaseProvider^ Provider {
    IBaseStationDatabaseProvider^ get ();
    void set (IBaseStationDatabaseProvider^ value);
}
abstract Provider : IBaseStationDatabaseProvider with get, set

Property Value

Type: IBaseStationDatabaseProvider
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.WriteSupportEnabled Property

IBaseStationDatabaseWriteSupportEnabled Property
Gets or sets a flag indicating that methods that can create or modify the database are enabled. By default this setting is disabled. Changing this setting closes the current connection, the next call to access the database will reopen it.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WriteSupportEnabled { get; set; }
Property WriteSupportEnabled As Boolean
    Get
    Set
property bool WriteSupportEnabled {
    bool get ();
    void set (bool value);
}
abstract WriteSupportEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase Methods

IBaseStationDatabase Methods

The IBaseStationDatabase type exposes the following members.

Methods
 | Name | Description
Public method | AttemptAutoFix | Takes an exception that was thrown from TestConnection and attempts to correct the error that was encountered. If it's likely to have succeeded then returns true.
Public method | CreateDatabaseIfMissing | If the database file is missing or entirely empty then this method creates the file and pre-populates the tables with roughly the same records that BaseStation prepopulates a new database with.
Public method | DeleteAircraft | Deletes an existing aircraft record.
Public method | DeleteFlight | Deletes an existing flight record. Ignores the aircraft record attached to the flight (if any).
Public method | DeleteLocation | Deletes an existing location record.
Public method | DeleteSession | Deletes the record for a session. This automatically deletes all flights associated with the session.
Public method | DeleteSystemEvent | Deletes an existing SystemEvents record.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndTransaction | Ends a transaction. Ending a nested transaction has no effect. (Inherited from ITransactionable.)
Public method | GetAircraftByCode | Returns the first aircraft with the ICAO24 code passed across.
Public method | GetAircraftById | Retrieves an aircraft record by its identifier.
Public method | GetAircraftByRegistration | Returns the first aircraft with the registration passed across.
Public method | GetAllAircraft | Returns every aircraft record in the database.
Public method | GetCountOfFlights | Returns the number of flights that match the criteria passed across.
Public method | GetCountOfFlightsForAircraft | Returns the number of flight records that match the criteria passed across.
Public method | GetDatabaseHistory | Returns all of the records from BaseStation's DBHistory table.
Public method | GetDatabaseVersion | Returns the single DBInfo record in BaseStation's DBInfo table. Note that this has no key.
Public method | GetFlightById | Retrieves a flight record from the database by its ID number. This does not read the associated aircraft record.
Public method | GetFlights | Returns all flights, or a subset of all flights, that match the criteria passed across.
Public method | GetFlightsForAircraft | Returns a list of every flight, or a subset of every flight, that matches the criteria passed across.
Public method | GetLocations | Returns all of the locations from BaseStation's Locations table.
Public method | GetManyAircraftAndFlightsCountByCode | Returns aircraft records and counts of flights for many ICAO24 codes simultaneously.
Public method | GetManyAircraftByCode | Returns aircraft records for many ICAO24 codes simultaneously.
Public method | GetOrInsertAircraftByCode | Fetches an aircraft by its ICAO code. If there is no record for the aircraft then the createNewAircraftFunc method is called to build a new record, and that is inserted.
Public method | GetSessions | Returns all of the sessions from BaseStation's Sessions table.
Public method | GetSystemEvents | Returns the entire content of the SystemEvents table.
Public method | InsertAircraft | Inserts a new aircraft record and fills AircraftID with the identifier of the record.
Public method | InsertFlight | Inserts a new flight record and assigns the unique identifier of the new record to the FlightID property. The AircraftID property must be filled with the identifier of an existing aircraft record.
Public method | InsertLocation | Inserts a new record in the database for the location passed across and sets the LocationID to the identifier of the new record.
Public method | InsertSession | Inserts a record in the Sessions table, setting SessionID to the identifier of the new record.
Public method | InsertSystemEvent | Inserts a new SystemEvents record and sets the SystemEventsID to the identifier of the new record.
Public method | RecordManyMissingAircraft | Does the same as RecordMissingAircraft(String) but for many ICAOs simultaneously.
Public method | RecordMissingAircraft | Records a missing aircraft record.
Public method | RollbackTransaction | Rolls back a transaction. Rolling back a nested transaction rolls back all transactions. (Inherited from ITransactionable.)
Public method | StartTransaction | Begins a new transaction. Nesting transactions is allowed. (Inherited from ITransactionable.)
Public method | TestConnection | Returns true if a connection could be made to FileName, false if it could not. If it could be made then the connection is left open.
Public method | UpdateAircraft | Updates an existing aircraft record.
Public method | UpdateAircraftModeSCountry | Updates the Mode-S country for an aircraft.
Public method | UpdateFlight | Updates an existing flight record. Ignores the aircraft record attached to the flight (if any).
Public method | UpdateLocation | Updates an existing location record.
Public method | UpdateSession | Updates the record for a session.
Public method | UpdateSystemEvent | Updates an existing SystemEvents record.
Public method | UpsertAircraftByCode | Creates or updates an aircraft record.
Public method | UpsertManyAircraftByCodes | Does the same as UpsertAircraftByCode(String, FuncBaseStationAircraft, BaseStationAircraft) but for many ICAOs.
Top
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.AttemptAutoFix Method

IBaseStationDatabaseAttemptAutoFix Method
Takes an exception that was thrown from TestConnection and attempts to correct the error that was encountered. If it's likely to have succeeded then returns true.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AttemptAutoFix(
    Exception ex
)
Function AttemptAutoFix (
    ex As Exception
) As Boolean
bool AttemptAutoFix(
    Exception^ ex
)
abstract AttemptAutoFix :
        ex : Exception -> bool

Parameters

ex
Type: SystemException

Return Value

Type: Boolean
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.CreateDatabaseIfMissing Method

IBaseStationDatabaseCreateDatabaseIfMissing Method
If the database file is missing or entirely empty then this method creates the file and pre-populates the tables with roughly the same records that BaseStation prepopulates a new database with.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateDatabaseIfMissing(
    string fileName
)
Sub CreateDatabaseIfMissing (
    fileName As String
)
void CreateDatabaseIfMissing(
    String^ fileName
)
abstract CreateDatabaseIfMissing :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The name of the database file to create. This need not be the same as FileName.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if WriteSupportEnabled is false.
Remarks
This does nothing if the database file exists and is not zero-length or if the database file is not set.
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.DeleteAircraft Method

IBaseStationDatabaseDeleteAircraft Method
Deletes an existing aircraft record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteAircraft(
    BaseStationAircraft aircraft
)
Sub DeleteAircraft (
    aircraft As BaseStationAircraft
)
void DeleteAircraft(
    BaseStationAircraft^ aircraft
)
abstract DeleteAircraft :
        aircraft : BaseStationAircraft -> unit

Parameters

aircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.DeleteFlight Method

IBaseStationDatabaseDeleteFlight Method
Deletes an existing flight record. Ignores the aircraft record attached to the flight (if any).

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteFlight(
    BaseStationFlight flight
)
Sub DeleteFlight (
    flight As BaseStationFlight
)
void DeleteFlight(
    BaseStationFlight^ flight
)
abstract DeleteFlight :
        flight : BaseStationFlight -> unit

Parameters

flight
Type: VirtualRadar.Interface.DatabaseBaseStationFlight
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.DeleteLocation Method

IBaseStationDatabaseDeleteLocation Method
Deletes an existing location record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteLocation(
    BaseStationLocation location
)
Sub DeleteLocation (
    location As BaseStationLocation
)
void DeleteLocation(
    BaseStationLocation^ location
)
abstract DeleteLocation :
        location : BaseStationLocation -> unit

Parameters

location
Type: VirtualRadar.Interface.DatabaseBaseStationLocation
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.DeleteSession Method

IBaseStationDatabaseDeleteSession Method
Deletes the record for a session. This automatically deletes all flights associated with the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteSession(
    BaseStationSession session
)
Sub DeleteSession (
    session As BaseStationSession
)
void DeleteSession(
    BaseStationSession^ session
)
abstract DeleteSession :
        session : BaseStationSession -> unit

Parameters

session
Type: VirtualRadar.Interface.DatabaseBaseStationSession
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.DeleteSystemEvent Method

IBaseStationDatabaseDeleteSystemEvent Method
Deletes an existing SystemEvents record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteSystemEvent(
    BaseStationSystemEvents systemEvent
)
Sub DeleteSystemEvent (
    systemEvent As BaseStationSystemEvents
)
void DeleteSystemEvent(
    BaseStationSystemEvents^ systemEvent
)
abstract DeleteSystemEvent :
        systemEvent : BaseStationSystemEvents -> unit

Parameters

systemEvent
Type: VirtualRadar.Interface.DatabaseBaseStationSystemEvents
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetAircraftByCode Method

IBaseStationDatabaseGetAircraftByCode Method
Returns the first aircraft with the ICAO24 code passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationAircraft GetAircraftByCode(
    string icao24
)
Function GetAircraftByCode (
    icao24 As String
) As BaseStationAircraft
BaseStationAircraft^ GetAircraftByCode(
    String^ icao24
)
abstract GetAircraftByCode :
        icao24 : string -> BaseStationAircraft

Parameters

icao24
Type: SystemString

Return Value

Type: BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetAircraftById Method

IBaseStationDatabaseGetAircraftById Method
Retrieves an aircraft record by its identifier.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationAircraft GetAircraftById(
    int id
)
Function GetAircraftById (
    id As Integer
) As BaseStationAircraft
BaseStationAircraft^ GetAircraftById(
    int id
)
abstract GetAircraftById :
        id : int -> BaseStationAircraft

Parameters

id
Type: SystemInt32

Return Value

Type: BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetAircraftByRegistration Method

IBaseStationDatabaseGetAircraftByRegistration Method
Returns the first aircraft with the registration passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationAircraft GetAircraftByRegistration(
    string registration
)
Function GetAircraftByRegistration (
    registration As String
) As BaseStationAircraft
BaseStationAircraft^ GetAircraftByRegistration(
    String^ registration
)
abstract GetAircraftByRegistration :
        registration : string -> BaseStationAircraft

Parameters

registration
Type: SystemString

Return Value

Type: BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetAllAircraft Method

IBaseStationDatabaseGetAllAircraft Method
Returns every aircraft record in the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<BaseStationAircraft> GetAllAircraft()
Function GetAllAircraft As List(Of BaseStationAircraft)
List<BaseStationAircraft^>^ GetAllAircraft()
abstract GetAllAircraft : unit -> List<BaseStationAircraft>

Return Value

Type: List BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetCountOfFlights Method

IBaseStationDatabaseGetCountOfFlights Method
Returns the number of flights that match the criteria passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetCountOfFlights(
    SearchBaseStationCriteria criteria
)
Function GetCountOfFlights (
    criteria As SearchBaseStationCriteria
) As Integer
int GetCountOfFlights(
    SearchBaseStationCriteria^ criteria
)
abstract GetCountOfFlights :
        criteria : SearchBaseStationCriteria -> int

Parameters

criteria
Type: VirtualRadar.Interface.DatabaseSearchBaseStationCriteria

Return Value

Type: Int32
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetCountOfFlightsForAircraft Method

IBaseStationDatabaseGetCountOfFlightsForAircraft Method
Returns the number of flight records that match the criteria passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetCountOfFlightsForAircraft(
    BaseStationAircraft aircraft,
    SearchBaseStationCriteria criteria
)
Function GetCountOfFlightsForAircraft (
    aircraft As BaseStationAircraft,
    criteria As SearchBaseStationCriteria
) As Integer
int GetCountOfFlightsForAircraft(
    BaseStationAircraft^ aircraft,
    SearchBaseStationCriteria^ criteria
)
abstract GetCountOfFlightsForAircraft :
        aircraft : BaseStationAircraft *
        criteria : SearchBaseStationCriteria -> int

Parameters

aircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
criteria
Type: VirtualRadar.Interface.DatabaseSearchBaseStationCriteria

Return Value

Type: Int32
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetDatabaseHistory Method

IBaseStationDatabaseGetDatabaseHistory Method
Returns all of the records from BaseStation's DBHistory table.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<BaseStationDBHistory> GetDatabaseHistory()
Function GetDatabaseHistory As IList(Of BaseStationDBHistory)
IList<BaseStationDBHistory^>^ GetDatabaseHistory()
abstract GetDatabaseHistory : unit -> IList<BaseStationDBHistory>

Return Value

Type: IList BaseStationDBHistory
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetDatabaseVersion Method

IBaseStationDatabaseGetDatabaseVersion Method
Returns the single DBInfo record in BaseStation's DBInfo table. Note that this has no key.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationDBInfo GetDatabaseVersion()
Function GetDatabaseVersion As BaseStationDBInfo
BaseStationDBInfo^ GetDatabaseVersion()
abstract GetDatabaseVersion : unit -> BaseStationDBInfo

Return Value

Type: BaseStationDBInfo
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetFlightById Method

IBaseStationDatabaseGetFlightById Method
Retrieves a flight record from the database by its ID number. This does not read the associated aircraft record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationFlight GetFlightById(
    int id
)
Function GetFlightById (
    id As Integer
) As BaseStationFlight
BaseStationFlight^ GetFlightById(
    int id
)
abstract GetFlightById :
        id : int -> BaseStationFlight

Parameters

id
Type: SystemInt32

Return Value

Type: BaseStationFlight
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetFlights Method

IBaseStationDatabaseGetFlights Method
Returns all flights, or a subset of all flights, that match the criteria passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<BaseStationFlight> GetFlights(
    SearchBaseStationCriteria criteria,
    int fromRow,
    int toRow,
    string sortField1,
    bool sortField1Ascending,
    string sortField2,
    bool sortField2Ascending
)
Function GetFlights (
    criteria As SearchBaseStationCriteria,
    fromRow As Integer,
    toRow As Integer,
    sortField1 As String,
    sortField1Ascending As Boolean,
    sortField2 As String,
    sortField2Ascending As Boolean
) As List(Of BaseStationFlight)
List<BaseStationFlight^>^ GetFlights(
    SearchBaseStationCriteria^ criteria,
    int fromRow,
    int toRow,
    String^ sortField1,
    bool sortField1Ascending,
    String^ sortField2,
    bool sortField2Ascending
)
abstract GetFlights :
        criteria : SearchBaseStationCriteria *
        fromRow : int *
        toRow : int *
        sortField1 : string *
        sortField1Ascending : bool *
        sortField2 : string *
        sortField2Ascending : bool -> List<BaseStationFlight>

Parameters

criteria
Type: VirtualRadar.Interface.DatabaseSearchBaseStationCriteria
fromRow
Type: SystemInt32
toRow
Type: SystemInt32
sortField1
Type: SystemString
sortField1Ascending
Type: SystemBoolean
sortField2
Type: SystemString
sortField2Ascending
Type: SystemBoolean

Return Value

Type: List BaseStationFlight
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetFlightsForAircraft Method

IBaseStationDatabaseGetFlightsForAircraft Method
Returns a list of every flight, or a subset of every flight, that matches the criteria passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<BaseStationFlight> GetFlightsForAircraft(
    BaseStationAircraft aircraft,
    SearchBaseStationCriteria criteria,
    int fromRow,
    int toRow,
    string sort1,
    bool sort1Ascending,
    string sort2,
    bool sort2Ascending
)
Function GetFlightsForAircraft (
    aircraft As BaseStationAircraft,
    criteria As SearchBaseStationCriteria,
    fromRow As Integer,
    toRow As Integer,
    sort1 As String,
    sort1Ascending As Boolean,
    sort2 As String,
    sort2Ascending As Boolean
) As List(Of BaseStationFlight)
List<BaseStationFlight^>^ GetFlightsForAircraft(
    BaseStationAircraft^ aircraft,
    SearchBaseStationCriteria^ criteria,
    int fromRow,
    int toRow,
    String^ sort1,
    bool sort1Ascending,
    String^ sort2,
    bool sort2Ascending
)
abstract GetFlightsForAircraft :
        aircraft : BaseStationAircraft *
        criteria : SearchBaseStationCriteria *
        fromRow : int *
        toRow : int *
        sort1 : string *
        sort1Ascending : bool *
        sort2 : string *
        sort2Ascending : bool -> List<BaseStationFlight>

Parameters

aircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
criteria
Type: VirtualRadar.Interface.DatabaseSearchBaseStationCriteria
fromRow
Type: SystemInt32
toRow
Type: SystemInt32
sort1
Type: SystemString
sort1Ascending
Type: SystemBoolean
sort2
Type: SystemString
sort2Ascending
Type: SystemBoolean

Return Value

Type: List BaseStationFlight
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetLocations Method

IBaseStationDatabaseGetLocations Method
Returns all of the locations from BaseStation's Locations table.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<BaseStationLocation> GetLocations()
Function GetLocations As IList(Of BaseStationLocation)
IList<BaseStationLocation^>^ GetLocations()
abstract GetLocations : unit -> IList<BaseStationLocation>

Return Value

Type: IList BaseStationLocation
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetManyAircraftAndFlightsCountByCode Method

IBaseStationDatabaseGetManyAircraftAndFlightsCountByCode Method
Returns aircraft records and counts of flights for many ICAO24 codes simultaneously.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Dictionary<string, BaseStationAircraftAndFlightsCount> GetManyAircraftAndFlightsCountByCode(
    IEnumerable<string> icao24s
)
Function GetManyAircraftAndFlightsCountByCode (
    icao24s As IEnumerable(Of String)
) As Dictionary(Of String, BaseStationAircraftAndFlightsCount)
Dictionary<String^, BaseStationAircraftAndFlightsCount^>^ GetManyAircraftAndFlightsCountByCode(
    IEnumerable<String^>^ icao24s
)
abstract GetManyAircraftAndFlightsCountByCode :
        icao24s : IEnumerable<string> -> Dictionary<string, BaseStationAircraftAndFlightsCount>

Parameters

icao24s
Type: System.Collections.GenericIEnumerable String

Return Value

Type: Dictionary String, BaseStationAircraftAndFlightsCount
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetManyAircraftByCode Method

IBaseStationDatabaseGetManyAircraftByCode Method
Returns aircraft records for many ICAO24 codes simultaneously.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Dictionary<string, BaseStationAircraft> GetManyAircraftByCode(
    IEnumerable<string> icao24s
)
Function GetManyAircraftByCode (
    icao24s As IEnumerable(Of String)
) As Dictionary(Of String, BaseStationAircraft)
Dictionary<String^, BaseStationAircraft^>^ GetManyAircraftByCode(
    IEnumerable<String^>^ icao24s
)
abstract GetManyAircraftByCode :
        icao24s : IEnumerable<string> -> Dictionary<string, BaseStationAircraft>

Parameters

icao24s
Type: System.Collections.GenericIEnumerable String

Return Value

Type: Dictionary String, BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetOrInsertAircraftByCode Method

IBaseStationDatabaseGetOrInsertAircraftByCode Method
Fetches an aircraft by its ICAO code. If there is no record for the aircraft then the createNewAircraftFunc method is called to build a new record, and that is inserted.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationAircraft GetOrInsertAircraftByCode(
    string icao24,
    Func<string, BaseStationAircraft> createNewAircraftFunc
)
Function GetOrInsertAircraftByCode (
    icao24 As String,
    createNewAircraftFunc As Func(Of String, BaseStationAircraft)
) As BaseStationAircraft
BaseStationAircraft^ GetOrInsertAircraftByCode(
    String^ icao24,
    Func<String^, BaseStationAircraft^>^ createNewAircraftFunc
)
abstract GetOrInsertAircraftByCode :
        icao24 : string *
        createNewAircraftFunc : Func<string, BaseStationAircraft> -> BaseStationAircraft

Parameters

icao24
Type: SystemString
createNewAircraftFunc
Type: SystemFunc String, BaseStationAircraft

Return Value

Type: BaseStationAircraft
Remarks
A lock is held over both the fetch and the insert, this is an atomic operation.
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetSessions Method

IBaseStationDatabaseGetSessions Method
Returns all of the sessions from BaseStation's Sessions table.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<BaseStationSession> GetSessions()
Function GetSessions As IList(Of BaseStationSession)
IList<BaseStationSession^>^ GetSessions()
abstract GetSessions : unit -> IList<BaseStationSession>

Return Value

Type: IList BaseStationSession
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.GetSystemEvents Method

IBaseStationDatabaseGetSystemEvents Method
Returns the entire content of the SystemEvents table.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<BaseStationSystemEvents> GetSystemEvents()
Function GetSystemEvents As IList(Of BaseStationSystemEvents)
IList<BaseStationSystemEvents^>^ GetSystemEvents()
abstract GetSystemEvents : unit -> IList<BaseStationSystemEvents>

Return Value

Type: IList BaseStationSystemEvents
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.InsertAircraft Method

IBaseStationDatabaseInsertAircraft Method
Inserts a new aircraft record and fills AircraftID with the identifier of the record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertAircraft(
    BaseStationAircraft aircraft
)
Sub InsertAircraft (
    aircraft As BaseStationAircraft
)
void InsertAircraft(
    BaseStationAircraft^ aircraft
)
abstract InsertAircraft :
        aircraft : BaseStationAircraft -> unit

Parameters

aircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.InsertFlight Method

IBaseStationDatabaseInsertFlight Method
Inserts a new flight record and assigns the unique identifier of the new record to the FlightID property. The AircraftID property must be filled with the identifier of an existing aircraft record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertFlight(
    BaseStationFlight flight
)
Sub InsertFlight (
    flight As BaseStationFlight
)
void InsertFlight(
    BaseStationFlight^ flight
)
abstract InsertFlight :
        flight : BaseStationFlight -> unit

Parameters

flight
Type: VirtualRadar.Interface.DatabaseBaseStationFlight
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.InsertLocation Method

IBaseStationDatabaseInsertLocation Method
Inserts a new record in the database for the location passed across and sets the LocationID to the identifier of the new record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertLocation(
    BaseStationLocation location
)
Sub InsertLocation (
    location As BaseStationLocation
)
void InsertLocation(
    BaseStationLocation^ location
)
abstract InsertLocation :
        location : BaseStationLocation -> unit

Parameters

location
Type: VirtualRadar.Interface.DatabaseBaseStationLocation
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.InsertSession Method

IBaseStationDatabaseInsertSession Method
Inserts a record in the Sessions table, setting SessionID to the identifier of the new record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertSession(
    BaseStationSession session
)
Sub InsertSession (
    session As BaseStationSession
)
void InsertSession(
    BaseStationSession^ session
)
abstract InsertSession :
        session : BaseStationSession -> unit

Parameters

session
Type: VirtualRadar.Interface.DatabaseBaseStationSession
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.InsertSystemEvent Method

IBaseStationDatabaseInsertSystemEvent Method
Inserts a new SystemEvents record and sets the SystemEventsID to the identifier of the new record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertSystemEvent(
    BaseStationSystemEvents systemEvent
)
Sub InsertSystemEvent (
    systemEvent As BaseStationSystemEvents
)
void InsertSystemEvent(
    BaseStationSystemEvents^ systemEvent
)
abstract InsertSystemEvent :
        systemEvent : BaseStationSystemEvents -> unit

Parameters

systemEvent
Type: VirtualRadar.Interface.DatabaseBaseStationSystemEvents
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.RecordManyMissingAircraft Method

IBaseStationDatabaseRecordManyMissingAircraft Method
Does the same as RecordMissingAircraft(String) but for many ICAOs simultaneously.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordManyMissingAircraft(
    IEnumerable<string> icaos
)
Sub RecordManyMissingAircraft (
    icaos As IEnumerable(Of String)
)
void RecordManyMissingAircraft(
    IEnumerable<String^>^ icaos
)
abstract RecordManyMissingAircraft :
        icaos : IEnumerable<string> -> unit

Parameters

icaos
Type: System.Collections.GenericIEnumerable String
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.RecordMissingAircraft Method

IBaseStationDatabaseRecordMissingAircraft Method
Records a missing aircraft record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordMissingAircraft(
    string icao
)
Sub RecordMissingAircraft (
    icao As String
)
void RecordMissingAircraft(
    String^ icao
)
abstract RecordMissingAircraft :
        icao : string -> unit

Parameters

icao
Type: SystemString
Remarks
An aircraft is missing if it has no registration, no manufacturer, no model, no operator and the UserString1 is set to 'Missing'. If the aircraft record does not exist then it is created with the created and updated times set, along with the UserString1. If it exists and has the correct values for a missing aircraft (except for UserString1, that can be anything) then this method updates the time and forces UserString1 to Missing. Otherwise the method does nothing.
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.TestConnection Method

IBaseStationDatabaseTestConnection Method
Returns true if a connection could be made to FileName, false if it could not. If it could be made then the connection is left open.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TestConnection()
Function TestConnection As Boolean
bool TestConnection()
abstract TestConnection : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpdateAircraft Method

IBaseStationDatabaseUpdateAircraft Method
Updates an existing aircraft record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateAircraft(
    BaseStationAircraft aircraft
)
Sub UpdateAircraft (
    aircraft As BaseStationAircraft
)
void UpdateAircraft(
    BaseStationAircraft^ aircraft
)
abstract UpdateAircraft :
        aircraft : BaseStationAircraft -> unit

Parameters

aircraft
Type: VirtualRadar.Interface.DatabaseBaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpdateAircraftModeSCountry Method

IBaseStationDatabaseUpdateAircraftModeSCountry Method
Updates the Mode-S country for an aircraft.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateAircraftModeSCountry(
    int aircraftId,
    string modeSCountry
)
Sub UpdateAircraftModeSCountry (
    aircraftId As Integer,
    modeSCountry As String
)
void UpdateAircraftModeSCountry(
    int aircraftId,
    String^ modeSCountry
)
abstract UpdateAircraftModeSCountry :
        aircraftId : int *
        modeSCountry : string -> unit

Parameters

aircraftId
Type: SystemInt32
modeSCountry
Type: SystemString
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpdateFlight Method

IBaseStationDatabaseUpdateFlight Method
Updates an existing flight record. Ignores the aircraft record attached to the flight (if any).

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateFlight(
    BaseStationFlight flight
)
Sub UpdateFlight (
    flight As BaseStationFlight
)
void UpdateFlight(
    BaseStationFlight^ flight
)
abstract UpdateFlight :
        flight : BaseStationFlight -> unit

Parameters

flight
Type: VirtualRadar.Interface.DatabaseBaseStationFlight
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpdateLocation Method

IBaseStationDatabaseUpdateLocation Method
Updates an existing location record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateLocation(
    BaseStationLocation location
)
Sub UpdateLocation (
    location As BaseStationLocation
)
void UpdateLocation(
    BaseStationLocation^ location
)
abstract UpdateLocation :
        location : BaseStationLocation -> unit

Parameters

location
Type: VirtualRadar.Interface.DatabaseBaseStationLocation
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpdateSession Method

IBaseStationDatabaseUpdateSession Method
Updates the record for a session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSession(
    BaseStationSession session
)
Sub UpdateSession (
    session As BaseStationSession
)
void UpdateSession(
    BaseStationSession^ session
)
abstract UpdateSession :
        session : BaseStationSession -> unit

Parameters

session
Type: VirtualRadar.Interface.DatabaseBaseStationSession
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpdateSystemEvent Method

IBaseStationDatabaseUpdateSystemEvent Method
Updates an existing SystemEvents record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSystemEvent(
    BaseStationSystemEvents systemEvent
)
Sub UpdateSystemEvent (
    systemEvent As BaseStationSystemEvents
)
void UpdateSystemEvent(
    BaseStationSystemEvents^ systemEvent
)
abstract UpdateSystemEvent :
        systemEvent : BaseStationSystemEvents -> unit

Parameters

systemEvent
Type: VirtualRadar.Interface.DatabaseBaseStationSystemEvents
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpsertAircraftByCode Method

IBaseStationDatabaseUpsertAircraftByCode Method
Creates or updates an aircraft record.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationAircraft UpsertAircraftByCode(
    string icao,
    Func<BaseStationAircraft, BaseStationAircraft> fillAircraft
)
Function UpsertAircraftByCode (
    icao As String,
    fillAircraft As Func(Of BaseStationAircraft, BaseStationAircraft)
) As BaseStationAircraft
BaseStationAircraft^ UpsertAircraftByCode(
    String^ icao,
    Func<BaseStationAircraft^, BaseStationAircraft^>^ fillAircraft
)
abstract UpsertAircraftByCode :
        icao : string *
        fillAircraft : Func<BaseStationAircraft, BaseStationAircraft> -> BaseStationAircraft

Parameters

icao
Type: SystemString
The ICAO of the aircraft to create or update.
fillAircraft
Type: SystemFunc BaseStationAircraft, BaseStationAircraft
A callback that is passed the existing aircraft record or, if there is no record for the record, a partially-filled record. The callback can either return the record (optionally modified) or return null. If it returns null then the record is not inserted / changed, otherwise the record returned is written back to the database.

Return Value

Type: BaseStationAircraft
Remarks
The callback is called from within a lock, be careful not to do anything that will cause a deadlock.
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.UpsertManyAircraftByCodes Method

IBaseStationDatabaseUpsertManyAircraftByCodes Method
Does the same as UpsertAircraftByCode(String, FuncBaseStationAircraft, BaseStationAircraft) but for many ICAOs.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
BaseStationAircraft[] UpsertManyAircraftByCodes(
    IEnumerable<string> icaos,
    Func<BaseStationAircraft, BaseStationAircraft> fillAircraft
)
Function UpsertManyAircraftByCodes (
    icaos As IEnumerable(Of String),
    fillAircraft As Func(Of BaseStationAircraft, BaseStationAircraft)
) As BaseStationAircraft()
array<BaseStationAircraft^>^ UpsertManyAircraftByCodes(
    IEnumerable<String^>^ icaos,
    Func<BaseStationAircraft^, BaseStationAircraft^>^ fillAircraft
)
abstract UpsertManyAircraftByCodes :
        icaos : IEnumerable<string> *
        fillAircraft : Func<BaseStationAircraft, BaseStationAircraft> -> BaseStationAircraft[]

Parameters

icaos
Type: System.Collections.GenericIEnumerable String
fillAircraft
Type: SystemFunc BaseStationAircraft, BaseStationAircraft

Return Value

Type: BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase Events

IBaseStationDatabase Events

The IBaseStationDatabase type exposes the following members.

Events
 | Name | Description
Public event | AircraftUpdated | Raised after an aircraft has been updated.
Public event | FileNameChanged | Raised after FileName has changed as the result of a configuration change.
Public event | FileNameChanging | Raised before FileName is changed as the result of a configuration change.
Top
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.AircraftUpdated Event

IBaseStationDatabaseAircraftUpdated Event
Raised after an aircraft has been updated.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<BaseStationAircraft>> AircraftUpdated
Event AircraftUpdated As EventHandler(Of EventArgs(Of BaseStationAircraft))
 event EventHandler<EventArgs<BaseStationAircraft^>^>^ AircraftUpdated {
    void add (EventHandler<EventArgs<BaseStationAircraft^>^>^ value);
    void remove (EventHandler<EventArgs<BaseStationAircraft^>^>^ value);
}
abstract AircraftUpdated : IEvent<EventHandler<EventArgs<BaseStationAircraft>>,
    EventArgs<BaseStationAircraft>>

Value

Type: SystemEventHandler EventArgs BaseStationAircraft
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.FileNameChanged Event

IBaseStationDatabaseFileNameChanged Event
Raised after FileName has changed as the result of a configuration change.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FileNameChanged
Event FileNameChanged As EventHandler
 event EventHandler^ FileNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FileNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabase.FileNameChanging Event

IBaseStationDatabaseFileNameChanging Event
Raised before FileName is changed as the result of a configuration change.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FileNameChanging
Event FileNameChanging As EventHandler
 event EventHandler^ FileNameChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FileNameChanging : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IBaseStationDatabase Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabaseProvider Interface

IBaseStationDatabaseProvider Interface
The interface for objects that abstract away the environment for the IBaseStationDatabase implementations.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBaseStationDatabaseProvider
Public Interface IBaseStationDatabaseProvider
public interface class IBaseStationDatabaseProvider
type IBaseStationDatabaseProvider =  interface end

The IBaseStationDatabaseProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current time at UTC.
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


IBaseStationDatabaseProvider Properties

IBaseStationDatabaseProvider Properties

The IBaseStationDatabaseProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current time at UTC.
Top
See Also

Reference

IBaseStationDatabaseProvider Interface
VirtualRadar.Interface.Database Namespace


IBaseStationDatabaseProvider.UtcNow Property

IBaseStationDatabaseProviderUtcNow Property
Gets the current time at UTC.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UtcNow { get; }
ReadOnly Property UtcNow As DateTime
    Get
property DateTime UtcNow {
    DateTime get ();
}
abstract UtcNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IBaseStationDatabaseProvider Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase Interface

ILogDatabase Interface
The interface to the log database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILogDatabase : ISingleton<ILogDatabase>,
    ITransactionable, IDisposable
Public Interface ILogDatabase
    Inherits ISingleton(Of ILogDatabase), ITransactionable, IDisposable
public interface class ILogDatabase : ISingleton<ILogDatabase^>,
    ITransactionable, IDisposable
type ILogDatabase =
    interface
        interface ISingleton<ILogDatabase>
        interface ITransactionable
        interface IDisposable
    end

The ILogDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the provider that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndTransaction | Ends a transaction. Ending a nested transaction has no effect. (Inherited from ITransactionable.)
Public method | EstablishSession | Creates a new session record for the IP address passed across.
Public method | FetchAll | Fetches the entire log.
Public method | FetchSessions | Fetches all sessions that start and end within the date range passed across.
Public method | RollbackTransaction | Rolls back a transaction. Rolling back a nested transaction rolls back all transactions. (Inherited from ITransactionable.)
Public method | StartTransaction | Begins a new transaction. Nesting transactions is allowed. (Inherited from ITransactionable.)
Public method | UpdateClient | Writes the client back to the database.
Public method | UpdateSession | Writes the session record passed across back to the database.
Top
Remarks
The log database is an SQLite database that Virtual Radar Server maintains for itself in its configuration folder. It holds information about the connections that have been made to the web server.
See Also

Reference

VirtualRadar.Interface.Database Namespace


ILogDatabase Properties

ILogDatabase Properties

The ILogDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the provider that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase.Provider Property

ILogDatabaseProvider Property
Gets or sets the provider that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ILogDatabaseProvider Provider { get; set; }
Property Provider As ILogDatabaseProvider
    Get
    Set
property ILogDatabaseProvider^ Provider {
    ILogDatabaseProvider^ get ();
    void set (ILogDatabaseProvider^ value);
}
abstract Provider : ILogDatabaseProvider with get, set

Property Value

Type: ILogDatabaseProvider
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase Methods

ILogDatabase Methods

The ILogDatabase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndTransaction | Ends a transaction. Ending a nested transaction has no effect. (Inherited from ITransactionable.)
Public method | EstablishSession | Creates a new session record for the IP address passed across.
Public method | FetchAll | Fetches the entire log.
Public method | FetchSessions | Fetches all sessions that start and end within the date range passed across.
Public method | RollbackTransaction | Rolls back a transaction. Rolling back a nested transaction rolls back all transactions. (Inherited from ITransactionable.)
Public method | StartTransaction | Begins a new transaction. Nesting transactions is allowed. (Inherited from ITransactionable.)
Public method | UpdateClient | Writes the client back to the database.
Public method | UpdateSession | Writes the session record passed across back to the database.
Top
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase.EstablishSession Method

ILogDatabaseEstablishSession Method
Creates a new session record for the IP address passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
LogSession EstablishSession(
    string ipAddress,
    string userName
)
Function EstablishSession (
    ipAddress As String,
    userName As String
) As LogSession
LogSession^ EstablishSession(
    String^ ipAddress,
    String^ userName
)
abstract EstablishSession :
        ipAddress : string *
        userName : string -> LogSession

Parameters

ipAddress
Type: SystemString
userName
Type: SystemString

Return Value

Type: LogSession
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase.FetchAll Method

ILogDatabaseFetchAll Method
Fetches the entire log.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FetchAll(
    IList<LogClient> clients,
    IDictionary<long, IList<LogSession>> sessionsMap
)
Sub FetchAll (
    clients As IList(Of LogClient),
    sessionsMap As IDictionary(Of Long, IList(Of LogSession))
)
void FetchAll(
    IList<LogClient^>^ clients,
    IDictionary<long long, IList<LogSession^>^>^ sessionsMap
)
abstract FetchAll :
        clients : IList<LogClient> *
        sessionsMap : IDictionary<int64, IList<LogSession>> -> unit

Parameters

clients
Type: System.Collections.GenericIList LogClient
sessionsMap
Type: System.Collections.GenericIDictionary Int64, IList LogSession
A map of client ID to all sessions for the client.
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase.FetchSessions Method

ILogDatabaseFetchSessions Method
Fetches all sessions that start and end within the date range passed across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FetchSessions(
    IList<LogClient> clients,
    IList<LogSession> sessions,
    DateTime startTime,
    DateTime endTime
)
Sub FetchSessions (
    clients As IList(Of LogClient),
    sessions As IList(Of LogSession),
    startTime As DateTime,
    endTime As DateTime
)
void FetchSessions(
    IList<LogClient^>^ clients,
    IList<LogSession^>^ sessions,
    DateTime startTime,
    DateTime endTime
)
abstract FetchSessions :
        clients : IList<LogClient> *
        sessions : IList<LogSession> *
        startTime : DateTime *
        endTime : DateTime -> unit

Parameters

clients
Type: System.Collections.GenericIList LogClient
sessions
Type: System.Collections.GenericIList LogSession
startTime
Type: SystemDateTime
endTime
Type: SystemDateTime
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase.UpdateClient Method

ILogDatabaseUpdateClient Method
Writes the client back to the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateClient(
    LogClient client
)
Sub UpdateClient (
    client As LogClient
)
void UpdateClient(
    LogClient^ client
)
abstract UpdateClient :
        client : LogClient -> unit

Parameters

client
Type: VirtualRadar.Interface.DatabaseLogClient
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabase.UpdateSession Method

ILogDatabaseUpdateSession Method
Writes the session record passed across back to the database.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSession(
    LogSession session
)
Sub UpdateSession (
    session As LogSession
)
void UpdateSession(
    LogSession^ session
)
abstract UpdateSession :
        session : LogSession -> unit

Parameters

session
Type: VirtualRadar.Interface.DatabaseLogSession
See Also

Reference

ILogDatabase Interface
VirtualRadar.Interface.Database Namespace


ILogDatabaseProvider Interface

ILogDatabaseProvider Interface
The interface for providers for the ILogDatabase implementations that abstract away the environment for tests.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILogDatabaseProvider
Public Interface ILogDatabaseProvider
public interface class ILogDatabaseProvider
type ILogDatabaseProvider =  interface end

The ILogDatabaseProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current UTC date and time.
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


ILogDatabaseProvider Properties

ILogDatabaseProvider Properties

The ILogDatabaseProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current UTC date and time.
Top
See Also

Reference

ILogDatabaseProvider Interface
VirtualRadar.Interface.Database Namespace


ILogDatabaseProvider.UtcNow Property

ILogDatabaseProviderUtcNow Property
Gets the current UTC date and time.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UtcNow { get; }
ReadOnly Property UtcNow As DateTime
    Get
property DateTime UtcNow {
    DateTime get ();
}
abstract UtcNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

ILogDatabaseProvider Interface
VirtualRadar.Interface.Database Namespace


ITransactionable Interface

ITransactionable Interface
The interface that should be implemented by database objects that support transactions.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITransactionable
Public Interface ITransactionable
public interface class ITransactionable
type ITransactionable =  interface end

The ITransactionable type exposes the following members.

Methods
 | Name | Description
Public method | EndTransaction | Ends a transaction. Ending a nested transaction has no effect.
Public method | RollbackTransaction | Rolls back a transaction. Rolling back a nested transaction rolls back all transactions.
Public method | StartTransaction | Begins a new transaction. Nesting transactions is allowed.
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


ITransactionable Methods

ITransactionable Methods

The ITransactionable type exposes the following members.

Methods
 | Name | Description
Public method | EndTransaction | Ends a transaction. Ending a nested transaction has no effect.
Public method | RollbackTransaction | Rolls back a transaction. Rolling back a nested transaction rolls back all transactions.
Public method | StartTransaction | Begins a new transaction. Nesting transactions is allowed.
Top
See Also

Reference

ITransactionable Interface
VirtualRadar.Interface.Database Namespace


ITransactionable.EndTransaction Method

ITransactionableEndTransaction Method
Ends a transaction. Ending a nested transaction has no effect.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndTransaction()
Sub EndTransaction
void EndTransaction()
abstract EndTransaction : unit -> unit
See Also

Reference

ITransactionable Interface
VirtualRadar.Interface.Database Namespace


ITransactionable.RollbackTransaction Method

ITransactionableRollbackTransaction Method
Rolls back a transaction. Rolling back a nested transaction rolls back all transactions.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RollbackTransaction()
Sub RollbackTransaction
void RollbackTransaction()
abstract RollbackTransaction : unit -> unit
See Also

Reference

ITransactionable Interface
VirtualRadar.Interface.Database Namespace


ITransactionable.StartTransaction Method

ITransactionableStartTransaction Method
Begins a new transaction. Nesting transactions is allowed.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartTransaction()
Sub StartTransaction
void StartTransaction()
abstract StartTransaction : unit -> unit
See Also

Reference

ITransactionable Interface
VirtualRadar.Interface.Database Namespace


LogClient Class

LogClient Class
A record in the log database that holds information about an IP address that has been used to connect to the program.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseLogClient

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogClient
Public Class LogClient
public ref class LogClient
type LogClient =  class end

The LogClient type exposes the following members.

Constructors
 | Name | Description
Public method | LogClient | Initializes a new instance of the LogClient class
Top
Properties
 | Name | Description
Public property | Address | Gets the IP address of the client.
Public property | Id | Gets or sets unique ID of the client.
Public property | IpAddress | Gets or sets the IP address of the client.
Public property | IsLocal | Gets a bool indicating whether the client is a local client or an Internet client.
Public property | ReverseDns | Gets or sets the result of the last reverse DNS lookup on the client.
Public property | ReverseDnsDate | Gets or sets the time that ReverseDns was acquired.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


LogClient Constructor

LogClient Constructor
Initializes a new instance of the LogClient class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogClient()
Public Sub New
public:
LogClient()
new : unit -> LogClient
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient Properties

LogClient Properties

The LogClient type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the IP address of the client.
Public property | Id | Gets or sets unique ID of the client.
Public property | IpAddress | Gets or sets the IP address of the client.
Public property | IsLocal | Gets a bool indicating whether the client is a local client or an Internet client.
Public property | ReverseDns | Gets or sets the result of the last reverse DNS lookup on the client.
Public property | ReverseDnsDate | Gets or sets the time that ReverseDns was acquired.
Top
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient.Address Property

LogClientAddress Property
Gets the IP address of the client.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPAddress Address { get; }
Public ReadOnly Property Address As IPAddress
    Get
public:
property IPAddress^ Address {
    IPAddress^ get ();
}
member Address : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient.Id Property

LogClientId Property
Gets or sets unique ID of the client.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Id { get; set; }
Public Property Id As Long
    Get
    Set
public:
property long long Id {
    long long get ();
    void set (long long value);
}
member Id : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient.IpAddress Property

LogClientIpAddress Property
Gets or sets the IP address of the client.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IpAddress { get; set; }
Public Property IpAddress As String
    Get
    Set
public:
property String^ IpAddress {
    String^ get ();
    void set (String^ value);
}
member IpAddress : string with get, set

Property Value

Type: String
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient.IsLocal Property

LogClientIsLocal Property
Gets a bool indicating whether the client is a local client or an Internet client.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocal { get; }
Public ReadOnly Property IsLocal As Boolean
    Get
public:
property bool IsLocal {
    bool get ();
}
member IsLocal : bool with get

Property Value

Type: Boolean
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient.ReverseDns Property

LogClientReverseDns Property
Gets or sets the result of the last reverse DNS lookup on the client.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReverseDns { get; set; }
Public Property ReverseDns As String
    Get
    Set
public:
property String^ ReverseDns {
    String^ get ();
    void set (String^ value);
}
member ReverseDns : string with get, set

Property Value

Type: String
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient.ReverseDnsDate Property

LogClientReverseDnsDate Property
Gets or sets the time that ReverseDns was acquired.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> ReverseDnsDate { get; set; }
Public Property ReverseDnsDate As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> ReverseDnsDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ReverseDnsDate : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogClient Methods

LogClient Methods

The LogClient type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogClient Class
VirtualRadar.Interface.Database Namespace


LogSession Class

LogSession Class
A record from the log database that describes a single session from an IP address.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseLogSession

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogSession
Public Class LogSession
public ref class LogSession
type LogSession =  class end

The LogSession type exposes the following members.

Constructors
 | Name | Description
Public method | LogSession | Initializes a new instance of the LogSession class
Top
Properties
 | Name | Description
Public property | AudioBytesSent | Gets or sets the overall size of all of the audio files sent in the session.
Public property | ClientId | Gets or sets the unique ID of the client that made the session.
Public property | CountRequests | Gets or sets the number of requests the client made during the session.
Public property | Duration | Gets the duration of the session.
Public property | EndTime | Gets or sets the end of the session. While the session is in progress this holds the last time the database record was updated with the session details.
Public property | HtmlBytesSent | Gets or sets the overall size of all of the web pages sent in the session.
Public property | Id | Gets or sets the unique ID of the session.
Public property | ImageBytesSent | Gets or sets the overall size of all of the images sent in the session.
Public property | JsonBytesSent | Gets or sets the overall size of all of the JSON files sent in the session.
Public property | OtherBytesSent | Gets or sets the number of bytes sent in response to requests for miscellaneous files.
Public property | StartTime | Gets or sets the time that the session was first established.
Public property | TotalBytesSent | Gets the total number of bytes sent.
Public property | UserName | Gets or sets the first non-null user name used in the session. Will be null if the user never logged in.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


LogSession Constructor

LogSession Constructor
Initializes a new instance of the LogSession class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogSession()
Public Sub New
public:
LogSession()
new : unit -> LogSession
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession Properties

LogSession Properties

The LogSession type exposes the following members.

Properties
 | Name | Description
Public property | AudioBytesSent | Gets or sets the overall size of all of the audio files sent in the session.
Public property | ClientId | Gets or sets the unique ID of the client that made the session.
Public property | CountRequests | Gets or sets the number of requests the client made during the session.
Public property | Duration | Gets the duration of the session.
Public property | EndTime | Gets or sets the end of the session. While the session is in progress this holds the last time the database record was updated with the session details.
Public property | HtmlBytesSent | Gets or sets the overall size of all of the web pages sent in the session.
Public property | Id | Gets or sets the unique ID of the session.
Public property | ImageBytesSent | Gets or sets the overall size of all of the images sent in the session.
Public property | JsonBytesSent | Gets or sets the overall size of all of the JSON files sent in the session.
Public property | OtherBytesSent | Gets or sets the number of bytes sent in response to requests for miscellaneous files.
Public property | StartTime | Gets or sets the time that the session was first established.
Public property | TotalBytesSent | Gets the total number of bytes sent.
Public property | UserName | Gets or sets the first non-null user name used in the session. Will be null if the user never logged in.
Top
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.AudioBytesSent Property

LogSessionAudioBytesSent Property
Gets or sets the overall size of all of the audio files sent in the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long AudioBytesSent { get; set; }
Public Property AudioBytesSent As Long
    Get
    Set
public:
property long long AudioBytesSent {
    long long get ();
    void set (long long value);
}
member AudioBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.ClientId Property

LogSessionClientId Property
Gets or sets the unique ID of the client that made the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ClientId { get; set; }
Public Property ClientId As Long
    Get
    Set
public:
property long long ClientId {
    long long get ();
    void set (long long value);
}
member ClientId : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.CountRequests Property

LogSessionCountRequests Property
Gets or sets the number of requests the client made during the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long CountRequests { get; set; }
Public Property CountRequests As Long
    Get
    Set
public:
property long long CountRequests {
    long long get ();
    void set (long long value);
}
member CountRequests : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.Duration Property

LogSessionDuration Property
Gets the duration of the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; }
Public ReadOnly Property Duration As TimeSpan
    Get
public:
property TimeSpan Duration {
    TimeSpan get ();
}
member Duration : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.EndTime Property

LogSessionEndTime Property
Gets or sets the end of the session. While the session is in progress this holds the last time the database record was updated with the session details.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}
member EndTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.HtmlBytesSent Property

LogSessionHtmlBytesSent Property
Gets or sets the overall size of all of the web pages sent in the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long HtmlBytesSent { get; set; }
Public Property HtmlBytesSent As Long
    Get
    Set
public:
property long long HtmlBytesSent {
    long long get ();
    void set (long long value);
}
member HtmlBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.Id Property

LogSessionId Property
Gets or sets the unique ID of the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Id { get; set; }
Public Property Id As Long
    Get
    Set
public:
property long long Id {
    long long get ();
    void set (long long value);
}
member Id : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.ImageBytesSent Property

LogSessionImageBytesSent Property
Gets or sets the overall size of all of the images sent in the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ImageBytesSent { get; set; }
Public Property ImageBytesSent As Long
    Get
    Set
public:
property long long ImageBytesSent {
    long long get ();
    void set (long long value);
}
member ImageBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.JsonBytesSent Property

LogSessionJsonBytesSent Property
Gets or sets the overall size of all of the JSON files sent in the session.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long JsonBytesSent { get; set; }
Public Property JsonBytesSent As Long
    Get
    Set
public:
property long long JsonBytesSent {
    long long get ();
    void set (long long value);
}
member JsonBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.OtherBytesSent Property

LogSessionOtherBytesSent Property
Gets or sets the number of bytes sent in response to requests for miscellaneous files.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long OtherBytesSent { get; set; }
Public Property OtherBytesSent As Long
    Get
    Set
public:
property long long OtherBytesSent {
    long long get ();
    void set (long long value);
}
member OtherBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.StartTime Property

LogSessionStartTime Property
Gets or sets the time that the session was first established.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.TotalBytesSent Property

LogSessionTotalBytesSent Property
Gets the total number of bytes sent.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesSent { get; }
Public ReadOnly Property TotalBytesSent As Long
    Get
public:
property long long TotalBytesSent {
    long long get ();
}
member TotalBytesSent : int64 with get

Property Value

Type: Int64
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession.UserName Property

LogSessionUserName Property
Gets or sets the first non-null user name used in the session. Will be null if the user never logged in.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


LogSession Methods

LogSession Methods

The LogSession type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogSession Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria Class

SearchBaseStationCriteria Class
An object that carries search criteria for use in searching the BaseStation database. All string criteria are case insensitive.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.DatabaseSearchBaseStationCriteria

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SearchBaseStationCriteria
Public Class SearchBaseStationCriteria
public ref class SearchBaseStationCriteria
type SearchBaseStationCriteria =  class end

The SearchBaseStationCriteria type exposes the following members.

Constructors
 | Name | Description
Public method | SearchBaseStationCriteria | Initializes a new instance of the SearchBaseStationCriteria class
Top
Properties
 | Name | Description
Public property | Callsign | Gets or sets the callsign to search for.
Public property | Country | Gets or sets the ICAO24 country to search for.
Public property | Date | Gets or sets the date range to search across.
Public property | FirstAltitude | Gets or sets the first altitude range to search for.
Public property | Icao | Gets or sets the ICAO24 code to search for.
Public property | IsEmergency | Gets or sets a value indicating that only flights that broadcast an emergency squawk code should be included.
Public property | LastAltitude | Gets or sets the last altitude range to search for.
Public property | Operator | Gets or sets the aircraft owner / operator to search for.
Public property | Registration | Gets or sets the registration to search for.
Public property | Type | Gets or sets the model ICAO code to search for.
Public property | UseAlternateCallsigns | Gets or sets a value indicating that alternate callsigns should be searched for.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria Constructor

SearchBaseStationCriteria Constructor
Initializes a new instance of the SearchBaseStationCriteria class

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchBaseStationCriteria()
Public Sub New
public:
SearchBaseStationCriteria()
new : unit -> SearchBaseStationCriteria
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria Properties

SearchBaseStationCriteria Properties

The SearchBaseStationCriteria type exposes the following members.

Properties
 | Name | Description
Public property | Callsign | Gets or sets the callsign to search for.
Public property | Country | Gets or sets the ICAO24 country to search for.
Public property | Date | Gets or sets the date range to search across.
Public property | FirstAltitude | Gets or sets the first altitude range to search for.
Public property | Icao | Gets or sets the ICAO24 code to search for.
Public property | IsEmergency | Gets or sets a value indicating that only flights that broadcast an emergency squawk code should be included.
Public property | LastAltitude | Gets or sets the last altitude range to search for.
Public property | Operator | Gets or sets the aircraft owner / operator to search for.
Public property | Registration | Gets or sets the registration to search for.
Public property | Type | Gets or sets the model ICAO code to search for.
Public property | UseAlternateCallsigns | Gets or sets a value indicating that alternate callsigns should be searched for.
Top
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Callsign Property

SearchBaseStationCriteriaCallsign Property
Gets or sets the callsign to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Callsign { get; set; }
Public Property Callsign As FilterString
    Get
    Set
public:
property FilterString^ Callsign {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Callsign : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Country Property

SearchBaseStationCriteriaCountry Property
Gets or sets the ICAO24 country to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Country { get; set; }
Public Property Country As FilterString
    Get
    Set
public:
property FilterString^ Country {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Country : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Date Property

SearchBaseStationCriteriaDate Property
Gets or sets the date range to search across.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange<DateTime> Date { get; set; }
Public Property Date As FilterRange(Of DateTime)
    Get
    Set
public:
property FilterRange<DateTime>^ Date {
    FilterRange<DateTime>^ get ();
    void set (FilterRange<DateTime>^ value);
}
member Date : FilterRange<DateTime> with get, set

Property Value

Type: FilterRange DateTime
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.FirstAltitude Property

SearchBaseStationCriteriaFirstAltitude Property
Gets or sets the first altitude range to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange<int> FirstAltitude { get; set; }
Public Property FirstAltitude As FilterRange(Of Integer)
    Get
    Set
public:
property FilterRange<int>^ FirstAltitude {
    FilterRange<int>^ get ();
    void set (FilterRange<int>^ value);
}
member FirstAltitude : FilterRange<int> with get, set

Property Value

Type: FilterRange Int32
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Icao Property

SearchBaseStationCriteriaIcao Property
Gets or sets the ICAO24 code to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Icao { get; set; }
Public Property Icao As FilterString
    Get
    Set
public:
property FilterString^ Icao {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Icao : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.IsEmergency Property

SearchBaseStationCriteriaIsEmergency Property
Gets or sets a value indicating that only flights that broadcast an emergency squawk code should be included.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterBool IsEmergency { get; set; }
Public Property IsEmergency As FilterBool
    Get
    Set
public:
property FilterBool^ IsEmergency {
    FilterBool^ get ();
    void set (FilterBool^ value);
}
member IsEmergency : FilterBool with get, set

Property Value

Type: FilterBool
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.LastAltitude Property

SearchBaseStationCriteriaLastAltitude Property
Gets or sets the last altitude range to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange<int> LastAltitude { get; set; }
Public Property LastAltitude As FilterRange(Of Integer)
    Get
    Set
public:
property FilterRange<int>^ LastAltitude {
    FilterRange<int>^ get ();
    void set (FilterRange<int>^ value);
}
member LastAltitude : FilterRange<int> with get, set

Property Value

Type: FilterRange Int32
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Operator Property

SearchBaseStationCriteriaOperator Property
Gets or sets the aircraft owner / operator to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Operator { get; set; }
Public Property Operator As FilterString
    Get
    Set
public:
property FilterString^ Operator {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Operator : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Registration Property

SearchBaseStationCriteriaRegistration Property
Gets or sets the registration to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Registration { get; set; }
Public Property Registration As FilterString
    Get
    Set
public:
property FilterString^ Registration {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Registration : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.Type Property

SearchBaseStationCriteriaType Property
Gets or sets the model ICAO code to search for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Type { get; set; }
Public Property Type As FilterString
    Get
    Set
public:
property FilterString^ Type {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Type : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria.UseAlternateCallsigns Property

SearchBaseStationCriteriaUseAlternateCallsigns Property
Gets or sets a value indicating that alternate callsigns should be searched for.

Namespace: VirtualRadar.Interface.Database
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseAlternateCallsigns { get; set; }
Public Property UseAlternateCallsigns As Boolean
    Get
    Set
public:
property bool UseAlternateCallsigns {
    bool get ();
    void set (bool value);
}
member UseAlternateCallsigns : bool with get, set

Property Value

Type: Boolean
Remarks
Alternate callsigns are callsigns where leading zeros are added to the flight number portion of the callsign. It also includes callsigns where the IATA or ICAO code is swapped out for the ICAO or IATA code. It does not have anything to do with alphanumeric alternates for a standard CODE/NUMBER callsign.
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


SearchBaseStationCriteria Methods

SearchBaseStationCriteria Methods

The SearchBaseStationCriteria type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SearchBaseStationCriteria Class
VirtualRadar.Interface.Database Namespace


VirtualRadar.Interface.FlightSimulatorX Namespace

VirtualRadar.Interface.FlightSimulatorX Namespace
The namespace for all of the interfaces and objects associated with talking to Microsoft's Flight Simulator X.
Classes
 | Class | Description
Public class | FlightSimulatorXException | Thrown when FlightSimulatorX reports an exception.
Public class | SimConnectEventObservedEventArgs | The event args for the EventObserved event.
Public class | SimConnectExceptionRaisedEventArgs | The event args for ExceptionRaised
Public class | SimConnectObjectReceivedEventArgs | The event args for ObjectReceived.
Structures
 | Structure | Description
Public structure | ReadAircraftInformation | The structure that IFlightSimulatorX will fill in with information about the simulated aircraft currently flying in FSX.
Public structure | WriteAircraftInformation | The structure that is passed to IFlightSimulatorX to control the location, altitude, attitude and details of the simulated aircraft.
Interfaces
 | Interface | Description
Public interface | IFlightSimulatorX | The interface for objects that can talk to Microsoft's Flight Simulator X for us.
Public interface | ISimConnectWrapper | The interface for objects that allows tests to abstract away the SimConnect object that we have to use to connect to FSX.
Enumerations
 | Enumeration | Description
Public enumeration | FlightSimulatorXEventId | An enumeration of the values used to identify events within FSX that we are interested in. Many of these events are sent to FSX although some identify events which have taken place at the user's behest.
Public enumeration | FlightSimulatorXExceptionCode | An enumeration of the reasons given by Flight Simulator X for throwing an exception.
Remarks

The main class here is IFlightSimulatorX. ISimConnectWrapper is also of interest as implementations of IFlightSimulatorX may use it to talk to FSX. You will need to have read the SimConnect documentation before you can make use of ISimConnectWrapper. Only the parts of SimConnect that were of interest to the application were wrapped.


FlightSimulatorXEventId Enumeration

FlightSimulatorXEventId Enumeration
An enumeration of the values used to identify events within FSX that we are interested in. Many of these events are sent to FSX although some identify events which have taken place at the user's behest.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FlightSimulatorXEventId
Public Enumeration FlightSimulatorXEventId
public enum class FlightSimulatorXEventId
type FlightSimulatorXEventId
Members
Member name | Value | Description
SlewModeOn | 0 | (Sent) Turn slew mode on.
SlewModeOff | 1 | (Sent) Turn slew mode off.
SlewAltitudeUpSlow | 2 | (Sent) Increase altitude slowly.
SlewFreeze | 3 | (Sent) Stop moving the aircraft.
SlewToggle | 4 | (Received) The user has toggled slew mode.
FreezeLatitudeLongitude | 5 | (Sent) Stop moving the aircraft when not in slew.
FreezeAltitude | 6 | (Sent) Stop the aircraft from changing altitude when not in slew.
FreezeAttitude | 7 | (Sent) Stop the aircraft from rolling or changing pitch.
Crashed | 8 | (Received) The aircraft has crashed.
MissionCompleted | 9 | (Received) The user has finished the mission they were flying.
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Class

FlightSimulatorXException Class
Thrown when FlightSimulatorX reports an exception.
Inheritance Hierarchy
SystemObject
SystemException
VirtualRadar.Interface.FlightSimulatorXFlightSimulatorXException

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FlightSimulatorXException : Exception
<SerializableAttribute>
Public Class FlightSimulatorXException
    Inherits Exception
[SerializableAttribute]
public ref class FlightSimulatorXException : public Exception
[<SerializableAttribute>]
type FlightSimulatorXException =
    class
        inherit Exception
    end

The FlightSimulatorXException type exposes the following members.

Constructors
 | Name | Description
Public method | FlightSimulatorXException | Creates a new object.
Public method | FlightSimulatorXException(String) | Creates a new object.
Protected method | FlightSimulatorXException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | FlightSimulatorXException(String, Exception) | Creates a new object.
Public method | FlightSimulatorXException(UInt32, UInt32, UInt32) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | Gets the FSX exception identifier.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | RawExceptionCode | Gets the FSX exception code that underlies ExceptionCode.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | IndexNumber | Gets the index number (1-based) of the parameter that caused the exception. 0 indicates that the erroneous parameter number is not known / not applicable.
Public field | SendID | Gets the identifier of the packet that caused the error.
Top
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Constructor

FlightSimulatorXException Constructor
Overload List
 | Name | Description
Public method | FlightSimulatorXException | Creates a new object.
Public method | FlightSimulatorXException(String) | Creates a new object.
Protected method | FlightSimulatorXException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | FlightSimulatorXException(String, Exception) | Creates a new object.
Public method | FlightSimulatorXException(UInt32, UInt32, UInt32) | Creates a new object.
Top
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Constructor

FlightSimulatorXException Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightSimulatorXException()
Public Sub New
public:
FlightSimulatorXException()
new : unit -> FlightSimulatorXException
See Also

Reference

FlightSimulatorXException Class
FlightSimulatorXException Overload
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Constructor (String)

FlightSimulatorXException Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightSimulatorXException(
    string message
)
Public Sub New (
    message As String
)
public:
FlightSimulatorXException(
    String^ message
)
new :
        message : string -> FlightSimulatorXException

Parameters

message
Type: SystemString
See Also

Reference

FlightSimulatorXException Class
FlightSimulatorXException Overload
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Constructor (SerializationInfo, StreamingContext)

FlightSimulatorXException Constructor (SerializationInfo, StreamingContext)
Creates a new object.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected FlightSimulatorXException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
FlightSimulatorXException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FlightSimulatorXException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

FlightSimulatorXException Class
FlightSimulatorXException Overload
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Constructor (String, Exception)

FlightSimulatorXException Constructor (String, Exception)
Creates a new object.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightSimulatorXException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
FlightSimulatorXException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> FlightSimulatorXException

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

FlightSimulatorXException Class
FlightSimulatorXException Overload
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Constructor (UInt32, UInt32, UInt32)

FlightSimulatorXException Constructor (UInt32, UInt32, UInt32)
Creates a new object.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightSimulatorXException(
    uint exceptionID,
    uint indexNumber,
    uint sendID
)
Public Sub New (
    exceptionID As UInteger,
    indexNumber As UInteger,
    sendID As UInteger
)
public:
FlightSimulatorXException(
    unsigned int exceptionID,
    unsigned int indexNumber,
    unsigned int sendID
)
new :
        exceptionID : uint32 *
        indexNumber : uint32 *
        sendID : uint32 -> FlightSimulatorXException

Parameters

exceptionID
Type: SystemUInt32
indexNumber
Type: SystemUInt32
sendID
Type: SystemUInt32
See Also

Reference

FlightSimulatorXException Class
FlightSimulatorXException Overload
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Properties

FlightSimulatorXException Properties

The FlightSimulatorXException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | Gets the FSX exception identifier.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | RawExceptionCode | Gets the FSX exception code that underlies ExceptionCode.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException.ExceptionCode Property

FlightSimulatorXExceptionExceptionCode Property
Gets the FSX exception identifier.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightSimulatorXExceptionCode ExceptionCode { get; }
Public ReadOnly Property ExceptionCode As FlightSimulatorXExceptionCode
    Get
public:
property FlightSimulatorXExceptionCode ExceptionCode {
    FlightSimulatorXExceptionCode get ();
}
member ExceptionCode : FlightSimulatorXExceptionCode with get

Property Value

Type: FlightSimulatorXExceptionCode
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException.RawExceptionCode Property

FlightSimulatorXExceptionRawExceptionCode Property
Gets the FSX exception code that underlies ExceptionCode.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint RawExceptionCode { get; }
Public ReadOnly Property RawExceptionCode As UInteger
    Get
public:
property unsigned int RawExceptionCode {
    unsigned int get ();
}
member RawExceptionCode : uint32 with get

Property Value

Type: UInt32
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Methods

FlightSimulatorXException Methods

The FlightSimulatorXException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Events

FlightSimulatorXException Events

The FlightSimulatorXException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException Fields

FlightSimulatorXException Fields

The FlightSimulatorXException type exposes the following members.

Fields
 | Name | Description
Public field | IndexNumber | Gets the index number (1-based) of the parameter that caused the exception. 0 indicates that the erroneous parameter number is not known / not applicable.
Public field | SendID | Gets the identifier of the packet that caused the error.
Top
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException.IndexNumber Field

FlightSimulatorXExceptionIndexNumber Field
Gets the index number (1-based) of the parameter that caused the exception. 0 indicates that the erroneous parameter number is not known / not applicable.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint IndexNumber
Public IndexNumber As UInteger
public:
unsigned int IndexNumber
val mutable IndexNumber: uint32

Field Value

Type: UInt32
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXException.SendID Field

FlightSimulatorXExceptionSendID Field
Gets the identifier of the packet that caused the error.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint SendID
Public SendID As UInteger
public:
unsigned int SendID
val mutable SendID: uint32

Field Value

Type: UInt32
See Also

Reference

FlightSimulatorXException Class
VirtualRadar.Interface.FlightSimulatorX Namespace


FlightSimulatorXExceptionCode Enumeration

FlightSimulatorXExceptionCode Enumeration
An enumeration of the reasons given by Flight Simulator X for throwing an exception.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FlightSimulatorXExceptionCode
Public Enumeration FlightSimulatorXExceptionCode
public enum class FlightSimulatorXExceptionCode
type FlightSimulatorXExceptionCode
Members
Member name | Value | Description
None | 0 |
Error | 1 |
SizeMismatch | 2 |
UnrecognizedId | 3 |
Unopened | 4 |
VersionMismatch | 5 |
TooManyGroups | 6 |
NameUnrecognized | 7 |
TooManyEventNames | 8 |
EventIdDuplicate | 9 |
TooManyMaps | 10 |
TooManyObjects | 11 |
TooManyRequests | 12 |
WeatherInvalidPort | 13 |
WeatherInvalidMetar | 14 |
WeatherUnableToGetObservation | 15 |
WeatherUnableToCreateStation | 16 |
WeatherUnableToRemoveStation | 17 |
Invalid_dataType | 18 |
Invalid_dataSize | 19 |
DataError | 20 |
InvalidArray | 21 |
CreateObjectFailed | 22 |
LoadFlightplanFailed | 23 |
OperationInvalidForOjbectType | 24 |
IllegalOperation | 25 |
AlreadySubscribed | 26 |
InvalidEnum | 27 |
DefinitionError | 28 |
DuplicateId | 29 |
DatumId | 30 |
OutOfBounds | 31 |
AlreadyCreated | 32 |
ObjectOutsideReality_bubble | 33 |
ObjectContainer | 34 |
ObjectAi | 35 |
ObjectAtc | 36 |
ObjectSchedule | 37 |
Unknown | 4294967295 |
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX Interface

IFlightSimulatorX Interface
The interface for objects that can talk to Microsoft's Flight Simulator X for us.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFlightSimulatorX : IDisposable
Public Interface IFlightSimulatorX
    Inherits IDisposable
public interface class IFlightSimulatorX : IDisposable
type IFlightSimulatorX =
    interface
        interface IDisposable
    end

The IFlightSimulatorX type exposes the following members.

Properties
 | Name | Description
Public property | Connected | Gets a value indicating whether we are connected to Flight Simulator X or not.
Public property | ConnectionStatus | Gets a description of the state of the connection to FSX.
Public property | IsFrozen | Gets or sets a value indicating that the simulated aircraft's position, altitude and attitude are frozen in FSX. When an aircraft is frozen it is unable to move but FSX will register a collision if it hits an object or the ground.
Public property | IsInstalled | Gets a value indicating that Flight Simulator X appears to be installed.
Public property | IsSlewing | Gets or sets a value indicating that the simulator is in slew mode. In slew mode the aircraft does not fly normally but the pitch is still affected by the simulated environment. FSX will ignore collisions with objects or the ground.
Public property | MessagesReceivedCount | Gets a count of messages that have been sent from FSX.
Top
Methods
 | Name | Description
Public method | Connect | Connects to Flight Simulator X.
Public method | Disconnect | Disconnects from Flight Simulator X.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | IsSimConnectMessage | Returns true if the Windows message is a SimConnect message from Flight Simulator X.
Public method | MoveAircraft | Tells Flight Simulator to move the simulated aircraft to the position specified.
Public method | RequestAircraftInformation | Sends a request to Flight Simulator for information about the simulated aircraft.
Top
Events
 | Name | Description
Public event | AircraftInformationReceived | Raised when Flight Simulator responds to a call to RequestAircraftInformation.
Public event | ConnectionStatusChanged | Raised whenever ConnectionStatus changes.
Public event | FlightSimulatorXExceptionRaised | Raised whenever Flight Simulator raises an exception.
Public event | FreezeStatusChanged | Raised whenever IsFrozen changes.
Public event | SlewStatusChanged | Raised whenever IsSlewing changes.
Public event | SlewToggled | Raised whenever the user manually toggles slew mode within the game.
Top
Remarks
SimConnect sends messages to another application via Windows messages, so we need to have access to a WndProc for this to work. The .NET framework doesn't make it easy to get at the WndProc for a form directly, you need to inherit from the form to do so. We could use interop and just do it the old-fashioned way but it feels a bit naughty-naughty, so instead the caller should call IsSimConnectMessage(Message) for every message they receive and do nothing if it returns true.
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX Properties

IFlightSimulatorX Properties

The IFlightSimulatorX type exposes the following members.

Properties
 | Name | Description
Public property | Connected | Gets a value indicating whether we are connected to Flight Simulator X or not.
Public property | ConnectionStatus | Gets a description of the state of the connection to FSX.
Public property | IsFrozen | Gets or sets a value indicating that the simulated aircraft's position, altitude and attitude are frozen in FSX. When an aircraft is frozen it is unable to move but FSX will register a collision if it hits an object or the ground.
Public property | IsInstalled | Gets a value indicating that Flight Simulator X appears to be installed.
Public property | IsSlewing | Gets or sets a value indicating that the simulator is in slew mode. In slew mode the aircraft does not fly normally but the pitch is still affected by the simulated environment. FSX will ignore collisions with objects or the ground.
Public property | MessagesReceivedCount | Gets a count of messages that have been sent from FSX.
Top
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.Connected Property

IFlightSimulatorXConnected Property
Gets a value indicating whether we are connected to Flight Simulator X or not.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Connected { get; }
ReadOnly Property Connected As Boolean
    Get
property bool Connected {
    bool get ();
}
abstract Connected : bool with get

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.ConnectionStatus Property

IFlightSimulatorXConnectionStatus Property
Gets a description of the state of the connection to FSX.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConnectionStatus { get; }
ReadOnly Property ConnectionStatus As String
    Get
property String^ ConnectionStatus {
    String^ get ();
}
abstract ConnectionStatus : string with get

Property Value

Type: String
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.IsFrozen Property

IFlightSimulatorXIsFrozen Property
Gets or sets a value indicating that the simulated aircraft's position, altitude and attitude are frozen in FSX. When an aircraft is frozen it is unable to move but FSX will register a collision if it hits an object or the ground.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsFrozen { get; set; }
Property IsFrozen As Boolean
    Get
    Set
property bool IsFrozen {
    bool get ();
    void set (bool value);
}
abstract IsFrozen : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.IsInstalled Property

IFlightSimulatorXIsInstalled Property
Gets a value indicating that Flight Simulator X appears to be installed.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsInstalled { get; }
ReadOnly Property IsInstalled As Boolean
    Get
property bool IsInstalled {
    bool get ();
}
abstract IsInstalled : bool with get

Property Value

Type: Boolean
Remarks
If this returns false then the behaviour of the rest of the object is undefined.
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.IsSlewing Property

IFlightSimulatorXIsSlewing Property
Gets or sets a value indicating that the simulator is in slew mode. In slew mode the aircraft does not fly normally but the pitch is still affected by the simulated environment. FSX will ignore collisions with objects or the ground.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSlewing { get; set; }
Property IsSlewing As Boolean
    Get
    Set
property bool IsSlewing {
    bool get ();
    void set (bool value);
}
abstract IsSlewing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.MessagesReceivedCount Property

IFlightSimulatorXMessagesReceivedCount Property
Gets a count of messages that have been sent from FSX.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MessagesReceivedCount { get; }
ReadOnly Property MessagesReceivedCount As Integer
    Get
property int MessagesReceivedCount {
    int get ();
}
abstract MessagesReceivedCount : int with get

Property Value

Type: Int32
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX Methods

IFlightSimulatorX Methods

The IFlightSimulatorX type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connects to Flight Simulator X.
Public method | Disconnect | Disconnects from Flight Simulator X.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | IsSimConnectMessage | Returns true if the Windows message is a SimConnect message from Flight Simulator X.
Public method | MoveAircraft | Tells Flight Simulator to move the simulated aircraft to the position specified.
Public method | RequestAircraftInformation | Sends a request to Flight Simulator for information about the simulated aircraft.
Top
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.Connect Method

IFlightSimulatorXConnect Method
Connects to Flight Simulator X.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Connect(
    IntPtr windowHandle
)
Sub Connect (
    windowHandle As IntPtr
)
void Connect(
    IntPtr windowHandle
)
abstract Connect :
        windowHandle : IntPtr -> unit

Parameters

windowHandle
Type: SystemIntPtr
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.Disconnect Method

IFlightSimulatorXDisconnect Method
Disconnects from Flight Simulator X.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.IsSimConnectMessage Method

IFlightSimulatorXIsSimConnectMessage Method
Returns true if the Windows message is a SimConnect message from Flight Simulator X.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSimConnectMessage(
    Message message
)
Function IsSimConnectMessage (
    message As Message
) As Boolean
bool IsSimConnectMessage(
    Message message
)
abstract IsSimConnectMessage :
        message : Message -> bool

Parameters

message
Type: System.Windows.FormsMessage

Return Value

Type: Boolean
True if the message is a SimConnect message, false if it is not.
Remarks
You will need to have an open form for SimConnect / Flight Simulator X to send messages to. Override the DefWndProc method on the form and then pass every message that comes into the form to this method. If this method returns true then throw the message away, otherwise pass it on for normal processing.
Examples
Copy
protected override void DefWndProc(ref Message m)
{
    if(!_FlightSimulatorX.IsSimConnectMessage(m)) base.DefWndProc(ref m);
}
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.MoveAircraft Method

IFlightSimulatorXMoveAircraft Method
Tells Flight Simulator to move the simulated aircraft to the position specified.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveAircraft(
    WriteAircraftInformation aircraftInformation
)
Sub MoveAircraft (
    aircraftInformation As WriteAircraftInformation
)
void MoveAircraft(
    WriteAircraftInformation aircraftInformation
)
abstract MoveAircraft :
        aircraftInformation : WriteAircraftInformation -> unit

Parameters

aircraftInformation
Type: VirtualRadar.Interface.FlightSimulatorXWriteAircraftInformation
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.RequestAircraftInformation Method

IFlightSimulatorXRequestAircraftInformation Method
Sends a request to Flight Simulator for information about the simulated aircraft.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RequestAircraftInformation()
Sub RequestAircraftInformation
void RequestAircraftInformation()
abstract RequestAircraftInformation : unit -> unit
Remarks
This should be sent to FSX from the GUI thread. FSX will reply at some point and cause AircraftInformationReceived to be raised, also on the GUI thread.
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX Events

IFlightSimulatorX Events

The IFlightSimulatorX type exposes the following members.

Events
 | Name | Description
Public event | AircraftInformationReceived | Raised when Flight Simulator responds to a call to RequestAircraftInformation.
Public event | ConnectionStatusChanged | Raised whenever ConnectionStatus changes.
Public event | FlightSimulatorXExceptionRaised | Raised whenever Flight Simulator raises an exception.
Public event | FreezeStatusChanged | Raised whenever IsFrozen changes.
Public event | SlewStatusChanged | Raised whenever IsSlewing changes.
Public event | SlewToggled | Raised whenever the user manually toggles slew mode within the game.
Top
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.AircraftInformationReceived Event

IFlightSimulatorXAircraftInformationReceived Event
Raised when Flight Simulator responds to a call to RequestAircraftInformation.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<ReadAircraftInformation>> AircraftInformationReceived
Event AircraftInformationReceived As EventHandler(Of EventArgs(Of ReadAircraftInformation))
 event EventHandler<EventArgs<ReadAircraftInformation>^>^ AircraftInformationReceived {
    void add (EventHandler<EventArgs<ReadAircraftInformation>^>^ value);
    void remove (EventHandler<EventArgs<ReadAircraftInformation>^>^ value);
}
abstract AircraftInformationReceived : IEvent<EventHandler<EventArgs<ReadAircraftInformation>>,
    EventArgs<ReadAircraftInformation>>

Value

Type: SystemEventHandler EventArgs ReadAircraftInformation
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.ConnectionStatusChanged Event

IFlightSimulatorXConnectionStatusChanged Event
Raised whenever ConnectionStatus changes.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConnectionStatusChanged
Event ConnectionStatusChanged As EventHandler
 event EventHandler^ ConnectionStatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConnectionStatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.FlightSimulatorXExceptionRaised Event

IFlightSimulatorXFlightSimulatorXExceptionRaised Event
Raised whenever Flight Simulator raises an exception.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<FlightSimulatorXException>> FlightSimulatorXExceptionRaised
Event FlightSimulatorXExceptionRaised As EventHandler(Of EventArgs(Of FlightSimulatorXException))
 event EventHandler<EventArgs<FlightSimulatorXException^>^>^ FlightSimulatorXExceptionRaised {
    void add (EventHandler<EventArgs<FlightSimulatorXException^>^>^ value);
    void remove (EventHandler<EventArgs<FlightSimulatorXException^>^>^ value);
}
abstract FlightSimulatorXExceptionRaised : IEvent<EventHandler<EventArgs<FlightSimulatorXException>>,
    EventArgs<FlightSimulatorXException>>

Value

Type: SystemEventHandler EventArgs FlightSimulatorXException
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.FreezeStatusChanged Event

IFlightSimulatorXFreezeStatusChanged Event
Raised whenever IsFrozen changes.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FreezeStatusChanged
Event FreezeStatusChanged As EventHandler
 event EventHandler^ FreezeStatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FreezeStatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.SlewStatusChanged Event

IFlightSimulatorXSlewStatusChanged Event
Raised whenever IsSlewing changes.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SlewStatusChanged
Event SlewStatusChanged As EventHandler
 event EventHandler^ SlewStatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SlewStatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


IFlightSimulatorX.SlewToggled Event

IFlightSimulatorXSlewToggled Event
Raised whenever the user manually toggles slew mode within the game.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SlewToggled
Event SlewToggled As EventHandler
 event EventHandler^ SlewToggled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SlewToggled : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorX Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper Interface

ISimConnectWrapper Interface
The interface for objects that allows tests to abstract away the SimConnect object that we have to use to connect to FSX.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISimConnectWrapper : IDisposable
Public Interface ISimConnectWrapper
    Inherits IDisposable
public interface class ISimConnectWrapper : IDisposable
type ISimConnectWrapper =
    interface
        interface IDisposable
    end

The ISimConnectWrapper type exposes the following members.

Properties
 | Name | Description
Public property | IsInstalled | Gets a value that indicates that SimConnect is installed and we were able to successfully make a null call on it without getting an exception.
Public property | UnusedValue | Gets the value to pass for parameters that are not used - wraps SimConnect.SIMCONNECT_UNUSED.
Top
Methods
 | Name | Description
Public method | AddClientEventToNotificationGroup | Wraps a call to SimConnect.AddClientEventToNotificationGroup.
Public method | AddToDataDefinition | Wraps a call to SimConnect.AddToDataDefinition.
Public method | CreateSimConnect | Wraps a call to create the SimConnect object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | MapClientEventToSimEvent | Wraps a call to SimConnect.MapClientEventToSimEvent.
Public method | ReceiveMessage | Wraps a call to SimConnect.ReceiveMessage.
Public method | RegisterDataDefineStructT | Wraps a call to SimConnect.RegisterDataDefineStruct.
Public method | RequestDataOnSimObjectType | Wraps a call to SimConnect.RequestDataOnSimObjectType.
Public method | SetDataOnSimObject | Wraps a call to SetDataOnSimObject.
Public method | SetSystemEventState | Wraps a call to SimConnect.SetSystemEventState.
Public method | SubscribeToSystemEvent | Wraps a call to SimConnect.SubscribeToSystemEvent.
Public method | TransmitClientEvent | Wraps a call to SimConnect.TransmitClientEvent.
Top
Events
 | Name | Description
Public event | EventObserved | Raised when SimConnect detects that an event has taken place within Flight Simulator.
Public event | ExceptionRaised | Raised when SimConnect throws an exception.
Public event | ObjectReceived | Raised when SimConnect returns information about an object that was previously requested.
Public event | UserHasQuit | Raised when the user quits Flight Simulator.
Top
Remarks
Part of the public behaviour of the IFlightSimulatorX object is that it must talk to SimConnect and say the right things. This provider wraps SimConnect so that we can check that IFSX is using it properly without having to have FSX installed. It is a very lightweight wrapper, you will need to read the SimConnect documentation in conjunction with the code.
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper Properties

ISimConnectWrapper Properties

The ISimConnectWrapper type exposes the following members.

Properties
 | Name | Description
Public property | IsInstalled | Gets a value that indicates that SimConnect is installed and we were able to successfully make a null call on it without getting an exception.
Public property | UnusedValue | Gets the value to pass for parameters that are not used - wraps SimConnect.SIMCONNECT_UNUSED.
Top
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.IsInstalled Property

ISimConnectWrapperIsInstalled Property
Gets a value that indicates that SimConnect is installed and we were able to successfully make a null call on it without getting an exception.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsInstalled { get; }
ReadOnly Property IsInstalled As Boolean
    Get
property bool IsInstalled {
    bool get ();
}
abstract IsInstalled : bool with get

Property Value

Type: Boolean
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.UnusedValue Property

ISimConnectWrapperUnusedValue Property
Gets the value to pass for parameters that are not used - wraps SimConnect.SIMCONNECT_UNUSED.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
uint UnusedValue { get; }
ReadOnly Property UnusedValue As UInteger
    Get
property unsigned int UnusedValue {
    unsigned int get ();
}
abstract UnusedValue : uint32 with get

Property Value

Type: UInt32
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper Methods

ISimConnectWrapper Methods

The ISimConnectWrapper type exposes the following members.

Methods
 | Name | Description
Public method | AddClientEventToNotificationGroup | Wraps a call to SimConnect.AddClientEventToNotificationGroup.
Public method | AddToDataDefinition | Wraps a call to SimConnect.AddToDataDefinition.
Public method | CreateSimConnect | Wraps a call to create the SimConnect object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | MapClientEventToSimEvent | Wraps a call to SimConnect.MapClientEventToSimEvent.
Public method | ReceiveMessage | Wraps a call to SimConnect.ReceiveMessage.
Public method | RegisterDataDefineStructT | Wraps a call to SimConnect.RegisterDataDefineStruct.
Public method | RequestDataOnSimObjectType | Wraps a call to SimConnect.RequestDataOnSimObjectType.
Public method | SetDataOnSimObject | Wraps a call to SetDataOnSimObject.
Public method | SetSystemEventState | Wraps a call to SimConnect.SetSystemEventState.
Public method | SubscribeToSystemEvent | Wraps a call to SimConnect.SubscribeToSystemEvent.
Public method | TransmitClientEvent | Wraps a call to SimConnect.TransmitClientEvent.
Top
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.AddClientEventToNotificationGroup Method

ISimConnectWrapperAddClientEventToNotificationGroup Method
Wraps a call to SimConnect.AddClientEventToNotificationGroup.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddClientEventToNotificationGroup(
    Enum groupId,
    Enum eventId,
    bool maskable
)
Sub AddClientEventToNotificationGroup (
    groupId As Enum,
    eventId As Enum,
    maskable As Boolean
)
void AddClientEventToNotificationGroup(
    Enum^ groupId,
    Enum^ eventId,
    bool maskable
)
abstract AddClientEventToNotificationGroup :
        groupId : Enum *
        eventId : Enum *
        maskable : bool -> unit

Parameters

groupId
Type: SystemEnum
eventId
Type: SystemEnum
maskable
Type: SystemBoolean
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.AddToDataDefinition Method

ISimConnectWrapperAddToDataDefinition Method
Wraps a call to SimConnect.AddToDataDefinition.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddToDataDefinition(
    Enum defineId,
    string fieldName,
    string unitsName,
    int dataType,
    float epsilon,
    uint dataId
)
Sub AddToDataDefinition (
    defineId As Enum,
    fieldName As String,
    unitsName As String,
    dataType As Integer,
    epsilon As Single,
    dataId As UInteger
)
void AddToDataDefinition(
    Enum^ defineId,
    String^ fieldName,
    String^ unitsName,
    int dataType,
    float epsilon,
    unsigned int dataId
)
abstract AddToDataDefinition :
        defineId : Enum *
        fieldName : string *
        unitsName : string *
        dataType : int *
        epsilon : float32 *
        dataId : uint32 -> unit

Parameters

defineId
Type: SystemEnum
fieldName
Type: SystemString
unitsName
Type: SystemString
dataType
Type: SystemInt32
epsilon
Type: SystemSingle
dataId
Type: SystemUInt32
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.CreateSimConnect Method

ISimConnectWrapperCreateSimConnect Method
Wraps a call to create the SimConnect object.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateSimConnect(
    string name,
    IntPtr windowHandle,
    uint userEventWin32,
    WaitHandle eventHandle,
    uint configurationIndex
)
Sub CreateSimConnect (
    name As String,
    windowHandle As IntPtr,
    userEventWin32 As UInteger,
    eventHandle As WaitHandle,
    configurationIndex As UInteger
)
void CreateSimConnect(
    String^ name,
    IntPtr windowHandle,
    unsigned int userEventWin32,
    WaitHandle^ eventHandle,
    unsigned int configurationIndex
)
abstract CreateSimConnect :
        name : string *
        windowHandle : IntPtr *
        userEventWin32 : uint32 *
        eventHandle : WaitHandle *
        configurationIndex : uint32 -> unit

Parameters

name
Type: SystemString
windowHandle
Type: SystemIntPtr
userEventWin32
Type: SystemUInt32
eventHandle
Type: System.ThreadingWaitHandle
configurationIndex
Type: SystemUInt32
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.MapClientEventToSimEvent Method

ISimConnectWrapperMapClientEventToSimEvent Method
Wraps a call to SimConnect.MapClientEventToSimEvent.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void MapClientEventToSimEvent(
    Enum eventId,
    string eventName
)
Sub MapClientEventToSimEvent (
    eventId As Enum,
    eventName As String
)
void MapClientEventToSimEvent(
    Enum^ eventId,
    String^ eventName
)
abstract MapClientEventToSimEvent :
        eventId : Enum *
        eventName : string -> unit

Parameters

eventId
Type: SystemEnum
eventName
Type: SystemString
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.ReceiveMessage Method

ISimConnectWrapperReceiveMessage Method
Wraps a call to SimConnect.ReceiveMessage.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReceiveMessage()
Sub ReceiveMessage
void ReceiveMessage()
abstract ReceiveMessage : unit -> unit
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.RegisterDataDefineStruct(T) Method

ISimConnectWrapperRegisterDataDefineStructT Method
Wraps a call to SimConnect.RegisterDataDefineStruct.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterDataDefineStruct<T>(
    Enum definitionId
)

Sub RegisterDataDefineStruct(Of T) (
    definitionId As Enum
)
generic<typename T>
void RegisterDataDefineStruct(
    Enum^ definitionId
)
abstract RegisterDataDefineStruct :
        definitionId : Enum -> unit

Parameters

definitionId
Type: SystemEnum

Type Parameters

T
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.RequestDataOnSimObjectType Method

ISimConnectWrapperRequestDataOnSimObjectType Method
Wraps a call to SimConnect.RequestDataOnSimObjectType.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RequestDataOnSimObjectType(
    Enum requestId,
    Enum definitionId,
    uint radius,
    int objectType
)
Sub RequestDataOnSimObjectType (
    requestId As Enum,
    definitionId As Enum,
    radius As UInteger,
    objectType As Integer
)
void RequestDataOnSimObjectType(
    Enum^ requestId,
    Enum^ definitionId,
    unsigned int radius,
    int objectType
)
abstract RequestDataOnSimObjectType :
        requestId : Enum *
        definitionId : Enum *
        radius : uint32 *
        objectType : int -> unit

Parameters

requestId
Type: SystemEnum
definitionId
Type: SystemEnum
radius
Type: SystemUInt32
objectType
Type: SystemInt32
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.SetDataOnSimObject Method

ISimConnectWrapperSetDataOnSimObject Method
Wraps a call to SetDataOnSimObject.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetDataOnSimObject(
    Enum defineID,
    uint objectID,
    int flags,
    Object data
)
Sub SetDataOnSimObject (
    defineID As Enum,
    objectID As UInteger,
    flags As Integer,
    data As Object
)
void SetDataOnSimObject(
    Enum^ defineID,
    unsigned int objectID,
    int flags,
    Object^ data
)
abstract SetDataOnSimObject :
        defineID : Enum *
        objectID : uint32 *
        flags : int *
        data : Object -> unit

Parameters

defineID
Type: SystemEnum
objectID
Type: SystemUInt32
flags
Type: SystemInt32
data
Type: SystemObject
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.SetSystemEventState Method

ISimConnectWrapperSetSystemEventState Method
Wraps a call to SimConnect.SetSystemEventState.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetSystemEventState(
    Enum eventId,
    bool on
)
Sub SetSystemEventState (
    eventId As Enum,
    on As Boolean
)
void SetSystemEventState(
    Enum^ eventId,
    bool on
)
abstract SetSystemEventState :
        eventId : Enum *
        on : bool -> unit

Parameters

eventId
Type: SystemEnum
on
Type: SystemBoolean
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.SubscribeToSystemEvent Method

ISimConnectWrapperSubscribeToSystemEvent Method
Wraps a call to SimConnect.SubscribeToSystemEvent.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SubscribeToSystemEvent(
    Enum eventId,
    string eventName
)
Sub SubscribeToSystemEvent (
    eventId As Enum,
    eventName As String
)
void SubscribeToSystemEvent(
    Enum^ eventId,
    String^ eventName
)
abstract SubscribeToSystemEvent :
        eventId : Enum *
        eventName : string -> unit

Parameters

eventId
Type: SystemEnum
eventName
Type: SystemString
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.TransmitClientEvent Method

ISimConnectWrapperTransmitClientEvent Method
Wraps a call to SimConnect.TransmitClientEvent.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TransmitClientEvent(
    uint objectId,
    Enum eventId,
    uint value,
    Enum groupId,
    int flags
)
Sub TransmitClientEvent (
    objectId As UInteger,
    eventId As Enum,
    value As UInteger,
    groupId As Enum,
    flags As Integer
)
void TransmitClientEvent(
    unsigned int objectId,
    Enum^ eventId,
    unsigned int value,
    Enum^ groupId,
    int flags
)
abstract TransmitClientEvent :
        objectId : uint32 *
        eventId : Enum *
        value : uint32 *
        groupId : Enum *
        flags : int -> unit

Parameters

objectId
Type: SystemUInt32
eventId
Type: SystemEnum
value
Type: SystemUInt32
groupId
Type: SystemEnum
flags
Type: SystemInt32
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper Events

ISimConnectWrapper Events

The ISimConnectWrapper type exposes the following members.

Events
 | Name | Description
Public event | EventObserved | Raised when SimConnect detects that an event has taken place within Flight Simulator.
Public event | ExceptionRaised | Raised when SimConnect throws an exception.
Public event | ObjectReceived | Raised when SimConnect returns information about an object that was previously requested.
Public event | UserHasQuit | Raised when the user quits Flight Simulator.
Top
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.EventObserved Event

ISimConnectWrapperEventObserved Event
Raised when SimConnect detects that an event has taken place within Flight Simulator.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<SimConnectEventObservedEventArgs> EventObserved
Event EventObserved As EventHandler(Of SimConnectEventObservedEventArgs)
 event EventHandler<SimConnectEventObservedEventArgs^>^ EventObserved {
    void add (EventHandler<SimConnectEventObservedEventArgs^>^ value);
    void remove (EventHandler<SimConnectEventObservedEventArgs^>^ value);
}
abstract EventObserved : IEvent<EventHandler<SimConnectEventObservedEventArgs>,
    SimConnectEventObservedEventArgs>

Value

Type: SystemEventHandler SimConnectEventObservedEventArgs
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.ExceptionRaised Event

ISimConnectWrapperExceptionRaised Event
Raised when SimConnect throws an exception.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<SimConnectExceptionRaisedEventArgs> ExceptionRaised
Event ExceptionRaised As EventHandler(Of SimConnectExceptionRaisedEventArgs)
 event EventHandler<SimConnectExceptionRaisedEventArgs^>^ ExceptionRaised {
    void add (EventHandler<SimConnectExceptionRaisedEventArgs^>^ value);
    void remove (EventHandler<SimConnectExceptionRaisedEventArgs^>^ value);
}
abstract ExceptionRaised : IEvent<EventHandler<SimConnectExceptionRaisedEventArgs>,
    SimConnectExceptionRaisedEventArgs>

Value

Type: SystemEventHandler SimConnectExceptionRaisedEventArgs
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.ObjectReceived Event

ISimConnectWrapperObjectReceived Event
Raised when SimConnect returns information about an object that was previously requested.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<SimConnectObjectReceivedEventArgs> ObjectReceived
Event ObjectReceived As EventHandler(Of SimConnectObjectReceivedEventArgs)
 event EventHandler<SimConnectObjectReceivedEventArgs^>^ ObjectReceived {
    void add (EventHandler<SimConnectObjectReceivedEventArgs^>^ value);
    void remove (EventHandler<SimConnectObjectReceivedEventArgs^>^ value);
}
abstract ObjectReceived : IEvent<EventHandler<SimConnectObjectReceivedEventArgs>,
    SimConnectObjectReceivedEventArgs>

Value

Type: SystemEventHandler SimConnectObjectReceivedEventArgs
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ISimConnectWrapper.UserHasQuit Event

ISimConnectWrapperUserHasQuit Event
Raised when the user quits Flight Simulator.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UserHasQuit
Event UserHasQuit As EventHandler
 event EventHandler^ UserHasQuit {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserHasQuit : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISimConnectWrapper Interface
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation Structure

ReadAircraftInformation Structure
The structure that IFlightSimulatorX will fill in with information about the simulated aircraft currently flying in FSX.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct ReadAircraftInformation
Public Structure ReadAircraftInformation
public value class ReadAircraftInformation
[<SealedAttribute>]
type ReadAircraftInformation =  struct end

The ReadAircraftInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AirspeedIndicated | The aircraft's current indicated airspeed in knots.
Public field | Altitude | The aircraft's altitude in feet.
Public field | Latitude | The aircraft's latitude.
Public field | Longitude | The aircraft's longitude.
Public field | MaxAirspeedIndicated | The aircraft's maximum indicated airspeed in knots.
Public field | Model | The aircraft's model (known as ATC TYPE in FSX).
Public field | OnGround | A value indicating whether the aircraft is flying.
Public field | Operator | The aircraft's operator.
Public field | Registration | The aircraft's registration.
Public field | Squawk | The squawk code on the main transponder for the aircraft.
Public field | TrueHeading | The aircraft's heading in degrees clockwise from north.
Public field | Type | The aircraft's type (known as ATC MODEL in FSX).
Public field | VerticalSpeed | The aircraft's rate of climb or descent in feet per minute.
Top
Remarks
The order in which the fields appear in this structure is important - do not change it without also changing the order of field registration in IFlightSimulatorX's implementation.
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation Methods

ReadAircraftInformation Methods

The ReadAircraftInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation Fields

ReadAircraftInformation Fields

The ReadAircraftInformation type exposes the following members.

Fields
 | Name | Description
Public field | AirspeedIndicated | The aircraft's current indicated airspeed in knots.
Public field | Altitude | The aircraft's altitude in feet.
Public field | Latitude | The aircraft's latitude.
Public field | Longitude | The aircraft's longitude.
Public field | MaxAirspeedIndicated | The aircraft's maximum indicated airspeed in knots.
Public field | Model | The aircraft's model (known as ATC TYPE in FSX).
Public field | OnGround | A value indicating whether the aircraft is flying.
Public field | Operator | The aircraft's operator.
Public field | Registration | The aircraft's registration.
Public field | Squawk | The squawk code on the main transponder for the aircraft.
Public field | TrueHeading | The aircraft's heading in degrees clockwise from north.
Public field | Type | The aircraft's type (known as ATC MODEL in FSX).
Public field | VerticalSpeed | The aircraft's rate of climb or descent in feet per minute.
Top
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.AirspeedIndicated Field

ReadAircraftInformationAirspeedIndicated Field
The aircraft's current indicated airspeed in knots.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AirspeedIndicated
Public AirspeedIndicated As Double
public:
double AirspeedIndicated
val mutable AirspeedIndicated: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Altitude Field

ReadAircraftInformationAltitude Field
The aircraft's altitude in feet.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Altitude
Public Altitude As Double
public:
double Altitude
val mutable Altitude: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Latitude Field

ReadAircraftInformationLatitude Field
The aircraft's latitude.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude
Public Latitude As Double
public:
double Latitude
val mutable Latitude: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Longitude Field

ReadAircraftInformationLongitude Field
The aircraft's longitude.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude
Public Longitude As Double
public:
double Longitude
val mutable Longitude: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.MaxAirspeedIndicated Field

ReadAircraftInformationMaxAirspeedIndicated Field
The aircraft's maximum indicated airspeed in knots.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaxAirspeedIndicated
Public MaxAirspeedIndicated As Double
public:
double MaxAirspeedIndicated
val mutable MaxAirspeedIndicated: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Model Field

ReadAircraftInformationModel Field
The aircraft's model (known as ATC TYPE in FSX).

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Model
Public Model As String
public:
String^ Model
val mutable Model: string

Field Value

Type: String
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.OnGround Field

ReadAircraftInformationOnGround Field
A value indicating whether the aircraft is flying.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OnGround
Public OnGround As Boolean
public:
bool OnGround
val mutable OnGround: bool

Field Value

Type: Boolean
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Operator Field

ReadAircraftInformationOperator Field
The aircraft's operator.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Operator
Public Operator As String
public:
String^ Operator
val mutable Operator: string

Field Value

Type: String
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Registration Field

ReadAircraftInformationRegistration Field
The aircraft's registration.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration
Public Registration As String
public:
String^ Registration
val mutable Registration: string

Field Value

Type: String
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Squawk Field

ReadAircraftInformationSquawk Field
The squawk code on the main transponder for the aircraft.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Squawk
Public Squawk As Integer
public:
int Squawk
val mutable Squawk: int

Field Value

Type: Int32
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.TrueHeading Field

ReadAircraftInformationTrueHeading Field
The aircraft's heading in degrees clockwise from north.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TrueHeading
Public TrueHeading As Double
public:
double TrueHeading
val mutable TrueHeading: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.Type Field

ReadAircraftInformationType Field
The aircraft's type (known as ATC MODEL in FSX).

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type
Public Type As String
public:
String^ Type
val mutable Type: string

Field Value

Type: String
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


ReadAircraftInformation.VerticalSpeed Field

ReadAircraftInformationVerticalSpeed Field
The aircraft's rate of climb or descent in feet per minute.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VerticalSpeed
Public VerticalSpeed As Double
public:
double VerticalSpeed
val mutable VerticalSpeed: float

Field Value

Type: Double
See Also

Reference

ReadAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs Class

SimConnectEventObservedEventArgs Class
The event args for the EventObserved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.FlightSimulatorXSimConnectEventObservedEventArgs

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SimConnectEventObservedEventArgs : EventArgs
Public Class SimConnectEventObservedEventArgs
    Inherits EventArgs
public ref class SimConnectEventObservedEventArgs : public EventArgs
type SimConnectEventObservedEventArgs =
    class
        inherit EventArgs
    end

The SimConnectEventObservedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimConnectEventObservedEventArgs | Initializes a new instance of the SimConnectEventObservedEventArgs class
Top
Properties
 | Name | Description
Public property | EventId |
Public property | GroupId |
Public property | GroupIdIsUnknown |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs Constructor

SimConnectEventObservedEventArgs Constructor
Initializes a new instance of the SimConnectEventObservedEventArgs class

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimConnectEventObservedEventArgs()
Public Sub New
public:
SimConnectEventObservedEventArgs()
new : unit -> SimConnectEventObservedEventArgs
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs Properties

SimConnectEventObservedEventArgs Properties

The SimConnectEventObservedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | EventId |
Public property | GroupId |
Public property | GroupIdIsUnknown |
Public property | Value |
Top
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs.EventId Property

SimConnectEventObservedEventArgsEventId Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectEventObservedEventArgs.EventId"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint EventId { get; set; }
Public Property EventId As UInteger
    Get
    Set
public:
property unsigned int EventId {
    unsigned int get ();
    void set (unsigned int value);
}
member EventId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs.GroupId Property

SimConnectEventObservedEventArgsGroupId Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectEventObservedEventArgs.GroupId"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint GroupId { get; set; }
Public Property GroupId As UInteger
    Get
    Set
public:
property unsigned int GroupId {
    unsigned int get ();
    void set (unsigned int value);
}
member GroupId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs.GroupIdIsUnknown Property

SimConnectEventObservedEventArgsGroupIdIsUnknown Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectEventObservedEventArgs.GroupIdIsUnknown"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GroupIdIsUnknown { get; set; }
Public Property GroupIdIsUnknown As Boolean
    Get
    Set
public:
property bool GroupIdIsUnknown {
    bool get ();
    void set (bool value);
}
member GroupIdIsUnknown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs.Value Property

SimConnectEventObservedEventArgsValue Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectEventObservedEventArgs.Value"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint Value { get; set; }
Public Property Value As UInteger
    Get
    Set
public:
property unsigned int Value {
    unsigned int get ();
    void set (unsigned int value);
}
member Value : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectEventObservedEventArgs Methods

SimConnectEventObservedEventArgs Methods

The SimConnectEventObservedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimConnectEventObservedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs Class

SimConnectExceptionRaisedEventArgs Class
The event args for ExceptionRaised
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.FlightSimulatorXSimConnectExceptionRaisedEventArgs

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SimConnectExceptionRaisedEventArgs : EventArgs
Public Class SimConnectExceptionRaisedEventArgs
    Inherits EventArgs
public ref class SimConnectExceptionRaisedEventArgs : public EventArgs
type SimConnectExceptionRaisedEventArgs =
    class
        inherit EventArgs
    end

The SimConnectExceptionRaisedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimConnectExceptionRaisedEventArgs | Initializes a new instance of the SimConnectExceptionRaisedEventArgs class
Top
Properties
 | Name | Description
Public property | ExceptionCode |
Public property | ParameterIndex |
Public property | ParameterIndexIsUnknown |
Public property | SendId |
Public property | SendIdIsUnknown |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs Constructor

SimConnectExceptionRaisedEventArgs Constructor
Initializes a new instance of the SimConnectExceptionRaisedEventArgs class

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimConnectExceptionRaisedEventArgs()
Public Sub New
public:
SimConnectExceptionRaisedEventArgs()
new : unit -> SimConnectExceptionRaisedEventArgs
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs Properties

SimConnectExceptionRaisedEventArgs Properties

The SimConnectExceptionRaisedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ExceptionCode |
Public property | ParameterIndex |
Public property | ParameterIndexIsUnknown |
Public property | SendId |
Public property | SendIdIsUnknown |
Top
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs.ExceptionCode Property

SimConnectExceptionRaisedEventArgsExceptionCode Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectExceptionRaisedEventArgs.ExceptionCode"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ExceptionCode { get; set; }
Public Property ExceptionCode As UInteger
    Get
    Set
public:
property unsigned int ExceptionCode {
    unsigned int get ();
    void set (unsigned int value);
}
member ExceptionCode : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs.ParameterIndex Property

SimConnectExceptionRaisedEventArgsParameterIndex Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectExceptionRaisedEventArgs.ParameterIndex"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ParameterIndex { get; set; }
Public Property ParameterIndex As UInteger
    Get
    Set
public:
property unsigned int ParameterIndex {
    unsigned int get ();
    void set (unsigned int value);
}
member ParameterIndex : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs.ParameterIndexIsUnknown Property

SimConnectExceptionRaisedEventArgsParameterIndexIsUnknown Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectExceptionRaisedEventArgs.ParameterIndexIsUnknown"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ParameterIndexIsUnknown { get; set; }
Public Property ParameterIndexIsUnknown As Boolean
    Get
    Set
public:
property bool ParameterIndexIsUnknown {
    bool get ();
    void set (bool value);
}
member ParameterIndexIsUnknown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs.SendId Property

SimConnectExceptionRaisedEventArgsSendId Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectExceptionRaisedEventArgs.SendId"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint SendId { get; set; }
Public Property SendId As UInteger
    Get
    Set
public:
property unsigned int SendId {
    unsigned int get ();
    void set (unsigned int value);
}
member SendId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs.SendIdIsUnknown Property

SimConnectExceptionRaisedEventArgsSendIdIsUnknown Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectExceptionRaisedEventArgs.SendIdIsUnknown"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SendIdIsUnknown { get; set; }
Public Property SendIdIsUnknown As Boolean
    Get
    Set
public:
property bool SendIdIsUnknown {
    bool get ();
    void set (bool value);
}
member SendIdIsUnknown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectExceptionRaisedEventArgs Methods

SimConnectExceptionRaisedEventArgs Methods

The SimConnectExceptionRaisedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimConnectExceptionRaisedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs Class

SimConnectObjectReceivedEventArgs Class
The event args for ObjectReceived.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.FlightSimulatorXSimConnectObjectReceivedEventArgs

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SimConnectObjectReceivedEventArgs : EventArgs
Public Class SimConnectObjectReceivedEventArgs
    Inherits EventArgs
public ref class SimConnectObjectReceivedEventArgs : public EventArgs
type SimConnectObjectReceivedEventArgs =
    class
        inherit EventArgs
    end

The SimConnectObjectReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimConnectObjectReceivedEventArgs | Initializes a new instance of the SimConnectObjectReceivedEventArgs class
Top
Properties
 | Name | Description
Public property | Data |
Public property | DefineCount |
Public property | DefineId |
Public property | EntryNumber |
Public property | Flags |
Public property | ObjectId |
Public property | OutOf |
Public property | RequestId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs Constructor

SimConnectObjectReceivedEventArgs Constructor
Initializes a new instance of the SimConnectObjectReceivedEventArgs class

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimConnectObjectReceivedEventArgs()
Public Sub New
public:
SimConnectObjectReceivedEventArgs()
new : unit -> SimConnectObjectReceivedEventArgs
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs Properties

SimConnectObjectReceivedEventArgs Properties

The SimConnectObjectReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Public property | DefineCount |
Public property | DefineId |
Public property | EntryNumber |
Public property | Flags |
Public property | ObjectId |
Public property | OutOf |
Public property | RequestId |
Top
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.Data Property

SimConnectObjectReceivedEventArgsData Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.Data"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object[] Data { get; set; }
Public Property Data As Object()
    Get
    Set
public:
property array<Object^>^ Data {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}
member Data : Object[] with get, set

Property Value

Type: Object
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.DefineCount Property

SimConnectObjectReceivedEventArgsDefineCount Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.DefineCount"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint DefineCount { get; set; }
Public Property DefineCount As UInteger
    Get
    Set
public:
property unsigned int DefineCount {
    unsigned int get ();
    void set (unsigned int value);
}
member DefineCount : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.DefineId Property

SimConnectObjectReceivedEventArgsDefineId Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.DefineId"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint DefineId { get; set; }
Public Property DefineId As UInteger
    Get
    Set
public:
property unsigned int DefineId {
    unsigned int get ();
    void set (unsigned int value);
}
member DefineId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.EntryNumber Property

SimConnectObjectReceivedEventArgsEntryNumber Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.EntryNumber"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint EntryNumber { get; set; }
Public Property EntryNumber As UInteger
    Get
    Set
public:
property unsigned int EntryNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member EntryNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.Flags Property

SimConnectObjectReceivedEventArgsFlags Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.Flags"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint Flags { get; set; }
Public Property Flags As UInteger
    Get
    Set
public:
property unsigned int Flags {
    unsigned int get ();
    void set (unsigned int value);
}
member Flags : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.ObjectId Property

SimConnectObjectReceivedEventArgsObjectId Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.ObjectId"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ObjectId { get; set; }
Public Property ObjectId As UInteger
    Get
    Set
public:
property unsigned int ObjectId {
    unsigned int get ();
    void set (unsigned int value);
}
member ObjectId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.OutOf Property

SimConnectObjectReceivedEventArgsOutOf Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.OutOf"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint OutOf { get; set; }
Public Property OutOf As UInteger
    Get
    Set
public:
property unsigned int OutOf {
    unsigned int get ();
    void set (unsigned int value);
}
member OutOf : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs.RequestId Property

SimConnectObjectReceivedEventArgsRequestId Property

[Missing <summary> documentation for "P:VirtualRadar.Interface.FlightSimulatorX.SimConnectObjectReceivedEventArgs.RequestId"]

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint RequestId { get; set; }
Public Property RequestId As UInteger
    Get
    Set
public:
property unsigned int RequestId {
    unsigned int get ();
    void set (unsigned int value);
}
member RequestId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


SimConnectObjectReceivedEventArgs Methods

SimConnectObjectReceivedEventArgs Methods

The SimConnectObjectReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimConnectObjectReceivedEventArgs Class
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation Structure

WriteAircraftInformation Structure
The structure that is passed to IFlightSimulatorX to control the location, altitude, attitude and details of the simulated aircraft.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct WriteAircraftInformation
Public Structure WriteAircraftInformation
public value class WriteAircraftInformation
[<SealedAttribute>]
type WriteAircraftInformation =  struct end

The WriteAircraftInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | AirspeedIndicated | The aircraft's current indicated airspeed in knots.
Public field | Altitude | The aircraft's altitude in feet.
Public field | Bank | The aircraft's bank in degrees.
Public field | Latitude | The aircraft's latitude.
Public field | Longitude | The aircraft's longitude.
Public field | Operator | The aircraft's operator.
Public field | Pitch | The aircraft's pitch in degrees.
Public field | Registration | The aircraft's registration.
Public field | TrueHeading | The aircraft's heading in degrees clockwise from north.
Public field | VerticalSpeed | The aircraft's rate of climb or descent in feet per minute.
Top
Remarks
The order in which the fields appear in this structure is important - do not change it without also changing the order of field registration in IFlightSimulatorX's implementation.
See Also

Reference

VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation Methods

WriteAircraftInformation Methods

The WriteAircraftInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation Fields

WriteAircraftInformation Fields

The WriteAircraftInformation type exposes the following members.

Fields
 | Name | Description
Public field | AirspeedIndicated | The aircraft's current indicated airspeed in knots.
Public field | Altitude | The aircraft's altitude in feet.
Public field | Bank | The aircraft's bank in degrees.
Public field | Latitude | The aircraft's latitude.
Public field | Longitude | The aircraft's longitude.
Public field | Operator | The aircraft's operator.
Public field | Pitch | The aircraft's pitch in degrees.
Public field | Registration | The aircraft's registration.
Public field | TrueHeading | The aircraft's heading in degrees clockwise from north.
Public field | VerticalSpeed | The aircraft's rate of climb or descent in feet per minute.
Top
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.AirspeedIndicated Field

WriteAircraftInformationAirspeedIndicated Field
The aircraft's current indicated airspeed in knots.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AirspeedIndicated
Public AirspeedIndicated As Double
public:
double AirspeedIndicated
val mutable AirspeedIndicated: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Altitude Field

WriteAircraftInformationAltitude Field
The aircraft's altitude in feet.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Altitude
Public Altitude As Double
public:
double Altitude
val mutable Altitude: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Bank Field

WriteAircraftInformationBank Field
The aircraft's bank in degrees.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Bank
Public Bank As Double
public:
double Bank
val mutable Bank: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Latitude Field

WriteAircraftInformationLatitude Field
The aircraft's latitude.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude
Public Latitude As Double
public:
double Latitude
val mutable Latitude: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Longitude Field

WriteAircraftInformationLongitude Field
The aircraft's longitude.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude
Public Longitude As Double
public:
double Longitude
val mutable Longitude: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Operator Field

WriteAircraftInformationOperator Field
The aircraft's operator.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Operator
Public Operator As String
public:
String^ Operator
val mutable Operator: string

Field Value

Type: String
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Pitch Field

WriteAircraftInformationPitch Field
The aircraft's pitch in degrees.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Pitch
Public Pitch As Double
public:
double Pitch
val mutable Pitch: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.Registration Field

WriteAircraftInformationRegistration Field
The aircraft's registration.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration
Public Registration As String
public:
String^ Registration
val mutable Registration: string

Field Value

Type: String
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.TrueHeading Field

WriteAircraftInformationTrueHeading Field
The aircraft's heading in degrees clockwise from north.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TrueHeading
Public TrueHeading As Double
public:
double TrueHeading
val mutable TrueHeading: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


WriteAircraftInformation.VerticalSpeed Field

WriteAircraftInformationVerticalSpeed Field
The aircraft's rate of climb or descent in feet per minute.

Namespace: VirtualRadar.Interface.FlightSimulatorX
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VerticalSpeed
Public VerticalSpeed As Double
public:
double VerticalSpeed
val mutable VerticalSpeed: float

Field Value

Type: Double
See Also

Reference

WriteAircraftInformation Structure
VirtualRadar.Interface.FlightSimulatorX Namespace


VirtualRadar.Interface.Listener Namespace

VirtualRadar.Interface.Listener Namespace
The namespace for all of the interfaces and objects associated with classes that can listen to sources of aircraft data and translate them into objects that the rest of the program can use.
Classes
 | Class | Description
Public class | ExtractedBytes | The object returned by message extractors that describes the bytes corresponding to one message.
Public class | PolarPlot | A DTO that carries a single point in a polar plot.
Public class | PolarPlotSlice | A DTO that carries a slice of polar plots for a given receiver.
Public class | ReceiverFormatName | Describes a registered receiver format.
Interfaces
 | Interface | Description
Public interface | IAircraftListJsonMessageBytesExtractor | The interface for objects that can extract AircraftListJson format messages.
Public interface | IAircraftListJsonMessageConverter | The interface for an object that can turn an AircraftListJson into a collection of BaseStationMessageEventArgs objects.
Public interface | IBeastMessageBytesExtractor | The interface for objects that can extract the bytes of a Mode-S message from bytes sent from a Mode-S Beast (http://www.modesbeast.com)
Public interface | ICompressedMessageBytesExtractor | The interface for objects that can extract bytes for a message from a compressed feed.
Public interface | IFeed | The interface that ties together an aircraft list, which tracks the state of aircraft picked up by a receiver or merged feed, and a receiver or merged feed's identifier from the configuration details.
Public interface | IFeedManager | The interface for objects that can collect together a IFeed for each receiver and merged feed configured in settings.
Public interface | IListener | The interface for objects that can listen to a stream of bytes and decode them into messages.
Public interface | IMergedFeedComponentListener | The listener for a receiver that will be merged into a single feed by IMergedFeedListener.
Public interface | IMergedFeedListener | A listener that merges together messages picked up by two or more listeners.
Public interface | IMessageBytesExtractor | The interface for objects that can extract raw message bytes from an array of bytes.
Public interface | IPlaneFinderMessageBytesExtractor | The interface for classes that can extract messages from Plane Finder feeds.
Public interface | IPolarPlotter | The interface for objects that can track the values required for a polar plot.
Public interface | IPort30003MessageBytesExtractor | The interface for objects that can extract Kinetic Port 30003 format messages.
Public interface | IReceiverFormatManager | Manages the feed formats that the program can decode.
Public interface | IReceiverFormatProvider | The interface that all receiver format providers must implement.
Public interface | ISbs3MessageBytesExtractor | The interface for objects that can extract Mode-S messages from bytes read from an SBS-3.
Enumerations
 | Enumeration | Description
Public enumeration | ExtractedBytesFormat | An enumeration of the different formats that the payload of ExtractedBytes can be in.
Remarks


ExtractedBytes Class

ExtractedBytes Class
The object returned by message extractors that describes the bytes corresponding to one message.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ListenerExtractedBytes

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExtractedBytes : ICloneable
Public Class ExtractedBytes
    Implements ICloneable
public ref class ExtractedBytes : ICloneable
type ExtractedBytes =
    class
        interface ICloneable
    end

The ExtractedBytes type exposes the following members.

Constructors
 | Name | Description
Public method | ExtractedBytes | Initializes a new instance of the ExtractedBytes class
Top
Properties
 | Name | Description
Public property | Bytes | Gets or sets the array of bytes extracted from the source that describes one complete message.
Public property | ChecksumFailed | Gets or sets a value indicating that the checksum on the extracted bytes was invalid (when applicable).
Public property | Format | Gets or sets the format that the content of Bytes is in.
Public property | HasParity | Gets or sets a value indicating that the bytes have parity applied to them (when applicable).
Public property | IsMlat | Gets or sets a value indicating that the message was generated by an MLAT receiver.
Public property | Length | Gets or sets the length of the payload within Bytes.
Public property | Offset | Gets or sets the start of the payload within Bytes.
Public property | SignalLevel | Gets or sets the signal level passed along with the message, if any. If the signal level is not present then the value is null.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep copy of the object.
Public method | Equals | See base docs. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


ExtractedBytes Constructor

ExtractedBytes Constructor
Initializes a new instance of the ExtractedBytes class

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtractedBytes()
Public Sub New
public:
ExtractedBytes()
new : unit -> ExtractedBytes
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes Properties

ExtractedBytes Properties

The ExtractedBytes type exposes the following members.

Properties
 | Name | Description
Public property | Bytes | Gets or sets the array of bytes extracted from the source that describes one complete message.
Public property | ChecksumFailed | Gets or sets a value indicating that the checksum on the extracted bytes was invalid (when applicable).
Public property | Format | Gets or sets the format that the content of Bytes is in.
Public property | HasParity | Gets or sets a value indicating that the bytes have parity applied to them (when applicable).
Public property | IsMlat | Gets or sets a value indicating that the message was generated by an MLAT receiver.
Public property | Length | Gets or sets the length of the payload within Bytes.
Public property | Offset | Gets or sets the start of the payload within Bytes.
Public property | SignalLevel | Gets or sets the signal level passed along with the message, if any. If the signal level is not present then the value is null.
Top
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.Bytes Property

ExtractedBytesBytes Property
Gets or sets the array of bytes extracted from the source that describes one complete message.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes { get; set; }
Public Property Bytes As Byte()
    Get
    Set
public:
property array<unsigned char>^ Bytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Bytes : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.ChecksumFailed Property

ExtractedBytesChecksumFailed Property
Gets or sets a value indicating that the checksum on the extracted bytes was invalid (when applicable).

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ChecksumFailed { get; set; }
Public Property ChecksumFailed As Boolean
    Get
    Set
public:
property bool ChecksumFailed {
    bool get ();
    void set (bool value);
}
member ChecksumFailed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.Format Property

ExtractedBytesFormat Property
Gets or sets the format that the content of Bytes is in.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtractedBytesFormat Format { get; set; }
Public Property Format As ExtractedBytesFormat
    Get
    Set
public:
property ExtractedBytesFormat Format {
    ExtractedBytesFormat get ();
    void set (ExtractedBytesFormat value);
}
member Format : ExtractedBytesFormat with get, set

Property Value

Type: ExtractedBytesFormat
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.HasParity Property

ExtractedBytesHasParity Property
Gets or sets a value indicating that the bytes have parity applied to them (when applicable).

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasParity { get; set; }
Public Property HasParity As Boolean
    Get
    Set
public:
property bool HasParity {
    bool get ();
    void set (bool value);
}
member HasParity : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.IsMlat Property

ExtractedBytesIsMlat Property
Gets or sets a value indicating that the message was generated by an MLAT receiver.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMlat { get; set; }
Public Property IsMlat As Boolean
    Get
    Set
public:
property bool IsMlat {
    bool get ();
    void set (bool value);
}
member IsMlat : bool with get, set

Property Value

Type: Boolean
Remarks
Only certain MLAT receivers / feeds generate a marker that can be detected this early.
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.Length Property

ExtractedBytesLength Property
Gets or sets the length of the payload within Bytes.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Type: Int32
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.Offset Property

ExtractedBytesOffset Property
Gets or sets the start of the payload within Bytes.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set
public:
property int Offset {
    int get ();
    void set (int value);
}
member Offset : int with get, set

Property Value

Type: Int32
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.SignalLevel Property

ExtractedBytesSignalLevel Property
Gets or sets the signal level passed along with the message, if any. If the signal level is not present then the value is null.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SignalLevel { get; set; }
Public Property SignalLevel As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SignalLevel {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SignalLevel : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes Methods

ExtractedBytes Methods

The ExtractedBytes type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep copy of the object.
Public method | Equals | See base docs. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.Clone Method

ExtractedBytesClone Method
Returns a deep copy of the object.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytes.Equals Method

ExtractedBytesEquals Method
See base docs.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
Remarks
Note that Equals is overridden to detect identical content - it is NOT implemented to allow the class to be used as a key. The class is mutable. It must not be used as a key in dictionaries, hash tables etc.
See Also

Reference

ExtractedBytes Class
VirtualRadar.Interface.Listener Namespace


ExtractedBytesFormat Enumeration

ExtractedBytesFormat Enumeration
An enumeration of the different formats that the payload of ExtractedBytes can be in.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExtractedBytesFormat
Public Enumeration ExtractedBytesFormat
public enum class ExtractedBytesFormat
type ExtractedBytesFormat
Members
Member name | Value | Description
None | 0 | The format of the payload is unknown.
Port30003 | 1 | The format of the payload corresponds with Kinetic's de-facto standard port 30003 text.
ModeS | 2 | The format of the payload corresponds with ICAO's specification for Mode-S messages.
Compressed | 3 | The format of the payload is a compressed Port30003 object.
AircraftListJson | 4 | The format of the payload is an aircraft list formatted in UTF-8 JSON.
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IAircraftListJsonMessageBytesExtractor Interface

IAircraftListJsonMessageBytesExtractor Interface
The interface for objects that can extract AircraftListJson format messages.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftListJsonMessageBytesExtractor : IMessageBytesExtractor
Public Interface IAircraftListJsonMessageBytesExtractor
    Inherits IMessageBytesExtractor
public interface class IAircraftListJsonMessageBytesExtractor : IMessageBytesExtractor
type IAircraftListJsonMessageBytesExtractor =
    interface
        interface IMessageBytesExtractor
    end

The IAircraftListJsonMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IAircraftListJsonMessageBytesExtractor Properties

IAircraftListJsonMessageBytesExtractor Properties

The IAircraftListJsonMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IAircraftListJsonMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IAircraftListJsonMessageBytesExtractor Methods

IAircraftListJsonMessageBytesExtractor Methods

The IAircraftListJsonMessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IAircraftListJsonMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IAircraftListJsonMessageConverter Interface

IAircraftListJsonMessageConverter Interface
The interface for an object that can turn an AircraftListJson into a collection of BaseStationMessageEventArgs objects.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftListJsonMessageConverter
Public Interface IAircraftListJsonMessageConverter
public interface class IAircraftListJsonMessageConverter
type IAircraftListJsonMessageConverter =  interface end

The IAircraftListJsonMessageConverter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertIntoBaseStationMessageEventArgs | Returns a collection of BaseStationMessageEventArgs objects, one for each aircraft in the aircraft list of the AircraftListJson passed across.
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IAircraftListJsonMessageConverter Methods

IAircraftListJsonMessageConverter Methods

The IAircraftListJsonMessageConverter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertIntoBaseStationMessageEventArgs | Returns a collection of BaseStationMessageEventArgs objects, one for each aircraft in the aircraft list of the AircraftListJson passed across.
Top
See Also

Reference

IAircraftListJsonMessageConverter Interface
VirtualRadar.Interface.Listener Namespace


IAircraftListJsonMessageConverter.ConvertIntoBaseStationMessageEventArgs Method

IAircraftListJsonMessageConverterConvertIntoBaseStationMessageEventArgs Method
Returns a collection of BaseStationMessageEventArgs objects, one for each aircraft in the aircraft list of the AircraftListJson passed across.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<BaseStationMessageEventArgs> ConvertIntoBaseStationMessageEventArgs(
    AircraftListJson aircraftListJson
)
Function ConvertIntoBaseStationMessageEventArgs (
    aircraftListJson As AircraftListJson
) As IEnumerable(Of BaseStationMessageEventArgs)
IEnumerable<BaseStationMessageEventArgs^>^ ConvertIntoBaseStationMessageEventArgs(
    AircraftListJson^ aircraftListJson
)
abstract ConvertIntoBaseStationMessageEventArgs :
        aircraftListJson : AircraftListJson -> IEnumerable<BaseStationMessageEventArgs>

Parameters

aircraftListJson
Type: VirtualRadar.Interface.WebSiteAircraftListJson

Return Value

Type: IEnumerable BaseStationMessageEventArgs
See Also

Reference

IAircraftListJsonMessageConverter Interface
VirtualRadar.Interface.Listener Namespace


IBeastMessageBytesExtractor Interface

IBeastMessageBytesExtractor Interface
The interface for objects that can extract the bytes of a Mode-S message from bytes sent from a Mode-S Beast (http://www.modesbeast.com)

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBeastMessageBytesExtractor : IMessageBytesExtractor
Public Interface IBeastMessageBytesExtractor
    Inherits IMessageBytesExtractor
public interface class IBeastMessageBytesExtractor : IMessageBytesExtractor
type IBeastMessageBytesExtractor =
    interface
        interface IMessageBytesExtractor
    end

The IBeastMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IBeastMessageBytesExtractor Properties

IBeastMessageBytesExtractor Properties

The IBeastMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IBeastMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IBeastMessageBytesExtractor Methods

IBeastMessageBytesExtractor Methods

The IBeastMessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IBeastMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


ICompressedMessageBytesExtractor Interface

ICompressedMessageBytesExtractor Interface
The interface for objects that can extract bytes for a message from a compressed feed.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICompressedMessageBytesExtractor : IMessageBytesExtractor
Public Interface ICompressedMessageBytesExtractor
    Inherits IMessageBytesExtractor
public interface class ICompressedMessageBytesExtractor : IMessageBytesExtractor
type ICompressedMessageBytesExtractor =
    interface
        interface IMessageBytesExtractor
    end

The ICompressedMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


ICompressedMessageBytesExtractor Properties

ICompressedMessageBytesExtractor Properties

The ICompressedMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

ICompressedMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


ICompressedMessageBytesExtractor Methods

ICompressedMessageBytesExtractor Methods

The ICompressedMessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

ICompressedMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IFeed Interface

IFeed Interface
The interface that ties together an aircraft list, which tracks the state of aircraft picked up by a receiver or merged feed, and a receiver or merged feed's identifier from the configuration details.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFeed : IBackgroundThreadExceptionCatcher, IDisposable
Public Interface IFeed
    Inherits IBackgroundThreadExceptionCatcher, IDisposable
public interface class IFeed : IBackgroundThreadExceptionCatcher,
    IDisposable
type IFeed =
    interface
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IFeed type exposes the following members.

Properties
 | Name | Description
Public property | AircraftList | Gets the aircraft list that the feed is supplying.
Public property | IsVisible | Gets a value indicating that the feed can be viewed from the web site.
Public property | Listener | Gets the listener that AircraftList is listening to.
Public property | Name | Gets the name of the feed.
Public property | UniqueId | Gets the unique identifier of the feed.
Top
Methods
 | Name | Description
Public method | ApplyConfiguration(MergedFeed, IEnumerableIFeed) | Updates the listener with the new configuration options passed across.
Public method | ApplyConfiguration(Receiver, Configuration) | Updates the listener with the new configuration options passed across.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise(MergedFeed, IEnumerableIFeed) | Initialises the feed with the merged feed configuration settings passed across.
Public method | Initialise(Receiver, Configuration) | Initialises the feed with the receiver configuration settings passed across.
Top
Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IFeed Properties

IFeed Properties

The IFeed type exposes the following members.

Properties
 | Name | Description
Public property | AircraftList | Gets the aircraft list that the feed is supplying.
Public property | IsVisible | Gets a value indicating that the feed can be viewed from the web site.
Public property | Listener | Gets the listener that AircraftList is listening to.
Public property | Name | Gets the name of the feed.
Public property | UniqueId | Gets the unique identifier of the feed.
Top
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.AircraftList Property

IFeedAircraftList Property
Gets the aircraft list that the feed is supplying.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IBaseStationAircraftList AircraftList { get; }
ReadOnly Property AircraftList As IBaseStationAircraftList
    Get
property IBaseStationAircraftList^ AircraftList {
    IBaseStationAircraftList^ get ();
}
abstract AircraftList : IBaseStationAircraftList with get

Property Value

Type: IBaseStationAircraftList
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.IsVisible Property

IFeedIsVisible Property
Gets a value indicating that the feed can be viewed from the web site.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsVisible { get; }
ReadOnly Property IsVisible As Boolean
    Get
property bool IsVisible {
    bool get ();
}
abstract IsVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.Listener Property

IFeedListener Property
Gets the listener that AircraftList is listening to.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IListener Listener { get; }
ReadOnly Property Listener As IListener
    Get
property IListener^ Listener {
    IListener^ get ();
}
abstract Listener : IListener with get

Property Value

Type: IListener
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.Name Property

IFeedName Property
Gets the name of the feed.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.UniqueId Property

IFeedUniqueId Property
Gets the unique identifier of the feed.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int UniqueId { get; }
ReadOnly Property UniqueId As Integer
    Get
property int UniqueId {
    int get ();
}
abstract UniqueId : int with get

Property Value

Type: Int32
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed Methods

IFeed Methods

The IFeed type exposes the following members.

Methods
 | Name | Description
Public method | ApplyConfiguration(MergedFeed, IEnumerableIFeed) | Updates the listener with the new configuration options passed across.
Public method | ApplyConfiguration(Receiver, Configuration) | Updates the listener with the new configuration options passed across.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise(MergedFeed, IEnumerableIFeed) | Initialises the feed with the merged feed configuration settings passed across.
Public method | Initialise(Receiver, Configuration) | Initialises the feed with the receiver configuration settings passed across.
Top
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.ApplyConfiguration Method

IFeedApplyConfiguration Method
Overload List
 | Name | Description
Public method | ApplyConfiguration(MergedFeed, IEnumerableIFeed) | Updates the listener with the new configuration options passed across.
Public method | ApplyConfiguration(Receiver, Configuration) | Updates the listener with the new configuration options passed across.
Top
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.ApplyConfiguration Method (MergedFeed, IEnumerable(IFeed))

IFeedApplyConfiguration Method (MergedFeed, IEnumerableIFeed)
Updates the listener with the new configuration options passed across.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyConfiguration(
    MergedFeed mergedFeed,
    IEnumerable<IFeed> mergePathways
)
Sub ApplyConfiguration (
    mergedFeed As MergedFeed,
    mergePathways As IEnumerable(Of IFeed)
)
void ApplyConfiguration(
    MergedFeed^ mergedFeed,
    IEnumerable<IFeed^>^ mergePathways
)
abstract ApplyConfiguration :
        mergedFeed : MergedFeed *
        mergePathways : IEnumerable<IFeed> -> unit

Parameters

mergedFeed
Type: VirtualRadar.Interface.SettingsMergedFeed
mergePathways
Type: System.Collections.GenericIEnumerable IFeed
See Also

Reference

IFeed Interface
ApplyConfiguration Overload
VirtualRadar.Interface.Listener Namespace


IFeed.ApplyConfiguration Method (Receiver, Configuration)

IFeedApplyConfiguration Method (Receiver, Configuration)
Updates the listener with the new configuration options passed across.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyConfiguration(
    Receiver receiver,
    Configuration configuration
)
Sub ApplyConfiguration (
    receiver As Receiver,
    configuration As Configuration
)
void ApplyConfiguration(
    Receiver^ receiver,
    Configuration^ configuration
)
abstract ApplyConfiguration :
        receiver : Receiver *
        configuration : Configuration -> unit

Parameters

receiver
Type: VirtualRadar.Interface.SettingsReceiver
configuration
Type: VirtualRadar.Interface.SettingsConfiguration
See Also

Reference

IFeed Interface
ApplyConfiguration Overload
VirtualRadar.Interface.Listener Namespace


IFeed.Initialise Method

IFeedInitialise Method
Overload List
 | Name | Description
Public method | Initialise(MergedFeed, IEnumerableIFeed) | Initialises the feed with the merged feed configuration settings passed across.
Public method | Initialise(Receiver, Configuration) | Initialises the feed with the receiver configuration settings passed across.
Top
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeed.Initialise Method (MergedFeed, IEnumerable(IFeed))

IFeedInitialise Method (MergedFeed, IEnumerableIFeed)
Initialises the feed with the merged feed configuration settings passed across.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    MergedFeed mergedFeed,
    IEnumerable<IFeed> mergePathways
)
Sub Initialise (
    mergedFeed As MergedFeed,
    mergePathways As IEnumerable(Of IFeed)
)
void Initialise(
    MergedFeed^ mergedFeed,
    IEnumerable<IFeed^>^ mergePathways
)
abstract Initialise :
        mergedFeed : MergedFeed *
        mergePathways : IEnumerable<IFeed> -> unit

Parameters

mergedFeed
Type: VirtualRadar.Interface.SettingsMergedFeed
mergePathways
Type: System.Collections.GenericIEnumerable IFeed
See Also

Reference

IFeed Interface
Initialise Overload
VirtualRadar.Interface.Listener Namespace


IFeed.Initialise Method (Receiver, Configuration)

IFeedInitialise Method (Receiver, Configuration)
Initialises the feed with the receiver configuration settings passed across.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    Receiver receiver,
    Configuration configuration
)
Sub Initialise (
    receiver As Receiver,
    configuration As Configuration
)
void Initialise(
    Receiver^ receiver,
    Configuration^ configuration
)
abstract Initialise :
        receiver : Receiver *
        configuration : Configuration -> unit

Parameters

receiver
Type: VirtualRadar.Interface.SettingsReceiver
configuration
Type: VirtualRadar.Interface.SettingsConfiguration
See Also

Reference

IFeed Interface
Initialise Overload
VirtualRadar.Interface.Listener Namespace


IFeed Events

IFeed Events

The IFeed type exposes the following members.

Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

IFeed Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager Interface

IFeedManager Interface
The interface for objects that can collect together a IFeed for each receiver and merged feed configured in settings.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFeedManager : ISingleton<IFeedManager>,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface IFeedManager
    Inherits ISingleton(Of IFeedManager), IBackgroundThreadExceptionCatcher, IDisposable
public interface class IFeedManager : ISingleton<IFeedManager^>,
    IBackgroundThreadExceptionCatcher, IDisposable
type IFeedManager =
    interface
        interface ISingleton<IFeedManager>
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IFeedManager type exposes the following members.

Properties
 | Name | Description
Public property | Feeds | Gets a collection of active and enabled feeds.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | VisibleFeeds | Gets a collection of feeds that the web site can see.
Top
Methods
 | Name | Description
Public method | Connect | Causes every feed to establish a connection.
Public method | Disconnect | Causes every feed to disconnect from the data source.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetByName | Returns the feed with a given name or null if no such feed exists. Only enabled feed are returned.
Public method | GetByUniqueId | Returns the feed with the given identifier or null if no such feed exists. Only enabled feeds are returned.
Public method | Initialise | Initialises the manager.
Top
Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when the listener attached to a feed changes its connection state.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | FeedsChanged | Raised when the collection of feeds managed by the object is changed.
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IFeedManager Properties

IFeedManager Properties

The IFeedManager type exposes the following members.

Properties
 | Name | Description
Public property | Feeds | Gets a collection of active and enabled feeds.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | VisibleFeeds | Gets a collection of feeds that the web site can see.
Top
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.Feeds Property

IFeedManagerFeeds Property
Gets a collection of active and enabled feeds.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFeed[] Feeds { get; }
ReadOnly Property Feeds As IFeed()
    Get
property array<IFeed^>^ Feeds {
    array<IFeed^>^ get ();
}
abstract Feeds : IFeed[] with get

Property Value

Type: IFeed
Remarks
If a feed has been disabled in the configuration then it is not included in this collection.
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.VisibleFeeds Property

IFeedManagerVisibleFeeds Property
Gets a collection of feeds that the web site can see.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFeed[] VisibleFeeds { get; }
ReadOnly Property VisibleFeeds As IFeed()
    Get
property array<IFeed^>^ VisibleFeeds {
    array<IFeed^>^ get ();
}
abstract VisibleFeeds : IFeed[] with get

Property Value

Type: IFeed
Remarks
This is a subset of Feeds.
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager Methods

IFeedManager Methods

The IFeedManager type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Causes every feed to establish a connection.
Public method | Disconnect | Causes every feed to disconnect from the data source.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetByName | Returns the feed with a given name or null if no such feed exists. Only enabled feed are returned.
Public method | GetByUniqueId | Returns the feed with the given identifier or null if no such feed exists. Only enabled feeds are returned.
Public method | Initialise | Initialises the manager.
Top
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.Connect Method

IFeedManagerConnect Method
Causes every feed to establish a connection.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.Disconnect Method

IFeedManagerDisconnect Method
Causes every feed to disconnect from the data source.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.GetByName Method

IFeedManagerGetByName Method
Returns the feed with a given name or null if no such feed exists. Only enabled feed are returned.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFeed GetByName(
    string name,
    bool ignoreInvisibleFeeds
)
Function GetByName (
    name As String,
    ignoreInvisibleFeeds As Boolean
) As IFeed
IFeed^ GetByName(
    String^ name,
    bool ignoreInvisibleFeeds
)
abstract GetByName :
        name : string *
        ignoreInvisibleFeeds : bool -> IFeed

Parameters

name
Type: SystemString
ignoreInvisibleFeeds
Type: SystemBoolean

Return Value

Type: IFeed
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.GetByUniqueId Method

IFeedManagerGetByUniqueId Method
Returns the feed with the given identifier or null if no such feed exists. Only enabled feeds are returned.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFeed GetByUniqueId(
    int id,
    bool ignoreInvisibleFeeds
)
Function GetByUniqueId (
    id As Integer,
    ignoreInvisibleFeeds As Boolean
) As IFeed
IFeed^ GetByUniqueId(
    int id,
    bool ignoreInvisibleFeeds
)
abstract GetByUniqueId :
        id : int *
        ignoreInvisibleFeeds : bool -> IFeed

Parameters

id
Type: SystemInt32
ignoreInvisibleFeeds
Type: SystemBoolean

Return Value

Type: IFeed
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.Initialise Method

IFeedManagerInitialise Method
Initialises the manager.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager Events

IFeedManager Events

The IFeedManager type exposes the following members.

Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when the listener attached to a feed changes its connection state.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | FeedsChanged | Raised when the collection of feeds managed by the object is changed.
Top
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.ConnectionStateChanged Event

IFeedManagerConnectionStateChanged Event
Raised when the listener attached to a feed changes its connection state.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<IFeed>> ConnectionStateChanged
Event ConnectionStateChanged As EventHandler(Of EventArgs(Of IFeed))
 event EventHandler<EventArgs<IFeed^>^>^ ConnectionStateChanged {
    void add (EventHandler<EventArgs<IFeed^>^>^ value);
    void remove (EventHandler<EventArgs<IFeed^>^>^ value);
}
abstract ConnectionStateChanged : IEvent<EventHandler<EventArgs<IFeed>>,
    EventArgs<IFeed>>

Value

Type: SystemEventHandler EventArgs IFeed
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IFeedManager.FeedsChanged Event

IFeedManagerFeedsChanged Event
Raised when the collection of feeds managed by the object is changed.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FeedsChanged
Event FeedsChanged As EventHandler
 event EventHandler^ FeedsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FeedsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFeedManager Interface
VirtualRadar.Interface.Listener Namespace


IListener Interface

IListener Interface
The interface for objects that can listen to a stream of bytes and decode them into messages.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IListener : IBackgroundThreadExceptionCatcher,
    IDisposable
Public Interface IListener
    Inherits IBackgroundThreadExceptionCatcher, IDisposable
public interface class IListener : IBackgroundThreadExceptionCatcher,
    IDisposable
type IListener =
    interface
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IListener type exposes the following members.

Properties
 | Name | Description
Public property | BytesExtractor | Gets the object that can extract the important bytes from the stream. Do not modify any properties on the extractor directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.
Public property | ConnectionStatus | Gets a value indicating whether the listener is connected to the source of aircraft message data.
Public property | Connector | Gets the connector that is handling the connection for the listener. Do not modify any properties on the connection directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.
Public property | IgnoreBadMessages | Gets or sets a value indicating whether exceptions thrown by the message translator cause a disconnection and raise ExceptionCaught or whether they are ignored.
Public property | IsSatcomFeed | Gets or sets a value indicating that this is a satcom feed.
Public property | RawMessageTranslator | Gets the object that translates raw messages into Port30003 format messages. Do not modify any properties on the translator directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.
Public property | ReceiverId | Gets or sets the identity of the receiver that is controlling this listener.
Public property | ReceiverName | Gets or sets the name of the receiver that is controlling this listener.
Public property | Statistics | Gets the statistics for the listener.
Public property | TotalBadMessages | Gets a count of the total number of messages that could not be translated.
Public property | TotalMessages | Gets a count of the total number of messages received by the object.
Top
Methods
 | Name | Description
Public method | ChangeSource | Changes the connector and/or message bytes extractor used by the listener.
Public method | Connect | Connects to the source of aircraft data. Incoming messages from the source will raise events on the listener.
Public method | Disconnect | Called implicitly by Dispose, disconnects from the source of aircraft message data.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when the listener connects or disconnects. Note that exceptions raised during parsing of messages will cause the object to automatically disconnect.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | ModeSBytesReceived | Raised when bytes representing a Mode-S message have been received. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | ModeSMessageReceived | Raised when a message has been received from the source of raw data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | Port30003MessageReceived | Raised when a message has been received from a source of Port30003 data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | PositionReset | Raised when a decoder that the listener is using to translate messages indicates that the previous position reported for an aircraft was wrong and that its position has been reset.
Public event | RawBytesReceived | Raised when bytes have been received from the data source. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | SourceChanged | Raised when the listener is asked to change source of data. If the change in source causes a disconnect and reconnect then this event is raised after the disconnect but before the reconnect.
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IListener Properties

IListener Properties

The IListener type exposes the following members.

Properties
 | Name | Description
Public property | BytesExtractor | Gets the object that can extract the important bytes from the stream. Do not modify any properties on the extractor directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.
Public property | ConnectionStatus | Gets a value indicating whether the listener is connected to the source of aircraft message data.
Public property | Connector | Gets the connector that is handling the connection for the listener. Do not modify any properties on the connection directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.
Public property | IgnoreBadMessages | Gets or sets a value indicating whether exceptions thrown by the message translator cause a disconnection and raise ExceptionCaught or whether they are ignored.
Public property | IsSatcomFeed | Gets or sets a value indicating that this is a satcom feed.
Public property | RawMessageTranslator | Gets the object that translates raw messages into Port30003 format messages. Do not modify any properties on the translator directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.
Public property | ReceiverId | Gets or sets the identity of the receiver that is controlling this listener.
Public property | ReceiverName | Gets or sets the name of the receiver that is controlling this listener.
Public property | Statistics | Gets the statistics for the listener.
Public property | TotalBadMessages | Gets a count of the total number of messages that could not be translated.
Public property | TotalMessages | Gets a count of the total number of messages received by the object.
Top
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.BytesExtractor Property

IListenerBytesExtractor Property
Gets the object that can extract the important bytes from the stream. Do not modify any properties on the extractor directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMessageBytesExtractor BytesExtractor { get; }
ReadOnly Property BytesExtractor As IMessageBytesExtractor
    Get
property IMessageBytesExtractor^ BytesExtractor {
    IMessageBytesExtractor^ get ();
}
abstract BytesExtractor : IMessageBytesExtractor with get

Property Value

Type: IMessageBytesExtractor
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ConnectionStatus Property

IListenerConnectionStatus Property
Gets a value indicating whether the listener is connected to the source of aircraft message data.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectionStatus ConnectionStatus { get; }
ReadOnly Property ConnectionStatus As ConnectionStatus
    Get
property ConnectionStatus ConnectionStatus {
    ConnectionStatus get ();
}
abstract ConnectionStatus : ConnectionStatus with get

Property Value

Type: ConnectionStatus
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.Connector Property

IListenerConnector Property
Gets the connector that is handling the connection for the listener. Do not modify any properties on the connection directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnector Connector { get; }
ReadOnly Property Connector As IConnector
    Get
property IConnector^ Connector {
    IConnector^ get ();
}
abstract Connector : IConnector with get

Property Value

Type: IConnector
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.IgnoreBadMessages Property

IListenerIgnoreBadMessages Property
Gets or sets a value indicating whether exceptions thrown by the message translator cause a disconnection and raise ExceptionCaught or whether they are ignored.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreBadMessages { get; set; }
Property IgnoreBadMessages As Boolean
    Get
    Set
property bool IgnoreBadMessages {
    bool get ();
    void set (bool value);
}
abstract IgnoreBadMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.IsSatcomFeed Property

IListenerIsSatcomFeed Property
Gets or sets a value indicating that this is a satcom feed.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSatcomFeed { get; set; }
Property IsSatcomFeed As Boolean
    Get
    Set
property bool IsSatcomFeed {
    bool get ();
    void set (bool value);
}
abstract IsSatcomFeed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.RawMessageTranslator Property

IListenerRawMessageTranslator Property
Gets the object that translates raw messages into Port30003 format messages. Do not modify any properties on the translator directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IRawMessageTranslator RawMessageTranslator { get; }
ReadOnly Property RawMessageTranslator As IRawMessageTranslator
    Get
property IRawMessageTranslator^ RawMessageTranslator {
    IRawMessageTranslator^ get ();
}
abstract RawMessageTranslator : IRawMessageTranslator with get

Property Value

Type: IRawMessageTranslator
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ReceiverId Property

IListenerReceiverId Property
Gets or sets the identity of the receiver that is controlling this listener.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int ReceiverId { get; set; }
Property ReceiverId As Integer
    Get
    Set
property int ReceiverId {
    int get ();
    void set (int value);
}
abstract ReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ReceiverName Property

IListenerReceiverName Property
Gets or sets the name of the receiver that is controlling this listener.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ReceiverName { get; set; }
Property ReceiverName As String
    Get
    Set
property String^ ReceiverName {
    String^ get ();
    void set (String^ value);
}
abstract ReceiverName : string with get, set

Property Value

Type: String
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.Statistics Property

IListenerStatistics Property
Gets the statistics for the listener.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStatistics Statistics { get; }
ReadOnly Property Statistics As IStatistics
    Get
property IStatistics^ Statistics {
    IStatistics^ get ();
}
abstract Statistics : IStatistics with get

Property Value

Type: IStatistics
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.TotalBadMessages Property

IListenerTotalBadMessages Property
Gets a count of the total number of messages that could not be translated.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TotalBadMessages { get; }
ReadOnly Property TotalBadMessages As Long
    Get
property long long TotalBadMessages {
    long long get ();
}
abstract TotalBadMessages : int64 with get

Property Value

Type: Int64
Remarks
This is incremented regardless of the value of IgnoreBadMessages.
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.TotalMessages Property

IListenerTotalMessages Property
Gets a count of the total number of messages received by the object.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long TotalMessages { get; }
ReadOnly Property TotalMessages As Long
    Get
property long long TotalMessages {
    long long get ();
}
abstract TotalMessages : int64 with get

Property Value

Type: Int64
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener Methods

IListener Methods

The IListener type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSource | Changes the connector and/or message bytes extractor used by the listener.
Public method | Connect | Connects to the source of aircraft data. Incoming messages from the source will raise events on the listener.
Public method | Disconnect | Called implicitly by Dispose, disconnects from the source of aircraft message data.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ChangeSource Method

IListenerChangeSource Method
Changes the connector and/or message bytes extractor used by the listener.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ChangeSource(
    IConnector connector,
    IMessageBytesExtractor bytesExtractor,
    IRawMessageTranslator rawMessageTranslator
)
Sub ChangeSource (
    connector As IConnector,
    bytesExtractor As IMessageBytesExtractor,
    rawMessageTranslator As IRawMessageTranslator
)
void ChangeSource(
    IConnector^ connector,
    IMessageBytesExtractor^ bytesExtractor,
    IRawMessageTranslator^ rawMessageTranslator
)
abstract ChangeSource :
        connector : IConnector *
        bytesExtractor : IMessageBytesExtractor *
        rawMessageTranslator : IRawMessageTranslator -> unit

Parameters

connector
Type: VirtualRadar.Interface.NetworkIConnector
bytesExtractor
Type: VirtualRadar.Interface.ListenerIMessageBytesExtractor
rawMessageTranslator
Type: VirtualRadar.Interface.BaseStationIRawMessageTranslator
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.Connect Method

IListenerConnect Method
Connects to the source of aircraft data. Incoming messages from the source will raise events on the listener.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
Remarks
The method begins the connection procedure on a background thread and returns almost immediately. It may not have connected by the time the connection returns. It may raise an exception if ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) has not been called but otherwise any exceptions raised during the connection procedure are passed through ExceptionCaught.
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.Disconnect Method

IListenerDisconnect Method
Called implicitly by Dispose, disconnects from the source of aircraft message data.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener Events

IListener Events

The IListener type exposes the following members.

Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when the listener connects or disconnects. Note that exceptions raised during parsing of messages will cause the object to automatically disconnect.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | ModeSBytesReceived | Raised when bytes representing a Mode-S message have been received. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | ModeSMessageReceived | Raised when a message has been received from the source of raw data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | Port30003MessageReceived | Raised when a message has been received from a source of Port30003 data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | PositionReset | Raised when a decoder that the listener is using to translate messages indicates that the previous position reported for an aircraft was wrong and that its position has been reset.
Public event | RawBytesReceived | Raised when bytes have been received from the data source. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.
Public event | SourceChanged | Raised when the listener is asked to change source of data. If the change in source causes a disconnect and reconnect then this event is raised after the disconnect but before the reconnect.
Top
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ConnectionStateChanged Event

IListenerConnectionStateChanged Event
Raised when the listener connects or disconnects. Note that exceptions raised during parsing of messages will cause the object to automatically disconnect.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConnectionStateChanged
Event ConnectionStateChanged As EventHandler
 event EventHandler^ ConnectionStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConnectionStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ModeSBytesReceived Event

IListenerModeSBytesReceived Event
Raised when bytes representing a Mode-S message have been received. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<ExtractedBytes>> ModeSBytesReceived
Event ModeSBytesReceived As EventHandler(Of EventArgs(Of ExtractedBytes))
 event EventHandler<EventArgs<ExtractedBytes^>^>^ ModeSBytesReceived {
    void add (EventHandler<EventArgs<ExtractedBytes^>^>^ value);
    void remove (EventHandler<EventArgs<ExtractedBytes^>^>^ value);
}
abstract ModeSBytesReceived : IEvent<EventHandler<EventArgs<ExtractedBytes>>,
    EventArgs<ExtractedBytes>>

Value

Type: SystemEventHandler EventArgs ExtractedBytes
Remarks
This is only raised when listening to sources of Mode-S data. It is not raised when listening to Port 30003 format sources. The ExtractedBytes passed as the event argument is a clone of the bytes original extracted. Bytes that fail the checksum test (when applicable) are not passed to the event handler.
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.ModeSMessageReceived Event

IListenerModeSMessageReceived Event
Raised when a message has been received from the source of raw data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ModeSMessageEventArgs> ModeSMessageReceived
Event ModeSMessageReceived As EventHandler(Of ModeSMessageEventArgs)
 event EventHandler<ModeSMessageEventArgs^>^ ModeSMessageReceived {
    void add (EventHandler<ModeSMessageEventArgs^>^ value);
    void remove (EventHandler<ModeSMessageEventArgs^>^ value);
}
abstract ModeSMessageReceived : IEvent<EventHandler<ModeSMessageEventArgs>,
    ModeSMessageEventArgs>

Value

Type: SystemEventHandler ModeSMessageEventArgs
Remarks
This is only raised when listening to sources of Mode-S data. It is not raised when listening to Port 30003 format sources.
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.Port30003MessageReceived Event

IListenerPort30003MessageReceived Event
Raised when a message has been received from a source of Port30003 data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<BaseStationMessageEventArgs> Port30003MessageReceived
Event Port30003MessageReceived As EventHandler(Of BaseStationMessageEventArgs)
 event EventHandler<BaseStationMessageEventArgs^>^ Port30003MessageReceived {
    void add (EventHandler<BaseStationMessageEventArgs^>^ value);
    void remove (EventHandler<BaseStationMessageEventArgs^>^ value);
}
abstract Port30003MessageReceived : IEvent<EventHandler<BaseStationMessageEventArgs>,
    BaseStationMessageEventArgs>

Value

Type: SystemEventHandler BaseStationMessageEventArgs
Remarks
This is raised when listening to both Mode-S and Port 30003 data feeds. When listening to Mode-S sources the listener uses an IRawMessageTranslator to create the Port 30003 message.
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.PositionReset Event

IListenerPositionReset Event
Raised when a decoder that the listener is using to translate messages indicates that the previous position reported for an aircraft was wrong and that its position has been reset.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<string>> PositionReset
Event PositionReset As EventHandler(Of EventArgs(Of String))
 event EventHandler<EventArgs<String^>^>^ PositionReset {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}
abstract PositionReset : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

Value

Type: SystemEventHandler EventArgs String
Remarks
The event args carries the ICAO24 code for the aircraft whose position has been reset. Any tracks held for the aircraft should be cleared down and restarted. This message is only used in conjunction with raw message decoding.
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.RawBytesReceived Event

IListenerRawBytesReceived Event
Raised when bytes have been received from the data source. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<byte[]>> RawBytesReceived
Event RawBytesReceived As EventHandler(Of EventArgs(Of Byte()))
 event EventHandler<EventArgs<array<unsigned char>^>^>^ RawBytesReceived {
    void add (EventHandler<EventArgs<array<unsigned char>^>^>^ value);
    void remove (EventHandler<EventArgs<array<unsigned char>^>^>^ value);
}
abstract RawBytesReceived : IEvent<EventHandler<EventArgs<byte[]>>,
    EventArgs<byte[]>>

Value

Type: SystemEventHandler EventArgs Byte
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IListener.SourceChanged Event

IListenerSourceChanged Event
Raised when the listener is asked to change source of data. If the change in source causes a disconnect and reconnect then this event is raised after the disconnect but before the reconnect.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SourceChanged
Event SourceChanged As EventHandler
 event EventHandler^ SourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SourceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedComponentListener Interface

IMergedFeedComponentListener Interface
The listener for a receiver that will be merged into a single feed by IMergedFeedListener.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMergedFeedComponentListener
Public Interface IMergedFeedComponentListener
public interface class IMergedFeedComponentListener
type IMergedFeedComponentListener =  interface end

The IMergedFeedComponentListener type exposes the following members.

Properties
 | Name | Description
Public property | IsMlatFeed | Gets or sets a value indicating that every position message on the feed should be treated as an MLAT message.
Public property | Listener | Gets the listener for the receiver.
Top
Methods
 | Name | Description
Public method | SetListener | Initialises the object. Objects can only be initialised once.
Top
Remarks
Implementations are expected to be immutable. They need to implement Equals, returning true if the other object has the same instance of Listener and same value for IsMlatFeed.
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IMergedFeedComponentListener Properties

IMergedFeedComponentListener Properties

The IMergedFeedComponentListener type exposes the following members.

Properties
 | Name | Description
Public property | IsMlatFeed | Gets or sets a value indicating that every position message on the feed should be treated as an MLAT message.
Public property | Listener | Gets the listener for the receiver.
Top
See Also

Reference

IMergedFeedComponentListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedComponentListener.IsMlatFeed Property

IMergedFeedComponentListenerIsMlatFeed Property
Gets or sets a value indicating that every position message on the feed should be treated as an MLAT message.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMlatFeed { get; }
ReadOnly Property IsMlatFeed As Boolean
    Get
property bool IsMlatFeed {
    bool get ();
}
abstract IsMlatFeed : bool with get

Property Value

Type: Boolean
See Also

Reference

IMergedFeedComponentListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedComponentListener.Listener Property

IMergedFeedComponentListenerListener Property
Gets the listener for the receiver.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IListener Listener { get; }
ReadOnly Property Listener As IListener
    Get
property IListener^ Listener {
    IListener^ get ();
}
abstract Listener : IListener with get

Property Value

Type: IListener
See Also

Reference

IMergedFeedComponentListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedComponentListener Methods

IMergedFeedComponentListener Methods

The IMergedFeedComponentListener type exposes the following members.

Methods
 | Name | Description
Public method | SetListener | Initialises the object. Objects can only be initialised once.
Top
See Also

Reference

IMergedFeedComponentListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedComponentListener.SetListener Method

IMergedFeedComponentListenerSetListener Method
Initialises the object. Objects can only be initialised once.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetListener(
    IListener listener,
    bool isMlatFeed
)
Sub SetListener (
    listener As IListener,
    isMlatFeed As Boolean
)
void SetListener(
    IListener^ listener,
    bool isMlatFeed
)
abstract SetListener :
        listener : IListener *
        isMlatFeed : bool -> unit

Parameters

listener
Type: VirtualRadar.Interface.ListenerIListener
isMlatFeed
Type: SystemBoolean
See Also

Reference

IMergedFeedComponentListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener Interface

IMergedFeedListener Interface
A listener that merges together messages picked up by two or more listeners.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMergedFeedListener : IListener,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface IMergedFeedListener
    Inherits IListener, IBackgroundThreadExceptionCatcher, IDisposable
public interface class IMergedFeedListener : IListener,
    IBackgroundThreadExceptionCatcher, IDisposable
type IMergedFeedListener =
    interface
        interface IListener
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IMergedFeedListener type exposes the following members.

Properties
 | Name | Description
Public property | BytesExtractor | Gets the object that can extract the important bytes from the stream. Do not modify any properties on the extractor directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes. (Inherited from IListener.)
Public property | ConnectionStatus | Gets a value indicating whether the listener is connected to the source of aircraft message data. (Inherited from IListener.)
Public property | Connector | Gets the connector that is handling the connection for the listener. Do not modify any properties on the connection directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes. (Inherited from IListener.)
Public property | IcaoTimeout | Gets or sets the number of milliseconds that must elapse after the last message from a given ICAO on a receiver before that receiver is no longer considered to be the only source of messages for that ICAO.
Public property | IgnoreAircraftWithNoPosition | Gets or sets a value indicating whether messages from aircraft are ignored until they transmit a position.
Public property | IgnoreBadMessages | Gets or sets a value indicating whether exceptions thrown by the message translator cause a disconnection and raise ExceptionCaught or whether they are ignored. (Inherited from IListener.)
Public property | IsSatcomFeed | Gets or sets a value indicating that this is a satcom feed. (Inherited from IListener.)
Public property | Listeners | Gets the list of listeners that will be merged into a single feed.
Public property | RawMessageTranslator | Gets the object that translates raw messages into Port30003 format messages. Do not modify any properties on the translator directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes. (Inherited from IListener.)
Public property | ReceiverId | Gets or sets the identity of the receiver that is controlling this listener. (Inherited from IListener.)
Public property | ReceiverName | Gets or sets the name of the receiver that is controlling this listener. (Inherited from IListener.)
Public property | Statistics | Gets the statistics for the listener. (Inherited from IListener.)
Public property | TotalBadMessages | Gets a count of the total number of messages that could not be translated. (Inherited from IListener.)
Public property | TotalMessages | Gets a count of the total number of messages received by the object. (Inherited from IListener.)
Top
Methods
 | Name | Description
Public method | ChangeSource | Changes the connector and/or message bytes extractor used by the listener. (Inherited from IListener.)
Public method | Connect | Connects to the source of aircraft data. Incoming messages from the source will raise events on the listener. (Inherited from IListener.)
Public method | Disconnect | Called implicitly by Dispose, disconnects from the source of aircraft message data. (Inherited from IListener.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | SetListeners | Sets the Listeners list.
Top
Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when the listener connects or disconnects. Note that exceptions raised during parsing of messages will cause the object to automatically disconnect. (Inherited from IListener.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | ModeSBytesReceived | Raised when bytes representing a Mode-S message have been received. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | ModeSMessageReceived | Raised when a message has been received from the source of raw data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | Port30003MessageReceived | Raised when a message has been received from a source of Port30003 data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | PositionReset | Raised when a decoder that the listener is using to translate messages indicates that the previous position reported for an aircraft was wrong and that its position has been reset. (Inherited from IListener.)
Public event | RawBytesReceived | Raised when bytes have been received from the data source. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | SourceChanged | Raised when the listener is asked to change source of data. If the change in source causes a disconnect and reconnect then this event is raised after the disconnect but before the reconnect. (Inherited from IListener.)
Top
Remarks

Calls on the merged feed's version of methods like Connect etc. have no effect on the receivers that the feed is merging together - all the merged feed is doing is taking the messages from the receivers and merging them together. Many properties, events and methods on IListener are stubs on the merged feed. The only properties, events and methods that are fully operational are:

TotalMessagesTotalBadMessagesExceptionCaughtPort30003MessageReceivedPositionReset

Specifically, the connection is always on and cannot be turned off. To control the receivers that the feed is merging you must send messages to each receiver.

See Also

Reference

VirtualRadar.Interface.Listener Namespace


IMergedFeedListener Properties

IMergedFeedListener Properties

The IMergedFeedListener type exposes the following members.

Properties
 | Name | Description
Public property | BytesExtractor | Gets the object that can extract the important bytes from the stream. Do not modify any properties on the extractor directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes. (Inherited from IListener.)
Public property | ConnectionStatus | Gets a value indicating whether the listener is connected to the source of aircraft message data. (Inherited from IListener.)
Public property | Connector | Gets the connector that is handling the connection for the listener. Do not modify any properties on the connection directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes. (Inherited from IListener.)
Public property | IcaoTimeout | Gets or sets the number of milliseconds that must elapse after the last message from a given ICAO on a receiver before that receiver is no longer considered to be the only source of messages for that ICAO.
Public property | IgnoreAircraftWithNoPosition | Gets or sets a value indicating whether messages from aircraft are ignored until they transmit a position.
Public property | IgnoreBadMessages | Gets or sets a value indicating whether exceptions thrown by the message translator cause a disconnection and raise ExceptionCaught or whether they are ignored. (Inherited from IListener.)
Public property | IsSatcomFeed | Gets or sets a value indicating that this is a satcom feed. (Inherited from IListener.)
Public property | Listeners | Gets the list of listeners that will be merged into a single feed.
Public property | RawMessageTranslator | Gets the object that translates raw messages into Port30003 format messages. Do not modify any properties on the translator directly, always use ChangeSource(IConnector, IMessageBytesExtractor, IRawMessageTranslator) to perform configuration changes. (Inherited from IListener.)
Public property | ReceiverId | Gets or sets the identity of the receiver that is controlling this listener. (Inherited from IListener.)
Public property | ReceiverName | Gets or sets the name of the receiver that is controlling this listener. (Inherited from IListener.)
Public property | Statistics | Gets the statistics for the listener. (Inherited from IListener.)
Public property | TotalBadMessages | Gets a count of the total number of messages that could not be translated. (Inherited from IListener.)
Public property | TotalMessages | Gets a count of the total number of messages received by the object. (Inherited from IListener.)
Top
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener.IcaoTimeout Property

IMergedFeedListenerIcaoTimeout Property
Gets or sets the number of milliseconds that must elapse after the last message from a given ICAO on a receiver before that receiver is no longer considered to be the only source of messages for that ICAO.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int IcaoTimeout { get; set; }
Property IcaoTimeout As Integer
    Get
    Set
property int IcaoTimeout {
    int get ();
    void set (int value);
}
abstract IcaoTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener.IgnoreAircraftWithNoPosition Property

IMergedFeedListenerIgnoreAircraftWithNoPosition Property
Gets or sets a value indicating whether messages from aircraft are ignored until they transmit a position.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreAircraftWithNoPosition { get; set; }
Property IgnoreAircraftWithNoPosition As Boolean
    Get
    Set
property bool IgnoreAircraftWithNoPosition {
    bool get ();
    void set (bool value);
}
abstract IgnoreAircraftWithNoPosition : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener.Listeners Property

IMergedFeedListenerListeners Property
Gets the list of listeners that will be merged into a single feed.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IMergedFeedComponentListener> Listeners { get; }
ReadOnly Property Listeners As ReadOnlyCollection(Of IMergedFeedComponentListener)
    Get
property ReadOnlyCollection<IMergedFeedComponentListener^>^ Listeners {
    ReadOnlyCollection<IMergedFeedComponentListener^>^ get ();
}
abstract Listeners : ReadOnlyCollection<IMergedFeedComponentListener> with get

Property Value

Type: ReadOnlyCollection IMergedFeedComponentListener
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener Methods

IMergedFeedListener Methods

The IMergedFeedListener type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSource | Changes the connector and/or message bytes extractor used by the listener. (Inherited from IListener.)
Public method | Connect | Connects to the source of aircraft data. Incoming messages from the source will raise events on the listener. (Inherited from IListener.)
Public method | Disconnect | Called implicitly by Dispose, disconnects from the source of aircraft message data. (Inherited from IListener.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | SetListeners | Sets the Listeners list.
Top
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener.SetListeners Method

IMergedFeedListenerSetListeners Method
Sets the Listeners list.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetListeners(
    IEnumerable<IMergedFeedComponentListener> listeners
)
Sub SetListeners (
    listeners As IEnumerable(Of IMergedFeedComponentListener)
)
void SetListeners(
    IEnumerable<IMergedFeedComponentListener^>^ listeners
)
abstract SetListeners :
        listeners : IEnumerable<IMergedFeedComponentListener> -> unit

Parameters

listeners
Type: System.Collections.GenericIEnumerable IMergedFeedComponentListener
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMergedFeedListener Events

IMergedFeedListener Events

The IMergedFeedListener type exposes the following members.

Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when the listener connects or disconnects. Note that exceptions raised during parsing of messages will cause the object to automatically disconnect. (Inherited from IListener.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | ModeSBytesReceived | Raised when bytes representing a Mode-S message have been received. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | ModeSMessageReceived | Raised when a message has been received from the source of raw data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | Port30003MessageReceived | Raised when a message has been received from a source of Port30003 data. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | PositionReset | Raised when a decoder that the listener is using to translate messages indicates that the previous position reported for an aircraft was wrong and that its position has been reset. (Inherited from IListener.)
Public event | RawBytesReceived | Raised when bytes have been received from the data source. This may not be on the same thread that started the listener - however all messages are guaranteed to be transmitted in the order in which they were received. (Inherited from IListener.)
Public event | SourceChanged | Raised when the listener is asked to change source of data. If the change in source causes a disconnect and reconnect then this event is raised after the disconnect but before the reconnect. (Inherited from IListener.)
Top
See Also

Reference

IMergedFeedListener Interface
VirtualRadar.Interface.Listener Namespace


IMessageBytesExtractor Interface

IMessageBytesExtractor Interface
The interface for objects that can extract raw message bytes from an array of bytes.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMessageBytesExtractor
Public Interface IMessageBytesExtractor
public interface class IMessageBytesExtractor
type IMessageBytesExtractor =  interface end

The IMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers.
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message.
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IMessageBytesExtractor Properties

IMessageBytesExtractor Properties

The IMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers.
Top
See Also

Reference

IMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IMessageBytesExtractor.BufferSize Property

IMessageBytesExtractorBufferSize Property
Gets the number of bytes that the message extractor is currently consuming in buffers.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BufferSize { get; }
ReadOnly Property BufferSize As Long
    Get
property long long BufferSize {
    long long get ();
}
abstract BufferSize : int64 with get

Property Value

Type: Int64
See Also

Reference

IMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IMessageBytesExtractor Methods

IMessageBytesExtractor Methods

The IMessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message.
Top
See Also

Reference

IMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IMessageBytesExtractor.ExtractMessageBytes Method

IMessageBytesExtractorExtractMessageBytes Method
Returns a collection of byte arrays, each byte array corresponding to a complete message.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ExtractedBytes> ExtractMessageBytes(
    byte[] bytes,
    int offset,
    int length
)
Function ExtractMessageBytes (
    bytes As Byte(),
    offset As Integer,
    length As Integer
) As IEnumerable(Of ExtractedBytes)
IEnumerable<ExtractedBytes^>^ ExtractMessageBytes(
    array<unsigned char>^ bytes,
    int offset,
    int length
)
abstract ExtractMessageBytes :
        bytes : byte[] *
        offset : int *
        length : int -> IEnumerable<ExtractedBytes>

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: IEnumerable ExtractedBytes
Remarks

Extractors need to be miserly with the resources that they consume and so implementations are allowed to reuse the ExtractedBytes that they return and the byte array within the ExtractedBytes. If a caller wants to ensure that each element returned by the enumerator is independent of the others then it should clone each of them as they are returned - e.g.

Copy
var list = extractor.ExtractMessageBytes(bytes, 0, bytes.Length).Select(r => (ExtractedBytes)r.Clone()).ToList();
See Also

Reference

IMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IPlaneFinderMessageBytesExtractor Interface

IPlaneFinderMessageBytesExtractor Interface
The interface for classes that can extract messages from Plane Finder feeds.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPlaneFinderMessageBytesExtractor : IMessageBytesExtractor
Public Interface IPlaneFinderMessageBytesExtractor
    Inherits IMessageBytesExtractor
public interface class IPlaneFinderMessageBytesExtractor : IMessageBytesExtractor
type IPlaneFinderMessageBytesExtractor =
    interface
        interface IMessageBytesExtractor
    end

The IPlaneFinderMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IPlaneFinderMessageBytesExtractor Properties

IPlaneFinderMessageBytesExtractor Properties

The IPlaneFinderMessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IPlaneFinderMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IPlaneFinderMessageBytesExtractor Methods

IPlaneFinderMessageBytesExtractor Methods

The IPlaneFinderMessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IPlaneFinderMessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter Interface

IPolarPlotter Interface
The interface for objects that can track the values required for a polar plot.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPolarPlotter : IDisposable
Public Interface IPolarPlotter
    Inherits IDisposable
public interface class IPolarPlotter : IDisposable
type IPolarPlotter =
    interface
        interface IDisposable
    end

The IPolarPlotter type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets the latitude from which distances will be calculated.
Public property | Longitude | Gets the longitude from which distances will be calculated.
Public property | RoundToDegrees | Gets the number of degrees that bearings are rounded to.
Top
Methods
 | Name | Description
Public method | AddCheckedCoordinate | Adds a coordinate to all applicable slices. The coordinate is guaranteed to have been considered ProbablyRight by an instance of IAircraftSanityChecker.
Public method | AddCoordinate | Adds a coordinate to all applicable slices. The coordinate will be checked by an instance of IAircraftSanityChecker.
Public method | ClearPolarPlots | Removes all existing polar plots.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise(Double, Double) | Initialises the plotter with a standard set of slices and bearing rounding.
Public method | Initialise(Double, Double, Int32, Int32, Int32, Int32) | Initialises the plotter with custom slice dimensions.
Public method | LoadFrom | Overwrites the RoundToDegrees and slices with the values from the saved polar plot passed across.
Public method | TakeSnapshot | Returns a copy of all of the slices as-at the current point in time.
Top
Remarks

Polar plots are recorded over a series of slices, where each slice is a range of altitudes between two values in feet. The Initialise call tells the plotter the dimensions of the slices and the location to measure distances and angles from.

The plotter calculates the distance and bearing to the aircraft and then rounds the bearing to the nearest X degrees. If X is 1 then you will get 360 bearings stored for each slice, if X is 5 then you will get (360 / 5) 72 points stored for each slice. Once the rounded bearing has been calculated the plotter looks to see whether the distance it's calculated is further out than the one that already exists for the bearing - if it is then that distance and point is recorded, otherwise it is discarded.

All altitudes and positions are passed through an implementation of a IAircraftSanityChecker and only those values that are confirmed as ProbablyRight are used for the plot.

Implementations must be thread safe.

See Also

Reference

VirtualRadar.Interface.Listener Namespace


IPolarPlotter Properties

IPolarPlotter Properties

The IPolarPlotter type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets the latitude from which distances will be calculated.
Public property | Longitude | Gets the longitude from which distances will be calculated.
Public property | RoundToDegrees | Gets the number of degrees that bearings are rounded to.
Top
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.Latitude Property

IPolarPlotterLatitude Property
Gets the latitude from which distances will be calculated.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double Latitude { get; }
ReadOnly Property Latitude As Double
    Get
property double Latitude {
    double get ();
}
abstract Latitude : float with get

Property Value

Type: Double
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.Longitude Property

IPolarPlotterLongitude Property
Gets the longitude from which distances will be calculated.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double Longitude { get; }
ReadOnly Property Longitude As Double
    Get
property double Longitude {
    double get ();
}
abstract Longitude : float with get

Property Value

Type: Double
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.RoundToDegrees Property

IPolarPlotterRoundToDegrees Property
Gets the number of degrees that bearings are rounded to.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int RoundToDegrees { get; }
ReadOnly Property RoundToDegrees As Integer
    Get
property int RoundToDegrees {
    int get ();
}
abstract RoundToDegrees : int with get

Property Value

Type: Int32
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter Methods

IPolarPlotter Methods

The IPolarPlotter type exposes the following members.

Methods
 | Name | Description
Public method | AddCheckedCoordinate | Adds a coordinate to all applicable slices. The coordinate is guaranteed to have been considered ProbablyRight by an instance of IAircraftSanityChecker.
Public method | AddCoordinate | Adds a coordinate to all applicable slices. The coordinate will be checked by an instance of IAircraftSanityChecker.
Public method | ClearPolarPlots | Removes all existing polar plots.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise(Double, Double) | Initialises the plotter with a standard set of slices and bearing rounding.
Public method | Initialise(Double, Double, Int32, Int32, Int32, Int32) | Initialises the plotter with custom slice dimensions.
Public method | LoadFrom | Overwrites the RoundToDegrees and slices with the values from the saved polar plot passed across.
Public method | TakeSnapshot | Returns a copy of all of the slices as-at the current point in time.
Top
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.AddCheckedCoordinate Method

IPolarPlotterAddCheckedCoordinate Method
Adds a coordinate to all applicable slices. The coordinate is guaranteed to have been considered ProbablyRight by an instance of IAircraftSanityChecker.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddCheckedCoordinate(
    int aircraftId,
    int altitude,
    double latitude,
    double longitude
)
Sub AddCheckedCoordinate (
    aircraftId As Integer,
    altitude As Integer,
    latitude As Double,
    longitude As Double
)
void AddCheckedCoordinate(
    int aircraftId,
    int altitude,
    double latitude,
    double longitude
)
abstract AddCheckedCoordinate :
        aircraftId : int *
        altitude : int *
        latitude : float *
        longitude : float -> unit

Parameters

aircraftId
Type: SystemInt32
altitude
Type: SystemInt32
latitude
Type: SystemDouble
longitude
Type: SystemDouble
Remarks
Identical to AddCoordinate(Int32, Int32, Double, Double) except that the coordinate is not checked to see whether it is reasonable before it is used. If another sanity checker has already tested the coordinate then this method is more efficient, it avoids double-checking.
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.AddCoordinate Method

IPolarPlotterAddCoordinate Method
Adds a coordinate to all applicable slices. The coordinate will be checked by an instance of IAircraftSanityChecker.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddCoordinate(
    int aircraftId,
    int altitude,
    double latitude,
    double longitude
)
Sub AddCoordinate (
    aircraftId As Integer,
    altitude As Integer,
    latitude As Double,
    longitude As Double
)
void AddCoordinate(
    int aircraftId,
    int altitude,
    double latitude,
    double longitude
)
abstract AddCoordinate :
        aircraftId : int *
        altitude : int *
        latitude : float *
        longitude : float -> unit

Parameters

aircraftId
Type: SystemInt32
The unique identifier of the aircraft.
altitude
Type: SystemInt32
Altitude of the aircraft in feet.
latitude
Type: SystemDouble
The latitude of the aircraft.
longitude
Type: SystemDouble
The longitude of the aircraft.
Remarks
The plotter calculates the distance and bearing from Latitude and Longitude to the latitude and longitude passed across. If the distance is the furthest seen for that bearing then it is recorded in all slices that cover the altitude passed across, otherwise it is discarded.
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.ClearPolarPlots Method

IPolarPlotterClearPolarPlots Method
Removes all existing polar plots.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearPolarPlots()
Sub ClearPolarPlots
void ClearPolarPlots()
abstract ClearPolarPlots : unit -> unit
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.Initialise Method

IPolarPlotterInitialise Method
Overload List
 | Name | Description
Public method | Initialise(Double, Double) | Initialises the plotter with a standard set of slices and bearing rounding.
Public method | Initialise(Double, Double, Int32, Int32, Int32, Int32) | Initialises the plotter with custom slice dimensions.
Top
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.Initialise Method (Double, Double)

IPolarPlotterInitialise Method (Double, Double)
Initialises the plotter with a standard set of slices and bearing rounding.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    double latitude,
    double longitude
)
Sub Initialise (
    latitude As Double,
    longitude As Double
)
void Initialise(
    double latitude,
    double longitude
)
abstract Initialise :
        latitude : float *
        longitude : float -> unit

Parameters

latitude
Type: SystemDouble
longitude
Type: SystemDouble
Remarks
The standard slices are -2.1 billion to 9999', 10000 to 19999', 20000 to 29999' and 30000 to 2.1 billion feet, plus another that covers -2.1 billion to 2.1 billion feet. Bearings are rounded to the nearest degree.
See Also

Reference

IPolarPlotter Interface
Initialise Overload
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.Initialise Method (Double, Double, Int32, Int32, Int32, Int32)

IPolarPlotterInitialise Method (Double, Double, Int32, Int32, Int32, Int32)
Initialises the plotter with custom slice dimensions.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    double latitude,
    double longitude,
    int lowSliceAltitude,
    int highSliceAltitude,
    int sliceHeight,
    int roundToDegrees
)
Sub Initialise (
    latitude As Double,
    longitude As Double,
    lowSliceAltitude As Integer,
    highSliceAltitude As Integer,
    sliceHeight As Integer,
    roundToDegrees As Integer
)
void Initialise(
    double latitude,
    double longitude,
    int lowSliceAltitude,
    int highSliceAltitude,
    int sliceHeight,
    int roundToDegrees
)
abstract Initialise :
        latitude : float *
        longitude : float *
        lowSliceAltitude : int *
        highSliceAltitude : int *
        sliceHeight : int *
        roundToDegrees : int -> unit

Parameters

latitude
Type: SystemDouble
The latitude to measure distances from.
longitude
Type: SystemDouble
The longitude to measure distances from.
lowSliceAltitude
Type: SystemInt32
The lowest altitude to record distances for.
highSliceAltitude
Type: SystemInt32
The highest altitude to record distances for.
sliceHeight
Type: SystemInt32
The height in feet of each slice.
roundToDegrees
Type: SystemInt32
The number of degrees to round to.
See Also

Reference

IPolarPlotter Interface
Initialise Overload
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.LoadFrom Method

IPolarPlotterLoadFrom Method
Overwrites the RoundToDegrees and slices with the values from the saved polar plot passed across.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadFrom(
    SavedPolarPlot savedPolarPlot
)
Sub LoadFrom (
    savedPolarPlot As SavedPolarPlot
)
void LoadFrom(
    SavedPolarPlot^ savedPolarPlot
)
abstract LoadFrom :
        savedPolarPlot : SavedPolarPlot -> unit

Parameters

savedPolarPlot
Type: VirtualRadar.Interface.SettingsSavedPolarPlot
Remarks
The savedPolarPlot is not checked to make sure that the latitude and longitude are correct. It is assumed that the caller has already checked that they are valid, or at least close enough for jazz.
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPolarPlotter.TakeSnapshot Method

IPolarPlotterTakeSnapshot Method
Returns a copy of all of the slices as-at the current point in time.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<PolarPlotSlice> TakeSnapshot()
Function TakeSnapshot As List(Of PolarPlotSlice)
List<PolarPlotSlice^>^ TakeSnapshot()
abstract TakeSnapshot : unit -> List<PolarPlotSlice>

Return Value

Type: List PolarPlotSlice
See Also

Reference

IPolarPlotter Interface
VirtualRadar.Interface.Listener Namespace


IPort30003MessageBytesExtractor Interface

IPort30003MessageBytesExtractor Interface
The interface for objects that can extract Kinetic Port 30003 format messages.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPort30003MessageBytesExtractor : IMessageBytesExtractor
Public Interface IPort30003MessageBytesExtractor
    Inherits IMessageBytesExtractor
public interface class IPort30003MessageBytesExtractor : IMessageBytesExtractor
type IPort30003MessageBytesExtractor =
    interface
        interface IMessageBytesExtractor
    end

The IPort30003MessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IPort30003MessageBytesExtractor Properties

IPort30003MessageBytesExtractor Properties

The IPort30003MessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IPort30003MessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IPort30003MessageBytesExtractor Methods

IPort30003MessageBytesExtractor Methods

The IPort30003MessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

IPort30003MessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager Interface

IReceiverFormatManager Interface
Manages the feed formats that the program can decode.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReceiverFormatManager : ISingleton<IReceiverFormatManager>
Public Interface IReceiverFormatManager
    Inherits ISingleton(Of IReceiverFormatManager)
public interface class IReceiverFormatManager : ISingleton<IReceiverFormatManager^>
type IReceiverFormatManager =
    interface
        interface ISingleton<IReceiverFormatManager>
    end

The IReceiverFormatManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | GetProvider | Returns the registered provider with the identifier supplied or null if no provider has been registered for this ID.
Public method | GetRegisteredFormats | Returns a collection of all registered receiver formats in a summarised form.
Public method | Initialise | Initialises the format manager.
Public method | RegisterProvider | Registers a provider.
Public method | ShortName | Returns the short name associated with the unique ID passed across. If there is no provider registered with the unique ID then a string along the lines of "Unknown" is returned.
Top
Remarks
Plugins cannot provide their own implementation of this interface, the singleton is established before RegisterImplementations is called.
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager Properties

IReceiverFormatManager Properties

The IReceiverFormatManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager Methods

IReceiverFormatManager Methods

The IReceiverFormatManager type exposes the following members.

Methods
 | Name | Description
Public method | GetProvider | Returns the registered provider with the identifier supplied or null if no provider has been registered for this ID.
Public method | GetRegisteredFormats | Returns a collection of all registered receiver formats in a summarised form.
Public method | Initialise | Initialises the format manager.
Public method | RegisterProvider | Registers a provider.
Public method | ShortName | Returns the short name associated with the unique ID passed across. If there is no provider registered with the unique ID then a string along the lines of "Unknown" is returned.
Top
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager.GetProvider Method

IReceiverFormatManagerGetProvider Method
Returns the registered provider with the identifier supplied or null if no provider has been registered for this ID.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IReceiverFormatProvider GetProvider(
    string providerId
)
Function GetProvider (
    providerId As String
) As IReceiverFormatProvider
IReceiverFormatProvider^ GetProvider(
    String^ providerId
)
abstract GetProvider :
        providerId : string -> IReceiverFormatProvider

Parameters

providerId
Type: SystemString

Return Value

Type: IReceiverFormatProvider
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager.GetRegisteredFormats Method

IReceiverFormatManagerGetRegisteredFormats Method
Returns a collection of all registered receiver formats in a summarised form.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ReceiverFormatName[] GetRegisteredFormats()
Function GetRegisteredFormats As ReceiverFormatName()
array<ReceiverFormatName^>^ GetRegisteredFormats()
abstract GetRegisteredFormats : unit -> ReceiverFormatName[]

Return Value

Type: ReceiverFormatName
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager.Initialise Method

IReceiverFormatManagerInitialise Method
Initialises the format manager.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager.RegisterProvider Method

IReceiverFormatManagerRegisterProvider Method
Registers a provider.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterProvider(
    IReceiverFormatProvider provider
)
Sub RegisterProvider (
    provider As IReceiverFormatProvider
)
void RegisterProvider(
    IReceiverFormatProvider^ provider
)
abstract RegisterProvider :
        provider : IReceiverFormatProvider -> unit

Parameters

provider
Type: VirtualRadar.Interface.ListenerIReceiverFormatProvider
Remarks
Plugins should register their providers in RegisterImplementations, which should be called before VRS tries to connect to any feeds.
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatManager.ShortName Method

IReceiverFormatManagerShortName Method
Returns the short name associated with the unique ID passed across. If there is no provider registered with the unique ID then a string along the lines of "Unknown" is returned.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ShortName(
    string providerId
)
Function ShortName (
    providerId As String
) As String
String^ ShortName(
    String^ providerId
)
abstract ShortName :
        providerId : string -> string

Parameters

providerId
Type: SystemString

Return Value

Type: String
See Also

Reference

IReceiverFormatManager Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider Interface

IReceiverFormatProvider Interface
The interface that all receiver format providers must implement.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReceiverFormatProvider
Public Interface IReceiverFormatProvider
public interface class IReceiverFormatProvider
type IReceiverFormatProvider =  interface end

The IReceiverFormatProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsRawFormat | Gets a value indicating that the feed format holds raw messages from the aircraft that need to be decoded.
Public property | ShortName | Gets the short name for the format.
Public property | UniqueId | Gets the unique identifier of the format provider.
Top
Methods
 | Name | Description
Public method | CreateMessageBytesExtractor | Creates and returns a new message bytes extractor for the format.
Public method | IsUsableBytesExtractor | Returns true if the message bytes extractor passed across is appropriate for this receiver format.
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider Properties

IReceiverFormatProvider Properties

The IReceiverFormatProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsRawFormat | Gets a value indicating that the feed format holds raw messages from the aircraft that need to be decoded.
Public property | ShortName | Gets the short name for the format.
Public property | UniqueId | Gets the unique identifier of the format provider.
Top
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider.IsRawFormat Property

IReceiverFormatProviderIsRawFormat Property
Gets a value indicating that the feed format holds raw messages from the aircraft that need to be decoded.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsRawFormat { get; }
ReadOnly Property IsRawFormat As Boolean
    Get
property bool IsRawFormat {
    bool get ();
}
abstract IsRawFormat : bool with get

Property Value

Type: Boolean
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider.ShortName Property

IReceiverFormatProviderShortName Property
Gets the short name for the format.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ShortName { get; }
ReadOnly Property ShortName As String
    Get
property String^ ShortName {
    String^ get ();
}
abstract ShortName : string with get

Return Value

Type: String
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider.UniqueId Property

IReceiverFormatProviderUniqueId Property
Gets the unique identifier of the format provider.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UniqueId { get; }
ReadOnly Property UniqueId As String
    Get
property String^ UniqueId {
    String^ get ();
}
abstract UniqueId : string with get

Property Value

Type: String
Remarks
These values are saved in the user's configuration, choose your ID carefully and don't change it between releases. Do not re-use identifiers. Plugins should ensure that their unique ID cannot clash with other plugins.
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider Methods

IReceiverFormatProvider Methods

The IReceiverFormatProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateMessageBytesExtractor | Creates and returns a new message bytes extractor for the format.
Public method | IsUsableBytesExtractor | Returns true if the message bytes extractor passed across is appropriate for this receiver format.
Top
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider.CreateMessageBytesExtractor Method

IReceiverFormatProviderCreateMessageBytesExtractor Method
Creates and returns a new message bytes extractor for the format.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMessageBytesExtractor CreateMessageBytesExtractor()
Function CreateMessageBytesExtractor As IMessageBytesExtractor
IMessageBytesExtractor^ CreateMessageBytesExtractor()
abstract CreateMessageBytesExtractor : unit -> IMessageBytesExtractor

Return Value

Type: IMessageBytesExtractor
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


IReceiverFormatProvider.IsUsableBytesExtractor Method

IReceiverFormatProviderIsUsableBytesExtractor Method
Returns true if the message bytes extractor passed across is appropriate for this receiver format.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUsableBytesExtractor(
    IMessageBytesExtractor extractor
)
Function IsUsableBytesExtractor (
    extractor As IMessageBytesExtractor
) As Boolean
bool IsUsableBytesExtractor(
    IMessageBytesExtractor^ extractor
)
abstract IsUsableBytesExtractor :
        extractor : IMessageBytesExtractor -> bool

Parameters

extractor
Type: VirtualRadar.Interface.ListenerIMessageBytesExtractor

Return Value

Type: Boolean
See Also

Reference

IReceiverFormatProvider Interface
VirtualRadar.Interface.Listener Namespace


ISbs3MessageBytesExtractor Interface

ISbs3MessageBytesExtractor Interface
The interface for objects that can extract Mode-S messages from bytes read from an SBS-3.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISbs3MessageBytesExtractor : IMessageBytesExtractor
Public Interface ISbs3MessageBytesExtractor
    Inherits IMessageBytesExtractor
public interface class ISbs3MessageBytesExtractor : IMessageBytesExtractor
type ISbs3MessageBytesExtractor =
    interface
        interface IMessageBytesExtractor
    end

The ISbs3MessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


ISbs3MessageBytesExtractor Properties

ISbs3MessageBytesExtractor Properties

The ISbs3MessageBytesExtractor type exposes the following members.

Properties
 | Name | Description
Public property | BufferSize | Gets the number of bytes that the message extractor is currently consuming in buffers. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

ISbs3MessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


ISbs3MessageBytesExtractor Methods

ISbs3MessageBytesExtractor Methods

The ISbs3MessageBytesExtractor type exposes the following members.

Methods
 | Name | Description
Public method | ExtractMessageBytes | Returns a collection of byte arrays, each byte array corresponding to a complete message. (Inherited from IMessageBytesExtractor.)
Top
See Also

Reference

ISbs3MessageBytesExtractor Interface
VirtualRadar.Interface.Listener Namespace


PolarPlot Class

PolarPlot Class
A DTO that carries a single point in a polar plot.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ListenerPolarPlot

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolarPlot : ICloneable
Public Class PolarPlot
    Implements ICloneable
public ref class PolarPlot : ICloneable
type PolarPlot =
    class
        interface ICloneable
    end

The PolarPlot type exposes the following members.

Constructors
 | Name | Description
Public method | PolarPlot | Initializes a new instance of the PolarPlot class
Top
Properties
 | Name | Description
Public property | Altitude | Gets the altitude at which the plot was seen.
Public property | Angle | Gets or sets the angle in degrees from the receiver to the location.
Public property | Distance | Gets or sets the distance in kilometres from the receiver to the plot point.
Public property | Latitude | Gets or sets the latitude of the point.
Public property | Longitude | Gets or sets the longitude of the point.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of the polar plot.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


PolarPlot Constructor

PolarPlot Constructor
Initializes a new instance of the PolarPlot class

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolarPlot()
Public Sub New
public:
PolarPlot()
new : unit -> PolarPlot
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot Properties

PolarPlot Properties

The PolarPlot type exposes the following members.

Properties
 | Name | Description
Public property | Altitude | Gets the altitude at which the plot was seen.
Public property | Angle | Gets or sets the angle in degrees from the receiver to the location.
Public property | Distance | Gets or sets the distance in kilometres from the receiver to the plot point.
Public property | Latitude | Gets or sets the latitude of the point.
Public property | Longitude | Gets or sets the longitude of the point.
Top
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot.Altitude Property

PolarPlotAltitude Property
Gets the altitude at which the plot was seen.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Altitude { get; set; }
Public Property Altitude As Integer
    Get
    Set
public:
property int Altitude {
    int get ();
    void set (int value);
}
member Altitude : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot.Angle Property

PolarPlotAngle Property
Gets or sets the angle in degrees from the receiver to the location.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Angle { get; set; }
Public Property Angle As Integer
    Get
    Set
public:
property int Angle {
    int get ();
    void set (int value);
}
member Angle : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot.Distance Property

PolarPlotDistance Property
Gets or sets the distance in kilometres from the receiver to the plot point.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance { get; set; }
Public Property Distance As Double
    Get
    Set
public:
property double Distance {
    double get ();
    void set (double value);
}
member Distance : float with get, set

Property Value

Type: Double
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot.Latitude Property

PolarPlotLatitude Property
Gets or sets the latitude of the point.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Type: Double
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot.Longitude Property

PolarPlotLongitude Property
Gets or sets the longitude of the point.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Type: Double
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot Methods

PolarPlot Methods

The PolarPlot type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of the polar plot.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlot.Clone Method

PolarPlotClone Method
Creates a copy of the polar plot.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

PolarPlot Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice Class

PolarPlotSlice Class
A DTO that carries a slice of polar plots for a given receiver.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ListenerPolarPlotSlice

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolarPlotSlice : ICloneable
Public Class PolarPlotSlice
    Implements ICloneable
public ref class PolarPlotSlice : ICloneable
type PolarPlotSlice =
    class
        interface ICloneable
    end

The PolarPlotSlice type exposes the following members.

Constructors
 | Name | Description
Public method | PolarPlotSlice | Initializes a new instance of the PolarPlotSlice class
Top
Properties
 | Name | Description
Public property | AltitudeHigher | Gets or sets the upper-bound of the altitude that the plot covers.
Public property | AltitudeLower | Gets or sets the lower-bound of the altitude that the plot covers.
Public property | PolarPlots | Gets a dictionary of angles clockwise from 0° north to the last-seen plot.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


PolarPlotSlice Constructor

PolarPlotSlice Constructor
Initializes a new instance of the PolarPlotSlice class

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolarPlotSlice()
Public Sub New
public:
PolarPlotSlice()
new : unit -> PolarPlotSlice
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice Properties

PolarPlotSlice Properties

The PolarPlotSlice type exposes the following members.

Properties
 | Name | Description
Public property | AltitudeHigher | Gets or sets the upper-bound of the altitude that the plot covers.
Public property | AltitudeLower | Gets or sets the lower-bound of the altitude that the plot covers.
Public property | PolarPlots | Gets a dictionary of angles clockwise from 0° north to the last-seen plot.
Top
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice.AltitudeHigher Property

PolarPlotSliceAltitudeHigher Property
Gets or sets the upper-bound of the altitude that the plot covers.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AltitudeHigher { get; set; }
Public Property AltitudeHigher As Integer
    Get
    Set
public:
property int AltitudeHigher {
    int get ();
    void set (int value);
}
member AltitudeHigher : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice.AltitudeLower Property

PolarPlotSliceAltitudeLower Property
Gets or sets the lower-bound of the altitude that the plot covers.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AltitudeLower { get; set; }
Public Property AltitudeLower As Integer
    Get
    Set
public:
property int AltitudeLower {
    int get ();
    void set (int value);
}
member AltitudeLower : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice.PolarPlots Property

PolarPlotSlicePolarPlots Property
Gets a dictionary of angles clockwise from 0° north to the last-seen plot.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<int, PolarPlot> PolarPlots { get; }
Public ReadOnly Property PolarPlots As Dictionary(Of Integer, PolarPlot)
    Get
public:
property Dictionary<int, PolarPlot^>^ PolarPlots {
    Dictionary<int, PolarPlot^>^ get ();
}
member PolarPlots : Dictionary<int, PolarPlot> with get

Property Value

Type: Dictionary Int32, PolarPlot
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice Methods

PolarPlotSlice Methods

The PolarPlotSlice type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deep copy of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


PolarPlotSlice.Clone Method

PolarPlotSliceClone Method
Creates a deep copy of the object.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

PolarPlotSlice Class
VirtualRadar.Interface.Listener Namespace


ReceiverFormatName Class

ReceiverFormatName Class
Describes a registered receiver format.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ListenerReceiverFormatName

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReceiverFormatName
Public Class ReceiverFormatName
public ref class ReceiverFormatName
type ReceiverFormatName =  class end

The ReceiverFormatName type exposes the following members.

Constructors
 | Name | Description
Public method | ReceiverFormatName | Initializes a new instance of the ReceiverFormatName class
Top
Properties
 | Name | Description
Public property | ShortName | Gets or sets the name of the receiver format.
Public property | UniqueId | Gets or sets the unique ID of the receiver format.
Top
Methods
 | Name | Description
 | Create | Creates an object from an instance of a provider.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Listener Namespace


ReceiverFormatName Constructor

ReceiverFormatName Constructor
Initializes a new instance of the ReceiverFormatName class

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverFormatName()
Public Sub New
public:
ReceiverFormatName()
new : unit -> ReceiverFormatName
See Also

Reference

ReceiverFormatName Class
VirtualRadar.Interface.Listener Namespace


ReceiverFormatName Properties

ReceiverFormatName Properties

The ReceiverFormatName type exposes the following members.

Properties
 | Name | Description
Public property | ShortName | Gets or sets the name of the receiver format.
Public property | UniqueId | Gets or sets the unique ID of the receiver format.
Top
See Also

Reference

ReceiverFormatName Class
VirtualRadar.Interface.Listener Namespace


ReceiverFormatName.ShortName Property

ReceiverFormatNameShortName Property
Gets or sets the name of the receiver format.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ShortName { get; set; }
Public Property ShortName As String
    Get
    Set
public:
property String^ ShortName {
    String^ get ();
    void set (String^ value);
}
member ShortName : string with get, set

Property Value

Type: String
See Also

Reference

ReceiverFormatName Class
VirtualRadar.Interface.Listener Namespace


ReceiverFormatName.UniqueId Property

ReceiverFormatNameUniqueId Property
Gets or sets the unique ID of the receiver format.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
member UniqueId : string with get, set

Property Value

Type: String
See Also

Reference

ReceiverFormatName Class
VirtualRadar.Interface.Listener Namespace


ReceiverFormatName Methods

ReceiverFormatName Methods

The ReceiverFormatName type exposes the following members.

Methods
 | Name | Description
 | Create | Creates an object from an instance of a provider.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReceiverFormatName Class
VirtualRadar.Interface.Listener Namespace


ReceiverFormatName.Create Method

ReceiverFormatNameCreate Method
Creates an object from an instance of a provider.

Namespace: VirtualRadar.Interface.Listener
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ReceiverFormatName Create(
    IReceiverFormatProvider provider
)
Public Shared Function Create (
    provider As IReceiverFormatProvider
) As ReceiverFormatName
public:
static ReceiverFormatName^ Create(
    IReceiverFormatProvider^ provider
)
static member Create :
        provider : IReceiverFormatProvider -> ReceiverFormatName

Parameters

provider
Type: VirtualRadar.Interface.ListenerIReceiverFormatProvider

Return Value

Type: ReceiverFormatName
See Also

Reference

ReceiverFormatName Class
VirtualRadar.Interface.Listener Namespace


VirtualRadar.Interface.ModeS Namespace

VirtualRadar.Interface.ModeS Namespace
The namespace for all of the interfaces and objects associated with decoding raw Mode-S messages from aircraft.
Classes
 | Class | Description
Public class | ModeSMessage | Describes the content of a downlink message from a Mode A/C/S transponder.
Public class | ModeSMessageEventArgs | The event that is raised when a listener to a source of raw Mode-S messages from an aircraft receives a message.
Interfaces
 | Interface | Description
Public interface | IModeSParity | The interface for objects that can strip parity from a Mode-S message.
Public interface | IModeSTranslator | The interface for objects that can decode a raw Mode-S downlink message sent by a transponder into the information carried by the Mode-S message. Note that this does not decode the content of extended squitter messages.
Enumerations
 | Enumeration | Description
Public enumeration | ApplicationField | An enumeration of the different possible values for the AF field in DF19 messages.
Public enumeration | Capability | An enumeration of the different communications capabilities of a transponder.
Public enumeration | ControlField | An enumeration of the different values contained within the CF field of DF18 replies.
Public enumeration | DownlinkFormat | An enumeration of the different downlink formats transmitted by transponders.
Public enumeration | ElmControl | An enumeration of the different values of the ELM control bit in KE fields.
Public enumeration | FlightStatus | An enumeration of the different values for FS fields in transponder replies.
Public enumeration | VerticalStatus | An enumeration of the different possible values in a VS field.
Remarks


ApplicationField Enumeration

ApplicationField Enumeration
An enumeration of the different possible values for the AF field in DF19 messages.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ApplicationField
Public Enumeration ApplicationField
public enum class ApplicationField
type ApplicationField
Members
Member name | Value | Description
ADSB | 0 | The message content is as per DF17 extended squitter.
AF1 | 1 | Reserved for military applications.
AF2 | 2 | Reserved for military applications.
AF3 | 3 | Reserved for military applications.
AF4 | 4 | Reserved for military applications.
AF5 | 5 | Reserved for military applications.
AF6 | 6 | Reserved for military applications.
AF7 | 7 | Reserved for military applications.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


Capability Enumeration

Capability Enumeration
An enumeration of the different communications capabilities of a transponder.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Capability
Public Enumeration Capability
public enum class Capability
type Capability
Members
Member name | Value | Description
SurveillanceOnly | 0 | No communications capability.
CA1 | 1 | Reserved.
CA2 | 2 | Reserved.
CA3 | 3 | Reserved.
HasCommACommBAndOnGround | 4 | Has at least Comm-A and Comm-B capability and ability to set CA 7 and is on the ground.
HasCommACommBAndAirborne | 5 | Has at least Comm-A and Comm-B capability and ability to set CA 7 and is airborne.
HasCommACommB | 6 | Has at least Comm-A and Comm-B capability and ability to set CA 7, cannot automatically determine whether airborne or on ground.
DownlinkRequestOrAlertOrSpiInForce | 7 | DR is not 0 or FS is 2, 3, 4 or 5, and either airborne or on the ground :)
Remarks
The CA field of a DF11 reply.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


ControlField Enumeration

ControlField Enumeration
An enumeration of the different values contained within the CF field of DF18 replies.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlField
Public Enumeration ControlField
public enum class ControlField
type ControlField
Members
Member name | Value | Description
AdsbDeviceTransmittingIcao24 | 0 | Non-transponder ADS-B device transmitting ICAO24 code in the AA field.
AdsbDeviceNotTransmittingIcao24 | 1 | Non-transponder ADS-B device transmitting a non-ICAO24 address in the AA field.
FineFormatTisb | 2 | Fine-format TIS-B message.
CoarseFormatTisb | 3 | Coarse-format TIS-B message.
TisbManagement | 4 | Reserved for TIS-B management messages.
TisbRelayNotTransmittingIcao24 | 5 | TIS-B relay of ADS-B messages that have a non-ICAO24 address in the AA field.
AdsbRebroadcastOfExtendedSquitter | 6 | ADS-B rebroadcast using same type codes and message formats as defined for Extended Squitter (DF17) messages.
CF7 | 7 | Reserved.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


DownlinkFormat Enumeration

DownlinkFormat Enumeration
An enumeration of the different downlink formats transmitted by transponders.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DownlinkFormat
Public Enumeration DownlinkFormat
public enum class DownlinkFormat
type DownlinkFormat
Members
Member name | Value | Description
ShortAirToAirSurveillance | 0 | Short ACAS reply (DF = 0).
DF1 | 1 | Unused.
DF2 | 2 | Unused.
DF3 | 3 | Unused.
SurveillanceAltitudeReply | 4 | Surveillance altitude reply (DF = 4).
SurveillanceIdentityReply | 5 | Surveillance identity reply (DF = 5).
DF6 | 6 | Unused.
DF7 | 7 | Unused.
DF8 | 8 | Unused.
DF9 | 9 | Unused.
DF10 | 10 | Unused.
AllCallReply | 11 | Reply to an all-call interrogation (DF = 11).
DF12 | 12 | Unused.
DF13 | 13 | Unused.
DF14 | 14 | Unused.
DF15 | 15 | Unused.
LongAirToAirSurveillance | 16 | Long ACAS reply (DF = 16).
ExtendedSquitter | 17 | Extended squitter (DF = 17).
ExtendedSquitterNonTransponder | 18 | Extended squitter from a non-transponder reply (DF = 18).
MilitaryExtendedSquitter | 19 | Military extended squitter reply (DF = 19).
CommBAltitudeReply | 20 | Comm-B altitude reply (DF = 20).
CommBIdentityReply | 21 | Comm-B identity reply (DF = 21).
DF22 | 22 | Unused.
DF23 | 23 | Unused.
CommD | 24 | Comm-D reply (DF = 24).
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


ElmControl Enumeration

ElmControl Enumeration
An enumeration of the different values of the ELM control bit in KE fields.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ElmControl
Public Enumeration ElmControl
public enum class ElmControl
type ElmControl
Members
Member name | Value | Description
DownlinkTransmission | 0 | Indicates that the MD field contains a segment of a downlink ELM being sent to the interrogator.
UplinkAcknowledgement | 1 | Indicates that the MD field contains control codes for an uplink ELM.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


FlightStatus Enumeration

FlightStatus Enumeration
An enumeration of the different values for FS fields in transponder replies.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FlightStatus
Public Enumeration FlightStatus
public enum class FlightStatus
type FlightStatus
Members
Member name | Value | Description
Airborne | 0 | No alert, no SPI, aircraft is airborne.
OnGround | 1 | No alert, no SPI, aircraft is on ground.
AirborneAlert | 2 | Alert, aircraft is airborne.
OnGroundAlert | 3 | Alert, aircraft is on ground.
SpiWithAlert | 4 | SPI with alert.
SpiWithNoAlert | 5 | SPI with no alert.
FS6 | 6 | Reserved.
FS7 | 7 | Unassigned.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


IModeSParity Interface

IModeSParity Interface
The interface for objects that can strip parity from a Mode-S message.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IModeSParity
Public Interface IModeSParity
public interface class IModeSParity
type IModeSParity =  interface end

The IModeSParity type exposes the following members.

Methods
 | Name | Description
Public method | StripParity | Strips the parity from the last three bytes of the message.
Top
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


IModeSParity Methods

IModeSParity Methods

The IModeSParity type exposes the following members.

Methods
 | Name | Description
Public method | StripParity | Strips the parity from the last three bytes of the message.
Top
See Also

Reference

IModeSParity Interface
VirtualRadar.Interface.ModeS Namespace


IModeSParity.StripParity Method

IModeSParityStripParity Method
Strips the parity from the last three bytes of the message.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void StripParity(
    byte[] bytes,
    int offset,
    int length
)
Sub StripParity (
    bytes As Byte(),
    offset As Integer,
    length As Integer
)
void StripParity(
    array<unsigned char>^ bytes,
    int offset,
    int length
)
abstract StripParity :
        bytes : byte[] *
        offset : int *
        length : int -> unit

Parameters

bytes
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
Remarks
The length should be either 7 or 14 bytes.
See Also

Reference

IModeSParity Interface
VirtualRadar.Interface.ModeS Namespace


IModeSTranslator Interface

IModeSTranslator Interface
The interface for objects that can decode a raw Mode-S downlink message sent by a transponder into the information carried by the Mode-S message. Note that this does not decode the content of extended squitter messages.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IModeSTranslator
Public Interface IModeSTranslator
public interface class IModeSTranslator
type IModeSTranslator =  interface end

The IModeSTranslator type exposes the following members.

Properties
 | Name | Description
Public property | Statistics | Gets or sets the statistics to update when translating messages.
Top
Methods
 | Name | Description
Public method | Translate | Converts the bytes passed across into a ModeSMessage object.
Top
Remarks
Implementations are not expected to be thread-safe.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


IModeSTranslator Properties

IModeSTranslator Properties

The IModeSTranslator type exposes the following members.

Properties
 | Name | Description
Public property | Statistics | Gets or sets the statistics to update when translating messages.
Top
See Also

Reference

IModeSTranslator Interface
VirtualRadar.Interface.ModeS Namespace


IModeSTranslator.Statistics Property

IModeSTranslatorStatistics Property
Gets or sets the statistics to update when translating messages.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStatistics Statistics { get; set; }
Property Statistics As IStatistics
    Get
    Set
property IStatistics^ Statistics {
    IStatistics^ get ();
    void set (IStatistics^ value);
}
abstract Statistics : IStatistics with get, set

Property Value

Type: IStatistics
See Also

Reference

IModeSTranslator Interface
VirtualRadar.Interface.ModeS Namespace


IModeSTranslator Methods

IModeSTranslator Methods

The IModeSTranslator type exposes the following members.

Methods
 | Name | Description
Public method | Translate | Converts the bytes passed across into a ModeSMessage object.
Top
See Also

Reference

IModeSTranslator Interface
VirtualRadar.Interface.ModeS Namespace


IModeSTranslator.Translate Method

IModeSTranslatorTranslate Method
Converts the bytes passed across into a ModeSMessage object.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ModeSMessage Translate(
    byte[] rawMessage,
    int start,
    Nullable<int> signalLevel,
    bool isMlat
)
Function Translate (
    rawMessage As Byte(),
    start As Integer,
    signalLevel As Nullable(Of Integer),
    isMlat As Boolean
) As ModeSMessage
ModeSMessage^ Translate(
    array<unsigned char>^ rawMessage,
    int start,
    Nullable<int> signalLevel,
    bool isMlat
)
abstract Translate :
        rawMessage : byte[] *
        start : int *
        signalLevel : Nullable<int> *
        isMlat : bool -> ModeSMessage

Parameters

rawMessage
Type: SystemByte
start
Type: SystemInt32
The offset into the array of the start of the packet. The length is implied from the packet type.
signalLevel
Type: SystemNullable Int32
The signal level, if known. Null if not known.
isMlat
Type: SystemBoolean
True if the message is known to have been generated by an MLAT receiver / servar, false otherwise.

Return Value

Type: ModeSMessage
See Also

Reference

IModeSTranslator Interface
VirtualRadar.Interface.ModeS Namespace


ModeSMessage Class

ModeSMessage Class
Describes the content of a downlink message from a Mode A/C/S transponder.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ModeSModeSMessage

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModeSMessage
Public Class ModeSMessage
public ref class ModeSMessage
type ModeSMessage =  class end

The ModeSMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ModeSMessage | Initializes a new instance of the ModeSMessage class
Top
Properties
 | Name | Description
Public property | ACASMessage | Gets or sets the 7-byte information in the MV field of the reply.
Public property | Altitude | Gets or sets the altitude in feet as described by the AC field from the reply.
Public property | AltitudeIsMetric | Gets or sets a value indicating that the AC field had the M bit set, which indicates that Altitude is in metric units.
Public property | ApplicationField | Gets or sets the content of the AF field in a DF19 reply.
Public property | Capability | Gets or sets the CA field of the reply.
Public property | CommBMessage | Gets or sets the content of a 7-byte message being sent to the ground in the MB field of the reply.
Public property | CommDMessage | Gets or sets the content of the 10-byte MD field from the reply.
Public property | ControlField | Gets or sets the content of the CF field for a non-transponder extended squitter reply.
Public property | CrossLinkCapability | Gets or sets a value indicating that the transponder supports the cross-link capability, as exposed by the CC field of the reply.
Public property | DownlinkFormat | Gets or sets the decoded downlink format (DF) field of the reply. This is present on all replies.
Public property | DownlinkRequest | Gets or sets the DR field from the reply.
Public property | DSegmentNumber | Gets or sets the content of the ND field from the reply.
Public property | ElmControl | Gets or sets the ELM control setting in the KE field of the reply.
Public property | ExtendedSquitterMessage | Gets or sets the 7-byte broadcast message in the ME field of an extended squitter reply.
Public property | ExtendedSquitterSupplementaryMessage | Gets or sets the 10-byte body of a DF18 reply when the control field is not 0, 1 or 6 in a DF18 reply, or the 13-byte body of a DF19 reply where the application field is not 0.
Public property | FlightStatus | Gets or sets the FS field from the reply.
Public property | FormattedIcao24 | Gets the formatted ICAO24 code of the aircraft after any parity bits have been masked out (if applicable).
Public property | Icao24 | Gets or sets the ICAO24 identifier of the aircraft, either from the AP field or the AA field of the reply (as appropriate).
Public property | Identity | Gets or sets the content of the ID field (the squawk code) from the reply.
Public property | IsMlat | Gets or sets a value indicating that the message was generated by an MLAT receiver / server.
Public property | NonIcao24Address | Gets or sets the content of AA fields where the content is not an ICAO24 address.
Public property | ParityInterrogatorIdentifier | Gets or sets the 24-bit interrogator's identifier code with parity masked out (PI).
Public property | PossibleCallsign | Gets or sets the content of the CommBMessage when the first byte indicates that it is a BDS2,0 reply.
Public property | ReplyInformation | Gets or sets the reply information from the RI field of the reply.
Public property | SensitivityLevel | Gets or sets the ACAS sensitivity level from the SL field of the reply.
Public property | SignalLevel | Gets or sets the signal level of the message, if known. Null if not known.
Public property | UtilityMessage | Gets or sets the UM field from the reply.
Public property | VerticalStatus | Gets or sets the vertical status from the VS field of the reply.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
Remarks
This object carries the information from all Mode-S transponder replies. Null properties were either not present in the reply or could not be decoded. The class is not thread-safe.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


ModeSMessage Constructor

ModeSMessage Constructor
Initializes a new instance of the ModeSMessage class

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModeSMessage()
Public Sub New
public:
ModeSMessage()
new : unit -> ModeSMessage
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage Properties

ModeSMessage Properties

The ModeSMessage type exposes the following members.

Properties
 | Name | Description
Public property | ACASMessage | Gets or sets the 7-byte information in the MV field of the reply.
Public property | Altitude | Gets or sets the altitude in feet as described by the AC field from the reply.
Public property | AltitudeIsMetric | Gets or sets a value indicating that the AC field had the M bit set, which indicates that Altitude is in metric units.
Public property | ApplicationField | Gets or sets the content of the AF field in a DF19 reply.
Public property | Capability | Gets or sets the CA field of the reply.
Public property | CommBMessage | Gets or sets the content of a 7-byte message being sent to the ground in the MB field of the reply.
Public property | CommDMessage | Gets or sets the content of the 10-byte MD field from the reply.
Public property | ControlField | Gets or sets the content of the CF field for a non-transponder extended squitter reply.
Public property | CrossLinkCapability | Gets or sets a value indicating that the transponder supports the cross-link capability, as exposed by the CC field of the reply.
Public property | DownlinkFormat | Gets or sets the decoded downlink format (DF) field of the reply. This is present on all replies.
Public property | DownlinkRequest | Gets or sets the DR field from the reply.
Public property | DSegmentNumber | Gets or sets the content of the ND field from the reply.
Public property | ElmControl | Gets or sets the ELM control setting in the KE field of the reply.
Public property | ExtendedSquitterMessage | Gets or sets the 7-byte broadcast message in the ME field of an extended squitter reply.
Public property | ExtendedSquitterSupplementaryMessage | Gets or sets the 10-byte body of a DF18 reply when the control field is not 0, 1 or 6 in a DF18 reply, or the 13-byte body of a DF19 reply where the application field is not 0.
Public property | FlightStatus | Gets or sets the FS field from the reply.
Public property | FormattedIcao24 | Gets the formatted ICAO24 code of the aircraft after any parity bits have been masked out (if applicable).
Public property | Icao24 | Gets or sets the ICAO24 identifier of the aircraft, either from the AP field or the AA field of the reply (as appropriate).
Public property | Identity | Gets or sets the content of the ID field (the squawk code) from the reply.
Public property | IsMlat | Gets or sets a value indicating that the message was generated by an MLAT receiver / server.
Public property | NonIcao24Address | Gets or sets the content of AA fields where the content is not an ICAO24 address.
Public property | ParityInterrogatorIdentifier | Gets or sets the 24-bit interrogator's identifier code with parity masked out (PI).
Public property | PossibleCallsign | Gets or sets the content of the CommBMessage when the first byte indicates that it is a BDS2,0 reply.
Public property | ReplyInformation | Gets or sets the reply information from the RI field of the reply.
Public property | SensitivityLevel | Gets or sets the ACAS sensitivity level from the SL field of the reply.
Public property | SignalLevel | Gets or sets the signal level of the message, if known. Null if not known.
Public property | UtilityMessage | Gets or sets the UM field from the reply.
Public property | VerticalStatus | Gets or sets the vertical status from the VS field of the reply.
Top
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ACASMessage Property

ModeSMessageACASMessage Property
Gets or sets the 7-byte information in the MV field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ACASMessage { get; set; }
Public Property ACASMessage As Byte()
    Get
    Set
public:
property array<unsigned char>^ ACASMessage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ACASMessage : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.Altitude Property

ModeSMessageAltitude Property
Gets or sets the altitude in feet as described by the AC field from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Altitude { get; set; }
Public Property Altitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Altitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Altitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.AltitudeIsMetric Property

ModeSMessageAltitudeIsMetric Property
Gets or sets a value indicating that the AC field had the M bit set, which indicates that Altitude is in metric units.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> AltitudeIsMetric { get; set; }
Public Property AltitudeIsMetric As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> AltitudeIsMetric {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member AltitudeIsMetric : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks
This is reserved for the formatting of altitude in metric units. However it appears that such an encoding has not yet (Jul 2012) been specified - if you see this set in a message then the message was likely corrupt and should be discarded.
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ApplicationField Property

ModeSMessageApplicationField Property
Gets or sets the content of the AF field in a DF19 reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<ApplicationField> ApplicationField { get; set; }
Public Property ApplicationField As Nullable(Of ApplicationField)
    Get
    Set
public:
property Nullable<ApplicationField> ApplicationField {
    Nullable<ApplicationField> get ();
    void set (Nullable<ApplicationField> value);
}
member ApplicationField : Nullable<ApplicationField> with get, set

Property Value

Type: Nullable ApplicationField
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.Capability Property

ModeSMessageCapability Property
Gets or sets the CA field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Capability> Capability { get; set; }
Public Property Capability As Nullable(Of Capability)
    Get
    Set
public:
property Nullable<Capability> Capability {
    Nullable<Capability> get ();
    void set (Nullable<Capability> value);
}
member Capability : Nullable<Capability> with get, set

Property Value

Type: Nullable Capability
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.CommBMessage Property

ModeSMessageCommBMessage Property
Gets or sets the content of a 7-byte message being sent to the ground in the MB field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] CommBMessage { get; set; }
Public Property CommBMessage As Byte()
    Get
    Set
public:
property array<unsigned char>^ CommBMessage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member CommBMessage : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.CommDMessage Property

ModeSMessageCommDMessage Property
Gets or sets the content of the 10-byte MD field from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] CommDMessage { get; set; }
Public Property CommDMessage As Byte()
    Get
    Set
public:
property array<unsigned char>^ CommDMessage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member CommDMessage : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ControlField Property

ModeSMessageControlField Property
Gets or sets the content of the CF field for a non-transponder extended squitter reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<ControlField> ControlField { get; set; }
Public Property ControlField As Nullable(Of ControlField)
    Get
    Set
public:
property Nullable<ControlField> ControlField {
    Nullable<ControlField> get ();
    void set (Nullable<ControlField> value);
}
member ControlField : Nullable<ControlField> with get, set

Property Value

Type: Nullable ControlField
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.CrossLinkCapability Property

ModeSMessageCrossLinkCapability Property
Gets or sets a value indicating that the transponder supports the cross-link capability, as exposed by the CC field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> CrossLinkCapability { get; set; }
Public Property CrossLinkCapability As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> CrossLinkCapability {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member CrossLinkCapability : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.DownlinkFormat Property

ModeSMessageDownlinkFormat Property
Gets or sets the decoded downlink format (DF) field of the reply. This is present on all replies.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DownlinkFormat DownlinkFormat { get; set; }
Public Property DownlinkFormat As DownlinkFormat
    Get
    Set
public:
property DownlinkFormat DownlinkFormat {
    DownlinkFormat get ();
    void set (DownlinkFormat value);
}
member DownlinkFormat : DownlinkFormat with get, set

Property Value

Type: DownlinkFormat
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.DownlinkRequest Property

ModeSMessageDownlinkRequest Property
Gets or sets the DR field from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> DownlinkRequest { get; set; }
Public Property DownlinkRequest As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> DownlinkRequest {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member DownlinkRequest : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.DSegmentNumber Property

ModeSMessageDSegmentNumber Property
Gets or sets the content of the ND field from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> DSegmentNumber { get; set; }
Public Property DSegmentNumber As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> DSegmentNumber {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member DSegmentNumber : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ElmControl Property

ModeSMessageElmControl Property
Gets or sets the ELM control setting in the KE field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<ElmControl> ElmControl { get; set; }
Public Property ElmControl As Nullable(Of ElmControl)
    Get
    Set
public:
property Nullable<ElmControl> ElmControl {
    Nullable<ElmControl> get ();
    void set (Nullable<ElmControl> value);
}
member ElmControl : Nullable<ElmControl> with get, set

Property Value

Type: Nullable ElmControl
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ExtendedSquitterMessage Property

ModeSMessageExtendedSquitterMessage Property
Gets or sets the 7-byte broadcast message in the ME field of an extended squitter reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ExtendedSquitterMessage { get; set; }
Public Property ExtendedSquitterMessage As Byte()
    Get
    Set
public:
property array<unsigned char>^ ExtendedSquitterMessage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ExtendedSquitterMessage : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ExtendedSquitterSupplementaryMessage Property

ModeSMessageExtendedSquitterSupplementaryMessage Property
Gets or sets the 10-byte body of a DF18 reply when the control field is not 0, 1 or 6 in a DF18 reply, or the 13-byte body of a DF19 reply where the application field is not 0.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ExtendedSquitterSupplementaryMessage { get; set; }
Public Property ExtendedSquitterSupplementaryMessage As Byte()
    Get
    Set
public:
property array<unsigned char>^ ExtendedSquitterSupplementaryMessage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ExtendedSquitterSupplementaryMessage : byte[] with get, set

Property Value

Type: Byte
Remarks

3.1.2.8.7.2 states that the control field determines the content of DF18 messages. If the control field is set to 0 (ControlField).AdsbDeviceTransmittingIcao24 then the Icao24 and ExtendedSquitterMessage properties are set and this field is null. Otherwise Icao24 is left at 0, ExtendedSquitterMessage is null and this property is filled with the ten bytes between the CF field and the PI field. I've labelled this as a MEX field in the ToString() description of the object but in reality the spec does not declare a name for the field and only describes the content for CF0 messages.

For DF19 messages the only messages that can potentially be decoded are those where the AF field is 0, although even this appears contentious. For all other message types the entire body of the message (which is likely to be encrypted) is placed in this block.

See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.FlightStatus Property

ModeSMessageFlightStatus Property
Gets or sets the FS field from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<FlightStatus> FlightStatus { get; set; }
Public Property FlightStatus As Nullable(Of FlightStatus)
    Get
    Set
public:
property Nullable<FlightStatus> FlightStatus {
    Nullable<FlightStatus> get ();
    void set (Nullable<FlightStatus> value);
}
member FlightStatus : Nullable<FlightStatus> with get, set

Property Value

Type: Nullable FlightStatus
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.FormattedIcao24 Property

ModeSMessageFormattedIcao24 Property
Gets the formatted ICAO24 code of the aircraft after any parity bits have been masked out (if applicable).

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FormattedIcao24 { get; }
Public ReadOnly Property FormattedIcao24 As String
    Get
public:
property String^ FormattedIcao24 {
    String^ get ();
}
member FormattedIcao24 : string with get

Property Value

Type: String
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.Icao24 Property

ModeSMessageIcao24 Property
Gets or sets the ICAO24 identifier of the aircraft, either from the AP field or the AA field of the reply (as appropriate).

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Icao24 { get; set; }
Public Property Icao24 As Integer
    Get
    Set
public:
property int Icao24 {
    int get ();
    void set (int value);
}
member Icao24 : int with get, set

Property Value

Type: Int32
Remarks
This can be zero for DF18 (Extended Squitter from Non-Transponder devices) replies if the ControlField indicates that the message is coming from a non-transponder device that does not broadcast ICAO24 addresses in its AA field. It can also be zero for downlink formats that are either reserved for future use or for DF19 (military extended squitter) where the aircraft address field is not defined by the spec.
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.Identity Property

ModeSMessageIdentity Property
Gets or sets the content of the ID field (the squawk code) from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<short> Identity { get; set; }
Public Property Identity As Nullable(Of Short)
    Get
    Set
public:
property Nullable<short> Identity {
    Nullable<short> get ();
    void set (Nullable<short> value);
}
member Identity : Nullable<int16> with get, set

Property Value

Type: Nullable Int16
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.IsMlat Property

ModeSMessageIsMlat Property
Gets or sets a value indicating that the message was generated by an MLAT receiver / server.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMlat { get; set; }
Public Property IsMlat As Boolean
    Get
    Set
public:
property bool IsMlat {
    bool get ();
    void set (bool value);
}
member IsMlat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.NonIcao24Address Property

ModeSMessageNonIcao24Address Property
Gets or sets the content of AA fields where the content is not an ICAO24 address.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> NonIcao24Address { get; set; }
Public Property NonIcao24Address As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> NonIcao24Address {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member NonIcao24Address : Nullable<int> with get, set

Property Value

Type: Nullable Int32
Remarks
This is filled for DF18 messages where the control field indicates that the transmitter is not using an ICAO24 address.
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ParityInterrogatorIdentifier Property

ModeSMessageParityInterrogatorIdentifier Property
Gets or sets the 24-bit interrogator's identifier code with parity masked out (PI).

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ParityInterrogatorIdentifier { get; set; }
Public Property ParityInterrogatorIdentifier As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ParityInterrogatorIdentifier {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ParityInterrogatorIdentifier : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.PossibleCallsign Property

ModeSMessagePossibleCallsign Property
Gets or sets the content of the CommBMessage when the first byte indicates that it is a BDS2,0 reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PossibleCallsign { get; set; }
Public Property PossibleCallsign As String
    Get
    Set
public:
property String^ PossibleCallsign {
    String^ get ();
    void set (String^ value);
}
member PossibleCallsign : string with get, set

Property Value

Type: String
Remarks
Other BDS replies could potentially also decode to 0x20 in the first byte of the CommBMessage so the content of this field should be treated as suspect. If a more certain source of callsign information is available then that should be preferred over this.
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ReplyInformation Property

ModeSMessageReplyInformation Property
Gets or sets the reply information from the RI field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> ReplyInformation { get; set; }
Public Property ReplyInformation As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> ReplyInformation {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member ReplyInformation : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
Remarks
Originally I had this as an enum of the different values in 3.1.2.8.2.2 of the spec, but then when I read 3.1.2.8.4 it seemed to be saying that the RI field would change its meaning depending on values sent by the interrogator that elicited the ACAS reply. As we don't know what those values were we can't be sure what the meaning of RI is, and as the only useful information contained in 3.1.2.8.2.2 was the maximum cruise airspeed - which isn't really very interesting from a radar spotting perspective - I decided to just make it a raw number instead.
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.SensitivityLevel Property

ModeSMessageSensitivityLevel Property
Gets or sets the ACAS sensitivity level from the SL field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> SensitivityLevel { get; set; }
Public Property SensitivityLevel As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> SensitivityLevel {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member SensitivityLevel : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.SignalLevel Property

ModeSMessageSignalLevel Property
Gets or sets the signal level of the message, if known. Null if not known.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SignalLevel { get; set; }
Public Property SignalLevel As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SignalLevel {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SignalLevel : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.UtilityMessage Property

ModeSMessageUtilityMessage Property
Gets or sets the UM field from the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<byte> UtilityMessage { get; set; }
Public Property UtilityMessage As Nullable(Of Byte)
    Get
    Set
public:
property Nullable<unsigned char> UtilityMessage {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}
member UtilityMessage : Nullable<byte> with get, set

Property Value

Type: Nullable Byte
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.VerticalStatus Property

ModeSMessageVerticalStatus Property
Gets or sets the vertical status from the VS field of the reply.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<VerticalStatus> VerticalStatus { get; set; }
Public Property VerticalStatus As Nullable(Of VerticalStatus)
    Get
    Set
public:
property Nullable<VerticalStatus> VerticalStatus {
    Nullable<VerticalStatus> get ();
    void set (Nullable<VerticalStatus> value);
}
member VerticalStatus : Nullable<VerticalStatus> with get, set

Property Value

Type: Nullable VerticalStatus
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage Methods

ModeSMessage Methods

The ModeSMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns an English description of the object. (Overrides ObjectToString.)
Top
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessage.ToString Method

ModeSMessageToString Method
Returns an English description of the object.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ModeSMessage Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs Class

ModeSMessageEventArgs Class
The event that is raised when a listener to a source of raw Mode-S messages from an aircraft receives a message.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.ModeSModeSMessageEventArgs

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModeSMessageEventArgs : EventArgs
Public Class ModeSMessageEventArgs
    Inherits EventArgs
public ref class ModeSMessageEventArgs : public EventArgs
type ModeSMessageEventArgs =
    class
        inherit EventArgs
    end

The ModeSMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ModeSMessageEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | AdsbMessage | Gets the decoded ADS-B message from extended squitter Mode-S messages. This will be null if the Mode-S message did not contain an ADS-B payload.
Public property | ModeSMessage | Gets the decoded Mode-S message from the aircraft.
Public property | ReceivedUtc | Gets the date and time at UTC when the message was received.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs Constructor

ModeSMessageEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModeSMessageEventArgs(
    DateTime utcNow,
    ModeSMessage modeSMessage,
    AdsbMessage adsbMessage
)
Public Sub New (
    utcNow As DateTime,
    modeSMessage As ModeSMessage,
    adsbMessage As AdsbMessage
)
public:
ModeSMessageEventArgs(
    DateTime utcNow,
    ModeSMessage^ modeSMessage,
    AdsbMessage^ adsbMessage
)
new :
        utcNow : DateTime *
        modeSMessage : ModeSMessage *
        adsbMessage : AdsbMessage -> ModeSMessageEventArgs

Parameters

utcNow
Type: SystemDateTime
modeSMessage
Type: VirtualRadar.Interface.ModeSModeSMessage
adsbMessage
Type: VirtualRadar.Interface.AdsbAdsbMessage
See Also

Reference

ModeSMessageEventArgs Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs Properties

ModeSMessageEventArgs Properties

The ModeSMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AdsbMessage | Gets the decoded ADS-B message from extended squitter Mode-S messages. This will be null if the Mode-S message did not contain an ADS-B payload.
Public property | ModeSMessage | Gets the decoded Mode-S message from the aircraft.
Public property | ReceivedUtc | Gets the date and time at UTC when the message was received.
Top
See Also

Reference

ModeSMessageEventArgs Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs.AdsbMessage Property

ModeSMessageEventArgsAdsbMessage Property
Gets the decoded ADS-B message from extended squitter Mode-S messages. This will be null if the Mode-S message did not contain an ADS-B payload.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AdsbMessage AdsbMessage { get; }
Public ReadOnly Property AdsbMessage As AdsbMessage
    Get
public:
property AdsbMessage^ AdsbMessage {
    AdsbMessage^ get ();
}
member AdsbMessage : AdsbMessage with get

Property Value

Type: AdsbMessage
See Also

Reference

ModeSMessageEventArgs Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs.ModeSMessage Property

ModeSMessageEventArgsModeSMessage Property
Gets the decoded Mode-S message from the aircraft.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModeSMessage ModeSMessage { get; }
Public ReadOnly Property ModeSMessage As ModeSMessage
    Get
public:
property ModeSMessage^ ModeSMessage {
    ModeSMessage^ get ();
}
member ModeSMessage : ModeSMessage with get

Property Value

Type: ModeSMessage
See Also

Reference

ModeSMessageEventArgs Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs.ReceivedUtc Property

ModeSMessageEventArgsReceivedUtc Property
Gets the date and time at UTC when the message was received.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ReceivedUtc { get; }
Public ReadOnly Property ReceivedUtc As DateTime
    Get
public:
property DateTime ReceivedUtc {
    DateTime get ();
}
member ReceivedUtc : DateTime with get

Property Value

Type: DateTime
See Also

Reference

ModeSMessageEventArgs Class
VirtualRadar.Interface.ModeS Namespace


ModeSMessageEventArgs Methods

ModeSMessageEventArgs Methods

The ModeSMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ModeSMessageEventArgs Class
VirtualRadar.Interface.ModeS Namespace


VerticalStatus Enumeration

VerticalStatus Enumeration
An enumeration of the different possible values in a VS field.

Namespace: VirtualRadar.Interface.ModeS
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerticalStatus
Public Enumeration VerticalStatus
public enum class VerticalStatus
type VerticalStatus
Members
Member name | Value | Description
Airborne | 0 | The aircraft is airborne.
OnGround | 1 | The aircraft is on the ground.
See Also

Reference

VirtualRadar.Interface.ModeS Namespace


VirtualRadar.Interface.Network Namespace

VirtualRadar.Interface.Network Namespace

[Missing <summary> documentation for "N:VirtualRadar.Interface.Network"]

Classes
 | Class | Description
Public class | ConnectionEventArgs | The arguments passed to connection events.
Public class | ConnectorActivityEvent | Describes a single event that occurred for a connector.
Public class | RebroadcastFormatName | Links a rebroadcast server format's name to its unique ID.
Interfaces
 | Interface | Description
Public interface | IConnection | Describes a single connection exposed by an IConnector.
Public interface | IConnector | The interface for objects that can establish a connection with a remote machine.
Public interface | IConnectorActivityLog | The interface for a singleton object that records activity across every connector created by the application.
Public interface | IConnectorAuthentication | The interface for all authentication classes.
Public interface | IConnectorSnapshotLogger | The interface that objects that log snapshots of all of the connections must implement.
Public interface | INetworkConnection | The interface for an IConnection exposed by INetworkConnector.
Public interface | INetworkConnector | An active connector that connects to a single machine over the IP network.
Public interface | IPassphraseAuthentication | The interface for objects that implement passphrase authentication on rebroadcast servers.
Public interface | IRebroadcastFormatManager | The singleton manager that keeps track of all registered rebroadcast server formats.
Public interface | IRebroadcastFormatProvider | The interface that all rebroadcast server format providers must implement.
Public interface | IRebroadcastServer | The interface for objects that can rebroadcast messages or bytes received by an IListener.
Public interface | IRebroadcastServerManager | The interface for a singleton object that can configure and control a collection of IRebroadcastServers.
Public interface | ISerialConnector | An active connector that connects to a device over a serial COM port.
Public interface | ITcpConnectionStateService | A service that can retrieve the state of TCP connections.
Delegates
 | Delegate | Description
Public delegate | ConnectionReadDelegate | The delegate that is called when an IConnection reads bytes off the connection.
Enumerations
 | Enumeration | Description
Public enumeration | ConnectionStatus | The various states that an IListener can be in.
Public enumeration | ConnectorActivityType | Describes the types of connector activity that are logged.


ConnectionEventArgs Class

ConnectionEventArgs Class
The arguments passed to connection events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.NetworkConnectionEventArgs

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectionEventArgs : EventArgs
Public Class ConnectionEventArgs
    Inherits EventArgs
public ref class ConnectionEventArgs : public EventArgs
type ConnectionEventArgs =
    class
        inherit EventArgs
    end

The ConnectionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | Connection | Gets the connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


ConnectionEventArgs Constructor

ConnectionEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionEventArgs(
    IConnection connection
)
Public Sub New (
    connection As IConnection
)
public:
ConnectionEventArgs(
    IConnection^ connection
)
new :
        connection : IConnection -> ConnectionEventArgs

Parameters

connection
Type: VirtualRadar.Interface.NetworkIConnection
See Also

Reference

ConnectionEventArgs Class
VirtualRadar.Interface.Network Namespace


ConnectionEventArgs Properties

ConnectionEventArgs Properties

The ConnectionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Connection | Gets the connection.
Top
See Also

Reference

ConnectionEventArgs Class
VirtualRadar.Interface.Network Namespace


ConnectionEventArgs.Connection Property

ConnectionEventArgsConnection Property
Gets the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IConnection Connection { get; }
Public ReadOnly Property Connection As IConnection
    Get
public:
property IConnection^ Connection {
    IConnection^ get ();
}
member Connection : IConnection with get

Property Value

Type: IConnection
See Also

Reference

ConnectionEventArgs Class
VirtualRadar.Interface.Network Namespace


ConnectionEventArgs Methods

ConnectionEventArgs Methods

The ConnectionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionEventArgs Class
VirtualRadar.Interface.Network Namespace


ConnectionReadDelegate Delegate

ConnectionReadDelegate Delegate
The delegate that is called when an IConnection reads bytes off the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ConnectionReadDelegate(
    IConnection connection,
    byte[] buffer,
    int offset,
    int length,
    int bytesRead
)
Public Delegate Sub ConnectionReadDelegate (
    connection As IConnection,
    buffer As Byte(),
    offset As Integer,
    length As Integer,
    bytesRead As Integer
)
public delegate void ConnectionReadDelegate(
    IConnection^ connection,
    array<unsigned char>^ buffer,
    int offset,
    int length,
    int bytesRead
)
type ConnectionReadDelegate =
    delegate of
        connection : IConnection *
        buffer : byte[] *
        offset : int *
        length : int *
        bytesRead : int -> unit

Parameters

connection
Type: VirtualRadar.Interface.NetworkIConnection
buffer
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
bytesRead
Type: SystemInt32
See Also

Reference

VirtualRadar.Interface.Network Namespace


ConnectionStatus Enumeration

ConnectionStatus Enumeration
The various states that an IListener can be in.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionStatus
Public Enumeration ConnectionStatus
public enum class ConnectionStatus
type ConnectionStatus
Members
Member name | Value | Description
Disconnected | 0 | The listener is not connected to the source of aircraft message data.
Connecting | 1 | The listener is attempting to connect to the source of aircraft message data.
Connected | 2 | The listener has connected to the source of aircraft message data.
CannotConnect | 3 | The listener tried to connect to the source of aircraft message data and failed. It won't try again.
Reconnecting | 4 | The listener was connected to the source of aircraft message data but it seems to have broken and it is trying to automatically reconnect.
Waiting | 5 | The listener is waiting for a connection to be made to it.
See Also

Reference

VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Class

ConnectorActivityEvent Class
Describes a single event that occurred for a connector.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.NetworkConnectorActivityEvent

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectorActivityEvent
Public Class ConnectorActivityEvent
public ref class ConnectorActivityEvent
type ConnectorActivityEvent =  class end

The ConnectorActivityEvent type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorActivityEvent(String, String, TimestampedException) | Creates a new object.
Public method | ConnectorActivityEvent(String, ConnectorActivityType, String) | Creates a new object.
Protected method | ConnectorActivityEvent(String, ConnectorActivityType, String, TimestampedException) | Creates a new object.
Top
Properties
 | Name | Description
Public property | ConnectorName | Gets the name of the connector.
Public property | Exception | Gets the recorded exception.
Public property | Id | Gets a unique identifier assigned to each event object created.
Public property | Message | Gets a message describing the activity. The message is always in English, I need to be able to read them when supporting VRS.
Public property | Time | Gets the time (at UTC) that the activity took place.
Public property | Type | Gets the type of activity.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShiftTimeForwardOneMillisecond | Moves the activity's time forward one millisecond so that it sorts into the true order when two activities with the exact same time are recorded.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Constructor

ConnectorActivityEvent Constructor
Overload List
 | Name | Description
Public method | ConnectorActivityEvent(String, String, TimestampedException) | Creates a new object.
Public method | ConnectorActivityEvent(String, ConnectorActivityType, String) | Creates a new object.
Protected method | ConnectorActivityEvent(String, ConnectorActivityType, String, TimestampedException) | Creates a new object.
Top
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Constructor (String, String, TimestampedException)

ConnectorActivityEvent Constructor (String, String, TimestampedException)
Creates a new object.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorActivityEvent(
    string connectorName,
    string message,
    TimestampedException exception
)
Public Sub New (
    connectorName As String,
    message As String,
    exception As TimestampedException
)
public:
ConnectorActivityEvent(
    String^ connectorName,
    String^ message,
    TimestampedException^ exception
)
new :
        connectorName : string *
        message : string *
        exception : TimestampedException -> ConnectorActivityEvent

Parameters

connectorName
Type: SystemString
message
Type: SystemString
exception
Type: VirtualRadar.InterfaceTimestampedException
See Also

Reference

ConnectorActivityEvent Class
ConnectorActivityEvent Overload
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Constructor (String, ConnectorActivityType, String)

ConnectorActivityEvent Constructor (String, ConnectorActivityType, String)
Creates a new object.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorActivityEvent(
    string connectorName,
    ConnectorActivityType type,
    string message
)
Public Sub New (
    connectorName As String,
    type As ConnectorActivityType,
    message As String
)
public:
ConnectorActivityEvent(
    String^ connectorName,
    ConnectorActivityType type,
    String^ message
)
new :
        connectorName : string *
        type : ConnectorActivityType *
        message : string -> ConnectorActivityEvent

Parameters

connectorName
Type: SystemString
type
Type: VirtualRadar.Interface.NetworkConnectorActivityType
message
Type: SystemString
See Also

Reference

ConnectorActivityEvent Class
ConnectorActivityEvent Overload
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Constructor (String, ConnectorActivityType, String, TimestampedException)

ConnectorActivityEvent Constructor (String, ConnectorActivityType, String, TimestampedException)
Creates a new object.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ConnectorActivityEvent(
    string connectorName,
    ConnectorActivityType type,
    string message,
    TimestampedException exception
)
Protected Sub New (
    connectorName As String,
    type As ConnectorActivityType,
    message As String,
    exception As TimestampedException
)
protected:
ConnectorActivityEvent(
    String^ connectorName,
    ConnectorActivityType type,
    String^ message,
    TimestampedException^ exception
)
new :
        connectorName : string *
        type : ConnectorActivityType *
        message : string *
        exception : TimestampedException -> ConnectorActivityEvent

Parameters

connectorName
Type: SystemString
type
Type: VirtualRadar.Interface.NetworkConnectorActivityType
message
Type: SystemString
exception
Type: VirtualRadar.InterfaceTimestampedException
See Also

Reference

ConnectorActivityEvent Class
ConnectorActivityEvent Overload
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Properties

ConnectorActivityEvent Properties

The ConnectorActivityEvent type exposes the following members.

Properties
 | Name | Description
Public property | ConnectorName | Gets the name of the connector.
Public property | Exception | Gets the recorded exception.
Public property | Id | Gets a unique identifier assigned to each event object created.
Public property | Message | Gets a message describing the activity. The message is always in English, I need to be able to read them when supporting VRS.
Public property | Time | Gets the time (at UTC) that the activity took place.
Public property | Type | Gets the type of activity.
Top
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.ConnectorName Property

ConnectorActivityEventConnectorName Property
Gets the name of the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConnectorName { get; }
Public ReadOnly Property ConnectorName As String
    Get
public:
property String^ ConnectorName {
    String^ get ();
}
member ConnectorName : string with get

Property Value

Type: String
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.Exception Property

ConnectorActivityEventException Property
Gets the recorded exception.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimestampedException Exception { get; }
Public ReadOnly Property Exception As TimestampedException
    Get
public:
property TimestampedException^ Exception {
    TimestampedException^ get ();
}
member Exception : TimestampedException with get

Property Value

Type: TimestampedException
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.Id Property

ConnectorActivityEventId Property
Gets a unique identifier assigned to each event object created.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Id { get; }
Public ReadOnly Property Id As Long
    Get
public:
property long long Id {
    long long get ();
}
member Id : int64 with get

Property Value

Type: Int64
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.Message Property

ConnectorActivityEventMessage Property
Gets a message describing the activity. The message is always in English, I need to be able to read them when supporting VRS.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
member Message : string with get

Property Value

Type: String
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.Time Property

ConnectorActivityEventTime Property
Gets the time (at UTC) that the activity took place.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime Time { get; }
Public ReadOnly Property Time As DateTime
    Get
public:
property DateTime Time {
    DateTime get ();
}
member Time : DateTime with get

Property Value

Type: DateTime
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.Type Property

ConnectorActivityEventType Property
Gets the type of activity.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorActivityType Type { get; }
Public ReadOnly Property Type As ConnectorActivityType
    Get
public:
property ConnectorActivityType Type {
    ConnectorActivityType get ();
}
member Type : ConnectorActivityType with get

Property Value

Type: ConnectorActivityType
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent Methods

ConnectorActivityEvent Methods

The ConnectorActivityEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShiftTimeForwardOneMillisecond | Moves the activity's time forward one millisecond so that it sorts into the true order when two activities with the exact same time are recorded.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityEvent.ShiftTimeForwardOneMillisecond Method

ConnectorActivityEventShiftTimeForwardOneMillisecond Method
Moves the activity's time forward one millisecond so that it sorts into the true order when two activities with the exact same time are recorded.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShiftTimeForwardOneMillisecond()
Public Sub ShiftTimeForwardOneMillisecond
public:
void ShiftTimeForwardOneMillisecond()
member ShiftTimeForwardOneMillisecond : unit -> unit
See Also

Reference

ConnectorActivityEvent Class
VirtualRadar.Interface.Network Namespace


ConnectorActivityType Enumeration

ConnectorActivityType Enumeration
Describes the types of connector activity that are logged.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorActivityType
Public Enumeration ConnectorActivityType
public enum class ConnectorActivityType
type ConnectorActivityType
Members
Member name | Value | Description
Miscellaneous | 0 | Any categories of activity not covered by the other types.
Connected | 1 | A connection was established.
Disconnected | 2 | A connection was dropped.
Exception | 3 | An exception was caught.
See Also

Reference

VirtualRadar.Interface.Network Namespace


IConnection Interface

IConnection Interface
Describes a single connection exposed by an IConnector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnection : IDisposable
Public Interface IConnection
    Inherits IDisposable
public interface class IConnection : IDisposable
type IConnection =
    interface
        interface IDisposable
    end

The IConnection type exposes the following members.

Properties
 | Name | Description
Public property | BytesRead | Gets the total number of bytes read on the connection.
Public property | BytesWritten | Gets the total number of bytes sent.
Public property | ConnectionStatus | Gets the current state of the connection.
Public property | Connector | Gets the connector that owns this connection.
Public property | Created | Gets the date and time at UTC when the connection was established.
Public property | Description | Gets a description of the connection.
Public property | OperationQueueEntries | Gets how many operations are queued for this connection.
Public property | StaleBytesDiscarded | Gets the total number of bytes that have been discarded because they were stale.
Public property | WriteQueueBytes | Gets the total number of bytes queued for sending.
Top
Methods
 | Name | Description
Public method | Abandon | Abandons the connection, closing and destroying it.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the connection.
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the connection.
Public method | Write(Byte, Int32) | Sends the content of the buffer over the connection.
Public method | Write(Byte, Int32, Int32, Int32) | Sends the content of the buffer over the connection.
Top
Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when ConnectionStatus changes.
Top
Remarks
Exceptions caught by the connection are channeled through the owning IConnector with the sender set to the IConnection object.
See Also

Reference

VirtualRadar.Interface.Network Namespace


IConnection Properties

IConnection Properties

The IConnection type exposes the following members.

Properties
 | Name | Description
Public property | BytesRead | Gets the total number of bytes read on the connection.
Public property | BytesWritten | Gets the total number of bytes sent.
Public property | ConnectionStatus | Gets the current state of the connection.
Public property | Connector | Gets the connector that owns this connection.
Public property | Created | Gets the date and time at UTC when the connection was established.
Public property | Description | Gets a description of the connection.
Public property | OperationQueueEntries | Gets how many operations are queued for this connection.
Public property | StaleBytesDiscarded | Gets the total number of bytes that have been discarded because they were stale.
Public property | WriteQueueBytes | Gets the total number of bytes queued for sending.
Top
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.BytesRead Property

IConnectionBytesRead Property
Gets the total number of bytes read on the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BytesRead { get; }
ReadOnly Property BytesRead As Long
    Get
property long long BytesRead {
    long long get ();
}
abstract BytesRead : int64 with get

Property Value

Type: Int64
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.BytesWritten Property

IConnectionBytesWritten Property
Gets the total number of bytes sent.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BytesWritten { get; }
ReadOnly Property BytesWritten As Long
    Get
property long long BytesWritten {
    long long get ();
}
abstract BytesWritten : int64 with get

Property Value

Type: Int64
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.ConnectionStatus Property

IConnectionConnectionStatus Property
Gets the current state of the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectionStatus ConnectionStatus { get; }
ReadOnly Property ConnectionStatus As ConnectionStatus
    Get
property ConnectionStatus ConnectionStatus {
    ConnectionStatus get ();
}
abstract ConnectionStatus : ConnectionStatus with get

Property Value

Type: ConnectionStatus
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Connector Property

IConnectionConnector Property
Gets the connector that owns this connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnector Connector { get; }
ReadOnly Property Connector As IConnector
    Get
property IConnector^ Connector {
    IConnector^ get ();
}
abstract Connector : IConnector with get

Property Value

Type: IConnector
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Created Property

IConnectionCreated Property
Gets the date and time at UTC when the connection was established.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime Created { get; }
ReadOnly Property Created As DateTime
    Get
property DateTime Created {
    DateTime get ();
}
abstract Created : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Description Property

IConnectionDescription Property
Gets a description of the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.OperationQueueEntries Property

IConnectionOperationQueueEntries Property
Gets how many operations are queued for this connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int OperationQueueEntries { get; }
ReadOnly Property OperationQueueEntries As Integer
    Get
property int OperationQueueEntries {
    int get ();
}
abstract OperationQueueEntries : int with get

Property Value

Type: Int32
Remarks
The meaning of the term "operation" depends on the implementation of the connection. The intent is for this to show how many writes are queued on connections that send data to another machine; for other types of connection the result may be zero or one. Use for diagnostic purposes only.
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.StaleBytesDiscarded Property

IConnectionStaleBytesDiscarded Property
Gets the total number of bytes that have been discarded because they were stale.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long StaleBytesDiscarded { get; }
ReadOnly Property StaleBytesDiscarded As Long
    Get
property long long StaleBytesDiscarded {
    long long get ();
}
abstract StaleBytesDiscarded : int64 with get

Property Value

Type: Int64
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.WriteQueueBytes Property

IConnectionWriteQueueBytes Property
Gets the total number of bytes queued for sending.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long WriteQueueBytes { get; }
ReadOnly Property WriteQueueBytes As Long
    Get
property long long WriteQueueBytes {
    long long get ();
}
abstract WriteQueueBytes : int64 with get

Property Value

Type: Int64
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection Methods

IConnection Methods

The IConnection type exposes the following members.

Methods
 | Name | Description
Public method | Abandon | Abandons the connection, closing and destroying it.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the connection.
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the connection.
Public method | Write(Byte, Int32) | Sends the content of the buffer over the connection.
Public method | Write(Byte, Int32, Int32, Int32) | Sends the content of the buffer over the connection.
Top
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Abandon Method

IConnectionAbandon Method
Abandons the connection, closing and destroying it.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Abandon()
Sub Abandon
void Abandon()
abstract Abandon : unit -> unit
Remarks
Abandoning a connection is irreversible, you cannot make any further calls on it.
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Read Method

IConnectionRead Method
Overload List
 | Name | Description
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the connection.
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the connection.
Top
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Read Method (Byte[], ConnectionReadDelegate)

IConnectionRead Method (Byte, ConnectionReadDelegate)
Reads the next chunk from the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Read(
    byte[] buffer,
    ConnectionReadDelegate readDelegate
)
Sub Read (
    buffer As Byte(),
    readDelegate As ConnectionReadDelegate
)
void Read(
    array<unsigned char>^ buffer,
    ConnectionReadDelegate^ readDelegate
)
abstract Read :
        buffer : byte[] *
        readDelegate : ConnectionReadDelegate -> unit

Parameters

buffer
Type: SystemByte
readDelegate
Type: VirtualRadar.Interface.NetworkConnectionReadDelegate
Remarks
The call is non-blocking.
See Also

Reference

IConnection Interface
Read Overload
VirtualRadar.Interface.Network Namespace


IConnection.Read Method (Byte[], Int32, Int32, ConnectionReadDelegate)

IConnectionRead Method (Byte, Int32, Int32, ConnectionReadDelegate)
Reads the next chunk from the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Read(
    byte[] buffer,
    int offset,
    int length,
    ConnectionReadDelegate readDelegate
)
Sub Read (
    buffer As Byte(),
    offset As Integer,
    length As Integer,
    readDelegate As ConnectionReadDelegate
)
void Read(
    array<unsigned char>^ buffer,
    int offset,
    int length,
    ConnectionReadDelegate^ readDelegate
)
abstract Read :
        buffer : byte[] *
        offset : int *
        length : int *
        readDelegate : ConnectionReadDelegate -> unit

Parameters

buffer
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
readDelegate
Type: VirtualRadar.Interface.NetworkConnectionReadDelegate
See Also

Reference

IConnection Interface
Read Overload
VirtualRadar.Interface.Network Namespace


IConnection.Write Method

IConnectionWrite Method
Overload List
 | Name | Description
Public method | Write(Byte, Int32) | Sends the content of the buffer over the connection.
Public method | Write(Byte, Int32, Int32, Int32) | Sends the content of the buffer over the connection.
Top
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.Write Method (Byte[], Int32)

IConnectionWrite Method (Byte, Int32)
Sends the content of the buffer over the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Write(
    byte[] buffer,
    int staleMessageTimeoutOverride = -1
)
Sub Write (
    buffer As Byte(),
    Optional staleMessageTimeoutOverride As Integer = -1
)
void Write(
    array<unsigned char>^ buffer,
    int staleMessageTimeoutOverride = -1
)
abstract Write :
        buffer : byte[] *
        ?staleMessageTimeoutOverride : int
(* Defaults:
        let _staleMessageTimeoutOverride = defaultArg staleMessageTimeoutOverride -1
*)
-> unit

Parameters

buffer
Type: SystemByte
staleMessageTimeoutOverride (Optional)
Type: SystemInt32
See Also

Reference

IConnection Interface
Write Overload
VirtualRadar.Interface.Network Namespace


IConnection.Write Method (Byte[], Int32, Int32, Int32)

IConnectionWrite Method (Byte, Int32, Int32, Int32)
Sends the content of the buffer over the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Write(
    byte[] buffer,
    int offset,
    int length,
    int staleMessageTimeoutOverride = -1
)
Sub Write (
    buffer As Byte(),
    offset As Integer,
    length As Integer,
    Optional staleMessageTimeoutOverride As Integer = -1
)
void Write(
    array<unsigned char>^ buffer,
    int offset,
    int length,
    int staleMessageTimeoutOverride = -1
)
abstract Write :
        buffer : byte[] *
        offset : int *
        length : int *
        ?staleMessageTimeoutOverride : int
(* Defaults:
        let _staleMessageTimeoutOverride = defaultArg staleMessageTimeoutOverride -1
*)
-> unit

Parameters

buffer
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
staleMessageTimeoutOverride (Optional)
Type: SystemInt32
See Also

Reference

IConnection Interface
Write Overload
VirtualRadar.Interface.Network Namespace


IConnection Events

IConnection Events

The IConnection type exposes the following members.

Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when ConnectionStatus changes.
Top
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnection.ConnectionStateChanged Event

IConnectionConnectionStateChanged Event
Raised when ConnectionStatus changes.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConnectionStateChanged
Event ConnectionStateChanged As EventHandler
 event EventHandler^ ConnectionStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConnectionStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IConnection Interface
VirtualRadar.Interface.Network Namespace


IConnector Interface

IConnector Interface
The interface for objects that can establish a connection with a remote machine.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnector : IBackgroundThreadExceptionCatcher,
    IDisposable
Public Interface IConnector
    Inherits IBackgroundThreadExceptionCatcher, IDisposable
public interface class IConnector : IBackgroundThreadExceptionCatcher,
    IDisposable
type IConnector =
    interface
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IConnector type exposes the following members.

Properties
 | Name | Description
Public property | Authentication | Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication.
Public property | Connection | Gets the first (or only) connection established by the connector.
Public property | ConnectionStatus | Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status.
Public property | CountExceptions | Gets the number of exceptions ever encountered by the connector.
Public property | Created | Gets the date and time, at UTC, that the connector was first created.
Public property | EstablishingConnections | Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection.
Public property | HasConnection | Gets a value indicating that the connector has established a connection with at least one end point.
Public property | Intent | Gets a description of the intended use of the connector. Only used for diagnostics.
Public property | IsPassive | Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things.
Public property | IsSingleConnection | Gets or sets a value indicating whether the connector supports multiple connections or a single connection.
Public property | LastException | Gets the last exception encountered by the connector.
Public property | Name | Gets or sets the name of the connector.
Public property | StaleMessageTimeout | Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded.
Top
Methods
 | Name | Description
Public method | CloseConnection | Tells the connector to close all connections. This blocks until all connections have been shut down.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EstablishConnection | Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background.
Public method | GetActivityHistory | Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities.
Public method | GetConnections | Returns an array of established connections made by the connector.
Public method | GetExceptionHistory | Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions.
Public method | GetFirstConnection | Returns the first established connection or null if there are no connections.
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection.
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection.
Public method | RestartConnection | Closes the connection and then establishes the connection.
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection.
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection.
Top
Events
 | Name | Description
Public event | ActivityRecorded | Raised when an activity is recorded by the connector.
Public event | AddingConnection | Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread.
Public event | ConnectionClosed | Raised when a connection has been permanently closed. This will usually be raised from a background thread.
Public event | ConnectionEstablished | Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised.
Public event | ConnectionStateChanged | Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
Remarks

Connectors do the work of establishing a link with another machine or a piece of hardware. The intention is that the connector is created by another object that then either sends or receives a stream of bytes over the connection.

Connectors and their child connections have the capacity to generate a LOT of exceptions under the right conditions. All exceptions are caught and routed through the background thread exception event. The last exception raised is also recorded.

You cannot instantiate an IConnector. There are other interfaces that are based on this that you can instantiate.

See Also

Reference

VirtualRadar.Interface.Network Namespace
VirtualRadar.Interface.NetworkINetworkConnector
VirtualRadar.Interface.NetworkISerialConnector


IConnector Properties

IConnector Properties

The IConnector type exposes the following members.

Properties
 | Name | Description
Public property | Authentication | Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication.
Public property | Connection | Gets the first (or only) connection established by the connector.
Public property | ConnectionStatus | Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status.
Public property | CountExceptions | Gets the number of exceptions ever encountered by the connector.
Public property | Created | Gets the date and time, at UTC, that the connector was first created.
Public property | EstablishingConnections | Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection.
Public property | HasConnection | Gets a value indicating that the connector has established a connection with at least one end point.
Public property | Intent | Gets a description of the intended use of the connector. Only used for diagnostics.
Public property | IsPassive | Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things.
Public property | IsSingleConnection | Gets or sets a value indicating whether the connector supports multiple connections or a single connection.
Public property | LastException | Gets the last exception encountered by the connector.
Public property | Name | Gets or sets the name of the connector.
Public property | StaleMessageTimeout | Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded.
Top
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Authentication Property

IConnectorAuthentication Property
Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnectorAuthentication Authentication { get; set; }
Property Authentication As IConnectorAuthentication
    Get
    Set
property IConnectorAuthentication^ Authentication {
    IConnectorAuthentication^ get ();
    void set (IConnectorAuthentication^ value);
}
abstract Authentication : IConnectorAuthentication with get, set

Property Value

Type: IConnectorAuthentication
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Connection Property

IConnectorConnection Property
Gets the first (or only) connection established by the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnection Connection { get; }
ReadOnly Property Connection As IConnection
    Get
property IConnection^ Connection {
    IConnection^ get ();
}
abstract Connection : IConnection with get

Property Value

Type: IConnection
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.ConnectionStatus Property

IConnectorConnectionStatus Property
Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectionStatus ConnectionStatus { get; }
ReadOnly Property ConnectionStatus As ConnectionStatus
    Get
property ConnectionStatus ConnectionStatus {
    ConnectionStatus get ();
}
abstract ConnectionStatus : ConnectionStatus with get

Property Value

Type: ConnectionStatus
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.CountExceptions Property

IConnectorCountExceptions Property
Gets the number of exceptions ever encountered by the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CountExceptions { get; }
ReadOnly Property CountExceptions As Long
    Get
property long long CountExceptions {
    long long get ();
}
abstract CountExceptions : int64 with get

Property Value

Type: Int64
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Created Property

IConnectorCreated Property
Gets the date and time, at UTC, that the connector was first created.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime Created { get; }
ReadOnly Property Created As DateTime
    Get
property DateTime Created {
    DateTime get ();
}
abstract Created : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.EstablishingConnections Property

IConnectorEstablishingConnections Property
Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EstablishingConnections { get; }
ReadOnly Property EstablishingConnections As Boolean
    Get
property bool EstablishingConnections {
    bool get ();
}
abstract EstablishingConnections : bool with get

Property Value

Type: Boolean
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.HasConnection Property

IConnectorHasConnection Property
Gets a value indicating that the connector has established a connection with at least one end point.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasConnection { get; }
ReadOnly Property HasConnection As Boolean
    Get
property bool HasConnection {
    bool get ();
}
abstract HasConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Intent Property

IConnectorIntent Property
Gets a description of the intended use of the connector. Only used for diagnostics.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Intent { get; }
ReadOnly Property Intent As String
    Get
property String^ Intent {
    String^ get ();
}
abstract Intent : string with get

Property Value

Type: String
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.IsPassive Property

IConnectorIsPassive Property
Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPassive { get; set; }
Property IsPassive As Boolean
    Get
    Set
property bool IsPassive {
    bool get ();
    void set (bool value);
}
abstract IsPassive : bool with get, set

Property Value

Type: Boolean
Remarks

Attempting to change this after EstablishConnection has been called will throw an exception.

Passive connectors wait for incoming connections from another machine. They can accept one or many simultaneous connections.

By contrast active connectors attempt to create a connection with a remote machine or hardware and usually keep trying until they manage to establish the connection. They only create one connection.

See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.IsSingleConnection Property

IConnectorIsSingleConnection Property
Gets or sets a value indicating whether the connector supports multiple connections or a single connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSingleConnection { get; set; }
Property IsSingleConnection As Boolean
    Get
    Set
property bool IsSingleConnection {
    bool get ();
    void set (bool value);
}
abstract IsSingleConnection : bool with get, set

Property Value

Type: Boolean
Remarks
Attempting to change this after EstablishConnection has been called will throw an exception.
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.LastException Property

IConnectorLastException Property
Gets the last exception encountered by the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TimestampedException LastException { get; }
ReadOnly Property LastException As TimestampedException
    Get
property TimestampedException^ LastException {
    TimestampedException^ get ();
}
abstract LastException : TimestampedException with get

Property Value

Type: TimestampedException
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Name Property

IConnectorName Property
Gets or sets the name of the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
Remarks
This is for diagnostic purposes only, the code doesn't rely on anything about the name.
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.StaleMessageTimeout Property

IConnectorStaleMessageTimeout Property
Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int StaleMessageTimeout { get; set; }
Property StaleMessageTimeout As Integer
    Get
    Set
property int StaleMessageTimeout {
    int get ();
    void set (int value);
}
abstract StaleMessageTimeout : int with get, set

Property Value

Type: Int32
Remarks
Only used in passive mode. Set to a value below 1 to disable. Assumes that the entire set of bytes sent to the connection's Write constitute an entire message.
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector Methods

IConnector Methods

The IConnector type exposes the following members.

Methods
 | Name | Description
Public method | CloseConnection | Tells the connector to close all connections. This blocks until all connections have been shut down.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EstablishConnection | Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background.
Public method | GetActivityHistory | Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities.
Public method | GetConnections | Returns an array of established connections made by the connector.
Public method | GetExceptionHistory | Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions.
Public method | GetFirstConnection | Returns the first established connection or null if there are no connections.
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection.
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection.
Public method | RestartConnection | Closes the connection and then establishes the connection.
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection.
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection.
Top
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.CloseConnection Method

IConnectorCloseConnection Method
Tells the connector to close all connections. This blocks until all connections have been shut down.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CloseConnection()
Sub CloseConnection
void CloseConnection()
abstract CloseConnection : unit -> unit
Remarks
Connections can be re-opened by calling EstablishConnection once this call returns.
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.EstablishConnection Method

IConnectorEstablishConnection Method
Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void EstablishConnection()
Sub EstablishConnection
void EstablishConnection()
abstract EstablishConnection : unit -> unit
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.GetActivityHistory Method

IConnectorGetActivityHistory Method
Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectorActivityEvent[] GetActivityHistory()
Function GetActivityHistory As ConnectorActivityEvent()
array<ConnectorActivityEvent^>^ GetActivityHistory()
abstract GetActivityHistory : unit -> ConnectorActivityEvent[]

Return Value

Type: ConnectorActivityEvent
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.GetConnections Method

IConnectorGetConnections Method
Returns an array of established connections made by the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnection[] GetConnections()
Function GetConnections As IConnection()
array<IConnection^>^ GetConnections()
abstract GetConnections : unit -> IConnection[]

Return Value

Type: IConnection
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.GetExceptionHistory Method

IConnectorGetExceptionHistory Method
Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TimestampedException[] GetExceptionHistory()
Function GetExceptionHistory As TimestampedException()
array<TimestampedException^>^ GetExceptionHistory()
abstract GetExceptionHistory : unit -> TimestampedException[]

Return Value

Type: TimestampedException
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.GetFirstConnection Method

IConnectorGetFirstConnection Method
Returns the first established connection or null if there are no connections.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnection GetFirstConnection()
Function GetFirstConnection As IConnection
IConnection^ GetFirstConnection()
abstract GetFirstConnection : unit -> IConnection

Return Value

Type: IConnection
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Read Method

IConnectorRead Method
Overload List
 | Name | Description
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection.
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection.
Top
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Read Method (Byte[], ConnectionReadDelegate)

IConnectorRead Method (Byte, ConnectionReadDelegate)
Reads the next chunk from the first (or only) connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Read(
    byte[] buffer,
    ConnectionReadDelegate readDelegate
)
Sub Read (
    buffer As Byte(),
    readDelegate As ConnectionReadDelegate
)
void Read(
    array<unsigned char>^ buffer,
    ConnectionReadDelegate^ readDelegate
)
abstract Read :
        buffer : byte[] *
        readDelegate : ConnectionReadDelegate -> unit

Parameters

buffer
Type: SystemByte
readDelegate
Type: VirtualRadar.Interface.NetworkConnectionReadDelegate
Remarks
The call is non-blocking.
See Also

Reference

IConnector Interface
Read Overload
VirtualRadar.Interface.Network Namespace


IConnector.Read Method (Byte[], Int32, Int32, ConnectionReadDelegate)

IConnectorRead Method (Byte, Int32, Int32, ConnectionReadDelegate)
Reads the next chunk from the first (or only) connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Read(
    byte[] buffer,
    int offset,
    int length,
    ConnectionReadDelegate readDelegate
)
Sub Read (
    buffer As Byte(),
    offset As Integer,
    length As Integer,
    readDelegate As ConnectionReadDelegate
)
void Read(
    array<unsigned char>^ buffer,
    int offset,
    int length,
    ConnectionReadDelegate^ readDelegate
)
abstract Read :
        buffer : byte[] *
        offset : int *
        length : int *
        readDelegate : ConnectionReadDelegate -> unit

Parameters

buffer
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
readDelegate
Type: VirtualRadar.Interface.NetworkConnectionReadDelegate
See Also

Reference

IConnector Interface
Read Overload
VirtualRadar.Interface.Network Namespace


IConnector.RestartConnection Method

IConnectorRestartConnection Method
Closes the connection and then establishes the connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestartConnection()
Sub RestartConnection
void RestartConnection()
abstract RestartConnection : unit -> unit
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Write Method

IConnectorWrite Method
Overload List
 | Name | Description
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection.
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection.
Top
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.Write Method (Byte[], Int32)

IConnectorWrite Method (Byte, Int32)
Writes the content of the buffer to every connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Write(
    byte[] buffer,
    int staleMessageTimeoutOverride = -1
)
Sub Write (
    buffer As Byte(),
    Optional staleMessageTimeoutOverride As Integer = -1
)
void Write(
    array<unsigned char>^ buffer,
    int staleMessageTimeoutOverride = -1
)
abstract Write :
        buffer : byte[] *
        ?staleMessageTimeoutOverride : int
(* Defaults:
        let _staleMessageTimeoutOverride = defaultArg staleMessageTimeoutOverride -1
*)
-> unit

Parameters

buffer
Type: SystemByte
staleMessageTimeoutOverride (Optional)
Type: SystemInt32
See Also

Reference

IConnector Interface
Write Overload
VirtualRadar.Interface.Network Namespace


IConnector.Write Method (Byte[], Int32, Int32, Int32)

IConnectorWrite Method (Byte, Int32, Int32, Int32)
Writes the content of the buffer to every connection.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Write(
    byte[] buffer,
    int offset,
    int length,
    int staleMessageTimeoutOverride = -1
)
Sub Write (
    buffer As Byte(),
    offset As Integer,
    length As Integer,
    Optional staleMessageTimeoutOverride As Integer = -1
)
void Write(
    array<unsigned char>^ buffer,
    int offset,
    int length,
    int staleMessageTimeoutOverride = -1
)
abstract Write :
        buffer : byte[] *
        offset : int *
        length : int *
        ?staleMessageTimeoutOverride : int
(* Defaults:
        let _staleMessageTimeoutOverride = defaultArg staleMessageTimeoutOverride -1
*)
-> unit

Parameters

buffer
Type: SystemByte
offset
Type: SystemInt32
length
Type: SystemInt32
staleMessageTimeoutOverride (Optional)
Type: SystemInt32
See Also

Reference

IConnector Interface
Write Overload
VirtualRadar.Interface.Network Namespace


IConnector Events

IConnector Events

The IConnector type exposes the following members.

Events
 | Name | Description
Public event | ActivityRecorded | Raised when an activity is recorded by the connector.
Public event | AddingConnection | Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread.
Public event | ConnectionClosed | Raised when a connection has been permanently closed. This will usually be raised from a background thread.
Public event | ConnectionEstablished | Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised.
Public event | ConnectionStateChanged | Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.ActivityRecorded Event

IConnectorActivityRecorded Event
Raised when an activity is recorded by the connector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<ConnectorActivityEvent>> ActivityRecorded
Event ActivityRecorded As EventHandler(Of EventArgs(Of ConnectorActivityEvent))
 event EventHandler<EventArgs<ConnectorActivityEvent^>^>^ ActivityRecorded {
    void add (EventHandler<EventArgs<ConnectorActivityEvent^>^>^ value);
    void remove (EventHandler<EventArgs<ConnectorActivityEvent^>^>^ value);
}
abstract ActivityRecorded : IEvent<EventHandler<EventArgs<ConnectorActivityEvent>>,
    EventArgs<ConnectorActivityEvent>>

Value

Type: SystemEventHandler EventArgs ConnectorActivityEvent
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.AddingConnection Event

IConnectorAddingConnection Event
Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ConnectionEventArgs> AddingConnection
Event AddingConnection As EventHandler(Of ConnectionEventArgs)
 event EventHandler<ConnectionEventArgs^>^ AddingConnection {
    void add (EventHandler<ConnectionEventArgs^>^ value);
    void remove (EventHandler<ConnectionEventArgs^>^ value);
}
abstract AddingConnection : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

Value

Type: SystemEventHandler ConnectionEventArgs
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.ConnectionClosed Event

IConnectorConnectionClosed Event
Raised when a connection has been permanently closed. This will usually be raised from a background thread.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ConnectionEventArgs> ConnectionClosed
Event ConnectionClosed As EventHandler(Of ConnectionEventArgs)
 event EventHandler<ConnectionEventArgs^>^ ConnectionClosed {
    void add (EventHandler<ConnectionEventArgs^>^ value);
    void remove (EventHandler<ConnectionEventArgs^>^ value);
}
abstract ConnectionClosed : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

Value

Type: SystemEventHandler ConnectionEventArgs
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.ConnectionEstablished Event

IConnectorConnectionEstablished Event
Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ConnectionEventArgs> ConnectionEstablished
Event ConnectionEstablished As EventHandler(Of ConnectionEventArgs)
 event EventHandler<ConnectionEventArgs^>^ ConnectionEstablished {
    void add (EventHandler<ConnectionEventArgs^>^ value);
    void remove (EventHandler<ConnectionEventArgs^>^ value);
}
abstract ConnectionEstablished : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

Value

Type: SystemEventHandler ConnectionEventArgs
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnector.ConnectionStateChanged Event

IConnectorConnectionStateChanged Event
Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConnectionStateChanged
Event ConnectionStateChanged As EventHandler
 event EventHandler^ ConnectionStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConnectionStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IConnector Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog Interface

IConnectorActivityLog Interface
The interface for a singleton object that records activity across every connector created by the application.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectorActivityLog : ISingleton<IConnectorActivityLog>
Public Interface IConnectorActivityLog
    Inherits ISingleton(Of IConnectorActivityLog)
public interface class IConnectorActivityLog : ISingleton<IConnectorActivityLog^>
type IConnectorActivityLog =
    interface
        interface ISingleton<IConnectorActivityLog>
    end

The IConnectorActivityLog type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | GetActiveConnectors | Returns an array of every connector currently being tracked by the logger.
Public method | GetActivityHistory | Returns the last so-many activities recorded by the logger. The exact number is undefined, but it always contains the latest set of activities.
Public method | RecordConnectorCreated | Called by every connector to register itself with the logger.
Public method | RecordConnectorDestroyed | Called by every connector to deregister itself from the logger.
Top
Events
 | Name | Description
Public event | ActivityRecorded | Raised when any connector records some activity.
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IConnectorActivityLog Properties

IConnectorActivityLog Properties

The IConnectorActivityLog type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog Methods

IConnectorActivityLog Methods

The IConnectorActivityLog type exposes the following members.

Methods
 | Name | Description
Public method | GetActiveConnectors | Returns an array of every connector currently being tracked by the logger.
Public method | GetActivityHistory | Returns the last so-many activities recorded by the logger. The exact number is undefined, but it always contains the latest set of activities.
Public method | RecordConnectorCreated | Called by every connector to register itself with the logger.
Public method | RecordConnectorDestroyed | Called by every connector to deregister itself from the logger.
Top
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog.GetActiveConnectors Method

IConnectorActivityLogGetActiveConnectors Method
Returns an array of every connector currently being tracked by the logger.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnector[] GetActiveConnectors()
Function GetActiveConnectors As IConnector()
array<IConnector^>^ GetActiveConnectors()
abstract GetActiveConnectors : unit -> IConnector[]

Return Value

Type: IConnector
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog.GetActivityHistory Method

IConnectorActivityLogGetActivityHistory Method
Returns the last so-many activities recorded by the logger. The exact number is undefined, but it always contains the latest set of activities.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectorActivityEvent[] GetActivityHistory()
Function GetActivityHistory As ConnectorActivityEvent()
array<ConnectorActivityEvent^>^ GetActivityHistory()
abstract GetActivityHistory : unit -> ConnectorActivityEvent[]

Return Value

Type: ConnectorActivityEvent
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog.RecordConnectorCreated Method

IConnectorActivityLogRecordConnectorCreated Method
Called by every connector to register itself with the logger.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordConnectorCreated(
    IConnector connector
)
Sub RecordConnectorCreated (
    connector As IConnector
)
void RecordConnectorCreated(
    IConnector^ connector
)
abstract RecordConnectorCreated :
        connector : IConnector -> unit

Parameters

connector
Type: VirtualRadar.Interface.NetworkIConnector
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog.RecordConnectorDestroyed Method

IConnectorActivityLogRecordConnectorDestroyed Method
Called by every connector to deregister itself from the logger.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordConnectorDestroyed(
    IConnector connector
)
Sub RecordConnectorDestroyed (
    connector As IConnector
)
void RecordConnectorDestroyed(
    IConnector^ connector
)
abstract RecordConnectorDestroyed :
        connector : IConnector -> unit

Parameters

connector
Type: VirtualRadar.Interface.NetworkIConnector
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog Events

IConnectorActivityLog Events

The IConnectorActivityLog type exposes the following members.

Events
 | Name | Description
Public event | ActivityRecorded | Raised when any connector records some activity.
Top
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorActivityLog.ActivityRecorded Event

IConnectorActivityLogActivityRecorded Event
Raised when any connector records some activity.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<ConnectorActivityEvent>> ActivityRecorded
Event ActivityRecorded As EventHandler(Of EventArgs(Of ConnectorActivityEvent))
 event EventHandler<EventArgs<ConnectorActivityEvent^>^>^ ActivityRecorded {
    void add (EventHandler<EventArgs<ConnectorActivityEvent^>^>^ value);
    void remove (EventHandler<EventArgs<ConnectorActivityEvent^>^>^ value);
}
abstract ActivityRecorded : IEvent<EventHandler<EventArgs<ConnectorActivityEvent>>,
    EventArgs<ConnectorActivityEvent>>

Value

Type: SystemEventHandler EventArgs ConnectorActivityEvent
See Also

Reference

IConnectorActivityLog Interface
VirtualRadar.Interface.Network Namespace


IConnectorAuthentication Interface

IConnectorAuthentication Interface
The interface for all authentication classes.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectorAuthentication
Public Interface IConnectorAuthentication
public interface class IConnectorAuthentication
type IConnectorAuthentication =  interface end

The IConnectorAuthentication type exposes the following members.

Properties
 | Name | Description
Public property | MaximumResponseLength | Gets the longest response that the class can handle.
Top
Methods
 | Name | Description
Public method | GetResponseIsComplete | Returns true if the response passed across is complete. The validity doesn't matter.
Public method | GetResponseIsValid | Passed a complete response, returns true if the response is valid and false if it does not.
Public method | SendAuthentication | Returns the bytes that need to be sent to the listening side to authenticate.
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IConnectorAuthentication Properties

IConnectorAuthentication Properties

The IConnectorAuthentication type exposes the following members.

Properties
 | Name | Description
Public property | MaximumResponseLength | Gets the longest response that the class can handle.
Top
See Also

Reference

IConnectorAuthentication Interface
VirtualRadar.Interface.Network Namespace


IConnectorAuthentication.MaximumResponseLength Property

IConnectorAuthenticationMaximumResponseLength Property
Gets the longest response that the class can handle.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaximumResponseLength { get; }
ReadOnly Property MaximumResponseLength As Integer
    Get
property int MaximumResponseLength {
    int get ();
}
abstract MaximumResponseLength : int with get

Property Value

Type: Int32
Remarks
If the connecting side returns a response that is longer than this then it is deemed invalid and the connection is closed.
See Also

Reference

IConnectorAuthentication Interface
VirtualRadar.Interface.Network Namespace


IConnectorAuthentication Methods

IConnectorAuthentication Methods

The IConnectorAuthentication type exposes the following members.

Methods
 | Name | Description
Public method | GetResponseIsComplete | Returns true if the response passed across is complete. The validity doesn't matter.
Public method | GetResponseIsValid | Passed a complete response, returns true if the response is valid and false if it does not.
Public method | SendAuthentication | Returns the bytes that need to be sent to the listening side to authenticate.
Top
See Also

Reference

IConnectorAuthentication Interface
VirtualRadar.Interface.Network Namespace


IConnectorAuthentication.GetResponseIsComplete Method

IConnectorAuthenticationGetResponseIsComplete Method
Returns true if the response passed across is complete. The validity doesn't matter.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetResponseIsComplete(
    byte[] response
)
Function GetResponseIsComplete (
    response As Byte()
) As Boolean
bool GetResponseIsComplete(
    array<unsigned char>^ response
)
abstract GetResponseIsComplete :
        response : byte[] -> bool

Parameters

response
Type: SystemByte

Return Value

Type: Boolean
True if the byte array contains the entire response, false if it's too short.
See Also

Reference

IConnectorAuthentication Interface
VirtualRadar.Interface.Network Namespace


IConnectorAuthentication.GetResponseIsValid Method

IConnectorAuthenticationGetResponseIsValid Method
Passed a complete response, returns true if the response is valid and false if it does not.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetResponseIsValid(
    byte[] response
)
Function GetResponseIsValid (
    response As Byte()
) As Boolean
bool GetResponseIsValid(
    array<unsigned char>^ response
)
abstract GetResponseIsValid :
        response : byte[] -> bool

Parameters

response
Type: SystemByte

Return Value

Type: Boolean
See Also

Reference

IConnectorAuthentication Interface
VirtualRadar.Interface.Network Namespace


IConnectorAuthentication.SendAuthentication Method

IConnectorAuthenticationSendAuthentication Method
Returns the bytes that need to be sent to the listening side to authenticate.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
byte[] SendAuthentication()
Function SendAuthentication As Byte()
array<unsigned char>^ SendAuthentication()
abstract SendAuthentication : unit -> byte[]

Return Value

Type: Byte
See Also

Reference

IConnectorAuthentication Interface
VirtualRadar.Interface.Network Namespace


IConnectorSnapshotLogger Interface

IConnectorSnapshotLogger Interface
The interface that objects that log snapshots of all of the connections must implement.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectorSnapshotLogger : ISingleton<IConnectorSnapshotLogger>
Public Interface IConnectorSnapshotLogger
    Inherits ISingleton(Of IConnectorSnapshotLogger)
public interface class IConnectorSnapshotLogger : ISingleton<IConnectorSnapshotLogger^>
type IConnectorSnapshotLogger =
    interface
        interface ISingleton<IConnectorSnapshotLogger>
    end

The IConnectorSnapshotLogger type exposes the following members.

Properties
 | Name | Description
Public property | FullPath | Gets the full path to the snapshot log.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Initialise | Initialises the snapshot logger.
Public method | RecordSnapshot | Records a snapshot. Note that snapshots are also periodically recorded automatically.
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IConnectorSnapshotLogger Properties

IConnectorSnapshotLogger Properties

The IConnectorSnapshotLogger type exposes the following members.

Properties
 | Name | Description
Public property | FullPath | Gets the full path to the snapshot log.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IConnectorSnapshotLogger Interface
VirtualRadar.Interface.Network Namespace


IConnectorSnapshotLogger.FullPath Property

IConnectorSnapshotLoggerFullPath Property
Gets the full path to the snapshot log.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FullPath { get; }
ReadOnly Property FullPath As String
    Get
property String^ FullPath {
    String^ get ();
}
abstract FullPath : string with get

Property Value

Type: String
See Also

Reference

IConnectorSnapshotLogger Interface
VirtualRadar.Interface.Network Namespace


IConnectorSnapshotLogger Methods

IConnectorSnapshotLogger Methods

The IConnectorSnapshotLogger type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the snapshot logger.
Public method | RecordSnapshot | Records a snapshot. Note that snapshots are also periodically recorded automatically.
Top
See Also

Reference

IConnectorSnapshotLogger Interface
VirtualRadar.Interface.Network Namespace


IConnectorSnapshotLogger.Initialise Method

IConnectorSnapshotLoggerInitialise Method
Initialises the snapshot logger.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IConnectorSnapshotLogger Interface
VirtualRadar.Interface.Network Namespace


IConnectorSnapshotLogger.RecordSnapshot Method

IConnectorSnapshotLoggerRecordSnapshot Method
Records a snapshot. Note that snapshots are also periodically recorded automatically.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordSnapshot()
Sub RecordSnapshot
void RecordSnapshot()
abstract RecordSnapshot : unit -> unit
See Also

Reference

IConnectorSnapshotLogger Interface
VirtualRadar.Interface.Network Namespace


INetworkConnection Interface

INetworkConnection Interface
The interface for an IConnection exposed by INetworkConnector.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INetworkConnection : IConnection,
    IDisposable
Public Interface INetworkConnection
    Inherits IConnection, IDisposable
public interface class INetworkConnection : IConnection,
    IDisposable
type INetworkConnection =
    interface
        interface IConnection
        interface IDisposable
    end

The INetworkConnection type exposes the following members.

Properties
 | Name | Description
Public property | BytesRead | Gets the total number of bytes read on the connection. (Inherited from IConnection.)
Public property | BytesWritten | Gets the total number of bytes sent. (Inherited from IConnection.)
Public property | ConnectionStatus | Gets the current state of the connection. (Inherited from IConnection.)
Public property | Connector | Gets the connector that owns this connection. (Inherited from IConnection.)
Public property | Created | Gets the date and time at UTC when the connection was established. (Inherited from IConnection.)
Public property | Description | Gets a description of the connection. (Inherited from IConnection.)
Public property | LocalEndPoint | Gets the local end point. Can be null if connection has been broken.
Public property | OperationQueueEntries | Gets how many operations are queued for this connection. (Inherited from IConnection.)
Public property | RemoteEndPoint | Gets the remote end point. Can be null if connection has been broken.
Public property | StaleBytesDiscarded | Gets the total number of bytes that have been discarded because they were stale. (Inherited from IConnection.)
Public property | WriteQueueBytes | Gets the total number of bytes queued for sending. (Inherited from IConnection.)
Top
Methods
 | Name | Description
Public method | Abandon | Abandons the connection, closing and destroying it. (Inherited from IConnection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the connection. (Inherited from IConnection.)
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the connection. (Inherited from IConnection.)
Public method | Write(Byte, Int32) | Sends the content of the buffer over the connection. (Inherited from IConnection.)
Public method | Write(Byte, Int32, Int32, Int32) | Sends the content of the buffer over the connection. (Inherited from IConnection.)
Top
Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when ConnectionStatus changes. (Inherited from IConnection.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


INetworkConnection Properties

INetworkConnection Properties

The INetworkConnection type exposes the following members.

Properties
 | Name | Description
Public property | BytesRead | Gets the total number of bytes read on the connection. (Inherited from IConnection.)
Public property | BytesWritten | Gets the total number of bytes sent. (Inherited from IConnection.)
Public property | ConnectionStatus | Gets the current state of the connection. (Inherited from IConnection.)
Public property | Connector | Gets the connector that owns this connection. (Inherited from IConnection.)
Public property | Created | Gets the date and time at UTC when the connection was established. (Inherited from IConnection.)
Public property | Description | Gets a description of the connection. (Inherited from IConnection.)
Public property | LocalEndPoint | Gets the local end point. Can be null if connection has been broken.
Public property | OperationQueueEntries | Gets how many operations are queued for this connection. (Inherited from IConnection.)
Public property | RemoteEndPoint | Gets the remote end point. Can be null if connection has been broken.
Public property | StaleBytesDiscarded | Gets the total number of bytes that have been discarded because they were stale. (Inherited from IConnection.)
Public property | WriteQueueBytes | Gets the total number of bytes queued for sending. (Inherited from IConnection.)
Top
See Also

Reference

INetworkConnection Interface
VirtualRadar.Interface.Network Namespace


INetworkConnection.LocalEndPoint Property

INetworkConnectionLocalEndPoint Property
Gets the local end point. Can be null if connection has been broken.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPEndPoint LocalEndPoint { get; }
ReadOnly Property LocalEndPoint As IPEndPoint
    Get
property IPEndPoint^ LocalEndPoint {
    IPEndPoint^ get ();
}
abstract LocalEndPoint : IPEndPoint with get

Property Value

Type: IPEndPoint
See Also

Reference

INetworkConnection Interface
VirtualRadar.Interface.Network Namespace


INetworkConnection.RemoteEndPoint Property

INetworkConnectionRemoteEndPoint Property
Gets the remote end point. Can be null if connection has been broken.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPEndPoint RemoteEndPoint { get; }
ReadOnly Property RemoteEndPoint As IPEndPoint
    Get
property IPEndPoint^ RemoteEndPoint {
    IPEndPoint^ get ();
}
abstract RemoteEndPoint : IPEndPoint with get

Property Value

Type: IPEndPoint
See Also

Reference

INetworkConnection Interface
VirtualRadar.Interface.Network Namespace


INetworkConnection Methods

INetworkConnection Methods

The INetworkConnection type exposes the following members.

Methods
 | Name | Description
Public method | Abandon | Abandons the connection, closing and destroying it. (Inherited from IConnection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the connection. (Inherited from IConnection.)
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the connection. (Inherited from IConnection.)
Public method | Write(Byte, Int32) | Sends the content of the buffer over the connection. (Inherited from IConnection.)
Public method | Write(Byte, Int32, Int32, Int32) | Sends the content of the buffer over the connection. (Inherited from IConnection.)
Top
See Also

Reference

INetworkConnection Interface
VirtualRadar.Interface.Network Namespace


INetworkConnection Events

INetworkConnection Events

The INetworkConnection type exposes the following members.

Events
 | Name | Description
Public event | ConnectionStateChanged | Raised when ConnectionStatus changes. (Inherited from IConnection.)
Top
See Also

Reference

INetworkConnection Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector Interface

INetworkConnector Interface
An active connector that connects to a single machine over the IP network.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INetworkConnector : IConnector,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface INetworkConnector
    Inherits IConnector, IBackgroundThreadExceptionCatcher, IDisposable
public interface class INetworkConnector : IConnector,
    IBackgroundThreadExceptionCatcher, IDisposable
type INetworkConnector =
    interface
        interface IConnector
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The INetworkConnector type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets or sets the access settings for the connection. Unused if the connector is in active mode.
Public property | Address | Gets or sets the address of the machine to connect to. Unused if the connector is in passive mode.
Public property | Authentication | Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication. (Inherited from IConnector.)
Public property | Connection | Gets the first (or only) connection established by the connector. (Inherited from IConnector.)
Public property | ConnectionStatus | Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status. (Inherited from IConnector.)
Public property | CountExceptions | Gets the number of exceptions ever encountered by the connector. (Inherited from IConnector.)
Public property | Created | Gets the date and time, at UTC, that the connector was first created. (Inherited from IConnector.)
Public property | EstablishingConnections | Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection. (Inherited from IConnector.)
Public property | HasConnection | Gets a value indicating that the connector has established a connection with at least one end point. (Inherited from IConnector.)
Public property | IdleTimeout | Gets the period of inactivity (in milliseconds) before the connection is reset.
Public property | Intent | Gets a description of the intended use of the connector. Only used for diagnostics. (Inherited from IConnector.)
Public property | IsPassive | Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things. (Inherited from IConnector.)
Public property | IsSingleConnection | Gets or sets a value indicating whether the connector supports multiple connections or a single connection. (Inherited from IConnector.)
Public property | LastException | Gets the last exception encountered by the connector. (Inherited from IConnector.)
Public property | Name | Gets or sets the name of the connector. (Inherited from IConnector.)
Public property | Port | Gets or sets the port to connect or bind to.
Public property | StaleMessageTimeout | Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded. (Inherited from IConnector.)
Public property | UseKeepAlive | Gets a value indicating that keep-alive packets are to be used instead of the connection reset value.
Top
Methods
 | Name | Description
Public method | CloseConnection | Tells the connector to close all connections. This blocks until all connections have been shut down. (Inherited from IConnector.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EstablishConnection | Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background. (Inherited from IConnector.)
Public method | GetActivityHistory | Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities. (Inherited from IConnector.)
Public method | GetConnections | Returns an array of established connections made by the connector. (Inherited from IConnector.)
Public method | GetExceptionHistory | Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions. (Inherited from IConnector.)
Public method | GetFirstConnection | Returns the first established connection or null if there are no connections. (Inherited from IConnector.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | RestartConnection | Closes the connection and then establishes the connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Top
Events
 | Name | Description
Public event | ActivityRecorded | Raised when an activity is recorded by the connector. (Inherited from IConnector.)
Public event | AddingConnection | Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionClosed | Raised when a connection has been permanently closed. This will usually be raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionEstablished | Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised. (Inherited from IConnector.)
Public event | ConnectionStateChanged | Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector. (Inherited from IConnector.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


INetworkConnector Properties

INetworkConnector Properties

The INetworkConnector type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets or sets the access settings for the connection. Unused if the connector is in active mode.
Public property | Address | Gets or sets the address of the machine to connect to. Unused if the connector is in passive mode.
Public property | Authentication | Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication. (Inherited from IConnector.)
Public property | Connection | Gets the first (or only) connection established by the connector. (Inherited from IConnector.)
Public property | ConnectionStatus | Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status. (Inherited from IConnector.)
Public property | CountExceptions | Gets the number of exceptions ever encountered by the connector. (Inherited from IConnector.)
Public property | Created | Gets the date and time, at UTC, that the connector was first created. (Inherited from IConnector.)
Public property | EstablishingConnections | Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection. (Inherited from IConnector.)
Public property | HasConnection | Gets a value indicating that the connector has established a connection with at least one end point. (Inherited from IConnector.)
Public property | IdleTimeout | Gets the period of inactivity (in milliseconds) before the connection is reset.
Public property | Intent | Gets a description of the intended use of the connector. Only used for diagnostics. (Inherited from IConnector.)
Public property | IsPassive | Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things. (Inherited from IConnector.)
Public property | IsSingleConnection | Gets or sets a value indicating whether the connector supports multiple connections or a single connection. (Inherited from IConnector.)
Public property | LastException | Gets the last exception encountered by the connector. (Inherited from IConnector.)
Public property | Name | Gets or sets the name of the connector. (Inherited from IConnector.)
Public property | Port | Gets or sets the port to connect or bind to.
Public property | StaleMessageTimeout | Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded. (Inherited from IConnector.)
Public property | UseKeepAlive | Gets a value indicating that keep-alive packets are to be used instead of the connection reset value.
Top
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector.Access Property

INetworkConnectorAccess Property
Gets or sets the access settings for the connection. Unused if the connector is in active mode.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Access Access { get; set; }
Property Access As Access
    Get
    Set
property Access^ Access {
    Access^ get ();
    void set (Access^ value);
}
abstract Access : Access with get, set

Property Value

Type: Access
Remarks
If this is null then connections are accepted from any address.
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector.Address Property

INetworkConnectorAddress Property
Gets or sets the address of the machine to connect to. Unused if the connector is in passive mode.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Address { get; set; }
Property Address As String
    Get
    Set
property String^ Address {
    String^ get ();
    void set (String^ value);
}
abstract Address : string with get, set

Property Value

Type: String
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector.IdleTimeout Property

INetworkConnectorIdleTimeout Property
Gets the period of inactivity (in milliseconds) before the connection is reset.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int IdleTimeout { get; set; }
Property IdleTimeout As Integer
    Get
    Set
property int IdleTimeout {
    int get ();
    void set (int value);
}
abstract IdleTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector.Port Property

INetworkConnectorPort Property
Gets or sets the port to connect or bind to.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Port { get; set; }
Property Port As Integer
    Get
    Set
property int Port {
    int get ();
    void set (int value);
}
abstract Port : int with get, set

Property Value

Type: Int32
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector.UseKeepAlive Property

INetworkConnectorUseKeepAlive Property
Gets a value indicating that keep-alive packets are to be used instead of the connection reset value.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseKeepAlive { get; set; }
Property UseKeepAlive As Boolean
    Get
    Set
property bool UseKeepAlive {
    bool get ();
    void set (bool value);
}
abstract UseKeepAlive : bool with get, set

Property Value

Type: Boolean
Remarks
Note that Mono does not support the use of keep-alive packets. When running under Mono this flag is always set to false.
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector Methods

INetworkConnector Methods

The INetworkConnector type exposes the following members.

Methods
 | Name | Description
Public method | CloseConnection | Tells the connector to close all connections. This blocks until all connections have been shut down. (Inherited from IConnector.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EstablishConnection | Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background. (Inherited from IConnector.)
Public method | GetActivityHistory | Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities. (Inherited from IConnector.)
Public method | GetConnections | Returns an array of established connections made by the connector. (Inherited from IConnector.)
Public method | GetExceptionHistory | Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions. (Inherited from IConnector.)
Public method | GetFirstConnection | Returns the first established connection or null if there are no connections. (Inherited from IConnector.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | RestartConnection | Closes the connection and then establishes the connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Top
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


INetworkConnector Events

INetworkConnector Events

The INetworkConnector type exposes the following members.

Events
 | Name | Description
Public event | ActivityRecorded | Raised when an activity is recorded by the connector. (Inherited from IConnector.)
Public event | AddingConnection | Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionClosed | Raised when a connection has been permanently closed. This will usually be raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionEstablished | Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised. (Inherited from IConnector.)
Public event | ConnectionStateChanged | Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector. (Inherited from IConnector.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

INetworkConnector Interface
VirtualRadar.Interface.Network Namespace


IPassphraseAuthentication Interface

IPassphraseAuthentication Interface
The interface for objects that implement passphrase authentication on rebroadcast servers.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPassphraseAuthentication : IConnectorAuthentication
Public Interface IPassphraseAuthentication
    Inherits IConnectorAuthentication
public interface class IPassphraseAuthentication : IConnectorAuthentication
type IPassphraseAuthentication =
    interface
        interface IConnectorAuthentication
    end

The IPassphraseAuthentication type exposes the following members.

Properties
 | Name | Description
Public property | MaximumResponseLength | Gets the longest response that the class can handle. (Inherited from IConnectorAuthentication.)
Public property | Passphrase | Gets or sets the passphrase that the class will accept.
Top
Methods
 | Name | Description
Public method | GetResponseIsComplete | Returns true if the response passed across is complete. The validity doesn't matter. (Inherited from IConnectorAuthentication.)
Public method | GetResponseIsValid | Passed a complete response, returns true if the response is valid and false if it does not. (Inherited from IConnectorAuthentication.)
Public method | SendAuthentication | Returns the bytes that need to be sent to the listening side to authenticate. (Inherited from IConnectorAuthentication.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IPassphraseAuthentication Properties

IPassphraseAuthentication Properties

The IPassphraseAuthentication type exposes the following members.

Properties
 | Name | Description
Public property | MaximumResponseLength | Gets the longest response that the class can handle. (Inherited from IConnectorAuthentication.)
Public property | Passphrase | Gets or sets the passphrase that the class will accept.
Top
See Also

Reference

IPassphraseAuthentication Interface
VirtualRadar.Interface.Network Namespace


IPassphraseAuthentication.Passphrase Property

IPassphraseAuthenticationPassphrase Property
Gets or sets the passphrase that the class will accept.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Passphrase { get; set; }
Property Passphrase As String
    Get
    Set
property String^ Passphrase {
    String^ get ();
    void set (String^ value);
}
abstract Passphrase : string with get, set

Property Value

Type: String
See Also

Reference

IPassphraseAuthentication Interface
VirtualRadar.Interface.Network Namespace


IPassphraseAuthentication Methods

IPassphraseAuthentication Methods

The IPassphraseAuthentication type exposes the following members.

Methods
 | Name | Description
Public method | GetResponseIsComplete | Returns true if the response passed across is complete. The validity doesn't matter. (Inherited from IConnectorAuthentication.)
Public method | GetResponseIsValid | Passed a complete response, returns true if the response is valid and false if it does not. (Inherited from IConnectorAuthentication.)
Public method | SendAuthentication | Returns the bytes that need to be sent to the listening side to authenticate. (Inherited from IConnectorAuthentication.)
Top
See Also

Reference

IPassphraseAuthentication Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager Interface

IRebroadcastFormatManager Interface
The singleton manager that keeps track of all registered rebroadcast server formats.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRebroadcastFormatManager : ISingleton<IRebroadcastFormatManager>
Public Interface IRebroadcastFormatManager
    Inherits ISingleton(Of IRebroadcastFormatManager)
public interface class IRebroadcastFormatManager : ISingleton<IRebroadcastFormatManager^>
type IRebroadcastFormatManager =
    interface
        interface ISingleton<IRebroadcastFormatManager>
    end

The IRebroadcastFormatManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | CreateProvider | Creates a new instance of the provider with the unique ID passed across. Returns null if no provider is registered for the ID passed across.
Public method | GetProvider | Returns the registered provider with the identifier supplied or null if no provider has been registered for this ID.
Public method | GetRegisteredFormats | Returns a collection of all registered rebroadcast server formats in a summarised form.
Public method | Initialise | Initialises the format manager.
Public method | RegisterProvider | Registers a provider.
Public method | ShortName | Returns the short name associated with the unique ID passed across. If there is no provider registered with the unique ID then a string along the lines of "Unknown" is returned.
Top
Remarks
Plugins cannot provide their own implementation of this interface, the singleton is established before RegisterImplementations is called.
See Also

Reference

VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager Properties

IRebroadcastFormatManager Properties

The IRebroadcastFormatManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager Methods

IRebroadcastFormatManager Methods

The IRebroadcastFormatManager type exposes the following members.

Methods
 | Name | Description
Public method | CreateProvider | Creates a new instance of the provider with the unique ID passed across. Returns null if no provider is registered for the ID passed across.
Public method | GetProvider | Returns the registered provider with the identifier supplied or null if no provider has been registered for this ID.
Public method | GetRegisteredFormats | Returns a collection of all registered rebroadcast server formats in a summarised form.
Public method | Initialise | Initialises the format manager.
Public method | RegisterProvider | Registers a provider.
Public method | ShortName | Returns the short name associated with the unique ID passed across. If there is no provider registered with the unique ID then a string along the lines of "Unknown" is returned.
Top
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager.CreateProvider Method

IRebroadcastFormatManagerCreateProvider Method
Creates a new instance of the provider with the unique ID passed across. Returns null if no provider is registered for the ID passed across.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IRebroadcastFormatProvider CreateProvider(
    string providerId
)
Function CreateProvider (
    providerId As String
) As IRebroadcastFormatProvider
IRebroadcastFormatProvider^ CreateProvider(
    String^ providerId
)
abstract CreateProvider :
        providerId : string -> IRebroadcastFormatProvider

Parameters

providerId
Type: SystemString

Return Value

Type: IRebroadcastFormatProvider
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager.GetProvider Method

IRebroadcastFormatManagerGetProvider Method
Returns the registered provider with the identifier supplied or null if no provider has been registered for this ID.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IRebroadcastFormatProvider GetProvider(
    string providerId
)
Function GetProvider (
    providerId As String
) As IRebroadcastFormatProvider
IRebroadcastFormatProvider^ GetProvider(
    String^ providerId
)
abstract GetProvider :
        providerId : string -> IRebroadcastFormatProvider

Parameters

providerId
Type: SystemString

Return Value

Type: IRebroadcastFormatProvider
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager.GetRegisteredFormats Method

IRebroadcastFormatManagerGetRegisteredFormats Method
Returns a collection of all registered rebroadcast server formats in a summarised form.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RebroadcastFormatName[] GetRegisteredFormats()
Function GetRegisteredFormats As RebroadcastFormatName()
array<RebroadcastFormatName^>^ GetRegisteredFormats()
abstract GetRegisteredFormats : unit -> RebroadcastFormatName[]

Return Value

Type: RebroadcastFormatName
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager.Initialise Method

IRebroadcastFormatManagerInitialise Method
Initialises the format manager.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager.RegisterProvider Method

IRebroadcastFormatManagerRegisterProvider Method
Registers a provider.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterProvider(
    IRebroadcastFormatProvider provider
)
Sub RegisterProvider (
    provider As IRebroadcastFormatProvider
)
void RegisterProvider(
    IRebroadcastFormatProvider^ provider
)
abstract RegisterProvider :
        provider : IRebroadcastFormatProvider -> unit

Parameters

provider
Type: VirtualRadar.Interface.NetworkIRebroadcastFormatProvider
Remarks
Plugins should register their providers in RegisterImplementations, which should be called before VRS tries to connect to any feeds.
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatManager.ShortName Method

IRebroadcastFormatManagerShortName Method
Returns the short name associated with the unique ID passed across. If there is no provider registered with the unique ID then a string along the lines of "Unknown" is returned.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ShortName(
    string providerId
)
Function ShortName (
    providerId As String
) As String
String^ ShortName(
    String^ providerId
)
abstract ShortName :
        providerId : string -> string

Parameters

providerId
Type: SystemString

Return Value

Type: String
See Also

Reference

IRebroadcastFormatManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider Interface

IRebroadcastFormatProvider Interface
The interface that all rebroadcast server format providers must implement.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRebroadcastFormatProvider
Public Interface IRebroadcastFormatProvider
public interface class IRebroadcastFormatProvider
type IRebroadcastFormatProvider =  interface end

The IRebroadcastFormatProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanRebroadcastMergedFeed | Gets a value indicating that the server can rebroadcast a merged feed.
Public property | RebroadcastServer | Gets or sets the rebroadcast server that has created this instance of the provider.
Public property | ShortName | Gets a short localised description of the format.
Public property | UniqueId | The unique identifier for the rebroadcast format. These are written to the configuration file so avoid changing them. Do not reuse IDs. Plugins should ensure that their IDs cannot clash with other plugins.
Public property | UsesReceiverAircraftList | Gets a value indicating that the server uses the receiver's aircraft list.
Public property | UsesSendIntervalMilliseconds | Gets a value indicating that the server sends in bursts with pauses of SendIntervalMilliseconds milliseconds between each send.
Top
Methods
 | Name | Description
Public method | CanRebroadcastReceiver | Returns true if the server can rebroadcast a receiver with the settings passed across.
Public method | CreateNewInstance | Creates a new instance of the provider.
Public method | HookFeed | Hook the events that the rebroadcast server needs to listen to in order to rebroadcast a feed.
Public method | IsValidSendIntervalMilliseconds | Returns true if the send interval passed across is acceptable.
Public method | SendIntervalElapsed | Called when the send interval has elapsed.
Public method | UnhookFeed | Unhooks the events that were hooked by HookFeed.
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider Properties

IRebroadcastFormatProvider Properties

The IRebroadcastFormatProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanRebroadcastMergedFeed | Gets a value indicating that the server can rebroadcast a merged feed.
Public property | RebroadcastServer | Gets or sets the rebroadcast server that has created this instance of the provider.
Public property | ShortName | Gets a short localised description of the format.
Public property | UniqueId | The unique identifier for the rebroadcast format. These are written to the configuration file so avoid changing them. Do not reuse IDs. Plugins should ensure that their IDs cannot clash with other plugins.
Public property | UsesReceiverAircraftList | Gets a value indicating that the server uses the receiver's aircraft list.
Public property | UsesSendIntervalMilliseconds | Gets a value indicating that the server sends in bursts with pauses of SendIntervalMilliseconds milliseconds between each send.
Top
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.CanRebroadcastMergedFeed Property

IRebroadcastFormatProviderCanRebroadcastMergedFeed Property
Gets a value indicating that the server can rebroadcast a merged feed.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanRebroadcastMergedFeed { get; }
ReadOnly Property CanRebroadcastMergedFeed As Boolean
    Get
property bool CanRebroadcastMergedFeed {
    bool get ();
}
abstract CanRebroadcastMergedFeed : bool with get

Property Value

Type: Boolean
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.RebroadcastServer Property

IRebroadcastFormatProviderRebroadcastServer Property
Gets or sets the rebroadcast server that has created this instance of the provider.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IRebroadcastServer RebroadcastServer { get; set; }
Property RebroadcastServer As IRebroadcastServer
    Get
    Set
property IRebroadcastServer^ RebroadcastServer {
    IRebroadcastServer^ get ();
    void set (IRebroadcastServer^ value);
}
abstract RebroadcastServer : IRebroadcastServer with get, set

Property Value

Type: IRebroadcastServer
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.ShortName Property

IRebroadcastFormatProviderShortName Property
Gets a short localised description of the format.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ShortName { get; }
ReadOnly Property ShortName As String
    Get
property String^ ShortName {
    String^ get ();
}
abstract ShortName : string with get

Property Value

Type: String
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.UniqueId Property

IRebroadcastFormatProviderUniqueId Property
The unique identifier for the rebroadcast format. These are written to the configuration file so avoid changing them. Do not reuse IDs. Plugins should ensure that their IDs cannot clash with other plugins.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UniqueId { get; }
ReadOnly Property UniqueId As String
    Get
property String^ UniqueId {
    String^ get ();
}
abstract UniqueId : string with get

Property Value

Type: String
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.UsesReceiverAircraftList Property

IRebroadcastFormatProviderUsesReceiverAircraftList Property
Gets a value indicating that the server uses the receiver's aircraft list.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UsesReceiverAircraftList { get; }
ReadOnly Property UsesReceiverAircraftList As Boolean
    Get
property bool UsesReceiverAircraftList {
    bool get ();
}
abstract UsesReceiverAircraftList : bool with get

Property Value

Type: Boolean
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.UsesSendIntervalMilliseconds Property

IRebroadcastFormatProviderUsesSendIntervalMilliseconds Property
Gets a value indicating that the server sends in bursts with pauses of SendIntervalMilliseconds milliseconds between each send.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UsesSendIntervalMilliseconds { get; }
ReadOnly Property UsesSendIntervalMilliseconds As Boolean
    Get
property bool UsesSendIntervalMilliseconds {
    bool get ();
}
abstract UsesSendIntervalMilliseconds : bool with get

Property Value

Type: Boolean
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider Methods

IRebroadcastFormatProvider Methods

The IRebroadcastFormatProvider type exposes the following members.

Methods
 | Name | Description
Public method | CanRebroadcastReceiver | Returns true if the server can rebroadcast a receiver with the settings passed across.
Public method | CreateNewInstance | Creates a new instance of the provider.
Public method | HookFeed | Hook the events that the rebroadcast server needs to listen to in order to rebroadcast a feed.
Public method | IsValidSendIntervalMilliseconds | Returns true if the send interval passed across is acceptable.
Public method | SendIntervalElapsed | Called when the send interval has elapsed.
Public method | UnhookFeed | Unhooks the events that were hooked by HookFeed.
Top
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.CanRebroadcastReceiver Method

IRebroadcastFormatProviderCanRebroadcastReceiver Method
Returns true if the server can rebroadcast a receiver with the settings passed across.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanRebroadcastReceiver(
    Receiver receiver
)
Function CanRebroadcastReceiver (
    receiver As Receiver
) As Boolean
bool CanRebroadcastReceiver(
    Receiver^ receiver
)
abstract CanRebroadcastReceiver :
        receiver : Receiver -> bool

Parameters

receiver
Type: VirtualRadar.Interface.SettingsReceiver

Return Value

Type: Boolean
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.CreateNewInstance Method

IRebroadcastFormatProviderCreateNewInstance Method
Creates a new instance of the provider.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IRebroadcastFormatProvider CreateNewInstance()
Function CreateNewInstance As IRebroadcastFormatProvider
IRebroadcastFormatProvider^ CreateNewInstance()
abstract CreateNewInstance : unit -> IRebroadcastFormatProvider

Return Value

Type: IRebroadcastFormatProvider
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.HookFeed Method

IRebroadcastFormatProviderHookFeed Method
Hook the events that the rebroadcast server needs to listen to in order to rebroadcast a feed.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void HookFeed()
Sub HookFeed
void HookFeed()
abstract HookFeed : unit -> unit
Remarks
Implementations should record the objects that they hook and use those references in UnhookFeed. The feed's properties may change between the hook and unhook calls, do not just record a reference to the feed.
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.IsValidSendIntervalMilliseconds Method

IRebroadcastFormatProviderIsValidSendIntervalMilliseconds Method
Returns true if the send interval passed across is acceptable.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsValidSendIntervalMilliseconds(
    int sendIntervalMilliseconds
)
Function IsValidSendIntervalMilliseconds (
    sendIntervalMilliseconds As Integer
) As Boolean
bool IsValidSendIntervalMilliseconds(
    int sendIntervalMilliseconds
)
abstract IsValidSendIntervalMilliseconds :
        sendIntervalMilliseconds : int -> bool

Parameters

sendIntervalMilliseconds
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.SendIntervalElapsed Method

IRebroadcastFormatProviderSendIntervalElapsed Method
Called when the send interval has elapsed.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendIntervalElapsed()
Sub SendIntervalElapsed
void SendIntervalElapsed()
abstract SendIntervalElapsed : unit -> unit
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastFormatProvider.UnhookFeed Method

IRebroadcastFormatProviderUnhookFeed Method
Unhooks the events that were hooked by HookFeed.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnhookFeed()
Sub UnhookFeed
void UnhookFeed()
abstract UnhookFeed : unit -> unit
See Also

Reference

IRebroadcastFormatProvider Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer Interface

IRebroadcastServer Interface
The interface for objects that can rebroadcast messages or bytes received by an IListener.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRebroadcastServer : IBackgroundThreadExceptionCatcher,
    IDisposable
Public Interface IRebroadcastServer
    Inherits IBackgroundThreadExceptionCatcher, IDisposable
public interface class IRebroadcastServer : IBackgroundThreadExceptionCatcher,
    IDisposable
type IRebroadcastServer =
    interface
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IRebroadcastServer type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionEstablished | Gets a value indicating that the server is online and something is connected to it.
Public property | Connector | Gets or sets the object that establishes the connection for us.
Public property | Feed | Gets or sets the feed to take messages and bytes from.
Public property | Format | Gets or sets the format that the server is going to send information in.
Public property | Name | Gets or sets the name of the rebroadcast server.
Public property | Online | Gets or sets a flag indicating that the server is online.
Public property | SendIntervalMilliseconds | Gets or sets the interval at which aircraft lists are rebroadcast.
Public property | UniqueId | Gets or sets the unique ID of the rebroadcast server.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetConnections | Returns a list of every connection to the rebroadcast server.
Public method | Initialise | Initialises the listener and provider. After this has been called no changes should be made to any properties other than Online.
Top
Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | OnlineChanged | Raised when Online changes.
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IRebroadcastServer Properties

IRebroadcastServer Properties

The IRebroadcastServer type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionEstablished | Gets a value indicating that the server is online and something is connected to it.
Public property | Connector | Gets or sets the object that establishes the connection for us.
Public property | Feed | Gets or sets the feed to take messages and bytes from.
Public property | Format | Gets or sets the format that the server is going to send information in.
Public property | Name | Gets or sets the name of the rebroadcast server.
Public property | Online | Gets or sets a flag indicating that the server is online.
Public property | SendIntervalMilliseconds | Gets or sets the interval at which aircraft lists are rebroadcast.
Public property | UniqueId | Gets or sets the unique ID of the rebroadcast server.
Top
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.ConnectionEstablished Property

IRebroadcastServerConnectionEstablished Property
Gets a value indicating that the server is online and something is connected to it.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ConnectionEstablished { get; }
ReadOnly Property ConnectionEstablished As Boolean
    Get
property bool ConnectionEstablished {
    bool get ();
}
abstract ConnectionEstablished : bool with get

Property Value

Type: Boolean
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.Connector Property

IRebroadcastServerConnector Property
Gets or sets the object that establishes the connection for us.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
INetworkConnector Connector { get; set; }
Property Connector As INetworkConnector
    Get
    Set
property INetworkConnector^ Connector {
    INetworkConnector^ get ();
    void set (INetworkConnector^ value);
}
abstract Connector : INetworkConnector with get, set

Property Value

Type: INetworkConnector
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.Feed Property

IRebroadcastServerFeed Property
Gets or sets the feed to take messages and bytes from.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFeed Feed { get; set; }
Property Feed As IFeed
    Get
    Set
property IFeed^ Feed {
    IFeed^ get ();
    void set (IFeed^ value);
}
abstract Feed : IFeed with get, set

Property Value

Type: IFeed
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.Format Property

IRebroadcastServerFormat Property
Gets or sets the format that the server is going to send information in.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Format { get; set; }
Property Format As String
    Get
    Set
property String^ Format {
    String^ get ();
    void set (String^ value);
}
abstract Format : string with get, set

Property Value

Type: String
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.Name Property

IRebroadcastServerName Property
Gets or sets the name of the rebroadcast server.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.Online Property

IRebroadcastServerOnline Property
Gets or sets a flag indicating that the server is online.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Online { get; set; }
Property Online As Boolean
    Get
    Set
property bool Online {
    bool get ();
    void set (bool value);
}
abstract Online : bool with get, set

Property Value

Type: Boolean
Remarks
Setting this to false does not disconnect the clients attached to the Connector, it just stops sending bytes to them. To disconnect the clients you need to dispose of the provider and create a new one after you go offline.
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.SendIntervalMilliseconds Property

IRebroadcastServerSendIntervalMilliseconds Property
Gets or sets the interval at which aircraft lists are rebroadcast.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int SendIntervalMilliseconds { get; set; }
Property SendIntervalMilliseconds As Integer
    Get
    Set
property int SendIntervalMilliseconds {
    int get ();
    void set (int value);
}
abstract SendIntervalMilliseconds : int with get, set

Property Value

Type: Int32
Remarks
Only used when the rebroadcast format involves sending the aircraft list instead of sending aircraft messages. Defaults to 1 second.
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.UniqueId Property

IRebroadcastServerUniqueId Property
Gets or sets the unique ID of the rebroadcast server.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int UniqueId { get; set; }
Property UniqueId As Integer
    Get
    Set
property int UniqueId {
    int get ();
    void set (int value);
}
abstract UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer Methods

IRebroadcastServer Methods

The IRebroadcastServer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetConnections | Returns a list of every connection to the rebroadcast server.
Public method | Initialise | Initialises the listener and provider. After this has been called no changes should be made to any properties other than Online.
Top
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.GetConnections Method

IRebroadcastServerGetConnections Method
Returns a list of every connection to the rebroadcast server.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<RebroadcastServerConnection> GetConnections()
Function GetConnections As List(Of RebroadcastServerConnection)
List<RebroadcastServerConnection^>^ GetConnections()
abstract GetConnections : unit -> List<RebroadcastServerConnection>

Return Value

Type: List RebroadcastServerConnection
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.Initialise Method

IRebroadcastServerInitialise Method
Initialises the listener and provider. After this has been called no changes should be made to any properties other than Online.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer Events

IRebroadcastServer Events

The IRebroadcastServer type exposes the following members.

Events
 | Name | Description
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | OnlineChanged | Raised when Online changes.
Top
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServer.OnlineChanged Event

IRebroadcastServerOnlineChanged Event
Raised when Online changes.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnlineChanged
Event OnlineChanged As EventHandler
 event EventHandler^ OnlineChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnlineChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastServer Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager Interface

IRebroadcastServerManager Interface
The interface for a singleton object that can configure and control a collection of IRebroadcastServers.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRebroadcastServerManager : ISingleton<IRebroadcastServerManager>,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface IRebroadcastServerManager
    Inherits ISingleton(Of IRebroadcastServerManager), IBackgroundThreadExceptionCatcher, IDisposable
public interface class IRebroadcastServerManager : ISingleton<IRebroadcastServerManager^>,
    IBackgroundThreadExceptionCatcher, IDisposable
type IRebroadcastServerManager =
    interface
        interface ISingleton<IRebroadcastServerManager>
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IRebroadcastServerManager type exposes the following members.

Properties
 | Name | Description
Public property | Online | Gets or sets a flag indicating that the server is online.
Public property | RebroadcastServers | Gets the collection of rebroadcast servers that are being controlled by the manager.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetConnections | Returns a list of objects describing all of the connections to the rebroadcast servers.
Public method | Initialise | Creates the initial collection of rebroadcast servers from the configuration settings.
Top
Events
 | Name | Description
Public event | ClientConnected | Raised when a client connects to one of the servers.
Public event | ClientDisconnected | Raised when a client disconnects from one of the servers.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | OnlineChanged | Raised when Online changes.
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager Properties

IRebroadcastServerManager Properties

The IRebroadcastServerManager type exposes the following members.

Properties
 | Name | Description
Public property | Online | Gets or sets a flag indicating that the server is online.
Public property | RebroadcastServers | Gets the collection of rebroadcast servers that are being controlled by the manager.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.Online Property

IRebroadcastServerManagerOnline Property
Gets or sets a flag indicating that the server is online.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Online { get; set; }
Property Online As Boolean
    Get
    Set
property bool Online {
    bool get ();
    void set (bool value);
}
abstract Online : bool with get, set

Property Value

Type: Boolean
Remarks
Setting this to false does not disconnect the clients attached to the RebroadcastServers, it just stops sending bytes to them. To disconnect the clients you need to dispose of the provider and create a new one after you go offline.
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.RebroadcastServers Property

IRebroadcastServerManagerRebroadcastServers Property
Gets the collection of rebroadcast servers that are being controlled by the manager.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<IRebroadcastServer> RebroadcastServers { get; }
ReadOnly Property RebroadcastServers As List(Of IRebroadcastServer)
    Get
property List<IRebroadcastServer^>^ RebroadcastServers {
    List<IRebroadcastServer^>^ get ();
}
abstract RebroadcastServers : List<IRebroadcastServer> with get

Property Value

Type: List IRebroadcastServer
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager Methods

IRebroadcastServerManager Methods

The IRebroadcastServerManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetConnections | Returns a list of objects describing all of the connections to the rebroadcast servers.
Public method | Initialise | Creates the initial collection of rebroadcast servers from the configuration settings.
Top
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.GetConnections Method

IRebroadcastServerManagerGetConnections Method
Returns a list of objects describing all of the connections to the rebroadcast servers.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<RebroadcastServerConnection> GetConnections()
Function GetConnections As List(Of RebroadcastServerConnection)
List<RebroadcastServerConnection^>^ GetConnections()
abstract GetConnections : unit -> List<RebroadcastServerConnection>

Return Value

Type: List RebroadcastServerConnection
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.Initialise Method

IRebroadcastServerManagerInitialise Method
Creates the initial collection of rebroadcast servers from the configuration settings.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager Events

IRebroadcastServerManager Events

The IRebroadcastServerManager type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Raised when a client connects to one of the servers.
Public event | ClientDisconnected | Raised when a client disconnects from one of the servers.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | OnlineChanged | Raised when Online changes.
Top
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.ClientConnected Event

IRebroadcastServerManagerClientConnected Event
Raised when a client connects to one of the servers.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ConnectionEventArgs> ClientConnected
Event ClientConnected As EventHandler(Of ConnectionEventArgs)
 event EventHandler<ConnectionEventArgs^>^ ClientConnected {
    void add (EventHandler<ConnectionEventArgs^>^ value);
    void remove (EventHandler<ConnectionEventArgs^>^ value);
}
abstract ClientConnected : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

Value

Type: SystemEventHandler ConnectionEventArgs
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.ClientDisconnected Event

IRebroadcastServerManagerClientDisconnected Event
Raised when a client disconnects from one of the servers.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ConnectionEventArgs> ClientDisconnected
Event ClientDisconnected As EventHandler(Of ConnectionEventArgs)
 event EventHandler<ConnectionEventArgs^>^ ClientDisconnected {
    void add (EventHandler<ConnectionEventArgs^>^ value);
    void remove (EventHandler<ConnectionEventArgs^>^ value);
}
abstract ClientDisconnected : IEvent<EventHandler<ConnectionEventArgs>,
    ConnectionEventArgs>

Value

Type: SystemEventHandler ConnectionEventArgs
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


IRebroadcastServerManager.OnlineChanged Event

IRebroadcastServerManagerOnlineChanged Event
Raised when Online changes.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnlineChanged
Event OnlineChanged As EventHandler
 event EventHandler^ OnlineChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnlineChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastServerManager Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector Interface

ISerialConnector Interface
An active connector that connects to a device over a serial COM port.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISerialConnector : IConnector,
    IBackgroundThreadExceptionCatcher, IDisposable
Public Interface ISerialConnector
    Inherits IConnector, IBackgroundThreadExceptionCatcher, IDisposable
public interface class ISerialConnector : IConnector,
    IBackgroundThreadExceptionCatcher, IDisposable
type ISerialConnector =
    interface
        interface IConnector
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The ISerialConnector type exposes the following members.

Properties
 | Name | Description
Public property | Authentication | Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication. (Inherited from IConnector.)
Public property | BaudRate | Gets or sets the baud rate to use.
Public property | ComPort | Gets or sets the COM port to listen to.
Public property | Connection | Gets the first (or only) connection established by the connector. (Inherited from IConnector.)
Public property | ConnectionStatus | Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status. (Inherited from IConnector.)
Public property | CountExceptions | Gets the number of exceptions ever encountered by the connector. (Inherited from IConnector.)
Public property | Created | Gets the date and time, at UTC, that the connector was first created. (Inherited from IConnector.)
Public property | DataBits | Gets or sets the data bits to use.
Public property | EstablishingConnections | Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection. (Inherited from IConnector.)
Public property | Handshake | Gets or sets the handshake protocol to use.
Public property | HasConnection | Gets a value indicating that the connector has established a connection with at least one end point. (Inherited from IConnector.)
Public property | Intent | Gets a description of the intended use of the connector. Only used for diagnostics. (Inherited from IConnector.)
Public property | IsPassive | Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things. (Inherited from IConnector.)
Public property | IsSingleConnection | Gets or sets a value indicating whether the connector supports multiple connections or a single connection. (Inherited from IConnector.)
Public property | LastException | Gets the last exception encountered by the connector. (Inherited from IConnector.)
Public property | Name | Gets or sets the name of the connector. (Inherited from IConnector.)
Public property | Parity | Gets or sets the parity to use.
Public property | ShutdownText | Gets or sets the text to send across the COM port on shutdown - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StaleMessageTimeout | Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded. (Inherited from IConnector.)
Public property | StartupText | Gets or sets the text to send across the COM port on startup - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StopBits | Gets or sets the stop bits to use.
Top
Methods
 | Name | Description
Public method | CloseConnection | Tells the connector to close all connections. This blocks until all connections have been shut down. (Inherited from IConnector.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EstablishConnection | Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background. (Inherited from IConnector.)
Public method | GetActivityHistory | Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities. (Inherited from IConnector.)
Public method | GetConnections | Returns an array of established connections made by the connector. (Inherited from IConnector.)
Public method | GetExceptionHistory | Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions. (Inherited from IConnector.)
Public method | GetFirstConnection | Returns the first established connection or null if there are no connections. (Inherited from IConnector.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | RestartConnection | Closes the connection and then establishes the connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Top
Events
 | Name | Description
Public event | ActivityRecorded | Raised when an activity is recorded by the connector. (Inherited from IConnector.)
Public event | AddingConnection | Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionClosed | Raised when a connection has been permanently closed. This will usually be raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionEstablished | Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised. (Inherited from IConnector.)
Public event | ConnectionStateChanged | Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector. (Inherited from IConnector.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


ISerialConnector Properties

ISerialConnector Properties

The ISerialConnector type exposes the following members.

Properties
 | Name | Description
Public property | Authentication | Gets or sets the authentication to use with the connection. If this is set then the other side must implement the same authentication. (Inherited from IConnector.)
Public property | BaudRate | Gets or sets the baud rate to use.
Public property | ComPort | Gets or sets the COM port to listen to.
Public property | Connection | Gets the first (or only) connection established by the connector. (Inherited from IConnector.)
Public property | ConnectionStatus | Gets the connection status. This only reflects the status of the connector - individual connections being maintained by the connector have their own status. (Inherited from IConnector.)
Public property | CountExceptions | Gets the number of exceptions ever encountered by the connector. (Inherited from IConnector.)
Public property | Created | Gets the date and time, at UTC, that the connector was first created. (Inherited from IConnector.)
Public property | DataBits | Gets or sets the data bits to use.
Public property | EstablishingConnections | Gets a value that EstablishConnection has been called without a subsequent call to CloseConnection. (Inherited from IConnector.)
Public property | Handshake | Gets or sets the handshake protocol to use.
Public property | HasConnection | Gets a value indicating that the connector has established a connection with at least one end point. (Inherited from IConnector.)
Public property | Intent | Gets a description of the intended use of the connector. Only used for diagnostics. (Inherited from IConnector.)
Public property | IsPassive | Gets or sets a value indicating whether the connector waits for other things to connect to it or it actively connects to other things. (Inherited from IConnector.)
Public property | IsSingleConnection | Gets or sets a value indicating whether the connector supports multiple connections or a single connection. (Inherited from IConnector.)
Public property | LastException | Gets the last exception encountered by the connector. (Inherited from IConnector.)
Public property | Name | Gets or sets the name of the connector. (Inherited from IConnector.)
Public property | Parity | Gets or sets the parity to use.
Public property | ShutdownText | Gets or sets the text to send across the COM port on shutdown - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StaleMessageTimeout | Gets the maximum age (in milliseconds) that a message can sit in the transmit queue before it is considered stale and discarded. (Inherited from IConnector.)
Public property | StartupText | Gets or sets the text to send across the COM port on startup - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StopBits | Gets or sets the stop bits to use.
Top
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.BaudRate Property

ISerialConnectorBaudRate Property
Gets or sets the baud rate to use.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int BaudRate { get; set; }
Property BaudRate As Integer
    Get
    Set
property int BaudRate {
    int get ();
    void set (int value);
}
abstract BaudRate : int with get, set

Property Value

Type: Int32
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.ComPort Property

ISerialConnectorComPort Property
Gets or sets the COM port to listen to.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ComPort { get; set; }
Property ComPort As String
    Get
    Set
property String^ ComPort {
    String^ get ();
    void set (String^ value);
}
abstract ComPort : string with get, set

Property Value

Type: String
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.DataBits Property

ISerialConnectorDataBits Property
Gets or sets the data bits to use.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int DataBits { get; set; }
Property DataBits As Integer
    Get
    Set
property int DataBits {
    int get ();
    void set (int value);
}
abstract DataBits : int with get, set

Property Value

Type: Int32
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.Handshake Property

ISerialConnectorHandshake Property
Gets or sets the handshake protocol to use.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Handshake Handshake { get; set; }
Property Handshake As Handshake
    Get
    Set
property Handshake Handshake {
    Handshake get ();
    void set (Handshake value);
}
abstract Handshake : Handshake with get, set

Property Value

Type: Handshake
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.Parity Property

ISerialConnectorParity Property
Gets or sets the parity to use.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Parity Parity { get; set; }
Property Parity As Parity
    Get
    Set
property Parity Parity {
    Parity get ();
    void set (Parity value);
}
abstract Parity : Parity with get, set

Property Value

Type: Parity
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.ShutdownText Property

ISerialConnectorShutdownText Property
Gets or sets the text to send across the COM port on shutdown - a null or empty string will disable the feature. Can contain \r and \n.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ShutdownText { get; set; }
Property ShutdownText As String
    Get
    Set
property String^ ShutdownText {
    String^ get ();
    void set (String^ value);
}
abstract ShutdownText : string with get, set

Property Value

Type: String
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.StartupText Property

ISerialConnectorStartupText Property
Gets or sets the text to send across the COM port on startup - a null or empty string will disable the feature. Can contain \r and \n.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string StartupText { get; set; }
Property StartupText As String
    Get
    Set
property String^ StartupText {
    String^ get ();
    void set (String^ value);
}
abstract StartupText : string with get, set

Property Value

Type: String
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector.StopBits Property

ISerialConnectorStopBits Property
Gets or sets the stop bits to use.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
StopBits StopBits { get; set; }
Property StopBits As StopBits
    Get
    Set
property StopBits StopBits {
    StopBits get ();
    void set (StopBits value);
}
abstract StopBits : StopBits with get, set

Property Value

Type: StopBits
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector Methods

ISerialConnector Methods

The ISerialConnector type exposes the following members.

Methods
 | Name | Description
Public method | CloseConnection | Tells the connector to close all connections. This blocks until all connections have been shut down. (Inherited from IConnector.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EstablishConnection | Tells the connector to establish a connection. This is a non-blocking call, the function will return immediately and establish the connection in the background. (Inherited from IConnector.)
Public method | GetActivityHistory | Returns an array of the last so-many activities performed by the connector or any of its connections. Exactly how many is undefined. This always returns the most recent set of activities. (Inherited from IConnector.)
Public method | GetConnections | Returns an array of established connections made by the connector. (Inherited from IConnector.)
Public method | GetExceptionHistory | Returns an array of the last so-many exceptions encountered by the connector. Exactly how many is undefined, but it can be more than one and will never exceed CountExceptions. Always returns the most recent set of exceptions. (Inherited from IConnector.)
Public method | GetFirstConnection | Returns the first established connection or null if there are no connections. (Inherited from IConnector.)
Public method | Read(Byte, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | Read(Byte, Int32, Int32, ConnectionReadDelegate) | Reads the next chunk from the first (or only) connection. (Inherited from IConnector.)
Public method | RestartConnection | Closes the connection and then establishes the connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Public method | Write(Byte, Int32, Int32, Int32) | Writes the content of the buffer to every connection. (Inherited from IConnector.)
Top
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ISerialConnector Events

ISerialConnector Events

The ISerialConnector type exposes the following members.

Events
 | Name | Description
Public event | ActivityRecorded | Raised when an activity is recorded by the connector. (Inherited from IConnector.)
Public event | AddingConnection | Raised when a connection has been established. The connection will not yet be in the list of established connections, writes on the connector will not go to this connection. Usually raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionClosed | Raised when a connection has been permanently closed. This will usually be raised from a background thread. (Inherited from IConnector.)
Public event | ConnectionEstablished | Raised when a connection has been established. This will usually be raised from a background thread. The connection will be in the list of established connections when this is raised. (Inherited from IConnector.)
Public event | ConnectionStateChanged | Raised when a connection's connection state has changed. This will usually be raised from a background thread. Sender will either be an IConnection or this IConnector. (Inherited from IConnector.)
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Top
See Also

Reference

ISerialConnector Interface
VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService Interface

ITcpConnectionStateService Interface
A service that can retrieve the state of TCP connections.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITcpConnectionStateService
Public Interface ITcpConnectionStateService
public interface class ITcpConnectionStateService
type ITcpConnectionStateService =  interface end

The ITcpConnectionStateService type exposes the following members.

Properties
 | Name | Description
Public property | CountConnections | Gets the count of connections that the service knows about.
Top
Methods
 | Name | Description
Public method | DescribeRemoteConnectionState | Returns a description of the state of a remote end-point.
Public method | IsRemoteConnectionEstablished | Returns true if the connection to the remote end-point was in the ESTABLISHED state when the object was constructed.
Public method | RefreshTcpConnectionStates | Reloads the cache of connection states that was established when the object was created. All other methods work off this cache, they do not perform live lookups.
Top
Remarks
Getting the TCP connection state is fairly straight-forward - however under Mono the IPGlobalProperties.GetIPGlobalProperties().GetActiveTcpConnections() call is currently bugged, we need to handle it differently when running under Mono. This interface wraps the call and copes with the bugged call.
See Also

Reference

VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService Properties

ITcpConnectionStateService Properties

The ITcpConnectionStateService type exposes the following members.

Properties
 | Name | Description
Public property | CountConnections | Gets the count of connections that the service knows about.
Top
See Also

Reference

ITcpConnectionStateService Interface
VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService.CountConnections Property

ITcpConnectionStateServiceCountConnections Property
Gets the count of connections that the service knows about.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int CountConnections { get; }
ReadOnly Property CountConnections As Integer
    Get
property int CountConnections {
    int get ();
}
abstract CountConnections : int with get

Property Value

Type: Int32
See Also

Reference

ITcpConnectionStateService Interface
VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService Methods

ITcpConnectionStateService Methods

The ITcpConnectionStateService type exposes the following members.

Methods
 | Name | Description
Public method | DescribeRemoteConnectionState | Returns a description of the state of a remote end-point.
Public method | IsRemoteConnectionEstablished | Returns true if the connection to the remote end-point was in the ESTABLISHED state when the object was constructed.
Public method | RefreshTcpConnectionStates | Reloads the cache of connection states that was established when the object was created. All other methods work off this cache, they do not perform live lookups.
Top
See Also

Reference

ITcpConnectionStateService Interface
VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService.DescribeRemoteConnectionState Method

ITcpConnectionStateServiceDescribeRemoteConnectionState Method
Returns a description of the state of a remote end-point.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DescribeRemoteConnectionState(
    IPEndPoint localEndPoint,
    IPEndPoint remoteEndPoint
)
Function DescribeRemoteConnectionState (
    localEndPoint As IPEndPoint,
    remoteEndPoint As IPEndPoint
) As String
String^ DescribeRemoteConnectionState(
    IPEndPoint^ localEndPoint,
    IPEndPoint^ remoteEndPoint
)
abstract DescribeRemoteConnectionState :
        localEndPoint : IPEndPoint *
        remoteEndPoint : IPEndPoint -> string

Parameters

localEndPoint
Type: System.NetIPEndPoint
remoteEndPoint
Type: System.NetIPEndPoint

Return Value

Type: String
See Also

Reference

ITcpConnectionStateService Interface
VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService.IsRemoteConnectionEstablished Method

ITcpConnectionStateServiceIsRemoteConnectionEstablished Method
Returns true if the connection to the remote end-point was in the ESTABLISHED state when the object was constructed.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsRemoteConnectionEstablished(
    IPEndPoint localEndPoint,
    IPEndPoint remoteEndPoint
)
Function IsRemoteConnectionEstablished (
    localEndPoint As IPEndPoint,
    remoteEndPoint As IPEndPoint
) As Boolean
bool IsRemoteConnectionEstablished(
    IPEndPoint^ localEndPoint,
    IPEndPoint^ remoteEndPoint
)
abstract IsRemoteConnectionEstablished :
        localEndPoint : IPEndPoint *
        remoteEndPoint : IPEndPoint -> bool

Parameters

localEndPoint
Type: System.NetIPEndPoint
remoteEndPoint
Type: System.NetIPEndPoint
The remote endpoint to check.

Return Value

Type: Boolean
True if the connection is established, false if it does not exist or is not in the established state.
See Also

Reference

ITcpConnectionStateService Interface
VirtualRadar.Interface.Network Namespace


ITcpConnectionStateService.RefreshTcpConnectionStates Method

ITcpConnectionStateServiceRefreshTcpConnectionStates Method
Reloads the cache of connection states that was established when the object was created. All other methods work off this cache, they do not perform live lookups.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshTcpConnectionStates()
Sub RefreshTcpConnectionStates
void RefreshTcpConnectionStates()
abstract RefreshTcpConnectionStates : unit -> unit
See Also

Reference

ITcpConnectionStateService Interface
VirtualRadar.Interface.Network Namespace


RebroadcastFormatName Class

RebroadcastFormatName Class
Links a rebroadcast server format's name to its unique ID.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.NetworkRebroadcastFormatName

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RebroadcastFormatName
Public Class RebroadcastFormatName
public ref class RebroadcastFormatName
type RebroadcastFormatName =  class end

The RebroadcastFormatName type exposes the following members.

Constructors
 | Name | Description
Public method | RebroadcastFormatName | Initializes a new instance of the RebroadcastFormatName class
Top
Properties
 | Name | Description
Public property | ShortName | Gets or sets the rebroadcast server format's name.
Public property | UniqueId | Gets or sets the rebroadcast server format unique ID.
Top
Methods
 | Name | Description
 | Create | Creates a new RebroadcastFormatName.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Network Namespace


RebroadcastFormatName Constructor

RebroadcastFormatName Constructor
Initializes a new instance of the RebroadcastFormatName class

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastFormatName()
Public Sub New
public:
RebroadcastFormatName()
new : unit -> RebroadcastFormatName
See Also

Reference

RebroadcastFormatName Class
VirtualRadar.Interface.Network Namespace


RebroadcastFormatName Properties

RebroadcastFormatName Properties

The RebroadcastFormatName type exposes the following members.

Properties
 | Name | Description
Public property | ShortName | Gets or sets the rebroadcast server format's name.
Public property | UniqueId | Gets or sets the rebroadcast server format unique ID.
Top
See Also

Reference

RebroadcastFormatName Class
VirtualRadar.Interface.Network Namespace


RebroadcastFormatName.ShortName Property

RebroadcastFormatNameShortName Property
Gets or sets the rebroadcast server format's name.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ShortName { get; set; }
Public Property ShortName As String
    Get
    Set
public:
property String^ ShortName {
    String^ get ();
    void set (String^ value);
}
member ShortName : string with get, set

Property Value

Type: String
See Also

Reference

RebroadcastFormatName Class
VirtualRadar.Interface.Network Namespace


RebroadcastFormatName.UniqueId Property

RebroadcastFormatNameUniqueId Property
Gets or sets the rebroadcast server format unique ID.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
member UniqueId : string with get, set

Property Value

Type: String
See Also

Reference

RebroadcastFormatName Class
VirtualRadar.Interface.Network Namespace


RebroadcastFormatName Methods

RebroadcastFormatName Methods

The RebroadcastFormatName type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a new RebroadcastFormatName.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RebroadcastFormatName Class
VirtualRadar.Interface.Network Namespace


RebroadcastFormatName.Create Method

RebroadcastFormatNameCreate Method
Creates a new RebroadcastFormatName.

Namespace: VirtualRadar.Interface.Network
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RebroadcastFormatName Create(
    IRebroadcastFormatProvider provider
)
Public Shared Function Create (
    provider As IRebroadcastFormatProvider
) As RebroadcastFormatName
public:
static RebroadcastFormatName^ Create(
    IRebroadcastFormatProvider^ provider
)
static member Create :
        provider : IRebroadcastFormatProvider -> RebroadcastFormatName

Parameters

provider
Type: VirtualRadar.Interface.NetworkIRebroadcastFormatProvider

Return Value

Type: RebroadcastFormatName
See Also

Reference

RebroadcastFormatName Class
VirtualRadar.Interface.Network Namespace


VirtualRadar.Interface.PortableBinding Namespace

VirtualRadar.Interface.PortableBinding Namespace

[Missing <summary> documentation for "N:VirtualRadar.Interface.PortableBinding"]

Classes
 | Class | Description
Public class | GenericListWrapperT | A wrapper that accepts a generic IList and exposes the non-generic IList interface for it.
Public class | NotifyListT | A list collection that implements INotifyCollectionChanged, INotifyPropertyChanged, IBindingList and IRaiseItemChangedEvents.


GenericListWrapper(T) Class

GenericListWrapperT Class
A wrapper that accepts a generic IList and exposes the non-generic IList interface for it.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.PortableBindingGenericListWrapperT

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GenericListWrapper<T> : IList,
    ICollection, IEnumerable

Public Class GenericListWrapper(Of T)
    Implements IList, ICollection, IEnumerable
generic<typename T>
public ref class GenericListWrapper : IList,
    ICollection, IEnumerable
type GenericListWrapper<'T> =
    class
        interface IList
        interface ICollection
        interface IEnumerable
    end

Type Parameters

T

The GenericListWrapperT type exposes the following members.

Constructors
 | Name | Description
Public method | GenericListWrapperT | Creates a new object.
Top
Properties
 | Name | Description
Public property | Count | See interface docs.
Public property | GenericList | Gets the list that is being wrapped.
Public property | IsFixedSize | See interface docs.
Public property | IsReadOnly | See interface docs.
Public property | IsSynchronized | See interface docs.
Public property | Item | See interface docs.
Public property | SyncRoot | See interface docs.
Top
Methods
 | Name | Description
Public method | Add | See interface docs.
Public method | Clear | See interface docs.
Public method | Contains | See interface docs.
Public method | CopyTo | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | See interface docs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | See interface docs.
Public method | Insert | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | See interface docs.
Public method | RemoveAt | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | HasSameContentAs | Returns true if two ILists have the same content. (Defined by IListExtensions.)
Top
Remarks
Using generics with WinForms controls is a PITA but using the non-generic version of IList outside of controls is not good. This is a simple-minded wrapper that takes the non-generic version of a list that the program uses and translates it into an IList that can be used with WinForms controls.
See Also

Reference

VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T) Constructor

GenericListWrapperT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GenericListWrapper(
    IList<T> list
)
Public Sub New (
    list As IList(Of T)
)
public:
GenericListWrapper(
    IList<T>^ list
)
new :
        list : IList<'T> -> GenericListWrapper

Parameters

list
Type: System.Collections.GenericIList T
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T) Properties

GenericListWrapperT Properties

The GenericListWrapperT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | See interface docs.
Public property | GenericList | Gets the list that is being wrapped.
Public property | IsFixedSize | See interface docs.
Public property | IsReadOnly | See interface docs.
Public property | IsSynchronized | See interface docs.
Public property | Item | See interface docs.
Public property | SyncRoot | See interface docs.
Top
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Count Property

GenericListWrapperTCount Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionCount
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).GenericList Property

GenericListWrapperTGenericList Property
Gets the list that is being wrapped.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<T> GenericList { get; }
Public ReadOnly Property GenericList As IList(Of T)
    Get
public:
property IList<T>^ GenericList {
    IList<T>^ get ();
}
member GenericList : IList<'T> with get

Property Value

Type: IList T
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).IsFixedSize Property

GenericListWrapperTIsFixedSize Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}
abstract IsFixedSize : bool with get
override IsFixedSize : bool with get

Property Value

Type: Boolean

Implements

IListIsFixedSize
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).IsReadOnly Property

GenericListWrapperTIsReadOnly Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

IListIsReadOnly
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).IsSynchronized Property

GenericListWrapperTIsSynchronized Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
abstract IsSynchronized : bool with get
override IsSynchronized : bool with get

Property Value

Type: Boolean

Implements

ICollectionIsSynchronized
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Item Property

GenericListWrapperTItem Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set
public:
virtual property Object^ default[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}
abstract Item : Object with get, set
override Item : Object with get, set

Parameters

index
Type: SystemInt32

Return Value

Type: Object

Implements

IListItemInt32
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).SyncRoot Property

GenericListWrapperTSyncRoot Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
abstract SyncRoot : Object with get
override SyncRoot : Object with get

Property Value

Type: Object

Implements

ICollectionSyncRoot
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T) Methods

GenericListWrapperT Methods

The GenericListWrapperT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | See interface docs.
Public method | Clear | See interface docs.
Public method | Contains | See interface docs.
Public method | CopyTo | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | See interface docs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | See interface docs.
Public method | Insert | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | See interface docs.
Public method | RemoveAt | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | HasSameContentAs | Returns true if two ILists have the same content. (Defined by IListExtensions.)
Top
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Add Method

GenericListWrapperTAdd Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Add(
    Object value
)
Public Function Add (
    value As Object
) As Integer
public:
virtual int Add(
    Object^ value
) sealed
abstract Add :
        value : Object -> int
override Add :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32

Implements

IListAdd(Object)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Clear Method

GenericListWrapperTClear Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IListClear
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Contains Method

GenericListWrapperTContains Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Object value
)
Public Function Contains (
    value As Object
) As Boolean
public:
virtual bool Contains(
    Object^ value
) sealed
abstract Contains :
        value : Object -> bool
override Contains :
        value : Object -> bool

Parameters

value
Type: SystemObject

Return Value

Type: Boolean

Implements

IListContains(Object)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).CopyTo Method

GenericListWrapperTCopyTo Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
abstract CopyTo :
        array : Array *
        index : int -> unit
override CopyTo :
        array : Array *
        index : int -> unit

Parameters

array
Type: SystemArray
index
Type: SystemInt32

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).GetEnumerator Method

GenericListWrapperTGetEnumerator Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).IndexOf Method

GenericListWrapperTIndexOf Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    Object value
)
Public Function IndexOf (
    value As Object
) As Integer
public:
virtual int IndexOf(
    Object^ value
) sealed
abstract IndexOf :
        value : Object -> int
override IndexOf :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32

Implements

IListIndexOf(Object)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Insert Method

GenericListWrapperTInsert Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int index,
    Object value
)
Public Sub Insert (
    index As Integer,
    value As Object
)
public:
virtual void Insert(
    int index,
    Object^ value
) sealed
abstract Insert :
        index : int *
        value : Object -> unit
override Insert :
        index : int *
        value : Object -> unit

Parameters

index
Type: SystemInt32
value
Type: SystemObject

Implements

IListInsert(Int32, Object)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).Remove Method

GenericListWrapperTRemove Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    Object value
)
Public Sub Remove (
    value As Object
)
public:
virtual void Remove(
    Object^ value
) sealed
abstract Remove :
        value : Object -> unit
override Remove :
        value : Object -> unit

Parameters

value
Type: SystemObject

Implements

IListRemove(Object)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


GenericListWrapper(T).RemoveAt Method

GenericListWrapperTRemoveAt Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) sealed
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32

Implements

IListRemoveAt(Int32)
See Also

Reference

GenericListWrapperT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T) Class

NotifyListT Class
A list collection that implements INotifyCollectionChanged, INotifyPropertyChanged, IBindingList and IRaiseItemChangedEvents.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
VirtualRadar.Interface.PortableBindingNotifyListT

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class NotifyList<T> : ObservableCollection<T>,
    IBindingList, IList, ICollection, IEnumerable, IEnumerable<T>,
    IRaiseItemChangedEvents

<SerializableAttribute>
Public Class NotifyList(Of T)
    Inherits ObservableCollection(Of T)
    Implements IBindingList, IList, ICollection, IEnumerable,
    IEnumerable(Of T), IRaiseItemChangedEvents
[SerializableAttribute]
generic<typename T>
public ref class NotifyList : public ObservableCollection<T>,
    IBindingList, IList, ICollection, IEnumerable, IEnumerable<T>,
    IRaiseItemChangedEvents
[<SerializableAttribute>]
type NotifyList<'T> =
    class
        inherit ObservableCollection<'T>
        interface IBindingList
        interface IList
        interface ICollection
        interface IEnumerable
        interface IEnumerable<'T>
        interface IRaiseItemChangedEvents
    end

Type Parameters

T

The NotifyListT type exposes the following members.

Constructors
 | Name | Description
Public method | NotifyListT | Creates a new object.
Top
Properties
 | Name | Description
Public property | AllowEdit | See interface docs.
Public property | AllowNew | See interface docs.
Public property | AllowRemove | See interface docs.
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T.)
Public property | IsSorted | See interface docs.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T.)
Public property | RaiseListChangedEvents | Gets or sets a value indicating whether Add, Insert and Remove raise ListChanged events.
Public property | RaisesItemChangedEvents | See interface docs.
Public property | SortDirection | See interface docs.
Public property | SortProperty | See interface docs.
Public property | SupportsChangeNotification | See interface docs.
Public property | SupportsSearching | See interface docs.
Public property | SupportsSorting | See interface docs.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T.)
Public method | AddIndex | Not implemented.
Public method | AddNew | See interface docs.
Public method | ApplySort | Not implemented.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T.)
Protected method | ClearItems | See base docs. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Not implemented.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T.)
Protected method | InsertItem | See base docs. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Called when the underlying collection is changed. (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnListChanged | Raises ListChanged.
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection T.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T.)
Public method | RemoveIndex | Not implemented.
Protected method | RemoveItem | See base docs. (Overrides ObservableCollectionTRemoveItem(Int32).)
Public method | RemoveSort | Not implemented.
Protected method | SetItem | See base docs. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T.)
Public event | ListChanged | See interface docs.
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsListT | Obtains the data as a list; if it is *already* a list, the original object is returned without any duplication; otherwise, ToList() is invoked. (Defined by SqlMapper.)
Public Extension Method | HasSameContentAs | Returns true if two ILists have the same content. (Defined by IListExtensions.)
Top
Remarks
This was not written because I had nothing better to do. I needed it because Mono's implementation of BindingList doesn't work. Only the bits of IBindingList that I need have been implemented. I implemented both ObservableCollection and IBindingList because I was using BindingList and I want this to work as a drop-in replacement.
See Also

Reference

VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T) Constructor

NotifyListT Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList()
Public Sub New
public:
NotifyList()
new : unit -> NotifyList
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T) Properties

NotifyListT Properties

The NotifyListT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowEdit | See interface docs.
Public property | AllowNew | See interface docs.
Public property | AllowRemove | See interface docs.
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection T .)
Public property | IsSorted | See interface docs.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection T .)
Public property | RaiseListChangedEvents | Gets or sets a value indicating whether Add, Insert and Remove raise ListChanged events.
Public property | RaisesItemChangedEvents | See interface docs.
Public property | SortDirection | See interface docs.
Public property | SortProperty | See interface docs.
Public property | SupportsChangeNotification | See interface docs.
Public property | SupportsSearching | See interface docs.
Public property | SupportsSorting | See interface docs.
Top
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).AllowEdit Property

NotifyListTAllowEdit Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowEdit { get; }
Public ReadOnly Property AllowEdit As Boolean
    Get
public:
virtual property bool AllowEdit {
    bool get () sealed;
}
abstract AllowEdit : bool with get
override AllowEdit : bool with get

Property Value

Type: Boolean

Implements

IBindingListAllowEdit
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).AllowNew Property

NotifyListTAllowNew Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowNew { get; }
Public ReadOnly Property AllowNew As Boolean
    Get
public:
virtual property bool AllowNew {
    bool get () sealed;
}
abstract AllowNew : bool with get
override AllowNew : bool with get

Property Value

Type: Boolean

Implements

IBindingListAllowNew
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).AllowRemove Property

NotifyListTAllowRemove Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowRemove { get; }
Public ReadOnly Property AllowRemove As Boolean
    Get
public:
virtual property bool AllowRemove {
    bool get () sealed;
}
abstract AllowRemove : bool with get
override AllowRemove : bool with get

Property Value

Type: Boolean

Implements

IBindingListAllowRemove
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).IsSorted Property

NotifyListTIsSorted Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSorted { get; }
Public ReadOnly Property IsSorted As Boolean
    Get
public:
virtual property bool IsSorted {
    bool get () sealed;
}
abstract IsSorted : bool with get
override IsSorted : bool with get

Property Value

Type: Boolean

Implements

IBindingListIsSorted
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).RaiseListChangedEvents Property

NotifyListTRaiseListChangedEvents Property
Gets or sets a value indicating whether Add, Insert and Remove raise ListChanged events.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RaiseListChangedEvents { get; set; }
Public Property RaiseListChangedEvents As Boolean
    Get
    Set
public:
property bool RaiseListChangedEvents {
    bool get ();
    void set (bool value);
}
member RaiseListChangedEvents : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).RaisesItemChangedEvents Property

NotifyListTRaisesItemChangedEvents Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RaisesItemChangedEvents { get; }
Public ReadOnly Property RaisesItemChangedEvents As Boolean
    Get
public:
virtual property bool RaisesItemChangedEvents {
    bool get () sealed;
}
abstract RaisesItemChangedEvents : bool with get
override RaisesItemChangedEvents : bool with get

Property Value

Type: Boolean

Implements

IRaiseItemChangedEventsRaisesItemChangedEvents
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).SortDirection Property

NotifyListTSortDirection Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListSortDirection SortDirection { get; }
Public ReadOnly Property SortDirection As ListSortDirection
    Get
public:
virtual property ListSortDirection SortDirection {
    ListSortDirection get () sealed;
}
abstract SortDirection : ListSortDirection with get
override SortDirection : ListSortDirection with get

Property Value

Type: ListSortDirection

Implements

IBindingListSortDirection
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).SortProperty Property

NotifyListTSortProperty Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyDescriptor SortProperty { get; }
Public ReadOnly Property SortProperty As PropertyDescriptor
    Get
public:
virtual property PropertyDescriptor^ SortProperty {
    PropertyDescriptor^ get () sealed;
}
abstract SortProperty : PropertyDescriptor with get
override SortProperty : PropertyDescriptor with get

Property Value

Type: PropertyDescriptor

Implements

IBindingListSortProperty
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).SupportsChangeNotification Property

NotifyListTSupportsChangeNotification Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsChangeNotification { get; }
Public ReadOnly Property SupportsChangeNotification As Boolean
    Get
public:
virtual property bool SupportsChangeNotification {
    bool get () sealed;
}
abstract SupportsChangeNotification : bool with get
override SupportsChangeNotification : bool with get

Property Value

Type: Boolean

Implements

IBindingListSupportsChangeNotification
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).SupportsSearching Property

NotifyListTSupportsSearching Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsSearching { get; }
Public ReadOnly Property SupportsSearching As Boolean
    Get
public:
virtual property bool SupportsSearching {
    bool get () sealed;
}
abstract SupportsSearching : bool with get
override SupportsSearching : bool with get

Property Value

Type: Boolean

Implements

IBindingListSupportsSearching
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).SupportsSorting Property

NotifyListTSupportsSorting Property
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsSorting { get; }
Public ReadOnly Property SupportsSorting As Boolean
    Get
public:
virtual property bool SupportsSorting {
    bool get () sealed;
}
abstract SupportsSorting : bool with get
override SupportsSorting : bool with get

Property Value

Type: Boolean

Implements

IBindingListSupportsSorting
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T) Methods

NotifyListT Methods

The NotifyListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection T .)
Public method | AddIndex | Not implemented.
Public method | AddNew | See interface docs.
Public method | ApplySort | Not implemented.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection T .)
Protected method | ClearItems | See base docs. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection T .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Not implemented.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection T .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection T .)
Protected method | InsertItem | See base docs. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Called when the underlying collection is changed. (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnListChanged | Raises ListChanged.
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection T .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection T .)
Public method | RemoveIndex | Not implemented.
Protected method | RemoveItem | See base docs. (Overrides ObservableCollectionTRemoveItem(Int32).)
Public method | RemoveSort | Not implemented.
Protected method | SetItem | See base docs. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsListT | Obtains the data as a list; if it is *already* a list, the original object is returned without any duplication; otherwise, ToList() is invoked. (Defined by SqlMapper.)
Public Extension Method | HasSameContentAs | Returns true if two ILists have the same content. (Defined by IListExtensions.)
Top
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).AddIndex Method

NotifyListTAddIndex Method
Not implemented.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddIndex(
    PropertyDescriptor property
)
Public Sub AddIndex (
    property As PropertyDescriptor
)
public:
virtual void AddIndex(
    PropertyDescriptor^ property
) sealed
abstract AddIndex :
        property : PropertyDescriptor -> unit
override AddIndex :
        property : PropertyDescriptor -> unit

Parameters

property
Type: System.ComponentModelPropertyDescriptor

Implements

IBindingListAddIndex(PropertyDescriptor)
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).AddNew Method

NotifyListTAddNew Method
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object AddNew()
Public Function AddNew As Object
public:
virtual Object^ AddNew() sealed
abstract AddNew : unit -> Object
override AddNew : unit -> Object

Return Value

Type: Object

Implements

IBindingListAddNew
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).ApplySort Method

NotifyListTApplySort Method
Not implemented.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplySort(
    PropertyDescriptor property,
    ListSortDirection direction
)
Public Sub ApplySort (
    property As PropertyDescriptor,
    direction As ListSortDirection
)
public:
virtual void ApplySort(
    PropertyDescriptor^ property,
    ListSortDirection direction
) sealed
abstract ApplySort :
        property : PropertyDescriptor *
        direction : ListSortDirection -> unit
override ApplySort :
        property : PropertyDescriptor *
        direction : ListSortDirection -> unit

Parameters

property
Type: System.ComponentModelPropertyDescriptor
direction
Type: System.ComponentModelListSortDirection

Implements

IBindingListApplySort(PropertyDescriptor, ListSortDirection)
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).ClearItems Method

NotifyListTClearItems Method
See base docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
protected:
virtual void ClearItems() override
abstract ClearItems : unit -> unit
override ClearItems : unit -> unit
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).Find Method

NotifyListTFind Method
Not implemented.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Find(
    PropertyDescriptor property,
    Object key
)
Public Function Find (
    property As PropertyDescriptor,
    key As Object
) As Integer
public:
virtual int Find(
    PropertyDescriptor^ property,
    Object^ key
) sealed
abstract Find :
        property : PropertyDescriptor *
        key : Object -> int
override Find :
        property : PropertyDescriptor *
        key : Object -> int

Parameters

property
Type: System.ComponentModelPropertyDescriptor
key
Type: SystemObject

Return Value

Type: Int32

Implements

IBindingListFind(PropertyDescriptor, Object)
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).InsertItem Method

NotifyListTInsertItem Method
See base docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)
protected:
virtual void InsertItem(
    int index,
    T item
) override
abstract InsertItem :
        index : int *
        item : 'T -> unit
override InsertItem :
        index : int *
        item : 'T -> unit

Parameters

index
Type: SystemInt32
item
Type: T
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).OnCollectionChanged Method

NotifyListTOnCollectionChanged Method
Called when the underlying collection is changed.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overrides Sub OnCollectionChanged (
    e As NotifyCollectionChangedEventArgs
)
protected:
virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs^ e
) override
abstract OnCollectionChanged :
        e : NotifyCollectionChangedEventArgs -> unit
override OnCollectionChanged :
        e : NotifyCollectionChangedEventArgs -> unit

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).OnListChanged Method

NotifyListTOnListChanged Method
Raises ListChanged.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnListChanged(
    ListChangedEventArgs args
)
Protected Overridable Sub OnListChanged (
    args As ListChangedEventArgs
)
protected:
virtual void OnListChanged(
    ListChangedEventArgs^ args
)
abstract OnListChanged :
        args : ListChangedEventArgs -> unit
override OnListChanged :
        args : ListChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelListChangedEventArgs
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).RemoveIndex Method

NotifyListTRemoveIndex Method
Not implemented.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveIndex(
    PropertyDescriptor property
)
Public Sub RemoveIndex (
    property As PropertyDescriptor
)
public:
virtual void RemoveIndex(
    PropertyDescriptor^ property
) sealed
abstract RemoveIndex :
        property : PropertyDescriptor -> unit
override RemoveIndex :
        property : PropertyDescriptor -> unit

Parameters

property
Type: System.ComponentModelPropertyDescriptor

Implements

IBindingListRemoveIndex(PropertyDescriptor)
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).RemoveItem Method

NotifyListTRemoveItem Method
See base docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
protected:
virtual void RemoveItem(
    int index
) override
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit

Parameters

index
Type: SystemInt32
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).RemoveSort Method

NotifyListTRemoveSort Method
Not implemented.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSort()
Public Sub RemoveSort
public:
virtual void RemoveSort() sealed
abstract RemoveSort : unit -> unit
override RemoveSort : unit -> unit

Implements

IBindingListRemoveSort
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).SetItem Method

NotifyListTSetItem Method
See base docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)
protected:
virtual void SetItem(
    int index,
    T item
) override
abstract SetItem :
        index : int *
        item : 'T -> unit
override SetItem :
        index : int *
        item : 'T -> unit

Parameters

index
Type: SystemInt32
item
Type: T
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T) Events

NotifyListT Events

The NotifyListT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection T .)
Public event | ListChanged | See interface docs.
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection T .)
Top
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


NotifyList(T).ListChanged Event

NotifyListTListChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.PortableBinding
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ListChangedEventHandler ListChanged
Public Event ListChanged As ListChangedEventHandler
public:
virtual  event ListChangedEventHandler^ ListChanged {
    void add (ListChangedEventHandler^ value);
    void remove (ListChangedEventHandler^ value);
}
abstract ListChanged : IEvent<ListChangedEventHandler,
    ListChangedEventArgs>
override ListChanged : IEvent<ListChangedEventHandler,
    ListChangedEventArgs>

Value

Type: System.ComponentModelListChangedEventHandler

Implements

IBindingListListChanged
See Also

Reference

NotifyListT Class
VirtualRadar.Interface.PortableBinding Namespace


VirtualRadar.Interface.Presenter Namespace

VirtualRadar.Interface.Presenter Namespace
The namespace for all of the interfaces for user interface presenters.
Interfaces
 | Interface | Description
Public interface | IAboutPresenter | The presenter for the About view.
Public interface | IAircraftOnlineLookupLogPresenter | The presenter that controls IAircraftOnlineLookupLogView.
Public interface | IBackgroundThreadQueuesPresenter | The interface for presenters that can manage an IBackgroundThreadQueuesView.
Public interface | ICidrEditPresenter | The interface for objects that hold the business logic behind CIDR editors.
Public interface | IConnectionClientLogPresenter | The interface for objects that can control an IConnectionClientLogView.
Public interface | IConnectionClientLogPresenterProvider | The interface for objects that abstract away the environment and background thread work for IConnectionClientLogPresenter.
Public interface | IConnectionSessionLogPresenter | The interface for objects that can control an IConnectionSessionLogView.
Public interface | IConnectorActivityLogPresenter | The interface for presenters that control IConnectorActivityLogView views.
Public interface | IDownloadDataPresenter | The interface for objects that can control an IDownloadDataView.
Public interface | IFlightSimulatorXPresenter | The interface for objects that can control IFlightSimulatorXView views.
Public interface | IFlightSimulatorXPresenterProvider | The interface for objects that abstract away the environment for IFlightSimulatorXPresenters.
Public interface | IInvalidPluginsPresenter | The presenter for objects that can control an IInvalidPluginsView.
Public interface | IMainPresenter | The presenter for the main view that the user is shown when the application begins.
Public interface | IPluginsPresenter | The interface for objects that can present information about plugins via an IPluginsView.
Public interface | IPresenterT | The base interface that all presenters must implement.
Public interface | IRebroadcastOptionsPresenter | The interface that all presenters of IRebroadcastOptionsViews must implement.
Public interface | IReceiverLocationsPresenter | The interface for the presenter that controls the editing of receiver locations.
Public interface | ISettingsPresenter | The interface for objects that provide the business logic for ISettingsView views.
Public interface | ISettingsPresenterProvider | The interface for objects that abstract away the environment for ISettingsPresenter tests.
Public interface | IShutdownPresenter | The interface for presenters that control IShutdownView views. These objects are responsible for disposing of singletons and other objects as the application closes down.
Public interface | ISplashPresenter | The interface for objects that control the initial splash screen.
Public interface | ISplashPresenterProvider | The interface for objects that abstract away the environment for testing purposes.
Public interface | IStatisticsPresenter | The interface for presenters that can control an IStatisticsView.
Remarks

Virtual Radar Server follows the MVP pattern for user interface screens. This interface holds the descriptions of the presenters. Typically the view creates the presenter as a private field when it's created and then calls the presenter's Initialise method when the view is fully-formed, after which the presenter tends to take over and drive the view. The more interesting presenters are probably ISplashPresenter, which controls the initialisation of the application's main objects while the splash screen is shown, the IMainPresenter which controls the main view while the application is running and IShutdownPresenter which disposes of the application's main objects during a controlled shutdown of the program.


IAboutPresenter Interface

IAboutPresenter Interface
The presenter for the About view.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAboutPresenter : IPresenter<IAboutView>
Public Interface IAboutPresenter
    Inherits IPresenter(Of IAboutView)
public interface class IAboutPresenter : IPresenter<IAboutView^>
type IAboutPresenter =
    interface
        interface IPresenter<IAboutView>
    end

The IAboutPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IAboutPresenter Methods

IAboutPresenter Methods

The IAboutPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IAboutPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IAircraftOnlineLookupLogPresenter Interface

IAircraftOnlineLookupLogPresenter Interface
The presenter that controls IAircraftOnlineLookupLogView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookupLogPresenter : IPresenter<IAircraftOnlineLookupLogView>,
    IDisposable
Public Interface IAircraftOnlineLookupLogPresenter
    Inherits IPresenter(Of IAircraftOnlineLookupLogView), IDisposable
public interface class IAircraftOnlineLookupLogPresenter : IPresenter<IAircraftOnlineLookupLogView^>,
    IDisposable
type IAircraftOnlineLookupLogPresenter =
    interface
        interface IPresenter<IAircraftOnlineLookupLogView>
        interface IDisposable
    end

The IAircraftOnlineLookupLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IAircraftOnlineLookupLogPresenter Methods

IAircraftOnlineLookupLogPresenter Methods

The IAircraftOnlineLookupLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IAircraftOnlineLookupLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IBackgroundThreadQueuesPresenter Interface

IBackgroundThreadQueuesPresenter Interface
The interface for presenters that can manage an IBackgroundThreadQueuesView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundThreadQueuesPresenter : IPresenter<IBackgroundThreadQueuesView>,
    IDisposable
Public Interface IBackgroundThreadQueuesPresenter
    Inherits IPresenter(Of IBackgroundThreadQueuesView), IDisposable
public interface class IBackgroundThreadQueuesPresenter : IPresenter<IBackgroundThreadQueuesView^>,
    IDisposable
type IBackgroundThreadQueuesPresenter =
    interface
        interface IPresenter<IBackgroundThreadQueuesView>
        interface IDisposable
    end

The IBackgroundThreadQueuesPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IBackgroundThreadQueuesPresenter Methods

IBackgroundThreadQueuesPresenter Methods

The IBackgroundThreadQueuesPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IBackgroundThreadQueuesPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ICidrEditPresenter Interface

ICidrEditPresenter Interface
The interface for objects that hold the business logic behind CIDR editors.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICidrEditPresenter : IPresenter<ICidrEditView>
Public Interface ICidrEditPresenter
    Inherits IPresenter(Of ICidrEditView)
public interface class ICidrEditPresenter : IPresenter<ICidrEditView^>
type ICidrEditPresenter =
    interface
        interface IPresenter<ICidrEditView>
    end

The ICidrEditPresenter type exposes the following members.

Properties
 | Name | Description
Public property | CidrIsValid | Gets a value indicating that the CIDR on the view is valid.
Top
Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


ICidrEditPresenter Properties

ICidrEditPresenter Properties

The ICidrEditPresenter type exposes the following members.

Properties
 | Name | Description
Public property | CidrIsValid | Gets a value indicating that the CIDR on the view is valid.
Top
See Also

Reference

ICidrEditPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ICidrEditPresenter.CidrIsValid Property

ICidrEditPresenterCidrIsValid Property
Gets a value indicating that the CIDR on the view is valid.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CidrIsValid { get; }
ReadOnly Property CidrIsValid As Boolean
    Get
property bool CidrIsValid {
    bool get ();
}
abstract CidrIsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

ICidrEditPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ICidrEditPresenter Methods

ICidrEditPresenter Methods

The ICidrEditPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

ICidrEditPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenter Interface

IConnectionClientLogPresenter Interface
The interface for objects that can control an IConnectionClientLogView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionClientLogPresenter : IPresenter<IConnectionClientLogView>
Public Interface IConnectionClientLogPresenter
    Inherits IPresenter(Of IConnectionClientLogView)
public interface class IConnectionClientLogPresenter : IPresenter<IConnectionClientLogView^>
type IConnectionClientLogPresenter =
    interface
        interface IPresenter<IConnectionClientLogView>
    end

The IConnectionClientLogPresenter type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing purposes.
Top
Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenter Properties

IConnectionClientLogPresenter Properties

The IConnectionClientLogPresenter type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing purposes.
Top
See Also

Reference

IConnectionClientLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenter.Provider Property

IConnectionClientLogPresenterProvider Property
Gets or sets the object that abstracts away the environment for testing purposes.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnectionClientLogPresenterProvider Provider { get; set; }
Property Provider As IConnectionClientLogPresenterProvider
    Get
    Set
property IConnectionClientLogPresenterProvider^ Provider {
    IConnectionClientLogPresenterProvider^ get ();
    void set (IConnectionClientLogPresenterProvider^ value);
}
abstract Provider : IConnectionClientLogPresenterProvider with get, set

Property Value

Type: IConnectionClientLogPresenterProvider
See Also

Reference

IConnectionClientLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenter Methods

IConnectionClientLogPresenter Methods

The IConnectionClientLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IConnectionClientLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenterProvider Interface

IConnectionClientLogPresenterProvider Interface
The interface for objects that abstract away the environment and background thread work for IConnectionClientLogPresenter.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionClientLogPresenterProvider
Public Interface IConnectionClientLogPresenterProvider
public interface class IConnectionClientLogPresenterProvider
type IConnectionClientLogPresenterProvider =  interface end

The IConnectionClientLogPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | InvokeOnBackgroundThread | Invokes the callback passed across on a background thread.
Public method | LookupReverseDns | Performs a reverse DNS lookup on the IP address passed across.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenterProvider Methods

IConnectionClientLogPresenterProvider Methods

The IConnectionClientLogPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | InvokeOnBackgroundThread | Invokes the callback passed across on a background thread.
Public method | LookupReverseDns | Performs a reverse DNS lookup on the IP address passed across.
Top
See Also

Reference

IConnectionClientLogPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenterProvider.InvokeOnBackgroundThread Method

IConnectionClientLogPresenterProviderInvokeOnBackgroundThread Method
Invokes the callback passed across on a background thread.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InvokeOnBackgroundThread(
    Action<IList<LogClient>> callbackMethod,
    IList<LogClient> lookupClients
)
Sub InvokeOnBackgroundThread (
    callbackMethod As Action(Of IList(Of LogClient)),
    lookupClients As IList(Of LogClient)
)
void InvokeOnBackgroundThread(
    Action<IList<LogClient^>^>^ callbackMethod,
    IList<LogClient^>^ lookupClients
)
abstract InvokeOnBackgroundThread :
        callbackMethod : Action<IList<LogClient>> *
        lookupClients : IList<LogClient> -> unit

Parameters

callbackMethod
Type: SystemAction IList LogClient
lookupClients
Type: System.Collections.GenericIList LogClient
See Also

Reference

IConnectionClientLogPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionClientLogPresenterProvider.LookupReverseDns Method

IConnectionClientLogPresenterProviderLookupReverseDns Method
Performs a reverse DNS lookup on the IP address passed across.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string LookupReverseDns(
    IPAddress ipAddress
)
Function LookupReverseDns (
    ipAddress As IPAddress
) As String
String^ LookupReverseDns(
    IPAddress^ ipAddress
)
abstract LookupReverseDns :
        ipAddress : IPAddress -> string

Parameters

ipAddress
Type: System.NetIPAddress

Return Value

Type: String
See Also

Reference

IConnectionClientLogPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IConnectionSessionLogPresenter Interface

IConnectionSessionLogPresenter Interface
The interface for objects that can control an IConnectionSessionLogView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionSessionLogPresenter : IPresenter<IConnectionSessionLogView>
Public Interface IConnectionSessionLogPresenter
    Inherits IPresenter(Of IConnectionSessionLogView)
public interface class IConnectionSessionLogPresenter : IPresenter<IConnectionSessionLogView^>
type IConnectionSessionLogPresenter =
    interface
        interface IPresenter<IConnectionSessionLogView>
    end

The IConnectionSessionLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IConnectionSessionLogPresenter Methods

IConnectionSessionLogPresenter Methods

The IConnectionSessionLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IConnectionSessionLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectorActivityLogPresenter Interface

IConnectorActivityLogPresenter Interface
The interface for presenters that control IConnectorActivityLogView views.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectorActivityLogPresenter : IPresenter<IConnectorActivityLogView>
Public Interface IConnectorActivityLogPresenter
    Inherits IPresenter(Of IConnectorActivityLogView)
public interface class IConnectorActivityLogPresenter : IPresenter<IConnectorActivityLogView^>
type IConnectorActivityLogPresenter =
    interface
        interface IPresenter<IConnectorActivityLogView>
    end

The IConnectorActivityLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | FormatDetailText | Returns the text for the display of a single activity.
Public method | FormatDetailTitle | Returns the title for the display of a single activity.
Public method | FormatTime | Returns the formatted value of a UTC time.
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IConnectorActivityLogPresenter Methods

IConnectorActivityLogPresenter Methods

The IConnectorActivityLogPresenter type exposes the following members.

Methods
 | Name | Description
Public method | FormatDetailText | Returns the text for the display of a single activity.
Public method | FormatDetailTitle | Returns the title for the display of a single activity.
Public method | FormatTime | Returns the formatted value of a UTC time.
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IConnectorActivityLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectorActivityLogPresenter.FormatDetailText Method

IConnectorActivityLogPresenterFormatDetailText Method
Returns the text for the display of a single activity.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FormatDetailText(
    ConnectorActivityEvent activity
)
Function FormatDetailText (
    activity As ConnectorActivityEvent
) As String
String^ FormatDetailText(
    ConnectorActivityEvent^ activity
)
abstract FormatDetailText :
        activity : ConnectorActivityEvent -> string

Parameters

activity
Type: VirtualRadar.Interface.NetworkConnectorActivityEvent

Return Value

Type: String
See Also

Reference

IConnectorActivityLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectorActivityLogPresenter.FormatDetailTitle Method

IConnectorActivityLogPresenterFormatDetailTitle Method
Returns the title for the display of a single activity.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FormatDetailTitle(
    ConnectorActivityEvent activity
)
Function FormatDetailTitle (
    activity As ConnectorActivityEvent
) As String
String^ FormatDetailTitle(
    ConnectorActivityEvent^ activity
)
abstract FormatDetailTitle :
        activity : ConnectorActivityEvent -> string

Parameters

activity
Type: VirtualRadar.Interface.NetworkConnectorActivityEvent

Return Value

Type: String
See Also

Reference

IConnectorActivityLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IConnectorActivityLogPresenter.FormatTime Method

IConnectorActivityLogPresenterFormatTime Method
Returns the formatted value of a UTC time.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FormatTime(
    DateTime utcTime
)
Function FormatTime (
    utcTime As DateTime
) As String
String^ FormatTime(
    DateTime utcTime
)
abstract FormatTime :
        utcTime : DateTime -> string

Parameters

utcTime
Type: SystemDateTime

Return Value

Type: String
See Also

Reference

IConnectorActivityLogPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IDownloadDataPresenter Interface

IDownloadDataPresenter Interface
The interface for objects that can control an IDownloadDataView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDownloadDataPresenter : IPresenter<IDownloadDataView>
Public Interface IDownloadDataPresenter
    Inherits IPresenter(Of IDownloadDataView)
public interface class IDownloadDataPresenter : IPresenter<IDownloadDataView^>
type IDownloadDataPresenter =
    interface
        interface IPresenter<IDownloadDataView>
    end

The IDownloadDataPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IDownloadDataPresenter Methods

IDownloadDataPresenter Methods

The IDownloadDataPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IDownloadDataPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter Interface

IFlightSimulatorXPresenter Interface
The interface for objects that can control IFlightSimulatorXView views.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFlightSimulatorXPresenter : IPresenter<IFlightSimulatorXView>,
    IDisposable
Public Interface IFlightSimulatorXPresenter
    Inherits IPresenter(Of IFlightSimulatorXView), IDisposable
public interface class IFlightSimulatorXPresenter : IPresenter<IFlightSimulatorXView^>,
    IDisposable
type IFlightSimulatorXPresenter =
    interface
        interface IPresenter<IFlightSimulatorXView>
        interface IDisposable
    end

The IFlightSimulatorXPresenter type exposes the following members.

Properties
 | Name | Description
Public property | FlightSimulatorAircraftList | Gets or sets the object that will be modified by the presenter to record the simulated aircraft in FSX.
Public property | Provider | Gets or sets the provider that will abstract away the environment for the provider to make it easier to test.
Public property | WebServer | Gets or sets the web server that the view will show a link to.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | IsSimConnectMessage | Returns true if the message passed across is intended for SimConnect (i.e. it's a Flight Simulator X message). If it is then the view should not process it.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter Properties

IFlightSimulatorXPresenter Properties

The IFlightSimulatorXPresenter type exposes the following members.

Properties
 | Name | Description
Public property | FlightSimulatorAircraftList | Gets or sets the object that will be modified by the presenter to record the simulated aircraft in FSX.
Public property | Provider | Gets or sets the provider that will abstract away the environment for the provider to make it easier to test.
Public property | WebServer | Gets or sets the web server that the view will show a link to.
Top
See Also

Reference

IFlightSimulatorXPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter.FlightSimulatorAircraftList Property

IFlightSimulatorXPresenterFlightSimulatorAircraftList Property
Gets or sets the object that will be modified by the presenter to record the simulated aircraft in FSX.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISimpleAircraftList FlightSimulatorAircraftList { get; set; }
Property FlightSimulatorAircraftList As ISimpleAircraftList
    Get
    Set
property ISimpleAircraftList^ FlightSimulatorAircraftList {
    ISimpleAircraftList^ get ();
    void set (ISimpleAircraftList^ value);
}
abstract FlightSimulatorAircraftList : ISimpleAircraftList with get, set

Property Value

Type: ISimpleAircraftList
See Also

Reference

IFlightSimulatorXPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter.Provider Property

IFlightSimulatorXPresenterProvider Property
Gets or sets the provider that will abstract away the environment for the provider to make it easier to test.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFlightSimulatorXPresenterProvider Provider { get; set; }
Property Provider As IFlightSimulatorXPresenterProvider
    Get
    Set
property IFlightSimulatorXPresenterProvider^ Provider {
    IFlightSimulatorXPresenterProvider^ get ();
    void set (IFlightSimulatorXPresenterProvider^ value);
}
abstract Provider : IFlightSimulatorXPresenterProvider with get, set

Property Value

Type: IFlightSimulatorXPresenterProvider
See Also

Reference

IFlightSimulatorXPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter.WebServer Property

IFlightSimulatorXPresenterWebServer Property
Gets or sets the web server that the view will show a link to.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServer WebServer { get; set; }
Property WebServer As IWebServer
    Get
    Set
property IWebServer^ WebServer {
    IWebServer^ get ();
    void set (IWebServer^ value);
}
abstract WebServer : IWebServer with get, set

Property Value

Type: IWebServer
See Also

Reference

IFlightSimulatorXPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter Methods

IFlightSimulatorXPresenter Methods

The IFlightSimulatorXPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | IsSimConnectMessage | Returns true if the message passed across is intended for SimConnect (i.e. it's a Flight Simulator X message). If it is then the view should not process it.
Top
See Also

Reference

IFlightSimulatorXPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenter.IsSimConnectMessage Method

IFlightSimulatorXPresenterIsSimConnectMessage Method
Returns true if the message passed across is intended for SimConnect (i.e. it's a Flight Simulator X message). If it is then the view should not process it.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSimConnectMessage(
    Message message
)
Function IsSimConnectMessage (
    message As Message
) As Boolean
bool IsSimConnectMessage(
    Message message
)
abstract IsSimConnectMessage :
        message : Message -> bool

Parameters

message
Type: System.Windows.FormsMessage

Return Value

Type: Boolean
See Also

Reference

IFlightSimulatorXPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenterProvider Interface

IFlightSimulatorXPresenterProvider Interface
The interface for objects that abstract away the environment for IFlightSimulatorXPresenters.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFlightSimulatorXPresenterProvider
Public Interface IFlightSimulatorXPresenterProvider
public interface class IFlightSimulatorXPresenterProvider
type IFlightSimulatorXPresenterProvider =  interface end

The IFlightSimulatorXPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | TimedInvokeOnBackgroundThread | Invoke the callback on a background thread after a non-blocking pause of so-many milliseconds.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenterProvider Methods

IFlightSimulatorXPresenterProvider Methods

The IFlightSimulatorXPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | TimedInvokeOnBackgroundThread | Invoke the callback on a background thread after a non-blocking pause of so-many milliseconds.
Top
See Also

Reference

IFlightSimulatorXPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IFlightSimulatorXPresenterProvider.TimedInvokeOnBackgroundThread Method

IFlightSimulatorXPresenterProviderTimedInvokeOnBackgroundThread Method
Invoke the callback on a background thread after a non-blocking pause of so-many milliseconds.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TimedInvokeOnBackgroundThread(
    Action callback,
    int milliseconds
)
Sub TimedInvokeOnBackgroundThread (
    callback As Action,
    milliseconds As Integer
)
void TimedInvokeOnBackgroundThread(
    Action^ callback,
    int milliseconds
)
abstract TimedInvokeOnBackgroundThread :
        callback : Action *
        milliseconds : int -> unit

Parameters

callback
Type: SystemAction
milliseconds
Type: SystemInt32
See Also

Reference

IFlightSimulatorXPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IInvalidPluginsPresenter Interface

IInvalidPluginsPresenter Interface
The presenter for objects that can control an IInvalidPluginsView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IInvalidPluginsPresenter : IPresenter<IInvalidPluginsView>
Public Interface IInvalidPluginsPresenter
    Inherits IPresenter(Of IInvalidPluginsView)
public interface class IInvalidPluginsPresenter : IPresenter<IInvalidPluginsView^>
type IInvalidPluginsPresenter =
    interface
        interface IPresenter<IInvalidPluginsView>
    end

The IInvalidPluginsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IInvalidPluginsPresenter Methods

IInvalidPluginsPresenter Methods

The IInvalidPluginsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IInvalidPluginsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IMainPresenter Interface

IMainPresenter Interface
The presenter for the main view that the user is shown when the application begins.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMainPresenter : IPresenter<IMainView>
Public Interface IMainPresenter
    Inherits IPresenter(Of IMainView)
public interface class IMainPresenter : IPresenter<IMainView^>
type IMainPresenter =
    interface
        interface IPresenter<IMainView>
    end

The IMainPresenter type exposes the following members.

Properties
 | Name | Description
Public property | UPnpManager | Gets or sets the object that controls the UPnP router on the application's behalf.
Public property | View | Gets the view that created the presenter, and which is being controlled by the presenter.
Top
Methods
 | Name | Description
Public method | GetFeedConfigurationObject | Returns the configuration object associated with a feed ID. Could be either a receiver or a merged feed configuration object.
Public method | GetReceiverFeeds | Returns an array of receiver feeds. Merged feeds are not included.
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IMainPresenter Properties

IMainPresenter Properties

The IMainPresenter type exposes the following members.

Properties
 | Name | Description
Public property | UPnpManager | Gets or sets the object that controls the UPnP router on the application's behalf.
Public property | View | Gets the view that created the presenter, and which is being controlled by the presenter.
Top
See Also

Reference

IMainPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IMainPresenter.UPnpManager Property

IMainPresenterUPnpManager Property
Gets or sets the object that controls the UPnP router on the application's behalf.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IUniversalPlugAndPlayManager UPnpManager { get; set; }
Property UPnpManager As IUniversalPlugAndPlayManager
    Get
    Set
property IUniversalPlugAndPlayManager^ UPnpManager {
    IUniversalPlugAndPlayManager^ get ();
    void set (IUniversalPlugAndPlayManager^ value);
}
abstract UPnpManager : IUniversalPlugAndPlayManager with get, set

Property Value

Type: IUniversalPlugAndPlayManager
See Also

Reference

IMainPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IMainPresenter.View Property

IMainPresenterView Property
Gets the view that created the presenter, and which is being controlled by the presenter.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IMainView View { get; }
ReadOnly Property View As IMainView
    Get
property IMainView^ View {
    IMainView^ get ();
}
abstract View : IMainView with get

Property Value

Type: IMainView
See Also

Reference

IMainPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IMainPresenter Methods

IMainPresenter Methods

The IMainPresenter type exposes the following members.

Methods
 | Name | Description
Public method | GetFeedConfigurationObject | Returns the configuration object associated with a feed ID. Could be either a receiver or a merged feed configuration object.
Public method | GetReceiverFeeds | Returns an array of receiver feeds. Merged feeds are not included.
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IMainPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IMainPresenter.GetFeedConfigurationObject Method

IMainPresenterGetFeedConfigurationObject Method
Returns the configuration object associated with a feed ID. Could be either a receiver or a merged feed configuration object.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object GetFeedConfigurationObject(
    int feedId
)
Function GetFeedConfigurationObject (
    feedId As Integer
) As Object
Object^ GetFeedConfigurationObject(
    int feedId
)
abstract GetFeedConfigurationObject :
        feedId : int -> Object

Parameters

feedId
Type: SystemInt32

Return Value

Type: Object
See Also

Reference

IMainPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IMainPresenter.GetReceiverFeeds Method

IMainPresenterGetReceiverFeeds Method
Returns an array of receiver feeds. Merged feeds are not included.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IFeed[] GetReceiverFeeds()
Function GetReceiverFeeds As IFeed()
array<IFeed^>^ GetReceiverFeeds()
abstract GetReceiverFeeds : unit -> IFeed[]

Return Value

Type: IFeed
See Also

Reference

IMainPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IPluginsPresenter Interface

IPluginsPresenter Interface
The interface for objects that can present information about plugins via an IPluginsView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginsPresenter
Public Interface IPluginsPresenter
public interface class IPluginsPresenter
type IPluginsPresenter =  interface end

The IPluginsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IPluginsPresenter Methods

IPluginsPresenter Methods

The IPluginsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view.
Top
See Also

Reference

IPluginsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IPluginsPresenter.Initialise Method

IPluginsPresenterInitialise Method
Initialises the view.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    IPluginsView view
)
Sub Initialise (
    view As IPluginsView
)
void Initialise(
    IPluginsView^ view
)
abstract Initialise :
        view : IPluginsView -> unit

Parameters

view
Type: VirtualRadar.Interface.ViewIPluginsView
See Also

Reference

IPluginsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IPresenter(T) Interface

IPresenterT Interface
The base interface that all presenters must implement.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPresenter<T>

Public Interface IPresenter(Of T)
generic<typename T>
public interface class IPresenter
type IPresenter<'T> =  interface end

Type Parameters

T
The interface type of the view that the presenter is controlling.

The IPresenterT type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IPresenter(T) Methods

IPresenterT Methods

The IPresenterT generic type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view.
Top
See Also

Reference

IPresenterT Interface
VirtualRadar.Interface.Presenter Namespace


IPresenter(T).Initialise Method

IPresenterTInitialise Method
Initialises the view.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    T view
)
Sub Initialise (
    view As T
)
void Initialise(
    T view
)
abstract Initialise :
        view : 'T -> unit

Parameters

view
Type: T
See Also

Reference

IPresenterT Interface
VirtualRadar.Interface.Presenter Namespace


IRebroadcastOptionsPresenter Interface

IRebroadcastOptionsPresenter Interface
The interface that all presenters of IRebroadcastOptionsViews must implement.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRebroadcastOptionsPresenter : IPresenter<IRebroadcastOptionsView>
Public Interface IRebroadcastOptionsPresenter
    Inherits IPresenter(Of IRebroadcastOptionsView)
public interface class IRebroadcastOptionsPresenter : IPresenter<IRebroadcastOptionsView^>
type IRebroadcastOptionsPresenter =
    interface
        interface IPresenter<IRebroadcastOptionsView>
    end

The IRebroadcastOptionsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IRebroadcastOptionsPresenter Methods

IRebroadcastOptionsPresenter Methods

The IRebroadcastOptionsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IRebroadcastOptionsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IReceiverLocationsPresenter Interface

IReceiverLocationsPresenter Interface
The interface for the presenter that controls the editing of receiver locations.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReceiverLocationsPresenter : IPresenter<IReceiverLocationsView>
Public Interface IReceiverLocationsPresenter
    Inherits IPresenter(Of IReceiverLocationsView)
public interface class IReceiverLocationsPresenter : IPresenter<IReceiverLocationsView^>
type IReceiverLocationsPresenter =
    interface
        interface IPresenter<IReceiverLocationsView>
    end

The IReceiverLocationsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IReceiverLocationsPresenter Methods

IReceiverLocationsPresenter Methods

The IReceiverLocationsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IReceiverLocationsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter Interface

ISettingsPresenter Interface
The interface for objects that provide the business logic for ISettingsView views.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISettingsPresenter : IPresenter<ISettingsView>,
    IDisposable
Public Interface ISettingsPresenter
    Inherits IPresenter(Of ISettingsView), IDisposable
public interface class ISettingsPresenter : IPresenter<ISettingsView^>,
    IDisposable
type ISettingsPresenter =
    interface
        interface IPresenter<ISettingsView>
        interface IDisposable
    end

The ISettingsPresenter type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for the presenter.
Top
Methods
 | Name | Description
Public method | ApplyReceiverConfigurationWizard | Applies the answers from a receiver configuration wizard to the receiver passed across.
Public method | CreateMergedFeed | Creates a new merged feed. The object is not attached to the configuration being edited.
Public method | CreateRebroadcastServer | Creates a new rebroadcast server. The object is not attached to the configuration being edited.
Public method | CreateReceiver | Creates a new receiver. The receiver is not attached to the configuration being edited.
Public method | CreateReceiverLocation | Creates a new receiver location. The receiver location is not attached to the configuration being edited.
Public method | CreateUser | Creates a new user. The user is not attached to the configuration being edited.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetSerialPortNames | Returns a list of serial port names. Guaranteed not to throw an exception and to be current (i.e. no caching).
Public method | GetVoiceNames | Returns a collection of voice names. A voice name of null indicates the presence of a default voice.
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | ValidateView | Validates the current content of the entire form and reports the results back to the view.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter Properties

ISettingsPresenter Properties

The ISettingsPresenter type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for the presenter.
Top
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.Provider Property

ISettingsPresenterProvider Property
Gets or sets the object that abstracts away the environment for the presenter.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISettingsPresenterProvider Provider { get; set; }
Property Provider As ISettingsPresenterProvider
    Get
    Set
property ISettingsPresenterProvider^ Provider {
    ISettingsPresenterProvider^ get ();
    void set (ISettingsPresenterProvider^ value);
}
abstract Provider : ISettingsPresenterProvider with get, set

Property Value

Type: ISettingsPresenterProvider
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter Methods

ISettingsPresenter Methods

The ISettingsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | ApplyReceiverConfigurationWizard | Applies the answers from a receiver configuration wizard to the receiver passed across.
Public method | CreateMergedFeed | Creates a new merged feed. The object is not attached to the configuration being edited.
Public method | CreateRebroadcastServer | Creates a new rebroadcast server. The object is not attached to the configuration being edited.
Public method | CreateReceiver | Creates a new receiver. The receiver is not attached to the configuration being edited.
Public method | CreateReceiverLocation | Creates a new receiver location. The receiver location is not attached to the configuration being edited.
Public method | CreateUser | Creates a new user. The user is not attached to the configuration being edited.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetSerialPortNames | Returns a list of serial port names. Guaranteed not to throw an exception and to be current (i.e. no caching).
Public method | GetVoiceNames | Returns a collection of voice names. A voice name of null indicates the presence of a default voice.
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | ValidateView | Validates the current content of the entire form and reports the results back to the view.
Top
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.ApplyReceiverConfigurationWizard Method

ISettingsPresenterApplyReceiverConfigurationWizard Method
Applies the answers from a receiver configuration wizard to the receiver passed across.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyReceiverConfigurationWizard(
    IReceiverConfigurationWizardAnswers answers,
    Receiver receiver
)
Sub ApplyReceiverConfigurationWizard (
    answers As IReceiverConfigurationWizardAnswers,
    receiver As Receiver
)
void ApplyReceiverConfigurationWizard(
    IReceiverConfigurationWizardAnswers^ answers,
    Receiver^ receiver
)
abstract ApplyReceiverConfigurationWizard :
        answers : IReceiverConfigurationWizardAnswers *
        receiver : Receiver -> unit

Parameters

answers
Type: VirtualRadar.Interface.ViewIReceiverConfigurationWizardAnswers
receiver
Type: VirtualRadar.Interface.SettingsReceiver
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.CreateMergedFeed Method

ISettingsPresenterCreateMergedFeed Method
Creates a new merged feed. The object is not attached to the configuration being edited.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
MergedFeed CreateMergedFeed()
Function CreateMergedFeed As MergedFeed
MergedFeed^ CreateMergedFeed()
abstract CreateMergedFeed : unit -> MergedFeed

Return Value

Type: MergedFeed
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.CreateRebroadcastServer Method

ISettingsPresenterCreateRebroadcastServer Method
Creates a new rebroadcast server. The object is not attached to the configuration being edited.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RebroadcastSettings CreateRebroadcastServer()
Function CreateRebroadcastServer As RebroadcastSettings
RebroadcastSettings^ CreateRebroadcastServer()
abstract CreateRebroadcastServer : unit -> RebroadcastSettings

Return Value

Type: RebroadcastSettings
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.CreateReceiver Method

ISettingsPresenterCreateReceiver Method
Creates a new receiver. The receiver is not attached to the configuration being edited.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Receiver CreateReceiver()
Function CreateReceiver As Receiver
Receiver^ CreateReceiver()
abstract CreateReceiver : unit -> Receiver

Return Value

Type: Receiver
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.CreateReceiverLocation Method

ISettingsPresenterCreateReceiverLocation Method
Creates a new receiver location. The receiver location is not attached to the configuration being edited.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ReceiverLocation CreateReceiverLocation()
Function CreateReceiverLocation As ReceiverLocation
ReceiverLocation^ CreateReceiverLocation()
abstract CreateReceiverLocation : unit -> ReceiverLocation

Return Value

Type: ReceiverLocation
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.CreateUser Method

ISettingsPresenterCreateUser Method
Creates a new user. The user is not attached to the configuration being edited.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IUser CreateUser()
Function CreateUser As IUser
IUser^ CreateUser()
abstract CreateUser : unit -> IUser

Return Value

Type: IUser
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.GetSerialPortNames Method

ISettingsPresenterGetSerialPortNames Method
Returns a list of serial port names. Guaranteed not to throw an exception and to be current (i.e. no caching).

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetSerialPortNames()
Function GetSerialPortNames As IEnumerable(Of String)
IEnumerable<String^>^ GetSerialPortNames()
abstract GetSerialPortNames : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.GetVoiceNames Method

ISettingsPresenterGetVoiceNames Method
Returns a collection of voice names. A voice name of null indicates the presence of a default voice.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetVoiceNames()
Function GetVoiceNames As IEnumerable(Of String)
IEnumerable<String^>^ GetVoiceNames()
abstract GetVoiceNames : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenter.ValidateView Method

ISettingsPresenterValidateView Method
Validates the current content of the entire form and reports the results back to the view.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ValidateView()
Sub ValidateView
void ValidateView()
abstract ValidateView : unit -> unit
See Also

Reference

ISettingsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider Interface

ISettingsPresenterProvider Interface
The interface for objects that abstract away the environment for ISettingsPresenter tests.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISettingsPresenterProvider : IDisposable
Public Interface ISettingsPresenterProvider
    Inherits IDisposable
public interface class ISettingsPresenterProvider : IDisposable
type ISettingsPresenterProvider =
    interface
        interface IDisposable
    end

The ISettingsPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FileExists | Returns true if there is a file with the full path as passed.
Public method | FolderExists | Returns true if there is a folder with the path as passed.
Public method | GetSerialPortNames | Returns a list of serial port names. Guaranteed not to throw an exception and to be current (i.e. no caching).
Public method | GetVoiceNames | Returns a collection of voice names for the installed text-to-speech service. Guaranteed not to throw an exception and to be current (i.e. no caching).
Public method | TestNetworkConnection | Returns the exception (if any) that was thrown while attempting to establish a connection to a data feed using the network settings passed across.
Public method | TestSerialConnection | Returns the exception (if any) that was thrown while attempting to establish a connection to a data feed using the serial settings passed across.
Public method | TestTextToSpeech | Conducts a test of the text-to-speech settings passed across.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider Methods

ISettingsPresenterProvider Methods

The ISettingsPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FileExists | Returns true if there is a file with the full path as passed.
Public method | FolderExists | Returns true if there is a folder with the path as passed.
Public method | GetSerialPortNames | Returns a list of serial port names. Guaranteed not to throw an exception and to be current (i.e. no caching).
Public method | GetVoiceNames | Returns a collection of voice names for the installed text-to-speech service. Guaranteed not to throw an exception and to be current (i.e. no caching).
Public method | TestNetworkConnection | Returns the exception (if any) that was thrown while attempting to establish a connection to a data feed using the network settings passed across.
Public method | TestSerialConnection | Returns the exception (if any) that was thrown while attempting to establish a connection to a data feed using the serial settings passed across.
Public method | TestTextToSpeech | Conducts a test of the text-to-speech settings passed across.
Top
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.FileExists Method

ISettingsPresenterProviderFileExists Method
Returns true if there is a file with the full path as passed.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FileExists(
    string fileName
)
Function FileExists (
    fileName As String
) As Boolean
bool FileExists(
    String^ fileName
)
abstract FileExists :
        fileName : string -> bool

Parameters

fileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.FolderExists Method

ISettingsPresenterProviderFolderExists Method
Returns true if there is a folder with the path as passed.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FolderExists(
    string folder
)
Function FolderExists (
    folder As String
) As Boolean
bool FolderExists(
    String^ folder
)
abstract FolderExists :
        folder : string -> bool

Parameters

folder
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.GetSerialPortNames Method

ISettingsPresenterProviderGetSerialPortNames Method
Returns a list of serial port names. Guaranteed not to throw an exception and to be current (i.e. no caching).

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetSerialPortNames()
Function GetSerialPortNames As IEnumerable(Of String)
IEnumerable<String^>^ GetSerialPortNames()
abstract GetSerialPortNames : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.GetVoiceNames Method

ISettingsPresenterProviderGetVoiceNames Method
Returns a collection of voice names for the installed text-to-speech service. Guaranteed not to throw an exception and to be current (i.e. no caching).

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetVoiceNames()
Function GetVoiceNames As IEnumerable(Of String)
IEnumerable<String^>^ GetVoiceNames()
abstract GetVoiceNames : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.TestNetworkConnection Method

ISettingsPresenterProviderTestNetworkConnection Method
Returns the exception (if any) that was thrown while attempting to establish a connection to a data feed using the network settings passed across.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Exception TestNetworkConnection(
    string address,
    int port
)
Function TestNetworkConnection (
    address As String,
    port As Integer
) As Exception
Exception^ TestNetworkConnection(
    String^ address,
    int port
)
abstract TestNetworkConnection :
        address : string *
        port : int -> Exception

Parameters

address
Type: SystemString
port
Type: SystemInt32

Return Value

Type: Exception
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.TestSerialConnection Method

ISettingsPresenterProviderTestSerialConnection Method
Returns the exception (if any) that was thrown while attempting to establish a connection to a data feed using the serial settings passed across.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Exception TestSerialConnection(
    string comPort,
    int baudRate,
    int dataBits,
    StopBits stopBits,
    Parity parity,
    Handshake handShake
)
Function TestSerialConnection (
    comPort As String,
    baudRate As Integer,
    dataBits As Integer,
    stopBits As StopBits,
    parity As Parity,
    handShake As Handshake
) As Exception
Exception^ TestSerialConnection(
    String^ comPort,
    int baudRate,
    int dataBits,
    StopBits stopBits,
    Parity parity,
    Handshake handShake
)
abstract TestSerialConnection :
        comPort : string *
        baudRate : int *
        dataBits : int *
        stopBits : StopBits *
        parity : Parity *
        handShake : Handshake -> Exception

Parameters

comPort
Type: SystemString
baudRate
Type: SystemInt32
dataBits
Type: SystemInt32
stopBits
Type: System.IO.PortsStopBits
parity
Type: System.IO.PortsParity
handShake
Type: System.IO.PortsHandshake

Return Value

Type: Exception
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISettingsPresenterProvider.TestTextToSpeech Method

ISettingsPresenterProviderTestTextToSpeech Method
Conducts a test of the text-to-speech settings passed across.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TestTextToSpeech(
    string name,
    int rate
)
Sub TestTextToSpeech (
    name As String,
    rate As Integer
)
void TestTextToSpeech(
    String^ name,
    int rate
)
abstract TestTextToSpeech :
        name : string *
        rate : int -> unit

Parameters

name
Type: SystemString
rate
Type: SystemInt32
See Also

Reference

ISettingsPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IShutdownPresenter Interface

IShutdownPresenter Interface
The interface for presenters that control IShutdownView views. These objects are responsible for disposing of singletons and other objects as the application closes down.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IShutdownPresenter : IPresenter<IShutdownView>
Public Interface IShutdownPresenter
    Inherits IPresenter(Of IShutdownView)
public interface class IShutdownPresenter : IPresenter<IShutdownView^>
type IShutdownPresenter =
    interface
        interface IPresenter<IShutdownView>
    end

The IShutdownPresenter type exposes the following members.

Properties
 | Name | Description
Public property | UPnpManager | Gets or sets the UPnP Manager that the program had been using.
Top
Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | ShutdownApplication | Disposes of the objects used by the application, possibly called on a background thread.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IShutdownPresenter Properties

IShutdownPresenter Properties

The IShutdownPresenter type exposes the following members.

Properties
 | Name | Description
Public property | UPnpManager | Gets or sets the UPnP Manager that the program had been using.
Top
See Also

Reference

IShutdownPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IShutdownPresenter.UPnpManager Property

IShutdownPresenterUPnpManager Property
Gets or sets the UPnP Manager that the program had been using.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IUniversalPlugAndPlayManager UPnpManager { get; set; }
Property UPnpManager As IUniversalPlugAndPlayManager
    Get
    Set
property IUniversalPlugAndPlayManager^ UPnpManager {
    IUniversalPlugAndPlayManager^ get ();
    void set (IUniversalPlugAndPlayManager^ value);
}
abstract UPnpManager : IUniversalPlugAndPlayManager with get, set

Property Value

Type: IUniversalPlugAndPlayManager
See Also

Reference

IShutdownPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IShutdownPresenter Methods

IShutdownPresenter Methods

The IShutdownPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | ShutdownApplication | Disposes of the objects used by the application, possibly called on a background thread.
Top
See Also

Reference

IShutdownPresenter Interface
VirtualRadar.Interface.Presenter Namespace


IShutdownPresenter.ShutdownApplication Method

IShutdownPresenterShutdownApplication Method
Disposes of the objects used by the application, possibly called on a background thread.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShutdownApplication()
Sub ShutdownApplication
void ShutdownApplication()
abstract ShutdownApplication : unit -> unit
See Also

Reference

IShutdownPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenter Interface

ISplashPresenter Interface
The interface for objects that control the initial splash screen.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISplashPresenter : IPresenter<ISplashView>
Public Interface ISplashPresenter
    Inherits IPresenter(Of ISplashView)
public interface class ISplashPresenter : IPresenter<ISplashView^>
type ISplashPresenter =
    interface
        interface IPresenter<ISplashView>
    end

The ISplashPresenter type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundThreadExceptionHandler | Gets or sets the delegate that will be hooked up to the ExceptionCaught events for objects that implement IBackgroundThreadExceptionCatcher.
Public property | CommandLineArgs | Gets or sets the command-line arguments that were passed to the program on startup.
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Top
Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | StartApplication | Builds up the application, possibly on a background thread.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


ISplashPresenter Properties

ISplashPresenter Properties

The ISplashPresenter type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundThreadExceptionHandler | Gets or sets the delegate that will be hooked up to the ExceptionCaught events for objects that implement IBackgroundThreadExceptionCatcher.
Public property | CommandLineArgs | Gets or sets the command-line arguments that were passed to the program on startup.
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Top
See Also

Reference

ISplashPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenter.BackgroundThreadExceptionHandler Property

ISplashPresenterBackgroundThreadExceptionHandler Property
Gets or sets the delegate that will be hooked up to the ExceptionCaught events for objects that implement IBackgroundThreadExceptionCatcher.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
EventHandler<EventArgs<Exception>> BackgroundThreadExceptionHandler { get; set; }
Property BackgroundThreadExceptionHandler As EventHandler(Of EventArgs(Of Exception))
    Get
    Set
property EventHandler<EventArgs<Exception^>^>^ BackgroundThreadExceptionHandler {
    EventHandler<EventArgs<Exception^>^>^ get ();
    void set (EventHandler<EventArgs<Exception^>^>^ value);
}
abstract BackgroundThreadExceptionHandler : EventHandler<EventArgs<Exception>> with get, set

Property Value

Type: EventHandler EventArgs Exception
See Also

Reference

ISplashPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenter.CommandLineArgs Property

ISplashPresenterCommandLineArgs Property
Gets or sets the command-line arguments that were passed to the program on startup.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] CommandLineArgs { get; set; }
Property CommandLineArgs As String()
    Get
    Set
property array<String^>^ CommandLineArgs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract CommandLineArgs : string[] with get, set

Property Value

Type: String
See Also

Reference

ISplashPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenter.Provider Property

ISplashPresenterProvider Property
Gets or sets the object that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISplashPresenterProvider Provider { get; set; }
Property Provider As ISplashPresenterProvider
    Get
    Set
property ISplashPresenterProvider^ Provider {
    ISplashPresenterProvider^ get ();
    void set (ISplashPresenterProvider^ value);
}
abstract Provider : ISplashPresenterProvider with get, set

Property Value

Type: ISplashPresenterProvider
See Also

Reference

ISplashPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenter Methods

ISplashPresenter Methods

The ISplashPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Public method | StartApplication | Builds up the application, possibly on a background thread.
Top
See Also

Reference

ISplashPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenter.StartApplication Method

ISplashPresenterStartApplication Method
Builds up the application, possibly on a background thread.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartApplication()
Sub StartApplication
void StartApplication()
abstract StartApplication : unit -> unit
See Also

Reference

ISplashPresenter Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenterProvider Interface

ISplashPresenterProvider Interface
The interface for objects that abstract away the environment for testing purposes.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISplashPresenterProvider
Public Interface ISplashPresenterProvider
public interface class ISplashPresenterProvider
type ISplashPresenterProvider =  interface end

The ISplashPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | AbortApplication | Stops the application with error code 1.
Public method | FolderExists | Returns true if the folder passed across exists.
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


ISplashPresenterProvider Methods

ISplashPresenterProvider Methods

The ISplashPresenterProvider type exposes the following members.

Methods
 | Name | Description
Public method | AbortApplication | Stops the application with error code 1.
Public method | FolderExists | Returns true if the folder passed across exists.
Top
See Also

Reference

ISplashPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenterProvider.AbortApplication Method

ISplashPresenterProviderAbortApplication Method
Stops the application with error code 1.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AbortApplication()
Sub AbortApplication
void AbortApplication()
abstract AbortApplication : unit -> unit
See Also

Reference

ISplashPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


ISplashPresenterProvider.FolderExists Method

ISplashPresenterProviderFolderExists Method
Returns true if the folder passed across exists.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FolderExists(
    string folder
)
Function FolderExists (
    folder As String
) As Boolean
bool FolderExists(
    String^ folder
)
abstract FolderExists :
        folder : string -> bool

Parameters

folder
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ISplashPresenterProvider Interface
VirtualRadar.Interface.Presenter Namespace


IStatisticsPresenter Interface

IStatisticsPresenter Interface
The interface for presenters that can control an IStatisticsView.

Namespace: VirtualRadar.Interface.Presenter
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStatisticsPresenter : IPresenter<IStatisticsView>
Public Interface IStatisticsPresenter
    Inherits IPresenter(Of IStatisticsView)
public interface class IStatisticsPresenter : IPresenter<IStatisticsView^>
type IStatisticsPresenter =
    interface
        interface IPresenter<IStatisticsView>
    end

The IStatisticsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

VirtualRadar.Interface.Presenter Namespace


IStatisticsPresenter Methods

IStatisticsPresenter Methods

The IStatisticsPresenter type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Initialises the view. (Inherited from IPresenterT.)
Top
See Also

Reference

IStatisticsPresenter Interface
VirtualRadar.Interface.Presenter Namespace


VirtualRadar.Interface.Settings Namespace

VirtualRadar.Interface.Settings Namespace
The namespace for all of the interfaces and objects that deal with reading and writing configuration information.
Classes
 | Class | Description
Public class | Access | A class that holds access lists to Internet resources.
Public class | AudioSettings | Holds the configuration of the speech-to-audio features that the website can access.
Public class | BaseStationSettings | An object that describes the source of data we should connect to.
Public class | Configuration | An object that carries all of the configuration settings for the application.
Public class | ConfigurationListenerEventArgs | Carries information in events from IConfigurationListener.
Public class | ConflictingUpdateException | Thrown when an update conflicts with a previous update.
Public class | DataSource | A collection of strings describing the UniqueId values for the receiver formats that ship with VRS.
Public class | FlightRouteSettings | Holds the configuration pertaining to the handling of flight routes.
Public class | GoogleMapSettings | The web site configuration options (originally these were just Google Map settings but they expanded over time - unfortunately I can't change the class name without breaking backwards compatibility).
Public class | Hash | Describes a hashed password in the configuration.
Public class | InstallerSettings | The object for configuration settings that are created or overwritten by the installer.
Public class | InternetClientSettings | Settings that control how browsers on the Internet interact with the server.
Public class | MergedFeed | The configuration settings for a merged feed.
Public class | MergedFeedReceiver | Describes a receiver in a merged feed.
Public class | MonoSettings | Carries settings that are only used when VRS is loaded under Mono.
 | PluginManifest | A class that represents the content of a plugin manifest file.
 | PluginSettings | The class that holds the settings for the plugins. These are loaded and saved via IPluginSettingsStorage.
Public class | RawDecodingSettings | The data-transfer object that carries the configuration of the raw message decoder.
Public class | RebroadcastFormat | A collection of strings describing the UniqueId values for the rebroadcast server formats that ship with VRS.
Public class | RebroadcastSettings | The settings for the rebroadcast server.
Public class | Receiver | A settings object that carries information about a receiever.
Public class | ReceiverLocation | A class describing the location of a receiver.
Public class | SavedPolarPlot | Carries the details for an individual receiver's polar plot.
Public class | VersionCheckSettings | The configuration settings controlling the checking for new versions of the server.
Public class | WebServerSettings | A class that holds the configuration of the web server.
Interfaces
 | Interface | Description
Public interface | IConfigurationListener | The interface for a class that can listen to a Configuration object and raise a single event when one of its properties (or the properties of a child object) are changed.
 | IConfigurationStorage | The interface for objects that can load and save Configuration objects.
Public interface | IConfigurationStorageProvider | The interface for the objects that abstract away the environment for tests on IConfigurationStorage.
Public interface | IInstallerSettingsStorage | The interface for the object that can load installer settings.
Public interface | IInstallerSettingsStorageProvider | The interface for objects that abstract away the environment for IInstallerSettingsStorage.
Public interface | IPluginManifestStorage | The interface for objects that can read the content of a plugin's manifest file.
Public interface | IPluginManifestStorageProvider | The interface for objects that can abstract away the environment for IPluginManifestStorage implementations.
Public interface | IPluginSettingsStorage | The interface for objects that load and save PluginSettings objects.
Public interface | IPluginSettingsStorageProvider | The interface for objects that abstract away the environment for IPluginSettingsStorage implementations.
Public interface | ISavedPolarPlotStorage | Manages the loading and saving of polar plots.
Public interface | ISharedConfiguration | Exposes the current configuration.
Public interface | ISiteSettingsParser | The interface for objects that can parse the site's exported settings.
Public interface | IUser | The interface that describes a user.
Public interface | IUserManager | The interface for the object that manages lists of users.
Enumerations
 | Enumeration | Description
Public enumeration | ConfigurationListenerGroup | An enumeration of the different groups that can appear in a ConfigurationListenerEventArgs.
Public enumeration | ConnectionType | An enumeration of the different types of connection supported by VRS.
Public enumeration | DefaultAccess | An enumeration of the default access allowed to an Internet resource.
Public enumeration | ProxyType | An enumeration of the type of proxies that the server is sitting behind.
Public enumeration | ReceiverUsage | An enumeration of the different ways that a receiver can be used by the system.
Remarks

The application's configuration information is stored in Configuration, which is read and written by the singleton object IConfigurationStorage. This object raises an event when a new configuration is saved which the application can hook to automatically pick up changes to the configuration. To avoid repeatedly loading the configuration you can also use ISharedConfiguration, which caches the most recent configuration.

The program's installer writes a configuration file that contains settings that cannot be changed without stopping the program and re-running the installer. The settings are in InstallerSettings and are loaded by IInstallerSettingsStorage. Unlike IConfigurationStorage this interface is not a singleton, with it being read-only there is no need to notify the application when the values change and therefore no need to have a single object whose events can be hooked.

Finally we have PluginSettings, which is loaded and saved by IPluginSettingsStorage. This is likely to be of the most interest to plugin developers.


Access Class

Access Class
A class that holds access lists to Internet resources.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsAccess

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Access : INotifyPropertyChanged
Public Class Access
    Implements INotifyPropertyChanged
public ref class Access : INotifyPropertyChanged
type Access =
    class
        interface INotifyPropertyChanged
    end

The Access type exposes the following members.

Constructors
 | Name | Description
Public method | Access | Creates a new object.
Top
Properties
 | Name | Description
Public property | Addresses | Gets a list of domain or IPv4 CIDR notation addresses that are either explicitly denied or allowed access to the resource.
Public property | DefaultAccess | Gets or sets a value indicating the default access to support for the resource. This also indicates how Addresses is to be interpreted.
Top
Methods
 | Name | Description
 | CreateDenyAllButLocalMachine | Returns an Access object that denies all access aside from the local machine.
 | CreateDenyAllButLocalMachineAndNetwork | Returns an Access object that denies all access aside from the local machine and the local network.
Public method | Equals | Returns true if the object passed across is an Access object with the same properties as this one. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


Access Constructor

Access Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Access()
Public Sub New
public:
Access()
new : unit -> Access
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access Properties

Access Properties

The Access type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | Gets a list of domain or IPv4 CIDR notation addresses that are either explicitly denied or allowed access to the resource.
Public property | DefaultAccess | Gets or sets a value indicating the default access to support for the resource. This also indicates how Addresses is to be interpreted.
Top
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.Addresses Property

AccessAddresses Property
Gets a list of domain or IPv4 CIDR notation addresses that are either explicitly denied or allowed access to the resource.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<string> Addresses { get; }
Public ReadOnly Property Addresses As NotifyList(Of String)
    Get
public:
property NotifyList<String^>^ Addresses {
    NotifyList<String^>^ get ();
}
member Addresses : NotifyList<string> with get

Property Value

Type: NotifyList String
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.DefaultAccess Property

AccessDefaultAccess Property
Gets or sets a value indicating the default access to support for the resource. This also indicates how Addresses is to be interpreted.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefaultAccess DefaultAccess { get; set; }
Public Property DefaultAccess As DefaultAccess
    Get
    Set
public:
property DefaultAccess DefaultAccess {
    DefaultAccess get ();
    void set (DefaultAccess value);
}
member DefaultAccess : DefaultAccess with get, set

Property Value

Type: DefaultAccess
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access Methods

Access Methods

The Access type exposes the following members.

Methods
 | Name | Description
 | CreateDenyAllButLocalMachine | Returns an Access object that denies all access aside from the local machine.
 | CreateDenyAllButLocalMachineAndNetwork | Returns an Access object that denies all access aside from the local machine and the local network.
Public method | Equals | Returns true if the object passed across is an Access object with the same properties as this one. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.CreateDenyAllButLocalMachine Method

AccessCreateDenyAllButLocalMachine Method
Returns an Access object that denies all access aside from the local machine.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Access CreateDenyAllButLocalMachine()
Public Shared Function CreateDenyAllButLocalMachine As Access
public:
static Access^ CreateDenyAllButLocalMachine()
static member CreateDenyAllButLocalMachine : unit -> Access

Return Value

Type: Access
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.CreateDenyAllButLocalMachineAndNetwork Method

AccessCreateDenyAllButLocalMachineAndNetwork Method
Returns an Access object that denies all access aside from the local machine and the local network.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Access CreateDenyAllButLocalMachineAndNetwork()
Public Shared Function CreateDenyAllButLocalMachineAndNetwork As Access
public:
static Access^ CreateDenyAllButLocalMachineAndNetwork()
static member CreateDenyAllButLocalMachineAndNetwork : unit -> Access

Return Value

Type: Access
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.Equals Method

AccessEquals Method
Returns true if the object passed across is an Access object with the same properties as this one.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.OnPropertyChanged Method

AccessOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.SetField(T) Method

AccessSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access Events

Access Events

The Access type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


Access.PropertyChanged Event

AccessPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Access Class
VirtualRadar.Interface.Settings Namespace


AudioSettings Class

AudioSettings Class
Holds the configuration of the speech-to-audio features that the website can access.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsAudioSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AudioSettings : INotifyPropertyChanged
Public Class AudioSettings
    Implements INotifyPropertyChanged
public ref class AudioSettings : INotifyPropertyChanged
type AudioSettings =
    class
        interface INotifyPropertyChanged
    end

The AudioSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AudioSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating that the user wants to use the feature.
Public property | VoiceName | Gets or sets the Microsoft Voice to use.
Public property | VoiceRate | Gets or sets the speed at which the voice should say the text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


AudioSettings Constructor

AudioSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AudioSettings()
Public Sub New
public:
AudioSettings()
new : unit -> AudioSettings
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings Properties

AudioSettings Properties

The AudioSettings type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating that the user wants to use the feature.
Public property | VoiceName | Gets or sets the Microsoft Voice to use.
Public property | VoiceRate | Gets or sets the speed at which the voice should say the text.
Top
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings.Enabled Property

AudioSettingsEnabled Property
Gets or sets a value indicating that the user wants to use the feature.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings.VoiceName Property

AudioSettingsVoiceName Property
Gets or sets the Microsoft Voice to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VoiceName { get; set; }
Public Property VoiceName As String
    Get
    Set
public:
property String^ VoiceName {
    String^ get ();
    void set (String^ value);
}
member VoiceName : string with get, set

Property Value

Type: String
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings.VoiceRate Property

AudioSettingsVoiceRate Property
Gets or sets the speed at which the voice should say the text.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VoiceRate { get; set; }
Public Property VoiceRate As Integer
    Get
    Set
public:
property int VoiceRate {
    int get ();
    void set (int value);
}
member VoiceRate : int with get, set

Property Value

Type: Int32
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings Methods

AudioSettings Methods

The AudioSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings.OnPropertyChanged Method

AudioSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings.SetField(T) Method

AudioSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings Events

AudioSettings Events

The AudioSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


AudioSettings.PropertyChanged Event

AudioSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

AudioSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings Class

BaseStationSettings Class
An object that describes the source of data we should connect to.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsBaseStationSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseStationSettings : INotifyPropertyChanged
Public Class BaseStationSettings
    Implements INotifyPropertyChanged
public ref class BaseStationSettings : INotifyPropertyChanged
type BaseStationSettings =
    class
        interface INotifyPropertyChanged
    end

The BaseStationSettings type exposes the following members.

Constructors
 | Name | Description
Public method | BaseStationSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | Address | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | AutoReconnectAtStartup | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | AutoSavePolarPlotsMinutes | Gets or sets the number of minutes to wait between automatic saves of polar plots.
Public property | BaudRate | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | ComPort | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | ConnectionType | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | DatabaseFileName | Gets or sets the full path to the BaseStation database file to use.
Public property | DataBits | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | DataSource | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | DisplayTimeoutSeconds | Gets or sets the number of seconds that aircraft should remain on display in the browser after their last transmission.
Public property | DownloadGlobalAirPressureReadings | Gets or sets a value indicating that global air pressure readings should be downloaded so that true altitudes can be calculated for aircraft that report pressure altitudes.
Public property | Handshake | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | IgnoreBadMessages | Gets or sets a value indicating that badly formatted messages on the feed should be ignored rather than triggering a disconnection from the feed.
Public property | LookupAircraftDetailsOnline | Gets or sets a value indicating that the program should lookup aircraft details online.
Public property | MinimiseToSystemTray | Gets or sets a value indicating that the program should minimise to the system tray rather than the taskbar.
Public property | OperatorFlagsFolder | Gets or sets the folder that holds operator logo images to display to the user.
Public property | OutlinesFolder | No longer used.
Public property | Parity | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | PicturesFolder | Gets or sets the folder that holds pictures of aircraft to display to the user.
Public property | Port | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | SatcomDisplayTimeoutMinutes | Gets or sets the number of minutes that aircraft on a satellite feed should remain on display after their last transmission.
Public property | SatcomTrackingTimeoutMinutes | Gets or sets the number of minutes that aircraft on a satellite feed should remain in the aircraft list after their last transmission.
Public property | SearchPictureSubFolders | Gets or sets a value indicating that sub-folders of PicturesFolder should be searched for aircraft pictures.
Public property | ShutdownText | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | SilhouettesFolder | Gets or sets the folder that holds aircraft silhouette images to display to the user.
Public property | StartupText | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | StopBits | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | TrackingTimeoutSeconds | Gets or sets the number of seconds that aircraft should remain in the aircraft list after their last transmission.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
Remarks
Originally the application was only able to connect to instances of BaseStation. Later versions were able to deal with a wider variety of sources. Ideally the name of this class would be changed to something that doesn't imply that it's only talking about BaseStation connections but the name has been serialised into the configuration files and it's not worth the pain of changing it.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


BaseStationSettings Constructor

BaseStationSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationSettings()
Public Sub New
public:
BaseStationSettings()
new : unit -> BaseStationSettings
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings Properties

BaseStationSettings Properties

The BaseStationSettings type exposes the following members.

Properties
 | Name | Description
Public property | Address | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | AutoReconnectAtStartup | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | AutoSavePolarPlotsMinutes | Gets or sets the number of minutes to wait between automatic saves of polar plots.
Public property | BaudRate | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | ComPort | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | ConnectionType | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | DatabaseFileName | Gets or sets the full path to the BaseStation database file to use.
Public property | DataBits | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | DataSource | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | DisplayTimeoutSeconds | Gets or sets the number of seconds that aircraft should remain on display in the browser after their last transmission.
Public property | DownloadGlobalAirPressureReadings | Gets or sets a value indicating that global air pressure readings should be downloaded so that true altitudes can be calculated for aircraft that report pressure altitudes.
Public property | Handshake | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | IgnoreBadMessages | Gets or sets a value indicating that badly formatted messages on the feed should be ignored rather than triggering a disconnection from the feed.
Public property | LookupAircraftDetailsOnline | Gets or sets a value indicating that the program should lookup aircraft details online.
Public property | MinimiseToSystemTray | Gets or sets a value indicating that the program should minimise to the system tray rather than the taskbar.
Public property | OperatorFlagsFolder | Gets or sets the folder that holds operator logo images to display to the user.
Public property | OutlinesFolder | No longer used.
Public property | Parity | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | PicturesFolder | Gets or sets the folder that holds pictures of aircraft to display to the user.
Public property | Port | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | SatcomDisplayTimeoutMinutes | Gets or sets the number of minutes that aircraft on a satellite feed should remain on display after their last transmission.
Public property | SatcomTrackingTimeoutMinutes | Gets or sets the number of minutes that aircraft on a satellite feed should remain in the aircraft list after their last transmission.
Public property | SearchPictureSubFolders | Gets or sets a value indicating that sub-folders of PicturesFolder should be searched for aircraft pictures.
Public property | ShutdownText | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | SilhouettesFolder | Gets or sets the folder that holds aircraft silhouette images to display to the user.
Public property | StartupText | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | StopBits | No longer used. Not marked as obsolete as that prevents serialisation.
Public property | TrackingTimeoutSeconds | Gets or sets the number of seconds that aircraft should remain in the aircraft list after their last transmission.
Top
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.Address Property

BaseStationSettingsAddress Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.AutoReconnectAtStartup Property

BaseStationSettingsAutoReconnectAtStartup Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoReconnectAtStartup { get; set; }
Public Property AutoReconnectAtStartup As Boolean
    Get
    Set
public:
property bool AutoReconnectAtStartup {
    bool get ();
    void set (bool value);
}
member AutoReconnectAtStartup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.AutoSavePolarPlotsMinutes Property

BaseStationSettingsAutoSavePolarPlotsMinutes Property
Gets or sets the number of minutes to wait between automatic saves of polar plots.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AutoSavePolarPlotsMinutes { get; set; }
Public Property AutoSavePolarPlotsMinutes As Integer
    Get
    Set
public:
property int AutoSavePolarPlotsMinutes {
    int get ();
    void set (int value);
}
member AutoSavePolarPlotsMinutes : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.BaudRate Property

BaseStationSettingsBaudRate Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BaudRate { get; set; }
Public Property BaudRate As Integer
    Get
    Set
public:
property int BaudRate {
    int get ();
    void set (int value);
}
member BaudRate : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.ComPort Property

BaseStationSettingsComPort Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ComPort { get; set; }
Public Property ComPort As String
    Get
    Set
public:
property String^ ComPort {
    String^ get ();
    void set (String^ value);
}
member ComPort : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.ConnectionType Property

BaseStationSettingsConnectionType Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionType ConnectionType { get; set; }
Public Property ConnectionType As ConnectionType
    Get
    Set
public:
property ConnectionType ConnectionType {
    ConnectionType get ();
    void set (ConnectionType value);
}
member ConnectionType : ConnectionType with get, set

Property Value

Type: ConnectionType
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.DatabaseFileName Property

BaseStationSettingsDatabaseFileName Property
Gets or sets the full path to the BaseStation database file to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DatabaseFileName { get; set; }
Public Property DatabaseFileName As String
    Get
    Set
public:
property String^ DatabaseFileName {
    String^ get ();
    void set (String^ value);
}
member DatabaseFileName : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.DataBits Property

BaseStationSettingsDataBits Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DataBits { get; set; }
Public Property DataBits As Integer
    Get
    Set
public:
property int DataBits {
    int get ();
    void set (int value);
}
member DataBits : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.DataSource Property

BaseStationSettingsDataSource Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DataSource { get; set; }
Public Property DataSource As String
    Get
    Set
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}
member DataSource : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.DisplayTimeoutSeconds Property

BaseStationSettingsDisplayTimeoutSeconds Property
Gets or sets the number of seconds that aircraft should remain on display in the browser after their last transmission.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisplayTimeoutSeconds { get; set; }
Public Property DisplayTimeoutSeconds As Integer
    Get
    Set
public:
property int DisplayTimeoutSeconds {
    int get ();
    void set (int value);
}
member DisplayTimeoutSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.DownloadGlobalAirPressureReadings Property

BaseStationSettingsDownloadGlobalAirPressureReadings Property
Gets or sets a value indicating that global air pressure readings should be downloaded so that true altitudes can be calculated for aircraft that report pressure altitudes.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DownloadGlobalAirPressureReadings { get; set; }
Public Property DownloadGlobalAirPressureReadings As Boolean
    Get
    Set
public:
property bool DownloadGlobalAirPressureReadings {
    bool get ();
    void set (bool value);
}
member DownloadGlobalAirPressureReadings : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.Handshake Property

BaseStationSettingsHandshake Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Handshake Handshake { get; set; }
Public Property Handshake As Handshake
    Get
    Set
public:
property Handshake Handshake {
    Handshake get ();
    void set (Handshake value);
}
member Handshake : Handshake with get, set

Property Value

Type: Handshake
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.IgnoreBadMessages Property

BaseStationSettingsIgnoreBadMessages Property
Gets or sets a value indicating that badly formatted messages on the feed should be ignored rather than triggering a disconnection from the feed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreBadMessages { get; set; }
Public Property IgnoreBadMessages As Boolean
    Get
    Set
public:
property bool IgnoreBadMessages {
    bool get ();
    void set (bool value);
}
member IgnoreBadMessages : bool with get, set

Property Value

Type: Boolean
Remarks
This has been retired - the program sets this to true and the configuration loader is expected to force it to true on load. Bad messages will no longer disconnect the listener.
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.LookupAircraftDetailsOnline Property

BaseStationSettingsLookupAircraftDetailsOnline Property
Gets or sets a value indicating that the program should lookup aircraft details online.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LookupAircraftDetailsOnline { get; set; }
Public Property LookupAircraftDetailsOnline As Boolean
    Get
    Set
public:
property bool LookupAircraftDetailsOnline {
    bool get ();
    void set (bool value);
}
member LookupAircraftDetailsOnline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.MinimiseToSystemTray Property

BaseStationSettingsMinimiseToSystemTray Property
Gets or sets a value indicating that the program should minimise to the system tray rather than the taskbar.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MinimiseToSystemTray { get; set; }
Public Property MinimiseToSystemTray As Boolean
    Get
    Set
public:
property bool MinimiseToSystemTray {
    bool get ();
    void set (bool value);
}
member MinimiseToSystemTray : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.OperatorFlagsFolder Property

BaseStationSettingsOperatorFlagsFolder Property
Gets or sets the folder that holds operator logo images to display to the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorFlagsFolder { get; set; }
Public Property OperatorFlagsFolder As String
    Get
    Set
public:
property String^ OperatorFlagsFolder {
    String^ get ();
    void set (String^ value);
}
member OperatorFlagsFolder : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.OutlinesFolder Property

BaseStationSettingsOutlinesFolder Property
No longer used.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OutlinesFolder { get; set; }
Public Property OutlinesFolder As String
    Get
    Set
public:
property String^ OutlinesFolder {
    String^ get ();
    void set (String^ value);
}
member OutlinesFolder : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.Parity Property

BaseStationSettingsParity Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parity Parity { get; set; }
Public Property Parity As Parity
    Get
    Set
public:
property Parity Parity {
    Parity get ();
    void set (Parity value);
}
member Parity : Parity with get, set

Property Value

Type: Parity
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.PicturesFolder Property

BaseStationSettingsPicturesFolder Property
Gets or sets the folder that holds pictures of aircraft to display to the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PicturesFolder { get; set; }
Public Property PicturesFolder As String
    Get
    Set
public:
property String^ PicturesFolder {
    String^ get ();
    void set (String^ value);
}
member PicturesFolder : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.Port Property

BaseStationSettingsPort Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.SatcomDisplayTimeoutMinutes Property

BaseStationSettingsSatcomDisplayTimeoutMinutes Property
Gets or sets the number of minutes that aircraft on a satellite feed should remain on display after their last transmission.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SatcomDisplayTimeoutMinutes { get; set; }
Public Property SatcomDisplayTimeoutMinutes As Integer
    Get
    Set
public:
property int SatcomDisplayTimeoutMinutes {
    int get ();
    void set (int value);
}
member SatcomDisplayTimeoutMinutes : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.SatcomTrackingTimeoutMinutes Property

BaseStationSettingsSatcomTrackingTimeoutMinutes Property
Gets or sets the number of minutes that aircraft on a satellite feed should remain in the aircraft list after their last transmission.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SatcomTrackingTimeoutMinutes { get; set; }
Public Property SatcomTrackingTimeoutMinutes As Integer
    Get
    Set
public:
property int SatcomTrackingTimeoutMinutes {
    int get ();
    void set (int value);
}
member SatcomTrackingTimeoutMinutes : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.SearchPictureSubFolders Property

BaseStationSettingsSearchPictureSubFolders Property
Gets or sets a value indicating that sub-folders of PicturesFolder should be searched for aircraft pictures.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SearchPictureSubFolders { get; set; }
Public Property SearchPictureSubFolders As Boolean
    Get
    Set
public:
property bool SearchPictureSubFolders {
    bool get ();
    void set (bool value);
}
member SearchPictureSubFolders : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.ShutdownText Property

BaseStationSettingsShutdownText Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ShutdownText { get; set; }
Public Property ShutdownText As String
    Get
    Set
public:
property String^ ShutdownText {
    String^ get ();
    void set (String^ value);
}
member ShutdownText : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.SilhouettesFolder Property

BaseStationSettingsSilhouettesFolder Property
Gets or sets the folder that holds aircraft silhouette images to display to the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SilhouettesFolder { get; set; }
Public Property SilhouettesFolder As String
    Get
    Set
public:
property String^ SilhouettesFolder {
    String^ get ();
    void set (String^ value);
}
member SilhouettesFolder : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.StartupText Property

BaseStationSettingsStartupText Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StartupText { get; set; }
Public Property StartupText As String
    Get
    Set
public:
property String^ StartupText {
    String^ get ();
    void set (String^ value);
}
member StartupText : string with get, set

Property Value

Type: String
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.StopBits Property

BaseStationSettingsStopBits Property
No longer used. Not marked as obsolete as that prevents serialisation.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StopBits StopBits { get; set; }
Public Property StopBits As StopBits
    Get
    Set
public:
property StopBits StopBits {
    StopBits get ();
    void set (StopBits value);
}
member StopBits : StopBits with get, set

Property Value

Type: StopBits
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.TrackingTimeoutSeconds Property

BaseStationSettingsTrackingTimeoutSeconds Property
Gets or sets the number of seconds that aircraft should remain in the aircraft list after their last transmission.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TrackingTimeoutSeconds { get; set; }
Public Property TrackingTimeoutSeconds As Integer
    Get
    Set
public:
property int TrackingTimeoutSeconds {
    int get ();
    void set (int value);
}
member TrackingTimeoutSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings Methods

BaseStationSettings Methods

The BaseStationSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.OnPropertyChanged Method

BaseStationSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.SetField(T) Method

BaseStationSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings Events

BaseStationSettings Events

The BaseStationSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


BaseStationSettings.PropertyChanged Event

BaseStationSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

BaseStationSettings Class
VirtualRadar.Interface.Settings Namespace


Configuration Class

Configuration Class
An object that carries all of the configuration settings for the application.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsConfiguration

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Configuration : INotifyPropertyChanged
Public Class Configuration
    Implements INotifyPropertyChanged
public ref class Configuration : INotifyPropertyChanged
type Configuration =
    class
        interface INotifyPropertyChanged
    end

The Configuration type exposes the following members.

Constructors
 | Name | Description
Public method | Configuration | Creates a new object.
Top
Properties
 | Name | Description
Public property | AudioSettings | Gets or sets the object that controls the audio that is sent to browsers.
Public property | BaseStationSettings | Gets or sets the object holding settings that describe the source of data that we are listening to.
Public property | DataVersion | Gets or sets a counter that is incremented every time the configuration is saved. Unlike all other properties this will not raise NotifyPropertyChanged when modified.
Public property | FlightRouteSettings | Gets or sets the object holding settings that control how flight routes are used and stored.
Public property | GoogleMapSettings | Gets or sets the object holding settings that modify how the Google Maps pages are shown to connecting browsers.
Public property | InternetClientSettings | Gets or sets the object holding settings that control what resources are made available to browsers connecting from public Internet addresses.
Public property | MergedFeeds | Gets a list of the merged feeds of receivers that the program will maintain.
Public property | MonoSettings | Gets or sets the object that carries Mono-only settings.
Public property | RawDecodingSettings | Gets or sets the object that configures the raw message decoding.
Public property | RebroadcastSettings | Gets a list of all of the rebroadcast server settings recorded by the user.
Public property | ReceiverLocations | Gets a list of every receiver location recorded by the user.
Public property | Receivers | Gets a list of every receveiver that the program will listen to.
Public property | VersionCheckSettings | Gets or sets the object holding settings that control how checks for new versions of the application are made.
Public property | WebServerSettings | Gets or sets the object holding the configuration of the web server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Public method | ReceiverLocation | Returns the receiver location.
Protected method | SetFieldT | Changes the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


Configuration Constructor

Configuration Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Configuration()
Public Sub New
public:
Configuration()
new : unit -> Configuration
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration Properties

Configuration Properties

The Configuration type exposes the following members.

Properties
 | Name | Description
Public property | AudioSettings | Gets or sets the object that controls the audio that is sent to browsers.
Public property | BaseStationSettings | Gets or sets the object holding settings that describe the source of data that we are listening to.
Public property | DataVersion | Gets or sets a counter that is incremented every time the configuration is saved. Unlike all other properties this will not raise NotifyPropertyChanged when modified.
Public property | FlightRouteSettings | Gets or sets the object holding settings that control how flight routes are used and stored.
Public property | GoogleMapSettings | Gets or sets the object holding settings that modify how the Google Maps pages are shown to connecting browsers.
Public property | InternetClientSettings | Gets or sets the object holding settings that control what resources are made available to browsers connecting from public Internet addresses.
Public property | MergedFeeds | Gets a list of the merged feeds of receivers that the program will maintain.
Public property | MonoSettings | Gets or sets the object that carries Mono-only settings.
Public property | RawDecodingSettings | Gets or sets the object that configures the raw message decoding.
Public property | RebroadcastSettings | Gets a list of all of the rebroadcast server settings recorded by the user.
Public property | ReceiverLocations | Gets a list of every receiver location recorded by the user.
Public property | Receivers | Gets a list of every receveiver that the program will listen to.
Public property | VersionCheckSettings | Gets or sets the object holding settings that control how checks for new versions of the application are made.
Public property | WebServerSettings | Gets or sets the object holding the configuration of the web server.
Top
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.AudioSettings Property

ConfigurationAudioSettings Property
Gets or sets the object that controls the audio that is sent to browsers.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AudioSettings AudioSettings { get; set; }
Public Property AudioSettings As AudioSettings
    Get
    Set
public:
property AudioSettings^ AudioSettings {
    AudioSettings^ get ();
    void set (AudioSettings^ value);
}
member AudioSettings : AudioSettings with get, set

Property Value

Type: AudioSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.BaseStationSettings Property

ConfigurationBaseStationSettings Property
Gets or sets the object holding settings that describe the source of data that we are listening to.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseStationSettings BaseStationSettings { get; set; }
Public Property BaseStationSettings As BaseStationSettings
    Get
    Set
public:
property BaseStationSettings^ BaseStationSettings {
    BaseStationSettings^ get ();
    void set (BaseStationSettings^ value);
}
member BaseStationSettings : BaseStationSettings with get, set

Property Value

Type: BaseStationSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.DataVersion Property

ConfigurationDataVersion Property
Gets or sets a counter that is incremented every time the configuration is saved. Unlike all other properties this will not raise NotifyPropertyChanged when modified.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DataVersion { get; set; }
Public Property DataVersion As Integer
    Get
    Set
public:
property int DataVersion {
    int get ();
    void set (int value);
}
member DataVersion : int with get, set

Property Value

Type: Int32
Remarks
This was introduced when the web admin plugin was introduced. IConfigurationStorage implementations are expected to check that the value of this property is the same as the value of the property stored on disk, and to throw an exception if they are not. In this way if a user edits the configuration in the WinForms and web GUIs simultaneously only one edit will "win", the others will fail because they are attempting to save an out-of-date version of the configuration.
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.FlightRouteSettings Property

ConfigurationFlightRouteSettings Property
Gets or sets the object holding settings that control how flight routes are used and stored.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightRouteSettings FlightRouteSettings { get; set; }
Public Property FlightRouteSettings As FlightRouteSettings
    Get
    Set
public:
property FlightRouteSettings^ FlightRouteSettings {
    FlightRouteSettings^ get ();
    void set (FlightRouteSettings^ value);
}
member FlightRouteSettings : FlightRouteSettings with get, set

Property Value

Type: FlightRouteSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.GoogleMapSettings Property

ConfigurationGoogleMapSettings Property
Gets or sets the object holding settings that modify how the Google Maps pages are shown to connecting browsers.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GoogleMapSettings GoogleMapSettings { get; set; }
Public Property GoogleMapSettings As GoogleMapSettings
    Get
    Set
public:
property GoogleMapSettings^ GoogleMapSettings {
    GoogleMapSettings^ get ();
    void set (GoogleMapSettings^ value);
}
member GoogleMapSettings : GoogleMapSettings with get, set

Property Value

Type: GoogleMapSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.InternetClientSettings Property

ConfigurationInternetClientSettings Property
Gets or sets the object holding settings that control what resources are made available to browsers connecting from public Internet addresses.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InternetClientSettings InternetClientSettings { get; set; }
Public Property InternetClientSettings As InternetClientSettings
    Get
    Set
public:
property InternetClientSettings^ InternetClientSettings {
    InternetClientSettings^ get ();
    void set (InternetClientSettings^ value);
}
member InternetClientSettings : InternetClientSettings with get, set

Property Value

Type: InternetClientSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.MergedFeeds Property

ConfigurationMergedFeeds Property
Gets a list of the merged feeds of receivers that the program will maintain.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<MergedFeed> MergedFeeds { get; }
Public ReadOnly Property MergedFeeds As NotifyList(Of MergedFeed)
    Get
public:
property NotifyList<MergedFeed^>^ MergedFeeds {
    NotifyList<MergedFeed^>^ get ();
}
member MergedFeeds : NotifyList<MergedFeed> with get

Property Value

Type: NotifyList MergedFeed
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.MonoSettings Property

ConfigurationMonoSettings Property
Gets or sets the object that carries Mono-only settings.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonoSettings MonoSettings { get; set; }
Public Property MonoSettings As MonoSettings
    Get
    Set
public:
property MonoSettings^ MonoSettings {
    MonoSettings^ get ();
    void set (MonoSettings^ value);
}
member MonoSettings : MonoSettings with get, set

Property Value

Type: MonoSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.RawDecodingSettings Property

ConfigurationRawDecodingSettings Property
Gets or sets the object that configures the raw message decoding.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RawDecodingSettings RawDecodingSettings { get; set; }
Public Property RawDecodingSettings As RawDecodingSettings
    Get
    Set
public:
property RawDecodingSettings^ RawDecodingSettings {
    RawDecodingSettings^ get ();
    void set (RawDecodingSettings^ value);
}
member RawDecodingSettings : RawDecodingSettings with get, set

Property Value

Type: RawDecodingSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.RebroadcastSettings Property

ConfigurationRebroadcastSettings Property
Gets a list of all of the rebroadcast server settings recorded by the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<RebroadcastSettings> RebroadcastSettings { get; }
Public ReadOnly Property RebroadcastSettings As NotifyList(Of RebroadcastSettings)
    Get
public:
property NotifyList<RebroadcastSettings^>^ RebroadcastSettings {
    NotifyList<RebroadcastSettings^>^ get ();
}
member RebroadcastSettings : NotifyList<RebroadcastSettings> with get

Property Value

Type: NotifyList RebroadcastSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.ReceiverLocations Property

ConfigurationReceiverLocations Property
Gets a list of every receiver location recorded by the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<ReceiverLocation> ReceiverLocations { get; }
Public ReadOnly Property ReceiverLocations As NotifyList(Of ReceiverLocation)
    Get
public:
property NotifyList<ReceiverLocation^>^ ReceiverLocations {
    NotifyList<ReceiverLocation^>^ get ();
}
member ReceiverLocations : NotifyList<ReceiverLocation> with get

Property Value

Type: NotifyList ReceiverLocation
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.Receivers Property

ConfigurationReceivers Property
Gets a list of every receveiver that the program will listen to.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<Receiver> Receivers { get; }
Public ReadOnly Property Receivers As NotifyList(Of Receiver)
    Get
public:
property NotifyList<Receiver^>^ Receivers {
    NotifyList<Receiver^>^ get ();
}
member Receivers : NotifyList<Receiver> with get

Property Value

Type: NotifyList Receiver
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.VersionCheckSettings Property

ConfigurationVersionCheckSettings Property
Gets or sets the object holding settings that control how checks for new versions of the application are made.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VersionCheckSettings VersionCheckSettings { get; set; }
Public Property VersionCheckSettings As VersionCheckSettings
    Get
    Set
public:
property VersionCheckSettings^ VersionCheckSettings {
    VersionCheckSettings^ get ();
    void set (VersionCheckSettings^ value);
}
member VersionCheckSettings : VersionCheckSettings with get, set

Property Value

Type: VersionCheckSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.WebServerSettings Property

ConfigurationWebServerSettings Property
Gets or sets the object holding the configuration of the web server.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebServerSettings WebServerSettings { get; set; }
Public Property WebServerSettings As WebServerSettings
    Get
    Set
public:
property WebServerSettings^ WebServerSettings {
    WebServerSettings^ get ();
    void set (WebServerSettings^ value);
}
member WebServerSettings : WebServerSettings with get, set

Property Value

Type: WebServerSettings
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration Methods

Configuration Methods

The Configuration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Public method | ReceiverLocation | Returns the receiver location.
Protected method | SetFieldT | Changes the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.OnPropertyChanged Method

ConfigurationOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.ReceiverLocation Method

ConfigurationReceiverLocation Method
Returns the receiver location.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverLocation ReceiverLocation(
    int locationUniqueId
)
Public Function ReceiverLocation (
    locationUniqueId As Integer
) As ReceiverLocation
public:
ReceiverLocation^ ReceiverLocation(
    int locationUniqueId
)
member ReceiverLocation :
        locationUniqueId : int -> ReceiverLocation

Parameters

locationUniqueId
Type: SystemInt32

Return Value

Type: ReceiverLocation
Remarks
Originally the program didn't need to know where the receiver was located, but after ADS-B decoding was added it needed to know for local surface position decoding. Because all of this data is being serialised we unfortunately can't have direct references to ReceiverLocation(Int32) objects in the classes so when a receiver location needs to be recorded only its ID is stored. This looks up the location for the ID passed across in a consistent fashion. It may return null if the receiver location with that name no longer exists.
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.SetField(T) Method

ConfigurationSetFieldT Method
Changes the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration Events

Configuration Events

The Configuration type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


Configuration.PropertyChanged Event

ConfigurationPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Configuration Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs Class

ConfigurationListenerEventArgs Class
Carries information in events from IConfigurationListener.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.SettingsConfigurationListenerEventArgs

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConfigurationListenerEventArgs : EventArgs
Public Class ConfigurationListenerEventArgs
    Inherits EventArgs
public ref class ConfigurationListenerEventArgs : public EventArgs
type ConfigurationListenerEventArgs =
    class
        inherit EventArgs
    end

The ConfigurationListenerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationListenerEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | Configuration | Gets the configuration that was changed.
Public property | Group | Gets the group of settings that were changed.
Public property | IsListChild | Gets or sets a value indicating that the Record is a child object in a list.
Public property | PropertyName | Gets the name of the property that has been changed.
Public property | Record | Gets the record that was changed (either a Configuration or more typically one of the child objects such as BaseStationSettings, MergedFeed etc).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs Constructor

ConfigurationListenerEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConfigurationListenerEventArgs(
    Configuration configuration,
    Object record,
    bool isListChild,
    ConfigurationListenerGroup group,
    string propertyName
)
Public Sub New (
    configuration As Configuration,
    record As Object,
    isListChild As Boolean,
    group As ConfigurationListenerGroup,
    propertyName As String
)
public:
ConfigurationListenerEventArgs(
    Configuration^ configuration,
    Object^ record,
    bool isListChild,
    ConfigurationListenerGroup group,
    String^ propertyName
)
new :
        configuration : Configuration *
        record : Object *
        isListChild : bool *
        group : ConfigurationListenerGroup *
        propertyName : string -> ConfigurationListenerEventArgs

Parameters

configuration
Type: VirtualRadar.Interface.SettingsConfiguration
record
Type: SystemObject
isListChild
Type: SystemBoolean
group
Type: VirtualRadar.Interface.SettingsConfigurationListenerGroup
propertyName
Type: SystemString
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs Properties

ConfigurationListenerEventArgs Properties

The ConfigurationListenerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets the configuration that was changed.
Public property | Group | Gets the group of settings that were changed.
Public property | IsListChild | Gets or sets a value indicating that the Record is a child object in a list.
Public property | PropertyName | Gets the name of the property that has been changed.
Public property | Record | Gets the record that was changed (either a Configuration or more typically one of the child objects such as BaseStationSettings, MergedFeed etc).
Top
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs.Configuration Property

ConfigurationListenerEventArgsConfiguration Property
Gets the configuration that was changed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
public:
property Configuration^ Configuration {
    Configuration^ get ();
}
member Configuration : Configuration with get

Property Value

Type: Configuration
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs.Group Property

ConfigurationListenerEventArgsGroup Property
Gets the group of settings that were changed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConfigurationListenerGroup Group { get; }
Public ReadOnly Property Group As ConfigurationListenerGroup
    Get
public:
property ConfigurationListenerGroup Group {
    ConfigurationListenerGroup get ();
}
member Group : ConfigurationListenerGroup with get

Property Value

Type: ConfigurationListenerGroup
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs.IsListChild Property

ConfigurationListenerEventArgsIsListChild Property
Gets or sets a value indicating that the Record is a child object in a list.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsListChild { get; }
Public ReadOnly Property IsListChild As Boolean
    Get
public:
property bool IsListChild {
    bool get ();
}
member IsListChild : bool with get

Property Value

Type: Boolean
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs.PropertyName Property

ConfigurationListenerEventArgsPropertyName Property
Gets the name of the property that has been changed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get
public:
property String^ PropertyName {
    String^ get ();
}
member PropertyName : string with get

Property Value

Type: String
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs.Record Property

ConfigurationListenerEventArgsRecord Property
Gets the record that was changed (either a Configuration or more typically one of the child objects such as BaseStationSettings, MergedFeed etc).

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Record { get; }
Public ReadOnly Property Record As Object
    Get
public:
property Object^ Record {
    Object^ get ();
}
member Record : Object with get

Property Value

Type: Object
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerEventArgs Methods

ConfigurationListenerEventArgs Methods

The ConfigurationListenerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConfigurationListenerEventArgs Class
VirtualRadar.Interface.Settings Namespace


ConfigurationListenerGroup Enumeration

ConfigurationListenerGroup Enumeration
An enumeration of the different groups that can appear in a ConfigurationListenerEventArgs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConfigurationListenerGroup
Public Enumeration ConfigurationListenerGroup
public enum class ConfigurationListenerGroup
type ConfigurationListenerGroup
Members
Member name | Value | Description
Configuration | 0 | The property belongs to the top-level Configuration object.
Access | 1 | The property belongs to an Access object.
Audio | 2 | The property belongs to the AudioSettings object.
BaseStation | 3 | The property belongs to the BaseStationSettings object.
FlightRoute | 4 | The property belongs to the FlightRouteSettings object.
GoogleMapSettings | 5 | The property belongs to the GoogleMapSettings object.
InternetClientSettings | 6 | The property belongs to the InternetClientSettings object.
MergedFeed | 7 | The property belongs to a MergedFeed object.
MergedFeedReceiver | 8 | The property belongs to a MergedFeedReceiver object.
MonoSettings | 9 | The property belongs to the MonoSettings object.
RawDecodingSettings | 10 | The property belongs to the RawDecodingSettings object.
RebroadcastSetting | 11 | The property belongs to a RebroadcastSetting object.
Receiver | 12 | The property belongs to a Receiver object.
ReceiverLocation | 13 | The property belongs to a ReceiverLocation object.
VersionCheckSettings | 14 | The property belongs to the VersionCheckSettings object.
WebServerSettings | 15 | The property belongs to the WebServerSettings object.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Class

ConflictingUpdateException Class
Thrown when an update conflicts with a previous update.
Inheritance Hierarchy
SystemObject
SystemException
VirtualRadar.Interface.SettingsConflictingUpdateException

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ConflictingUpdateException : Exception
<SerializableAttribute>
Public Class ConflictingUpdateException
    Inherits Exception
[SerializableAttribute]
public ref class ConflictingUpdateException : public Exception
[<SerializableAttribute>]
type ConflictingUpdateException =
    class
        inherit Exception
    end

The ConflictingUpdateException type exposes the following members.

Constructors
 | Name | Description
Public method | ConflictingUpdateException | Creates a new object.
Public method | ConflictingUpdateException(String) | Creates a new object.
Protected method | ConflictingUpdateException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | ConflictingUpdateException(String, Exception) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Constructor

ConflictingUpdateException Constructor
Overload List
 | Name | Description
Public method | ConflictingUpdateException | Creates a new object.
Public method | ConflictingUpdateException(String) | Creates a new object.
Protected method | ConflictingUpdateException(SerializationInfo, StreamingContext) | Creates a new object.
Public method | ConflictingUpdateException(String, Exception) | Creates a new object.
Top
See Also

Reference

ConflictingUpdateException Class
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Constructor

ConflictingUpdateException Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConflictingUpdateException()
Public Sub New
public:
ConflictingUpdateException()
new : unit -> ConflictingUpdateException
See Also

Reference

ConflictingUpdateException Class
ConflictingUpdateException Overload
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Constructor (String)

ConflictingUpdateException Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConflictingUpdateException(
    string message
)
Public Sub New (
    message As String
)
public:
ConflictingUpdateException(
    String^ message
)
new :
        message : string -> ConflictingUpdateException

Parameters

message
Type: SystemString
See Also

Reference

ConflictingUpdateException Class
ConflictingUpdateException Overload
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Constructor (SerializationInfo, StreamingContext)

ConflictingUpdateException Constructor (SerializationInfo, StreamingContext)
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ConflictingUpdateException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ConflictingUpdateException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConflictingUpdateException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ConflictingUpdateException Class
ConflictingUpdateException Overload
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Constructor (String, Exception)

ConflictingUpdateException Constructor (String, Exception)
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConflictingUpdateException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
ConflictingUpdateException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> ConflictingUpdateException

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

ConflictingUpdateException Class
ConflictingUpdateException Overload
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Properties

ConflictingUpdateException Properties

The ConflictingUpdateException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ConflictingUpdateException Class
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Methods

ConflictingUpdateException Methods

The ConflictingUpdateException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ConflictingUpdateException Class
VirtualRadar.Interface.Settings Namespace


ConflictingUpdateException Events

ConflictingUpdateException Events

The ConflictingUpdateException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ConflictingUpdateException Class
VirtualRadar.Interface.Settings Namespace


ConnectionType Enumeration

ConnectionType Enumeration
An enumeration of the different types of connection supported by VRS.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionType
Public Enumeration ConnectionType
public enum class ConnectionType
type ConnectionType
Members
Member name | Value | Description
TCP | 0 | The connection to the data source is via a TCP socket.
COM | 1 | The connection to the data source is via a serial COM port.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


DataSource Class

DataSource Class
A collection of strings describing the UniqueId values for the receiver formats that ship with VRS.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsDataSource

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DataSource
Public NotInheritable Class DataSource
public ref class DataSource abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataSource =  class end

The DataSource type exposes the following members.

Properties
Name | Description
AllInternalDataSources | Gets an array of all internal data sources. This is not used by the server, it's just to make life easier for the unit tests.
Top
Fields
Name | Description
AircraftListJson | The feed is sending changes to an aircraft list in JSON format.
Beast | Raw messages from the Mode-S Beast.
CompressedVRS | Compressed messages in VRS format.
PlaneFinder | The receiver is sending its feed in PlaneFinder format.
Port30003 | Any source of port 30003 data such as BaseStation, PlanePlotter etc.
Sbs3 | Raw Mode-S messages from the Kinetics Avionics SBS-3.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


DataSource Properties

DataSource Properties

The DataSource type exposes the following members.

Properties
Name | Description
AllInternalDataSources | Gets an array of all internal data sources. This is not used by the server, it's just to make life easier for the unit tests.
Top
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.AllInternalDataSources Property

DataSourceAllInternalDataSources Property
Gets an array of all internal data sources. This is not used by the server, it's just to make life easier for the unit tests.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] AllInternalDataSources { get; }
Public Shared ReadOnly Property AllInternalDataSources As String()
    Get
public:
static property array<String^>^ AllInternalDataSources {
    array<String^>^ get ();
}
static member AllInternalDataSources : string[] with get

Property Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource Fields

DataSource Fields

The DataSource type exposes the following members.

Fields
Name | Description
AircraftListJson | The feed is sending changes to an aircraft list in JSON format.
Beast | Raw messages from the Mode-S Beast.
CompressedVRS | Compressed messages in VRS format.
PlaneFinder | The receiver is sending its feed in PlaneFinder format.
Port30003 | Any source of port 30003 data such as BaseStation, PlanePlotter etc.
Sbs3 | Raw Mode-S messages from the Kinetics Avionics SBS-3.
Top
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.AircraftListJson Field

DataSourceAircraftListJson Field
The feed is sending changes to an aircraft list in JSON format.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string AircraftListJson
Public Shared ReadOnly AircraftListJson As String
public:
static initonly String^ AircraftListJson
static val AircraftListJson: string

Field Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.Beast Field

DataSourceBeast Field
Raw messages from the Mode-S Beast.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string Beast
Public Shared ReadOnly Beast As String
public:
static initonly String^ Beast
static val Beast: string

Field Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.CompressedVRS Field

DataSourceCompressedVRS Field
Compressed messages in VRS format.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string CompressedVRS
Public Shared ReadOnly CompressedVRS As String
public:
static initonly String^ CompressedVRS
static val CompressedVRS: string

Field Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.PlaneFinder Field

DataSourcePlaneFinder Field
The receiver is sending its feed in PlaneFinder format.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string PlaneFinder
Public Shared ReadOnly PlaneFinder As String
public:
static initonly String^ PlaneFinder
static val PlaneFinder: string

Field Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.Port30003 Field

DataSourcePort30003 Field
Any source of port 30003 data such as BaseStation, PlanePlotter etc.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string Port30003
Public Shared ReadOnly Port30003 As String
public:
static initonly String^ Port30003
static val Port30003: string

Field Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DataSource.Sbs3 Field

DataSourceSbs3 Field
Raw Mode-S messages from the Kinetics Avionics SBS-3.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string Sbs3
Public Shared ReadOnly Sbs3 As String
public:
static initonly String^ Sbs3
static val Sbs3: string

Field Value

Type: String
See Also

Reference

DataSource Class
VirtualRadar.Interface.Settings Namespace


DefaultAccess Enumeration

DefaultAccess Enumeration
An enumeration of the default access allowed to an Internet resource.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DefaultAccess
Public Enumeration DefaultAccess
public enum class DefaultAccess
type DefaultAccess
Members
Member name | Value | Description
Unrestricted | 0 | Any user may access the resource. The Addresses list's contents are ignored.
Allow | 1 | Allow access to any address except those that are in Addresses.
Deny | 2 | Deny access to all addresses except those that are in Addresses.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


FlightRouteSettings Class

FlightRouteSettings Class
Holds the configuration pertaining to the handling of flight routes.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsFlightRouteSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FlightRouteSettings : INotifyPropertyChanged
Public Class FlightRouteSettings
    Implements INotifyPropertyChanged
public ref class FlightRouteSettings : INotifyPropertyChanged
type FlightRouteSettings =
    class
        interface INotifyPropertyChanged
    end

The FlightRouteSettings type exposes the following members.

Constructors
 | Name | Description
Public method | FlightRouteSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | AutoUpdateEnabled | Gets or sets a value indicating that new flight routes should be automatically downloaded.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


FlightRouteSettings Constructor

FlightRouteSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightRouteSettings()
Public Sub New
public:
FlightRouteSettings()
new : unit -> FlightRouteSettings
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings Properties

FlightRouteSettings Properties

The FlightRouteSettings type exposes the following members.

Properties
 | Name | Description
Public property | AutoUpdateEnabled | Gets or sets a value indicating that new flight routes should be automatically downloaded.
Top
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings.AutoUpdateEnabled Property

FlightRouteSettingsAutoUpdateEnabled Property
Gets or sets a value indicating that new flight routes should be automatically downloaded.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoUpdateEnabled { get; set; }
Public Property AutoUpdateEnabled As Boolean
    Get
    Set
public:
property bool AutoUpdateEnabled {
    bool get ();
    void set (bool value);
}
member AutoUpdateEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings Methods

FlightRouteSettings Methods

The FlightRouteSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings.OnPropertyChanged Method

FlightRouteSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings.SetField(T) Method

FlightRouteSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings Events

FlightRouteSettings Events

The FlightRouteSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


FlightRouteSettings.PropertyChanged Event

FlightRouteSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

FlightRouteSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings Class

GoogleMapSettings Class
The web site configuration options (originally these were just Google Map settings but they expanded over time - unfortunately I can't change the class name without breaking backwards compatibility).
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsGoogleMapSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GoogleMapSettings : INotifyPropertyChanged
Public Class GoogleMapSettings
    Implements INotifyPropertyChanged
public ref class GoogleMapSettings : INotifyPropertyChanged
type GoogleMapSettings =
    class
        interface INotifyPropertyChanged
    end

The GoogleMapSettings type exposes the following members.

Constructors
 | Name | Description
Public method | GoogleMapSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | AllowCorsDomains | Gets or sets a semi-colon separated list of domains that can access the server's content via CORS.
Public property | ClosestAircraftReceiverId | Gets or sets the receiver to use when the closest aircraft desktop widget asks for details of the closest aircraft.
Public property | DirectoryEntryKey | Gets or sets the key that directory entry requests must contain before the site will respond with directory entry information.
Public property | EnableBundling | Gets or sets a value indicating that the server should bundle multiple CSS and JavaScript files into a single download before serving them.
Public property | EnableCompression | Gets or sets a value indicating that the server should compress responses.
Public property | EnableCorsSupport | Gets or sets a value indicating that the web site should respond to the CORS OPTIONS request.
Public property | EnableMinifying | Gets or sets a value indicating that the server should minify CSS and JavaScript files before serving them.
Public property | FlightSimulatorXReceiverId | Gets or sets the receiver to use with the Flight Simulator X ride-along feature.
Public property | GoogleMapsApiKey | Gets or sets the Google Maps API key to use with the site.
Public property | InitialDistanceUnit | Gets or sets the initial unit used to display distances. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialHeightUnit | Gets or sets the initial unit used to display heights. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapLatitude | Gets or sets the initial latitude to show. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapLongitude | Gets or sets the initial longitude to show. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapType | Gets or sets the initial map type to use (terrain, satellite etc.). This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapZoom | Gets or sets the initial level of zoom to use. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialRefreshSeconds | Gets or sets the initial refresh period. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialSettings | Gets or sets the initial settings to use for new visitors.
Public property | InitialSpeedUnit | Gets or sets the initial unit used to display speeds. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | MinimumRefreshSeconds | Gets or sets the smallest refresh period that the browser will allow the user to set.
Public property | PreferIataAirportCodes | Gets or sets a value indicating that IATA codes should be used to describe airports whenever possible.
Public property | ProxyType | Gets or sets the type of proxy that the server is sitting behind.
Public property | ShortTrailLengthSeconds | Gets or sets the number of seconds that short trails are to be stored for.
Public property | UseGoogleMapsAPIKeyWithLocalRequests | True if the Google Maps API key should be used for requests from local addresses. This should only be switched on if the installation is behind a proxy.
Public property | WebSiteReceiverId | Gets or sets the receiver to show to the user when they visit the web site.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


GoogleMapSettings Constructor

GoogleMapSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GoogleMapSettings()
Public Sub New
public:
GoogleMapSettings()
new : unit -> GoogleMapSettings
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings Properties

GoogleMapSettings Properties

The GoogleMapSettings type exposes the following members.

Properties
 | Name | Description
Public property | AllowCorsDomains | Gets or sets a semi-colon separated list of domains that can access the server's content via CORS.
Public property | ClosestAircraftReceiverId | Gets or sets the receiver to use when the closest aircraft desktop widget asks for details of the closest aircraft.
Public property | DirectoryEntryKey | Gets or sets the key that directory entry requests must contain before the site will respond with directory entry information.
Public property | EnableBundling | Gets or sets a value indicating that the server should bundle multiple CSS and JavaScript files into a single download before serving them.
Public property | EnableCompression | Gets or sets a value indicating that the server should compress responses.
Public property | EnableCorsSupport | Gets or sets a value indicating that the web site should respond to the CORS OPTIONS request.
Public property | EnableMinifying | Gets or sets a value indicating that the server should minify CSS and JavaScript files before serving them.
Public property | FlightSimulatorXReceiverId | Gets or sets the receiver to use with the Flight Simulator X ride-along feature.
Public property | GoogleMapsApiKey | Gets or sets the Google Maps API key to use with the site.
Public property | InitialDistanceUnit | Gets or sets the initial unit used to display distances. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialHeightUnit | Gets or sets the initial unit used to display heights. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapLatitude | Gets or sets the initial latitude to show. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapLongitude | Gets or sets the initial longitude to show. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapType | Gets or sets the initial map type to use (terrain, satellite etc.). This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialMapZoom | Gets or sets the initial level of zoom to use. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialRefreshSeconds | Gets or sets the initial refresh period. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | InitialSettings | Gets or sets the initial settings to use for new visitors.
Public property | InitialSpeedUnit | Gets or sets the initial unit used to display speeds. This is overridden by the user's own settings after they have viewed the page the first time.
Public property | MinimumRefreshSeconds | Gets or sets the smallest refresh period that the browser will allow the user to set.
Public property | PreferIataAirportCodes | Gets or sets a value indicating that IATA codes should be used to describe airports whenever possible.
Public property | ProxyType | Gets or sets the type of proxy that the server is sitting behind.
Public property | ShortTrailLengthSeconds | Gets or sets the number of seconds that short trails are to be stored for.
Public property | UseGoogleMapsAPIKeyWithLocalRequests | True if the Google Maps API key should be used for requests from local addresses. This should only be switched on if the installation is behind a proxy.
Public property | WebSiteReceiverId | Gets or sets the receiver to show to the user when they visit the web site.
Top
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.AllowCorsDomains Property

GoogleMapSettingsAllowCorsDomains Property
Gets or sets a semi-colon separated list of domains that can access the server's content via CORS.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AllowCorsDomains { get; set; }
Public Property AllowCorsDomains As String
    Get
    Set
public:
property String^ AllowCorsDomains {
    String^ get ();
    void set (String^ value);
}
member AllowCorsDomains : string with get, set

Property Value

Type: String
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.ClosestAircraftReceiverId Property

GoogleMapSettingsClosestAircraftReceiverId Property
Gets or sets the receiver to use when the closest aircraft desktop widget asks for details of the closest aircraft.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ClosestAircraftReceiverId { get; set; }
Public Property ClosestAircraftReceiverId As Integer
    Get
    Set
public:
property int ClosestAircraftReceiverId {
    int get ();
    void set (int value);
}
member ClosestAircraftReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.DirectoryEntryKey Property

GoogleMapSettingsDirectoryEntryKey Property
Gets or sets the key that directory entry requests must contain before the site will respond with directory entry information.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DirectoryEntryKey { get; set; }
Public Property DirectoryEntryKey As String
    Get
    Set
public:
property String^ DirectoryEntryKey {
    String^ get ();
    void set (String^ value);
}
member DirectoryEntryKey : string with get, set

Property Value

Type: String
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.EnableBundling Property

GoogleMapSettingsEnableBundling Property
Gets or sets a value indicating that the server should bundle multiple CSS and JavaScript files into a single download before serving them.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableBundling { get; set; }
Public Property EnableBundling As Boolean
    Get
    Set
public:
property bool EnableBundling {
    bool get ();
    void set (bool value);
}
member EnableBundling : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.EnableCompression Property

GoogleMapSettingsEnableCompression Property
Gets or sets a value indicating that the server should compress responses.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableCompression { get; set; }
Public Property EnableCompression As Boolean
    Get
    Set
public:
property bool EnableCompression {
    bool get ();
    void set (bool value);
}
member EnableCompression : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.EnableCorsSupport Property

GoogleMapSettingsEnableCorsSupport Property
Gets or sets a value indicating that the web site should respond to the CORS OPTIONS request.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableCorsSupport { get; set; }
Public Property EnableCorsSupport As Boolean
    Get
    Set
public:
property bool EnableCorsSupport {
    bool get ();
    void set (bool value);
}
member EnableCorsSupport : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.EnableMinifying Property

GoogleMapSettingsEnableMinifying Property
Gets or sets a value indicating that the server should minify CSS and JavaScript files before serving them.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableMinifying { get; set; }
Public Property EnableMinifying As Boolean
    Get
    Set
public:
property bool EnableMinifying {
    bool get ();
    void set (bool value);
}
member EnableMinifying : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.FlightSimulatorXReceiverId Property

GoogleMapSettingsFlightSimulatorXReceiverId Property
Gets or sets the receiver to use with the Flight Simulator X ride-along feature.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlightSimulatorXReceiverId { get; set; }
Public Property FlightSimulatorXReceiverId As Integer
    Get
    Set
public:
property int FlightSimulatorXReceiverId {
    int get ();
    void set (int value);
}
member FlightSimulatorXReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.GoogleMapsApiKey Property

GoogleMapSettingsGoogleMapsApiKey Property
Gets or sets the Google Maps API key to use with the site.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GoogleMapsApiKey { get; set; }
Public Property GoogleMapsApiKey As String
    Get
    Set
public:
property String^ GoogleMapsApiKey {
    String^ get ();
    void set (String^ value);
}
member GoogleMapsApiKey : string with get, set

Property Value

Type: String
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialDistanceUnit Property

GoogleMapSettingsInitialDistanceUnit Property
Gets or sets the initial unit used to display distances. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DistanceUnit InitialDistanceUnit { get; set; }
Public Property InitialDistanceUnit As DistanceUnit
    Get
    Set
public:
property DistanceUnit InitialDistanceUnit {
    DistanceUnit get ();
    void set (DistanceUnit value);
}
member InitialDistanceUnit : DistanceUnit with get, set

Property Value

Type: DistanceUnit
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialHeightUnit Property

GoogleMapSettingsInitialHeightUnit Property
Gets or sets the initial unit used to display heights. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HeightUnit InitialHeightUnit { get; set; }
Public Property InitialHeightUnit As HeightUnit
    Get
    Set
public:
property HeightUnit InitialHeightUnit {
    HeightUnit get ();
    void set (HeightUnit value);
}
member InitialHeightUnit : HeightUnit with get, set

Property Value

Type: HeightUnit
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialMapLatitude Property

GoogleMapSettingsInitialMapLatitude Property
Gets or sets the initial latitude to show. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InitialMapLatitude { get; set; }
Public Property InitialMapLatitude As Double
    Get
    Set
public:
property double InitialMapLatitude {
    double get ();
    void set (double value);
}
member InitialMapLatitude : float with get, set

Property Value

Type: Double
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialMapLongitude Property

GoogleMapSettingsInitialMapLongitude Property
Gets or sets the initial longitude to show. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InitialMapLongitude { get; set; }
Public Property InitialMapLongitude As Double
    Get
    Set
public:
property double InitialMapLongitude {
    double get ();
    void set (double value);
}
member InitialMapLongitude : float with get, set

Property Value

Type: Double
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialMapType Property

GoogleMapSettingsInitialMapType Property
Gets or sets the initial map type to use (terrain, satellite etc.). This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialMapType { get; set; }
Public Property InitialMapType As String
    Get
    Set
public:
property String^ InitialMapType {
    String^ get ();
    void set (String^ value);
}
member InitialMapType : string with get, set

Property Value

Type: String
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialMapZoom Property

GoogleMapSettingsInitialMapZoom Property
Gets or sets the initial level of zoom to use. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InitialMapZoom { get; set; }
Public Property InitialMapZoom As Integer
    Get
    Set
public:
property int InitialMapZoom {
    int get ();
    void set (int value);
}
member InitialMapZoom : int with get, set

Property Value

Type: Int32
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialRefreshSeconds Property

GoogleMapSettingsInitialRefreshSeconds Property
Gets or sets the initial refresh period. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InitialRefreshSeconds { get; set; }
Public Property InitialRefreshSeconds As Integer
    Get
    Set
public:
property int InitialRefreshSeconds {
    int get ();
    void set (int value);
}
member InitialRefreshSeconds : int with get, set

Property Value

Type: Int32
Remarks
For historical reasons the browser always adds one second to whatever value it has been configured to use. Setting 0 here indicates a 1 second refresh period, a 1 is 2 seconds and so on.
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialSettings Property

GoogleMapSettingsInitialSettings Property
Gets or sets the initial settings to use for new visitors.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialSettings { get; set; }
Public Property InitialSettings As String
    Get
    Set
public:
property String^ InitialSettings {
    String^ get ();
    void set (String^ value);
}
member InitialSettings : string with get, set

Property Value

Type: String
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.InitialSpeedUnit Property

GoogleMapSettingsInitialSpeedUnit Property
Gets or sets the initial unit used to display speeds. This is overridden by the user's own settings after they have viewed the page the first time.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpeedUnit InitialSpeedUnit { get; set; }
Public Property InitialSpeedUnit As SpeedUnit
    Get
    Set
public:
property SpeedUnit InitialSpeedUnit {
    SpeedUnit get ();
    void set (SpeedUnit value);
}
member InitialSpeedUnit : SpeedUnit with get, set

Property Value

Type: SpeedUnit
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.MinimumRefreshSeconds Property

GoogleMapSettingsMinimumRefreshSeconds Property
Gets or sets the smallest refresh period that the browser will allow the user to set.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MinimumRefreshSeconds { get; set; }
Public Property MinimumRefreshSeconds As Integer
    Get
    Set
public:
property int MinimumRefreshSeconds {
    int get ();
    void set (int value);
}
member MinimumRefreshSeconds : int with get, set

Property Value

Type: Int32
Remarks
This setting is difficult to police in the server so it should just be taken as a hint to well-behaved code rather than a guarantee that the server will reject the second and subsequent request under this threshold.
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.PreferIataAirportCodes Property

GoogleMapSettingsPreferIataAirportCodes Property
Gets or sets a value indicating that IATA codes should be used to describe airports whenever possible.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreferIataAirportCodes { get; set; }
Public Property PreferIataAirportCodes As Boolean
    Get
    Set
public:
property bool PreferIataAirportCodes {
    bool get ();
    void set (bool value);
}
member PreferIataAirportCodes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.ProxyType Property

GoogleMapSettingsProxyType Property
Gets or sets the type of proxy that the server is sitting behind.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProxyType ProxyType { get; set; }
Public Property ProxyType As ProxyType
    Get
    Set
public:
property ProxyType ProxyType {
    ProxyType get ();
    void set (ProxyType value);
}
member ProxyType : ProxyType with get, set

Property Value

Type: ProxyType
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.ShortTrailLengthSeconds Property

GoogleMapSettingsShortTrailLengthSeconds Property
Gets or sets the number of seconds that short trails are to be stored for.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ShortTrailLengthSeconds { get; set; }
Public Property ShortTrailLengthSeconds As Integer
    Get
    Set
public:
property int ShortTrailLengthSeconds {
    int get ();
    void set (int value);
}
member ShortTrailLengthSeconds : int with get, set

Property Value

Type: Int32
Remarks
Short trails are lines connecting the current position of the aircraft to each coordinate it was at over the past NN seconds. This property holds the NN value.
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.UseGoogleMapsAPIKeyWithLocalRequests Property

GoogleMapSettingsUseGoogleMapsAPIKeyWithLocalRequests Property
True if the Google Maps API key should be used for requests from local addresses. This should only be switched on if the installation is behind a proxy.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseGoogleMapsAPIKeyWithLocalRequests { get; set; }
Public Property UseGoogleMapsAPIKeyWithLocalRequests As Boolean
    Get
    Set
public:
property bool UseGoogleMapsAPIKeyWithLocalRequests {
    bool get ();
    void set (bool value);
}
member UseGoogleMapsAPIKeyWithLocalRequests : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.WebSiteReceiverId Property

GoogleMapSettingsWebSiteReceiverId Property
Gets or sets the receiver to show to the user when they visit the web site.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int WebSiteReceiverId { get; set; }
Public Property WebSiteReceiverId As Integer
    Get
    Set
public:
property int WebSiteReceiverId {
    int get ();
    void set (int value);
}
member WebSiteReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings Methods

GoogleMapSettings Methods

The GoogleMapSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.OnPropertyChanged Method

GoogleMapSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.SetField(T) Method

GoogleMapSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings Events

GoogleMapSettings Events

The GoogleMapSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


GoogleMapSettings.PropertyChanged Event

GoogleMapSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

GoogleMapSettings Class
VirtualRadar.Interface.Settings Namespace


Hash Class

Hash Class
Describes a hashed password in the configuration.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsHash

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Hash
Public Class Hash
public ref class Hash
type Hash =  class end

The Hash type exposes the following members.

Constructors
 | Name | Description
Public method | Hash | Creates a new object.
Public method | Hash(Int32) | Creates a new object.
Public method | Hash(String) | Creates a new object.
Public method | Hash(Int32, String) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Buffer | Gets the hash of the password. Callers can set this list to be the full byte sequence of the hash or read the hash from here.
Public property | Version | Gets or sets the version of the hashing algorithm used to produce Buffer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PasswordMatches | Returns true if the text passed across hashes into the same byte sequence held within Buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
LatestVersion | The version of the hashing algorithm used. If a new algorithm is implemented support should remain for hashes in older algorithms.
Top
Remarks
Passwords are not stored in the configuration file - instead the code hashes them and stores the hash. When considering whether the password matches it hashes the attempted password and then compares hashes.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


Hash Constructor

Hash Constructor
Overload List
 | Name | Description
Public method | Hash | Creates a new object.
Public method | Hash(Int32) | Creates a new object.
Public method | Hash(String) | Creates a new object.
Public method | Hash(Int32, String) | Creates a new object.
Top
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash Constructor

Hash Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hash()
Public Sub New
public:
Hash()
new : unit -> Hash
See Also

Reference

Hash Class
Hash Overload
VirtualRadar.Interface.Settings Namespace


Hash Constructor (Int32)

Hash Constructor (Int32)
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hash(
    int version
)
Public Sub New (
    version As Integer
)
public:
Hash(
    int version
)
new :
        version : int -> Hash

Parameters

version
Type: SystemInt32
See Also

Reference

Hash Class
Hash Overload
VirtualRadar.Interface.Settings Namespace


Hash Constructor (String)

Hash Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hash(
    string password
)
Public Sub New (
    password As String
)
public:
Hash(
    String^ password
)
new :
        password : string -> Hash

Parameters

password
Type: SystemString
See Also

Reference

Hash Class
Hash Overload
VirtualRadar.Interface.Settings Namespace


Hash Constructor (Int32, String)

Hash Constructor (Int32, String)
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hash(
    int version,
    string password
)
Public Sub New (
    version As Integer,
    password As String
)
public:
Hash(
    int version,
    String^ password
)
new :
        version : int *
        password : string -> Hash

Parameters

version
Type: SystemInt32
password
Type: SystemString
See Also

Reference

Hash Class
Hash Overload
VirtualRadar.Interface.Settings Namespace


Hash Properties

Hash Properties

The Hash type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | Gets the hash of the password. Callers can set this list to be the full byte sequence of the hash or read the hash from here.
Public property | Version | Gets or sets the version of the hashing algorithm used to produce Buffer.
Top
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash.Buffer Property

HashBuffer Property
Gets the hash of the password. Callers can set this list to be the full byte sequence of the hash or read the hash from here.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<byte> Buffer { get; }
Public ReadOnly Property Buffer As List(Of Byte)
    Get
public:
property List<unsigned char>^ Buffer {
    List<unsigned char>^ get ();
}
member Buffer : List<byte> with get

Property Value

Type: List Byte
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash.Version Property

HashVersion Property
Gets or sets the version of the hashing algorithm used to produce Buffer.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Version { get; set; }
Public Property Version As Integer
    Get
    Set
public:
property int Version {
    int get ();
    void set (int value);
}
member Version : int with get, set

Property Value

Type: Int32
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash Methods

Hash Methods

The Hash type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PasswordMatches | Returns true if the text passed across hashes into the same byte sequence held within Buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash.PasswordMatches Method

HashPasswordMatches Method
Returns true if the text passed across hashes into the same byte sequence held within Buffer.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PasswordMatches(
    string password
)
Public Function PasswordMatches (
    password As String
) As Boolean
public:
bool PasswordMatches(
    String^ password
)
member PasswordMatches :
        password : string -> bool

Parameters

password
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash Fields

Hash Fields

The Hash type exposes the following members.

Fields
Name | Description
LatestVersion | The version of the hashing algorithm used. If a new algorithm is implemented support should remain for hashes in older algorithms.
Top
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


Hash.LatestVersion Field

HashLatestVersion Field
The version of the hashing algorithm used. If a new algorithm is implemented support should remain for hashes in older algorithms.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly int LatestVersion
Public Shared ReadOnly LatestVersion As Integer
public:
static initonly int LatestVersion
static val LatestVersion: int

Field Value

Type: Int32
See Also

Reference

Hash Class
VirtualRadar.Interface.Settings Namespace


IConfigurationListener Interface

IConfigurationListener Interface
The interface for a class that can listen to a Configuration object and raise a single event when one of its properties (or the properties of a child object) are changed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurationListener : IDisposable
Public Interface IConfigurationListener
    Inherits IDisposable
public interface class IConfigurationListener : IDisposable
type IConfigurationListener =
    interface
        interface IDisposable
    end

The IConfigurationListener type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Starts observing a configuration for changes.
Public method | Release | Stops observing a configuration for changes.
Top
Events
 | Name | Description
Public event | PropertyChanged | Raised when a configuration value changes.
Top
Remarks
Note that at the time of writing there is no one singleton instance of Configuration that you can listen to. This is currently only really of interest to GUI objects that want to observe a configuration as it is changed by the user.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IConfigurationListener Methods

IConfigurationListener Methods

The IConfigurationListener type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Starts observing a configuration for changes.
Public method | Release | Stops observing a configuration for changes.
Top
See Also

Reference

IConfigurationListener Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationListener.Initialise Method

IConfigurationListenerInitialise Method
Starts observing a configuration for changes.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    Configuration configuration
)
Sub Initialise (
    configuration As Configuration
)
void Initialise(
    Configuration^ configuration
)
abstract Initialise :
        configuration : Configuration -> unit

Parameters

configuration
Type: VirtualRadar.Interface.SettingsConfiguration
See Also

Reference

IConfigurationListener Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationListener.Release Method

IConfigurationListenerRelease Method
Stops observing a configuration for changes.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Release()
Sub Release
void Release()
abstract Release : unit -> unit
See Also

Reference

IConfigurationListener Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationListener Events

IConfigurationListener Events

The IConfigurationListener type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Raised when a configuration value changes.
Top
See Also

Reference

IConfigurationListener Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationListener.PropertyChanged Event

IConfigurationListenerPropertyChanged Event
Raised when a configuration value changes.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ConfigurationListenerEventArgs> PropertyChanged
Event PropertyChanged As EventHandler(Of ConfigurationListenerEventArgs)
 event EventHandler<ConfigurationListenerEventArgs^>^ PropertyChanged {
    void add (EventHandler<ConfigurationListenerEventArgs^>^ value);
    void remove (EventHandler<ConfigurationListenerEventArgs^>^ value);
}
abstract PropertyChanged : IEvent<EventHandler<ConfigurationListenerEventArgs>,
    ConfigurationListenerEventArgs>

Value

Type: SystemEventHandler ConfigurationListenerEventArgs
See Also

Reference

IConfigurationListener Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage Interface

IConfigurationStorage Interface
The interface for objects that can load and save Configuration objects.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurationStorage : ISingleton<IConfigurationStorage>
Public Interface IConfigurationStorage
    Inherits ISingleton(Of IConfigurationStorage)
public interface class IConfigurationStorage : ISingleton<IConfigurationStorage^>
type IConfigurationStorage =
    interface
        interface ISingleton<IConfigurationStorage>
    end

The IConfigurationStorage type exposes the following members.

Properties
 | Name | Description
Public property | Folder | Gets or sets the folder the contains the configuration and log files.
Public property | Provider | Gets or sets a value that abstracts away the environment for testing purposes.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Erase | Deletes all of the configuration settings, resetting everything back to factory settings.
Public method | Load | Loads the current configuration for the user.
Public method | Save | Saves the configuration for the user.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Raised after Save(Configuration) has saved a new configuration to disk or Erase has deleted the user's configuration.
Top
Examples
To read all of the application settings in one go:
Copy
IConfigurationStorage storage = Factory.Singleton.Resolve<IConfigurationStorage>().Singleton;
Configuration configuration = storage.Load();
To change a setting, save it and automatically raise ConfigurationChanged:
Copy
IConfigurationStorage storage = Factory.Singleton.Resolve<IConfigurationStorage>().Singleton;
Configuration configuration = storage.Load();
configuration.AudioSettings.Enabled = false;
storage.Save(configuration);
And to have an event handler that is raised whenever something changes the configuration:
Copy
private void SetupMyObject()
{
    IConfigurationStorage storage = Factory.Singleton.Resolve<IConfigurationStorage>().Singleton;
    storage.ConfigurationChanged += ConfigurationStorage_ConfigurationChanged;
}

private void ConfigurationStorage_ConfigurationChanged(object sender, EventArgs args)
{
    // reload and apply new configuration here
}
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IConfigurationStorage Properties

IConfigurationStorage Properties

The IConfigurationStorage type exposes the following members.

Properties
 | Name | Description
Public property | Folder | Gets or sets the folder the contains the configuration and log files.
Public property | Provider | Gets or sets a value that abstracts away the environment for testing purposes.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage.Folder Property

IConfigurationStorageFolder Property
Gets or sets the folder the contains the configuration and log files.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Folder { get; set; }
Property Folder As String
    Get
    Set
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
abstract Folder : string with get, set

Property Value

Type: String
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage.Provider Property

IConfigurationStorageProvider Property
Gets or sets a value that abstracts away the environment for testing purposes.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConfigurationStorageProvider Provider { get; set; }
Property Provider As IConfigurationStorageProvider
    Get
    Set
property IConfigurationStorageProvider^ Provider {
    IConfigurationStorageProvider^ get ();
    void set (IConfigurationStorageProvider^ value);
}
abstract Provider : IConfigurationStorageProvider with get, set

Property Value

Type: IConfigurationStorageProvider
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage Methods

IConfigurationStorage Methods

The IConfigurationStorage type exposes the following members.

Methods
 | Name | Description
Public method | Erase | Deletes all of the configuration settings, resetting everything back to factory settings.
Public method | Load | Loads the current configuration for the user.
Public method | Save | Saves the configuration for the user.
Top
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage.Erase Method

IConfigurationStorageErase Method
Deletes all of the configuration settings, resetting everything back to factory settings.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Erase()
Sub Erase
void Erase()
abstract Erase : unit -> unit
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage.Load Method

IConfigurationStorageLoad Method
Loads the current configuration for the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Configuration Load()
Function Load As Configuration
Configuration^ Load()
abstract Load : unit -> Configuration

Return Value

Type: Configuration
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage.Save Method

IConfigurationStorageSave Method
Saves the configuration for the user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save(
    Configuration configuration
)
Sub Save (
    configuration As Configuration
)
void Save(
    Configuration^ configuration
)
abstract Save :
        configuration : Configuration -> unit

Parameters

configuration
Type: VirtualRadar.Interface.SettingsConfiguration
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage Events

IConfigurationStorage Events

The IConfigurationStorage type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Raised after Save(Configuration) has saved a new configuration to disk or Erase has deleted the user's configuration.
Top
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorage.ConfigurationChanged Event

IConfigurationStorageConfigurationChanged Event
Raised after Save(Configuration) has saved a new configuration to disk or Erase has deleted the user's configuration.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs> ConfigurationChanged
Event ConfigurationChanged As EventHandler(Of EventArgs)
 event EventHandler<EventArgs^>^ ConfigurationChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
abstract ConfigurationChanged : IEvent<EventHandler<EventArgs>,
    EventArgs>

Value

Type: SystemEventHandler EventArgs
See Also

Reference

IConfigurationStorage Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorageProvider Interface

IConfigurationStorageProvider Interface
The interface for the objects that abstract away the environment for tests on IConfigurationStorage.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurationStorageProvider
Public Interface IConfigurationStorageProvider
public interface class IConfigurationStorageProvider
type IConfigurationStorageProvider =  interface end

The IConfigurationStorageProvider type exposes the following members.

Properties
 | Name | Description
Public property | Folder | Gets or sets the folder holding the configuration file(s).
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IConfigurationStorageProvider Properties

IConfigurationStorageProvider Properties

The IConfigurationStorageProvider type exposes the following members.

Properties
 | Name | Description
Public property | Folder | Gets or sets the folder holding the configuration file(s).
Top
See Also

Reference

IConfigurationStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IConfigurationStorageProvider.Folder Property

IConfigurationStorageProviderFolder Property
Gets or sets the folder holding the configuration file(s).

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Folder { get; set; }
Property Folder As String
    Get
    Set
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
abstract Folder : string with get, set

Property Value

Type: String
See Also

Reference

IConfigurationStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorage Interface

IInstallerSettingsStorage Interface
The interface for the object that can load installer settings.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IInstallerSettingsStorage
Public Interface IInstallerSettingsStorage
public interface class IInstallerSettingsStorage
type IInstallerSettingsStorage =  interface end

The IInstallerSettingsStorage type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for us.
Top
Methods
 | Name | Description
Public method | Load | Returns the content of the configuration file written when the application was installed.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorage Properties

IInstallerSettingsStorage Properties

The IInstallerSettingsStorage type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for us.
Top
See Also

Reference

IInstallerSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorage.Provider Property

IInstallerSettingsStorageProvider Property
Gets or sets the object that abstracts away the environment for us.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IInstallerSettingsStorageProvider Provider { get; set; }
Property Provider As IInstallerSettingsStorageProvider
    Get
    Set
property IInstallerSettingsStorageProvider^ Provider {
    IInstallerSettingsStorageProvider^ get ();
    void set (IInstallerSettingsStorageProvider^ value);
}
abstract Provider : IInstallerSettingsStorageProvider with get, set

Property Value

Type: IInstallerSettingsStorageProvider
See Also

Reference

IInstallerSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorage Methods

IInstallerSettingsStorage Methods

The IInstallerSettingsStorage type exposes the following members.

Methods
 | Name | Description
Public method | Load | Returns the content of the configuration file written when the application was installed.
Top
See Also

Reference

IInstallerSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorage.Load Method

IInstallerSettingsStorageLoad Method
Returns the content of the configuration file written when the application was installed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
InstallerSettings Load()
Function Load As InstallerSettings
InstallerSettings^ Load()
abstract Load : unit -> InstallerSettings

Return Value

Type: InstallerSettings
See Also

Reference

IInstallerSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorageProvider Interface

IInstallerSettingsStorageProvider Interface
The interface for objects that abstract away the environment for IInstallerSettingsStorage.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IInstallerSettingsStorageProvider
Public Interface IInstallerSettingsStorageProvider
public interface class IInstallerSettingsStorageProvider
type IInstallerSettingsStorageProvider =  interface end

The IInstallerSettingsStorageProvider type exposes the following members.

Properties
 | Name | Description
Public property | Folder | Gets or sets the folder holding the installer settings configuration file(s).
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorageProvider Properties

IInstallerSettingsStorageProvider Properties

The IInstallerSettingsStorageProvider type exposes the following members.

Properties
 | Name | Description
Public property | Folder | Gets or sets the folder holding the installer settings configuration file(s).
Top
See Also

Reference

IInstallerSettingsStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IInstallerSettingsStorageProvider.Folder Property

IInstallerSettingsStorageProviderFolder Property
Gets or sets the folder holding the installer settings configuration file(s).

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Folder { get; }
ReadOnly Property Folder As String
    Get
property String^ Folder {
    String^ get ();
}
abstract Folder : string with get

Property Value

Type: String
See Also

Reference

IInstallerSettingsStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


InstallerSettings Class

InstallerSettings Class
The object for configuration settings that are created or overwritten by the installer.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsInstallerSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InstallerSettings
Public Class InstallerSettings
public ref class InstallerSettings
type InstallerSettings =  class end

The InstallerSettings type exposes the following members.

Constructors
 | Name | Description
Public method | InstallerSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | WebServerPort | Gets and sets the port number to listen on.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


InstallerSettings Constructor

InstallerSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InstallerSettings()
Public Sub New
public:
InstallerSettings()
new : unit -> InstallerSettings
See Also

Reference

InstallerSettings Class
VirtualRadar.Interface.Settings Namespace


InstallerSettings Properties

InstallerSettings Properties

The InstallerSettings type exposes the following members.

Properties
 | Name | Description
Public property | WebServerPort | Gets and sets the port number to listen on.
Top
See Also

Reference

InstallerSettings Class
VirtualRadar.Interface.Settings Namespace


InstallerSettings.WebServerPort Property

InstallerSettingsWebServerPort Property
Gets and sets the port number to listen on.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int WebServerPort { get; set; }
Public Property WebServerPort As Integer
    Get
    Set
public:
property int WebServerPort {
    int get ();
    void set (int value);
}
member WebServerPort : int with get, set

Property Value

Type: Int32
See Also

Reference

InstallerSettings Class
VirtualRadar.Interface.Settings Namespace


InstallerSettings Methods

InstallerSettings Methods

The InstallerSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InstallerSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings Class

InternetClientSettings Class
Settings that control how browsers on the Internet interact with the server.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsInternetClientSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InternetClientSettings : INotifyPropertyChanged
Public Class InternetClientSettings
    Implements INotifyPropertyChanged
public ref class InternetClientSettings : INotifyPropertyChanged
type InternetClientSettings =
    class
        interface INotifyPropertyChanged
    end

The InternetClientSettings type exposes the following members.

Constructors
 | Name | Description
Public method | InternetClientSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | AllowInternetProximityGadgets | Gets or sets a value indicating whether proximity gadgets can connect to this server over the Internet.
Public property | CanPlayAudio | Gets or sets a value indicating that Internet clients are allowed to play audio from the server.
Public property | CanRunReports | Gets or sets a value indicating that Internet clients are allowed to run reports.
Public property | CanShowPictures | Gets or sets a value indicating that Internet clients are allowed to see aircraft pictures.
Public property | CanShowPinText | Gets or sets a value indicating that Internet clients are allowed to show text labels on the aircraft pins.
Public property | CanShowPolarPlots | Gets or sets a value indicating that Internet clients can see polar plots.
Public property | CanSubmitRoutes | Gets or sets a value indicating that Internet clients can see the links to submit routes.
Public property | TimeoutMinutes | Gets or sets the number of minutes of inactivity before the client times out and stops asking for the aircraft list. If this is zero then the timeout is disabled.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


InternetClientSettings Constructor

InternetClientSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InternetClientSettings()
Public Sub New
public:
InternetClientSettings()
new : unit -> InternetClientSettings
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings Properties

InternetClientSettings Properties

The InternetClientSettings type exposes the following members.

Properties
 | Name | Description
Public property | AllowInternetProximityGadgets | Gets or sets a value indicating whether proximity gadgets can connect to this server over the Internet.
Public property | CanPlayAudio | Gets or sets a value indicating that Internet clients are allowed to play audio from the server.
Public property | CanRunReports | Gets or sets a value indicating that Internet clients are allowed to run reports.
Public property | CanShowPictures | Gets or sets a value indicating that Internet clients are allowed to see aircraft pictures.
Public property | CanShowPinText | Gets or sets a value indicating that Internet clients are allowed to show text labels on the aircraft pins.
Public property | CanShowPolarPlots | Gets or sets a value indicating that Internet clients can see polar plots.
Public property | CanSubmitRoutes | Gets or sets a value indicating that Internet clients can see the links to submit routes.
Public property | TimeoutMinutes | Gets or sets the number of minutes of inactivity before the client times out and stops asking for the aircraft list. If this is zero then the timeout is disabled.
Top
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.AllowInternetProximityGadgets Property

InternetClientSettingsAllowInternetProximityGadgets Property
Gets or sets a value indicating whether proximity gadgets can connect to this server over the Internet.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowInternetProximityGadgets { get; set; }
Public Property AllowInternetProximityGadgets As Boolean
    Get
    Set
public:
property bool AllowInternetProximityGadgets {
    bool get ();
    void set (bool value);
}
member AllowInternetProximityGadgets : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.CanPlayAudio Property

InternetClientSettingsCanPlayAudio Property
Gets or sets a value indicating that Internet clients are allowed to play audio from the server.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPlayAudio { get; set; }
Public Property CanPlayAudio As Boolean
    Get
    Set
public:
property bool CanPlayAudio {
    bool get ();
    void set (bool value);
}
member CanPlayAudio : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.CanRunReports Property

InternetClientSettingsCanRunReports Property
Gets or sets a value indicating that Internet clients are allowed to run reports.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRunReports { get; set; }
Public Property CanRunReports As Boolean
    Get
    Set
public:
property bool CanRunReports {
    bool get ();
    void set (bool value);
}
member CanRunReports : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.CanShowPictures Property

InternetClientSettingsCanShowPictures Property
Gets or sets a value indicating that Internet clients are allowed to see aircraft pictures.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanShowPictures { get; set; }
Public Property CanShowPictures As Boolean
    Get
    Set
public:
property bool CanShowPictures {
    bool get ();
    void set (bool value);
}
member CanShowPictures : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.CanShowPinText Property

InternetClientSettingsCanShowPinText Property
Gets or sets a value indicating that Internet clients are allowed to show text labels on the aircraft pins.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanShowPinText { get; set; }
Public Property CanShowPinText As Boolean
    Get
    Set
public:
property bool CanShowPinText {
    bool get ();
    void set (bool value);
}
member CanShowPinText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.CanShowPolarPlots Property

InternetClientSettingsCanShowPolarPlots Property
Gets or sets a value indicating that Internet clients can see polar plots.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanShowPolarPlots { get; set; }
Public Property CanShowPolarPlots As Boolean
    Get
    Set
public:
property bool CanShowPolarPlots {
    bool get ();
    void set (bool value);
}
member CanShowPolarPlots : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.CanSubmitRoutes Property

InternetClientSettingsCanSubmitRoutes Property
Gets or sets a value indicating that Internet clients can see the links to submit routes.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSubmitRoutes { get; set; }
Public Property CanSubmitRoutes As Boolean
    Get
    Set
public:
property bool CanSubmitRoutes {
    bool get ();
    void set (bool value);
}
member CanSubmitRoutes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.TimeoutMinutes Property

InternetClientSettingsTimeoutMinutes Property
Gets or sets the number of minutes of inactivity before the client times out and stops asking for the aircraft list. If this is zero then the timeout is disabled.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TimeoutMinutes { get; set; }
Public Property TimeoutMinutes As Integer
    Get
    Set
public:
property int TimeoutMinutes {
    int get ();
    void set (int value);
}
member TimeoutMinutes : int with get, set

Property Value

Type: Int32
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings Methods

InternetClientSettings Methods

The InternetClientSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.OnPropertyChanged Method

InternetClientSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.SetField(T) Method

InternetClientSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings Events

InternetClientSettings Events

The InternetClientSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


InternetClientSettings.PropertyChanged Event

InternetClientSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

InternetClientSettings Class
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorage Interface

IPluginManifestStorage Interface
The interface for objects that can read the content of a plugin's manifest file.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginManifestStorage
Public Interface IPluginManifestStorage
public interface class IPluginManifestStorage
type IPluginManifestStorage =  interface end

The IPluginManifestStorage type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for tests.
Top
Methods
 | Name | Description
Public method | LoadForPlugin | Loads the manifest file for a plugin.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IPluginManifestStorage Properties

IPluginManifestStorage Properties

The IPluginManifestStorage type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for tests.
Top
See Also

Reference

IPluginManifestStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorage.Provider Property

IPluginManifestStorageProvider Property
Gets or sets the object that abstracts away the environment for tests.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPluginManifestStorageProvider Provider { get; set; }
Property Provider As IPluginManifestStorageProvider
    Get
    Set
property IPluginManifestStorageProvider^ Provider {
    IPluginManifestStorageProvider^ get ();
    void set (IPluginManifestStorageProvider^ value);
}
abstract Provider : IPluginManifestStorageProvider with get, set

Property Value

Type: IPluginManifestStorageProvider
See Also

Reference

IPluginManifestStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorage Methods

IPluginManifestStorage Methods

The IPluginManifestStorage type exposes the following members.

Methods
 | Name | Description
Public method | LoadForPlugin | Loads the manifest file for a plugin.
Top
See Also

Reference

IPluginManifestStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorage.LoadForPlugin Method

IPluginManifestStorageLoadForPlugin Method
Loads the manifest file for a plugin.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PluginManifest LoadForPlugin(
    string pluginFileName
)
Function LoadForPlugin (
    pluginFileName As String
) As PluginManifest
PluginManifest^ LoadForPlugin(
    String^ pluginFileName
)
abstract LoadForPlugin :
        pluginFileName : string -> PluginManifest

Parameters

pluginFileName
Type: SystemString
The full path to a plugin file (e.g. c:\folder\plugin.dll)

Return Value

Type: PluginManifest
The content of the manifest file or null if the plugin file does not exist.
Remarks
The manifest file is an XML file, see the notes against PluginManifest file for more details. If the file exists but could not be parsed then an exception is thrown - the precise exception will depend on how the parsing of the XML is performed, in theory it could be anything.
See Also

Reference

IPluginManifestStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorageProvider Interface

IPluginManifestStorageProvider Interface
The interface for objects that can abstract away the environment for IPluginManifestStorage implementations.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginManifestStorageProvider
Public Interface IPluginManifestStorageProvider
public interface class IPluginManifestStorageProvider
type IPluginManifestStorageProvider =  interface end

The IPluginManifestStorageProvider type exposes the following members.

Methods
 | Name | Description
Public method | FileExists | Returns true if the file exists.
Public method | ReadAllText | Returns the content of the file.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IPluginManifestStorageProvider Methods

IPluginManifestStorageProvider Methods

The IPluginManifestStorageProvider type exposes the following members.

Methods
 | Name | Description
Public method | FileExists | Returns true if the file exists.
Public method | ReadAllText | Returns the content of the file.
Top
See Also

Reference

IPluginManifestStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorageProvider.FileExists Method

IPluginManifestStorageProviderFileExists Method
Returns true if the file exists.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FileExists(
    string fileName
)
Function FileExists (
    fileName As String
) As Boolean
bool FileExists(
    String^ fileName
)
abstract FileExists :
        fileName : string -> bool

Parameters

fileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IPluginManifestStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IPluginManifestStorageProvider.ReadAllText Method

IPluginManifestStorageProviderReadAllText Method
Returns the content of the file.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ReadAllText(
    string fileName
)
Function ReadAllText (
    fileName As String
) As String
String^ ReadAllText(
    String^ fileName
)
abstract ReadAllText :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

IPluginManifestStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage Interface

IPluginSettingsStorage Interface
The interface for objects that load and save PluginSettings objects.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginSettingsStorage : ISingleton<IPluginSettingsStorage>
Public Interface IPluginSettingsStorage
    Inherits ISingleton(Of IPluginSettingsStorage)
public interface class IPluginSettingsStorage : ISingleton<IPluginSettingsStorage^>
type IPluginSettingsStorage =
    interface
        interface ISingleton<IPluginSettingsStorage>
    end

The IPluginSettingsStorage type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Load | Loads the configuration information for all plugins.
Public method | Save | Saves the configuration information for all plugins.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Raised after Save(PluginSettings) records a new configuration.
Top
Remarks
The plugin settings are always stored in the configuration folder (see Folder).
See Also

Reference

VirtualRadar.Interface.Settings Namespace
VirtualRadar.Interface.SettingsPluginSettings


IPluginSettingsStorage Properties

IPluginSettingsStorage Properties

The IPluginSettingsStorage type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage.Provider Property

IPluginSettingsStorageProvider Property
Gets or sets the object that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPluginSettingsStorageProvider Provider { get; set; }
Property Provider As IPluginSettingsStorageProvider
    Get
    Set
property IPluginSettingsStorageProvider^ Provider {
    IPluginSettingsStorageProvider^ get ();
    void set (IPluginSettingsStorageProvider^ value);
}
abstract Provider : IPluginSettingsStorageProvider with get, set

Property Value

Type: IPluginSettingsStorageProvider
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage Methods

IPluginSettingsStorage Methods

The IPluginSettingsStorage type exposes the following members.

Methods
 | Name | Description
Public method | Load | Loads the configuration information for all plugins.
Public method | Save | Saves the configuration information for all plugins.
Top
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage.Load Method

IPluginSettingsStorageLoad Method
Loads the configuration information for all plugins.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PluginSettings Load()
Function Load As PluginSettings
PluginSettings^ Load()
abstract Load : unit -> PluginSettings

Return Value

Type: PluginSettings
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage.Save Method

IPluginSettingsStorageSave Method
Saves the configuration information for all plugins.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save(
    PluginSettings pluginSettings
)
Sub Save (
    pluginSettings As PluginSettings
)
void Save(
    PluginSettings^ pluginSettings
)
abstract Save :
        pluginSettings : PluginSettings -> unit

Parameters

pluginSettings
Type: VirtualRadar.Interface.SettingsPluginSettings
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage Events

IPluginSettingsStorage Events

The IPluginSettingsStorage type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Raised after Save(PluginSettings) records a new configuration.
Top
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorage.ConfigurationChanged Event

IPluginSettingsStorageConfigurationChanged Event
Raised after Save(PluginSettings) records a new configuration.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConfigurationChanged
Event ConfigurationChanged As EventHandler
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IPluginSettingsStorage Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorageProvider Interface

IPluginSettingsStorageProvider Interface
The interface for objects that abstract away the environment for IPluginSettingsStorage implementations.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginSettingsStorageProvider
Public Interface IPluginSettingsStorageProvider
public interface class IPluginSettingsStorageProvider
type IPluginSettingsStorageProvider =  interface end

The IPluginSettingsStorageProvider type exposes the following members.

Methods
 | Name | Description
Public method | FileExists | Returns true if the file exists.
Public method | FileReadAllLines | Returns an array of every line read from the file.
Public method | FileWriteAllLines | Writes all of the lines to the file, overwriting it if it already exists or creating it if it does not.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorageProvider Methods

IPluginSettingsStorageProvider Methods

The IPluginSettingsStorageProvider type exposes the following members.

Methods
 | Name | Description
Public method | FileExists | Returns true if the file exists.
Public method | FileReadAllLines | Returns an array of every line read from the file.
Public method | FileWriteAllLines | Writes all of the lines to the file, overwriting it if it already exists or creating it if it does not.
Top
See Also

Reference

IPluginSettingsStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorageProvider.FileExists Method

IPluginSettingsStorageProviderFileExists Method
Returns true if the file exists.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FileExists(
    string fileName
)
Function FileExists (
    fileName As String
) As Boolean
bool FileExists(
    String^ fileName
)
abstract FileExists :
        fileName : string -> bool

Parameters

fileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IPluginSettingsStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorageProvider.FileReadAllLines Method

IPluginSettingsStorageProviderFileReadAllLines Method
Returns an array of every line read from the file.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] FileReadAllLines(
    string fileName
)
Function FileReadAllLines (
    fileName As String
) As String()
array<String^>^ FileReadAllLines(
    String^ fileName
)
abstract FileReadAllLines :
        fileName : string -> string[]

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

IPluginSettingsStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


IPluginSettingsStorageProvider.FileWriteAllLines Method

IPluginSettingsStorageProviderFileWriteAllLines Method
Writes all of the lines to the file, overwriting it if it already exists or creating it if it does not.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FileWriteAllLines(
    string fileName,
    string[] lines
)
Sub FileWriteAllLines (
    fileName As String,
    lines As String()
)
void FileWriteAllLines(
    String^ fileName,
    array<String^>^ lines
)
abstract FileWriteAllLines :
        fileName : string *
        lines : string[] -> unit

Parameters

fileName
Type: SystemString
lines
Type: SystemString
See Also

Reference

IPluginSettingsStorageProvider Interface
VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage Interface

ISavedPolarPlotStorage Interface
Manages the loading and saving of polar plots.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISavedPolarPlotStorage : ISingleton<ISavedPolarPlotStorage>
Public Interface ISavedPolarPlotStorage
    Inherits ISingleton(Of ISavedPolarPlotStorage)
public interface class ISavedPolarPlotStorage : ISingleton<ISavedPolarPlotStorage^>
type ISavedPolarPlotStorage =
    interface
        interface ISingleton<ISavedPolarPlotStorage>
    end

The ISavedPolarPlotStorage type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Load | Loads the saved polar plot for a feed. If there is no saved polar plot, or if the feed's properties have changed since the plot was last saved, then null is returned.
Public method | Save | Uses the FeedManager to retrieve all feeds and saves polar plots for those that have them.
Public method | Save(IFeed) | Saves the polar plot for a single feed.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage Properties

ISavedPolarPlotStorage Properties

The ISavedPolarPlotStorage type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

ISavedPolarPlotStorage Interface
VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage Methods

ISavedPolarPlotStorage Methods

The ISavedPolarPlotStorage type exposes the following members.

Methods
 | Name | Description
Public method | Load | Loads the saved polar plot for a feed. If there is no saved polar plot, or if the feed's properties have changed since the plot was last saved, then null is returned.
Public method | Save | Uses the FeedManager to retrieve all feeds and saves polar plots for those that have them.
Public method | Save(IFeed) | Saves the polar plot for a single feed.
Top
See Also

Reference

ISavedPolarPlotStorage Interface
VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage.Load Method

ISavedPolarPlotStorageLoad Method
Loads the saved polar plot for a feed. If there is no saved polar plot, or if the feed's properties have changed since the plot was last saved, then null is returned.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SavedPolarPlot Load(
    IFeed feed
)
Function Load (
    feed As IFeed
) As SavedPolarPlot
SavedPolarPlot^ Load(
    IFeed^ feed
)
abstract Load :
        feed : IFeed -> SavedPolarPlot

Parameters

feed
Type: VirtualRadar.Interface.ListenerIFeed

Return Value

Type: SavedPolarPlot
See Also

Reference

ISavedPolarPlotStorage Interface
VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage.Save Method

ISavedPolarPlotStorageSave Method
Overload List
 | Name | Description
Public method | Save | Uses the FeedManager to retrieve all feeds and saves polar plots for those that have them.
Public method | Save(IFeed) | Saves the polar plot for a single feed.
Top
See Also

Reference

ISavedPolarPlotStorage Interface
VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage.Save Method

ISavedPolarPlotStorageSave Method
Uses the FeedManager to retrieve all feeds and saves polar plots for those that have them.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

ISavedPolarPlotStorage Interface
Save Overload
VirtualRadar.Interface.Settings Namespace


ISavedPolarPlotStorage.Save Method (IFeed)

ISavedPolarPlotStorageSave Method (IFeed)
Saves the polar plot for a single feed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save(
    IFeed feed
)
Sub Save (
    feed As IFeed
)
void Save(
    IFeed^ feed
)
abstract Save :
        feed : IFeed -> unit

Parameters

feed
Type: VirtualRadar.Interface.ListenerIFeed
See Also

Reference

ISavedPolarPlotStorage Interface
Save Overload
VirtualRadar.Interface.Settings Namespace


ISharedConfiguration Interface

ISharedConfiguration Interface
Exposes the current configuration.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISharedConfiguration : ISingleton<ISharedConfiguration>
Public Interface ISharedConfiguration
    Inherits ISingleton(Of ISharedConfiguration)
public interface class ISharedConfiguration : ISingleton<ISharedConfiguration^>
type ISharedConfiguration =
    interface
        interface ISingleton<ISharedConfiguration>
    end

The ISharedConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Get | Gets the current configuration.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Raised when the configuration returned by Get has changed.
Top
Remarks

For a long time if you wanted to get the current configuration you had to hook the ConfigurationChanged event on IConfigurationStorage and call Load when the configuration changed. This was fine, it worked, but there were two problems with it:

  1. Hooking the event was awkward for objects with a limited lifetime. It meant that they had to be disposable so that there was a point where the unhook could take place.
  2. When the configuration changes dozens of objects jump in and call Load. Load reads the configuration off disk, so you had dozens of redundant reads.

This class aims to get around these problems. When a configuration value is required a class can call Get. The configuration returned is guaranteed to be current and consistent - if the configuration is changed after Get is called it won't affect the configuration returned by the method.

The drawback is that the configuration is shared. Any changes that you make to the configuration will affect everything using this object. To protect against bugs introduced by this kind of behaviour the object listens for changes to the configuration and throws an exception when they're detected.

See Also

Reference

VirtualRadar.Interface.Settings Namespace


ISharedConfiguration Properties

ISharedConfiguration Properties

The ISharedConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

ISharedConfiguration Interface
VirtualRadar.Interface.Settings Namespace


ISharedConfiguration Methods

ISharedConfiguration Methods

The ISharedConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Get | Gets the current configuration.
Top
See Also

Reference

ISharedConfiguration Interface
VirtualRadar.Interface.Settings Namespace


ISharedConfiguration.Get Method

ISharedConfigurationGet Method
Gets the current configuration.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Configuration Get()
Function Get As Configuration
Configuration^ Get()
abstract Get : unit -> Configuration

Return Value

Type: Configuration
Remarks
I didn't make this a property because the configuration it returns can change between calls, and I didn't want people calling it repeatedly within a function and getting inconsistencies.
See Also

Reference

ISharedConfiguration Interface
VirtualRadar.Interface.Settings Namespace


ISharedConfiguration Events

ISharedConfiguration Events

The ISharedConfiguration type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Raised when the configuration returned by Get has changed.
Top
See Also

Reference

ISharedConfiguration Interface
VirtualRadar.Interface.Settings Namespace


ISharedConfiguration.ConfigurationChanged Event

ISharedConfigurationConfigurationChanged Event
Raised when the configuration returned by Get has changed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConfigurationChanged
Event ConfigurationChanged As EventHandler
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
Basically the same as IConfigurationStorage.ConfigurationChanged except that calling Get to get the new configuration doesn't involve a fresh load from disk.
See Also

Reference

ISharedConfiguration Interface
VirtualRadar.Interface.Settings Namespace


ISiteSettingsParser Interface

ISiteSettingsParser Interface
The interface for objects that can parse the site's exported settings.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISiteSettingsParser
Public Interface ISiteSettingsParser
public interface class ISiteSettingsParser
type ISiteSettingsParser =  interface end

The ISiteSettingsParser type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Gets a value indicating whether the last call to Load(String) worked.
Public property | LoadException | The exception encountered by the last call to Load(String), if any.
Top
Methods
 | Name | Description
Public method | Load | Loads the exported settings from the site. Sets or clears IsValid. Returns true if the load was successful.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


ISiteSettingsParser Properties

ISiteSettingsParser Properties

The ISiteSettingsParser type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Gets a value indicating whether the last call to Load(String) worked.
Public property | LoadException | The exception encountered by the last call to Load(String), if any.
Top
See Also

Reference

ISiteSettingsParser Interface
VirtualRadar.Interface.Settings Namespace


ISiteSettingsParser.IsValid Property

ISiteSettingsParserIsValid Property
Gets a value indicating whether the last call to Load(String) worked.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsValid { get; }
ReadOnly Property IsValid As Boolean
    Get
property bool IsValid {
    bool get ();
}
abstract IsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

ISiteSettingsParser Interface
VirtualRadar.Interface.Settings Namespace


ISiteSettingsParser.LoadException Property

ISiteSettingsParserLoadException Property
The exception encountered by the last call to Load(String), if any.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Exception LoadException { get; }
ReadOnly Property LoadException As Exception
    Get
property Exception^ LoadException {
    Exception^ get ();
}
abstract LoadException : Exception with get

Property Value

Type: Exception
See Also

Reference

ISiteSettingsParser Interface
VirtualRadar.Interface.Settings Namespace


ISiteSettingsParser Methods

ISiteSettingsParser Methods

The ISiteSettingsParser type exposes the following members.

Methods
 | Name | Description
Public method | Load | Loads the exported settings from the site. Sets or clears IsValid. Returns true if the load was successful.
Top
See Also

Reference

ISiteSettingsParser Interface
VirtualRadar.Interface.Settings Namespace


ISiteSettingsParser.Load Method

ISiteSettingsParserLoad Method
Loads the exported settings from the site. Sets or clears IsValid. Returns true if the load was successful.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Load(
    string exportedSettings
)
Function Load (
    exportedSettings As String
) As Boolean
bool Load(
    String^ exportedSettings
)
abstract Load :
        exportedSettings : string -> bool

Parameters

exportedSettings
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ISiteSettingsParser Interface
VirtualRadar.Interface.Settings Namespace


IUser Interface

IUser Interface
The interface that describes a user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUser : INotifyPropertyChanged
Public Interface IUser
    Inherits INotifyPropertyChanged
public interface class IUser : INotifyPropertyChanged
type IUser =
    interface
        interface INotifyPropertyChanged
    end

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating that the user account is enabled.
Public property | IsPersisted | Gets a value indicating that this record has been persisted to the store of users, or has been read from the store of users.
Public property | LoginName | Gets or sets the user's login name. This should be unique to a user.
Public property | Name | Gets or sets the user's name.
Public property | Tag | Gets or sets an object that the application can tag the user with.
Public property | UIPassword | Gets or sets the password as entered at the user interface.
Public property | UniqueId | Gets or sets the user's unique identifier.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IUser Properties

IUser Properties

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating that the user account is enabled.
Public property | IsPersisted | Gets a value indicating that this record has been persisted to the store of users, or has been read from the store of users.
Public property | LoginName | Gets or sets the user's login name. This should be unique to a user.
Public property | Name | Gets or sets the user's name.
Public property | Tag | Gets or sets an object that the application can tag the user with.
Public property | UIPassword | Gets or sets the password as entered at the user interface.
Public property | UniqueId | Gets or sets the user's unique identifier.
Top
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.Enabled Property

IUserEnabled Property
Gets or sets a value indicating that the user account is enabled.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.IsPersisted Property

IUserIsPersisted Property
Gets a value indicating that this record has been persisted to the store of users, or has been read from the store of users.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPersisted { get; }
ReadOnly Property IsPersisted As Boolean
    Get
property bool IsPersisted {
    bool get ();
}
abstract IsPersisted : bool with get

Property Value

Type: Boolean
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.LoginName Property

IUserLoginName Property
Gets or sets the user's login name. This should be unique to a user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string LoginName { get; set; }
Property LoginName As String
    Get
    Set
property String^ LoginName {
    String^ get ();
    void set (String^ value);
}
abstract LoginName : string with get, set

Property Value

Type: String
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.Name Property

IUserName Property
Gets or sets the user's name.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.Tag Property

IUserTag Property
Gets or sets an object that the application can tag the user with.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
abstract Tag : Object with get, set

Property Value

Type: Object
Remarks
This is not to be saved to the database, it's just an object that the application has assigned to the user. It should be ignored by the user manager.
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.UIPassword Property

IUserUIPassword Property
Gets or sets the password as entered at the user interface.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UIPassword { get; set; }
Property UIPassword As String
    Get
    Set
property String^ UIPassword {
    String^ get ();
    void set (String^ value);
}
abstract UIPassword : string with get, set

Property Value

Type: String
Remarks
This is only ever filled by the user interface - the IUserManager should not store passwords and it must never return passwords when loading users.
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser.UniqueId Property

IUserUniqueId Property
Gets or sets the user's unique identifier.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UniqueId { get; set; }
Property UniqueId As String
    Get
    Set
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
abstract UniqueId : string with get, set

Property Value

Type: String
Remarks
The Unique ID should ideally be a value that you can guarantee will only be assigned to a single user and, if that user is deleted, will not be re-used for another user. However, if your user repository cannot make that guarantee then it would be acceptable to return the LoginName here, there would be side-effects but they would not be too surprising.
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUser Events

IUser Events

The IUser type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IUser Interface
VirtualRadar.Interface.Settings Namespace


IUserManager Interface

IUserManager Interface
The interface for the object that manages lists of users.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUserManager : ISingleton<IUserManager>
Public Interface IUserManager
    Inherits ISingleton(Of IUserManager)
public interface class IUserManager : ISingleton<IUserManager^>
type IUserManager =
    interface
        interface ISingleton<IUserManager>
    end

The IUserManager type exposes the following members.

Properties
 | Name | Description
Public property | CanChangeEnabledState | Gets a value indicating that the manager can enable or disable user accounts.
Public property | CanChangePassword | Gets a value indicating that the manager can change passwords on user accounts.
Public property | CanCreateUsers | Gets a value indicating that the manager can create new user accounts.
Public property | CanCreateUsersWithHash | Gets a value indicating that the manager can create a user and make use of a password hash supplied by VRS.
Public property | CanDeleteUsers | Gets a value indicating that the manager can delete user accounts.
Public property | CanEditUsers | Gets a value indicating that the manager can modify user accounts.
Public property | CanListUsers | Gets a value indicating that the manager can retrieve a list of users.
Public property | LoginNameIsCaseSensitive | Gets a value indicating that the login name is case sensitive.
Public property | Name | Gets the name of the manager.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | CreateUser | Creates a new user. If CanCreateUsers is false then this should throw an exception when called. The user manager is expected to modify the record passed in to set IsPersisted to true and to fill in the unique ID.
Public method | CreateUserWithHash | Creates a new user. If CanCreateUsersWithHash is false then this should throw an exception when called.
Public method | DeleteUser | Delete the user passed across. Throw an exception if the deletion is not permitted, otherwise remove the user from the backing store.
Public method | GenerateTemporaryUniqueId | Returns an identifier that does not exist on any user record, has not been previously returned by other calls to GenerateTemporaryUniqueId in this session and cannot be assigned to a new user by any of the Create calls.
Public method | GetUserByLoginName | Returns the user with the login name specified or null if no such user exists.
Public method | GetUsers | Returns a list of all users. Throw an exception if CanListUsers is false.
Public method | GetUsersByUniqueId | Returns a collection of users that have the unique identifiers passed across.
Public method | Initialise | Initialises the manager.
Public method | PasswordMatches | Returns true if the password is a match for the user's password.
Public method | Shutdown | Shuts the manager down.
Public method | UpdateUser | Edits an existing user. Throw an exception if the change is not permitted, otherwise modify the backing store to reflect the change in details for the user with the appropriate UniqueID.
Public method | ValidateUser | Validates the record passed across.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


IUserManager Properties

IUserManager Properties

The IUserManager type exposes the following members.

Properties
 | Name | Description
Public property | CanChangeEnabledState | Gets a value indicating that the manager can enable or disable user accounts.
Public property | CanChangePassword | Gets a value indicating that the manager can change passwords on user accounts.
Public property | CanCreateUsers | Gets a value indicating that the manager can create new user accounts.
Public property | CanCreateUsersWithHash | Gets a value indicating that the manager can create a user and make use of a password hash supplied by VRS.
Public property | CanDeleteUsers | Gets a value indicating that the manager can delete user accounts.
Public property | CanEditUsers | Gets a value indicating that the manager can modify user accounts.
Public property | CanListUsers | Gets a value indicating that the manager can retrieve a list of users.
Public property | LoginNameIsCaseSensitive | Gets a value indicating that the login name is case sensitive.
Public property | Name | Gets the name of the manager.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanChangeEnabledState Property

IUserManagerCanChangeEnabledState Property
Gets a value indicating that the manager can enable or disable user accounts.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanChangeEnabledState { get; }
ReadOnly Property CanChangeEnabledState As Boolean
    Get
property bool CanChangeEnabledState {
    bool get ();
}
abstract CanChangeEnabledState : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanChangePassword Property

IUserManagerCanChangePassword Property
Gets a value indicating that the manager can change passwords on user accounts.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanChangePassword { get; }
ReadOnly Property CanChangePassword As Boolean
    Get
property bool CanChangePassword {
    bool get ();
}
abstract CanChangePassword : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanCreateUsers Property

IUserManagerCanCreateUsers Property
Gets a value indicating that the manager can create new user accounts.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCreateUsers { get; }
ReadOnly Property CanCreateUsers As Boolean
    Get
property bool CanCreateUsers {
    bool get ();
}
abstract CanCreateUsers : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanCreateUsersWithHash Property

IUserManagerCanCreateUsersWithHash Property
Gets a value indicating that the manager can create a user and make use of a password hash supplied by VRS.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCreateUsersWithHash { get; }
ReadOnly Property CanCreateUsersWithHash As Boolean
    Get
property bool CanCreateUsersWithHash {
    bool get ();
}
abstract CanCreateUsersWithHash : bool with get

Property Value

Type: Boolean
Remarks
This is only used to port the old Basic Authentication user from legacy versions of VRS into IUserManager - it is expected that most 3rd party user repositories can't support this, in which case they should return false here.
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanDeleteUsers Property

IUserManagerCanDeleteUsers Property
Gets a value indicating that the manager can delete user accounts.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDeleteUsers { get; }
ReadOnly Property CanDeleteUsers As Boolean
    Get
property bool CanDeleteUsers {
    bool get ();
}
abstract CanDeleteUsers : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanEditUsers Property

IUserManagerCanEditUsers Property
Gets a value indicating that the manager can modify user accounts.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanEditUsers { get; }
ReadOnly Property CanEditUsers As Boolean
    Get
property bool CanEditUsers {
    bool get ();
}
abstract CanEditUsers : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CanListUsers Property

IUserManagerCanListUsers Property
Gets a value indicating that the manager can retrieve a list of users.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanListUsers { get; }
ReadOnly Property CanListUsers As Boolean
    Get
property bool CanListUsers {
    bool get ();
}
abstract CanListUsers : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.LoginNameIsCaseSensitive Property

IUserManagerLoginNameIsCaseSensitive Property
Gets a value indicating that the login name is case sensitive.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoginNameIsCaseSensitive { get; }
ReadOnly Property LoginNameIsCaseSensitive As Boolean
    Get
property bool LoginNameIsCaseSensitive {
    bool get ();
}
abstract LoginNameIsCaseSensitive : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.Name Property

IUserManagerName Property
Gets the name of the manager.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager Methods

IUserManager Methods

The IUserManager type exposes the following members.

Methods
 | Name | Description
Public method | CreateUser | Creates a new user. If CanCreateUsers is false then this should throw an exception when called. The user manager is expected to modify the record passed in to set IsPersisted to true and to fill in the unique ID.
Public method | CreateUserWithHash | Creates a new user. If CanCreateUsersWithHash is false then this should throw an exception when called.
Public method | DeleteUser | Delete the user passed across. Throw an exception if the deletion is not permitted, otherwise remove the user from the backing store.
Public method | GenerateTemporaryUniqueId | Returns an identifier that does not exist on any user record, has not been previously returned by other calls to GenerateTemporaryUniqueId in this session and cannot be assigned to a new user by any of the Create calls.
Public method | GetUserByLoginName | Returns the user with the login name specified or null if no such user exists.
Public method | GetUsers | Returns a list of all users. Throw an exception if CanListUsers is false.
Public method | GetUsersByUniqueId | Returns a collection of users that have the unique identifiers passed across.
Public method | Initialise | Initialises the manager.
Public method | PasswordMatches | Returns true if the password is a match for the user's password.
Public method | Shutdown | Shuts the manager down.
Public method | UpdateUser | Edits an existing user. Throw an exception if the change is not permitted, otherwise modify the backing store to reflect the change in details for the user with the appropriate UniqueID.
Public method | ValidateUser | Validates the record passed across.
Top
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CreateUser Method

IUserManagerCreateUser Method
Creates a new user. If CanCreateUsers is false then this should throw an exception when called. The user manager is expected to modify the record passed in to set IsPersisted to true and to fill in the unique ID.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateUser(
    IUser user
)
Sub CreateUser (
    user As IUser
)
void CreateUser(
    IUser^ user
)
abstract CreateUser :
        user : IUser -> unit

Parameters

user
Type: VirtualRadar.Interface.SettingsIUser
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.CreateUserWithHash Method

IUserManagerCreateUserWithHash Method
Creates a new user. If CanCreateUsersWithHash is false then this should throw an exception when called.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateUserWithHash(
    IUser user,
    Hash passwordHash
)
Sub CreateUserWithHash (
    user As IUser,
    passwordHash As Hash
)
void CreateUserWithHash(
    IUser^ user,
    Hash^ passwordHash
)
abstract CreateUserWithHash :
        user : IUser *
        passwordHash : Hash -> unit

Parameters

user
Type: VirtualRadar.Interface.SettingsIUser
passwordHash
Type: VirtualRadar.Interface.SettingsHash
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.DeleteUser Method

IUserManagerDeleteUser Method
Delete the user passed across. Throw an exception if the deletion is not permitted, otherwise remove the user from the backing store.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteUser(
    IUser user
)
Sub DeleteUser (
    user As IUser
)
void DeleteUser(
    IUser^ user
)
abstract DeleteUser :
        user : IUser -> unit

Parameters

user
Type: VirtualRadar.Interface.SettingsIUser
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.GenerateTemporaryUniqueId Method

IUserManagerGenerateTemporaryUniqueId Method
Returns an identifier that does not exist on any user record, has not been previously returned by other calls to GenerateTemporaryUniqueId in this session and cannot be assigned to a new user by any of the Create calls.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GenerateTemporaryUniqueId(
    IUser user
)
Function GenerateTemporaryUniqueId (
    user As IUser
) As String
String^ GenerateTemporaryUniqueId(
    IUser^ user
)
abstract GenerateTemporaryUniqueId :
        user : IUser -> string

Parameters

user
Type: VirtualRadar.Interface.SettingsIUser
The user that the temporary ID will be assigned to.

Return Value

Type: String
Remarks

The user creation UI has a bit of a chicken-and-egg situation, whereby the same screen that lets people create users also lets them use the new user's unique IDs in the settings. All new users tend to have the same default ID so any settings that refer to these new users are all referring to an ID that won't exist once the user is saved.

What the UI now does is it creates a new user object via the factory and then assigns it a temporary ID, the ID returned by this function. When the settings are saved it saves the users first and then replaces instances of the temporary ID with the ID assigned during the save.

See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.GetUserByLoginName Method

IUserManagerGetUserByLoginName Method
Returns the user with the login name specified or null if no such user exists.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IUser GetUserByLoginName(
    string loginName
)
Function GetUserByLoginName (
    loginName As String
) As IUser
IUser^ GetUserByLoginName(
    String^ loginName
)
abstract GetUserByLoginName :
        loginName : string -> IUser

Parameters

loginName
Type: SystemString

Return Value

Type: IUser
The user record or null.
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.GetUsers Method

IUserManagerGetUsers Method
Returns a list of all users. Throw an exception if CanListUsers is false.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IUser> GetUsers()
Function GetUsers As IEnumerable(Of IUser)
IEnumerable<IUser^>^ GetUsers()
abstract GetUsers : unit -> IEnumerable<IUser>

Return Value

Type: IEnumerable IUser
Remarks
Do not return deleted users in this list. Do not consider the Enabled flag - this must return both enabled and disabled users.
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.GetUsersByUniqueId Method

IUserManagerGetUsersByUniqueId Method
Returns a collection of users that have the unique identifiers passed across.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IUser> GetUsersByUniqueId(
    IEnumerable<string> uniqueIdentifiers
)
Function GetUsersByUniqueId (
    uniqueIdentifiers As IEnumerable(Of String)
) As IEnumerable(Of IUser)
IEnumerable<IUser^>^ GetUsersByUniqueId(
    IEnumerable<String^>^ uniqueIdentifiers
)
abstract GetUsersByUniqueId :
        uniqueIdentifiers : IEnumerable<string> -> IEnumerable<IUser>

Parameters

uniqueIdentifiers
Type: System.Collections.GenericIEnumerable String

Return Value

Type: IEnumerable IUser
Remarks
It is very likely that you will be passed identifiers for users that do not exist, or had existed at one point but were since deleted. This is because the UI to maintain users is separate from the configuration UI. When you are passed a unique ID that no longer exists you should omit it entirely from the result - do not return null elements for them. If every unique ID passed across has no user associated with it then you would return an empty list.
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.Initialise Method

IUserManagerInitialise Method
Initialises the manager.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.PasswordMatches Method

IUserManagerPasswordMatches Method
Returns true if the password is a match for the user's password.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PasswordMatches(
    IUser user,
    string password
)
Function PasswordMatches (
    user As IUser,
    password As String
) As Boolean
bool PasswordMatches(
    IUser^ user,
    String^ password
)
abstract PasswordMatches :
        user : IUser *
        password : string -> bool

Parameters

user
Type: VirtualRadar.Interface.SettingsIUser
password
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.Shutdown Method

IUserManagerShutdown Method
Shuts the manager down.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Shutdown()
Sub Shutdown
void Shutdown()
abstract Shutdown : unit -> unit
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.UpdateUser Method

IUserManagerUpdateUser Method
Edits an existing user. Throw an exception if the change is not permitted, otherwise modify the backing store to reflect the change in details for the user with the appropriate UniqueID.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateUser(
    IUser user,
    string newPassword
)
Sub UpdateUser (
    user As IUser,
    newPassword As String
)
void UpdateUser(
    IUser^ user,
    String^ newPassword
)
abstract UpdateUser :
        user : IUser *
        newPassword : string -> unit

Parameters

user
Type: VirtualRadar.Interface.SettingsIUser
newPassword
Type: SystemString
This will be null if the password is to remain unchanged, otherwise it is the new password.
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


IUserManager.ValidateUser Method

IUserManagerValidateUser Method
Validates the record passed across.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ValidateUser(
    List<ValidationResult> results,
    IUser record,
    IUser currentRecord,
    IList<IUser> allRecords
)
Sub ValidateUser (
    results As List(Of ValidationResult),
    record As IUser,
    currentRecord As IUser,
    allRecords As IList(Of IUser)
)
void ValidateUser(
    List<ValidationResult^>^ results,
    IUser^ record,
    IUser^ currentRecord,
    IList<IUser^>^ allRecords
)
abstract ValidateUser :
        results : List<ValidationResult> *
        record : IUser *
        currentRecord : IUser *
        allRecords : IList<IUser> -> unit

Parameters

results
Type: System.Collections.GenericList ValidationResult
A list of every problem with the record. If there are no problems then leave this alone.
record
Type: VirtualRadar.Interface.SettingsIUser
The record to validate.
currentRecord
Type: VirtualRadar.Interface.SettingsIUser
If the record is new then this will be null - otherwise it is the original record that is now being modified.
allRecords
Type: System.Collections.GenericIList IUser
If this is null then validate against the source of users - otherwise it is the entire list of users to validate against (the assumption being that this was originally returned by GetAll and may contain new, modified or deleted objects that have not yet been saved).

Return Value

Type:
Remarks
If the user manager does not support a particular feature, such as the changing of the enabled state or the changing of the password, then return an appropriate validation message. However the UI should have taken care not to let such modifications get this far.
See Also

Reference

IUserManager Interface
VirtualRadar.Interface.Settings Namespace


MergedFeed Class

MergedFeed Class
The configuration settings for a merged feed.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsMergedFeed

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MergedFeed : INotifyPropertyChanged
Public Class MergedFeed
    Implements INotifyPropertyChanged
public ref class MergedFeed : INotifyPropertyChanged
type MergedFeed =
    class
        interface INotifyPropertyChanged
    end

The MergedFeed type exposes the following members.

Constructors
 | Name | Description
Public method | MergedFeed | Creates a new object.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating that the merged feed is to be used.
Public property | IcaoTimeout | Gets or sets the number of milliseconds that any given receiver will be considered to be the only source of messages for an ICAO.
Public property | IgnoreAircraftWithNoPosition | Gets or sets a value indicating that aircraft are ignored until they report a position that isn't 0/0.
Public property | Name | Gets or sets the name that the merged feed will be known by.
Public property | ReceiverFlags | Gets a list of settings stored against each receiver that is merged into this feed.
Public property | ReceiverIds | Gets a list of the IDs for the receivers that are going to be merged into this feed.
Public property | ReceiverUsage | Gets or sets a value indicating how the merged feed is going to be used by the system.
Public property | UniqueId | Gets or sets the unique identifier of the merged feed. This value is unique across MergedFeed and Receiver records. It cannot be zero.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


MergedFeed Constructor

MergedFeed Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MergedFeed()
Public Sub New
public:
MergedFeed()
new : unit -> MergedFeed
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed Properties

MergedFeed Properties

The MergedFeed type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating that the merged feed is to be used.
Public property | IcaoTimeout | Gets or sets the number of milliseconds that any given receiver will be considered to be the only source of messages for an ICAO.
Public property | IgnoreAircraftWithNoPosition | Gets or sets a value indicating that aircraft are ignored until they report a position that isn't 0/0.
Public property | Name | Gets or sets the name that the merged feed will be known by.
Public property | ReceiverFlags | Gets a list of settings stored against each receiver that is merged into this feed.
Public property | ReceiverIds | Gets a list of the IDs for the receivers that are going to be merged into this feed.
Public property | ReceiverUsage | Gets or sets a value indicating how the merged feed is going to be used by the system.
Public property | UniqueId | Gets or sets the unique identifier of the merged feed. This value is unique across MergedFeed and Receiver records. It cannot be zero.
Top
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.Enabled Property

MergedFeedEnabled Property
Gets or sets a value indicating that the merged feed is to be used.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.IcaoTimeout Property

MergedFeedIcaoTimeout Property
Gets or sets the number of milliseconds that any given receiver will be considered to be the only source of messages for an ICAO.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IcaoTimeout { get; set; }
Public Property IcaoTimeout As Integer
    Get
    Set
public:
property int IcaoTimeout {
    int get ();
    void set (int value);
}
member IcaoTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.IgnoreAircraftWithNoPosition Property

MergedFeedIgnoreAircraftWithNoPosition Property
Gets or sets a value indicating that aircraft are ignored until they report a position that isn't 0/0.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreAircraftWithNoPosition { get; set; }
Public Property IgnoreAircraftWithNoPosition As Boolean
    Get
    Set
public:
property bool IgnoreAircraftWithNoPosition {
    bool get ();
    void set (bool value);
}
member IgnoreAircraftWithNoPosition : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.Name Property

MergedFeedName Property
Gets or sets the name that the merged feed will be known by.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.ReceiverFlags Property

MergedFeedReceiverFlags Property
Gets a list of settings stored against each receiver that is merged into this feed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<MergedFeedReceiver> ReceiverFlags { get; }
Public ReadOnly Property ReceiverFlags As NotifyList(Of MergedFeedReceiver)
    Get
public:
property NotifyList<MergedFeedReceiver^>^ ReceiverFlags {
    NotifyList<MergedFeedReceiver^>^ get ();
}
member ReceiverFlags : NotifyList<MergedFeedReceiver> with get

Property Value

Type: NotifyList MergedFeedReceiver
Remarks
See the comments against ReceiverIds. The configuration GUI is reponsible for adding and removing entries in this list. There may be entries in this list that are not in ReceiverIds, in which case those entries should be ignored. This list is subordinate to ReceiverIds, it only carries extra information that could not be held by ReceiverIds without breaking backwards compatibility.
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.ReceiverIds Property

MergedFeedReceiverIds Property
Gets a list of the IDs for the receivers that are going to be merged into this feed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<int> ReceiverIds { get; }
Public ReadOnly Property ReceiverIds As NotifyList(Of Integer)
    Get
public:
property NotifyList<int>^ ReceiverIds {
    NotifyList<int>^ get ();
}
member ReceiverIds : NotifyList<int> with get

Property Value

Type: NotifyList Int32
Remarks

Originally this was the only list of receivers on a merged feed. Unfortunately because it's just a list of integers and not a list of objects I couldn't store any information that was unique to a receiver in a merged feed. That caused problems, so the ReceiverFlags list was added.

I could not just abandon ReceiverIds without causing backwards compatability issues, so this property continues to be sole source of receiver IDs for the merged feed. The user is responsible for adding and removing entries in this list. The ReceiverFlags entries are maintained by the configuration GUI, it tries to ensure that each receiver in ReceiverIds gets a mirror entry in ReceiverFlags but it may not be a perfect mirror.

Always use ReceiverIds when building the list of receivers to merge together.

See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.ReceiverUsage Property

MergedFeedReceiverUsage Property
Gets or sets a value indicating how the merged feed is going to be used by the system.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverUsage ReceiverUsage { get; set; }
Public Property ReceiverUsage As ReceiverUsage
    Get
    Set
public:
property ReceiverUsage ReceiverUsage {
    ReceiverUsage get ();
    void set (ReceiverUsage value);
}
member ReceiverUsage : ReceiverUsage with get, set

Property Value

Type: ReceiverUsage
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.UniqueId Property

MergedFeedUniqueId Property
Gets or sets the unique identifier of the merged feed. This value is unique across MergedFeed and Receiver records. It cannot be zero.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed Methods

MergedFeed Methods

The MergedFeed type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.OnPropertyChanged Method

MergedFeedOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.SetField(T) Method

MergedFeedSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed Events

MergedFeed Events

The MergedFeed type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeed.PropertyChanged Event

MergedFeedPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

MergedFeed Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver Class

MergedFeedReceiver Class
Describes a receiver in a merged feed.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsMergedFeedReceiver

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MergedFeedReceiver : INotifyPropertyChanged
Public Class MergedFeedReceiver
    Implements INotifyPropertyChanged
public ref class MergedFeedReceiver : INotifyPropertyChanged
type MergedFeedReceiver =
    class
        interface INotifyPropertyChanged
    end

The MergedFeedReceiver type exposes the following members.

Constructors
 | Name | Description
Public method | MergedFeedReceiver | Initializes a new instance of the MergedFeedReceiver class
Top
Properties
 | Name | Description
Public property | IsMlatFeed | Gets or sets a value indicating that the feed should be treated as if it is coming from an MLAT source. Every position message is potentially an MLAT position, even if it is not marked as such in the feed.
Public property | UniqueId | Gets or sets the unique ID of the receiver that is being merged.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver Constructor

MergedFeedReceiver Constructor
Initializes a new instance of the MergedFeedReceiver class

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MergedFeedReceiver()
Public Sub New
public:
MergedFeedReceiver()
new : unit -> MergedFeedReceiver
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver Properties

MergedFeedReceiver Properties

The MergedFeedReceiver type exposes the following members.

Properties
 | Name | Description
Public property | IsMlatFeed | Gets or sets a value indicating that the feed should be treated as if it is coming from an MLAT source. Every position message is potentially an MLAT position, even if it is not marked as such in the feed.
Public property | UniqueId | Gets or sets the unique ID of the receiver that is being merged.
Top
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver.IsMlatFeed Property

MergedFeedReceiverIsMlatFeed Property
Gets or sets a value indicating that the feed should be treated as if it is coming from an MLAT source. Every position message is potentially an MLAT position, even if it is not marked as such in the feed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMlatFeed { get; set; }
Public Property IsMlatFeed As Boolean
    Get
    Set
public:
property bool IsMlatFeed {
    bool get ();
    void set (bool value);
}
member IsMlatFeed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver.UniqueId Property

MergedFeedReceiverUniqueId Property
Gets or sets the unique ID of the receiver that is being merged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver Methods

MergedFeedReceiver Methods

The MergedFeedReceiver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver.OnPropertyChanged Method

MergedFeedReceiverOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver.SetField(T) Method

MergedFeedReceiverSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver Events

MergedFeedReceiver Events

The MergedFeedReceiver type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MergedFeedReceiver.PropertyChanged Event

MergedFeedReceiverPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

MergedFeedReceiver Class
VirtualRadar.Interface.Settings Namespace


MonoSettings Class

MonoSettings Class
Carries settings that are only used when VRS is loaded under Mono.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsMonoSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MonoSettings : INotifyPropertyChanged
Public Class MonoSettings
    Implements INotifyPropertyChanged
public ref class MonoSettings : INotifyPropertyChanged
type MonoSettings =
    class
        interface INotifyPropertyChanged
    end

The MonoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MonoSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | UseMarkerLabels | Gets or sets a value indicating that the text on aircraft markers will be rendered by the website using the labels library, and not directly onto the graphic by the web site.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


MonoSettings Constructor

MonoSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonoSettings()
Public Sub New
public:
MonoSettings()
new : unit -> MonoSettings
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings Properties

MonoSettings Properties

The MonoSettings type exposes the following members.

Properties
 | Name | Description
Public property | UseMarkerLabels | Gets or sets a value indicating that the text on aircraft markers will be rendered by the website using the labels library, and not directly onto the graphic by the web site.
Top
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings.UseMarkerLabels Property

MonoSettingsUseMarkerLabels Property
Gets or sets a value indicating that the text on aircraft markers will be rendered by the website using the labels library, and not directly onto the graphic by the web site.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseMarkerLabels { get; set; }
Public Property UseMarkerLabels As Boolean
    Get
    Set
public:
property bool UseMarkerLabels {
    bool get ();
    void set (bool value);
}
member UseMarkerLabels : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings Methods

MonoSettings Methods

The MonoSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings.OnPropertyChanged Method

MonoSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings.SetField(T) Method

MonoSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings Events

MonoSettings Events

The MonoSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


MonoSettings.PropertyChanged Event

MonoSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

MonoSettings Class
VirtualRadar.Interface.Settings Namespace


PluginManifest Class

PluginManifest Class
A class that represents the content of a plugin manifest file.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsPluginManifest

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PluginManifest
<SerializableAttribute>
Public Class PluginManifest
[SerializableAttribute]
public ref class PluginManifest
[<SerializableAttribute>]
type PluginManifest =  class end

The PluginManifest type exposes the following members.

Constructors
 | Name | Description
Public method | PluginManifest | Initializes a new instance of the PluginManifest class
Top
Properties
 | Name | Description
Public property | MaximumVersion | Gets or sets the latest version of Virtual Radar Server that this plugin will work with.
Public property | MinimumVersion | Gets or sets the earliest version of Virtual Radar Server that this plugin will work with.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

The plugin manifest file tells Virtual Radar Server information about your plugin without having to load the plugin DLL. It can be used to make a decision about whether the plugin can be loaded or not.

The file has to be in the same folder as the plugin DLL and have the same filename as the dll but with an extension of .xml

Examples
The manifest file is XML and an example is laid out below. Please refer to the various properties of this class for an explanantion of the different elements:
Copy
<?xml version="1.0" encoding="utf-8"?>
<PluginManifest xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <MinimumVersion>1.0.0</MinimumVersion>
    <MaximumVersion>1.0.1</MaximumVersion>
</PluginManifest>
See Also

Reference

VirtualRadar.Interface.Settings Namespace


PluginManifest Constructor

PluginManifest Constructor
Initializes a new instance of the PluginManifest class

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PluginManifest()
Public Sub New
public:
PluginManifest()
new : unit -> PluginManifest
See Also

Reference

PluginManifest Class
VirtualRadar.Interface.Settings Namespace


PluginManifest Properties

PluginManifest Properties

The PluginManifest type exposes the following members.

Properties
 | Name | Description
Public property | MaximumVersion | Gets or sets the latest version of Virtual Radar Server that this plugin will work with.
Public property | MinimumVersion | Gets or sets the earliest version of Virtual Radar Server that this plugin will work with.
Top
See Also

Reference

PluginManifest Class
VirtualRadar.Interface.Settings Namespace


PluginManifest.MaximumVersion Property

PluginManifestMaximumVersion Property
Gets or sets the latest version of Virtual Radar Server that this plugin will work with.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MaximumVersion { get; set; }
Public Property MaximumVersion As String
    Get
    Set
public:
property String^ MaximumVersion {
    String^ get ();
    void set (String^ value);
}
member MaximumVersion : string with get, set

Property Value

Type: String
Remarks

The version should be of the form "1.2.3" - i.e. do not specify the Virtual Radar Server revision number here.

If the currently installed version of Virtual Radar Server is higher than the version specified here then the plugin will not be loaded. An entry will be shown in the plugin's list to explain why the plugin was not loaded.

If this value is null or an empty string then the check for the minimum version is disabled.

If your plugin provides custom implementations of interfaces then it is recommended that you set this value to the version of Virtual Radar Server that you built the plugin against. In the long run the interfaces in Virtual Radar Server should settle down and not change between versions but in these early days they are likely to change quite often. If a later version of VRS changes the interfaces that you are overriding then your plugin will generate an exception message on startup - setting this property will prevent that. It will mean, however, that you will need to release new versions of your plugin when the main Virtual Radar Server application changes.

See Also

Reference

PluginManifest Class
VirtualRadar.Interface.Settings Namespace


PluginManifest.MinimumVersion Property

PluginManifestMinimumVersion Property
Gets or sets the earliest version of Virtual Radar Server that this plugin will work with.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MinimumVersion { get; set; }
Public Property MinimumVersion As String
    Get
    Set
public:
property String^ MinimumVersion {
    String^ get ();
    void set (String^ value);
}
member MinimumVersion : string with get, set

Property Value

Type: String
Remarks

The version should be of the form "1.2.3" - i.e. do not specify the Virtual Radar Server revision number here.

If the currently installed version of Virtual Radar Server is lower than the version specified here then the plugin will not be loaded. An entry will be shown in the plugin's list to explain why the plugin was not loaded.

If this value is null or an empty string then the check for the minimum version is disabled.

See Also

Reference

PluginManifest Class
VirtualRadar.Interface.Settings Namespace


PluginManifest Methods

PluginManifest Methods

The PluginManifest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PluginManifest Class
VirtualRadar.Interface.Settings Namespace


PluginSettings Class

PluginSettings Class
The class that holds the settings for the plugins. These are loaded and saved via IPluginSettingsStorage.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsPluginSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PluginSettings
Public Class PluginSettings
public ref class PluginSettings
type PluginSettings =  class end

The PluginSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PluginSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | Values | Gets a collection of property names and their values. Plugins should ensure the keys for the values are unique across all plugins.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadBool(IPlugin, String) | Returns a nullable bool from Values.
Public method | ReadBool(IPlugin, String, Boolean) | Returns a bool from Values.
Public method | ReadDateTime(IPlugin, String) | Returns a nullable DateTime from Values. The DateTimeKind is local.
Public method | ReadDateTime(IPlugin, String, DateTime) | Returns a DateTime from Values. The DateTimeKind is local.
Public method | ReadDouble(IPlugin, String) | Returns a nullable double from Values.
Public method | ReadDouble(IPlugin, String, Double) | Returns a double from Values.
Public method | ReadInt(IPlugin, String) | Returns a nullable int from Values.
Public method | ReadInt(IPlugin, String, Int32) | Returns an integer from Values.
Public method | ReadLong(IPlugin, String) | Returns a nullable long from Values.
Public method | ReadLong(IPlugin, String, Int64) | Returns a long from Values.
Public method | ReadString | Returns a string from Values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IPlugin, String, Boolean) | Writes a bool into Values.
Public method | Write(IPlugin, String, DateTime) | Writes a DateTime into Values.
Public method | Write(IPlugin, String, Double) | Writes a double into Values.
Public method | Write(IPlugin, String, Int32) | Writes an int into Values.
Public method | Write(IPlugin, String, Int64) | Writes a long into Values.
Public method | WriteT(IPlugin, String, T) | Writes a value into Values.
Top
Remarks

It is important to note that this object will contain every setting for every plugin, not just the plugin that loaded it. When writing settings out you should read the old settings first and amend them rather than create new settings and save them, otherwise you will obliterate the settings for all of the other plugins.

The settings are stored as strings in the Values collection. The collection is indexed by a key which must be unique. If you use the supplied Read and Write methods then the Id property is joined to the key supplied to the method to form a full key that should be unique to your plugin. The Read and Write methods also ensure that when ValueTypes are converted to and from strings they use the invariant culture, e.g. the same string is written for the floating point value 1.234 regardless of the region setting that Windows is configured for.

Examples
To load a setting from within an IPlugin:
Copy
IPluginSettingsStorage storage = Factory.Singleton.Resolve<IPluginSettingsStorage>().Singleton;
PluginSettings settings = storage.Load();

bool mySetting = ReadBool(this, "Key", true);
To save a setting from within an IPlugin: IPluginSettingsStorage storage = Factory.Singleton.Resolve<IPluginSettingsStorage>().Singleton; PluginSettings settings = storage.Load(); settings.Write(this, "Key", false); storage.Save(settings);
See Also

Reference

VirtualRadar.Interface.Settings Namespace


PluginSettings Constructor

PluginSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PluginSettings()
Public Sub New
public:
PluginSettings()
new : unit -> PluginSettings
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings Properties

PluginSettings Properties

The PluginSettings type exposes the following members.

Properties
 | Name | Description
Public property | Values | Gets a collection of property names and their values. Plugins should ensure the keys for the values are unique across all plugins.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.Values Property

PluginSettingsValues Property
Gets a collection of property names and their values. Plugins should ensure the keys for the values are unique across all plugins.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NameValueCollection Values { get; }
Public ReadOnly Property Values As NameValueCollection
    Get
public:
property NameValueCollection^ Values {
    NameValueCollection^ get ();
}
member Values : NameValueCollection with get

Property Value

Type: NameValueCollection
Remarks
This collection is shared by all plugins. The keys should be prefaced by a string unique to each plugin, for example by the plugin ID string.
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings Methods

PluginSettings Methods

The PluginSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadBool(IPlugin, String) | Returns a nullable bool from Values.
Public method | ReadBool(IPlugin, String, Boolean) | Returns a bool from Values.
Public method | ReadDateTime(IPlugin, String) | Returns a nullable DateTime from Values. The DateTimeKind is local.
Public method | ReadDateTime(IPlugin, String, DateTime) | Returns a DateTime from Values. The DateTimeKind is local.
Public method | ReadDouble(IPlugin, String) | Returns a nullable double from Values.
Public method | ReadDouble(IPlugin, String, Double) | Returns a double from Values.
Public method | ReadInt(IPlugin, String) | Returns a nullable int from Values.
Public method | ReadInt(IPlugin, String, Int32) | Returns an integer from Values.
Public method | ReadLong(IPlugin, String) | Returns a nullable long from Values.
Public method | ReadLong(IPlugin, String, Int64) | Returns a long from Values.
Public method | ReadString | Returns a string from Values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IPlugin, String, Boolean) | Writes a bool into Values.
Public method | Write(IPlugin, String, DateTime) | Writes a DateTime into Values.
Public method | Write(IPlugin, String, Double) | Writes a double into Values.
Public method | Write(IPlugin, String, Int32) | Writes an int into Values.
Public method | Write(IPlugin, String, Int64) | Writes a long into Values.
Public method | WriteT(IPlugin, String, T) | Writes a value into Values.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadBool Method

PluginSettingsReadBool Method
Overload List
 | Name | Description
Public method | ReadBool(IPlugin, String) | Returns a nullable bool from Values.
Public method | ReadBool(IPlugin, String, Boolean) | Returns a bool from Values.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadBool Method (IPlugin, String)

PluginSettingsReadBool Method (IPlugin, String)
Returns a nullable bool from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> ReadBool(
    IPlugin plugin,
    string key
)
Public Function ReadBool (
    plugin As IPlugin,
    key As String
) As Nullable(Of Boolean)
public:
Nullable<bool> ReadBool(
    IPlugin^ plugin,
    String^ key
)
member ReadBool :
        plugin : IPlugin *
        key : string -> Nullable<bool>

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString

Return Value

Type: Nullable Boolean
See Also

Reference

PluginSettings Class
ReadBool Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadBool Method (IPlugin, String, Boolean)

PluginSettingsReadBool Method (IPlugin, String, Boolean)
Returns a bool from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadBool(
    IPlugin plugin,
    string key,
    bool defaultValue
)
Public Function ReadBool (
    plugin As IPlugin,
    key As String,
    defaultValue As Boolean
) As Boolean
public:
bool ReadBool(
    IPlugin^ plugin,
    String^ key,
    bool defaultValue
)
member ReadBool :
        plugin : IPlugin *
        key : string *
        defaultValue : bool -> bool

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
defaultValue
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

PluginSettings Class
ReadBool Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadDateTime Method

PluginSettingsReadDateTime Method
Overload List
 | Name | Description
Public method | ReadDateTime(IPlugin, String) | Returns a nullable DateTime from Values. The DateTimeKind is local.
Public method | ReadDateTime(IPlugin, String, DateTime) | Returns a DateTime from Values. The DateTimeKind is local.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadDateTime Method (IPlugin, String)

PluginSettingsReadDateTime Method (IPlugin, String)
Returns a nullable DateTime from Values. The DateTimeKind is local.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> ReadDateTime(
    IPlugin plugin,
    string key
)
Public Function ReadDateTime (
    plugin As IPlugin,
    key As String
) As Nullable(Of DateTime)
public:
Nullable<DateTime> ReadDateTime(
    IPlugin^ plugin,
    String^ key
)
member ReadDateTime :
        plugin : IPlugin *
        key : string -> Nullable<DateTime>

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString

Return Value

Type: Nullable DateTime
See Also

Reference

PluginSettings Class
ReadDateTime Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadDateTime Method (IPlugin, String, DateTime)

PluginSettingsReadDateTime Method (IPlugin, String, DateTime)
Returns a DateTime from Values. The DateTimeKind is local.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ReadDateTime(
    IPlugin plugin,
    string key,
    DateTime defaultValue
)
Public Function ReadDateTime (
    plugin As IPlugin,
    key As String,
    defaultValue As DateTime
) As DateTime
public:
DateTime ReadDateTime(
    IPlugin^ plugin,
    String^ key,
    DateTime defaultValue
)
member ReadDateTime :
        plugin : IPlugin *
        key : string *
        defaultValue : DateTime -> DateTime

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
defaultValue
Type: SystemDateTime

Return Value

Type: DateTime
See Also

Reference

PluginSettings Class
ReadDateTime Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadDouble Method

PluginSettingsReadDouble Method
Overload List
 | Name | Description
Public method | ReadDouble(IPlugin, String) | Returns a nullable double from Values.
Public method | ReadDouble(IPlugin, String, Double) | Returns a double from Values.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadDouble Method (IPlugin, String)

PluginSettingsReadDouble Method (IPlugin, String)
Returns a nullable double from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> ReadDouble(
    IPlugin plugin,
    string key
)
Public Function ReadDouble (
    plugin As IPlugin,
    key As String
) As Nullable(Of Double)
public:
Nullable<double> ReadDouble(
    IPlugin^ plugin,
    String^ key
)
member ReadDouble :
        plugin : IPlugin *
        key : string -> Nullable<float>

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString

Return Value

Type: Nullable Double
See Also

Reference

PluginSettings Class
ReadDouble Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadDouble Method (IPlugin, String, Double)

PluginSettingsReadDouble Method (IPlugin, String, Double)
Returns a double from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ReadDouble(
    IPlugin plugin,
    string key,
    double defaultValue
)
Public Function ReadDouble (
    plugin As IPlugin,
    key As String,
    defaultValue As Double
) As Double
public:
double ReadDouble(
    IPlugin^ plugin,
    String^ key,
    double defaultValue
)
member ReadDouble :
        plugin : IPlugin *
        key : string *
        defaultValue : float -> float

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
defaultValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

PluginSettings Class
ReadDouble Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadInt Method

PluginSettingsReadInt Method
Overload List
 | Name | Description
Public method | ReadInt(IPlugin, String) | Returns a nullable int from Values.
Public method | ReadInt(IPlugin, String, Int32) | Returns an integer from Values.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadInt Method (IPlugin, String)

PluginSettingsReadInt Method (IPlugin, String)
Returns a nullable int from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ReadInt(
    IPlugin plugin,
    string key
)
Public Function ReadInt (
    plugin As IPlugin,
    key As String
) As Nullable(Of Integer)
public:
Nullable<int> ReadInt(
    IPlugin^ plugin,
    String^ key
)
member ReadInt :
        plugin : IPlugin *
        key : string -> Nullable<int>

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString

Return Value

Type: Nullable Int32
See Also

Reference

PluginSettings Class
ReadInt Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadInt Method (IPlugin, String, Int32)

PluginSettingsReadInt Method (IPlugin, String, Int32)
Returns an integer from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReadInt(
    IPlugin plugin,
    string key,
    int defaultValue
)
Public Function ReadInt (
    plugin As IPlugin,
    key As String,
    defaultValue As Integer
) As Integer
public:
int ReadInt(
    IPlugin^ plugin,
    String^ key,
    int defaultValue
)
member ReadInt :
        plugin : IPlugin *
        key : string *
        defaultValue : int -> int

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
defaultValue
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

PluginSettings Class
ReadInt Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadLong Method

PluginSettingsReadLong Method
Overload List
 | Name | Description
Public method | ReadLong(IPlugin, String) | Returns a nullable long from Values.
Public method | ReadLong(IPlugin, String, Int64) | Returns a long from Values.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadLong Method (IPlugin, String)

PluginSettingsReadLong Method (IPlugin, String)
Returns a nullable long from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> ReadLong(
    IPlugin plugin,
    string key
)
Public Function ReadLong (
    plugin As IPlugin,
    key As String
) As Nullable(Of Long)
public:
Nullable<long long> ReadLong(
    IPlugin^ plugin,
    String^ key
)
member ReadLong :
        plugin : IPlugin *
        key : string -> Nullable<int64>

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString

Return Value

Type: Nullable Int64
See Also

Reference

PluginSettings Class
ReadLong Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadLong Method (IPlugin, String, Int64)

PluginSettingsReadLong Method (IPlugin, String, Int64)
Returns a long from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ReadLong(
    IPlugin plugin,
    string key,
    long defaultValue
)
Public Function ReadLong (
    plugin As IPlugin,
    key As String,
    defaultValue As Long
) As Long
public:
long long ReadLong(
    IPlugin^ plugin,
    String^ key,
    long long defaultValue
)
member ReadLong :
        plugin : IPlugin *
        key : string *
        defaultValue : int64 -> int64

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
defaultValue
Type: SystemInt64

Return Value

Type: Int64
See Also

Reference

PluginSettings Class
ReadLong Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.ReadString Method

PluginSettingsReadString Method
Returns a string from Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReadString(
    IPlugin plugin,
    string key
)
Public Function ReadString (
    plugin As IPlugin,
    key As String
) As String
public:
String^ ReadString(
    IPlugin^ plugin,
    String^ key
)
member ReadString :
        plugin : IPlugin *
        key : string -> string

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString

Return Value

Type: String
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write Method

PluginSettingsWrite Method
Overload List
 | Name | Description
Public method | Write(IPlugin, String, Boolean) | Writes a bool into Values.
Public method | Write(IPlugin, String, DateTime) | Writes a DateTime into Values.
Public method | Write(IPlugin, String, Double) | Writes a double into Values.
Public method | Write(IPlugin, String, Int32) | Writes an int into Values.
Public method | Write(IPlugin, String, Int64) | Writes a long into Values.
Public method | WriteT(IPlugin, String, T) | Writes a value into Values.
Top
See Also

Reference

PluginSettings Class
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write Method (IPlugin, String, Boolean)

PluginSettingsWrite Method (IPlugin, String, Boolean)
Writes a bool into Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Write(
    IPlugin plugin,
    string key,
    bool value
)
Public Sub Write (
    plugin As IPlugin,
    key As String,
    value As Boolean
)
public:
void Write(
    IPlugin^ plugin,
    String^ key,
    bool value
)
member Write :
        plugin : IPlugin *
        key : string *
        value : bool -> unit

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
value
Type: SystemBoolean
See Also

Reference

PluginSettings Class
Write Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write Method (IPlugin, String, DateTime)

PluginSettingsWrite Method (IPlugin, String, DateTime)
Writes a DateTime into Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Write(
    IPlugin plugin,
    string key,
    DateTime value
)
Public Sub Write (
    plugin As IPlugin,
    key As String,
    value As DateTime
)
public:
void Write(
    IPlugin^ plugin,
    String^ key,
    DateTime value
)
member Write :
        plugin : IPlugin *
        key : string *
        value : DateTime -> unit

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
value
Type: SystemDateTime
See Also

Reference

PluginSettings Class
Write Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write Method (IPlugin, String, Double)

PluginSettingsWrite Method (IPlugin, String, Double)
Writes a double into Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Write(
    IPlugin plugin,
    string key,
    double value
)
Public Sub Write (
    plugin As IPlugin,
    key As String,
    value As Double
)
public:
void Write(
    IPlugin^ plugin,
    String^ key,
    double value
)
member Write :
        plugin : IPlugin *
        key : string *
        value : float -> unit

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
value
Type: SystemDouble
See Also

Reference

PluginSettings Class
Write Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write Method (IPlugin, String, Int32)

PluginSettingsWrite Method (IPlugin, String, Int32)
Writes an int into Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Write(
    IPlugin plugin,
    string key,
    int value
)
Public Sub Write (
    plugin As IPlugin,
    key As String,
    value As Integer
)
public:
void Write(
    IPlugin^ plugin,
    String^ key,
    int value
)
member Write :
        plugin : IPlugin *
        key : string *
        value : int -> unit

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
value
Type: SystemInt32
See Also

Reference

PluginSettings Class
Write Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write Method (IPlugin, String, Int64)

PluginSettingsWrite Method (IPlugin, String, Int64)
Writes a long into Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Write(
    IPlugin plugin,
    string key,
    long value
)
Public Sub Write (
    plugin As IPlugin,
    key As String,
    value As Long
)
public:
void Write(
    IPlugin^ plugin,
    String^ key,
    long long value
)
member Write :
        plugin : IPlugin *
        key : string *
        value : int64 -> unit

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
value
Type: SystemInt64
See Also

Reference

PluginSettings Class
Write Overload
VirtualRadar.Interface.Settings Namespace


PluginSettings.Write(T) Method (IPlugin, String, T)

PluginSettingsWriteT Method (IPlugin, String, T)
Writes a value into Values.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Write<T>(
    IPlugin plugin,
    string key,
    T value
)

Public Sub Write(Of T) (
    plugin As IPlugin,
    key As String,
    value As T
)
public:
generic<typename T>
void Write(
    IPlugin^ plugin,
    String^ key,
    T value
)
member Write :
        plugin : IPlugin *
        key : string *
        value : 'T -> unit

Parameters

plugin
Type: VirtualRadar.InterfaceIPlugin
key
Type: SystemString
value
Type: T

Type Parameters

T
See Also

Reference

PluginSettings Class
Write Overload
VirtualRadar.Interface.Settings Namespace


ProxyType Enumeration

ProxyType Enumeration
An enumeration of the type of proxies that the server is sitting behind.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProxyType
Public Enumeration ProxyType
public enum class ProxyType
type ProxyType
Members
Member name | Value | Description
Unknown | 0 | The user hasn't specified what kind of proxy the server is behind.
Forward | 1 | A forward proxy is forwarding traffic to the server.
Reverse | 2 | A reverse proxy is mirroring traffic to the server.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


RawDecodingSettings Class

RawDecodingSettings Class
The data-transfer object that carries the configuration of the raw message decoder.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsRawDecodingSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RawDecodingSettings : INotifyPropertyChanged
<SerializableAttribute>
Public Class RawDecodingSettings
    Implements INotifyPropertyChanged
[SerializableAttribute]
public ref class RawDecodingSettings : INotifyPropertyChanged
[<SerializableAttribute>]
type RawDecodingSettings =
    class
        interface INotifyPropertyChanged
    end

The RawDecodingSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RawDecodingSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | AcceptableAirborneSpeed | Gets or sets the maximum number of kilometres an aircraft can travel while airborne over 30 seconds before a local position decode is deemed invalid.
Public property | AcceptableAirSurfaceTransitionSpeed | Gets or sets the maximum number of kilometres an aircraft can travel while landing or taking off over 30 seconds before a local position decode is deemed invalid.
Public property | AcceptableSurfaceSpeed | Gets or sets the maximum number of kilometres an surface vehicle can travel over 30 seconds before a local position decode is deemed invalid.
Public property | AcceptIcaoInNonPICount | Gets or sets the number of times the same ICAO is seen in messages that do not have PI before it is accepted as valid.
Public property | AcceptIcaoInNonPISeconds | Gets or sets the number of seconds over which the same ICAO is seen in messages that do not have PI before it is accepted as valid.
Public property | AcceptIcaoInPI0Count | Gets or sets the number of times the same ICAO is seen in PI0 message before it is accepted as valid.
Public property | AcceptIcaoInPI0Seconds | Gets or sets the number of seconds over which the same ICAO is seen in PI0 messages before it is accepted as valid.
Public property | AirborneGlobalPositionLimit | Gets or sets the maximum number of seconds that can elapse when performing global decoding on airborne position messages.
Public property | FastSurfaceGlobalPositionLimit | Gets or sets the maximum number of seconds that can elapse when performing global decoding on surface position messages for vehicles travelling over 25 km/h.
Public property | IgnoreCallsignsInBds20 | Gets or sets a value indicating that callsigns should not be extracted from BDS2,0 messages.
Public property | IgnoreInvalidCodeBlockInOtherMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that do not have parity.
Public property | IgnoreInvalidCodeBlockInParityMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that have parity.
Public property | IgnoreMilitaryExtendedSquitter | Gets or sets a value indicating that DF19/AF0 is to be interpretted as an extended squitter message.
Public property | ReceiverLocationId | No longer used. Not marked as Obsolete because Microsoft decided it'd be a good idea to break loading and saving data via XmlSerialiser by ignoring Obsolete properties.
Public property | ReceiverRange | Gets or sets the range of the receiver in kilometres.
Public property | SlowSurfaceGlobalPositionLimit | Gets or sets the maximum number of seconds that can elapse when performing global decoding on surface position messages for vehicles travelling at or under 25 km/h.
Public property | SuppressIcao0 | Gets or sets a value indicating that ICAOs of 000000 are to be suppressed.
Public property | SuppressReceiverRangeCheck | Gets or sets a value indicating that decoded locations that are further away than the receiver can see are still allowed through, disabling part of the ICAO reasonableness tests.
Public property | SuppressTisbDecoding | Gets or sets a value indicating whether TIS-B messages should be used or ignored.
Public property | UseLocalDecodeForInitialPosition | Gets or sets a value indicating that local decoding should be used to determine the initial position of an aircraft instead of global decoding of an odd / even frame.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


RawDecodingSettings Constructor

RawDecodingSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RawDecodingSettings()
Public Sub New
public:
RawDecodingSettings()
new : unit -> RawDecodingSettings
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings Properties

RawDecodingSettings Properties

The RawDecodingSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcceptableAirborneSpeed | Gets or sets the maximum number of kilometres an aircraft can travel while airborne over 30 seconds before a local position decode is deemed invalid.
Public property | AcceptableAirSurfaceTransitionSpeed | Gets or sets the maximum number of kilometres an aircraft can travel while landing or taking off over 30 seconds before a local position decode is deemed invalid.
Public property | AcceptableSurfaceSpeed | Gets or sets the maximum number of kilometres an surface vehicle can travel over 30 seconds before a local position decode is deemed invalid.
Public property | AcceptIcaoInNonPICount | Gets or sets the number of times the same ICAO is seen in messages that do not have PI before it is accepted as valid.
Public property | AcceptIcaoInNonPISeconds | Gets or sets the number of seconds over which the same ICAO is seen in messages that do not have PI before it is accepted as valid.
Public property | AcceptIcaoInPI0Count | Gets or sets the number of times the same ICAO is seen in PI0 message before it is accepted as valid.
Public property | AcceptIcaoInPI0Seconds | Gets or sets the number of seconds over which the same ICAO is seen in PI0 messages before it is accepted as valid.
Public property | AirborneGlobalPositionLimit | Gets or sets the maximum number of seconds that can elapse when performing global decoding on airborne position messages.
Public property | FastSurfaceGlobalPositionLimit | Gets or sets the maximum number of seconds that can elapse when performing global decoding on surface position messages for vehicles travelling over 25 km/h.
Public property | IgnoreCallsignsInBds20 | Gets or sets a value indicating that callsigns should not be extracted from BDS2,0 messages.
Public property | IgnoreInvalidCodeBlockInOtherMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that do not have parity.
Public property | IgnoreInvalidCodeBlockInParityMessages | Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that have parity.
Public property | IgnoreMilitaryExtendedSquitter | Gets or sets a value indicating that DF19/AF0 is to be interpretted as an extended squitter message.
Public property | ReceiverLocationId | No longer used. Not marked as Obsolete because Microsoft decided it'd be a good idea to break loading and saving data via XmlSerialiser by ignoring Obsolete properties.
Public property | ReceiverRange | Gets or sets the range of the receiver in kilometres.
Public property | SlowSurfaceGlobalPositionLimit | Gets or sets the maximum number of seconds that can elapse when performing global decoding on surface position messages for vehicles travelling at or under 25 km/h.
Public property | SuppressIcao0 | Gets or sets a value indicating that ICAOs of 000000 are to be suppressed.
Public property | SuppressReceiverRangeCheck | Gets or sets a value indicating that decoded locations that are further away than the receiver can see are still allowed through, disabling part of the ICAO reasonableness tests.
Public property | SuppressTisbDecoding | Gets or sets a value indicating whether TIS-B messages should be used or ignored.
Public property | UseLocalDecodeForInitialPosition | Gets or sets a value indicating that local decoding should be used to determine the initial position of an aircraft instead of global decoding of an odd / even frame.
Top
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptableAirborneSpeed Property

RawDecodingSettingsAcceptableAirborneSpeed Property
Gets or sets the maximum number of kilometres an aircraft can travel while airborne over 30 seconds before a local position decode is deemed invalid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AcceptableAirborneSpeed { get; set; }
Public Property AcceptableAirborneSpeed As Double
    Get
    Set
public:
property double AcceptableAirborneSpeed {
    double get ();
    void set (double value);
}
member AcceptableAirborneSpeed : float with get, set

Property Value

Type: Double
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptableAirSurfaceTransitionSpeed Property

RawDecodingSettingsAcceptableAirSurfaceTransitionSpeed Property
Gets or sets the maximum number of kilometres an aircraft can travel while landing or taking off over 30 seconds before a local position decode is deemed invalid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AcceptableAirSurfaceTransitionSpeed { get; set; }
Public Property AcceptableAirSurfaceTransitionSpeed As Double
    Get
    Set
public:
property double AcceptableAirSurfaceTransitionSpeed {
    double get ();
    void set (double value);
}
member AcceptableAirSurfaceTransitionSpeed : float with get, set

Property Value

Type: Double
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptableSurfaceSpeed Property

RawDecodingSettingsAcceptableSurfaceSpeed Property
Gets or sets the maximum number of kilometres an surface vehicle can travel over 30 seconds before a local position decode is deemed invalid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AcceptableSurfaceSpeed { get; set; }
Public Property AcceptableSurfaceSpeed As Double
    Get
    Set
public:
property double AcceptableSurfaceSpeed {
    double get ();
    void set (double value);
}
member AcceptableSurfaceSpeed : float with get, set

Property Value

Type: Double
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptIcaoInNonPICount Property

RawDecodingSettingsAcceptIcaoInNonPICount Property
Gets or sets the number of times the same ICAO is seen in messages that do not have PI before it is accepted as valid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AcceptIcaoInNonPICount { get; set; }
Public Property AcceptIcaoInNonPICount As Integer
    Get
    Set
public:
property int AcceptIcaoInNonPICount {
    int get ();
    void set (int value);
}
member AcceptIcaoInNonPICount : int with get, set

Property Value

Type: Int32
Remarks
If this is zero then ICAOs are never accepted from messages that do not have PI.
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptIcaoInNonPISeconds Property

RawDecodingSettingsAcceptIcaoInNonPISeconds Property
Gets or sets the number of seconds over which the same ICAO is seen in messages that do not have PI before it is accepted as valid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AcceptIcaoInNonPISeconds { get; set; }
Public Property AcceptIcaoInNonPISeconds As Integer
    Get
    Set
public:
property int AcceptIcaoInNonPISeconds {
    int get ();
    void set (int value);
}
member AcceptIcaoInNonPISeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptIcaoInPI0Count Property

RawDecodingSettingsAcceptIcaoInPI0Count Property
Gets or sets the number of times the same ICAO is seen in PI0 message before it is accepted as valid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AcceptIcaoInPI0Count { get; set; }
Public Property AcceptIcaoInPI0Count As Integer
    Get
    Set
public:
property int AcceptIcaoInPI0Count {
    int get ();
    void set (int value);
}
member AcceptIcaoInPI0Count : int with get, set

Property Value

Type: Int32
Remarks
The minimum value for this is 1 - i.e. accept it immediately.
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AcceptIcaoInPI0Seconds Property

RawDecodingSettingsAcceptIcaoInPI0Seconds Property
Gets or sets the number of seconds over which the same ICAO is seen in PI0 messages before it is accepted as valid.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AcceptIcaoInPI0Seconds { get; set; }
Public Property AcceptIcaoInPI0Seconds As Integer
    Get
    Set
public:
property int AcceptIcaoInPI0Seconds {
    int get ();
    void set (int value);
}
member AcceptIcaoInPI0Seconds : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.AirborneGlobalPositionLimit Property

RawDecodingSettingsAirborneGlobalPositionLimit Property
Gets or sets the maximum number of seconds that can elapse when performing global decoding on airborne position messages.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AirborneGlobalPositionLimit { get; set; }
Public Property AirborneGlobalPositionLimit As Integer
    Get
    Set
public:
property int AirborneGlobalPositionLimit {
    int get ();
    void set (int value);
}
member AirborneGlobalPositionLimit : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.FastSurfaceGlobalPositionLimit Property

RawDecodingSettingsFastSurfaceGlobalPositionLimit Property
Gets or sets the maximum number of seconds that can elapse when performing global decoding on surface position messages for vehicles travelling over 25 km/h.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FastSurfaceGlobalPositionLimit { get; set; }
Public Property FastSurfaceGlobalPositionLimit As Integer
    Get
    Set
public:
property int FastSurfaceGlobalPositionLimit {
    int get ();
    void set (int value);
}
member FastSurfaceGlobalPositionLimit : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.IgnoreCallsignsInBds20 Property

RawDecodingSettingsIgnoreCallsignsInBds20 Property
Gets or sets a value indicating that callsigns should not be extracted from BDS2,0 messages.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreCallsignsInBds20 { get; set; }
Public Property IgnoreCallsignsInBds20 As Boolean
    Get
    Set
public:
property bool IgnoreCallsignsInBds20 {
    bool get ();
    void set (bool value);
}
member IgnoreCallsignsInBds20 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.IgnoreInvalidCodeBlockInOtherMessages Property

RawDecodingSettingsIgnoreInvalidCodeBlockInOtherMessages Property
Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that do not have parity.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreInvalidCodeBlockInOtherMessages { get; set; }
Public Property IgnoreInvalidCodeBlockInOtherMessages As Boolean
    Get
    Set
public:
property bool IgnoreInvalidCodeBlockInOtherMessages {
    bool get ();
    void set (bool value);
}
member IgnoreInvalidCodeBlockInOtherMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.IgnoreInvalidCodeBlockInParityMessages Property

RawDecodingSettingsIgnoreInvalidCodeBlockInParityMessages Property
Gets or sets a value indicating that ICAOs that are not in a recognised code block are to be ignored for messages that have parity.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreInvalidCodeBlockInParityMessages { get; set; }
Public Property IgnoreInvalidCodeBlockInParityMessages As Boolean
    Get
    Set
public:
property bool IgnoreInvalidCodeBlockInParityMessages {
    bool get ();
    void set (bool value);
}
member IgnoreInvalidCodeBlockInParityMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.IgnoreMilitaryExtendedSquitter Property

RawDecodingSettingsIgnoreMilitaryExtendedSquitter Property
Gets or sets a value indicating that DF19/AF0 is to be interpretted as an extended squitter message.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreMilitaryExtendedSquitter { get; set; }
Public Property IgnoreMilitaryExtendedSquitter As Boolean
    Get
    Set
public:
property bool IgnoreMilitaryExtendedSquitter {
    bool get ();
    void set (bool value);
}
member IgnoreMilitaryExtendedSquitter : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.ReceiverLocationId Property

RawDecodingSettingsReceiverLocationId Property
No longer used. Not marked as Obsolete because Microsoft decided it'd be a good idea to break loading and saving data via XmlSerialiser by ignoring Obsolete properties.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReceiverLocationId { get; set; }
Public Property ReceiverLocationId As Integer
    Get
    Set
public:
property int ReceiverLocationId {
    int get ();
    void set (int value);
}
member ReceiverLocationId : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.ReceiverRange Property

RawDecodingSettingsReceiverRange Property
Gets or sets the range of the receiver in kilometres.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReceiverRange { get; set; }
Public Property ReceiverRange As Integer
    Get
    Set
public:
property int ReceiverRange {
    int get ();
    void set (int value);
}
member ReceiverRange : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.SlowSurfaceGlobalPositionLimit Property

RawDecodingSettingsSlowSurfaceGlobalPositionLimit Property
Gets or sets the maximum number of seconds that can elapse when performing global decoding on surface position messages for vehicles travelling at or under 25 km/h.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SlowSurfaceGlobalPositionLimit { get; set; }
Public Property SlowSurfaceGlobalPositionLimit As Integer
    Get
    Set
public:
property int SlowSurfaceGlobalPositionLimit {
    int get ();
    void set (int value);
}
member SlowSurfaceGlobalPositionLimit : int with get, set

Property Value

Type: Int32
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.SuppressIcao0 Property

RawDecodingSettingsSuppressIcao0 Property
Gets or sets a value indicating that ICAOs of 000000 are to be suppressed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressIcao0 { get; set; }
Public Property SuppressIcao0 As Boolean
    Get
    Set
public:
property bool SuppressIcao0 {
    bool get ();
    void set (bool value);
}
member SuppressIcao0 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.SuppressReceiverRangeCheck Property

RawDecodingSettingsSuppressReceiverRangeCheck Property
Gets or sets a value indicating that decoded locations that are further away than the receiver can see are still allowed through, disabling part of the ICAO reasonableness tests.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressReceiverRangeCheck { get; set; }
Public Property SuppressReceiverRangeCheck As Boolean
    Get
    Set
public:
property bool SuppressReceiverRangeCheck {
    bool get ();
    void set (bool value);
}
member SuppressReceiverRangeCheck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.SuppressTisbDecoding Property

RawDecodingSettingsSuppressTisbDecoding Property
Gets or sets a value indicating whether TIS-B messages should be used or ignored.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressTisbDecoding { get; set; }
Public Property SuppressTisbDecoding As Boolean
    Get
    Set
public:
property bool SuppressTisbDecoding {
    bool get ();
    void set (bool value);
}
member SuppressTisbDecoding : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.UseLocalDecodeForInitialPosition Property

RawDecodingSettingsUseLocalDecodeForInitialPosition Property
Gets or sets a value indicating that local decoding should be used to determine the initial position of an aircraft instead of global decoding of an odd / even frame.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseLocalDecodeForInitialPosition { get; set; }
Public Property UseLocalDecodeForInitialPosition As Boolean
    Get
    Set
public:
property bool UseLocalDecodeForInitialPosition {
    bool get ();
    void set (bool value);
}
member UseLocalDecodeForInitialPosition : bool with get, set

Property Value

Type: Boolean
Remarks
If the aircraft is so far away that the local decode produces the wrong position then it will eventually be picked up by the ICAO reasonableness tests (perform global decode using CPR values not used in the initial decode and confirm that position corresponds). If it fails that test then the position is reset and the next initial fix is forced to be made using a global decode.
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings Methods

RawDecodingSettings Methods

The RawDecodingSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.OnPropertyChanged Method

RawDecodingSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.SetField(T) Method

RawDecodingSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings Events

RawDecodingSettings Events

The RawDecodingSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RawDecodingSettings.PropertyChanged Event

RawDecodingSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

RawDecodingSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat Class

RebroadcastFormat Class
A collection of strings describing the UniqueId values for the rebroadcast server formats that ship with VRS.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsRebroadcastFormat

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebroadcastFormat
Public NotInheritable Class RebroadcastFormat
public ref class RebroadcastFormat abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebroadcastFormat =  class end

The RebroadcastFormat type exposes the following members.

Properties
Name | Description
AllInternalFormats | A collection of all rebroadcast server formats that ship with VRS. The server doesn't use this, it's to help make life easier with unit testing.
Top
Fields
Name | Description
AircraftListJson | Changes to the aircraft list are periodically sent as JSON. On the receiving side the JSON is translated into a set of BaseStation messages, one per aircraft.
Avr | The Mode-S messages are rebroadcast in either * or : AVR format, depending on whether the original Mode-S message source had parity stripped or not.
CompressedVRS | The Port30003 messages are compressed before broadcast.
ExtendedBaseStation | Same as BaseStation except if the message is an MLAT generated message then MLAT is sent instead of MSG.
Passthrough | The original messages from the receiver are rebroadcast without change.
Port30003 | The Port30003 messages derived from the receiver's transmissions are rebroadcast.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


RebroadcastFormat Properties

RebroadcastFormat Properties

The RebroadcastFormat type exposes the following members.

Properties
Name | Description
AllInternalFormats | A collection of all rebroadcast server formats that ship with VRS. The server doesn't use this, it's to help make life easier with unit testing.
Top
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.AllInternalFormats Property

RebroadcastFormatAllInternalFormats Property
A collection of all rebroadcast server formats that ship with VRS. The server doesn't use this, it's to help make life easier with unit testing.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] AllInternalFormats { get; }
Public Shared ReadOnly Property AllInternalFormats As String()
    Get
public:
static property array<String^>^ AllInternalFormats {
    array<String^>^ get ();
}
static member AllInternalFormats : string[] with get

Property Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat Fields

RebroadcastFormat Fields

The RebroadcastFormat type exposes the following members.

Fields
Name | Description
AircraftListJson | Changes to the aircraft list are periodically sent as JSON. On the receiving side the JSON is translated into a set of BaseStation messages, one per aircraft.
Avr | The Mode-S messages are rebroadcast in either * or : AVR format, depending on whether the original Mode-S message source had parity stripped or not.
CompressedVRS | The Port30003 messages are compressed before broadcast.
ExtendedBaseStation | Same as BaseStation except if the message is an MLAT generated message then MLAT is sent instead of MSG.
Passthrough | The original messages from the receiver are rebroadcast without change.
Port30003 | The Port30003 messages derived from the receiver's transmissions are rebroadcast.
Top
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.AircraftListJson Field

RebroadcastFormatAircraftListJson Field
Changes to the aircraft list are periodically sent as JSON. On the receiving side the JSON is translated into a set of BaseStation messages, one per aircraft.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string AircraftListJson
Public Shared ReadOnly AircraftListJson As String
public:
static initonly String^ AircraftListJson
static val AircraftListJson: string

Field Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.Avr Field

RebroadcastFormatAvr Field
The Mode-S messages are rebroadcast in either * or : AVR format, depending on whether the original Mode-S message source had parity stripped or not.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string Avr
Public Shared ReadOnly Avr As String
public:
static initonly String^ Avr
static val Avr: string

Field Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.CompressedVRS Field

RebroadcastFormatCompressedVRS Field
The Port30003 messages are compressed before broadcast.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string CompressedVRS
Public Shared ReadOnly CompressedVRS As String
public:
static initonly String^ CompressedVRS
static val CompressedVRS: string

Field Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.ExtendedBaseStation Field

RebroadcastFormatExtendedBaseStation Field
Same as BaseStation except if the message is an MLAT generated message then MLAT is sent instead of MSG.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string ExtendedBaseStation
Public Shared ReadOnly ExtendedBaseStation As String
public:
static initonly String^ ExtendedBaseStation
static val ExtendedBaseStation: string

Field Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.Passthrough Field

RebroadcastFormatPassthrough Field
The original messages from the receiver are rebroadcast without change.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string Passthrough
Public Shared ReadOnly Passthrough As String
public:
static initonly String^ Passthrough
static val Passthrough: string

Field Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastFormat.Port30003 Field

RebroadcastFormatPort30003 Field
The Port30003 messages derived from the receiver's transmissions are rebroadcast.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string Port30003
Public Shared ReadOnly Port30003 As String
public:
static initonly String^ Port30003
static val Port30003: string

Field Value

Type: String
See Also

Reference

RebroadcastFormat Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings Class

RebroadcastSettings Class
The settings for the rebroadcast server.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsRebroadcastSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RebroadcastSettings : INotifyPropertyChanged
<SerializableAttribute>
Public Class RebroadcastSettings
    Implements INotifyPropertyChanged
[SerializableAttribute]
public ref class RebroadcastSettings : INotifyPropertyChanged
[<SerializableAttribute>]
type RebroadcastSettings =
    class
        interface INotifyPropertyChanged
    end

The RebroadcastSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RebroadcastSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | Access | Gets or sets the access settings for the rebroadcast server.
Public property | Enabled | Gets or sets a value indicating whether the rebroadcast server is enabled.
Public property | Format | Gets or sets the format in which to rebroadcast the receiver's messages.
Public property | IdleTimeoutMilliseconds | Gets or sets the period of time that the receiving side has to accept a message within before the connection is dropped.
Public property | IsTransmitter | Gets or sets a value that indicates whether the rebroadcast server is active (it transmits the feed to another machine) or passive (it accepts multiple connections from other machines).
Public property | Name | Gets or sets the unique name for the server.
Public property | Passphrase | Gets or sets the passphrase that the connecting side has to send before the connection is accepted.
Public property | Port | Gets or sets the port number to rebroadcast the receiver's messages on or the port to transmit the feed to.
Public property | ReceiverId | Gets or sets the receiver that the rebroadcast server will rebroadcast.
Public property | SendIntervalMilliseconds | Gets or sets the delay between sends for formats that lend themselves to message batching.
Public property | StaleSeconds | Gets or sets the threshold for discarding buffered messages that are too old.
Public property | TransmitAddress | Gets or sets the address of the machine to send the feed to in Transmitter mode.
Public property | UniqueId | Gets or sets the unique identifier for the server. This cannot be zero.
Public property | UseKeepAlive | Gets or sets a value indicating that the network connection should use KeepAlive packets.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


RebroadcastSettings Constructor

RebroadcastSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastSettings()
Public Sub New
public:
RebroadcastSettings()
new : unit -> RebroadcastSettings
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings Properties

RebroadcastSettings Properties

The RebroadcastSettings type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets or sets the access settings for the rebroadcast server.
Public property | Enabled | Gets or sets a value indicating whether the rebroadcast server is enabled.
Public property | Format | Gets or sets the format in which to rebroadcast the receiver's messages.
Public property | IdleTimeoutMilliseconds | Gets or sets the period of time that the receiving side has to accept a message within before the connection is dropped.
Public property | IsTransmitter | Gets or sets a value that indicates whether the rebroadcast server is active (it transmits the feed to another machine) or passive (it accepts multiple connections from other machines).
Public property | Name | Gets or sets the unique name for the server.
Public property | Passphrase | Gets or sets the passphrase that the connecting side has to send before the connection is accepted.
Public property | Port | Gets or sets the port number to rebroadcast the receiver's messages on or the port to transmit the feed to.
Public property | ReceiverId | Gets or sets the receiver that the rebroadcast server will rebroadcast.
Public property | SendIntervalMilliseconds | Gets or sets the delay between sends for formats that lend themselves to message batching.
Public property | StaleSeconds | Gets or sets the threshold for discarding buffered messages that are too old.
Public property | TransmitAddress | Gets or sets the address of the machine to send the feed to in Transmitter mode.
Public property | UniqueId | Gets or sets the unique identifier for the server. This cannot be zero.
Public property | UseKeepAlive | Gets or sets a value indicating that the network connection should use KeepAlive packets.
Top
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.Access Property

RebroadcastSettingsAccess Property
Gets or sets the access settings for the rebroadcast server.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Access Access { get; set; }
Public Property Access As Access
    Get
    Set
public:
property Access^ Access {
    Access^ get ();
    void set (Access^ value);
}
member Access : Access with get, set

Property Value

Type: Access
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.Enabled Property

RebroadcastSettingsEnabled Property
Gets or sets a value indicating whether the rebroadcast server is enabled.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.Format Property

RebroadcastSettingsFormat Property
Gets or sets the format in which to rebroadcast the receiver's messages.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Property Value

Type: String
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.IdleTimeoutMilliseconds Property

RebroadcastSettingsIdleTimeoutMilliseconds Property
Gets or sets the period of time that the receiving side has to accept a message within before the connection is dropped.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IdleTimeoutMilliseconds { get; set; }
Public Property IdleTimeoutMilliseconds As Integer
    Get
    Set
public:
property int IdleTimeoutMilliseconds {
    int get ();
    void set (int value);
}
member IdleTimeoutMilliseconds : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.IsTransmitter Property

RebroadcastSettingsIsTransmitter Property
Gets or sets a value that indicates whether the rebroadcast server is active (it transmits the feed to another machine) or passive (it accepts multiple connections from other machines).

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransmitter { get; set; }
Public Property IsTransmitter As Boolean
    Get
    Set
public:
property bool IsTransmitter {
    bool get ();
    void set (bool value);
}
member IsTransmitter : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.Name Property

RebroadcastSettingsName Property
Gets or sets the unique name for the server.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.Passphrase Property

RebroadcastSettingsPassphrase Property
Gets or sets the passphrase that the connecting side has to send before the connection is accepted.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Passphrase { get; set; }
Public Property Passphrase As String
    Get
    Set
public:
property String^ Passphrase {
    String^ get ();
    void set (String^ value);
}
member Passphrase : string with get, set

Property Value

Type: String
Remarks
If this is null or empty then no passphrase is required.
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.Port Property

RebroadcastSettingsPort Property
Gets or sets the port number to rebroadcast the receiver's messages on or the port to transmit the feed to.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.ReceiverId Property

RebroadcastSettingsReceiverId Property
Gets or sets the receiver that the rebroadcast server will rebroadcast.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReceiverId { get; set; }
Public Property ReceiverId As Integer
    Get
    Set
public:
property int ReceiverId {
    int get ();
    void set (int value);
}
member ReceiverId : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.SendIntervalMilliseconds Property

RebroadcastSettingsSendIntervalMilliseconds Property
Gets or sets the delay between sends for formats that lend themselves to message batching.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SendIntervalMilliseconds { get; set; }
Public Property SendIntervalMilliseconds As Integer
    Get
    Set
public:
property int SendIntervalMilliseconds {
    int get ();
    void set (int value);
}
member SendIntervalMilliseconds : int with get, set

Property Value

Type: Int32
Remarks
At the time of writing the only format that uses this is AircraftListJson.
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.StaleSeconds Property

RebroadcastSettingsStaleSeconds Property
Gets or sets the threshold for discarding buffered messages that are too old.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StaleSeconds { get; set; }
Public Property StaleSeconds As Integer
    Get
    Set
public:
property int StaleSeconds {
    int get ();
    void set (int value);
}
member StaleSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.TransmitAddress Property

RebroadcastSettingsTransmitAddress Property
Gets or sets the address of the machine to send the feed to in Transmitter mode.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TransmitAddress { get; set; }
Public Property TransmitAddress As String
    Get
    Set
public:
property String^ TransmitAddress {
    String^ get ();
    void set (String^ value);
}
member TransmitAddress : string with get, set

Property Value

Type: String
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.UniqueId Property

RebroadcastSettingsUniqueId Property
Gets or sets the unique identifier for the server. This cannot be zero.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.UseKeepAlive Property

RebroadcastSettingsUseKeepAlive Property
Gets or sets a value indicating that the network connection should use KeepAlive packets.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseKeepAlive { get; set; }
Public Property UseKeepAlive As Boolean
    Get
    Set
public:
property bool UseKeepAlive {
    bool get ();
    void set (bool value);
}
member UseKeepAlive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings Methods

RebroadcastSettings Methods

The RebroadcastSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.OnPropertyChanged Method

RebroadcastSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.SetField(T) Method

RebroadcastSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings Events

RebroadcastSettings Events

The RebroadcastSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


RebroadcastSettings.PropertyChanged Event

RebroadcastSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

RebroadcastSettings Class
VirtualRadar.Interface.Settings Namespace


Receiver Class

Receiver Class
A settings object that carries information about a receiever.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsReceiver

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Receiver : INotifyPropertyChanged
Public Class Receiver
    Implements INotifyPropertyChanged
public ref class Receiver : INotifyPropertyChanged
type Receiver =
    class
        interface INotifyPropertyChanged
    end

The Receiver type exposes the following members.

Constructors
 | Name | Description
Public method | Receiver | Creates a new object.
Top
Properties
 | Name | Description
Public property | Access | Gets or sets the access settings to use when the receiver is in passive mode.
Public property | Address | Gets or sets the address of the source of data to listen to.
Public property | AutoReconnectAtStartup | Obsolete since version 2.0.3. Network connections now always reconnect until you disable them.
Public property | BaudRate | Gets or sets the baud rate to use.
Public property | ComPort | Gets or sets the COM port to listen to.
Public property | ConnectionType | Gets or sets the mechanism to use to connect to the data source.
Public property | DataBits | Gets or sets the data bits to use.
Public property | DataSource | Gets or sets the unique ID of the IReceiverFormatProvider that will handle the feed from the receiever.
Public property | Enabled | Gets or sets a value indicating that the receiver is to be used.
Public property | Handshake | Gets or sets the handshake protocol to use.
Public property | IdleTimeoutMilliseconds | Gets or sets the period of time that must elapse with no received content before the network connection is reset.
Public property | IsPassive | Gets or sets a value indicating that the receiver will not connect to the source but will instead wait for the source to connect to it.
Public property | IsSatcomFeed | Gets or sets a value indicating that the feed is coming off a satellite.
Public property | Name | Gets or sets the unique name of the receiver.
Public property | Parity | Gets or sets the parity to use.
Public property | Passphrase | Gets or sets the passphrase that the other side is expecting us to send in order to authenticate.
Public property | Port | Gets or sets the port of the source of data to listen to.
Public property | ReceiverLocationId | Gets or sets the identifier of the receiever location record associated with the receiver.
Public property | ReceiverUsage | Gets or sets a value indicating how the receiver should be used by the system.
Public property | ShutdownText | Gets or sets the text to send across the COM port on shutdown - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StartupText | Gets or sets the text to send across the COM port on startup - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StopBits | Gets or sets the stop bits to use.
Public property | UniqueId | Gets or sets a unique identifier for the receiever. This is unique across receivers and merged feeds. It cannot be zero.
Public property | UseKeepAlive | Gets or sets a value indicating that the network connection should use KeepAlive packets.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | See base class docs. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


Receiver Constructor

Receiver Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Receiver()
Public Sub New
public:
Receiver()
new : unit -> Receiver
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver Properties

Receiver Properties

The Receiver type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets or sets the access settings to use when the receiver is in passive mode.
Public property | Address | Gets or sets the address of the source of data to listen to.
Public property | AutoReconnectAtStartup | Obsolete since version 2.0.3. Network connections now always reconnect until you disable them.
Public property | BaudRate | Gets or sets the baud rate to use.
Public property | ComPort | Gets or sets the COM port to listen to.
Public property | ConnectionType | Gets or sets the mechanism to use to connect to the data source.
Public property | DataBits | Gets or sets the data bits to use.
Public property | DataSource | Gets or sets the unique ID of the IReceiverFormatProvider that will handle the feed from the receiever.
Public property | Enabled | Gets or sets a value indicating that the receiver is to be used.
Public property | Handshake | Gets or sets the handshake protocol to use.
Public property | IdleTimeoutMilliseconds | Gets or sets the period of time that must elapse with no received content before the network connection is reset.
Public property | IsPassive | Gets or sets a value indicating that the receiver will not connect to the source but will instead wait for the source to connect to it.
Public property | IsSatcomFeed | Gets or sets a value indicating that the feed is coming off a satellite.
Public property | Name | Gets or sets the unique name of the receiver.
Public property | Parity | Gets or sets the parity to use.
Public property | Passphrase | Gets or sets the passphrase that the other side is expecting us to send in order to authenticate.
Public property | Port | Gets or sets the port of the source of data to listen to.
Public property | ReceiverLocationId | Gets or sets the identifier of the receiever location record associated with the receiver.
Public property | ReceiverUsage | Gets or sets a value indicating how the receiver should be used by the system.
Public property | ShutdownText | Gets or sets the text to send across the COM port on shutdown - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StartupText | Gets or sets the text to send across the COM port on startup - a null or empty string will disable the feature. Can contain \r and \n.
Public property | StopBits | Gets or sets the stop bits to use.
Public property | UniqueId | Gets or sets a unique identifier for the receiever. This is unique across receivers and merged feeds. It cannot be zero.
Public property | UseKeepAlive | Gets or sets a value indicating that the network connection should use KeepAlive packets.
Top
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Access Property

ReceiverAccess Property
Gets or sets the access settings to use when the receiver is in passive mode.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Access Access { get; set; }
Public Property Access As Access
    Get
    Set
public:
property Access^ Access {
    Access^ get ();
    void set (Access^ value);
}
member Access : Access with get, set

Property Value

Type: Access
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Address Property

ReceiverAddress Property
Gets or sets the address of the source of data to listen to.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.AutoReconnectAtStartup Property

ReceiverAutoReconnectAtStartup Property
Obsolete since version 2.0.3. Network connections now always reconnect until you disable them.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoReconnectAtStartup { get; set; }
Public Property AutoReconnectAtStartup As Boolean
    Get
    Set
public:
property bool AutoReconnectAtStartup {
    bool get ();
    void set (bool value);
}
member AutoReconnectAtStartup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.BaudRate Property

ReceiverBaudRate Property
Gets or sets the baud rate to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BaudRate { get; set; }
Public Property BaudRate As Integer
    Get
    Set
public:
property int BaudRate {
    int get ();
    void set (int value);
}
member BaudRate : int with get, set

Property Value

Type: Int32
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.ComPort Property

ReceiverComPort Property
Gets or sets the COM port to listen to.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ComPort { get; set; }
Public Property ComPort As String
    Get
    Set
public:
property String^ ComPort {
    String^ get ();
    void set (String^ value);
}
member ComPort : string with get, set

Property Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.ConnectionType Property

ReceiverConnectionType Property
Gets or sets the mechanism to use to connect to the data source.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionType ConnectionType { get; set; }
Public Property ConnectionType As ConnectionType
    Get
    Set
public:
property ConnectionType ConnectionType {
    ConnectionType get ();
    void set (ConnectionType value);
}
member ConnectionType : ConnectionType with get, set

Property Value

Type: ConnectionType
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.DataBits Property

ReceiverDataBits Property
Gets or sets the data bits to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DataBits { get; set; }
Public Property DataBits As Integer
    Get
    Set
public:
property int DataBits {
    int get ();
    void set (int value);
}
member DataBits : int with get, set

Property Value

Type: Int32
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.DataSource Property

ReceiverDataSource Property
Gets or sets the unique ID of the IReceiverFormatProvider that will handle the feed from the receiever.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DataSource { get; set; }
Public Property DataSource As String
    Get
    Set
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}
member DataSource : string with get, set

Property Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Enabled Property

ReceiverEnabled Property
Gets or sets a value indicating that the receiver is to be used.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Handshake Property

ReceiverHandshake Property
Gets or sets the handshake protocol to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Handshake Handshake { get; set; }
Public Property Handshake As Handshake
    Get
    Set
public:
property Handshake Handshake {
    Handshake get ();
    void set (Handshake value);
}
member Handshake : Handshake with get, set

Property Value

Type: Handshake
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.IdleTimeoutMilliseconds Property

ReceiverIdleTimeoutMilliseconds Property
Gets or sets the period of time that must elapse with no received content before the network connection is reset.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IdleTimeoutMilliseconds { get; set; }
Public Property IdleTimeoutMilliseconds As Integer
    Get
    Set
public:
property int IdleTimeoutMilliseconds {
    int get ();
    void set (int value);
}
member IdleTimeoutMilliseconds : int with get, set

Property Value

Type: Int32
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.IsPassive Property

ReceiverIsPassive Property
Gets or sets a value indicating that the receiver will not connect to the source but will instead wait for the source to connect to it.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPassive { get; set; }
Public Property IsPassive As Boolean
    Get
    Set
public:
property bool IsPassive {
    bool get ();
    void set (bool value);
}
member IsPassive : bool with get, set

Property Value

Type: Boolean
Remarks
Only used when the ConnectionType is TCP. When a receiver is in passive mode the Address is ignored. Only one source can connect to a passive receiver at a time, once a connection is established the receiver stops listening.
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.IsSatcomFeed Property

ReceiverIsSatcomFeed Property
Gets or sets a value indicating that the feed is coming off a satellite.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSatcomFeed { get; set; }
Public Property IsSatcomFeed As Boolean
    Get
    Set
public:
property bool IsSatcomFeed {
    bool get ();
    void set (bool value);
}
member IsSatcomFeed : bool with get, set

Property Value

Type: Boolean
Remarks
Aero Satcom feeds have much longer intervals between transmissions so they are subject to a separate set of display and tracking timeouts.
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Name Property

ReceiverName Property
Gets or sets the unique name of the receiver.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Parity Property

ReceiverParity Property
Gets or sets the parity to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parity Parity { get; set; }
Public Property Parity As Parity
    Get
    Set
public:
property Parity Parity {
    Parity get ();
    void set (Parity value);
}
member Parity : Parity with get, set

Property Value

Type: Parity
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Passphrase Property

ReceiverPassphrase Property
Gets or sets the passphrase that the other side is expecting us to send in order to authenticate.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Passphrase { get; set; }
Public Property Passphrase As String
    Get
    Set
public:
property String^ Passphrase {
    String^ get ();
    void set (String^ value);
}
member Passphrase : string with get, set

Property Value

Type: String
Remarks
If this is null or empty then no passphrase is sent.
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.Port Property

ReceiverPort Property
Gets or sets the port of the source of data to listen to.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.ReceiverLocationId Property

ReceiverReceiverLocationId Property
Gets or sets the identifier of the receiever location record associated with the receiver.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReceiverLocationId { get; set; }
Public Property ReceiverLocationId As Integer
    Get
    Set
public:
property int ReceiverLocationId {
    int get ();
    void set (int value);
}
member ReceiverLocationId : int with get, set

Property Value

Type: Int32
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.ReceiverUsage Property

ReceiverReceiverUsage Property
Gets or sets a value indicating how the receiver should be used by the system.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverUsage ReceiverUsage { get; set; }
Public Property ReceiverUsage As ReceiverUsage
    Get
    Set
public:
property ReceiverUsage ReceiverUsage {
    ReceiverUsage get ();
    void set (ReceiverUsage value);
}
member ReceiverUsage : ReceiverUsage with get, set

Property Value

Type: ReceiverUsage
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.ShutdownText Property

ReceiverShutdownText Property
Gets or sets the text to send across the COM port on shutdown - a null or empty string will disable the feature. Can contain \r and \n.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ShutdownText { get; set; }
Public Property ShutdownText As String
    Get
    Set
public:
property String^ ShutdownText {
    String^ get ();
    void set (String^ value);
}
member ShutdownText : string with get, set

Property Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.StartupText Property

ReceiverStartupText Property
Gets or sets the text to send across the COM port on startup - a null or empty string will disable the feature. Can contain \r and \n.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StartupText { get; set; }
Public Property StartupText As String
    Get
    Set
public:
property String^ StartupText {
    String^ get ();
    void set (String^ value);
}
member StartupText : string with get, set

Property Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.StopBits Property

ReceiverStopBits Property
Gets or sets the stop bits to use.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StopBits StopBits { get; set; }
Public Property StopBits As StopBits
    Get
    Set
public:
property StopBits StopBits {
    StopBits get ();
    void set (StopBits value);
}
member StopBits : StopBits with get, set

Property Value

Type: StopBits
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.UniqueId Property

ReceiverUniqueId Property
Gets or sets a unique identifier for the receiever. This is unique across receivers and merged feeds. It cannot be zero.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.UseKeepAlive Property

ReceiverUseKeepAlive Property
Gets or sets a value indicating that the network connection should use KeepAlive packets.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseKeepAlive { get; set; }
Public Property UseKeepAlive As Boolean
    Get
    Set
public:
property bool UseKeepAlive {
    bool get ();
    void set (bool value);
}
member UseKeepAlive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver Methods

Receiver Methods

The Receiver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | See base class docs. (Overrides ObjectToString.)
Top
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.OnPropertyChanged Method

ReceiverOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.SetField(T) Method

ReceiverSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.ToString Method

ReceiverToString Method
See base class docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver Events

Receiver Events

The Receiver type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


Receiver.PropertyChanged Event

ReceiverPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Receiver Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation Class

ReceiverLocation Class
A class describing the location of a receiver.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsReceiverLocation

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReceiverLocation : INotifyPropertyChanged,
    ICloneable
<SerializableAttribute>
Public Class ReceiverLocation
    Implements INotifyPropertyChanged, ICloneable
[SerializableAttribute]
public ref class ReceiverLocation : INotifyPropertyChanged,
    ICloneable
[<SerializableAttribute>]
type ReceiverLocation =
    class
        interface INotifyPropertyChanged
        interface ICloneable
    end

The ReceiverLocation type exposes the following members.

Constructors
 | Name | Description
Public method | ReceiverLocation | Initializes a new instance of the ReceiverLocation class
Top
Properties
 | Name | Description
Public property | IsBaseStationLocation | Gets or sets a value indicating that the location was copied from the BaseStation database.
Public property | Latitude | Gets or sets the location's latitude.
Public property | Longitude | Gets or sets the location's longitude.
Public property | Name | Gets or sets the name of the location.
Public property | UniqueId | Gets or sets the unique internal identifier of the receiver location.
Top
Methods
 | Name | Description
Public method | Clone | Creates a clone of the object.
Public method | Equals | See base docs. Note that GetHashCode is not overridden, this class is mutable and not safe for use as a key. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns an English description of the location. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


ReceiverLocation Constructor

ReceiverLocation Constructor
Initializes a new instance of the ReceiverLocation class

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverLocation()
Public Sub New
public:
ReceiverLocation()
new : unit -> ReceiverLocation
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation Properties

ReceiverLocation Properties

The ReceiverLocation type exposes the following members.

Properties
 | Name | Description
Public property | IsBaseStationLocation | Gets or sets a value indicating that the location was copied from the BaseStation database.
Public property | Latitude | Gets or sets the location's latitude.
Public property | Longitude | Gets or sets the location's longitude.
Public property | Name | Gets or sets the name of the location.
Public property | UniqueId | Gets or sets the unique internal identifier of the receiver location.
Top
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.IsBaseStationLocation Property

ReceiverLocationIsBaseStationLocation Property
Gets or sets a value indicating that the location was copied from the BaseStation database.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBaseStationLocation { get; set; }
Public Property IsBaseStationLocation As Boolean
    Get
    Set
public:
property bool IsBaseStationLocation {
    bool get ();
    void set (bool value);
}
member IsBaseStationLocation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.Latitude Property

ReceiverLocationLatitude Property
Gets or sets the location's latitude.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Type: Double
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.Longitude Property

ReceiverLocationLongitude Property
Gets or sets the location's longitude.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Type: Double
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.Name Property

ReceiverLocationName Property
Gets or sets the name of the location.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.UniqueId Property

ReceiverLocationUniqueId Property
Gets or sets the unique internal identifier of the receiver location.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation Methods

ReceiverLocation Methods

The ReceiverLocation type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a clone of the object.
Public method | Equals | See base docs. Note that GetHashCode is not overridden, this class is mutable and not safe for use as a key. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns an English description of the location. (Overrides ObjectToString.)
Top
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.Clone Method

ReceiverLocationClone Method
Creates a clone of the object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.Equals Method

ReceiverLocationEquals Method
See base docs. Note that GetHashCode is not overridden, this class is mutable and not safe for use as a key.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.OnPropertyChanged Method

ReceiverLocationOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.SetField(T) Method

ReceiverLocationSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.ToString Method

ReceiverLocationToString Method
Returns an English description of the location.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation Events

ReceiverLocation Events

The ReceiverLocation type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverLocation.PropertyChanged Event

ReceiverLocationPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ReceiverLocation Class
VirtualRadar.Interface.Settings Namespace


ReceiverUsage Enumeration

ReceiverUsage Enumeration
An enumeration of the different ways that a receiver can be used by the system.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReceiverUsage
Public Enumeration ReceiverUsage
public enum class ReceiverUsage
type ReceiverUsage
Members
Member name | Value | Description
Normal | 0 | Show the receiver on the web site, maintain an aircraft list for it, use it for merging etc.
HideFromWebSite | 1 | Maintain an aircraft list for the receiver, allow the receiver to be used in merges etc. but do not show it on the web site.
MergeOnly | 2 | Do not maintain an aircraft list for the receiver, can only be rebroadcast using formats that do not require an aircraft list and do not show it on the web site. It can only be merged with other feeds. Illegal on merged feeds.
See Also

Reference

VirtualRadar.Interface.Settings Namespace


SavedPolarPlot Class

SavedPolarPlot Class
Carries the details for an individual receiver's polar plot.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsSavedPolarPlot

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SavedPolarPlot
Public Class SavedPolarPlot
public ref class SavedPolarPlot
type SavedPolarPlot =  class end

The SavedPolarPlot type exposes the following members.

Constructors
 | Name | Description
Public method | SavedPolarPlot | Creates a new object.
Public method | SavedPolarPlot(IFeed) | Creates a saved polar plot from a feed.
Top
Properties
 | Name | Description
Public property | FeedId | Gets or sets the unique identifier of the feed that the polar plot is for.
Public property | Latitude | Gets or sets the latitude of the receiver.
Public property | Longitude | Gets or sets the longitude of the receiver.
Public property | PolarPlotSlices | Gets a list of saved polar plot slices.
Public property | RoundToDegrees | Gets or sets the rounding applied to the polar plotter.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsForSameFeed | Returns true if the feed passed across looks to be a good match for this saved polar plot.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


SavedPolarPlot Constructor

SavedPolarPlot Constructor
Overload List
 | Name | Description
Public method | SavedPolarPlot | Creates a new object.
Public method | SavedPolarPlot(IFeed) | Creates a saved polar plot from a feed.
Top
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot Constructor

SavedPolarPlot Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SavedPolarPlot()
Public Sub New
public:
SavedPolarPlot()
new : unit -> SavedPolarPlot
See Also

Reference

SavedPolarPlot Class
SavedPolarPlot Overload
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot Constructor (IFeed)

SavedPolarPlot Constructor (IFeed)
Creates a saved polar plot from a feed.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SavedPolarPlot(
    IFeed feed
)
Public Sub New (
    feed As IFeed
)
public:
SavedPolarPlot(
    IFeed^ feed
)
new :
        feed : IFeed -> SavedPolarPlot

Parameters

feed
Type: VirtualRadar.Interface.ListenerIFeed
See Also

Reference

SavedPolarPlot Class
SavedPolarPlot Overload
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot Properties

SavedPolarPlot Properties

The SavedPolarPlot type exposes the following members.

Properties
 | Name | Description
Public property | FeedId | Gets or sets the unique identifier of the feed that the polar plot is for.
Public property | Latitude | Gets or sets the latitude of the receiver.
Public property | Longitude | Gets or sets the longitude of the receiver.
Public property | PolarPlotSlices | Gets a list of saved polar plot slices.
Public property | RoundToDegrees | Gets or sets the rounding applied to the polar plotter.
Top
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot.FeedId Property

SavedPolarPlotFeedId Property
Gets or sets the unique identifier of the feed that the polar plot is for.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FeedId { get; set; }
Public Property FeedId As Integer
    Get
    Set
public:
property int FeedId {
    int get ();
    void set (int value);
}
member FeedId : int with get, set

Property Value

Type: Int32
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot.Latitude Property

SavedPolarPlotLatitude Property
Gets or sets the latitude of the receiver.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Type: Double
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot.Longitude Property

SavedPolarPlotLongitude Property
Gets or sets the longitude of the receiver.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Type: Double
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot.PolarPlotSlices Property

SavedPolarPlotPolarPlotSlices Property
Gets a list of saved polar plot slices.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<PolarPlotSlice> PolarPlotSlices { get; }
Public ReadOnly Property PolarPlotSlices As List(Of PolarPlotSlice)
    Get
public:
property List<PolarPlotSlice^>^ PolarPlotSlices {
    List<PolarPlotSlice^>^ get ();
}
member PolarPlotSlices : List<PolarPlotSlice> with get

Property Value

Type: List PolarPlotSlice
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot.RoundToDegrees Property

SavedPolarPlotRoundToDegrees Property
Gets or sets the rounding applied to the polar plotter.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RoundToDegrees { get; set; }
Public Property RoundToDegrees As Integer
    Get
    Set
public:
property int RoundToDegrees {
    int get ();
    void set (int value);
}
member RoundToDegrees : int with get, set

Property Value

Type: Int32
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot Methods

SavedPolarPlot Methods

The SavedPolarPlot type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsForSameFeed | Returns true if the feed passed across looks to be a good match for this saved polar plot.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


SavedPolarPlot.IsForSameFeed Method

SavedPolarPlotIsForSameFeed Method
Returns true if the feed passed across looks to be a good match for this saved polar plot.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsForSameFeed(
    IFeed feed
)
Public Function IsForSameFeed (
    feed As IFeed
) As Boolean
public:
bool IsForSameFeed(
    IFeed^ feed
)
member IsForSameFeed :
        feed : IFeed -> bool

Parameters

feed
Type: VirtualRadar.Interface.ListenerIFeed

Return Value

Type: Boolean
See Also

Reference

SavedPolarPlot Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings Class

VersionCheckSettings Class
The configuration settings controlling the checking for new versions of the server.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsVersionCheckSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VersionCheckSettings : INotifyPropertyChanged
Public Class VersionCheckSettings
    Implements INotifyPropertyChanged
public ref class VersionCheckSettings : INotifyPropertyChanged
type VersionCheckSettings =
    class
        interface INotifyPropertyChanged
    end

The VersionCheckSettings type exposes the following members.

Constructors
 | Name | Description
Public method | VersionCheckSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | CheckAutomatically | Gets and sets a value indicating that the user wants the program to check for itself every so often.
Public property | CheckPeriodDays | Gets and sets the period between automatic checks.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


VersionCheckSettings Constructor

VersionCheckSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VersionCheckSettings()
Public Sub New
public:
VersionCheckSettings()
new : unit -> VersionCheckSettings
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings Properties

VersionCheckSettings Properties

The VersionCheckSettings type exposes the following members.

Properties
 | Name | Description
Public property | CheckAutomatically | Gets and sets a value indicating that the user wants the program to check for itself every so often.
Public property | CheckPeriodDays | Gets and sets the period between automatic checks.
Top
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings.CheckAutomatically Property

VersionCheckSettingsCheckAutomatically Property
Gets and sets a value indicating that the user wants the program to check for itself every so often.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckAutomatically { get; set; }
Public Property CheckAutomatically As Boolean
    Get
    Set
public:
property bool CheckAutomatically {
    bool get ();
    void set (bool value);
}
member CheckAutomatically : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings.CheckPeriodDays Property

VersionCheckSettingsCheckPeriodDays Property
Gets and sets the period between automatic checks.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CheckPeriodDays { get; set; }
Public Property CheckPeriodDays As Integer
    Get
    Set
public:
property int CheckPeriodDays {
    int get ();
    void set (int value);
}
member CheckPeriodDays : int with get, set

Property Value

Type: Int32
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings Methods

VersionCheckSettings Methods

The VersionCheckSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings.OnPropertyChanged Method

VersionCheckSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings.SetField(T) Method

VersionCheckSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings Events

VersionCheckSettings Events

The VersionCheckSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


VersionCheckSettings.PropertyChanged Event

VersionCheckSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

VersionCheckSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings Class

WebServerSettings Class
A class that holds the configuration of the web server.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.SettingsWebServerSettings

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WebServerSettings : INotifyPropertyChanged
Public Class WebServerSettings
    Implements INotifyPropertyChanged
public ref class WebServerSettings : INotifyPropertyChanged
type WebServerSettings =
    class
        interface INotifyPropertyChanged
    end

The WebServerSettings type exposes the following members.

Constructors
 | Name | Description
Public method | WebServerSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | AdministratorUserIds | Gets the list of users that are considered to be administrators of the site.
Public property | AuthenticationScheme | Gets or sets the authentication scheme that the server will employ for new connections.
Public property | AutoStartUPnP | Gets or sets a value indicating that server should automatically go onto the Internet when the program first starts up.
Public property | BasicAuthenticationPasswordHash | Gets or sets the hash of the password for the basic authentication user.
Public property | BasicAuthenticationUser | Gets or sets the user for basic authentication.
Public property | BasicAuthenticationUserIds | Gets the list of users that can log onto the site when Basic Authentication is switched on.
Public property | ConvertedUser | Gets or sets a value indicating that the BasicAuthenticationUser and BasicAuthenticationPasswordHash have been converted to an IUser and are now managed by the IUserManager.
Public property | EnableUPnp | Gets or sets a value indicating that the server is allowed to control UPnP NAT routers.
Public property | IsOnlyInternetServerOnLan | Gets or sets a value indicating that this is the only instance of VRS on the LAN that is allowed to respond to requests from the Internet.
Public property | UPnpPort | Gets or sets the port number that the UPnP NAT router will listen on for traffic to forward to VRS.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.Interface.Settings Namespace


WebServerSettings Constructor

WebServerSettings Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebServerSettings()
Public Sub New
public:
WebServerSettings()
new : unit -> WebServerSettings
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings Properties

WebServerSettings Properties

The WebServerSettings type exposes the following members.

Properties
 | Name | Description
Public property | AdministratorUserIds | Gets the list of users that are considered to be administrators of the site.
Public property | AuthenticationScheme | Gets or sets the authentication scheme that the server will employ for new connections.
Public property | AutoStartUPnP | Gets or sets a value indicating that server should automatically go onto the Internet when the program first starts up.
Public property | BasicAuthenticationPasswordHash | Gets or sets the hash of the password for the basic authentication user.
Public property | BasicAuthenticationUser | Gets or sets the user for basic authentication.
Public property | BasicAuthenticationUserIds | Gets the list of users that can log onto the site when Basic Authentication is switched on.
Public property | ConvertedUser | Gets or sets a value indicating that the BasicAuthenticationUser and BasicAuthenticationPasswordHash have been converted to an IUser and are now managed by the IUserManager.
Public property | EnableUPnp | Gets or sets a value indicating that the server is allowed to control UPnP NAT routers.
Public property | IsOnlyInternetServerOnLan | Gets or sets a value indicating that this is the only instance of VRS on the LAN that is allowed to respond to requests from the Internet.
Public property | UPnpPort | Gets or sets the port number that the UPnP NAT router will listen on for traffic to forward to VRS.
Top
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.AdministratorUserIds Property

WebServerSettingsAdministratorUserIds Property
Gets the list of users that are considered to be administrators of the site.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<string> AdministratorUserIds { get; }
Public ReadOnly Property AdministratorUserIds As NotifyList(Of String)
    Get
public:
property NotifyList<String^>^ AdministratorUserIds {
    NotifyList<String^>^ get ();
}
member AdministratorUserIds : NotifyList<string> with get

Property Value

Type: NotifyList String
Remarks
Administrators can automatically do anything a user can do, they do not need to be listed both here and BasicAuthenticationUserIds.
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.AuthenticationScheme Property

WebServerSettingsAuthenticationScheme Property
Gets or sets the authentication scheme that the server will employ for new connections.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AuthenticationSchemes AuthenticationScheme { get; set; }
Public Property AuthenticationScheme As AuthenticationSchemes
    Get
    Set
public:
property AuthenticationSchemes AuthenticationScheme {
    AuthenticationSchemes get ();
    void set (AuthenticationSchemes value);
}
member AuthenticationScheme : AuthenticationSchemes with get, set

Property Value

Type: AuthenticationSchemes
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.AutoStartUPnP Property

WebServerSettingsAutoStartUPnP Property
Gets or sets a value indicating that server should automatically go onto the Internet when the program first starts up.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoStartUPnP { get; set; }
Public Property AutoStartUPnP As Boolean
    Get
    Set
public:
property bool AutoStartUPnP {
    bool get ();
    void set (bool value);
}
member AutoStartUPnP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.BasicAuthenticationPasswordHash Property

WebServerSettingsBasicAuthenticationPasswordHash Property
Gets or sets the hash of the password for the basic authentication user.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hash BasicAuthenticationPasswordHash { get; set; }
Public Property BasicAuthenticationPasswordHash As Hash
    Get
    Set
public:
property Hash^ BasicAuthenticationPasswordHash {
    Hash^ get ();
    void set (Hash^ value);
}
member BasicAuthenticationPasswordHash : Hash with get, set

Property Value

Type: Hash
Remarks
Last used in version 2.0.2, now superceded by BasicAuthenticationUserIds.
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.BasicAuthenticationUser Property

WebServerSettingsBasicAuthenticationUser Property
Gets or sets the user for basic authentication.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BasicAuthenticationUser { get; set; }
Public Property BasicAuthenticationUser As String
    Get
    Set
public:
property String^ BasicAuthenticationUser {
    String^ get ();
    void set (String^ value);
}
member BasicAuthenticationUser : string with get, set

Property Value

Type: String
Remarks
Last used in version 2.0.2, now superceded by BasicAuthenticationUserIds.
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.BasicAuthenticationUserIds Property

WebServerSettingsBasicAuthenticationUserIds Property
Gets the list of users that can log onto the site when Basic Authentication is switched on.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<string> BasicAuthenticationUserIds { get; }
Public ReadOnly Property BasicAuthenticationUserIds As NotifyList(Of String)
    Get
public:
property NotifyList<String^>^ BasicAuthenticationUserIds {
    NotifyList<String^>^ get ();
}
member BasicAuthenticationUserIds : NotifyList<string> with get

Property Value

Type: NotifyList String
Remarks
The site will also allow any users listed in AdministratorUserIds to log in, even if they are not present in this list.
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.ConvertedUser Property

WebServerSettingsConvertedUser Property
Gets or sets a value indicating that the BasicAuthenticationUser and BasicAuthenticationPasswordHash have been converted to an IUser and are now managed by the IUserManager.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ConvertedUser { get; set; }
Public Property ConvertedUser As Boolean
    Get
    Set
public:
property bool ConvertedUser {
    bool get ();
    void set (bool value);
}
member ConvertedUser : bool with get, set

Property Value

Type: Boolean
Remarks
The user is converted the first time version 2.0.3 is run, but only if the user manager allows new users to be created. If creation is permitted then the user is added to the BasicAuthenticationUserIds list.
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.EnableUPnp Property

WebServerSettingsEnableUPnp Property
Gets or sets a value indicating that the server is allowed to control UPnP NAT routers.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableUPnp { get; set; }
Public Property EnableUPnp As Boolean
    Get
    Set
public:
property bool EnableUPnp {
    bool get ();
    void set (bool value);
}
member EnableUPnp : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.IsOnlyInternetServerOnLan Property

WebServerSettingsIsOnlyInternetServerOnLan Property
Gets or sets a value indicating that this is the only instance of VRS on the LAN that is allowed to respond to requests from the Internet.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOnlyInternetServerOnLan { get; set; }
Public Property IsOnlyInternetServerOnLan As Boolean
    Get
    Set
public:
property bool IsOnlyInternetServerOnLan {
    bool get ();
    void set (bool value);
}
member IsOnlyInternetServerOnLan : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.UPnpPort Property

WebServerSettingsUPnpPort Property
Gets or sets the port number that the UPnP NAT router will listen on for traffic to forward to VRS.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UPnpPort { get; set; }
Public Property UPnpPort As Integer
    Get
    Set
public:
property int UPnpPort {
    int get ();
    void set (int value);
}
member UPnpPort : int with get, set

Property Value

Type: Int32
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings Methods

WebServerSettings Methods

The WebServerSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Protected method | SetFieldT | Sets the field's value and raises PropertyChanged.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.OnPropertyChanged Method

WebServerSettingsOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.SetField(T) Method

WebServerSettingsSetFieldT Method
Sets the field's value and raises PropertyChanged.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool SetField<T>(
    ref T field,
    T value,
    Expression<Func<T>> selectorExpression
)

Protected Function SetField(Of T) (
    ByRef field As T,
    value As T,
    selectorExpression As Expression(Of Func(Of T))
) As Boolean
protected:
generic<typename T>
bool SetField(
    T% field,
    T value,
    Expression<Func<T>^>^ selectorExpression
)
member SetField :
        field : 'T byref *
        value : 'T *
        selectorExpression : Expression<Func<'T>> -> bool

Parameters

field
Type: T
value
Type: T
selectorExpression
Type: System.Linq.ExpressionsExpression Func T

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings Events

WebServerSettings Events

The WebServerSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


WebServerSettings.PropertyChanged Event

WebServerSettingsPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.Interface.Settings
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

WebServerSettings Class
VirtualRadar.Interface.Settings Namespace


VirtualRadar.Interface.SQLite Namespace

VirtualRadar.Interface.SQLite Namespace
The namespace for all of the interfaces and objects associated with wrapping different SQLite providers.
Interfaces
 | Interface | Description
Public interface | ISQLiteConnectionProvider | The interface for an object that can create an SQLite connection.
Public interface | ISQLiteConnectionStringBuilder | The interface that wrappers around a provider's SQLiteConnectionStringBuilder must implement.
Public interface | ISQLiteException | The interface for objects that can wrap an SQLite exception.
Enumerations
 | Enumeration | Description
Public enumeration | SQLiteDateFormats | The wrapper version of the provider's SQLiteDateFormats enumeration.
Public enumeration | SQLiteErrorCode | An enumeration of the different error codes that can be exposed in an ISQLiteException.
Public enumeration | SQLiteJournalModeEnum | The wrapped version of the provider's SQLiteJournalModeEnum enumeration.
Public enumeration | SynchronizationModes | The wrapped version of the provider's SynchronizationModes enum.
Remarks

Up until version 1.1.2 of VRS the application bound directly to Robert Simpson's SQLite ADO.Net Provider. When the Mono version came along it used a Mono build from source of the provider. However under some Linux systems this was not very stable, so the new approach is to use the native Mono SQLite library when running under Mono.

This wrapper only wraps the parts of SQLite used by VRS.


ISQLiteConnectionProvider Interface

ISQLiteConnectionProvider Interface
The interface for an object that can create an SQLite connection.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISQLiteConnectionProvider
Public Interface ISQLiteConnectionProvider
public interface class ISQLiteConnectionProvider
type ISQLiteConnectionProvider =  interface end

The ISQLiteConnectionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates a connection.
Top
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionProvider Methods

ISQLiteConnectionProvider Methods

The ISQLiteConnectionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates a connection.
Top
See Also

Reference

ISQLiteConnectionProvider Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionProvider.Create Method

ISQLiteConnectionProviderCreate Method
Creates a connection.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDbConnection Create(
    string connectionString
)
Function Create (
    connectionString As String
) As IDbConnection
IDbConnection^ Create(
    String^ connectionString
)
abstract Create :
        connectionString : string -> IDbConnection

Parameters

connectionString
Type: SystemString

Return Value

Type: IDbConnection
See Also

Reference

ISQLiteConnectionProvider Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder Interface

ISQLiteConnectionStringBuilder Interface
The interface that wrappers around a provider's SQLiteConnectionStringBuilder must implement.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISQLiteConnectionStringBuilder
Public Interface ISQLiteConnectionStringBuilder
public interface class ISQLiteConnectionStringBuilder
type ISQLiteConnectionStringBuilder =  interface end

The ISQLiteConnectionStringBuilder type exposes the following members.

Properties
 | Name | Description
Public property | BinaryGUID | See SQLite docs.
Public property | CacheSize | See SQLite docs.
Public property | ConnectionString | See SQLite docs.
Public property | DataSource | See SQLite docs.
Public property | DateTimeFormat | See SQLite docs.
Public property | DefaultIsolationLevel | See SQLite docs.
Public property | DefaultTimeout | See SQLite docs.
Public property | Enlist | See SQLite docs.
Public property | FailIfMissing | See SQLite docs.
Public property | ForeignKeys | See SQLite docs.
Public property | JournalMode | See SQLite docs.
Public property | LegacyFormat | See SQLite docs.
Public property | MaxPageCount | See SQLite docs.
Public property | PageSize | See SQLite docs.
Public property | Password | See SQLite docs.
Public property | Pooling | See SQLite docs.
Public property | ReadOnly | See SQLite docs.
Public property | SyncMode | See SQLite docs.
Public property | Uri | See SQLite docs.
Public property | UseUTF16Encoding | See SQLite docs.
Public property | Version | See SQLite docs.
Top
Methods
 | Name | Description
Public method | Initialise | Constructs the object.
Public method | Initialise(String) | Constructs the object.
Public method | TryGetValue | See SQLite docs.
Top
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder Properties

ISQLiteConnectionStringBuilder Properties

The ISQLiteConnectionStringBuilder type exposes the following members.

Properties
 | Name | Description
Public property | BinaryGUID | See SQLite docs.
Public property | CacheSize | See SQLite docs.
Public property | ConnectionString | See SQLite docs.
Public property | DataSource | See SQLite docs.
Public property | DateTimeFormat | See SQLite docs.
Public property | DefaultIsolationLevel | See SQLite docs.
Public property | DefaultTimeout | See SQLite docs.
Public property | Enlist | See SQLite docs.
Public property | FailIfMissing | See SQLite docs.
Public property | ForeignKeys | See SQLite docs.
Public property | JournalMode | See SQLite docs.
Public property | LegacyFormat | See SQLite docs.
Public property | MaxPageCount | See SQLite docs.
Public property | PageSize | See SQLite docs.
Public property | Password | See SQLite docs.
Public property | Pooling | See SQLite docs.
Public property | ReadOnly | See SQLite docs.
Public property | SyncMode | See SQLite docs.
Public property | Uri | See SQLite docs.
Public property | UseUTF16Encoding | See SQLite docs.
Public property | Version | See SQLite docs.
Top
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.BinaryGUID Property

ISQLiteConnectionStringBuilderBinaryGUID Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BinaryGUID { get; set; }
Property BinaryGUID As Boolean
    Get
    Set
property bool BinaryGUID {
    bool get ();
    void set (bool value);
}
abstract BinaryGUID : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.CacheSize Property

ISQLiteConnectionStringBuilderCacheSize Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int CacheSize { get; set; }
Property CacheSize As Integer
    Get
    Set
property int CacheSize {
    int get ();
    void set (int value);
}
abstract CacheSize : int with get, set

Property Value

Type: Int32
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.ConnectionString Property

ISQLiteConnectionStringBuilderConnectionString Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConnectionString { get; set; }
Property ConnectionString As String
    Get
    Set
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
abstract ConnectionString : string with get, set

Property Value

Type: String
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.DataSource Property

ISQLiteConnectionStringBuilderDataSource Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string DataSource { get; set; }
Property DataSource As String
    Get
    Set
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}
abstract DataSource : string with get, set

Property Value

Type: String
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.DateTimeFormat Property

ISQLiteConnectionStringBuilderDateTimeFormat Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SQLiteDateFormats DateTimeFormat { get; set; }
Property DateTimeFormat As SQLiteDateFormats
    Get
    Set
property SQLiteDateFormats DateTimeFormat {
    SQLiteDateFormats get ();
    void set (SQLiteDateFormats value);
}
abstract DateTimeFormat : SQLiteDateFormats with get, set

Property Value

Type: SQLiteDateFormats
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.DefaultIsolationLevel Property

ISQLiteConnectionStringBuilderDefaultIsolationLevel Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IsolationLevel DefaultIsolationLevel { get; set; }
Property DefaultIsolationLevel As IsolationLevel
    Get
    Set
property IsolationLevel DefaultIsolationLevel {
    IsolationLevel get ();
    void set (IsolationLevel value);
}
abstract DefaultIsolationLevel : IsolationLevel with get, set

Property Value

Type: IsolationLevel
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.DefaultTimeout Property

ISQLiteConnectionStringBuilderDefaultTimeout Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int DefaultTimeout { get; set; }
Property DefaultTimeout As Integer
    Get
    Set
property int DefaultTimeout {
    int get ();
    void set (int value);
}
abstract DefaultTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Enlist Property

ISQLiteConnectionStringBuilderEnlist Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enlist { get; set; }
Property Enlist As Boolean
    Get
    Set
property bool Enlist {
    bool get ();
    void set (bool value);
}
abstract Enlist : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.FailIfMissing Property

ISQLiteConnectionStringBuilderFailIfMissing Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FailIfMissing { get; set; }
Property FailIfMissing As Boolean
    Get
    Set
property bool FailIfMissing {
    bool get ();
    void set (bool value);
}
abstract FailIfMissing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.ForeignKeys Property

ISQLiteConnectionStringBuilderForeignKeys Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ForeignKeys { get; set; }
Property ForeignKeys As Boolean
    Get
    Set
property bool ForeignKeys {
    bool get ();
    void set (bool value);
}
abstract ForeignKeys : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.JournalMode Property

ISQLiteConnectionStringBuilderJournalMode Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SQLiteJournalModeEnum JournalMode { get; set; }
Property JournalMode As SQLiteJournalModeEnum
    Get
    Set
property SQLiteJournalModeEnum JournalMode {
    SQLiteJournalModeEnum get ();
    void set (SQLiteJournalModeEnum value);
}
abstract JournalMode : SQLiteJournalModeEnum with get, set

Property Value

Type: SQLiteJournalModeEnum
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.LegacyFormat Property

ISQLiteConnectionStringBuilderLegacyFormat Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LegacyFormat { get; set; }
Property LegacyFormat As Boolean
    Get
    Set
property bool LegacyFormat {
    bool get ();
    void set (bool value);
}
abstract LegacyFormat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.MaxPageCount Property

ISQLiteConnectionStringBuilderMaxPageCount Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxPageCount { get; set; }
Property MaxPageCount As Integer
    Get
    Set
property int MaxPageCount {
    int get ();
    void set (int value);
}
abstract MaxPageCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.PageSize Property

ISQLiteConnectionStringBuilderPageSize Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int PageSize { get; set; }
Property PageSize As Integer
    Get
    Set
property int PageSize {
    int get ();
    void set (int value);
}
abstract PageSize : int with get, set

Property Value

Type: Int32
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Password Property

ISQLiteConnectionStringBuilderPassword Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Password { get; set; }
Property Password As String
    Get
    Set
property String^ Password {
    String^ get ();
    void set (String^ value);
}
abstract Password : string with get, set

Property Value

Type: String
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Pooling Property

ISQLiteConnectionStringBuilderPooling Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Pooling { get; set; }
Property Pooling As Boolean
    Get
    Set
property bool Pooling {
    bool get ();
    void set (bool value);
}
abstract Pooling : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.ReadOnly Property

ISQLiteConnectionStringBuilderReadOnly Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReadOnly { get; set; }
Property ReadOnly As Boolean
    Get
    Set
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.SyncMode Property

ISQLiteConnectionStringBuilderSyncMode Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SynchronizationModes SyncMode { get; set; }
Property SyncMode As SynchronizationModes
    Get
    Set
property SynchronizationModes SyncMode {
    SynchronizationModes get ();
    void set (SynchronizationModes value);
}
abstract SyncMode : SynchronizationModes with get, set

Property Value

Type: SynchronizationModes
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Uri Property

ISQLiteConnectionStringBuilderUri Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Uri { get; set; }
Property Uri As String
    Get
    Set
property String^ Uri {
    String^ get ();
    void set (String^ value);
}
abstract Uri : string with get, set

Property Value

Type: String
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.UseUTF16Encoding Property

ISQLiteConnectionStringBuilderUseUTF16Encoding Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseUTF16Encoding { get; set; }
Property UseUTF16Encoding As Boolean
    Get
    Set
property bool UseUTF16Encoding {
    bool get ();
    void set (bool value);
}
abstract UseUTF16Encoding : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Version Property

ISQLiteConnectionStringBuilderVersion Property
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Version { get; set; }
Property Version As Integer
    Get
    Set
property int Version {
    int get ();
    void set (int value);
}
abstract Version : int with get, set

Property Value

Type: Int32
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder Methods

ISQLiteConnectionStringBuilder Methods

The ISQLiteConnectionStringBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Constructs the object.
Public method | Initialise(String) | Constructs the object.
Public method | TryGetValue | See SQLite docs.
Top
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Initialise Method

ISQLiteConnectionStringBuilderInitialise Method
Overload List
 | Name | Description
Public method | Initialise | Constructs the object.
Public method | Initialise(String) | Constructs the object.
Top
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Initialise Method

ISQLiteConnectionStringBuilderInitialise Method
Constructs the object.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISQLiteConnectionStringBuilder Initialise()
Function Initialise As ISQLiteConnectionStringBuilder
ISQLiteConnectionStringBuilder^ Initialise()
abstract Initialise : unit -> ISQLiteConnectionStringBuilder

Return Value

Type: ISQLiteConnectionStringBuilder
See Also

Reference

ISQLiteConnectionStringBuilder Interface
Initialise Overload
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.Initialise Method (String)

ISQLiteConnectionStringBuilderInitialise Method (String)
Constructs the object.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISQLiteConnectionStringBuilder Initialise(
    string connectionString
)
Function Initialise (
    connectionString As String
) As ISQLiteConnectionStringBuilder
ISQLiteConnectionStringBuilder^ Initialise(
    String^ connectionString
)
abstract Initialise :
        connectionString : string -> ISQLiteConnectionStringBuilder

Parameters

connectionString
Type: SystemString

Return Value

Type: ISQLiteConnectionStringBuilder
See Also

Reference

ISQLiteConnectionStringBuilder Interface
Initialise Overload
VirtualRadar.Interface.SQLite Namespace


ISQLiteConnectionStringBuilder.TryGetValue Method

ISQLiteConnectionStringBuilderTryGetValue Method
See SQLite docs.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TryGetValue(
    string keyword,
    out Object value
)
Function TryGetValue (
    keyword As String,
    <OutAttribute> ByRef value As Object
) As Boolean
bool TryGetValue(
    String^ keyword,
    [OutAttribute] Object^% value
)
abstract TryGetValue :
        keyword : string *
        value : Object byref -> bool

Parameters

keyword
Type: SystemString
value
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ISQLiteConnectionStringBuilder Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException Interface

ISQLiteException Interface
The interface for objects that can wrap an SQLite exception.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISQLiteException
Public Interface ISQLiteException
public interface class ISQLiteException
type ISQLiteException =  interface end

The ISQLiteException type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Gets the error code from the exception.
Public property | Exception | Gets the exception that was passed to Initialise(Exception).
Public property | IsLocked | Gets a value, derived from ErrorCode, indicating that the database is locked.
Public property | IsSQLiteException | Gets a value indicating that the exception passed to Initialise(Exception) was a valid SQLite exception.
Top
Methods
 | Name | Description
Public method | Initialise | Populates the object with the details of an exception.
Top
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


ISQLiteException Properties

ISQLiteException Properties

The ISQLiteException type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Gets the error code from the exception.
Public property | Exception | Gets the exception that was passed to Initialise(Exception).
Public property | IsLocked | Gets a value, derived from ErrorCode, indicating that the database is locked.
Public property | IsSQLiteException | Gets a value indicating that the exception passed to Initialise(Exception) was a valid SQLite exception.
Top
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException.ErrorCode Property

ISQLiteExceptionErrorCode Property
Gets the error code from the exception.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SQLiteErrorCode ErrorCode { get; }
ReadOnly Property ErrorCode As SQLiteErrorCode
    Get
property SQLiteErrorCode ErrorCode {
    SQLiteErrorCode get ();
}
abstract ErrorCode : SQLiteErrorCode with get

Property Value

Type: SQLiteErrorCode
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException.Exception Property

ISQLiteExceptionException Property
Gets the exception that was passed to Initialise(Exception).

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Exception Exception { get; }
ReadOnly Property Exception As Exception
    Get
property Exception^ Exception {
    Exception^ get ();
}
abstract Exception : Exception with get

Property Value

Type: Exception
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException.IsLocked Property

ISQLiteExceptionIsLocked Property
Gets a value, derived from ErrorCode, indicating that the database is locked.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLocked { get; }
ReadOnly Property IsLocked As Boolean
    Get
property bool IsLocked {
    bool get ();
}
abstract IsLocked : bool with get

Property Value

Type: Boolean
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException.IsSQLiteException Property

ISQLiteExceptionIsSQLiteException Property
Gets a value indicating that the exception passed to Initialise(Exception) was a valid SQLite exception.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSQLiteException { get; }
ReadOnly Property IsSQLiteException As Boolean
    Get
property bool IsSQLiteException {
    bool get ();
}
abstract IsSQLiteException : bool with get

Property Value

Type: Boolean
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException Methods

ISQLiteException Methods

The ISQLiteException type exposes the following members.

Methods
 | Name | Description
Public method | Initialise | Populates the object with the details of an exception.
Top
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


ISQLiteException.Initialise Method

ISQLiteExceptionInitialise Method
Populates the object with the details of an exception.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    Exception ex
)
Sub Initialise (
    ex As Exception
)
void Initialise(
    Exception^ ex
)
abstract Initialise :
        ex : Exception -> unit

Parameters

ex
Type: SystemException
See Also

Reference

ISQLiteException Interface
VirtualRadar.Interface.SQLite Namespace


SQLiteDateFormats Enumeration

SQLiteDateFormats Enumeration
The wrapper version of the provider's SQLiteDateFormats enumeration.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SQLiteDateFormats
Public Enumeration SQLiteDateFormats
public enum class SQLiteDateFormats
type SQLiteDateFormats
Members
Member name | Value | Description
Ticks | 0 | See SQLite docs.
Default | 1 | See SQLite docs.
ISO8601 | 1 | See SQLite docs.
JulianDay | 2 | See SQLite docs.
UnixEpoch | 3 | See SQLite docs.
InvariantCulture | 4 | See SQLite docs.
CurrentCulture | 5 | See SQLite docs.
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


SQLiteErrorCode Enumeration

SQLiteErrorCode Enumeration
An enumeration of the different error codes that can be exposed in an ISQLiteException.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SQLiteErrorCode
Public Enumeration SQLiteErrorCode
public enum class SQLiteErrorCode
type SQLiteErrorCode
Members
Member name | Value | Description
Unknown | -1 | The error code is unknown. This error code is only used by the managed wrapper itself.
Ok | 0 | Successful result
Error | 1 | SQL error or missing database
Internal | 2 | Internal logic error in SQLite
Perm | 3 | Access permission denied
Abort | 4 | Callback routine requested an abort
Busy | 5 | The database file could not be written, probably because another process has it locked.
Locked | 6 | The database file could not be written, probably because another command on the same connection has it locked or because it has been locked through a cache that is shared with another process.
NoMem | 7 | A malloc() failed
ReadOnly | 8 | Attempt to write a readonly database
Interrupt | 9 | Operation terminated by sqlite3_interrupt()
IoErr | 10 | Some kind of disk I/O error occurred
Corrupt | 11 | The database disk image is malformed
NotFound | 12 | Unknown opcode in sqlite3_file_control()
Full | 13 | Insertion failed because database is full
CantOpen | 14 | Unable to open the database file
Protocol | 15 | Database lock protocol error
Empty | 16 | Database is empty
Schema | 17 | The database schema changed
TooBig | 18 | String or BLOB exceeds size limit
Constraint | 19 | Abort due to constraint violation
Mismatch | 20 | Data type mismatch
Misuse | 21 | Library used incorrectly
NoLfs | 22 | Uses OS features not supported on host
Auth | 23 | Authorization denied
Format | 24 | Auxiliary database format error
Range | 25 | 2nd parameter to sqlite3_bind out of range
NotADb | 26 | File opened that is not a database file
Notice | 27 | Notifications from sqlite3_log()
Warning | 28 | Warnings from sqlite3_log()
Row | 100 | sqlite3_step() has another row ready
Done | 101 | sqlite3_step() has finished executing
NonExtendedMask | 255 | Used to mask off extended result codes
Remarks
These are copied verbatim from the SQLite source.
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


SQLiteJournalModeEnum Enumeration

SQLiteJournalModeEnum Enumeration
The wrapped version of the provider's SQLiteJournalModeEnum enumeration.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SQLiteJournalModeEnum
Public Enumeration SQLiteJournalModeEnum
public enum class SQLiteJournalModeEnum
type SQLiteJournalModeEnum
Members
Member name | Value | Description
Default | -1 | See SQLite docs.
Delete | 0 | See SQLite docs.
Persist | 1 | See SQLite docs.
Off | 2 | See SQLite docs.
Truncate | 3 | See SQLite docs.
Memory | 4 | See SQLite docs.
Wal | 5 | See SQLite docs.
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


SynchronizationModes Enumeration

SynchronizationModes Enumeration
The wrapped version of the provider's SynchronizationModes enum.

Namespace: VirtualRadar.Interface.SQLite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SynchronizationModes
Public Enumeration SynchronizationModes
public enum class SynchronizationModes
type SynchronizationModes
Members
Member name | Value | Description
Normal | 0 | See SQLite docs.
Full | 1 | See SQLite docs.
Off | 2 | See SQLite docs.
See Also

Reference

VirtualRadar.Interface.SQLite Namespace


VirtualRadar.Interface.StandingData Namespace

VirtualRadar.Interface.StandingData Namespace
The namespace for all of the interfaces and objects associated with handling the standing data files.
Classes
 | Class | Description
Public class | AircraftType | Describes an aircraft type as read from ICAO8643
Public class | Airline | Describes an airline in the standing data files.
Public class | Airport | Describes an airport in the standing data files.
Public class | CallsignRouteDetail | A DTO that carries information about a callsign and its route for instances of ICallsignRouteFetcher.
Public class | CodeBlock | The interface for objects that hold information about an assigned block of ICAO24 codes.
Public class | FlightNumber | Describes a flight number in the data files.
Public class | Route | Describes a route stored or inferred from the standing data files.
Interfaces
 | Interface | Description
Public interface | IBackgroundDataDownloader | The interface for the object that downloads updates to the data in the background once a day (configuration permitting).
Public interface | IBackgroundDataDownloaderProvider | The interface for objects that abstract away the environment for IBackgroundDataDownloader.
Public interface | ICallsignRouteFetcher | The interface for a singleton object that manages the fetching of routes for callsigns across many aircraft lists (or potentially anything that needs to find callsigns from routes).
Public interface | IStandingDataManager | The interface for objects that manage standing data for the server.
Public interface | IStandingDataManagerProvider | The interface for objects that abstract away the environment for IStandingDataManager.
Public interface | IStandingDataUpdater | The interface for objects that can update the standing data maintenance files.
Public interface | IStandingDataUpdaterProvider | The interface for objects that can abstract away the environment for IStandingDataUpdater.
Enumerations
 | Enumeration | Description
Public enumeration | EnginePlacement | An enumeration of the placement of the engines on the aircraft, if known.
Public enumeration | EngineType | An enumeration of the type of aircraft engine in use on the aircraft.
Public enumeration | Species | An enumeration of the different species of flying machine described by ICAO8643.
Public enumeration | WakeTurbulenceCategory | An enumeration of the different wake turbulence categories as used in ICAO8643.
Remarks

The standing data contains information about aircraft types, airport codes, airline codes and routes. The plugins would probably be most interested in the IStandingDataManager interface as this is the one that can perform lookups.


AircraftType Class

AircraftType Class
Describes an aircraft type as read from ICAO8643
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataAircraftType

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftType
Public Class AircraftType
public ref class AircraftType
type AircraftType =  class end

The AircraftType type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftType | Creates a new object.
Top
Properties
 | Name | Description
Public property | EnginePlacement | Gets or sets an indication of how the engines are mounted on the aircraft.
Public property | Engines | Gets or sets the number of engines - 1, 2, 3 etc. or C for two engines coupled to drive a single propeller. This will be null if the number of engines is not known or not applicable.
Public property | EngineType | Gets or sets the type of engine predominantly used to propel the aircraft.
Public property | Manufacturers | Gets a list of every manufacturer that has an aircraft that uses this type code.
Public property | Models | Gets a list of every model that is covered by this type code. There will be one entry in this list for every entry in Manufacturers.
Public property | Species | Gets or sets the type of aircraft this is (fixed-wing, seaplane, helicopter etc.).
Public property | Type | Gets or sets the aircraft type code.
Public property | WakeTurbulenceCategory | Gets or sets the heaviest wake turbulence category that applies to the aircraft.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See Object.ToString(). (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


AircraftType Constructor

AircraftType Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftType()
Public Sub New
public:
AircraftType()
new : unit -> AircraftType
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType Properties

AircraftType Properties

The AircraftType type exposes the following members.

Properties
 | Name | Description
Public property | EnginePlacement | Gets or sets an indication of how the engines are mounted on the aircraft.
Public property | Engines | Gets or sets the number of engines - 1, 2, 3 etc. or C for two engines coupled to drive a single propeller. This will be null if the number of engines is not known or not applicable.
Public property | EngineType | Gets or sets the type of engine predominantly used to propel the aircraft.
Public property | Manufacturers | Gets a list of every manufacturer that has an aircraft that uses this type code.
Public property | Models | Gets a list of every model that is covered by this type code. There will be one entry in this list for every entry in Manufacturers.
Public property | Species | Gets or sets the type of aircraft this is (fixed-wing, seaplane, helicopter etc.).
Public property | Type | Gets or sets the aircraft type code.
Public property | WakeTurbulenceCategory | Gets or sets the heaviest wake turbulence category that applies to the aircraft.
Top
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.EnginePlacement Property

AircraftTypeEnginePlacement Property
Gets or sets an indication of how the engines are mounted on the aircraft.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnginePlacement EnginePlacement { get; set; }
Public Property EnginePlacement As EnginePlacement
    Get
    Set
public:
property EnginePlacement EnginePlacement {
    EnginePlacement get ();
    void set (EnginePlacement value);
}
member EnginePlacement : EnginePlacement with get, set

Property Value

Type: EnginePlacement
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.Engines Property

AircraftTypeEngines Property
Gets or sets the number of engines - 1, 2, 3 etc. or C for two engines coupled to drive a single propeller. This will be null if the number of engines is not known or not applicable.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Engines { get; set; }
Public Property Engines As String
    Get
    Set
public:
property String^ Engines {
    String^ get ();
    void set (String^ value);
}
member Engines : string with get, set

Property Value

Type: String
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.EngineType Property

AircraftTypeEngineType Property
Gets or sets the type of engine predominantly used to propel the aircraft.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EngineType EngineType { get; set; }
Public Property EngineType As EngineType
    Get
    Set
public:
property EngineType EngineType {
    EngineType get ();
    void set (EngineType value);
}
member EngineType : EngineType with get, set

Property Value

Type: EngineType
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.Manufacturers Property

AircraftTypeManufacturers Property
Gets a list of every manufacturer that has an aircraft that uses this type code.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Manufacturers { get; }
Public ReadOnly Property Manufacturers As IList(Of String)
    Get
public:
property IList<String^>^ Manufacturers {
    IList<String^>^ get ();
}
member Manufacturers : IList<string> with get

Property Value

Type: IList String
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.Models Property

AircraftTypeModels Property
Gets a list of every model that is covered by this type code. There will be one entry in this list for every entry in Manufacturers.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Models { get; }
Public ReadOnly Property Models As IList(Of String)
    Get
public:
property IList<String^>^ Models {
    IList<String^>^ get ();
}
member Models : IList<string> with get

Property Value

Type: IList String
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.Species Property

AircraftTypeSpecies Property
Gets or sets the type of aircraft this is (fixed-wing, seaplane, helicopter etc.).

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Species Species { get; set; }
Public Property Species As Species
    Get
    Set
public:
property Species Species {
    Species get ();
    void set (Species value);
}
member Species : Species with get, set

Property Value

Type: Species
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.Type Property

AircraftTypeType Property
Gets or sets the aircraft type code.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.WakeTurbulenceCategory Property

AircraftTypeWakeTurbulenceCategory Property
Gets or sets the heaviest wake turbulence category that applies to the aircraft.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WakeTurbulenceCategory WakeTurbulenceCategory { get; set; }
Public Property WakeTurbulenceCategory As WakeTurbulenceCategory
    Get
    Set
public:
property WakeTurbulenceCategory WakeTurbulenceCategory {
    WakeTurbulenceCategory get ();
    void set (WakeTurbulenceCategory value);
}
member WakeTurbulenceCategory : WakeTurbulenceCategory with get, set

Property Value

Type: WakeTurbulenceCategory
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType Methods

AircraftType Methods

The AircraftType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See Object.ToString(). (Overrides ObjectToString.)
Top
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


AircraftType.ToString Method

AircraftTypeToString Method
See Object.ToString().

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AircraftType Class
VirtualRadar.Interface.StandingData Namespace


Airline Class

Airline Class
Describes an airline in the standing data files.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataAirline

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Airline
Public Class Airline
public ref class Airline
type Airline =  class end

The Airline type exposes the following members.

Constructors
 | Name | Description
Public method | Airline | Initializes a new instance of the Airline class
Top
Properties
 | Name | Description
Public property | IataCode | Gets or sets the IATA code of the airline, if any.
Public property | IcaoCode | Gets or sets the ICAO code of the airline, if any.
Public property | Name | Gets or sets the name of the airline.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


Airline Constructor

Airline Constructor
Initializes a new instance of the Airline class

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Airline()
Public Sub New
public:
Airline()
new : unit -> Airline
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airline Properties

Airline Properties

The Airline type exposes the following members.

Properties
 | Name | Description
Public property | IataCode | Gets or sets the IATA code of the airline, if any.
Public property | IcaoCode | Gets or sets the ICAO code of the airline, if any.
Public property | Name | Gets or sets the name of the airline.
Top
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airline.IataCode Property

AirlineIataCode Property
Gets or sets the IATA code of the airline, if any.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IataCode { get; set; }
Public Property IataCode As String
    Get
    Set
public:
property String^ IataCode {
    String^ get ();
    void set (String^ value);
}
member IataCode : string with get, set

Property Value

Type: String
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airline.IcaoCode Property

AirlineIcaoCode Property
Gets or sets the ICAO code of the airline, if any.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IcaoCode { get; set; }
Public Property IcaoCode As String
    Get
    Set
public:
property String^ IcaoCode {
    String^ get ();
    void set (String^ value);
}
member IcaoCode : string with get, set

Property Value

Type: String
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airline.Name Property

AirlineName Property
Gets or sets the name of the airline.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airline Methods

Airline Methods

The Airline type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airline.ToString Method

AirlineToString Method
See base docs.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Airline Class
VirtualRadar.Interface.StandingData Namespace


Airport Class

Airport Class
Describes an airport in the standing data files.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataAirport

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Airport
Public Class Airport
public ref class Airport
type Airport =  class end

The Airport type exposes the following members.

Constructors
 | Name | Description
Public method | Airport | Initializes a new instance of the Airport class
Top
Properties
 | Name | Description
Public property | AltitudeFeet | Gets or sets the altitude in feet of the airport.
Public property | Country | Gets or sets the country that the airport is in.
Public property | IataCode | Gets or sets the IATA code for the airport.
Public property | IcaoCode | Gets or sets the ICAO code for the airport.
Public property | Latitude | Gets or sets the latitude part of the airport's coordinate.
Public property | Longitude | Gets or sets the longitude part of the airport's coordinate.
Public property | Name | Gets or sets the name of the airport.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See Object.ToString(). (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


Airport Constructor

Airport Constructor
Initializes a new instance of the Airport class

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Airport()
Public Sub New
public:
Airport()
new : unit -> Airport
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport Properties

Airport Properties

The Airport type exposes the following members.

Properties
 | Name | Description
Public property | AltitudeFeet | Gets or sets the altitude in feet of the airport.
Public property | Country | Gets or sets the country that the airport is in.
Public property | IataCode | Gets or sets the IATA code for the airport.
Public property | IcaoCode | Gets or sets the ICAO code for the airport.
Public property | Latitude | Gets or sets the latitude part of the airport's coordinate.
Public property | Longitude | Gets or sets the longitude part of the airport's coordinate.
Public property | Name | Gets or sets the name of the airport.
Top
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.AltitudeFeet Property

AirportAltitudeFeet Property
Gets or sets the altitude in feet of the airport.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> AltitudeFeet { get; set; }
Public Property AltitudeFeet As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> AltitudeFeet {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member AltitudeFeet : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.Country Property

AirportCountry Property
Gets or sets the country that the airport is in.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
member Country : string with get, set

Property Value

Type: String
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.IataCode Property

AirportIataCode Property
Gets or sets the IATA code for the airport.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IataCode { get; set; }
Public Property IataCode As String
    Get
    Set
public:
property String^ IataCode {
    String^ get ();
    void set (String^ value);
}
member IataCode : string with get, set

Property Value

Type: String
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.IcaoCode Property

AirportIcaoCode Property
Gets or sets the ICAO code for the airport.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IcaoCode { get; set; }
Public Property IcaoCode As String
    Get
    Set
public:
property String^ IcaoCode {
    String^ get ();
    void set (String^ value);
}
member IcaoCode : string with get, set

Property Value

Type: String
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.Latitude Property

AirportLatitude Property
Gets or sets the latitude part of the airport's coordinate.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Latitude { get; set; }
Public Property Latitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Latitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Latitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.Longitude Property

AirportLongitude Property
Gets or sets the longitude part of the airport's coordinate.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Longitude { get; set; }
Public Property Longitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Longitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Longitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.Name Property

AirportName Property
Gets or sets the name of the airport.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport Methods

Airport Methods

The Airport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See Object.ToString(). (Overrides ObjectToString.)
Top
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


Airport.ToString Method

AirportToString Method
See Object.ToString().

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Airport Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail Class

CallsignRouteDetail Class
A DTO that carries information about a callsign and its route for instances of ICallsignRouteFetcher.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataCallsignRouteDetail

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CallsignRouteDetail
Public Class CallsignRouteDetail
public ref class CallsignRouteDetail
type CallsignRouteDetail =  class end

The CallsignRouteDetail type exposes the following members.

Constructors
 | Name | Description
Public method | CallsignRouteDetail | Initializes a new instance of the CallsignRouteDetail class
Top
Properties
 | Name | Description
Public property | Callsign | Gets or sets the callsign that the route was based on.
Public property | Icao24 | Gets or sets the ICAO24 of the aircraft whose route has been fetched.
Public property | Route | Gets or sets the route for the callsign. This will be null if no details could be fetched for the callsign.
Public property | UsedCallsign | Gets or sets the callsign that the route was actually found under.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail Constructor

CallsignRouteDetail Constructor
Initializes a new instance of the CallsignRouteDetail class

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CallsignRouteDetail()
Public Sub New
public:
CallsignRouteDetail()
new : unit -> CallsignRouteDetail
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail Properties

CallsignRouteDetail Properties

The CallsignRouteDetail type exposes the following members.

Properties
 | Name | Description
Public property | Callsign | Gets or sets the callsign that the route was based on.
Public property | Icao24 | Gets or sets the ICAO24 of the aircraft whose route has been fetched.
Public property | Route | Gets or sets the route for the callsign. This will be null if no details could be fetched for the callsign.
Public property | UsedCallsign | Gets or sets the callsign that the route was actually found under.
Top
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail.Callsign Property

CallsignRouteDetailCallsign Property
Gets or sets the callsign that the route was based on.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Callsign { get; set; }
Public Property Callsign As String
    Get
    Set
public:
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
member Callsign : string with get, set

Property Value

Type: String
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail.Icao24 Property

CallsignRouteDetailIcao24 Property
Gets or sets the ICAO24 of the aircraft whose route has been fetched.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao24 { get; set; }
Public Property Icao24 As String
    Get
    Set
public:
property String^ Icao24 {
    String^ get ();
    void set (String^ value);
}
member Icao24 : string with get, set

Property Value

Type: String
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail.Route Property

CallsignRouteDetailRoute Property
Gets or sets the route for the callsign. This will be null if no details could be fetched for the callsign.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Route Route { get; set; }
Public Property Route As Route
    Get
    Set
public:
property Route^ Route {
    Route^ get ();
    void set (Route^ value);
}
member Route : Route with get, set

Property Value

Type: Route
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail.UsedCallsign Property

CallsignRouteDetailUsedCallsign Property
Gets or sets the callsign that the route was actually found under.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UsedCallsign { get; set; }
Public Property UsedCallsign As String
    Get
    Set
public:
property String^ UsedCallsign {
    String^ get ();
    void set (String^ value);
}
member UsedCallsign : string with get, set

Property Value

Type: String
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CallsignRouteDetail Methods

CallsignRouteDetail Methods

The CallsignRouteDetail type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CallsignRouteDetail Class
VirtualRadar.Interface.StandingData Namespace


CodeBlock Class

CodeBlock Class
The interface for objects that hold information about an assigned block of ICAO24 codes.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataCodeBlock

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeBlock
Public Class CodeBlock
public ref class CodeBlock
type CodeBlock =  class end

The CodeBlock type exposes the following members.

Constructors
 | Name | Description
Public method | CodeBlock | Initializes a new instance of the CodeBlock class
Top
Properties
 | Name | Description
Public property | Country | Gets or sets the country that this block is assigned to. This will be null if the block is not assigned to a nation.
Public property | IsMilitary | Gets or sets a flag indicating that this block is used by the nation's military.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


CodeBlock Constructor

CodeBlock Constructor
Initializes a new instance of the CodeBlock class

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeBlock()
Public Sub New
public:
CodeBlock()
new : unit -> CodeBlock
See Also

Reference

CodeBlock Class
VirtualRadar.Interface.StandingData Namespace


CodeBlock Properties

CodeBlock Properties

The CodeBlock type exposes the following members.

Properties
 | Name | Description
Public property | Country | Gets or sets the country that this block is assigned to. This will be null if the block is not assigned to a nation.
Public property | IsMilitary | Gets or sets a flag indicating that this block is used by the nation's military.
Top
See Also

Reference

CodeBlock Class
VirtualRadar.Interface.StandingData Namespace


CodeBlock.Country Property

CodeBlockCountry Property
Gets or sets the country that this block is assigned to. This will be null if the block is not assigned to a nation.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
member Country : string with get, set

Property Value

Type: String
See Also

Reference

CodeBlock Class
VirtualRadar.Interface.StandingData Namespace


CodeBlock.IsMilitary Property

CodeBlockIsMilitary Property
Gets or sets a flag indicating that this block is used by the nation's military.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMilitary { get; set; }
Public Property IsMilitary As Boolean
    Get
    Set
public:
property bool IsMilitary {
    bool get ();
    void set (bool value);
}
member IsMilitary : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeBlock Class
VirtualRadar.Interface.StandingData Namespace


CodeBlock Methods

CodeBlock Methods

The CodeBlock type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeBlock Class
VirtualRadar.Interface.StandingData Namespace


EnginePlacement Enumeration

EnginePlacement Enumeration
An enumeration of the placement of the engines on the aircraft, if known.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnginePlacement
Public Enumeration EnginePlacement
public enum class EnginePlacement
type EnginePlacement
Members
Member name | Value | Description
Unknown | 0 | The engine placement has not been recorded for the aircraft.
AftMounted | 1 | The engines are mainly mounted towards the rear of the aircraft.
WingBuried | 2 | The engines are mounted within the wings.
FuselageBuried | 3 | The engines are mounted within the fuselage.
NoseMounted | 4 | The engine is mounted within the nose of the aircraft.
WingMounted | 5 | The engines are mounted on wing pylons.
Remarks
The integer values for these are sent to browsers - try not to change the numbers between releases.
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


EngineType Enumeration

EngineType Enumeration
An enumeration of the type of aircraft engine in use on the aircraft.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EngineType
Public Enumeration EngineType
public enum class EngineType
type EngineType
Members
Member name | Value | Description
None | 0 | The type of engine is unknown or the aircraft has no engines.
Piston | 1 | Internal combustion engine.
Turboprop | 2 | Turboprop or turboshaft engine.
Jet | 3 | Jet engine.
Electric | 4 | Electric engine.
Remarks
The integer values for these are sent to browsers - try not to change the numbers between releases.
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


FlightNumber Class

FlightNumber Class
Describes a flight number in the data files.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataFlightNumber

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FlightNumber
Public Class FlightNumber
public ref class FlightNumber
type FlightNumber =  class end

The FlightNumber type exposes the following members.

Constructors
 | Name | Description
Public method | FlightNumber | Creates a new object.
Top
Properties
 | Name | Description
Public property | AirlineCode | Gets or sets the airline code (either ICAO or IATA) of the flight.
Public property | AirportCodes | Gets a list of airports in the route that the flight number describes.
Public property | FlightCode | Gets the flight code portion of the flight number.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


FlightNumber Constructor

FlightNumber Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightNumber()
Public Sub New
public:
FlightNumber()
new : unit -> FlightNumber
See Also

Reference

FlightNumber Class
VirtualRadar.Interface.StandingData Namespace


FlightNumber Properties

FlightNumber Properties

The FlightNumber type exposes the following members.

Properties
 | Name | Description
Public property | AirlineCode | Gets or sets the airline code (either ICAO or IATA) of the flight.
Public property | AirportCodes | Gets a list of airports in the route that the flight number describes.
Public property | FlightCode | Gets the flight code portion of the flight number.
Top
See Also

Reference

FlightNumber Class
VirtualRadar.Interface.StandingData Namespace


FlightNumber.AirlineCode Property

FlightNumberAirlineCode Property
Gets or sets the airline code (either ICAO or IATA) of the flight.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AirlineCode { get; set; }
Public Property AirlineCode As String
    Get
    Set
public:
property String^ AirlineCode {
    String^ get ();
    void set (String^ value);
}
member AirlineCode : string with get, set

Property Value

Type: String
Remarks
In the flight number ANZ039C this would be ANZ.
See Also

Reference

FlightNumber Class
VirtualRadar.Interface.StandingData Namespace


FlightNumber.AirportCodes Property

FlightNumberAirportCodes Property
Gets a list of airports in the route that the flight number describes.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> AirportCodes { get; }
Public ReadOnly Property AirportCodes As List(Of String)
    Get
public:
property List<String^>^ AirportCodes {
    List<String^>^ get ();
}
member AirportCodes : List<string> with get

Property Value

Type: List String
See Also

Reference

FlightNumber Class
VirtualRadar.Interface.StandingData Namespace


FlightNumber.FlightCode Property

FlightNumberFlightCode Property
Gets the flight code portion of the flight number.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FlightCode { get; set; }
Public Property FlightCode As String
    Get
    Set
public:
property String^ FlightCode {
    String^ get ();
    void set (String^ value);
}
member FlightCode : string with get, set

Property Value

Type: String
Remarks
In the flight number ANZ039C this would be 039C.
See Also

Reference

FlightNumber Class
VirtualRadar.Interface.StandingData Namespace


FlightNumber Methods

FlightNumber Methods

The FlightNumber type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FlightNumber Class
VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloader Interface

IBackgroundDataDownloader Interface
The interface for the object that downloads updates to the data in the background once a day (configuration permitting).

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundDataDownloader : ISingleton<IBackgroundDataDownloader>
Public Interface IBackgroundDataDownloader
    Inherits ISingleton(Of IBackgroundDataDownloader)
public interface class IBackgroundDataDownloader : ISingleton<IBackgroundDataDownloader^>
type IBackgroundDataDownloader =
    interface
        interface ISingleton<IBackgroundDataDownloader>
    end

The IBackgroundDataDownloader type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | Start | Triggers an immediate download and then a period download check once a day.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloader Properties

IBackgroundDataDownloader Properties

The IBackgroundDataDownloader type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IBackgroundDataDownloader Interface
VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloader.Provider Property

IBackgroundDataDownloaderProvider Property
Gets or sets the object that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IBackgroundDataDownloaderProvider Provider { get; set; }
Property Provider As IBackgroundDataDownloaderProvider
    Get
    Set
property IBackgroundDataDownloaderProvider^ Provider {
    IBackgroundDataDownloaderProvider^ get ();
    void set (IBackgroundDataDownloaderProvider^ value);
}
abstract Provider : IBackgroundDataDownloaderProvider with get, set

Property Value

Type: IBackgroundDataDownloaderProvider
See Also

Reference

IBackgroundDataDownloader Interface
VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloader Methods

IBackgroundDataDownloader Methods

The IBackgroundDataDownloader type exposes the following members.

Methods
 | Name | Description
Public method | Start | Triggers an immediate download and then a period download check once a day.
Top
See Also

Reference

IBackgroundDataDownloader Interface
VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloader.Start Method

IBackgroundDataDownloaderStart Method
Triggers an immediate download and then a period download check once a day.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

IBackgroundDataDownloader Interface
VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloaderProvider Interface

IBackgroundDataDownloaderProvider Interface
The interface for objects that abstract away the environment for IBackgroundDataDownloader.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundDataDownloaderProvider
Public Interface IBackgroundDataDownloaderProvider
public interface class IBackgroundDataDownloaderProvider
type IBackgroundDataDownloaderProvider =  interface end

The IBackgroundDataDownloaderProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current date and time in UTC.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloaderProvider Properties

IBackgroundDataDownloaderProvider Properties

The IBackgroundDataDownloaderProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current date and time in UTC.
Top
See Also

Reference

IBackgroundDataDownloaderProvider Interface
VirtualRadar.Interface.StandingData Namespace


IBackgroundDataDownloaderProvider.UtcNow Property

IBackgroundDataDownloaderProviderUtcNow Property
Gets the current date and time in UTC.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UtcNow { get; }
ReadOnly Property UtcNow As DateTime
    Get
property DateTime UtcNow {
    DateTime get ();
}
abstract UtcNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IBackgroundDataDownloaderProvider Interface
VirtualRadar.Interface.StandingData Namespace


ICallsignRouteFetcher Interface

ICallsignRouteFetcher Interface
The interface for a singleton object that manages the fetching of routes for callsigns across many aircraft lists (or potentially anything that needs to find callsigns from routes).

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICallsignRouteFetcher : ISingleton<ICallsignRouteFetcher>
Public Interface ICallsignRouteFetcher
    Inherits ISingleton(Of ICallsignRouteFetcher)
public interface class ICallsignRouteFetcher : ISingleton<ICallsignRouteFetcher^>
type ICallsignRouteFetcher =
    interface
        interface ISingleton<ICallsignRouteFetcher>
    end

The ICallsignRouteFetcher type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | RegisterAircraft | Registers an aircraft's callsign with the fetcher. If the details are already known then they are immediately returned, otherwise they will be fetched on a background thread.
Top
Events
 | Name | Description
Public event | Fetched | Raised when callsign details have been fetched or changed, or if a fetch attempt was made and no details could be found.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


ICallsignRouteFetcher Properties

ICallsignRouteFetcher Properties

The ICallsignRouteFetcher type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

ICallsignRouteFetcher Interface
VirtualRadar.Interface.StandingData Namespace


ICallsignRouteFetcher Methods

ICallsignRouteFetcher Methods

The ICallsignRouteFetcher type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAircraft | Registers an aircraft's callsign with the fetcher. If the details are already known then they are immediately returned, otherwise they will be fetched on a background thread.
Top
See Also

Reference

ICallsignRouteFetcher Interface
VirtualRadar.Interface.StandingData Namespace


ICallsignRouteFetcher.RegisterAircraft Method

ICallsignRouteFetcherRegisterAircraft Method
Registers an aircraft's callsign with the fetcher. If the details are already known then they are immediately returned, otherwise they will be fetched on a background thread.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CallsignRouteDetail RegisterAircraft(
    IAircraft aircraft
)
Function RegisterAircraft (
    aircraft As IAircraft
) As CallsignRouteDetail
CallsignRouteDetail^ RegisterAircraft(
    IAircraft^ aircraft
)
abstract RegisterAircraft :
        aircraft : IAircraft -> CallsignRouteDetail

Parameters

aircraft
Type: VirtualRadar.InterfaceIAircraft

Return Value

Type: CallsignRouteDetail
Null if the callsign has not been fetched, the callsign details if they have been fetched.
Remarks
There is no unregister call, any given callsign is automatically deregistered after the fetcher hasn't seen a RegisterAircraft for it in a while.
See Also

Reference

ICallsignRouteFetcher Interface
VirtualRadar.Interface.StandingData Namespace


ICallsignRouteFetcher Events

ICallsignRouteFetcher Events

The ICallsignRouteFetcher type exposes the following members.

Events
 | Name | Description
Public event | Fetched | Raised when callsign details have been fetched or changed, or if a fetch attempt was made and no details could be found.
Top
See Also

Reference

ICallsignRouteFetcher Interface
VirtualRadar.Interface.StandingData Namespace


ICallsignRouteFetcher.Fetched Event

ICallsignRouteFetcherFetched Event
Raised when callsign details have been fetched or changed, or if a fetch attempt was made and no details could be found.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<CallsignRouteDetail>> Fetched
Event Fetched As EventHandler(Of EventArgs(Of CallsignRouteDetail))
 event EventHandler<EventArgs<CallsignRouteDetail^>^>^ Fetched {
    void add (EventHandler<EventArgs<CallsignRouteDetail^>^>^ value);
    void remove (EventHandler<EventArgs<CallsignRouteDetail^>^>^ value);
}
abstract Fetched : IEvent<EventHandler<EventArgs<CallsignRouteDetail>>,
    EventArgs<CallsignRouteDetail>>

Value

Type: SystemEventHandler EventArgs CallsignRouteDetail
Remarks
This is raised on a background thread. If you allow exceptions to bubble up from your event handler then they will be logged but they could also interfere with other heartbeat event handlers - do not let exceptions bubble up.
See Also

Reference

ICallsignRouteFetcher Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager Interface

IStandingDataManager Interface
The interface for objects that manage standing data for the server.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStandingDataManager : ISingleton<IStandingDataManager>
Public Interface IStandingDataManager
    Inherits ISingleton(Of IStandingDataManager)
public interface class IStandingDataManager : ISingleton<IStandingDataManager^>
type IStandingDataManager =
    interface
        interface ISingleton<IStandingDataManager>
    end

The IStandingDataManager type exposes the following members.

Properties
 | Name | Description
Public property | CodeBlocksLoaded | Returns true if the code blocks have been loaded.
Public property | Lock | Gets the lock object.
Public property | Provider | Gets or sets the object that abstracts away the environment to make testing easier.
Public property | RouteStatus | Returns status information about the current route files.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | FindAircraftType | Returns the ICAO8643 type information for the aircraft type passed across.
Public method | FindAirlinesForCode | Returns the airlines that have the IATA or ICAO code passed across.
Public method | FindCodeBlock | Returns the code block for the ICAO24 aircraft identifier passed across.
Public method | FindRoute | Returns the route that the aircraft using the callsign passed across is most likely following.
Public method | Load | Forces the manager to load the data if it hasn't already been loaded. Does nothing if the data is already loaded.
Top
Events
 | Name | Description
Public event | LoadCompleted | Raised after Load has finished loading the data and RouteStatus has been updated.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


IStandingDataManager Properties

IStandingDataManager Properties

The IStandingDataManager type exposes the following members.

Properties
 | Name | Description
Public property | CodeBlocksLoaded | Returns true if the code blocks have been loaded.
Public property | Lock | Gets the lock object.
Public property | Provider | Gets or sets the object that abstracts away the environment to make testing easier.
Public property | RouteStatus | Returns status information about the current route files.
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.CodeBlocksLoaded Property

IStandingDataManagerCodeBlocksLoaded Property
Returns true if the code blocks have been loaded.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CodeBlocksLoaded { get; }
ReadOnly Property CodeBlocksLoaded As Boolean
    Get
property bool CodeBlocksLoaded {
    bool get ();
}
abstract CodeBlocksLoaded : bool with get

Property Value

Type: Boolean
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.Lock Property

IStandingDataManagerLock Property
Gets the lock object.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Lock { get; }
ReadOnly Property Lock As Object
    Get
property Object^ Lock {
    Object^ get ();
}
abstract Lock : Object with get

Property Value

Type: Object
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.Provider Property

IStandingDataManagerProvider Property
Gets or sets the object that abstracts away the environment to make testing easier.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStandingDataManagerProvider Provider { get; set; }
Property Provider As IStandingDataManagerProvider
    Get
    Set
property IStandingDataManagerProvider^ Provider {
    IStandingDataManagerProvider^ get ();
    void set (IStandingDataManagerProvider^ value);
}
abstract Provider : IStandingDataManagerProvider with get, set

Property Value

Type: IStandingDataManagerProvider
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.RouteStatus Property

IStandingDataManagerRouteStatus Property
Returns status information about the current route files.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string RouteStatus { get; }
ReadOnly Property RouteStatus As String
    Get
property String^ RouteStatus {
    String^ get ();
}
abstract RouteStatus : string with get

Property Value

Type: String
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager Methods

IStandingDataManager Methods

The IStandingDataManager type exposes the following members.

Methods
 | Name | Description
Public method | FindAircraftType | Returns the ICAO8643 type information for the aircraft type passed across.
Public method | FindAirlinesForCode | Returns the airlines that have the IATA or ICAO code passed across.
Public method | FindCodeBlock | Returns the code block for the ICAO24 aircraft identifier passed across.
Public method | FindRoute | Returns the route that the aircraft using the callsign passed across is most likely following.
Public method | Load | Forces the manager to load the data if it hasn't already been loaded. Does nothing if the data is already loaded.
Top
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.FindAircraftType Method

IStandingDataManagerFindAircraftType Method
Returns the ICAO8643 type information for the aircraft type passed across.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftType FindAircraftType(
    string type
)
Function FindAircraftType (
    type As String
) As AircraftType
AircraftType^ FindAircraftType(
    String^ type
)
abstract FindAircraftType :
        type : string -> AircraftType

Parameters

type
Type: SystemString

Return Value

Type: AircraftType
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.FindAirlinesForCode Method

IStandingDataManagerFindAirlinesForCode Method
Returns the airlines that have the IATA or ICAO code passed across.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<Airline> FindAirlinesForCode(
    string code
)
Function FindAirlinesForCode (
    code As String
) As IEnumerable(Of Airline)
IEnumerable<Airline^>^ FindAirlinesForCode(
    String^ code
)
abstract FindAirlinesForCode :
        code : string -> IEnumerable<Airline>

Parameters

code
Type: SystemString

Return Value

Type: IEnumerable Airline
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.FindCodeBlock Method

IStandingDataManagerFindCodeBlock Method
Returns the code block for the ICAO24 aircraft identifier passed across.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CodeBlock FindCodeBlock(
    string icao24
)
Function FindCodeBlock (
    icao24 As String
) As CodeBlock
CodeBlock^ FindCodeBlock(
    String^ icao24
)
abstract FindCodeBlock :
        icao24 : string -> CodeBlock

Parameters

icao24
Type: SystemString

Return Value

Type: CodeBlock
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.FindRoute Method

IStandingDataManagerFindRoute Method
Returns the route that the aircraft using the callsign passed across is most likely following.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Route FindRoute(
    string callSign
)
Function FindRoute (
    callSign As String
) As Route
Route^ FindRoute(
    String^ callSign
)
abstract FindRoute :
        callSign : string -> Route

Parameters

callSign
Type: SystemString

Return Value

Type: Route
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.Load Method

IStandingDataManagerLoad Method
Forces the manager to load the data if it hasn't already been loaded. Does nothing if the data is already loaded.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Load()
Sub Load
void Load()
abstract Load : unit -> unit
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager Events

IStandingDataManager Events

The IStandingDataManager type exposes the following members.

Events
 | Name | Description
Public event | LoadCompleted | Raised after Load has finished loading the data and RouteStatus has been updated.
Top
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManager.LoadCompleted Event

IStandingDataManagerLoadCompleted Event
Raised after Load has finished loading the data and RouteStatus has been updated.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler LoadCompleted
Event LoadCompleted As EventHandler
 event EventHandler^ LoadCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract LoadCompleted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IStandingDataManager Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManagerProvider Interface

IStandingDataManagerProvider Interface
The interface for objects that abstract away the environment for IStandingDataManager.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStandingDataManagerProvider
Public Interface IStandingDataManagerProvider
public interface class IStandingDataManagerProvider
type IStandingDataManagerProvider =  interface end

The IStandingDataManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | FileExists | Returns true if the file exists.
Public method | ReadAllLines | Returns an array of every line of text from the file.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


IStandingDataManagerProvider Methods

IStandingDataManagerProvider Methods

The IStandingDataManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | FileExists | Returns true if the file exists.
Public method | ReadAllLines | Returns an array of every line of text from the file.
Top
See Also

Reference

IStandingDataManagerProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManagerProvider.FileExists Method

IStandingDataManagerProviderFileExists Method
Returns true if the file exists.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FileExists(
    string fileName
)
Function FileExists (
    fileName As String
) As Boolean
bool FileExists(
    String^ fileName
)
abstract FileExists :
        fileName : string -> bool

Parameters

fileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IStandingDataManagerProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataManagerProvider.ReadAllLines Method

IStandingDataManagerProviderReadAllLines Method
Returns an array of every line of text from the file.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] ReadAllLines(
    string fileName
)
Function ReadAllLines (
    fileName As String
) As String()
array<String^>^ ReadAllLines(
    String^ fileName
)
abstract ReadAllLines :
        fileName : string -> string[]

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

IStandingDataManagerProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdater Interface

IStandingDataUpdater Interface
The interface for objects that can update the standing data maintenance files.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStandingDataUpdater
Public Interface IStandingDataUpdater
public interface class IStandingDataUpdater
type IStandingDataUpdater =  interface end

The IStandingDataUpdater type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Top
Methods
 | Name | Description
Public method | DataIsOld | Returns true if the data is out of date and should be updated.
Public method | Update | Updates any files that are out of date.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdater Properties

IStandingDataUpdater Properties

The IStandingDataUpdater type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets or sets the object that abstracts away the environment for testing.
Top
See Also

Reference

IStandingDataUpdater Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdater.Provider Property

IStandingDataUpdaterProvider Property
Gets or sets the object that abstracts away the environment for testing.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStandingDataUpdaterProvider Provider { get; set; }
Property Provider As IStandingDataUpdaterProvider
    Get
    Set
property IStandingDataUpdaterProvider^ Provider {
    IStandingDataUpdaterProvider^ get ();
    void set (IStandingDataUpdaterProvider^ value);
}
abstract Provider : IStandingDataUpdaterProvider with get, set

Property Value

Type: IStandingDataUpdaterProvider
See Also

Reference

IStandingDataUpdater Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdater Methods

IStandingDataUpdater Methods

The IStandingDataUpdater type exposes the following members.

Methods
 | Name | Description
Public method | DataIsOld | Returns true if the data is out of date and should be updated.
Public method | Update | Updates any files that are out of date.
Top
See Also

Reference

IStandingDataUpdater Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdater.DataIsOld Method

IStandingDataUpdaterDataIsOld Method
Returns true if the data is out of date and should be updated.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DataIsOld()
Function DataIsOld As Boolean
bool DataIsOld()
abstract DataIsOld : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IStandingDataUpdater Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdater.Update Method

IStandingDataUpdaterUpdate Method
Updates any files that are out of date.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Update()
Sub Update
void Update()
abstract Update : unit -> unit

Return Value

Type:
See Also

Reference

IStandingDataUpdater Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider Interface

IStandingDataUpdaterProvider Interface
The interface for objects that can abstract away the environment for IStandingDataUpdater.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStandingDataUpdaterProvider
Public Interface IStandingDataUpdaterProvider
public interface class IStandingDataUpdaterProvider
type IStandingDataUpdaterProvider =  interface end

The IStandingDataUpdaterProvider type exposes the following members.

Methods
 | Name | Description
Public method | DownloadAndDecompressFile | Downloads the URL passed across to the file passed across, overwriting the file if it already exists.
Public method | DownloadLines | Downloads the content of a text file from the URL passed across.
Public method | FileExists | Returns true if the file exists.
Public method | MoveFile | Deletes the live file and moves the temporary file to the live filename.
Public method | ReadLines | Returns the entire content of the file.
Public method | WriteLines | Overwrites the entire file with the text passed across.
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider Methods

IStandingDataUpdaterProvider Methods

The IStandingDataUpdaterProvider type exposes the following members.

Methods
 | Name | Description
Public method | DownloadAndDecompressFile | Downloads the URL passed across to the file passed across, overwriting the file if it already exists.
Public method | DownloadLines | Downloads the content of a text file from the URL passed across.
Public method | FileExists | Returns true if the file exists.
Public method | MoveFile | Deletes the live file and moves the temporary file to the live filename.
Public method | ReadLines | Returns the entire content of the file.
Public method | WriteLines | Overwrites the entire file with the text passed across.
Top
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider.DownloadAndDecompressFile Method

IStandingDataUpdaterProviderDownloadAndDecompressFile Method
Downloads the URL passed across to the file passed across, overwriting the file if it already exists.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void DownloadAndDecompressFile(
    string url,
    string temporaryFileName
)
Sub DownloadAndDecompressFile (
    url As String,
    temporaryFileName As String
)
void DownloadAndDecompressFile(
    String^ url,
    String^ temporaryFileName
)
abstract DownloadAndDecompressFile :
        url : string *
        temporaryFileName : string -> unit

Parameters

url
Type: SystemString
temporaryFileName
Type: SystemString
Remarks
The URL is assumed to be pointing to a GZIP format compressed source, the file written is the decompressed version.
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider.DownloadLines Method

IStandingDataUpdaterProviderDownloadLines Method
Downloads the content of a text file from the URL passed across.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] DownloadLines(
    string url
)
Function DownloadLines (
    url As String
) As String()
array<String^>^ DownloadLines(
    String^ url
)
abstract DownloadLines :
        url : string -> string[]

Parameters

url
Type: SystemString

Return Value

Type: String
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider.FileExists Method

IStandingDataUpdaterProviderFileExists Method
Returns true if the file exists.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FileExists(
    string fileName
)
Function FileExists (
    fileName As String
) As Boolean
bool FileExists(
    String^ fileName
)
abstract FileExists :
        fileName : string -> bool

Parameters

fileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider.MoveFile Method

IStandingDataUpdaterProviderMoveFile Method
Deletes the live file and moves the temporary file to the live filename.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveFile(
    string temporaryFileName,
    string liveFileName
)
Sub MoveFile (
    temporaryFileName As String,
    liveFileName As String
)
void MoveFile(
    String^ temporaryFileName,
    String^ liveFileName
)
abstract MoveFile :
        temporaryFileName : string *
        liveFileName : string -> unit

Parameters

temporaryFileName
Type: SystemString
liveFileName
Type: SystemString
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider.ReadLines Method

IStandingDataUpdaterProviderReadLines Method
Returns the entire content of the file.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] ReadLines(
    string fileName
)
Function ReadLines (
    fileName As String
) As String()
array<String^>^ ReadLines(
    String^ fileName
)
abstract ReadLines :
        fileName : string -> string[]

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


IStandingDataUpdaterProvider.WriteLines Method

IStandingDataUpdaterProviderWriteLines Method
Overwrites the entire file with the text passed across.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void WriteLines(
    string fileName,
    string[] lines
)
Sub WriteLines (
    fileName As String,
    lines As String()
)
void WriteLines(
    String^ fileName,
    array<String^>^ lines
)
abstract WriteLines :
        fileName : string *
        lines : string[] -> unit

Parameters

fileName
Type: SystemString
lines
Type: SystemString
See Also

Reference

IStandingDataUpdaterProvider Interface
VirtualRadar.Interface.StandingData Namespace


Route Class

Route Class
Describes a route stored or inferred from the standing data files.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.StandingDataRoute

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Route
Public Class Route
public ref class Route
type Route =  class end

The Route type exposes the following members.

Constructors
 | Name | Description
Public method | Route | Creates a new object.
Top
Properties
 | Name | Description
Public property | From | Gets or sets the airport that the route starts from.
Public property | Stopovers | Gets or sets all of the airports between the From and To airports, if any.
Public property | To | Gets or sets the airport that the route ends on.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


Route Constructor

Route Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Route()
Public Sub New
public:
Route()
new : unit -> Route
See Also

Reference

Route Class
VirtualRadar.Interface.StandingData Namespace


Route Properties

Route Properties

The Route type exposes the following members.

Properties
 | Name | Description
Public property | From | Gets or sets the airport that the route starts from.
Public property | Stopovers | Gets or sets all of the airports between the From and To airports, if any.
Public property | To | Gets or sets the airport that the route ends on.
Top
See Also

Reference

Route Class
VirtualRadar.Interface.StandingData Namespace


Route.From Property

RouteFrom Property
Gets or sets the airport that the route starts from.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Airport From { get; set; }
Public Property From As Airport
    Get
    Set
public:
property Airport^ From {
    Airport^ get ();
    void set (Airport^ value);
}
member From : Airport with get, set

Property Value

Type: Airport
See Also

Reference

Route Class
VirtualRadar.Interface.StandingData Namespace


Route.Stopovers Property

RouteStopovers Property
Gets or sets all of the airports between the From and To airports, if any.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<Airport> Stopovers { get; }
Public ReadOnly Property Stopovers As List(Of Airport)
    Get
public:
property List<Airport^>^ Stopovers {
    List<Airport^>^ get ();
}
member Stopovers : List<Airport> with get

Property Value

Type: List Airport
See Also

Reference

Route Class
VirtualRadar.Interface.StandingData Namespace


Route.To Property

RouteTo Property
Gets or sets the airport that the route ends on.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Airport To { get; set; }
Public Property To As Airport
    Get
    Set
public:
property Airport^ To {
    Airport^ get ();
    void set (Airport^ value);
}
member To : Airport with get, set

Property Value

Type: Airport
See Also

Reference

Route Class
VirtualRadar.Interface.StandingData Namespace


Route Methods

Route Methods

The Route type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Route Class
VirtualRadar.Interface.StandingData Namespace


Species Enumeration

Species Enumeration
An enumeration of the different species of flying machine described by ICAO8643.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Species
Public Enumeration Species
public enum class Species
type Species
Members
Member name | Value | Description
None | 0 | Species is not known or not applicable.
Landplane | 1 | A fixed-wing aircraft that can only land or take off from terra firma.
Seaplane | 2 | A fixed-wing aircraft that can only land or take off from a body of water.
Amphibian | 3 | A fixed-wing aircraft that can land or take off either from land or water.
Helicopter | 4 | A rotary-wing aircraft whose rotors are driven by a motor.
Gyrocopter | 5 | A rotary-wing aircraft whose rotors are not driven by a motor.
TiltWing | 6 | An aircraft whose wing (and the engines / propellers attached) are horizontal during forward flight but can be tilted 90° upwards to allow it to take off and land vertically.
GroundVehicle | 7 | A ground vehicle.
Tower | 8 | A tower or radio beacon of some kind.
Remarks
The numbers associated with these entries are sent to the browsers. Try to keep them unchanged across releases.
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


WakeTurbulenceCategory Enumeration

WakeTurbulenceCategory Enumeration
An enumeration of the different wake turbulence categories as used in ICAO8643.

Namespace: VirtualRadar.Interface.StandingData
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WakeTurbulenceCategory
Public Enumeration WakeTurbulenceCategory
public enum class WakeTurbulenceCategory
type WakeTurbulenceCategory
Members
Member name | Value | Description
None | 0 | No WTC has been declared or is applicable.
Light | 1 | Aircraft up to 7 tons.
Medium | 2 | Aircraft up to 135.999 tons.
Heavy | 3 | Aircraft weighing 136 tons or more.
Remarks
The numeric values of these categories are sent to the browser. Try to leave them unchanged across releases.
See Also

Reference

VirtualRadar.Interface.StandingData Namespace


VirtualRadar.Interface.View Namespace

VirtualRadar.Interface.View Namespace
The namespace for the interfaces for all of the user interface views in the application.
Classes
 | Class | Description
Public class | EnumModel | Holds an enum value as an integer and a localised description of the enum value. Used to carry lists of enums (or other fixed values) to web interfaces.
Public class | FeedStatus | A DTO that carries information about a feed.
Public class | ServerRequest | A DTO class that carries information about a web server request.
Public class | ValidationModelField | An object that can carry validation information in view models for web interfaces.
Public class | ValidationModelFieldAttribute | Used to decorate ValidationFieldModel properties in a view model with the ValidationField corresponding to the property.
Public class | ValidationModelHelper | A class that can help with copying validation results from a presenter to a web form view model.
Public class | ValidationResult | Describes the result of the validation of a single field.
Public class | ValidationResults | Describes the results of the validation of an entire form or a single field.
Interfaces
 | Interface | Description
Public interface | IAboutView | The interface for views that display information about the application and contain small support helpers for the app.
Public interface | IAircraftOnlineLookupLogView | The view for the display of aircraft online lookup log entries.
Public interface | IBackgroundThreadQueuesView | The interface for a diagnostics view that shows details of all of the background thread queues running on the system.
Public interface | IBusyView | The interface for views that can show that the presenter is doing some work and isn't necessarily keeping the UI responsive.
Public interface | ICidrEditView | The interface for views that let the user enter CIDRs.
Public interface | IConfirmView | The interface that views capable of confirming an action with the user must implement.
Public interface | IConnectionClientLogView | The interface for views that can display the details of clients that have connected to the server and the sessions established by the client.
Public interface | IConnectionSessionLogView | The interface for GUIs that display connection sessions to the user.
Public interface | IConnectorActivityLogView | The interface for views that can display connector activity logs.
Public interface | IDownloadDataView | The interface for UI objects that allow the user to manually update the standing data.
Public interface | IFlightSimulatorXView | The interface for views that can display information about the connection to Flight Simulator X.
Public interface | IInvalidPluginsView | The interface for GUI objects that can display a list of invalid plugins.
Public interface | IListDetailEditorViewT | The interface that views capable of presenting and maintaining a list of records should implement.
Public interface | IMainView | The interface for the view that the user sees when they first start the application.
Public interface | IPluginsView | The interface for GUI objects that can display information about plugins and allow the user to configure them.
Public interface | IRebroadcastOptionsView | The interface for all views that allow the user to enter the details of rebroadcast servers.
Public interface | IReceiverConfigurationWizard | The interface that Receiver Configuration wizards need to implement.
Public interface | IReceiverConfigurationWizardAnswers | The interface that IReceiverConfigurationWizard views expose to carry the answers supplied by the user.
Public interface | IReceiverLocationsView | The interface for the view that can be used to edit the list of receiver locations.
Public interface | ISettingsView | The interface for views that lets the user view and edit the configuration.
Public interface | IShutdownView | The interface for the splash screen that is displayed while the application is closing down.
Public interface | ISplashView | The interface for the splash screen that is displayed while the application is firing up.
Public interface | IStatisticsView | The interface for the view that displays the statistics and refreshes the display on a timer.
Public interface | IValidateDelegate | The interface for user controls that want to nominate which of their controls should have validation messages shown against it (as opposed to the validation message being shown against the user control itself).
Public interface | IValidateView | The interface for views that can display validation results.
Public interface | IView | The interface that all views must implement.
Enumerations
 | Enumeration | Description
Public enumeration | DedicatedReceiver | An enumeration of the dedicated receivers that the receiver configuration wizard knows about.
Public enumeration | ReceiverClass | An enumeration of the different classes of receiver that the receiver configuration wizard can collect information about.
Public enumeration | SdrDecoder | An enumeration of the SDR decoders that the receiver configuration wizard knows about.
Public enumeration | ValidationField | An enumeration of fields that are subject to validation.
Remarks

The application follows the MVP pattern for user interfaces, whereby the view is hidden behind an interface, is very dumb (it only contains code to drive the user interface elements, it is not allowed to directly load or save data) and is controlled by a presenter. In almost all cases the object implementing the view doesn't actually need to be a GUI object, although in the case of IFlightSimulatorXView is must create a window handle somewhere for the SimConnect library to communicate through.


DedicatedReceiver Enumeration

DedicatedReceiver Enumeration
An enumeration of the dedicated receivers that the receiver configuration wizard knows about.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DedicatedReceiver
Public Enumeration DedicatedReceiver
public enum class DedicatedReceiver
type DedicatedReceiver
Members
Member name | Value | Description
RadarBox | 0 | The user has an AirNav RadioBox.
Beast | 1 | The user has a Beast.
KineticAvionicsAll | 2 | The user has a Kinetics receiver.
MicroAdsb | 3 | The user has a microADSB USB stick receiver.
PlaneFinderRadar | 4 | The user has a Plane Finder Radar receiver.
Other | 5 | The user has a receiver that we don't know about.
See Also

Reference

VirtualRadar.Interface.View Namespace


EnumModel Class

EnumModel Class
Holds an enum value as an integer and a localised description of the enum value. Used to carry lists of enums (or other fixed values) to web interfaces.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewEnumModel

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnumModel
Public Class EnumModel
public ref class EnumModel
type EnumModel =  class end

The EnumModel type exposes the following members.

Constructors
 | Name | Description
Public method | EnumModel | Creates a new object.
Public method | EnumModel(Int32, String) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the localised description of the enum.
Public property | Value | Gets or sets the enum value.
Top
Methods
 | Name | Description
 | CastFromIntT | Casts an integer back to an enum value. Throws an InvalidCastException if the integer is not one of the enum's values.
 | CreateFromEnumT | Creates a sorted array of records for an enum.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsInRangeT | Returns true if the value passed across is an valid value for the enum type parameter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


EnumModel Constructor

EnumModel Constructor
Overload List
 | Name | Description
Public method | EnumModel | Creates a new object.
Public method | EnumModel(Int32, String) | Creates a new object.
Top
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel Constructor

EnumModel Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnumModel()
Public Sub New
public:
EnumModel()
new : unit -> EnumModel
See Also

Reference

EnumModel Class
EnumModel Overload
VirtualRadar.Interface.View Namespace


EnumModel Constructor (Int32, String)

EnumModel Constructor (Int32, String)
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnumModel(
    int value,
    string description
)
Public Sub New (
    value As Integer,
    description As String
)
public:
EnumModel(
    int value,
    String^ description
)
new :
        value : int *
        description : string -> EnumModel

Parameters

value
Type: SystemInt32
description
Type: SystemString
See Also

Reference

EnumModel Class
EnumModel Overload
VirtualRadar.Interface.View Namespace


EnumModel Properties

EnumModel Properties

The EnumModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the localised description of the enum.
Public property | Value | Gets or sets the enum value.
Top
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel.Description Property

EnumModelDescription Property
Gets or sets the localised description of the enum.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel.Value Property

EnumModelValue Property
Gets or sets the enum value.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}
member Value : int with get, set

Property Value

Type: Int32
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel Methods

EnumModel Methods

The EnumModel type exposes the following members.

Methods
 | Name | Description
 | CastFromIntT | Casts an integer back to an enum value. Throws an InvalidCastException if the integer is not one of the enum's values.
 | CreateFromEnumT | Creates a sorted array of records for an enum.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsInRangeT | Returns true if the value passed across is an valid value for the enum type parameter.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel.CastFromInt(T) Method

EnumModelCastFromIntT Method
Casts an integer back to an enum value. Throws an InvalidCastException if the integer is not one of the enum's values.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T CastFromInt<T>(
    int value
)

Public Shared Function CastFromInt(Of T) (
    value As Integer
) As T
public:
generic<typename T>
static T CastFromInt(
    int value
)
static member CastFromInt :
        value : int -> 'T

Parameters

value
Type: SystemInt32

Type Parameters

T

Return Value

Type: T
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel.CreateFromEnum(T) Method

EnumModelCreateFromEnumT Method
Creates a sorted array of records for an enum.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EnumModel[] CreateFromEnum<T>(
    Func<T, string> getDescription,
    bool sortByDescription = true,
    Func<T, bool> filter = null
)
where T : struct, new()

Public Shared Function CreateFromEnum(Of T As {Structure, New}) (
    getDescription As Func(Of T, String),
    Optional sortByDescription As Boolean = true,
    Optional filter As Func(Of T, Boolean) = Nothing
) As EnumModel()
public:
generic<typename T>
where T : value class, gcnew()
static array<EnumModel^>^ CreateFromEnum(
    Func<T, String^>^ getDescription,
    bool sortByDescription = true,
    Func<T, bool>^ filter = nullptr
)
static member CreateFromEnum :
        getDescription : Func<'T, string> *
        ?sortByDescription : bool *
        ?filter : Func<'T, bool>
(* Defaults:
        let _sortByDescription = defaultArg sortByDescription true
        let _filter = defaultArg filter null
*)
-> EnumModel[]  when 'T : struct, new()

Parameters

getDescription
Type: SystemFunc T, String
sortByDescription (Optional)
Type: SystemBoolean
filter (Optional)
Type: SystemFunc T, Boolean

Type Parameters

T

Return Value

Type: EnumModel
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


EnumModel.IsInRange(T) Method

EnumModelIsInRangeT Method
Returns true if the value passed across is an valid value for the enum type parameter.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsInRange<T>(
    int value
)

Public Shared Function IsInRange(Of T) (
    value As Integer
) As Boolean
public:
generic<typename T>
static bool IsInRange(
    int value
)
static member IsInRange :
        value : int -> bool

Parameters

value
Type: SystemInt32

Type Parameters

T

Return Value

Type: Boolean
See Also

Reference

EnumModel Class
VirtualRadar.Interface.View Namespace


FeedStatus Class

FeedStatus Class
A DTO that carries information about a feed.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewFeedStatus

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FeedStatus : ICloneable
Public Class FeedStatus
    Implements ICloneable
public ref class FeedStatus : ICloneable
type FeedStatus =
    class
        interface ICloneable
    end

The FeedStatus type exposes the following members.

Constructors
 | Name | Description
Public method | FeedStatus | Initializes a new instance of the FeedStatus class
Top
Properties
 | Name | Description
Public property | ConnectionStatus | Gets or sets the connection status.
Public property | ConnectionStatusDescription | Gets or sets a description of the connection status.
Public property | DataVersion | Gets or sets a value that is incremented any time there is a change of value for the feed.
Public property | FeedId | Gets or sets the unique ID of the feed.
Public property | HasAircraftList | Gets or sets a value indicating that an aircraft list is tracking the aircraft on the feed.
Public property | HasPolarPlot | Gets or sets a value indicating that the feed has a polar plot attached to it.
Public property | IsMergedFeed | Gets or sets a value indicating that this is a merged feed as opposed to a reciever.
Public property | Name | Gets or sets the name of the feed.
Public property | TotalAircraft | Gets or sets the total number of bad messages.
Public property | TotalBadMessages | Gets or sets the total number of bad messages received.
Public property | TotalMessages | Gets or sets the total number of messages received.
Top
Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


FeedStatus Constructor

FeedStatus Constructor
Initializes a new instance of the FeedStatus class

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FeedStatus()
Public Sub New
public:
FeedStatus()
new : unit -> FeedStatus
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus Properties

FeedStatus Properties

The FeedStatus type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStatus | Gets or sets the connection status.
Public property | ConnectionStatusDescription | Gets or sets a description of the connection status.
Public property | DataVersion | Gets or sets a value that is incremented any time there is a change of value for the feed.
Public property | FeedId | Gets or sets the unique ID of the feed.
Public property | HasAircraftList | Gets or sets a value indicating that an aircraft list is tracking the aircraft on the feed.
Public property | HasPolarPlot | Gets or sets a value indicating that the feed has a polar plot attached to it.
Public property | IsMergedFeed | Gets or sets a value indicating that this is a merged feed as opposed to a reciever.
Public property | Name | Gets or sets the name of the feed.
Public property | TotalAircraft | Gets or sets the total number of bad messages.
Public property | TotalBadMessages | Gets or sets the total number of bad messages received.
Public property | TotalMessages | Gets or sets the total number of messages received.
Top
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.ConnectionStatus Property

FeedStatusConnectionStatus Property
Gets or sets the connection status.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatus ConnectionStatus { get; set; }
Public Property ConnectionStatus As ConnectionStatus
    Get
    Set
public:
property ConnectionStatus ConnectionStatus {
    ConnectionStatus get ();
    void set (ConnectionStatus value);
}
member ConnectionStatus : ConnectionStatus with get, set

Property Value

Type: ConnectionStatus
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.ConnectionStatusDescription Property

FeedStatusConnectionStatusDescription Property
Gets or sets a description of the connection status.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConnectionStatusDescription { get; set; }
Public Property ConnectionStatusDescription As String
    Get
    Set
public:
property String^ ConnectionStatusDescription {
    String^ get ();
    void set (String^ value);
}
member ConnectionStatusDescription : string with get, set

Property Value

Type: String
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.DataVersion Property

FeedStatusDataVersion Property
Gets or sets a value that is incremented any time there is a change of value for the feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DataVersion { get; set; }
Public Property DataVersion As Long
    Get
    Set
public:
property long long DataVersion {
    long long get ();
    void set (long long value);
}
member DataVersion : int64 with get, set

Property Value

Type: Int64
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.FeedId Property

FeedStatusFeedId Property
Gets or sets the unique ID of the feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FeedId { get; set; }
Public Property FeedId As Integer
    Get
    Set
public:
property int FeedId {
    int get ();
    void set (int value);
}
member FeedId : int with get, set

Property Value

Type: Int32
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.HasAircraftList Property

FeedStatusHasAircraftList Property
Gets or sets a value indicating that an aircraft list is tracking the aircraft on the feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasAircraftList { get; set; }
Public Property HasAircraftList As Boolean
    Get
    Set
public:
property bool HasAircraftList {
    bool get ();
    void set (bool value);
}
member HasAircraftList : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.HasPolarPlot Property

FeedStatusHasPolarPlot Property
Gets or sets a value indicating that the feed has a polar plot attached to it.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPolarPlot { get; set; }
Public Property HasPolarPlot As Boolean
    Get
    Set
public:
property bool HasPolarPlot {
    bool get ();
    void set (bool value);
}
member HasPolarPlot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.IsMergedFeed Property

FeedStatusIsMergedFeed Property
Gets or sets a value indicating that this is a merged feed as opposed to a reciever.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMergedFeed { get; set; }
Public Property IsMergedFeed As Boolean
    Get
    Set
public:
property bool IsMergedFeed {
    bool get ();
    void set (bool value);
}
member IsMergedFeed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.Name Property

FeedStatusName Property
Gets or sets the name of the feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.TotalAircraft Property

FeedStatusTotalAircraft Property
Gets or sets the total number of bad messages.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TotalAircraft { get; set; }
Public Property TotalAircraft As Integer
    Get
    Set
public:
property int TotalAircraft {
    int get ();
    void set (int value);
}
member TotalAircraft : int with get, set

Property Value

Type: Int32
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.TotalBadMessages Property

FeedStatusTotalBadMessages Property
Gets or sets the total number of bad messages received.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalBadMessages { get; set; }
Public Property TotalBadMessages As Long
    Get
    Set
public:
property long long TotalBadMessages {
    long long get ();
    void set (long long value);
}
member TotalBadMessages : int64 with get, set

Property Value

Type: Int64
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.TotalMessages Property

FeedStatusTotalMessages Property
Gets or sets the total number of messages received.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalMessages { get; set; }
Public Property TotalMessages As Long
    Get
    Set
public:
property long long TotalMessages {
    long long get ();
    void set (long long value);
}
member TotalMessages : int64 with get, set

Property Value

Type: Int64
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus Methods

FeedStatus Methods

The FeedStatus type exposes the following members.

Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.Clone Method

FeedStatusClone Method
See interface docs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


FeedStatus.ToString Method

FeedStatusToString Method
See base docs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

FeedStatus Class
VirtualRadar.Interface.View Namespace


IAboutView Interface

IAboutView Interface
The interface for views that display information about the application and contain small support helpers for the app.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAboutView : IView,
    IDisposable
Public Interface IAboutView
    Inherits IView, IDisposable
public interface class IAboutView : IView,
    IDisposable
type IAboutView =
    interface
        interface IView
        interface IDisposable
    end

The IAboutView type exposes the following members.

Properties
 | Name | Description
Public property | BuildDate | Gets or sets the application's build date.
Public property | Caption | Gets or sets the view's title.
Public property | ConfigurationFolder | Gets or sets the full path to the configuration folder used by the application to store configuration files and data.
Public property | Copyright | Gets or sets a small summary of the application's copyright information.
Public property | Description | Gets or sets a full description of the application, licenses etc.
Public property | Is64BitProcess | Gets or sets a value indicating that VRS is running as a 64-bit process.
Public property | IsMono | Gets or sets a value indicating that VRS is running under Mono.
Public property | ProductName | Gets or sets the product's name.
Public property | Version | Gets or sets the application's version information.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowConfigurationFolderContents | Displays the contents of the configuration folder to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | OpenConfigurationFolderClicked | Raised when the user wants to see the content of the configuration folder.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IAboutView Properties

IAboutView Properties

The IAboutView type exposes the following members.

Properties
 | Name | Description
Public property | BuildDate | Gets or sets the application's build date.
Public property | Caption | Gets or sets the view's title.
Public property | ConfigurationFolder | Gets or sets the full path to the configuration folder used by the application to store configuration files and data.
Public property | Copyright | Gets or sets a small summary of the application's copyright information.
Public property | Description | Gets or sets a full description of the application, licenses etc.
Public property | Is64BitProcess | Gets or sets a value indicating that VRS is running as a 64-bit process.
Public property | IsMono | Gets or sets a value indicating that VRS is running under Mono.
Public property | ProductName | Gets or sets the product's name.
Public property | Version | Gets or sets the application's version information.
Top
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.BuildDate Property

IAboutViewBuildDate Property
Gets or sets the application's build date.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime BuildDate { get; set; }
Property BuildDate As DateTime
    Get
    Set
property DateTime BuildDate {
    DateTime get ();
    void set (DateTime value);
}
abstract BuildDate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.Caption Property

IAboutViewCaption Property
Gets or sets the view's title.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Caption { get; set; }
Property Caption As String
    Get
    Set
property String^ Caption {
    String^ get ();
    void set (String^ value);
}
abstract Caption : string with get, set

Property Value

Type: String
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.ConfigurationFolder Property

IAboutViewConfigurationFolder Property
Gets or sets the full path to the configuration folder used by the application to store configuration files and data.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConfigurationFolder { get; set; }
Property ConfigurationFolder As String
    Get
    Set
property String^ ConfigurationFolder {
    String^ get ();
    void set (String^ value);
}
abstract ConfigurationFolder : string with get, set

Property Value

Type: String
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.Copyright Property

IAboutViewCopyright Property
Gets or sets a small summary of the application's copyright information.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Copyright { get; set; }
Property Copyright As String
    Get
    Set
property String^ Copyright {
    String^ get ();
    void set (String^ value);
}
abstract Copyright : string with get, set

Property Value

Type: String
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.Description Property

IAboutViewDescription Property
Gets or sets a full description of the application, licenses etc.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.Is64BitProcess Property

IAboutViewIs64BitProcess Property
Gets or sets a value indicating that VRS is running as a 64-bit process.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Is64BitProcess { get; set; }
Property Is64BitProcess As Boolean
    Get
    Set
property bool Is64BitProcess {
    bool get ();
    void set (bool value);
}
abstract Is64BitProcess : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.IsMono Property

IAboutViewIsMono Property
Gets or sets a value indicating that VRS is running under Mono.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMono { get; set; }
Property IsMono As Boolean
    Get
    Set
property bool IsMono {
    bool get ();
    void set (bool value);
}
abstract IsMono : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.ProductName Property

IAboutViewProductName Property
Gets or sets the product's name.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProductName { get; set; }
Property ProductName As String
    Get
    Set
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
abstract ProductName : string with get, set

Property Value

Type: String
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.Version Property

IAboutViewVersion Property
Gets or sets the application's version information.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Version { get; set; }
Property Version As String
    Get
    Set
property String^ Version {
    String^ get ();
    void set (String^ value);
}
abstract Version : string with get, set

Property Value

Type: String
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView Methods

IAboutView Methods

The IAboutView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowConfigurationFolderContents | Displays the contents of the configuration folder to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.ShowConfigurationFolderContents Method

IAboutViewShowConfigurationFolderContents Method
Displays the contents of the configuration folder to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowConfigurationFolderContents()
Sub ShowConfigurationFolderContents
void ShowConfigurationFolderContents()
abstract ShowConfigurationFolderContents : unit -> unit
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView Events

IAboutView Events

The IAboutView type exposes the following members.

Events
 | Name | Description
Public event | OpenConfigurationFolderClicked | Raised when the user wants to see the content of the configuration folder.
Top
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAboutView.OpenConfigurationFolderClicked Event

IAboutViewOpenConfigurationFolderClicked Event
Raised when the user wants to see the content of the configuration folder.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler OpenConfigurationFolderClicked
Event OpenConfigurationFolderClicked As EventHandler
 event EventHandler^ OpenConfigurationFolderClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OpenConfigurationFolderClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IAboutView Interface
VirtualRadar.Interface.View Namespace


IAircraftOnlineLookupLogView Interface

IAircraftOnlineLookupLogView Interface
The view for the display of aircraft online lookup log entries.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftOnlineLookupLogView : IView,
    IDisposable
Public Interface IAircraftOnlineLookupLogView
    Inherits IView, IDisposable
public interface class IAircraftOnlineLookupLogView : IView,
    IDisposable
type IAircraftOnlineLookupLogView =
    interface
        interface IView
        interface IDisposable
    end

The IAircraftOnlineLookupLogView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Populate | Refreshes the display of log entries.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IAircraftOnlineLookupLogView Methods

IAircraftOnlineLookupLogView Methods

The IAircraftOnlineLookupLogView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Populate | Refreshes the display of log entries.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IAircraftOnlineLookupLogView Interface
VirtualRadar.Interface.View Namespace


IAircraftOnlineLookupLogView.Populate Method

IAircraftOnlineLookupLogViewPopulate Method
Refreshes the display of log entries.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Populate(
    IEnumerable<AircraftOnlineLookupLogEntry> logEntries
)
Sub Populate (
    logEntries As IEnumerable(Of AircraftOnlineLookupLogEntry)
)
void Populate(
    IEnumerable<AircraftOnlineLookupLogEntry^>^ logEntries
)
abstract Populate :
        logEntries : IEnumerable<AircraftOnlineLookupLogEntry> -> unit

Parameters

logEntries
Type: System.Collections.GenericIEnumerable AircraftOnlineLookupLogEntry
See Also

Reference

IAircraftOnlineLookupLogView Interface
VirtualRadar.Interface.View Namespace


IBackgroundThreadQueuesView Interface

IBackgroundThreadQueuesView Interface
The interface for a diagnostics view that shows details of all of the background thread queues running on the system.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBackgroundThreadQueuesView : IView,
    IDisposable
Public Interface IBackgroundThreadQueuesView
    Inherits IView, IDisposable
public interface class IBackgroundThreadQueuesView : IView,
    IDisposable
type IBackgroundThreadQueuesView =
    interface
        interface IView
        interface IDisposable
    end

The IBackgroundThreadQueuesView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RefreshDisplay | Refreshes the display of queues.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IBackgroundThreadQueuesView Methods

IBackgroundThreadQueuesView Methods

The IBackgroundThreadQueuesView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RefreshDisplay | Refreshes the display of queues.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IBackgroundThreadQueuesView Interface
VirtualRadar.Interface.View Namespace


IBackgroundThreadQueuesView.RefreshDisplay Method

IBackgroundThreadQueuesViewRefreshDisplay Method
Refreshes the display of queues.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshDisplay(
    IQueue[] queues
)
Sub RefreshDisplay (
    queues As IQueue()
)
void RefreshDisplay(
    array<IQueue^>^ queues
)
abstract RefreshDisplay :
        queues : IQueue[] -> unit

Parameters

queues
Type: VirtualRadar.InterfaceIQueue
See Also

Reference

IBackgroundThreadQueuesView Interface
VirtualRadar.Interface.View Namespace


IBusyView Interface

IBusyView Interface
The interface for views that can show that the presenter is doing some work and isn't necessarily keeping the UI responsive.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBusyView
Public Interface IBusyView
public interface class IBusyView
type IBusyView =  interface end

The IBusyView type exposes the following members.

Methods
 | Name | Description
Public method | ShowBusy | Indicates to the user that the application is busy.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IBusyView Methods

IBusyView Methods

The IBusyView type exposes the following members.

Methods
 | Name | Description
Public method | ShowBusy | Indicates to the user that the application is busy.
Top
See Also

Reference

IBusyView Interface
VirtualRadar.Interface.View Namespace


IBusyView.ShowBusy Method

IBusyViewShowBusy Method
Indicates to the user that the application is busy.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object ShowBusy(
    bool isBusy,
    Object previousState
)
Function ShowBusy (
    isBusy As Boolean,
    previousState As Object
) As Object
Object^ ShowBusy(
    bool isBusy,
    Object^ previousState
)
abstract ShowBusy :
        isBusy : bool *
        previousState : Object -> Object

Parameters

isBusy
Type: SystemBoolean
previousState
Type: SystemObject

Return Value

Type: Object
An object that reflects the state on display to the user before the call was made.
Remarks
The intent is that this call is always made as a pair within a try / finally block. The try block calls ShowBusy(true, null) and stores the result. The finally block always calls (false, obj) where obj is the result of the first call.
See Also

Reference

IBusyView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView Interface

ICidrEditView Interface
The interface for views that let the user enter CIDRs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICidrEditView : IView,
    IDisposable
Public Interface ICidrEditView
    Inherits IView, IDisposable
public interface class ICidrEditView : IView,
    IDisposable
type ICidrEditView =
    interface
        interface IView
        interface IDisposable
    end

The ICidrEditView type exposes the following members.

Properties
 | Name | Description
Public property | Cidr | Gets or sets the text of the CIDR.
Public property | CidrIsValid | Gets a value indicating that the value of Cidr represents a valid CIDR.
Public property | FirstMatchingAddress | Gets or sets a description that shows the first matching address.
Public property | LastMatchingAddress | Gets or sets a description that shows the last matching address.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | CidrChanged | Raised when the Cidr has changed.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ICidrEditView Properties

ICidrEditView Properties

The ICidrEditView type exposes the following members.

Properties
 | Name | Description
Public property | Cidr | Gets or sets the text of the CIDR.
Public property | CidrIsValid | Gets a value indicating that the value of Cidr represents a valid CIDR.
Public property | FirstMatchingAddress | Gets or sets a description that shows the first matching address.
Public property | LastMatchingAddress | Gets or sets a description that shows the last matching address.
Top
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView.Cidr Property

ICidrEditViewCidr Property
Gets or sets the text of the CIDR.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Cidr { get; set; }
Property Cidr As String
    Get
    Set
property String^ Cidr {
    String^ get ();
    void set (String^ value);
}
abstract Cidr : string with get, set

Property Value

Type: String
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView.CidrIsValid Property

ICidrEditViewCidrIsValid Property
Gets a value indicating that the value of Cidr represents a valid CIDR.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CidrIsValid { get; }
ReadOnly Property CidrIsValid As Boolean
    Get
property bool CidrIsValid {
    bool get ();
}
abstract CidrIsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView.FirstMatchingAddress Property

ICidrEditViewFirstMatchingAddress Property
Gets or sets a description that shows the first matching address.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FirstMatchingAddress { get; set; }
Property FirstMatchingAddress As String
    Get
    Set
property String^ FirstMatchingAddress {
    String^ get ();
    void set (String^ value);
}
abstract FirstMatchingAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView.LastMatchingAddress Property

ICidrEditViewLastMatchingAddress Property
Gets or sets a description that shows the last matching address.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string LastMatchingAddress { get; set; }
Property LastMatchingAddress As String
    Get
    Set
property String^ LastMatchingAddress {
    String^ get ();
    void set (String^ value);
}
abstract LastMatchingAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView Methods

ICidrEditView Methods

The ICidrEditView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView Events

ICidrEditView Events

The ICidrEditView type exposes the following members.

Events
 | Name | Description
Public event | CidrChanged | Raised when the Cidr has changed.
Top
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


ICidrEditView.CidrChanged Event

ICidrEditViewCidrChanged Event
Raised when the Cidr has changed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CidrChanged
Event CidrChanged As EventHandler
 event EventHandler^ CidrChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CidrChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICidrEditView Interface
VirtualRadar.Interface.View Namespace


IConfirmView Interface

IConfirmView Interface
The interface that views capable of confirming an action with the user must implement.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConfirmView
Public Interface IConfirmView
public interface class IConfirmView
type IConfirmView =  interface end

The IConfirmView type exposes the following members.

Methods
 | Name | Description
Public method | ConfirmWithUser | Asks the user to confirm some action. This must be a modal confirmation, the method should not return until the answer is known.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IConfirmView Methods

IConfirmView Methods

The IConfirmView type exposes the following members.

Methods
 | Name | Description
Public method | ConfirmWithUser | Asks the user to confirm some action. This must be a modal confirmation, the method should not return until the answer is known.
Top
See Also

Reference

IConfirmView Interface
VirtualRadar.Interface.View Namespace


IConfirmView.ConfirmWithUser Method

IConfirmViewConfirmWithUser Method
Asks the user to confirm some action. This must be a modal confirmation, the method should not return until the answer is known.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<bool> ConfirmWithUser(
    string title,
    string message,
    bool defaultYes
)
Function ConfirmWithUser (
    title As String,
    message As String,
    defaultYes As Boolean
) As Nullable(Of Boolean)
Nullable<bool> ConfirmWithUser(
    String^ title,
    String^ message,
    bool defaultYes
)
abstract ConfirmWithUser :
        title : string *
        message : string *
        defaultYes : bool -> Nullable<bool>

Parameters

title
Type: SystemString
message
Type: SystemString
defaultYes
Type: SystemBoolean

Return Value

Type: Nullable Boolean
True if the answer is Yes, false if the answer is No, null if the answer is Cancel Everything.
See Also

Reference

IConfirmView Interface
VirtualRadar.Interface.View Namespace


IConnectionClientLogView Interface

IConnectionClientLogView Interface
The interface for views that can display the details of clients that have connected to the server and the sessions established by the client.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionClientLogView : IView,
    IDisposable
Public Interface IConnectionClientLogView
    Inherits IView, IDisposable
public interface class IConnectionClientLogView : IView,
    IDisposable
type IConnectionClientLogView =
    interface
        interface IView
        interface IDisposable
    end

The IConnectionClientLogView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RefreshClientReverseDnsDetails | Refreshes the display of a client's reverse DNS details. This may not be called on a GUI thread.
Public method | ShowClientsAndSessions | Shows a list of clients and sessions to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IConnectionClientLogView Methods

IConnectionClientLogView Methods

The IConnectionClientLogView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RefreshClientReverseDnsDetails | Refreshes the display of a client's reverse DNS details. This may not be called on a GUI thread.
Public method | ShowClientsAndSessions | Shows a list of clients and sessions to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IConnectionClientLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionClientLogView.RefreshClientReverseDnsDetails Method

IConnectionClientLogViewRefreshClientReverseDnsDetails Method
Refreshes the display of a client's reverse DNS details. This may not be called on a GUI thread.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshClientReverseDnsDetails(
    LogClient client
)
Sub RefreshClientReverseDnsDetails (
    client As LogClient
)
void RefreshClientReverseDnsDetails(
    LogClient^ client
)
abstract RefreshClientReverseDnsDetails :
        client : LogClient -> unit

Parameters

client
Type: VirtualRadar.Interface.DatabaseLogClient
See Also

Reference

IConnectionClientLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionClientLogView.ShowClientsAndSessions Method

IConnectionClientLogViewShowClientsAndSessions Method
Shows a list of clients and sessions to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowClientsAndSessions(
    IList<LogClient> clients,
    IDictionary<long, IList<LogSession>> sessionMap
)
Sub ShowClientsAndSessions (
    clients As IList(Of LogClient),
    sessionMap As IDictionary(Of Long, IList(Of LogSession))
)
void ShowClientsAndSessions(
    IList<LogClient^>^ clients,
    IDictionary<long long, IList<LogSession^>^>^ sessionMap
)
abstract ShowClientsAndSessions :
        clients : IList<LogClient> *
        sessionMap : IDictionary<int64, IList<LogSession>> -> unit

Parameters

clients
Type: System.Collections.GenericIList LogClient
sessionMap
Type: System.Collections.GenericIDictionary Int64, IList LogSession
See Also

Reference

IConnectionClientLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView Interface

IConnectionSessionLogView Interface
The interface for GUIs that display connection sessions to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionSessionLogView : IView,
    IDisposable, IValidateView
Public Interface IConnectionSessionLogView
    Inherits IView, IDisposable, IValidateView
public interface class IConnectionSessionLogView : IView,
    IDisposable, IValidateView
type IConnectionSessionLogView =
    interface
        interface IView
        interface IDisposable
        interface IValidateView
    end

The IConnectionSessionLogView type exposes the following members.

Properties
 | Name | Description
Public property | EndDate | Gets or sets the end date for the list of sessions to show to the user.
Public property | StartDate | Gets or sets the start date for the list of sessions to show to the user.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowSessions | Displays the sessions passed across to the user.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | ShowSessionsClicked | The user has indicated that they've entered enough information to identify the sessions and now they want to see them.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IConnectionSessionLogView Properties

IConnectionSessionLogView Properties

The IConnectionSessionLogView type exposes the following members.

Properties
 | Name | Description
Public property | EndDate | Gets or sets the end date for the list of sessions to show to the user.
Public property | StartDate | Gets or sets the start date for the list of sessions to show to the user.
Top
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView.EndDate Property

IConnectionSessionLogViewEndDate Property
Gets or sets the end date for the list of sessions to show to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime EndDate { get; set; }
Property EndDate As DateTime
    Get
    Set
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}
abstract EndDate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView.StartDate Property

IConnectionSessionLogViewStartDate Property
Gets or sets the start date for the list of sessions to show to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime StartDate { get; set; }
Property StartDate As DateTime
    Get
    Set
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}
abstract StartDate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView Methods

IConnectionSessionLogView Methods

The IConnectionSessionLogView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowSessions | Displays the sessions passed across to the user.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView.ShowSessions Method

IConnectionSessionLogViewShowSessions Method
Displays the sessions passed across to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowSessions(
    IEnumerable<LogClient> clients,
    IEnumerable<LogSession> sessions
)
Sub ShowSessions (
    clients As IEnumerable(Of LogClient),
    sessions As IEnumerable(Of LogSession)
)
void ShowSessions(
    IEnumerable<LogClient^>^ clients,
    IEnumerable<LogSession^>^ sessions
)
abstract ShowSessions :
        clients : IEnumerable<LogClient> *
        sessions : IEnumerable<LogSession> -> unit

Parameters

clients
Type: System.Collections.GenericIEnumerable LogClient
sessions
Type: System.Collections.GenericIEnumerable LogSession
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView Events

IConnectionSessionLogView Events

The IConnectionSessionLogView type exposes the following members.

Events
 | Name | Description
Public event | ShowSessionsClicked | The user has indicated that they've entered enough information to identify the sessions and now they want to see them.
Top
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectionSessionLogView.ShowSessionsClicked Event

IConnectionSessionLogViewShowSessionsClicked Event
The user has indicated that they've entered enough information to identify the sessions and now they want to see them.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ShowSessionsClicked
Event ShowSessionsClicked As EventHandler
 event EventHandler^ ShowSessionsClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ShowSessionsClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IConnectionSessionLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView Interface

IConnectorActivityLogView Interface
The interface for views that can display connector activity logs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnectorActivityLogView : IView,
    IDisposable
Public Interface IConnectorActivityLogView
    Inherits IView, IDisposable
public interface class IConnectorActivityLogView : IView,
    IDisposable
type IConnectorActivityLogView =
    interface
        interface IView
        interface IDisposable
    end

The IConnectorActivityLogView type exposes the following members.

Properties
 | Name | Description
Public property | Connector | Gets or sets the connector to show activities for. If no connector is supplied then activities across all connectors are shown.
Public property | ConnectorActivityEvents | Gets all of the connector activity events on display.
Public property | HideConnectorName | Gets or sets a value indicating that the connector name column should be hidden from view. Only has an effect if set before the control is loaded.
Public property | SelectedConnectorActivityEvents | Gets or sets the selected connector activity events.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Populate | Shows the connector activity events passed across to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | CopySelectedItemsToClipboardClicked | Raised when the copy selected items to clipboard button is clicked.
Public event | RefreshClicked | Raised when the refresh button is clicked.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IConnectorActivityLogView Properties

IConnectorActivityLogView Properties

The IConnectorActivityLogView type exposes the following members.

Properties
 | Name | Description
Public property | Connector | Gets or sets the connector to show activities for. If no connector is supplied then activities across all connectors are shown.
Public property | ConnectorActivityEvents | Gets all of the connector activity events on display.
Public property | HideConnectorName | Gets or sets a value indicating that the connector name column should be hidden from view. Only has an effect if set before the control is loaded.
Public property | SelectedConnectorActivityEvents | Gets or sets the selected connector activity events.
Top
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.Connector Property

IConnectorActivityLogViewConnector Property
Gets or sets the connector to show activities for. If no connector is supplied then activities across all connectors are shown.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IConnector Connector { get; set; }
Property Connector As IConnector
    Get
    Set
property IConnector^ Connector {
    IConnector^ get ();
    void set (IConnector^ value);
}
abstract Connector : IConnector with get, set

Property Value

Type: IConnector
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.ConnectorActivityEvents Property

IConnectorActivityLogViewConnectorActivityEvents Property
Gets all of the connector activity events on display.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectorActivityEvent[] ConnectorActivityEvents { get; }
ReadOnly Property ConnectorActivityEvents As ConnectorActivityEvent()
    Get
property array<ConnectorActivityEvent^>^ ConnectorActivityEvents {
    array<ConnectorActivityEvent^>^ get ();
}
abstract ConnectorActivityEvents : ConnectorActivityEvent[] with get

Property Value

Type: ConnectorActivityEvent
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.HideConnectorName Property

IConnectorActivityLogViewHideConnectorName Property
Gets or sets a value indicating that the connector name column should be hidden from view. Only has an effect if set before the control is loaded.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HideConnectorName { get; set; }
Property HideConnectorName As Boolean
    Get
    Set
property bool HideConnectorName {
    bool get ();
    void set (bool value);
}
abstract HideConnectorName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.SelectedConnectorActivityEvents Property

IConnectorActivityLogViewSelectedConnectorActivityEvents Property
Gets or sets the selected connector activity events.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectorActivityEvent[] SelectedConnectorActivityEvents { get; set; }
Property SelectedConnectorActivityEvents As ConnectorActivityEvent()
    Get
    Set
property array<ConnectorActivityEvent^>^ SelectedConnectorActivityEvents {
    array<ConnectorActivityEvent^>^ get ();
    void set (array<ConnectorActivityEvent^>^ value);
}
abstract SelectedConnectorActivityEvents : ConnectorActivityEvent[] with get, set

Property Value

Type: ConnectorActivityEvent
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView Methods

IConnectorActivityLogView Methods

The IConnectorActivityLogView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Populate | Shows the connector activity events passed across to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.Populate Method

IConnectorActivityLogViewPopulate Method
Shows the connector activity events passed across to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Populate(
    IEnumerable<ConnectorActivityEvent> connectorActivityEvents
)
Sub Populate (
    connectorActivityEvents As IEnumerable(Of ConnectorActivityEvent)
)
void Populate(
    IEnumerable<ConnectorActivityEvent^>^ connectorActivityEvents
)
abstract Populate :
        connectorActivityEvents : IEnumerable<ConnectorActivityEvent> -> unit

Parameters

connectorActivityEvents
Type: System.Collections.GenericIEnumerable ConnectorActivityEvent
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView Events

IConnectorActivityLogView Events

The IConnectorActivityLogView type exposes the following members.

Events
 | Name | Description
Public event | CopySelectedItemsToClipboardClicked | Raised when the copy selected items to clipboard button is clicked.
Public event | RefreshClicked | Raised when the refresh button is clicked.
Top
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.CopySelectedItemsToClipboardClicked Event

IConnectorActivityLogViewCopySelectedItemsToClipboardClicked Event
Raised when the copy selected items to clipboard button is clicked.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CopySelectedItemsToClipboardClicked
Event CopySelectedItemsToClipboardClicked As EventHandler
 event EventHandler^ CopySelectedItemsToClipboardClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CopySelectedItemsToClipboardClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IConnectorActivityLogView.RefreshClicked Event

IConnectorActivityLogViewRefreshClicked Event
Raised when the refresh button is clicked.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler RefreshClicked
Event RefreshClicked As EventHandler
 event EventHandler^ RefreshClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RefreshClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IConnectorActivityLogView Interface
VirtualRadar.Interface.View Namespace


IDownloadDataView Interface

IDownloadDataView Interface
The interface for UI objects that allow the user to manually update the standing data.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDownloadDataView : IView,
    IDisposable, IBusyView
Public Interface IDownloadDataView
    Inherits IView, IDisposable, IBusyView
public interface class IDownloadDataView : IView,
    IDisposable, IBusyView
type IDownloadDataView =
    interface
        interface IView
        interface IDisposable
        interface IBusyView
    end

The IDownloadDataView type exposes the following members.

Properties
 | Name | Description
Public property | Status | Gets or sets a description of the current state of the download operation.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowBusy | Indicates to the user that the application is busy. (Inherited from IBusyView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | DownloadButtonClicked | Raised when the user wants to start downloading fresh data.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IDownloadDataView Properties

IDownloadDataView Properties

The IDownloadDataView type exposes the following members.

Properties
 | Name | Description
Public property | Status | Gets or sets a description of the current state of the download operation.
Top
See Also

Reference

IDownloadDataView Interface
VirtualRadar.Interface.View Namespace


IDownloadDataView.Status Property

IDownloadDataViewStatus Property
Gets or sets a description of the current state of the download operation.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Status { get; set; }
Property Status As String
    Get
    Set
property String^ Status {
    String^ get ();
    void set (String^ value);
}
abstract Status : string with get, set

Property Value

Type: String
See Also

Reference

IDownloadDataView Interface
VirtualRadar.Interface.View Namespace


IDownloadDataView Methods

IDownloadDataView Methods

The IDownloadDataView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowBusy | Indicates to the user that the application is busy. (Inherited from IBusyView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IDownloadDataView Interface
VirtualRadar.Interface.View Namespace


IDownloadDataView Events

IDownloadDataView Events

The IDownloadDataView type exposes the following members.

Events
 | Name | Description
Public event | DownloadButtonClicked | Raised when the user wants to start downloading fresh data.
Top
See Also

Reference

IDownloadDataView Interface
VirtualRadar.Interface.View Namespace


IDownloadDataView.DownloadButtonClicked Event

IDownloadDataViewDownloadButtonClicked Event
Raised when the user wants to start downloading fresh data.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DownloadButtonClicked
Event DownloadButtonClicked As EventHandler
 event EventHandler^ DownloadButtonClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DownloadButtonClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDownloadDataView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView Interface

IFlightSimulatorXView Interface
The interface for views that can display information about the connection to Flight Simulator X.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFlightSimulatorXView : IView,
    IDisposable
Public Interface IFlightSimulatorXView
    Inherits IView, IDisposable
public interface class IFlightSimulatorXView : IView,
    IDisposable
type IFlightSimulatorXView =
    interface
        interface IView
        interface IDisposable
    end

The IFlightSimulatorXView type exposes the following members.

Properties
 | Name | Description
Public property | CanBeRefreshed | Gets a value indicating to the presenter that the view is on show and should be refreshed.
Public property | ConnectionStatus | Gets or sets a description of the state of the connection to FSX.
Public property | ConnectToFlightSimulatorXEnabled | Gets or sets a value indicating that the user should be allowed to elect to connect to Flight Simulator X.
Public property | FlightSimulatorPageAddress | Gets or sets the address of the flight simulator web page that the server can display.
Public property | RideAircraftEnabled | Gets or sets a value indicating that the user should be allowed to elect to ride an aircraft.
Public property | RideStatus | Gets or sets a description of the state of the FSX 'ride' feature.
Public property | RidingAircraft | Gets or sets a value indicating that the user is mirroring a real aircraft's position etc. in FSX.
Public property | SelectedRealAircraft | Gets the real aircraft selected by the user for riding.
Public property | UseSlewMode | Gets or sets a value indicating then the ride feature should use slew mode to move the simulated aircraft instead of freeze mode.
Public property | WindowHandle | Gets the window handle that will be passed to IFlightSimulatorX.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records objects that will be passed on to IFlightSimulatorXPresenter when it is created.
Public method | InitialiseRealAircraftListDisplay | Displays the list of real aircraft for the first time. Any existing display of real aircraft will be cleared by this.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | UpdateRealAircraftListDisplay | Updates the display of real aircraft. This could be called from a non-GUI thread.
Top
Events
 | Name | Description
Public event | CloseClicked | Raised when the view is shutting down.
Public event | ConnectClicked | Raised when the user has indicated that they want to connect to Flight Simulator X.
Public event | RefreshFlightSimulatorXInformation | Raised by a timer running on the GUI thread. Indicates that the presenter should ask FSX for an update of the simulated aircraft's position or send updates of real-world aircraft positions to FSX.
Public event | RideAircraftClicked | Raised when the user has indicated that they want to duplicate the position, airspeed, attitude etc. of a real aircraft in Flight Simulator X.
Public event | StopRidingAircraftClicked | Raised when the user has indicated that they don't want to ride the aircraft any more.
Top
Remarks
Note that SimConnect requires that this have a window handle to which messages can be sent which may limit the circumstances under which this can be fully implemented.
See Also

Reference

VirtualRadar.Interface.View Namespace


IFlightSimulatorXView Properties

IFlightSimulatorXView Properties

The IFlightSimulatorXView type exposes the following members.

Properties
 | Name | Description
Public property | CanBeRefreshed | Gets a value indicating to the presenter that the view is on show and should be refreshed.
Public property | ConnectionStatus | Gets or sets a description of the state of the connection to FSX.
Public property | ConnectToFlightSimulatorXEnabled | Gets or sets a value indicating that the user should be allowed to elect to connect to Flight Simulator X.
Public property | FlightSimulatorPageAddress | Gets or sets the address of the flight simulator web page that the server can display.
Public property | RideAircraftEnabled | Gets or sets a value indicating that the user should be allowed to elect to ride an aircraft.
Public property | RideStatus | Gets or sets a description of the state of the FSX 'ride' feature.
Public property | RidingAircraft | Gets or sets a value indicating that the user is mirroring a real aircraft's position etc. in FSX.
Public property | SelectedRealAircraft | Gets the real aircraft selected by the user for riding.
Public property | UseSlewMode | Gets or sets a value indicating then the ride feature should use slew mode to move the simulated aircraft instead of freeze mode.
Public property | WindowHandle | Gets the window handle that will be passed to IFlightSimulatorX.
Top
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.CanBeRefreshed Property

IFlightSimulatorXViewCanBeRefreshed Property
Gets a value indicating to the presenter that the view is on show and should be refreshed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanBeRefreshed { get; }
ReadOnly Property CanBeRefreshed As Boolean
    Get
property bool CanBeRefreshed {
    bool get ();
}
abstract CanBeRefreshed : bool with get

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.ConnectionStatus Property

IFlightSimulatorXViewConnectionStatus Property
Gets or sets a description of the state of the connection to FSX.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConnectionStatus { get; set; }
Property ConnectionStatus As String
    Get
    Set
property String^ ConnectionStatus {
    String^ get ();
    void set (String^ value);
}
abstract ConnectionStatus : string with get, set

Property Value

Type: String
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.ConnectToFlightSimulatorXEnabled Property

IFlightSimulatorXViewConnectToFlightSimulatorXEnabled Property
Gets or sets a value indicating that the user should be allowed to elect to connect to Flight Simulator X.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ConnectToFlightSimulatorXEnabled { get; set; }
Property ConnectToFlightSimulatorXEnabled As Boolean
    Get
    Set
property bool ConnectToFlightSimulatorXEnabled {
    bool get ();
    void set (bool value);
}
abstract ConnectToFlightSimulatorXEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.FlightSimulatorPageAddress Property

IFlightSimulatorXViewFlightSimulatorPageAddress Property
Gets or sets the address of the flight simulator web page that the server can display.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string FlightSimulatorPageAddress { get; set; }
Property FlightSimulatorPageAddress As String
    Get
    Set
property String^ FlightSimulatorPageAddress {
    String^ get ();
    void set (String^ value);
}
abstract FlightSimulatorPageAddress : string with get, set

Property Value

Type: String
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.RideAircraftEnabled Property

IFlightSimulatorXViewRideAircraftEnabled Property
Gets or sets a value indicating that the user should be allowed to elect to ride an aircraft.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RideAircraftEnabled { get; set; }
Property RideAircraftEnabled As Boolean
    Get
    Set
property bool RideAircraftEnabled {
    bool get ();
    void set (bool value);
}
abstract RideAircraftEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.RideStatus Property

IFlightSimulatorXViewRideStatus Property
Gets or sets a description of the state of the FSX 'ride' feature.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string RideStatus { get; set; }
Property RideStatus As String
    Get
    Set
property String^ RideStatus {
    String^ get ();
    void set (String^ value);
}
abstract RideStatus : string with get, set

Property Value

Type: String
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.RidingAircraft Property

IFlightSimulatorXViewRidingAircraft Property
Gets or sets a value indicating that the user is mirroring a real aircraft's position etc. in FSX.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RidingAircraft { get; set; }
Property RidingAircraft As Boolean
    Get
    Set
property bool RidingAircraft {
    bool get ();
    void set (bool value);
}
abstract RidingAircraft : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.SelectedRealAircraft Property

IFlightSimulatorXViewSelectedRealAircraft Property
Gets the real aircraft selected by the user for riding.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IAircraft SelectedRealAircraft { get; }
ReadOnly Property SelectedRealAircraft As IAircraft
    Get
property IAircraft^ SelectedRealAircraft {
    IAircraft^ get ();
}
abstract SelectedRealAircraft : IAircraft with get

Property Value

Type: IAircraft
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.UseSlewMode Property

IFlightSimulatorXViewUseSlewMode Property
Gets or sets a value indicating then the ride feature should use slew mode to move the simulated aircraft instead of freeze mode.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseSlewMode { get; set; }
Property UseSlewMode As Boolean
    Get
    Set
property bool UseSlewMode {
    bool get ();
    void set (bool value);
}
abstract UseSlewMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.WindowHandle Property

IFlightSimulatorXViewWindowHandle Property
Gets the window handle that will be passed to IFlightSimulatorX.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IntPtr WindowHandle { get; }
ReadOnly Property WindowHandle As IntPtr
    Get
property IntPtr WindowHandle {
    IntPtr get ();
}
abstract WindowHandle : IntPtr with get

Property Value

Type: IntPtr
Remarks
The SimConnect object that FlightSimulatorX uses needs a window handle to pass messages to, so non-Win32 implementations of this might be in some trouble!
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView Methods

IFlightSimulatorXView Methods

The IFlightSimulatorXView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records objects that will be passed on to IFlightSimulatorXPresenter when it is created.
Public method | InitialiseRealAircraftListDisplay | Displays the list of real aircraft for the first time. Any existing display of real aircraft will be cleared by this.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | UpdateRealAircraftListDisplay | Updates the display of real aircraft. This could be called from a non-GUI thread.
Top
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.Initialise Method

IFlightSimulatorXViewInitialise Method
Records objects that will be passed on to IFlightSimulatorXPresenter when it is created.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    IBaseStationAircraftList baseStationAircraftList,
    ISimpleAircraftList flightSimulatorAircraftList,
    IWebServer webServer
)
Sub Initialise (
    baseStationAircraftList As IBaseStationAircraftList,
    flightSimulatorAircraftList As ISimpleAircraftList,
    webServer As IWebServer
)
void Initialise(
    IBaseStationAircraftList^ baseStationAircraftList,
    ISimpleAircraftList^ flightSimulatorAircraftList,
    IWebServer^ webServer
)
abstract Initialise :
        baseStationAircraftList : IBaseStationAircraftList *
        flightSimulatorAircraftList : ISimpleAircraftList *
        webServer : IWebServer -> unit

Parameters

baseStationAircraftList
Type: VirtualRadar.Interface.BaseStationIBaseStationAircraftList
flightSimulatorAircraftList
Type: VirtualRadar.InterfaceISimpleAircraftList
webServer
Type: VirtualRadar.Interface.WebServerIWebServer
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.InitialiseRealAircraftListDisplay Method

IFlightSimulatorXViewInitialiseRealAircraftListDisplay Method
Displays the list of real aircraft for the first time. Any existing display of real aircraft will be cleared by this.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InitialiseRealAircraftListDisplay(
    IList<IAircraft> aircraftList
)
Sub InitialiseRealAircraftListDisplay (
    aircraftList As IList(Of IAircraft)
)
void InitialiseRealAircraftListDisplay(
    IList<IAircraft^>^ aircraftList
)
abstract InitialiseRealAircraftListDisplay :
        aircraftList : IList<IAircraft> -> unit

Parameters

aircraftList
Type: System.Collections.GenericIList IAircraft
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.UpdateRealAircraftListDisplay Method

IFlightSimulatorXViewUpdateRealAircraftListDisplay Method
Updates the display of real aircraft. This could be called from a non-GUI thread.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateRealAircraftListDisplay(
    IList<IAircraft> aircraftList
)
Sub UpdateRealAircraftListDisplay (
    aircraftList As IList(Of IAircraft)
)
void UpdateRealAircraftListDisplay(
    IList<IAircraft^>^ aircraftList
)
abstract UpdateRealAircraftListDisplay :
        aircraftList : IList<IAircraft> -> unit

Parameters

aircraftList
Type: System.Collections.GenericIList IAircraft
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView Events

IFlightSimulatorXView Events

The IFlightSimulatorXView type exposes the following members.

Events
 | Name | Description
Public event | CloseClicked | Raised when the view is shutting down.
Public event | ConnectClicked | Raised when the user has indicated that they want to connect to Flight Simulator X.
Public event | RefreshFlightSimulatorXInformation | Raised by a timer running on the GUI thread. Indicates that the presenter should ask FSX for an update of the simulated aircraft's position or send updates of real-world aircraft positions to FSX.
Public event | RideAircraftClicked | Raised when the user has indicated that they want to duplicate the position, airspeed, attitude etc. of a real aircraft in Flight Simulator X.
Public event | StopRidingAircraftClicked | Raised when the user has indicated that they don't want to ride the aircraft any more.
Top
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.CloseClicked Event

IFlightSimulatorXViewCloseClicked Event
Raised when the view is shutting down.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CloseClicked
Event CloseClicked As EventHandler
 event EventHandler^ CloseClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CloseClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.ConnectClicked Event

IFlightSimulatorXViewConnectClicked Event
Raised when the user has indicated that they want to connect to Flight Simulator X.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ConnectClicked
Event ConnectClicked As EventHandler
 event EventHandler^ ConnectClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ConnectClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.RefreshFlightSimulatorXInformation Event

IFlightSimulatorXViewRefreshFlightSimulatorXInformation Event
Raised by a timer running on the GUI thread. Indicates that the presenter should ask FSX for an update of the simulated aircraft's position or send updates of real-world aircraft positions to FSX.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler RefreshFlightSimulatorXInformation
Event RefreshFlightSimulatorXInformation As EventHandler
 event EventHandler^ RefreshFlightSimulatorXInformation {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RefreshFlightSimulatorXInformation : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
This should be done on the GUI thread because SimConnect doesn't respond well when sent messages on a non-GUI thread.
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.RideAircraftClicked Event

IFlightSimulatorXViewRideAircraftClicked Event
Raised when the user has indicated that they want to duplicate the position, airspeed, attitude etc. of a real aircraft in Flight Simulator X.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler RideAircraftClicked
Event RideAircraftClicked As EventHandler
 event EventHandler^ RideAircraftClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RideAircraftClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IFlightSimulatorXView.StopRidingAircraftClicked Event

IFlightSimulatorXViewStopRidingAircraftClicked Event
Raised when the user has indicated that they don't want to ride the aircraft any more.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler StopRidingAircraftClicked
Event StopRidingAircraftClicked As EventHandler
 event EventHandler^ StopRidingAircraftClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StopRidingAircraftClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFlightSimulatorXView Interface
VirtualRadar.Interface.View Namespace


IInvalidPluginsView Interface

IInvalidPluginsView Interface
The interface for GUI objects that can display a list of invalid plugins.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IInvalidPluginsView : IView,
    IDisposable
Public Interface IInvalidPluginsView
    Inherits IView, IDisposable
public interface class IInvalidPluginsView : IView,
    IDisposable
type IInvalidPluginsView =
    interface
        interface IView
        interface IDisposable
    end

The IInvalidPluginsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowInvalidPlugins | Displays the list of invalid plugins. The key to the dictionary is the full path to the plugin and the value is the reason why the plugin was not loaded.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IInvalidPluginsView Methods

IInvalidPluginsView Methods

The IInvalidPluginsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowInvalidPlugins | Displays the list of invalid plugins. The key to the dictionary is the full path to the plugin and the value is the reason why the plugin was not loaded.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IInvalidPluginsView Interface
VirtualRadar.Interface.View Namespace


IInvalidPluginsView.ShowInvalidPlugins Method

IInvalidPluginsViewShowInvalidPlugins Method
Displays the list of invalid plugins. The key to the dictionary is the full path to the plugin and the value is the reason why the plugin was not loaded.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowInvalidPlugins(
    IDictionary<string, string> invalidPlugins
)
Sub ShowInvalidPlugins (
    invalidPlugins As IDictionary(Of String, String)
)
void ShowInvalidPlugins(
    IDictionary<String^, String^>^ invalidPlugins
)
abstract ShowInvalidPlugins :
        invalidPlugins : IDictionary<string, string> -> unit

Parameters

invalidPlugins
Type: System.Collections.GenericIDictionary String, String
See Also

Reference

IInvalidPluginsView Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T) Interface

IListDetailEditorViewT Interface
The interface that views capable of presenting and maintaining a list of records should implement.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IListDetailEditorView<T> : IValidateView,
    IConfirmView

Public Interface IListDetailEditorView(Of T)
    Inherits IValidateView, IConfirmView
generic<typename T>
public interface class IListDetailEditorView : IValidateView,
    IConfirmView
type IListDetailEditorView<'T> =
    interface
        interface IValidateView
        interface IConfirmView
    end

Type Parameters

T

The IListDetailEditorViewT type exposes the following members.

Properties
 | Name | Description
Public property | Records | Gets the list of records to show to the user.
Public property | SelectedRecord | Gets the currently selected record, if any.
Top
Methods
 | Name | Description
Public method | ConfirmWithUser | Asks the user to confirm some action. This must be a modal confirmation, the method should not return until the answer is known. (Inherited from IConfirmView.)
Public method | FocusOnEditFields | Sets the user's input focus to the first field that represents the content of the selected record.
Public method | RefreshRecords | Refreshes the list of records shown to the user.
Public method | RefreshSelectedRecord | Refreshes the fields that hold the content of the selected record.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Top
Events
 | Name | Description
Public event | DeleteRecordClicked | Raised when the user indicates that they want to delete an existing record.
Public event | NewRecordClicked | Raised when the user indicates that they want to create a new record.
Public event | ResetClicked | Raised when the user has indicated that they want to rollback their changes to the selected record.
Public event | SaveClicked | Raised when the user indicates that they want to save their changes.
Public event | SelectedRecordChanged | Raised when the user has selected a record in the list.
Public event | ValueChanged | Raised when the user modifies a value on the selected record.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IListDetailEditorView(T) Properties

IListDetailEditorViewT Properties

The IListDetailEditorViewT generic type exposes the following members.

Properties
 | Name | Description
Public property | Records | Gets the list of records to show to the user.
Public property | SelectedRecord | Gets the currently selected record, if any.
Top
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).Records Property

IListDetailEditorViewTRecords Property
Gets the list of records to show to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<T> Records { get; }
ReadOnly Property Records As List(Of T)
    Get
property List<T>^ Records {
    List<T>^ get ();
}
abstract Records : List<'T> with get

Property Value

Type: List T
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).SelectedRecord Property

IListDetailEditorViewTSelectedRecord Property
Gets the currently selected record, if any.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
T SelectedRecord { get; set; }
Property SelectedRecord As T
    Get
    Set
property T SelectedRecord {
    T get ();
    void set (T value);
}
abstract SelectedRecord : 'T with get, set

Property Value

Type: T
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T) Methods

IListDetailEditorViewT Methods

The IListDetailEditorViewT generic type exposes the following members.

Methods
 | Name | Description
Public method | ConfirmWithUser | Asks the user to confirm some action. This must be a modal confirmation, the method should not return until the answer is known. (Inherited from IConfirmView.)
Public method | FocusOnEditFields | Sets the user's input focus to the first field that represents the content of the selected record.
Public method | RefreshRecords | Refreshes the list of records shown to the user.
Public method | RefreshSelectedRecord | Refreshes the fields that hold the content of the selected record.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Top
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).FocusOnEditFields Method

IListDetailEditorViewTFocusOnEditFields Method
Sets the user's input focus to the first field that represents the content of the selected record.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FocusOnEditFields()
Sub FocusOnEditFields
void FocusOnEditFields()
abstract FocusOnEditFields : unit -> unit
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).RefreshRecords Method

IListDetailEditorViewTRefreshRecords Method
Refreshes the list of records shown to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshRecords()
Sub RefreshRecords
void RefreshRecords()
abstract RefreshRecords : unit -> unit
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).RefreshSelectedRecord Method

IListDetailEditorViewTRefreshSelectedRecord Method
Refreshes the fields that hold the content of the selected record.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshSelectedRecord()
Sub RefreshSelectedRecord
void RefreshSelectedRecord()
abstract RefreshSelectedRecord : unit -> unit
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T) Events

IListDetailEditorViewT Events

The IListDetailEditorViewT generic type exposes the following members.

Events
 | Name | Description
Public event | DeleteRecordClicked | Raised when the user indicates that they want to delete an existing record.
Public event | NewRecordClicked | Raised when the user indicates that they want to create a new record.
Public event | ResetClicked | Raised when the user has indicated that they want to rollback their changes to the selected record.
Public event | SaveClicked | Raised when the user indicates that they want to save their changes.
Public event | SelectedRecordChanged | Raised when the user has selected a record in the list.
Public event | ValueChanged | Raised when the user modifies a value on the selected record.
Top
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).DeleteRecordClicked Event

IListDetailEditorViewTDeleteRecordClicked Event
Raised when the user indicates that they want to delete an existing record.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DeleteRecordClicked
Event DeleteRecordClicked As EventHandler
 event EventHandler^ DeleteRecordClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRecordClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).NewRecordClicked Event

IListDetailEditorViewTNewRecordClicked Event
Raised when the user indicates that they want to create a new record.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler NewRecordClicked
Event NewRecordClicked As EventHandler
 event EventHandler^ NewRecordClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract NewRecordClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).ResetClicked Event

IListDetailEditorViewTResetClicked Event
Raised when the user has indicated that they want to rollback their changes to the selected record.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ResetClicked
Event ResetClicked As EventHandler
 event EventHandler^ ResetClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResetClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).SaveClicked Event

IListDetailEditorViewTSaveClicked Event
Raised when the user indicates that they want to save their changes.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CancelEventArgs> SaveClicked
Event SaveClicked As EventHandler(Of CancelEventArgs)
 event EventHandler<CancelEventArgs^>^ SaveClicked {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}
abstract SaveClicked : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

Value

Type: SystemEventHandler CancelEventArgs
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).SelectedRecordChanged Event

IListDetailEditorViewTSelectedRecordChanged Event
Raised when the user has selected a record in the list.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectedRecordChanged
Event SelectedRecordChanged As EventHandler
 event EventHandler^ SelectedRecordChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectedRecordChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IListDetailEditorView(T).ValueChanged Event

IListDetailEditorViewTValueChanged Event
Raised when the user modifies a value on the selected record.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IListDetailEditorViewT Interface
VirtualRadar.Interface.View Namespace


IMainView Interface

IMainView Interface
The interface for the view that the user sees when they first start the application.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMainView : IView,
    IDisposable, IBusyView
Public Interface IMainView
    Inherits IView, IDisposable, IBusyView
public interface class IMainView : IView,
    IDisposable, IBusyView
type IMainView =
    interface
        interface IView
        interface IDisposable
        interface IBusyView
    end

The IMainView type exposes the following members.

Properties
 | Name | Description
Public property | InvalidPluginCount | Gets or sets a count of the number of plugins that could not be loaded at startup.
Public property | LogFileName | Gets or sets the full path to the log file that will be displayed if the user indicates they want to see its content.
Public property | NewVersionAvailable | Gets or sets a value indicating that the user should be informed that a new version of the application is available.
Public property | NewVersionDownloadUrl | Gets or sets the URL to send users to when a new version is detected.
Public property | RebroadcastServersConfiguration | Gets or sets localised text that describes the configuration of the rebroadcast servers.
Public property | UPnpEnabled | Gets or sets a value indicating that control of a UPnP router has been enabled in the configuration.
Public property | UPnpPortForwardingActive | Gets or sets a value indicating that there is a port forwarding mapping on the router to our webserver.
Public property | UPnpRouterPresent | Gets or sets a value indicating that a UPnP router is present on the network.
Public property | WebServerExternalAddress | Gets or sets the address of the web server on the Internet.
Public property | WebServerIsOnline | Gets or sets a value indicating that the server is online and listening to requests.
Public property | WebServerLocalAddress | Gets or sets the address of the web server on the local loopback.
Public property | WebServerNetworkAddress | Gets or sets the address of the web server on the LAN.
Top
Methods
 | Name | Description
Public method | BubbleExceptionToGui | Throws the exception passed across as an inner exception to an ApplicationException on the GUI thread.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records references to objects that will be set on IMainPresenter when it is created.
Public method | ShowBusy | Indicates to the user that the application is busy. (Inherited from IBusyView.)
Public method | ShowFeedConnectionStatus | Updates the display for a feed with a fresh connection status.
Public method | ShowFeeds | Updates the list of feeds shown to the user. Old feeds are removed, new ones added.
Public method | ShowManualVersionCheckResult | Show the result of a manual check for a new version of the application to the user.
Public method | ShowRebroadcastServerStatus | Updates the display with the current set of connections to the rebroadcast servers.
Public method | ShowServerRequests | Show a list of current requests to the user.
Public method | ShowSettingsConfigurationUI | Opens the configuration GUI, optionally jumping to a specific page / tab etc. or to the GUI for a given configuration object.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | UpdateFeedCounters | Updates the list of feeds with fresh counts.
Top
Events
 | Name | Description
Public event | CheckForNewVersion | Raised when the user wants to manually check for a new version of the application.
Public event | ReconnectFeed | Raised when the user wants to manually cycle the connection to the feed.
Public event | ResetPolarPlot | Raised when the user wants to reset the polar plot for a feed.
Public event | ToggleServerStatus | Raised when the user has indicated that they want to toggle the server's online status.
Public event | ToggleUPnpStatus | Raised when the user has indicated that they want to put the server onto or take the server off the Internet.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IMainView Properties

IMainView Properties

The IMainView type exposes the following members.

Properties
 | Name | Description
Public property | InvalidPluginCount | Gets or sets a count of the number of plugins that could not be loaded at startup.
Public property | LogFileName | Gets or sets the full path to the log file that will be displayed if the user indicates they want to see its content.
Public property | NewVersionAvailable | Gets or sets a value indicating that the user should be informed that a new version of the application is available.
Public property | NewVersionDownloadUrl | Gets or sets the URL to send users to when a new version is detected.
Public property | RebroadcastServersConfiguration | Gets or sets localised text that describes the configuration of the rebroadcast servers.
Public property | UPnpEnabled | Gets or sets a value indicating that control of a UPnP router has been enabled in the configuration.
Public property | UPnpPortForwardingActive | Gets or sets a value indicating that there is a port forwarding mapping on the router to our webserver.
Public property | UPnpRouterPresent | Gets or sets a value indicating that a UPnP router is present on the network.
Public property | WebServerExternalAddress | Gets or sets the address of the web server on the Internet.
Public property | WebServerIsOnline | Gets or sets a value indicating that the server is online and listening to requests.
Public property | WebServerLocalAddress | Gets or sets the address of the web server on the local loopback.
Public property | WebServerNetworkAddress | Gets or sets the address of the web server on the LAN.
Top
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.InvalidPluginCount Property

IMainViewInvalidPluginCount Property
Gets or sets a count of the number of plugins that could not be loaded at startup.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int InvalidPluginCount { get; set; }
Property InvalidPluginCount As Integer
    Get
    Set
property int InvalidPluginCount {
    int get ();
    void set (int value);
}
abstract InvalidPluginCount : int with get, set

Property Value

Type: Int32
Remarks
If this number is zero then any UI associated with reporting the count of invalid plugins should be hidden from view.
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.LogFileName Property

IMainViewLogFileName Property
Gets or sets the full path to the log file that will be displayed if the user indicates they want to see its content.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string LogFileName { get; set; }
Property LogFileName As String
    Get
    Set
property String^ LogFileName {
    String^ get ();
    void set (String^ value);
}
abstract LogFileName : string with get, set

Property Value

Type: String
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.NewVersionAvailable Property

IMainViewNewVersionAvailable Property
Gets or sets a value indicating that the user should be informed that a new version of the application is available.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NewVersionAvailable { get; set; }
Property NewVersionAvailable As Boolean
    Get
    Set
property bool NewVersionAvailable {
    bool get ();
    void set (bool value);
}
abstract NewVersionAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.NewVersionDownloadUrl Property

IMainViewNewVersionDownloadUrl Property
Gets or sets the URL to send users to when a new version is detected.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string NewVersionDownloadUrl { get; set; }
Property NewVersionDownloadUrl As String
    Get
    Set
property String^ NewVersionDownloadUrl {
    String^ get ();
    void set (String^ value);
}
abstract NewVersionDownloadUrl : string with get, set

Property Value

Type: String
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.RebroadcastServersConfiguration Property

IMainViewRebroadcastServersConfiguration Property
Gets or sets localised text that describes the configuration of the rebroadcast servers.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string RebroadcastServersConfiguration { get; set; }
Property RebroadcastServersConfiguration As String
    Get
    Set
property String^ RebroadcastServersConfiguration {
    String^ get ();
    void set (String^ value);
}
abstract RebroadcastServersConfiguration : string with get, set

Property Value

Type: String
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.UPnpEnabled Property

IMainViewUPnpEnabled Property
Gets or sets a value indicating that control of a UPnP router has been enabled in the configuration.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UPnpEnabled { get; set; }
Property UPnpEnabled As Boolean
    Get
    Set
property bool UPnpEnabled {
    bool get ();
    void set (bool value);
}
abstract UPnpEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.UPnpPortForwardingActive Property

IMainViewUPnpPortForwardingActive Property
Gets or sets a value indicating that there is a port forwarding mapping on the router to our webserver.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UPnpPortForwardingActive { get; set; }
Property UPnpPortForwardingActive As Boolean
    Get
    Set
property bool UPnpPortForwardingActive {
    bool get ();
    void set (bool value);
}
abstract UPnpPortForwardingActive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.UPnpRouterPresent Property

IMainViewUPnpRouterPresent Property
Gets or sets a value indicating that a UPnP router is present on the network.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UPnpRouterPresent { get; set; }
Property UPnpRouterPresent As Boolean
    Get
    Set
property bool UPnpRouterPresent {
    bool get ();
    void set (bool value);
}
abstract UPnpRouterPresent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.WebServerExternalAddress Property

IMainViewWebServerExternalAddress Property
Gets or sets the address of the web server on the Internet.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string WebServerExternalAddress { get; set; }
Property WebServerExternalAddress As String
    Get
    Set
property String^ WebServerExternalAddress {
    String^ get ();
    void set (String^ value);
}
abstract WebServerExternalAddress : string with get, set

Property Value

Type: String
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.WebServerIsOnline Property

IMainViewWebServerIsOnline Property
Gets or sets a value indicating that the server is online and listening to requests.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WebServerIsOnline { get; set; }
Property WebServerIsOnline As Boolean
    Get
    Set
property bool WebServerIsOnline {
    bool get ();
    void set (bool value);
}
abstract WebServerIsOnline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.WebServerLocalAddress Property

IMainViewWebServerLocalAddress Property
Gets or sets the address of the web server on the local loopback.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string WebServerLocalAddress { get; set; }
Property WebServerLocalAddress As String
    Get
    Set
property String^ WebServerLocalAddress {
    String^ get ();
    void set (String^ value);
}
abstract WebServerLocalAddress : string with get, set

Property Value

Type: String
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.WebServerNetworkAddress Property

IMainViewWebServerNetworkAddress Property
Gets or sets the address of the web server on the LAN.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string WebServerNetworkAddress { get; set; }
Property WebServerNetworkAddress As String
    Get
    Set
property String^ WebServerNetworkAddress {
    String^ get ();
    void set (String^ value);
}
abstract WebServerNetworkAddress : string with get, set

Property Value

Type: String
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView Methods

IMainView Methods

The IMainView type exposes the following members.

Methods
 | Name | Description
Public method | BubbleExceptionToGui | Throws the exception passed across as an inner exception to an ApplicationException on the GUI thread.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records references to objects that will be set on IMainPresenter when it is created.
Public method | ShowBusy | Indicates to the user that the application is busy. (Inherited from IBusyView.)
Public method | ShowFeedConnectionStatus | Updates the display for a feed with a fresh connection status.
Public method | ShowFeeds | Updates the list of feeds shown to the user. Old feeds are removed, new ones added.
Public method | ShowManualVersionCheckResult | Show the result of a manual check for a new version of the application to the user.
Public method | ShowRebroadcastServerStatus | Updates the display with the current set of connections to the rebroadcast servers.
Public method | ShowServerRequests | Show a list of current requests to the user.
Public method | ShowSettingsConfigurationUI | Opens the configuration GUI, optionally jumping to a specific page / tab etc. or to the GUI for a given configuration object.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | UpdateFeedCounters | Updates the list of feeds with fresh counts.
Top
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.BubbleExceptionToGui Method

IMainViewBubbleExceptionToGui Method
Throws the exception passed across as an inner exception to an ApplicationException on the GUI thread.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void BubbleExceptionToGui(
    Exception ex
)
Sub BubbleExceptionToGui (
    ex As Exception
)
void BubbleExceptionToGui(
    Exception^ ex
)
abstract BubbleExceptionToGui :
        ex : Exception -> unit

Parameters

ex
Type: SystemException
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.Initialise Method

IMainViewInitialise Method
Records references to objects that will be set on IMainPresenter when it is created.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    IUniversalPlugAndPlayManager uPnpManager,
    ISimpleAircraftList flightSimulatorXAircraftList
)
Sub Initialise (
    uPnpManager As IUniversalPlugAndPlayManager,
    flightSimulatorXAircraftList As ISimpleAircraftList
)
void Initialise(
    IUniversalPlugAndPlayManager^ uPnpManager,
    ISimpleAircraftList^ flightSimulatorXAircraftList
)
abstract Initialise :
        uPnpManager : IUniversalPlugAndPlayManager *
        flightSimulatorXAircraftList : ISimpleAircraftList -> unit

Parameters

uPnpManager
Type: VirtualRadar.Interface.WebServerIUniversalPlugAndPlayManager
flightSimulatorXAircraftList
Type: VirtualRadar.InterfaceISimpleAircraftList
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ShowFeedConnectionStatus Method

IMainViewShowFeedConnectionStatus Method
Updates the display for a feed with a fresh connection status.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowFeedConnectionStatus(
    FeedStatus feed
)
Sub ShowFeedConnectionStatus (
    feed As FeedStatus
)
void ShowFeedConnectionStatus(
    FeedStatus^ feed
)
abstract ShowFeedConnectionStatus :
        feed : FeedStatus -> unit

Parameters

feed
Type: VirtualRadar.Interface.ViewFeedStatus
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ShowFeeds Method

IMainViewShowFeeds Method
Updates the list of feeds shown to the user. Old feeds are removed, new ones added.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowFeeds(
    FeedStatus[] feeds
)
Sub ShowFeeds (
    feeds As FeedStatus()
)
void ShowFeeds(
    array<FeedStatus^>^ feeds
)
abstract ShowFeeds :
        feeds : FeedStatus[] -> unit

Parameters

feeds
Type: VirtualRadar.Interface.ViewFeedStatus
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ShowManualVersionCheckResult Method

IMainViewShowManualVersionCheckResult Method
Show the result of a manual check for a new version of the application to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowManualVersionCheckResult(
    bool newVersionAvailable
)
Sub ShowManualVersionCheckResult (
    newVersionAvailable As Boolean
)
void ShowManualVersionCheckResult(
    bool newVersionAvailable
)
abstract ShowManualVersionCheckResult :
        newVersionAvailable : bool -> unit

Parameters

newVersionAvailable
Type: SystemBoolean
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ShowRebroadcastServerStatus Method

IMainViewShowRebroadcastServerStatus Method
Updates the display with the current set of connections to the rebroadcast servers.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowRebroadcastServerStatus(
    IList<RebroadcastServerConnection> connections
)
Sub ShowRebroadcastServerStatus (
    connections As IList(Of RebroadcastServerConnection)
)
void ShowRebroadcastServerStatus(
    IList<RebroadcastServerConnection^>^ connections
)
abstract ShowRebroadcastServerStatus :
        connections : IList<RebroadcastServerConnection> -> unit

Parameters

connections
Type: System.Collections.GenericIList RebroadcastServerConnection
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ShowServerRequests Method

IMainViewShowServerRequests Method
Show a list of current requests to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowServerRequests(
    ServerRequest[] serverRequests
)
Sub ShowServerRequests (
    serverRequests As ServerRequest()
)
void ShowServerRequests(
    array<ServerRequest^>^ serverRequests
)
abstract ShowServerRequests :
        serverRequests : ServerRequest[] -> unit

Parameters

serverRequests
Type: VirtualRadar.Interface.ViewServerRequest
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ShowSettingsConfigurationUI Method

IMainViewShowSettingsConfigurationUI Method
Opens the configuration GUI, optionally jumping to a specific page / tab etc. or to the GUI for a given configuration object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowSettingsConfigurationUI(
    string openOnPageTitle,
    Object openOnConfigurationObject
)
Sub ShowSettingsConfigurationUI (
    openOnPageTitle As String,
    openOnConfigurationObject As Object
)
void ShowSettingsConfigurationUI(
    String^ openOnPageTitle,
    Object^ openOnConfigurationObject
)
abstract ShowSettingsConfigurationUI :
        openOnPageTitle : string *
        openOnConfigurationObject : Object -> unit

Parameters

openOnPageTitle
Type: SystemString
openOnConfigurationObject
Type: SystemObject
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.UpdateFeedCounters Method

IMainViewUpdateFeedCounters Method
Updates the list of feeds with fresh counts.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateFeedCounters(
    FeedStatus[] feeds
)
Sub UpdateFeedCounters (
    feeds As FeedStatus()
)
void UpdateFeedCounters(
    array<FeedStatus^>^ feeds
)
abstract UpdateFeedCounters :
        feeds : FeedStatus[] -> unit

Parameters

feeds
Type: VirtualRadar.Interface.ViewFeedStatus
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView Events

IMainView Events

The IMainView type exposes the following members.

Events
 | Name | Description
Public event | CheckForNewVersion | Raised when the user wants to manually check for a new version of the application.
Public event | ReconnectFeed | Raised when the user wants to manually cycle the connection to the feed.
Public event | ResetPolarPlot | Raised when the user wants to reset the polar plot for a feed.
Public event | ToggleServerStatus | Raised when the user has indicated that they want to toggle the server's online status.
Public event | ToggleUPnpStatus | Raised when the user has indicated that they want to put the server onto or take the server off the Internet.
Top
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.CheckForNewVersion Event

IMainViewCheckForNewVersion Event
Raised when the user wants to manually check for a new version of the application.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CheckForNewVersion
Event CheckForNewVersion As EventHandler
 event EventHandler^ CheckForNewVersion {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CheckForNewVersion : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ReconnectFeed Event

IMainViewReconnectFeed Event
Raised when the user wants to manually cycle the connection to the feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<IFeed>> ReconnectFeed
Event ReconnectFeed As EventHandler(Of EventArgs(Of IFeed))
 event EventHandler<EventArgs<IFeed^>^>^ ReconnectFeed {
    void add (EventHandler<EventArgs<IFeed^>^>^ value);
    void remove (EventHandler<EventArgs<IFeed^>^>^ value);
}
abstract ReconnectFeed : IEvent<EventHandler<EventArgs<IFeed>>,
    EventArgs<IFeed>>

Value

Type: SystemEventHandler EventArgs IFeed
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ResetPolarPlot Event

IMainViewResetPolarPlot Event
Raised when the user wants to reset the polar plot for a feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<IFeed>> ResetPolarPlot
Event ResetPolarPlot As EventHandler(Of EventArgs(Of IFeed))
 event EventHandler<EventArgs<IFeed^>^>^ ResetPolarPlot {
    void add (EventHandler<EventArgs<IFeed^>^>^ value);
    void remove (EventHandler<EventArgs<IFeed^>^>^ value);
}
abstract ResetPolarPlot : IEvent<EventHandler<EventArgs<IFeed>>,
    EventArgs<IFeed>>

Value

Type: SystemEventHandler EventArgs IFeed
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ToggleServerStatus Event

IMainViewToggleServerStatus Event
Raised when the user has indicated that they want to toggle the server's online status.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ToggleServerStatus
Event ToggleServerStatus As EventHandler
 event EventHandler^ ToggleServerStatus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToggleServerStatus : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IMainView.ToggleUPnpStatus Event

IMainViewToggleUPnpStatus Event
Raised when the user has indicated that they want to put the server onto or take the server off the Internet.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ToggleUPnpStatus
Event ToggleUPnpStatus As EventHandler
 event EventHandler^ ToggleUPnpStatus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToggleUPnpStatus : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMainView Interface
VirtualRadar.Interface.View Namespace


IPluginsView Interface

IPluginsView Interface
The interface for GUI objects that can display information about plugins and allow the user to configure them.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPluginsView : IView,
    IDisposable
Public Interface IPluginsView
    Inherits IView, IDisposable
public interface class IPluginsView : IView,
    IDisposable
type IPluginsView =
    interface
        interface IView
        interface IDisposable
    end

The IPluginsView type exposes the following members.

Properties
 | Name | Description
Public property | InvalidPluginsCount | Gets or sets a count of plugins that could not be loaded.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowPlugins | Shows information about the plugins to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IPluginsView Properties

IPluginsView Properties

The IPluginsView type exposes the following members.

Properties
 | Name | Description
Public property | InvalidPluginsCount | Gets or sets a count of plugins that could not be loaded.
Top
See Also

Reference

IPluginsView Interface
VirtualRadar.Interface.View Namespace


IPluginsView.InvalidPluginsCount Property

IPluginsViewInvalidPluginsCount Property
Gets or sets a count of plugins that could not be loaded.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int InvalidPluginsCount { get; set; }
Property InvalidPluginsCount As Integer
    Get
    Set
property int InvalidPluginsCount {
    int get ();
    void set (int value);
}
abstract InvalidPluginsCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IPluginsView Interface
VirtualRadar.Interface.View Namespace


IPluginsView Methods

IPluginsView Methods

The IPluginsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowPlugins | Shows information about the plugins to the user.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IPluginsView Interface
VirtualRadar.Interface.View Namespace


IPluginsView.ShowPlugins Method

IPluginsViewShowPlugins Method
Shows information about the plugins to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowPlugins(
    IEnumerable<IPlugin> plugins
)
Sub ShowPlugins (
    plugins As IEnumerable(Of IPlugin)
)
void ShowPlugins(
    IEnumerable<IPlugin^>^ plugins
)
abstract ShowPlugins :
        plugins : IEnumerable<IPlugin> -> unit

Parameters

plugins
Type: System.Collections.GenericIEnumerable IPlugin
See Also

Reference

IPluginsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView Interface

IRebroadcastOptionsView Interface
The interface for all views that allow the user to enter the details of rebroadcast servers.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRebroadcastOptionsView : IView,
    IDisposable, IValidateView
Public Interface IRebroadcastOptionsView
    Inherits IView, IDisposable, IValidateView
public interface class IRebroadcastOptionsView : IView,
    IDisposable, IValidateView
type IRebroadcastOptionsView =
    interface
        interface IView
        interface IDisposable
        interface IValidateView
    end

The IRebroadcastOptionsView type exposes the following members.

Properties
 | Name | Description
Public property | RebroadcastSettings | Gets the list of rebroadcast server settings.
Public property | SelectedRebroadcastSettings | Gets or sets the currently selected server settings.
Public property | ServerEnabled | Gets or sets the Enabled value of the currently selected server.
Public property | ServerFormat | Gets or sets the Format value of the currently selected server.
Public property | ServerName | Gets or sets the Name value of the currently selected server.
Public property | ServerPort | Gets or sets the Port value of the currently selected server.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FocusOnEditFields | Place the focus onto the data entry fields.
Public method | RefreshSelectedServer | Refreshes the display of the selected server in the list of servers.
Public method | RefreshServers | Refreshes the display of all of the servers.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | DeleteServerClicked | Raised when the user clicks the button to delete an existing server.
Public event | NewServerClicked | Raised when the user clicks the button to add a new server.
Public event | ResetClicked | Raised when the user indicates that they want to abandon their edits of the selected server.
Public event | SelectedServerChanged | Raised when the user changes the selection in the list of rebroadcast servers.
Public event | ValueChanged | Raised when the content of the ServerName field changes.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView Properties

IRebroadcastOptionsView Properties

The IRebroadcastOptionsView type exposes the following members.

Properties
 | Name | Description
Public property | RebroadcastSettings | Gets the list of rebroadcast server settings.
Public property | SelectedRebroadcastSettings | Gets or sets the currently selected server settings.
Public property | ServerEnabled | Gets or sets the Enabled value of the currently selected server.
Public property | ServerFormat | Gets or sets the Format value of the currently selected server.
Public property | ServerName | Gets or sets the Name value of the currently selected server.
Public property | ServerPort | Gets or sets the Port value of the currently selected server.
Top
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.RebroadcastSettings Property

IRebroadcastOptionsViewRebroadcastSettings Property
Gets the list of rebroadcast server settings.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<RebroadcastSettings> RebroadcastSettings { get; }
ReadOnly Property RebroadcastSettings As List(Of RebroadcastSettings)
    Get
property List<RebroadcastSettings^>^ RebroadcastSettings {
    List<RebroadcastSettings^>^ get ();
}
abstract RebroadcastSettings : List<RebroadcastSettings> with get

Property Value

Type: List RebroadcastSettings
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.SelectedRebroadcastSettings Property

IRebroadcastOptionsViewSelectedRebroadcastSettings Property
Gets or sets the currently selected server settings.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RebroadcastSettings SelectedRebroadcastSettings { get; set; }
Property SelectedRebroadcastSettings As RebroadcastSettings
    Get
    Set
property RebroadcastSettings^ SelectedRebroadcastSettings {
    RebroadcastSettings^ get ();
    void set (RebroadcastSettings^ value);
}
abstract SelectedRebroadcastSettings : RebroadcastSettings with get, set

Property Value

Type: RebroadcastSettings
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.ServerEnabled Property

IRebroadcastOptionsViewServerEnabled Property
Gets or sets the Enabled value of the currently selected server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ServerEnabled { get; set; }
Property ServerEnabled As Boolean
    Get
    Set
property bool ServerEnabled {
    bool get ();
    void set (bool value);
}
abstract ServerEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.ServerFormat Property

IRebroadcastOptionsViewServerFormat Property
Gets or sets the Format value of the currently selected server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RebroadcastFormat ServerFormat { get; set; }
Property ServerFormat As RebroadcastFormat
    Get
    Set
property RebroadcastFormat^ ServerFormat {
    RebroadcastFormat^ get ();
    void set (RebroadcastFormat^ value);
}
abstract ServerFormat : RebroadcastFormat with get, set

Property Value

Type: RebroadcastFormat
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.ServerName Property

IRebroadcastOptionsViewServerName Property
Gets or sets the Name value of the currently selected server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ServerName { get; set; }
Property ServerName As String
    Get
    Set
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
abstract ServerName : string with get, set

Property Value

Type: String
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.ServerPort Property

IRebroadcastOptionsViewServerPort Property
Gets or sets the Port value of the currently selected server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int ServerPort { get; set; }
Property ServerPort As Integer
    Get
    Set
property int ServerPort {
    int get ();
    void set (int value);
}
abstract ServerPort : int with get, set

Property Value

Type: Int32
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView Methods

IRebroadcastOptionsView Methods

The IRebroadcastOptionsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FocusOnEditFields | Place the focus onto the data entry fields.
Public method | RefreshSelectedServer | Refreshes the display of the selected server in the list of servers.
Public method | RefreshServers | Refreshes the display of all of the servers.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.FocusOnEditFields Method

IRebroadcastOptionsViewFocusOnEditFields Method
Place the focus onto the data entry fields.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FocusOnEditFields()
Sub FocusOnEditFields
void FocusOnEditFields()
abstract FocusOnEditFields : unit -> unit
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.RefreshSelectedServer Method

IRebroadcastOptionsViewRefreshSelectedServer Method
Refreshes the display of the selected server in the list of servers.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshSelectedServer()
Sub RefreshSelectedServer
void RefreshSelectedServer()
abstract RefreshSelectedServer : unit -> unit
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.RefreshServers Method

IRebroadcastOptionsViewRefreshServers Method
Refreshes the display of all of the servers.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshServers()
Sub RefreshServers
void RefreshServers()
abstract RefreshServers : unit -> unit
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView Events

IRebroadcastOptionsView Events

The IRebroadcastOptionsView type exposes the following members.

Events
 | Name | Description
Public event | DeleteServerClicked | Raised when the user clicks the button to delete an existing server.
Public event | NewServerClicked | Raised when the user clicks the button to add a new server.
Public event | ResetClicked | Raised when the user indicates that they want to abandon their edits of the selected server.
Public event | SelectedServerChanged | Raised when the user changes the selection in the list of rebroadcast servers.
Public event | ValueChanged | Raised when the content of the ServerName field changes.
Top
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.DeleteServerClicked Event

IRebroadcastOptionsViewDeleteServerClicked Event
Raised when the user clicks the button to delete an existing server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DeleteServerClicked
Event DeleteServerClicked As EventHandler
 event EventHandler^ DeleteServerClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteServerClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.NewServerClicked Event

IRebroadcastOptionsViewNewServerClicked Event
Raised when the user clicks the button to add a new server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler NewServerClicked
Event NewServerClicked As EventHandler
 event EventHandler^ NewServerClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract NewServerClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.ResetClicked Event

IRebroadcastOptionsViewResetClicked Event
Raised when the user indicates that they want to abandon their edits of the selected server.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ResetClicked
Event ResetClicked As EventHandler
 event EventHandler^ ResetClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResetClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.SelectedServerChanged Event

IRebroadcastOptionsViewSelectedServerChanged Event
Raised when the user changes the selection in the list of rebroadcast servers.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectedServerChanged
Event SelectedServerChanged As EventHandler
 event EventHandler^ SelectedServerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectedServerChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IRebroadcastOptionsView.ValueChanged Event

IRebroadcastOptionsViewValueChanged Event
Raised when the content of the ServerName field changes.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IRebroadcastOptionsView Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizard Interface

IReceiverConfigurationWizard Interface
The interface that Receiver Configuration wizards need to implement.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReceiverConfigurationWizard : IView,
    IDisposable
Public Interface IReceiverConfigurationWizard
    Inherits IView, IDisposable
public interface class IReceiverConfigurationWizard : IView,
    IDisposable
type IReceiverConfigurationWizard =
    interface
        interface IView
        interface IDisposable
    end

The IReceiverConfigurationWizard type exposes the following members.

Properties
 | Name | Description
Public property | Answers | Gets or sets the user's answers to the wizard's questions.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizard Properties

IReceiverConfigurationWizard Properties

The IReceiverConfigurationWizard type exposes the following members.

Properties
 | Name | Description
Public property | Answers | Gets or sets the user's answers to the wizard's questions.
Top
See Also

Reference

IReceiverConfigurationWizard Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizard.Answers Property

IReceiverConfigurationWizardAnswers Property
Gets or sets the user's answers to the wizard's questions.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IReceiverConfigurationWizardAnswers Answers { get; set; }
Property Answers As IReceiverConfigurationWizardAnswers
    Get
    Set
property IReceiverConfigurationWizardAnswers^ Answers {
    IReceiverConfigurationWizardAnswers^ get ();
    void set (IReceiverConfigurationWizardAnswers^ value);
}
abstract Answers : IReceiverConfigurationWizardAnswers with get, set

Property Value

Type: IReceiverConfigurationWizardAnswers
See Also

Reference

IReceiverConfigurationWizard Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizard Methods

IReceiverConfigurationWizard Methods

The IReceiverConfigurationWizard type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IReceiverConfigurationWizard Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers Interface

IReceiverConfigurationWizardAnswers Interface
The interface that IReceiverConfigurationWizard views expose to carry the answers supplied by the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReceiverConfigurationWizardAnswers
Public Interface IReceiverConfigurationWizardAnswers
public interface class IReceiverConfigurationWizardAnswers
type IReceiverConfigurationWizardAnswers =  interface end

The IReceiverConfigurationWizardAnswers type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionType | Gets or sets the connection type used by the receiver. Ignore if the receiver class is SDR, or if the dedicated receiver is anything except Beast.
Public property | DedicatedReceiver | Gets or sets the dedicated receiver in use. Ignore if receiver class is not Dedicated.
Public property | IsLoopback | Gets or sets a value indicating that the feed is coming from a program and that program is on the same machine as VRS.
Public property | IsUsingBaseStation | Gets or sets a value indicating that the user is using BaseStation. Ignore if the receiver is not Kinetics.
Public property | NetworkAddress | Gets or sets the address to use if the receiver is reached over the network and it cannot be reached over the loopback interface.
Public property | ReceiverClass | Gets or sets the broad class of receiver - SDR vs. Dedicated.
Public property | SdrDecoder | Gets or sets the SDR decoder in use. Ignore if receiver class is not SDR.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers Properties

IReceiverConfigurationWizardAnswers Properties

The IReceiverConfigurationWizardAnswers type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionType | Gets or sets the connection type used by the receiver. Ignore if the receiver class is SDR, or if the dedicated receiver is anything except Beast.
Public property | DedicatedReceiver | Gets or sets the dedicated receiver in use. Ignore if receiver class is not Dedicated.
Public property | IsLoopback | Gets or sets a value indicating that the feed is coming from a program and that program is on the same machine as VRS.
Public property | IsUsingBaseStation | Gets or sets a value indicating that the user is using BaseStation. Ignore if the receiver is not Kinetics.
Public property | NetworkAddress | Gets or sets the address to use if the receiver is reached over the network and it cannot be reached over the loopback interface.
Public property | ReceiverClass | Gets or sets the broad class of receiver - SDR vs. Dedicated.
Public property | SdrDecoder | Gets or sets the SDR decoder in use. Ignore if receiver class is not SDR.
Top
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.ConnectionType Property

IReceiverConfigurationWizardAnswersConnectionType Property
Gets or sets the connection type used by the receiver. Ignore if the receiver class is SDR, or if the dedicated receiver is anything except Beast.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectionType ConnectionType { get; set; }
Property ConnectionType As ConnectionType
    Get
    Set
property ConnectionType ConnectionType {
    ConnectionType get ();
    void set (ConnectionType value);
}
abstract ConnectionType : ConnectionType with get, set

Property Value

Type: ConnectionType
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.DedicatedReceiver Property

IReceiverConfigurationWizardAnswersDedicatedReceiver Property
Gets or sets the dedicated receiver in use. Ignore if receiver class is not Dedicated.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DedicatedReceiver DedicatedReceiver { get; set; }
Property DedicatedReceiver As DedicatedReceiver
    Get
    Set
property DedicatedReceiver DedicatedReceiver {
    DedicatedReceiver get ();
    void set (DedicatedReceiver value);
}
abstract DedicatedReceiver : DedicatedReceiver with get, set

Property Value

Type: DedicatedReceiver
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.IsLoopback Property

IReceiverConfigurationWizardAnswersIsLoopback Property
Gets or sets a value indicating that the feed is coming from a program and that program is on the same machine as VRS.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLoopback { get; set; }
Property IsLoopback As Boolean
    Get
    Set
property bool IsLoopback {
    bool get ();
    void set (bool value);
}
abstract IsLoopback : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.IsUsingBaseStation Property

IReceiverConfigurationWizardAnswersIsUsingBaseStation Property
Gets or sets a value indicating that the user is using BaseStation. Ignore if the receiver is not Kinetics.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUsingBaseStation { get; set; }
Property IsUsingBaseStation As Boolean
    Get
    Set
property bool IsUsingBaseStation {
    bool get ();
    void set (bool value);
}
abstract IsUsingBaseStation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.NetworkAddress Property

IReceiverConfigurationWizardAnswersNetworkAddress Property
Gets or sets the address to use if the receiver is reached over the network and it cannot be reached over the loopback interface.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string NetworkAddress { get; set; }
Property NetworkAddress As String
    Get
    Set
property String^ NetworkAddress {
    String^ get ();
    void set (String^ value);
}
abstract NetworkAddress : string with get, set

Property Value

Type: String
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.ReceiverClass Property

IReceiverConfigurationWizardAnswersReceiverClass Property
Gets or sets the broad class of receiver - SDR vs. Dedicated.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ReceiverClass ReceiverClass { get; set; }
Property ReceiverClass As ReceiverClass
    Get
    Set
property ReceiverClass ReceiverClass {
    ReceiverClass get ();
    void set (ReceiverClass value);
}
abstract ReceiverClass : ReceiverClass with get, set

Property Value

Type: ReceiverClass
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverConfigurationWizardAnswers.SdrDecoder Property

IReceiverConfigurationWizardAnswersSdrDecoder Property
Gets or sets the SDR decoder in use. Ignore if receiver class is not SDR.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SdrDecoder SdrDecoder { get; set; }
Property SdrDecoder As SdrDecoder
    Get
    Set
property SdrDecoder SdrDecoder {
    SdrDecoder get ();
    void set (SdrDecoder value);
}
abstract SdrDecoder : SdrDecoder with get, set

Property Value

Type: SdrDecoder
See Also

Reference

IReceiverConfigurationWizardAnswers Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView Interface

IReceiverLocationsView Interface
The interface for the view that can be used to edit the list of receiver locations.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReceiverLocationsView : IView,
    IDisposable, IValidateView
Public Interface IReceiverLocationsView
    Inherits IView, IDisposable, IValidateView
public interface class IReceiverLocationsView : IView,
    IDisposable, IValidateView
type IReceiverLocationsView =
    interface
        interface IView
        interface IDisposable
        interface IValidateView
    end

The IReceiverLocationsView type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude of the location being edited by the user.
Public property | Location | Gets or sets the name of the location being edited by the user.
Public property | Longitude | Gets or sets the longitude of the location being edited by the user.
Public property | ReceiverLocations | Gets the full list of receiver locations.
Public property | SelectedReceiverLocation | Gets or sets the currently-selected receiver location.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FocusOnEditFields | Place the focus onto the location / latitude / longitude fields.
Public method | RefreshLocations | Refreshes the display of all of the locations.
Public method | RefreshSelectedLocation | Refreshes the display of the selected location in the list of locations.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | CloseClicked | Raised when the user closes the dialog. The currently selected location should be validated and used.
Public event | DeleteLocationClicked | Raised when the user clicks the button to delete an existing location.
Public event | NewLocationClicked | Raised when the user clicks the button to add a new location.
Public event | ResetClicked | Raised when the user indicates that they want to abandon their edits of the selected location.
Public event | SelectedLocationChanged | Raised when the user changes the selection in the list of receiver locations.
Public event | UpdateFromBaseStationDatabaseClicked | Raised when the user indicates that they want to refresh the content of the list with locations from the BaseStation database.
Public event | ValueChanged | Raised when the content of the Location, Latitude or Longitude fields change.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IReceiverLocationsView Properties

IReceiverLocationsView Properties

The IReceiverLocationsView type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude of the location being edited by the user.
Public property | Location | Gets or sets the name of the location being edited by the user.
Public property | Longitude | Gets or sets the longitude of the location being edited by the user.
Public property | ReceiverLocations | Gets the full list of receiver locations.
Public property | SelectedReceiverLocation | Gets or sets the currently-selected receiver location.
Top
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.Latitude Property

IReceiverLocationsViewLatitude Property
Gets or sets the latitude of the location being edited by the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Latitude { get; set; }
Property Latitude As String
    Get
    Set
property String^ Latitude {
    String^ get ();
    void set (String^ value);
}
abstract Latitude : string with get, set

Property Value

Type: String
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.Location Property

IReceiverLocationsViewLocation Property
Gets or sets the name of the location being edited by the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Location { get; set; }
Property Location As String
    Get
    Set
property String^ Location {
    String^ get ();
    void set (String^ value);
}
abstract Location : string with get, set

Property Value

Type: String
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.Longitude Property

IReceiverLocationsViewLongitude Property
Gets or sets the longitude of the location being edited by the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Longitude { get; set; }
Property Longitude As String
    Get
    Set
property String^ Longitude {
    String^ get ();
    void set (String^ value);
}
abstract Longitude : string with get, set

Property Value

Type: String
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.ReceiverLocations Property

IReceiverLocationsViewReceiverLocations Property
Gets the full list of receiver locations.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<ReceiverLocation> ReceiverLocations { get; }
ReadOnly Property ReceiverLocations As List(Of ReceiverLocation)
    Get
property List<ReceiverLocation^>^ ReceiverLocations {
    List<ReceiverLocation^>^ get ();
}
abstract ReceiverLocations : List<ReceiverLocation> with get

Property Value

Type: List ReceiverLocation
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.SelectedReceiverLocation Property

IReceiverLocationsViewSelectedReceiverLocation Property
Gets or sets the currently-selected receiver location.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ReceiverLocation SelectedReceiverLocation { get; set; }
Property SelectedReceiverLocation As ReceiverLocation
    Get
    Set
property ReceiverLocation^ SelectedReceiverLocation {
    ReceiverLocation^ get ();
    void set (ReceiverLocation^ value);
}
abstract SelectedReceiverLocation : ReceiverLocation with get, set

Property Value

Type: ReceiverLocation
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView Methods

IReceiverLocationsView Methods

The IReceiverLocationsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FocusOnEditFields | Place the focus onto the location / latitude / longitude fields.
Public method | RefreshLocations | Refreshes the display of all of the locations.
Public method | RefreshSelectedLocation | Refreshes the display of the selected location in the list of locations.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.FocusOnEditFields Method

IReceiverLocationsViewFocusOnEditFields Method
Place the focus onto the location / latitude / longitude fields.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FocusOnEditFields()
Sub FocusOnEditFields
void FocusOnEditFields()
abstract FocusOnEditFields : unit -> unit
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.RefreshLocations Method

IReceiverLocationsViewRefreshLocations Method
Refreshes the display of all of the locations.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshLocations()
Sub RefreshLocations
void RefreshLocations()
abstract RefreshLocations : unit -> unit
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.RefreshSelectedLocation Method

IReceiverLocationsViewRefreshSelectedLocation Method
Refreshes the display of the selected location in the list of locations.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshSelectedLocation()
Sub RefreshSelectedLocation
void RefreshSelectedLocation()
abstract RefreshSelectedLocation : unit -> unit
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView Events

IReceiverLocationsView Events

The IReceiverLocationsView type exposes the following members.

Events
 | Name | Description
Public event | CloseClicked | Raised when the user closes the dialog. The currently selected location should be validated and used.
Public event | DeleteLocationClicked | Raised when the user clicks the button to delete an existing location.
Public event | NewLocationClicked | Raised when the user clicks the button to add a new location.
Public event | ResetClicked | Raised when the user indicates that they want to abandon their edits of the selected location.
Public event | SelectedLocationChanged | Raised when the user changes the selection in the list of receiver locations.
Public event | UpdateFromBaseStationDatabaseClicked | Raised when the user indicates that they want to refresh the content of the list with locations from the BaseStation database.
Public event | ValueChanged | Raised when the content of the Location, Latitude or Longitude fields change.
Top
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.CloseClicked Event

IReceiverLocationsViewCloseClicked Event
Raised when the user closes the dialog. The currently selected location should be validated and used.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CloseClicked
Event CloseClicked As EventHandler
 event EventHandler^ CloseClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CloseClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.DeleteLocationClicked Event

IReceiverLocationsViewDeleteLocationClicked Event
Raised when the user clicks the button to delete an existing location.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DeleteLocationClicked
Event DeleteLocationClicked As EventHandler
 event EventHandler^ DeleteLocationClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteLocationClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.NewLocationClicked Event

IReceiverLocationsViewNewLocationClicked Event
Raised when the user clicks the button to add a new location.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler NewLocationClicked
Event NewLocationClicked As EventHandler
 event EventHandler^ NewLocationClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract NewLocationClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.ResetClicked Event

IReceiverLocationsViewResetClicked Event
Raised when the user indicates that they want to abandon their edits of the selected location.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ResetClicked
Event ResetClicked As EventHandler
 event EventHandler^ ResetClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResetClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.SelectedLocationChanged Event

IReceiverLocationsViewSelectedLocationChanged Event
Raised when the user changes the selection in the list of receiver locations.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectedLocationChanged
Event SelectedLocationChanged As EventHandler
 event EventHandler^ SelectedLocationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectedLocationChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.UpdateFromBaseStationDatabaseClicked Event

IReceiverLocationsViewUpdateFromBaseStationDatabaseClicked Event
Raised when the user indicates that they want to refresh the content of the list with locations from the BaseStation database.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UpdateFromBaseStationDatabaseClicked
Event UpdateFromBaseStationDatabaseClicked As EventHandler
 event EventHandler^ UpdateFromBaseStationDatabaseClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UpdateFromBaseStationDatabaseClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


IReceiverLocationsView.ValueChanged Event

IReceiverLocationsViewValueChanged Event
Raised when the content of the Location, Latitude or Longitude fields change.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IReceiverLocationsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView Interface

ISettingsView Interface
The interface for views that lets the user view and edit the configuration.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISettingsView : IView,
    IDisposable, IBusyView, IValidateView
Public Interface ISettingsView
    Inherits IView, IDisposable, IBusyView, IValidateView
public interface class ISettingsView : IView,
    IDisposable, IBusyView, IValidateView
type ISettingsView =
    interface
        interface IView
        interface IDisposable
        interface IBusyView
        interface IValidateView
    end

The ISettingsView type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the configuration to display and edit.
Public property | OpenOnPageTitle | Gets or sets the title of the page to start the view on.
Public property | OpenOnRecord | Gets or sets the record to start the view on. Note that this will not have the same object references as the records in Configuration.
Public property | UserManager | Gets or sets the name of the user manager.
Public property | Users | Gets the list of configured users.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | PopulateTextToSpeechVoices | The names of every voice installed on the system.
Public method | ShowAircraftDataLookupSettings | Displays the current server-side settings for the aircraft online lookup data supplier.
Public method | ShowBusy | Indicates to the user that the application is busy. (Inherited from IBusyView.)
Public method | ShowTestConnectionResults | Displays the results of a connection test attempt to the user.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
Events
 | Name | Description
Public event | FlightSimulatorXOnlyClicked | Raised when the user indicates that they don't have any radio, they just want to set this thing up to show their aircraft from FSX.
Public event | OpenUrlClicked | Raised when the user wants to open a browser on a URL.
Public event | SaveClicked | Raised when the user wants to save their changes.
Public event | TestConnectionClicked | Raised when the user indicates that they want to see if their current data feed settings will connect to something.
Public event | TestTextToSpeechSettingsClicked | Raised when the user wants to test the speech synthesis settings.
Public event | UpdateReceiverLocationsFromBaseStationDatabaseClicked | Raised when the user indicates that they want to refresh the content of the ReceiverLocations list with locations from the BaseStation database.
Public event | UseIcaoRawDecodingSettingsClicked | Raised when the user wants to use the ICAO specification settings for the raw decoder.
Public event | UseRecommendedRawDecodingSettingsClicked | Raised when the user wants to use the default values for the raw decoder.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ISettingsView Properties

ISettingsView Properties

The ISettingsView type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the configuration to display and edit.
Public property | OpenOnPageTitle | Gets or sets the title of the page to start the view on.
Public property | OpenOnRecord | Gets or sets the record to start the view on. Note that this will not have the same object references as the records in Configuration.
Public property | UserManager | Gets or sets the name of the user manager.
Public property | Users | Gets the list of configured users.
Top
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.Configuration Property

ISettingsViewConfiguration Property
Gets or sets the configuration to display and edit.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Configuration Configuration { get; set; }
Property Configuration As Configuration
    Get
    Set
property Configuration^ Configuration {
    Configuration^ get ();
    void set (Configuration^ value);
}
abstract Configuration : Configuration with get, set

Property Value

Type: Configuration
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.OpenOnPageTitle Property

ISettingsViewOpenOnPageTitle Property
Gets or sets the title of the page to start the view on.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string OpenOnPageTitle { get; set; }
Property OpenOnPageTitle As String
    Get
    Set
property String^ OpenOnPageTitle {
    String^ get ();
    void set (String^ value);
}
abstract OpenOnPageTitle : string with get, set

Property Value

Type: String
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.OpenOnRecord Property

ISettingsViewOpenOnRecord Property
Gets or sets the record to start the view on. Note that this will not have the same object references as the records in Configuration.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Object OpenOnRecord { get; set; }
Property OpenOnRecord As Object
    Get
    Set
property Object^ OpenOnRecord {
    Object^ get ();
    void set (Object^ value);
}
abstract OpenOnRecord : Object with get, set

Property Value

Type: Object
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.UserManager Property

ISettingsViewUserManager Property
Gets or sets the name of the user manager.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserManager { get; set; }
Property UserManager As String
    Get
    Set
property String^ UserManager {
    String^ get ();
    void set (String^ value);
}
abstract UserManager : string with get, set

Property Value

Type: String
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.Users Property

ISettingsViewUsers Property
Gets the list of configured users.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
NotifyList<IUser> Users { get; }
ReadOnly Property Users As NotifyList(Of IUser)
    Get
property NotifyList<IUser^>^ Users {
    NotifyList<IUser^>^ get ();
}
abstract Users : NotifyList<IUser> with get

Property Value

Type: NotifyList IUser
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView Methods

ISettingsView Methods

The ISettingsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | PopulateTextToSpeechVoices | The names of every voice installed on the system.
Public method | ShowAircraftDataLookupSettings | Displays the current server-side settings for the aircraft online lookup data supplier.
Public method | ShowBusy | Indicates to the user that the application is busy. (Inherited from IBusyView.)
Public method | ShowTestConnectionResults | Displays the results of a connection test attempt to the user.
Public method | ShowValidationResults | Displays the results of the validation of input to the user. (Inherited from IValidateView.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.PopulateTextToSpeechVoices Method

ISettingsViewPopulateTextToSpeechVoices Method
The names of every voice installed on the system.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void PopulateTextToSpeechVoices(
    IEnumerable<string> voiceNames
)
Sub PopulateTextToSpeechVoices (
    voiceNames As IEnumerable(Of String)
)
void PopulateTextToSpeechVoices(
    IEnumerable<String^>^ voiceNames
)
abstract PopulateTextToSpeechVoices :
        voiceNames : IEnumerable<string> -> unit

Parameters

voiceNames
Type: System.Collections.GenericIEnumerable String
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.ShowAircraftDataLookupSettings Method

ISettingsViewShowAircraftDataLookupSettings Method
Displays the current server-side settings for the aircraft online lookup data supplier.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowAircraftDataLookupSettings(
    string dataSupplier,
    string supplierCredits,
    string supplierUrl
)
Sub ShowAircraftDataLookupSettings (
    dataSupplier As String,
    supplierCredits As String,
    supplierUrl As String
)
void ShowAircraftDataLookupSettings(
    String^ dataSupplier,
    String^ supplierCredits,
    String^ supplierUrl
)
abstract ShowAircraftDataLookupSettings :
        dataSupplier : string *
        supplierCredits : string *
        supplierUrl : string -> unit

Parameters

dataSupplier
Type: SystemString
supplierCredits
Type: SystemString
supplierUrl
Type: SystemString
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.ShowTestConnectionResults Method

ISettingsViewShowTestConnectionResults Method
Displays the results of a connection test attempt to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowTestConnectionResults(
    string message,
    string title
)
Sub ShowTestConnectionResults (
    message As String,
    title As String
)
void ShowTestConnectionResults(
    String^ message,
    String^ title
)
abstract ShowTestConnectionResults :
        message : string *
        title : string -> unit

Parameters

message
Type: SystemString
title
Type: SystemString
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView Events

ISettingsView Events

The ISettingsView type exposes the following members.

Events
 | Name | Description
Public event | FlightSimulatorXOnlyClicked | Raised when the user indicates that they don't have any radio, they just want to set this thing up to show their aircraft from FSX.
Public event | OpenUrlClicked | Raised when the user wants to open a browser on a URL.
Public event | SaveClicked | Raised when the user wants to save their changes.
Public event | TestConnectionClicked | Raised when the user indicates that they want to see if their current data feed settings will connect to something.
Public event | TestTextToSpeechSettingsClicked | Raised when the user wants to test the speech synthesis settings.
Public event | UpdateReceiverLocationsFromBaseStationDatabaseClicked | Raised when the user indicates that they want to refresh the content of the ReceiverLocations list with locations from the BaseStation database.
Public event | UseIcaoRawDecodingSettingsClicked | Raised when the user wants to use the ICAO specification settings for the raw decoder.
Public event | UseRecommendedRawDecodingSettingsClicked | Raised when the user wants to use the default values for the raw decoder.
Top
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.FlightSimulatorXOnlyClicked Event

ISettingsViewFlightSimulatorXOnlyClicked Event
Raised when the user indicates that they don't have any radio, they just want to set this thing up to show their aircraft from FSX.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FlightSimulatorXOnlyClicked
Event FlightSimulatorXOnlyClicked As EventHandler
 event EventHandler^ FlightSimulatorXOnlyClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FlightSimulatorXOnlyClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.OpenUrlClicked Event

ISettingsViewOpenUrlClicked Event
Raised when the user wants to open a browser on a URL.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<string>> OpenUrlClicked
Event OpenUrlClicked As EventHandler(Of EventArgs(Of String))
 event EventHandler<EventArgs<String^>^>^ OpenUrlClicked {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}
abstract OpenUrlClicked : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

Value

Type: SystemEventHandler EventArgs String
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.SaveClicked Event

ISettingsViewSaveClicked Event
Raised when the user wants to save their changes.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SaveClicked
Event SaveClicked As EventHandler
 event EventHandler^ SaveClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SaveClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.TestConnectionClicked Event

ISettingsViewTestConnectionClicked Event
Raised when the user indicates that they want to see if their current data feed settings will connect to something.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<Receiver>> TestConnectionClicked
Event TestConnectionClicked As EventHandler(Of EventArgs(Of Receiver))
 event EventHandler<EventArgs<Receiver^>^>^ TestConnectionClicked {
    void add (EventHandler<EventArgs<Receiver^>^>^ value);
    void remove (EventHandler<EventArgs<Receiver^>^>^ value);
}
abstract TestConnectionClicked : IEvent<EventHandler<EventArgs<Receiver>>,
    EventArgs<Receiver>>

Value

Type: SystemEventHandler EventArgs Receiver
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.TestTextToSpeechSettingsClicked Event

ISettingsViewTestTextToSpeechSettingsClicked Event
Raised when the user wants to test the speech synthesis settings.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler TestTextToSpeechSettingsClicked
Event TestTextToSpeechSettingsClicked As EventHandler
 event EventHandler^ TestTextToSpeechSettingsClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TestTextToSpeechSettingsClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.UpdateReceiverLocationsFromBaseStationDatabaseClicked Event

ISettingsViewUpdateReceiverLocationsFromBaseStationDatabaseClicked Event
Raised when the user indicates that they want to refresh the content of the ReceiverLocations list with locations from the BaseStation database.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UpdateReceiverLocationsFromBaseStationDatabaseClicked
Event UpdateReceiverLocationsFromBaseStationDatabaseClicked As EventHandler
 event EventHandler^ UpdateReceiverLocationsFromBaseStationDatabaseClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UpdateReceiverLocationsFromBaseStationDatabaseClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.UseIcaoRawDecodingSettingsClicked Event

ISettingsViewUseIcaoRawDecodingSettingsClicked Event
Raised when the user wants to use the ICAO specification settings for the raw decoder.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UseIcaoRawDecodingSettingsClicked
Event UseIcaoRawDecodingSettingsClicked As EventHandler
 event EventHandler^ UseIcaoRawDecodingSettingsClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UseIcaoRawDecodingSettingsClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


ISettingsView.UseRecommendedRawDecodingSettingsClicked Event

ISettingsViewUseRecommendedRawDecodingSettingsClicked Event
Raised when the user wants to use the default values for the raw decoder.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UseRecommendedRawDecodingSettingsClicked
Event UseRecommendedRawDecodingSettingsClicked As EventHandler
 event EventHandler^ UseRecommendedRawDecodingSettingsClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UseRecommendedRawDecodingSettingsClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISettingsView Interface
VirtualRadar.Interface.View Namespace


IShutdownView Interface

IShutdownView Interface
The interface for the splash screen that is displayed while the application is closing down.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IShutdownView : IView,
    IDisposable
Public Interface IShutdownView
    Inherits IView, IDisposable
public interface class IShutdownView : IView,
    IDisposable
type IShutdownView =
    interface
        interface IView
        interface IDisposable
    end

The IShutdownView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records references to objects that will be passed on to the presenter when the time comes to create it.
Public method | ReportProgress | Non-blocking method to display text to the user indicating the stage of shutdown that the program's reached.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IShutdownView Methods

IShutdownView Methods

The IShutdownView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records references to objects that will be passed on to the presenter when the time comes to create it.
Public method | ReportProgress | Non-blocking method to display text to the user indicating the stage of shutdown that the program's reached.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Top
See Also

Reference

IShutdownView Interface
VirtualRadar.Interface.View Namespace


IShutdownView.Initialise Method

IShutdownViewInitialise Method
Records references to objects that will be passed on to the presenter when the time comes to create it.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    IUniversalPlugAndPlayManager uPnpManager,
    IBaseStationAircraftList baseStationAircraftList
)
Sub Initialise (
    uPnpManager As IUniversalPlugAndPlayManager,
    baseStationAircraftList As IBaseStationAircraftList
)
void Initialise(
    IUniversalPlugAndPlayManager^ uPnpManager,
    IBaseStationAircraftList^ baseStationAircraftList
)
abstract Initialise :
        uPnpManager : IUniversalPlugAndPlayManager *
        baseStationAircraftList : IBaseStationAircraftList -> unit

Parameters

uPnpManager
Type: VirtualRadar.Interface.WebServerIUniversalPlugAndPlayManager
baseStationAircraftList
Type: VirtualRadar.Interface.BaseStationIBaseStationAircraftList
See Also

Reference

IShutdownView Interface
VirtualRadar.Interface.View Namespace


IShutdownView.ReportProgress Method

IShutdownViewReportProgress Method
Non-blocking method to display text to the user indicating the stage of shutdown that the program's reached.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReportProgress(
    string text
)
Sub ReportProgress (
    text As String
)
void ReportProgress(
    String^ text
)
abstract ReportProgress :
        text : string -> unit

Parameters

text
Type: SystemString
See Also

Reference

IShutdownView Interface
VirtualRadar.Interface.View Namespace


ISplashView Interface

ISplashView Interface
The interface for the splash screen that is displayed while the application is firing up.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISplashView : IView,
    IDisposable
Public Interface ISplashView
    Inherits IView, IDisposable
public interface class ISplashView : IView,
    IDisposable
type ISplashView =
    interface
        interface IView
        interface IDisposable
    end

The ISplashView type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application to show to the user.
Public property | ApplicationVersion | Gets or sets the version information to show to the user.
Public property | BaseStationAircraftList | Gets or sets the aircraft list tracking real aircraft that the presenter will create in the background.
Public property | FlightSimulatorXAircraftList | Gets or sets the aircraft list tracking simulated aircraft in FSX that the presenter will create in the background.
Public property | LoadSucceeded | Gets a value indicating that the load succeeded without any obvious problems.
Public property | UPnpManager | Gets or sets the universal plug and play manager that the presenter creates for the application.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records references to objects that will be passed on to the presenter when the time comes to create it.
Public method | ReportProblem | Blocking method that displays details of a problem to the user.
Public method | ReportProgress | Non-blocking method to display text to the user, intended to show the current state of the presenter's build up of the application.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | YesNoPrompt | Blocking method that displays a prompt and asks the user to choose one of a yes/no response. Returns true if the user answers yes.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ISplashView Properties

ISplashView Properties

The ISplashView type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application to show to the user.
Public property | ApplicationVersion | Gets or sets the version information to show to the user.
Public property | BaseStationAircraftList | Gets or sets the aircraft list tracking real aircraft that the presenter will create in the background.
Public property | FlightSimulatorXAircraftList | Gets or sets the aircraft list tracking simulated aircraft in FSX that the presenter will create in the background.
Public property | LoadSucceeded | Gets a value indicating that the load succeeded without any obvious problems.
Public property | UPnpManager | Gets or sets the universal plug and play manager that the presenter creates for the application.
Top
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.ApplicationName Property

ISplashViewApplicationName Property
Gets or sets the name of the application to show to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ApplicationName { get; set; }
Property ApplicationName As String
    Get
    Set
property String^ ApplicationName {
    String^ get ();
    void set (String^ value);
}
abstract ApplicationName : string with get, set

Property Value

Type: String
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.ApplicationVersion Property

ISplashViewApplicationVersion Property
Gets or sets the version information to show to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ApplicationVersion { get; set; }
Property ApplicationVersion As String
    Get
    Set
property String^ ApplicationVersion {
    String^ get ();
    void set (String^ value);
}
abstract ApplicationVersion : string with get, set

Property Value

Type: String
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.BaseStationAircraftList Property

ISplashViewBaseStationAircraftList Property
Gets or sets the aircraft list tracking real aircraft that the presenter will create in the background.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IBaseStationAircraftList BaseStationAircraftList { get; set; }
Property BaseStationAircraftList As IBaseStationAircraftList
    Get
    Set
property IBaseStationAircraftList^ BaseStationAircraftList {
    IBaseStationAircraftList^ get ();
    void set (IBaseStationAircraftList^ value);
}
abstract BaseStationAircraftList : IBaseStationAircraftList with get, set

Property Value

Type: IBaseStationAircraftList
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.FlightSimulatorXAircraftList Property

ISplashViewFlightSimulatorXAircraftList Property
Gets or sets the aircraft list tracking simulated aircraft in FSX that the presenter will create in the background.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISimpleAircraftList FlightSimulatorXAircraftList { get; set; }
Property FlightSimulatorXAircraftList As ISimpleAircraftList
    Get
    Set
property ISimpleAircraftList^ FlightSimulatorXAircraftList {
    ISimpleAircraftList^ get ();
    void set (ISimpleAircraftList^ value);
}
abstract FlightSimulatorXAircraftList : ISimpleAircraftList with get, set

Property Value

Type: ISimpleAircraftList
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.LoadSucceeded Property

ISplashViewLoadSucceeded Property
Gets a value indicating that the load succeeded without any obvious problems.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadSucceeded { get; }
ReadOnly Property LoadSucceeded As Boolean
    Get
property bool LoadSucceeded {
    bool get ();
}
abstract LoadSucceeded : bool with get

Property Value

Type: Boolean
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.UPnpManager Property

ISplashViewUPnpManager Property
Gets or sets the universal plug and play manager that the presenter creates for the application.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IUniversalPlugAndPlayManager UPnpManager { get; set; }
Property UPnpManager As IUniversalPlugAndPlayManager
    Get
    Set
property IUniversalPlugAndPlayManager^ UPnpManager {
    IUniversalPlugAndPlayManager^ get ();
    void set (IUniversalPlugAndPlayManager^ value);
}
abstract UPnpManager : IUniversalPlugAndPlayManager with get, set

Property Value

Type: IUniversalPlugAndPlayManager
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView Methods

ISplashView Methods

The ISplashView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Records references to objects that will be passed on to the presenter when the time comes to create it.
Public method | ReportProblem | Blocking method that displays details of a problem to the user.
Public method | ReportProgress | Non-blocking method to display text to the user, intended to show the current state of the presenter's build up of the application.
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | YesNoPrompt | Blocking method that displays a prompt and asks the user to choose one of a yes/no response. Returns true if the user answers yes.
Top
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.Initialise Method

ISplashViewInitialise Method
Records references to objects that will be passed on to the presenter when the time comes to create it.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    string[] commandLineArgs,
    EventHandler<EventArgs<Exception>> backgroundThreadExceptionHandler
)
Sub Initialise (
    commandLineArgs As String(),
    backgroundThreadExceptionHandler As EventHandler(Of EventArgs(Of Exception))
)
void Initialise(
    array<String^>^ commandLineArgs,
    EventHandler<EventArgs<Exception^>^>^ backgroundThreadExceptionHandler
)
abstract Initialise :
        commandLineArgs : string[] *
        backgroundThreadExceptionHandler : EventHandler<EventArgs<Exception>> -> unit

Parameters

commandLineArgs
Type: SystemString
backgroundThreadExceptionHandler
Type: SystemEventHandler EventArgs Exception
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.ReportProblem Method

ISplashViewReportProblem Method
Blocking method that displays details of a problem to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReportProblem(
    string message,
    string title,
    bool quitApplication
)
Sub ReportProblem (
    message As String,
    title As String,
    quitApplication As Boolean
)
void ReportProblem(
    String^ message,
    String^ title,
    bool quitApplication
)
abstract ReportProblem :
        message : string *
        title : string *
        quitApplication : bool -> unit

Parameters

message
Type: SystemString
title
Type: SystemString
quitApplication
Type: SystemBoolean
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.ReportProgress Method

ISplashViewReportProgress Method
Non-blocking method to display text to the user, intended to show the current state of the presenter's build up of the application.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReportProgress(
    string text
)
Sub ReportProgress (
    text As String
)
void ReportProgress(
    String^ text
)
abstract ReportProgress :
        text : string -> unit

Parameters

text
Type: SystemString
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


ISplashView.YesNoPrompt Method

ISplashViewYesNoPrompt Method
Blocking method that displays a prompt and asks the user to choose one of a yes/no response. Returns true if the user answers yes.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool YesNoPrompt(
    string message,
    string title,
    bool defaultYes
)
Function YesNoPrompt (
    message As String,
    title As String,
    defaultYes As Boolean
) As Boolean
bool YesNoPrompt(
    String^ message,
    String^ title,
    bool defaultYes
)
abstract YesNoPrompt :
        message : string *
        title : string *
        defaultYes : bool -> bool

Parameters

message
Type: SystemString
title
Type: SystemString
defaultYes
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

ISplashView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView Interface

IStatisticsView Interface
The interface for the view that displays the statistics and refreshes the display on a timer.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStatisticsView : IView,
    IDisposable
Public Interface IStatisticsView
    Inherits IView, IDisposable
public interface class IStatisticsView : IView,
    IDisposable
type IStatisticsView =
    interface
        interface IView
        interface IDisposable
    end

The IStatisticsView type exposes the following members.

Properties
 | Name | Description
Public property | AdsbMessageFormatCount | Gets an array of counters of ADS-B messages against their message format.
Public property | AdsbMessages | Gets or sets the count of ADS-B messages seen.
Public property | AdsbMessageTypeCount | Gets an array of counters of ADS-B messages against their message type.
Public property | AdsbRejected | Gets or sets the count of ADS-B messages that were not used.
Public property | AdsbRejectedRatio | Gets or sets the %age of ADS-B messages that were rejected, either because of bad parity or settings.
Public property | BadlyFormedBaseStationMessages | Gets or sets the count of BaseStation messages that were badly formed.
Public property | BadlyFormedBaseStationMessagesRatio | Gets or sets the %age of BaseStation messages that were badly formed.
Public property | BaseStationMessages | Gets or sets the count of BaseStation messages received.
Public property | BytesReceived | Gets or sets the number of bytes received.
Public property | ConnectedDuration | Gets or sets the span of time that has elapsed since the user first connected.
Public property | CurrentBufferSize | Gets or sets the current buffer size.
Public property | ModeSDFCount | Gets an array of counters of Mode-S messages indexed by the message's DF.
Public property | ModeSLongFrame | Gets or sets the number of long-frame Mode-S messages.
Public property | ModeSMessageCount | Gets or sets the number of Mode-S messages seen.
Public property | ModeSNoAdsbPayload | Gets or sets the number of Mode-S messages that were not DF17.
Public property | ModeSNoAdsbPayloadRatio | Gets or sets the %age of Mode-S messages that were not DF17.
Public property | ModeSPIBadParity | Gets or sets the number of Mode-S messages with a PI field that indicated bad parity.
Public property | ModeSPIBadParityRatio | Gets or sets the %age of Mode-S messages with a PI field that had bad parity.
Public property | ModeSShortFrame | Gets or sets the number of short-frame Mode-S messages.
Public property | ModeSShortFrameUnusable | Gets or sets the number of short-frame Mode-S messages that VRS couldn't use.
Public property | ModeSShortFrameUnusableRatio | Gets or sets the %age of short-frame Mode-S messages that VRS couldn't use.
Public property | ModeSWithPI | Gets or sets the number of Mode-S messages that have a PI field, both long and short frame.
Public property | PositionsOutOfRange | Gets or sets the number of ADS-B position messages that were rejected because the position was out of range of the receiver.
Public property | PositionSpeedCheckExceeded | Gets or sets the number of ADS-B position messages that exceeded the ICAO speed check.
Public property | PositionsReset | Gets or sets the number of ADS-B position messages that triggered a position reset.
Public property | ReceiverBadChecksum | Gets or sets the number of messages from a receiver that adds a checksum during transmission which had a bad checksum.
Public property | ReceiverThroughput | Gets or sets the throughput from the receiver in KB/sec.
Public property | Statistics | Gets or sets the statistics object that the view will display.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | UpdateCounters | Refreshes the display of counters.
Top
Events
 | Name | Description
Public event | CloseClicked | Raised when the user closes the view.
Public event | ResetCountersClicked | Raised when the user wants to reset the counters.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IStatisticsView Properties

IStatisticsView Properties

The IStatisticsView type exposes the following members.

Properties
 | Name | Description
Public property | AdsbMessageFormatCount | Gets an array of counters of ADS-B messages against their message format.
Public property | AdsbMessages | Gets or sets the count of ADS-B messages seen.
Public property | AdsbMessageTypeCount | Gets an array of counters of ADS-B messages against their message type.
Public property | AdsbRejected | Gets or sets the count of ADS-B messages that were not used.
Public property | AdsbRejectedRatio | Gets or sets the %age of ADS-B messages that were rejected, either because of bad parity or settings.
Public property | BadlyFormedBaseStationMessages | Gets or sets the count of BaseStation messages that were badly formed.
Public property | BadlyFormedBaseStationMessagesRatio | Gets or sets the %age of BaseStation messages that were badly formed.
Public property | BaseStationMessages | Gets or sets the count of BaseStation messages received.
Public property | BytesReceived | Gets or sets the number of bytes received.
Public property | ConnectedDuration | Gets or sets the span of time that has elapsed since the user first connected.
Public property | CurrentBufferSize | Gets or sets the current buffer size.
Public property | ModeSDFCount | Gets an array of counters of Mode-S messages indexed by the message's DF.
Public property | ModeSLongFrame | Gets or sets the number of long-frame Mode-S messages.
Public property | ModeSMessageCount | Gets or sets the number of Mode-S messages seen.
Public property | ModeSNoAdsbPayload | Gets or sets the number of Mode-S messages that were not DF17.
Public property | ModeSNoAdsbPayloadRatio | Gets or sets the %age of Mode-S messages that were not DF17.
Public property | ModeSPIBadParity | Gets or sets the number of Mode-S messages with a PI field that indicated bad parity.
Public property | ModeSPIBadParityRatio | Gets or sets the %age of Mode-S messages with a PI field that had bad parity.
Public property | ModeSShortFrame | Gets or sets the number of short-frame Mode-S messages.
Public property | ModeSShortFrameUnusable | Gets or sets the number of short-frame Mode-S messages that VRS couldn't use.
Public property | ModeSShortFrameUnusableRatio | Gets or sets the %age of short-frame Mode-S messages that VRS couldn't use.
Public property | ModeSWithPI | Gets or sets the number of Mode-S messages that have a PI field, both long and short frame.
Public property | PositionsOutOfRange | Gets or sets the number of ADS-B position messages that were rejected because the position was out of range of the receiver.
Public property | PositionSpeedCheckExceeded | Gets or sets the number of ADS-B position messages that exceeded the ICAO speed check.
Public property | PositionsReset | Gets or sets the number of ADS-B position messages that triggered a position reset.
Public property | ReceiverBadChecksum | Gets or sets the number of messages from a receiver that adds a checksum during transmission which had a bad checksum.
Public property | ReceiverThroughput | Gets or sets the throughput from the receiver in KB/sec.
Public property | Statistics | Gets or sets the statistics object that the view will display.
Top
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.AdsbMessageFormatCount Property

IStatisticsViewAdsbMessageFormatCount Property
Gets an array of counters of ADS-B messages against their message format.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long[] AdsbMessageFormatCount { get; }
ReadOnly Property AdsbMessageFormatCount As Long()
    Get
property array<long long>^ AdsbMessageFormatCount {
    array<long long>^ get ();
}
abstract AdsbMessageFormatCount : int64[] with get

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.AdsbMessages Property

IStatisticsViewAdsbMessages Property
Gets or sets the count of ADS-B messages seen.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbMessages { get; set; }
Property AdsbMessages As Long
    Get
    Set
property long long AdsbMessages {
    long long get ();
    void set (long long value);
}
abstract AdsbMessages : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.AdsbMessageTypeCount Property

IStatisticsViewAdsbMessageTypeCount Property
Gets an array of counters of ADS-B messages against their message type.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long[] AdsbMessageTypeCount { get; }
ReadOnly Property AdsbMessageTypeCount As Long()
    Get
property array<long long>^ AdsbMessageTypeCount {
    array<long long>^ get ();
}
abstract AdsbMessageTypeCount : int64[] with get

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.AdsbRejected Property

IStatisticsViewAdsbRejected Property
Gets or sets the count of ADS-B messages that were not used.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long AdsbRejected { get; set; }
Property AdsbRejected As Long
    Get
    Set
property long long AdsbRejected {
    long long get ();
    void set (long long value);
}
abstract AdsbRejected : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.AdsbRejectedRatio Property

IStatisticsViewAdsbRejectedRatio Property
Gets or sets the %age of ADS-B messages that were rejected, either because of bad parity or settings.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double AdsbRejectedRatio { get; set; }
Property AdsbRejectedRatio As Double
    Get
    Set
property double AdsbRejectedRatio {
    double get ();
    void set (double value);
}
abstract AdsbRejectedRatio : float with get, set

Property Value

Type: Double
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.BadlyFormedBaseStationMessages Property

IStatisticsViewBadlyFormedBaseStationMessages Property
Gets or sets the count of BaseStation messages that were badly formed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BadlyFormedBaseStationMessages { get; set; }
Property BadlyFormedBaseStationMessages As Long
    Get
    Set
property long long BadlyFormedBaseStationMessages {
    long long get ();
    void set (long long value);
}
abstract BadlyFormedBaseStationMessages : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.BadlyFormedBaseStationMessagesRatio Property

IStatisticsViewBadlyFormedBaseStationMessagesRatio Property
Gets or sets the %age of BaseStation messages that were badly formed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double BadlyFormedBaseStationMessagesRatio { get; set; }
Property BadlyFormedBaseStationMessagesRatio As Double
    Get
    Set
property double BadlyFormedBaseStationMessagesRatio {
    double get ();
    void set (double value);
}
abstract BadlyFormedBaseStationMessagesRatio : float with get, set

Property Value

Type: Double
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.BaseStationMessages Property

IStatisticsViewBaseStationMessages Property
Gets or sets the count of BaseStation messages received.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BaseStationMessages { get; set; }
Property BaseStationMessages As Long
    Get
    Set
property long long BaseStationMessages {
    long long get ();
    void set (long long value);
}
abstract BaseStationMessages : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.BytesReceived Property

IStatisticsViewBytesReceived Property
Gets or sets the number of bytes received.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long BytesReceived { get; set; }
Property BytesReceived As Long
    Get
    Set
property long long BytesReceived {
    long long get ();
    void set (long long value);
}
abstract BytesReceived : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ConnectedDuration Property

IStatisticsViewConnectedDuration Property
Gets or sets the span of time that has elapsed since the user first connected.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
TimeSpan ConnectedDuration { get; set; }
Property ConnectedDuration As TimeSpan
    Get
    Set
property TimeSpan ConnectedDuration {
    TimeSpan get ();
    void set (TimeSpan value);
}
abstract ConnectedDuration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.CurrentBufferSize Property

IStatisticsViewCurrentBufferSize Property
Gets or sets the current buffer size.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long CurrentBufferSize { get; set; }
Property CurrentBufferSize As Long
    Get
    Set
property long long CurrentBufferSize {
    long long get ();
    void set (long long value);
}
abstract CurrentBufferSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSDFCount Property

IStatisticsViewModeSDFCount Property
Gets an array of counters of Mode-S messages indexed by the message's DF.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long[] ModeSDFCount { get; }
ReadOnly Property ModeSDFCount As Long()
    Get
property array<long long>^ ModeSDFCount {
    array<long long>^ get ();
}
abstract ModeSDFCount : int64[] with get

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSLongFrame Property

IStatisticsViewModeSLongFrame Property
Gets or sets the number of long-frame Mode-S messages.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSLongFrame { get; set; }
Property ModeSLongFrame As Long
    Get
    Set
property long long ModeSLongFrame {
    long long get ();
    void set (long long value);
}
abstract ModeSLongFrame : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSMessageCount Property

IStatisticsViewModeSMessageCount Property
Gets or sets the number of Mode-S messages seen.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSMessageCount { get; set; }
Property ModeSMessageCount As Long
    Get
    Set
property long long ModeSMessageCount {
    long long get ();
    void set (long long value);
}
abstract ModeSMessageCount : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSNoAdsbPayload Property

IStatisticsViewModeSNoAdsbPayload Property
Gets or sets the number of Mode-S messages that were not DF17.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSNoAdsbPayload { get; set; }
Property ModeSNoAdsbPayload As Long
    Get
    Set
property long long ModeSNoAdsbPayload {
    long long get ();
    void set (long long value);
}
abstract ModeSNoAdsbPayload : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSNoAdsbPayloadRatio Property

IStatisticsViewModeSNoAdsbPayloadRatio Property
Gets or sets the %age of Mode-S messages that were not DF17.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double ModeSNoAdsbPayloadRatio { get; set; }
Property ModeSNoAdsbPayloadRatio As Double
    Get
    Set
property double ModeSNoAdsbPayloadRatio {
    double get ();
    void set (double value);
}
abstract ModeSNoAdsbPayloadRatio : float with get, set

Property Value

Type: Double
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSPIBadParity Property

IStatisticsViewModeSPIBadParity Property
Gets or sets the number of Mode-S messages with a PI field that indicated bad parity.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSPIBadParity { get; set; }
Property ModeSPIBadParity As Long
    Get
    Set
property long long ModeSPIBadParity {
    long long get ();
    void set (long long value);
}
abstract ModeSPIBadParity : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSPIBadParityRatio Property

IStatisticsViewModeSPIBadParityRatio Property
Gets or sets the %age of Mode-S messages with a PI field that had bad parity.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double ModeSPIBadParityRatio { get; set; }
Property ModeSPIBadParityRatio As Double
    Get
    Set
property double ModeSPIBadParityRatio {
    double get ();
    void set (double value);
}
abstract ModeSPIBadParityRatio : float with get, set

Property Value

Type: Double
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSShortFrame Property

IStatisticsViewModeSShortFrame Property
Gets or sets the number of short-frame Mode-S messages.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSShortFrame { get; set; }
Property ModeSShortFrame As Long
    Get
    Set
property long long ModeSShortFrame {
    long long get ();
    void set (long long value);
}
abstract ModeSShortFrame : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSShortFrameUnusable Property

IStatisticsViewModeSShortFrameUnusable Property
Gets or sets the number of short-frame Mode-S messages that VRS couldn't use.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSShortFrameUnusable { get; set; }
Property ModeSShortFrameUnusable As Long
    Get
    Set
property long long ModeSShortFrameUnusable {
    long long get ();
    void set (long long value);
}
abstract ModeSShortFrameUnusable : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSShortFrameUnusableRatio Property

IStatisticsViewModeSShortFrameUnusableRatio Property
Gets or sets the %age of short-frame Mode-S messages that VRS couldn't use.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double ModeSShortFrameUnusableRatio { get; set; }
Property ModeSShortFrameUnusableRatio As Double
    Get
    Set
property double ModeSShortFrameUnusableRatio {
    double get ();
    void set (double value);
}
abstract ModeSShortFrameUnusableRatio : float with get, set

Property Value

Type: Double
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ModeSWithPI Property

IStatisticsViewModeSWithPI Property
Gets or sets the number of Mode-S messages that have a PI field, both long and short frame.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ModeSWithPI { get; set; }
Property ModeSWithPI As Long
    Get
    Set
property long long ModeSWithPI {
    long long get ();
    void set (long long value);
}
abstract ModeSWithPI : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.PositionsOutOfRange Property

IStatisticsViewPositionsOutOfRange Property
Gets or sets the number of ADS-B position messages that were rejected because the position was out of range of the receiver.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PositionsOutOfRange { get; set; }
Property PositionsOutOfRange As Long
    Get
    Set
property long long PositionsOutOfRange {
    long long get ();
    void set (long long value);
}
abstract PositionsOutOfRange : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.PositionSpeedCheckExceeded Property

IStatisticsViewPositionSpeedCheckExceeded Property
Gets or sets the number of ADS-B position messages that exceeded the ICAO speed check.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PositionSpeedCheckExceeded { get; set; }
Property PositionSpeedCheckExceeded As Long
    Get
    Set
property long long PositionSpeedCheckExceeded {
    long long get ();
    void set (long long value);
}
abstract PositionSpeedCheckExceeded : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.PositionsReset Property

IStatisticsViewPositionsReset Property
Gets or sets the number of ADS-B position messages that triggered a position reset.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long PositionsReset { get; set; }
Property PositionsReset As Long
    Get
    Set
property long long PositionsReset {
    long long get ();
    void set (long long value);
}
abstract PositionsReset : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ReceiverBadChecksum Property

IStatisticsViewReceiverBadChecksum Property
Gets or sets the number of messages from a receiver that adds a checksum during transmission which had a bad checksum.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ReceiverBadChecksum { get; set; }
Property ReceiverBadChecksum As Long
    Get
    Set
property long long ReceiverBadChecksum {
    long long get ();
    void set (long long value);
}
abstract ReceiverBadChecksum : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ReceiverThroughput Property

IStatisticsViewReceiverThroughput Property
Gets or sets the throughput from the receiver in KB/sec.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double ReceiverThroughput { get; set; }
Property ReceiverThroughput As Double
    Get
    Set
property double ReceiverThroughput {
    double get ();
    void set (double value);
}
abstract ReceiverThroughput : float with get, set

Property Value

Type: Double
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.Statistics Property

IStatisticsViewStatistics Property
Gets or sets the statistics object that the view will display.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStatistics Statistics { get; set; }
Property Statistics As IStatistics
    Get
    Set
property IStatistics^ Statistics {
    IStatistics^ get ();
    void set (IStatistics^ value);
}
abstract Statistics : IStatistics with get, set

Property Value

Type: IStatistics
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView Methods

IStatisticsView Methods

The IStatisticsView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user. (Inherited from IView.)
Public method | UpdateCounters | Refreshes the display of counters.
Top
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.UpdateCounters Method

IStatisticsViewUpdateCounters Method
Refreshes the display of counters.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateCounters()
Sub UpdateCounters
void UpdateCounters()
abstract UpdateCounters : unit -> unit
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView Events

IStatisticsView Events

The IStatisticsView type exposes the following members.

Events
 | Name | Description
Public event | CloseClicked | Raised when the user closes the view.
Public event | ResetCountersClicked | Raised when the user wants to reset the counters.
Top
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.CloseClicked Event

IStatisticsViewCloseClicked Event
Raised when the user closes the view.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CloseClicked
Event CloseClicked As EventHandler
 event EventHandler^ CloseClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CloseClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IStatisticsView.ResetCountersClicked Event

IStatisticsViewResetCountersClicked Event
Raised when the user wants to reset the counters.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ResetCountersClicked
Event ResetCountersClicked As EventHandler
 event EventHandler^ ResetCountersClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResetCountersClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IStatisticsView Interface
VirtualRadar.Interface.View Namespace


IValidateDelegate Interface

IValidateDelegate Interface
The interface for user controls that want to nominate which of their controls should have validation messages shown against it (as opposed to the validation message being shown against the user control itself).

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IValidateDelegate
Public Interface IValidateDelegate
public interface class IValidateDelegate
type IValidateDelegate =  interface end

The IValidateDelegate type exposes the following members.

Methods
 | Name | Description
Public method | GetValidationDisplayControl | Returns the control to display validation messages against.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IValidateDelegate Methods

IValidateDelegate Methods

The IValidateDelegate type exposes the following members.

Methods
 | Name | Description
Public method | GetValidationDisplayControl | Returns the control to display validation messages against.
Top
See Also

Reference

IValidateDelegate Interface
VirtualRadar.Interface.View Namespace


IValidateDelegate.GetValidationDisplayControl Method

IValidateDelegateGetValidationDisplayControl Method
Returns the control to display validation messages against.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Control GetValidationDisplayControl(
    ErrorProvider errorProvider
)
Function GetValidationDisplayControl (
    errorProvider As ErrorProvider
) As Control
Control^ GetValidationDisplayControl(
    ErrorProvider^ errorProvider
)
abstract GetValidationDisplayControl :
        errorProvider : ErrorProvider -> Control

Parameters

errorProvider
Type: System.Windows.FormsErrorProvider

Return Value

Type: Control
See Also

Reference

IValidateDelegate Interface
VirtualRadar.Interface.View Namespace


IValidateView Interface

IValidateView Interface
The interface for views that can display validation results.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IValidateView
Public Interface IValidateView
public interface class IValidateView
type IValidateView =  interface end

The IValidateView type exposes the following members.

Methods
 | Name | Description
Public method | ShowValidationResults | Displays the results of the validation of input to the user.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IValidateView Methods

IValidateView Methods

The IValidateView type exposes the following members.

Methods
 | Name | Description
Public method | ShowValidationResults | Displays the results of the validation of input to the user.
Top
See Also

Reference

IValidateView Interface
VirtualRadar.Interface.View Namespace


IValidateView.ShowValidationResults Method

IValidateViewShowValidationResults Method
Displays the results of the validation of input to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowValidationResults(
    ValidationResults results
)
Sub ShowValidationResults (
    results As ValidationResults
)
void ShowValidationResults(
    ValidationResults^ results
)
abstract ShowValidationResults :
        results : ValidationResults -> unit

Parameters

results
Type: VirtualRadar.Interface.ViewValidationResults
An object describing all of the results of a validation.
See Also

Reference

IValidateView Interface
VirtualRadar.Interface.View Namespace


IView Interface

IView Interface
The interface that all views must implement.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IView : IDisposable
Public Interface IView
    Inherits IDisposable
public interface class IView : IDisposable
type IView =
    interface
        interface IDisposable
    end

The IView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user.
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


IView Methods

IView Methods

The IView type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ShowView | Displays the view to the user.
Top
See Also

Reference

IView Interface
VirtualRadar.Interface.View Namespace


IView.ShowView Method

IViewShowView Method
Displays the view to the user.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ShowView()
Function ShowView As DialogResult
DialogResult ShowView()
abstract ShowView : unit -> DialogResult

Return Value

Type: DialogResult
See Also

Reference

IView Interface
VirtualRadar.Interface.View Namespace


ReceiverClass Enumeration

ReceiverClass Enumeration
An enumeration of the different classes of receiver that the receiver configuration wizard can collect information about.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReceiverClass
Public Enumeration ReceiverClass
public enum class ReceiverClass
type ReceiverClass
Members
Member name | Value | Description
SoftwareDefinedRadio | 0 | The receiver is a software defined radio, aka an SDR.
DedicatedHardware | 1 | The receiver is a dedicated lump of hardware that was built to pick up Mode-S transmissions.
See Also

Reference

VirtualRadar.Interface.View Namespace


SdrDecoder Enumeration

SdrDecoder Enumeration
An enumeration of the SDR decoders that the receiver configuration wizard knows about.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SdrDecoder
Public Enumeration SdrDecoder
public enum class SdrDecoder
type SdrDecoder
Members
Member name | Value | Description
AdsbSharp | 0 | The user is using ADSBSharp.
Dump1090 | 1 | The user is using dump1090.
GrAirModes | 2 | The user is using gr-air-modes.
Modesdeco | 3 | The user is using modesdeco.
Rtl1090 | 4 | The user is using RTL1090.
FR24Feeder | 5 | The user is using FR24 Feeder.
Other | 6 | The user is using something we don't know about.
See Also

Reference

VirtualRadar.Interface.View Namespace


ServerRequest Class

ServerRequest Class
A DTO class that carries information about a web server request.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewServerRequest

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerRequest
Public Class ServerRequest
public ref class ServerRequest
type ServerRequest =  class end

The ServerRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ServerRequest | Initializes a new instance of the ServerRequest class
Top
Properties
 | Name | Description
Public property | BytesSent | Gets or sets the number of bytes sent to the RemoteEndPoint.
Public property | DataVersion | Gets or sets a value that is incremented any time there is a change of value for the feed.
Public property | LastRequest | Gets or sets the date and time of the last request made from the RemoteEndPoint.
Public property | LastUrl | Gets or sets the last URL served to the RemoteEndPoint.
Public property | RemoteAddress | Gets the address of the machine that made the request.
Public property | RemoteEndPoint | Gets or sets the remote endpoint IP address.
Public property | RemotePort | Gets the port that the response is to go to.
Public property | UserName | Gets or sets the name of the user that is making the request, if any. Null if anonymous.
Top
Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ServerRequest Constructor

ServerRequest Constructor
Initializes a new instance of the ServerRequest class

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerRequest()
Public Sub New
public:
ServerRequest()
new : unit -> ServerRequest
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest Properties

ServerRequest Properties

The ServerRequest type exposes the following members.

Properties
 | Name | Description
Public property | BytesSent | Gets or sets the number of bytes sent to the RemoteEndPoint.
Public property | DataVersion | Gets or sets a value that is incremented any time there is a change of value for the feed.
Public property | LastRequest | Gets or sets the date and time of the last request made from the RemoteEndPoint.
Public property | LastUrl | Gets or sets the last URL served to the RemoteEndPoint.
Public property | RemoteAddress | Gets the address of the machine that made the request.
Public property | RemoteEndPoint | Gets or sets the remote endpoint IP address.
Public property | RemotePort | Gets the port that the response is to go to.
Public property | UserName | Gets or sets the name of the user that is making the request, if any. Null if anonymous.
Top
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.BytesSent Property

ServerRequestBytesSent Property
Gets or sets the number of bytes sent to the RemoteEndPoint.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long BytesSent { get; set; }
Public Property BytesSent As Long
    Get
    Set
public:
property long long BytesSent {
    long long get ();
    void set (long long value);
}
member BytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.DataVersion Property

ServerRequestDataVersion Property
Gets or sets a value that is incremented any time there is a change of value for the feed.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DataVersion { get; set; }
Public Property DataVersion As Long
    Get
    Set
public:
property long long DataVersion {
    long long get ();
    void set (long long value);
}
member DataVersion : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.LastRequest Property

ServerRequestLastRequest Property
Gets or sets the date and time of the last request made from the RemoteEndPoint.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastRequest { get; set; }
Public Property LastRequest As DateTime
    Get
    Set
public:
property DateTime LastRequest {
    DateTime get ();
    void set (DateTime value);
}
member LastRequest : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.LastUrl Property

ServerRequestLastUrl Property
Gets or sets the last URL served to the RemoteEndPoint.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LastUrl { get; set; }
Public Property LastUrl As String
    Get
    Set
public:
property String^ LastUrl {
    String^ get ();
    void set (String^ value);
}
member LastUrl : string with get, set

Property Value

Type: String
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.RemoteAddress Property

ServerRequestRemoteAddress Property
Gets the address of the machine that made the request.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RemoteAddress { get; }
Public ReadOnly Property RemoteAddress As String
    Get
public:
property String^ RemoteAddress {
    String^ get ();
}
member RemoteAddress : string with get

Property Value

Type: String
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.RemoteEndPoint Property

ServerRequestRemoteEndPoint Property
Gets or sets the remote endpoint IP address.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPEndPoint RemoteEndPoint { get; set; }
Public Property RemoteEndPoint As IPEndPoint
    Get
    Set
public:
property IPEndPoint^ RemoteEndPoint {
    IPEndPoint^ get ();
    void set (IPEndPoint^ value);
}
member RemoteEndPoint : IPEndPoint with get, set

Property Value

Type: IPEndPoint
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.RemotePort Property

ServerRequestRemotePort Property
Gets the port that the response is to go to.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RemotePort { get; }
Public ReadOnly Property RemotePort As Integer
    Get
public:
property int RemotePort {
    int get ();
}
member RemotePort : int with get

Property Value

Type: Int32
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.UserName Property

ServerRequestUserName Property
Gets or sets the name of the user that is making the request, if any. Null if anonymous.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest Methods

ServerRequest Methods

The ServerRequest type exposes the following members.

Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.Clone Method

ServerRequestClone Method
See interface docs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
Object^ Clone()
member Clone : unit -> Object

Return Value

Type: Object
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ServerRequest.ToString Method

ServerRequestToString Method
See base docs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ServerRequest Class
VirtualRadar.Interface.View Namespace


ValidationField Enumeration

ValidationField Enumeration
An enumeration of fields that are subject to validation.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ValidationField
Public Enumeration ValidationField
public enum class ValidationField
type ValidationField
Members
Member name | Value | Description
None | 0 | No field defined.
BaseStationAddress | 1 | The IP address of an instance of BaseStation.
BaseStationPort | 2 | The port number of an instance of BaseStation.
BaseStationDatabase | 3 | The full path to a database file that conforms with the de-facto standard for aircraft information as used by Kinetic.
Enabled | 4 | A value indicating whether something has been enabled or not.
EndDate | 5 | End date.
FlagsFolder | 6 | The full path to the folder containing operator flag images.
InitialGoogleMapRefreshSeconds | 7 | The initial number of seconds between refreshes of the Google Map aircraft list.
MinimumGoogleMapRefreshSeconds | 8 | The minimum number of seconds between refreshes of the Google Map aircraft list.
PicturesFolder | 9 | The full path to the folder containing pictures of aircraft.
SilhouettesFolder | 10 | The full path to the folder containing silhouette images of aircraft.
WebUserName | 11 | The name of the user that browser must send when authenticating.
Location | 12 | The location of a receiver.
Latitude | 13 | The latitude portion of a location.
Longitude | 14 | The longitude portion of a location.
RebroadcastServerPort | 15 | The port number for a rebroadcast server.
ReceiverRange | 16 | The distance in kilometres over which a receiver can pick up messages.
AirborneGlobalPositionLimit | 17 | The time that can elapse between odd/even format CPR messages for global airborne position decoding.
FastSurfaceGlobalPositionLimit | 18 | The time that can elapse between odd/even format CPR messages for global fast surface vehicle position decoding.
SlowSurfaceGlobalPositionLimit | 19 | The time that can elapse between odd/even format CPR messages for global slow surface vehicle position decoding.
AcceptableAirborneLocalPositionSpeed | 20 | The highest speed in km/30 seconds allowable in the local decoding sanity check for airborne aircraft.
AcceptableTransitionLocalPositionSpeed | 21 | The highest speed in km/30 seconds allowable in the local decoding sanity check for aircraft taking off or landing.
AcceptableSurfaceLocalPositionSpeed | 22 | The highest speed in km/30 seconds allowable in the local decoding sanity check for surface vehicles.
UPnpPortNumber | 23 | The port number that UPnP will assign to VRS.
InternetUserIdleTimeout | 24 | The number of idle minutes allowed to an Internet user before the site times out.
GoogleMapZoomLevel | 25 | The initial zoom level for a Google map.
CheckForNewVersions | 26 | The number of days between version checks.
DisplayTimeout | 27 | The number of seconds after loss of signal before the aircraft is removed from the map.
TrackingTimeout | 28 | The number of seconds after loss of signal before the aircraft is removed from the aircraft list.
SatcomDisplayTimeout | 29 | The number of seconds after loss of signal before a satellite feed aircraft is removed from the map.
SatcomTrackingTimeout | 30 | The number of seconds after loss of signal before a satellite feed aircraft is removed from the aircraft list.
ShortTrailLength | 31 | The number of seconds a short trail lasts for.
TextToSpeechSpeed | 32 | The speed at which text converted to speech is read out.
ComPort | 33 | The COM port that a serial device is connected to.
BaudRate | 34 | The baud rate used on a COM port.
DataBits | 35 | The data bits used on a COM port.
Name | 36 | A name or description.
Format | 37 | A format.
AcceptIcaoInNonPICount | 38 | A count of Mode-S messages that do not carry PI.
AcceptIcaoInNonPISeconds | 39 | A number of seconds of Mode-S messages that do not carry PI.
AcceptIcaoInPI0Count | 40 | A count of Mode-S messages that carry PI.
AcceptIcaoInPI0Seconds | 41 | A number of seconds of Mode-S messages that carry PI.
SiteRootFolder | 42 | The root folder of the site to serve.
ResourceImagesFolder | 43 | The folder that contains copies or alternate versions of the resource images.
PathAndFile | 44 | A path and file to a page.
RebroadcastReceiver | 45 | The receiver used by a rebroadcast server.
WebSiteReceiver | 46 | The receiver shown via the web site.
ClosestAircraftReceiver | 47 | The receiver that the Closest Aircraft desktop widget will use.
FlightSimulatorXReceiver | 48 | The receiver that drives some FSX features.
IcaoTimeout | 49 | The period of time that can elapse before a receiver is no longer considered to be the main source of messages for an ICAO.
ReceiverIds | 50 | A collection of receivers.
StaleSeconds | 51 | The duration before a message is discarded from a rebroadcast server buffer.
LoginName | 52 | The login name for a user account.
Password | 53 | The password for a user account.
IdleTimeout | 54 | The idle timeout.
UseKeepAlive | 55 | Whether to use keep-alive packets on a connection.
IsTransmitter | 56 | Indicates whether a rebroadcast server is in transmit mode.
IsPassive | 57 | Indicates whether a receiver is in passive mode,
AutoSavePolarPlots | 58 | The auto-save polar plots field.
ExportedSettings | 59 | The field that accepts exported settings from the web site.
SendInterval | 60 | The interval between sends.
AllowCorsDomains | 61 |
See Also

Reference

VirtualRadar.Interface.View Namespace


ValidationModelField Class

ValidationModelField Class
An object that can carry validation information in view models for web interfaces.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewValidationModelField

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValidationModelField
Public Class ValidationModelField
public ref class ValidationModelField
type ValidationModelField =  class end

The ValidationModelField type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationModelField | Creates a new object.
Top
Properties
 | Name | Description
Public property | IsError | Gets a value indicating that the message is an error.
Public property | IsValid | Gets a value indicating that the value is valid.
Public property | IsWarning | Gets or sets a value indicating that the message is a warning.
Public property | Message | Gets or sets the validation message.
Top
Methods
 | Name | Description
Public method | Clear | Clears the message.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMessage | Sets the message and associated flags.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ValidationModelField Constructor

ValidationModelField Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationModelField()
Public Sub New
public:
ValidationModelField()
new : unit -> ValidationModelField
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField Properties

ValidationModelField Properties

The ValidationModelField type exposes the following members.

Properties
 | Name | Description
Public property | IsError | Gets a value indicating that the message is an error.
Public property | IsValid | Gets a value indicating that the value is valid.
Public property | IsWarning | Gets or sets a value indicating that the message is a warning.
Public property | Message | Gets or sets the validation message.
Top
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField.IsError Property

ValidationModelFieldIsError Property
Gets a value indicating that the message is an error.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsError { get; }
Public ReadOnly Property IsError As Boolean
    Get
public:
property bool IsError {
    bool get ();
}
member IsError : bool with get

Property Value

Type: Boolean
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField.IsValid Property

ValidationModelFieldIsValid Property
Gets a value indicating that the value is valid.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField.IsWarning Property

ValidationModelFieldIsWarning Property
Gets or sets a value indicating that the message is a warning.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWarning { get; set; }
Public Property IsWarning As Boolean
    Get
    Set
public:
property bool IsWarning {
    bool get ();
    void set (bool value);
}
member IsWarning : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField.Message Property

ValidationModelFieldMessage Property
Gets or sets the validation message.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField Methods

ValidationModelField Methods

The ValidationModelField type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the message.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMessage | Sets the message and associated flags.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField.Clear Method

ValidationModelFieldClear Method
Clears the message.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelField.SetMessage Method

ValidationModelFieldSetMessage Method
Sets the message and associated flags.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMessage(
    string message,
    bool isWarning
)
Public Sub SetMessage (
    message As String,
    isWarning As Boolean
)
public:
void SetMessage(
    String^ message,
    bool isWarning
)
member SetMessage :
        message : string *
        isWarning : bool -> unit

Parameters

message
Type: SystemString
isWarning
Type: SystemBoolean
See Also

Reference

ValidationModelField Class
VirtualRadar.Interface.View Namespace


ValidationModelFieldAttribute Class

ValidationModelFieldAttribute Class
Used to decorate ValidationFieldModel properties in a view model with the ValidationField corresponding to the property.
Inheritance Hierarchy
SystemObject
SystemAttribute
VirtualRadar.Interface.ViewValidationModelFieldAttribute

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValidationModelFieldAttribute : Attribute
Public Class ValidationModelFieldAttribute
    Inherits Attribute
public ref class ValidationModelFieldAttribute : public Attribute
type ValidationModelFieldAttribute =
    class
        inherit Attribute
    end

The ValidationModelFieldAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationModelFieldAttribute | Creates a new object.
Top
Properties
 | Name | Description
Public property | Field | Gets the field corresponding to the property.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ValidationModelFieldAttribute Constructor

ValidationModelFieldAttribute Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationModelFieldAttribute(
    ValidationField field
)
Public Sub New (
    field As ValidationField
)
public:
ValidationModelFieldAttribute(
    ValidationField field
)
new :
        field : ValidationField -> ValidationModelFieldAttribute

Parameters

field
Type: VirtualRadar.Interface.ViewValidationField
See Also

Reference

ValidationModelFieldAttribute Class
VirtualRadar.Interface.View Namespace


ValidationModelFieldAttribute Properties

ValidationModelFieldAttribute Properties

The ValidationModelFieldAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets the field corresponding to the property.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ValidationModelFieldAttribute Class
VirtualRadar.Interface.View Namespace


ValidationModelFieldAttribute.Field Property

ValidationModelFieldAttributeField Property
Gets the field corresponding to the property.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationField Field { get; }
Public ReadOnly Property Field As ValidationField
    Get
public:
property ValidationField Field {
    ValidationField get ();
}
member Field : ValidationField with get

Property Value

Type: ValidationField
See Also

Reference

ValidationModelFieldAttribute Class
VirtualRadar.Interface.View Namespace


ValidationModelFieldAttribute Methods

ValidationModelFieldAttribute Methods

The ValidationModelFieldAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValidationModelFieldAttribute Class
VirtualRadar.Interface.View Namespace


ValidationModelHelper Class

ValidationModelHelper Class
A class that can help with copying validation results from a presenter to a web form view model.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewValidationModelHelper

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValidationModelHelper
Public Class ValidationModelHelper
public ref class ValidationModelHelper
type ValidationModelHelper =  class end

The ValidationModelHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationModelHelper | Creates a new object.
Public method | ValidationModelHelper(FuncValidationResult, Object) | Creates a new object.
Top
Properties
 | Name | Description
Public property | FindViewModelForRecord | Gets the method that can convert from a ValidationResult.Record object to a view model object.
Top
Methods
 | Name | Description
Public method | ApplyValidationResults | Applies the validation results to the view model.
 | CreateEmptyViewModelValidationFields | Creates empty ValidationModelField objects in the view model passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ValidationModelHelper Constructor

ValidationModelHelper Constructor
Overload List
 | Name | Description
Public method | ValidationModelHelper | Creates a new object.
Public method | ValidationModelHelper(FuncValidationResult, Object) | Creates a new object.
Top
See Also

Reference

ValidationModelHelper Class
VirtualRadar.Interface.View Namespace


ValidationModelHelper Constructor

ValidationModelHelper Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationModelHelper()
Public Sub New
public:
ValidationModelHelper()
new : unit -> ValidationModelHelper
See Also

Reference

ValidationModelHelper Class
ValidationModelHelper Overload
VirtualRadar.Interface.View Namespace


ValidationModelHelper Constructor (Func(ValidationResult, Object))

ValidationModelHelper Constructor (FuncValidationResult, Object)
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationModelHelper(
    Func<ValidationResult, Object> findViewModelForRecord
)
Public Sub New (
    findViewModelForRecord As Func(Of ValidationResult, Object)
)
public:
ValidationModelHelper(
    Func<ValidationResult^, Object^>^ findViewModelForRecord
)
new :
        findViewModelForRecord : Func<ValidationResult, Object> -> ValidationModelHelper

Parameters

findViewModelForRecord
Type: SystemFunc ValidationResult, Object
See Also

Reference

ValidationModelHelper Class
ValidationModelHelper Overload
VirtualRadar.Interface.View Namespace


ValidationModelHelper Properties

ValidationModelHelper Properties

The ValidationModelHelper type exposes the following members.

Properties
 | Name | Description
Public property | FindViewModelForRecord | Gets the method that can convert from a ValidationResult.Record object to a view model object.
Top
See Also

Reference

ValidationModelHelper Class
VirtualRadar.Interface.View Namespace


ValidationModelHelper.FindViewModelForRecord Property

ValidationModelHelperFindViewModelForRecord Property
Gets the method that can convert from a ValidationResult.Record object to a view model object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<ValidationResult, Object> FindViewModelForRecord { get; }
Public ReadOnly Property FindViewModelForRecord As Func(Of ValidationResult, Object)
    Get
public:
property Func<ValidationResult^, Object^>^ FindViewModelForRecord {
    Func<ValidationResult^, Object^>^ get ();
}
member FindViewModelForRecord : Func<ValidationResult, Object> with get

Property Value

Type: Func ValidationResult, Object
Remarks
This is only required if the presenter returns ValidationResults that use the Record property.
See Also

Reference

ValidationModelHelper Class
VirtualRadar.Interface.View Namespace


ValidationModelHelper Methods

ValidationModelHelper Methods

The ValidationModelHelper type exposes the following members.

Methods
 | Name | Description
Public method | ApplyValidationResults | Applies the validation results to the view model.
 | CreateEmptyViewModelValidationFields | Creates empty ValidationModelField objects in the view model passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValidationModelHelper Class
VirtualRadar.Interface.View Namespace


ValidationModelHelper.ApplyValidationResults Method

ValidationModelHelperApplyValidationResults Method
Applies the validation results to the view model.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyValidationResults(
    ValidationResults validationResults,
    Object viewModelRoot
)
Public Sub ApplyValidationResults (
    validationResults As ValidationResults,
    viewModelRoot As Object
)
public:
void ApplyValidationResults(
    ValidationResults^ validationResults,
    Object^ viewModelRoot
)
member ApplyValidationResults :
        validationResults : ValidationResults *
        viewModelRoot : Object -> unit

Parameters

validationResults
Type: VirtualRadar.Interface.ViewValidationResults
viewModelRoot
Type: SystemObject
See Also

Reference

ValidationModelHelper Class
VirtualRadar.Interface.View Namespace


ValidationModelHelper.CreateEmptyViewModelValidationFields Method

ValidationModelHelperCreateEmptyViewModelValidationFields Method
Creates empty ValidationModelField objects in the view model passed across.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateEmptyViewModelValidationFields(
    Object viewModel
)
Public Shared Sub CreateEmptyViewModelValidationFields (
    viewModel As Object
)
public:
static void CreateEmptyViewModelValidationFields(
    Object^ viewModel
)
static member CreateEmptyViewModelValidationFields :
        viewModel : Object -> unit

Parameters

viewModel
Type: SystemObject
See Also

Reference

ValidationModelHelper Class
VirtualRadar.Interface.View Namespace


ValidationResult Class

ValidationResult Class
Describes the result of the validation of a single field.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewValidationResult

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValidationResult
Public Class ValidationResult
public ref class ValidationResult
type ValidationResult =  class end

The ValidationResult type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationResult | Creates a new object.
Public method | ValidationResult(ValidationField, String) | Creates a new object.
Public method | ValidationResult(Object, ValidationField, String) | Creates a new object.
Public method | ValidationResult(ValidationField, String, Boolean) | Creates a new object.
Public method | ValidationResult(Object, ValidationField, String, Boolean) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Field | Gets or sets the field that has failed validation.
Public property | IsWarning | Gets or sets a value indicating that the validation result represents a warning to the user that they can ignore if they so wish, as opposed to an error that must be corrected before the input can be accepted.
Public property | Message | Gets or sets the message describing the problem with the field's content.
Public property | Record | Gets or sets the object that this result applies to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Displays an English description of the validation result. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ValidationResult Constructor

ValidationResult Constructor
Overload List
 | Name | Description
Public method | ValidationResult | Creates a new object.
Public method | ValidationResult(ValidationField, String) | Creates a new object.
Public method | ValidationResult(Object, ValidationField, String) | Creates a new object.
Public method | ValidationResult(ValidationField, String, Boolean) | Creates a new object.
Public method | ValidationResult(Object, ValidationField, String, Boolean) | Creates a new object.
Top
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult Constructor

ValidationResult Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult()
Public Sub New
public:
ValidationResult()
new : unit -> ValidationResult
See Also

Reference

ValidationResult Class
ValidationResult Overload
VirtualRadar.Interface.View Namespace


ValidationResult Constructor (ValidationField, String)

ValidationResult Constructor (ValidationField, String)
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult(
    ValidationField field,
    string message
)
Public Sub New (
    field As ValidationField,
    message As String
)
public:
ValidationResult(
    ValidationField field,
    String^ message
)
new :
        field : ValidationField *
        message : string -> ValidationResult

Parameters

field
Type: VirtualRadar.Interface.ViewValidationField
message
Type: SystemString
See Also

Reference

ValidationResult Class
ValidationResult Overload
VirtualRadar.Interface.View Namespace


ValidationResult Constructor (Object, ValidationField, String)

ValidationResult Constructor (Object, ValidationField, String)
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult(
    Object record,
    ValidationField field,
    string message
)
Public Sub New (
    record As Object,
    field As ValidationField,
    message As String
)
public:
ValidationResult(
    Object^ record,
    ValidationField field,
    String^ message
)
new :
        record : Object *
        field : ValidationField *
        message : string -> ValidationResult

Parameters

record
Type: SystemObject
field
Type: VirtualRadar.Interface.ViewValidationField
message
Type: SystemString
See Also

Reference

ValidationResult Class
ValidationResult Overload
VirtualRadar.Interface.View Namespace


ValidationResult Constructor (ValidationField, String, Boolean)

ValidationResult Constructor (ValidationField, String, Boolean)
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult(
    ValidationField field,
    string message,
    bool isWarning
)
Public Sub New (
    field As ValidationField,
    message As String,
    isWarning As Boolean
)
public:
ValidationResult(
    ValidationField field,
    String^ message,
    bool isWarning
)
new :
        field : ValidationField *
        message : string *
        isWarning : bool -> ValidationResult

Parameters

field
Type: VirtualRadar.Interface.ViewValidationField
message
Type: SystemString
isWarning
Type: SystemBoolean
See Also

Reference

ValidationResult Class
ValidationResult Overload
VirtualRadar.Interface.View Namespace


ValidationResult Constructor (Object, ValidationField, String, Boolean)

ValidationResult Constructor (Object, ValidationField, String, Boolean)
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult(
    Object record,
    ValidationField field,
    string message,
    bool isWarning
)
Public Sub New (
    record As Object,
    field As ValidationField,
    message As String,
    isWarning As Boolean
)
public:
ValidationResult(
    Object^ record,
    ValidationField field,
    String^ message,
    bool isWarning
)
new :
        record : Object *
        field : ValidationField *
        message : string *
        isWarning : bool -> ValidationResult

Parameters

record
Type: SystemObject
field
Type: VirtualRadar.Interface.ViewValidationField
message
Type: SystemString
isWarning
Type: SystemBoolean
See Also

Reference

ValidationResult Class
ValidationResult Overload
VirtualRadar.Interface.View Namespace


ValidationResult Properties

ValidationResult Properties

The ValidationResult type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets or sets the field that has failed validation.
Public property | IsWarning | Gets or sets a value indicating that the validation result represents a warning to the user that they can ignore if they so wish, as opposed to an error that must be corrected before the input can be accepted.
Public property | Message | Gets or sets the message describing the problem with the field's content.
Public property | Record | Gets or sets the object that this result applies to.
Top
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult.Field Property

ValidationResultField Property
Gets or sets the field that has failed validation.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationField Field { get; set; }
Public Property Field As ValidationField
    Get
    Set
public:
property ValidationField Field {
    ValidationField get ();
    void set (ValidationField value);
}
member Field : ValidationField with get, set

Property Value

Type: ValidationField
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult.IsWarning Property

ValidationResultIsWarning Property
Gets or sets a value indicating that the validation result represents a warning to the user that they can ignore if they so wish, as opposed to an error that must be corrected before the input can be accepted.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWarning { get; set; }
Public Property IsWarning As Boolean
    Get
    Set
public:
property bool IsWarning {
    bool get ();
    void set (bool value);
}
member IsWarning : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult.Message Property

ValidationResultMessage Property
Gets or sets the message describing the problem with the field's content.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult.Record Property

ValidationResultRecord Property
Gets or sets the object that this result applies to.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Record { get; set; }
Public Property Record As Object
    Get
    Set
public:
property Object^ Record {
    Object^ get ();
    void set (Object^ value);
}
member Record : Object with get, set

Property Value

Type: Object
Remarks
This property is optional - it is only required if the validation result could apply to more than one object being validated.
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult Methods

ValidationResult Methods

The ValidationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Displays an English description of the validation result. (Overrides ObjectToString.)
Top
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResult.ToString Method

ValidationResultToString Method
Displays an English description of the validation result.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ValidationResult Class
VirtualRadar.Interface.View Namespace


ValidationResults Class

ValidationResults Class
Describes the results of the validation of an entire form or a single field.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.ViewValidationResults

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValidationResults
Public Class ValidationResults
public ref class ValidationResults
type ValidationResults =  class end

The ValidationResults type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationResults | Creates a new object.
Top
Properties
 | Name | Description
Public property | Errors | Gets an array of all of the errors from Results.
Public property | HasErrors | Gets a value indicating whether Results contains any errors.
Public property | HasWarnings | Gets a value indicating that Results contains at least one warning.
Public property | IsPartialValidation | Gets a value indicating that validation was only run over a subset of all available fields.
Public property | PartialValidationFields | Gets a collection of validation results that indicate the records and fields that were examined in a partial validation. The content of this collection is undefined when IsPartialValidation is false.
Public property | Results | Gets a collection of every error and warning found.
Public property | Warnings | Gets an array of all of the warnings found in Results.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.View Namespace


ValidationResults Constructor

ValidationResults Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResults(
    bool isPartialValidation
)
Public Sub New (
    isPartialValidation As Boolean
)
public:
ValidationResults(
    bool isPartialValidation
)
new :
        isPartialValidation : bool -> ValidationResults

Parameters

isPartialValidation
Type: SystemBoolean
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults Properties

ValidationResults Properties

The ValidationResults type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets an array of all of the errors from Results.
Public property | HasErrors | Gets a value indicating whether Results contains any errors.
Public property | HasWarnings | Gets a value indicating that Results contains at least one warning.
Public property | IsPartialValidation | Gets a value indicating that validation was only run over a subset of all available fields.
Public property | PartialValidationFields | Gets a collection of validation results that indicate the records and fields that were examined in a partial validation. The content of this collection is undefined when IsPartialValidation is false.
Public property | Results | Gets a collection of every error and warning found.
Public property | Warnings | Gets an array of all of the warnings found in Results.
Top
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.Errors Property

ValidationResultsErrors Property
Gets an array of all of the errors from Results.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult[] Errors { get; }
Public ReadOnly Property Errors As ValidationResult()
    Get
public:
property array<ValidationResult^>^ Errors {
    array<ValidationResult^>^ get ();
}
member Errors : ValidationResult[] with get

Property Value

Type: ValidationResult
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.HasErrors Property

ValidationResultsHasErrors Property
Gets a value indicating whether Results contains any errors.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get
public:
property bool HasErrors {
    bool get ();
}
member HasErrors : bool with get

Property Value

Type: Boolean
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.HasWarnings Property

ValidationResultsHasWarnings Property
Gets a value indicating that Results contains at least one warning.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasWarnings { get; }
Public ReadOnly Property HasWarnings As Boolean
    Get
public:
property bool HasWarnings {
    bool get ();
}
member HasWarnings : bool with get

Property Value

Type: Boolean
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.IsPartialValidation Property

ValidationResultsIsPartialValidation Property
Gets a value indicating that validation was only run over a subset of all available fields.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPartialValidation { get; }
Public ReadOnly Property IsPartialValidation As Boolean
    Get
public:
property bool IsPartialValidation {
    bool get ();
}
member IsPartialValidation : bool with get

Property Value

Type: Boolean
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.PartialValidationFields Property

ValidationResultsPartialValidationFields Property
Gets a collection of validation results that indicate the records and fields that were examined in a partial validation. The content of this collection is undefined when IsPartialValidation is false.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ValidationResult> PartialValidationFields { get; }
Public ReadOnly Property PartialValidationFields As List(Of ValidationResult)
    Get
public:
property List<ValidationResult^>^ PartialValidationFields {
    List<ValidationResult^>^ get ();
}
member PartialValidationFields : List<ValidationResult> with get

Property Value

Type: List ValidationResult
Remarks
Only the Record and Field properties are set on the validation results held here.
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.Results Property

ValidationResultsResults Property
Gets a collection of every error and warning found.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ValidationResult> Results { get; }
Public ReadOnly Property Results As List(Of ValidationResult)
    Get
public:
property List<ValidationResult^>^ Results {
    List<ValidationResult^>^ get ();
}
member Results : List<ValidationResult> with get

Property Value

Type: List ValidationResult
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.Warnings Property

ValidationResultsWarnings Property
Gets an array of all of the warnings found in Results.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationResult[] Warnings { get; }
Public ReadOnly Property Warnings As ValidationResult()
    Get
public:
property array<ValidationResult^>^ Warnings {
    array<ValidationResult^>^ get ();
}
member Warnings : ValidationResult[] with get

Property Value

Type: ValidationResult
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults Methods

ValidationResults Methods

The ValidationResults type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


ValidationResults.ToString Method

ValidationResultsToString Method
See base docs.

Namespace: VirtualRadar.Interface.View
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ValidationResults Class
VirtualRadar.Interface.View Namespace


VirtualRadar.Interface.WebServer Namespace

VirtualRadar.Interface.WebServer Namespace
The namespace for the interfaces and objects that deal with the application's web server.
Classes
 | Class | Description
Public class | AuthenticationRequiredEventArgs | The EventArgs raised by the IWebServer.AuthenticationRequired event.
Public class | MimeType | A collection of different mime types.
Public class | RequestException | An exception that is thrown when an exception occurs during the handling of a web server request.
Public class | RequestReceivedEventArgs | The arguments passed for the RequestReceived event on IWebServer.
Public class | ResponseSentEventArgs | The event args for IWebServer events that are raised when a response is sent to a web browser.
Interfaces
 | Interface | Description
Public interface | IAutoConfigWebServer | The interface for a singleton object that automatically applies configuration settings to an IWebServer.
Public interface | IContext | The interface for objects that describe an incoming request and the response that will be made for it.
Public interface | IPortMapping | The interface for objects that describe a static port mapping on a UPnP router.
Public interface | IRequest | The interface for objects that describe an incoming request.
Public interface | IResponder | The interface for objects that can fill IResponse objects correctly for different types of content.
Public interface | IResponse | The interface for objects that describe the response to a request.
Public interface | IUniversalPlugAndPlayManager | The interface for the object that deals with UPnP routers for the application.
Public interface | IUniversalPlugAndPlayManagerProvider | The interface for objects that abstract away the Windows universal plug'n'play COM component and other aspects of the environment for IUniversalPlugAndPlayManager.
Public interface | IWebServer | The interface for objects that can serve requests for web pages.
Public interface | IWebServerProvider | The provider that implementations of IWebServer should use to access the .NET framework.
Enumerations
 | Enumeration | Description
Public enumeration | ContentClassification | The types of web content that the server deals with.
Remarks

The main interface of interest here is IWebServer which describes an object that listens for requests from web browsers and raises an event when it sees them.

The web server does not contain any content - other objects hook the events on IWebServer and set the Handled, Classification and Response properties as appropriate. By default this duty is performed by the IWebSite object.


AuthenticationRequiredEventArgs Class

AuthenticationRequiredEventArgs Class
The EventArgs raised by the IWebServer.AuthenticationRequired event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.WebServerAuthenticationRequiredEventArgs

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AuthenticationRequiredEventArgs : EventArgs
Public Class AuthenticationRequiredEventArgs
    Inherits EventArgs
public ref class AuthenticationRequiredEventArgs : public EventArgs
type AuthenticationRequiredEventArgs =
    class
        inherit EventArgs
    end

The AuthenticationRequiredEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AuthenticationRequiredEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | IsAdministrator | Gets or sets a value indicating that the user is an administrator.
Public property | IsAuthenticated | Gets or sets a value indicating that the combination of user and password indicates a valid user.
Public property | IsHandled | Gets or sets a value indicating that the authentication request has been handled.
Public property | Password | Gets the password as supplied by the browser.
Public property | User | Gets the user name as supplied by the browser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs Constructor

AuthenticationRequiredEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AuthenticationRequiredEventArgs(
    string user,
    string password
)
Public Sub New (
    user As String,
    password As String
)
public:
AuthenticationRequiredEventArgs(
    String^ user,
    String^ password
)
new :
        user : string *
        password : string -> AuthenticationRequiredEventArgs

Parameters

user
Type: SystemString
password
Type: SystemString
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs Properties

AuthenticationRequiredEventArgs Properties

The AuthenticationRequiredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsAdministrator | Gets or sets a value indicating that the user is an administrator.
Public property | IsAuthenticated | Gets or sets a value indicating that the combination of user and password indicates a valid user.
Public property | IsHandled | Gets or sets a value indicating that the authentication request has been handled.
Public property | Password | Gets the password as supplied by the browser.
Public property | User | Gets the user name as supplied by the browser.
Top
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs.IsAdministrator Property

AuthenticationRequiredEventArgsIsAdministrator Property
Gets or sets a value indicating that the user is an administrator.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAdministrator { get; set; }
Public Property IsAdministrator As Boolean
    Get
    Set
public:
property bool IsAdministrator {
    bool get ();
    void set (bool value);
}
member IsAdministrator : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs.IsAuthenticated Property

AuthenticationRequiredEventArgsIsAuthenticated Property
Gets or sets a value indicating that the combination of user and password indicates a valid user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAuthenticated { get; set; }
Public Property IsAuthenticated As Boolean
    Get
    Set
public:
property bool IsAuthenticated {
    bool get ();
    void set (bool value);
}
member IsAuthenticated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs.IsHandled Property

AuthenticationRequiredEventArgsIsHandled Property
Gets or sets a value indicating that the authentication request has been handled.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHandled { get; set; }
Public Property IsHandled As Boolean
    Get
    Set
public:
property bool IsHandled {
    bool get ();
    void set (bool value);
}
member IsHandled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs.Password Property

AuthenticationRequiredEventArgsPassword Property
Gets the password as supplied by the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}
member Password : string with get

Property Value

Type: String
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs.User Property

AuthenticationRequiredEventArgsUser Property
Gets the user name as supplied by the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string User { get; }
Public ReadOnly Property User As String
    Get
public:
property String^ User {
    String^ get ();
}
member User : string with get

Property Value

Type: String
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


AuthenticationRequiredEventArgs Methods

AuthenticationRequiredEventArgs Methods

The AuthenticationRequiredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AuthenticationRequiredEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ContentClassification Enumeration

ContentClassification Enumeration
The types of web content that the server deals with.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ContentClassification
Public Enumeration ContentClassification
public enum class ContentClassification
type ContentClassification
Members
Member name | Value | Description
Other | 0 | Other files.
Html | 1 | Web pages.
Json | 2 | JSON files.
Image | 3 | Images.
Audio | 4 | Audio.
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IAutoConfigWebServer Interface

IAutoConfigWebServer Interface
The interface for a singleton object that automatically applies configuration settings to an IWebServer.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAutoConfigWebServer : ISingleton<IAutoConfigWebServer>,
    IDisposable
Public Interface IAutoConfigWebServer
    Inherits ISingleton(Of IAutoConfigWebServer), IDisposable
public interface class IAutoConfigWebServer : ISingleton<IAutoConfigWebServer^>,
    IDisposable
type IAutoConfigWebServer =
    interface
        interface ISingleton<IAutoConfigWebServer>
        interface IDisposable
    end

The IAutoConfigWebServer type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | WebServer | Gets the web server that this object is applying configuration settings to.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the WebServer property and hooks events to pick up changes in configuration.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IAutoConfigWebServer Properties

IAutoConfigWebServer Properties

The IAutoConfigWebServer type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | WebServer | Gets the web server that this object is applying configuration settings to.
Top
See Also

Reference

IAutoConfigWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IAutoConfigWebServer.WebServer Property

IAutoConfigWebServerWebServer Property
Gets the web server that this object is applying configuration settings to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServer WebServer { get; }
ReadOnly Property WebServer As IWebServer
    Get
property IWebServer^ WebServer {
    IWebServer^ get ();
}
abstract WebServer : IWebServer with get

Property Value

Type: IWebServer
See Also

Reference

IAutoConfigWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IAutoConfigWebServer Methods

IAutoConfigWebServer Methods

The IAutoConfigWebServer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the WebServer property and hooks events to pick up changes in configuration.
Top
See Also

Reference

IAutoConfigWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IAutoConfigWebServer.Initialise Method

IAutoConfigWebServerInitialise Method
Initialises the WebServer property and hooks events to pick up changes in configuration.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IAutoConfigWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IContext Interface

IContext Interface
The interface for objects that describe an incoming request and the response that will be made for it.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IContext
Public Interface IContext
public interface class IContext
type IContext =  interface end

The IContext type exposes the following members.

Properties
 | Name | Description
Public property | BasicPassword | Gets the Basic authentication password as supplied by the browser.
Public property | BasicUserName | Gets the Basic authentication username as supplied by the browser.
Public property | Request | Gets the request from the user.
Public property | Response | Gets the response to send back to the user.
Top
Remarks
The intention is that the implementation of IWebServerProvider creates these, they are wrappers around the underlying HTTP server mechanism's objects.
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IContext Properties

IContext Properties

The IContext type exposes the following members.

Properties
 | Name | Description
Public property | BasicPassword | Gets the Basic authentication password as supplied by the browser.
Public property | BasicUserName | Gets the Basic authentication username as supplied by the browser.
Public property | Request | Gets the request from the user.
Public property | Response | Gets the response to send back to the user.
Top
See Also

Reference

IContext Interface
VirtualRadar.Interface.WebServer Namespace


IContext.BasicPassword Property

IContextBasicPassword Property
Gets the Basic authentication password as supplied by the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string BasicPassword { get; }
ReadOnly Property BasicPassword As String
    Get
property String^ BasicPassword {
    String^ get ();
}
abstract BasicPassword : string with get

Property Value

Type: String
See Also

Reference

IContext Interface
VirtualRadar.Interface.WebServer Namespace


IContext.BasicUserName Property

IContextBasicUserName Property
Gets the Basic authentication username as supplied by the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string BasicUserName { get; }
ReadOnly Property BasicUserName As String
    Get
property String^ BasicUserName {
    String^ get ();
}
abstract BasicUserName : string with get

Property Value

Type: String
See Also

Reference

IContext Interface
VirtualRadar.Interface.WebServer Namespace


IContext.Request Property

IContextRequest Property
Gets the request from the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IRequest Request { get; }
ReadOnly Property Request As IRequest
    Get
property IRequest^ Request {
    IRequest^ get ();
}
abstract Request : IRequest with get

Property Value

Type: IRequest
See Also

Reference

IContext Interface
VirtualRadar.Interface.WebServer Namespace


IContext.Response Property

IContextResponse Property
Gets the response to send back to the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IResponse Response { get; }
ReadOnly Property Response As IResponse
    Get
property IResponse^ Response {
    IResponse^ get ();
}
abstract Response : IResponse with get

Property Value

Type: IResponse
See Also

Reference

IContext Interface
VirtualRadar.Interface.WebServer Namespace


IPortMapping Interface

IPortMapping Interface
The interface for objects that describe a static port mapping on a UPnP router.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPortMapping
Public Interface IPortMapping
public interface class IPortMapping
type IPortMapping =  interface end

The IPortMapping type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description that the router holds for this port mapping.
Public property | ExternalPort | Gets the Internet-facing port number that the router will allow from the Internet onto the LAN.
Public property | InternalClient | Gets the address of the machine on the LAN that the UPnP router will forward packets to.
Public property | InternalPort | Gets the port number of the machine at InternalClient that the UPnP router will forward packets to.
Public property | Protocol | Gets the protocol of the packets that this port mapping is for.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IPortMapping Properties

IPortMapping Properties

The IPortMapping type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description that the router holds for this port mapping.
Public property | ExternalPort | Gets the Internet-facing port number that the router will allow from the Internet onto the LAN.
Public property | InternalClient | Gets the address of the machine on the LAN that the UPnP router will forward packets to.
Public property | InternalPort | Gets the port number of the machine at InternalClient that the UPnP router will forward packets to.
Public property | Protocol | Gets the protocol of the packets that this port mapping is for.
Top
See Also

Reference

IPortMapping Interface
VirtualRadar.Interface.WebServer Namespace


IPortMapping.Description Property

IPortMappingDescription Property
Gets the description that the router holds for this port mapping.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IPortMapping Interface
VirtualRadar.Interface.WebServer Namespace


IPortMapping.ExternalPort Property

IPortMappingExternalPort Property
Gets the Internet-facing port number that the router will allow from the Internet onto the LAN.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int ExternalPort { get; }
ReadOnly Property ExternalPort As Integer
    Get
property int ExternalPort {
    int get ();
}
abstract ExternalPort : int with get

Property Value

Type: Int32
See Also

Reference

IPortMapping Interface
VirtualRadar.Interface.WebServer Namespace


IPortMapping.InternalClient Property

IPortMappingInternalClient Property
Gets the address of the machine on the LAN that the UPnP router will forward packets to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string InternalClient { get; }
ReadOnly Property InternalClient As String
    Get
property String^ InternalClient {
    String^ get ();
}
abstract InternalClient : string with get

Property Value

Type: String
See Also

Reference

IPortMapping Interface
VirtualRadar.Interface.WebServer Namespace


IPortMapping.InternalPort Property

IPortMappingInternalPort Property
Gets the port number of the machine at InternalClient that the UPnP router will forward packets to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int InternalPort { get; }
ReadOnly Property InternalPort As Integer
    Get
property int InternalPort {
    int get ();
}
abstract InternalPort : int with get

Property Value

Type: Int32
See Also

Reference

IPortMapping Interface
VirtualRadar.Interface.WebServer Namespace


IPortMapping.Protocol Property

IPortMappingProtocol Property
Gets the protocol of the packets that this port mapping is for.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Protocol { get; }
ReadOnly Property Protocol As String
    Get
property String^ Protocol {
    String^ get ();
}
abstract Protocol : string with get

Property Value

Type: String
See Also

Reference

IPortMapping Interface
VirtualRadar.Interface.WebServer Namespace


IRequest Interface

IRequest Interface
The interface for objects that describe an incoming request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRequest
Public Interface IRequest
public interface class IRequest
type IRequest =  interface end

The IRequest type exposes the following members.

Properties
 | Name | Description
Public property | ContentLength64 | Gets the number of bytes of the content exposed by InputStream.
Public property | Cookies | Gets the cookies on the request.
Public property | CorsOrigin | Gets the CORS origin.
Public property | FormValues | Gets the values sent in the body of a POST request.
Public property | Headers | Gets a collection of the headers that were sent with the request.
Public property | HttpMethod | Gets the HTTP method used in the request.
Public property | InputStream | Gets a stream that exposes the body of post requests.
Public property | IsLocal | Gets a value indicating that the request came from the local computer.
Public property | IsValidCorsRequest | Gets or sets a value indicating that the web site has detected a valid CORS request and wants the response to include the correct headers if the request is successful.
Public property | LocalEndPoint | Gets the address that the Internet request was sent to.
Public property | MaximumPostBodySize | Gets or sets the maximum post body size.
Public property | RawUrl | Gets the URL from the root of the site.
Public property | RemoteEndPoint | Gets the address that the Internet request originated from.
Public property | Url | Gets the URL of the request.
Public property | UserAgent | Gets the user-agent as reported by the client browser.
Public property | UserHostName | Gets the user hostname, the hostname that the browser originally requested. For requests coming through port forwarding this will be the address that the browser requested and not necessarily the true address of the site.
Top
Methods
 | Name | Description
Public method | ReadBodyAsString | Returns the body as a single string.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IRequest Properties

IRequest Properties

The IRequest type exposes the following members.

Properties
 | Name | Description
Public property | ContentLength64 | Gets the number of bytes of the content exposed by InputStream.
Public property | Cookies | Gets the cookies on the request.
Public property | CorsOrigin | Gets the CORS origin.
Public property | FormValues | Gets the values sent in the body of a POST request.
Public property | Headers | Gets a collection of the headers that were sent with the request.
Public property | HttpMethod | Gets the HTTP method used in the request.
Public property | InputStream | Gets a stream that exposes the body of post requests.
Public property | IsLocal | Gets a value indicating that the request came from the local computer.
Public property | IsValidCorsRequest | Gets or sets a value indicating that the web site has detected a valid CORS request and wants the response to include the correct headers if the request is successful.
Public property | LocalEndPoint | Gets the address that the Internet request was sent to.
Public property | MaximumPostBodySize | Gets or sets the maximum post body size.
Public property | RawUrl | Gets the URL from the root of the site.
Public property | RemoteEndPoint | Gets the address that the Internet request originated from.
Public property | Url | Gets the URL of the request.
Public property | UserAgent | Gets the user-agent as reported by the client browser.
Public property | UserHostName | Gets the user hostname, the hostname that the browser originally requested. For requests coming through port forwarding this will be the address that the browser requested and not necessarily the true address of the site.
Top
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.ContentLength64 Property

IRequestContentLength64 Property
Gets the number of bytes of the content exposed by InputStream.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ContentLength64 { get; }
ReadOnly Property ContentLength64 As Long
    Get
property long long ContentLength64 {
    long long get ();
}
abstract ContentLength64 : int64 with get

Property Value

Type: Int64
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.Cookies Property

IRequestCookies Property
Gets the cookies on the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CookieCollection Cookies { get; }
ReadOnly Property Cookies As CookieCollection
    Get
property CookieCollection^ Cookies {
    CookieCollection^ get ();
}
abstract Cookies : CookieCollection with get

Property Value

Type: CookieCollection
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.CorsOrigin Property

IRequestCorsOrigin Property
Gets the CORS origin.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string CorsOrigin { get; }
ReadOnly Property CorsOrigin As String
    Get
property String^ CorsOrigin {
    String^ get ();
}
abstract CorsOrigin : string with get

Property Value

Type: String
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.FormValues Property

IRequestFormValues Property
Gets the values sent in the body of a POST request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
NameValueCollection FormValues { get; }
ReadOnly Property FormValues As NameValueCollection
    Get
property NameValueCollection^ FormValues {
    NameValueCollection^ get ();
}
abstract FormValues : NameValueCollection with get

Property Value

Type: NameValueCollection
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.Headers Property

IRequestHeaders Property
Gets a collection of the headers that were sent with the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
NameValueCollection Headers { get; }
ReadOnly Property Headers As NameValueCollection
    Get
property NameValueCollection^ Headers {
    NameValueCollection^ get ();
}
abstract Headers : NameValueCollection with get

Property Value

Type: NameValueCollection
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.HttpMethod Property

IRequestHttpMethod Property
Gets the HTTP method used in the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string HttpMethod { get; }
ReadOnly Property HttpMethod As String
    Get
property String^ HttpMethod {
    String^ get ();
}
abstract HttpMethod : string with get

Property Value

Type: String
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.InputStream Property

IRequestInputStream Property
Gets a stream that exposes the body of post requests.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Stream InputStream { get; }
ReadOnly Property InputStream As Stream
    Get
property Stream^ InputStream {
    Stream^ get ();
}
abstract InputStream : Stream with get

Property Value

Type: Stream
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.IsLocal Property

IRequestIsLocal Property
Gets a value indicating that the request came from the local computer.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLocal { get; }
ReadOnly Property IsLocal As Boolean
    Get
property bool IsLocal {
    bool get ();
}
abstract IsLocal : bool with get

Property Value

Type: Boolean
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.IsValidCorsRequest Property

IRequestIsValidCorsRequest Property
Gets or sets a value indicating that the web site has detected a valid CORS request and wants the response to include the correct headers if the request is successful.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsValidCorsRequest { get; set; }
Property IsValidCorsRequest As Boolean
    Get
    Set
property bool IsValidCorsRequest {
    bool get ();
    void set (bool value);
}
abstract IsValidCorsRequest : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.LocalEndPoint Property

IRequestLocalEndPoint Property
Gets the address that the Internet request was sent to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPEndPoint LocalEndPoint { get; }
ReadOnly Property LocalEndPoint As IPEndPoint
    Get
property IPEndPoint^ LocalEndPoint {
    IPEndPoint^ get ();
}
abstract LocalEndPoint : IPEndPoint with get

Property Value

Type: IPEndPoint
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.MaximumPostBodySize Property

IRequestMaximumPostBodySize Property
Gets or sets the maximum post body size.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaximumPostBodySize { get; set; }
Property MaximumPostBodySize As Integer
    Get
    Set
property int MaximumPostBodySize {
    int get ();
    void set (int value);
}
abstract MaximumPostBodySize : int with get, set

Property Value

Type: Int32
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.RawUrl Property

IRequestRawUrl Property
Gets the URL from the root of the site.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string RawUrl { get; }
ReadOnly Property RawUrl As String
    Get
property String^ RawUrl {
    String^ get ();
}
abstract RawUrl : string with get

Property Value

Type: String
Remarks
For the request address 'http://127.0.0.1/MySite/MyPage.html", where MySite is the server root, this would return '/MySite/MyPage.html'.
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.RemoteEndPoint Property

IRequestRemoteEndPoint Property
Gets the address that the Internet request originated from.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPEndPoint RemoteEndPoint { get; }
ReadOnly Property RemoteEndPoint As IPEndPoint
    Get
property IPEndPoint^ RemoteEndPoint {
    IPEndPoint^ get ();
}
abstract RemoteEndPoint : IPEndPoint with get

Property Value

Type: IPEndPoint
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.Url Property

IRequestUrl Property
Gets the URL of the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Uri Url { get; }
ReadOnly Property Url As Uri
    Get
property Uri^ Url {
    Uri^ get ();
}
abstract Url : Uri with get

Property Value

Type: Uri
Remarks
This is the full address of the requested page, e.g. 'http://127.0.0.1/MySite/MyPage.html'.
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.UserAgent Property

IRequestUserAgent Property
Gets the user-agent as reported by the client browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserAgent { get; }
ReadOnly Property UserAgent As String
    Get
property String^ UserAgent {
    String^ get ();
}
abstract UserAgent : string with get

Property Value

Type: String
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.UserHostName Property

IRequestUserHostName Property
Gets the user hostname, the hostname that the browser originally requested. For requests coming through port forwarding this will be the address that the browser requested and not necessarily the true address of the site.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserHostName { get; }
ReadOnly Property UserHostName As String
    Get
property String^ UserHostName {
    String^ get ();
}
abstract UserHostName : string with get

Property Value

Type: String
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest Methods

IRequest Methods

The IRequest type exposes the following members.

Methods
 | Name | Description
Public method | ReadBodyAsString | Returns the body as a single string.
Top
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IRequest.ReadBodyAsString Method

IRequestReadBodyAsString Method
Returns the body as a single string.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ReadBodyAsString(
    Encoding encoding
)
Function ReadBodyAsString (
    encoding As Encoding
) As String
String^ ReadBodyAsString(
    Encoding^ encoding
)
abstract ReadBodyAsString :
        encoding : Encoding -> string

Parameters

encoding
Type: System.TextEncoding

Return Value

Type: String
See Also

Reference

IRequest Interface
VirtualRadar.Interface.WebServer Namespace


IResponder Interface

IResponder Interface
The interface for objects that can fill IResponse objects correctly for different types of content.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IResponder
Public Interface IResponder
public interface class IResponder
type IResponder =  interface end

The IResponder type exposes the following members.

Methods
 | Name | Description
Public method | AddCorsHeaders | Adds CORS headers to a successful response.
Public method | Forbidden | Returns a response indicating that the request is not authorised.
Public method | SendAudio | Sends the audio back to the browser. The format of the audio is inferred from the MIME type.
Public method | SendBinary | Sends the bytes back to the browser.
Public method | SendImage | Sends a copy of the image in the correct format back to the browser.
Public method | SendJson | Formats the object as a JSON object and sends it via the response to the browser.
Public method | SendText(IRequest, IResponse, String, Encoding, String) | Configures the response object to send text back to the browser.
Public method | SendText(IRequest, IResponse, String, Encoding, String, Int32) | Configures the response object to send text back to the browser.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IResponder Methods

IResponder Methods

The IResponder type exposes the following members.

Methods
 | Name | Description
Public method | AddCorsHeaders | Adds CORS headers to a successful response.
Public method | Forbidden | Returns a response indicating that the request is not authorised.
Public method | SendAudio | Sends the audio back to the browser. The format of the audio is inferred from the MIME type.
Public method | SendBinary | Sends the bytes back to the browser.
Public method | SendImage | Sends a copy of the image in the correct format back to the browser.
Public method | SendJson | Formats the object as a JSON object and sends it via the response to the browser.
Public method | SendText(IRequest, IResponse, String, Encoding, String) | Configures the response object to send text back to the browser.
Public method | SendText(IRequest, IResponse, String, Encoding, String, Int32) | Configures the response object to send text back to the browser.
Top
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.AddCorsHeaders Method

IResponderAddCorsHeaders Method
Adds CORS headers to a successful response.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddCorsHeaders(
    IRequest request,
    IResponse response
)
Sub AddCorsHeaders (
    request As IRequest,
    response As IResponse
)
void AddCorsHeaders(
    IRequest^ request,
    IResponse^ response
)
abstract AddCorsHeaders :
        request : IRequest *
        response : IResponse -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
response
Type: VirtualRadar.Interface.WebServerIResponse
Remarks
All of the responder's Send methods are expected to call this when setting headers. The function has been exposed so that custom responses can also set the headers without having to call a Send method.
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.Forbidden Method

IResponderForbidden Method
Returns a response indicating that the request is not authorised.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Forbidden(
    IResponse response
)
Sub Forbidden (
    response As IResponse
)
void Forbidden(
    IResponse^ response
)
abstract Forbidden :
        response : IResponse -> unit

Parameters

response
Type: VirtualRadar.Interface.WebServerIResponse
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.SendAudio Method

IResponderSendAudio Method
Sends the audio back to the browser. The format of the audio is inferred from the MIME type.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendAudio(
    IRequest request,
    IResponse response,
    byte[] audio,
    string mimeType
)
Sub SendAudio (
    request As IRequest,
    response As IResponse,
    audio As Byte(),
    mimeType As String
)
void SendAudio(
    IRequest^ request,
    IResponse^ response,
    array<unsigned char>^ audio,
    String^ mimeType
)
abstract SendAudio :
        request : IRequest *
        response : IResponse *
        audio : byte[] *
        mimeType : string -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
response
Type: VirtualRadar.Interface.WebServerIResponse
audio
Type: SystemByte
mimeType
Type: SystemString
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.SendBinary Method

IResponderSendBinary Method
Sends the bytes back to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendBinary(
    IRequest request,
    IResponse response,
    byte[] binary,
    string mimeType,
    bool compressResponse
)
Sub SendBinary (
    request As IRequest,
    response As IResponse,
    binary As Byte(),
    mimeType As String,
    compressResponse As Boolean
)
void SendBinary(
    IRequest^ request,
    IResponse^ response,
    array<unsigned char>^ binary,
    String^ mimeType,
    bool compressResponse
)
abstract SendBinary :
        request : IRequest *
        response : IResponse *
        binary : byte[] *
        mimeType : string *
        compressResponse : bool -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
response
Type: VirtualRadar.Interface.WebServerIResponse
binary
Type: SystemByte
mimeType
Type: SystemString
compressResponse
Type: SystemBoolean
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.SendImage Method

IResponderSendImage Method
Sends a copy of the image in the correct format back to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendImage(
    IRequest request,
    IResponse response,
    Image image,
    ImageFormat format
)
Sub SendImage (
    request As IRequest,
    response As IResponse,
    image As Image,
    format As ImageFormat
)
void SendImage(
    IRequest^ request,
    IResponse^ response,
    Image^ image,
    ImageFormat^ format
)
abstract SendImage :
        request : IRequest *
        response : IResponse *
        image : Image *
        format : ImageFormat -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
response
Type: VirtualRadar.Interface.WebServerIResponse
image
Type: System.DrawingImage
format
Type: System.Drawing.ImagingImageFormat
Remarks
The supported image formats are PNG, GIF and BMP.
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.SendJson Method

IResponderSendJson Method
Formats the object as a JSON object and sends it via the response to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendJson(
    IRequest request,
    IResponse response,
    Object json,
    string jsonpFunctionName,
    string mimeType
)
Sub SendJson (
    request As IRequest,
    response As IResponse,
    json As Object,
    jsonpFunctionName As String,
    mimeType As String
)
void SendJson(
    IRequest^ request,
    IResponse^ response,
    Object^ json,
    String^ jsonpFunctionName,
    String^ mimeType
)
abstract SendJson :
        request : IRequest *
        response : IResponse *
        json : Object *
        jsonpFunctionName : string *
        mimeType : string -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
The request object.
response
Type: VirtualRadar.Interface.WebServerIResponse
The response object to populate.
json
Type: SystemObject
The JSON object to serialise and send.
jsonpFunctionName
Type: SystemString
The JSONP callback text to append to content. Pass null if the browser did not request a JSONP callback function.
mimeType
Type: SystemString
The MIME type to use. Pass null to go with the default MIME type for JSON.
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.SendText Method

IResponderSendText Method
Overload List
 | Name | Description
Public method | SendText(IRequest, IResponse, String, Encoding, String) | Configures the response object to send text back to the browser.
Public method | SendText(IRequest, IResponse, String, Encoding, String, Int32) | Configures the response object to send text back to the browser.
Top
See Also

Reference

IResponder Interface
VirtualRadar.Interface.WebServer Namespace


IResponder.SendText Method (IRequest, IResponse, String, Encoding, String)

IResponderSendText Method (IRequest, IResponse, String, Encoding, String)
Configures the response object to send text back to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendText(
    IRequest request,
    IResponse response,
    string text,
    Encoding encoding,
    string mimeType
)
Sub SendText (
    request As IRequest,
    response As IResponse,
    text As String,
    encoding As Encoding,
    mimeType As String
)
void SendText(
    IRequest^ request,
    IResponse^ response,
    String^ text,
    Encoding^ encoding,
    String^ mimeType
)
abstract SendText :
        request : IRequest *
        response : IResponse *
        text : string *
        encoding : Encoding *
        mimeType : string -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
The request object - must be supplied.
response
Type: VirtualRadar.Interface.WebServerIResponse
The response object to fill in - must be supplied.
text
Type: SystemString
The text to send back - defaults to an empty string.
encoding
Type: System.TextEncoding
The encoding to use when sending the text - defaults to UTF8.
mimeType
Type: SystemString
The MimeType to use when sending the text - defaults to MimeType.Text.
See Also

Reference

IResponder Interface
SendText Overload
VirtualRadar.Interface.WebServer Namespace


IResponder.SendText Method (IRequest, IResponse, String, Encoding, String, Int32)

IResponderSendText Method (IRequest, IResponse, String, Encoding, String, Int32)
Configures the response object to send text back to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendText(
    IRequest request,
    IResponse response,
    string text,
    Encoding encoding,
    string mimeType,
    int cacheSeconds
)
Sub SendText (
    request As IRequest,
    response As IResponse,
    text As String,
    encoding As Encoding,
    mimeType As String,
    cacheSeconds As Integer
)
void SendText(
    IRequest^ request,
    IResponse^ response,
    String^ text,
    Encoding^ encoding,
    String^ mimeType,
    int cacheSeconds
)
abstract SendText :
        request : IRequest *
        response : IResponse *
        text : string *
        encoding : Encoding *
        mimeType : string *
        cacheSeconds : int -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
The request object - must be supplied.
response
Type: VirtualRadar.Interface.WebServerIResponse
The response object to fill in - must be supplied.
text
Type: SystemString
The text to send back - defaults to an empty string.
encoding
Type: System.TextEncoding
The encoding to use when sending the text - defaults to UTF8.
mimeType
Type: SystemString
The MimeType to use when sending the text - defaults to MimeType.Text.
cacheSeconds
Type: SystemInt32
The number of seconds that the browser should cache the response for. Set to 0 to tell the browser not to cache the response.
See Also

Reference

IResponder Interface
SendText Overload
VirtualRadar.Interface.WebServer Namespace


IResponse Interface

IResponse Interface
The interface for objects that describe the response to a request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IResponse : IDisposable
Public Interface IResponse
    Inherits IDisposable
public interface class IResponse : IDisposable
type IResponse =
    interface
        interface IDisposable
    end

The IResponse type exposes the following members.

Properties
 | Name | Description
Public property | ContentEncoding | Gets or sets the encoding used in the response.
Public property | ContentLength | Gets or sets the length of the content to send back to the user.
Public property | Cookies | Gets the cookies to set on the response.
Public property | MimeType | Gets or sets the mime type to associate with the content.
Public property | OutputStream | Gets the stream that can be used to send data to the browser.
Public property | StatusCode | Gets or sets the HTTP status code to send back to the user.
Top
Methods
 | Name | Description
Public method | Abort | Aborts the response without sending the content to the browser.
Public method | AddHeader | Adds a header to the response. If the header already exists then its value is overwritten.
Public method | Close | Closes the response, sending the content to the browser.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableCompression | Switches compression of the response, but only if the request indicates that the server supports a compression encoding that we can support.
Public method | Redirect | Instructs the web server to redirect the browser to another URL. This sets StatusCode to an appropriate value but does not close OutputStream.
Public method | SetCookie | Sets or updates a cookie in the collection of cookies to return to the caller.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IResponse Properties

IResponse Properties

The IResponse type exposes the following members.

Properties
 | Name | Description
Public property | ContentEncoding | Gets or sets the encoding used in the response.
Public property | ContentLength | Gets or sets the length of the content to send back to the user.
Public property | Cookies | Gets the cookies to set on the response.
Public property | MimeType | Gets or sets the mime type to associate with the content.
Public property | OutputStream | Gets the stream that can be used to send data to the browser.
Public property | StatusCode | Gets or sets the HTTP status code to send back to the user.
Top
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.ContentEncoding Property

IResponseContentEncoding Property
Gets or sets the encoding used in the response.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Encoding ContentEncoding { get; set; }
Property ContentEncoding As Encoding
    Get
    Set
property Encoding^ ContentEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
abstract ContentEncoding : Encoding with get, set

Property Value

Type: Encoding
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.ContentLength Property

IResponseContentLength Property
Gets or sets the length of the content to send back to the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
long ContentLength { get; set; }
Property ContentLength As Long
    Get
    Set
property long long ContentLength {
    long long get ();
    void set (long long value);
}
abstract ContentLength : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.Cookies Property

IResponseCookies Property
Gets the cookies to set on the response.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
CookieCollection Cookies { get; set; }
Property Cookies As CookieCollection
    Get
    Set
property CookieCollection^ Cookies {
    CookieCollection^ get ();
    void set (CookieCollection^ value);
}
abstract Cookies : CookieCollection with get, set

Property Value

Type: CookieCollection
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.MimeType Property

IResponseMimeType Property
Gets or sets the mime type to associate with the content.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string MimeType { get; set; }
Property MimeType As String
    Get
    Set
property String^ MimeType {
    String^ get ();
    void set (String^ value);
}
abstract MimeType : string with get, set

Property Value

Type: String
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.OutputStream Property

IResponseOutputStream Property
Gets the stream that can be used to send data to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Stream OutputStream { get; }
ReadOnly Property OutputStream As Stream
    Get
property Stream^ OutputStream {
    Stream^ get ();
}
abstract OutputStream : Stream with get

Property Value

Type: Stream
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.StatusCode Property

IResponseStatusCode Property
Gets or sets the HTTP status code to send back to the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
HttpStatusCode StatusCode { get; set; }
Property StatusCode As HttpStatusCode
    Get
    Set
property HttpStatusCode StatusCode {
    HttpStatusCode get ();
    void set (HttpStatusCode value);
}
abstract StatusCode : HttpStatusCode with get, set

Property Value

Type: HttpStatusCode
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse Methods

IResponse Methods

The IResponse type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts the response without sending the content to the browser.
Public method | AddHeader | Adds a header to the response. If the header already exists then its value is overwritten.
Public method | Close | Closes the response, sending the content to the browser.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableCompression | Switches compression of the response, but only if the request indicates that the server supports a compression encoding that we can support.
Public method | Redirect | Instructs the web server to redirect the browser to another URL. This sets StatusCode to an appropriate value but does not close OutputStream.
Public method | SetCookie | Sets or updates a cookie in the collection of cookies to return to the caller.
Top
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.Abort Method

IResponseAbort Method
Aborts the response without sending the content to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Abort()
Sub Abort
void Abort()
abstract Abort : unit -> unit
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.AddHeader Method

IResponseAddHeader Method
Adds a header to the response. If the header already exists then its value is overwritten.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddHeader(
    string name,
    string value
)
Sub AddHeader (
    name As String,
    value As String
)
void AddHeader(
    String^ name,
    String^ value
)
abstract AddHeader :
        name : string *
        value : string -> unit

Parameters

name
Type: SystemString
value
Type: SystemString
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.Close Method

IResponseClose Method
Closes the response, sending the content to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.EnableCompression Method

IResponseEnableCompression Method
Switches compression of the response, but only if the request indicates that the server supports a compression encoding that we can support.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnableCompression(
    IRequest request
)
Sub EnableCompression (
    request As IRequest
)
void EnableCompression(
    IRequest^ request
)
abstract EnableCompression :
        request : IRequest -> unit

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
Remarks
If this is called after the first request for OutputStream then an exception is thrown. If this is called then ResponseComplete must be called, after which it is illegal to write anything else to the OutputStream.
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.Redirect Method

IResponseRedirect Method
Instructs the web server to redirect the browser to another URL. This sets StatusCode to an appropriate value but does not close OutputStream.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Redirect(
    string url
)
Sub Redirect (
    url As String
)
void Redirect(
    String^ url
)
abstract Redirect :
        url : string -> unit

Parameters

url
Type: SystemString
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IResponse.SetCookie Method

IResponseSetCookie Method
Sets or updates a cookie in the collection of cookies to return to the caller.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetCookie(
    Cookie cookie
)
Sub SetCookie (
    cookie As Cookie
)
void SetCookie(
    Cookie^ cookie
)
abstract SetCookie :
        cookie : Cookie -> unit

Parameters

cookie
Type: System.NetCookie
See Also

Reference

IResponse Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager Interface

IUniversalPlugAndPlayManager Interface
The interface for the object that deals with UPnP routers for the application.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUniversalPlugAndPlayManager : IDisposable
Public Interface IUniversalPlugAndPlayManager
    Inherits IDisposable
public interface class IUniversalPlugAndPlayManager : IDisposable
type IUniversalPlugAndPlayManager =
    interface
        interface IDisposable
    end

The IUniversalPlugAndPlayManager type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Gets a value mirroring the configuration option that enables or disables the use of the UPnP router.
Public property | IsRouterPresent | Gets a value indicating that a UPnP router is present on the network.
Public property | PortForwardingPresent | Gets a value indicating that there is a port forwarding on the router that redirects packets from the Internet on the UPnP port indicated by the configuration to this machine and to the port that WebServer is listening to.
Public property | Provider | Gets or sets the provider that abstracts away the environment for the tests.
Public property | WebServer | Gets or sets the web server that wants packets sent to it from the outside world via the UPnP router.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the manager once all of the properties have been built up.
Public method | PutServerOntoInternet | Adds the necessary port mappings to the UPnP router to put the WebServer onto the Internet.
Public method | TakeServerOffInternet | Reverses the port mappings added to the UPnP router by PutServerOntoInternet with the intention of taking the WebServer off the Internet.
Top
Events
 | Name | Description
Public event | StateChanged | Raised when any of the properties that describe the state of the manager changes.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager Properties

IUniversalPlugAndPlayManager Properties

The IUniversalPlugAndPlayManager type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Gets a value mirroring the configuration option that enables or disables the use of the UPnP router.
Public property | IsRouterPresent | Gets a value indicating that a UPnP router is present on the network.
Public property | PortForwardingPresent | Gets a value indicating that there is a port forwarding on the router that redirects packets from the Internet on the UPnP port indicated by the configuration to this machine and to the port that WebServer is listening to.
Public property | Provider | Gets or sets the provider that abstracts away the environment for the tests.
Public property | WebServer | Gets or sets the web server that wants packets sent to it from the outside world via the UPnP router.
Top
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.IsEnabled Property

IUniversalPlugAndPlayManagerIsEnabled Property
Gets a value mirroring the configuration option that enables or disables the use of the UPnP router.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsEnabled { get; }
ReadOnly Property IsEnabled As Boolean
    Get
property bool IsEnabled {
    bool get ();
}
abstract IsEnabled : bool with get

Property Value

Type: Boolean
Remarks
This is provided here for the sake of convenience.
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.IsRouterPresent Property

IUniversalPlugAndPlayManagerIsRouterPresent Property
Gets a value indicating that a UPnP router is present on the network.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsRouterPresent { get; }
ReadOnly Property IsRouterPresent As Boolean
    Get
property bool IsRouterPresent {
    bool get ();
}
abstract IsRouterPresent : bool with get

Property Value

Type: Boolean
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.PortForwardingPresent Property

IUniversalPlugAndPlayManagerPortForwardingPresent Property
Gets a value indicating that there is a port forwarding on the router that redirects packets from the Internet on the UPnP port indicated by the configuration to this machine and to the port that WebServer is listening to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PortForwardingPresent { get; }
ReadOnly Property PortForwardingPresent As Boolean
    Get
property bool PortForwardingPresent {
    bool get ();
}
abstract PortForwardingPresent : bool with get

Property Value

Type: Boolean
Remarks
This may be true even if the user has disabled the UPnP features of the program. It could be true because another instance of the program on another machine on the network has added the mapping to the router, or the user may have disabled UPnP control in the configuration while the router was turned off, or the user or another application has added their own port forwarding that the router is reporting back to us.
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.Provider Property

IUniversalPlugAndPlayManagerProvider Property
Gets or sets the provider that abstracts away the environment for the tests.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IUniversalPlugAndPlayManagerProvider Provider { get; set; }
Property Provider As IUniversalPlugAndPlayManagerProvider
    Get
    Set
property IUniversalPlugAndPlayManagerProvider^ Provider {
    IUniversalPlugAndPlayManagerProvider^ get ();
    void set (IUniversalPlugAndPlayManagerProvider^ value);
}
abstract Provider : IUniversalPlugAndPlayManagerProvider with get, set

Property Value

Type: IUniversalPlugAndPlayManagerProvider
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.WebServer Property

IUniversalPlugAndPlayManagerWebServer Property
Gets or sets the web server that wants packets sent to it from the outside world via the UPnP router.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServer WebServer { get; set; }
Property WebServer As IWebServer
    Get
    Set
property IWebServer^ WebServer {
    IWebServer^ get ();
    void set (IWebServer^ value);
}
abstract WebServer : IWebServer with get, set

Property Value

Type: IWebServer
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager Methods

IUniversalPlugAndPlayManager Methods

The IUniversalPlugAndPlayManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the manager once all of the properties have been built up.
Public method | PutServerOntoInternet | Adds the necessary port mappings to the UPnP router to put the WebServer onto the Internet.
Public method | TakeServerOffInternet | Reverses the port mappings added to the UPnP router by PutServerOntoInternet with the intention of taking the WebServer off the Internet.
Top
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.Initialise Method

IUniversalPlugAndPlayManagerInitialise Method
Initialises the manager once all of the properties have been built up.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.PutServerOntoInternet Method

IUniversalPlugAndPlayManagerPutServerOntoInternet Method
Adds the necessary port mappings to the UPnP router to put the WebServer onto the Internet.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void PutServerOntoInternet()
Sub PutServerOntoInternet
void PutServerOntoInternet()
abstract PutServerOntoInternet : unit -> unit
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.TakeServerOffInternet Method

IUniversalPlugAndPlayManagerTakeServerOffInternet Method
Reverses the port mappings added to the UPnP router by PutServerOntoInternet with the intention of taking the WebServer off the Internet.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void TakeServerOffInternet()
Sub TakeServerOffInternet
void TakeServerOffInternet()
abstract TakeServerOffInternet : unit -> unit
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager Events

IUniversalPlugAndPlayManager Events

The IUniversalPlugAndPlayManager type exposes the following members.

Events
 | Name | Description
Public event | StateChanged | Raised when any of the properties that describe the state of the manager changes.
Top
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManager.StateChanged Event

IUniversalPlugAndPlayManagerStateChanged Event
Raised when any of the properties that describe the state of the manager changes.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler StateChanged
Event StateChanged As EventHandler
 event EventHandler^ StateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IUniversalPlugAndPlayManager Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManagerProvider Interface

IUniversalPlugAndPlayManagerProvider Interface
The interface for objects that abstract away the Windows universal plug'n'play COM component and other aspects of the environment for IUniversalPlugAndPlayManager.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUniversalPlugAndPlayManagerProvider
Public Interface IUniversalPlugAndPlayManagerProvider
public interface class IUniversalPlugAndPlayManagerProvider
type IUniversalPlugAndPlayManagerProvider =  interface end

The IUniversalPlugAndPlayManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | AddMapping | Adds a new port mapping via the UPnP COM component.
Public method | CreateUPnPComComponent | Creates the UPnP COM component, some aspects of which are exposed by the provider.
Public method | GetPortMappings | Returns a list of every port mapping exposed by the UPnP COM component. Can return null if the COM component can't expose static port mappings.
Public method | RemoveMapping | Removes a mapping via the UPnP COM component.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManagerProvider Methods

IUniversalPlugAndPlayManagerProvider Methods

The IUniversalPlugAndPlayManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | AddMapping | Adds a new port mapping via the UPnP COM component.
Public method | CreateUPnPComComponent | Creates the UPnP COM component, some aspects of which are exposed by the provider.
Public method | GetPortMappings | Returns a list of every port mapping exposed by the UPnP COM component. Can return null if the COM component can't expose static port mappings.
Public method | RemoveMapping | Removes a mapping via the UPnP COM component.
Top
See Also

Reference

IUniversalPlugAndPlayManagerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManagerProvider.AddMapping Method

IUniversalPlugAndPlayManagerProviderAddMapping Method
Adds a new port mapping via the UPnP COM component.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddMapping(
    int externalPort,
    string protocol,
    int internalPort,
    string internalClient,
    bool startEnabled,
    string description
)
Sub AddMapping (
    externalPort As Integer,
    protocol As String,
    internalPort As Integer,
    internalClient As String,
    startEnabled As Boolean,
    description As String
)
void AddMapping(
    int externalPort,
    String^ protocol,
    int internalPort,
    String^ internalClient,
    bool startEnabled,
    String^ description
)
abstract AddMapping :
        externalPort : int *
        protocol : string *
        internalPort : int *
        internalClient : string *
        startEnabled : bool *
        description : string -> unit

Parameters

externalPort
Type: SystemInt32
protocol
Type: SystemString
internalPort
Type: SystemInt32
internalClient
Type: SystemString
startEnabled
Type: SystemBoolean
description
Type: SystemString
See Also

Reference

IUniversalPlugAndPlayManagerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManagerProvider.CreateUPnPComComponent Method

IUniversalPlugAndPlayManagerProviderCreateUPnPComComponent Method
Creates the UPnP COM component, some aspects of which are exposed by the provider.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateUPnPComComponent()
Sub CreateUPnPComComponent
void CreateUPnPComComponent()
abstract CreateUPnPComComponent : unit -> unit
See Also

Reference

IUniversalPlugAndPlayManagerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManagerProvider.GetPortMappings Method

IUniversalPlugAndPlayManagerProviderGetPortMappings Method
Returns a list of every port mapping exposed by the UPnP COM component. Can return null if the COM component can't expose static port mappings.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<IPortMapping> GetPortMappings()
Function GetPortMappings As List(Of IPortMapping)
List<IPortMapping^>^ GetPortMappings()
abstract GetPortMappings : unit -> List<IPortMapping>

Return Value

Type: List IPortMapping
See Also

Reference

IUniversalPlugAndPlayManagerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IUniversalPlugAndPlayManagerProvider.RemoveMapping Method

IUniversalPlugAndPlayManagerProviderRemoveMapping Method
Removes a mapping via the UPnP COM component.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveMapping(
    int externalPort,
    string protocol
)
Sub RemoveMapping (
    externalPort As Integer,
    protocol As String
)
void RemoveMapping(
    int externalPort,
    String^ protocol
)
abstract RemoveMapping :
        externalPort : int *
        protocol : string -> unit

Parameters

externalPort
Type: SystemInt32
protocol
Type: SystemString
See Also

Reference

IUniversalPlugAndPlayManagerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer Interface

IWebServer Interface
The interface for objects that can serve requests for web pages.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebServer : IBackgroundThreadExceptionCatcher,
    IDisposable
Public Interface IWebServer
    Inherits IBackgroundThreadExceptionCatcher, IDisposable
public interface class IWebServer : IBackgroundThreadExceptionCatcher,
    IDisposable
type IWebServer =
    interface
        interface IBackgroundThreadExceptionCatcher
        interface IDisposable
    end

The IWebServer type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationScheme | Gets or sets the authentication scheme to use.
Public property | CacheCredentials | Gets or sets a value indicating that authentication credentials can be cached by the server.
Public property | ExternalAddress | Gets the address of the web server on the public Internet (e.g. http://12.13.14.15:8080/Root).
Public property | ExternalIPAddress | Gets or sets the IP address of the local machine on the public internet. Optional, used to build ExternalAddress.
Public property | ExternalPort | Gets or sets the port number that public Internet clients can connect to in order to reach this machine. Optional, used to build ExternalAddress.
Public property | LocalAddress | Gets the local address of the web server (e.g. http://127.0.0.1:8090/Root).
Public property | NetworkAddress | Gets the address of the web server on the LAN (e.g. http://192.168.0.1:8090/Root).
Public property | NetworkIPAddress | Gets the IP address of the current machine on the LAN (e.g. 192.168.0.1).
Public property | Online | Gets or sets a value indicating that the server is online.
Public property | Port | Gets or sets the port number to listen to.
Public property | PortText | Gets the Port number as a string suitable for use in a URL.
Public property | Prefix | Gets the prefix that describes the combination of root and port.
Public property | Provider | Gets or sets the provider used to wrap bits of the .NET framework.
Public property | Root | Gets or sets the root of the web site that the server will listen to.
Top
Methods
 | Name | Description
Public method | AddAdministratorPath | Tells the server that all access to this path must be authenticated and that the user must be configured as an administrator.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAdministratorPaths | Returns the paths that have been marked as requiring authentication.
Public method | GetRestrictedPathsMap | Returns a map of restricted paths to the Access describing which IPAddresses can access the path.
Public method | RemoveAdministratorPath | Tells the server that anyone can now access this path.
Public method | ResetCredentialCache | Clears the cache of credentials held by the server - see CacheCredentials.
Public method | SetRestrictedPath | Sets access on a restricted path. If access is null then the restrictions are removed from the path.
Top
Events
 | Name | Description
Public event | AfterRequestReceived | Raised on a background thread when the web server receives a request from a browser. Called after RequestReceived is raised.
Public event | AuthenticationRequired | Raised when the AuthenticationScheme is not 'None' and the browser has supplied credentials that need testing.
Public event | BeforeRequestReceived | Raised on a background thread when the web server receives a request from a browser. Called before RequestReceived is raised.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | ExternalAddressChanged | Raised when the ExternalAddress property changes.
Public event | OnlineChanged | Raised when the Online property changes state.
Public event | RequestFinished | Raised after a response has been sent and the request completely closed down. The parameter is the UniqueId of the ResponseSentEventArgs original created for the request.
Public event | RequestReceived | Raised on a background thread when the web server receives a request from a browser.
Public event | ResponseSent | Raised on a background thread when the web server responds to a request.
Top
Remarks

Once the properties have been set the server is controlled through the Online property. Setting it to true starts the server, setting it to false takes it offline.

When a request is received from a browser the RequestReceived event is raised. This is passed a RequestReceivedEventArgs object. If the handler(s) do not set the Handled property of the args then the server responds with a "Content not found" error, otherwise the content as described by Response property is sent to the browser.

The web server supports authentication. When authentication is required the AuthenticationScheme property should be set to a value that is not Anonymous. The server will raise AuthenticationRequired and pass an AuthenticationRequiredEventArgs. Setting the IsAuthenticated property will allow the request to proceed. The CacheCredentials property can be used to prevent the event being raised for credentials that the server has previously seen, and which were previously confirmed to be good by an event handler.

If the implementation of IWebServer is using the .NET Framework HttpListener then be aware that this will not run without admin privileges under Windows 7 or Vista, unless you first run a NETSH command to give the application permission to listen to a particular root and port. The installer for Virtual Radar Server sets this permission up so that Virtual Radar Server can remain at normal user permissions, if you use the server for your own applications you may need to do the same or ask the user to run your application as an administrator. It is not guaranteed, however, that the implementation is using HttpListener.

See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IWebServer Properties

IWebServer Properties

The IWebServer type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationScheme | Gets or sets the authentication scheme to use.
Public property | CacheCredentials | Gets or sets a value indicating that authentication credentials can be cached by the server.
Public property | ExternalAddress | Gets the address of the web server on the public Internet (e.g. http://12.13.14.15:8080/Root).
Public property | ExternalIPAddress | Gets or sets the IP address of the local machine on the public internet. Optional, used to build ExternalAddress.
Public property | ExternalPort | Gets or sets the port number that public Internet clients can connect to in order to reach this machine. Optional, used to build ExternalAddress.
Public property | LocalAddress | Gets the local address of the web server (e.g. http://127.0.0.1:8090/Root).
Public property | NetworkAddress | Gets the address of the web server on the LAN (e.g. http://192.168.0.1:8090/Root).
Public property | NetworkIPAddress | Gets the IP address of the current machine on the LAN (e.g. 192.168.0.1).
Public property | Online | Gets or sets a value indicating that the server is online.
Public property | Port | Gets or sets the port number to listen to.
Public property | PortText | Gets the Port number as a string suitable for use in a URL.
Public property | Prefix | Gets the prefix that describes the combination of root and port.
Public property | Provider | Gets or sets the provider used to wrap bits of the .NET framework.
Public property | Root | Gets or sets the root of the web site that the server will listen to.
Top
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.AuthenticationScheme Property

IWebServerAuthenticationScheme Property
Gets or sets the authentication scheme to use.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AuthenticationSchemes AuthenticationScheme { get; set; }
Property AuthenticationScheme As AuthenticationSchemes
    Get
    Set
property AuthenticationSchemes AuthenticationScheme {
    AuthenticationSchemes get ();
    void set (AuthenticationSchemes value);
}
abstract AuthenticationScheme : AuthenticationSchemes with get, set

Property Value

Type: AuthenticationSchemes
Remarks
Defaults to AuthenticationSchemes.None. Only None, Anonymous and Basic are currently supported.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.CacheCredentials Property

IWebServerCacheCredentials Property
Gets or sets a value indicating that authentication credentials can be cached by the server.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CacheCredentials { get; set; }
Property CacheCredentials As Boolean
    Get
    Set
property bool CacheCredentials {
    bool get ();
    void set (bool value);
}
abstract CacheCredentials : bool with get, set

Property Value

Type: Boolean
Remarks
If this is set then AuthenticationRequired will only be raised if AuthenticationScheme is not 'None' and the combination of username and password sent by the browser has never previously been confirmed as valid. Invalid combinations are not cached.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.ExternalAddress Property

IWebServerExternalAddress Property
Gets the address of the web server on the public Internet (e.g. http://12.13.14.15:8080/Root).

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExternalAddress { get; }
ReadOnly Property ExternalAddress As String
    Get
property String^ ExternalAddress {
    String^ get ();
}
abstract ExternalAddress : string with get

Property Value

Type: String
Remarks
This is derived from ExternalIPAddress and ExternalPort.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.ExternalIPAddress Property

IWebServerExternalIPAddress Property
Gets or sets the IP address of the local machine on the public internet. Optional, used to build ExternalAddress.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExternalIPAddress { get; set; }
Property ExternalIPAddress As String
    Get
    Set
property String^ ExternalIPAddress {
    String^ get ();
    void set (String^ value);
}
abstract ExternalIPAddress : string with get, set

Property Value

Type: String
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.ExternalPort Property

IWebServerExternalPort Property
Gets or sets the port number that public Internet clients can connect to in order to reach this machine. Optional, used to build ExternalAddress.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int ExternalPort { get; set; }
Property ExternalPort As Integer
    Get
    Set
property int ExternalPort {
    int get ();
    void set (int value);
}
abstract ExternalPort : int with get, set

Property Value

Type: Int32
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.LocalAddress Property

IWebServerLocalAddress Property
Gets the local address of the web server (e.g. http://127.0.0.1:8090/Root).

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string LocalAddress { get; }
ReadOnly Property LocalAddress As String
    Get
property String^ LocalAddress {
    String^ get ();
}
abstract LocalAddress : string with get

Property Value

Type: String
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.NetworkAddress Property

IWebServerNetworkAddress Property
Gets the address of the web server on the LAN (e.g. http://192.168.0.1:8090/Root).

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string NetworkAddress { get; }
ReadOnly Property NetworkAddress As String
    Get
property String^ NetworkAddress {
    String^ get ();
}
abstract NetworkAddress : string with get

Property Value

Type: String
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.NetworkIPAddress Property

IWebServerNetworkIPAddress Property
Gets the IP address of the current machine on the LAN (e.g. 192.168.0.1).

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string NetworkIPAddress { get; }
ReadOnly Property NetworkIPAddress As String
    Get
property String^ NetworkIPAddress {
    String^ get ();
}
abstract NetworkIPAddress : string with get

Property Value

Type: String
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.Online Property

IWebServerOnline Property
Gets or sets a value indicating that the server is online.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Online { get; set; }
Property Online As Boolean
    Get
    Set
property bool Online {
    bool get ();
    void set (bool value);
}
abstract Online : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.Port Property

IWebServerPort Property
Gets or sets the port number to listen to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Port { get; set; }
Property Port As Integer
    Get
    Set
property int Port {
    int get ();
    void set (int value);
}
abstract Port : int with get, set

Property Value

Type: Int32
Remarks
Defaults to 80.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.PortText Property

IWebServerPortText Property
Gets the Port number as a string suitable for use in a URL.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string PortText { get; }
ReadOnly Property PortText As String
    Get
property String^ PortText {
    String^ get ();
}
abstract PortText : string with get

Property Value

Type: String
Remarks
If Port is 80 then it returns an empty string, otherwise it returns ":nnn" where nnn is the port number.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.Prefix Property

IWebServerPrefix Property
Gets the prefix that describes the combination of root and port.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Prefix { get; }
ReadOnly Property Prefix As String
    Get
property String^ Prefix {
    String^ get ();
}
abstract Prefix : string with get

Property Value

Type: String
Remarks
See http://msdn.microsoft.com/en-us/library/aa364698(VS.85).aspx for a description of prefix strings.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.Provider Property

IWebServerProvider Property
Gets or sets the provider used to wrap bits of the .NET framework.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServerProvider Provider { get; set; }
Property Provider As IWebServerProvider
    Get
    Set
property IWebServerProvider^ Provider {
    IWebServerProvider^ get ();
    void set (IWebServerProvider^ value);
}
abstract Provider : IWebServerProvider with get, set

Property Value

Type: IWebServerProvider
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.Root Property

IWebServerRoot Property
Gets or sets the root of the web site that the server will listen to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Root { get; set; }
Property Root As String
    Get
    Set
property String^ Root {
    String^ get ();
    void set (String^ value);
}
abstract Root : string with get, set

Property Value

Type: String
Remarks
The root is the full path from the address of the machine to the root of the site, e.g. /Foobar will be the root in the address http://127.0.0.1/Foobar. A leading slash and no trailing slash is enforced. Defaults to /.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer Methods

IWebServer Methods

The IWebServer type exposes the following members.

Methods
 | Name | Description
Public method | AddAdministratorPath | Tells the server that all access to this path must be authenticated and that the user must be configured as an administrator.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAdministratorPaths | Returns the paths that have been marked as requiring authentication.
Public method | GetRestrictedPathsMap | Returns a map of restricted paths to the Access describing which IPAddresses can access the path.
Public method | RemoveAdministratorPath | Tells the server that anyone can now access this path.
Public method | ResetCredentialCache | Clears the cache of credentials held by the server - see CacheCredentials.
Public method | SetRestrictedPath | Sets access on a restricted path. If access is null then the restrictions are removed from the path.
Top
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.AddAdministratorPath Method

IWebServerAddAdministratorPath Method
Tells the server that all access to this path must be authenticated and that the user must be configured as an administrator.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddAdministratorPath(
    string pathFromRoot
)
Sub AddAdministratorPath (
    pathFromRoot As String
)
void AddAdministratorPath(
    String^ pathFromRoot
)
abstract AddAdministratorPath :
        pathFromRoot : string -> unit

Parameters

pathFromRoot
Type: SystemString
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.GetAdministratorPaths Method

IWebServerGetAdministratorPaths Method
Returns the paths that have been marked as requiring authentication.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] GetAdministratorPaths()
Function GetAdministratorPaths As String()
array<String^>^ GetAdministratorPaths()
abstract GetAdministratorPaths : unit -> string[]

Return Value

Type: String
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.GetRestrictedPathsMap Method

IWebServerGetRestrictedPathsMap Method
Returns a map of restricted paths to the Access describing which IPAddresses can access the path.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, Access> GetRestrictedPathsMap()
Function GetRestrictedPathsMap As IDictionary(Of String, Access)
IDictionary<String^, Access^>^ GetRestrictedPathsMap()
abstract GetRestrictedPathsMap : unit -> IDictionary<string, Access>

Return Value

Type: IDictionary String, Access
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.RemoveAdministratorPath Method

IWebServerRemoveAdministratorPath Method
Tells the server that anyone can now access this path.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveAdministratorPath(
    string pathFromRoot
)
Sub RemoveAdministratorPath (
    pathFromRoot As String
)
void RemoveAdministratorPath(
    String^ pathFromRoot
)
abstract RemoveAdministratorPath :
        pathFromRoot : string -> unit

Parameters

pathFromRoot
Type: SystemString
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.ResetCredentialCache Method

IWebServerResetCredentialCache Method
Clears the cache of credentials held by the server - see CacheCredentials.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCredentialCache()
Sub ResetCredentialCache
void ResetCredentialCache()
abstract ResetCredentialCache : unit -> unit
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.SetRestrictedPath Method

IWebServerSetRestrictedPath Method
Sets access on a restricted path. If access is null then the restrictions are removed from the path.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetRestrictedPath(
    string pathFromRoot,
    Access access
)
Sub SetRestrictedPath (
    pathFromRoot As String,
    access As Access
)
void SetRestrictedPath(
    String^ pathFromRoot,
    Access^ access
)
abstract SetRestrictedPath :
        pathFromRoot : string *
        access : Access -> unit

Parameters

pathFromRoot
Type: SystemString
access
Type: VirtualRadar.Interface.SettingsAccess
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer Events

IWebServer Events

The IWebServer type exposes the following members.

Events
 | Name | Description
Public event | AfterRequestReceived | Raised on a background thread when the web server receives a request from a browser. Called after RequestReceived is raised.
Public event | AuthenticationRequired | Raised when the AuthenticationScheme is not 'None' and the browser has supplied credentials that need testing.
Public event | BeforeRequestReceived | Raised on a background thread when the web server receives a request from a browser. Called before RequestReceived is raised.
Public event | ExceptionCaught | Raised when an exception is caught on the background thread. The background thread should not pass ThreadAbortException through this. (Inherited from IBackgroundThreadExceptionCatcher.)
Public event | ExternalAddressChanged | Raised when the ExternalAddress property changes.
Public event | OnlineChanged | Raised when the Online property changes state.
Public event | RequestFinished | Raised after a response has been sent and the request completely closed down. The parameter is the UniqueId of the ResponseSentEventArgs original created for the request.
Public event | RequestReceived | Raised on a background thread when the web server receives a request from a browser.
Public event | ResponseSent | Raised on a background thread when the web server responds to a request.
Top
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.AfterRequestReceived Event

IWebServerAfterRequestReceived Event
Raised on a background thread when the web server receives a request from a browser. Called after RequestReceived is raised.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<RequestReceivedEventArgs> AfterRequestReceived
Event AfterRequestReceived As EventHandler(Of RequestReceivedEventArgs)
 event EventHandler<RequestReceivedEventArgs^>^ AfterRequestReceived {
    void add (EventHandler<RequestReceivedEventArgs^>^ value);
    void remove (EventHandler<RequestReceivedEventArgs^>^ value);
}
abstract AfterRequestReceived : IEvent<EventHandler<RequestReceivedEventArgs>,
    RequestReceivedEventArgs>

Value

Type: SystemEventHandler RequestReceivedEventArgs
Remarks
This event allows plugins to fulfil web requests that they are sure have not been handled by the main web site.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.AuthenticationRequired Event

IWebServerAuthenticationRequired Event
Raised when the AuthenticationScheme is not 'None' and the browser has supplied credentials that need testing.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AuthenticationRequiredEventArgs> AuthenticationRequired
Event AuthenticationRequired As EventHandler(Of AuthenticationRequiredEventArgs)
 event EventHandler<AuthenticationRequiredEventArgs^>^ AuthenticationRequired {
    void add (EventHandler<AuthenticationRequiredEventArgs^>^ value);
    void remove (EventHandler<AuthenticationRequiredEventArgs^>^ value);
}
abstract AuthenticationRequired : IEvent<EventHandler<AuthenticationRequiredEventArgs>,
    AuthenticationRequiredEventArgs>

Value

Type: SystemEventHandler AuthenticationRequiredEventArgs
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.BeforeRequestReceived Event

IWebServerBeforeRequestReceived Event
Raised on a background thread when the web server receives a request from a browser. Called before RequestReceived is raised.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<RequestReceivedEventArgs> BeforeRequestReceived
Event BeforeRequestReceived As EventHandler(Of RequestReceivedEventArgs)
 event EventHandler<RequestReceivedEventArgs^>^ BeforeRequestReceived {
    void add (EventHandler<RequestReceivedEventArgs^>^ value);
    void remove (EventHandler<RequestReceivedEventArgs^>^ value);
}
abstract BeforeRequestReceived : IEvent<EventHandler<RequestReceivedEventArgs>,
    RequestReceivedEventArgs>

Value

Type: SystemEventHandler RequestReceivedEventArgs
Remarks
This event allows plugins to intercept web requests before the main web site sees them. The main web site only hooks RequestReceived, if the plugin hooks this request and then sets Handled to true it will prevent the main web site from attempting to honour that request.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.ExternalAddressChanged Event

IWebServerExternalAddressChanged Event
Raised when the ExternalAddress property changes.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ExternalAddressChanged
Event ExternalAddressChanged As EventHandler
 event EventHandler^ ExternalAddressChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ExternalAddressChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.OnlineChanged Event

IWebServerOnlineChanged Event
Raised when the Online property changes state.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnlineChanged
Event OnlineChanged As EventHandler
 event EventHandler^ OnlineChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnlineChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.RequestFinished Event

IWebServerRequestFinished Event
Raised after a response has been sent and the request completely closed down. The parameter is the UniqueId of the ResponseSentEventArgs original created for the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<long>> RequestFinished
Event RequestFinished As EventHandler(Of EventArgs(Of Long))
 event EventHandler<EventArgs<long long>^>^ RequestFinished {
    void add (EventHandler<EventArgs<long long>^>^ value);
    void remove (EventHandler<EventArgs<long long>^>^ value);
}
abstract RequestFinished : IEvent<EventHandler<EventArgs<int64>>,
    EventArgs<int64>>

Value

Type: SystemEventHandler EventArgs Int64
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.RequestReceived Event

IWebServerRequestReceived Event
Raised on a background thread when the web server receives a request from a browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<RequestReceivedEventArgs> RequestReceived
Event RequestReceived As EventHandler(Of RequestReceivedEventArgs)
 event EventHandler<RequestReceivedEventArgs^>^ RequestReceived {
    void add (EventHandler<RequestReceivedEventArgs^>^ value);
    void remove (EventHandler<RequestReceivedEventArgs^>^ value);
}
abstract RequestReceived : IEvent<EventHandler<RequestReceivedEventArgs>,
    RequestReceivedEventArgs>

Value

Type: SystemEventHandler RequestReceivedEventArgs
Remarks
This is raised even if an event handler for BeforeRequestReceived flagged the request as having been handled. However the default web site will ignore requests that have been handled.
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServer.ResponseSent Event

IWebServerResponseSent Event
Raised on a background thread when the web server responds to a request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ResponseSentEventArgs> ResponseSent
Event ResponseSent As EventHandler(Of ResponseSentEventArgs)
 event EventHandler<ResponseSentEventArgs^>^ ResponseSent {
    void add (EventHandler<ResponseSentEventArgs^>^ value);
    void remove (EventHandler<ResponseSentEventArgs^>^ value);
}
abstract ResponseSent : IEvent<EventHandler<ResponseSentEventArgs>,
    ResponseSentEventArgs>

Value

Type: SystemEventHandler ResponseSentEventArgs
See Also

Reference

IWebServer Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider Interface

IWebServerProvider Interface
The provider that implementations of IWebServer should use to access the .NET framework.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebServerProvider : IDisposable
Public Interface IWebServerProvider
    Inherits IDisposable
public interface class IWebServerProvider : IDisposable
type IWebServerProvider =
    interface
        interface IDisposable
    end

The IWebServerProvider type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationSchemes | Gets or sets the authentication schemes that will be accepted by the server.
Public property | EnableCompression | Gets or sets a value indication that compression has been enabled by the user.
Public property | IsListening | Gets a value indicating that the listener is listening.
Public property | ListenerPrefix | Gets or sets the prefix that the webserver will listen to.
Public property | ListenerRealm | Gets the realm that the listener is responding to.
Public property | UtcNow | Gets the time now at UTC.
Top
Methods
 | Name | Description
Public method | BeginGetContext | Starts the process of listening for and retrieving the next IContext from the user on a background thread.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndGetContext | Retrieves the IContext that represents the request from the user.
Public method | GetHostAddresses | Returns the IP addresses for the local machine.
Public method | StartListener | Starts the web server.
Public method | StopListener | Stops the web server.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


IWebServerProvider Properties

IWebServerProvider Properties

The IWebServerProvider type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationSchemes | Gets or sets the authentication schemes that will be accepted by the server.
Public property | EnableCompression | Gets or sets a value indication that compression has been enabled by the user.
Public property | IsListening | Gets a value indicating that the listener is listening.
Public property | ListenerPrefix | Gets or sets the prefix that the webserver will listen to.
Public property | ListenerRealm | Gets the realm that the listener is responding to.
Public property | UtcNow | Gets the time now at UTC.
Top
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.AuthenticationSchemes Property

IWebServerProviderAuthenticationSchemes Property
Gets or sets the authentication schemes that will be accepted by the server.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AuthenticationSchemes AuthenticationSchemes { get; set; }
Property AuthenticationSchemes As AuthenticationSchemes
    Get
    Set
property AuthenticationSchemes AuthenticationSchemes {
    AuthenticationSchemes get ();
    void set (AuthenticationSchemes value);
}
abstract AuthenticationSchemes : AuthenticationSchemes with get, set

Property Value

Type: AuthenticationSchemes
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.EnableCompression Property

IWebServerProviderEnableCompression Property
Gets or sets a value indication that compression has been enabled by the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EnableCompression { get; set; }
Property EnableCompression As Boolean
    Get
    Set
property bool EnableCompression {
    bool get ();
    void set (bool value);
}
abstract EnableCompression : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.IsListening Property

IWebServerProviderIsListening Property
Gets a value indicating that the listener is listening.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsListening { get; }
ReadOnly Property IsListening As Boolean
    Get
property bool IsListening {
    bool get ();
}
abstract IsListening : bool with get

Property Value

Type: Boolean
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.ListenerPrefix Property

IWebServerProviderListenerPrefix Property
Gets or sets the prefix that the webserver will listen to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ListenerPrefix { get; set; }
Property ListenerPrefix As String
    Get
    Set
property String^ ListenerPrefix {
    String^ get ();
    void set (String^ value);
}
abstract ListenerPrefix : string with get, set

Property Value

Type: String
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.ListenerRealm Property

IWebServerProviderListenerRealm Property
Gets the realm that the listener is responding to.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ListenerRealm { get; }
ReadOnly Property ListenerRealm As String
    Get
property String^ ListenerRealm {
    String^ get ();
}
abstract ListenerRealm : string with get

Property Value

Type: String
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.UtcNow Property

IWebServerProviderUtcNow Property
Gets the time now at UTC.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UtcNow { get; }
ReadOnly Property UtcNow As DateTime
    Get
property DateTime UtcNow {
    DateTime get ();
}
abstract UtcNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider Methods

IWebServerProvider Methods

The IWebServerProvider type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetContext | Starts the process of listening for and retrieving the next IContext from the user on a background thread.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndGetContext | Retrieves the IContext that represents the request from the user.
Public method | GetHostAddresses | Returns the IP addresses for the local machine.
Public method | StartListener | Starts the web server.
Public method | StopListener | Stops the web server.
Top
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.BeginGetContext Method

IWebServerProviderBeginGetContext Method
Starts the process of listening for and retrieving the next IContext from the user on a background thread.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IAsyncResult BeginGetContext(
    AsyncCallback callback
)
Function BeginGetContext (
    callback As AsyncCallback
) As IAsyncResult
IAsyncResult^ BeginGetContext(
    AsyncCallback^ callback
)
abstract BeginGetContext :
        callback : AsyncCallback -> IAsyncResult

Parameters

callback
Type: SystemAsyncCallback

Return Value

Type: IAsyncResult
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.EndGetContext Method

IWebServerProviderEndGetContext Method
Retrieves the IContext that represents the request from the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IContext EndGetContext(
    IAsyncResult asyncResult
)
Function EndGetContext (
    asyncResult As IAsyncResult
) As IContext
IContext^ EndGetContext(
    IAsyncResult^ asyncResult
)
abstract EndGetContext :
        asyncResult : IAsyncResult -> IContext

Parameters

asyncResult
Type: SystemIAsyncResult

Return Value

Type: IContext
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.GetHostAddresses Method

IWebServerProviderGetHostAddresses Method
Returns the IP addresses for the local machine.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IPAddress[] GetHostAddresses()
Function GetHostAddresses As IPAddress()
array<IPAddress^>^ GetHostAddresses()
abstract GetHostAddresses : unit -> IPAddress[]

Return Value

Type: IPAddress
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.StartListener Method

IWebServerProviderStartListener Method
Starts the web server.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartListener()
Sub StartListener
void StartListener()
abstract StartListener : unit -> unit
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


IWebServerProvider.StopListener Method

IWebServerProviderStopListener Method
Stops the web server.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void StopListener()
Sub StopListener
void StopListener()
abstract StopListener : unit -> unit
See Also

Reference

IWebServerProvider Interface
VirtualRadar.Interface.WebServer Namespace


MimeType Class

MimeType Class
A collection of different mime types.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebServerMimeType

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MimeType
Public NotInheritable Class MimeType
public ref class MimeType abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MimeType =  class end

The MimeType type exposes the following members.

Properties
Name | Description
BitmapImage | Gets the MIME type for a .BMP file.
Css | Gets the MIME type for a cascading stylesheet file.
GifImage | Gets the MIME type for a .GIF file.
Html | Gets the MIME type for an HTML file.
IconImage | Gets the MIME type for a .ICO file.
Javascript | Gets the MIME type for a .JS file.
JpegImage | Gets the MIME type for a .JPG file.
Json | Gets the MIME type for a JSON text file.
PngImage | Gets the MIME type for a .PNG file.
Text | Gets the MIME type for a plain text file.
TiffImage | Gets the MIME type for a .TIF file.
WaveAudio | Gets the MIME type for a .WAV file.
Top
Methods
Name | Description
GetContentClassification | Returns the appropriate classification for a mime type.
GetForExtension | Returns the MIME type for a file extension. The leading full-stop on the extension is optional.
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


MimeType Properties

MimeType Properties

The MimeType type exposes the following members.

Properties
Name | Description
BitmapImage | Gets the MIME type for a .BMP file.
Css | Gets the MIME type for a cascading stylesheet file.
GifImage | Gets the MIME type for a .GIF file.
Html | Gets the MIME type for an HTML file.
IconImage | Gets the MIME type for a .ICO file.
Javascript | Gets the MIME type for a .JS file.
JpegImage | Gets the MIME type for a .JPG file.
Json | Gets the MIME type for a JSON text file.
PngImage | Gets the MIME type for a .PNG file.
Text | Gets the MIME type for a plain text file.
TiffImage | Gets the MIME type for a .TIF file.
WaveAudio | Gets the MIME type for a .WAV file.
Top
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.BitmapImage Property

MimeTypeBitmapImage Property
Gets the MIME type for a .BMP file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BitmapImage { get; }
Public Shared ReadOnly Property BitmapImage As String
    Get
public:
static property String^ BitmapImage {
    String^ get ();
}
static member BitmapImage : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.Css Property

MimeTypeCss Property
Gets the MIME type for a cascading stylesheet file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Css { get; }
Public Shared ReadOnly Property Css As String
    Get
public:
static property String^ Css {
    String^ get ();
}
static member Css : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.GifImage Property

MimeTypeGifImage Property
Gets the MIME type for a .GIF file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GifImage { get; }
Public Shared ReadOnly Property GifImage As String
    Get
public:
static property String^ GifImage {
    String^ get ();
}
static member GifImage : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.Html Property

MimeTypeHtml Property
Gets the MIME type for an HTML file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Html { get; }
Public Shared ReadOnly Property Html As String
    Get
public:
static property String^ Html {
    String^ get ();
}
static member Html : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.IconImage Property

MimeTypeIconImage Property
Gets the MIME type for a .ICO file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IconImage { get; }
Public Shared ReadOnly Property IconImage As String
    Get
public:
static property String^ IconImage {
    String^ get ();
}
static member IconImage : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.Javascript Property

MimeTypeJavascript Property
Gets the MIME type for a .JS file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Javascript { get; }
Public Shared ReadOnly Property Javascript As String
    Get
public:
static property String^ Javascript {
    String^ get ();
}
static member Javascript : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.JpegImage Property

MimeTypeJpegImage Property
Gets the MIME type for a .JPG file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string JpegImage { get; }
Public Shared ReadOnly Property JpegImage As String
    Get
public:
static property String^ JpegImage {
    String^ get ();
}
static member JpegImage : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.Json Property

MimeTypeJson Property
Gets the MIME type for a JSON text file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Json { get; }
Public Shared ReadOnly Property Json As String
    Get
public:
static property String^ Json {
    String^ get ();
}
static member Json : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.PngImage Property

MimeTypePngImage Property
Gets the MIME type for a .PNG file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PngImage { get; }
Public Shared ReadOnly Property PngImage As String
    Get
public:
static property String^ PngImage {
    String^ get ();
}
static member PngImage : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.Text Property

MimeTypeText Property
Gets the MIME type for a plain text file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Text { get; }
Public Shared ReadOnly Property Text As String
    Get
public:
static property String^ Text {
    String^ get ();
}
static member Text : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.TiffImage Property

MimeTypeTiffImage Property
Gets the MIME type for a .TIF file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TiffImage { get; }
Public Shared ReadOnly Property TiffImage As String
    Get
public:
static property String^ TiffImage {
    String^ get ();
}
static member TiffImage : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.WaveAudio Property

MimeTypeWaveAudio Property
Gets the MIME type for a .WAV file.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WaveAudio { get; }
Public Shared ReadOnly Property WaveAudio As String
    Get
public:
static property String^ WaveAudio {
    String^ get ();
}
static member WaveAudio : string with get

Property Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType Methods

MimeType Methods

The MimeType type exposes the following members.

Methods
Name | Description
GetContentClassification | Returns the appropriate classification for a mime type.
GetForExtension | Returns the MIME type for a file extension. The leading full-stop on the extension is optional.
Top
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.GetContentClassification Method

MimeTypeGetContentClassification Method
Returns the appropriate classification for a mime type.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ContentClassification GetContentClassification(
    string mimeType
)
Public Shared Function GetContentClassification (
    mimeType As String
) As ContentClassification
public:
static ContentClassification GetContentClassification(
    String^ mimeType
)
static member GetContentClassification :
        mimeType : string -> ContentClassification

Parameters

mimeType
Type: SystemString

Return Value

Type: ContentClassification
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


MimeType.GetForExtension Method

MimeTypeGetForExtension Method
Returns the MIME type for a file extension. The leading full-stop on the extension is optional.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetForExtension(
    string extension
)
Public Shared Function GetForExtension (
    extension As String
) As String
public:
static String^ GetForExtension(
    String^ extension
)
static member GetForExtension :
        extension : string -> string

Parameters

extension
Type: SystemString

Return Value

Type: String
See Also

Reference

MimeType Class
VirtualRadar.Interface.WebServer Namespace


RequestException Class

RequestException Class
An exception that is thrown when an exception occurs during the handling of a web server request.
Inheritance Hierarchy
SystemObject
SystemException
VirtualRadar.Interface.WebServerRequestException

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RequestException : Exception
<SerializableAttribute>
Public Class RequestException
    Inherits Exception
[SerializableAttribute]
public ref class RequestException : public Exception
[<SerializableAttribute>]
type RequestException =
    class
        inherit Exception
    end

The RequestException type exposes the following members.

Constructors
 | Name | Description
Public method | RequestException | See base docs.
Public method | RequestException(String) | See base docs.
Protected method | RequestException(SerializationInfo, StreamingContext) | See base docs.
Public method | RequestException(String, Exception) | See base docs.
Public method | RequestException(IRequest, Exception) | Wraps an exception that was thrown while a request was being processed. Gives a little more information about the request that triggered the exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


RequestException Constructor

RequestException Constructor
Overload List
 | Name | Description
Public method | RequestException | See base docs.
Public method | RequestException(String) | See base docs.
Protected method | RequestException(SerializationInfo, StreamingContext) | See base docs.
Public method | RequestException(String, Exception) | See base docs.
Public method | RequestException(IRequest, Exception) | Wraps an exception that was thrown while a request was being processed. Gives a little more information about the request that triggered the exception.
Top
See Also

Reference

RequestException Class
VirtualRadar.Interface.WebServer Namespace


RequestException Constructor

RequestException Constructor
See base docs.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RequestException()
Public Sub New
public:
RequestException()
new : unit -> RequestException
See Also

Reference

RequestException Class
RequestException Overload
VirtualRadar.Interface.WebServer Namespace


RequestException Constructor (String)

RequestException Constructor (String)
See base docs.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RequestException(
    string message
)
Public Sub New (
    message As String
)
public:
RequestException(
    String^ message
)
new :
        message : string -> RequestException

Parameters

message
Type: SystemString
See Also

Reference

RequestException Class
RequestException Overload
VirtualRadar.Interface.WebServer Namespace


RequestException Constructor (SerializationInfo, StreamingContext)

RequestException Constructor (SerializationInfo, StreamingContext)
See base docs.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected RequestException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
RequestException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RequestException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

RequestException Class
RequestException Overload
VirtualRadar.Interface.WebServer Namespace


RequestException Constructor (String, Exception)

RequestException Constructor (String, Exception)
See base docs.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RequestException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
RequestException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> RequestException

Parameters

message
Type: SystemString
inner
Type: SystemException
See Also

Reference

RequestException Class
RequestException Overload
VirtualRadar.Interface.WebServer Namespace


RequestException Constructor (IRequest, Exception)

RequestException Constructor (IRequest, Exception)
Wraps an exception that was thrown while a request was being processed. Gives a little more information about the request that triggered the exception.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RequestException(
    IRequest request,
    Exception inner
)
Public Sub New (
    request As IRequest,
    inner As Exception
)
public:
RequestException(
    IRequest^ request,
    Exception^ inner
)
new :
        request : IRequest *
        inner : Exception -> RequestException

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
inner
Type: SystemException
See Also

Reference

RequestException Class
RequestException Overload
VirtualRadar.Interface.WebServer Namespace


RequestException Properties

RequestException Properties

The RequestException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

RequestException Class
VirtualRadar.Interface.WebServer Namespace


RequestException Methods

RequestException Methods

The RequestException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

RequestException Class
VirtualRadar.Interface.WebServer Namespace


RequestException Events

RequestException Events

The RequestException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

RequestException Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs Class

RequestReceivedEventArgs Class
The arguments passed for the RequestReceived event on IWebServer.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.WebServerRequestReceivedEventArgs

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RequestReceivedEventArgs : EventArgs
Public Class RequestReceivedEventArgs
    Inherits EventArgs
public ref class RequestReceivedEventArgs : public EventArgs
type RequestReceivedEventArgs =
    class
        inherit EventArgs
    end

The RequestReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RequestReceivedEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | Classification | Gets or sets a value indicating the classification that has been assigned to the response.
Public property | ClientAddress | Gets the address of the machine that is accessing the server. If the request is going through a reverse proxy then it is the address of the machine that accessed the reverse proxy.
Public property | File | Gets the file portion of PathAndFile or an empty string if there is no file portion.
Public property | Handled | Gets or sets a value indicating that an event handler somewhere has dealt with the request and produced an appropriate response.
Public property | IsAndroid | Gets a value indicating that the request probably came from an Android device.
Public property | IsInternetRequest | Gets a value indicating whether the request originated from the Internet.
Public property | IsIPad | Gets a value indicating that the request probably came from an iPad.
Public property | IsIPhone | Gets a value indicating that the request probably came from an iPhone.
Public property | IsIPod | Gets a value indicating that the request probably came from an iPod.
Public property | Path | Gets the path portion of PathAndFile or '/' if the request is for a file in the root.
Public property | PathAndFile | Gets the requested path from the root of the site.
Public property | PathParts | Gets a list of the folders from the root to the file. An empty list indicates that the file is in root.
Public property | ProxyAddress | Gets the address of the reverse proxy that forwarded this request to the server.
Public property | QueryString | Gets the query string portions sent with the request.
Public property | Request | Gets details of the page requested by the user.
Public property | Response | Gets details of the response to send back to the user.
Public property | Root | Gets the root of the website.
Public property | UniqueId | Gets a value that uniquely identifies the request.
Public property | UserName | Gets or sets the user name used to authenticate the request, if any.
Public property | WebSite | Gets the website address, as seen by the browser.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs Constructor

RequestReceivedEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RequestReceivedEventArgs(
    IRequest request,
    IResponse response,
    string root
)
Public Sub New (
    request As IRequest,
    response As IResponse,
    root As String
)
public:
RequestReceivedEventArgs(
    IRequest^ request,
    IResponse^ response,
    String^ root
)
new :
        request : IRequest *
        response : IResponse *
        root : string -> RequestReceivedEventArgs

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
response
Type: VirtualRadar.Interface.WebServerIResponse
root
Type: SystemString
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs Properties

RequestReceivedEventArgs Properties

The RequestReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Classification | Gets or sets a value indicating the classification that has been assigned to the response.
Public property | ClientAddress | Gets the address of the machine that is accessing the server. If the request is going through a reverse proxy then it is the address of the machine that accessed the reverse proxy.
Public property | File | Gets the file portion of PathAndFile or an empty string if there is no file portion.
Public property | Handled | Gets or sets a value indicating that an event handler somewhere has dealt with the request and produced an appropriate response.
Public property | IsAndroid | Gets a value indicating that the request probably came from an Android device.
Public property | IsInternetRequest | Gets a value indicating whether the request originated from the Internet.
Public property | IsIPad | Gets a value indicating that the request probably came from an iPad.
Public property | IsIPhone | Gets a value indicating that the request probably came from an iPhone.
Public property | IsIPod | Gets a value indicating that the request probably came from an iPod.
Public property | Path | Gets the path portion of PathAndFile or '/' if the request is for a file in the root.
Public property | PathAndFile | Gets the requested path from the root of the site.
Public property | PathParts | Gets a list of the folders from the root to the file. An empty list indicates that the file is in root.
Public property | ProxyAddress | Gets the address of the reverse proxy that forwarded this request to the server.
Public property | QueryString | Gets the query string portions sent with the request.
Public property | Request | Gets details of the page requested by the user.
Public property | Response | Gets details of the response to send back to the user.
Public property | Root | Gets the root of the website.
Public property | UniqueId | Gets a value that uniquely identifies the request.
Public property | UserName | Gets or sets the user name used to authenticate the request, if any.
Public property | WebSite | Gets the website address, as seen by the browser.
Top
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.Classification Property

RequestReceivedEventArgsClassification Property
Gets or sets a value indicating the classification that has been assigned to the response.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContentClassification Classification { get; set; }
Public Property Classification As ContentClassification
    Get
    Set
public:
property ContentClassification Classification {
    ContentClassification get ();
    void set (ContentClassification value);
}
member Classification : ContentClassification with get, set

Property Value

Type: ContentClassification
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.ClientAddress Property

RequestReceivedEventArgsClientAddress Property
Gets the address of the machine that is accessing the server. If the request is going through a reverse proxy then it is the address of the machine that accessed the reverse proxy.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClientAddress { get; }
Public ReadOnly Property ClientAddress As String
    Get
public:
property String^ ClientAddress {
    String^ get ();
}
member ClientAddress : string with get

Property Value

Type: String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.File Property

RequestReceivedEventArgsFile Property
Gets the file portion of PathAndFile or an empty string if there is no file portion.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string File { get; }
Public ReadOnly Property File As String
    Get
public:
property String^ File {
    String^ get ();
}
member File : string with get

Property Value

Type: String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.Handled Property

RequestReceivedEventArgsHandled Property
Gets or sets a value indicating that an event handler somewhere has dealt with the request and produced an appropriate response.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.IsAndroid Property

RequestReceivedEventArgsIsAndroid Property
Gets a value indicating that the request probably came from an Android device.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAndroid { get; }
Public ReadOnly Property IsAndroid As Boolean
    Get
public:
property bool IsAndroid {
    bool get ();
}
member IsAndroid : bool with get

Property Value

Type: Boolean
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.IsInternetRequest Property

RequestReceivedEventArgsIsInternetRequest Property
Gets a value indicating whether the request originated from the Internet.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInternetRequest { get; }
Public ReadOnly Property IsInternetRequest As Boolean
    Get
public:
property bool IsInternetRequest {
    bool get ();
}
member IsInternetRequest : bool with get

Property Value

Type: Boolean
Remarks
This takes into account reverse proxies when determining whether the request came from the Internet.
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.IsIPad Property

RequestReceivedEventArgsIsIPad Property
Gets a value indicating that the request probably came from an iPad.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIPad { get; }
Public ReadOnly Property IsIPad As Boolean
    Get
public:
property bool IsIPad {
    bool get ();
}
member IsIPad : bool with get

Property Value

Type: Boolean
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.IsIPhone Property

RequestReceivedEventArgsIsIPhone Property
Gets a value indicating that the request probably came from an iPhone.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIPhone { get; }
Public ReadOnly Property IsIPhone As Boolean
    Get
public:
property bool IsIPhone {
    bool get ();
}
member IsIPhone : bool with get

Property Value

Type: Boolean
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.IsIPod Property

RequestReceivedEventArgsIsIPod Property
Gets a value indicating that the request probably came from an iPod.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIPod { get; }
Public ReadOnly Property IsIPod As Boolean
    Get
public:
property bool IsIPod {
    bool get ();
}
member IsIPod : bool with get

Property Value

Type: Boolean
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.Path Property

RequestReceivedEventArgsPath Property
Gets the path portion of PathAndFile or '/' if the request is for a file in the root.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.PathAndFile Property

RequestReceivedEventArgsPathAndFile Property
Gets the requested path from the root of the site.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PathAndFile { get; }
Public ReadOnly Property PathAndFile As String
    Get
public:
property String^ PathAndFile {
    String^ get ();
}
member PathAndFile : string with get

Property Value

Type: String
Remarks
If the server root is /Root then for the RawUrl of '/Root' this would return '/', for the RawUrl of '/Root/' it would also return '/', for '/Root/Page.htm' it would return '/Page.htm', '/Root/Folder/' it would return '/Folder/' and so on. Query strings are stripped off and escaped characters are unescaped.
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.PathParts Property

RequestReceivedEventArgsPathParts Property
Gets a list of the folders from the root to the file. An empty list indicates that the file is in root.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> PathParts { get; }
Public ReadOnly Property PathParts As List(Of String)
    Get
public:
property List<String^>^ PathParts {
    List<String^>^ get ();
}
member PathParts : List<string> with get

Property Value

Type: List String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.ProxyAddress Property

RequestReceivedEventArgsProxyAddress Property
Gets the address of the reverse proxy that forwarded this request to the server.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProxyAddress { get; }
Public ReadOnly Property ProxyAddress As String
    Get
public:
property String^ ProxyAddress {
    String^ get ();
}
member ProxyAddress : string with get

Property Value

Type: String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.QueryString Property

RequestReceivedEventArgsQueryString Property
Gets the query string portions sent with the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NameValueCollection QueryString { get; }
Public ReadOnly Property QueryString As NameValueCollection
    Get
public:
property NameValueCollection^ QueryString {
    NameValueCollection^ get ();
}
member QueryString : NameValueCollection with get

Property Value

Type: NameValueCollection
Remarks
For the URL 'http://127.0.0.1/Root/File.txt?val1=10&val2=20' there would be two name-value pairs in the container for val1 = 10 and val2 = 20.
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.Request Property

RequestReceivedEventArgsRequest Property
Gets details of the page requested by the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRequest Request { get; }
Public ReadOnly Property Request As IRequest
    Get
public:
property IRequest^ Request {
    IRequest^ get ();
}
member Request : IRequest with get

Property Value

Type: IRequest
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.Response Property

RequestReceivedEventArgsResponse Property
Gets details of the response to send back to the user.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IResponse Response { get; }
Public ReadOnly Property Response As IResponse
    Get
public:
property IResponse^ Response {
    IResponse^ get ();
}
member Response : IResponse with get

Property Value

Type: IResponse
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.Root Property

RequestReceivedEventArgsRoot Property
Gets the root of the website.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Root { get; }
Public ReadOnly Property Root As String
    Get
public:
property String^ Root {
    String^ get ();
}
member Root : string with get

Property Value

Type: String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.UniqueId Property

RequestReceivedEventArgsUniqueId Property
Gets a value that uniquely identifies the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long UniqueId { get; }
Public ReadOnly Property UniqueId As Long
    Get
public:
property long long UniqueId {
    long long get ();
}
member UniqueId : int64 with get

Property Value

Type: Int64
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.UserName Property

RequestReceivedEventArgsUserName Property
Gets or sets the user name used to authenticate the request, if any.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs.WebSite Property

RequestReceivedEventArgsWebSite Property
Gets the website address, as seen by the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WebSite { get; }
Public ReadOnly Property WebSite As String
    Get
public:
property String^ WebSite {
    String^ get ();
}
member WebSite : string with get

Property Value

Type: String
Remarks
If the request URL is 'http://192.168.0.1/MyRoot/MyPage.html' then this would be 'http://192.168.0.1/MyRoot'.
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


RequestReceivedEventArgs Methods

RequestReceivedEventArgs Methods

The RequestReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RequestReceivedEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs Class

ResponseSentEventArgs Class
The event args for IWebServer events that are raised when a response is sent to a web browser.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.WebServerResponseSentEventArgs

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ResponseSentEventArgs : EventArgs
Public Class ResponseSentEventArgs
    Inherits EventArgs
public ref class ResponseSentEventArgs : public EventArgs
type ResponseSentEventArgs =
    class
        inherit EventArgs
    end

The ResponseSentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResponseSentEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | BytesSent | Gets the bytes sent in response to the request.
Public property | Classification | Gets a value indicating the type of content served.
Public property | HttpStatus | Gets the HTTP status code send to the browser.
Public property | Milliseconds | Gets the number of milliseconds that elapsed between the RequestReceived event being raised and the response returned.
Public property | Request | Gets the object describing the original request.
Public property | UrlRequested | Gets the address of the page requested.
Public property | UserAddress | Gets the address without the port of the browser that requested the page.
Public property | UserAddressAndPort | Gets the full address and port of the browser that requested the page.
Public property | UserName | Gets the name of the authenticated user that made the request, if any.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs Constructor

ResponseSentEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResponseSentEventArgs(
    string urlRequested,
    string userAddressAndPort,
    string userAddress,
    long bytesSent,
    ContentClassification classification,
    IRequest request,
    int httpStatus,
    int milliseconds,
    string userName
)
Public Sub New (
    urlRequested As String,
    userAddressAndPort As String,
    userAddress As String,
    bytesSent As Long,
    classification As ContentClassification,
    request As IRequest,
    httpStatus As Integer,
    milliseconds As Integer,
    userName As String
)
public:
ResponseSentEventArgs(
    String^ urlRequested,
    String^ userAddressAndPort,
    String^ userAddress,
    long long bytesSent,
    ContentClassification classification,
    IRequest^ request,
    int httpStatus,
    int milliseconds,
    String^ userName
)
new :
        urlRequested : string *
        userAddressAndPort : string *
        userAddress : string *
        bytesSent : int64 *
        classification : ContentClassification *
        request : IRequest *
        httpStatus : int *
        milliseconds : int *
        userName : string -> ResponseSentEventArgs

Parameters

urlRequested
Type: SystemString
userAddressAndPort
Type: SystemString
userAddress
Type: SystemString
bytesSent
Type: SystemInt64
classification
Type: VirtualRadar.Interface.WebServerContentClassification
request
Type: VirtualRadar.Interface.WebServerIRequest
httpStatus
Type: SystemInt32
milliseconds
Type: SystemInt32
userName
Type: SystemString
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs Properties

ResponseSentEventArgs Properties

The ResponseSentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BytesSent | Gets the bytes sent in response to the request.
Public property | Classification | Gets a value indicating the type of content served.
Public property | HttpStatus | Gets the HTTP status code send to the browser.
Public property | Milliseconds | Gets the number of milliseconds that elapsed between the RequestReceived event being raised and the response returned.
Public property | Request | Gets the object describing the original request.
Public property | UrlRequested | Gets the address of the page requested.
Public property | UserAddress | Gets the address without the port of the browser that requested the page.
Public property | UserAddressAndPort | Gets the full address and port of the browser that requested the page.
Public property | UserName | Gets the name of the authenticated user that made the request, if any.
Top
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.BytesSent Property

ResponseSentEventArgsBytesSent Property
Gets the bytes sent in response to the request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long BytesSent { get; }
Public ReadOnly Property BytesSent As Long
    Get
public:
property long long BytesSent {
    long long get ();
}
member BytesSent : int64 with get

Property Value

Type: Int64
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.Classification Property

ResponseSentEventArgsClassification Property
Gets a value indicating the type of content served.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContentClassification Classification { get; }
Public ReadOnly Property Classification As ContentClassification
    Get
public:
property ContentClassification Classification {
    ContentClassification get ();
}
member Classification : ContentClassification with get

Property Value

Type: ContentClassification
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.HttpStatus Property

ResponseSentEventArgsHttpStatus Property
Gets the HTTP status code send to the browser.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int HttpStatus { get; }
Public ReadOnly Property HttpStatus As Integer
    Get
public:
property int HttpStatus {
    int get ();
}
member HttpStatus : int with get

Property Value

Type: Int32
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.Milliseconds Property

ResponseSentEventArgsMilliseconds Property
Gets the number of milliseconds that elapsed between the RequestReceived event being raised and the response returned.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Milliseconds { get; }
Public ReadOnly Property Milliseconds As Integer
    Get
public:
property int Milliseconds {
    int get ();
}
member Milliseconds : int with get

Property Value

Type: Int32
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.Request Property

ResponseSentEventArgsRequest Property
Gets the object describing the original request.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRequest Request { get; }
Public ReadOnly Property Request As IRequest
    Get
public:
property IRequest^ Request {
    IRequest^ get ();
}
member Request : IRequest with get

Property Value

Type: IRequest
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.UrlRequested Property

ResponseSentEventArgsUrlRequested Property
Gets the address of the page requested.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UrlRequested { get; }
Public ReadOnly Property UrlRequested As String
    Get
public:
property String^ UrlRequested {
    String^ get ();
}
member UrlRequested : string with get

Property Value

Type: String
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.UserAddress Property

ResponseSentEventArgsUserAddress Property
Gets the address without the port of the browser that requested the page.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserAddress { get; }
Public ReadOnly Property UserAddress As String
    Get
public:
property String^ UserAddress {
    String^ get ();
}
member UserAddress : string with get

Property Value

Type: String
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.UserAddressAndPort Property

ResponseSentEventArgsUserAddressAndPort Property
Gets the full address and port of the browser that requested the page.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserAddressAndPort { get; }
Public ReadOnly Property UserAddressAndPort As String
    Get
public:
property String^ UserAddressAndPort {
    String^ get ();
}
member UserAddressAndPort : string with get

Property Value

Type: String
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs.UserName Property

ResponseSentEventArgsUserName Property
Gets the name of the authenticated user that made the request, if any.

Namespace: VirtualRadar.Interface.WebServer
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}
member UserName : string with get

Property Value

Type: String
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


ResponseSentEventArgs Methods

ResponseSentEventArgs Methods

The ResponseSentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResponseSentEventArgs Class
VirtualRadar.Interface.WebServer Namespace


VirtualRadar.Interface.WebSite Namespace

VirtualRadar.Interface.WebSite Namespace
The namespace for the interfaces and objects that deal with the web site that the program produces.
Classes
 | Class | Description
Public class | AircraftJson | The object that describes an aircraft in JSON files that are sent to the browser.
Public class | AircraftListJson | The list of aircraft that is sent to the browser as a JSON file.
Public class | AircraftListJsonBuilderArgs | The object that passes arguments to the Build(AircraftListJsonBuilderArgs) method.
Public class | AircraftListJsonBuilderFilter | The arguments passed to Build(AircraftListJsonBuilderArgs) that can be used to suppress aircraft from the generated JSON.
Public class | AircraftReportJson | The top-level JSON object for reports on the flights taken by a single aircraft.
Public class | ChecksumFile | A class that can read a checksum file.
Public class | ChecksumFileEntry | Describes the content of a single line in a checksum file resource.
Public class | DirectoryEntryJson | The JSON object that carries directory information back to the VRS mothership.
Public class | FeedJson | The JSON object that describes a data feed from a receiver.
Public class | FlightReportJson | The top-level JSON object for reports on the flights taken by many aircraft.
Public class | HtmlContentInjector | A class that describes content to inject into HTML.
Public class | PolarPlotJson | The JSON for a single polar plot.
Public class | PolarPlotsJson | The JSON that describes all of the available polar plots for a single feed.
Public class | PolarPlotsSliceJson | The JSON for a polar plot slice.
Public class | ProximityGadgetAircraftJson | The data transfer object for the JSON file that is sent to the Windows 7 promixity gadget.
Public class | ProximityGadgetClosestAircraftJson | The DTO that carries information about the closest aircraft to the Windows Vista/7 proximity gadget.
Public class | ReportAircraftJson | Describes an aircraft in a report.
Public class | ReportAirportJson | Describes a single instance of an airport in a report.
Public class | ReportFlightJson | Describes the flight of an aircraft in a report.
Public class | ReportRouteJson | Describes the route taken by an aircraft.
Public class | ReportRowsJson | The base class for all top-level report JSON objects.
Public class | ServerConfigJson | The JSON object that carries server settings to the site.
Public class | ServerReceiverJson | The JSON object that describes a receiver that the server is listening to.
Public class | SimpleContent | The object returned by RequestSimpleContent(String).
Public class | SiteRoot | A class that describes a root folder to serve files from.
Public class | TextContentEventArgs | The event args that are raised by the web site for text content events.
Public class | WebAdminMethodAttribute | Marks a method on a view returned by a WebAdminView as being callable from the web page.
Public class | WebAdminView | The class that describes a web admin view.
Interfaces
 | Interface | Description
Public interface | IAircraftListJsonBuilder | The interface for an object that can build an AircraftListJson object from an IAircraftList object's list of aircraft.
Public interface | IBundler | The interface for objects that can bundle multiple JavaScript declarations in an HTML file into a single download.
Public interface | IHtmlLocaliser | The interface for objects that can localise HTML using string resources.
Public interface | IMinifier | The interface for an object that can minify JavaScript and CSS.
Public interface | IWebAdminViewManager | The interface that objects which handle collections of WebAdminViews must implement.
Public interface | IWebSite | The interface for objects that bring together a collection of pages into the website that is presented to the browser.
Public interface | IWebSiteExtender | The interface for a wrapper around the extension methods exposed in IWebSite. Intended for use by plugins to make life a bit easier for those that want to extend the website.
Public interface | IWebSiteGraphics | The interface for objects that handle graphics manipulation for the web site.
Public interface | IWebSiteProvider | The interface for the provider on VirtualRadar.Interface.WebSite that abstracts away parts of the environment that we want to control during testing.
Enumerations
 | Enumeration | Description
Public enumeration | ResizeImageMode | An enumeration of the different resize modes supported by the website graphics code.
Public enumeration | StandardWebSiteImageSize | An enumeration of the standard sizes for images used by the web site.
Public enumeration | TrailType | An enumeration of the different trail types.
Remarks

The main interface of interest here is IWebSite. This listens for requests for content coming from IWebServer and responds to them with the HTML, JS, JSON and image files that between them make up the web site.


AircraftJson Class

AircraftJson Class
The object that describes an aircraft in JSON files that are sent to the browser.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteAircraftJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftJson
Public Class AircraftJson
public ref class AircraftJson
type AircraftJson =  class end

The AircraftJson type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftJson | Initializes a new instance of the AircraftJson class
Top
Properties
 | Name | Description
Public property | AirPressureInHg | Gets or sets the aircraft's air pressure setting in inches of mercury.
Public property | Altitude | Gets or sets the aircraft's pressure altitude in feet.
Public property | AltitudeType | Gets or sets the type of altitude transmitted by the aircraft.
Public property | BearingFromHere | Gets or sets the bearing from the browser to the aircraft in degrees from 0° north.
Public property | Callsign | Gets or sets the aircraft's callsign.
Public property | CallsignIsSuspect | Gets or sets a value indicating that the Callsign came from an unreliable source.
Public property | ConstructionNumber | Gets or sets the construction / serial number of the aircraft.
Public property | CountMessagesReceived | Gets or sets the number of messages received for the aircraft.
Public property | Destination | Gets or sets the airport that the aircraft is travelling to.
Public property | DistanceFromHere | Gets or sets the distance from the browser's location to the aircraft in kilometres.
Public property | Emergency | Gets or sets a flag indicating that the aircraft is transmitting a mayday squawk.
Public property | EnginePlacement | Gets or sets a value indicating the placement of the engines mounted to the aircraft (see EnginePlacement).
Public property | EngineType | Gets or sets a value indicating the type of engines that the aircraft uses (see EngineType).
Public property | FirstSeen | Gets or sets the date and time (UTC) that a transmission from the aircraft was first received by the server.
Public property | FlightsCount | Gets or sets a value indicating how many flights this aircraft has logged in the BaseStation database.
Public property | FullCoordinates | Gets or sets a list of coordinates representing the full trail for the aircraft. If ResetTrail is true then it is the entire trail, otherwise it extends the existing trail.
Public property | GeometricAltitude | Gets or sets the aircraft's geometric altitude in feet.
Public property | GroundSpeed | Gets or sets the ground speed of the aircraft in knots.
Public property | HasPicture | Gets or sets a value indicating that the server can supply a picture of the aircraft.
Public property | HasSignalLevel | Gets or sets a value indicating whether the receiver emitted a signal level for the aircraft.
Public property | Icao24 | Gets or sets the 24-bit Mode-S identifier of the aircraft.
Public property | Icao24Country | Gets or sets the country that the aircraft's Icao24 was allocated to.
Public property | Icao24Invalid | Gets or sets a value indicating that the Icao24 code is wrong - either it is an unallocated code or the aircraft is known to be transmitting the wrong code.
Public property | IsInteresting | Gets or sets a value indicating that the aircraft is flagged as interesting in the BaseStation database.
Public property | IsMilitary | Gets or sets a value indicating that the aircraft is operated by a country's military.
Public property | IsSatcomFeed | Gets or sets a value indicating that the aircraft was seen on a SatCom feed.
Public property | IsTisb | Gets or sets a value indicating that the last message received for this aircraft was from a TIS-B source.
Public property | Latitude | Gets or sets the latitude of the aircraft.
Public property | Longitude | Gets or sets the aircraft's longitude.
Public property | Manufacturer | Gets or sets the manufacturer's name.
Public property | Model | Gets or sets the English description of the aircraft model. Usually includes the manufacturer.
Public property | NumberOfEngines | Gets or sets the number of engines that the aircraft has - note that this is a copy of the ICAO8643 engine count which is not always a number!
Public property | OnGround | Gets or sets a value indicating that the aircraft is on the ground.
Public property | Operator | Gets or sets the operator's name.
Public property | OperatorIcao | Gets or sets the operator's ICAO code.
Public property | Origin | Gets or sets the airport that the aircraft set out from.
Public property | PictureHeight | Gets or sets the height of the aircraft picture in pixels.
Public property | PictureWidth | Gets or sets the width of the aircraft picture in pixels.
Public property | PositionIsMlat | Gets or sets a value indicating that the Latitude and Longitude were calculated by an MLAT source.
Public property | PositionIsStale | Gets or sets a value indicating whether the position is older than the display timeout.
Public property | PositionTime | Gets or sets the time that the Latitude and Longitude were transmitted as a number of .NET ticks.
Public property | ReceiverId | Gets or sets the ID of the receiver that is currently tracking the aircraft.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | ResetTrail | Gets or sets a value indicating that the server wants all trails for the aircraft to be reset.
Public property | SecondsTracked | Gets or sets the number of seconds that the aircraft has been tracked for.
Public property | ShortCoordinates | Gets or sets a list of coordinates representing the short trail for the aircraft. If ResetTrail is true then it is the entire trail, otherwise it extends the existing trail.
Public property | SignalLevel | Gets or sets the signal level of the last message received for the aircraft. Use in conjunction with HasSignalLevel.
Public property | Species | Gets or sets a value indicating the species of aircraft (see Species).
Public property | SpeedType | Gets or sets a value indicating the type of speed the aircraft is transmitting.
Public property | Squawk | Gets or sets the squawk currently transmitted by the aircraft.
Public property | Stopovers | Gets or sets a list of airports that the aircraft will be stopping at on its way to Destination.
Public property | TargetAltitude | Gets or sets the altitude set on the autopilot / FMS etc.
Public property | TargetTrack | Gets or sets the heading on the aircraft's autopilot or FMS.
Public property | Track | Gets or sets the heading that the aircraft is tracking across the ground in degrees from 0° north.
Public property | TrackIsHeading | Gets or sets a value indicating that the track is the aircraft's heading, not its ground track.
Public property | TrailType | Gets or sets the trail type. It is empty for plain trails (just position), 'a' for trails that have altitude attached and 's' for trails with speeds attached.
Public property | TransponderType | Gets or sets the transponder type.
Public property | Type | Gets or sets the ICAO8643 type code of the aircraft.
Public property | UniqueId | Gets or sets the unique identifier of the aircraft.
Public property | UserTag | Gets or sets the user tag from the aircraft's database record.
Public property | VerticalRate | Gets or sets the vertical speed in feet per second.
Public property | VerticalRateType | Gets or sets the type of altitude reported in VerticalRate.
Public property | WakeTurbulenceCategory | Gets or sets a value indicating the wake turbulence category of the aircraft (see WakeTurbulenceCategory).
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


AircraftJson Constructor

AircraftJson Constructor
Initializes a new instance of the AircraftJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftJson()
Public Sub New
public:
AircraftJson()
new : unit -> AircraftJson
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson Properties

AircraftJson Properties

The AircraftJson type exposes the following members.

Properties
 | Name | Description
Public property | AirPressureInHg | Gets or sets the aircraft's air pressure setting in inches of mercury.
Public property | Altitude | Gets or sets the aircraft's pressure altitude in feet.
Public property | AltitudeType | Gets or sets the type of altitude transmitted by the aircraft.
Public property | BearingFromHere | Gets or sets the bearing from the browser to the aircraft in degrees from 0° north.
Public property | Callsign | Gets or sets the aircraft's callsign.
Public property | CallsignIsSuspect | Gets or sets a value indicating that the Callsign came from an unreliable source.
Public property | ConstructionNumber | Gets or sets the construction / serial number of the aircraft.
Public property | CountMessagesReceived | Gets or sets the number of messages received for the aircraft.
Public property | Destination | Gets or sets the airport that the aircraft is travelling to.
Public property | DistanceFromHere | Gets or sets the distance from the browser's location to the aircraft in kilometres.
Public property | Emergency | Gets or sets a flag indicating that the aircraft is transmitting a mayday squawk.
Public property | EnginePlacement | Gets or sets a value indicating the placement of the engines mounted to the aircraft (see EnginePlacement).
Public property | EngineType | Gets or sets a value indicating the type of engines that the aircraft uses (see EngineType).
Public property | FirstSeen | Gets or sets the date and time (UTC) that a transmission from the aircraft was first received by the server.
Public property | FlightsCount | Gets or sets a value indicating how many flights this aircraft has logged in the BaseStation database.
Public property | FullCoordinates | Gets or sets a list of coordinates representing the full trail for the aircraft. If ResetTrail is true then it is the entire trail, otherwise it extends the existing trail.
Public property | GeometricAltitude | Gets or sets the aircraft's geometric altitude in feet.
Public property | GroundSpeed | Gets or sets the ground speed of the aircraft in knots.
Public property | HasPicture | Gets or sets a value indicating that the server can supply a picture of the aircraft.
Public property | HasSignalLevel | Gets or sets a value indicating whether the receiver emitted a signal level for the aircraft.
Public property | Icao24 | Gets or sets the 24-bit Mode-S identifier of the aircraft.
Public property | Icao24Country | Gets or sets the country that the aircraft's Icao24 was allocated to.
Public property | Icao24Invalid | Gets or sets a value indicating that the Icao24 code is wrong - either it is an unallocated code or the aircraft is known to be transmitting the wrong code.
Public property | IsInteresting | Gets or sets a value indicating that the aircraft is flagged as interesting in the BaseStation database.
Public property | IsMilitary | Gets or sets a value indicating that the aircraft is operated by a country's military.
Public property | IsSatcomFeed | Gets or sets a value indicating that the aircraft was seen on a SatCom feed.
Public property | IsTisb | Gets or sets a value indicating that the last message received for this aircraft was from a TIS-B source.
Public property | Latitude | Gets or sets the latitude of the aircraft.
Public property | Longitude | Gets or sets the aircraft's longitude.
Public property | Manufacturer | Gets or sets the manufacturer's name.
Public property | Model | Gets or sets the English description of the aircraft model. Usually includes the manufacturer.
Public property | NumberOfEngines | Gets or sets the number of engines that the aircraft has - note that this is a copy of the ICAO8643 engine count which is not always a number!
Public property | OnGround | Gets or sets a value indicating that the aircraft is on the ground.
Public property | Operator | Gets or sets the operator's name.
Public property | OperatorIcao | Gets or sets the operator's ICAO code.
Public property | Origin | Gets or sets the airport that the aircraft set out from.
Public property | PictureHeight | Gets or sets the height of the aircraft picture in pixels.
Public property | PictureWidth | Gets or sets the width of the aircraft picture in pixels.
Public property | PositionIsMlat | Gets or sets a value indicating that the Latitude and Longitude were calculated by an MLAT source.
Public property | PositionIsStale | Gets or sets a value indicating whether the position is older than the display timeout.
Public property | PositionTime | Gets or sets the time that the Latitude and Longitude were transmitted as a number of .NET ticks.
Public property | ReceiverId | Gets or sets the ID of the receiver that is currently tracking the aircraft.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | ResetTrail | Gets or sets a value indicating that the server wants all trails for the aircraft to be reset.
Public property | SecondsTracked | Gets or sets the number of seconds that the aircraft has been tracked for.
Public property | ShortCoordinates | Gets or sets a list of coordinates representing the short trail for the aircraft. If ResetTrail is true then it is the entire trail, otherwise it extends the existing trail.
Public property | SignalLevel | Gets or sets the signal level of the last message received for the aircraft. Use in conjunction with HasSignalLevel.
Public property | Species | Gets or sets a value indicating the species of aircraft (see Species).
Public property | SpeedType | Gets or sets a value indicating the type of speed the aircraft is transmitting.
Public property | Squawk | Gets or sets the squawk currently transmitted by the aircraft.
Public property | Stopovers | Gets or sets a list of airports that the aircraft will be stopping at on its way to Destination.
Public property | TargetAltitude | Gets or sets the altitude set on the autopilot / FMS etc.
Public property | TargetTrack | Gets or sets the heading on the aircraft's autopilot or FMS.
Public property | Track | Gets or sets the heading that the aircraft is tracking across the ground in degrees from 0° north.
Public property | TrackIsHeading | Gets or sets a value indicating that the track is the aircraft's heading, not its ground track.
Public property | TrailType | Gets or sets the trail type. It is empty for plain trails (just position), 'a' for trails that have altitude attached and 's' for trails with speeds attached.
Public property | TransponderType | Gets or sets the transponder type.
Public property | Type | Gets or sets the ICAO8643 type code of the aircraft.
Public property | UniqueId | Gets or sets the unique identifier of the aircraft.
Public property | UserTag | Gets or sets the user tag from the aircraft's database record.
Public property | VerticalRate | Gets or sets the vertical speed in feet per second.
Public property | VerticalRateType | Gets or sets the type of altitude reported in VerticalRate.
Public property | WakeTurbulenceCategory | Gets or sets a value indicating the wake turbulence category of the aircraft (see WakeTurbulenceCategory).
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured.
Top
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.AirPressureInHg Property

AircraftJsonAirPressureInHg Property
Gets or sets the aircraft's air pressure setting in inches of mercury.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> AirPressureInHg { get; set; }
Public Property AirPressureInHg As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> AirPressureInHg {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member AirPressureInHg : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Altitude Property

AircraftJsonAltitude Property
Gets or sets the aircraft's pressure altitude in feet.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Altitude { get; set; }
Public Property Altitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Altitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Altitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.AltitudeType Property

AircraftJsonAltitudeType Property
Gets or sets the type of altitude transmitted by the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> AltitudeType { get; set; }
Public Property AltitudeType As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> AltitudeType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member AltitudeType : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.BearingFromHere Property

AircraftJsonBearingFromHere Property
Gets or sets the bearing from the browser to the aircraft in degrees from 0° north.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> BearingFromHere { get; set; }
Public Property BearingFromHere As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> BearingFromHere {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member BearingFromHere : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Callsign Property

AircraftJsonCallsign Property
Gets or sets the aircraft's callsign.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Callsign { get; set; }
Public Property Callsign As String
    Get
    Set
public:
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
member Callsign : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.CallsignIsSuspect Property

AircraftJsonCallsignIsSuspect Property
Gets or sets a value indicating that the Callsign came from an unreliable source.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> CallsignIsSuspect { get; set; }
Public Property CallsignIsSuspect As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> CallsignIsSuspect {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member CallsignIsSuspect : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.ConstructionNumber Property

AircraftJsonConstructionNumber Property
Gets or sets the construction / serial number of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConstructionNumber { get; set; }
Public Property ConstructionNumber As String
    Get
    Set
public:
property String^ ConstructionNumber {
    String^ get ();
    void set (String^ value);
}
member ConstructionNumber : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.CountMessagesReceived Property

AircraftJsonCountMessagesReceived Property
Gets or sets the number of messages received for the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> CountMessagesReceived { get; set; }
Public Property CountMessagesReceived As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> CountMessagesReceived {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member CountMessagesReceived : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Destination Property

AircraftJsonDestination Property
Gets or sets the airport that the aircraft is travelling to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Destination { get; set; }
Public Property Destination As String
    Get
    Set
public:
property String^ Destination {
    String^ get ();
    void set (String^ value);
}
member Destination : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.DistanceFromHere Property

AircraftJsonDistanceFromHere Property
Gets or sets the distance from the browser's location to the aircraft in kilometres.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> DistanceFromHere { get; set; }
Public Property DistanceFromHere As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> DistanceFromHere {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member DistanceFromHere : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Emergency Property

AircraftJsonEmergency Property
Gets or sets a flag indicating that the aircraft is transmitting a mayday squawk.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> Emergency { get; set; }
Public Property Emergency As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> Emergency {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member Emergency : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.EnginePlacement Property

AircraftJsonEnginePlacement Property
Gets or sets a value indicating the placement of the engines mounted to the aircraft (see EnginePlacement).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePlacement { get; set; }
Public Property EnginePlacement As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePlacement {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePlacement : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.EngineType Property

AircraftJsonEngineType Property
Gets or sets a value indicating the type of engines that the aircraft uses (see EngineType).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EngineType { get; set; }
Public Property EngineType As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EngineType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EngineType : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.FirstSeen Property

AircraftJsonFirstSeen Property
Gets or sets the date and time (UTC) that a transmission from the aircraft was first received by the server.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> FirstSeen { get; set; }
Public Property FirstSeen As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> FirstSeen {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member FirstSeen : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.FlightsCount Property

AircraftJsonFlightsCount Property
Gets or sets a value indicating how many flights this aircraft has logged in the BaseStation database.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> FlightsCount { get; set; }
Public Property FlightsCount As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> FlightsCount {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member FlightsCount : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.FullCoordinates Property

AircraftJsonFullCoordinates Property
Gets or sets a list of coordinates representing the full trail for the aircraft. If ResetTrail is true then it is the entire trail, otherwise it extends the existing trail.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<Nullable<double>> FullCoordinates { get; set; }
Public Property FullCoordinates As List(Of Nullable(Of Double))
    Get
    Set
public:
property List<Nullable<double>>^ FullCoordinates {
    List<Nullable<double>>^ get ();
    void set (List<Nullable<double>>^ value);
}
member FullCoordinates : List<Nullable<float>> with get, set

Property Value

Type: List Nullable Double
Remarks
This is a set of 3-tuples - latitude, longitude and the heading. If TrailType is 'a' or 's' then it's a set of 4-tuples, with altitude or speed being added to the end of the tuple.
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.GeometricAltitude Property

AircraftJsonGeometricAltitude Property
Gets or sets the aircraft's geometric altitude in feet.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> GeometricAltitude { get; set; }
Public Property GeometricAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> GeometricAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member GeometricAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.GroundSpeed Property

AircraftJsonGroundSpeed Property
Gets or sets the ground speed of the aircraft in knots.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> GroundSpeed { get; set; }
Public Property GroundSpeed As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> GroundSpeed {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member GroundSpeed : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.HasPicture Property

AircraftJsonHasPicture Property
Gets or sets a value indicating that the server can supply a picture of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> HasPicture { get; set; }
Public Property HasPicture As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> HasPicture {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member HasPicture : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.HasSignalLevel Property

AircraftJsonHasSignalLevel Property
Gets or sets a value indicating whether the receiver emitted a signal level for the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> HasSignalLevel { get; set; }
Public Property HasSignalLevel As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> HasSignalLevel {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member HasSignalLevel : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Icao24 Property

AircraftJsonIcao24 Property
Gets or sets the 24-bit Mode-S identifier of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao24 { get; set; }
Public Property Icao24 As String
    Get
    Set
public:
property String^ Icao24 {
    String^ get ();
    void set (String^ value);
}
member Icao24 : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Icao24Country Property

AircraftJsonIcao24Country Property
Gets or sets the country that the aircraft's Icao24 was allocated to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao24Country { get; set; }
Public Property Icao24Country As String
    Get
    Set
public:
property String^ Icao24Country {
    String^ get ();
    void set (String^ value);
}
member Icao24Country : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Icao24Invalid Property

AircraftJsonIcao24Invalid Property
Gets or sets a value indicating that the Icao24 code is wrong - either it is an unallocated code or the aircraft is known to be transmitting the wrong code.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> Icao24Invalid { get; set; }
Public Property Icao24Invalid As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> Icao24Invalid {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member Icao24Invalid : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.IsInteresting Property

AircraftJsonIsInteresting Property
Gets or sets a value indicating that the aircraft is flagged as interesting in the BaseStation database.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsInteresting { get; set; }
Public Property IsInteresting As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsInteresting {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsInteresting : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.IsMilitary Property

AircraftJsonIsMilitary Property
Gets or sets a value indicating that the aircraft is operated by a country's military.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsMilitary { get; set; }
Public Property IsMilitary As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsMilitary {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsMilitary : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.IsSatcomFeed Property

AircraftJsonIsSatcomFeed Property
Gets or sets a value indicating that the aircraft was seen on a SatCom feed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSatcomFeed { get; set; }
Public Property IsSatcomFeed As Boolean
    Get
    Set
public:
property bool IsSatcomFeed {
    bool get ();
    void set (bool value);
}
member IsSatcomFeed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.IsTisb Property

AircraftJsonIsTisb Property
Gets or sets a value indicating that the last message received for this aircraft was from a TIS-B source.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> IsTisb { get; set; }
Public Property IsTisb As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsTisb {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member IsTisb : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Latitude Property

AircraftJsonLatitude Property
Gets or sets the latitude of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Latitude { get; set; }
Public Property Latitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Latitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Latitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Longitude Property

AircraftJsonLongitude Property
Gets or sets the aircraft's longitude.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Longitude { get; set; }
Public Property Longitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Longitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Longitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Manufacturer Property

AircraftJsonManufacturer Property
Gets or sets the manufacturer's name.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Model Property

AircraftJsonModel Property
Gets or sets the English description of the aircraft model. Usually includes the manufacturer.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Model { get; set; }
Public Property Model As String
    Get
    Set
public:
property String^ Model {
    String^ get ();
    void set (String^ value);
}
member Model : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.NumberOfEngines Property

AircraftJsonNumberOfEngines Property
Gets or sets the number of engines that the aircraft has - note that this is a copy of the ICAO8643 engine count which is not always a number!

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NumberOfEngines { get; set; }
Public Property NumberOfEngines As String
    Get
    Set
public:
property String^ NumberOfEngines {
    String^ get ();
    void set (String^ value);
}
member NumberOfEngines : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.OnGround Property

AircraftJsonOnGround Property
Gets or sets a value indicating that the aircraft is on the ground.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> OnGround { get; set; }
Public Property OnGround As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> OnGround {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member OnGround : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Operator Property

AircraftJsonOperator Property
Gets or sets the operator's name.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Operator { get; set; }
Public Property Operator As String
    Get
    Set
public:
property String^ Operator {
    String^ get ();
    void set (String^ value);
}
member Operator : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.OperatorIcao Property

AircraftJsonOperatorIcao Property
Gets or sets the operator's ICAO code.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorIcao { get; set; }
Public Property OperatorIcao As String
    Get
    Set
public:
property String^ OperatorIcao {
    String^ get ();
    void set (String^ value);
}
member OperatorIcao : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Origin Property

AircraftJsonOrigin Property
Gets or sets the airport that the aircraft set out from.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Origin { get; set; }
Public Property Origin As String
    Get
    Set
public:
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
member Origin : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.PictureHeight Property

AircraftJsonPictureHeight Property
Gets or sets the height of the aircraft picture in pixels.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> PictureHeight { get; set; }
Public Property PictureHeight As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> PictureHeight {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member PictureHeight : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.PictureWidth Property

AircraftJsonPictureWidth Property
Gets or sets the width of the aircraft picture in pixels.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> PictureWidth { get; set; }
Public Property PictureWidth As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> PictureWidth {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member PictureWidth : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.PositionIsMlat Property

AircraftJsonPositionIsMlat Property
Gets or sets a value indicating that the Latitude and Longitude were calculated by an MLAT source.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> PositionIsMlat { get; set; }
Public Property PositionIsMlat As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> PositionIsMlat {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member PositionIsMlat : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.PositionIsStale Property

AircraftJsonPositionIsStale Property
Gets or sets a value indicating whether the position is older than the display timeout.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> PositionIsStale { get; set; }
Public Property PositionIsStale As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> PositionIsStale {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member PositionIsStale : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
Remarks
This is usually only seen on merged feeds that include an MLAT feed, and only for aircraft that are not transmitting positions. The aircraft can appear to freeze on the map when it moves out of range of the MLAT receiver, this flag controls whether we should keep showing the aircraft on the map.
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.PositionTime Property

AircraftJsonPositionTime Property
Gets or sets the time that the Latitude and Longitude were transmitted as a number of .NET ticks.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> PositionTime { get; set; }
Public Property PositionTime As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> PositionTime {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member PositionTime : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.ReceiverId Property

AircraftJsonReceiverId Property
Gets or sets the ID of the receiver that is currently tracking the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ReceiverId { get; set; }
Public Property ReceiverId As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ReceiverId {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ReceiverId : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Registration Property

AircraftJsonRegistration Property
Gets or sets the aircraft's registration.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration { get; set; }
Public Property Registration As String
    Get
    Set
public:
property String^ Registration {
    String^ get ();
    void set (String^ value);
}
member Registration : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.ResetTrail Property

AircraftJsonResetTrail Property
Gets or sets a value indicating that the server wants all trails for the aircraft to be reset.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ResetTrail { get; set; }
Public Property ResetTrail As Boolean
    Get
    Set
public:
property bool ResetTrail {
    bool get ();
    void set (bool value);
}
member ResetTrail : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.SecondsTracked Property

AircraftJsonSecondsTracked Property
Gets or sets the number of seconds that the aircraft has been tracked for.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long SecondsTracked { get; set; }
Public Property SecondsTracked As Long
    Get
    Set
public:
property long long SecondsTracked {
    long long get ();
    void set (long long value);
}
member SecondsTracked : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.ShortCoordinates Property

AircraftJsonShortCoordinates Property
Gets or sets a list of coordinates representing the short trail for the aircraft. If ResetTrail is true then it is the entire trail, otherwise it extends the existing trail.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<Nullable<double>> ShortCoordinates { get; set; }
Public Property ShortCoordinates As List(Of Nullable(Of Double))
    Get
    Set
public:
property List<Nullable<double>>^ ShortCoordinates {
    List<Nullable<double>>^ get ();
    void set (List<Nullable<double>>^ value);
}
member ShortCoordinates : List<Nullable<float>> with get, set

Property Value

Type: List Nullable Double
Remarks
This is a set of 3-tuples - latitude, longitude and the time of the position in Javascript ticks. When TrailType is 'a' or 's' then it's a set of 4-tuples, where altitude or speed are added to the end of the tuple.
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.SignalLevel Property

AircraftJsonSignalLevel Property
Gets or sets the signal level of the last message received for the aircraft. Use in conjunction with HasSignalLevel.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SignalLevel { get; set; }
Public Property SignalLevel As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SignalLevel {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SignalLevel : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Species Property

AircraftJsonSpecies Property
Gets or sets a value indicating the species of aircraft (see Species).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Species { get; set; }
Public Property Species As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Species {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Species : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.SpeedType Property

AircraftJsonSpeedType Property
Gets or sets a value indicating the type of speed the aircraft is transmitting.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SpeedType { get; set; }
Public Property SpeedType As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SpeedType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SpeedType : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Squawk Property

AircraftJsonSquawk Property
Gets or sets the squawk currently transmitted by the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Squawk { get; set; }
Public Property Squawk As String
    Get
    Set
public:
property String^ Squawk {
    String^ get ();
    void set (String^ value);
}
member Squawk : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Stopovers Property

AircraftJsonStopovers Property
Gets or sets a list of airports that the aircraft will be stopping at on its way to Destination.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> Stopovers { get; set; }
Public Property Stopovers As List(Of String)
    Get
    Set
public:
property List<String^>^ Stopovers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Stopovers : List<string> with get, set

Property Value

Type: List String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.TargetAltitude Property

AircraftJsonTargetAltitude Property
Gets or sets the altitude set on the autopilot / FMS etc.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> TargetAltitude { get; set; }
Public Property TargetAltitude As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> TargetAltitude {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member TargetAltitude : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.TargetTrack Property

AircraftJsonTargetTrack Property
Gets or sets the heading on the aircraft's autopilot or FMS.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> TargetTrack { get; set; }
Public Property TargetTrack As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> TargetTrack {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member TargetTrack : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Track Property

AircraftJsonTrack Property
Gets or sets the heading that the aircraft is tracking across the ground in degrees from 0° north.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<float> Track { get; set; }
Public Property Track As Nullable(Of Single)
    Get
    Set
public:
property Nullable<float> Track {
    Nullable<float> get ();
    void set (Nullable<float> value);
}
member Track : Nullable<float32> with get, set

Property Value

Type: Nullable Single
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.TrackIsHeading Property

AircraftJsonTrackIsHeading Property
Gets or sets a value indicating that the track is the aircraft's heading, not its ground track.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> TrackIsHeading { get; set; }
Public Property TrackIsHeading As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> TrackIsHeading {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member TrackIsHeading : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.TrailType Property

AircraftJsonTrailType Property
Gets or sets the trail type. It is empty for plain trails (just position), 'a' for trails that have altitude attached and 's' for trails with speeds attached.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TrailType { get; set; }
Public Property TrailType As String
    Get
    Set
public:
property String^ TrailType {
    String^ get ();
    void set (String^ value);
}
member TrailType : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.TransponderType Property

AircraftJsonTransponderType Property
Gets or sets the transponder type.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> TransponderType { get; set; }
Public Property TransponderType As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> TransponderType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member TransponderType : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.Type Property

AircraftJsonType Property
Gets or sets the ICAO8643 type code of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.UniqueId Property

AircraftJsonUniqueId Property
Gets or sets the unique identifier of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.UserTag Property

AircraftJsonUserTag Property
Gets or sets the user tag from the aircraft's database record.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserTag { get; set; }
Public Property UserTag As String
    Get
    Set
public:
property String^ UserTag {
    String^ get ();
    void set (String^ value);
}
member UserTag : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.VerticalRate Property

AircraftJsonVerticalRate Property
Gets or sets the vertical speed in feet per second.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> VerticalRate { get; set; }
Public Property VerticalRate As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> VerticalRate {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member VerticalRate : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.VerticalRateType Property

AircraftJsonVerticalRateType Property
Gets or sets the type of altitude reported in VerticalRate.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> VerticalRateType { get; set; }
Public Property VerticalRateType As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> VerticalRateType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member VerticalRateType : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.WakeTurbulenceCategory Property

AircraftJsonWakeTurbulenceCategory Property
Gets or sets a value indicating the wake turbulence category of the aircraft (see WakeTurbulenceCategory).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> WakeTurbulenceCategory { get; set; }
Public Property WakeTurbulenceCategory As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> WakeTurbulenceCategory {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member WakeTurbulenceCategory : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson.YearBuilt Property

AircraftJsonYearBuilt Property
Gets or sets the year the aircraft was manufactured.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string YearBuilt { get; set; }
Public Property YearBuilt As String
    Get
    Set
public:
property String^ YearBuilt {
    String^ get ();
    void set (String^ value);
}
member YearBuilt : string with get, set

Property Value

Type: String
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftJson Methods

AircraftJson Methods

The AircraftJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson Class

AircraftListJson Class
The list of aircraft that is sent to the browser as a JSON file.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteAircraftListJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftListJson
Public Class AircraftListJson
public ref class AircraftListJson
type AircraftListJson =  class end

The AircraftListJson type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftListJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | Aircraft | Gets the list of aircraft to show to the user.
Public property | AvailableAircraft | Gets or sets the total number of aircraft that the server is currently tracking.
Public property | Feeds | Gets a collection of feeds that VRS has been configured to listen to and are currently enabled.
Public property | FlagHeight | Gets or sets the height of the operator flags.
Public property | FlagWidth | Gets or sets the width of the operator flags.
Public property | LastDataVersion | Gets or sets the latest DataVersion for the aircraft in the aircraft list.
Public property | ServerConfigChanged | Gets or sets a value indicating that the server configuration has changed since their last update.
Public property | ServerTime | Gets or sets the server's current time as the number of Javascript ticks in a UTC DateTime.
Public property | ShortTrailLengthSeconds | Gets or sets the number of seconds of positions to show in short trails.
Public property | ShowFlags | Gets or sets a value indicating that operator flags can be shown for aircraft.
Public property | ShowPictures | Gets or sets a value indicating that pictures can be shown for aircraft.
Public property | ShowSilhouettes | Gets or sets a value indicating that silhouettes can be shown for aircraft.
Public property | Source | Gets or sets the source of the aircraft list (see AircraftListSource).
Public property | SourceFeedId | Gets or sets the ID of the feed that this aircraft list is showing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


AircraftListJson Constructor

AircraftListJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftListJson()
Public Sub New
public:
AircraftListJson()
new : unit -> AircraftListJson
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson Properties

AircraftListJson Properties

The AircraftListJson type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets the list of aircraft to show to the user.
Public property | AvailableAircraft | Gets or sets the total number of aircraft that the server is currently tracking.
Public property | Feeds | Gets a collection of feeds that VRS has been configured to listen to and are currently enabled.
Public property | FlagHeight | Gets or sets the height of the operator flags.
Public property | FlagWidth | Gets or sets the width of the operator flags.
Public property | LastDataVersion | Gets or sets the latest DataVersion for the aircraft in the aircraft list.
Public property | ServerConfigChanged | Gets or sets a value indicating that the server configuration has changed since their last update.
Public property | ServerTime | Gets or sets the server's current time as the number of Javascript ticks in a UTC DateTime.
Public property | ShortTrailLengthSeconds | Gets or sets the number of seconds of positions to show in short trails.
Public property | ShowFlags | Gets or sets a value indicating that operator flags can be shown for aircraft.
Public property | ShowPictures | Gets or sets a value indicating that pictures can be shown for aircraft.
Public property | ShowSilhouettes | Gets or sets a value indicating that silhouettes can be shown for aircraft.
Public property | Source | Gets or sets the source of the aircraft list (see AircraftListSource).
Public property | SourceFeedId | Gets or sets the ID of the feed that this aircraft list is showing.
Top
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.Aircraft Property

AircraftListJsonAircraft Property
Gets the list of aircraft to show to the user.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<AircraftJson> Aircraft { get; }
Public ReadOnly Property Aircraft As List(Of AircraftJson)
    Get
public:
property List<AircraftJson^>^ Aircraft {
    List<AircraftJson^>^ get ();
}
member Aircraft : List<AircraftJson> with get

Property Value

Type: List AircraftJson
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.AvailableAircraft Property

AircraftListJsonAvailableAircraft Property
Gets or sets the total number of aircraft that the server is currently tracking.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AvailableAircraft { get; set; }
Public Property AvailableAircraft As Integer
    Get
    Set
public:
property int AvailableAircraft {
    int get ();
    void set (int value);
}
member AvailableAircraft : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.Feeds Property

AircraftListJsonFeeds Property
Gets a collection of feeds that VRS has been configured to listen to and are currently enabled.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<FeedJson> Feeds { get; }
Public ReadOnly Property Feeds As List(Of FeedJson)
    Get
public:
property List<FeedJson^>^ Feeds {
    List<FeedJson^>^ get ();
}
member Feeds : List<FeedJson> with get

Property Value

Type: List FeedJson
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.FlagHeight Property

AircraftListJsonFlagHeight Property
Gets or sets the height of the operator flags.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlagHeight { get; set; }
Public Property FlagHeight As Integer
    Get
    Set
public:
property int FlagHeight {
    int get ();
    void set (int value);
}
member FlagHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.FlagWidth Property

AircraftListJsonFlagWidth Property
Gets or sets the width of the operator flags.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FlagWidth { get; set; }
Public Property FlagWidth As Integer
    Get
    Set
public:
property int FlagWidth {
    int get ();
    void set (int value);
}
member FlagWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.LastDataVersion Property

AircraftListJsonLastDataVersion Property
Gets or sets the latest DataVersion for the aircraft in the aircraft list.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LastDataVersion { get; set; }
Public Property LastDataVersion As String
    Get
    Set
public:
property String^ LastDataVersion {
    String^ get ();
    void set (String^ value);
}
member LastDataVersion : string with get, set

Property Value

Type: String
Remarks
The browser sends this value back to the server when it asks for another aircraft list. In this way the server can figure out what has changed since the last time the browser asked for a list.
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.ServerConfigChanged Property

AircraftListJsonServerConfigChanged Property
Gets or sets a value indicating that the server configuration has changed since their last update.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ServerConfigChanged { get; set; }
Public Property ServerConfigChanged As Boolean
    Get
    Set
public:
property bool ServerConfigChanged {
    bool get ();
    void set (bool value);
}
member ServerConfigChanged : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.ServerTime Property

AircraftListJsonServerTime Property
Gets or sets the server's current time as the number of Javascript ticks in a UTC DateTime.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ServerTime { get; set; }
Public Property ServerTime As Long
    Get
    Set
public:
property long long ServerTime {
    long long get ();
    void set (long long value);
}
member ServerTime : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.ShortTrailLengthSeconds Property

AircraftListJsonShortTrailLengthSeconds Property
Gets or sets the number of seconds of positions to show in short trails.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ShortTrailLengthSeconds { get; set; }
Public Property ShortTrailLengthSeconds As Integer
    Get
    Set
public:
property int ShortTrailLengthSeconds {
    int get ();
    void set (int value);
}
member ShortTrailLengthSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.ShowFlags Property

AircraftListJsonShowFlags Property
Gets or sets a value indicating that operator flags can be shown for aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowFlags { get; set; }
Public Property ShowFlags As Boolean
    Get
    Set
public:
property bool ShowFlags {
    bool get ();
    void set (bool value);
}
member ShowFlags : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.ShowPictures Property

AircraftListJsonShowPictures Property
Gets or sets a value indicating that pictures can be shown for aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowPictures { get; set; }
Public Property ShowPictures As Boolean
    Get
    Set
public:
property bool ShowPictures {
    bool get ();
    void set (bool value);
}
member ShowPictures : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.ShowSilhouettes Property

AircraftListJsonShowSilhouettes Property
Gets or sets a value indicating that silhouettes can be shown for aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowSilhouettes { get; set; }
Public Property ShowSilhouettes As Boolean
    Get
    Set
public:
property bool ShowSilhouettes {
    bool get ();
    void set (bool value);
}
member ShowSilhouettes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.Source Property

AircraftListJsonSource Property
Gets or sets the source of the aircraft list (see AircraftListSource).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Source { get; set; }
Public Property Source As Integer
    Get
    Set
public:
property int Source {
    int get ();
    void set (int value);
}
member Source : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson.SourceFeedId Property

AircraftListJsonSourceFeedId Property
Gets or sets the ID of the feed that this aircraft list is showing.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceFeedId { get; set; }
Public Property SourceFeedId As Integer
    Get
    Set
public:
property int SourceFeedId {
    int get ();
    void set (int value);
}
member SourceFeedId : int with get, set

Property Value

Type: Int32
Remarks
It's entirely possible that this ID number does not correspond with any feed in Feeds - this can happen when reporting on the Flight Simulator X feed, or when the feed requested by the website no longer exists on the server.
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJson Methods

AircraftListJson Methods

The AircraftListJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftListJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs Class

AircraftListJsonBuilderArgs Class
The object that passes arguments to the Build(AircraftListJsonBuilderArgs) method.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteAircraftListJsonBuilderArgs

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftListJsonBuilderArgs
Public Class AircraftListJsonBuilderArgs
public ref class AircraftListJsonBuilderArgs
type AircraftListJsonBuilderArgs =  class end

The AircraftListJsonBuilderArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftListJsonBuilderArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | AircraftList | Gets or sets the aircraft list that provides details of the aircraft being tracked.
Public property | AlwaysShowIcao | Gets or sets a value indicating that the ICAO should always be shown for each aircraft, even if it has not changed.
Public property | BrowserLatitude | Gets or sets the latitude that the browser is located on.
Public property | BrowserLongitude | Gets or sets the longitude that the browser is located on.
Public property | FeedsNotRequired | Gets or sets a value indicating that the Feeds list does not need to be filled in.
Public property | Filter | Gets or sets the filters used to suppress aircraft from the list.
Public property | IgnoreUnchanged | Gets or sets a value indicating that aircraft that have not changed are not to be included in the aircraft list.
Public property | IsFlightSimulatorList | Gets or sets a value indicating that this is being used to build a list of flight simulator aircraft.
Public property | IsInternetClient | Gets or sets a value indicating that the aircraft JSON list is going to be sent to an Internet client.
Public property | OnlyIncludeMessageFields | Gets or sets a value indicating that fields derived from aircraft messages are to be suppressed, only fields taken directly from an aircraft are to be included in the aircraft JSON.
Public property | PreviousAircraft | Gets the list of aircraft that the browser was told about the last time it asked for a list.
Public property | PreviousDataVersion | Gets or sets the DataVersion of the data that was last sent to the browser. Use -1 if the browser does not report the previous data version.
Public property | ResendTrails | Gets or sets a flag indicating that the entire trail for each aircraft should be sent regardless of whether the browser has been previously sent the trail or not.
Public property | SelectedAircraftId | Gets or sets the ID of the selected aircraft or -1 if no aircraft was selected.
Public property | ServerTimeTicks | Gets or sets the time (in ticks) that the last aircraft list received by the site was generated by the server. This is -1 if the stm query string parameter is not present or not parseable.
Public property | SortBy | Gets a list of AircraftComparerColumn columns to sort by and a bool to indicate whether the sort direction is ascending (true) or descending (false).
Public property | SourceFeedId | Gets or sets the ID of the source receiver.
Public property | TrailType | Gets or sets a value indicating what type of trail is required.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs Constructor

AircraftListJsonBuilderArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftListJsonBuilderArgs()
Public Sub New
public:
AircraftListJsonBuilderArgs()
new : unit -> AircraftListJsonBuilderArgs
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs Properties

AircraftListJsonBuilderArgs Properties

The AircraftListJsonBuilderArgs type exposes the following members.

Properties
 | Name | Description
Public property | AircraftList | Gets or sets the aircraft list that provides details of the aircraft being tracked.
Public property | AlwaysShowIcao | Gets or sets a value indicating that the ICAO should always be shown for each aircraft, even if it has not changed.
Public property | BrowserLatitude | Gets or sets the latitude that the browser is located on.
Public property | BrowserLongitude | Gets or sets the longitude that the browser is located on.
Public property | FeedsNotRequired | Gets or sets a value indicating that the Feeds list does not need to be filled in.
Public property | Filter | Gets or sets the filters used to suppress aircraft from the list.
Public property | IgnoreUnchanged | Gets or sets a value indicating that aircraft that have not changed are not to be included in the aircraft list.
Public property | IsFlightSimulatorList | Gets or sets a value indicating that this is being used to build a list of flight simulator aircraft.
Public property | IsInternetClient | Gets or sets a value indicating that the aircraft JSON list is going to be sent to an Internet client.
Public property | OnlyIncludeMessageFields | Gets or sets a value indicating that fields derived from aircraft messages are to be suppressed, only fields taken directly from an aircraft are to be included in the aircraft JSON.
Public property | PreviousAircraft | Gets the list of aircraft that the browser was told about the last time it asked for a list.
Public property | PreviousDataVersion | Gets or sets the DataVersion of the data that was last sent to the browser. Use -1 if the browser does not report the previous data version.
Public property | ResendTrails | Gets or sets a flag indicating that the entire trail for each aircraft should be sent regardless of whether the browser has been previously sent the trail or not.
Public property | SelectedAircraftId | Gets or sets the ID of the selected aircraft or -1 if no aircraft was selected.
Public property | ServerTimeTicks | Gets or sets the time (in ticks) that the last aircraft list received by the site was generated by the server. This is -1 if the stm query string parameter is not present or not parseable.
Public property | SortBy | Gets a list of AircraftComparerColumn columns to sort by and a bool to indicate whether the sort direction is ascending (true) or descending (false).
Public property | SourceFeedId | Gets or sets the ID of the source receiver.
Public property | TrailType | Gets or sets a value indicating what type of trail is required.
Top
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.AircraftList Property

AircraftListJsonBuilderArgsAircraftList Property
Gets or sets the aircraft list that provides details of the aircraft being tracked.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IAircraftList AircraftList { get; set; }
Public Property AircraftList As IAircraftList
    Get
    Set
public:
property IAircraftList^ AircraftList {
    IAircraftList^ get ();
    void set (IAircraftList^ value);
}
member AircraftList : IAircraftList with get, set

Property Value

Type: IAircraftList
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.AlwaysShowIcao Property

AircraftListJsonBuilderArgsAlwaysShowIcao Property
Gets or sets a value indicating that the ICAO should always be shown for each aircraft, even if it has not changed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlwaysShowIcao { get; set; }
Public Property AlwaysShowIcao As Boolean
    Get
    Set
public:
property bool AlwaysShowIcao {
    bool get ();
    void set (bool value);
}
member AlwaysShowIcao : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.BrowserLatitude Property

AircraftListJsonBuilderArgsBrowserLatitude Property
Gets or sets the latitude that the browser is located on.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> BrowserLatitude { get; set; }
Public Property BrowserLatitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> BrowserLatitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member BrowserLatitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.BrowserLongitude Property

AircraftListJsonBuilderArgsBrowserLongitude Property
Gets or sets the longitude that the browser is located on.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> BrowserLongitude { get; set; }
Public Property BrowserLongitude As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> BrowserLongitude {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member BrowserLongitude : Nullable<float> with get, set

Property Value

Type: Nullable Double
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.FeedsNotRequired Property

AircraftListJsonBuilderArgsFeedsNotRequired Property
Gets or sets a value indicating that the Feeds list does not need to be filled in.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FeedsNotRequired { get; set; }
Public Property FeedsNotRequired As Boolean
    Get
    Set
public:
property bool FeedsNotRequired {
    bool get ();
    void set (bool value);
}
member FeedsNotRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.Filter Property

AircraftListJsonBuilderArgsFilter Property
Gets or sets the filters used to suppress aircraft from the list.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftListJsonBuilderFilter Filter { get; set; }
Public Property Filter As AircraftListJsonBuilderFilter
    Get
    Set
public:
property AircraftListJsonBuilderFilter^ Filter {
    AircraftListJsonBuilderFilter^ get ();
    void set (AircraftListJsonBuilderFilter^ value);
}
member Filter : AircraftListJsonBuilderFilter with get, set

Property Value

Type: AircraftListJsonBuilderFilter
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.IgnoreUnchanged Property

AircraftListJsonBuilderArgsIgnoreUnchanged Property
Gets or sets a value indicating that aircraft that have not changed are not to be included in the aircraft list.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreUnchanged { get; set; }
Public Property IgnoreUnchanged As Boolean
    Get
    Set
public:
property bool IgnoreUnchanged {
    bool get ();
    void set (bool value);
}
member IgnoreUnchanged : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.IsFlightSimulatorList Property

AircraftListJsonBuilderArgsIsFlightSimulatorList Property
Gets or sets a value indicating that this is being used to build a list of flight simulator aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFlightSimulatorList { get; set; }
Public Property IsFlightSimulatorList As Boolean
    Get
    Set
public:
property bool IsFlightSimulatorList {
    bool get ();
    void set (bool value);
}
member IsFlightSimulatorList : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.IsInternetClient Property

AircraftListJsonBuilderArgsIsInternetClient Property
Gets or sets a value indicating that the aircraft JSON list is going to be sent to an Internet client.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInternetClient { get; set; }
Public Property IsInternetClient As Boolean
    Get
    Set
public:
property bool IsInternetClient {
    bool get ();
    void set (bool value);
}
member IsInternetClient : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.OnlyIncludeMessageFields Property

AircraftListJsonBuilderArgsOnlyIncludeMessageFields Property
Gets or sets a value indicating that fields derived from aircraft messages are to be suppressed, only fields taken directly from an aircraft are to be included in the aircraft JSON.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OnlyIncludeMessageFields { get; set; }
Public Property OnlyIncludeMessageFields As Boolean
    Get
    Set
public:
property bool OnlyIncludeMessageFields {
    bool get ();
    void set (bool value);
}
member OnlyIncludeMessageFields : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.PreviousAircraft Property

AircraftListJsonBuilderArgsPreviousAircraft Property
Gets the list of aircraft that the browser was told about the last time it asked for a list.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<int> PreviousAircraft { get; }
Public ReadOnly Property PreviousAircraft As List(Of Integer)
    Get
public:
property List<int>^ PreviousAircraft {
    List<int>^ get ();
}
member PreviousAircraft : List<int> with get

Property Value

Type: List Int32
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.PreviousDataVersion Property

AircraftListJsonBuilderArgsPreviousDataVersion Property
Gets or sets the DataVersion of the data that was last sent to the browser. Use -1 if the browser does not report the previous data version.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long PreviousDataVersion { get; set; }
Public Property PreviousDataVersion As Long
    Get
    Set
public:
property long long PreviousDataVersion {
    long long get ();
    void set (long long value);
}
member PreviousDataVersion : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.ResendTrails Property

AircraftListJsonBuilderArgsResendTrails Property
Gets or sets a flag indicating that the entire trail for each aircraft should be sent regardless of whether the browser has been previously sent the trail or not.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ResendTrails { get; set; }
Public Property ResendTrails As Boolean
    Get
    Set
public:
property bool ResendTrails {
    bool get ();
    void set (bool value);
}
member ResendTrails : bool with get, set

Property Value

Type: Boolean
Remarks
Browsers are allowed to ask for the full trail to be sent - this happens when the user switches between short and full trails.
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.SelectedAircraftId Property

AircraftListJsonBuilderArgsSelectedAircraftId Property
Gets or sets the ID of the selected aircraft or -1 if no aircraft was selected.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SelectedAircraftId { get; set; }
Public Property SelectedAircraftId As Integer
    Get
    Set
public:
property int SelectedAircraftId {
    int get ();
    void set (int value);
}
member SelectedAircraftId : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.ServerTimeTicks Property

AircraftListJsonBuilderArgsServerTimeTicks Property
Gets or sets the time (in ticks) that the last aircraft list received by the site was generated by the server. This is -1 if the stm query string parameter is not present or not parseable.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ServerTimeTicks { get; set; }
Public Property ServerTimeTicks As Long
    Get
    Set
public:
property long long ServerTimeTicks {
    long long get ();
    void set (long long value);
}
member ServerTimeTicks : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.SortBy Property

AircraftListJsonBuilderArgsSortBy Property
Gets a list of AircraftComparerColumn columns to sort by and a bool to indicate whether the sort direction is ascending (true) or descending (false).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<KeyValuePair<string, bool>> SortBy { get; }
Public ReadOnly Property SortBy As List(Of KeyValuePair(Of String, Boolean))
    Get
public:
property List<KeyValuePair<String^, bool>>^ SortBy {
    List<KeyValuePair<String^, bool>>^ get ();
}
member SortBy : List<KeyValuePair<string, bool>> with get

Property Value

Type: List KeyValuePair String, Boolean
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.SourceFeedId Property

AircraftListJsonBuilderArgsSourceFeedId Property
Gets or sets the ID of the source receiver.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceFeedId { get; set; }
Public Property SourceFeedId As Integer
    Get
    Set
public:
property int SourceFeedId {
    int get ();
    void set (int value);
}
member SourceFeedId : int with get, set

Property Value

Type: Int32
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs.TrailType Property

AircraftListJsonBuilderArgsTrailType Property
Gets or sets a value indicating what type of trail is required.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TrailType TrailType { get; set; }
Public Property TrailType As TrailType
    Get
    Set
public:
property TrailType TrailType {
    TrailType get ();
    void set (TrailType value);
}
member TrailType : TrailType with get, set

Property Value

Type: TrailType
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderArgs Methods

AircraftListJsonBuilderArgs Methods

The AircraftListJsonBuilderArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftListJsonBuilderArgs Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter Class

AircraftListJsonBuilderFilter Class
The arguments passed to Build(AircraftListJsonBuilderArgs) that can be used to suppress aircraft from the generated JSON.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteAircraftListJsonBuilderFilter

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftListJsonBuilderFilter
Public Class AircraftListJsonBuilderFilter
public ref class AircraftListJsonBuilderFilter
type AircraftListJsonBuilderFilter =  class end

The AircraftListJsonBuilderFilter type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftListJsonBuilderFilter | Initializes a new instance of the AircraftListJsonBuilderFilter class
Top
Properties
 | Name | Description
Public property | Airport | Gets or sets an airport code that the aircraft has to be flying from, to or via in order to pass the filter.
Public property | Altitude | Gets or sets the range of altitudes that an aircraft can be flying at in order to pass the filter.
Public property | Callsign | Gets or sets the text that will be compared to aircraft's callsign before it can pass the filter.
Public property | Distance | Gets or sets the range of distances in kilometres that the aircraft can be at before it can pass the filter.
Public property | EngineType | Gets or sets the engine type that the aircraft must have before it can pass the filter.
Public property | Icao24 | Gets or sets the ICAO24 code that the aircraft must have before it can pass the filter.
Public property | Icao24Country | Gets or sets the text that will be compared to an aircraft's ICAO24 country before it can pass the filter.
Public property | IsInteresting | Gets or sets a value indicating that the aircraft must be flagged as Interested in the BaseStation database before it can pass the filter.
Public property | IsMilitary | Gets or sets a value indicating that the aircraft must be operated by the military before it can pass the filter.
Public property | MustTransmitPosition | Gets or sets a value indicating that the aircraft must (or must not) be transmitting a position before it can pass the filter.
Public property | Operator | Gets or sets the text that will be compared to an aircraft's operator to pass the filter.
Public property | OperatorIcao | Gets or sets the text that will be compared to an aircraft's operator code to pass the filter.
Public property | PositionWithin | Gets or sets the lines of latitude and longitude that the aircraft must be within before it can pass the filter. The first coordinate is Top-Left and the second is Bottom-Right.
Public property | Registration | Gets or sets the text that will be compared to an aircraft's registration before it can pass the filter.
Public property | Species | Gets or sets the aircraft species that is allowed to pass the filter.
Public property | Squawk | Gets or sets the range of squawk values that allow an aircraft to pass the filter.
Public property | Type | Gets or sets the text that will be compared to an aircraft's type before it can pass the filter.
Public property | UserTag | Gets or sets the text that will be compared to an aircraft's user tag before it can pass the filter.
Public property | WakeTurbulenceCategory | Gets or sets the wake turbulence category that the aircraft must have before it can pass the filter.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter Constructor

AircraftListJsonBuilderFilter Constructor
Initializes a new instance of the AircraftListJsonBuilderFilter class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftListJsonBuilderFilter()
Public Sub New
public:
AircraftListJsonBuilderFilter()
new : unit -> AircraftListJsonBuilderFilter
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter Properties

AircraftListJsonBuilderFilter Properties

The AircraftListJsonBuilderFilter type exposes the following members.

Properties
 | Name | Description
Public property | Airport | Gets or sets an airport code that the aircraft has to be flying from, to or via in order to pass the filter.
Public property | Altitude | Gets or sets the range of altitudes that an aircraft can be flying at in order to pass the filter.
Public property | Callsign | Gets or sets the text that will be compared to aircraft's callsign before it can pass the filter.
Public property | Distance | Gets or sets the range of distances in kilometres that the aircraft can be at before it can pass the filter.
Public property | EngineType | Gets or sets the engine type that the aircraft must have before it can pass the filter.
Public property | Icao24 | Gets or sets the ICAO24 code that the aircraft must have before it can pass the filter.
Public property | Icao24Country | Gets or sets the text that will be compared to an aircraft's ICAO24 country before it can pass the filter.
Public property | IsInteresting | Gets or sets a value indicating that the aircraft must be flagged as Interested in the BaseStation database before it can pass the filter.
Public property | IsMilitary | Gets or sets a value indicating that the aircraft must be operated by the military before it can pass the filter.
Public property | MustTransmitPosition | Gets or sets a value indicating that the aircraft must (or must not) be transmitting a position before it can pass the filter.
Public property | Operator | Gets or sets the text that will be compared to an aircraft's operator to pass the filter.
Public property | OperatorIcao | Gets or sets the text that will be compared to an aircraft's operator code to pass the filter.
Public property | PositionWithin | Gets or sets the lines of latitude and longitude that the aircraft must be within before it can pass the filter. The first coordinate is Top-Left and the second is Bottom-Right.
Public property | Registration | Gets or sets the text that will be compared to an aircraft's registration before it can pass the filter.
Public property | Species | Gets or sets the aircraft species that is allowed to pass the filter.
Public property | Squawk | Gets or sets the range of squawk values that allow an aircraft to pass the filter.
Public property | Type | Gets or sets the text that will be compared to an aircraft's type before it can pass the filter.
Public property | UserTag | Gets or sets the text that will be compared to an aircraft's user tag before it can pass the filter.
Public property | WakeTurbulenceCategory | Gets or sets the wake turbulence category that the aircraft must have before it can pass the filter.
Top
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Airport Property

AircraftListJsonBuilderFilterAirport Property
Gets or sets an airport code that the aircraft has to be flying from, to or via in order to pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Airport { get; set; }
Public Property Airport As FilterString
    Get
    Set
public:
property FilterString^ Airport {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Airport : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Altitude Property

AircraftListJsonBuilderFilterAltitude Property
Gets or sets the range of altitudes that an aircraft can be flying at in order to pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange<int> Altitude { get; set; }
Public Property Altitude As FilterRange(Of Integer)
    Get
    Set
public:
property FilterRange<int>^ Altitude {
    FilterRange<int>^ get ();
    void set (FilterRange<int>^ value);
}
member Altitude : FilterRange<int> with get, set

Property Value

Type: FilterRange Int32
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Callsign Property

AircraftListJsonBuilderFilterCallsign Property
Gets or sets the text that will be compared to aircraft's callsign before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Callsign { get; set; }
Public Property Callsign As FilterString
    Get
    Set
public:
property FilterString^ Callsign {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Callsign : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Distance Property

AircraftListJsonBuilderFilterDistance Property
Gets or sets the range of distances in kilometres that the aircraft can be at before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange<double> Distance { get; set; }
Public Property Distance As FilterRange(Of Double)
    Get
    Set
public:
property FilterRange<double>^ Distance {
    FilterRange<double>^ get ();
    void set (FilterRange<double>^ value);
}
member Distance : FilterRange<float> with get, set

Property Value

Type: FilterRange Double
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.EngineType Property

AircraftListJsonBuilderFilterEngineType Property
Gets or sets the engine type that the aircraft must have before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterEnum<EngineType> EngineType { get; set; }
Public Property EngineType As FilterEnum(Of EngineType)
    Get
    Set
public:
property FilterEnum<EngineType>^ EngineType {
    FilterEnum<EngineType>^ get ();
    void set (FilterEnum<EngineType>^ value);
}
member EngineType : FilterEnum<EngineType> with get, set

Property Value

Type: FilterEnum EngineType
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Icao24 Property

AircraftListJsonBuilderFilterIcao24 Property
Gets or sets the ICAO24 code that the aircraft must have before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Icao24 { get; set; }
Public Property Icao24 As FilterString
    Get
    Set
public:
property FilterString^ Icao24 {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Icao24 : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Icao24Country Property

AircraftListJsonBuilderFilterIcao24Country Property
Gets or sets the text that will be compared to an aircraft's ICAO24 country before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Icao24Country { get; set; }
Public Property Icao24Country As FilterString
    Get
    Set
public:
property FilterString^ Icao24Country {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Icao24Country : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.IsInteresting Property

AircraftListJsonBuilderFilterIsInteresting Property
Gets or sets a value indicating that the aircraft must be flagged as Interested in the BaseStation database before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterBool IsInteresting { get; set; }
Public Property IsInteresting As FilterBool
    Get
    Set
public:
property FilterBool^ IsInteresting {
    FilterBool^ get ();
    void set (FilterBool^ value);
}
member IsInteresting : FilterBool with get, set

Property Value

Type: FilterBool
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.IsMilitary Property

AircraftListJsonBuilderFilterIsMilitary Property
Gets or sets a value indicating that the aircraft must be operated by the military before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterBool IsMilitary { get; set; }
Public Property IsMilitary As FilterBool
    Get
    Set
public:
property FilterBool^ IsMilitary {
    FilterBool^ get ();
    void set (FilterBool^ value);
}
member IsMilitary : FilterBool with get, set

Property Value

Type: FilterBool
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.MustTransmitPosition Property

AircraftListJsonBuilderFilterMustTransmitPosition Property
Gets or sets a value indicating that the aircraft must (or must not) be transmitting a position before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterBool MustTransmitPosition { get; set; }
Public Property MustTransmitPosition As FilterBool
    Get
    Set
public:
property FilterBool^ MustTransmitPosition {
    FilterBool^ get ();
    void set (FilterBool^ value);
}
member MustTransmitPosition : FilterBool with get, set

Property Value

Type: FilterBool
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Operator Property

AircraftListJsonBuilderFilterOperator Property
Gets or sets the text that will be compared to an aircraft's operator to pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Operator { get; set; }
Public Property Operator As FilterString
    Get
    Set
public:
property FilterString^ Operator {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Operator : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.OperatorIcao Property

AircraftListJsonBuilderFilterOperatorIcao Property
Gets or sets the text that will be compared to an aircraft's operator code to pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString OperatorIcao { get; set; }
Public Property OperatorIcao As FilterString
    Get
    Set
public:
property FilterString^ OperatorIcao {
    FilterString^ get ();
    void set (FilterString^ value);
}
member OperatorIcao : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.PositionWithin Property

AircraftListJsonBuilderFilterPositionWithin Property
Gets or sets the lines of latitude and longitude that the aircraft must be within before it can pass the filter. The first coordinate is Top-Left and the second is Bottom-Right.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Pair<Coordinate> PositionWithin { get; set; }
Public Property PositionWithin As Pair(Of Coordinate)
    Get
    Set
public:
property Pair<Coordinate^>^ PositionWithin {
    Pair<Coordinate^>^ get ();
    void set (Pair<Coordinate^>^ value);
}
member PositionWithin : Pair<Coordinate> with get, set

Property Value

Type: Pair Coordinate
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Registration Property

AircraftListJsonBuilderFilterRegistration Property
Gets or sets the text that will be compared to an aircraft's registration before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Registration { get; set; }
Public Property Registration As FilterString
    Get
    Set
public:
property FilterString^ Registration {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Registration : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Species Property

AircraftListJsonBuilderFilterSpecies Property
Gets or sets the aircraft species that is allowed to pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterEnum<Species> Species { get; set; }
Public Property Species As FilterEnum(Of Species)
    Get
    Set
public:
property FilterEnum<Species>^ Species {
    FilterEnum<Species>^ get ();
    void set (FilterEnum<Species>^ value);
}
member Species : FilterEnum<Species> with get, set

Property Value

Type: FilterEnum Species
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Squawk Property

AircraftListJsonBuilderFilterSquawk Property
Gets or sets the range of squawk values that allow an aircraft to pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRange<int> Squawk { get; set; }
Public Property Squawk As FilterRange(Of Integer)
    Get
    Set
public:
property FilterRange<int>^ Squawk {
    FilterRange<int>^ get ();
    void set (FilterRange<int>^ value);
}
member Squawk : FilterRange<int> with get, set

Property Value

Type: FilterRange Int32
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.Type Property

AircraftListJsonBuilderFilterType Property
Gets or sets the text that will be compared to an aircraft's type before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString Type { get; set; }
Public Property Type As FilterString
    Get
    Set
public:
property FilterString^ Type {
    FilterString^ get ();
    void set (FilterString^ value);
}
member Type : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.UserTag Property

AircraftListJsonBuilderFilterUserTag Property
Gets or sets the text that will be compared to an aircraft's user tag before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterString UserTag { get; set; }
Public Property UserTag As FilterString
    Get
    Set
public:
property FilterString^ UserTag {
    FilterString^ get ();
    void set (FilterString^ value);
}
member UserTag : FilterString with get, set

Property Value

Type: FilterString
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter.WakeTurbulenceCategory Property

AircraftListJsonBuilderFilterWakeTurbulenceCategory Property
Gets or sets the wake turbulence category that the aircraft must have before it can pass the filter.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterEnum<WakeTurbulenceCategory> WakeTurbulenceCategory { get; set; }
Public Property WakeTurbulenceCategory As FilterEnum(Of WakeTurbulenceCategory)
    Get
    Set
public:
property FilterEnum<WakeTurbulenceCategory>^ WakeTurbulenceCategory {
    FilterEnum<WakeTurbulenceCategory>^ get ();
    void set (FilterEnum<WakeTurbulenceCategory>^ value);
}
member WakeTurbulenceCategory : FilterEnum<WakeTurbulenceCategory> with get, set

Property Value

Type: FilterEnum WakeTurbulenceCategory
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftListJsonBuilderFilter Methods

AircraftListJsonBuilderFilter Methods

The AircraftListJsonBuilderFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftListJsonBuilderFilter Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson Class

AircraftReportJson Class
The top-level JSON object for reports on the flights taken by a single aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportRowsJson
VirtualRadar.Interface.WebSiteAircraftReportJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AircraftReportJson : ReportRowsJson
Public Class AircraftReportJson
    Inherits ReportRowsJson
public ref class AircraftReportJson : public ReportRowsJson
type AircraftReportJson =
    class
        inherit ReportRowsJson
    end

The AircraftReportJson type exposes the following members.

Constructors
 | Name | Description
Public method | AircraftReportJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | Aircraft | Gets or sets the object that describes the aircraft that is the subject of the report.
Public property | Airports | Gets a list of airports that are referred to by the routes.
Public property | CountRows | Gets or sets the total number of rows that match the report criteria. (Inherited from ReportRowsJson.)
Public property | ErrorText | Gets or sets the content of any errors or exceptions that were thrown during the processing of the report. (Inherited from ReportRowsJson.)
Public property | Flights | Gets a list of flights taken by the aircraft that match the report critera.
Public property | GroupBy | Gets or sets a value indicating the column that the data has been grouped by. (Inherited from ReportRowsJson.)
Public property | OperatorFlagsAvailable | Gets or sets a value indicating that operator flags can be shown on the report. (Inherited from ReportRowsJson.)
Public property | ProcessingTime | Gets or sets a value indicating how long the report took to process. (Inherited from ReportRowsJson.)
Public property | Routes | Gets a list of routes that are referred to by the flights.
Public property | SilhouettesAvailable | Gets or sets a value indicating that silhouettes can be shown on the report. (Inherited from ReportRowsJson.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


AircraftReportJson Constructor

AircraftReportJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AircraftReportJson()
Public Sub New
public:
AircraftReportJson()
new : unit -> AircraftReportJson
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson Properties

AircraftReportJson Properties

The AircraftReportJson type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets or sets the object that describes the aircraft that is the subject of the report.
Public property | Airports | Gets a list of airports that are referred to by the routes.
Public property | CountRows | Gets or sets the total number of rows that match the report criteria. (Inherited from ReportRowsJson.)
Public property | ErrorText | Gets or sets the content of any errors or exceptions that were thrown during the processing of the report. (Inherited from ReportRowsJson.)
Public property | Flights | Gets a list of flights taken by the aircraft that match the report critera.
Public property | GroupBy | Gets or sets a value indicating the column that the data has been grouped by. (Inherited from ReportRowsJson.)
Public property | OperatorFlagsAvailable | Gets or sets a value indicating that operator flags can be shown on the report. (Inherited from ReportRowsJson.)
Public property | ProcessingTime | Gets or sets a value indicating how long the report took to process. (Inherited from ReportRowsJson.)
Public property | Routes | Gets a list of routes that are referred to by the flights.
Public property | SilhouettesAvailable | Gets or sets a value indicating that silhouettes can be shown on the report. (Inherited from ReportRowsJson.)
Top
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson.Aircraft Property

AircraftReportJsonAircraft Property
Gets or sets the object that describes the aircraft that is the subject of the report.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReportAircraftJson Aircraft { get; set; }
Public Property Aircraft As ReportAircraftJson
    Get
    Set
public:
property ReportAircraftJson^ Aircraft {
    ReportAircraftJson^ get ();
    void set (ReportAircraftJson^ value);
}
member Aircraft : ReportAircraftJson with get, set

Property Value

Type: ReportAircraftJson
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson.Airports Property

AircraftReportJsonAirports Property
Gets a list of airports that are referred to by the routes.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportAirportJson> Airports { get; }
Public ReadOnly Property Airports As List(Of ReportAirportJson)
    Get
public:
property List<ReportAirportJson^>^ Airports {
    List<ReportAirportJson^>^ get ();
}
member Airports : List<ReportAirportJson> with get

Property Value

Type: List ReportAirportJson
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson.Flights Property

AircraftReportJsonFlights Property
Gets a list of flights taken by the aircraft that match the report critera.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportFlightJson> Flights { get; }
Public ReadOnly Property Flights As List(Of ReportFlightJson)
    Get
public:
property List<ReportFlightJson^>^ Flights {
    List<ReportFlightJson^>^ get ();
}
member Flights : List<ReportFlightJson> with get

Property Value

Type: List ReportFlightJson
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson.Routes Property

AircraftReportJsonRoutes Property
Gets a list of routes that are referred to by the flights.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportRouteJson> Routes { get; }
Public ReadOnly Property Routes As List(Of ReportRouteJson)
    Get
public:
property List<ReportRouteJson^>^ Routes {
    List<ReportRouteJson^>^ get ();
}
member Routes : List<ReportRouteJson> with get

Property Value

Type: List ReportRouteJson
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


AircraftReportJson Methods

AircraftReportJson Methods

The AircraftReportJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AircraftReportJson Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFile Class

ChecksumFile Class
A class that can read a checksum file.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteChecksumFile

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ChecksumFile
Public NotInheritable Class ChecksumFile
public ref class ChecksumFile abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ChecksumFile =  class end

The ChecksumFile type exposes the following members.

Methods
Name | Description
Load | Parses the content of a checksum file into checksum file entries.
Top
Remarks

A checksum file is a flat text file with one line per file. The format of the line is:
CHECKSUM FILE-SIZE FILE-PATH-FROM-ROOT.

The checksum and file size can be generated by static methods on CheckSumFileEntry.

See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ChecksumFile Methods

ChecksumFile Methods

The ChecksumFile type exposes the following members.

Methods
Name | Description
Load | Parses the content of a checksum file into checksum file entries.
Top
See Also

Reference

ChecksumFile Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFile.Load Method

ChecksumFileLoad Method
Parses the content of a checksum file into checksum file entries.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<ChecksumFileEntry> Load(
    string checksumFileContent
)
Public Shared Function Load (
    checksumFileContent As String
) As List(Of ChecksumFileEntry)
public:
static List<ChecksumFileEntry^>^ Load(
    String^ checksumFileContent
)
static member Load :
        checksumFileContent : string -> List<ChecksumFileEntry>

Parameters

checksumFileContent
Type: SystemString

Return Value

Type: List ChecksumFileEntry
See Also

Reference

ChecksumFile Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry Class

ChecksumFileEntry Class
Describes the content of a single line in a checksum file resource.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteChecksumFileEntry

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ChecksumFileEntry
Public Class ChecksumFileEntry
public ref class ChecksumFileEntry
type ChecksumFileEntry =  class end

The ChecksumFileEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ChecksumFileEntry | Initializes a new instance of the ChecksumFileEntry class
Top
Properties
 | Name | Description
Public property | Checksum | Gets or sets the checksum for the file.
Public property | FileName | Gets or sets the name of the file from root.
Public property | FileSize | Gets or sets the size of the file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateChecksum | Generates a checksum for a file.
 | GetFileNameFromFullPath | Returns the filename of the file from the root folder.
 | GetFileSize | Returns the length of the file.
Public method | GetFullPathFromRoot | Returns the full path and name of the file from the root folder.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry Constructor

ChecksumFileEntry Constructor
Initializes a new instance of the ChecksumFileEntry class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ChecksumFileEntry()
Public Sub New
public:
ChecksumFileEntry()
new : unit -> ChecksumFileEntry
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry Properties

ChecksumFileEntry Properties

The ChecksumFileEntry type exposes the following members.

Properties
 | Name | Description
Public property | Checksum | Gets or sets the checksum for the file.
Public property | FileName | Gets or sets the name of the file from root.
Public property | FileSize | Gets or sets the size of the file.
Top
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.Checksum Property

ChecksumFileEntryChecksum Property
Gets or sets the checksum for the file.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Checksum { get; set; }
Public Property Checksum As String
    Get
    Set
public:
property String^ Checksum {
    String^ get ();
    void set (String^ value);
}
member Checksum : string with get, set

Property Value

Type: String
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.FileName Property

ChecksumFileEntryFileName Property
Gets or sets the name of the file from root.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
Remarks
For example, if the file's full path is c:\Site\Root\Subfolder\File.html and the root folder of the site is c:\Site\Root then this property would be \Subfolder\File.html.
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.FileSize Property

ChecksumFileEntryFileSize Property
Gets or sets the size of the file.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long FileSize { get; set; }
Public Property FileSize As Long
    Get
    Set
public:
property long long FileSize {
    long long get ();
    void set (long long value);
}
member FileSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry Methods

ChecksumFileEntry Methods

The ChecksumFileEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateChecksum | Generates a checksum for a file.
 | GetFileNameFromFullPath | Returns the filename of the file from the root folder.
 | GetFileSize | Returns the length of the file.
Public method | GetFullPathFromRoot | Returns the full path and name of the file from the root folder.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.GenerateChecksum Method

ChecksumFileEntryGenerateChecksum Method
Generates a checksum for a file.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GenerateChecksum(
    string fileName
)
Public Shared Function GenerateChecksum (
    fileName As String
) As String
public:
static String^ GenerateChecksum(
    String^ fileName
)
static member GenerateChecksum :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.GetFileNameFromFullPath Method

ChecksumFileEntryGetFileNameFromFullPath Method
Returns the filename of the file from the root folder.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFileNameFromFullPath(
    string rootFolder,
    string fileName
)
Public Shared Function GetFileNameFromFullPath (
    rootFolder As String,
    fileName As String
) As String
public:
static String^ GetFileNameFromFullPath(
    String^ rootFolder,
    String^ fileName
)
static member GetFileNameFromFullPath :
        rootFolder : string *
        fileName : string -> string

Parameters

rootFolder
Type: SystemString
fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.GetFileSize Method

ChecksumFileEntryGetFileSize Method
Returns the length of the file.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static long GetFileSize(
    string fileName
)
Public Shared Function GetFileSize (
    fileName As String
) As Long
public:
static long long GetFileSize(
    String^ fileName
)
static member GetFileSize :
        fileName : string -> int64

Parameters

fileName
Type: SystemString

Return Value

Type: Int64
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.GetFullPathFromRoot Method

ChecksumFileEntryGetFullPathFromRoot Method
Returns the full path and name of the file from the root folder.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFullPathFromRoot(
    string rootFolder
)
Public Function GetFullPathFromRoot (
    rootFolder As String
) As String
public:
String^ GetFullPathFromRoot(
    String^ rootFolder
)
member GetFullPathFromRoot :
        rootFolder : string -> string

Parameters

rootFolder
Type: SystemString

Return Value

Type: String
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


ChecksumFileEntry.ToString Method

ChecksumFileEntryToString Method
See base docs.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ChecksumFileEntry Class
VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson Class

DirectoryEntryJson Class
The JSON object that carries directory information back to the VRS mothership.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteDirectoryEntryJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectoryEntryJson
Public Class DirectoryEntryJson
public ref class DirectoryEntryJson
type DirectoryEntryJson =  class end

The DirectoryEntryJson type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryEntryJson | Initializes a new instance of the DirectoryEntryJson class
Top
Properties
 | Name | Description
Public property | NumberOfAircraft | Gets or sets the highest number of aircraft across all feeds that can be viewed from the site.
Public property | NumberOfFeeds | Gets or sets the number of feeds that can be viewed from the site.
Public property | Version | Gets or sets the version number of VRS that the site is running.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
These are not sent automatically - rather the VRS site requests one when it is checking to see if the site is still alive. The user has to register the site with the directory before the mothership will start requesting directory entries.
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson Constructor

DirectoryEntryJson Constructor
Initializes a new instance of the DirectoryEntryJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectoryEntryJson()
Public Sub New
public:
DirectoryEntryJson()
new : unit -> DirectoryEntryJson
See Also

Reference

DirectoryEntryJson Class
VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson Properties

DirectoryEntryJson Properties

The DirectoryEntryJson type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfAircraft | Gets or sets the highest number of aircraft across all feeds that can be viewed from the site.
Public property | NumberOfFeeds | Gets or sets the number of feeds that can be viewed from the site.
Public property | Version | Gets or sets the version number of VRS that the site is running.
Top
See Also

Reference

DirectoryEntryJson Class
VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson.NumberOfAircraft Property

DirectoryEntryJsonNumberOfAircraft Property
Gets or sets the highest number of aircraft across all feeds that can be viewed from the site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfAircraft { get; set; }
Public Property NumberOfAircraft As Integer
    Get
    Set
public:
property int NumberOfAircraft {
    int get ();
    void set (int value);
}
member NumberOfAircraft : int with get, set

Property Value

Type: Int32
See Also

Reference

DirectoryEntryJson Class
VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson.NumberOfFeeds Property

DirectoryEntryJsonNumberOfFeeds Property
Gets or sets the number of feeds that can be viewed from the site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfFeeds { get; set; }
Public Property NumberOfFeeds As Integer
    Get
    Set
public:
property int NumberOfFeeds {
    int get ();
    void set (int value);
}
member NumberOfFeeds : int with get, set

Property Value

Type: Int32
See Also

Reference

DirectoryEntryJson Class
VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson.Version Property

DirectoryEntryJsonVersion Property
Gets or sets the version number of VRS that the site is running.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

DirectoryEntryJson Class
VirtualRadar.Interface.WebSite Namespace


DirectoryEntryJson Methods

DirectoryEntryJson Methods

The DirectoryEntryJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DirectoryEntryJson Class
VirtualRadar.Interface.WebSite Namespace


FeedJson Class

FeedJson Class
The JSON object that describes a data feed from a receiver.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteFeedJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FeedJson
Public Class FeedJson
public ref class FeedJson
type FeedJson =  class end

The FeedJson type exposes the following members.

Constructors
 | Name | Description
Public method | FeedJson | Initializes a new instance of the FeedJson class
Top
Properties
 | Name | Description
Public property | HasPolarPlot | Gets or sets a value indicating that a polar plot exists for the feed.
Public property | Name | Gets or sets the current name of the feed.
Public property | UniqueId | Gets or sets the unique ID of the feed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


FeedJson Constructor

FeedJson Constructor
Initializes a new instance of the FeedJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FeedJson()
Public Sub New
public:
FeedJson()
new : unit -> FeedJson
See Also

Reference

FeedJson Class
VirtualRadar.Interface.WebSite Namespace


FeedJson Properties

FeedJson Properties

The FeedJson type exposes the following members.

Properties
 | Name | Description
Public property | HasPolarPlot | Gets or sets a value indicating that a polar plot exists for the feed.
Public property | Name | Gets or sets the current name of the feed.
Public property | UniqueId | Gets or sets the unique ID of the feed.
Top
See Also

Reference

FeedJson Class
VirtualRadar.Interface.WebSite Namespace


FeedJson.HasPolarPlot Property

FeedJsonHasPolarPlot Property
Gets or sets a value indicating that a polar plot exists for the feed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPolarPlot { get; set; }
Public Property HasPolarPlot As Boolean
    Get
    Set
public:
property bool HasPolarPlot {
    bool get ();
    void set (bool value);
}
member HasPolarPlot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FeedJson Class
VirtualRadar.Interface.WebSite Namespace


FeedJson.Name Property

FeedJsonName Property
Gets or sets the current name of the feed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

FeedJson Class
VirtualRadar.Interface.WebSite Namespace


FeedJson.UniqueId Property

FeedJsonUniqueId Property
Gets or sets the unique ID of the feed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

FeedJson Class
VirtualRadar.Interface.WebSite Namespace


FeedJson Methods

FeedJson Methods

The FeedJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FeedJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson Class

FlightReportJson Class
The top-level JSON object for reports on the flights taken by many aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportRowsJson
VirtualRadar.Interface.WebSiteFlightReportJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FlightReportJson : ReportRowsJson
Public Class FlightReportJson
    Inherits ReportRowsJson
public ref class FlightReportJson : public ReportRowsJson
type FlightReportJson =
    class
        inherit ReportRowsJson
    end

The FlightReportJson type exposes the following members.

Constructors
 | Name | Description
Public method | FlightReportJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | Aircraft | Gets the list of aircraft that the flights refer to.
Public property | Airports | Gets the list of airports that the routes refer to.
Public property | CountRows | Gets or sets the total number of rows that match the report criteria. (Inherited from ReportRowsJson.)
Public property | ErrorText | Gets or sets the content of any errors or exceptions that were thrown during the processing of the report. (Inherited from ReportRowsJson.)
Public property | Flights | Gets the list of flights that match the report criteria.
Public property | FromDate | Gets or sets the first date that the report covers.
Public property | GroupBy | Gets or sets a value indicating the column that the data has been grouped by. (Inherited from ReportRowsJson.)
Public property | OperatorFlagsAvailable | Gets or sets a value indicating that operator flags can be shown on the report. (Inherited from ReportRowsJson.)
Public property | ProcessingTime | Gets or sets a value indicating how long the report took to process. (Inherited from ReportRowsJson.)
Public property | Routes | Gets the list of routes that the flights refer to.
Public property | SilhouettesAvailable | Gets or sets a value indicating that silhouettes can be shown on the report. (Inherited from ReportRowsJson.)
Public property | ToDate | Gets or sets the last date that the report covers.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


FlightReportJson Constructor

FlightReportJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlightReportJson()
Public Sub New
public:
FlightReportJson()
new : unit -> FlightReportJson
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson Properties

FlightReportJson Properties

The FlightReportJson type exposes the following members.

Properties
 | Name | Description
Public property | Aircraft | Gets the list of aircraft that the flights refer to.
Public property | Airports | Gets the list of airports that the routes refer to.
Public property | CountRows | Gets or sets the total number of rows that match the report criteria. (Inherited from ReportRowsJson.)
Public property | ErrorText | Gets or sets the content of any errors or exceptions that were thrown during the processing of the report. (Inherited from ReportRowsJson.)
Public property | Flights | Gets the list of flights that match the report criteria.
Public property | FromDate | Gets or sets the first date that the report covers.
Public property | GroupBy | Gets or sets a value indicating the column that the data has been grouped by. (Inherited from ReportRowsJson.)
Public property | OperatorFlagsAvailable | Gets or sets a value indicating that operator flags can be shown on the report. (Inherited from ReportRowsJson.)
Public property | ProcessingTime | Gets or sets a value indicating how long the report took to process. (Inherited from ReportRowsJson.)
Public property | Routes | Gets the list of routes that the flights refer to.
Public property | SilhouettesAvailable | Gets or sets a value indicating that silhouettes can be shown on the report. (Inherited from ReportRowsJson.)
Public property | ToDate | Gets or sets the last date that the report covers.
Top
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson.Aircraft Property

FlightReportJsonAircraft Property
Gets the list of aircraft that the flights refer to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportAircraftJson> Aircraft { get; }
Public ReadOnly Property Aircraft As List(Of ReportAircraftJson)
    Get
public:
property List<ReportAircraftJson^>^ Aircraft {
    List<ReportAircraftJson^>^ get ();
}
member Aircraft : List<ReportAircraftJson> with get

Property Value

Type: List ReportAircraftJson
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson.Airports Property

FlightReportJsonAirports Property
Gets the list of airports that the routes refer to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportAirportJson> Airports { get; }
Public ReadOnly Property Airports As List(Of ReportAirportJson)
    Get
public:
property List<ReportAirportJson^>^ Airports {
    List<ReportAirportJson^>^ get ();
}
member Airports : List<ReportAirportJson> with get

Property Value

Type: List ReportAirportJson
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson.Flights Property

FlightReportJsonFlights Property
Gets the list of flights that match the report criteria.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportFlightJson> Flights { get; }
Public ReadOnly Property Flights As List(Of ReportFlightJson)
    Get
public:
property List<ReportFlightJson^>^ Flights {
    List<ReportFlightJson^>^ get ();
}
member Flights : List<ReportFlightJson> with get

Property Value

Type: List ReportFlightJson
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson.FromDate Property

FlightReportJsonFromDate Property
Gets or sets the first date that the report covers.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FromDate { get; set; }
Public Property FromDate As String
    Get
    Set
public:
property String^ FromDate {
    String^ get ();
    void set (String^ value);
}
member FromDate : string with get, set

Property Value

Type: String
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson.Routes Property

FlightReportJsonRoutes Property
Gets the list of routes that the flights refer to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ReportRouteJson> Routes { get; }
Public ReadOnly Property Routes As List(Of ReportRouteJson)
    Get
public:
property List<ReportRouteJson^>^ Routes {
    List<ReportRouteJson^>^ get ();
}
member Routes : List<ReportRouteJson> with get

Property Value

Type: List ReportRouteJson
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson.ToDate Property

FlightReportJsonToDate Property
Gets or sets the last date that the report covers.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ToDate { get; set; }
Public Property ToDate As String
    Get
    Set
public:
property String^ ToDate {
    String^ get ();
    void set (String^ value);
}
member ToDate : string with get, set

Property Value

Type: String
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


FlightReportJson Methods

FlightReportJson Methods

The FlightReportJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FlightReportJson Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector Class

HtmlContentInjector Class
A class that describes content to inject into HTML.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteHtmlContentInjector

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlContentInjector
Public Class HtmlContentInjector
public ref class HtmlContentInjector
type HtmlContentInjector =  class end

The HtmlContentInjector type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlContentInjector | Initializes a new instance of the HtmlContentInjector class
Top
Properties
 | Name | Description
Public property | AtStart | Gets and sets a value indicating whether the content should be injected at the start or end of an HTML element.
Public property | Content | Gets and sets a delegate that returns the content to inject into the HTML.
Public property | Element | Gets and sets the HTML element to inject the content into - e.g. HEAD, BODY, HTML etc. Case insensitive.
Public property | PathAndFile | Gets and sets the path and file of the HTML file to inject content into. A null string injects into every HTML file served by the site. Case insensitive.
Public property | Priority | Gets or sets the order in which the injector will be called. Lower values have priority over higher values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
This differs from SiteRoot in that you are free to change the values after you have added it to the IWebSite. Be aware that the multi-threaded nature of the server and site can mean that your Content method could be called while you are changing the injector's properties - if your Content method refers to the properties of the injector then you should remove the existing injector from the web site, change its values and then add it back to the web site rather than change them while it's still attached.
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector Constructor

HtmlContentInjector Constructor
Initializes a new instance of the HtmlContentInjector class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlContentInjector()
Public Sub New
public:
HtmlContentInjector()
new : unit -> HtmlContentInjector
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector Properties

HtmlContentInjector Properties

The HtmlContentInjector type exposes the following members.

Properties
 | Name | Description
Public property | AtStart | Gets and sets a value indicating whether the content should be injected at the start or end of an HTML element.
Public property | Content | Gets and sets a delegate that returns the content to inject into the HTML.
Public property | Element | Gets and sets the HTML element to inject the content into - e.g. HEAD, BODY, HTML etc. Case insensitive.
Public property | PathAndFile | Gets and sets the path and file of the HTML file to inject content into. A null string injects into every HTML file served by the site. Case insensitive.
Public property | Priority | Gets or sets the order in which the injector will be called. Lower values have priority over higher values.
Top
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector.AtStart Property

HtmlContentInjectorAtStart Property
Gets and sets a value indicating whether the content should be injected at the start or end of an HTML element.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AtStart { get; set; }
Public Property AtStart As Boolean
    Get
    Set
public:
property bool AtStart {
    bool get ();
    void set (bool value);
}
member AtStart : bool with get, set

Property Value

Type: Boolean
Remarks
True injects the content directly after the open tag, false injects the content directly before the end tag.
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector.Content Property

HtmlContentInjectorContent Property
Gets and sets a delegate that returns the content to inject into the HTML.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Func<string> Content { get; set; }
Public Overridable Property Content As Func(Of String)
    Get
    Set
public:
virtual property Func<String^>^ Content {
    Func<String^>^ get ();
    void set (Func<String^>^ value);
}
abstract Content : Func<string> with get, set
override Content : Func<string> with get, set

Property Value

Type: Func String
Remarks
If this is missing or if the function returns a null or empty string then nothing is injected into the file.
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector.Element Property

HtmlContentInjectorElement Property
Gets and sets the HTML element to inject the content into - e.g. HEAD, BODY, HTML etc. Case insensitive.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
member Element : string with get, set

Property Value

Type: String
Remarks
If there are more than one of these elements in the HTML then only the first or last has the content injected into it, depending on whether AtStart is true or false. If the HTML does not contain this element then nothing is injected into the file.
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector.PathAndFile Property

HtmlContentInjectorPathAndFile Property
Gets and sets the path and file of the HTML file to inject content into. A null string injects into every HTML file served by the site. Case insensitive.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PathAndFile { get; set; }
Public Property PathAndFile As String
    Get
    Set
public:
property String^ PathAndFile {
    String^ get ();
    void set (String^ value);
}
member PathAndFile : string with get, set

Property Value

Type: String
Remarks
The path must start from the root of the site - so for http://127.0.0.1/VirtualRadar/index.html the PathAndFile would be "/index.html". Content injectors cannot add new pages to the site - if the page you specify is not served by the site then requests for it will still fail, a new page will not be added to satisfy the content injector.
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector.Priority Property

HtmlContentInjectorPriority Property
Gets or sets the order in which the injector will be called. Lower values have priority over higher values.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set
public:
property int Priority {
    int get ();
    void set (int value);
}
member Priority : int with get, set

Property Value

Type: Int32
Remarks
The relative order of two injectors with the same priority is undefined.
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


HtmlContentInjector Methods

HtmlContentInjector Methods

The HtmlContentInjector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HtmlContentInjector Class
VirtualRadar.Interface.WebSite Namespace


IAircraftListJsonBuilder Interface

IAircraftListJsonBuilder Interface
The interface for an object that can build an AircraftListJson object from an IAircraftList object's list of aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAircraftListJsonBuilder
Public Interface IAircraftListJsonBuilder
public interface class IAircraftListJsonBuilder
type IAircraftListJsonBuilder =  interface end

The IAircraftListJsonBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets the provider that abstracts away some aspects of the environment for the object.
Top
Methods
 | Name | Description
Public method | Build | Returns a fully-formed AircraftListJson from the arguments passed across.
Public method | Initialise | Initialises the object.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IAircraftListJsonBuilder Properties

IAircraftListJsonBuilder Properties

The IAircraftListJsonBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Provider | Gets the provider that abstracts away some aspects of the environment for the object.
Top
See Also

Reference

IAircraftListJsonBuilder Interface
VirtualRadar.Interface.WebSite Namespace


IAircraftListJsonBuilder.Provider Property

IAircraftListJsonBuilderProvider Property
Gets the provider that abstracts away some aspects of the environment for the object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebSiteProvider Provider { get; }
ReadOnly Property Provider As IWebSiteProvider
    Get
property IWebSiteProvider^ Provider {
    IWebSiteProvider^ get ();
}
abstract Provider : IWebSiteProvider with get

Property Value

Type: IWebSiteProvider
See Also

Reference

IAircraftListJsonBuilder Interface
VirtualRadar.Interface.WebSite Namespace


IAircraftListJsonBuilder Methods

IAircraftListJsonBuilder Methods

The IAircraftListJsonBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Returns a fully-formed AircraftListJson from the arguments passed across.
Public method | Initialise | Initialises the object.
Top
See Also

Reference

IAircraftListJsonBuilder Interface
VirtualRadar.Interface.WebSite Namespace


IAircraftListJsonBuilder.Build Method

IAircraftListJsonBuilderBuild Method
Returns a fully-formed AircraftListJson from the arguments passed across.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
AircraftListJson Build(
    AircraftListJsonBuilderArgs args
)
Function Build (
    args As AircraftListJsonBuilderArgs
) As AircraftListJson
AircraftListJson^ Build(
    AircraftListJsonBuilderArgs^ args
)
abstract Build :
        args : AircraftListJsonBuilderArgs -> AircraftListJson

Parameters

args
Type: VirtualRadar.Interface.WebSiteAircraftListJsonBuilderArgs

Return Value

Type: AircraftListJson
See Also

Reference

IAircraftListJsonBuilder Interface
VirtualRadar.Interface.WebSite Namespace


IAircraftListJsonBuilder.Initialise Method

IAircraftListJsonBuilderInitialise Method
Initialises the object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    IWebSiteProvider provider
)
Sub Initialise (
    provider As IWebSiteProvider
)
void Initialise(
    IWebSiteProvider^ provider
)
abstract Initialise :
        provider : IWebSiteProvider -> unit

Parameters

provider
Type: VirtualRadar.Interface.WebSiteIWebSiteProvider
See Also

Reference

IAircraftListJsonBuilder Interface
VirtualRadar.Interface.WebSite Namespace


IBundler Interface

IBundler Interface
The interface for objects that can bundle multiple JavaScript declarations in an HTML file into a single download.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBundler : IDisposable
Public Interface IBundler
    Inherits IDisposable
public interface class IBundler : IDisposable
type IBundler =
    interface
        interface IDisposable
    end

The IBundler type exposes the following members.

Properties
 | Name | Description
Public property | WebServer | Gets the web server that the bundler is attached to.
Public property | WebSite | Gets the web site that the bundler is attached to.
Top
Methods
 | Name | Description
Public method | AttachToWebSite | Attaches the bundler to the web site passed across.
Public method | BundleHtml | Replaces multiple statements in the HTML that drag in JavaScript files with a single statement that downloads all of the files in one go.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IBundler Properties

IBundler Properties

The IBundler type exposes the following members.

Properties
 | Name | Description
Public property | WebServer | Gets the web server that the bundler is attached to.
Public property | WebSite | Gets the web site that the bundler is attached to.
Top
See Also

Reference

IBundler Interface
VirtualRadar.Interface.WebSite Namespace


IBundler.WebServer Property

IBundlerWebServer Property
Gets the web server that the bundler is attached to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServer WebServer { get; }
ReadOnly Property WebServer As IWebServer
    Get
property IWebServer^ WebServer {
    IWebServer^ get ();
}
abstract WebServer : IWebServer with get

Property Value

Type: IWebServer
See Also

Reference

IBundler Interface
VirtualRadar.Interface.WebSite Namespace


IBundler.WebSite Property

IBundlerWebSite Property
Gets the web site that the bundler is attached to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebSite WebSite { get; }
ReadOnly Property WebSite As IWebSite
    Get
property IWebSite^ WebSite {
    IWebSite^ get ();
}
abstract WebSite : IWebSite with get

Property Value

Type: IWebSite
See Also

Reference

IBundler Interface
VirtualRadar.Interface.WebSite Namespace


IBundler Methods

IBundler Methods

The IBundler type exposes the following members.

Methods
 | Name | Description
Public method | AttachToWebSite | Attaches the bundler to the web site passed across.
Public method | BundleHtml | Replaces multiple statements in the HTML that drag in JavaScript files with a single statement that downloads all of the files in one go.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

IBundler Interface
VirtualRadar.Interface.WebSite Namespace


IBundler.AttachToWebSite Method

IBundlerAttachToWebSite Method
Attaches the bundler to the web site passed across.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AttachToWebSite(
    IWebSite webSite
)
Sub AttachToWebSite (
    webSite As IWebSite
)
void AttachToWebSite(
    IWebSite^ webSite
)
abstract AttachToWebSite :
        webSite : IWebSite -> unit

Parameters

webSite
Type: VirtualRadar.Interface.WebSiteIWebSite
Remarks
This gives the bundler the opportunity to register itself as a provider of content with the web server that the web site is using. When files are bundled they are fetched directly though the web site.
See Also

Reference

IBundler Interface
VirtualRadar.Interface.WebSite Namespace


IBundler.BundleHtml Method

IBundlerBundleHtml Method
Replaces multiple statements in the HTML that drag in JavaScript files with a single statement that downloads all of the files in one go.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string BundleHtml(
    string requestPathAndFile,
    string htmlContent
)
Function BundleHtml (
    requestPathAndFile As String,
    htmlContent As String
) As String
String^ BundleHtml(
    String^ requestPathAndFile,
    String^ htmlContent
)
abstract BundleHtml :
        requestPathAndFile : string *
        htmlContent : string -> string

Parameters

requestPathAndFile
Type: SystemString
The path and file part of the request URL for the HTML file being served.
htmlContent
Type: SystemString
The original content of the HTML file.

Return Value

Type: String
The (possibly modified) content of the HTML file.
Remarks

Bundles are delineated in the HTML with two HTML comments. The opening comment, which comes before the first of a set of files to bundle together, is of the form:

Copy
!<-- [[ JS BUNDLE START ]] -->

The end tag is:

Copy
!<-- [[ BUNDLE END ]] -->

All script statements of type="text/javascript" between the BUNDLE START / END lines are removed, unless they point to remote files, and are replaced with a single statement. The URL for the single statement has a random unique filename. When the browser requests that file the bundler causes the site to serve a file that has the content of all of the JS files concatenated together into a single file.

The JavaScript files that are concatenated together are fetched via the web site.

See Also

Reference

IBundler Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser Interface

IHtmlLocaliser Interface
The interface for objects that can localise HTML using string resources.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IHtmlLocaliser
Public Interface IHtmlLocaliser
public interface class IHtmlLocaliser
type IHtmlLocaliser =  interface end

The IHtmlLocaliser type exposes the following members.

Properties
 | Name | Description
Public property | LocalisedStringsMap | Gets the localised strings that the localiser is using.
Top
Methods
 | Name | Description
Public method | AddResourceStrings | Adds resource strings to the localised strings map.
Public method | ConvertResourceStringToHtmlString | Escapes HTML in the string, converts linebreaks to break tags and so on.
Public method | ConvertResourceStringToJavaScriptString | Escapes quotes in the string, converts linebreaks to \r or \n etc.
Public method | Html | Replaces all instances of ::STRING:: with the localised text.
Public method | Initialise | Initialises the localiser with the Virtual Radar Server application strings.
Public method | Initialise(Type) | Initialises the localiser with the strings from the compiled resource object passed across.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser Properties

IHtmlLocaliser Properties

The IHtmlLocaliser type exposes the following members.

Properties
 | Name | Description
Public property | LocalisedStringsMap | Gets the localised strings that the localiser is using.
Top
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.LocalisedStringsMap Property

IHtmlLocaliserLocalisedStringsMap Property
Gets the localised strings that the localiser is using.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
LocalisedStringsMap LocalisedStringsMap { get; }
ReadOnly Property LocalisedStringsMap As LocalisedStringsMap
    Get
property LocalisedStringsMap^ LocalisedStringsMap {
    LocalisedStringsMap^ get ();
}
abstract LocalisedStringsMap : LocalisedStringsMap with get

Property Value

Type: LocalisedStringsMap
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser Methods

IHtmlLocaliser Methods

The IHtmlLocaliser type exposes the following members.

Methods
 | Name | Description
Public method | AddResourceStrings | Adds resource strings to the localised strings map.
Public method | ConvertResourceStringToHtmlString | Escapes HTML in the string, converts linebreaks to break tags and so on.
Public method | ConvertResourceStringToJavaScriptString | Escapes quotes in the string, converts linebreaks to \r or \n etc.
Public method | Html | Replaces all instances of ::STRING:: with the localised text.
Public method | Initialise | Initialises the localiser with the Virtual Radar Server application strings.
Public method | Initialise(Type) | Initialises the localiser with the strings from the compiled resource object passed across.
Top
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.AddResourceStrings Method

IHtmlLocaliserAddResourceStrings Method
Adds resource strings to the localised strings map.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddResourceStrings(
    Type resourceStringsType
)
Sub AddResourceStrings (
    resourceStringsType As Type
)
void AddResourceStrings(
    Type^ resourceStringsType
)
abstract AddResourceStrings :
        resourceStringsType : Type -> unit

Parameters

resourceStringsType
Type: SystemType
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.ConvertResourceStringToHtmlString Method

IHtmlLocaliserConvertResourceStringToHtmlString Method
Escapes HTML in the string, converts linebreaks to break tags and so on.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConvertResourceStringToHtmlString(
    string resourceString
)
Function ConvertResourceStringToHtmlString (
    resourceString As String
) As String
String^ ConvertResourceStringToHtmlString(
    String^ resourceString
)
abstract ConvertResourceStringToHtmlString :
        resourceString : string -> string

Parameters

resourceString
Type: SystemString

Return Value

Type: String
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.ConvertResourceStringToJavaScriptString Method

IHtmlLocaliserConvertResourceStringToJavaScriptString Method
Escapes quotes in the string, converts linebreaks to \r or \n etc.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string ConvertResourceStringToJavaScriptString(
    string resourceString,
    char stringDelimiter
)
Function ConvertResourceStringToJavaScriptString (
    resourceString As String,
    stringDelimiter As Char
) As String
String^ ConvertResourceStringToJavaScriptString(
    String^ resourceString,
    wchar_t stringDelimiter
)
abstract ConvertResourceStringToJavaScriptString :
        resourceString : string *
        stringDelimiter : char -> string

Parameters

resourceString
Type: SystemString
stringDelimiter
Type: SystemChar

Return Value

Type: String
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.Html Method

IHtmlLocaliserHtml Method
Replaces all instances of ::STRING:: with the localised text.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string Html(
    string html,
    Encoding encoding
)
Function Html (
    html As String,
    encoding As Encoding
) As String
String^ Html(
    String^ html,
    Encoding^ encoding
)
abstract Html :
        html : string *
        encoding : Encoding -> string

Parameters

html
Type: SystemString
encoding
Type: System.TextEncoding

Return Value

Type: String
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.Initialise Method

IHtmlLocaliserInitialise Method
Overload List
 | Name | Description
Public method | Initialise | Initialises the localiser with the Virtual Radar Server application strings.
Public method | Initialise(Type) | Initialises the localiser with the strings from the compiled resource object passed across.
Top
See Also

Reference

IHtmlLocaliser Interface
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.Initialise Method

IHtmlLocaliserInitialise Method
Initialises the localiser with the Virtual Radar Server application strings.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IHtmlLocaliser Interface
Initialise Overload
VirtualRadar.Interface.WebSite Namespace


IHtmlLocaliser.Initialise Method (Type)

IHtmlLocaliserInitialise Method (Type)
Initialises the localiser with the strings from the compiled resource object passed across.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    Type resourceStringsType
)
Sub Initialise (
    resourceStringsType As Type
)
void Initialise(
    Type^ resourceStringsType
)
abstract Initialise :
        resourceStringsType : Type -> unit

Parameters

resourceStringsType
Type: SystemType
See Also

Reference

IHtmlLocaliser Interface
Initialise Overload
VirtualRadar.Interface.WebSite Namespace


IMinifier Interface

IMinifier Interface
The interface for an object that can minify JavaScript and CSS.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMinifier : IDisposable
Public Interface IMinifier
    Inherits IDisposable
public interface class IMinifier : IDisposable
type IMinifier =
    interface
        interface IDisposable
    end

The IMinifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the minifier.
Public method | MinifyCss | Returns the CSS passed across with the content compressed as much as possible.
Public method | MinifyJavaScript | Returns the JavaScript passed across with the content compressed as much as possible.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IMinifier Methods

IMinifier Methods

The IMinifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the minifier.
Public method | MinifyCss | Returns the CSS passed across with the content compressed as much as possible.
Public method | MinifyJavaScript | Returns the JavaScript passed across with the content compressed as much as possible.
Top
See Also

Reference

IMinifier Interface
VirtualRadar.Interface.WebSite Namespace


IMinifier.Initialise Method

IMinifierInitialise Method
Initialises the minifier.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise()
Sub Initialise
void Initialise()
abstract Initialise : unit -> unit
See Also

Reference

IMinifier Interface
VirtualRadar.Interface.WebSite Namespace


IMinifier.MinifyCss Method

IMinifierMinifyCss Method
Returns the CSS passed across with the content compressed as much as possible.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string MinifyCss(
    string cssContent
)
Function MinifyCss (
    cssContent As String
) As String
String^ MinifyCss(
    String^ cssContent
)
abstract MinifyCss :
        cssContent : string -> string

Parameters

cssContent
Type: SystemString

Return Value

Type: String
See Also

Reference

IMinifier Interface
VirtualRadar.Interface.WebSite Namespace


IMinifier.MinifyJavaScript Method

IMinifierMinifyJavaScript Method
Returns the JavaScript passed across with the content compressed as much as possible.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string MinifyJavaScript(
    string javaScriptContent
)
Function MinifyJavaScript (
    javaScriptContent As String
) As String
String^ MinifyJavaScript(
    String^ javaScriptContent
)
abstract MinifyJavaScript :
        javaScriptContent : string -> string

Parameters

javaScriptContent
Type: SystemString

Return Value

Type: String
See Also

Reference

IMinifier Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager Interface

IWebAdminViewManager Interface
The interface that objects which handle collections of WebAdminViews must implement.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebAdminViewManager : ISingleton<IWebAdminViewManager>
Public Interface IWebAdminViewManager
    Inherits ISingleton(Of IWebAdminViewManager)
public interface class IWebAdminViewManager : ISingleton<IWebAdminViewManager^>
type IWebAdminViewManager =
    interface
        interface ISingleton<IWebAdminViewManager>
    end

The IWebAdminViewManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | WebAdminPluginInstalled | Returns true if the web admin plugin has been installed.
Top
Methods
 | Name | Description
Public method | AddWebAdminView | Registers a view with the web admin site. The view's folder must previously have been registered with a call to RegisterWebAdminViewFolder(String, String).
Public method | RegisterTemplateFileName | Registers a template marker and the file that contains the HTML that should be subtituted in its place when seen within a web admin HTML file.
Public method | RegisterTranslations | Registers a string resources file that should be made available to JavaScript. It can be loaded via the URL WebAdmin/Script/Strings.<namespace>.js. Do not use the namespace Server, that is used by the plugin to expose the VRS's strings. Strings.js loads the web site strings and a Globalize object for the server's language.
Public method | RegisterWebAdminViewFolder | Registers a folder with web admin view HTML files on behalf of a plugin.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager Properties

IWebAdminViewManager Properties

The IWebAdminViewManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Public property | WebAdminPluginInstalled | Returns true if the web admin plugin has been installed.
Top
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager.WebAdminPluginInstalled Property

IWebAdminViewManagerWebAdminPluginInstalled Property
Returns true if the web admin plugin has been installed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WebAdminPluginInstalled { get; }
ReadOnly Property WebAdminPluginInstalled As Boolean
    Get
property bool WebAdminPluginInstalled {
    bool get ();
}
abstract WebAdminPluginInstalled : bool with get

Property Value

Type: Boolean
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager Methods

IWebAdminViewManager Methods

The IWebAdminViewManager type exposes the following members.

Methods
 | Name | Description
Public method | AddWebAdminView | Registers a view with the web admin site. The view's folder must previously have been registered with a call to RegisterWebAdminViewFolder(String, String).
Public method | RegisterTemplateFileName | Registers a template marker and the file that contains the HTML that should be subtituted in its place when seen within a web admin HTML file.
Public method | RegisterTranslations | Registers a string resources file that should be made available to JavaScript. It can be loaded via the URL WebAdmin/Script/Strings.<namespace>.js. Do not use the namespace Server, that is used by the plugin to expose the VRS's strings. Strings.js loads the web site strings and a Globalize object for the server's language.
Public method | RegisterWebAdminViewFolder | Registers a folder with web admin view HTML files on behalf of a plugin.
Top
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager.AddWebAdminView Method

IWebAdminViewManagerAddWebAdminView Method
Registers a view with the web admin site. The view's folder must previously have been registered with a call to RegisterWebAdminViewFolder(String, String).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddWebAdminView(
    WebAdminView webAdminView
)
Sub AddWebAdminView (
    webAdminView As WebAdminView
)
void AddWebAdminView(
    WebAdminView^ webAdminView
)
abstract AddWebAdminView :
        webAdminView : WebAdminView -> unit

Parameters

webAdminView
Type: VirtualRadar.Interface.WebSiteWebAdminView
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager.RegisterTemplateFileName Method

IWebAdminViewManagerRegisterTemplateFileName Method
Registers a template marker and the file that contains the HTML that should be subtituted in its place when seen within a web admin HTML file.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterTemplateFileName(
    string templateMarker,
    string templateHtmlFullPath
)
Sub RegisterTemplateFileName (
    templateMarker As String,
    templateHtmlFullPath As String
)
void RegisterTemplateFileName(
    String^ templateMarker,
    String^ templateHtmlFullPath
)
abstract RegisterTemplateFileName :
        templateMarker : string *
        templateHtmlFullPath : string -> unit

Parameters

templateMarker
Type: SystemString
templateHtmlFullPath
Type: SystemString
Remarks
The web admin plugin reserves the @head.html@ template marker. All web admin views should include this marker in their head tag.
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager.RegisterTranslations Method

IWebAdminViewManagerRegisterTranslations Method
Registers a string resources file that should be made available to JavaScript. It can be loaded via the URL WebAdmin/Script/Strings.<namespace>.js. Do not use the namespace Server, that is used by the plugin to expose the VRS's strings. Strings.js loads the web site strings and a Globalize object for the server's language.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterTranslations(
    Type stringResourcesType,
    string namespace
)
Sub RegisterTranslations (
    stringResourcesType As Type,
    namespace As String
)
void RegisterTranslations(
    Type^ stringResourcesType,
    String^ namespace
)
abstract RegisterTranslations :
        stringResourcesType : Type *
        namespace : string -> unit

Parameters

stringResourcesType
Type: SystemType
namespace
Type: SystemString
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebAdminViewManager.RegisterWebAdminViewFolder Method

IWebAdminViewManagerRegisterWebAdminViewFolder Method
Registers a folder with web admin view HTML files on behalf of a plugin.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterWebAdminViewFolder(
    string pluginFolder,
    string subFolder
)
Sub RegisterWebAdminViewFolder (
    pluginFolder As String,
    subFolder As String
)
void RegisterWebAdminViewFolder(
    String^ pluginFolder,
    String^ subFolder
)
abstract RegisterWebAdminViewFolder :
        pluginFolder : string *
        subFolder : string -> unit

Parameters

pluginFolder
Type: SystemString
subFolder
Type: SystemString
Remarks
Do not put web admin views in or under the plugin's normal Web folder, keep them separate so that they are not served if the WebAdmin plugin is not installed.
See Also

Reference

IWebAdminViewManager Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite Interface

IWebSite Interface
The interface for objects that bring together a collection of pages into the website that is presented to the browser.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebSite
Public Interface IWebSite
public interface class IWebSite
type IWebSite =  interface end

The IWebSite type exposes the following members.

Properties
 | Name | Description
Public property | BaseStationDatabase | Gets or sets the BaseStation database that the site will use when generating reports.
Public property | FlightSimulatorAircraftList | Gets or sets the aircraft list to use when browsers ask for the FSX aircraft list.
Public property | Provider | Gets or sets the testing provider.
Public property | StandingDataManager | Gets or sets the object that can lookup entries in the standing data on our behalf.
Public property | WebServer | Gets the web server that the site is attached to.
Top
Methods
 | Name | Description
Public method | AddHtmlContentInjector | Adds an object that can cause content to be injected into HTML files served by the site.
Public method | AddSiteRoot | Adds a folder from which files can be served by the site.
Public method | AttachSiteToServer | Attaches the website to a server.
Public method | GetSiteRootFolders | Returns a collection of all of the folders from which content will be served.
Public method | IsSiteRootActive | Returns true if the site root is currently being used to serve files.
Public method | RemoveHtmlContentInjector | Removes an HtmlContentInjector previously added by AddHtmlContentInjector(HtmlContentInjector).
Public method | RemoveSiteRoot | Removes a site root that had been previously added to the site via AddSiteRoot(SiteRoot).
Public method | RequestContent | Processes the request for content as if it had been a request received event raised by a web server.
Public method | RequestSimpleContent | Processes the request for content indicated by the path from root and file passed across.
Top
Events
 | Name | Description
Public event | HtmlLoadedFromFile | Raised when an HTML file is loaded from a disk-bound file. Listeners can modify the HTML before it is sent to the browser.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IWebSite Properties

IWebSite Properties

The IWebSite type exposes the following members.

Properties
 | Name | Description
Public property | BaseStationDatabase | Gets or sets the BaseStation database that the site will use when generating reports.
Public property | FlightSimulatorAircraftList | Gets or sets the aircraft list to use when browsers ask for the FSX aircraft list.
Public property | Provider | Gets or sets the testing provider.
Public property | StandingDataManager | Gets or sets the object that can lookup entries in the standing data on our behalf.
Public property | WebServer | Gets the web server that the site is attached to.
Top
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.BaseStationDatabase Property

IWebSiteBaseStationDatabase Property
Gets or sets the BaseStation database that the site will use when generating reports.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IBaseStationDatabase BaseStationDatabase { get; set; }
Property BaseStationDatabase As IBaseStationDatabase
    Get
    Set
property IBaseStationDatabase^ BaseStationDatabase {
    IBaseStationDatabase^ get ();
    void set (IBaseStationDatabase^ value);
}
abstract BaseStationDatabase : IBaseStationDatabase with get, set

Property Value

Type: IBaseStationDatabase
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.FlightSimulatorAircraftList Property

IWebSiteFlightSimulatorAircraftList Property
Gets or sets the aircraft list to use when browsers ask for the FSX aircraft list.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ISimpleAircraftList FlightSimulatorAircraftList { get; set; }
Property FlightSimulatorAircraftList As ISimpleAircraftList
    Get
    Set
property ISimpleAircraftList^ FlightSimulatorAircraftList {
    ISimpleAircraftList^ get ();
    void set (ISimpleAircraftList^ value);
}
abstract FlightSimulatorAircraftList : ISimpleAircraftList with get, set

Property Value

Type: ISimpleAircraftList
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.Provider Property

IWebSiteProvider Property
Gets or sets the testing provider.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebSiteProvider Provider { get; set; }
Property Provider As IWebSiteProvider
    Get
    Set
property IWebSiteProvider^ Provider {
    IWebSiteProvider^ get ();
    void set (IWebSiteProvider^ value);
}
abstract Provider : IWebSiteProvider with get, set

Property Value

Type: IWebSiteProvider
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.StandingDataManager Property

IWebSiteStandingDataManager Property
Gets or sets the object that can lookup entries in the standing data on our behalf.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IStandingDataManager StandingDataManager { get; set; }
Property StandingDataManager As IStandingDataManager
    Get
    Set
property IStandingDataManager^ StandingDataManager {
    IStandingDataManager^ get ();
    void set (IStandingDataManager^ value);
}
abstract StandingDataManager : IStandingDataManager with get, set

Property Value

Type: IStandingDataManager
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.WebServer Property

IWebSiteWebServer Property
Gets the web server that the site is attached to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebServer WebServer { get; }
ReadOnly Property WebServer As IWebServer
    Get
property IWebServer^ WebServer {
    IWebServer^ get ();
}
abstract WebServer : IWebServer with get

Property Value

Type: IWebServer
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite Methods

IWebSite Methods

The IWebSite type exposes the following members.

Methods
 | Name | Description
Public method | AddHtmlContentInjector | Adds an object that can cause content to be injected into HTML files served by the site.
Public method | AddSiteRoot | Adds a folder from which files can be served by the site.
Public method | AttachSiteToServer | Attaches the website to a server.
Public method | GetSiteRootFolders | Returns a collection of all of the folders from which content will be served.
Public method | IsSiteRootActive | Returns true if the site root is currently being used to serve files.
Public method | RemoveHtmlContentInjector | Removes an HtmlContentInjector previously added by AddHtmlContentInjector(HtmlContentInjector).
Public method | RemoveSiteRoot | Removes a site root that had been previously added to the site via AddSiteRoot(SiteRoot).
Public method | RequestContent | Processes the request for content as if it had been a request received event raised by a web server.
Public method | RequestSimpleContent | Processes the request for content indicated by the path from root and file passed across.
Top
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.AddHtmlContentInjector Method

IWebSiteAddHtmlContentInjector Method
Adds an object that can cause content to be injected into HTML files served by the site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddHtmlContentInjector(
    HtmlContentInjector contentInjector
)
Sub AddHtmlContentInjector (
    contentInjector As HtmlContentInjector
)
void AddHtmlContentInjector(
    HtmlContentInjector^ contentInjector
)
abstract AddHtmlContentInjector :
        contentInjector : HtmlContentInjector -> unit

Parameters

contentInjector
Type: VirtualRadar.Interface.WebSiteHtmlContentInjector
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.AddSiteRoot Method

IWebSiteAddSiteRoot Method
Adds a folder from which files can be served by the site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddSiteRoot(
    SiteRoot siteRoot
)
Sub AddSiteRoot (
    siteRoot As SiteRoot
)
void AddSiteRoot(
    SiteRoot^ siteRoot
)
abstract AddSiteRoot :
        siteRoot : SiteRoot -> unit

Parameters

siteRoot
Type: VirtualRadar.Interface.WebSiteSiteRoot
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.AttachSiteToServer Method

IWebSiteAttachSiteToServer Method
Attaches the website to a server.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void AttachSiteToServer(
    IWebServer server
)
Sub AttachSiteToServer (
    server As IWebServer
)
void AttachSiteToServer(
    IWebServer^ server
)
abstract AttachSiteToServer :
        server : IWebServer -> unit

Parameters

server
Type: VirtualRadar.Interface.WebServerIWebServer
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.GetSiteRootFolders Method

IWebSiteGetSiteRootFolders Method
Returns a collection of all of the folders from which content will be served.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
List<string> GetSiteRootFolders()
Function GetSiteRootFolders As List(Of String)
List<String^>^ GetSiteRootFolders()
abstract GetSiteRootFolders : unit -> List<string>

Return Value

Type: List String
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.IsSiteRootActive Method

IWebSiteIsSiteRootActive Method
Returns true if the site root is currently being used to serve files.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSiteRootActive(
    SiteRoot siteRoot,
    bool folderMustMatch
)
Function IsSiteRootActive (
    siteRoot As SiteRoot,
    folderMustMatch As Boolean
) As Boolean
bool IsSiteRootActive(
    SiteRoot^ siteRoot,
    bool folderMustMatch
)
abstract IsSiteRootActive :
        siteRoot : SiteRoot *
        folderMustMatch : bool -> bool

Parameters

siteRoot
Type: VirtualRadar.Interface.WebSiteSiteRoot
folderMustMatch
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.RemoveHtmlContentInjector Method

IWebSiteRemoveHtmlContentInjector Method
Removes an HtmlContentInjector previously added by AddHtmlContentInjector(HtmlContentInjector).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveHtmlContentInjector(
    HtmlContentInjector contentInjector
)
Sub RemoveHtmlContentInjector (
    contentInjector As HtmlContentInjector
)
void RemoveHtmlContentInjector(
    HtmlContentInjector^ contentInjector
)
abstract RemoveHtmlContentInjector :
        contentInjector : HtmlContentInjector -> unit

Parameters

contentInjector
Type: VirtualRadar.Interface.WebSiteHtmlContentInjector
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.RemoveSiteRoot Method

IWebSiteRemoveSiteRoot Method
Removes a site root that had been previously added to the site via AddSiteRoot(SiteRoot).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveSiteRoot(
    SiteRoot siteRoot
)
Sub RemoveSiteRoot (
    siteRoot As SiteRoot
)
void RemoveSiteRoot(
    SiteRoot^ siteRoot
)
abstract RemoveSiteRoot :
        siteRoot : SiteRoot -> unit

Parameters

siteRoot
Type: VirtualRadar.Interface.WebSiteSiteRoot
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.RequestContent Method

IWebSiteRequestContent Method
Processes the request for content as if it had been a request received event raised by a web server.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RequestContent(
    RequestReceivedEventArgs args
)
Sub RequestContent (
    args As RequestReceivedEventArgs
)
void RequestContent(
    RequestReceivedEventArgs^ args
)
abstract RequestContent :
        args : RequestReceivedEventArgs -> unit

Parameters

args
Type: VirtualRadar.Interface.WebServerRequestReceivedEventArgs
Remarks
This method allows other parts of the system to fetch pages as a browser would see them but without having to mimic an IWebServer, or interfere with the live IWebServer.
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.RequestSimpleContent Method

IWebSiteRequestSimpleContent Method
Processes the request for content indicated by the path from root and file passed across.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SimpleContent RequestSimpleContent(
    string pathAndFile
)
Function RequestSimpleContent (
    pathAndFile As String
) As SimpleContent
SimpleContent^ RequestSimpleContent(
    String^ pathAndFile
)
abstract RequestSimpleContent :
        pathAndFile : string -> SimpleContent

Parameters

pathAndFile
Type: SystemString
The path and file portion of a URL.

Return Value

Type: SimpleContent
An object describing the result of the request.
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite Events

IWebSite Events

The IWebSite type exposes the following members.

Events
 | Name | Description
Public event | HtmlLoadedFromFile | Raised when an HTML file is loaded from a disk-bound file. Listeners can modify the HTML before it is sent to the browser.
Top
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSite.HtmlLoadedFromFile Event

IWebSiteHtmlLoadedFromFile Event
Raised when an HTML file is loaded from a disk-bound file. Listeners can modify the HTML before it is sent to the browser.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<TextContentEventArgs> HtmlLoadedFromFile
Event HtmlLoadedFromFile As EventHandler(Of TextContentEventArgs)
 event EventHandler<TextContentEventArgs^>^ HtmlLoadedFromFile {
    void add (EventHandler<TextContentEventArgs^>^ value);
    void remove (EventHandler<TextContentEventArgs^>^ value);
}
abstract HtmlLoadedFromFile : IEvent<EventHandler<TextContentEventArgs>,
    TextContentEventArgs>

Value

Type: SystemEventHandler TextContentEventArgs
See Also

Reference

IWebSite Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender Interface

IWebSiteExtender Interface
The interface for a wrapper around the extension methods exposed in IWebSite. Intended for use by plugins to make life a bit easier for those that want to extend the website.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebSiteExtender : IDisposable
Public Interface IWebSiteExtender
    Inherits IDisposable
public interface class IWebSiteExtender : IDisposable
type IWebSiteExtender =
    interface
        interface IDisposable
    end

The IWebSiteExtender type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the extensions are enabled or disabled.
Public property | InjectContent | Gets or sets a string that will be injected at the end of the HEAD tag for all of the pages in InjectPages.
Public property | InjectPages | Gets a collection of pages that InjectContent will be injected into. If this is empty then the content will be injected into all pages.
Public property | PageHandlers | Gets a map of page handler methods keyed by the address that they will handle.
Public property | Priority | Gets or sets the priority of your plugin relative to the standard Virtual Radar Server web site and other plugins.
Public property | WebRootSubFolder | Gets or sets the folder under the plugin's installation folder that contains the files to add to the root of the web site.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the web extender.
Public method | InjectMapPages | Adds the map page addresses to InjectPages. Has no effect if called after Initialise(PluginStartupParameters).
Public method | InjectReportPages | Adds the report page addresses to InjectPages. Has no effect if called after Initialise(PluginStartupParameters).
Public method | ProtectFolder | Marks a URL folder as protected. Only administrators may access protected folders.
Public method | RestrictAccessToFolder | Restricts access to a folder based on IP address.
Public method | UnprotectFolder | Marks a URL folder as unprotected. Anyone can access unprotected folders (subject to global authentication rules).
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender Properties

IWebSiteExtender Properties

The IWebSiteExtender type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the extensions are enabled or disabled.
Public property | InjectContent | Gets or sets a string that will be injected at the end of the HEAD tag for all of the pages in InjectPages.
Public property | InjectPages | Gets a collection of pages that InjectContent will be injected into. If this is empty then the content will be injected into all pages.
Public property | PageHandlers | Gets a map of page handler methods keyed by the address that they will handle.
Public property | Priority | Gets or sets the priority of your plugin relative to the standard Virtual Radar Server web site and other plugins.
Public property | WebRootSubFolder | Gets or sets the folder under the plugin's installation folder that contains the files to add to the root of the web site.
Top
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.Enabled Property

IWebSiteExtenderEnabled Property
Gets or sets a value indicating whether the extensions are enabled or disabled.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.InjectContent Property

IWebSiteExtenderInjectContent Property
Gets or sets a string that will be injected at the end of the HEAD tag for all of the pages in InjectPages.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string InjectContent { get; set; }
Property InjectContent As String
    Get
    Set
property String^ InjectContent {
    String^ get ();
    void set (String^ value);
}
abstract InjectContent : string with get, set

Property Value

Type: String
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.InjectPages Property

IWebSiteExtenderInjectPages Property
Gets a collection of pages that InjectContent will be injected into. If this is empty then the content will be injected into all pages.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> InjectPages { get; }
ReadOnly Property InjectPages As IList(Of String)
    Get
property IList<String^>^ InjectPages {
    IList<String^>^ get ();
}
abstract InjectPages : IList<string> with get

Property Value

Type: IList String
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.PageHandlers Property

IWebSiteExtenderPageHandlers Property
Gets a map of page handler methods keyed by the address that they will handle.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, Action<RequestReceivedEventArgs>> PageHandlers { get; }
ReadOnly Property PageHandlers As IDictionary(Of String, Action(Of RequestReceivedEventArgs))
    Get
property IDictionary<String^, Action<RequestReceivedEventArgs^>^>^ PageHandlers {
    IDictionary<String^, Action<RequestReceivedEventArgs^>^>^ get ();
}
abstract PageHandlers : IDictionary<string, Action<RequestReceivedEventArgs>> with get

Property Value

Type: IDictionary String, Action RequestReceivedEventArgs
Remarks

If your plugin needs to handle requests in code - for example it needs to create JSON responses on the fly - then you can register your handlers for those requests here. The key to the dictionary is the address from the VRS root of the address that you want your code called for (e.g. '/MyPlugin/GiveMeData.json') and the value is a delegate, anonymous delegate or function that takes a single parameter, a RequestReceivedEventArgs, that passes information about the request and can be used to send a response to the browser.

Addresses are not case sensitive.

See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.Priority Property

IWebSiteExtenderPriority Property
Gets or sets the priority of your plugin relative to the standard Virtual Radar Server web site and other plugins.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
int Priority { get; set; }
Property Priority As Integer
    Get
    Set
property int Priority {
    int get ();
    void set (int value);
}
abstract Priority : int with get, set

Property Value

Type: Int32
Remarks

Under normal use you can leave this at the default value, in which case if there is a clash between a file you are serving and a file that Virtual Radar Server is serving then the standard Virtual Radar Server file is served. If you make sure that your files are in a well named sub-folder then clashes should not occur and priority should not be an issue.

If you want to override a standard VRS file then set this to a value that is below zero. However you need to be careful with this as your plugin may end up breaking with a future version of VRS.

See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.WebRootSubFolder Property

IWebSiteExtenderWebRootSubFolder Property
Gets or sets the folder under the plugin's installation folder that contains the files to add to the root of the web site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string WebRootSubFolder { get; set; }
Property WebRootSubFolder As String
    Get
    Set
property String^ WebRootSubFolder {
    String^ get ();
    void set (String^ value);
}
abstract WebRootSubFolder : string with get, set

Property Value

Type: String
Remarks

If this property is null then no files will be added to the root of the site. To avoid accidentally interferring with future updates of VRS it is recommended that you create a sub-folder under this folder that is named after your plugin and put all of your files there. So, if your plugin is called 'MyPlugin' then you might:

Create a folder in your plugin installation folder called Web.Set this property to "Web".Create a sub-folder under Web called MyPlugin.Put all of your HTML, JavaScript and CSS into the MyPlugin folder.
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender Methods

IWebSiteExtender Methods

The IWebSiteExtender type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialise | Initialises the web extender.
Public method | InjectMapPages | Adds the map page addresses to InjectPages. Has no effect if called after Initialise(PluginStartupParameters).
Public method | InjectReportPages | Adds the report page addresses to InjectPages. Has no effect if called after Initialise(PluginStartupParameters).
Public method | ProtectFolder | Marks a URL folder as protected. Only administrators may access protected folders.
Public method | RestrictAccessToFolder | Restricts access to a folder based on IP address.
Public method | UnprotectFolder | Marks a URL folder as unprotected. Anyone can access unprotected folders (subject to global authentication rules).
Top
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.Initialise Method

IWebSiteExtenderInitialise Method
Initialises the web extender.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Initialise(
    PluginStartupParameters pluginStartupParameters
)
Sub Initialise (
    pluginStartupParameters As PluginStartupParameters
)
void Initialise(
    PluginStartupParameters^ pluginStartupParameters
)
abstract Initialise :
        pluginStartupParameters : PluginStartupParameters -> unit

Parameters

pluginStartupParameters
Type: VirtualRadar.InterfacePluginStartupParameters
The startup parameters passed to the plugin's Startup method.
Remarks
Once you call this method any changes to the properties, aside from Enabled, are ignored. You can use the Enabled property to turn your plugins extensions on and off on the fly or you can dispose of the extender entirely, but you cannot change anything else.
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.InjectMapPages Method

IWebSiteExtenderInjectMapPages Method
Adds the map page addresses to InjectPages. Has no effect if called after Initialise(PluginStartupParameters).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebSiteExtender InjectMapPages()
Function InjectMapPages As IWebSiteExtender
IWebSiteExtender^ InjectMapPages()
abstract InjectMapPages : unit -> IWebSiteExtender

Return Value

Type: IWebSiteExtender
The web site extender object that was called.
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.InjectReportPages Method

IWebSiteExtenderInjectReportPages Method
Adds the report page addresses to InjectPages. Has no effect if called after Initialise(PluginStartupParameters).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IWebSiteExtender InjectReportPages()
Function InjectReportPages As IWebSiteExtender
IWebSiteExtender^ InjectReportPages()
abstract InjectReportPages : unit -> IWebSiteExtender

Return Value

Type: IWebSiteExtender
The web site extender object that was called.
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.ProtectFolder Method

IWebSiteExtenderProtectFolder Method
Marks a URL folder as protected. Only administrators may access protected folders.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ProtectFolder(
    string folder
)
Sub ProtectFolder (
    folder As String
)
void ProtectFolder(
    String^ folder
)
abstract ProtectFolder :
        folder : string -> unit

Parameters

folder
Type: SystemString
Remarks
For example, if you were to protect the folder "MyPlugin/Admin" then access to http://127.0.0.1/VirtualRadar/MyPlugin/index.html would not be protected, but access to http://127.0.0.1/VirtualRadar/MyPlugin/Admin/index.html would only be allowed once the user had supplied credentials, and only if the credentials could be authenticated against the list of administrator users.
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.RestrictAccessToFolder Method

IWebSiteExtenderRestrictAccessToFolder Method
Restricts access to a folder based on IP address.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestrictAccessToFolder(
    string folder,
    Access access
)
Sub RestrictAccessToFolder (
    folder As String,
    access As Access
)
void RestrictAccessToFolder(
    String^ folder,
    Access^ access
)
abstract RestrictAccessToFolder :
        folder : string *
        access : Access -> unit

Parameters

folder
Type: SystemString
access
Type: VirtualRadar.Interface.SettingsAccess
Remarks
Similar to ProtectFolder(String) except you can call this method many times after you have called Initialise(PluginStartupParameters). To remove access restrictions pass a null reference for access.
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteExtender.UnprotectFolder Method

IWebSiteExtenderUnprotectFolder Method
Marks a URL folder as unprotected. Anyone can access unprotected folders (subject to global authentication rules).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnprotectFolder(
    string folder
)
Sub UnprotectFolder (
    folder As String
)
void UnprotectFolder(
    String^ folder
)
abstract UnprotectFolder :
        folder : string -> unit

Parameters

folder
Type: SystemString
See Also

Reference

IWebSiteExtender Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics Interface

IWebSiteGraphics Interface
The interface for objects that handle graphics manipulation for the web site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebSiteGraphics : ISingleton<IWebSiteGraphics>
Public Interface IWebSiteGraphics
    Inherits ISingleton(Of IWebSiteGraphics)
public interface class IWebSiteGraphics : ISingleton<IWebSiteGraphics^>
type IWebSiteGraphics =
    interface
        interface ISingleton<IWebSiteGraphics>
    end

The IWebSiteGraphics type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
Methods
 | Name | Description
Public method | AddAltitudeStalk | Creates a new image of the required height with an altitude stalk drawn centred on the X pixel passed across.
Public method | AddTextLines | Overlays lines of text onto the image.
Public method | CreateBlankImage | Creates a fully-transparent image of the size specified.
Public method | CreateIPhoneSplash | Creates an iPhone splash page image.
Public method | HeightenImage | Heightens the image and centres the original image within it. The new pixels are transparent.
Public method | ResizeBitmap | Returns a new bitmap with the dimensions specified. The entire bitmap is filled with the background and then the original bitmap is drawn into the centre. If the aspect ratio of the original image is different to that of the new image then the ResizeMode indicates how to deal with it.
Public method | ResizeForHiDpi | Doubles the width and height of the image for use on high DPI displays.
Public method | RotateImage | Rotates the image passed across by a number of degrees, running clockwise with 0 being north.
Public method | UseImage | When passed the current temporary image and the image that will become the new temporary image this disposes of the old temporary image and returns the new one. Can cope when the same image is passed across for both the temporary and new image.
Public method | WidenImage | Widens the image and centres the original image within it. The new pixels are transparent.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics Properties

IWebSiteGraphics Properties

The IWebSiteGraphics type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | Gets the single instance of the class that should be used throughout the application. (Inherited from ISingletonT.)
Top
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics Methods

IWebSiteGraphics Methods

The IWebSiteGraphics type exposes the following members.

Methods
 | Name | Description
Public method | AddAltitudeStalk | Creates a new image of the required height with an altitude stalk drawn centred on the X pixel passed across.
Public method | AddTextLines | Overlays lines of text onto the image.
Public method | CreateBlankImage | Creates a fully-transparent image of the size specified.
Public method | CreateIPhoneSplash | Creates an iPhone splash page image.
Public method | HeightenImage | Heightens the image and centres the original image within it. The new pixels are transparent.
Public method | ResizeBitmap | Returns a new bitmap with the dimensions specified. The entire bitmap is filled with the background and then the original bitmap is drawn into the centre. If the aspect ratio of the original image is different to that of the new image then the ResizeMode indicates how to deal with it.
Public method | ResizeForHiDpi | Doubles the width and height of the image for use on high DPI displays.
Public method | RotateImage | Rotates the image passed across by a number of degrees, running clockwise with 0 being north.
Public method | UseImage | When passed the current temporary image and the image that will become the new temporary image this disposes of the old temporary image and returns the new one. Can cope when the same image is passed across for both the temporary and new image.
Public method | WidenImage | Widens the image and centres the original image within it. The new pixels are transparent.
Top
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.AddAltitudeStalk Method

IWebSiteGraphicsAddAltitudeStalk Method
Creates a new image of the required height with an altitude stalk drawn centred on the X pixel passed across.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image AddAltitudeStalk(
    Image original,
    int height,
    int centreX
)
Function AddAltitudeStalk (
    original As Image,
    height As Integer,
    centreX As Integer
) As Image
Image^ AddAltitudeStalk(
    Image^ original,
    int height,
    int centreX
)
abstract AddAltitudeStalk :
        original : Image *
        height : int *
        centreX : int -> Image

Parameters

original
Type: System.DrawingImage
height
Type: SystemInt32
centreX
Type: SystemInt32

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.AddTextLines Method

IWebSiteGraphicsAddTextLines Method
Overlays lines of text onto the image.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image AddTextLines(
    Image image,
    IEnumerable<string> textLines,
    bool centreText,
    bool isHighDpi
)
Function AddTextLines (
    image As Image,
    textLines As IEnumerable(Of String),
    centreText As Boolean,
    isHighDpi As Boolean
) As Image
Image^ AddTextLines(
    Image^ image,
    IEnumerable<String^>^ textLines,
    bool centreText,
    bool isHighDpi
)
abstract AddTextLines :
        image : Image *
        textLines : IEnumerable<string> *
        centreText : bool *
        isHighDpi : bool -> Image

Parameters

image
Type: System.DrawingImage
textLines
Type: System.Collections.GenericIEnumerable String
centreText
Type: SystemBoolean
isHighDpi
Type: SystemBoolean

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.CreateBlankImage Method

IWebSiteGraphicsCreateBlankImage Method
Creates a fully-transparent image of the size specified.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image CreateBlankImage(
    int width,
    int height
)
Function CreateBlankImage (
    width As Integer,
    height As Integer
) As Image
Image^ CreateBlankImage(
    int width,
    int height
)
abstract CreateBlankImage :
        width : int *
        height : int -> Image

Parameters

width
Type: SystemInt32
height
Type: SystemInt32

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.CreateIPhoneSplash Method

IWebSiteGraphicsCreateIPhoneSplash Method
Creates an iPhone splash page image.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image CreateIPhoneSplash(
    string webSiteAddress,
    bool isIPad,
    List<string> pathParts
)
Function CreateIPhoneSplash (
    webSiteAddress As String,
    isIPad As Boolean,
    pathParts As List(Of String)
) As Image
Image^ CreateIPhoneSplash(
    String^ webSiteAddress,
    bool isIPad,
    List<String^>^ pathParts
)
abstract CreateIPhoneSplash :
        webSiteAddress : string *
        isIPad : bool *
        pathParts : List<string> -> Image

Parameters

webSiteAddress
Type: SystemString
isIPad
Type: SystemBoolean
pathParts
Type: System.Collections.GenericList String

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.HeightenImage Method

IWebSiteGraphicsHeightenImage Method
Heightens the image and centres the original image within it. The new pixels are transparent.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image HeightenImage(
    Image original,
    int height,
    bool centreVertically
)
Function HeightenImage (
    original As Image,
    height As Integer,
    centreVertically As Boolean
) As Image
Image^ HeightenImage(
    Image^ original,
    int height,
    bool centreVertically
)
abstract HeightenImage :
        original : Image *
        height : int *
        centreVertically : bool -> Image

Parameters

original
Type: System.DrawingImage
height
Type: SystemInt32
centreVertically
Type: SystemBoolean

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.ResizeBitmap Method

IWebSiteGraphicsResizeBitmap Method
Returns a new bitmap with the dimensions specified. The entire bitmap is filled with the background and then the original bitmap is drawn into the centre. If the aspect ratio of the original image is different to that of the new image then the ResizeMode indicates how to deal with it.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Bitmap ResizeBitmap(
    Bitmap original,
    int width,
    int height,
    ResizeImageMode mode,
    Brush zoomBackground,
    bool preferSpeedOverQuality
)
Function ResizeBitmap (
    original As Bitmap,
    width As Integer,
    height As Integer,
    mode As ResizeImageMode,
    zoomBackground As Brush,
    preferSpeedOverQuality As Boolean
) As Bitmap
Bitmap^ ResizeBitmap(
    Bitmap^ original,
    int width,
    int height,
    ResizeImageMode mode,
    Brush^ zoomBackground,
    bool preferSpeedOverQuality
)
abstract ResizeBitmap :
        original : Bitmap *
        width : int *
        height : int *
        mode : ResizeImageMode *
        zoomBackground : Brush *
        preferSpeedOverQuality : bool -> Bitmap

Parameters

original
Type: System.DrawingBitmap
width
Type: SystemInt32
height
Type: SystemInt32
mode
Type: VirtualRadar.Interface.WebSiteResizeImageMode
zoomBackground
Type: System.DrawingBrush
preferSpeedOverQuality
Type: SystemBoolean

Return Value

Type: Bitmap
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.ResizeForHiDpi Method

IWebSiteGraphicsResizeForHiDpi Method
Doubles the width and height of the image for use on high DPI displays.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image ResizeForHiDpi(
    Image original
)
Function ResizeForHiDpi (
    original As Image
) As Image
Image^ ResizeForHiDpi(
    Image^ original
)
abstract ResizeForHiDpi :
        original : Image -> Image

Parameters

original
Type: System.DrawingImage

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.RotateImage Method

IWebSiteGraphicsRotateImage Method
Rotates the image passed across by a number of degrees, running clockwise with 0 being north.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image RotateImage(
    Image original,
    double degrees
)
Function RotateImage (
    original As Image,
    degrees As Double
) As Image
Image^ RotateImage(
    Image^ original,
    double degrees
)
abstract RotateImage :
        original : Image *
        degrees : float -> Image

Parameters

original
Type: System.DrawingImage
degrees
Type: SystemDouble

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.UseImage Method

IWebSiteGraphicsUseImage Method
When passed the current temporary image and the image that will become the new temporary image this disposes of the old temporary image and returns the new one. Can cope when the same image is passed across for both the temporary and new image.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image UseImage(
    Image tempImage,
    Image newImage
)
Function UseImage (
    tempImage As Image,
    newImage As Image
) As Image
Image^ UseImage(
    Image^ tempImage,
    Image^ newImage
)
abstract UseImage :
        tempImage : Image *
        newImage : Image -> Image

Parameters

tempImage
Type: System.DrawingImage
newImage
Type: System.DrawingImage

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteGraphics.WidenImage Method

IWebSiteGraphicsWidenImage Method
Widens the image and centres the original image within it. The new pixels are transparent.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Image WidenImage(
    Image original,
    int width,
    bool centreHorizontally
)
Function WidenImage (
    original As Image,
    width As Integer,
    centreHorizontally As Boolean
) As Image
Image^ WidenImage(
    Image^ original,
    int width,
    bool centreHorizontally
)
abstract WidenImage :
        original : Image *
        width : int *
        centreHorizontally : bool -> Image

Parameters

original
Type: System.DrawingImage
width
Type: SystemInt32
centreHorizontally
Type: SystemBoolean

Return Value

Type: Image
See Also

Reference

IWebSiteGraphics Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteProvider Interface

IWebSiteProvider Interface
The interface for the provider on VirtualRadar.Interface.WebSite that abstracts away parts of the environment that we want to control during testing.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWebSiteProvider
Public Interface IWebSiteProvider
public interface class IWebSiteProvider
type IWebSiteProvider =  interface end

The IWebSiteProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current date and time.
Top
Methods
 | Name | Description
Public method | DirectoryExists | Returns true if the folder exists.
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


IWebSiteProvider Properties

IWebSiteProvider Properties

The IWebSiteProvider type exposes the following members.

Properties
 | Name | Description
Public property | UtcNow | Gets the current date and time.
Top
See Also

Reference

IWebSiteProvider Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteProvider.UtcNow Property

IWebSiteProviderUtcNow Property
Gets the current date and time.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime UtcNow { get; }
ReadOnly Property UtcNow As DateTime
    Get
property DateTime UtcNow {
    DateTime get ();
}
abstract UtcNow : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IWebSiteProvider Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteProvider Methods

IWebSiteProvider Methods

The IWebSiteProvider type exposes the following members.

Methods
 | Name | Description
Public method | DirectoryExists | Returns true if the folder exists.
Top
See Also

Reference

IWebSiteProvider Interface
VirtualRadar.Interface.WebSite Namespace


IWebSiteProvider.DirectoryExists Method

IWebSiteProviderDirectoryExists Method
Returns true if the folder exists.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DirectoryExists(
    string folder
)
Function DirectoryExists (
    folder As String
) As Boolean
bool DirectoryExists(
    String^ folder
)
abstract DirectoryExists :
        folder : string -> bool

Parameters

folder
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IWebSiteProvider Interface
VirtualRadar.Interface.WebSite Namespace


PolarPlotJson Class

PolarPlotJson Class
The JSON for a single polar plot.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSitePolarPlotJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolarPlotJson
Public Class PolarPlotJson
public ref class PolarPlotJson
type PolarPlotJson =  class end

The PolarPlotJson type exposes the following members.

Constructors
 | Name | Description
Public method | PolarPlotJson | Initializes a new instance of the PolarPlotJson class
Top
Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


PolarPlotJson Constructor

PolarPlotJson Constructor
Initializes a new instance of the PolarPlotJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolarPlotJson()
Public Sub New
public:
PolarPlotJson()
new : unit -> PolarPlotJson
See Also

Reference

PolarPlotJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotJson Properties

PolarPlotJson Properties

The PolarPlotJson type exposes the following members.

Properties
 | Name | Description
Public property | Latitude | Gets or sets the latitude.
Public property | Longitude | Gets or sets the longitude.
Top
See Also

Reference

PolarPlotJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotJson.Latitude Property

PolarPlotJsonLatitude Property
Gets or sets the latitude.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Latitude { get; set; }
Public Property Latitude As Single
    Get
    Set
public:
property float Latitude {
    float get ();
    void set (float value);
}
member Latitude : float32 with get, set

Property Value

Type: Single
See Also

Reference

PolarPlotJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotJson.Longitude Property

PolarPlotJsonLongitude Property
Gets or sets the longitude.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float Longitude { get; set; }
Public Property Longitude As Single
    Get
    Set
public:
property float Longitude {
    float get ();
    void set (float value);
}
member Longitude : float32 with get, set

Property Value

Type: Single
See Also

Reference

PolarPlotJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotJson Methods

PolarPlotJson Methods

The PolarPlotJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolarPlotJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsJson Class

PolarPlotsJson Class
The JSON that describes all of the available polar plots for a single feed.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSitePolarPlotsJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolarPlotsJson
Public Class PolarPlotsJson
public ref class PolarPlotsJson
type PolarPlotsJson =  class end

The PolarPlotsJson type exposes the following members.

Constructors
 | Name | Description
Public method | PolarPlotsJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | FeedId | Gets or sets the unique identifier of the feed.
Public property | Slices | Gets the list of slices.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


PolarPlotsJson Constructor

PolarPlotsJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolarPlotsJson()
Public Sub New
public:
PolarPlotsJson()
new : unit -> PolarPlotsJson
See Also

Reference

PolarPlotsJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsJson Properties

PolarPlotsJson Properties

The PolarPlotsJson type exposes the following members.

Properties
 | Name | Description
Public property | FeedId | Gets or sets the unique identifier of the feed.
Public property | Slices | Gets the list of slices.
Top
See Also

Reference

PolarPlotsJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsJson.FeedId Property

PolarPlotsJsonFeedId Property
Gets or sets the unique identifier of the feed.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FeedId { get; set; }
Public Property FeedId As Integer
    Get
    Set
public:
property int FeedId {
    int get ();
    void set (int value);
}
member FeedId : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlotsJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsJson.Slices Property

PolarPlotsJsonSlices Property
Gets the list of slices.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<PolarPlotsSliceJson> Slices { get; }
Public ReadOnly Property Slices As List(Of PolarPlotsSliceJson)
    Get
public:
property List<PolarPlotsSliceJson^>^ Slices {
    List<PolarPlotsSliceJson^>^ get ();
}
member Slices : List<PolarPlotsSliceJson> with get

Property Value

Type: List PolarPlotsSliceJson
See Also

Reference

PolarPlotsJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsJson Methods

PolarPlotsJson Methods

The PolarPlotsJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolarPlotsJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson Class

PolarPlotsSliceJson Class
The JSON for a polar plot slice.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSitePolarPlotsSliceJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolarPlotsSliceJson
Public Class PolarPlotsSliceJson
public ref class PolarPlotsSliceJson
type PolarPlotsSliceJson =  class end

The PolarPlotsSliceJson type exposes the following members.

Constructors
 | Name | Description
Public method | PolarPlotsSliceJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | FinishAltitude | Gets or sets the end altitude for the slice.
Public property | Plots | Gets or sets the plots for the slice.
Public property | StartAltitude | Gets or sets the start altitude for the slice.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson Constructor

PolarPlotsSliceJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolarPlotsSliceJson()
Public Sub New
public:
PolarPlotsSliceJson()
new : unit -> PolarPlotsSliceJson
See Also

Reference

PolarPlotsSliceJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson Properties

PolarPlotsSliceJson Properties

The PolarPlotsSliceJson type exposes the following members.

Properties
 | Name | Description
Public property | FinishAltitude | Gets or sets the end altitude for the slice.
Public property | Plots | Gets or sets the plots for the slice.
Public property | StartAltitude | Gets or sets the start altitude for the slice.
Top
See Also

Reference

PolarPlotsSliceJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson.FinishAltitude Property

PolarPlotsSliceJsonFinishAltitude Property
Gets or sets the end altitude for the slice.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FinishAltitude { get; set; }
Public Property FinishAltitude As Integer
    Get
    Set
public:
property int FinishAltitude {
    int get ();
    void set (int value);
}
member FinishAltitude : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlotsSliceJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson.Plots Property

PolarPlotsSliceJsonPlots Property
Gets or sets the plots for the slice.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<PolarPlotJson> Plots { get; }
Public ReadOnly Property Plots As List(Of PolarPlotJson)
    Get
public:
property List<PolarPlotJson^>^ Plots {
    List<PolarPlotJson^>^ get ();
}
member Plots : List<PolarPlotJson> with get

Property Value

Type: List PolarPlotJson
See Also

Reference

PolarPlotsSliceJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson.StartAltitude Property

PolarPlotsSliceJsonStartAltitude Property
Gets or sets the start altitude for the slice.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StartAltitude { get; set; }
Public Property StartAltitude As Integer
    Get
    Set
public:
property int StartAltitude {
    int get ();
    void set (int value);
}
member StartAltitude : int with get, set

Property Value

Type: Int32
See Also

Reference

PolarPlotsSliceJson Class
VirtualRadar.Interface.WebSite Namespace


PolarPlotsSliceJson Methods

PolarPlotsSliceJson Methods

The PolarPlotsSliceJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PolarPlotsSliceJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson Class

ProximityGadgetAircraftJson Class
The data transfer object for the JSON file that is sent to the Windows 7 promixity gadget.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteProximityGadgetAircraftJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProximityGadgetAircraftJson
Public Class ProximityGadgetAircraftJson
public ref class ProximityGadgetAircraftJson
type ProximityGadgetAircraftJson =  class end

The ProximityGadgetAircraftJson type exposes the following members.

Constructors
 | Name | Description
Public method | ProximityGadgetAircraftJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | ClosestAircraft | Gets or sets the closest aircraft, if any.
Public property | EmergencyAircraft | Gets a list of every aircraft that is transmitting an emergency squawk.
Public property | WarningMessage | Gets or sets the content of any warnings that need to be transmitted back to the gadget.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson Constructor

ProximityGadgetAircraftJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProximityGadgetAircraftJson()
Public Sub New
public:
ProximityGadgetAircraftJson()
new : unit -> ProximityGadgetAircraftJson
See Also

Reference

ProximityGadgetAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson Properties

ProximityGadgetAircraftJson Properties

The ProximityGadgetAircraftJson type exposes the following members.

Properties
 | Name | Description
Public property | ClosestAircraft | Gets or sets the closest aircraft, if any.
Public property | EmergencyAircraft | Gets a list of every aircraft that is transmitting an emergency squawk.
Public property | WarningMessage | Gets or sets the content of any warnings that need to be transmitted back to the gadget.
Top
See Also

Reference

ProximityGadgetAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson.ClosestAircraft Property

ProximityGadgetAircraftJsonClosestAircraft Property
Gets or sets the closest aircraft, if any.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProximityGadgetClosestAircraftJson ClosestAircraft { get; set; }
Public Property ClosestAircraft As ProximityGadgetClosestAircraftJson
    Get
    Set
public:
property ProximityGadgetClosestAircraftJson^ ClosestAircraft {
    ProximityGadgetClosestAircraftJson^ get ();
    void set (ProximityGadgetClosestAircraftJson^ value);
}
member ClosestAircraft : ProximityGadgetClosestAircraftJson with get, set

Property Value

Type: ProximityGadgetClosestAircraftJson
Remarks
This is an object because the historical code would write {} if there wasn't a closest aircraft and I want to keep the same behaviour. When I come to revamp the proximity gadget I will change this.
See Also

Reference

ProximityGadgetAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson.EmergencyAircraft Property

ProximityGadgetAircraftJsonEmergencyAircraft Property
Gets a list of every aircraft that is transmitting an emergency squawk.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ProximityGadgetClosestAircraftJson> EmergencyAircraft { get; }
Public ReadOnly Property EmergencyAircraft As List(Of ProximityGadgetClosestAircraftJson)
    Get
public:
property List<ProximityGadgetClosestAircraftJson^>^ EmergencyAircraft {
    List<ProximityGadgetClosestAircraftJson^>^ get ();
}
member EmergencyAircraft : List<ProximityGadgetClosestAircraftJson> with get

Property Value

Type: List ProximityGadgetClosestAircraftJson
See Also

Reference

ProximityGadgetAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson.WarningMessage Property

ProximityGadgetAircraftJsonWarningMessage Property
Gets or sets the content of any warnings that need to be transmitted back to the gadget.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WarningMessage { get; set; }
Public Property WarningMessage As String
    Get
    Set
public:
property String^ WarningMessage {
    String^ get ();
    void set (String^ value);
}
member WarningMessage : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetAircraftJson Methods

ProximityGadgetAircraftJson Methods

The ProximityGadgetAircraftJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProximityGadgetAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson Class

ProximityGadgetClosestAircraftJson Class
The DTO that carries information about the closest aircraft to the Windows Vista/7 proximity gadget.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteProximityGadgetClosestAircraftJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProximityGadgetClosestAircraftJson
Public Class ProximityGadgetClosestAircraftJson
public ref class ProximityGadgetClosestAircraftJson
type ProximityGadgetClosestAircraftJson =  class end

The ProximityGadgetClosestAircraftJson type exposes the following members.

Constructors
 | Name | Description
Public method | ProximityGadgetClosestAircraftJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | Altitude | Gets or sets the aircraft's altitude in feet.
Public property | BearingFromHere | Gets or sets the bearing from the browser to the aircraft in degrees from 0° north.
Public property | Callsign | Gets or sets the aircraft's callsign.
Public property | Destination | Gets or sets the airport that the aircraft is travelling to.
Public property | DistanceFromHere | Gets or sets the distance from the browser's location to the aircraft in kilometres.
Public property | Emergency | Gets or sets a flag indicating that the aircraft is transmitting a mayday squawk.
Public property | GroundSpeed | Gets or sets the ground speed of the aircraft in knots.
Public property | HasPicture | Gets or sets a value indicating that a picture exists for the aircraft.
Public property | Icao24 | Gets or sets the 24-bit Mode-S identifier of the aircraft.
Public property | Icao24Invalid | Gets or sets a value indicating that the Icao24 code is wrong - either it is an unallocated code or the aircraft is known to be transmitting the wrong code.
Public property | Latitude | Gets or sets the latitude of the aircraft.
Public property | Longitude | Gets or sets the aircraft's longitude.
Public property | Manufacturer | Gets or sets the name of the aircraft's manufacturer.
Public property | Model | Gets or sets the model of the aircraft.
Public property | Operator | Gets or sets the operator's name.
Public property | OperatorIcao | Gets or sets the operator's ICAO code.
Public property | Origin | Gets or sets the airport that the aircraft set out from.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | Squawk | Gets or sets the squawk currently transmitted by the aircraft.
Public property | Stopovers | Gets or sets a list of airports that the aircraft will be stopping at on its way to Destination.
Public property | Track | Gets or sets the heading that the aircraft is tracking across the ground in degrees from 0° north.
Public property | Type | Gets or sets the ICAO8643 type code of the aircraft.
Public property | VerticalRate | Gets or sets the vertical speed in feet per second.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson Constructor

ProximityGadgetClosestAircraftJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProximityGadgetClosestAircraftJson()
Public Sub New
public:
ProximityGadgetClosestAircraftJson()
new : unit -> ProximityGadgetClosestAircraftJson
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson Properties

ProximityGadgetClosestAircraftJson Properties

The ProximityGadgetClosestAircraftJson type exposes the following members.

Properties
 | Name | Description
Public property | Altitude | Gets or sets the aircraft's altitude in feet.
Public property | BearingFromHere | Gets or sets the bearing from the browser to the aircraft in degrees from 0° north.
Public property | Callsign | Gets or sets the aircraft's callsign.
Public property | Destination | Gets or sets the airport that the aircraft is travelling to.
Public property | DistanceFromHere | Gets or sets the distance from the browser's location to the aircraft in kilometres.
Public property | Emergency | Gets or sets a flag indicating that the aircraft is transmitting a mayday squawk.
Public property | GroundSpeed | Gets or sets the ground speed of the aircraft in knots.
Public property | HasPicture | Gets or sets a value indicating that a picture exists for the aircraft.
Public property | Icao24 | Gets or sets the 24-bit Mode-S identifier of the aircraft.
Public property | Icao24Invalid | Gets or sets a value indicating that the Icao24 code is wrong - either it is an unallocated code or the aircraft is known to be transmitting the wrong code.
Public property | Latitude | Gets or sets the latitude of the aircraft.
Public property | Longitude | Gets or sets the aircraft's longitude.
Public property | Manufacturer | Gets or sets the name of the aircraft's manufacturer.
Public property | Model | Gets or sets the model of the aircraft.
Public property | Operator | Gets or sets the operator's name.
Public property | OperatorIcao | Gets or sets the operator's ICAO code.
Public property | Origin | Gets or sets the airport that the aircraft set out from.
Public property | Registration | Gets or sets the aircraft's registration.
Public property | Squawk | Gets or sets the squawk currently transmitted by the aircraft.
Public property | Stopovers | Gets or sets a list of airports that the aircraft will be stopping at on its way to Destination.
Public property | Track | Gets or sets the heading that the aircraft is tracking across the ground in degrees from 0° north.
Public property | Type | Gets or sets the ICAO8643 type code of the aircraft.
Public property | VerticalRate | Gets or sets the vertical speed in feet per second.
Top
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Altitude Property

ProximityGadgetClosestAircraftJsonAltitude Property
Gets or sets the aircraft's altitude in feet.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Altitude { get; set; }
Public Property Altitude As String
    Get
    Set
public:
property String^ Altitude {
    String^ get ();
    void set (String^ value);
}
member Altitude : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.BearingFromHere Property

ProximityGadgetClosestAircraftJsonBearingFromHere Property
Gets or sets the bearing from the browser to the aircraft in degrees from 0° north.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BearingFromHere { get; set; }
Public Property BearingFromHere As String
    Get
    Set
public:
property String^ BearingFromHere {
    String^ get ();
    void set (String^ value);
}
member BearingFromHere : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Callsign Property

ProximityGadgetClosestAircraftJsonCallsign Property
Gets or sets the aircraft's callsign.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Callsign { get; set; }
Public Property Callsign As String
    Get
    Set
public:
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
member Callsign : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Destination Property

ProximityGadgetClosestAircraftJsonDestination Property
Gets or sets the airport that the aircraft is travelling to.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Destination { get; set; }
Public Property Destination As String
    Get
    Set
public:
property String^ Destination {
    String^ get ();
    void set (String^ value);
}
member Destination : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.DistanceFromHere Property

ProximityGadgetClosestAircraftJsonDistanceFromHere Property
Gets or sets the distance from the browser's location to the aircraft in kilometres.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DistanceFromHere { get; set; }
Public Property DistanceFromHere As String
    Get
    Set
public:
property String^ DistanceFromHere {
    String^ get ();
    void set (String^ value);
}
member DistanceFromHere : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Emergency Property

ProximityGadgetClosestAircraftJsonEmergency Property
Gets or sets a flag indicating that the aircraft is transmitting a mayday squawk.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Emergency { get; set; }
Public Property Emergency As Boolean
    Get
    Set
public:
property bool Emergency {
    bool get ();
    void set (bool value);
}
member Emergency : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.GroundSpeed Property

ProximityGadgetClosestAircraftJsonGroundSpeed Property
Gets or sets the ground speed of the aircraft in knots.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GroundSpeed { get; set; }
Public Property GroundSpeed As String
    Get
    Set
public:
property String^ GroundSpeed {
    String^ get ();
    void set (String^ value);
}
member GroundSpeed : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.HasPicture Property

ProximityGadgetClosestAircraftJsonHasPicture Property
Gets or sets a value indicating that a picture exists for the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPicture { get; set; }
Public Property HasPicture As Boolean
    Get
    Set
public:
property bool HasPicture {
    bool get ();
    void set (bool value);
}
member HasPicture : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Icao24 Property

ProximityGadgetClosestAircraftJsonIcao24 Property
Gets or sets the 24-bit Mode-S identifier of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao24 { get; set; }
Public Property Icao24 As String
    Get
    Set
public:
property String^ Icao24 {
    String^ get ();
    void set (String^ value);
}
member Icao24 : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Icao24Invalid Property

ProximityGadgetClosestAircraftJsonIcao24Invalid Property
Gets or sets a value indicating that the Icao24 code is wrong - either it is an unallocated code or the aircraft is known to be transmitting the wrong code.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Icao24Invalid { get; set; }
Public Property Icao24Invalid As Boolean
    Get
    Set
public:
property bool Icao24Invalid {
    bool get ();
    void set (bool value);
}
member Icao24Invalid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Latitude Property

ProximityGadgetClosestAircraftJsonLatitude Property
Gets or sets the latitude of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Latitude { get; set; }
Public Property Latitude As String
    Get
    Set
public:
property String^ Latitude {
    String^ get ();
    void set (String^ value);
}
member Latitude : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Longitude Property

ProximityGadgetClosestAircraftJsonLongitude Property
Gets or sets the aircraft's longitude.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Longitude { get; set; }
Public Property Longitude As String
    Get
    Set
public:
property String^ Longitude {
    String^ get ();
    void set (String^ value);
}
member Longitude : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Manufacturer Property

ProximityGadgetClosestAircraftJsonManufacturer Property
Gets or sets the name of the aircraft's manufacturer.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Model Property

ProximityGadgetClosestAircraftJsonModel Property
Gets or sets the model of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Model { get; set; }
Public Property Model As String
    Get
    Set
public:
property String^ Model {
    String^ get ();
    void set (String^ value);
}
member Model : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Operator Property

ProximityGadgetClosestAircraftJsonOperator Property
Gets or sets the operator's name.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Operator { get; set; }
Public Property Operator As String
    Get
    Set
public:
property String^ Operator {
    String^ get ();
    void set (String^ value);
}
member Operator : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.OperatorIcao Property

ProximityGadgetClosestAircraftJsonOperatorIcao Property
Gets or sets the operator's ICAO code.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorIcao { get; set; }
Public Property OperatorIcao As String
    Get
    Set
public:
property String^ OperatorIcao {
    String^ get ();
    void set (String^ value);
}
member OperatorIcao : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Origin Property

ProximityGadgetClosestAircraftJsonOrigin Property
Gets or sets the airport that the aircraft set out from.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Origin { get; set; }
Public Property Origin As String
    Get
    Set
public:
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
member Origin : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Registration Property

ProximityGadgetClosestAircraftJsonRegistration Property
Gets or sets the aircraft's registration.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration { get; set; }
Public Property Registration As String
    Get
    Set
public:
property String^ Registration {
    String^ get ();
    void set (String^ value);
}
member Registration : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Squawk Property

ProximityGadgetClosestAircraftJsonSquawk Property
Gets or sets the squawk currently transmitted by the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Squawk { get; set; }
Public Property Squawk As String
    Get
    Set
public:
property String^ Squawk {
    String^ get ();
    void set (String^ value);
}
member Squawk : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Stopovers Property

ProximityGadgetClosestAircraftJsonStopovers Property
Gets or sets a list of airports that the aircraft will be stopping at on its way to Destination.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> Stopovers { get; }
Public ReadOnly Property Stopovers As List(Of String)
    Get
public:
property List<String^>^ Stopovers {
    List<String^>^ get ();
}
member Stopovers : List<string> with get

Property Value

Type: List String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Track Property

ProximityGadgetClosestAircraftJsonTrack Property
Gets or sets the heading that the aircraft is tracking across the ground in degrees from 0° north.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Track { get; set; }
Public Property Track As String
    Get
    Set
public:
property String^ Track {
    String^ get ();
    void set (String^ value);
}
member Track : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.Type Property

ProximityGadgetClosestAircraftJsonType Property
Gets or sets the ICAO8643 type code of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson.VerticalRate Property

ProximityGadgetClosestAircraftJsonVerticalRate Property
Gets or sets the vertical speed in feet per second.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VerticalRate { get; set; }
Public Property VerticalRate As String
    Get
    Set
public:
property String^ VerticalRate {
    String^ get ();
    void set (String^ value);
}
member VerticalRate : string with get, set

Property Value

Type: String
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ProximityGadgetClosestAircraftJson Methods

ProximityGadgetClosestAircraftJson Methods

The ProximityGadgetClosestAircraftJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProximityGadgetClosestAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson Class

ReportAircraftJson Class
Describes an aircraft in a report.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportAircraftJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReportAircraftJson
Public Class ReportAircraftJson
public ref class ReportAircraftJson
type ReportAircraftJson =  class end

The ReportAircraftJson type exposes the following members.

Constructors
 | Name | Description
Public method | ReportAircraftJson | Initializes a new instance of the ReportAircraftJson class
Top
Properties
 | Name | Description
Public property | AircraftClass | Gets or sets the aircraft's 'class' - can't find out what this actually is! Still report it though.
Public property | AircraftId | Gets or sets the unique identifier of the aircraft in the database.
Public property | AirframeReg | Obsolete. Gets or sets the registration as formatted for Airframes.org
Public property | CofACategory | Gets or sets the certificate of airworthiness category.
Public property | CofAExpiry | Gets or sets the date that the certificate of airworthiness expires.
Public property | Country | Gets or sets the country of the operator.
Public property | CurrentRegDate | Gets or sets the date that the aircraft was registered.
Public property | DeRegDate | Gets or sets the date that the plane was taken off the register.
Public property | EnginePlacement | Gets or sets the placement of the engine on the aircraft.
Public property | Engines | Gets or sets a value indicating how many engines there are, or whether the engines are coupled.
Public property | EngineType | Gets or sets the engine type used by the aircraft cast to an int (see EngineType).
Public property | FirstRegDate | Gets or sets the date that the aircraft was first placed onto the register.
Public property | GenericName | Gets or sets the generic name for the type of aircraft.
Public property | HasPicture | Gets or sets a value indicating that the user has a local picture of the aircraft.
Public property | Icao | Gets or sets the 24-bit Mode-S identifier assigned to the aircraft.
Public property | IcaoTypeCode | Gets or sets the ICAO 8643 type code for the aircraft.
Public property | InfoUrl | Gets or sets the URL of a web page showing more information about the aircraft.
Public property | Interested | Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears.
Public property | IsUnknown | Gets or sets a value that indicates that the registraton does not correspond to any aircraft in the database.
Public property | Manufacturer | Gets or sets the full name of the aircraft's manufacturer.
Public property | Military | Gets or sets a value indicating that the aircraft is operated by a military force.
Public property | ModeSCountry | Gets or sets the country of registration.
Public property | MTOW | Gets or sets the maximum takeoff weight of the aircraft.
Public property | Notes | Gets or sets the user's notes on the aircraft.
Public property | OperatorFlagCode | Gets or sets the ICAO code for the aircraft's operator.
Public property | OwnershipStatus | Gets or sets a value describing whether the aircraft is owned outright, leased etc.
Public property | PictureHeight | Gets or sets the height of the picture in pixels.
Public property | PictureUrl1 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl2 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl3 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureWidth | Gets or sets the width of the picture in pixels.
Public property | PopularName | Gets or sets the popular name for the type of aircraft.
Public property | PreviousId | Gets or sets the previous Mode-S ID of the aircraft (I think? doesn't make a great deal of sense, would be better off as an int back to another aircraft record - but mine is not to question why...)
Public property | RegisteredOwners | Gets or sets the operator of the aircraft.
Public property | Registration | Gets or sets the registration of the aircraft.
Public property | SerialNumber | Gets or sets the manufacturers serial number assigned to the aircraft.
Public property | Species | Gets or sets the species of the aircraft cast to an int (see Species).
Public property | Status | Gets or sets a value describing whether the aircraft is in service, mothballed etc.
Public property | TotalHours | Gets or sets the total hours flown by the aircraft.
Public property | Type | Gets or sets a description of the model of the aircraft.
Public property | WakeTurbulenceCategory | Gets or sets the ATC wake turbulence category for the aircraft (see WakeTurbulenceCategory) cast to an int.
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson Constructor

ReportAircraftJson Constructor
Initializes a new instance of the ReportAircraftJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReportAircraftJson()
Public Sub New
public:
ReportAircraftJson()
new : unit -> ReportAircraftJson
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson Properties

ReportAircraftJson Properties

The ReportAircraftJson type exposes the following members.

Properties
 | Name | Description
Public property | AircraftClass | Gets or sets the aircraft's 'class' - can't find out what this actually is! Still report it though.
Public property | AircraftId | Gets or sets the unique identifier of the aircraft in the database.
Public property | AirframeReg | Obsolete. Gets or sets the registration as formatted for Airframes.org
Public property | CofACategory | Gets or sets the certificate of airworthiness category.
Public property | CofAExpiry | Gets or sets the date that the certificate of airworthiness expires.
Public property | Country | Gets or sets the country of the operator.
Public property | CurrentRegDate | Gets or sets the date that the aircraft was registered.
Public property | DeRegDate | Gets or sets the date that the plane was taken off the register.
Public property | EnginePlacement | Gets or sets the placement of the engine on the aircraft.
Public property | Engines | Gets or sets a value indicating how many engines there are, or whether the engines are coupled.
Public property | EngineType | Gets or sets the engine type used by the aircraft cast to an int (see EngineType).
Public property | FirstRegDate | Gets or sets the date that the aircraft was first placed onto the register.
Public property | GenericName | Gets or sets the generic name for the type of aircraft.
Public property | HasPicture | Gets or sets a value indicating that the user has a local picture of the aircraft.
Public property | Icao | Gets or sets the 24-bit Mode-S identifier assigned to the aircraft.
Public property | IcaoTypeCode | Gets or sets the ICAO 8643 type code for the aircraft.
Public property | InfoUrl | Gets or sets the URL of a web page showing more information about the aircraft.
Public property | Interested | Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears.
Public property | IsUnknown | Gets or sets a value that indicates that the registraton does not correspond to any aircraft in the database.
Public property | Manufacturer | Gets or sets the full name of the aircraft's manufacturer.
Public property | Military | Gets or sets a value indicating that the aircraft is operated by a military force.
Public property | ModeSCountry | Gets or sets the country of registration.
Public property | MTOW | Gets or sets the maximum takeoff weight of the aircraft.
Public property | Notes | Gets or sets the user's notes on the aircraft.
Public property | OperatorFlagCode | Gets or sets the ICAO code for the aircraft's operator.
Public property | OwnershipStatus | Gets or sets a value describing whether the aircraft is owned outright, leased etc.
Public property | PictureHeight | Gets or sets the height of the picture in pixels.
Public property | PictureUrl1 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl2 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureUrl3 | Gets or sets the URL of a picture of the aircraft.
Public property | PictureWidth | Gets or sets the width of the picture in pixels.
Public property | PopularName | Gets or sets the popular name for the type of aircraft.
Public property | PreviousId | Gets or sets the previous Mode-S ID of the aircraft (I think? doesn't make a great deal of sense, would be better off as an int back to another aircraft record - but mine is not to question why...)
Public property | RegisteredOwners | Gets or sets the operator of the aircraft.
Public property | Registration | Gets or sets the registration of the aircraft.
Public property | SerialNumber | Gets or sets the manufacturers serial number assigned to the aircraft.
Public property | Species | Gets or sets the species of the aircraft cast to an int (see Species).
Public property | Status | Gets or sets a value describing whether the aircraft is in service, mothballed etc.
Public property | TotalHours | Gets or sets the total hours flown by the aircraft.
Public property | Type | Gets or sets a description of the model of the aircraft.
Public property | WakeTurbulenceCategory | Gets or sets the ATC wake turbulence category for the aircraft (see WakeTurbulenceCategory) cast to an int.
Public property | YearBuilt | Gets or sets the year the aircraft was manufactured.
Top
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.AircraftClass Property

ReportAircraftJsonAircraftClass Property
Gets or sets the aircraft's 'class' - can't find out what this actually is! Still report it though.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AircraftClass { get; set; }
Public Property AircraftClass As String
    Get
    Set
public:
property String^ AircraftClass {
    String^ get ();
    void set (String^ value);
}
member AircraftClass : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.AircraftId Property

ReportAircraftJsonAircraftId Property
Gets or sets the unique identifier of the aircraft in the database.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AircraftId { get; set; }
Public Property AircraftId As Integer
    Get
    Set
public:
property int AircraftId {
    int get ();
    void set (int value);
}
member AircraftId : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.AirframeReg Property

ReportAircraftJsonAirframeReg Property

Note: This API is now obsolete.

Gets or sets the registration as formatted for Airframes.org

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Have the javascript do this instead")]
public string AirframeReg { get; set; }
<ObsoleteAttribute("Have the javascript do this instead")>
Public Property AirframeReg As String
    Get
    Set
public:
[ObsoleteAttribute(L"Have the javascript do this instead")]
property String^ AirframeReg {
    String^ get ();
    void set (String^ value);
}
[<ObsoleteAttribute("Have the javascript do this instead")>]
member AirframeReg : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.CofACategory Property

ReportAircraftJsonCofACategory Property
Gets or sets the certificate of airworthiness category.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CofACategory { get; set; }
Public Property CofACategory As String
    Get
    Set
public:
property String^ CofACategory {
    String^ get ();
    void set (String^ value);
}
member CofACategory : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.CofAExpiry Property

ReportAircraftJsonCofAExpiry Property
Gets or sets the date that the certificate of airworthiness expires.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CofAExpiry { get; set; }
Public Property CofAExpiry As String
    Get
    Set
public:
property String^ CofAExpiry {
    String^ get ();
    void set (String^ value);
}
member CofAExpiry : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Country Property

ReportAircraftJsonCountry Property
Gets or sets the country of the operator.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Country { get; set; }
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
member Country : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.CurrentRegDate Property

ReportAircraftJsonCurrentRegDate Property
Gets or sets the date that the aircraft was registered.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentRegDate { get; set; }
Public Property CurrentRegDate As String
    Get
    Set
public:
property String^ CurrentRegDate {
    String^ get ();
    void set (String^ value);
}
member CurrentRegDate : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.DeRegDate Property

ReportAircraftJsonDeRegDate Property
Gets or sets the date that the plane was taken off the register.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DeRegDate { get; set; }
Public Property DeRegDate As String
    Get
    Set
public:
property String^ DeRegDate {
    String^ get ();
    void set (String^ value);
}
member DeRegDate : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.EnginePlacement Property

ReportAircraftJsonEnginePlacement Property
Gets or sets the placement of the engine on the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePlacement { get; set; }
Public Property EnginePlacement As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePlacement {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePlacement : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Engines Property

ReportAircraftJsonEngines Property
Gets or sets a value indicating how many engines there are, or whether the engines are coupled.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Engines { get; set; }
Public Property Engines As String
    Get
    Set
public:
property String^ Engines {
    String^ get ();
    void set (String^ value);
}
member Engines : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.EngineType Property

ReportAircraftJsonEngineType Property
Gets or sets the engine type used by the aircraft cast to an int (see EngineType).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EngineType { get; set; }
Public Property EngineType As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EngineType {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EngineType : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.FirstRegDate Property

ReportAircraftJsonFirstRegDate Property
Gets or sets the date that the aircraft was first placed onto the register.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FirstRegDate { get; set; }
Public Property FirstRegDate As String
    Get
    Set
public:
property String^ FirstRegDate {
    String^ get ();
    void set (String^ value);
}
member FirstRegDate : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.GenericName Property

ReportAircraftJsonGenericName Property
Gets or sets the generic name for the type of aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GenericName { get; set; }
Public Property GenericName As String
    Get
    Set
public:
property String^ GenericName {
    String^ get ();
    void set (String^ value);
}
member GenericName : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.HasPicture Property

ReportAircraftJsonHasPicture Property
Gets or sets a value indicating that the user has a local picture of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPicture { get; set; }
Public Property HasPicture As Boolean
    Get
    Set
public:
property bool HasPicture {
    bool get ();
    void set (bool value);
}
member HasPicture : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Icao Property

ReportAircraftJsonIcao Property
Gets or sets the 24-bit Mode-S identifier assigned to the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Icao { get; set; }
Public Property Icao As String
    Get
    Set
public:
property String^ Icao {
    String^ get ();
    void set (String^ value);
}
member Icao : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.IcaoTypeCode Property

ReportAircraftJsonIcaoTypeCode Property
Gets or sets the ICAO 8643 type code for the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IcaoTypeCode { get; set; }
Public Property IcaoTypeCode As String
    Get
    Set
public:
property String^ IcaoTypeCode {
    String^ get ();
    void set (String^ value);
}
member IcaoTypeCode : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.InfoUrl Property

ReportAircraftJsonInfoUrl Property
Gets or sets the URL of a web page showing more information about the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InfoUrl { get; set; }
Public Property InfoUrl As String
    Get
    Set
public:
property String^ InfoUrl {
    String^ get ();
    void set (String^ value);
}
member InfoUrl : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Interested Property

ReportAircraftJsonInterested Property
Gets or sets a value indicating that the BaseStation operator wants to be alerted when this aircraft appears.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Interested { get; set; }
Public Property Interested As Boolean
    Get
    Set
public:
property bool Interested {
    bool get ();
    void set (bool value);
}
member Interested : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.IsUnknown Property

ReportAircraftJsonIsUnknown Property
Gets or sets a value that indicates that the registraton does not correspond to any aircraft in the database.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnknown { get; set; }
Public Property IsUnknown As Boolean
    Get
    Set
public:
property bool IsUnknown {
    bool get ();
    void set (bool value);
}
member IsUnknown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Manufacturer Property

ReportAircraftJsonManufacturer Property
Gets or sets the full name of the aircraft's manufacturer.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Manufacturer { get; set; }
Public Property Manufacturer As String
    Get
    Set
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}
member Manufacturer : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Military Property

ReportAircraftJsonMilitary Property
Gets or sets a value indicating that the aircraft is operated by a military force.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Military { get; set; }
Public Property Military As Boolean
    Get
    Set
public:
property bool Military {
    bool get ();
    void set (bool value);
}
member Military : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.ModeSCountry Property

ReportAircraftJsonModeSCountry Property
Gets or sets the country of registration.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModeSCountry { get; set; }
Public Property ModeSCountry As String
    Get
    Set
public:
property String^ ModeSCountry {
    String^ get ();
    void set (String^ value);
}
member ModeSCountry : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.MTOW Property

ReportAircraftJsonMTOW Property
Gets or sets the maximum takeoff weight of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MTOW { get; set; }
Public Property MTOW As String
    Get
    Set
public:
property String^ MTOW {
    String^ get ();
    void set (String^ value);
}
member MTOW : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Notes Property

ReportAircraftJsonNotes Property
Gets or sets the user's notes on the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}
member Notes : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.OperatorFlagCode Property

ReportAircraftJsonOperatorFlagCode Property
Gets or sets the ICAO code for the aircraft's operator.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatorFlagCode { get; set; }
Public Property OperatorFlagCode As String
    Get
    Set
public:
property String^ OperatorFlagCode {
    String^ get ();
    void set (String^ value);
}
member OperatorFlagCode : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.OwnershipStatus Property

ReportAircraftJsonOwnershipStatus Property
Gets or sets a value describing whether the aircraft is owned outright, leased etc.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OwnershipStatus { get; set; }
Public Property OwnershipStatus As String
    Get
    Set
public:
property String^ OwnershipStatus {
    String^ get ();
    void set (String^ value);
}
member OwnershipStatus : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PictureHeight Property

ReportAircraftJsonPictureHeight Property
Gets or sets the height of the picture in pixels.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PictureHeight { get; set; }
Public Property PictureHeight As Integer
    Get
    Set
public:
property int PictureHeight {
    int get ();
    void set (int value);
}
member PictureHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PictureUrl1 Property

ReportAircraftJsonPictureUrl1 Property
Gets or sets the URL of a picture of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PictureUrl1 { get; set; }
Public Property PictureUrl1 As String
    Get
    Set
public:
property String^ PictureUrl1 {
    String^ get ();
    void set (String^ value);
}
member PictureUrl1 : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PictureUrl2 Property

ReportAircraftJsonPictureUrl2 Property
Gets or sets the URL of a picture of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PictureUrl2 { get; set; }
Public Property PictureUrl2 As String
    Get
    Set
public:
property String^ PictureUrl2 {
    String^ get ();
    void set (String^ value);
}
member PictureUrl2 : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PictureUrl3 Property

ReportAircraftJsonPictureUrl3 Property
Gets or sets the URL of a picture of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PictureUrl3 { get; set; }
Public Property PictureUrl3 As String
    Get
    Set
public:
property String^ PictureUrl3 {
    String^ get ();
    void set (String^ value);
}
member PictureUrl3 : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PictureWidth Property

ReportAircraftJsonPictureWidth Property
Gets or sets the width of the picture in pixels.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PictureWidth { get; set; }
Public Property PictureWidth As Integer
    Get
    Set
public:
property int PictureWidth {
    int get ();
    void set (int value);
}
member PictureWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PopularName Property

ReportAircraftJsonPopularName Property
Gets or sets the popular name for the type of aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PopularName { get; set; }
Public Property PopularName As String
    Get
    Set
public:
property String^ PopularName {
    String^ get ();
    void set (String^ value);
}
member PopularName : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.PreviousId Property

ReportAircraftJsonPreviousId Property
Gets or sets the previous Mode-S ID of the aircraft (I think? doesn't make a great deal of sense, would be better off as an int back to another aircraft record - but mine is not to question why...)

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreviousId { get; set; }
Public Property PreviousId As String
    Get
    Set
public:
property String^ PreviousId {
    String^ get ();
    void set (String^ value);
}
member PreviousId : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.RegisteredOwners Property

ReportAircraftJsonRegisteredOwners Property
Gets or sets the operator of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RegisteredOwners { get; set; }
Public Property RegisteredOwners As String
    Get
    Set
public:
property String^ RegisteredOwners {
    String^ get ();
    void set (String^ value);
}
member RegisteredOwners : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Registration Property

ReportAircraftJsonRegistration Property
Gets or sets the registration of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Registration { get; set; }
Public Property Registration As String
    Get
    Set
public:
property String^ Registration {
    String^ get ();
    void set (String^ value);
}
member Registration : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.SerialNumber Property

ReportAircraftJsonSerialNumber Property
Gets or sets the manufacturers serial number assigned to the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}
member SerialNumber : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Species Property

ReportAircraftJsonSpecies Property
Gets or sets the species of the aircraft cast to an int (see Species).

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Species { get; set; }
Public Property Species As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Species {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Species : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Status Property

ReportAircraftJsonStatus Property
Gets or sets a value describing whether the aircraft is in service, mothballed etc.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.TotalHours Property

ReportAircraftJsonTotalHours Property
Gets or sets the total hours flown by the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TotalHours { get; set; }
Public Property TotalHours As String
    Get
    Set
public:
property String^ TotalHours {
    String^ get ();
    void set (String^ value);
}
member TotalHours : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.Type Property

ReportAircraftJsonType Property
Gets or sets a description of the model of the aircraft.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.WakeTurbulenceCategory Property

ReportAircraftJsonWakeTurbulenceCategory Property
Gets or sets the ATC wake turbulence category for the aircraft (see WakeTurbulenceCategory) cast to an int.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> WakeTurbulenceCategory { get; set; }
Public Property WakeTurbulenceCategory As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> WakeTurbulenceCategory {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member WakeTurbulenceCategory : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson.YearBuilt Property

ReportAircraftJsonYearBuilt Property
Gets or sets the year the aircraft was manufactured.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string YearBuilt { get; set; }
Public Property YearBuilt As String
    Get
    Set
public:
property String^ YearBuilt {
    String^ get ();
    void set (String^ value);
}
member YearBuilt : string with get, set

Property Value

Type: String
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAircraftJson Methods

ReportAircraftJson Methods

The ReportAircraftJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportAircraftJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAirportJson Class

ReportAirportJson Class
Describes a single instance of an airport in a report.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportAirportJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReportAirportJson
Public Class ReportAirportJson
public ref class ReportAirportJson
type ReportAirportJson =  class end

The ReportAirportJson type exposes the following members.

Constructors
 | Name | Description
Public method | ReportAirportJson | Initializes a new instance of the ReportAirportJson class
Top
Properties
 | Name | Description
Public property | Code | Get or sets the ICAO or IATA code of the airport.
Public property | Name | Gets or sets the name of the airport.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ReportAirportJson Constructor

ReportAirportJson Constructor
Initializes a new instance of the ReportAirportJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReportAirportJson()
Public Sub New
public:
ReportAirportJson()
new : unit -> ReportAirportJson
See Also

Reference

ReportAirportJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAirportJson Properties

ReportAirportJson Properties

The ReportAirportJson type exposes the following members.

Properties
 | Name | Description
Public property | Code | Get or sets the ICAO or IATA code of the airport.
Public property | Name | Gets or sets the name of the airport.
Top
See Also

Reference

ReportAirportJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAirportJson.Code Property

ReportAirportJsonCode Property
Get or sets the ICAO or IATA code of the airport.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
See Also

Reference

ReportAirportJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAirportJson.Name Property

ReportAirportJsonName Property
Gets or sets the name of the airport.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ReportAirportJson Class
VirtualRadar.Interface.WebSite Namespace


ReportAirportJson Methods

ReportAirportJson Methods

The ReportAirportJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportAirportJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson Class

ReportFlightJson Class
Describes the flight of an aircraft in a report.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportFlightJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReportFlightJson
Public Class ReportFlightJson
public ref class ReportFlightJson
type ReportFlightJson =  class end

The ReportFlightJson type exposes the following members.

Constructors
 | Name | Description
Public method | ReportFlightJson | Initializes a new instance of the ReportFlightJson class
Top
Properties
 | Name | Description
Public property | AircraftIndex | Gets or sets the index in the Aircraft list on either AircraftReportJson or FlightReportJson of the ReportAircraftJson for the aircraft's that undertook the flight.
Public property | Callsign | Gets or sets the callsign that the aircraft used during the flight.
Public property | EndTime | Gets or sets the time that a transmission from the aircraft was last seen.
Public property | FirstAltitude | Gets or sets the altitude that the aircraft was flying at when it was first seen.
Public property | FirstGroundSpeed | Gets or sets the ground speed that the aircraft was travelling at when it was first seen.
Public property | FirstIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when it was first seen.
Public property | FirstLatitude | Gets or sets the latitude of the aircraft when it was first seen.
Public property | FirstLongitude | Gets or sets the longitude of the aircraft when it was first seen.
Public property | FirstSquawk | Gets or sets the squawk that the aircraft was transmitting when it was first seen.
Public property | FirstTrack | Gets or sets the heading that the aircraft was flying over the ground when it was first seen.
Public property | FirstVerticalRate | Gets or sets the rate of climb / descent that the aircraft was making when first seen.
Public property | HadAlert | Gets or sets a value indicating that the aircraft changed its squawk during the flight.
Public property | HadEmergency | Gets or sets a value indicating that the aircraft transmitted an emergency squawk code during the flight.
Public property | HadSpi | Gets or sets a value indicating that the pilot pressed the IDENT button at some point during the flight.
Public property | LastAltitude | Gets or sets the altitude that the aircraft was flying at when it was last seen.
Public property | LastGroundSpeed | Gets or sets the ground speed that the aircraft was travelling at when it was last seen.
Public property | LastIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when it was last seen.
Public property | LastLatitude | Gets or sets the latitude of the aircraft when it was last seen.
Public property | LastLongitude | Gets or sets the longitude of the aircraft when it was last seen.
Public property | LastSquawk | Gets or sets the squawk that the aircraft was transmitting when it was last seen.
Public property | LastTrack | Gets or sets the heading that the aircraft was flying over the ground when it was last seen.
Public property | LastVerticalRate | Gets or sets the rate of climb / descent that the aircraft was making when last seen.
Public property | NumADSBMsgRec | Gets or sets the total number of ADSB messages received over the course of the flight.
Public property | NumModeSMsgRec | Gets or sets the total number of Mode-S messages received over the course of the flight.
Public property | NumPosMsgRec | Gets or sets the total number of messages that contained position information received over the course of the flight.
Public property | RouteIndex | Gets or sets the index in the Routes list on either AircraftReportJson or FlightReportJson of the ReportRouteJson for the route that the aircraft flew.
Public property | RowNumber | Gets or sets the position of the flight within the set of flights retrieved by the criteria.
Public property | StartTime | Gets or sets the time that a transmission from the aircraft was first seen.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ReportFlightJson Constructor

ReportFlightJson Constructor
Initializes a new instance of the ReportFlightJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReportFlightJson()
Public Sub New
public:
ReportFlightJson()
new : unit -> ReportFlightJson
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson Properties

ReportFlightJson Properties

The ReportFlightJson type exposes the following members.

Properties
 | Name | Description
Public property | AircraftIndex | Gets or sets the index in the Aircraft list on either AircraftReportJson or FlightReportJson of the ReportAircraftJson for the aircraft's that undertook the flight.
Public property | Callsign | Gets or sets the callsign that the aircraft used during the flight.
Public property | EndTime | Gets or sets the time that a transmission from the aircraft was last seen.
Public property | FirstAltitude | Gets or sets the altitude that the aircraft was flying at when it was first seen.
Public property | FirstGroundSpeed | Gets or sets the ground speed that the aircraft was travelling at when it was first seen.
Public property | FirstIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when it was first seen.
Public property | FirstLatitude | Gets or sets the latitude of the aircraft when it was first seen.
Public property | FirstLongitude | Gets or sets the longitude of the aircraft when it was first seen.
Public property | FirstSquawk | Gets or sets the squawk that the aircraft was transmitting when it was first seen.
Public property | FirstTrack | Gets or sets the heading that the aircraft was flying over the ground when it was first seen.
Public property | FirstVerticalRate | Gets or sets the rate of climb / descent that the aircraft was making when first seen.
Public property | HadAlert | Gets or sets a value indicating that the aircraft changed its squawk during the flight.
Public property | HadEmergency | Gets or sets a value indicating that the aircraft transmitted an emergency squawk code during the flight.
Public property | HadSpi | Gets or sets a value indicating that the pilot pressed the IDENT button at some point during the flight.
Public property | LastAltitude | Gets or sets the altitude that the aircraft was flying at when it was last seen.
Public property | LastGroundSpeed | Gets or sets the ground speed that the aircraft was travelling at when it was last seen.
Public property | LastIsOnGround | Gets or sets a value indicating whether the aircraft was on the ground when it was last seen.
Public property | LastLatitude | Gets or sets the latitude of the aircraft when it was last seen.
Public property | LastLongitude | Gets or sets the longitude of the aircraft when it was last seen.
Public property | LastSquawk | Gets or sets the squawk that the aircraft was transmitting when it was last seen.
Public property | LastTrack | Gets or sets the heading that the aircraft was flying over the ground when it was last seen.
Public property | LastVerticalRate | Gets or sets the rate of climb / descent that the aircraft was making when last seen.
Public property | NumADSBMsgRec | Gets or sets the total number of ADSB messages received over the course of the flight.
Public property | NumModeSMsgRec | Gets or sets the total number of Mode-S messages received over the course of the flight.
Public property | NumPosMsgRec | Gets or sets the total number of messages that contained position information received over the course of the flight.
Public property | RouteIndex | Gets or sets the index in the Routes list on either AircraftReportJson or FlightReportJson of the ReportRouteJson for the route that the aircraft flew.
Public property | RowNumber | Gets or sets the position of the flight within the set of flights retrieved by the criteria.
Public property | StartTime | Gets or sets the time that a transmission from the aircraft was first seen.
Top
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.AircraftIndex Property

ReportFlightJsonAircraftIndex Property
Gets or sets the index in the Aircraft list on either AircraftReportJson or FlightReportJson of the ReportAircraftJson for the aircraft's that undertook the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> AircraftIndex { get; set; }
Public Property AircraftIndex As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> AircraftIndex {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member AircraftIndex : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.Callsign Property

ReportFlightJsonCallsign Property
Gets or sets the callsign that the aircraft used during the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Callsign { get; set; }
Public Property Callsign As String
    Get
    Set
public:
property String^ Callsign {
    String^ get ();
    void set (String^ value);
}
member Callsign : string with get, set

Property Value

Type: String
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.EndTime Property

ReportFlightJsonEndTime Property
Gets or sets the time that a transmission from the aircraft was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}
member EndTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstAltitude Property

ReportFlightJsonFirstAltitude Property
Gets or sets the altitude that the aircraft was flying at when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstAltitude { get; set; }
Public Property FirstAltitude As Integer
    Get
    Set
public:
property int FirstAltitude {
    int get ();
    void set (int value);
}
member FirstAltitude : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstGroundSpeed Property

ReportFlightJsonFirstGroundSpeed Property
Gets or sets the ground speed that the aircraft was travelling at when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstGroundSpeed { get; set; }
Public Property FirstGroundSpeed As Integer
    Get
    Set
public:
property int FirstGroundSpeed {
    int get ();
    void set (int value);
}
member FirstGroundSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstIsOnGround Property

ReportFlightJsonFirstIsOnGround Property
Gets or sets a value indicating whether the aircraft was on the ground when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FirstIsOnGround { get; set; }
Public Property FirstIsOnGround As Boolean
    Get
    Set
public:
property bool FirstIsOnGround {
    bool get ();
    void set (bool value);
}
member FirstIsOnGround : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstLatitude Property

ReportFlightJsonFirstLatitude Property
Gets or sets the latitude of the aircraft when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FirstLatitude { get; set; }
Public Property FirstLatitude As Double
    Get
    Set
public:
property double FirstLatitude {
    double get ();
    void set (double value);
}
member FirstLatitude : float with get, set

Property Value

Type: Double
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstLongitude Property

ReportFlightJsonFirstLongitude Property
Gets or sets the longitude of the aircraft when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FirstLongitude { get; set; }
Public Property FirstLongitude As Double
    Get
    Set
public:
property double FirstLongitude {
    double get ();
    void set (double value);
}
member FirstLongitude : float with get, set

Property Value

Type: Double
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstSquawk Property

ReportFlightJsonFirstSquawk Property
Gets or sets the squawk that the aircraft was transmitting when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstSquawk { get; set; }
Public Property FirstSquawk As Integer
    Get
    Set
public:
property int FirstSquawk {
    int get ();
    void set (int value);
}
member FirstSquawk : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstTrack Property

ReportFlightJsonFirstTrack Property
Gets or sets the heading that the aircraft was flying over the ground when it was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float FirstTrack { get; set; }
Public Property FirstTrack As Single
    Get
    Set
public:
property float FirstTrack {
    float get ();
    void set (float value);
}
member FirstTrack : float32 with get, set

Property Value

Type: Single
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.FirstVerticalRate Property

ReportFlightJsonFirstVerticalRate Property
Gets or sets the rate of climb / descent that the aircraft was making when first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstVerticalRate { get; set; }
Public Property FirstVerticalRate As Integer
    Get
    Set
public:
property int FirstVerticalRate {
    int get ();
    void set (int value);
}
member FirstVerticalRate : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.HadAlert Property

ReportFlightJsonHadAlert Property
Gets or sets a value indicating that the aircraft changed its squawk during the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadAlert { get; set; }
Public Property HadAlert As Boolean
    Get
    Set
public:
property bool HadAlert {
    bool get ();
    void set (bool value);
}
member HadAlert : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.HadEmergency Property

ReportFlightJsonHadEmergency Property
Gets or sets a value indicating that the aircraft transmitted an emergency squawk code during the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadEmergency { get; set; }
Public Property HadEmergency As Boolean
    Get
    Set
public:
property bool HadEmergency {
    bool get ();
    void set (bool value);
}
member HadEmergency : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.HadSpi Property

ReportFlightJsonHadSpi Property
Gets or sets a value indicating that the pilot pressed the IDENT button at some point during the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadSpi { get; set; }
Public Property HadSpi As Boolean
    Get
    Set
public:
property bool HadSpi {
    bool get ();
    void set (bool value);
}
member HadSpi : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastAltitude Property

ReportFlightJsonLastAltitude Property
Gets or sets the altitude that the aircraft was flying at when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastAltitude { get; set; }
Public Property LastAltitude As Integer
    Get
    Set
public:
property int LastAltitude {
    int get ();
    void set (int value);
}
member LastAltitude : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastGroundSpeed Property

ReportFlightJsonLastGroundSpeed Property
Gets or sets the ground speed that the aircraft was travelling at when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastGroundSpeed { get; set; }
Public Property LastGroundSpeed As Integer
    Get
    Set
public:
property int LastGroundSpeed {
    int get ();
    void set (int value);
}
member LastGroundSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastIsOnGround Property

ReportFlightJsonLastIsOnGround Property
Gets or sets a value indicating whether the aircraft was on the ground when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LastIsOnGround { get; set; }
Public Property LastIsOnGround As Boolean
    Get
    Set
public:
property bool LastIsOnGround {
    bool get ();
    void set (bool value);
}
member LastIsOnGround : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastLatitude Property

ReportFlightJsonLastLatitude Property
Gets or sets the latitude of the aircraft when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LastLatitude { get; set; }
Public Property LastLatitude As Double
    Get
    Set
public:
property double LastLatitude {
    double get ();
    void set (double value);
}
member LastLatitude : float with get, set

Property Value

Type: Double
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastLongitude Property

ReportFlightJsonLastLongitude Property
Gets or sets the longitude of the aircraft when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LastLongitude { get; set; }
Public Property LastLongitude As Double
    Get
    Set
public:
property double LastLongitude {
    double get ();
    void set (double value);
}
member LastLongitude : float with get, set

Property Value

Type: Double
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastSquawk Property

ReportFlightJsonLastSquawk Property
Gets or sets the squawk that the aircraft was transmitting when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastSquawk { get; set; }
Public Property LastSquawk As Integer
    Get
    Set
public:
property int LastSquawk {
    int get ();
    void set (int value);
}
member LastSquawk : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastTrack Property

ReportFlightJsonLastTrack Property
Gets or sets the heading that the aircraft was flying over the ground when it was last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float LastTrack { get; set; }
Public Property LastTrack As Single
    Get
    Set
public:
property float LastTrack {
    float get ();
    void set (float value);
}
member LastTrack : float32 with get, set

Property Value

Type: Single
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.LastVerticalRate Property

ReportFlightJsonLastVerticalRate Property
Gets or sets the rate of climb / descent that the aircraft was making when last seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastVerticalRate { get; set; }
Public Property LastVerticalRate As Integer
    Get
    Set
public:
property int LastVerticalRate {
    int get ();
    void set (int value);
}
member LastVerticalRate : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.NumADSBMsgRec Property

ReportFlightJsonNumADSBMsgRec Property
Gets or sets the total number of ADSB messages received over the course of the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumADSBMsgRec { get; set; }
Public Property NumADSBMsgRec As Integer
    Get
    Set
public:
property int NumADSBMsgRec {
    int get ();
    void set (int value);
}
member NumADSBMsgRec : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.NumModeSMsgRec Property

ReportFlightJsonNumModeSMsgRec Property
Gets or sets the total number of Mode-S messages received over the course of the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumModeSMsgRec { get; set; }
Public Property NumModeSMsgRec As Integer
    Get
    Set
public:
property int NumModeSMsgRec {
    int get ();
    void set (int value);
}
member NumModeSMsgRec : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.NumPosMsgRec Property

ReportFlightJsonNumPosMsgRec Property
Gets or sets the total number of messages that contained position information received over the course of the flight.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumPosMsgRec { get; set; }
Public Property NumPosMsgRec As Integer
    Get
    Set
public:
property int NumPosMsgRec {
    int get ();
    void set (int value);
}
member NumPosMsgRec : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.RouteIndex Property

ReportFlightJsonRouteIndex Property
Gets or sets the index in the Routes list on either AircraftReportJson or FlightReportJson of the ReportRouteJson for the route that the aircraft flew.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RouteIndex { get; set; }
Public Property RouteIndex As Integer
    Get
    Set
public:
property int RouteIndex {
    int get ();
    void set (int value);
}
member RouteIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.RowNumber Property

ReportFlightJsonRowNumber Property
Gets or sets the position of the flight within the set of flights retrieved by the criteria.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RowNumber { get; set; }
Public Property RowNumber As Integer
    Get
    Set
public:
property int RowNumber {
    int get ();
    void set (int value);
}
member RowNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson.StartTime Property

ReportFlightJsonStartTime Property
Gets or sets the time that a transmission from the aircraft was first seen.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportFlightJson Methods

ReportFlightJson Methods

The ReportFlightJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportFlightJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRouteJson Class

ReportRouteJson Class
Describes the route taken by an aircraft.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportRouteJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReportRouteJson
Public Class ReportRouteJson
public ref class ReportRouteJson
type ReportRouteJson =  class end

The ReportRouteJson type exposes the following members.

Constructors
 | Name | Description
Public method | ReportRouteJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | FromIndex | Gets or sets the index into the Aircraft list on AircraftReportJson or FlightReportJson of the departure airport in the route.
Public property | StopoversIndex | Gets a list of indexes into the Aircraft list on AircraftReportJson or FlightReportJson of the stopover airports in the route.
Public property | ToIndex | Gets or sets the index into the Aircraft list on AircraftReportJson or FlightReportJson of the destination airport in the route.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ReportRouteJson Constructor

ReportRouteJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReportRouteJson()
Public Sub New
public:
ReportRouteJson()
new : unit -> ReportRouteJson
See Also

Reference

ReportRouteJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRouteJson Properties

ReportRouteJson Properties

The ReportRouteJson type exposes the following members.

Properties
 | Name | Description
Public property | FromIndex | Gets or sets the index into the Aircraft list on AircraftReportJson or FlightReportJson of the departure airport in the route.
Public property | StopoversIndex | Gets a list of indexes into the Aircraft list on AircraftReportJson or FlightReportJson of the stopover airports in the route.
Public property | ToIndex | Gets or sets the index into the Aircraft list on AircraftReportJson or FlightReportJson of the destination airport in the route.
Top
See Also

Reference

ReportRouteJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRouteJson.FromIndex Property

ReportRouteJsonFromIndex Property
Gets or sets the index into the Aircraft list on AircraftReportJson or FlightReportJson of the departure airport in the route.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FromIndex { get; set; }
Public Property FromIndex As Integer
    Get
    Set
public:
property int FromIndex {
    int get ();
    void set (int value);
}
member FromIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportRouteJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRouteJson.StopoversIndex Property

ReportRouteJsonStopoversIndex Property
Gets a list of indexes into the Aircraft list on AircraftReportJson or FlightReportJson of the stopover airports in the route.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<int> StopoversIndex { get; }
Public ReadOnly Property StopoversIndex As List(Of Integer)
    Get
public:
property List<int>^ StopoversIndex {
    List<int>^ get ();
}
member StopoversIndex : List<int> with get

Property Value

Type: List Int32
See Also

Reference

ReportRouteJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRouteJson.ToIndex Property

ReportRouteJsonToIndex Property
Gets or sets the index into the Aircraft list on AircraftReportJson or FlightReportJson of the destination airport in the route.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ToIndex { get; set; }
Public Property ToIndex As Integer
    Get
    Set
public:
property int ToIndex {
    int get ();
    void set (int value);
}
member ToIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportRouteJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRouteJson Methods

ReportRouteJson Methods

The ReportRouteJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportRouteJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson Class

ReportRowsJson Class
The base class for all top-level report JSON objects.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteReportRowsJson
VirtualRadar.Interface.WebSiteAircraftReportJson
VirtualRadar.Interface.WebSiteFlightReportJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ReportRowsJson
Public MustInherit Class ReportRowsJson
public ref class ReportRowsJson abstract
[<AbstractClassAttribute>]
type ReportRowsJson =  class end

The ReportRowsJson type exposes the following members.

Constructors
 | Name | Description
Protected method | ReportRowsJson | Initializes a new instance of the ReportRowsJson class
Top
Properties
 | Name | Description
Public property | CountRows | Gets or sets the total number of rows that match the report criteria.
Public property | ErrorText | Gets or sets the content of any errors or exceptions that were thrown during the processing of the report.
Public property | GroupBy | Gets or sets a value indicating the column that the data has been grouped by.
Public property | OperatorFlagsAvailable | Gets or sets a value indicating that operator flags can be shown on the report.
Public property | ProcessingTime | Gets or sets a value indicating how long the report took to process.
Public property | SilhouettesAvailable | Gets or sets a value indicating that silhouettes can be shown on the report.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ReportRowsJson Constructor

ReportRowsJson Constructor
Initializes a new instance of the ReportRowsJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ReportRowsJson()
Protected Sub New
protected:
ReportRowsJson()
new : unit -> ReportRowsJson
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson Properties

ReportRowsJson Properties

The ReportRowsJson type exposes the following members.

Properties
 | Name | Description
Public property | CountRows | Gets or sets the total number of rows that match the report criteria.
Public property | ErrorText | Gets or sets the content of any errors or exceptions that were thrown during the processing of the report.
Public property | GroupBy | Gets or sets a value indicating the column that the data has been grouped by.
Public property | OperatorFlagsAvailable | Gets or sets a value indicating that operator flags can be shown on the report.
Public property | ProcessingTime | Gets or sets a value indicating how long the report took to process.
Public property | SilhouettesAvailable | Gets or sets a value indicating that silhouettes can be shown on the report.
Top
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson.CountRows Property

ReportRowsJsonCountRows Property
Gets or sets the total number of rows that match the report criteria.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> CountRows { get; set; }
Public Property CountRows As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> CountRows {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member CountRows : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson.ErrorText Property

ReportRowsJsonErrorText Property
Gets or sets the content of any errors or exceptions that were thrown during the processing of the report.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
member ErrorText : string with get, set

Property Value

Type: String
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson.GroupBy Property

ReportRowsJsonGroupBy Property
Gets or sets a value indicating the column that the data has been grouped by.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GroupBy { get; set; }
Public Property GroupBy As String
    Get
    Set
public:
property String^ GroupBy {
    String^ get ();
    void set (String^ value);
}
member GroupBy : string with get, set

Property Value

Type: String
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson.OperatorFlagsAvailable Property

ReportRowsJsonOperatorFlagsAvailable Property
Gets or sets a value indicating that operator flags can be shown on the report.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OperatorFlagsAvailable { get; set; }
Public Property OperatorFlagsAvailable As Boolean
    Get
    Set
public:
property bool OperatorFlagsAvailable {
    bool get ();
    void set (bool value);
}
member OperatorFlagsAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson.ProcessingTime Property

ReportRowsJsonProcessingTime Property
Gets or sets a value indicating how long the report took to process.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProcessingTime { get; set; }
Public Property ProcessingTime As String
    Get
    Set
public:
property String^ ProcessingTime {
    String^ get ();
    void set (String^ value);
}
member ProcessingTime : string with get, set

Property Value

Type: String
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson.SilhouettesAvailable Property

ReportRowsJsonSilhouettesAvailable Property
Gets or sets a value indicating that silhouettes can be shown on the report.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SilhouettesAvailable { get; set; }
Public Property SilhouettesAvailable As Boolean
    Get
    Set
public:
property bool SilhouettesAvailable {
    bool get ();
    void set (bool value);
}
member SilhouettesAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ReportRowsJson Methods

ReportRowsJson Methods

The ReportRowsJson type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportRowsJson Class
VirtualRadar.Interface.WebSite Namespace


ResizeImageMode Enumeration

ResizeImageMode Enumeration
An enumeration of the different resize modes supported by the website graphics code.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResizeImageMode
Public Enumeration ResizeImageMode
public enum class ResizeImageMode
type ResizeImageMode
Members
Member name | Value | Description
Normal | 0 | Image is drawn at top-left and is just large enough to fill the new space in both axis. One axis may end up being clipped.
Centre | 1 | As per Normal but if an axis is clipped then the top or left is offset so that the centre is still in the middle of the new stockImage.
Stretch | 2 | Image is stretched to exactly fill the width and height of the new image.
Zoom | 3 | Image is centred within new image, keeping the same aspect ratio as the original. One axis will be the same as the new image, the other may be smaller. Unused space is filled with a brush.
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ServerConfigJson Class

ServerConfigJson Class
The JSON object that carries server settings to the site.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteServerConfigJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerConfigJson : ICloneable
Public Class ServerConfigJson
    Implements ICloneable
public ref class ServerConfigJson : ICloneable
type ServerConfigJson =
    class
        interface ICloneable
    end

The ServerConfigJson type exposes the following members.

Constructors
 | Name | Description
Public method | ServerConfigJson | Creates a new object.
Top
Properties
 | Name | Description
Public property | GoogleMapsApiKey | Gets or sets the API key to use when working with Google Maps.
Public property | InitialDistanceUnit | Gets or sets the initial distance unit to use.
Public property | InitialHeightUnit | Gets or sets the initial height unit to use.
Public property | InitialLatitude | Gets or sets the initial latitude for maps.
Public property | InitialLongitude | Gets or sets the initial longitude for maps.
Public property | InitialMapType | Gets or sets the map type to use if the user hasn't already configured one.
Public property | InitialSettings | Gets or sets the initial settings, if any, to apply to new users.
Public property | InitialSpeedUnit | Gets or sets the initial speed unit.
Public property | InitialZoom | Gets or sets the initial level of zoom to use.
Public property | InternetClientCanRunReports | Gets or sets a value indicating that an Internet client can run reports.
Public property | InternetClientCanShowPinText | Gets or set a value indicating that Internet clients are allowed to set pin text on aircraft markers.
Public property | InternetClientsCanPlayAudio | Gets or sets a value indicating that Internet clients can make use of the audio features of the site.
Public property | InternetClientsCanSeeAircraftPictures | Gets or sets a value indicating that Internet clients are allowed to view the local aircraft pictures.
Public property | InternetClientsCanSeePolarPlots | Gets or sets a value indicating that Internet clients are allowed to see receiver ranges.
Public property | InternetClientsCanSubmitRoutes | Gets or sets a value indicating that Internet clients can submit routes and route corrections.
Public property | InternetClientTimeoutMinutes | Gets or sets the number of minutes that Internet clients can remain idle before the site times out.
Public property | IsAudioEnabled | Gets or sets a value indicating that the user has enabled the site's audio features.
Public property | IsLocalAddress | Gets or sets a value indicating that the browser address is probably a local address.
Public property | IsMono | Gets or sets a value indicating that the server is running under Mono.
Public property | MinimumRefreshSeconds | Gets or sets the minimum number of seconds between refreshes configured that the site should allow.
Public property | Receivers | Gets a collection of receiver names.
Public property | RefreshSeconds | Gets or sets the seconds between refreshes if the user hasn't already set a value.
Public property | UseMarkerLabels | Gets or sets a value indicating that text should be drawn onto the markers using marker labels instead of asking the server to draw it directly onto the marker image.
Public property | VrsVersion | Gets or sets the version number of the server.
Top
Methods
 | Name | Description
Public method | Clone | See interface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ServerConfigJson Constructor

ServerConfigJson Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerConfigJson()
Public Sub New
public:
ServerConfigJson()
new : unit -> ServerConfigJson
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson Properties

ServerConfigJson Properties

The ServerConfigJson type exposes the following members.

Properties
 | Name | Description
Public property | GoogleMapsApiKey | Gets or sets the API key to use when working with Google Maps.
Public property | InitialDistanceUnit | Gets or sets the initial distance unit to use.
Public property | InitialHeightUnit | Gets or sets the initial height unit to use.
Public property | InitialLatitude | Gets or sets the initial latitude for maps.
Public property | InitialLongitude | Gets or sets the initial longitude for maps.
Public property | InitialMapType | Gets or sets the map type to use if the user hasn't already configured one.
Public property | InitialSettings | Gets or sets the initial settings, if any, to apply to new users.
Public property | InitialSpeedUnit | Gets or sets the initial speed unit.
Public property | InitialZoom | Gets or sets the initial level of zoom to use.
Public property | InternetClientCanRunReports | Gets or sets a value indicating that an Internet client can run reports.
Public property | InternetClientCanShowPinText | Gets or set a value indicating that Internet clients are allowed to set pin text on aircraft markers.
Public property | InternetClientsCanPlayAudio | Gets or sets a value indicating that Internet clients can make use of the audio features of the site.
Public property | InternetClientsCanSeeAircraftPictures | Gets or sets a value indicating that Internet clients are allowed to view the local aircraft pictures.
Public property | InternetClientsCanSeePolarPlots | Gets or sets a value indicating that Internet clients are allowed to see receiver ranges.
Public property | InternetClientsCanSubmitRoutes | Gets or sets a value indicating that Internet clients can submit routes and route corrections.
Public property | InternetClientTimeoutMinutes | Gets or sets the number of minutes that Internet clients can remain idle before the site times out.
Public property | IsAudioEnabled | Gets or sets a value indicating that the user has enabled the site's audio features.
Public property | IsLocalAddress | Gets or sets a value indicating that the browser address is probably a local address.
Public property | IsMono | Gets or sets a value indicating that the server is running under Mono.
Public property | MinimumRefreshSeconds | Gets or sets the minimum number of seconds between refreshes configured that the site should allow.
Public property | Receivers | Gets a collection of receiver names.
Public property | RefreshSeconds | Gets or sets the seconds between refreshes if the user hasn't already set a value.
Public property | UseMarkerLabels | Gets or sets a value indicating that text should be drawn onto the markers using marker labels instead of asking the server to draw it directly onto the marker image.
Public property | VrsVersion | Gets or sets the version number of the server.
Top
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.GoogleMapsApiKey Property

ServerConfigJsonGoogleMapsApiKey Property
Gets or sets the API key to use when working with Google Maps.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GoogleMapsApiKey { get; set; }
Public Property GoogleMapsApiKey As String
    Get
    Set
public:
property String^ GoogleMapsApiKey {
    String^ get ();
    void set (String^ value);
}
member GoogleMapsApiKey : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialDistanceUnit Property

ServerConfigJsonInitialDistanceUnit Property
Gets or sets the initial distance unit to use.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialDistanceUnit { get; set; }
Public Property InitialDistanceUnit As String
    Get
    Set
public:
property String^ InitialDistanceUnit {
    String^ get ();
    void set (String^ value);
}
member InitialDistanceUnit : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialHeightUnit Property

ServerConfigJsonInitialHeightUnit Property
Gets or sets the initial height unit to use.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialHeightUnit { get; set; }
Public Property InitialHeightUnit As String
    Get
    Set
public:
property String^ InitialHeightUnit {
    String^ get ();
    void set (String^ value);
}
member InitialHeightUnit : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialLatitude Property

ServerConfigJsonInitialLatitude Property
Gets or sets the initial latitude for maps.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InitialLatitude { get; set; }
Public Property InitialLatitude As Double
    Get
    Set
public:
property double InitialLatitude {
    double get ();
    void set (double value);
}
member InitialLatitude : float with get, set

Property Value

Type: Double
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialLongitude Property

ServerConfigJsonInitialLongitude Property
Gets or sets the initial longitude for maps.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InitialLongitude { get; set; }
Public Property InitialLongitude As Double
    Get
    Set
public:
property double InitialLongitude {
    double get ();
    void set (double value);
}
member InitialLongitude : float with get, set

Property Value

Type: Double
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialMapType Property

ServerConfigJsonInitialMapType Property
Gets or sets the map type to use if the user hasn't already configured one.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialMapType { get; set; }
Public Property InitialMapType As String
    Get
    Set
public:
property String^ InitialMapType {
    String^ get ();
    void set (String^ value);
}
member InitialMapType : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialSettings Property

ServerConfigJsonInitialSettings Property
Gets or sets the initial settings, if any, to apply to new users.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialSettings { get; set; }
Public Property InitialSettings As String
    Get
    Set
public:
property String^ InitialSettings {
    String^ get ();
    void set (String^ value);
}
member InitialSettings : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialSpeedUnit Property

ServerConfigJsonInitialSpeedUnit Property
Gets or sets the initial speed unit.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InitialSpeedUnit { get; set; }
Public Property InitialSpeedUnit As String
    Get
    Set
public:
property String^ InitialSpeedUnit {
    String^ get ();
    void set (String^ value);
}
member InitialSpeedUnit : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InitialZoom Property

ServerConfigJsonInitialZoom Property
Gets or sets the initial level of zoom to use.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InitialZoom { get; set; }
Public Property InitialZoom As Integer
    Get
    Set
public:
property int InitialZoom {
    int get ();
    void set (int value);
}
member InitialZoom : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientCanRunReports Property

ServerConfigJsonInternetClientCanRunReports Property
Gets or sets a value indicating that an Internet client can run reports.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InternetClientCanRunReports { get; set; }
Public Property InternetClientCanRunReports As Boolean
    Get
    Set
public:
property bool InternetClientCanRunReports {
    bool get ();
    void set (bool value);
}
member InternetClientCanRunReports : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientCanShowPinText Property

ServerConfigJsonInternetClientCanShowPinText Property
Gets or set a value indicating that Internet clients are allowed to set pin text on aircraft markers.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InternetClientCanShowPinText { get; set; }
Public Property InternetClientCanShowPinText As Boolean
    Get
    Set
public:
property bool InternetClientCanShowPinText {
    bool get ();
    void set (bool value);
}
member InternetClientCanShowPinText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientsCanPlayAudio Property

ServerConfigJsonInternetClientsCanPlayAudio Property
Gets or sets a value indicating that Internet clients can make use of the audio features of the site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InternetClientsCanPlayAudio { get; set; }
Public Property InternetClientsCanPlayAudio As Boolean
    Get
    Set
public:
property bool InternetClientsCanPlayAudio {
    bool get ();
    void set (bool value);
}
member InternetClientsCanPlayAudio : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientsCanSeeAircraftPictures Property

ServerConfigJsonInternetClientsCanSeeAircraftPictures Property
Gets or sets a value indicating that Internet clients are allowed to view the local aircraft pictures.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InternetClientsCanSeeAircraftPictures { get; set; }
Public Property InternetClientsCanSeeAircraftPictures As Boolean
    Get
    Set
public:
property bool InternetClientsCanSeeAircraftPictures {
    bool get ();
    void set (bool value);
}
member InternetClientsCanSeeAircraftPictures : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientsCanSeePolarPlots Property

ServerConfigJsonInternetClientsCanSeePolarPlots Property
Gets or sets a value indicating that Internet clients are allowed to see receiver ranges.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InternetClientsCanSeePolarPlots { get; set; }
Public Property InternetClientsCanSeePolarPlots As Boolean
    Get
    Set
public:
property bool InternetClientsCanSeePolarPlots {
    bool get ();
    void set (bool value);
}
member InternetClientsCanSeePolarPlots : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientsCanSubmitRoutes Property

ServerConfigJsonInternetClientsCanSubmitRoutes Property
Gets or sets a value indicating that Internet clients can submit routes and route corrections.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InternetClientsCanSubmitRoutes { get; set; }
Public Property InternetClientsCanSubmitRoutes As Boolean
    Get
    Set
public:
property bool InternetClientsCanSubmitRoutes {
    bool get ();
    void set (bool value);
}
member InternetClientsCanSubmitRoutes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.InternetClientTimeoutMinutes Property

ServerConfigJsonInternetClientTimeoutMinutes Property
Gets or sets the number of minutes that Internet clients can remain idle before the site times out.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InternetClientTimeoutMinutes { get; set; }
Public Property InternetClientTimeoutMinutes As Integer
    Get
    Set
public:
property int InternetClientTimeoutMinutes {
    int get ();
    void set (int value);
}
member InternetClientTimeoutMinutes : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.IsAudioEnabled Property

ServerConfigJsonIsAudioEnabled Property
Gets or sets a value indicating that the user has enabled the site's audio features.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAudioEnabled { get; set; }
Public Property IsAudioEnabled As Boolean
    Get
    Set
public:
property bool IsAudioEnabled {
    bool get ();
    void set (bool value);
}
member IsAudioEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.IsLocalAddress Property

ServerConfigJsonIsLocalAddress Property
Gets or sets a value indicating that the browser address is probably a local address.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocalAddress { get; set; }
Public Property IsLocalAddress As Boolean
    Get
    Set
public:
property bool IsLocalAddress {
    bool get ();
    void set (bool value);
}
member IsLocalAddress : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.IsMono Property

ServerConfigJsonIsMono Property
Gets or sets a value indicating that the server is running under Mono.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMono { get; set; }
Public Property IsMono As Boolean
    Get
    Set
public:
property bool IsMono {
    bool get ();
    void set (bool value);
}
member IsMono : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.MinimumRefreshSeconds Property

ServerConfigJsonMinimumRefreshSeconds Property
Gets or sets the minimum number of seconds between refreshes configured that the site should allow.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MinimumRefreshSeconds { get; set; }
Public Property MinimumRefreshSeconds As Integer
    Get
    Set
public:
property int MinimumRefreshSeconds {
    int get ();
    void set (int value);
}
member MinimumRefreshSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.Receivers Property

ServerConfigJsonReceivers Property
Gets a collection of receiver names.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ServerReceiverJson> Receivers { get; }
Public ReadOnly Property Receivers As List(Of ServerReceiverJson)
    Get
public:
property List<ServerReceiverJson^>^ Receivers {
    List<ServerReceiverJson^>^ get ();
}
member Receivers : List<ServerReceiverJson> with get

Property Value

Type: List ServerReceiverJson
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.RefreshSeconds Property

ServerConfigJsonRefreshSeconds Property
Gets or sets the seconds between refreshes if the user hasn't already set a value.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RefreshSeconds { get; set; }
Public Property RefreshSeconds As Integer
    Get
    Set
public:
property int RefreshSeconds {
    int get ();
    void set (int value);
}
member RefreshSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.UseMarkerLabels Property

ServerConfigJsonUseMarkerLabels Property
Gets or sets a value indicating that text should be drawn onto the markers using marker labels instead of asking the server to draw it directly onto the marker image.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseMarkerLabels { get; set; }
Public Property UseMarkerLabels As Boolean
    Get
    Set
public:
property bool UseMarkerLabels {
    bool get ();
    void set (bool value);
}
member UseMarkerLabels : bool with get, set

Property Value

Type: Boolean
Remarks
This is always false when running under .NET. It defaults to true when running under Mono but can be modified via Tools | Options | General | Mono.
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.VrsVersion Property

ServerConfigJsonVrsVersion Property
Gets or sets the version number of the server.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VrsVersion { get; set; }
Public Property VrsVersion As String
    Get
    Set
public:
property String^ VrsVersion {
    String^ get ();
    void set (String^ value);
}
member VrsVersion : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson Methods

ServerConfigJson Methods

The ServerConfigJson type exposes the following members.

Methods
 | Name | Description
Public method | Clone | See interface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerConfigJson.Clone Method

ServerConfigJsonClone Method
See interface.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

ServerConfigJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson Class

ServerReceiverJson Class
The JSON object that describes a receiver that the server is listening to.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteServerReceiverJson

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerReceiverJson : ICloneable
Public Class ServerReceiverJson
    Implements ICloneable
public ref class ServerReceiverJson : ICloneable
type ServerReceiverJson =
    class
        interface ICloneable
    end

The ServerReceiverJson type exposes the following members.

Constructors
 | Name | Description
Public method | ServerReceiverJson | Initializes a new instance of the ServerReceiverJson class
Top
Properties
 | Name | Description
Public property | HasPolarPlot | Gets or sets a value indicating that there is a polar plot for the receiver.
Public property | Name | Gets or sets the name of the receiver.
Public property | UniqueId | Gets or sets the unique ID of the receiver.
Top
Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson Constructor

ServerReceiverJson Constructor
Initializes a new instance of the ServerReceiverJson class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerReceiverJson()
Public Sub New
public:
ServerReceiverJson()
new : unit -> ServerReceiverJson
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson Properties

ServerReceiverJson Properties

The ServerReceiverJson type exposes the following members.

Properties
 | Name | Description
Public property | HasPolarPlot | Gets or sets a value indicating that there is a polar plot for the receiver.
Public property | Name | Gets or sets the name of the receiver.
Public property | UniqueId | Gets or sets the unique ID of the receiver.
Top
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson.HasPolarPlot Property

ServerReceiverJsonHasPolarPlot Property
Gets or sets a value indicating that there is a polar plot for the receiver.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPolarPlot { get; set; }
Public Property HasPolarPlot As Boolean
    Get
    Set
public:
property bool HasPolarPlot {
    bool get ();
    void set (bool value);
}
member HasPolarPlot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson.Name Property

ServerReceiverJsonName Property
Gets or sets the name of the receiver.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson.UniqueId Property

ServerReceiverJsonUniqueId Property
Gets or sets the unique ID of the receiver.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; set; }
Public Property UniqueId As Integer
    Get
    Set
public:
property int UniqueId {
    int get ();
    void set (int value);
}
member UniqueId : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson Methods

ServerReceiverJson Methods

The ServerReceiverJson type exposes the following members.

Methods
 | Name | Description
Public method | Clone | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


ServerReceiverJson.Clone Method

ServerReceiverJsonClone Method
See interface docs.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

ServerReceiverJson Class
VirtualRadar.Interface.WebSite Namespace


SimpleContent Class

SimpleContent Class
The object returned by RequestSimpleContent(String).
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteSimpleContent

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SimpleContent
Public Class SimpleContent
public ref class SimpleContent
type SimpleContent =  class end

The SimpleContent type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleContent | Initializes a new instance of the SimpleContent class
Top
Properties
 | Name | Description
Public property | Content | Gets or sets the content corresponding to the path and file passed across.
Public property | HttpStatusCode | Gets or sets the HTTP status code for the request.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


SimpleContent Constructor

SimpleContent Constructor
Initializes a new instance of the SimpleContent class

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleContent()
Public Sub New
public:
SimpleContent()
new : unit -> SimpleContent
See Also

Reference

SimpleContent Class
VirtualRadar.Interface.WebSite Namespace


SimpleContent Properties

SimpleContent Properties

The SimpleContent type exposes the following members.

Properties
 | Name | Description
Public property | Content | Gets or sets the content corresponding to the path and file passed across.
Public property | HttpStatusCode | Gets or sets the HTTP status code for the request.
Top
See Also

Reference

SimpleContent Class
VirtualRadar.Interface.WebSite Namespace


SimpleContent.Content Property

SimpleContentContent Property
Gets or sets the content corresponding to the path and file passed across.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Content { get; set; }
Public Property Content As Byte()
    Get
    Set
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Content : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

SimpleContent Class
VirtualRadar.Interface.WebSite Namespace


SimpleContent.HttpStatusCode Property

SimpleContentHttpStatusCode Property
Gets or sets the HTTP status code for the request.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HttpStatusCode HttpStatusCode { get; set; }
Public Property HttpStatusCode As HttpStatusCode
    Get
    Set
public:
property HttpStatusCode HttpStatusCode {
    HttpStatusCode get ();
    void set (HttpStatusCode value);
}
member HttpStatusCode : HttpStatusCode with get, set

Property Value

Type: HttpStatusCode
See Also

Reference

SimpleContent Class
VirtualRadar.Interface.WebSite Namespace


SimpleContent Methods

SimpleContent Methods

The SimpleContent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleContent Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot Class

SiteRoot Class
A class that describes a root folder to serve files from.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteSiteRoot

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SiteRoot
Public Class SiteRoot
public ref class SiteRoot
type SiteRoot =  class end

The SiteRoot type exposes the following members.

Constructors
 | Name | Description
Public method | SiteRoot | Creates a new object.
Top
Properties
 | Name | Description
Public property | Checksums | Gets an optional collection of checksums for the files in the root folder.
Public property | Folder | Gets or sets the folder to serve files from.
Public property | Priority | Gets or sets a value that indicates the order in which site roots are searched for files to serve. Lower numbers are searched before higher numbers. The VRS default website has a priority of 0.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


SiteRoot Constructor

SiteRoot Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SiteRoot()
Public Sub New
public:
SiteRoot()
new : unit -> SiteRoot
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot Properties

SiteRoot Properties

The SiteRoot type exposes the following members.

Properties
 | Name | Description
Public property | Checksums | Gets an optional collection of checksums for the files in the root folder.
Public property | Folder | Gets or sets the folder to serve files from.
Public property | Priority | Gets or sets a value that indicates the order in which site roots are searched for files to serve. Lower numbers are searched before higher numbers. The VRS default website has a priority of 0.
Top
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot.Checksums Property

SiteRootChecksums Property
Gets an optional collection of checksums for the files in the root folder.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<ChecksumFileEntry> Checksums { get; }
Public ReadOnly Property Checksums As List(Of ChecksumFileEntry)
    Get
public:
property List<ChecksumFileEntry^>^ Checksums {
    List<ChecksumFileEntry^>^ get ();
}
member Checksums : List<ChecksumFileEntry> with get

Property Value

Type: List ChecksumFileEntry
Remarks
If this is supplied then the files in the folder cannot be modified by the user.
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot.Folder Property

SiteRootFolder Property
Gets or sets the folder to serve files from.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Property Value

Type: String
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot.Priority Property

SiteRootPriority Property
Gets or sets a value that indicates the order in which site roots are searched for files to serve. Lower numbers are searched before higher numbers. The VRS default website has a priority of 0.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set
public:
property int Priority {
    int get ();
    void set (int value);
}
member Priority : int with get, set

Property Value

Type: Int32
Remarks
The default priority is 100. The relative order of two site roots with the same priority is not defined and may not be constant over the life of the site.
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot Methods

SiteRoot Methods

The SiteRoot type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


SiteRoot.ToString Method

SiteRootToString Method
See base docs.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

SiteRoot Class
VirtualRadar.Interface.WebSite Namespace


StandardWebSiteImageSize Enumeration

StandardWebSiteImageSize Enumeration
An enumeration of the standard sizes for images used by the web site.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StandardWebSiteImageSize
Public Enumeration StandardWebSiteImageSize
public enum class StandardWebSiteImageSize
type StandardWebSiteImageSize
Members
Member name | Value | Description
None | 0 | Not applicable / not specified.
Full | 1 | The original size of the stock image.
PictureListThumbnail | 2 | The size of a thumbnail of an aircraft picture in the aircraft list.
PictureDetail | 3 | The size of an aircraft picture in the aircraft detail panel.
IPhoneDetail | 4 | The size of an aircraft picture in the iPhone detail panel.
IPadDetail | 5 | The size of an aircraft picture in the iPad detail panel.
BaseStation | 6 | The size of an aircraft picture conforming to the 200 x 133 standard.
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs Class

TextContentEventArgs Class
The event args that are raised by the web site for text content events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VirtualRadar.Interface.WebSiteTextContentEventArgs

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextContentEventArgs : EventArgs
Public Class TextContentEventArgs
    Inherits EventArgs
public ref class TextContentEventArgs : public EventArgs
type TextContentEventArgs =
    class
        inherit EventArgs
    end

The TextContentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextContentEventArgs | Creates a new object.
Top
Properties
 | Name | Description
Public property | Content | Gets or sets the text content.
Public property | Encoding | Gets or sets the encoding of the content.
Public property | PathAndFile | Gets the path and file of the request from root.
Public property | Request | Gets the request that generated this content.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs Constructor

TextContentEventArgs Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextContentEventArgs(
    IRequest request,
    string pathAndFile,
    string content,
    Encoding encoding
)
Public Sub New (
    request As IRequest,
    pathAndFile As String,
    content As String,
    encoding As Encoding
)
public:
TextContentEventArgs(
    IRequest^ request,
    String^ pathAndFile,
    String^ content,
    Encoding^ encoding
)
new :
        request : IRequest *
        pathAndFile : string *
        content : string *
        encoding : Encoding -> TextContentEventArgs

Parameters

request
Type: VirtualRadar.Interface.WebServerIRequest
pathAndFile
Type: SystemString
content
Type: SystemString
encoding
Type: System.TextEncoding
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs Properties

TextContentEventArgs Properties

The TextContentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Content | Gets or sets the text content.
Public property | Encoding | Gets or sets the encoding of the content.
Public property | PathAndFile | Gets the path and file of the request from root.
Public property | Request | Gets the request that generated this content.
Top
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs.Content Property

TextContentEventArgsContent Property
Gets or sets the text content.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Content { get; set; }
Public Property Content As String
    Get
    Set
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}
member Content : string with get, set

Property Value

Type: String
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs.Encoding Property

TextContentEventArgsEncoding Property
Gets or sets the encoding of the content.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Property Value

Type: Encoding
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs.PathAndFile Property

TextContentEventArgsPathAndFile Property
Gets the path and file of the request from root.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PathAndFile { get; }
Public ReadOnly Property PathAndFile As String
    Get
public:
property String^ PathAndFile {
    String^ get ();
}
member PathAndFile : string with get

Property Value

Type: String
Remarks
If the server root is /Root then for the RawUrl of '/Root' this would return '/', for the RawUrl of '/Root/' it would also return '/', for '/Root/Page.htm' it would return '/Page.htm', '/Root/Folder/' it would return '/Folder/' and so on. Query strings are stripped off and escaped characters are unescaped.
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs.Request Property

TextContentEventArgsRequest Property
Gets the request that generated this content.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRequest Request { get; }
Public ReadOnly Property Request As IRequest
    Get
public:
property IRequest^ Request {
    IRequest^ get ();
}
member Request : IRequest with get

Property Value

Type: IRequest
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TextContentEventArgs Methods

TextContentEventArgs Methods

The TextContentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextContentEventArgs Class
VirtualRadar.Interface.WebSite Namespace


TrailType Enumeration

TrailType Enumeration
An enumeration of the different trail types.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TrailType
Public Enumeration TrailType
public enum class TrailType
type TrailType
Members
Member name | Value | Description
None | 0 | No trail is to be shown.
Full | 1 | Show the complete path taken by the aircraft.
Short | 2 | Show the path taken by the aircraft over the last so-many seconds.
FullAltitude | 3 | Show the entire path and all changes in altitude.
ShortAltitude | 4 | Show the path and changes in altitude over the last so-many seconds.
FullSpeed | 5 | Show the entire path and all changes in speed.
ShortSpeed | 6 | Show the path and changes in speed over the last so-many seconds.
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


WebAdminMethodAttribute Class

WebAdminMethodAttribute Class
Marks a method on a view returned by a WebAdminView as being callable from the web page.
Inheritance Hierarchy
SystemObject
SystemAttribute
VirtualRadar.Interface.WebSiteWebAdminMethodAttribute

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WebAdminMethodAttribute : Attribute
Public Class WebAdminMethodAttribute
    Inherits Attribute
public ref class WebAdminMethodAttribute : public Attribute
type WebAdminMethodAttribute =
    class
        inherit Attribute
    end

The WebAdminMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | WebAdminMethodAttribute | Creates a new object.
Top
Properties
 | Name | Description
Public property | DeferExecution | Gets or sets a value indicating that the method should be deferred.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | User | Gets or sets the name of the string parameter that should be filled with the current user's name.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


WebAdminMethodAttribute Constructor

WebAdminMethodAttribute Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebAdminMethodAttribute()
Public Sub New
public:
WebAdminMethodAttribute()
new : unit -> WebAdminMethodAttribute
See Also

Reference

WebAdminMethodAttribute Class
VirtualRadar.Interface.WebSite Namespace


WebAdminMethodAttribute Properties

WebAdminMethodAttribute Properties

The WebAdminMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | DeferExecution | Gets or sets a value indicating that the method should be deferred.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | User | Gets or sets the name of the string parameter that should be filled with the current user's name.
Top
See Also

Reference

WebAdminMethodAttribute Class
VirtualRadar.Interface.WebSite Namespace


WebAdminMethodAttribute.DeferExecution Property

WebAdminMethodAttributeDeferExecution Property
Gets or sets a value indicating that the method should be deferred.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeferExecution { get; set; }
Public Property DeferExecution As Boolean
    Get
    Set
public:
property bool DeferExecution {
    bool get ();
    void set (bool value);
}
member DeferExecution : bool with get, set

Property Value

Type: Boolean
Remarks

Some methods may want to do something that can cause the web server to close all connections and restart (this applies in particular to anything to do with UPnP). This can cause havoc with the WebAdmin site as it will close the connection while the browser is waiting for a reply, which at the very least will cause the browser to re-send the request.

Setting this property tells the web admin plugin that it should defer the execution of the method until after a response has been returned for the request. The response will carry a job identifier back to the browser and the browser is then expected to poll the server until the job has been run. Pages that use the ajax() method in ViewId do not need to do anything, the ajax() method will handle the job polling for them.

See Also

Reference

WebAdminMethodAttribute Class
VirtualRadar.Interface.WebSite Namespace


WebAdminMethodAttribute.User Property

WebAdminMethodAttributeUser Property
Gets or sets the name of the string parameter that should be filled with the current user's name.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Property Value

Type: String
See Also

Reference

WebAdminMethodAttribute Class
VirtualRadar.Interface.WebSite Namespace


WebAdminMethodAttribute Methods

WebAdminMethodAttribute Methods

The WebAdminMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebAdminMethodAttribute Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView Class

WebAdminView Class
The class that describes a web admin view.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSiteWebAdminView

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WebAdminView
Public Class WebAdminView
public ref class WebAdminView
type WebAdminView =  class end

The WebAdminView type exposes the following members.

Constructors
 | Name | Description
Public method | WebAdminView | Creates a new object.
Top
Properties
 | Name | Description
Public property | HtmlFileName | Gets the HTML filename without the path.
Public property | MenuName | Gets the name to use for the view in the web admin's site menu. Pass a null or empty string to prevent the view from appearing in the menu.
Public property | PathAndFile | Gets the path and file to the HTML file from the site root.
Public property | Plugin | Gets or sets the plugin that this view is the options screen for.
Public property | StringResources | Gets the resources that holds the strings to substitute into the view.
Top
Methods
 | Name | Description
Public method | CreateView | Creates the object that will handle the requests from the HTML page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite Namespace


WebAdminView Constructor

WebAdminView Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WebAdminView(
    string pathFromRoot,
    string htmlFileName,
    string menuName,
    Func<IView> createView,
    Type stringResources
)
Public Sub New (
    pathFromRoot As String,
    htmlFileName As String,
    menuName As String,
    createView As Func(Of IView),
    stringResources As Type
)
public:
WebAdminView(
    String^ pathFromRoot,
    String^ htmlFileName,
    String^ menuName,
    Func<IView^>^ createView,
    Type^ stringResources
)
new :
        pathFromRoot : string *
        htmlFileName : string *
        menuName : string *
        createView : Func<IView> *
        stringResources : Type -> WebAdminView

Parameters

pathFromRoot
Type: SystemString
htmlFileName
Type: SystemString
menuName
Type: SystemString
createView
Type: SystemFunc IView
stringResources
Type: SystemType
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView Properties

WebAdminView Properties

The WebAdminView type exposes the following members.

Properties
 | Name | Description
Public property | HtmlFileName | Gets the HTML filename without the path.
Public property | MenuName | Gets the name to use for the view in the web admin's site menu. Pass a null or empty string to prevent the view from appearing in the menu.
Public property | PathAndFile | Gets the path and file to the HTML file from the site root.
Public property | Plugin | Gets or sets the plugin that this view is the options screen for.
Public property | StringResources | Gets the resources that holds the strings to substitute into the view.
Top
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView.HtmlFileName Property

WebAdminViewHtmlFileName Property
Gets the HTML filename without the path.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HtmlFileName { get; }
Public ReadOnly Property HtmlFileName As String
    Get
public:
property String^ HtmlFileName {
    String^ get ();
}
member HtmlFileName : string with get

Property Value

Type: String
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView.MenuName Property

WebAdminViewMenuName Property
Gets the name to use for the view in the web admin's site menu. Pass a null or empty string to prevent the view from appearing in the menu.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MenuName { get; }
Public ReadOnly Property MenuName As String
    Get
public:
property String^ MenuName {
    String^ get ();
}
member MenuName : string with get

Property Value

Type: String
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView.PathAndFile Property

WebAdminViewPathAndFile Property
Gets the path and file to the HTML file from the site root.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PathAndFile { get; }
Public ReadOnly Property PathAndFile As String
    Get
public:
property String^ PathAndFile {
    String^ get ();
}
member PathAndFile : string with get

Property Value

Type: String
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView.Plugin Property

WebAdminViewPlugin Property
Gets or sets the plugin that this view is the options screen for.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPlugin Plugin { get; set; }
Public Property Plugin As IPlugin
    Get
    Set
public:
property IPlugin^ Plugin {
    IPlugin^ get ();
    void set (IPlugin^ value);
}
member Plugin : IPlugin with get, set

Property Value

Type: IPlugin
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView.StringResources Property

WebAdminViewStringResources Property
Gets the resources that holds the strings to substitute into the view.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Type StringResources { get; }
Public ReadOnly Property StringResources As Type
    Get
public:
property Type^ StringResources {
    Type^ get ();
}
member StringResources : Type with get

Property Value

Type: Type
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView Methods

WebAdminView Methods

The WebAdminView type exposes the following members.

Methods
 | Name | Description
Public method | CreateView | Creates the object that will handle the requests from the HTML page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


WebAdminView.CreateView Method

WebAdminViewCreateView Method
Creates the object that will handle the requests from the HTML page.

Namespace: VirtualRadar.Interface.WebSite
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IView CreateView()
Public Function CreateView As IView
public:
IView^ CreateView()
member CreateView : unit -> IView

Return Value

Type: IView
Remarks
The view is expected to create an instance of its presenter and dispose of the presenter if necessary.
See Also

Reference

WebAdminView Class
VirtualRadar.Interface.WebSite Namespace


VirtualRadar.Interface.WebSite.WebAdminModels Namespace

VirtualRadar.Interface.WebSite.WebAdminModels Namespace

[Missing <summary> documentation for "N:VirtualRadar.Interface.WebSite.WebAdminModels"]

Classes
 | Class | Description
Public class | AccessModel | Describes the properties of an Access object.
Public class | CidrModel | Represents a CIDR in an AccessModel.


AccessModel Class

AccessModel Class
Describes the properties of an Access object.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSite.WebAdminModelsAccessModel

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AccessModel
Public Class AccessModel
public ref class AccessModel
type AccessModel =  class end

The AccessModel type exposes the following members.

Constructors
 | Name | Description
Public method | AccessModel | Creates a new object.
Public method | AccessModel(Access) | Creates an object from an existing Access.
Top
Properties
 | Name | Description
Public property | Addresses | Gets a list of addresses.
Public property | DefaultAccess | Gets or sets the numeric value of a DefaultAccess enum.
Top
Methods
 | Name | Description
Public method | CopyToSettings | Overwrites an Access with values from the model's properties.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshFromSettings | Copies the values of an existing Access.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel Constructor

AccessModel Constructor
Overload List
 | Name | Description
Public method | AccessModel | Creates a new object.
Public method | AccessModel(Access) | Creates an object from an existing Access.
Top
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel Constructor

AccessModel Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessModel()
Public Sub New
public:
AccessModel()
new : unit -> AccessModel
See Also

Reference

AccessModel Class
AccessModel Overload
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel Constructor (Access)

AccessModel Constructor (Access)
Creates an object from an existing Access.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessModel(
    Access settings
)
Public Sub New (
    settings As Access
)
public:
AccessModel(
    Access^ settings
)
new :
        settings : Access -> AccessModel

Parameters

settings
Type: VirtualRadar.Interface.SettingsAccess
See Also

Reference

AccessModel Class
AccessModel Overload
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel Properties

AccessModel Properties

The AccessModel type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | Gets a list of addresses.
Public property | DefaultAccess | Gets or sets the numeric value of a DefaultAccess enum.
Top
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel.Addresses Property

AccessModelAddresses Property
Gets a list of addresses.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<CidrModel> Addresses { get; }
Public ReadOnly Property Addresses As List(Of CidrModel)
    Get
public:
property List<CidrModel^>^ Addresses {
    List<CidrModel^>^ get ();
}
member Addresses : List<CidrModel> with get

Property Value

Type: List CidrModel
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel.DefaultAccess Property

AccessModelDefaultAccess Property
Gets or sets the numeric value of a DefaultAccess enum.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DefaultAccess { get; set; }
Public Property DefaultAccess As Integer
    Get
    Set
public:
property int DefaultAccess {
    int get ();
    void set (int value);
}
member DefaultAccess : int with get, set

Property Value

Type: Int32
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel Methods

AccessModel Methods

The AccessModel type exposes the following members.

Methods
 | Name | Description
Public method | CopyToSettings | Overwrites an Access with values from the model's properties.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshFromSettings | Copies the values of an existing Access.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel.CopyToSettings Method

AccessModelCopyToSettings Method
Overwrites an Access with values from the model's properties.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Access CopyToSettings(
    Access settings
)
Public Function CopyToSettings (
    settings As Access
) As Access
public:
Access^ CopyToSettings(
    Access^ settings
)
member CopyToSettings :
        settings : Access -> Access

Parameters

settings
Type: VirtualRadar.Interface.SettingsAccess

Return Value

Type: Access
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


AccessModel.RefreshFromSettings Method

AccessModelRefreshFromSettings Method
Copies the values of an existing Access.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RefreshFromSettings(
    Access settings
)
Public Sub RefreshFromSettings (
    settings As Access
)
public:
void RefreshFromSettings(
    Access^ settings
)
member RefreshFromSettings :
        settings : Access -> unit

Parameters

settings
Type: VirtualRadar.Interface.SettingsAccess
See Also

Reference

AccessModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel Class

CidrModel Class
Represents a CIDR in an AccessModel.
Inheritance Hierarchy
SystemObject
VirtualRadar.Interface.WebSite.WebAdminModelsCidrModel

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CidrModel
Public Class CidrModel
public ref class CidrModel
type CidrModel =  class end

The CidrModel type exposes the following members.

Constructors
 | Name | Description
Public method | CidrModel | Creates a new object.
Public method | CidrModel(String) | Creates an object from a CIDR.
Top
Properties
 | Name | Description
Public property | Cidr | Gets or sets the CIDR.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel Constructor

CidrModel Constructor
Overload List
 | Name | Description
Public method | CidrModel | Creates a new object.
Public method | CidrModel(String) | Creates an object from a CIDR.
Top
See Also

Reference

CidrModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel Constructor

CidrModel Constructor
Creates a new object.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CidrModel()
Public Sub New
public:
CidrModel()
new : unit -> CidrModel
See Also

Reference

CidrModel Class
CidrModel Overload
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel Constructor (String)

CidrModel Constructor (String)
Creates an object from a CIDR.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CidrModel(
    string address
)
Public Sub New (
    address As String
)
public:
CidrModel(
    String^ address
)
new :
        address : string -> CidrModel

Parameters

address
Type: SystemString
See Also

Reference

CidrModel Class
CidrModel Overload
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel Properties

CidrModel Properties

The CidrModel type exposes the following members.

Properties
 | Name | Description
Public property | Cidr | Gets or sets the CIDR.
Top
See Also

Reference

CidrModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel.Cidr Property

CidrModelCidr Property
Gets or sets the CIDR.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Cidr { get; set; }
Public Property Cidr As String
    Get
    Set
public:
property String^ Cidr {
    String^ get ();
    void set (String^ value);
}
member Cidr : string with get, set

Property Value

Type: String
See Also

Reference

CidrModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel Methods

CidrModel Methods

The CidrModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

CidrModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


CidrModel.ToString Method

CidrModelToString Method
See base docs.

Namespace: VirtualRadar.Interface.WebSite.WebAdminModels
Assembly: VirtualRadar.Interface (in VirtualRadar.Interface.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

CidrModel Class
VirtualRadar.Interface.WebSite.WebAdminModels Namespace


VirtualRadar.Interop Namespace

VirtualRadar.Interop Namespace

[Missing <summary> documentation for "N:VirtualRadar.Interop"]

Classes
 | Class | Description
Public class | Console | Handles interop with the console.
Public class | FindFile | This is a wrapper around Win32's FindFirstFile and FindNextFile. When VRS moves over to .NET 4 we can get rid of this.
Public class | Window | Wraps Window interops.
Structures
 | Structure | Description
Public structure | FindFileData | A wrapper around the WIN32_FIND_DATA struct.
Public structure | HDITEM | See Microsoft's documentation for the HDITEM struct.
Public structure | TcpKeepAlive | A struct suitable for use with interop calls that require a tcp_keepalive block.


Console Class

Console Class
Handles interop with the console.
Inheritance Hierarchy
SystemObject
VirtualRadar.InteropConsole

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Console
Public NotInheritable Class Console
public ref class Console abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Console =  class end

The Console type exposes the following members.

Methods
Name | Description
HideConsole | Hides the console window.
ShowConsole | Shows the console window.
Top
See Also

Reference

VirtualRadar.Interop Namespace


Console Methods

Console Methods

The Console type exposes the following members.

Methods
Name | Description
HideConsole | Hides the console window.
ShowConsole | Shows the console window.
Top
See Also

Reference

Console Class
VirtualRadar.Interop Namespace


Console.HideConsole Method

ConsoleHideConsole Method
Hides the console window.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void HideConsole()
Public Shared Sub HideConsole
public:
static void HideConsole()
static member HideConsole : unit -> unit
See Also

Reference

Console Class
VirtualRadar.Interop Namespace


Console.ShowConsole Method

ConsoleShowConsole Method
Shows the console window.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ShowConsole()
Public Shared Sub ShowConsole
public:
static void ShowConsole()
static member ShowConsole : unit -> unit
See Also

Reference

Console Class
VirtualRadar.Interop Namespace


FindFile Class

FindFile Class
This is a wrapper around Win32's FindFirstFile and FindNextFile. When VRS moves over to .NET 4 we can get rid of this.
Inheritance Hierarchy
SystemObject
VirtualRadar.InteropFindFile

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FindFile
Public Class FindFile
public ref class FindFile
type FindFile =  class end

The FindFile type exposes the following members.

Constructors
 | Name | Description
Public method | FindFile | Initializes a new instance of the FindFile class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFiles | Returns a list of files in a folder.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

Before .NET 4.0 the DirectoryInfo.GetFiles() method would read all of the files in a folder in one go but it would lazily read the attributes, lengths etc. of those files. When reading the names and last modified dates of 7500 files across the network using DirectoryInfo it was taking a minute in 3.5 and a couple of seconds in 4.

I need it to be very fast but I can't justify switching the product over to .Net 4.0 just for that, so instead I've done this wrapper around Win32's FindFirstFile / FindNextFile. When I do move VRS onto .Net 4 I can probably ditch this. Also, if VRS is being ported to some other platform this can probably be reimplemented in C# using a DirectoryInfo.

See Also

Reference

VirtualRadar.Interop Namespace


FindFile Constructor

FindFile Constructor
Initializes a new instance of the FindFile class

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FindFile()
Public Sub New
public:
FindFile()
new : unit -> FindFile
See Also

Reference

FindFile Class
VirtualRadar.Interop Namespace


FindFile Methods

FindFile Methods

The FindFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFiles | Returns a list of files in a folder.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindFile Class
VirtualRadar.Interop Namespace


FindFile.GetFiles Method

FindFileGetFiles Method
Returns a list of files in a folder.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FindFileData> GetFiles(
    string path
)
Public Function GetFiles (
    path As String
) As IList(Of FindFileData)
public:
IList<FindFileData>^ GetFiles(
    String^ path
)
member GetFiles :
        path : string -> IList<FindFileData>

Parameters

path
Type: SystemString

Return Value

Type: IList FindFileData
See Also

Reference

FindFile Class
VirtualRadar.Interop Namespace


FindFileData Structure

FindFileData Structure
A wrapper around the WIN32_FIND_DATA struct.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct FindFileData
Public Structure FindFileData
public value class FindFileData
[<SealedAttribute>]
type FindFileData =  struct end

The FindFileData type exposes the following members.

Properties
 | Name | Description
Public property | LastWriteTimeUtc | Gets the time that the file was last modified in UTC.
Public property | Name | Gets the filename.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

VirtualRadar.Interop Namespace


FindFileData Properties

FindFileData Properties

The FindFileData type exposes the following members.

Properties
 | Name | Description
Public property | LastWriteTimeUtc | Gets the time that the file was last modified in UTC.
Public property | Name | Gets the filename.
Top
See Also

Reference

FindFileData Structure
VirtualRadar.Interop Namespace


FindFileData.LastWriteTimeUtc Property

FindFileDataLastWriteTimeUtc Property
Gets the time that the file was last modified in UTC.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastWriteTimeUtc { get; }
Public ReadOnly Property LastWriteTimeUtc As DateTime
    Get
public:
property DateTime LastWriteTimeUtc {
    DateTime get ();
}
member LastWriteTimeUtc : DateTime with get

Property Value

Type: DateTime
See Also

Reference

FindFileData Structure
VirtualRadar.Interop Namespace


FindFileData.Name Property

FindFileDataName Property
Gets the filename.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

FindFileData Structure
VirtualRadar.Interop Namespace


FindFileData Methods

FindFileData Methods

The FindFileData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

FindFileData Structure
VirtualRadar.Interop Namespace


HDITEM Structure

HDITEM Structure
See Microsoft's documentation for the HDITEM struct.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct HDITEM
Public Structure HDITEM
public value class HDITEM
[<SealedAttribute>]
type HDITEM =  struct end

The HDITEM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | cchTextMax | See MSDN documentation.
Public field | cxy | See MSDN documentation.
Public field | fmt | See MSDN documentation.
Public field | hbm | See MSDN documentation.
 | HDF_LEFT | See MSDN documentation.
 | HDF_SORTDOWN | See MSDN documentation.
 | HDF_SORTUP | See MSDN documentation.
 | HDF_STRING | See MSDN documentation.
 | HDI_FORMAT | See MSDN documentation.
 | HDM_FIRST | See MSDN documentation.
 | HDM_GETITEM | See MSDN documentation.
 | HDM_SETITEM | See MSDN documentation.
Public field | iImage | See MSDN documentation.
Public field | iOrder | See MSDN documentation.
Public field | lParam | See MSDN documentation.
Public field | mask | See MSDN documentation.
Public field | pszText | See MSDN documentation.
Top
Remarks
At the time of writing this was at http://msdn.microsoft.com/en-gb/library/windows/desktop/bb775247(v=vs.85).aspx but don't be surprised if Microsoft have moved it.
See Also

Reference

VirtualRadar.Interop Namespace


HDITEM Methods

HDITEM Methods

The HDITEM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM Fields

HDITEM Fields

The HDITEM type exposes the following members.

Fields
 | Name | Description
Public field | cchTextMax | See MSDN documentation.
Public field | cxy | See MSDN documentation.
Public field | fmt | See MSDN documentation.
Public field | hbm | See MSDN documentation.
 | HDF_LEFT | See MSDN documentation.
 | HDF_SORTDOWN | See MSDN documentation.
 | HDF_SORTUP | See MSDN documentation.
 | HDF_STRING | See MSDN documentation.
 | HDI_FORMAT | See MSDN documentation.
 | HDM_FIRST | See MSDN documentation.
 | HDM_GETITEM | See MSDN documentation.
 | HDM_SETITEM | See MSDN documentation.
Public field | iImage | See MSDN documentation.
Public field | iOrder | See MSDN documentation.
Public field | lParam | See MSDN documentation.
Public field | mask | See MSDN documentation.
Public field | pszText | See MSDN documentation.
Top
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.cchTextMax Field

HDITEMcchTextMax Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int cchTextMax
Public cchTextMax As Integer
public:
int cchTextMax
val mutable cchTextMax: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.cxy Field

HDITEMcxy Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int cxy
Public cxy As Integer
public:
int cxy
val mutable cxy: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.fmt Field

HDITEMfmt Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int fmt
Public fmt As Integer
public:
int fmt
val mutable fmt: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.hbm Field

HDITEMhbm Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntPtr hbm
Public hbm As IntPtr
public:
IntPtr hbm
val mutable hbm: IntPtr

Field Value

Type: IntPtr
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDF_LEFT Field

HDITEMHDF_LEFT Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDF_LEFT
Public Const HDF_LEFT As Integer
public:
literal int HDF_LEFT
static val mutable HDF_LEFT: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDF_SORTDOWN Field

HDITEMHDF_SORTDOWN Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDF_SORTDOWN
Public Const HDF_SORTDOWN As Integer
public:
literal int HDF_SORTDOWN
static val mutable HDF_SORTDOWN: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDF_SORTUP Field

HDITEMHDF_SORTUP Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDF_SORTUP
Public Const HDF_SORTUP As Integer
public:
literal int HDF_SORTUP
static val mutable HDF_SORTUP: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDF_STRING Field

HDITEMHDF_STRING Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDF_STRING
Public Const HDF_STRING As Integer
public:
literal int HDF_STRING
static val mutable HDF_STRING: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDI_FORMAT Field

HDITEMHDI_FORMAT Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDI_FORMAT
Public Const HDI_FORMAT As Integer
public:
literal int HDI_FORMAT
static val mutable HDI_FORMAT: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDM_FIRST Field

HDITEMHDM_FIRST Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDM_FIRST
Public Const HDM_FIRST As Integer
public:
literal int HDM_FIRST
static val mutable HDM_FIRST: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDM_GETITEM Field

HDITEMHDM_GETITEM Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDM_GETITEM
Public Const HDM_GETITEM As Integer
public:
literal int HDM_GETITEM
static val mutable HDM_GETITEM: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.HDM_SETITEM Field

HDITEMHDM_SETITEM Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int HDM_SETITEM
Public Const HDM_SETITEM As Integer
public:
literal int HDM_SETITEM
static val mutable HDM_SETITEM: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.iImage Field

HDITEMiImage Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int iImage
Public iImage As Integer
public:
int iImage
val mutable iImage: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.iOrder Field

HDITEMiOrder Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int iOrder
Public iOrder As Integer
public:
int iOrder
val mutable iOrder: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.lParam Field

HDITEMlParam Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int lParam
Public lParam As Integer
public:
int lParam
val mutable lParam: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.mask Field

HDITEMmask Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int mask
Public mask As Integer
public:
int mask
val mutable mask: int

Field Value

Type: Int32
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


HDITEM.pszText Field

HDITEMpszText Field
See MSDN documentation.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string pszText
Public pszText As String
public:
String^ pszText
val mutable pszText: string

Field Value

Type: String
See Also

Reference

HDITEM Structure
VirtualRadar.Interop Namespace


TcpKeepAlive Structure

TcpKeepAlive Structure
A struct suitable for use with interop calls that require a tcp_keepalive block.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct TcpKeepAlive
Public Structure TcpKeepAlive
public value class TcpKeepAlive
[<SealedAttribute>]
type TcpKeepAlive =  struct end

The TcpKeepAlive type exposes the following members.

Methods
 | Name | Description
Public method | BuildBuffer | Returns a managed array of bytes representing the struct content.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | KeepAliveInterval | The interval in milliseconds between successive keep-alive packets.
Public field | KeepAliveTime | The timeout in milliseconds.
Public field | OnOff | Indicates whether TCP keep-alive is enabled or disabled.
Top
Remarks

See http://msdn.microsoft.com/en-us/library/dd877220(VS.85).aspx, C version is tcp_keepalive and is associated with SIO_KEEPALIVE_VALS control code.

By default BeginRead on a socket will wait forever with no heartbeat. If the connection breaks you get no indication. By specifying a hearbeat check with SIO_KEEPALIVE_VALS you can force it to throw a SocketException after a connection has remained broken for a given period of time.

See Also

Reference

VirtualRadar.Interop Namespace


TcpKeepAlive Methods

TcpKeepAlive Methods

The TcpKeepAlive type exposes the following members.

Methods
 | Name | Description
Public method | BuildBuffer | Returns a managed array of bytes representing the struct content.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TcpKeepAlive Structure
VirtualRadar.Interop Namespace


TcpKeepAlive.BuildBuffer Method

TcpKeepAliveBuildBuffer Method
Returns a managed array of bytes representing the struct content.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] BuildBuffer()
Public Function BuildBuffer As Byte()
public:
array<unsigned char>^ BuildBuffer()
member BuildBuffer : unit -> byte[]

Return Value

Type: Byte
Remarks
This is intended for use with the Socket.IOControl method, which takes a managed array of bytes. We don't need to keep this struct hanging around in unmanaged memory when it's used.
See Also

Reference

TcpKeepAlive Structure
VirtualRadar.Interop Namespace


TcpKeepAlive Fields

TcpKeepAlive Fields

The TcpKeepAlive type exposes the following members.

Fields
 | Name | Description
Public field | KeepAliveInterval | The interval in milliseconds between successive keep-alive packets.
Public field | KeepAliveTime | The timeout in milliseconds.
Public field | OnOff | Indicates whether TCP keep-alive is enabled or disabled.
Top
See Also

Reference

TcpKeepAlive Structure
VirtualRadar.Interop Namespace


TcpKeepAlive.KeepAliveInterval Field

TcpKeepAliveKeepAliveInterval Field
The interval in milliseconds between successive keep-alive packets.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int KeepAliveInterval
Public KeepAliveInterval As Integer
public:
int KeepAliveInterval
val mutable KeepAliveInterval: int

Field Value

Type: Int32
See Also

Reference

TcpKeepAlive Structure
VirtualRadar.Interop Namespace


TcpKeepAlive.KeepAliveTime Field

TcpKeepAliveKeepAliveTime Field
The timeout in milliseconds.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int KeepAliveTime
Public KeepAliveTime As Integer
public:
int KeepAliveTime
val mutable KeepAliveTime: int

Field Value

Type: Int32
See Also

Reference

TcpKeepAlive Structure
VirtualRadar.Interop Namespace


TcpKeepAlive.OnOff Field

TcpKeepAliveOnOff Field
Indicates whether TCP keep-alive is enabled or disabled.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OnOff
Public OnOff As Integer
public:
int OnOff
val mutable OnOff: int

Field Value

Type: Int32
See Also

Reference

TcpKeepAlive Structure
VirtualRadar.Interop Namespace


Window Class

Window Class
Wraps Window interops.
Inheritance Hierarchy
SystemObject
VirtualRadar.InteropWindow

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Window
Public NotInheritable Class Window
public ref class Window abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Window =  class end

The Window type exposes the following members.

Properties
Name | Description
IsInert | Gets a value indicating that the methods here do nothing.
Top
Methods
Name | Description
CallSendMessage(IntPtr, UInt32, IntPtr, IntPtr) | Invokes SendMessage.
CallSendMessage(IntPtr, UInt32, IntPtr, HDITEM) | Invokes SendMessage with an HDITEM parameter.
Top
See Also

Reference

VirtualRadar.Interop Namespace


Window Properties

Window Properties

The Window type exposes the following members.

Properties
Name | Description
IsInert | Gets a value indicating that the methods here do nothing.
Top
See Also

Reference

Window Class
VirtualRadar.Interop Namespace


Window.IsInert Property

WindowIsInert Property
Gets a value indicating that the methods here do nothing.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsInert { get; }
Public Shared ReadOnly Property IsInert As Boolean
    Get
public:
static property bool IsInert {
    bool get ();
}
static member IsInert : bool with get

Property Value

Type: Boolean
See Also

Reference

Window Class
VirtualRadar.Interop Namespace


Window Methods

Window Methods
Methods
Name | Description
CallSendMessage(IntPtr, UInt32, IntPtr, IntPtr) | Invokes SendMessage.
CallSendMessage(IntPtr, UInt32, IntPtr, HDITEM) | Invokes SendMessage with an HDITEM parameter.
Top
See Also

Reference

Window Class
VirtualRadar.Interop Namespace


Window.CallSendMessage Method

WindowCallSendMessage Method
Overload List
Name | Description
CallSendMessage(IntPtr, UInt32, IntPtr, IntPtr) | Invokes SendMessage.
CallSendMessage(IntPtr, UInt32, IntPtr, HDITEM) | Invokes SendMessage with an HDITEM parameter.
Top
See Also

Reference

Window Class
VirtualRadar.Interop Namespace


Window.CallSendMessage Method (IntPtr, UInt32, IntPtr, IntPtr)

WindowCallSendMessage Method (IntPtr, UInt32, IntPtr, IntPtr)
Invokes SendMessage.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CallSendMessage(
    IntPtr hWnd,
    uint msg,
    IntPtr wParam,
    IntPtr lParam
)
Public Shared Function CallSendMessage (
    hWnd As IntPtr,
    msg As UInteger,
    wParam As IntPtr,
    lParam As IntPtr
) As IntPtr
public:
static IntPtr CallSendMessage(
    IntPtr hWnd,
    unsigned int msg,
    IntPtr wParam,
    IntPtr lParam
)
static member CallSendMessage :
        hWnd : IntPtr *
        msg : uint32 *
        wParam : IntPtr *
        lParam : IntPtr -> IntPtr

Parameters

hWnd
Type: SystemIntPtr
msg
Type: SystemUInt32
wParam
Type: SystemIntPtr
lParam
Type: SystemIntPtr

Return Value

Type: IntPtr
See Also

Reference

Window Class
CallSendMessage Overload
VirtualRadar.Interop Namespace


Window.CallSendMessage Method (IntPtr, UInt32, IntPtr, HDITEM)

WindowCallSendMessage Method (IntPtr, UInt32, IntPtr, HDITEM)
Invokes SendMessage with an HDITEM parameter.

Namespace: VirtualRadar.Interop
Assembly: VirtualRadar.Interop (in VirtualRadar.Interop.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CallSendMessage(
    IntPtr hWnd,
    uint msg,
    IntPtr wParam,
    ref HDITEM hditem
)
Public Shared Function CallSendMessage (
    hWnd As IntPtr,
    msg As UInteger,
    wParam As IntPtr,
    ByRef hditem As HDITEM
) As IntPtr
public:
static IntPtr CallSendMessage(
    IntPtr hWnd,
    unsigned int msg,
    IntPtr wParam,
    HDITEM% hditem
)
static member CallSendMessage :
        hWnd : IntPtr *
        msg : uint32 *
        wParam : IntPtr *
        hditem : HDITEM byref -> IntPtr

Parameters

hWnd
Type: SystemIntPtr
msg
Type: SystemUInt32
wParam
Type: SystemIntPtr
hditem
Type: VirtualRadar.InteropHDITEM

Return Value

Type: IntPtr
See Also

Reference

Window Class
CallSendMessage Overload
VirtualRadar.Interop Namespace


VirtualRadar.Library Namespace

VirtualRadar.Library Namespace
The namespace holding many of the standard implementations of the application's interfaces.
Classes
 | Class | Description
Public class | Implementations | Initialises the class factory with all the standard implementations in this library.
Remarks
None of the implementations are public, you must use the class factory to access them.


Implementations Class

Implementations Class
Initialises the class factory with all the standard implementations in this library.
Inheritance Hierarchy
SystemObject
VirtualRadar.LibraryImplementations

Namespace: VirtualRadar.Library
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Implementations
Public NotInheritable Class Implementations
public ref class Implementations abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Implementations =  class end

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

VirtualRadar.Library Namespace


Implementations Methods

Implementations Methods

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

Implementations Class
VirtualRadar.Library Namespace


Implementations.Register Method

ImplementationsRegister Method
Initialises the class factory with all the standard implementations in this library.

Namespace: VirtualRadar.Library
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Register(
    IClassFactory factory
)
Public Shared Sub Register (
    factory As IClassFactory
)
public:
static void Register(
    IClassFactory^ factory
)
static member Register :
        factory : IClassFactory -> unit

Parameters

factory
Type: InterfaceFactoryIClassFactory
See Also

Reference

Implementations Class
VirtualRadar.Library Namespace


VirtualRadar.Library.Listener Namespace

VirtualRadar.Library.Listener Namespace

[Missing <summary> documentation for "N:VirtualRadar.Library.Listener"]

Classes
 | Class | Description
Public class | ReceiverFormatManager | The default implementation of IReceiverFormatManager.


ReceiverFormatManager Class

ReceiverFormatManager Class
The default implementation of IReceiverFormatManager.
Inheritance Hierarchy
SystemObject
VirtualRadar.Library.ListenerReceiverFormatManager

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReceiverFormatManager : IReceiverFormatManager,
    ISingleton<IReceiverFormatManager>
Public Class ReceiverFormatManager
    Implements IReceiverFormatManager, ISingleton(Of IReceiverFormatManager)
public ref class ReceiverFormatManager : IReceiverFormatManager,
    ISingleton<IReceiverFormatManager^>
type ReceiverFormatManager =
    class
        interface IReceiverFormatManager
        interface ISingleton<IReceiverFormatManager>
    end

The ReceiverFormatManager type exposes the following members.

Constructors
 | Name | Description
Public method | ReceiverFormatManager | Initializes a new instance of the ReceiverFormatManager class
Top
Properties
 | Name | Description
Public property | Singleton | See interface docs.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProvider | See interface docs.
Public method | GetRegisteredFormats | See interface docs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialise | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterProvider | See interface docs.
Public method | ShortName | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Library.Listener Namespace


ReceiverFormatManager Constructor

ReceiverFormatManager Constructor
Initializes a new instance of the ReceiverFormatManager class

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverFormatManager()
Public Sub New
public:
ReceiverFormatManager()
new : unit -> ReceiverFormatManager
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager Properties

ReceiverFormatManager Properties

The ReceiverFormatManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | See interface docs.
Top
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager.Singleton Property

ReceiverFormatManagerSingleton Property
See interface docs.

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReceiverFormatManager Singleton { get; }
Public ReadOnly Property Singleton As IReceiverFormatManager
    Get
public:
virtual property IReceiverFormatManager^ Singleton {
    IReceiverFormatManager^ get () sealed;
}
abstract Singleton : IReceiverFormatManager with get
override Singleton : IReceiverFormatManager with get

Property Value

Type: IReceiverFormatManager

Implements

ISingletonTSingleton
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager Methods

ReceiverFormatManager Methods

The ReceiverFormatManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProvider | See interface docs.
Public method | GetRegisteredFormats | See interface docs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialise | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterProvider | See interface docs.
Public method | ShortName | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager.GetProvider Method

ReceiverFormatManagerGetProvider Method
See interface docs.

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReceiverFormatProvider GetProvider(
    string providerId
)
Public Function GetProvider (
    providerId As String
) As IReceiverFormatProvider
public:
virtual IReceiverFormatProvider^ GetProvider(
    String^ providerId
) sealed
abstract GetProvider :
        providerId : string -> IReceiverFormatProvider
override GetProvider :
        providerId : string -> IReceiverFormatProvider

Parameters

providerId
Type: SystemString

Return Value

Type: IReceiverFormatProvider

Implements

IReceiverFormatManagerGetProvider(String)
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager.GetRegisteredFormats Method

ReceiverFormatManagerGetRegisteredFormats Method
See interface docs.

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverFormatName[] GetRegisteredFormats()
Public Function GetRegisteredFormats As ReceiverFormatName()
public:
virtual array<ReceiverFormatName^>^ GetRegisteredFormats() sealed
abstract GetRegisteredFormats : unit -> ReceiverFormatName[]
override GetRegisteredFormats : unit -> ReceiverFormatName[]

Return Value

Type: ReceiverFormatName

Implements

IReceiverFormatManagerGetRegisteredFormats
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager.Initialise Method

ReceiverFormatManagerInitialise Method
See interface docs.

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise()
Public Sub Initialise
public:
virtual void Initialise() sealed
abstract Initialise : unit -> unit
override Initialise : unit -> unit

Implements

IReceiverFormatManagerInitialise
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager.RegisterProvider Method

ReceiverFormatManagerRegisterProvider Method
See interface docs.

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterProvider(
    IReceiverFormatProvider provider
)
Public Sub RegisterProvider (
    provider As IReceiverFormatProvider
)
public:
virtual void RegisterProvider(
    IReceiverFormatProvider^ provider
) sealed
abstract RegisterProvider :
        provider : IReceiverFormatProvider -> unit
override RegisterProvider :
        provider : IReceiverFormatProvider -> unit

Parameters

provider
Type: VirtualRadar.Interface.ListenerIReceiverFormatProvider

Implements

IReceiverFormatManagerRegisterProvider(IReceiverFormatProvider)
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


ReceiverFormatManager.ShortName Method

ReceiverFormatManagerShortName Method
See interface docs.

Namespace: VirtualRadar.Library.Listener
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ShortName(
    string providerId
)
Public Function ShortName (
    providerId As String
) As String
public:
virtual String^ ShortName(
    String^ providerId
) sealed
abstract ShortName :
        providerId : string -> string
override ShortName :
        providerId : string -> string

Parameters

providerId
Type: SystemString

Return Value

Type: String

Implements

IReceiverFormatManagerShortName(String)
See Also

Reference

ReceiverFormatManager Class
VirtualRadar.Library.Listener Namespace


VirtualRadar.Library.Network Namespace

VirtualRadar.Library.Network Namespace

[Missing <summary> documentation for "N:VirtualRadar.Library.Network"]

Classes
 | Class | Description
Public class | ConnectorActivityLog | The default implementation of IConnectorActivityLog.
Public class | RebroadcastFormatManager | The default implementation of IRebroadcastFormatManager.


ConnectorActivityLog Class

ConnectorActivityLog Class
The default implementation of IConnectorActivityLog.
Inheritance Hierarchy
SystemObject
VirtualRadar.Library.NetworkConnectorActivityLog

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectorActivityLog : IConnectorActivityLog,
    ISingleton<IConnectorActivityLog>
Public Class ConnectorActivityLog
    Implements IConnectorActivityLog, ISingleton(Of IConnectorActivityLog)
public ref class ConnectorActivityLog : IConnectorActivityLog,
    ISingleton<IConnectorActivityLog^>
type ConnectorActivityLog =
    class
        interface IConnectorActivityLog
        interface ISingleton<IConnectorActivityLog>
    end

The ConnectorActivityLog type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorActivityLog | Initializes a new instance of the ConnectorActivityLog class
Top
Properties
 | Name | Description
Public property | Singleton | See interface docs.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveConnectors | See interface docs.
Public method | GetActivityHistory | See interface docs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnActivityRecorded | Raises ActivityRecorded.
Public method | RecordConnectorCreated | See interface docs.
Public method | RecordConnectorDestroyed | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ActivityRecorded | See interface docs.
Top
Fields
Name | Description
MaximumActivities | The largest number of activities recorded by the log.
Top
See Also

Reference

VirtualRadar.Library.Network Namespace


ConnectorActivityLog Constructor

ConnectorActivityLog Constructor
Initializes a new instance of the ConnectorActivityLog class

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorActivityLog()
Public Sub New
public:
ConnectorActivityLog()
new : unit -> ConnectorActivityLog
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog Properties

ConnectorActivityLog Properties

The ConnectorActivityLog type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | See interface docs.
Top
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.Singleton Property

ConnectorActivityLogSingleton Property
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IConnectorActivityLog Singleton { get; }
Public ReadOnly Property Singleton As IConnectorActivityLog
    Get
public:
virtual property IConnectorActivityLog^ Singleton {
    IConnectorActivityLog^ get () sealed;
}
abstract Singleton : IConnectorActivityLog with get
override Singleton : IConnectorActivityLog with get

Property Value

Type: IConnectorActivityLog

Implements

ISingletonTSingleton
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog Methods

ConnectorActivityLog Methods

The ConnectorActivityLog type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveConnectors | See interface docs.
Public method | GetActivityHistory | See interface docs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnActivityRecorded | Raises ActivityRecorded.
Public method | RecordConnectorCreated | See interface docs.
Public method | RecordConnectorDestroyed | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.GetActiveConnectors Method

ConnectorActivityLogGetActiveConnectors Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IConnector[] GetActiveConnectors()
Public Function GetActiveConnectors As IConnector()
public:
virtual array<IConnector^>^ GetActiveConnectors() sealed
abstract GetActiveConnectors : unit -> IConnector[]
override GetActiveConnectors : unit -> IConnector[]

Return Value

Type: IConnector

Implements

IConnectorActivityLogGetActiveConnectors
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.GetActivityHistory Method

ConnectorActivityLogGetActivityHistory Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorActivityEvent[] GetActivityHistory()
Public Function GetActivityHistory As ConnectorActivityEvent()
public:
virtual array<ConnectorActivityEvent^>^ GetActivityHistory() sealed
abstract GetActivityHistory : unit -> ConnectorActivityEvent[]
override GetActivityHistory : unit -> ConnectorActivityEvent[]

Return Value

Type: ConnectorActivityEvent

Implements

IConnectorActivityLogGetActivityHistory
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.OnActivityRecorded Method

ConnectorActivityLogOnActivityRecorded Method
Raises ActivityRecorded.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnActivityRecorded(
    EventArgs<ConnectorActivityEvent> args
)
Protected Overridable Sub OnActivityRecorded (
    args As EventArgs(Of ConnectorActivityEvent)
)
protected:
virtual void OnActivityRecorded(
    EventArgs<ConnectorActivityEvent^>^ args
)
abstract OnActivityRecorded :
        args : EventArgs<ConnectorActivityEvent> -> unit
override OnActivityRecorded :
        args : EventArgs<ConnectorActivityEvent> -> unit

Parameters

args
Type: VirtualRadar.InterfaceEventArgs ConnectorActivityEvent
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.RecordConnectorCreated Method

ConnectorActivityLogRecordConnectorCreated Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RecordConnectorCreated(
    IConnector connector
)
Public Sub RecordConnectorCreated (
    connector As IConnector
)
public:
virtual void RecordConnectorCreated(
    IConnector^ connector
) sealed
abstract RecordConnectorCreated :
        connector : IConnector -> unit
override RecordConnectorCreated :
        connector : IConnector -> unit

Parameters

connector
Type: VirtualRadar.Interface.NetworkIConnector

Implements

IConnectorActivityLogRecordConnectorCreated(IConnector)
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.RecordConnectorDestroyed Method

ConnectorActivityLogRecordConnectorDestroyed Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RecordConnectorDestroyed(
    IConnector connector
)
Public Sub RecordConnectorDestroyed (
    connector As IConnector
)
public:
virtual void RecordConnectorDestroyed(
    IConnector^ connector
) sealed
abstract RecordConnectorDestroyed :
        connector : IConnector -> unit
override RecordConnectorDestroyed :
        connector : IConnector -> unit

Parameters

connector
Type: VirtualRadar.Interface.NetworkIConnector

Implements

IConnectorActivityLogRecordConnectorDestroyed(IConnector)
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog Events

ConnectorActivityLog Events

The ConnectorActivityLog type exposes the following members.

Events
 | Name | Description
Public event | ActivityRecorded | See interface docs.
Top
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.ActivityRecorded Event

ConnectorActivityLogActivityRecorded Event
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs<ConnectorActivityEvent>> ActivityRecorded
Public Event ActivityRecorded As EventHandler(Of EventArgs(Of ConnectorActivityEvent))
public:
virtual  event EventHandler<EventArgs<ConnectorActivityEvent^>^>^ ActivityRecorded {
    void add (EventHandler<EventArgs<ConnectorActivityEvent^>^>^ value);
    void remove (EventHandler<EventArgs<ConnectorActivityEvent^>^>^ value);
}
abstract ActivityRecorded : IEvent<EventHandler<EventArgs<ConnectorActivityEvent>>,
    EventArgs<ConnectorActivityEvent>>
override ActivityRecorded : IEvent<EventHandler<EventArgs<ConnectorActivityEvent>>,
    EventArgs<ConnectorActivityEvent>>

Value

Type: SystemEventHandler EventArgs ConnectorActivityEvent

Implements

IConnectorActivityLogActivityRecorded
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog Fields

ConnectorActivityLog Fields

The ConnectorActivityLog type exposes the following members.

Fields
Name | Description
MaximumActivities | The largest number of activities recorded by the log.
Top
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


ConnectorActivityLog.MaximumActivities Field

ConnectorActivityLogMaximumActivities Field
The largest number of activities recorded by the log.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly int MaximumActivities
Public Shared ReadOnly MaximumActivities As Integer
public:
static initonly int MaximumActivities
static val MaximumActivities: int

Field Value

Type: Int32
See Also

Reference

ConnectorActivityLog Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager Class

RebroadcastFormatManager Class
The default implementation of IRebroadcastFormatManager.
Inheritance Hierarchy
SystemObject
VirtualRadar.Library.NetworkRebroadcastFormatManager

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RebroadcastFormatManager : IRebroadcastFormatManager,
    ISingleton<IRebroadcastFormatManager>
Public Class RebroadcastFormatManager
    Implements IRebroadcastFormatManager, ISingleton(Of IRebroadcastFormatManager)
public ref class RebroadcastFormatManager : IRebroadcastFormatManager,
    ISingleton<IRebroadcastFormatManager^>
type RebroadcastFormatManager =
    class
        interface IRebroadcastFormatManager
        interface ISingleton<IRebroadcastFormatManager>
    end

The RebroadcastFormatManager type exposes the following members.

Constructors
 | Name | Description
Public method | RebroadcastFormatManager | Initializes a new instance of the RebroadcastFormatManager class
Top
Properties
 | Name | Description
Public property | Singleton | See interface docs.
Top
Methods
 | Name | Description
Public method | CreateProvider | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProvider | See interface docs.
Public method | GetRegisteredFormats | See interface docs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialise | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterProvider | See interface docs.
Public method | ShortName | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Library.Network Namespace


RebroadcastFormatManager Constructor

RebroadcastFormatManager Constructor
Initializes a new instance of the RebroadcastFormatManager class

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastFormatManager()
Public Sub New
public:
RebroadcastFormatManager()
new : unit -> RebroadcastFormatManager
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager Properties

RebroadcastFormatManager Properties

The RebroadcastFormatManager type exposes the following members.

Properties
 | Name | Description
Public property | Singleton | See interface docs.
Top
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.Singleton Property

RebroadcastFormatManagerSingleton Property
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRebroadcastFormatManager Singleton { get; }
Public ReadOnly Property Singleton As IRebroadcastFormatManager
    Get
public:
virtual property IRebroadcastFormatManager^ Singleton {
    IRebroadcastFormatManager^ get () sealed;
}
abstract Singleton : IRebroadcastFormatManager with get
override Singleton : IRebroadcastFormatManager with get

Property Value

Type: IRebroadcastFormatManager

Implements

ISingletonTSingleton
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager Methods

RebroadcastFormatManager Methods

The RebroadcastFormatManager type exposes the following members.

Methods
 | Name | Description
Public method | CreateProvider | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProvider | See interface docs.
Public method | GetRegisteredFormats | See interface docs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialise | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegisterProvider | See interface docs.
Public method | ShortName | See interface docs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.CreateProvider Method

RebroadcastFormatManagerCreateProvider Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRebroadcastFormatProvider CreateProvider(
    string providerId
)
Public Function CreateProvider (
    providerId As String
) As IRebroadcastFormatProvider
public:
virtual IRebroadcastFormatProvider^ CreateProvider(
    String^ providerId
) sealed
abstract CreateProvider :
        providerId : string -> IRebroadcastFormatProvider
override CreateProvider :
        providerId : string -> IRebroadcastFormatProvider

Parameters

providerId
Type: SystemString

Return Value

Type: IRebroadcastFormatProvider

Implements

IRebroadcastFormatManagerCreateProvider(String)
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.GetProvider Method

RebroadcastFormatManagerGetProvider Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRebroadcastFormatProvider GetProvider(
    string providerId
)
Public Function GetProvider (
    providerId As String
) As IRebroadcastFormatProvider
public:
virtual IRebroadcastFormatProvider^ GetProvider(
    String^ providerId
) sealed
abstract GetProvider :
        providerId : string -> IRebroadcastFormatProvider
override GetProvider :
        providerId : string -> IRebroadcastFormatProvider

Parameters

providerId
Type: SystemString

Return Value

Type: IRebroadcastFormatProvider

Implements

IRebroadcastFormatManagerGetProvider(String)
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.GetRegisteredFormats Method

RebroadcastFormatManagerGetRegisteredFormats Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastFormatName[] GetRegisteredFormats()
Public Function GetRegisteredFormats As RebroadcastFormatName()
public:
virtual array<RebroadcastFormatName^>^ GetRegisteredFormats() sealed
abstract GetRegisteredFormats : unit -> RebroadcastFormatName[]
override GetRegisteredFormats : unit -> RebroadcastFormatName[]

Return Value

Type: RebroadcastFormatName

Implements

IRebroadcastFormatManagerGetRegisteredFormats
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.Initialise Method

RebroadcastFormatManagerInitialise Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise()
Public Sub Initialise
public:
virtual void Initialise() sealed
abstract Initialise : unit -> unit
override Initialise : unit -> unit

Implements

IRebroadcastFormatManagerInitialise
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.RegisterProvider Method

RebroadcastFormatManagerRegisterProvider Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterProvider(
    IRebroadcastFormatProvider provider
)
Public Sub RegisterProvider (
    provider As IRebroadcastFormatProvider
)
public:
virtual void RegisterProvider(
    IRebroadcastFormatProvider^ provider
) sealed
abstract RegisterProvider :
        provider : IRebroadcastFormatProvider -> unit
override RegisterProvider :
        provider : IRebroadcastFormatProvider -> unit

Parameters

provider
Type: VirtualRadar.Interface.NetworkIRebroadcastFormatProvider

Implements

IRebroadcastFormatManagerRegisterProvider(IRebroadcastFormatProvider)
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


RebroadcastFormatManager.ShortName Method

RebroadcastFormatManagerShortName Method
See interface docs.

Namespace: VirtualRadar.Library.Network
Assembly: VirtualRadar.Library (in VirtualRadar.Library.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ShortName(
    string providerId
)
Public Function ShortName (
    providerId As String
) As String
public:
virtual String^ ShortName(
    String^ providerId
) sealed
abstract ShortName :
        providerId : string -> string
override ShortName :
        providerId : string -> string

Parameters

providerId
Type: SystemString

Return Value

Type: String

Implements

IRebroadcastFormatManagerShortName(String)
See Also

Reference

RebroadcastFormatManager Class
VirtualRadar.Library.Network Namespace


VirtualRadar.Localisation Namespace

VirtualRadar.Localisation Namespace
The namespace that holds static classes for localising content and the tables of localised strings.
Classes
 | Class | Description
Public class | Localise | A static wrapper around an instance of Localiser for the Virtual Radar Server's application strings class.
Public class | LocalisedCategoryAttribute | A localisable version of the ComponentModel CategoryAttribute.
Public class | LocalisedDescriptionAttribute | A localisable version of the ComponentModel DescriptionAttribute.
Public class | LocalisedDisplayNameAttribute | A localisable version of the ComponentModel DisplayNameAttribute.
Public class | LocalisedEnumConverterT | A base for EnumConverters that can translate between an enum and a localised string.
Public class | LocalisedStringsMap | A class that uses reflection to find all of the localised strings we've got set up in a generated string map class.
Public class | Localiser | A class that can localise Windows Forms elements with strings taken from a strings resource file.
Public class | ResourceStrings | A class that can extract strings from a resource for a specific culture info.
Remarks

.NET has a mechanism for localising strings in forms but it does not lend itself to having a centralised set of strings for the entire application that are shared amongst all of the libraries. To make it easier to farm the string table out for translation all of the localised strings were concentrated into this one library and a static class, Localise, was written to perform the localisation of strings on forms. A public class, Localiser, can be used by plugins to perform the same duties for their translations.

If you want to test your alternate cultures you can start Virtual Radar Server at the command line with the -culture switch. For example, to force Virtual Radar Server to use the German culture settings:

VirtualRadar.exe -culture:de-DE


Localise Class

Localise Class
A static wrapper around an instance of Localiser for the Virtual Radar Server's application strings class.
Inheritance Hierarchy
SystemObject
VirtualRadar.LocalisationLocalise

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Localise
Public NotInheritable Class Localise
public ref class Localise abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Localise =  class end

The Localise type exposes the following members.

Methods
Name | Description
ColumnHeader | See ColumnHeader(ColumnHeader).
Control | See Control(Control).
Form | See Form(Form).
GetLocalisedText | See GetLocalisedText(String).
ListViewColumns | See ListViewColumns(ListView).
Lookup | See Lookup(String).
ToolStrip | See ToolStrip(ToolStrip).
ToolStripItem | See ToolStripItem(ToolStripItem).
Top
Fields
Name | Description
VirtualRadarStrings | The localised strings map for the application's strings.
Top
See Also

Reference

VirtualRadar.Localisation Namespace


Localise Methods

Localise Methods

The Localise type exposes the following members.

Methods
Name | Description
ColumnHeader | See ColumnHeader(ColumnHeader).
Control | See Control(Control).
Form | See Form(Form).
GetLocalisedText | See GetLocalisedText(String).
ListViewColumns | See ListViewColumns(ListView).
Lookup | See Lookup(String).
ToolStrip | See ToolStrip(ToolStrip).
ToolStripItem | See ToolStripItem(ToolStripItem).
Top
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.ColumnHeader Method

LocaliseColumnHeader Method
See ColumnHeader(ColumnHeader).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ColumnHeader(
    ColumnHeader column
)
Public Shared Sub ColumnHeader (
    column As ColumnHeader
)
public:
static void ColumnHeader(
    ColumnHeader^ column
)
static member ColumnHeader :
        column : ColumnHeader -> unit

Parameters

column
Type: System.Windows.FormsColumnHeader
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.Control Method

LocaliseControl Method
See Control(Control).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Control(
    Control control
)
Public Shared Sub Control (
    control As Control
)
public:
static void Control(
    Control^ control
)
static member Control :
        control : Control -> unit

Parameters

control
Type: System.Windows.FormsControl
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.Form Method

LocaliseForm Method
See Form(Form).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Form(
    Form form
)
Public Shared Sub Form (
    form As Form
)
public:
static void Form(
    Form^ form
)
static member Form :
        form : Form -> unit

Parameters

form
Type: System.Windows.FormsForm
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.GetLocalisedText Method

LocaliseGetLocalisedText Method
See GetLocalisedText(String).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLocalisedText(
    string text
)
Public Shared Function GetLocalisedText (
    text As String
) As String
public:
static String^ GetLocalisedText(
    String^ text
)
static member GetLocalisedText :
        text : string -> string

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.ListViewColumns Method

LocaliseListViewColumns Method
See ListViewColumns(ListView).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ListViewColumns(
    ListView listView
)
Public Shared Sub ListViewColumns (
    listView As ListView
)
public:
static void ListViewColumns(
    ListView^ listView
)
static member ListViewColumns :
        listView : ListView -> unit

Parameters

listView
Type: System.Windows.FormsListView
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.Lookup Method

LocaliseLookup Method
See Lookup(String).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Lookup(
    string name
)
Public Shared Function Lookup (
    name As String
) As String
public:
static String^ Lookup(
    String^ name
)
static member Lookup :
        name : string -> string

Parameters

name
Type: SystemString

Return Value

Type: String
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.ToolStrip Method

LocaliseToolStrip Method
See ToolStrip(ToolStrip).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ToolStrip(
    ToolStrip toolStrip
)
Public Shared Sub ToolStrip (
    toolStrip As ToolStrip
)
public:
static void ToolStrip(
    ToolStrip^ toolStrip
)
static member ToolStrip :
        toolStrip : ToolStrip -> unit

Parameters

toolStrip
Type: System.Windows.FormsToolStrip
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.ToolStripItem Method

LocaliseToolStripItem Method
See ToolStripItem(ToolStripItem).

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ToolStripItem(
    ToolStripItem item
)
Public Shared Sub ToolStripItem (
    item As ToolStripItem
)
public:
static void ToolStripItem(
    ToolStripItem^ item
)
static member ToolStripItem :
        item : ToolStripItem -> unit

Parameters

item
Type: System.Windows.FormsToolStripItem
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise Fields

Localise Fields

The Localise type exposes the following members.

Fields
Name | Description
VirtualRadarStrings | The localised strings map for the application's strings.
Top
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


Localise.VirtualRadarStrings Field

LocaliseVirtualRadarStrings Field
The localised strings map for the application's strings.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly LocalisedStringsMap VirtualRadarStrings
Public Shared ReadOnly VirtualRadarStrings As LocalisedStringsMap
public:
static initonly LocalisedStringsMap^ VirtualRadarStrings
static val VirtualRadarStrings: LocalisedStringsMap

Field Value

Type: LocalisedStringsMap
See Also

Reference

Localise Class
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute Class

LocalisedCategoryAttribute Class
A localisable version of the ComponentModel CategoryAttribute.
Inheritance Hierarchy
SystemObject
SystemAttribute
System.ComponentModelCategoryAttribute
VirtualRadar.LocalisationLocalisedCategoryAttribute

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocalisedCategoryAttribute : CategoryAttribute
Public Class LocalisedCategoryAttribute
    Inherits CategoryAttribute
public ref class LocalisedCategoryAttribute : public CategoryAttribute
type LocalisedCategoryAttribute =
    class
        inherit CategoryAttribute
    end

The LocalisedCategoryAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LocalisedCategoryAttribute(String) | Creates a new object.
Public method | LocalisedCategoryAttribute(String, Int32, Int32) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Category | Gets the name of the category for the property or event that this attribute is applied to. (Inherited from CategoryAttribute.)
Public property | Prefix | Gets the prefix assigned to the category.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
 | AddLeadingSortText | Adds leading text to the category to force the sort order in a property grid.
Public method | Equals | Returns whether the value of the given object is equal to the current CategoryAttribute.. (Inherited from CategoryAttribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this attribute. (Inherited from CategoryAttribute.)
Protected method | GetLocalizedString | Looks up the localized name of the specified category. (Inherited from CategoryAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Determines if this attribute is the default. (Inherited from CategoryAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute Constructor

LocalisedCategoryAttribute Constructor
Overload List
 | Name | Description
Public method | LocalisedCategoryAttribute(String) | Creates a new object.
Public method | LocalisedCategoryAttribute(String, Int32, Int32) | Creates a new object.
Top
See Also

Reference

LocalisedCategoryAttribute Class
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute Constructor (String)

LocalisedCategoryAttribute Constructor (String)
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedCategoryAttribute(
    string key
)
Public Sub New (
    key As String
)
public:
LocalisedCategoryAttribute(
    String^ key
)
new :
        key : string -> LocalisedCategoryAttribute

Parameters

key
Type: SystemString
The index of the string to look up.
See Also

Reference

LocalisedCategoryAttribute Class
LocalisedCategoryAttribute Overload
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute Constructor (String, Int32, Int32)

LocalisedCategoryAttribute Constructor (String, Int32, Int32)
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedCategoryAttribute(
    string key,
    int displayOrder,
    int totalCategories
)
Public Sub New (
    key As String,
    displayOrder As Integer,
    totalCategories As Integer
)
public:
LocalisedCategoryAttribute(
    String^ key,
    int displayOrder,
    int totalCategories
)
new :
        key : string *
        displayOrder : int *
        totalCategories : int -> LocalisedCategoryAttribute

Parameters

key
Type: SystemString
displayOrder
Type: SystemInt32
totalCategories
Type: SystemInt32
See Also

Reference

LocalisedCategoryAttribute Class
LocalisedCategoryAttribute Overload
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute Properties

LocalisedCategoryAttribute Properties

The LocalisedCategoryAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the name of the category for the property or event that this attribute is applied to. (Inherited from CategoryAttribute.)
Public property | Prefix | Gets the prefix assigned to the category.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

LocalisedCategoryAttribute Class
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute.Prefix Property

LocalisedCategoryAttributePrefix Property
Gets the prefix assigned to the category.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; }
Public ReadOnly Property Prefix As String
    Get
public:
property String^ Prefix {
    String^ get ();
}
member Prefix : string with get

Property Value

Type: String
See Also

Reference

LocalisedCategoryAttribute Class
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute Methods

LocalisedCategoryAttribute Methods

The LocalisedCategoryAttribute type exposes the following members.

Methods
 | Name | Description
 | AddLeadingSortText | Adds leading text to the category to force the sort order in a property grid.
Public method | Equals | Returns whether the value of the given object is equal to the current CategoryAttribute.. (Inherited from CategoryAttribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this attribute. (Inherited from CategoryAttribute.)
Protected method | GetLocalizedString | Looks up the localized name of the specified category. (Inherited from CategoryAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Determines if this attribute is the default. (Inherited from CategoryAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalisedCategoryAttribute Class
VirtualRadar.Localisation Namespace


LocalisedCategoryAttribute.AddLeadingSortText Method

LocalisedCategoryAttributeAddLeadingSortText Method
Adds leading text to the category to force the sort order in a property grid.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AddLeadingSortText(
    string key,
    string prefix
)
Public Shared Function AddLeadingSortText (
    key As String,
    prefix As String
) As String
public:
static String^ AddLeadingSortText(
    String^ key,
    String^ prefix
)
static member AddLeadingSortText :
        key : string *
        prefix : string -> string

Parameters

key
Type: SystemString
prefix
Type: SystemString

Return Value

Type: String
See Also

Reference

LocalisedCategoryAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDescriptionAttribute Class

LocalisedDescriptionAttribute Class
A localisable version of the ComponentModel DescriptionAttribute.
Inheritance Hierarchy
SystemObject
SystemAttribute
System.ComponentModelDescriptionAttribute
VirtualRadar.LocalisationLocalisedDescriptionAttribute

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocalisedDescriptionAttribute : DescriptionAttribute
Public Class LocalisedDescriptionAttribute
    Inherits DescriptionAttribute
public ref class LocalisedDescriptionAttribute : public DescriptionAttribute
type LocalisedDescriptionAttribute =
    class
        inherit DescriptionAttribute
    end

The LocalisedDescriptionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LocalisedDescriptionAttribute | Creates a new object.
Top
Properties
 | Name | Description
Public property | Description | Gets the description stored in this attribute. (Inherited from DescriptionAttribute.)
Protected property | DescriptionValue | Gets or sets the string stored as the description. (Inherited from DescriptionAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns whether the value of the given object is equal to the current DescriptionAttribute. (Inherited from DescriptionAttribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Inherited from DescriptionAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Returns a value indicating whether this is the default DescriptionAttribute instance. (Inherited from DescriptionAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Localisation Namespace


LocalisedDescriptionAttribute Constructor

LocalisedDescriptionAttribute Constructor
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedDescriptionAttribute(
    string key
)
Public Sub New (
    key As String
)
public:
LocalisedDescriptionAttribute(
    String^ key
)
new :
        key : string -> LocalisedDescriptionAttribute

Parameters

key
Type: SystemString
The index of the string to look up.
See Also

Reference

LocalisedDescriptionAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDescriptionAttribute Properties

LocalisedDescriptionAttribute Properties

The LocalisedDescriptionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description stored in this attribute. (Inherited from DescriptionAttribute.)
Protected property | DescriptionValue | Gets or sets the string stored as the description. (Inherited from DescriptionAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

LocalisedDescriptionAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDescriptionAttribute Methods

LocalisedDescriptionAttribute Methods

The LocalisedDescriptionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns whether the value of the given object is equal to the current DescriptionAttribute. (Inherited from DescriptionAttribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Inherited from DescriptionAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Returns a value indicating whether this is the default DescriptionAttribute instance. (Inherited from DescriptionAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalisedDescriptionAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDisplayNameAttribute Class

LocalisedDisplayNameAttribute Class
A localisable version of the ComponentModel DisplayNameAttribute.
Inheritance Hierarchy
SystemObject
SystemAttribute
System.ComponentModelDisplayNameAttribute
VirtualRadar.LocalisationLocalisedDisplayNameAttribute

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocalisedDisplayNameAttribute : DisplayNameAttribute
Public Class LocalisedDisplayNameAttribute
    Inherits DisplayNameAttribute
public ref class LocalisedDisplayNameAttribute : public DisplayNameAttribute
type LocalisedDisplayNameAttribute =
    class
        inherit DisplayNameAttribute
    end

The LocalisedDisplayNameAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LocalisedDisplayNameAttribute | Creates a new object.
Top
Properties
 | Name | Description
Public property | DisplayName | See base docs. (Overrides DisplayNameAttributeDisplayName.)
Protected property | DisplayNameValue | Gets or sets the display name. (Inherited from DisplayNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether two DisplayNameAttribute instances are equal. (Inherited from DisplayNameAttribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForceMonoSortOrder | Adds leading text to the display name to force the correct sort order in property grids.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from DisplayNameAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Determines if this attribute is the default. (Inherited from DisplayNameAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Localisation Namespace


LocalisedDisplayNameAttribute Constructor

LocalisedDisplayNameAttribute Constructor
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedDisplayNameAttribute(
    string key
)
Public Sub New (
    key As String
)
public:
LocalisedDisplayNameAttribute(
    String^ key
)
new :
        key : string -> LocalisedDisplayNameAttribute

Parameters

key
Type: SystemString
The index of the string to look up.
See Also

Reference

LocalisedDisplayNameAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDisplayNameAttribute Properties

LocalisedDisplayNameAttribute Properties

The LocalisedDisplayNameAttribute type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | See base docs. (Overrides DisplayNameAttributeDisplayName.)
Protected property | DisplayNameValue | Gets or sets the display name. (Inherited from DisplayNameAttribute.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

LocalisedDisplayNameAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDisplayNameAttribute.DisplayName Property

LocalisedDisplayNameAttributeDisplayName Property
See base docs.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get
public:
virtual property String^ DisplayName {
    String^ get () override;
}
abstract DisplayName : string with get
override DisplayName : string with get

Property Value

Type: String
See Also

Reference

LocalisedDisplayNameAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDisplayNameAttribute Methods

LocalisedDisplayNameAttribute Methods

The LocalisedDisplayNameAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether two DisplayNameAttribute instances are equal. (Inherited from DisplayNameAttribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForceMonoSortOrder | Adds leading text to the display name to force the correct sort order in property grids.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from DisplayNameAttribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | Determines if this attribute is the default. (Inherited from DisplayNameAttribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalisedDisplayNameAttribute Class
VirtualRadar.Localisation Namespace


LocalisedDisplayNameAttribute.ForceMonoSortOrder Method

LocalisedDisplayNameAttributeForceMonoSortOrder Method
Adds leading text to the display name to force the correct sort order in property grids.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ForceMonoSortOrder(
    string categoryPrefix,
    int displayOrder,
    int totalDisplayItems
)
Public Sub ForceMonoSortOrder (
    categoryPrefix As String,
    displayOrder As Integer,
    totalDisplayItems As Integer
)
public:
void ForceMonoSortOrder(
    String^ categoryPrefix,
    int displayOrder,
    int totalDisplayItems
)
member ForceMonoSortOrder :
        categoryPrefix : string *
        displayOrder : int *
        totalDisplayItems : int -> unit

Parameters

categoryPrefix
Type: SystemString
displayOrder
Type: SystemInt32
totalDisplayItems
Type: SystemInt32
Remarks
The normal method for sorting properties in a grid with PropertySortMode.Category, which is to create a type descriptor for the owning object and call Sort on the PropertyDescriptorCollection it creates, does not work under Mono. This will work for both .NET and Mono.
See Also

Reference

LocalisedDisplayNameAttribute Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T) Class

LocalisedEnumConverterT Class
A base for EnumConverters that can translate between an enum and a localised string.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelEnumConverter
VirtualRadar.LocalisationLocalisedEnumConverterT

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocalisedEnumConverter<T> : EnumConverter

Public Class LocalisedEnumConverter(Of T)
    Inherits EnumConverter
generic<typename T>
public ref class LocalisedEnumConverter : public EnumConverter
type LocalisedEnumConverter<'T> =
    class
        inherit EnumConverter
    end

Type Parameters

T

The LocalisedEnumConverterT type exposes the following members.

Constructors
 | Name | Description
Public method | LocalisedEnumConverterT | Creates a new object.
Top
Properties
 | Name | Description
Protected property | Comparer | Gets an IComparer that can be used to sort the values of the enumeration. (Inherited from EnumConverter.)
Protected property | EnumType | Specifies the type of the enumerator this converter is associated with. (Inherited from EnumConverter.)
Public property | Translations | A map of enum values to localised translations.
Protected property | Values | Gets or sets a TypeConverterStandardValuesCollection that specifies the possible values for the enumeration. (Inherited from EnumConverter.)
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Inherited from EnumConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context. (Inherited from EnumConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Translates from the localised text to the enum value. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Translates from the enum value to the localised text. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Gets a collection of standard values for the data type this validator is designed for. (Inherited from EnumConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context. (Inherited from EnumConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context. (Inherited from EnumConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Gets a value indicating whether the given object value is valid for this type. (Inherited from EnumConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T) Constructor

LocalisedEnumConverterT Constructor
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedEnumConverter()
Public Sub New
public:
LocalisedEnumConverter()
new : unit -> LocalisedEnumConverter
See Also

Reference

LocalisedEnumConverterT Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T) Properties

LocalisedEnumConverterT Properties

The LocalisedEnumConverterT generic type exposes the following members.

Properties
 | Name | Description
Protected property | Comparer | Gets an IComparer that can be used to sort the values of the enumeration. (Inherited from EnumConverter.)
Protected property | EnumType | Specifies the type of the enumerator this converter is associated with. (Inherited from EnumConverter.)
Public property | Translations | A map of enum values to localised translations.
Protected property | Values | Gets or sets a TypeConverterStandardValuesCollection that specifies the possible values for the enumeration. (Inherited from EnumConverter.)
Top
See Also

Reference

LocalisedEnumConverterT Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T).Translations Property

LocalisedEnumConverterTTranslations Property
A map of enum values to localised translations.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<T, string> Translations { get; }
Public ReadOnly Property Translations As Dictionary(Of T, String)
    Get
public:
property Dictionary<T, String^>^ Translations {
    Dictionary<T, String^>^ get ();
}
member Translations : Dictionary<'T, string> with get

Property Value

Type: Dictionary T, String
See Also

Reference

LocalisedEnumConverterT Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T) Methods

LocalisedEnumConverterT Methods

The LocalisedEnumConverterT generic type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Inherited from EnumConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context. (Inherited from EnumConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Translates from the localised text to the enum value. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Translates from the enum value to the localised text. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Gets a collection of standard values for the data type this validator is designed for. (Inherited from EnumConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Gets a value indicating whether the list of standard values returned from GetStandardValues is an exclusive list using the specified context. (Inherited from EnumConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports a standard set of values that can be picked from a list using the specified context. (Inherited from EnumConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Gets a value indicating whether the given object value is valid for this type. (Inherited from EnumConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalisedEnumConverterT Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T).ConvertFrom Method

LocalisedEnumConverterTConvertFrom Method
Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Translates from the localised text to the enum value. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

LocalisedEnumConverterT Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T).ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

LocalisedEnumConverterTConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
Translates from the localised text to the enum value.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
abstract ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
override ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

LocalisedEnumConverterT Class
ConvertFrom Overload
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T).ConvertTo Method

LocalisedEnumConverterTConvertTo Method
Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Translates from the enum value to the localised text. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

LocalisedEnumConverterT Class
VirtualRadar.Localisation Namespace


LocalisedEnumConverter(T).ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

LocalisedEnumConverterTConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
Translates from the enum value to the localised text.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
abstract ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
override ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

LocalisedEnumConverterT Class
ConvertTo Overload
VirtualRadar.Localisation Namespace


LocalisedStringsMap Class

LocalisedStringsMap Class
A class that uses reflection to find all of the localised strings we've got set up in a generated string map class.
Inheritance Hierarchy
SystemObject
VirtualRadar.LocalisationLocalisedStringsMap

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocalisedStringsMap
Public Class LocalisedStringsMap
public ref class LocalisedStringsMap
type LocalisedStringsMap =  class end

The LocalisedStringsMap type exposes the following members.

Constructors
 | Name | Description
Public method | LocalisedStringsMap | Creates a new object.
Top
Methods
 | Name | Description
Public method | AddResourceStrings | Adds the strings from a generated strings resource object to the localised map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedString | Returns the localised string for the name passed across. If there is no such localised string then an exception is thrown.
Public method | GetStringNames | Returns a collection of all of the known string names.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetLocalisedString | Returns the localised string for the name passed across. If there is no such localised string then null is returned.
Top
See Also

Reference

VirtualRadar.Localisation Namespace


LocalisedStringsMap Constructor

LocalisedStringsMap Constructor
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedStringsMap(
    Type stringsType
)
Public Sub New (
    stringsType As Type
)
public:
LocalisedStringsMap(
    Type^ stringsType
)
new :
        stringsType : Type -> LocalisedStringsMap

Parameters

stringsType
Type: SystemType
The type of the generated strings resource object holding all of the strings.
See Also

Reference

LocalisedStringsMap Class
VirtualRadar.Localisation Namespace


LocalisedStringsMap Methods

LocalisedStringsMap Methods

The LocalisedStringsMap type exposes the following members.

Methods
 | Name | Description
Public method | AddResourceStrings | Adds the strings from a generated strings resource object to the localised map.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedString | Returns the localised string for the name passed across. If there is no such localised string then an exception is thrown.
Public method | GetStringNames | Returns a collection of all of the known string names.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetLocalisedString | Returns the localised string for the name passed across. If there is no such localised string then null is returned.
Top
See Also

Reference

LocalisedStringsMap Class
VirtualRadar.Localisation Namespace


LocalisedStringsMap.AddResourceStrings Method

LocalisedStringsMapAddResourceStrings Method
Adds the strings from a generated strings resource object to the localised map.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResourceStrings(
    Type stringsType
)
Public Sub AddResourceStrings (
    stringsType As Type
)
public:
void AddResourceStrings(
    Type^ stringsType
)
member AddResourceStrings :
        stringsType : Type -> unit

Parameters

stringsType
Type: SystemType
See Also

Reference

LocalisedStringsMap Class
VirtualRadar.Localisation Namespace


LocalisedStringsMap.GetLocalisedString Method

LocalisedStringsMapGetLocalisedString Method
Returns the localised string for the name passed across. If there is no such localised string then an exception is thrown.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetLocalisedString(
    string name
)
Public Function GetLocalisedString (
    name As String
) As String
public:
String^ GetLocalisedString(
    String^ name
)
member GetLocalisedString :
        name : string -> string

Parameters

name
Type: SystemString

Return Value

Type: String
See Also

Reference

LocalisedStringsMap Class
VirtualRadar.Localisation Namespace


LocalisedStringsMap.GetStringNames Method

LocalisedStringsMapGetStringNames Method
Returns a collection of all of the known string names.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetStringNames()
Public Function GetStringNames As String()
public:
array<String^>^ GetStringNames()
member GetStringNames : unit -> string[]

Return Value

Type: String
See Also

Reference

LocalisedStringsMap Class
VirtualRadar.Localisation Namespace


LocalisedStringsMap.TryGetLocalisedString Method

LocalisedStringsMapTryGetLocalisedString Method
Returns the localised string for the name passed across. If there is no such localised string then null is returned.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TryGetLocalisedString(
    string name
)
Public Function TryGetLocalisedString (
    name As String
) As String
public:
String^ TryGetLocalisedString(
    String^ name
)
member TryGetLocalisedString :
        name : string -> string

Parameters

name
Type: SystemString

Return Value

Type: String
See Also

Reference

LocalisedStringsMap Class
VirtualRadar.Localisation Namespace


Localiser Class

Localiser Class
A class that can localise Windows Forms elements with strings taken from a strings resource file.
Inheritance Hierarchy
SystemObject
VirtualRadar.LocalisationLocaliser

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Localiser
Public Class Localiser
public ref class Localiser
type Localiser =  class end

The Localiser type exposes the following members.

Constructors
 | Name | Description
Public method | Localiser(Type) | Creates a new object.
Public method | Localiser(LocalisedStringsMap) | Creates a new object.
Top
Methods
 | Name | Description
Public method | AddResourceStrings | Adds strings from a resource file to the localiser.
Public method | ColumnHeader | Localises a column header.
Public method | Control | Localises an arbitrary control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Form | Localises a form's title and then recursively localises all of the controls on the form.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedText | Returns the localised version of the text passed across.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListViewColumns | Localises the columns in a list view.
Public method | Lookup | Returns the localised version of the string identifier passed across.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToolStrip | Localises a toolstrip.
Public method | ToolStripItem | Localises a toolstrip item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

This class can be used by the plugins to translate strings for their UI.

All methods look for elements whose text contains tags delimited by double-colons. Those tags are replaced with strings whose name matches the text within the double-colon. So for example, a Label whose Text property is "::UserName::" would be subsituted with the content of the UserName string. Only chunks within double-colons are substituted.

See Also

Reference

VirtualRadar.Localisation Namespace


Localiser Constructor

Localiser Constructor
Overload List
 | Name | Description
Public method | Localiser(Type) | Creates a new object.
Public method | Localiser(LocalisedStringsMap) | Creates a new object.
Top
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser Constructor (Type)

Localiser Constructor (Type)
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Localiser(
    Type stringsResourceType
)
Public Sub New (
    stringsResourceType As Type
)
public:
Localiser(
    Type^ stringsResourceType
)
new :
        stringsResourceType : Type -> Localiser

Parameters

stringsResourceType
Type: SystemType
The type of the Strings class created by the resource compiler.
See Also

Reference

Localiser Class
Localiser Overload
VirtualRadar.Localisation Namespace


Localiser Constructor (LocalisedStringsMap)

Localiser Constructor (LocalisedStringsMap)
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Localiser(
    LocalisedStringsMap localisedStringsMap
)
Public Sub New (
    localisedStringsMap As LocalisedStringsMap
)
public:
Localiser(
    LocalisedStringsMap^ localisedStringsMap
)
new :
        localisedStringsMap : LocalisedStringsMap -> Localiser

Parameters

localisedStringsMap
Type: VirtualRadar.LocalisationLocalisedStringsMap
The localised strings map to use when looking up strings.
See Also

Reference

Localiser Class
Localiser Overload
VirtualRadar.Localisation Namespace


Localiser Methods

Localiser Methods

The Localiser type exposes the following members.

Methods
 | Name | Description
Public method | AddResourceStrings | Adds strings from a resource file to the localiser.
Public method | ColumnHeader | Localises a column header.
Public method | Control | Localises an arbitrary control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Form | Localises a form's title and then recursively localises all of the controls on the form.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedText | Returns the localised version of the text passed across.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListViewColumns | Localises the columns in a list view.
Public method | Lookup | Returns the localised version of the string identifier passed across.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToolStrip | Localises a toolstrip.
Public method | ToolStripItem | Localises a toolstrip item.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.AddResourceStrings Method

LocaliserAddResourceStrings Method
Adds strings from a resource file to the localiser.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResourceStrings(
    Type stringsResourceType
)
Public Sub AddResourceStrings (
    stringsResourceType As Type
)
public:
void AddResourceStrings(
    Type^ stringsResourceType
)
member AddResourceStrings :
        stringsResourceType : Type -> unit

Parameters

stringsResourceType
Type: SystemType
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.ColumnHeader Method

LocaliserColumnHeader Method
Localises a column header.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ColumnHeader(
    ColumnHeader column
)
Public Sub ColumnHeader (
    column As ColumnHeader
)
public:
void ColumnHeader(
    ColumnHeader^ column
)
member ColumnHeader :
        column : ColumnHeader -> unit

Parameters

column
Type: System.Windows.FormsColumnHeader
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.Control Method

LocaliserControl Method
Localises an arbitrary control.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Control(
    Control control
)
Public Sub Control (
    control As Control
)
public:
void Control(
    Control^ control
)
member Control :
        control : Control -> unit

Parameters

control
Type: System.Windows.FormsControl
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.Form Method

LocaliserForm Method
Localises a form's title and then recursively localises all of the controls on the form.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Form(
    Form form
)
Public Sub Form (
    form As Form
)
public:
void Form(
    Form^ form
)
member Form :
        form : Form -> unit

Parameters

form
Type: System.Windows.FormsForm
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.GetLocalisedText Method

LocaliserGetLocalisedText Method
Returns the localised version of the text passed across.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetLocalisedText(
    string text
)
Public Function GetLocalisedText (
    text As String
) As String
public:
String^ GetLocalisedText(
    String^ text
)
member GetLocalisedText :
        text : string -> string

Parameters

text
Type: SystemString

Return Value

Type: String
Remarks
If the text starts and ends with :: then the inner part is taken to be the name of a string in Strings and it's returned.
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.ListViewColumns Method

LocaliserListViewColumns Method
Localises the columns in a list view.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ListViewColumns(
    ListView listView
)
Public Sub ListViewColumns (
    listView As ListView
)
public:
void ListViewColumns(
    ListView^ listView
)
member ListViewColumns :
        listView : ListView -> unit

Parameters

listView
Type: System.Windows.FormsListView
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.Lookup Method

LocaliserLookup Method
Returns the localised version of the string identifier passed across.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Lookup(
    string name
)
Public Function Lookup (
    name As String
) As String
public:
String^ Lookup(
    String^ name
)
member Lookup :
        name : string -> string

Parameters

name
Type: SystemString

Return Value

Type: String
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.ToolStrip Method

LocaliserToolStrip Method
Localises a toolstrip.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToolStrip(
    ToolStrip toolStrip
)
Public Sub ToolStrip (
    toolStrip As ToolStrip
)
public:
void ToolStrip(
    ToolStrip^ toolStrip
)
member ToolStrip :
        toolStrip : ToolStrip -> unit

Parameters

toolStrip
Type: System.Windows.FormsToolStrip
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


Localiser.ToolStripItem Method

LocaliserToolStripItem Method
Localises a toolstrip item.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToolStripItem(
    ToolStripItem item
)
Public Sub ToolStripItem (
    item As ToolStripItem
)
public:
void ToolStripItem(
    ToolStripItem^ item
)
member ToolStripItem :
        item : ToolStripItem -> unit

Parameters

item
Type: System.Windows.FormsToolStripItem
See Also

Reference

Localiser Class
VirtualRadar.Localisation Namespace


ResourceStrings Class

ResourceStrings Class
A class that can extract strings from a resource for a specific culture info.
Inheritance Hierarchy
SystemObject
VirtualRadar.LocalisationResourceStrings

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ResourceStrings
Public Class ResourceStrings
public ref class ResourceStrings
type ResourceStrings =  class end

The ResourceStrings type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceStrings(Type, CultureInfo) | Creates a new object.
Public method | ResourceStrings(Type, String) | Creates a new object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedString | Returns the localised string for the name passed across.
Public method | GetStringNames | Returns an array of every string name in the map.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetLocalisedString | Tries to get the localised string for the name passed across.
Top
See Also

Reference

VirtualRadar.Localisation Namespace


ResourceStrings Constructor

ResourceStrings Constructor
Overload List
 | Name | Description
Public method | ResourceStrings(Type, CultureInfo) | Creates a new object.
Public method | ResourceStrings(Type, String) | Creates a new object.
Top
See Also

Reference

ResourceStrings Class
VirtualRadar.Localisation Namespace


ResourceStrings Constructor (Type, CultureInfo)

ResourceStrings Constructor (Type, CultureInfo)
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResourceStrings(
    Type resourceSource,
    CultureInfo cultureInfo
)
Public Sub New (
    resourceSource As Type,
    cultureInfo As CultureInfo
)
public:
ResourceStrings(
    Type^ resourceSource,
    CultureInfo^ cultureInfo
)
new :
        resourceSource : Type *
        cultureInfo : CultureInfo -> ResourceStrings

Parameters

resourceSource
Type: SystemType
cultureInfo
Type: System.GlobalizationCultureInfo
See Also

Reference

ResourceStrings Class
ResourceStrings Overload
VirtualRadar.Localisation Namespace


ResourceStrings Constructor (Type, String)

ResourceStrings Constructor (Type, String)
Creates a new object.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResourceStrings(
    Type resourceSource,
    string cultureName
)
Public Sub New (
    resourceSource As Type,
    cultureName As String
)
public:
ResourceStrings(
    Type^ resourceSource,
    String^ cultureName
)
new :
        resourceSource : Type *
        cultureName : string -> ResourceStrings

Parameters

resourceSource
Type: SystemType
cultureName
Type: SystemString
See Also

Reference

ResourceStrings Class
ResourceStrings Overload
VirtualRadar.Localisation Namespace


ResourceStrings Methods

ResourceStrings Methods

The ResourceStrings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedString | Returns the localised string for the name passed across.
Public method | GetStringNames | Returns an array of every string name in the map.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetLocalisedString | Tries to get the localised string for the name passed across.
Top
See Also

Reference

ResourceStrings Class
VirtualRadar.Localisation Namespace


ResourceStrings.GetLocalisedString Method

ResourceStringsGetLocalisedString Method
Returns the localised string for the name passed across.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetLocalisedString(
    string stringName
)
Public Function GetLocalisedString (
    stringName As String
) As String
public:
String^ GetLocalisedString(
    String^ stringName
)
member GetLocalisedString :
        stringName : string -> string

Parameters

stringName
Type: SystemString

Return Value

Type: String
See Also

Reference

ResourceStrings Class
VirtualRadar.Localisation Namespace


ResourceStrings.GetStringNames Method

ResourceStringsGetStringNames Method
Returns an array of every string name in the map.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetStringNames()
Public Function GetStringNames As String()
public:
array<String^>^ GetStringNames()
member GetStringNames : unit -> string[]

Return Value

Type: String
See Also

Reference

ResourceStrings Class
VirtualRadar.Localisation Namespace


ResourceStrings.TryGetLocalisedString Method

ResourceStringsTryGetLocalisedString Method
Tries to get the localised string for the name passed across.

Namespace: VirtualRadar.Localisation
Assembly: VirtualRadar.Localisation (in VirtualRadar.Localisation.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetLocalisedString(
    string stringName,
    out string value
)
Public Function TryGetLocalisedString (
    stringName As String,
    <OutAttribute> ByRef value As String
) As Boolean
public:
bool TryGetLocalisedString(
    String^ stringName,
    [OutAttribute] String^% value
)
member TryGetLocalisedString :
        stringName : string *
        value : string byref -> bool

Parameters

stringName
Type: SystemString
value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ResourceStrings Class
VirtualRadar.Localisation Namespace


VirtualRadar.Resources Namespace

VirtualRadar.Resources Namespace
The namespace that holds common resources for the application.
Classes
 | Class | Description
Public class | BinaryResources | Exposes access to the contents of the resources.
Public class | Images | A static class that exposes all of the images in the common resources.
Remarks

Common images are exposed via the static class Images. Plugins may use that class to modify the images used by the application and the website.


BinaryResources Class

BinaryResources Class
Exposes access to the contents of the resources.
Inheritance Hierarchy
SystemObject
VirtualRadar.ResourcesBinaryResources

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BinaryResources
Public NotInheritable Class BinaryResources
public ref class BinaryResources abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BinaryResources =  class end

The BinaryResources type exposes the following members.

Methods
Name | Description
Copy | Returns a copy of the named resource.
Top
See Also

Reference

VirtualRadar.Resources Namespace


BinaryResources Methods

BinaryResources Methods

The BinaryResources type exposes the following members.

Methods
Name | Description
Copy | Returns a copy of the named resource.
Top
See Also

Reference

BinaryResources Class
VirtualRadar.Resources Namespace


BinaryResources.Copy Method

BinaryResourcesCopy Method
Returns a copy of the named resource.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static byte[] Copy(
    string name
)
Public Shared Function Copy (
    name As String
) As Byte()
public:
static array<unsigned char>^ Copy(
    String^ name
)
static member Copy :
        name : string -> byte[]

Parameters

name
Type: SystemString

Return Value

Type: Byte
See Also

Reference

BinaryResources Class
VirtualRadar.Resources Namespace


Images Class

Images Class
A static class that exposes all of the images in the common resources.
Inheritance Hierarchy
SystemObject
VirtualRadar.ResourcesImages

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Images
Public NotInheritable Class Images
public ref class Images abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Images =  class end

The Images type exposes the following members.

Properties
Name | Description
Add16x16 | Gets or sets the Add16x16 image.
Add16x16_IsCustom | Gets a value indicating whether the Add16x16 image has been customised or not.
Add16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ApplicationIcon | Gets or sets the ApplicationIcon image.
ApplicationIcon_IsCustom | Gets a value indicating whether the ApplicationIcon image has been customised or not.
ApplicationIcon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ArrowBack16x16 | Gets or sets the ArrowBack16x16 image.
ArrowBack16x16_IsCustom | Gets a value indicating whether the ArrowBack16x16 image has been customised or not.
ArrowBack16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ArrowForward16x16 | Gets or sets the ArrowForward16x16 image.
ArrowForward16x16_IsCustom | Gets a value indicating whether the ArrowForward16x16 image has been customised or not.
ArrowForward16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
BlueBall | Gets or sets the BlueBall image.
BlueBall_IsCustom | Gets a value indicating whether the BlueBall image has been customised or not.
BlueBall_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Cancel16x16 | Gets or sets the Cancel16x16 image.
Cancel16x16_IsCustom | Gets a value indicating whether the Cancel16x16 image has been customised or not.
Cancel16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
CancelSmall16x16 | Gets or sets the CancelSmall16x16 image.
CancelSmall16x16_IsCustom | Gets a value indicating whether the CancelSmall16x16 image has been customised or not.
CancelSmall16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ChevronBlueCircle | Gets or sets the ChevronBlueCircle image.
ChevronBlueCircle_IsCustom | Gets a value indicating whether the ChevronBlueCircle image has been customised or not.
ChevronBlueCircle_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ChevronGreenCircle | Gets or sets the ChevronGreenCircle image.
ChevronGreenCircle_IsCustom | Gets a value indicating whether the ChevronGreenCircle image has been customised or not.
ChevronGreenCircle_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ChevronRedCircle | Gets or sets the ChevronRedCircle image.
ChevronRedCircle_IsCustom | Gets a value indicating whether the ChevronRedCircle image has been customised or not.
ChevronRedCircle_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
CloseSlider | Gets or sets the CloseSlider image.
CloseSlider_IsCustom | Gets a value indicating whether the CloseSlider image has been customised or not.
CloseSlider_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Collapse | Gets or sets the Collapse image.
Collapse_IsCustom | Gets a value indicating whether the Collapse image has been customised or not.
Collapse_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Compass | Gets or sets the Compass image.
Compass_IsCustom | Gets a value indicating whether the Compass image has been customised or not.
Compass_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_BottomLeft | Gets or sets the Corner_BottomLeft image.
Corner_BottomLeft_IsCustom | Gets a value indicating whether the Corner_BottomLeft image has been customised or not.
Corner_BottomLeft_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_BottomRight | Gets or sets the Corner_BottomRight image.
Corner_BottomRight_IsCustom | Gets a value indicating whether the Corner_BottomRight image has been customised or not.
Corner_BottomRight_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_TopLeft | Gets or sets the Corner_TopLeft image.
Corner_TopLeft_IsCustom | Gets a value indicating whether the Corner_TopLeft image has been customised or not.
Corner_TopLeft_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_TopRight | Gets or sets the Corner_TopRight image.
Corner_TopRight_IsCustom | Gets a value indicating whether the Corner_TopRight image has been customised or not.
Corner_TopRight_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Crosshair | Gets or sets the Crosshair image.
Crosshair_IsCustom | Gets a value indicating whether the Crosshair image has been customised or not.
Crosshair_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Decoding16x16 | Gets or sets the Decoding16x16 image.
Decoding16x16_IsCustom | Gets a value indicating whether the Decoding16x16 image has been customised or not.
Decoding16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Edit16x16 | Gets or sets the Edit16x16 image.
Edit16x16_IsCustom | Gets a value indicating whether the Edit16x16 image has been customised or not.
Edit16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Expand | Gets or sets the Expand image.
Expand_IsCustom | Gets a value indicating whether the Expand image has been customised or not.
Expand_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Favicon | Gets or sets the Favicon image.
Favicon_IsCustom | Gets a value indicating whether the Favicon image has been customised or not.
Favicon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
FollowMe | Gets or sets the FollowMe image.
FollowMe_IsCustom | Gets a value indicating whether the FollowMe image has been customised or not.
FollowMe_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Gear16x16 | Gets or sets the Gear16x16 image.
Gear16x16_IsCustom | Gets a value indicating whether the Gear16x16 image has been customised or not.
Gear16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
GotoCurrentLocation | Gets or sets the GotoCurrentLocation image.
GotoCurrentLocation_IsCustom | Gets a value indicating whether the GotoCurrentLocation image has been customised or not.
GotoCurrentLocation_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
HelpAbout | Gets or sets the HelpAbout image.
HelpAbout_IsCustom | Gets a value indicating whether the HelpAbout image has been customised or not.
HelpAbout_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
HideList | Gets or sets the HideList image.
HideList_IsCustom | Gets a value indicating whether the HideList image has been customised or not.
HideList_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPadSplash | Gets or sets the IPadSplash image.
IPadSplash_IsCustom | Gets a value indicating whether the IPadSplash image has been customised or not.
IPadSplash_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneBackButton | Gets or sets the IPhoneBackButton image.
IPhoneBackButton_IsCustom | Gets a value indicating whether the IPhoneBackButton image has been customised or not.
IPhoneBackButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneBlueButton | Gets or sets the IPhoneBlueButton image.
IPhoneBlueButton_IsCustom | Gets a value indicating whether the IPhoneBlueButton image has been customised or not.
IPhoneBlueButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneChevron | Gets or sets the IPhoneChevron image.
IPhoneChevron_IsCustom | Gets a value indicating whether the IPhoneChevron image has been customised or not.
IPhoneChevron_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneGrayButton | Gets or sets the IPhoneGrayButton image.
IPhoneGrayButton_IsCustom | Gets a value indicating whether the IPhoneGrayButton image has been customised or not.
IPhoneGrayButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneIcon | Gets or sets the IPhoneIcon image.
IPhoneIcon_IsCustom | Gets a value indicating whether the IPhoneIcon image has been customised or not.
IPhoneIcon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneListGroup | Gets or sets the IPhoneListGroup image.
IPhoneListGroup_IsCustom | Gets a value indicating whether the IPhoneListGroup image has been customised or not.
IPhoneListGroup_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneOnOff | Gets or sets the IPhoneOnOff image.
IPhoneOnOff_IsCustom | Gets a value indicating whether the IPhoneOnOff image has been customised or not.
IPhoneOnOff_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhonePinstripes | Gets or sets the IPhonePinstripes image.
IPhonePinstripes_IsCustom | Gets a value indicating whether the IPhonePinstripes image has been customised or not.
IPhonePinstripes_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneSelectedTick | Gets or sets the IPhoneSelectedTick image.
IPhoneSelectedTick_IsCustom | Gets a value indicating whether the IPhoneSelectedTick image has been customised or not.
IPhoneSelectedTick_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneSelection | Gets or sets the IPhoneSelection image.
IPhoneSelection_IsCustom | Gets a value indicating whether the IPhoneSelection image has been customised or not.
IPhoneSelection_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneSplash | Gets or sets the IPhoneSplash image.
IPhoneSplash_IsCustom | Gets a value indicating whether the IPhoneSplash image has been customised or not.
IPhoneSplash_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneToolbar | Gets or sets the IPhoneToolbar image.
IPhoneToolbar_IsCustom | Gets a value indicating whether the IPhoneToolbar image has been customised or not.
IPhoneToolbar_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneToolButton | Gets or sets the IPhoneToolButton image.
IPhoneToolButton_IsCustom | Gets a value indicating whether the IPhoneToolButton image has been customised or not.
IPhoneToolButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneWhiteButton | Gets or sets the IPhoneWhiteButton image.
IPhoneWhiteButton_IsCustom | Gets a value indicating whether the IPhoneWhiteButton image has been customised or not.
IPhoneWhiteButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Location16x16 | Gets or sets the Location16x16 image.
Location16x16_IsCustom | Gets a value indicating whether the Location16x16 image has been customised or not.
Location16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Logo128x128 | Gets or sets the Logo128x128 image.
Logo128x128_IsCustom | Gets a value indicating whether the Logo128x128 image has been customised or not.
Logo128x128_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Marker_Airplane | Gets or sets the Marker_Airplane image.
Marker_Airplane_IsCustom | Gets a value indicating whether the Marker_Airplane image has been customised or not.
Marker_Airplane_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Marker_AirplaneSelected | Gets or sets the Marker_AirplaneSelected image.
Marker_AirplaneSelected_IsCustom | Gets a value indicating whether the Marker_AirplaneSelected image has been customised or not.
Marker_AirplaneSelected_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
MergedFeed16x16 | Gets or sets the MergedFeed16x16 image.
MergedFeed16x16_IsCustom | Gets a value indicating whether the MergedFeed16x16 image has been customised or not.
MergedFeed16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
MovingMapChecked | Gets or sets the MovingMapChecked image.
MovingMapChecked_IsCustom | Gets a value indicating whether the MovingMapChecked image has been customised or not.
MovingMapChecked_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
MovingMapUnchecked | Gets or sets the MovingMapUnchecked image.
MovingMapUnchecked_IsCustom | Gets a value indicating whether the MovingMapUnchecked image has been customised or not.
MovingMapUnchecked_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Notebook16x16 | Gets or sets the Notebook16x16 image.
Notebook16x16_IsCustom | Gets a value indicating whether the Notebook16x16 image has been customised or not.
Notebook16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
OpenSlider | Gets or sets the OpenSlider image.
OpenSlider_IsCustom | Gets a value indicating whether the OpenSlider image has been customised or not.
OpenSlider_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Radio16x16 | Gets or sets the Radio16x16 image.
Radio16x16_IsCustom | Gets a value indicating whether the Radio16x16 image has been customised or not.
Radio16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Radio48x48 | Gets or sets the Radio48x48 image.
Radio48x48_IsCustom | Gets a value indicating whether the Radio48x48 image has been customised or not.
Radio48x48_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Rebroadcast16x16 | Gets or sets the Rebroadcast16x16 image.
Rebroadcast16x16_IsCustom | Gets a value indicating whether the Rebroadcast16x16 image has been customised or not.
Rebroadcast16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
RowHeader | Gets or sets the RowHeader image.
RowHeader_IsCustom | Gets a value indicating whether the RowHeader image has been customised or not.
RowHeader_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
RowHeaderSelected | Gets or sets the RowHeaderSelected image.
RowHeaderSelected_IsCustom | Gets a value indicating whether the RowHeaderSelected image has been customised or not.
RowHeaderSelected_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Server16x16 | Gets or sets the Server16x16 image.
Server16x16_IsCustom | Gets a value indicating whether the Server16x16 image has been customised or not.
Server16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ShowList | Gets or sets the ShowList image.
ShowList_IsCustom | Gets a value indicating whether the ShowList image has been customised or not.
ShowList_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Site16x16 | Gets or sets the Site16x16 image.
Site16x16_IsCustom | Gets a value indicating whether the Site16x16 image has been customised or not.
Site16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
SmallPlaneNorth | Gets or sets the SmallPlaneNorth image.
SmallPlaneNorth_IsCustom | Gets a value indicating whether the SmallPlaneNorth image has been customised or not.
SmallPlaneNorth_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Test16x16 | Gets or sets the Test16x16 image.
Test16x16_IsCustom | Gets a value indicating whether the Test16x16 image has been customised or not.
Test16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
TestSquare | Gets or sets the TestSquare image.
TestSquare_IsCustom | Gets a value indicating whether the TestSquare image has been customised or not.
TestSquare_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Tower | Gets or sets the Tower image.
Tower_IsCustom | Gets a value indicating whether the Tower image has been customised or not.
Tower_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Transparent_16x16 | Gets or sets the Transparent_16x16 image.
Transparent_16x16_IsCustom | Gets a value indicating whether the Transparent_16x16 image has been customised or not.
Transparent_16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Transparent_25 | Gets or sets the Transparent_25 image.
Transparent_25_IsCustom | Gets a value indicating whether the Transparent_25 image has been customised or not.
Transparent_25_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Transparent_50 | Gets or sets the Transparent_50 image.
Transparent_50_IsCustom | Gets a value indicating whether the Transparent_50 image has been customised or not.
Transparent_50_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
User16x16 | Gets or sets the User16x16 image.
User16x16_IsCustom | Gets a value indicating whether the User16x16 image has been customised or not.
User16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume0 | Gets or sets the Volume0 image.
Volume0_IsCustom | Gets a value indicating whether the Volume0 image has been customised or not.
Volume0_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume100 | Gets or sets the Volume100 image.
Volume100_IsCustom | Gets a value indicating whether the Volume100 image has been customised or not.
Volume100_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume25 | Gets or sets the Volume25 image.
Volume25_IsCustom | Gets a value indicating whether the Volume25 image has been customised or not.
Volume25_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume50 | Gets or sets the Volume50 image.
Volume50_IsCustom | Gets a value indicating whether the Volume50 image has been customised or not.
Volume50_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume75 | Gets or sets the Volume75 image.
Volume75_IsCustom | Gets a value indicating whether the Volume75 image has been customised or not.
Volume75_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
VolumeDown | Gets or sets the VolumeDown image.
VolumeDown_IsCustom | Gets a value indicating whether the VolumeDown image has been customised or not.
VolumeDown_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
VolumeMute | Gets or sets the VolumeMute image.
VolumeMute_IsCustom | Gets a value indicating whether the VolumeMute image has been customised or not.
VolumeMute_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
VolumeUp | Gets or sets the VolumeUp image.
VolumeUp_IsCustom | Gets a value indicating whether the VolumeUp image has been customised or not.
VolumeUp_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
WarningBitmap | Gets or sets the WarningBitmap image.
WarningBitmap_IsCustom | Gets a value indicating whether the WarningBitmap image has been customised or not.
WarningBitmap_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
WarningIcon | Gets or sets the WarningIcon image.
WarningIcon_IsCustom | Gets a value indicating whether the WarningIcon image has been customised or not.
WarningIcon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Wizard16x16 | Gets or sets the Wizard16x16 image.
Wizard16x16_IsCustom | Gets a value indicating whether the Wizard16x16 image has been customised or not.
Wizard16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Top
Methods
Name | Description
Clone_Add16x16 | Creates a copy of Add16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ApplicationIcon | Creates a copy of ApplicationIcon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ArrowBack16x16 | Creates a copy of ArrowBack16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ArrowForward16x16 | Creates a copy of ArrowForward16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_BlueBall | Creates a copy of BlueBall. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Cancel16x16 | Creates a copy of Cancel16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_CancelSmall16x16 | Creates a copy of CancelSmall16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ChevronBlueCircle | Creates a copy of ChevronBlueCircle. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ChevronGreenCircle | Creates a copy of ChevronGreenCircle. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ChevronRedCircle | Creates a copy of ChevronRedCircle. Despite the name this does not use Clone, it creates a fresh copy.
Clone_CloseSlider | Creates a copy of CloseSlider. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Collapse | Creates a copy of Collapse. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Compass | Creates a copy of Compass. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_BottomLeft | Creates a copy of Corner_BottomLeft. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_BottomRight | Creates a copy of Corner_BottomRight. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_TopLeft | Creates a copy of Corner_TopLeft. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_TopRight | Creates a copy of Corner_TopRight. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Crosshair | Creates a copy of Crosshair. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Decoding16x16 | Creates a copy of Decoding16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Edit16x16 | Creates a copy of Edit16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Expand | Creates a copy of Expand. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Favicon | Creates a copy of Favicon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_FollowMe | Creates a copy of FollowMe. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Gear16x16 | Creates a copy of Gear16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_GotoCurrentLocation | Creates a copy of GotoCurrentLocation. Despite the name this does not use Clone, it creates a fresh copy.
Clone_HelpAbout | Creates a copy of HelpAbout. Despite the name this does not use Clone, it creates a fresh copy.
Clone_HideList | Creates a copy of HideList. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPadSplash | Creates a copy of IPadSplash. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneBackButton | Creates a copy of IPhoneBackButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneBlueButton | Creates a copy of IPhoneBlueButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneChevron | Creates a copy of IPhoneChevron. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneGrayButton | Creates a copy of IPhoneGrayButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneIcon | Creates a copy of IPhoneIcon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneListGroup | Creates a copy of IPhoneListGroup. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneOnOff | Creates a copy of IPhoneOnOff. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhonePinstripes | Creates a copy of IPhonePinstripes. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneSelectedTick | Creates a copy of IPhoneSelectedTick. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneSelection | Creates a copy of IPhoneSelection. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneSplash | Creates a copy of IPhoneSplash. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneToolbar | Creates a copy of IPhoneToolbar. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneToolButton | Creates a copy of IPhoneToolButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneWhiteButton | Creates a copy of IPhoneWhiteButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Location16x16 | Creates a copy of Location16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Logo128x128 | Creates a copy of Logo128x128. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Marker_Airplane | Creates a copy of Marker_Airplane. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Marker_AirplaneSelected | Creates a copy of Marker_AirplaneSelected. Despite the name this does not use Clone, it creates a fresh copy.
Clone_MergedFeed16x16 | Creates a copy of MergedFeed16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_MovingMapChecked | Creates a copy of MovingMapChecked. Despite the name this does not use Clone, it creates a fresh copy.
Clone_MovingMapUnchecked | Creates a copy of MovingMapUnchecked. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Notebook16x16 | Creates a copy of Notebook16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_OpenSlider | Creates a copy of OpenSlider. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Radio16x16 | Creates a copy of Radio16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Radio48x48 | Creates a copy of Radio48x48. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Rebroadcast16x16 | Creates a copy of Rebroadcast16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_RowHeader | Creates a copy of RowHeader. Despite the name this does not use Clone, it creates a fresh copy.
Clone_RowHeaderSelected | Creates a copy of RowHeaderSelected. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Server16x16 | Creates a copy of Server16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ShowList | Creates a copy of ShowList. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Site16x16 | Creates a copy of Site16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_SmallPlaneNorth | Creates a copy of SmallPlaneNorth. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Test16x16 | Creates a copy of Test16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_TestSquare | Creates a copy of TestSquare. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Tower | Creates a copy of Tower. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Transparent_16x16 | Creates a copy of Transparent_16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Transparent_25 | Creates a copy of Transparent_25. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Transparent_50 | Creates a copy of Transparent_50. Despite the name this does not use Clone, it creates a fresh copy.
Clone_User16x16 | Creates a copy of User16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume0 | Creates a copy of Volume0. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume100 | Creates a copy of Volume100. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume25 | Creates a copy of Volume25. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume50 | Creates a copy of Volume50. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume75 | Creates a copy of Volume75. Despite the name this does not use Clone, it creates a fresh copy.
Clone_VolumeDown | Creates a copy of VolumeDown. Despite the name this does not use Clone, it creates a fresh copy.
Clone_VolumeMute | Creates a copy of VolumeMute. Despite the name this does not use Clone, it creates a fresh copy.
Clone_VolumeUp | Creates a copy of VolumeUp. Despite the name this does not use Clone, it creates a fresh copy.
Clone_WarningBitmap | Creates a copy of WarningBitmap. Despite the name this does not use Clone, it creates a fresh copy.
Clone_WarningIcon | Creates a copy of WarningIcon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Wizard16x16 | Creates a copy of Wizard16x16. Despite the name this does not use Clone, it creates a fresh copy.
Top
Remarks

These images are read/write properties. The application never writes to the properties but a plugin that wanted to change the graphics used by the application could do so by assigning new images to the appropriate properties of the class. Care should be taken to allow enough room on images that are rotated by the website and to replace existing images with images of the same dimensions and colour depth.

Assigning null to an image resets it back to the default image.

See Also

Reference

VirtualRadar.Resources Namespace


Images Properties

Images Properties

The Images type exposes the following members.

Properties
Name | Description
Add16x16 | Gets or sets the Add16x16 image.
Add16x16_IsCustom | Gets a value indicating whether the Add16x16 image has been customised or not.
Add16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ApplicationIcon | Gets or sets the ApplicationIcon image.
ApplicationIcon_IsCustom | Gets a value indicating whether the ApplicationIcon image has been customised or not.
ApplicationIcon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ArrowBack16x16 | Gets or sets the ArrowBack16x16 image.
ArrowBack16x16_IsCustom | Gets a value indicating whether the ArrowBack16x16 image has been customised or not.
ArrowBack16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ArrowForward16x16 | Gets or sets the ArrowForward16x16 image.
ArrowForward16x16_IsCustom | Gets a value indicating whether the ArrowForward16x16 image has been customised or not.
ArrowForward16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
BlueBall | Gets or sets the BlueBall image.
BlueBall_IsCustom | Gets a value indicating whether the BlueBall image has been customised or not.
BlueBall_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Cancel16x16 | Gets or sets the Cancel16x16 image.
Cancel16x16_IsCustom | Gets a value indicating whether the Cancel16x16 image has been customised or not.
Cancel16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
CancelSmall16x16 | Gets or sets the CancelSmall16x16 image.
CancelSmall16x16_IsCustom | Gets a value indicating whether the CancelSmall16x16 image has been customised or not.
CancelSmall16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ChevronBlueCircle | Gets or sets the ChevronBlueCircle image.
ChevronBlueCircle_IsCustom | Gets a value indicating whether the ChevronBlueCircle image has been customised or not.
ChevronBlueCircle_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ChevronGreenCircle | Gets or sets the ChevronGreenCircle image.
ChevronGreenCircle_IsCustom | Gets a value indicating whether the ChevronGreenCircle image has been customised or not.
ChevronGreenCircle_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ChevronRedCircle | Gets or sets the ChevronRedCircle image.
ChevronRedCircle_IsCustom | Gets a value indicating whether the ChevronRedCircle image has been customised or not.
ChevronRedCircle_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
CloseSlider | Gets or sets the CloseSlider image.
CloseSlider_IsCustom | Gets a value indicating whether the CloseSlider image has been customised or not.
CloseSlider_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Collapse | Gets or sets the Collapse image.
Collapse_IsCustom | Gets a value indicating whether the Collapse image has been customised or not.
Collapse_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Compass | Gets or sets the Compass image.
Compass_IsCustom | Gets a value indicating whether the Compass image has been customised or not.
Compass_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_BottomLeft | Gets or sets the Corner_BottomLeft image.
Corner_BottomLeft_IsCustom | Gets a value indicating whether the Corner_BottomLeft image has been customised or not.
Corner_BottomLeft_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_BottomRight | Gets or sets the Corner_BottomRight image.
Corner_BottomRight_IsCustom | Gets a value indicating whether the Corner_BottomRight image has been customised or not.
Corner_BottomRight_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_TopLeft | Gets or sets the Corner_TopLeft image.
Corner_TopLeft_IsCustom | Gets a value indicating whether the Corner_TopLeft image has been customised or not.
Corner_TopLeft_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Corner_TopRight | Gets or sets the Corner_TopRight image.
Corner_TopRight_IsCustom | Gets a value indicating whether the Corner_TopRight image has been customised or not.
Corner_TopRight_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Crosshair | Gets or sets the Crosshair image.
Crosshair_IsCustom | Gets a value indicating whether the Crosshair image has been customised or not.
Crosshair_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Decoding16x16 | Gets or sets the Decoding16x16 image.
Decoding16x16_IsCustom | Gets a value indicating whether the Decoding16x16 image has been customised or not.
Decoding16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Edit16x16 | Gets or sets the Edit16x16 image.
Edit16x16_IsCustom | Gets a value indicating whether the Edit16x16 image has been customised or not.
Edit16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Expand | Gets or sets the Expand image.
Expand_IsCustom | Gets a value indicating whether the Expand image has been customised or not.
Expand_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Favicon | Gets or sets the Favicon image.
Favicon_IsCustom | Gets a value indicating whether the Favicon image has been customised or not.
Favicon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
FollowMe | Gets or sets the FollowMe image.
FollowMe_IsCustom | Gets a value indicating whether the FollowMe image has been customised or not.
FollowMe_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Gear16x16 | Gets or sets the Gear16x16 image.
Gear16x16_IsCustom | Gets a value indicating whether the Gear16x16 image has been customised or not.
Gear16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
GotoCurrentLocation | Gets or sets the GotoCurrentLocation image.
GotoCurrentLocation_IsCustom | Gets a value indicating whether the GotoCurrentLocation image has been customised or not.
GotoCurrentLocation_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
HelpAbout | Gets or sets the HelpAbout image.
HelpAbout_IsCustom | Gets a value indicating whether the HelpAbout image has been customised or not.
HelpAbout_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
HideList | Gets or sets the HideList image.
HideList_IsCustom | Gets a value indicating whether the HideList image has been customised or not.
HideList_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPadSplash | Gets or sets the IPadSplash image.
IPadSplash_IsCustom | Gets a value indicating whether the IPadSplash image has been customised or not.
IPadSplash_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneBackButton | Gets or sets the IPhoneBackButton image.
IPhoneBackButton_IsCustom | Gets a value indicating whether the IPhoneBackButton image has been customised or not.
IPhoneBackButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneBlueButton | Gets or sets the IPhoneBlueButton image.
IPhoneBlueButton_IsCustom | Gets a value indicating whether the IPhoneBlueButton image has been customised or not.
IPhoneBlueButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneChevron | Gets or sets the IPhoneChevron image.
IPhoneChevron_IsCustom | Gets a value indicating whether the IPhoneChevron image has been customised or not.
IPhoneChevron_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneGrayButton | Gets or sets the IPhoneGrayButton image.
IPhoneGrayButton_IsCustom | Gets a value indicating whether the IPhoneGrayButton image has been customised or not.
IPhoneGrayButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneIcon | Gets or sets the IPhoneIcon image.
IPhoneIcon_IsCustom | Gets a value indicating whether the IPhoneIcon image has been customised or not.
IPhoneIcon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneListGroup | Gets or sets the IPhoneListGroup image.
IPhoneListGroup_IsCustom | Gets a value indicating whether the IPhoneListGroup image has been customised or not.
IPhoneListGroup_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneOnOff | Gets or sets the IPhoneOnOff image.
IPhoneOnOff_IsCustom | Gets a value indicating whether the IPhoneOnOff image has been customised or not.
IPhoneOnOff_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhonePinstripes | Gets or sets the IPhonePinstripes image.
IPhonePinstripes_IsCustom | Gets a value indicating whether the IPhonePinstripes image has been customised or not.
IPhonePinstripes_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneSelectedTick | Gets or sets the IPhoneSelectedTick image.
IPhoneSelectedTick_IsCustom | Gets a value indicating whether the IPhoneSelectedTick image has been customised or not.
IPhoneSelectedTick_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneSelection | Gets or sets the IPhoneSelection image.
IPhoneSelection_IsCustom | Gets a value indicating whether the IPhoneSelection image has been customised or not.
IPhoneSelection_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneSplash | Gets or sets the IPhoneSplash image.
IPhoneSplash_IsCustom | Gets a value indicating whether the IPhoneSplash image has been customised or not.
IPhoneSplash_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneToolbar | Gets or sets the IPhoneToolbar image.
IPhoneToolbar_IsCustom | Gets a value indicating whether the IPhoneToolbar image has been customised or not.
IPhoneToolbar_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneToolButton | Gets or sets the IPhoneToolButton image.
IPhoneToolButton_IsCustom | Gets a value indicating whether the IPhoneToolButton image has been customised or not.
IPhoneToolButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
IPhoneWhiteButton | Gets or sets the IPhoneWhiteButton image.
IPhoneWhiteButton_IsCustom | Gets a value indicating whether the IPhoneWhiteButton image has been customised or not.
IPhoneWhiteButton_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Location16x16 | Gets or sets the Location16x16 image.
Location16x16_IsCustom | Gets a value indicating whether the Location16x16 image has been customised or not.
Location16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Logo128x128 | Gets or sets the Logo128x128 image.
Logo128x128_IsCustom | Gets a value indicating whether the Logo128x128 image has been customised or not.
Logo128x128_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Marker_Airplane | Gets or sets the Marker_Airplane image.
Marker_Airplane_IsCustom | Gets a value indicating whether the Marker_Airplane image has been customised or not.
Marker_Airplane_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Marker_AirplaneSelected | Gets or sets the Marker_AirplaneSelected image.
Marker_AirplaneSelected_IsCustom | Gets a value indicating whether the Marker_AirplaneSelected image has been customised or not.
Marker_AirplaneSelected_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
MergedFeed16x16 | Gets or sets the MergedFeed16x16 image.
MergedFeed16x16_IsCustom | Gets a value indicating whether the MergedFeed16x16 image has been customised or not.
MergedFeed16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
MovingMapChecked | Gets or sets the MovingMapChecked image.
MovingMapChecked_IsCustom | Gets a value indicating whether the MovingMapChecked image has been customised or not.
MovingMapChecked_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
MovingMapUnchecked | Gets or sets the MovingMapUnchecked image.
MovingMapUnchecked_IsCustom | Gets a value indicating whether the MovingMapUnchecked image has been customised or not.
MovingMapUnchecked_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Notebook16x16 | Gets or sets the Notebook16x16 image.
Notebook16x16_IsCustom | Gets a value indicating whether the Notebook16x16 image has been customised or not.
Notebook16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
OpenSlider | Gets or sets the OpenSlider image.
OpenSlider_IsCustom | Gets a value indicating whether the OpenSlider image has been customised or not.
OpenSlider_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Radio16x16 | Gets or sets the Radio16x16 image.
Radio16x16_IsCustom | Gets a value indicating whether the Radio16x16 image has been customised or not.
Radio16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Radio48x48 | Gets or sets the Radio48x48 image.
Radio48x48_IsCustom | Gets a value indicating whether the Radio48x48 image has been customised or not.
Radio48x48_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Rebroadcast16x16 | Gets or sets the Rebroadcast16x16 image.
Rebroadcast16x16_IsCustom | Gets a value indicating whether the Rebroadcast16x16 image has been customised or not.
Rebroadcast16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
RowHeader | Gets or sets the RowHeader image.
RowHeader_IsCustom | Gets a value indicating whether the RowHeader image has been customised or not.
RowHeader_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
RowHeaderSelected | Gets or sets the RowHeaderSelected image.
RowHeaderSelected_IsCustom | Gets a value indicating whether the RowHeaderSelected image has been customised or not.
RowHeaderSelected_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Server16x16 | Gets or sets the Server16x16 image.
Server16x16_IsCustom | Gets a value indicating whether the Server16x16 image has been customised or not.
Server16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
ShowList | Gets or sets the ShowList image.
ShowList_IsCustom | Gets a value indicating whether the ShowList image has been customised or not.
ShowList_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Site16x16 | Gets or sets the Site16x16 image.
Site16x16_IsCustom | Gets a value indicating whether the Site16x16 image has been customised or not.
Site16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
SmallPlaneNorth | Gets or sets the SmallPlaneNorth image.
SmallPlaneNorth_IsCustom | Gets a value indicating whether the SmallPlaneNorth image has been customised or not.
SmallPlaneNorth_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Test16x16 | Gets or sets the Test16x16 image.
Test16x16_IsCustom | Gets a value indicating whether the Test16x16 image has been customised or not.
Test16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
TestSquare | Gets or sets the TestSquare image.
TestSquare_IsCustom | Gets a value indicating whether the TestSquare image has been customised or not.
TestSquare_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Tower | Gets or sets the Tower image.
Tower_IsCustom | Gets a value indicating whether the Tower image has been customised or not.
Tower_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Transparent_16x16 | Gets or sets the Transparent_16x16 image.
Transparent_16x16_IsCustom | Gets a value indicating whether the Transparent_16x16 image has been customised or not.
Transparent_16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Transparent_25 | Gets or sets the Transparent_25 image.
Transparent_25_IsCustom | Gets a value indicating whether the Transparent_25 image has been customised or not.
Transparent_25_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Transparent_50 | Gets or sets the Transparent_50 image.
Transparent_50_IsCustom | Gets a value indicating whether the Transparent_50 image has been customised or not.
Transparent_50_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
User16x16 | Gets or sets the User16x16 image.
User16x16_IsCustom | Gets a value indicating whether the User16x16 image has been customised or not.
User16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume0 | Gets or sets the Volume0 image.
Volume0_IsCustom | Gets a value indicating whether the Volume0 image has been customised or not.
Volume0_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume100 | Gets or sets the Volume100 image.
Volume100_IsCustom | Gets a value indicating whether the Volume100 image has been customised or not.
Volume100_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume25 | Gets or sets the Volume25 image.
Volume25_IsCustom | Gets a value indicating whether the Volume25 image has been customised or not.
Volume25_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume50 | Gets or sets the Volume50 image.
Volume50_IsCustom | Gets a value indicating whether the Volume50 image has been customised or not.
Volume50_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Volume75 | Gets or sets the Volume75 image.
Volume75_IsCustom | Gets a value indicating whether the Volume75 image has been customised or not.
Volume75_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
VolumeDown | Gets or sets the VolumeDown image.
VolumeDown_IsCustom | Gets a value indicating whether the VolumeDown image has been customised or not.
VolumeDown_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
VolumeMute | Gets or sets the VolumeMute image.
VolumeMute_IsCustom | Gets a value indicating whether the VolumeMute image has been customised or not.
VolumeMute_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
VolumeUp | Gets or sets the VolumeUp image.
VolumeUp_IsCustom | Gets a value indicating whether the VolumeUp image has been customised or not.
VolumeUp_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
WarningBitmap | Gets or sets the WarningBitmap image.
WarningBitmap_IsCustom | Gets a value indicating whether the WarningBitmap image has been customised or not.
WarningBitmap_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
WarningIcon | Gets or sets the WarningIcon image.
WarningIcon_IsCustom | Gets a value indicating whether the WarningIcon image has been customised or not.
WarningIcon_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Wizard16x16 | Gets or sets the Wizard16x16 image.
Wizard16x16_IsCustom | Gets a value indicating whether the Wizard16x16 image has been customised or not.
Wizard16x16_SyncLock | Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.
Top
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Add16x16 Property

ImagesAdd16x16 Property
Gets or sets the Add16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Add16x16 { get; set; }
Public Shared Property Add16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Add16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Add16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Add16x16_IsCustom Property

ImagesAdd16x16_IsCustom Property
Gets a value indicating whether the Add16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Add16x16_IsCustom { get; }
Public Shared ReadOnly Property Add16x16_IsCustom As Boolean
    Get
public:
static property bool Add16x16_IsCustom {
    bool get ();
}
static member Add16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Add16x16_SyncLock Property

ImagesAdd16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Add16x16_SyncLock { get; }
Public Shared ReadOnly Property Add16x16_SyncLock As Object
    Get
public:
static property Object^ Add16x16_SyncLock {
    Object^ get ();
}
static member Add16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Add16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ApplicationIcon Property

ImagesApplicationIcon Property
Gets or sets the ApplicationIcon image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Icon ApplicationIcon { get; set; }
Public Shared Property ApplicationIcon As Icon
    Get
    Set
public:
static property Icon^ ApplicationIcon {
    Icon^ get ();
    void set (Icon^ value);
}
static member ApplicationIcon : Icon with get, set

Property Value

Type: Icon
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ApplicationIcon_IsCustom Property

ImagesApplicationIcon_IsCustom Property
Gets a value indicating whether the ApplicationIcon image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ApplicationIcon_IsCustom { get; }
Public Shared ReadOnly Property ApplicationIcon_IsCustom As Boolean
    Get
public:
static property bool ApplicationIcon_IsCustom {
    bool get ();
}
static member ApplicationIcon_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ApplicationIcon_SyncLock Property

ImagesApplicationIcon_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ApplicationIcon_SyncLock { get; }
Public Shared ReadOnly Property ApplicationIcon_SyncLock As Object
    Get
public:
static property Object^ ApplicationIcon_SyncLock {
    Object^ get ();
}
static member ApplicationIcon_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ApplicationIcon to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ArrowBack16x16 Property

ImagesArrowBack16x16 Property
Gets or sets the ArrowBack16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ArrowBack16x16 { get; set; }
Public Shared Property ArrowBack16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ ArrowBack16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member ArrowBack16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ArrowBack16x16_IsCustom Property

ImagesArrowBack16x16_IsCustom Property
Gets a value indicating whether the ArrowBack16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ArrowBack16x16_IsCustom { get; }
Public Shared ReadOnly Property ArrowBack16x16_IsCustom As Boolean
    Get
public:
static property bool ArrowBack16x16_IsCustom {
    bool get ();
}
static member ArrowBack16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ArrowBack16x16_SyncLock Property

ImagesArrowBack16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ArrowBack16x16_SyncLock { get; }
Public Shared ReadOnly Property ArrowBack16x16_SyncLock As Object
    Get
public:
static property Object^ ArrowBack16x16_SyncLock {
    Object^ get ();
}
static member ArrowBack16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ArrowBack16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ArrowForward16x16 Property

ImagesArrowForward16x16 Property
Gets or sets the ArrowForward16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ArrowForward16x16 { get; set; }
Public Shared Property ArrowForward16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ ArrowForward16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member ArrowForward16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ArrowForward16x16_IsCustom Property

ImagesArrowForward16x16_IsCustom Property
Gets a value indicating whether the ArrowForward16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ArrowForward16x16_IsCustom { get; }
Public Shared ReadOnly Property ArrowForward16x16_IsCustom As Boolean
    Get
public:
static property bool ArrowForward16x16_IsCustom {
    bool get ();
}
static member ArrowForward16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ArrowForward16x16_SyncLock Property

ImagesArrowForward16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ArrowForward16x16_SyncLock { get; }
Public Shared ReadOnly Property ArrowForward16x16_SyncLock As Object
    Get
public:
static property Object^ ArrowForward16x16_SyncLock {
    Object^ get ();
}
static member ArrowForward16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ArrowForward16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.BlueBall Property

ImagesBlueBall Property
Gets or sets the BlueBall image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap BlueBall { get; set; }
Public Shared Property BlueBall As Bitmap
    Get
    Set
public:
static property Bitmap^ BlueBall {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member BlueBall : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.BlueBall_IsCustom Property

ImagesBlueBall_IsCustom Property
Gets a value indicating whether the BlueBall image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool BlueBall_IsCustom { get; }
Public Shared ReadOnly Property BlueBall_IsCustom As Boolean
    Get
public:
static property bool BlueBall_IsCustom {
    bool get ();
}
static member BlueBall_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.BlueBall_SyncLock Property

ImagesBlueBall_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object BlueBall_SyncLock { get; }
Public Shared ReadOnly Property BlueBall_SyncLock As Object
    Get
public:
static property Object^ BlueBall_SyncLock {
    Object^ get ();
}
static member BlueBall_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call BlueBall to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Cancel16x16 Property

ImagesCancel16x16 Property
Gets or sets the Cancel16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Cancel16x16 { get; set; }
Public Shared Property Cancel16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Cancel16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Cancel16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Cancel16x16_IsCustom Property

ImagesCancel16x16_IsCustom Property
Gets a value indicating whether the Cancel16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Cancel16x16_IsCustom { get; }
Public Shared ReadOnly Property Cancel16x16_IsCustom As Boolean
    Get
public:
static property bool Cancel16x16_IsCustom {
    bool get ();
}
static member Cancel16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Cancel16x16_SyncLock Property

ImagesCancel16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Cancel16x16_SyncLock { get; }
Public Shared ReadOnly Property Cancel16x16_SyncLock As Object
    Get
public:
static property Object^ Cancel16x16_SyncLock {
    Object^ get ();
}
static member Cancel16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Cancel16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.CancelSmall16x16 Property

ImagesCancelSmall16x16 Property
Gets or sets the CancelSmall16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap CancelSmall16x16 { get; set; }
Public Shared Property CancelSmall16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ CancelSmall16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member CancelSmall16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.CancelSmall16x16_IsCustom Property

ImagesCancelSmall16x16_IsCustom Property
Gets a value indicating whether the CancelSmall16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CancelSmall16x16_IsCustom { get; }
Public Shared ReadOnly Property CancelSmall16x16_IsCustom As Boolean
    Get
public:
static property bool CancelSmall16x16_IsCustom {
    bool get ();
}
static member CancelSmall16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.CancelSmall16x16_SyncLock Property

ImagesCancelSmall16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object CancelSmall16x16_SyncLock { get; }
Public Shared ReadOnly Property CancelSmall16x16_SyncLock As Object
    Get
public:
static property Object^ CancelSmall16x16_SyncLock {
    Object^ get ();
}
static member CancelSmall16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call CancelSmall16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronBlueCircle Property

ImagesChevronBlueCircle Property
Gets or sets the ChevronBlueCircle image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ChevronBlueCircle { get; set; }
Public Shared Property ChevronBlueCircle As Bitmap
    Get
    Set
public:
static property Bitmap^ ChevronBlueCircle {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member ChevronBlueCircle : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronBlueCircle_IsCustom Property

ImagesChevronBlueCircle_IsCustom Property
Gets a value indicating whether the ChevronBlueCircle image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ChevronBlueCircle_IsCustom { get; }
Public Shared ReadOnly Property ChevronBlueCircle_IsCustom As Boolean
    Get
public:
static property bool ChevronBlueCircle_IsCustom {
    bool get ();
}
static member ChevronBlueCircle_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronBlueCircle_SyncLock Property

ImagesChevronBlueCircle_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ChevronBlueCircle_SyncLock { get; }
Public Shared ReadOnly Property ChevronBlueCircle_SyncLock As Object
    Get
public:
static property Object^ ChevronBlueCircle_SyncLock {
    Object^ get ();
}
static member ChevronBlueCircle_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ChevronBlueCircle to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronGreenCircle Property

ImagesChevronGreenCircle Property
Gets or sets the ChevronGreenCircle image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ChevronGreenCircle { get; set; }
Public Shared Property ChevronGreenCircle As Bitmap
    Get
    Set
public:
static property Bitmap^ ChevronGreenCircle {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member ChevronGreenCircle : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronGreenCircle_IsCustom Property

ImagesChevronGreenCircle_IsCustom Property
Gets a value indicating whether the ChevronGreenCircle image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ChevronGreenCircle_IsCustom { get; }
Public Shared ReadOnly Property ChevronGreenCircle_IsCustom As Boolean
    Get
public:
static property bool ChevronGreenCircle_IsCustom {
    bool get ();
}
static member ChevronGreenCircle_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronGreenCircle_SyncLock Property

ImagesChevronGreenCircle_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ChevronGreenCircle_SyncLock { get; }
Public Shared ReadOnly Property ChevronGreenCircle_SyncLock As Object
    Get
public:
static property Object^ ChevronGreenCircle_SyncLock {
    Object^ get ();
}
static member ChevronGreenCircle_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ChevronGreenCircle to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronRedCircle Property

ImagesChevronRedCircle Property
Gets or sets the ChevronRedCircle image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ChevronRedCircle { get; set; }
Public Shared Property ChevronRedCircle As Bitmap
    Get
    Set
public:
static property Bitmap^ ChevronRedCircle {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member ChevronRedCircle : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronRedCircle_IsCustom Property

ImagesChevronRedCircle_IsCustom Property
Gets a value indicating whether the ChevronRedCircle image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ChevronRedCircle_IsCustom { get; }
Public Shared ReadOnly Property ChevronRedCircle_IsCustom As Boolean
    Get
public:
static property bool ChevronRedCircle_IsCustom {
    bool get ();
}
static member ChevronRedCircle_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ChevronRedCircle_SyncLock Property

ImagesChevronRedCircle_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ChevronRedCircle_SyncLock { get; }
Public Shared ReadOnly Property ChevronRedCircle_SyncLock As Object
    Get
public:
static property Object^ ChevronRedCircle_SyncLock {
    Object^ get ();
}
static member ChevronRedCircle_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ChevronRedCircle to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.CloseSlider Property

ImagesCloseSlider Property
Gets or sets the CloseSlider image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap CloseSlider { get; set; }
Public Shared Property CloseSlider As Bitmap
    Get
    Set
public:
static property Bitmap^ CloseSlider {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member CloseSlider : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.CloseSlider_IsCustom Property

ImagesCloseSlider_IsCustom Property
Gets a value indicating whether the CloseSlider image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CloseSlider_IsCustom { get; }
Public Shared ReadOnly Property CloseSlider_IsCustom As Boolean
    Get
public:
static property bool CloseSlider_IsCustom {
    bool get ();
}
static member CloseSlider_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.CloseSlider_SyncLock Property

ImagesCloseSlider_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object CloseSlider_SyncLock { get; }
Public Shared ReadOnly Property CloseSlider_SyncLock As Object
    Get
public:
static property Object^ CloseSlider_SyncLock {
    Object^ get ();
}
static member CloseSlider_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call CloseSlider to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Collapse Property

ImagesCollapse Property
Gets or sets the Collapse image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Collapse { get; set; }
Public Shared Property Collapse As Bitmap
    Get
    Set
public:
static property Bitmap^ Collapse {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Collapse : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Collapse_IsCustom Property

ImagesCollapse_IsCustom Property
Gets a value indicating whether the Collapse image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Collapse_IsCustom { get; }
Public Shared ReadOnly Property Collapse_IsCustom As Boolean
    Get
public:
static property bool Collapse_IsCustom {
    bool get ();
}
static member Collapse_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Collapse_SyncLock Property

ImagesCollapse_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Collapse_SyncLock { get; }
Public Shared ReadOnly Property Collapse_SyncLock As Object
    Get
public:
static property Object^ Collapse_SyncLock {
    Object^ get ();
}
static member Collapse_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Collapse to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Compass Property

ImagesCompass Property
Gets or sets the Compass image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Compass { get; set; }
Public Shared Property Compass As Bitmap
    Get
    Set
public:
static property Bitmap^ Compass {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Compass : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Compass_IsCustom Property

ImagesCompass_IsCustom Property
Gets a value indicating whether the Compass image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Compass_IsCustom { get; }
Public Shared ReadOnly Property Compass_IsCustom As Boolean
    Get
public:
static property bool Compass_IsCustom {
    bool get ();
}
static member Compass_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Compass_SyncLock Property

ImagesCompass_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Compass_SyncLock { get; }
Public Shared ReadOnly Property Compass_SyncLock As Object
    Get
public:
static property Object^ Compass_SyncLock {
    Object^ get ();
}
static member Compass_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Compass to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_BottomLeft Property

ImagesCorner_BottomLeft Property
Gets or sets the Corner_BottomLeft image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Corner_BottomLeft { get; set; }
Public Shared Property Corner_BottomLeft As Bitmap
    Get
    Set
public:
static property Bitmap^ Corner_BottomLeft {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Corner_BottomLeft : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_BottomLeft_IsCustom Property

ImagesCorner_BottomLeft_IsCustom Property
Gets a value indicating whether the Corner_BottomLeft image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Corner_BottomLeft_IsCustom { get; }
Public Shared ReadOnly Property Corner_BottomLeft_IsCustom As Boolean
    Get
public:
static property bool Corner_BottomLeft_IsCustom {
    bool get ();
}
static member Corner_BottomLeft_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_BottomLeft_SyncLock Property

ImagesCorner_BottomLeft_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Corner_BottomLeft_SyncLock { get; }
Public Shared ReadOnly Property Corner_BottomLeft_SyncLock As Object
    Get
public:
static property Object^ Corner_BottomLeft_SyncLock {
    Object^ get ();
}
static member Corner_BottomLeft_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Corner_BottomLeft to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_BottomRight Property

ImagesCorner_BottomRight Property
Gets or sets the Corner_BottomRight image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Corner_BottomRight { get; set; }
Public Shared Property Corner_BottomRight As Bitmap
    Get
    Set
public:
static property Bitmap^ Corner_BottomRight {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Corner_BottomRight : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_BottomRight_IsCustom Property

ImagesCorner_BottomRight_IsCustom Property
Gets a value indicating whether the Corner_BottomRight image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Corner_BottomRight_IsCustom { get; }
Public Shared ReadOnly Property Corner_BottomRight_IsCustom As Boolean
    Get
public:
static property bool Corner_BottomRight_IsCustom {
    bool get ();
}
static member Corner_BottomRight_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_BottomRight_SyncLock Property

ImagesCorner_BottomRight_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Corner_BottomRight_SyncLock { get; }
Public Shared ReadOnly Property Corner_BottomRight_SyncLock As Object
    Get
public:
static property Object^ Corner_BottomRight_SyncLock {
    Object^ get ();
}
static member Corner_BottomRight_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Corner_BottomRight to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_TopLeft Property

ImagesCorner_TopLeft Property
Gets or sets the Corner_TopLeft image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Corner_TopLeft { get; set; }
Public Shared Property Corner_TopLeft As Bitmap
    Get
    Set
public:
static property Bitmap^ Corner_TopLeft {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Corner_TopLeft : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_TopLeft_IsCustom Property

ImagesCorner_TopLeft_IsCustom Property
Gets a value indicating whether the Corner_TopLeft image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Corner_TopLeft_IsCustom { get; }
Public Shared ReadOnly Property Corner_TopLeft_IsCustom As Boolean
    Get
public:
static property bool Corner_TopLeft_IsCustom {
    bool get ();
}
static member Corner_TopLeft_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_TopLeft_SyncLock Property

ImagesCorner_TopLeft_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Corner_TopLeft_SyncLock { get; }
Public Shared ReadOnly Property Corner_TopLeft_SyncLock As Object
    Get
public:
static property Object^ Corner_TopLeft_SyncLock {
    Object^ get ();
}
static member Corner_TopLeft_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Corner_TopLeft to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_TopRight Property

ImagesCorner_TopRight Property
Gets or sets the Corner_TopRight image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Corner_TopRight { get; set; }
Public Shared Property Corner_TopRight As Bitmap
    Get
    Set
public:
static property Bitmap^ Corner_TopRight {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Corner_TopRight : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_TopRight_IsCustom Property

ImagesCorner_TopRight_IsCustom Property
Gets a value indicating whether the Corner_TopRight image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Corner_TopRight_IsCustom { get; }
Public Shared ReadOnly Property Corner_TopRight_IsCustom As Boolean
    Get
public:
static property bool Corner_TopRight_IsCustom {
    bool get ();
}
static member Corner_TopRight_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Corner_TopRight_SyncLock Property

ImagesCorner_TopRight_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Corner_TopRight_SyncLock { get; }
Public Shared ReadOnly Property Corner_TopRight_SyncLock As Object
    Get
public:
static property Object^ Corner_TopRight_SyncLock {
    Object^ get ();
}
static member Corner_TopRight_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Corner_TopRight to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Crosshair Property

ImagesCrosshair Property
Gets or sets the Crosshair image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Crosshair { get; set; }
Public Shared Property Crosshair As Bitmap
    Get
    Set
public:
static property Bitmap^ Crosshair {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Crosshair : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Crosshair_IsCustom Property

ImagesCrosshair_IsCustom Property
Gets a value indicating whether the Crosshair image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Crosshair_IsCustom { get; }
Public Shared ReadOnly Property Crosshair_IsCustom As Boolean
    Get
public:
static property bool Crosshair_IsCustom {
    bool get ();
}
static member Crosshair_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Crosshair_SyncLock Property

ImagesCrosshair_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Crosshair_SyncLock { get; }
Public Shared ReadOnly Property Crosshair_SyncLock As Object
    Get
public:
static property Object^ Crosshair_SyncLock {
    Object^ get ();
}
static member Crosshair_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Crosshair to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Decoding16x16 Property

ImagesDecoding16x16 Property
Gets or sets the Decoding16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Decoding16x16 { get; set; }
Public Shared Property Decoding16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Decoding16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Decoding16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Decoding16x16_IsCustom Property

ImagesDecoding16x16_IsCustom Property
Gets a value indicating whether the Decoding16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Decoding16x16_IsCustom { get; }
Public Shared ReadOnly Property Decoding16x16_IsCustom As Boolean
    Get
public:
static property bool Decoding16x16_IsCustom {
    bool get ();
}
static member Decoding16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Decoding16x16_SyncLock Property

ImagesDecoding16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Decoding16x16_SyncLock { get; }
Public Shared ReadOnly Property Decoding16x16_SyncLock As Object
    Get
public:
static property Object^ Decoding16x16_SyncLock {
    Object^ get ();
}
static member Decoding16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Decoding16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Edit16x16 Property

ImagesEdit16x16 Property
Gets or sets the Edit16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Edit16x16 { get; set; }
Public Shared Property Edit16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Edit16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Edit16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Edit16x16_IsCustom Property

ImagesEdit16x16_IsCustom Property
Gets a value indicating whether the Edit16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Edit16x16_IsCustom { get; }
Public Shared ReadOnly Property Edit16x16_IsCustom As Boolean
    Get
public:
static property bool Edit16x16_IsCustom {
    bool get ();
}
static member Edit16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Edit16x16_SyncLock Property

ImagesEdit16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Edit16x16_SyncLock { get; }
Public Shared ReadOnly Property Edit16x16_SyncLock As Object
    Get
public:
static property Object^ Edit16x16_SyncLock {
    Object^ get ();
}
static member Edit16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Edit16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Expand Property

ImagesExpand Property
Gets or sets the Expand image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Expand { get; set; }
Public Shared Property Expand As Bitmap
    Get
    Set
public:
static property Bitmap^ Expand {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Expand : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Expand_IsCustom Property

ImagesExpand_IsCustom Property
Gets a value indicating whether the Expand image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Expand_IsCustom { get; }
Public Shared ReadOnly Property Expand_IsCustom As Boolean
    Get
public:
static property bool Expand_IsCustom {
    bool get ();
}
static member Expand_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Expand_SyncLock Property

ImagesExpand_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Expand_SyncLock { get; }
Public Shared ReadOnly Property Expand_SyncLock As Object
    Get
public:
static property Object^ Expand_SyncLock {
    Object^ get ();
}
static member Expand_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Expand to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Favicon Property

ImagesFavicon Property
Gets or sets the Favicon image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Icon Favicon { get; set; }
Public Shared Property Favicon As Icon
    Get
    Set
public:
static property Icon^ Favicon {
    Icon^ get ();
    void set (Icon^ value);
}
static member Favicon : Icon with get, set

Property Value

Type: Icon
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Favicon_IsCustom Property

ImagesFavicon_IsCustom Property
Gets a value indicating whether the Favicon image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Favicon_IsCustom { get; }
Public Shared ReadOnly Property Favicon_IsCustom As Boolean
    Get
public:
static property bool Favicon_IsCustom {
    bool get ();
}
static member Favicon_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Favicon_SyncLock Property

ImagesFavicon_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Favicon_SyncLock { get; }
Public Shared ReadOnly Property Favicon_SyncLock As Object
    Get
public:
static property Object^ Favicon_SyncLock {
    Object^ get ();
}
static member Favicon_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Favicon to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.FollowMe Property

ImagesFollowMe Property
Gets or sets the FollowMe image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap FollowMe { get; set; }
Public Shared Property FollowMe As Bitmap
    Get
    Set
public:
static property Bitmap^ FollowMe {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member FollowMe : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.FollowMe_IsCustom Property

ImagesFollowMe_IsCustom Property
Gets a value indicating whether the FollowMe image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool FollowMe_IsCustom { get; }
Public Shared ReadOnly Property FollowMe_IsCustom As Boolean
    Get
public:
static property bool FollowMe_IsCustom {
    bool get ();
}
static member FollowMe_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.FollowMe_SyncLock Property

ImagesFollowMe_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object FollowMe_SyncLock { get; }
Public Shared ReadOnly Property FollowMe_SyncLock As Object
    Get
public:
static property Object^ FollowMe_SyncLock {
    Object^ get ();
}
static member FollowMe_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call FollowMe to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Gear16x16 Property

ImagesGear16x16 Property
Gets or sets the Gear16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Gear16x16 { get; set; }
Public Shared Property Gear16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Gear16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Gear16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Gear16x16_IsCustom Property

ImagesGear16x16_IsCustom Property
Gets a value indicating whether the Gear16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Gear16x16_IsCustom { get; }
Public Shared ReadOnly Property Gear16x16_IsCustom As Boolean
    Get
public:
static property bool Gear16x16_IsCustom {
    bool get ();
}
static member Gear16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Gear16x16_SyncLock Property

ImagesGear16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Gear16x16_SyncLock { get; }
Public Shared ReadOnly Property Gear16x16_SyncLock As Object
    Get
public:
static property Object^ Gear16x16_SyncLock {
    Object^ get ();
}
static member Gear16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Gear16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.GotoCurrentLocation Property

ImagesGotoCurrentLocation Property
Gets or sets the GotoCurrentLocation image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap GotoCurrentLocation { get; set; }
Public Shared Property GotoCurrentLocation As Bitmap
    Get
    Set
public:
static property Bitmap^ GotoCurrentLocation {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member GotoCurrentLocation : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.GotoCurrentLocation_IsCustom Property

ImagesGotoCurrentLocation_IsCustom Property
Gets a value indicating whether the GotoCurrentLocation image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GotoCurrentLocation_IsCustom { get; }
Public Shared ReadOnly Property GotoCurrentLocation_IsCustom As Boolean
    Get
public:
static property bool GotoCurrentLocation_IsCustom {
    bool get ();
}
static member GotoCurrentLocation_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.GotoCurrentLocation_SyncLock Property

ImagesGotoCurrentLocation_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object GotoCurrentLocation_SyncLock { get; }
Public Shared ReadOnly Property GotoCurrentLocation_SyncLock As Object
    Get
public:
static property Object^ GotoCurrentLocation_SyncLock {
    Object^ get ();
}
static member GotoCurrentLocation_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call GotoCurrentLocation to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.HelpAbout Property

ImagesHelpAbout Property
Gets or sets the HelpAbout image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap HelpAbout { get; set; }
Public Shared Property HelpAbout As Bitmap
    Get
    Set
public:
static property Bitmap^ HelpAbout {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member HelpAbout : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.HelpAbout_IsCustom Property

ImagesHelpAbout_IsCustom Property
Gets a value indicating whether the HelpAbout image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HelpAbout_IsCustom { get; }
Public Shared ReadOnly Property HelpAbout_IsCustom As Boolean
    Get
public:
static property bool HelpAbout_IsCustom {
    bool get ();
}
static member HelpAbout_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.HelpAbout_SyncLock Property

ImagesHelpAbout_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object HelpAbout_SyncLock { get; }
Public Shared ReadOnly Property HelpAbout_SyncLock As Object
    Get
public:
static property Object^ HelpAbout_SyncLock {
    Object^ get ();
}
static member HelpAbout_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call HelpAbout to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.HideList Property

ImagesHideList Property
Gets or sets the HideList image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap HideList { get; set; }
Public Shared Property HideList As Bitmap
    Get
    Set
public:
static property Bitmap^ HideList {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member HideList : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.HideList_IsCustom Property

ImagesHideList_IsCustom Property
Gets a value indicating whether the HideList image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HideList_IsCustom { get; }
Public Shared ReadOnly Property HideList_IsCustom As Boolean
    Get
public:
static property bool HideList_IsCustom {
    bool get ();
}
static member HideList_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.HideList_SyncLock Property

ImagesHideList_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object HideList_SyncLock { get; }
Public Shared ReadOnly Property HideList_SyncLock As Object
    Get
public:
static property Object^ HideList_SyncLock {
    Object^ get ();
}
static member HideList_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call HideList to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPadSplash Property

ImagesIPadSplash Property
Gets or sets the IPadSplash image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPadSplash { get; set; }
Public Shared Property IPadSplash As Bitmap
    Get
    Set
public:
static property Bitmap^ IPadSplash {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPadSplash : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPadSplash_IsCustom Property

ImagesIPadSplash_IsCustom Property
Gets a value indicating whether the IPadSplash image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPadSplash_IsCustom { get; }
Public Shared ReadOnly Property IPadSplash_IsCustom As Boolean
    Get
public:
static property bool IPadSplash_IsCustom {
    bool get ();
}
static member IPadSplash_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPadSplash_SyncLock Property

ImagesIPadSplash_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPadSplash_SyncLock { get; }
Public Shared ReadOnly Property IPadSplash_SyncLock As Object
    Get
public:
static property Object^ IPadSplash_SyncLock {
    Object^ get ();
}
static member IPadSplash_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPadSplash to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneBackButton Property

ImagesIPhoneBackButton Property
Gets or sets the IPhoneBackButton image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneBackButton { get; set; }
Public Shared Property IPhoneBackButton As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneBackButton {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneBackButton : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneBackButton_IsCustom Property

ImagesIPhoneBackButton_IsCustom Property
Gets a value indicating whether the IPhoneBackButton image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneBackButton_IsCustom { get; }
Public Shared ReadOnly Property IPhoneBackButton_IsCustom As Boolean
    Get
public:
static property bool IPhoneBackButton_IsCustom {
    bool get ();
}
static member IPhoneBackButton_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneBackButton_SyncLock Property

ImagesIPhoneBackButton_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneBackButton_SyncLock { get; }
Public Shared ReadOnly Property IPhoneBackButton_SyncLock As Object
    Get
public:
static property Object^ IPhoneBackButton_SyncLock {
    Object^ get ();
}
static member IPhoneBackButton_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneBackButton to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneBlueButton Property

ImagesIPhoneBlueButton Property
Gets or sets the IPhoneBlueButton image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneBlueButton { get; set; }
Public Shared Property IPhoneBlueButton As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneBlueButton {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneBlueButton : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneBlueButton_IsCustom Property

ImagesIPhoneBlueButton_IsCustom Property
Gets a value indicating whether the IPhoneBlueButton image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneBlueButton_IsCustom { get; }
Public Shared ReadOnly Property IPhoneBlueButton_IsCustom As Boolean
    Get
public:
static property bool IPhoneBlueButton_IsCustom {
    bool get ();
}
static member IPhoneBlueButton_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneBlueButton_SyncLock Property

ImagesIPhoneBlueButton_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneBlueButton_SyncLock { get; }
Public Shared ReadOnly Property IPhoneBlueButton_SyncLock As Object
    Get
public:
static property Object^ IPhoneBlueButton_SyncLock {
    Object^ get ();
}
static member IPhoneBlueButton_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneBlueButton to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneChevron Property

ImagesIPhoneChevron Property
Gets or sets the IPhoneChevron image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneChevron { get; set; }
Public Shared Property IPhoneChevron As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneChevron {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneChevron : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneChevron_IsCustom Property

ImagesIPhoneChevron_IsCustom Property
Gets a value indicating whether the IPhoneChevron image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneChevron_IsCustom { get; }
Public Shared ReadOnly Property IPhoneChevron_IsCustom As Boolean
    Get
public:
static property bool IPhoneChevron_IsCustom {
    bool get ();
}
static member IPhoneChevron_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneChevron_SyncLock Property

ImagesIPhoneChevron_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneChevron_SyncLock { get; }
Public Shared ReadOnly Property IPhoneChevron_SyncLock As Object
    Get
public:
static property Object^ IPhoneChevron_SyncLock {
    Object^ get ();
}
static member IPhoneChevron_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneChevron to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneGrayButton Property

ImagesIPhoneGrayButton Property
Gets or sets the IPhoneGrayButton image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneGrayButton { get; set; }
Public Shared Property IPhoneGrayButton As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneGrayButton {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneGrayButton : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneGrayButton_IsCustom Property

ImagesIPhoneGrayButton_IsCustom Property
Gets a value indicating whether the IPhoneGrayButton image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneGrayButton_IsCustom { get; }
Public Shared ReadOnly Property IPhoneGrayButton_IsCustom As Boolean
    Get
public:
static property bool IPhoneGrayButton_IsCustom {
    bool get ();
}
static member IPhoneGrayButton_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneGrayButton_SyncLock Property

ImagesIPhoneGrayButton_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneGrayButton_SyncLock { get; }
Public Shared ReadOnly Property IPhoneGrayButton_SyncLock As Object
    Get
public:
static property Object^ IPhoneGrayButton_SyncLock {
    Object^ get ();
}
static member IPhoneGrayButton_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneGrayButton to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneIcon Property

ImagesIPhoneIcon Property
Gets or sets the IPhoneIcon image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneIcon { get; set; }
Public Shared Property IPhoneIcon As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneIcon {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneIcon : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneIcon_IsCustom Property

ImagesIPhoneIcon_IsCustom Property
Gets a value indicating whether the IPhoneIcon image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneIcon_IsCustom { get; }
Public Shared ReadOnly Property IPhoneIcon_IsCustom As Boolean
    Get
public:
static property bool IPhoneIcon_IsCustom {
    bool get ();
}
static member IPhoneIcon_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneIcon_SyncLock Property

ImagesIPhoneIcon_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneIcon_SyncLock { get; }
Public Shared ReadOnly Property IPhoneIcon_SyncLock As Object
    Get
public:
static property Object^ IPhoneIcon_SyncLock {
    Object^ get ();
}
static member IPhoneIcon_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneIcon to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneListGroup Property

ImagesIPhoneListGroup Property
Gets or sets the IPhoneListGroup image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneListGroup { get; set; }
Public Shared Property IPhoneListGroup As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneListGroup {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneListGroup : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneListGroup_IsCustom Property

ImagesIPhoneListGroup_IsCustom Property
Gets a value indicating whether the IPhoneListGroup image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneListGroup_IsCustom { get; }
Public Shared ReadOnly Property IPhoneListGroup_IsCustom As Boolean
    Get
public:
static property bool IPhoneListGroup_IsCustom {
    bool get ();
}
static member IPhoneListGroup_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneListGroup_SyncLock Property

ImagesIPhoneListGroup_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneListGroup_SyncLock { get; }
Public Shared ReadOnly Property IPhoneListGroup_SyncLock As Object
    Get
public:
static property Object^ IPhoneListGroup_SyncLock {
    Object^ get ();
}
static member IPhoneListGroup_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneListGroup to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneOnOff Property

ImagesIPhoneOnOff Property
Gets or sets the IPhoneOnOff image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneOnOff { get; set; }
Public Shared Property IPhoneOnOff As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneOnOff {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneOnOff : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneOnOff_IsCustom Property

ImagesIPhoneOnOff_IsCustom Property
Gets a value indicating whether the IPhoneOnOff image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneOnOff_IsCustom { get; }
Public Shared ReadOnly Property IPhoneOnOff_IsCustom As Boolean
    Get
public:
static property bool IPhoneOnOff_IsCustom {
    bool get ();
}
static member IPhoneOnOff_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneOnOff_SyncLock Property

ImagesIPhoneOnOff_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneOnOff_SyncLock { get; }
Public Shared ReadOnly Property IPhoneOnOff_SyncLock As Object
    Get
public:
static property Object^ IPhoneOnOff_SyncLock {
    Object^ get ();
}
static member IPhoneOnOff_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneOnOff to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhonePinstripes Property

ImagesIPhonePinstripes Property
Gets or sets the IPhonePinstripes image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhonePinstripes { get; set; }
Public Shared Property IPhonePinstripes As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhonePinstripes {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhonePinstripes : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhonePinstripes_IsCustom Property

ImagesIPhonePinstripes_IsCustom Property
Gets a value indicating whether the IPhonePinstripes image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhonePinstripes_IsCustom { get; }
Public Shared ReadOnly Property IPhonePinstripes_IsCustom As Boolean
    Get
public:
static property bool IPhonePinstripes_IsCustom {
    bool get ();
}
static member IPhonePinstripes_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhonePinstripes_SyncLock Property

ImagesIPhonePinstripes_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhonePinstripes_SyncLock { get; }
Public Shared ReadOnly Property IPhonePinstripes_SyncLock As Object
    Get
public:
static property Object^ IPhonePinstripes_SyncLock {
    Object^ get ();
}
static member IPhonePinstripes_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhonePinstripes to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSelectedTick Property

ImagesIPhoneSelectedTick Property
Gets or sets the IPhoneSelectedTick image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneSelectedTick { get; set; }
Public Shared Property IPhoneSelectedTick As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneSelectedTick {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneSelectedTick : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSelectedTick_IsCustom Property

ImagesIPhoneSelectedTick_IsCustom Property
Gets a value indicating whether the IPhoneSelectedTick image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneSelectedTick_IsCustom { get; }
Public Shared ReadOnly Property IPhoneSelectedTick_IsCustom As Boolean
    Get
public:
static property bool IPhoneSelectedTick_IsCustom {
    bool get ();
}
static member IPhoneSelectedTick_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSelectedTick_SyncLock Property

ImagesIPhoneSelectedTick_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneSelectedTick_SyncLock { get; }
Public Shared ReadOnly Property IPhoneSelectedTick_SyncLock As Object
    Get
public:
static property Object^ IPhoneSelectedTick_SyncLock {
    Object^ get ();
}
static member IPhoneSelectedTick_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneSelectedTick to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSelection Property

ImagesIPhoneSelection Property
Gets or sets the IPhoneSelection image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneSelection { get; set; }
Public Shared Property IPhoneSelection As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneSelection {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneSelection : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSelection_IsCustom Property

ImagesIPhoneSelection_IsCustom Property
Gets a value indicating whether the IPhoneSelection image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneSelection_IsCustom { get; }
Public Shared ReadOnly Property IPhoneSelection_IsCustom As Boolean
    Get
public:
static property bool IPhoneSelection_IsCustom {
    bool get ();
}
static member IPhoneSelection_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSelection_SyncLock Property

ImagesIPhoneSelection_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneSelection_SyncLock { get; }
Public Shared ReadOnly Property IPhoneSelection_SyncLock As Object
    Get
public:
static property Object^ IPhoneSelection_SyncLock {
    Object^ get ();
}
static member IPhoneSelection_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneSelection to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSplash Property

ImagesIPhoneSplash Property
Gets or sets the IPhoneSplash image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneSplash { get; set; }
Public Shared Property IPhoneSplash As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneSplash {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneSplash : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSplash_IsCustom Property

ImagesIPhoneSplash_IsCustom Property
Gets a value indicating whether the IPhoneSplash image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneSplash_IsCustom { get; }
Public Shared ReadOnly Property IPhoneSplash_IsCustom As Boolean
    Get
public:
static property bool IPhoneSplash_IsCustom {
    bool get ();
}
static member IPhoneSplash_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneSplash_SyncLock Property

ImagesIPhoneSplash_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneSplash_SyncLock { get; }
Public Shared ReadOnly Property IPhoneSplash_SyncLock As Object
    Get
public:
static property Object^ IPhoneSplash_SyncLock {
    Object^ get ();
}
static member IPhoneSplash_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneSplash to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneToolbar Property

ImagesIPhoneToolbar Property
Gets or sets the IPhoneToolbar image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneToolbar { get; set; }
Public Shared Property IPhoneToolbar As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneToolbar {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneToolbar : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneToolbar_IsCustom Property

ImagesIPhoneToolbar_IsCustom Property
Gets a value indicating whether the IPhoneToolbar image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneToolbar_IsCustom { get; }
Public Shared ReadOnly Property IPhoneToolbar_IsCustom As Boolean
    Get
public:
static property bool IPhoneToolbar_IsCustom {
    bool get ();
}
static member IPhoneToolbar_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneToolbar_SyncLock Property

ImagesIPhoneToolbar_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneToolbar_SyncLock { get; }
Public Shared ReadOnly Property IPhoneToolbar_SyncLock As Object
    Get
public:
static property Object^ IPhoneToolbar_SyncLock {
    Object^ get ();
}
static member IPhoneToolbar_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneToolbar to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneToolButton Property

ImagesIPhoneToolButton Property
Gets or sets the IPhoneToolButton image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneToolButton { get; set; }
Public Shared Property IPhoneToolButton As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneToolButton {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneToolButton : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneToolButton_IsCustom Property

ImagesIPhoneToolButton_IsCustom Property
Gets a value indicating whether the IPhoneToolButton image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneToolButton_IsCustom { get; }
Public Shared ReadOnly Property IPhoneToolButton_IsCustom As Boolean
    Get
public:
static property bool IPhoneToolButton_IsCustom {
    bool get ();
}
static member IPhoneToolButton_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneToolButton_SyncLock Property

ImagesIPhoneToolButton_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneToolButton_SyncLock { get; }
Public Shared ReadOnly Property IPhoneToolButton_SyncLock As Object
    Get
public:
static property Object^ IPhoneToolButton_SyncLock {
    Object^ get ();
}
static member IPhoneToolButton_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneToolButton to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneWhiteButton Property

ImagesIPhoneWhiteButton Property
Gets or sets the IPhoneWhiteButton image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap IPhoneWhiteButton { get; set; }
Public Shared Property IPhoneWhiteButton As Bitmap
    Get
    Set
public:
static property Bitmap^ IPhoneWhiteButton {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member IPhoneWhiteButton : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneWhiteButton_IsCustom Property

ImagesIPhoneWhiteButton_IsCustom Property
Gets a value indicating whether the IPhoneWhiteButton image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IPhoneWhiteButton_IsCustom { get; }
Public Shared ReadOnly Property IPhoneWhiteButton_IsCustom As Boolean
    Get
public:
static property bool IPhoneWhiteButton_IsCustom {
    bool get ();
}
static member IPhoneWhiteButton_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.IPhoneWhiteButton_SyncLock Property

ImagesIPhoneWhiteButton_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object IPhoneWhiteButton_SyncLock { get; }
Public Shared ReadOnly Property IPhoneWhiteButton_SyncLock As Object
    Get
public:
static property Object^ IPhoneWhiteButton_SyncLock {
    Object^ get ();
}
static member IPhoneWhiteButton_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call IPhoneWhiteButton to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Location16x16 Property

ImagesLocation16x16 Property
Gets or sets the Location16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Location16x16 { get; set; }
Public Shared Property Location16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Location16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Location16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Location16x16_IsCustom Property

ImagesLocation16x16_IsCustom Property
Gets a value indicating whether the Location16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Location16x16_IsCustom { get; }
Public Shared ReadOnly Property Location16x16_IsCustom As Boolean
    Get
public:
static property bool Location16x16_IsCustom {
    bool get ();
}
static member Location16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Location16x16_SyncLock Property

ImagesLocation16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Location16x16_SyncLock { get; }
Public Shared ReadOnly Property Location16x16_SyncLock As Object
    Get
public:
static property Object^ Location16x16_SyncLock {
    Object^ get ();
}
static member Location16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Location16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Logo128x128 Property

ImagesLogo128x128 Property
Gets or sets the Logo128x128 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Logo128x128 { get; set; }
Public Shared Property Logo128x128 As Bitmap
    Get
    Set
public:
static property Bitmap^ Logo128x128 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Logo128x128 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Logo128x128_IsCustom Property

ImagesLogo128x128_IsCustom Property
Gets a value indicating whether the Logo128x128 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Logo128x128_IsCustom { get; }
Public Shared ReadOnly Property Logo128x128_IsCustom As Boolean
    Get
public:
static property bool Logo128x128_IsCustom {
    bool get ();
}
static member Logo128x128_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Logo128x128_SyncLock Property

ImagesLogo128x128_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Logo128x128_SyncLock { get; }
Public Shared ReadOnly Property Logo128x128_SyncLock As Object
    Get
public:
static property Object^ Logo128x128_SyncLock {
    Object^ get ();
}
static member Logo128x128_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Logo128x128 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Marker_Airplane Property

ImagesMarker_Airplane Property
Gets or sets the Marker_Airplane image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Marker_Airplane { get; set; }
Public Shared Property Marker_Airplane As Bitmap
    Get
    Set
public:
static property Bitmap^ Marker_Airplane {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Marker_Airplane : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Marker_Airplane_IsCustom Property

ImagesMarker_Airplane_IsCustom Property
Gets a value indicating whether the Marker_Airplane image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Marker_Airplane_IsCustom { get; }
Public Shared ReadOnly Property Marker_Airplane_IsCustom As Boolean
    Get
public:
static property bool Marker_Airplane_IsCustom {
    bool get ();
}
static member Marker_Airplane_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Marker_Airplane_SyncLock Property

ImagesMarker_Airplane_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Marker_Airplane_SyncLock { get; }
Public Shared ReadOnly Property Marker_Airplane_SyncLock As Object
    Get
public:
static property Object^ Marker_Airplane_SyncLock {
    Object^ get ();
}
static member Marker_Airplane_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Marker_Airplane to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Marker_AirplaneSelected Property

ImagesMarker_AirplaneSelected Property
Gets or sets the Marker_AirplaneSelected image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Marker_AirplaneSelected { get; set; }
Public Shared Property Marker_AirplaneSelected As Bitmap
    Get
    Set
public:
static property Bitmap^ Marker_AirplaneSelected {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Marker_AirplaneSelected : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Marker_AirplaneSelected_IsCustom Property

ImagesMarker_AirplaneSelected_IsCustom Property
Gets a value indicating whether the Marker_AirplaneSelected image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Marker_AirplaneSelected_IsCustom { get; }
Public Shared ReadOnly Property Marker_AirplaneSelected_IsCustom As Boolean
    Get
public:
static property bool Marker_AirplaneSelected_IsCustom {
    bool get ();
}
static member Marker_AirplaneSelected_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Marker_AirplaneSelected_SyncLock Property

ImagesMarker_AirplaneSelected_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Marker_AirplaneSelected_SyncLock { get; }
Public Shared ReadOnly Property Marker_AirplaneSelected_SyncLock As Object
    Get
public:
static property Object^ Marker_AirplaneSelected_SyncLock {
    Object^ get ();
}
static member Marker_AirplaneSelected_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Marker_AirplaneSelected to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MergedFeed16x16 Property

ImagesMergedFeed16x16 Property
Gets or sets the MergedFeed16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap MergedFeed16x16 { get; set; }
Public Shared Property MergedFeed16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ MergedFeed16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member MergedFeed16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MergedFeed16x16_IsCustom Property

ImagesMergedFeed16x16_IsCustom Property
Gets a value indicating whether the MergedFeed16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool MergedFeed16x16_IsCustom { get; }
Public Shared ReadOnly Property MergedFeed16x16_IsCustom As Boolean
    Get
public:
static property bool MergedFeed16x16_IsCustom {
    bool get ();
}
static member MergedFeed16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MergedFeed16x16_SyncLock Property

ImagesMergedFeed16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object MergedFeed16x16_SyncLock { get; }
Public Shared ReadOnly Property MergedFeed16x16_SyncLock As Object
    Get
public:
static property Object^ MergedFeed16x16_SyncLock {
    Object^ get ();
}
static member MergedFeed16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call MergedFeed16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MovingMapChecked Property

ImagesMovingMapChecked Property
Gets or sets the MovingMapChecked image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap MovingMapChecked { get; set; }
Public Shared Property MovingMapChecked As Bitmap
    Get
    Set
public:
static property Bitmap^ MovingMapChecked {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member MovingMapChecked : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MovingMapChecked_IsCustom Property

ImagesMovingMapChecked_IsCustom Property
Gets a value indicating whether the MovingMapChecked image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool MovingMapChecked_IsCustom { get; }
Public Shared ReadOnly Property MovingMapChecked_IsCustom As Boolean
    Get
public:
static property bool MovingMapChecked_IsCustom {
    bool get ();
}
static member MovingMapChecked_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MovingMapChecked_SyncLock Property

ImagesMovingMapChecked_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object MovingMapChecked_SyncLock { get; }
Public Shared ReadOnly Property MovingMapChecked_SyncLock As Object
    Get
public:
static property Object^ MovingMapChecked_SyncLock {
    Object^ get ();
}
static member MovingMapChecked_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call MovingMapChecked to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MovingMapUnchecked Property

ImagesMovingMapUnchecked Property
Gets or sets the MovingMapUnchecked image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap MovingMapUnchecked { get; set; }
Public Shared Property MovingMapUnchecked As Bitmap
    Get
    Set
public:
static property Bitmap^ MovingMapUnchecked {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member MovingMapUnchecked : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MovingMapUnchecked_IsCustom Property

ImagesMovingMapUnchecked_IsCustom Property
Gets a value indicating whether the MovingMapUnchecked image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool MovingMapUnchecked_IsCustom { get; }
Public Shared ReadOnly Property MovingMapUnchecked_IsCustom As Boolean
    Get
public:
static property bool MovingMapUnchecked_IsCustom {
    bool get ();
}
static member MovingMapUnchecked_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.MovingMapUnchecked_SyncLock Property

ImagesMovingMapUnchecked_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object MovingMapUnchecked_SyncLock { get; }
Public Shared ReadOnly Property MovingMapUnchecked_SyncLock As Object
    Get
public:
static property Object^ MovingMapUnchecked_SyncLock {
    Object^ get ();
}
static member MovingMapUnchecked_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call MovingMapUnchecked to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Notebook16x16 Property

ImagesNotebook16x16 Property
Gets or sets the Notebook16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Notebook16x16 { get; set; }
Public Shared Property Notebook16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Notebook16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Notebook16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Notebook16x16_IsCustom Property

ImagesNotebook16x16_IsCustom Property
Gets a value indicating whether the Notebook16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Notebook16x16_IsCustom { get; }
Public Shared ReadOnly Property Notebook16x16_IsCustom As Boolean
    Get
public:
static property bool Notebook16x16_IsCustom {
    bool get ();
}
static member Notebook16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Notebook16x16_SyncLock Property

ImagesNotebook16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Notebook16x16_SyncLock { get; }
Public Shared ReadOnly Property Notebook16x16_SyncLock As Object
    Get
public:
static property Object^ Notebook16x16_SyncLock {
    Object^ get ();
}
static member Notebook16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Notebook16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.OpenSlider Property

ImagesOpenSlider Property
Gets or sets the OpenSlider image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap OpenSlider { get; set; }
Public Shared Property OpenSlider As Bitmap
    Get
    Set
public:
static property Bitmap^ OpenSlider {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member OpenSlider : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.OpenSlider_IsCustom Property

ImagesOpenSlider_IsCustom Property
Gets a value indicating whether the OpenSlider image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool OpenSlider_IsCustom { get; }
Public Shared ReadOnly Property OpenSlider_IsCustom As Boolean
    Get
public:
static property bool OpenSlider_IsCustom {
    bool get ();
}
static member OpenSlider_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.OpenSlider_SyncLock Property

ImagesOpenSlider_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object OpenSlider_SyncLock { get; }
Public Shared ReadOnly Property OpenSlider_SyncLock As Object
    Get
public:
static property Object^ OpenSlider_SyncLock {
    Object^ get ();
}
static member OpenSlider_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call OpenSlider to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Radio16x16 Property

ImagesRadio16x16 Property
Gets or sets the Radio16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Radio16x16 { get; set; }
Public Shared Property Radio16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Radio16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Radio16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Radio16x16_IsCustom Property

ImagesRadio16x16_IsCustom Property
Gets a value indicating whether the Radio16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Radio16x16_IsCustom { get; }
Public Shared ReadOnly Property Radio16x16_IsCustom As Boolean
    Get
public:
static property bool Radio16x16_IsCustom {
    bool get ();
}
static member Radio16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Radio16x16_SyncLock Property

ImagesRadio16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Radio16x16_SyncLock { get; }
Public Shared ReadOnly Property Radio16x16_SyncLock As Object
    Get
public:
static property Object^ Radio16x16_SyncLock {
    Object^ get ();
}
static member Radio16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Radio16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Radio48x48 Property

ImagesRadio48x48 Property
Gets or sets the Radio48x48 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Radio48x48 { get; set; }
Public Shared Property Radio48x48 As Bitmap
    Get
    Set
public:
static property Bitmap^ Radio48x48 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Radio48x48 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Radio48x48_IsCustom Property

ImagesRadio48x48_IsCustom Property
Gets a value indicating whether the Radio48x48 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Radio48x48_IsCustom { get; }
Public Shared ReadOnly Property Radio48x48_IsCustom As Boolean
    Get
public:
static property bool Radio48x48_IsCustom {
    bool get ();
}
static member Radio48x48_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Radio48x48_SyncLock Property

ImagesRadio48x48_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Radio48x48_SyncLock { get; }
Public Shared ReadOnly Property Radio48x48_SyncLock As Object
    Get
public:
static property Object^ Radio48x48_SyncLock {
    Object^ get ();
}
static member Radio48x48_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Radio48x48 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Rebroadcast16x16 Property

ImagesRebroadcast16x16 Property
Gets or sets the Rebroadcast16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Rebroadcast16x16 { get; set; }
Public Shared Property Rebroadcast16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Rebroadcast16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Rebroadcast16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Rebroadcast16x16_IsCustom Property

ImagesRebroadcast16x16_IsCustom Property
Gets a value indicating whether the Rebroadcast16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Rebroadcast16x16_IsCustom { get; }
Public Shared ReadOnly Property Rebroadcast16x16_IsCustom As Boolean
    Get
public:
static property bool Rebroadcast16x16_IsCustom {
    bool get ();
}
static member Rebroadcast16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Rebroadcast16x16_SyncLock Property

ImagesRebroadcast16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Rebroadcast16x16_SyncLock { get; }
Public Shared ReadOnly Property Rebroadcast16x16_SyncLock As Object
    Get
public:
static property Object^ Rebroadcast16x16_SyncLock {
    Object^ get ();
}
static member Rebroadcast16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Rebroadcast16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.RowHeader Property

ImagesRowHeader Property
Gets or sets the RowHeader image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap RowHeader { get; set; }
Public Shared Property RowHeader As Bitmap
    Get
    Set
public:
static property Bitmap^ RowHeader {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member RowHeader : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.RowHeader_IsCustom Property

ImagesRowHeader_IsCustom Property
Gets a value indicating whether the RowHeader image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool RowHeader_IsCustom { get; }
Public Shared ReadOnly Property RowHeader_IsCustom As Boolean
    Get
public:
static property bool RowHeader_IsCustom {
    bool get ();
}
static member RowHeader_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.RowHeader_SyncLock Property

ImagesRowHeader_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object RowHeader_SyncLock { get; }
Public Shared ReadOnly Property RowHeader_SyncLock As Object
    Get
public:
static property Object^ RowHeader_SyncLock {
    Object^ get ();
}
static member RowHeader_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call RowHeader to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.RowHeaderSelected Property

ImagesRowHeaderSelected Property
Gets or sets the RowHeaderSelected image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap RowHeaderSelected { get; set; }
Public Shared Property RowHeaderSelected As Bitmap
    Get
    Set
public:
static property Bitmap^ RowHeaderSelected {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member RowHeaderSelected : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.RowHeaderSelected_IsCustom Property

ImagesRowHeaderSelected_IsCustom Property
Gets a value indicating whether the RowHeaderSelected image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool RowHeaderSelected_IsCustom { get; }
Public Shared ReadOnly Property RowHeaderSelected_IsCustom As Boolean
    Get
public:
static property bool RowHeaderSelected_IsCustom {
    bool get ();
}
static member RowHeaderSelected_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.RowHeaderSelected_SyncLock Property

ImagesRowHeaderSelected_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object RowHeaderSelected_SyncLock { get; }
Public Shared ReadOnly Property RowHeaderSelected_SyncLock As Object
    Get
public:
static property Object^ RowHeaderSelected_SyncLock {
    Object^ get ();
}
static member RowHeaderSelected_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call RowHeaderSelected to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Server16x16 Property

ImagesServer16x16 Property
Gets or sets the Server16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Server16x16 { get; set; }
Public Shared Property Server16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Server16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Server16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Server16x16_IsCustom Property

ImagesServer16x16_IsCustom Property
Gets a value indicating whether the Server16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Server16x16_IsCustom { get; }
Public Shared ReadOnly Property Server16x16_IsCustom As Boolean
    Get
public:
static property bool Server16x16_IsCustom {
    bool get ();
}
static member Server16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Server16x16_SyncLock Property

ImagesServer16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Server16x16_SyncLock { get; }
Public Shared ReadOnly Property Server16x16_SyncLock As Object
    Get
public:
static property Object^ Server16x16_SyncLock {
    Object^ get ();
}
static member Server16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Server16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ShowList Property

ImagesShowList Property
Gets or sets the ShowList image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ShowList { get; set; }
Public Shared Property ShowList As Bitmap
    Get
    Set
public:
static property Bitmap^ ShowList {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member ShowList : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ShowList_IsCustom Property

ImagesShowList_IsCustom Property
Gets a value indicating whether the ShowList image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ShowList_IsCustom { get; }
Public Shared ReadOnly Property ShowList_IsCustom As Boolean
    Get
public:
static property bool ShowList_IsCustom {
    bool get ();
}
static member ShowList_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.ShowList_SyncLock Property

ImagesShowList_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object ShowList_SyncLock { get; }
Public Shared ReadOnly Property ShowList_SyncLock As Object
    Get
public:
static property Object^ ShowList_SyncLock {
    Object^ get ();
}
static member ShowList_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call ShowList to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Site16x16 Property

ImagesSite16x16 Property
Gets or sets the Site16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Site16x16 { get; set; }
Public Shared Property Site16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Site16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Site16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Site16x16_IsCustom Property

ImagesSite16x16_IsCustom Property
Gets a value indicating whether the Site16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Site16x16_IsCustom { get; }
Public Shared ReadOnly Property Site16x16_IsCustom As Boolean
    Get
public:
static property bool Site16x16_IsCustom {
    bool get ();
}
static member Site16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Site16x16_SyncLock Property

ImagesSite16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Site16x16_SyncLock { get; }
Public Shared ReadOnly Property Site16x16_SyncLock As Object
    Get
public:
static property Object^ Site16x16_SyncLock {
    Object^ get ();
}
static member Site16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Site16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.SmallPlaneNorth Property

ImagesSmallPlaneNorth Property
Gets or sets the SmallPlaneNorth image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap SmallPlaneNorth { get; set; }
Public Shared Property SmallPlaneNorth As Bitmap
    Get
    Set
public:
static property Bitmap^ SmallPlaneNorth {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member SmallPlaneNorth : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.SmallPlaneNorth_IsCustom Property

ImagesSmallPlaneNorth_IsCustom Property
Gets a value indicating whether the SmallPlaneNorth image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SmallPlaneNorth_IsCustom { get; }
Public Shared ReadOnly Property SmallPlaneNorth_IsCustom As Boolean
    Get
public:
static property bool SmallPlaneNorth_IsCustom {
    bool get ();
}
static member SmallPlaneNorth_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.SmallPlaneNorth_SyncLock Property

ImagesSmallPlaneNorth_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object SmallPlaneNorth_SyncLock { get; }
Public Shared ReadOnly Property SmallPlaneNorth_SyncLock As Object
    Get
public:
static property Object^ SmallPlaneNorth_SyncLock {
    Object^ get ();
}
static member SmallPlaneNorth_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call SmallPlaneNorth to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Test16x16 Property

ImagesTest16x16 Property
Gets or sets the Test16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Test16x16 { get; set; }
Public Shared Property Test16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Test16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Test16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Test16x16_IsCustom Property

ImagesTest16x16_IsCustom Property
Gets a value indicating whether the Test16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Test16x16_IsCustom { get; }
Public Shared ReadOnly Property Test16x16_IsCustom As Boolean
    Get
public:
static property bool Test16x16_IsCustom {
    bool get ();
}
static member Test16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Test16x16_SyncLock Property

ImagesTest16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Test16x16_SyncLock { get; }
Public Shared ReadOnly Property Test16x16_SyncLock As Object
    Get
public:
static property Object^ Test16x16_SyncLock {
    Object^ get ();
}
static member Test16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Test16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.TestSquare Property

ImagesTestSquare Property
Gets or sets the TestSquare image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap TestSquare { get; set; }
Public Shared Property TestSquare As Bitmap
    Get
    Set
public:
static property Bitmap^ TestSquare {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member TestSquare : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.TestSquare_IsCustom Property

ImagesTestSquare_IsCustom Property
Gets a value indicating whether the TestSquare image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TestSquare_IsCustom { get; }
Public Shared ReadOnly Property TestSquare_IsCustom As Boolean
    Get
public:
static property bool TestSquare_IsCustom {
    bool get ();
}
static member TestSquare_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.TestSquare_SyncLock Property

ImagesTestSquare_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object TestSquare_SyncLock { get; }
Public Shared ReadOnly Property TestSquare_SyncLock As Object
    Get
public:
static property Object^ TestSquare_SyncLock {
    Object^ get ();
}
static member TestSquare_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call TestSquare to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Tower Property

ImagesTower Property
Gets or sets the Tower image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Tower { get; set; }
Public Shared Property Tower As Bitmap
    Get
    Set
public:
static property Bitmap^ Tower {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Tower : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Tower_IsCustom Property

ImagesTower_IsCustom Property
Gets a value indicating whether the Tower image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Tower_IsCustom { get; }
Public Shared ReadOnly Property Tower_IsCustom As Boolean
    Get
public:
static property bool Tower_IsCustom {
    bool get ();
}
static member Tower_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Tower_SyncLock Property

ImagesTower_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Tower_SyncLock { get; }
Public Shared ReadOnly Property Tower_SyncLock As Object
    Get
public:
static property Object^ Tower_SyncLock {
    Object^ get ();
}
static member Tower_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Tower to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_16x16 Property

ImagesTransparent_16x16 Property
Gets or sets the Transparent_16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Transparent_16x16 { get; set; }
Public Shared Property Transparent_16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Transparent_16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Transparent_16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_16x16_IsCustom Property

ImagesTransparent_16x16_IsCustom Property
Gets a value indicating whether the Transparent_16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Transparent_16x16_IsCustom { get; }
Public Shared ReadOnly Property Transparent_16x16_IsCustom As Boolean
    Get
public:
static property bool Transparent_16x16_IsCustom {
    bool get ();
}
static member Transparent_16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_16x16_SyncLock Property

ImagesTransparent_16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Transparent_16x16_SyncLock { get; }
Public Shared ReadOnly Property Transparent_16x16_SyncLock As Object
    Get
public:
static property Object^ Transparent_16x16_SyncLock {
    Object^ get ();
}
static member Transparent_16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Transparent_16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_25 Property

ImagesTransparent_25 Property
Gets or sets the Transparent_25 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Transparent_25 { get; set; }
Public Shared Property Transparent_25 As Bitmap
    Get
    Set
public:
static property Bitmap^ Transparent_25 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Transparent_25 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_25_IsCustom Property

ImagesTransparent_25_IsCustom Property
Gets a value indicating whether the Transparent_25 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Transparent_25_IsCustom { get; }
Public Shared ReadOnly Property Transparent_25_IsCustom As Boolean
    Get
public:
static property bool Transparent_25_IsCustom {
    bool get ();
}
static member Transparent_25_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_25_SyncLock Property

ImagesTransparent_25_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Transparent_25_SyncLock { get; }
Public Shared ReadOnly Property Transparent_25_SyncLock As Object
    Get
public:
static property Object^ Transparent_25_SyncLock {
    Object^ get ();
}
static member Transparent_25_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Transparent_25 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_50 Property

ImagesTransparent_50 Property
Gets or sets the Transparent_50 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Transparent_50 { get; set; }
Public Shared Property Transparent_50 As Bitmap
    Get
    Set
public:
static property Bitmap^ Transparent_50 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Transparent_50 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_50_IsCustom Property

ImagesTransparent_50_IsCustom Property
Gets a value indicating whether the Transparent_50 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Transparent_50_IsCustom { get; }
Public Shared ReadOnly Property Transparent_50_IsCustom As Boolean
    Get
public:
static property bool Transparent_50_IsCustom {
    bool get ();
}
static member Transparent_50_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Transparent_50_SyncLock Property

ImagesTransparent_50_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Transparent_50_SyncLock { get; }
Public Shared ReadOnly Property Transparent_50_SyncLock As Object
    Get
public:
static property Object^ Transparent_50_SyncLock {
    Object^ get ();
}
static member Transparent_50_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Transparent_50 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.User16x16 Property

ImagesUser16x16 Property
Gets or sets the User16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap User16x16 { get; set; }
Public Shared Property User16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ User16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member User16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.User16x16_IsCustom Property

ImagesUser16x16_IsCustom Property
Gets a value indicating whether the User16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool User16x16_IsCustom { get; }
Public Shared ReadOnly Property User16x16_IsCustom As Boolean
    Get
public:
static property bool User16x16_IsCustom {
    bool get ();
}
static member User16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.User16x16_SyncLock Property

ImagesUser16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object User16x16_SyncLock { get; }
Public Shared ReadOnly Property User16x16_SyncLock As Object
    Get
public:
static property Object^ User16x16_SyncLock {
    Object^ get ();
}
static member User16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call User16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume0 Property

ImagesVolume0 Property
Gets or sets the Volume0 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Volume0 { get; set; }
Public Shared Property Volume0 As Bitmap
    Get
    Set
public:
static property Bitmap^ Volume0 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Volume0 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume0_IsCustom Property

ImagesVolume0_IsCustom Property
Gets a value indicating whether the Volume0 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Volume0_IsCustom { get; }
Public Shared ReadOnly Property Volume0_IsCustom As Boolean
    Get
public:
static property bool Volume0_IsCustom {
    bool get ();
}
static member Volume0_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume0_SyncLock Property

ImagesVolume0_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Volume0_SyncLock { get; }
Public Shared ReadOnly Property Volume0_SyncLock As Object
    Get
public:
static property Object^ Volume0_SyncLock {
    Object^ get ();
}
static member Volume0_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Volume0 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume100 Property

ImagesVolume100 Property
Gets or sets the Volume100 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Volume100 { get; set; }
Public Shared Property Volume100 As Bitmap
    Get
    Set
public:
static property Bitmap^ Volume100 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Volume100 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume100_IsCustom Property

ImagesVolume100_IsCustom Property
Gets a value indicating whether the Volume100 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Volume100_IsCustom { get; }
Public Shared ReadOnly Property Volume100_IsCustom As Boolean
    Get
public:
static property bool Volume100_IsCustom {
    bool get ();
}
static member Volume100_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume100_SyncLock Property

ImagesVolume100_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Volume100_SyncLock { get; }
Public Shared ReadOnly Property Volume100_SyncLock As Object
    Get
public:
static property Object^ Volume100_SyncLock {
    Object^ get ();
}
static member Volume100_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Volume100 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume25 Property

ImagesVolume25 Property
Gets or sets the Volume25 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Volume25 { get; set; }
Public Shared Property Volume25 As Bitmap
    Get
    Set
public:
static property Bitmap^ Volume25 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Volume25 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume25_IsCustom Property

ImagesVolume25_IsCustom Property
Gets a value indicating whether the Volume25 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Volume25_IsCustom { get; }
Public Shared ReadOnly Property Volume25_IsCustom As Boolean
    Get
public:
static property bool Volume25_IsCustom {
    bool get ();
}
static member Volume25_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume25_SyncLock Property

ImagesVolume25_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Volume25_SyncLock { get; }
Public Shared ReadOnly Property Volume25_SyncLock As Object
    Get
public:
static property Object^ Volume25_SyncLock {
    Object^ get ();
}
static member Volume25_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Volume25 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume50 Property

ImagesVolume50 Property
Gets or sets the Volume50 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Volume50 { get; set; }
Public Shared Property Volume50 As Bitmap
    Get
    Set
public:
static property Bitmap^ Volume50 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Volume50 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume50_IsCustom Property

ImagesVolume50_IsCustom Property
Gets a value indicating whether the Volume50 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Volume50_IsCustom { get; }
Public Shared ReadOnly Property Volume50_IsCustom As Boolean
    Get
public:
static property bool Volume50_IsCustom {
    bool get ();
}
static member Volume50_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume50_SyncLock Property

ImagesVolume50_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Volume50_SyncLock { get; }
Public Shared ReadOnly Property Volume50_SyncLock As Object
    Get
public:
static property Object^ Volume50_SyncLock {
    Object^ get ();
}
static member Volume50_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Volume50 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume75 Property

ImagesVolume75 Property
Gets or sets the Volume75 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Volume75 { get; set; }
Public Shared Property Volume75 As Bitmap
    Get
    Set
public:
static property Bitmap^ Volume75 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Volume75 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume75_IsCustom Property

ImagesVolume75_IsCustom Property
Gets a value indicating whether the Volume75 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Volume75_IsCustom { get; }
Public Shared ReadOnly Property Volume75_IsCustom As Boolean
    Get
public:
static property bool Volume75_IsCustom {
    bool get ();
}
static member Volume75_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Volume75_SyncLock Property

ImagesVolume75_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Volume75_SyncLock { get; }
Public Shared ReadOnly Property Volume75_SyncLock As Object
    Get
public:
static property Object^ Volume75_SyncLock {
    Object^ get ();
}
static member Volume75_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Volume75 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeDown Property

ImagesVolumeDown Property
Gets or sets the VolumeDown image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap VolumeDown { get; set; }
Public Shared Property VolumeDown As Bitmap
    Get
    Set
public:
static property Bitmap^ VolumeDown {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member VolumeDown : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeDown_IsCustom Property

ImagesVolumeDown_IsCustom Property
Gets a value indicating whether the VolumeDown image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool VolumeDown_IsCustom { get; }
Public Shared ReadOnly Property VolumeDown_IsCustom As Boolean
    Get
public:
static property bool VolumeDown_IsCustom {
    bool get ();
}
static member VolumeDown_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeDown_SyncLock Property

ImagesVolumeDown_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object VolumeDown_SyncLock { get; }
Public Shared ReadOnly Property VolumeDown_SyncLock As Object
    Get
public:
static property Object^ VolumeDown_SyncLock {
    Object^ get ();
}
static member VolumeDown_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call VolumeDown to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeMute Property

ImagesVolumeMute Property
Gets or sets the VolumeMute image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap VolumeMute { get; set; }
Public Shared Property VolumeMute As Bitmap
    Get
    Set
public:
static property Bitmap^ VolumeMute {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member VolumeMute : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeMute_IsCustom Property

ImagesVolumeMute_IsCustom Property
Gets a value indicating whether the VolumeMute image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool VolumeMute_IsCustom { get; }
Public Shared ReadOnly Property VolumeMute_IsCustom As Boolean
    Get
public:
static property bool VolumeMute_IsCustom {
    bool get ();
}
static member VolumeMute_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeMute_SyncLock Property

ImagesVolumeMute_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object VolumeMute_SyncLock { get; }
Public Shared ReadOnly Property VolumeMute_SyncLock As Object
    Get
public:
static property Object^ VolumeMute_SyncLock {
    Object^ get ();
}
static member VolumeMute_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call VolumeMute to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeUp Property

ImagesVolumeUp Property
Gets or sets the VolumeUp image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap VolumeUp { get; set; }
Public Shared Property VolumeUp As Bitmap
    Get
    Set
public:
static property Bitmap^ VolumeUp {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member VolumeUp : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeUp_IsCustom Property

ImagesVolumeUp_IsCustom Property
Gets a value indicating whether the VolumeUp image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool VolumeUp_IsCustom { get; }
Public Shared ReadOnly Property VolumeUp_IsCustom As Boolean
    Get
public:
static property bool VolumeUp_IsCustom {
    bool get ();
}
static member VolumeUp_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.VolumeUp_SyncLock Property

ImagesVolumeUp_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object VolumeUp_SyncLock { get; }
Public Shared ReadOnly Property VolumeUp_SyncLock As Object
    Get
public:
static property Object^ VolumeUp_SyncLock {
    Object^ get ();
}
static member VolumeUp_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call VolumeUp to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.WarningBitmap Property

ImagesWarningBitmap Property
Gets or sets the WarningBitmap image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap WarningBitmap { get; set; }
Public Shared Property WarningBitmap As Bitmap
    Get
    Set
public:
static property Bitmap^ WarningBitmap {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member WarningBitmap : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.WarningBitmap_IsCustom Property

ImagesWarningBitmap_IsCustom Property
Gets a value indicating whether the WarningBitmap image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool WarningBitmap_IsCustom { get; }
Public Shared ReadOnly Property WarningBitmap_IsCustom As Boolean
    Get
public:
static property bool WarningBitmap_IsCustom {
    bool get ();
}
static member WarningBitmap_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.WarningBitmap_SyncLock Property

ImagesWarningBitmap_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object WarningBitmap_SyncLock { get; }
Public Shared ReadOnly Property WarningBitmap_SyncLock As Object
    Get
public:
static property Object^ WarningBitmap_SyncLock {
    Object^ get ();
}
static member WarningBitmap_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call WarningBitmap to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.WarningIcon Property

ImagesWarningIcon Property
Gets or sets the WarningIcon image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Icon WarningIcon { get; set; }
Public Shared Property WarningIcon As Icon
    Get
    Set
public:
static property Icon^ WarningIcon {
    Icon^ get ();
    void set (Icon^ value);
}
static member WarningIcon : Icon with get, set

Property Value

Type: Icon
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.WarningIcon_IsCustom Property

ImagesWarningIcon_IsCustom Property
Gets a value indicating whether the WarningIcon image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool WarningIcon_IsCustom { get; }
Public Shared ReadOnly Property WarningIcon_IsCustom As Boolean
    Get
public:
static property bool WarningIcon_IsCustom {
    bool get ();
}
static member WarningIcon_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.WarningIcon_SyncLock Property

ImagesWarningIcon_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object WarningIcon_SyncLock { get; }
Public Shared ReadOnly Property WarningIcon_SyncLock As Object
    Get
public:
static property Object^ WarningIcon_SyncLock {
    Object^ get ();
}
static member WarningIcon_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call WarningIcon to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Wizard16x16 Property

ImagesWizard16x16 Property
Gets or sets the Wizard16x16 image.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Wizard16x16 { get; set; }
Public Shared Property Wizard16x16 As Bitmap
    Get
    Set
public:
static property Bitmap^ Wizard16x16 {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
static member Wizard16x16 : Bitmap with get, set

Property Value

Type: Bitmap
Remarks
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Wizard16x16_IsCustom Property

ImagesWizard16x16_IsCustom Property
Gets a value indicating whether the Wizard16x16 image has been customised or not.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Wizard16x16_IsCustom { get; }
Public Shared ReadOnly Property Wizard16x16_IsCustom As Boolean
    Get
public:
static property bool Wizard16x16_IsCustom {
    bool get ();
}
static member Wizard16x16_IsCustom : bool with get

Property Value

Type: Boolean
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Wizard16x16_SyncLock Property

ImagesWizard16x16_SyncLock Property
Gets an object that can be used in a lock() statement on the image to force single-thread access to it while performing some operation on it.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Wizard16x16_SyncLock { get; }
Public Shared ReadOnly Property Wizard16x16_SyncLock As Object
    Get
public:
static property Object^ Wizard16x16_SyncLock {
    Object^ get ();
}
static member Wizard16x16_SyncLock : Object with get

Property Value

Type: Object
Remarks
This is a recipe for deadlocking, be careful when using this lock that you do not call anything that will acquire another lock elsewhere. If in doubt then call Wizard16x16 to make a thread-clone of the image and use that in your image manipulations.
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images Methods

Images Methods

The Images type exposes the following members.

Methods
Name | Description
Clone_Add16x16 | Creates a copy of Add16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ApplicationIcon | Creates a copy of ApplicationIcon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ArrowBack16x16 | Creates a copy of ArrowBack16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ArrowForward16x16 | Creates a copy of ArrowForward16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_BlueBall | Creates a copy of BlueBall. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Cancel16x16 | Creates a copy of Cancel16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_CancelSmall16x16 | Creates a copy of CancelSmall16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ChevronBlueCircle | Creates a copy of ChevronBlueCircle. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ChevronGreenCircle | Creates a copy of ChevronGreenCircle. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ChevronRedCircle | Creates a copy of ChevronRedCircle. Despite the name this does not use Clone, it creates a fresh copy.
Clone_CloseSlider | Creates a copy of CloseSlider. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Collapse | Creates a copy of Collapse. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Compass | Creates a copy of Compass. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_BottomLeft | Creates a copy of Corner_BottomLeft. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_BottomRight | Creates a copy of Corner_BottomRight. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_TopLeft | Creates a copy of Corner_TopLeft. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Corner_TopRight | Creates a copy of Corner_TopRight. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Crosshair | Creates a copy of Crosshair. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Decoding16x16 | Creates a copy of Decoding16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Edit16x16 | Creates a copy of Edit16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Expand | Creates a copy of Expand. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Favicon | Creates a copy of Favicon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_FollowMe | Creates a copy of FollowMe. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Gear16x16 | Creates a copy of Gear16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_GotoCurrentLocation | Creates a copy of GotoCurrentLocation. Despite the name this does not use Clone, it creates a fresh copy.
Clone_HelpAbout | Creates a copy of HelpAbout. Despite the name this does not use Clone, it creates a fresh copy.
Clone_HideList | Creates a copy of HideList. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPadSplash | Creates a copy of IPadSplash. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneBackButton | Creates a copy of IPhoneBackButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneBlueButton | Creates a copy of IPhoneBlueButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneChevron | Creates a copy of IPhoneChevron. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneGrayButton | Creates a copy of IPhoneGrayButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneIcon | Creates a copy of IPhoneIcon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneListGroup | Creates a copy of IPhoneListGroup. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneOnOff | Creates a copy of IPhoneOnOff. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhonePinstripes | Creates a copy of IPhonePinstripes. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneSelectedTick | Creates a copy of IPhoneSelectedTick. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneSelection | Creates a copy of IPhoneSelection. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneSplash | Creates a copy of IPhoneSplash. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneToolbar | Creates a copy of IPhoneToolbar. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneToolButton | Creates a copy of IPhoneToolButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_IPhoneWhiteButton | Creates a copy of IPhoneWhiteButton. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Location16x16 | Creates a copy of Location16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Logo128x128 | Creates a copy of Logo128x128. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Marker_Airplane | Creates a copy of Marker_Airplane. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Marker_AirplaneSelected | Creates a copy of Marker_AirplaneSelected. Despite the name this does not use Clone, it creates a fresh copy.
Clone_MergedFeed16x16 | Creates a copy of MergedFeed16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_MovingMapChecked | Creates a copy of MovingMapChecked. Despite the name this does not use Clone, it creates a fresh copy.
Clone_MovingMapUnchecked | Creates a copy of MovingMapUnchecked. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Notebook16x16 | Creates a copy of Notebook16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_OpenSlider | Creates a copy of OpenSlider. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Radio16x16 | Creates a copy of Radio16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Radio48x48 | Creates a copy of Radio48x48. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Rebroadcast16x16 | Creates a copy of Rebroadcast16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_RowHeader | Creates a copy of RowHeader. Despite the name this does not use Clone, it creates a fresh copy.
Clone_RowHeaderSelected | Creates a copy of RowHeaderSelected. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Server16x16 | Creates a copy of Server16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_ShowList | Creates a copy of ShowList. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Site16x16 | Creates a copy of Site16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_SmallPlaneNorth | Creates a copy of SmallPlaneNorth. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Test16x16 | Creates a copy of Test16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_TestSquare | Creates a copy of TestSquare. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Tower | Creates a copy of Tower. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Transparent_16x16 | Creates a copy of Transparent_16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Transparent_25 | Creates a copy of Transparent_25. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Transparent_50 | Creates a copy of Transparent_50. Despite the name this does not use Clone, it creates a fresh copy.
Clone_User16x16 | Creates a copy of User16x16. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume0 | Creates a copy of Volume0. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume100 | Creates a copy of Volume100. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume25 | Creates a copy of Volume25. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume50 | Creates a copy of Volume50. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Volume75 | Creates a copy of Volume75. Despite the name this does not use Clone, it creates a fresh copy.
Clone_VolumeDown | Creates a copy of VolumeDown. Despite the name this does not use Clone, it creates a fresh copy.
Clone_VolumeMute | Creates a copy of VolumeMute. Despite the name this does not use Clone, it creates a fresh copy.
Clone_VolumeUp | Creates a copy of VolumeUp. Despite the name this does not use Clone, it creates a fresh copy.
Clone_WarningBitmap | Creates a copy of WarningBitmap. Despite the name this does not use Clone, it creates a fresh copy.
Clone_WarningIcon | Creates a copy of WarningIcon. Despite the name this does not use Clone, it creates a fresh copy.
Clone_Wizard16x16 | Creates a copy of Wizard16x16. Despite the name this does not use Clone, it creates a fresh copy.
Top
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Add16x16 Method

ImagesClone_Add16x16 Method
Creates a copy of Add16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Add16x16()
Public Shared Function Clone_Add16x16 As Bitmap
public:
static Bitmap^ Clone_Add16x16()
static member Clone_Add16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ApplicationIcon Method

ImagesClone_ApplicationIcon Method
Creates a copy of ApplicationIcon. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Icon Clone_ApplicationIcon()
Public Shared Function Clone_ApplicationIcon As Icon
public:
static Icon^ Clone_ApplicationIcon()
static member Clone_ApplicationIcon : unit -> Icon

Return Value

Type: Icon
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ArrowBack16x16 Method

ImagesClone_ArrowBack16x16 Method
Creates a copy of ArrowBack16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_ArrowBack16x16()
Public Shared Function Clone_ArrowBack16x16 As Bitmap
public:
static Bitmap^ Clone_ArrowBack16x16()
static member Clone_ArrowBack16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ArrowForward16x16 Method

ImagesClone_ArrowForward16x16 Method
Creates a copy of ArrowForward16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_ArrowForward16x16()
Public Shared Function Clone_ArrowForward16x16 As Bitmap
public:
static Bitmap^ Clone_ArrowForward16x16()
static member Clone_ArrowForward16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_BlueBall Method

ImagesClone_BlueBall Method
Creates a copy of BlueBall. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_BlueBall()
Public Shared Function Clone_BlueBall As Bitmap
public:
static Bitmap^ Clone_BlueBall()
static member Clone_BlueBall : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Cancel16x16 Method

ImagesClone_Cancel16x16 Method
Creates a copy of Cancel16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Cancel16x16()
Public Shared Function Clone_Cancel16x16 As Bitmap
public:
static Bitmap^ Clone_Cancel16x16()
static member Clone_Cancel16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_CancelSmall16x16 Method

ImagesClone_CancelSmall16x16 Method
Creates a copy of CancelSmall16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_CancelSmall16x16()
Public Shared Function Clone_CancelSmall16x16 As Bitmap
public:
static Bitmap^ Clone_CancelSmall16x16()
static member Clone_CancelSmall16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ChevronBlueCircle Method

ImagesClone_ChevronBlueCircle Method
Creates a copy of ChevronBlueCircle. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_ChevronBlueCircle()
Public Shared Function Clone_ChevronBlueCircle As Bitmap
public:
static Bitmap^ Clone_ChevronBlueCircle()
static member Clone_ChevronBlueCircle : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ChevronGreenCircle Method

ImagesClone_ChevronGreenCircle Method
Creates a copy of ChevronGreenCircle. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_ChevronGreenCircle()
Public Shared Function Clone_ChevronGreenCircle As Bitmap
public:
static Bitmap^ Clone_ChevronGreenCircle()
static member Clone_ChevronGreenCircle : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ChevronRedCircle Method

ImagesClone_ChevronRedCircle Method
Creates a copy of ChevronRedCircle. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_ChevronRedCircle()
Public Shared Function Clone_ChevronRedCircle As Bitmap
public:
static Bitmap^ Clone_ChevronRedCircle()
static member Clone_ChevronRedCircle : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_CloseSlider Method

ImagesClone_CloseSlider Method
Creates a copy of CloseSlider. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_CloseSlider()
Public Shared Function Clone_CloseSlider As Bitmap
public:
static Bitmap^ Clone_CloseSlider()
static member Clone_CloseSlider : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Collapse Method

ImagesClone_Collapse Method
Creates a copy of Collapse. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Collapse()
Public Shared Function Clone_Collapse As Bitmap
public:
static Bitmap^ Clone_Collapse()
static member Clone_Collapse : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Compass Method

ImagesClone_Compass Method
Creates a copy of Compass. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Compass()
Public Shared Function Clone_Compass As Bitmap
public:
static Bitmap^ Clone_Compass()
static member Clone_Compass : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Corner_BottomLeft Method

ImagesClone_Corner_BottomLeft Method
Creates a copy of Corner_BottomLeft. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Corner_BottomLeft()
Public Shared Function Clone_Corner_BottomLeft As Bitmap
public:
static Bitmap^ Clone_Corner_BottomLeft()
static member Clone_Corner_BottomLeft : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Corner_BottomRight Method

ImagesClone_Corner_BottomRight Method
Creates a copy of Corner_BottomRight. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Corner_BottomRight()
Public Shared Function Clone_Corner_BottomRight As Bitmap
public:
static Bitmap^ Clone_Corner_BottomRight()
static member Clone_Corner_BottomRight : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Corner_TopLeft Method

ImagesClone_Corner_TopLeft Method
Creates a copy of Corner_TopLeft. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Corner_TopLeft()
Public Shared Function Clone_Corner_TopLeft As Bitmap
public:
static Bitmap^ Clone_Corner_TopLeft()
static member Clone_Corner_TopLeft : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Corner_TopRight Method

ImagesClone_Corner_TopRight Method
Creates a copy of Corner_TopRight. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Corner_TopRight()
Public Shared Function Clone_Corner_TopRight As Bitmap
public:
static Bitmap^ Clone_Corner_TopRight()
static member Clone_Corner_TopRight : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Crosshair Method

ImagesClone_Crosshair Method
Creates a copy of Crosshair. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Crosshair()
Public Shared Function Clone_Crosshair As Bitmap
public:
static Bitmap^ Clone_Crosshair()
static member Clone_Crosshair : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Decoding16x16 Method

ImagesClone_Decoding16x16 Method
Creates a copy of Decoding16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Decoding16x16()
Public Shared Function Clone_Decoding16x16 As Bitmap
public:
static Bitmap^ Clone_Decoding16x16()
static member Clone_Decoding16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Edit16x16 Method

ImagesClone_Edit16x16 Method
Creates a copy of Edit16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Edit16x16()
Public Shared Function Clone_Edit16x16 As Bitmap
public:
static Bitmap^ Clone_Edit16x16()
static member Clone_Edit16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Expand Method

ImagesClone_Expand Method
Creates a copy of Expand. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Expand()
Public Shared Function Clone_Expand As Bitmap
public:
static Bitmap^ Clone_Expand()
static member Clone_Expand : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Favicon Method

ImagesClone_Favicon Method
Creates a copy of Favicon. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Icon Clone_Favicon()
Public Shared Function Clone_Favicon As Icon
public:
static Icon^ Clone_Favicon()
static member Clone_Favicon : unit -> Icon

Return Value

Type: Icon
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_FollowMe Method

ImagesClone_FollowMe Method
Creates a copy of FollowMe. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_FollowMe()
Public Shared Function Clone_FollowMe As Bitmap
public:
static Bitmap^ Clone_FollowMe()
static member Clone_FollowMe : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Gear16x16 Method

ImagesClone_Gear16x16 Method
Creates a copy of Gear16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Gear16x16()
Public Shared Function Clone_Gear16x16 As Bitmap
public:
static Bitmap^ Clone_Gear16x16()
static member Clone_Gear16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_GotoCurrentLocation Method

ImagesClone_GotoCurrentLocation Method
Creates a copy of GotoCurrentLocation. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_GotoCurrentLocation()
Public Shared Function Clone_GotoCurrentLocation As Bitmap
public:
static Bitmap^ Clone_GotoCurrentLocation()
static member Clone_GotoCurrentLocation : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_HelpAbout Method

ImagesClone_HelpAbout Method
Creates a copy of HelpAbout. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_HelpAbout()
Public Shared Function Clone_HelpAbout As Bitmap
public:
static Bitmap^ Clone_HelpAbout()
static member Clone_HelpAbout : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_HideList Method

ImagesClone_HideList Method
Creates a copy of HideList. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_HideList()
Public Shared Function Clone_HideList As Bitmap
public:
static Bitmap^ Clone_HideList()
static member Clone_HideList : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPadSplash Method

ImagesClone_IPadSplash Method
Creates a copy of IPadSplash. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPadSplash()
Public Shared Function Clone_IPadSplash As Bitmap
public:
static Bitmap^ Clone_IPadSplash()
static member Clone_IPadSplash : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneBackButton Method

ImagesClone_IPhoneBackButton Method
Creates a copy of IPhoneBackButton. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneBackButton()
Public Shared Function Clone_IPhoneBackButton As Bitmap
public:
static Bitmap^ Clone_IPhoneBackButton()
static member Clone_IPhoneBackButton : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneBlueButton Method

ImagesClone_IPhoneBlueButton Method
Creates a copy of IPhoneBlueButton. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneBlueButton()
Public Shared Function Clone_IPhoneBlueButton As Bitmap
public:
static Bitmap^ Clone_IPhoneBlueButton()
static member Clone_IPhoneBlueButton : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneChevron Method

ImagesClone_IPhoneChevron Method
Creates a copy of IPhoneChevron. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneChevron()
Public Shared Function Clone_IPhoneChevron As Bitmap
public:
static Bitmap^ Clone_IPhoneChevron()
static member Clone_IPhoneChevron : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneGrayButton Method

ImagesClone_IPhoneGrayButton Method
Creates a copy of IPhoneGrayButton. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneGrayButton()
Public Shared Function Clone_IPhoneGrayButton As Bitmap
public:
static Bitmap^ Clone_IPhoneGrayButton()
static member Clone_IPhoneGrayButton : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneIcon Method

ImagesClone_IPhoneIcon Method
Creates a copy of IPhoneIcon. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneIcon()
Public Shared Function Clone_IPhoneIcon As Bitmap
public:
static Bitmap^ Clone_IPhoneIcon()
static member Clone_IPhoneIcon : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneListGroup Method

ImagesClone_IPhoneListGroup Method
Creates a copy of IPhoneListGroup. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneListGroup()
Public Shared Function Clone_IPhoneListGroup As Bitmap
public:
static Bitmap^ Clone_IPhoneListGroup()
static member Clone_IPhoneListGroup : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneOnOff Method

ImagesClone_IPhoneOnOff Method
Creates a copy of IPhoneOnOff. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneOnOff()
Public Shared Function Clone_IPhoneOnOff As Bitmap
public:
static Bitmap^ Clone_IPhoneOnOff()
static member Clone_IPhoneOnOff : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhonePinstripes Method

ImagesClone_IPhonePinstripes Method
Creates a copy of IPhonePinstripes. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhonePinstripes()
Public Shared Function Clone_IPhonePinstripes As Bitmap
public:
static Bitmap^ Clone_IPhonePinstripes()
static member Clone_IPhonePinstripes : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneSelectedTick Method

ImagesClone_IPhoneSelectedTick Method
Creates a copy of IPhoneSelectedTick. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneSelectedTick()
Public Shared Function Clone_IPhoneSelectedTick As Bitmap
public:
static Bitmap^ Clone_IPhoneSelectedTick()
static member Clone_IPhoneSelectedTick : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneSelection Method

ImagesClone_IPhoneSelection Method
Creates a copy of IPhoneSelection. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneSelection()
Public Shared Function Clone_IPhoneSelection As Bitmap
public:
static Bitmap^ Clone_IPhoneSelection()
static member Clone_IPhoneSelection : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneSplash Method

ImagesClone_IPhoneSplash Method
Creates a copy of IPhoneSplash. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneSplash()
Public Shared Function Clone_IPhoneSplash As Bitmap
public:
static Bitmap^ Clone_IPhoneSplash()
static member Clone_IPhoneSplash : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneToolbar Method

ImagesClone_IPhoneToolbar Method
Creates a copy of IPhoneToolbar. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneToolbar()
Public Shared Function Clone_IPhoneToolbar As Bitmap
public:
static Bitmap^ Clone_IPhoneToolbar()
static member Clone_IPhoneToolbar : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneToolButton Method

ImagesClone_IPhoneToolButton Method
Creates a copy of IPhoneToolButton. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneToolButton()
Public Shared Function Clone_IPhoneToolButton As Bitmap
public:
static Bitmap^ Clone_IPhoneToolButton()
static member Clone_IPhoneToolButton : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_IPhoneWhiteButton Method

ImagesClone_IPhoneWhiteButton Method
Creates a copy of IPhoneWhiteButton. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_IPhoneWhiteButton()
Public Shared Function Clone_IPhoneWhiteButton As Bitmap
public:
static Bitmap^ Clone_IPhoneWhiteButton()
static member Clone_IPhoneWhiteButton : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Location16x16 Method

ImagesClone_Location16x16 Method
Creates a copy of Location16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Location16x16()
Public Shared Function Clone_Location16x16 As Bitmap
public:
static Bitmap^ Clone_Location16x16()
static member Clone_Location16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Logo128x128 Method

ImagesClone_Logo128x128 Method
Creates a copy of Logo128x128. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Logo128x128()
Public Shared Function Clone_Logo128x128 As Bitmap
public:
static Bitmap^ Clone_Logo128x128()
static member Clone_Logo128x128 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Marker_Airplane Method

ImagesClone_Marker_Airplane Method
Creates a copy of Marker_Airplane. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Marker_Airplane()
Public Shared Function Clone_Marker_Airplane As Bitmap
public:
static Bitmap^ Clone_Marker_Airplane()
static member Clone_Marker_Airplane : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Marker_AirplaneSelected Method

ImagesClone_Marker_AirplaneSelected Method
Creates a copy of Marker_AirplaneSelected. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Marker_AirplaneSelected()
Public Shared Function Clone_Marker_AirplaneSelected As Bitmap
public:
static Bitmap^ Clone_Marker_AirplaneSelected()
static member Clone_Marker_AirplaneSelected : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_MergedFeed16x16 Method

ImagesClone_MergedFeed16x16 Method
Creates a copy of MergedFeed16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_MergedFeed16x16()
Public Shared Function Clone_MergedFeed16x16 As Bitmap
public:
static Bitmap^ Clone_MergedFeed16x16()
static member Clone_MergedFeed16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_MovingMapChecked Method

ImagesClone_MovingMapChecked Method
Creates a copy of MovingMapChecked. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_MovingMapChecked()
Public Shared Function Clone_MovingMapChecked As Bitmap
public:
static Bitmap^ Clone_MovingMapChecked()
static member Clone_MovingMapChecked : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_MovingMapUnchecked Method

ImagesClone_MovingMapUnchecked Method
Creates a copy of MovingMapUnchecked. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_MovingMapUnchecked()
Public Shared Function Clone_MovingMapUnchecked As Bitmap
public:
static Bitmap^ Clone_MovingMapUnchecked()
static member Clone_MovingMapUnchecked : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Notebook16x16 Method

ImagesClone_Notebook16x16 Method
Creates a copy of Notebook16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Notebook16x16()
Public Shared Function Clone_Notebook16x16 As Bitmap
public:
static Bitmap^ Clone_Notebook16x16()
static member Clone_Notebook16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_OpenSlider Method

ImagesClone_OpenSlider Method
Creates a copy of OpenSlider. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_OpenSlider()
Public Shared Function Clone_OpenSlider As Bitmap
public:
static Bitmap^ Clone_OpenSlider()
static member Clone_OpenSlider : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Radio16x16 Method

ImagesClone_Radio16x16 Method
Creates a copy of Radio16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Radio16x16()
Public Shared Function Clone_Radio16x16 As Bitmap
public:
static Bitmap^ Clone_Radio16x16()
static member Clone_Radio16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Radio48x48 Method

ImagesClone_Radio48x48 Method
Creates a copy of Radio48x48. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Radio48x48()
Public Shared Function Clone_Radio48x48 As Bitmap
public:
static Bitmap^ Clone_Radio48x48()
static member Clone_Radio48x48 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Rebroadcast16x16 Method

ImagesClone_Rebroadcast16x16 Method
Creates a copy of Rebroadcast16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Rebroadcast16x16()
Public Shared Function Clone_Rebroadcast16x16 As Bitmap
public:
static Bitmap^ Clone_Rebroadcast16x16()
static member Clone_Rebroadcast16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_RowHeader Method

ImagesClone_RowHeader Method
Creates a copy of RowHeader. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_RowHeader()
Public Shared Function Clone_RowHeader As Bitmap
public:
static Bitmap^ Clone_RowHeader()
static member Clone_RowHeader : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_RowHeaderSelected Method

ImagesClone_RowHeaderSelected Method
Creates a copy of RowHeaderSelected. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_RowHeaderSelected()
Public Shared Function Clone_RowHeaderSelected As Bitmap
public:
static Bitmap^ Clone_RowHeaderSelected()
static member Clone_RowHeaderSelected : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Server16x16 Method

ImagesClone_Server16x16 Method
Creates a copy of Server16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Server16x16()
Public Shared Function Clone_Server16x16 As Bitmap
public:
static Bitmap^ Clone_Server16x16()
static member Clone_Server16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_ShowList Method

ImagesClone_ShowList Method
Creates a copy of ShowList. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_ShowList()
Public Shared Function Clone_ShowList As Bitmap
public:
static Bitmap^ Clone_ShowList()
static member Clone_ShowList : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Site16x16 Method

ImagesClone_Site16x16 Method
Creates a copy of Site16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Site16x16()
Public Shared Function Clone_Site16x16 As Bitmap
public:
static Bitmap^ Clone_Site16x16()
static member Clone_Site16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_SmallPlaneNorth Method

ImagesClone_SmallPlaneNorth Method
Creates a copy of SmallPlaneNorth. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_SmallPlaneNorth()
Public Shared Function Clone_SmallPlaneNorth As Bitmap
public:
static Bitmap^ Clone_SmallPlaneNorth()
static member Clone_SmallPlaneNorth : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Test16x16 Method

ImagesClone_Test16x16 Method
Creates a copy of Test16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Test16x16()
Public Shared Function Clone_Test16x16 As Bitmap
public:
static Bitmap^ Clone_Test16x16()
static member Clone_Test16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_TestSquare Method

ImagesClone_TestSquare Method
Creates a copy of TestSquare. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_TestSquare()
Public Shared Function Clone_TestSquare As Bitmap
public:
static Bitmap^ Clone_TestSquare()
static member Clone_TestSquare : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Tower Method

ImagesClone_Tower Method
Creates a copy of Tower. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Tower()
Public Shared Function Clone_Tower As Bitmap
public:
static Bitmap^ Clone_Tower()
static member Clone_Tower : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Transparent_16x16 Method

ImagesClone_Transparent_16x16 Method
Creates a copy of Transparent_16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Transparent_16x16()
Public Shared Function Clone_Transparent_16x16 As Bitmap
public:
static Bitmap^ Clone_Transparent_16x16()
static member Clone_Transparent_16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Transparent_25 Method

ImagesClone_Transparent_25 Method
Creates a copy of Transparent_25. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Transparent_25()
Public Shared Function Clone_Transparent_25 As Bitmap
public:
static Bitmap^ Clone_Transparent_25()
static member Clone_Transparent_25 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Transparent_50 Method

ImagesClone_Transparent_50 Method
Creates a copy of Transparent_50. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Transparent_50()
Public Shared Function Clone_Transparent_50 As Bitmap
public:
static Bitmap^ Clone_Transparent_50()
static member Clone_Transparent_50 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_User16x16 Method

ImagesClone_User16x16 Method
Creates a copy of User16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_User16x16()
Public Shared Function Clone_User16x16 As Bitmap
public:
static Bitmap^ Clone_User16x16()
static member Clone_User16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Volume0 Method

ImagesClone_Volume0 Method
Creates a copy of Volume0. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Volume0()
Public Shared Function Clone_Volume0 As Bitmap
public:
static Bitmap^ Clone_Volume0()
static member Clone_Volume0 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Volume100 Method

ImagesClone_Volume100 Method
Creates a copy of Volume100. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Volume100()
Public Shared Function Clone_Volume100 As Bitmap
public:
static Bitmap^ Clone_Volume100()
static member Clone_Volume100 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Volume25 Method

ImagesClone_Volume25 Method
Creates a copy of Volume25. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Volume25()
Public Shared Function Clone_Volume25 As Bitmap
public:
static Bitmap^ Clone_Volume25()
static member Clone_Volume25 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Volume50 Method

ImagesClone_Volume50 Method
Creates a copy of Volume50. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Volume50()
Public Shared Function Clone_Volume50 As Bitmap
public:
static Bitmap^ Clone_Volume50()
static member Clone_Volume50 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Volume75 Method

ImagesClone_Volume75 Method
Creates a copy of Volume75. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Volume75()
Public Shared Function Clone_Volume75 As Bitmap
public:
static Bitmap^ Clone_Volume75()
static member Clone_Volume75 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_VolumeDown Method

ImagesClone_VolumeDown Method
Creates a copy of VolumeDown. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_VolumeDown()
Public Shared Function Clone_VolumeDown As Bitmap
public:
static Bitmap^ Clone_VolumeDown()
static member Clone_VolumeDown : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_VolumeMute Method

ImagesClone_VolumeMute Method
Creates a copy of VolumeMute. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_VolumeMute()
Public Shared Function Clone_VolumeMute As Bitmap
public:
static Bitmap^ Clone_VolumeMute()
static member Clone_VolumeMute : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_VolumeUp Method

ImagesClone_VolumeUp Method
Creates a copy of VolumeUp. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_VolumeUp()
Public Shared Function Clone_VolumeUp As Bitmap
public:
static Bitmap^ Clone_VolumeUp()
static member Clone_VolumeUp : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_WarningBitmap Method

ImagesClone_WarningBitmap Method
Creates a copy of WarningBitmap. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_WarningBitmap()
Public Shared Function Clone_WarningBitmap As Bitmap
public:
static Bitmap^ Clone_WarningBitmap()
static member Clone_WarningBitmap : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_WarningIcon Method

ImagesClone_WarningIcon Method
Creates a copy of WarningIcon. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Icon Clone_WarningIcon()
Public Shared Function Clone_WarningIcon As Icon
public:
static Icon^ Clone_WarningIcon()
static member Clone_WarningIcon : unit -> Icon

Return Value

Type: Icon
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


Images.Clone_Wizard16x16 Method

ImagesClone_Wizard16x16 Method
Creates a copy of Wizard16x16. Despite the name this does not use Clone, it creates a fresh copy.

Namespace: VirtualRadar.Resources
Assembly: VirtualRadar.Resources (in VirtualRadar.Resources.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Bitmap Clone_Wizard16x16()
Public Shared Function Clone_Wizard16x16 As Bitmap
public:
static Bitmap^ Clone_Wizard16x16()
static member Clone_Wizard16x16 : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

Images Class
VirtualRadar.Resources Namespace


VirtualRadar.WebServer Namespace

VirtualRadar.WebServer Namespace
The namespace that holds implementations of the WebServer interfaces.
Classes
 | Class | Description
Public class | Implementations | Initialises the class factory with all the standard implementations in this library.
Remarks
None of the implementations are public, you must use the class factory to access them.


Implementations Class

Implementations Class
Initialises the class factory with all the standard implementations in this library.
Inheritance Hierarchy
SystemObject
VirtualRadar.WebServerImplementations

Namespace: VirtualRadar.WebServer
Assembly: VirtualRadar.WebServer (in VirtualRadar.WebServer.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Implementations
Public NotInheritable Class Implementations
public ref class Implementations abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Implementations =  class end

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

VirtualRadar.WebServer Namespace


Implementations Methods

Implementations Methods

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

Implementations Class
VirtualRadar.WebServer Namespace


Implementations.Register Method

ImplementationsRegister Method
Initialises the class factory with all the standard implementations in this library.

Namespace: VirtualRadar.WebServer
Assembly: VirtualRadar.WebServer (in VirtualRadar.WebServer.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Register(
    IClassFactory factory
)
Public Shared Sub Register (
    factory As IClassFactory
)
public:
static void Register(
    IClassFactory^ factory
)
static member Register :
        factory : IClassFactory -> unit

Parameters

factory
Type: InterfaceFactoryIClassFactory
See Also

Reference

Implementations Class
VirtualRadar.WebServer Namespace


VirtualRadar.WebSite Namespace

VirtualRadar.WebSite Namespace
The namespace that holds implementations of the WebSite interfaces.
Classes
 | Class | Description
Public class | HtmlLocaliser | The default implementation of IHtmlLocaliser.
Public class | Implementations | Initialises the class factory with all the standard implementations in this library.
Remarks
None of the implementations are public, you must use the class factory to access them.


HtmlLocaliser Class

HtmlLocaliser Class
The default implementation of IHtmlLocaliser.
Inheritance Hierarchy
SystemObject
VirtualRadar.WebSiteHtmlLocaliser

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlLocaliser : IHtmlLocaliser
Public Class HtmlLocaliser
    Implements IHtmlLocaliser
public ref class HtmlLocaliser : IHtmlLocaliser
type HtmlLocaliser =
    class
        interface IHtmlLocaliser
    end

The HtmlLocaliser type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlLocaliser | Initializes a new instance of the HtmlLocaliser class
Top
Properties
 | Name | Description
Public property | LocalisedStringsMap | See interface docs.
Top
Methods
 | Name | Description
Public method | AddResourceStrings | See interface docs.
Public method | ConvertResourceStringToHtmlString | See interface docs.
Public method | ConvertResourceStringToJavaScriptString | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedText | Returns the localised version of the text passed across.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Html | See interface docs.
Public method | Initialise | See interface docs.
Public method | Initialise(Type) | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.WebSite Namespace


HtmlLocaliser Constructor

HtmlLocaliser Constructor
Initializes a new instance of the HtmlLocaliser class

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlLocaliser()
Public Sub New
public:
HtmlLocaliser()
new : unit -> HtmlLocaliser
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser Properties

HtmlLocaliser Properties

The HtmlLocaliser type exposes the following members.

Properties
 | Name | Description
Public property | LocalisedStringsMap | See interface docs.
Top
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.LocalisedStringsMap Property

HtmlLocaliserLocalisedStringsMap Property
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalisedStringsMap LocalisedStringsMap { get; }
Public ReadOnly Property LocalisedStringsMap As LocalisedStringsMap
    Get
public:
virtual property LocalisedStringsMap^ LocalisedStringsMap {
    LocalisedStringsMap^ get () sealed;
}
abstract LocalisedStringsMap : LocalisedStringsMap with get
override LocalisedStringsMap : LocalisedStringsMap with get

Property Value

Type: LocalisedStringsMap

Implements

IHtmlLocaliserLocalisedStringsMap
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser Methods

HtmlLocaliser Methods

The HtmlLocaliser type exposes the following members.

Methods
 | Name | Description
Public method | AddResourceStrings | See interface docs.
Public method | ConvertResourceStringToHtmlString | See interface docs.
Public method | ConvertResourceStringToJavaScriptString | See interface docs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalisedText | Returns the localised version of the text passed across.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Html | See interface docs.
Public method | Initialise | See interface docs.
Public method | Initialise(Type) | See interface docs.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.AddResourceStrings Method

HtmlLocaliserAddResourceStrings Method
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResourceStrings(
    Type resourceStringsType
)
Public Sub AddResourceStrings (
    resourceStringsType As Type
)
public:
virtual void AddResourceStrings(
    Type^ resourceStringsType
) sealed
abstract AddResourceStrings :
        resourceStringsType : Type -> unit
override AddResourceStrings :
        resourceStringsType : Type -> unit

Parameters

resourceStringsType
Type: SystemType

Implements

IHtmlLocaliserAddResourceStrings(Type)
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.ConvertResourceStringToHtmlString Method

HtmlLocaliserConvertResourceStringToHtmlString Method
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConvertResourceStringToHtmlString(
    string resourceString
)
Public Function ConvertResourceStringToHtmlString (
    resourceString As String
) As String
public:
virtual String^ ConvertResourceStringToHtmlString(
    String^ resourceString
) sealed
abstract ConvertResourceStringToHtmlString :
        resourceString : string -> string
override ConvertResourceStringToHtmlString :
        resourceString : string -> string

Parameters

resourceString
Type: SystemString

Return Value

Type: String

Implements

IHtmlLocaliserConvertResourceStringToHtmlString(String)
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.ConvertResourceStringToJavaScriptString Method

HtmlLocaliserConvertResourceStringToJavaScriptString Method
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConvertResourceStringToJavaScriptString(
    string resourceString,
    char stringDelimiter
)
Public Function ConvertResourceStringToJavaScriptString (
    resourceString As String,
    stringDelimiter As Char
) As String
public:
virtual String^ ConvertResourceStringToJavaScriptString(
    String^ resourceString,
    wchar_t stringDelimiter
) sealed
abstract ConvertResourceStringToJavaScriptString :
        resourceString : string *
        stringDelimiter : char -> string
override ConvertResourceStringToJavaScriptString :
        resourceString : string *
        stringDelimiter : char -> string

Parameters

resourceString
Type: SystemString
stringDelimiter
Type: SystemChar

Return Value

Type: String

Implements

IHtmlLocaliserConvertResourceStringToJavaScriptString(String, Char)
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.GetLocalisedText Method

HtmlLocaliserGetLocalisedText Method
Returns the localised version of the text passed across.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetLocalisedText(
    string text
)
Public Function GetLocalisedText (
    text As String
) As String
public:
String^ GetLocalisedText(
    String^ text
)
member GetLocalisedText :
        text : string -> string

Parameters

text
Type: SystemString

Return Value

Type: String
Remarks
If the text starts and ends with :: then the inner part is taken to be the name of a string in Strings and it's returned.
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.Html Method

HtmlLocaliserHtml Method
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Html(
    string html,
    Encoding encoding
)
Public Function Html (
    html As String,
    encoding As Encoding
) As String
public:
virtual String^ Html(
    String^ html,
    Encoding^ encoding
) sealed
abstract Html :
        html : string *
        encoding : Encoding -> string
override Html :
        html : string *
        encoding : Encoding -> string

Parameters

html
Type: SystemString
encoding
Type: System.TextEncoding

Return Value

Type: String

Implements

IHtmlLocaliserHtml(String, Encoding)
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.Initialise Method

HtmlLocaliserInitialise Method
Overload List
 | Name | Description
Public method | Initialise | See interface docs.
Public method | Initialise(Type) | See interface docs.
Top
See Also

Reference

HtmlLocaliser Class
VirtualRadar.WebSite Namespace


HtmlLocaliser.Initialise Method

HtmlLocaliserInitialise Method
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise()
Public Sub Initialise
public:
virtual void Initialise() sealed
abstract Initialise : unit -> unit
override Initialise : unit -> unit

Implements

IHtmlLocaliserInitialise
See Also

Reference

HtmlLocaliser Class
Initialise Overload
VirtualRadar.WebSite Namespace


HtmlLocaliser.Initialise Method (Type)

HtmlLocaliserInitialise Method (Type)
See interface docs.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise(
    Type resourceStringsType
)
Public Sub Initialise (
    resourceStringsType As Type
)
public:
virtual void Initialise(
    Type^ resourceStringsType
) sealed
abstract Initialise :
        resourceStringsType : Type -> unit
override Initialise :
        resourceStringsType : Type -> unit

Parameters

resourceStringsType
Type: SystemType

Implements

IHtmlLocaliserInitialise(Type)
See Also

Reference

HtmlLocaliser Class
Initialise Overload
VirtualRadar.WebSite Namespace


Implementations Class

Implementations Class
Initialises the class factory with all the standard implementations in this library.
Inheritance Hierarchy
SystemObject
VirtualRadar.WebSiteImplementations

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Implementations
Public NotInheritable Class Implementations
public ref class Implementations abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Implementations =  class end

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

VirtualRadar.WebSite Namespace


Implementations Methods

Implementations Methods

The Implementations type exposes the following members.

Methods
Name | Description
Register | Initialises the class factory with all the standard implementations in this library.
Top
See Also

Reference

Implementations Class
VirtualRadar.WebSite Namespace


Implementations.Register Method

ImplementationsRegister Method
Initialises the class factory with all the standard implementations in this library.

Namespace: VirtualRadar.WebSite
Assembly: VirtualRadar.WebSite (in VirtualRadar.WebSite.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Register(
    IClassFactory factory
)
Public Shared Sub Register (
    factory As IClassFactory
)
public:
static void Register(
    IClassFactory^ factory
)
static member Register :
        factory : IClassFactory -> unit

Parameters

factory
Type: InterfaceFactoryIClassFactory
See Also

Reference

Implementations Class
VirtualRadar.WebSite Namespace


VirtualRadar.WinForms.Controls Namespace

VirtualRadar.WinForms.Controls Namespace
The namespace that holds WinForms user controls and common controls.
Classes
 | Class | Description
Public class | FileNameControl | A user control containing a filename textbox control and a browse button.
Public class | FolderControl | A user control containing a directory textbox control and a browse button.
Remarks

Many of the controls here are tied strongly to the forms in VirtualRadar.WinForms but plugins may be interested in the common controls FileNameControl and FolderControl.


FileNameControl Class

FileNameControl Class
A user control containing a filename textbox control and a browse button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.ControlsFileNameControl

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileNameControl : BaseUserControl
Public Class FileNameControl
    Inherits BaseUserControl
public ref class FileNameControl : public BaseUserControl
type FileNameControl =
    class
        inherit BaseUserControl
    end

The FileNameControl type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameControl | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BrowserAddExtension | Gets or sets the AddExtension browser property.
Public property | BrowserCheckFileExists | Gets or sets the CheckFileExists browser property.
Public property | BrowserDefaultExt | Gets or sets the DefaultExt browser property.
Public property | BrowserDefaultFolder | Gets or sets the default folder to open on.
Public property | BrowserFilter | Gets or sets the Filter browser property.
Public property | BrowserTitle | Gets or sets the Title browser property.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileName | Gets or sets the name of the file.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFileNameTextChanged | Raises FileNameTextChanged.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FileNameTextChanged | Raised when the filename text is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

VirtualRadar.WinForms.Controls Namespace


FileNameControl Constructor

FileNameControl Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileNameControl()
Public Sub New
public:
FileNameControl()
new : unit -> FileNameControl
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl Properties

FileNameControl Properties

The FileNameControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BrowserAddExtension | Gets or sets the AddExtension browser property.
Public property | BrowserCheckFileExists | Gets or sets the CheckFileExists browser property.
Public property | BrowserDefaultExt | Gets or sets the DefaultExt browser property.
Public property | BrowserDefaultFolder | Gets or sets the default folder to open on.
Public property | BrowserFilter | Gets or sets the Filter browser property.
Public property | BrowserTitle | Gets or sets the Title browser property.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileName | Gets or sets the name of the file.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.BrowserAddExtension Property

FileNameControlBrowserAddExtension Property
Gets or sets the AddExtension browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BrowserAddExtension { get; set; }
Public Property BrowserAddExtension As Boolean
    Get
    Set
public:
property bool BrowserAddExtension {
    bool get ();
    void set (bool value);
}
member BrowserAddExtension : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.BrowserCheckFileExists Property

FileNameControlBrowserCheckFileExists Property
Gets or sets the CheckFileExists browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BrowserCheckFileExists { get; set; }
Public Property BrowserCheckFileExists As Boolean
    Get
    Set
public:
property bool BrowserCheckFileExists {
    bool get ();
    void set (bool value);
}
member BrowserCheckFileExists : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.BrowserDefaultExt Property

FileNameControlBrowserDefaultExt Property
Gets or sets the DefaultExt browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BrowserDefaultExt { get; set; }
Public Property BrowserDefaultExt As String
    Get
    Set
public:
property String^ BrowserDefaultExt {
    String^ get ();
    void set (String^ value);
}
member BrowserDefaultExt : string with get, set

Property Value

Type: String
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.BrowserDefaultFolder Property

FileNameControlBrowserDefaultFolder Property
Gets or sets the default folder to open on.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BrowserDefaultFolder { get; set; }
Public Property BrowserDefaultFolder As String
    Get
    Set
public:
property String^ BrowserDefaultFolder {
    String^ get ();
    void set (String^ value);
}
member BrowserDefaultFolder : string with get, set

Property Value

Type: String
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.BrowserFilter Property

FileNameControlBrowserFilter Property
Gets or sets the Filter browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BrowserFilter { get; set; }
Public Property BrowserFilter As String
    Get
    Set
public:
property String^ BrowserFilter {
    String^ get ();
    void set (String^ value);
}
member BrowserFilter : string with get, set

Property Value

Type: String
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.BrowserTitle Property

FileNameControlBrowserTitle Property
Gets or sets the Title browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BrowserTitle { get; set; }
Public Property BrowserTitle As String
    Get
    Set
public:
property String^ BrowserTitle {
    String^ get ();
    void set (String^ value);
}
member BrowserTitle : string with get, set

Property Value

Type: String
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.FileName Property

FileNameControlFileName Property
Gets or sets the name of the file.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl Methods

FileNameControl Methods

The FileNameControl type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFileNameTextChanged | Raises FileNameTextChanged.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.Dispose Method

FileNameControlDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Top
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.Dispose Method (Boolean)

FileNameControlDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

FileNameControl Class
Dispose Overload
VirtualRadar.WinForms.Controls Namespace


FileNameControl.OnFileNameTextChanged Method

FileNameControlOnFileNameTextChanged Method
Raises FileNameTextChanged.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnFileNameTextChanged(
    EventArgs args
)
Protected Overridable Sub OnFileNameTextChanged (
    args As EventArgs
)
protected:
virtual void OnFileNameTextChanged(
    EventArgs^ args
)
abstract OnFileNameTextChanged :
        args : EventArgs -> unit
override OnFileNameTextChanged :
        args : EventArgs -> unit

Parameters

args
Type: SystemEventArgs
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl Events

FileNameControl Events

The FileNameControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FileNameTextChanged | Raised when the filename text is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FileNameControl.FileNameTextChanged Event

FileNameControlFileNameTextChanged Event
Raised when the filename text is changed.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FileNameTextChanged
Public Event FileNameTextChanged As EventHandler
public:
 event EventHandler^ FileNameTextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member FileNameTextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

FileNameControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl Class

FolderControl Class
A user control containing a directory textbox control and a browse button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.ControlsFolderControl

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FolderControl : BaseUserControl
Public Class FolderControl
    Inherits BaseUserControl
public ref class FolderControl : public BaseUserControl
type FolderControl =
    class
        inherit BaseUserControl
    end

The FolderControl type exposes the following members.

Constructors
 | Name | Description
Public method | FolderControl | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BrowserDescription | Gets or sets the Description browser property.
Public property | BrowserShowNewFolderButton | Gets or sets the ShowNewFolderButton browser property.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Folder | Gets or sets the name of the folder.
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFolderTextChanged | Raises FolderTextChanged.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FolderTextChanged | Raised when the folder text is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

VirtualRadar.WinForms.Controls Namespace


FolderControl Constructor

FolderControl Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FolderControl()
Public Sub New
public:
FolderControl()
new : unit -> FolderControl
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl Properties

FolderControl Properties

The FolderControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | BrowserDescription | Gets or sets the Description browser property.
Public property | BrowserShowNewFolderButton | Gets or sets the ShowNewFolderButton browser property.
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Folder | Gets or sets the name of the folder.
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl.BrowserDescription Property

FolderControlBrowserDescription Property
Gets or sets the Description browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BrowserDescription { get; set; }
Public Property BrowserDescription As String
    Get
    Set
public:
property String^ BrowserDescription {
    String^ get ();
    void set (String^ value);
}
member BrowserDescription : string with get, set

Property Value

Type: String
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl.BrowserShowNewFolderButton Property

FolderControlBrowserShowNewFolderButton Property
Gets or sets the ShowNewFolderButton browser property.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BrowserShowNewFolderButton { get; set; }
Public Property BrowserShowNewFolderButton As Boolean
    Get
    Set
public:
property bool BrowserShowNewFolderButton {
    bool get ();
    void set (bool value);
}
member BrowserShowNewFolderButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl.Folder Property

FolderControlFolder Property
Gets or sets the name of the folder.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Property Value

Type: String
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl Methods

FolderControl Methods

The FolderControl type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFolderTextChanged | Raises FolderTextChanged.
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from UserControl.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl.Dispose Method

FolderControlDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Top
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl.Dispose Method (Boolean)

FolderControlDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

FolderControl Class
Dispose Overload
VirtualRadar.WinForms.Controls Namespace


FolderControl.OnFolderTextChanged Method

FolderControlOnFolderTextChanged Method
Raises FolderTextChanged.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnFolderTextChanged(
    EventArgs args
)
Protected Overridable Sub OnFolderTextChanged (
    args As EventArgs
)
protected:
virtual void OnFolderTextChanged(
    EventArgs^ args
)
abstract OnFolderTextChanged :
        args : EventArgs -> unit
override OnFolderTextChanged :
        args : EventArgs -> unit

Parameters

args
Type: SystemEventArgs
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl Events

FolderControl Events

The FolderControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FolderTextChanged | Raised when the folder text is changed.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


FolderControl.FolderTextChanged Event

FolderControlFolderTextChanged Event
Raised when the folder text is changed.

Namespace: VirtualRadar.WinForms.Controls
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FolderTextChanged
Public Event FolderTextChanged As EventHandler
public:
 event EventHandler^ FolderTextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member FolderTextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

FolderControl Class
VirtualRadar.WinForms.Controls Namespace


VirtualRadar.WinForms.PortableBinding Namespace

VirtualRadar.WinForms.PortableBinding Namespace

[Missing <summary> documentation for "N:VirtualRadar.WinForms.PortableBinding"]

Classes
 | Class | Description
Public class | AccessControlBinderTModel | A binder between an Access object and an AccessControl control.
Public class | CheckBoxBoolBinderTModel | Binds a boolean property on a model to a checkbox control.
Public class | ComboBoxBinderTModel, TListModel, TValue | A binder that populates a combo box with a list and lets the user select a single value from it.
Public class | ComboBoxEnumBinderTModel, TValue | Binds a combo box to a set of enum values.
Public class | ComboBoxValueBinderTModel, TValue | A binder between a combo box and a list of values, where the type of the value is also the type that we want to copy to and from the model.
Public class | ControlBinder | The base class for all control binders.
Public class | FileNameStringBinderTModel | Binds a filename control to a string property. The control's content is automatically trimmed before being sent to the model.
Public class | FolderStringBinderTModel | Binds a folder name control to a string property. The control's content is automatically trimmed before being sent to the model.
Public class | ItemDescriptionT | Carries an item and its description.
Public class | ItemDescriptionListT | A collection of ItemDescription objects.
Public class | LabelStringBinderTModel | Binds a label to a string property.
Public class | LinkLabelStringBinderTModel | Binds a link label to a string property.
Public class | MasterListToListBinderTModel, TListModel | A binder between a master list control and a list of objects.
Public class | MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier | A binder that binds between a master list and a subset of the master list's rows. Rows are distinguished by an identifier.
Public class | NumericDoubleBinderTModel | Binds an double property on a model to a numeric up-down control.
Public class | NumericIntBinderTModel | Binds an intger property on a model to a numeric up-down control.
Public class | RadioButtonEnumBinderTModel, TValue | Binds an enum value to a radio button control
Public class | TextBoxStringBinderTModel | Binds a text box to a string property. The text box's content is automatically trimmed before being sent to the model.
Public class | ValueBinderTModel, TControl, TValue | A layer above ControlBinder that takes care of the common chores involved in binding between a single property on a model that implements INotifyPropertyChanged and a single property on a control.
Public class | ValueFromListBinderTModel, TControl, TValue, TListModel | The base class for binders that let the user choose a single value from a list of values. If the list implements IBindingList then changes to the list are copied into the control.


AccessControlBinder(TModel) Class

AccessControlBinderTModel Class
A binder between an Access object and an AccessControl control.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingAccessControlBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AccessControlBinder<TModel> : ControlBinder

Public Class AccessControlBinder(Of TModel)
    Inherits ControlBinder
generic<typename TModel>
public ref class AccessControlBinder : public ControlBinder
type AccessControlBinder<'TModel> =
    class
        inherit ControlBinder
    end

Type Parameters

TModel

The AccessControlBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | AccessControlBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Access | Gets the Access exposed by the model.
Public property | Control | Gets the control that we're bound to.
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValueObject | See base docs. (Overrides ControlBinderControlValueObject.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model that we're bound to.
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelAccess parameter does more than just return a property. Cannot be set once the binder has been initialised.
Public property | ModelValueObject | See base docs. (Overrides ControlBinderModelValueObject.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | See base docs. (Overrides ControlBinderDoCopyControlToModel.)
Protected method | DoCopyModelToControl | See base docs. (Overrides ControlBinderDoCopyModelToControl.)
Protected method | DoHookControl | See base docs. (Overrides ControlBinderDoHookControl.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Overrides ControlBinderDoHookModel.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ControlBinderDoInitialising.)
Protected method | DoUnhookControl | See base docs. (Overrides ControlBinderDoUnhookControl.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Overrides ControlBinderDoUnhookModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel) Constructor

AccessControlBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessControlBinder(
    TModel model,
    AccessControl control,
    Func<TModel, Access> getModelAccess
)
Public Sub New (
    model As TModel,
    control As AccessControl,
    getModelAccess As Func(Of TModel, Access)
)
public:
AccessControlBinder(
    TModel model,
    AccessControl^ control,
    Func<TModel, Access^>^ getModelAccess
)
new :
        model : 'TModel *
        control : AccessControl *
        getModelAccess : Func<'TModel, Access> -> AccessControlBinder

Parameters

model
Type: TModel
control
Type: AccessControl
getModelAccess
Type: SystemFunc TModel, Access
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel) Properties

AccessControlBinderTModel Properties

The AccessControlBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets the Access exposed by the model.
Public property | Control | Gets the control that we're bound to.
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValueObject | See base docs. (Overrides ControlBinderControlValueObject.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model that we're bound to.
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelAccess parameter does more than just return a property. Cannot be set once the binder has been initialised.
Public property | ModelValueObject | See base docs. (Overrides ControlBinderModelValueObject.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).Access Property

AccessControlBinderTModelAccess Property
Gets the Access exposed by the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Access Access { get; }
Public ReadOnly Property Access As Access
    Get
public:
property Access^ Access {
    Access^ get ();
}
member Access : Access with get

Property Value

Type: Access
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).Control Property

AccessControlBinderTModelControl Property
Gets the control that we're bound to.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessControl Control { get; }
Public ReadOnly Property Control As AccessControl
    Get
public:
property AccessControl^ Control {
    AccessControl^ get ();
}
member Control : AccessControl with get

Property Value

Type: AccessControl
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).ControlValueObject Property

AccessControlBinderTModelControlValueObject Property
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ControlValueObject { get; protected set; }
Public Overrides Property ControlValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ControlValueObject {
    Object^ get () override;
    protected: void set (Object^ value) override;
}
abstract ControlValueObject : Object with get, set
override ControlValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).Model Property

AccessControlBinderTModelModel Property
Gets the model that we're bound to.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TModel Model { get; }
Public ReadOnly Property Model As TModel
    Get
public:
property TModel Model {
    TModel get ();
}
member Model : 'TModel with get

Property Value

Type: TModel
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).ModelPropertyName Property

AccessControlBinderTModelModelPropertyName Property
Gets or sets the name of the model's property to bind to. Only required if the ctor getModelAccess parameter does more than just return a property. Cannot be set once the binder has been initialised.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModelPropertyName { get; set; }
Public Property ModelPropertyName As String
    Get
    Set
public:
property String^ ModelPropertyName {
    String^ get ();
    void set (String^ value);
}
member ModelPropertyName : string with get, set

Property Value

Type: String
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).ModelValueObject Property

AccessControlBinderTModelModelValueObject Property
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ModelValueObject { get; protected set; }
Public Overrides Property ModelValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ModelValueObject {
    Object^ get () override;
    protected: void set (Object^ value) override;
}
abstract ModelValueObject : Object with get, set
override ModelValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel) Methods

AccessControlBinderTModel Methods

The AccessControlBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | See base docs. (Overrides ControlBinderDoCopyControlToModel.)
Protected method | DoCopyModelToControl | See base docs. (Overrides ControlBinderDoCopyModelToControl.)
Protected method | DoHookControl | See base docs. (Overrides ControlBinderDoHookControl.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Overrides ControlBinderDoHookModel.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ControlBinderDoInitialising.)
Protected method | DoUnhookControl | See base docs. (Overrides ControlBinderDoUnhookControl.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Overrides ControlBinderDoUnhookModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoCopyControlToModel Method

AccessControlBinderTModelDoCopyControlToModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyControlToModel()
Protected Overrides Sub DoCopyControlToModel
protected:
virtual void DoCopyControlToModel() override
abstract DoCopyControlToModel : unit -> unit
override DoCopyControlToModel : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoCopyModelToControl Method

AccessControlBinderTModelDoCopyModelToControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyModelToControl()
Protected Overrides Sub DoCopyModelToControl
protected:
virtual void DoCopyModelToControl() override
abstract DoCopyModelToControl : unit -> unit
override DoCopyModelToControl : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoHookControl Method

AccessControlBinderTModelDoHookControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControl()
Protected Overrides Sub DoHookControl
protected:
virtual void DoHookControl() override
abstract DoHookControl : unit -> unit
override DoHookControl : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoHookControlPropertyChanged Method

AccessControlBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoHookModel Method

AccessControlBinderTModelDoHookModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookModel()
Protected Overrides Sub DoHookModel
protected:
virtual void DoHookModel() override
abstract DoHookModel : unit -> unit
override DoHookModel : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoInitialising Method

AccessControlBinderTModelDoInitialising Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialising()
Protected Overrides Sub DoInitialising
protected:
virtual void DoInitialising() override
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoUnhookControl Method

AccessControlBinderTModelDoUnhookControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControl()
Protected Overrides Sub DoUnhookControl
protected:
virtual void DoUnhookControl() override
abstract DoUnhookControl : unit -> unit
override DoUnhookControl : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoUnhookControlPropertyChanged Method

AccessControlBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel).DoUnhookModel Method

AccessControlBinderTModelDoUnhookModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookModel()
Protected Overrides Sub DoUnhookModel
protected:
virtual void DoUnhookModel() override
abstract DoUnhookModel : unit -> unit
override DoUnhookModel : unit -> unit
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


AccessControlBinder(TModel) Fields

AccessControlBinderTModel Fields

The AccessControlBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

AccessControlBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel) Class

CheckBoxBoolBinderTModel Class
Binds a boolean property on a model to a checkbox control.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, CheckBox, Boolean
VirtualRadar.WinForms.PortableBindingCheckBoxBoolBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CheckBoxBoolBinder<TModel> : ValueBinder<TModel, CheckBox, bool>
where TModel : class, INotifyPropertyChanged

Public Class CheckBoxBoolBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, CheckBox, Boolean)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class CheckBoxBoolBinder : public ValueBinder<TModel, CheckBox^, bool>
type CheckBoxBoolBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, CheckBox, bool>
    end

Type Parameters

TModel

The CheckBoxBoolBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | CheckBoxBoolBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel) Constructor

CheckBoxBoolBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBoxBoolBinder(
    TModel model,
    CheckBox control,
    Expression<Func<TModel, bool>> getModelValue,
    Action<TModel, bool> setModelValue
)
Public Sub New (
    model As TModel,
    control As CheckBox,
    getModelValue As Expression(Of Func(Of TModel, Boolean)),
    setModelValue As Action(Of TModel, Boolean)
)
public:
CheckBoxBoolBinder(
    TModel model,
    CheckBox^ control,
    Expression<Func<TModel, bool>^>^ getModelValue,
    Action<TModel, bool>^ setModelValue
)
new :
        model : 'TModel *
        control : CheckBox *
        getModelValue : Expression<Func<'TModel, bool>> *
        setModelValue : Action<'TModel, bool> -> CheckBoxBoolBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsCheckBox
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, Boolean
setModelValue
Type: SystemAction TModel, Boolean
See Also

Reference

CheckBoxBoolBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel) Properties

CheckBoxBoolBinderTModel Properties

The CheckBoxBoolBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

CheckBoxBoolBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel) Methods

CheckBoxBoolBinderTModel Methods

The CheckBoxBoolBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

CheckBoxBoolBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel).DoHookControlPropertyChanged Method

CheckBoxBoolBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

CheckBoxBoolBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel).DoUnhookControlPropertyChanged Method

CheckBoxBoolBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

CheckBoxBoolBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


CheckBoxBoolBinder(TModel) Fields

CheckBoxBoolBinderTModel Fields

The CheckBoxBoolBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

CheckBoxBoolBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue) Class

ComboBoxBinderTModel, TListModel, TValue Class
A binder that populates a combo box with a list and lets the user select a single value from it.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, ComboBox, TValue
VirtualRadar.WinForms.PortableBindingValueFromListBinder TModel, ComboBox, TValue, TListModel
VirtualRadar.WinForms.PortableBindingComboBoxBinderTModel, TListModel, TValue
VirtualRadar.WinForms.PortableBindingComboBoxValueBinderTModel, TValue

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComboBoxBinder<TModel, TListModel, TValue> : ValueFromListBinder<TModel, ComboBox, TValue, TListModel>
where TModel : class, INotifyPropertyChanged

Public Class ComboBoxBinder(Of TModel As {Class, INotifyPropertyChanged}, TListModel, TValue)
    Inherits ValueFromListBinder(Of TModel, ComboBox, TValue, TListModel)
generic<typename TModel, typename TListModel, typename TValue>
where TModel : ref class, INotifyPropertyChanged
public ref class ComboBoxBinder : public ValueFromListBinder<TModel, ComboBox^, TValue, TListModel>
type ComboBoxBinder<'TModel, 'TListModel, 'TValue when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueFromListBinder<'TModel, ComboBox, 'TValue, 'TListModel>
    end

Type Parameters

TModel
TListModel
TValue

The ComboBoxBinderTModel, TListModel, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | ComboBoxBinderTModel, TListModel, TValue | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | List | Gets the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyControlToModel | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyListToControl | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoCopyListToControl(IEnumerableItemDescriptionTListModel).)
Protected method | DoCopyModelToControl | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoGetSelectedListValue | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoGetSelectedListValue.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoSetSelectedListValue | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoSetSelectedListValue(TValue).)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue) Constructor

ComboBoxBinderTModel, TListModel, TValue Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBoxBinder(
    TModel model,
    ComboBox control,
    IList<TListModel> list,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue
)
Public Sub New (
    model As TModel,
    control As ComboBox,
    list As IList(Of TListModel),
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue)
)
public:
ComboBoxBinder(
    TModel model,
    ComboBox^ control,
    IList<TListModel>^ list,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue
)
new :
        model : 'TModel *
        control : ComboBox *
        list : IList<'TListModel> *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> -> ComboBoxBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsComboBox
list
Type: System.Collections.GenericIList TListModel
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue) Properties

ComboBoxBinderTModel, TListModel, TValue Properties

The ComboBoxBinderTModel, TListModel, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | List | Gets the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue) Methods

ComboBoxBinderTModel, TListModel, TValue Methods

The ComboBoxBinderTModel, TListModel, TValue generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyControlToModel | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyListToControl | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoCopyListToControl(IEnumerableItemDescriptionTListModel).)
Protected method | DoCopyModelToControl | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoGetSelectedListValue | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoGetSelectedListValue.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoSetSelectedListValue | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoSetSelectedListValue(TValue).)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue).DoCopyListToControl Method

ComboBoxBinderTModel, TListModel, TValueDoCopyListToControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyListToControl(
    IEnumerable<ItemDescription<TListModel>> itemDescriptions
)
Protected Overrides Sub DoCopyListToControl (
    itemDescriptions As IEnumerable(Of ItemDescription(Of TListModel))
)
protected:
virtual void DoCopyListToControl(
    IEnumerable<ItemDescription<TListModel>^>^ itemDescriptions
) override
abstract DoCopyListToControl :
        itemDescriptions : IEnumerable<ItemDescription<'TListModel>> -> unit
override DoCopyListToControl :
        itemDescriptions : IEnumerable<ItemDescription<'TListModel>> -> unit

Parameters

itemDescriptions
Type: System.Collections.GenericIEnumerable ItemDescription TListModel
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue).DoGetSelectedListValue Method

ComboBoxBinderTModel, TListModel, TValueDoGetSelectedListValue Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override TValue DoGetSelectedListValue()
Protected Overrides Function DoGetSelectedListValue As TValue
protected:
virtual TValue DoGetSelectedListValue() override
abstract DoGetSelectedListValue : unit -> 'TValue
override DoGetSelectedListValue : unit -> 'TValue

Return Value

Type: TValue
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue).DoHookControlPropertyChanged Method

ComboBoxBinderTModel, TListModel, TValueDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue).DoSetSelectedListValue Method

ComboBoxBinderTModel, TListModel, TValueDoSetSelectedListValue Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoSetSelectedListValue(
    TValue value
)
Protected Overrides Sub DoSetSelectedListValue (
    value As TValue
)
protected:
virtual void DoSetSelectedListValue(
    TValue value
) override
abstract DoSetSelectedListValue :
        value : 'TValue -> unit
override DoSetSelectedListValue :
        value : 'TValue -> unit

Parameters

value
Type: TValue
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue).DoUnhookControlPropertyChanged Method

ComboBoxBinderTModel, TListModel, TValueDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxBinder(TModel, TListModel, TValue) Fields

ComboBoxBinderTModel, TListModel, TValue Fields

The ComboBoxBinderTModel, TListModel, TValue generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxBinderTModel, TListModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxEnumBinder(TModel, TValue) Class

ComboBoxEnumBinderTModel, TValue Class
Binds a combo box to a set of enum values.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, ComboBox, TValue
VirtualRadar.WinForms.PortableBindingValueFromListBinder TModel, ComboBox, TValue, TValue
VirtualRadar.WinForms.PortableBindingComboBoxBinder TModel, TValue, TValue
VirtualRadar.WinForms.PortableBindingComboBoxValueBinder TModel, TValue
VirtualRadar.WinForms.PortableBindingComboBoxEnumBinderTModel, TValue

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComboBoxEnumBinder<TModel, TValue> : ComboBoxValueBinder<TModel, TValue>
where TModel : class, INotifyPropertyChanged

Public Class ComboBoxEnumBinder(Of TModel As {Class, INotifyPropertyChanged}, TValue)
    Inherits ComboBoxValueBinder(Of TModel, TValue)
generic<typename TModel, typename TValue>
where TModel : ref class, INotifyPropertyChanged
public ref class ComboBoxEnumBinder : public ComboBoxValueBinder<TModel, TValue>
type ComboBoxEnumBinder<'TModel, 'TValue when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ComboBoxValueBinder<'TModel, 'TValue>
    end

Type Parameters

TModel
TValue

The ComboBoxEnumBinderTModel, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | ComboBoxEnumBinderTModel, TValue | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | List | Gets the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyControlToModel | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyListToControl | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoCopyModelToControl | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoGetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoInitialising.)
Protected method | DoSetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxEnumBinder(TModel, TValue) Constructor

ComboBoxEnumBinderTModel, TValue Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBoxEnumBinder(
    TModel model,
    ComboBox control,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue,
    Func<TValue, string> getEnumDescription
)
Public Sub New (
    model As TModel,
    control As ComboBox,
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue),
    getEnumDescription As Func(Of TValue, String)
)
public:
ComboBoxEnumBinder(
    TModel model,
    ComboBox^ control,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue,
    Func<TValue, String^>^ getEnumDescription
)
new :
        model : 'TModel *
        control : ComboBox *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> *
        getEnumDescription : Func<'TValue, string> -> ComboBoxEnumBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsComboBox
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
getEnumDescription
Type: SystemFunc TValue, String
See Also

Reference

ComboBoxEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxEnumBinder(TModel, TValue) Properties

ComboBoxEnumBinderTModel, TValue Properties

The ComboBoxEnumBinderTModel, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | List | Gets the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxEnumBinder(TModel, TValue) Methods

ComboBoxEnumBinderTModel, TValue Methods

The ComboBoxEnumBinderTModel, TValue generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyControlToModel | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyListToControl | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoCopyModelToControl | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoGetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ValueFromListBinderTModel, TControl, TValue, TListModelDoInitialising.)
Protected method | DoSetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxEnumBinder(TModel, TValue).DoInitialising Method

ComboBoxEnumBinderTModel, TValueDoInitialising Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialising()
Protected Overrides Sub DoInitialising
protected:
virtual void DoInitialising() override
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

ComboBoxEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxEnumBinder(TModel, TValue) Fields

ComboBoxEnumBinderTModel, TValue Fields

The ComboBoxEnumBinderTModel, TValue generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxValueBinder(TModel, TValue) Class

ComboBoxValueBinderTModel, TValue Class
A binder between a combo box and a list of values, where the type of the value is also the type that we want to copy to and from the model.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, ComboBox, TValue
VirtualRadar.WinForms.PortableBindingValueFromListBinder TModel, ComboBox, TValue, TValue
VirtualRadar.WinForms.PortableBindingComboBoxBinder TModel, TValue, TValue
VirtualRadar.WinForms.PortableBindingComboBoxValueBinderTModel, TValue
VirtualRadar.WinForms.PortableBindingComboBoxEnumBinderTModel, TValue

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComboBoxValueBinder<TModel, TValue> : ComboBoxBinder<TModel, TValue, TValue>
where TModel : class, INotifyPropertyChanged

Public Class ComboBoxValueBinder(Of TModel As {Class, INotifyPropertyChanged}, TValue)
    Inherits ComboBoxBinder(Of TModel, TValue, TValue)
generic<typename TModel, typename TValue>
where TModel : ref class, INotifyPropertyChanged
public ref class ComboBoxValueBinder : public ComboBoxBinder<TModel, TValue, TValue>
type ComboBoxValueBinder<'TModel, 'TValue when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ComboBoxBinder<'TModel, 'TValue, 'TValue>
    end

Type Parameters

TModel
TValue

The ComboBoxValueBinderTModel, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | ComboBoxValueBinderTModel, TValue | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | List | Gets the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyControlToModel | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyListToControl | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoCopyModelToControl | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoGetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoSetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxValueBinder(TModel, TValue) Constructor

ComboBoxValueBinderTModel, TValue Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBoxValueBinder(
    TModel model,
    ComboBox control,
    IList<TValue> list,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue
)
Public Sub New (
    model As TModel,
    control As ComboBox,
    list As IList(Of TValue),
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue)
)
public:
ComboBoxValueBinder(
    TModel model,
    ComboBox^ control,
    IList<TValue>^ list,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue
)
new :
        model : 'TModel *
        control : ComboBox *
        list : IList<'TValue> *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> -> ComboBoxValueBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsComboBox
list
Type: System.Collections.GenericIList TValue
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
See Also

Reference

ComboBoxValueBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxValueBinder(TModel, TValue) Properties

ComboBoxValueBinderTModel, TValue Properties

The ComboBoxValueBinderTModel, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | List | Gets the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxValueBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxValueBinder(TModel, TValue) Methods

ComboBoxValueBinderTModel, TValue Methods

The ComboBoxValueBinderTModel, TValue generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyControlToModel | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoCopyListToControl | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoCopyModelToControl | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoGetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected method | DoSetSelectedListValue | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Inherited from ComboBoxBinderTModel, TListModel, TValue.)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxValueBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ComboBoxValueBinder(TModel, TValue) Fields

ComboBoxValueBinderTModel, TValue Fields

The ComboBoxValueBinderTModel, TValue generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked. (Inherited from ValueFromListBinderTModel, TControl, TValue, TListModel.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ComboBoxValueBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder Class

ControlBinder Class
The base class for all control binders.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingAccessControlBinderTModel
VirtualRadar.WinForms.PortableBindingMasterListToListBinderTModel, TListModel
VirtualRadar.WinForms.PortableBindingValueBinderTModel, TControl, TValue

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ControlBinder : IDisposable
Public MustInherit Class ControlBinder
    Implements IDisposable
public ref class ControlBinder abstract : IDisposable
[<AbstractClassAttribute>]
type ControlBinder =
    class
        interface IDisposable
    end

The ControlBinder type exposes the following members.

Constructors
 | Name | Description
Public method | ControlBinder | Creates a new object.
Top
Properties
 | Name | Description
Public property | ControlObject | Gets the control that has been bound to the model.
Public property | ControlValueObject | Gets the value of the control.
Public property | Initialised | Gets a value indicating that the object has been initialised.
Public property | ModelObject | Gets the model that has been bound to the control.
Public property | ModelValueObject | Gets the value of the model.
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised.
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object.
Public method | CopyControlToModel | Refreshes the model's content with the content of the control.
Public method | CopyModelToControl | Refreshes the control's content with the content of the model.
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Finalises or disposes of the object.
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model.
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control.
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden.
Protected method | DoHookControlPropertyChanged | Overridden to hook the control event that is raised as soon as the user changes the control's value.
Protected method | DoHookModel | Performs the actual work of hooking the model. Can be overridden.
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl.
Protected method | DoInitialising | Called before any initialisation is performed, specifically before anything is hooked. Can be overridden to perform setup that must be in place before any event handlers can be called.
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden.
Protected method | DoUnhookControlPropertyChanged | Overridden to unhook the control event that is raised as soon as the user changes the control's value.
Protected method | DoUnhookModel | Performs the actual work of unhooking the model. Can be overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control.
Protected method | HookModel | Hooks the events on the model.
Public method | Initialise | Initialises the binder. Must be called before the binder will start working.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control.
Protected method | UnhookModel | Unhooks the events on the model.
Top
Fields
 | Name | Description
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model.
Top
Remarks

This takes care of the basics of binding models to controls. It tries not make too many assumptions about the nature of the binding - that's for derived classes to do.

ControlBinders have optional properties that can be configured before use - once Initialise has been called these properties can no longer be set. You can make multiple calls on Initialise but the second and subsequent calls do nothing.

ControlBinders must be disposed of in order to release the event hooks. If you do not dispose of them then the controls that they are hooking will remain in memory for the lifetime of the model. Forms and UserControls based on BaseForm and BaseUserControl automatically dispose of any ControlBinders that have been registered with AddControlBinder.

See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder Constructor

ControlBinder Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ControlBinder(
    Object model,
    Control control
)
Public Sub New (
    model As Object,
    control As Control
)
public:
ControlBinder(
    Object^ model,
    Control^ control
)
new :
        model : Object *
        control : Control -> ControlBinder

Parameters

model
Type: SystemObject
control
Type: System.Windows.FormsControl
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder Properties

ControlBinder Properties

The ControlBinder type exposes the following members.

Properties
 | Name | Description
Public property | ControlObject | Gets the control that has been bound to the model.
Public property | ControlValueObject | Gets the value of the control.
Public property | Initialised | Gets a value indicating that the object has been initialised.
Public property | ModelObject | Gets the model that has been bound to the control.
Public property | ModelValueObject | Gets the value of the model.
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised.
Top
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.ControlObject Property

ControlBinderControlObject Property
Gets the control that has been bound to the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Control ControlObject { get; }
Public ReadOnly Property ControlObject As Control
    Get
public:
property Control^ ControlObject {
    Control^ get ();
}
member ControlObject : Control with get

Property Value

Type: Control
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.ControlValueObject Property

ControlBinderControlValueObject Property
Gets the value of the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Object ControlValueObject { get; protected set; }
Public MustOverride Property ControlValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ControlValueObject {
    Object^ get () abstract;
    protected: void set (Object^ value) abstract;
}
abstract ControlValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.Initialised Property

ControlBinderInitialised Property
Gets a value indicating that the object has been initialised.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Initialised { get; }
Public ReadOnly Property Initialised As Boolean
    Get
public:
property bool Initialised {
    bool get ();
}
member Initialised : bool with get

Property Value

Type: Boolean
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.ModelObject Property

ControlBinderModelObject Property
Gets the model that has been bound to the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object ModelObject { get; }
Public ReadOnly Property ModelObject As Object
    Get
public:
property Object^ ModelObject {
    Object^ get ();
}
member ModelObject : Object with get

Property Value

Type: Object
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.ModelValueObject Property

ControlBinderModelValueObject Property
Gets the value of the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Object ModelValueObject { get; protected set; }
Public MustOverride Property ModelValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ModelValueObject {
    Object^ get () abstract;
    protected: void set (Object^ value) abstract;
}
abstract ModelValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.UpdateMode Property

ControlBinderUpdateMode Property
Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataSourceUpdateMode UpdateMode { get; set; }
Public Property UpdateMode As DataSourceUpdateMode
    Get
    Set
public:
property DataSourceUpdateMode UpdateMode {
    DataSourceUpdateMode get ();
    void set (DataSourceUpdateMode value);
}
member UpdateMode : DataSourceUpdateMode with get, set

Property Value

Type: DataSourceUpdateMode
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder Methods

ControlBinder Methods

The ControlBinder type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object.
Public method | CopyControlToModel | Refreshes the model's content with the content of the control.
Public method | CopyModelToControl | Refreshes the control's content with the content of the model.
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Finalises or disposes of the object.
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model.
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control.
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden.
Protected method | DoHookControlPropertyChanged | Overridden to hook the control event that is raised as soon as the user changes the control's value.
Protected method | DoHookModel | Performs the actual work of hooking the model. Can be overridden.
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl.
Protected method | DoInitialising | Called before any initialisation is performed, specifically before anything is hooked. Can be overridden to perform setup that must be in place before any event handlers can be called.
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden.
Protected method | DoUnhookControlPropertyChanged | Overridden to unhook the control event that is raised as soon as the user changes the control's value.
Protected method | DoUnhookModel | Performs the actual work of unhooking the model. Can be overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control.
Protected method | HookModel | Hooks the events on the model.
Public method | Initialise | Initialises the binder. Must be called before the binder will start working.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control.
Protected method | UnhookModel | Unhooks the events on the model.
Top
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.ChangeModelObject Method

ControlBinderChangeModelObject Method
Changes the model object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void ChangeModelObject(
    Object modelObject
)
Protected Sub ChangeModelObject (
    modelObject As Object
)
protected:
void ChangeModelObject(
    Object^ modelObject
)
member ChangeModelObject :
        modelObject : Object -> unit

Parameters

modelObject
Type: SystemObject
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.CopyControlToModel Method

ControlBinderCopyControlToModel Method
Refreshes the model's content with the content of the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyControlToModel()
Public Overridable Sub CopyControlToModel
public:
virtual void CopyControlToModel()
abstract CopyControlToModel : unit -> unit
override CopyControlToModel : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.CopyModelToControl Method

ControlBinderCopyModelToControl Method
Refreshes the control's content with the content of the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyModelToControl()
Public Overridable Sub CopyModelToControl
public:
virtual void CopyModelToControl()
abstract CopyModelToControl : unit -> unit
override CopyModelToControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.Dispose Method

ControlBinderDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Finalises or disposes of the object.
Top
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.Dispose Method

ControlBinderDispose Method
See interface docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ControlBinder Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.Dispose Method (Boolean)

ControlBinderDispose Method (Boolean)
Finalises or disposes of the object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

ControlBinder Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoCopyControlToModel Method

ControlBinderDoCopyControlToModel Method
Does the actual work of copying the value from the control to the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoCopyControlToModel()
Protected Overridable Sub DoCopyControlToModel
protected:
virtual void DoCopyControlToModel()
abstract DoCopyControlToModel : unit -> unit
override DoCopyControlToModel : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoCopyModelToControl Method

ControlBinderDoCopyModelToControl Method
Does the actual work of copying the value from the model to the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoCopyModelToControl()
Protected Overridable Sub DoCopyModelToControl
protected:
virtual void DoCopyModelToControl()
abstract DoCopyModelToControl : unit -> unit
override DoCopyModelToControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoHookControl Method

ControlBinderDoHookControl Method
Performs the actual work of hooking the control. Can be overridden.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoHookControl()
Protected Overridable Sub DoHookControl
protected:
virtual void DoHookControl()
abstract DoHookControl : unit -> unit
override DoHookControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoHookControlPropertyChanged Method

ControlBinderDoHookControlPropertyChanged Method
Overridden to hook the control event that is raised as soon as the user changes the control's value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected MustOverride Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) abstract
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoHookModel Method

ControlBinderDoHookModel Method
Performs the actual work of hooking the model. Can be overridden.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoHookModel()
Protected Overridable Sub DoHookModel
protected:
virtual void DoHookModel()
abstract DoHookModel : unit -> unit
override DoHookModel : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoInitialiseControl Method

ControlBinderDoInitialiseControl Method
Does the work of initialising the control. By default this just calls CopyModelToControl.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoInitialiseControl()
Protected Overridable Sub DoInitialiseControl
protected:
virtual void DoInitialiseControl()
abstract DoInitialiseControl : unit -> unit
override DoInitialiseControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoInitialising Method

ControlBinderDoInitialising Method
Called before any initialisation is performed, specifically before anything is hooked. Can be overridden to perform setup that must be in place before any event handlers can be called.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoInitialising()
Protected Overridable Sub DoInitialising
protected:
virtual void DoInitialising()
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoUnhookControl Method

ControlBinderDoUnhookControl Method
Performs the actual work of unhooking the control. Can be overridden.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoUnhookControl()
Protected Overridable Sub DoUnhookControl
protected:
virtual void DoUnhookControl()
abstract DoUnhookControl : unit -> unit
override DoUnhookControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoUnhookControlPropertyChanged Method

ControlBinderDoUnhookControlPropertyChanged Method
Overridden to unhook the control event that is raised as soon as the user changes the control's value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected MustOverride Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) abstract
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.DoUnhookModel Method

ControlBinderDoUnhookModel Method
Performs the actual work of unhooking the model. Can be overridden.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void DoUnhookModel()
Protected Overridable Sub DoUnhookModel
protected:
virtual void DoUnhookModel()
abstract DoUnhookModel : unit -> unit
override DoUnhookModel : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.Finalize Method

ControlBinderFinalize Method
Finalises the object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.HookControl Method

ControlBinderHookControl Method
Hooks the events on the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void HookControl()
Protected Sub HookControl
protected:
void HookControl()
member HookControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.HookModel Method

ControlBinderHookModel Method
Hooks the events on the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void HookModel()
Protected Sub HookModel
protected:
void HookModel()
member HookModel : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.Initialise Method

ControlBinderInitialise Method
Initialises the binder. Must be called before the binder will start working.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise()
Public Sub Initialise
public:
void Initialise()
member Initialise : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.UnhookControl Method

ControlBinderUnhookControl Method
Unhooks the events on the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void UnhookControl()
Protected Sub UnhookControl
protected:
void UnhookControl()
member UnhookControl : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder.UnhookModel Method

ControlBinderUnhookModel Method
Unhooks the events on the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void UnhookModel()
Protected Sub UnhookModel
protected:
void UnhookModel()
member UnhookModel : unit -> unit
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder Fields

ControlBinder Fields

The ControlBinder type exposes the following members.

Fields
 | Name | Description
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model.
Top
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


ControlBinder._UpdatesLocked Field

ControlBinder_UpdatesLocked Field
True if changes are not to be copied between the control and the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool _UpdatesLocked
Protected _UpdatesLocked As Boolean
protected:
bool _UpdatesLocked
val mutable _UpdatesLocked: bool

Field Value

Type: Boolean
See Also

Reference

ControlBinder Class
VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel) Class

FileNameStringBinderTModel Class
Binds a filename control to a string property. The control's content is automatically trimmed before being sent to the model.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, FileNameControl, String
VirtualRadar.WinForms.PortableBindingFileNameStringBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileNameStringBinder<TModel> : ValueBinder<TModel, FileNameControl, string>
where TModel : class, INotifyPropertyChanged

Public Class FileNameStringBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, FileNameControl, String)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class FileNameStringBinder : public ValueBinder<TModel, FileNameControl^, String^>
type FileNameStringBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, FileNameControl, string>
    end

Type Parameters

TModel

The FileNameStringBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameStringBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel) Constructor

FileNameStringBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileNameStringBinder(
    TModel model,
    FileNameControl control,
    Expression<Func<TModel, string>> getModelValue,
    Action<TModel, string> setModelValue
)
Public Sub New (
    model As TModel,
    control As FileNameControl,
    getModelValue As Expression(Of Func(Of TModel, String)),
    setModelValue As Action(Of TModel, String)
)
public:
FileNameStringBinder(
    TModel model,
    FileNameControl^ control,
    Expression<Func<TModel, String^>^>^ getModelValue,
    Action<TModel, String^>^ setModelValue
)
new :
        model : 'TModel *
        control : FileNameControl *
        getModelValue : Expression<Func<'TModel, string>> *
        setModelValue : Action<'TModel, string> -> FileNameStringBinder

Parameters

model
Type: TModel
control
Type: VirtualRadar.WinForms.ControlsFileNameControl
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, String
setModelValue
Type: SystemAction TModel, String
See Also

Reference

FileNameStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel) Properties

FileNameStringBinderTModel Properties

The FileNameStringBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

FileNameStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel) Methods

FileNameStringBinderTModel Methods

The FileNameStringBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

FileNameStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel).DoHookControlPropertyChanged Method

FileNameStringBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

FileNameStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel).DoUnhookControlPropertyChanged Method

FileNameStringBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

FileNameStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FileNameStringBinder(TModel) Fields

FileNameStringBinderTModel Fields

The FileNameStringBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

FileNameStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel) Class

FolderStringBinderTModel Class
Binds a folder name control to a string property. The control's content is automatically trimmed before being sent to the model.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, FolderControl, String
VirtualRadar.WinForms.PortableBindingFolderStringBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FolderStringBinder<TModel> : ValueBinder<TModel, FolderControl, string>
where TModel : class, INotifyPropertyChanged

Public Class FolderStringBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, FolderControl, String)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class FolderStringBinder : public ValueBinder<TModel, FolderControl^, String^>
type FolderStringBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, FolderControl, string>
    end

Type Parameters

TModel

The FolderStringBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | FolderStringBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel) Constructor

FolderStringBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FolderStringBinder(
    TModel model,
    FolderControl control,
    Expression<Func<TModel, string>> getModelValue,
    Action<TModel, string> setModelValue
)
Public Sub New (
    model As TModel,
    control As FolderControl,
    getModelValue As Expression(Of Func(Of TModel, String)),
    setModelValue As Action(Of TModel, String)
)
public:
FolderStringBinder(
    TModel model,
    FolderControl^ control,
    Expression<Func<TModel, String^>^>^ getModelValue,
    Action<TModel, String^>^ setModelValue
)
new :
        model : 'TModel *
        control : FolderControl *
        getModelValue : Expression<Func<'TModel, string>> *
        setModelValue : Action<'TModel, string> -> FolderStringBinder

Parameters

model
Type: TModel
control
Type: VirtualRadar.WinForms.ControlsFolderControl
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, String
setModelValue
Type: SystemAction TModel, String
See Also

Reference

FolderStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel) Properties

FolderStringBinderTModel Properties

The FolderStringBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

FolderStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel) Methods

FolderStringBinderTModel Methods

The FolderStringBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

FolderStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel).DoHookControlPropertyChanged Method

FolderStringBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

FolderStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel).DoUnhookControlPropertyChanged Method

FolderStringBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

FolderStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


FolderStringBinder(TModel) Fields

FolderStringBinderTModel Fields

The FolderStringBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

FolderStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T) Class

ItemDescriptionT Class
Carries an item and its description.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingItemDescriptionT

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ItemDescription<T>

Public Class ItemDescription(Of T)
generic<typename T>
public ref class ItemDescription
type ItemDescription<'T> =  class end

Type Parameters

T

The ItemDescriptionT type exposes the following members.

Constructors
 | Name | Description
Public method | ItemDescriptionT | Creates a new object.
Top
Properties
 | Name | Description
Public property | Description | Gets the item's description.
Public property | Item | Gets the item that is being described.
Top
Methods
 | Name | Description
Public method | AreItemDescriptionEqual | Returns true if both the item and the description are Object.Equal to the values held by this object.
Public method | Equals | See base class docs. Objects are equal to this if they are of the correct class and both Item and Description are Equal to this object's Item and Description. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | See base class docs. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base class docs. (Overrides ObjectToString.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T) Constructor

ItemDescriptionT Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ItemDescription(
    T item,
    string description
)
Public Sub New (
    item As T,
    description As String
)
public:
ItemDescription(
    T item,
    String^ description
)
new :
        item : 'T *
        description : string -> ItemDescription

Parameters

item
Type: T
description
Type: SystemString
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T) Properties

ItemDescriptionT Properties

The ItemDescriptionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the item's description.
Public property | Item | Gets the item that is being described.
Top
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T).Description Property

ItemDescriptionTDescription Property
Gets the item's description.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T).Item Property

ItemDescriptionTItem Property
Gets the item that is being described.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Item { get; }
Public ReadOnly Property Item As T
    Get
public:
property T Item {
    T get ();
}
member Item : 'T with get

Property Value

Type: T
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T) Methods

ItemDescriptionT Methods

The ItemDescriptionT generic type exposes the following members.

Methods
 | Name | Description
Public method | AreItemDescriptionEqual | Returns true if both the item and the description are Object.Equal to the values held by this object.
Public method | Equals | See base class docs. Objects are equal to this if they are of the correct class and both Item and Description are Equal to this object's Item and Description. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | See base class docs. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | See base class docs. (Overrides ObjectToString.)
Top
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T).AreItemDescriptionEqual Method

ItemDescriptionTAreItemDescriptionEqual Method
Returns true if both the item and the description are Object.Equal to the values held by this object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreItemDescriptionEqual(
    T item,
    string description
)
Public Function AreItemDescriptionEqual (
    item As T,
    description As String
) As Boolean
public:
bool AreItemDescriptionEqual(
    T item,
    String^ description
)
member AreItemDescriptionEqual :
        item : 'T *
        description : string -> bool

Parameters

item
Type: T
description
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T).Equals Method

ItemDescriptionTEquals Method
See base class docs. Objects are equal to this if they are of the correct class and both Item and Description are Equal to this object's Item and Description.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T).GetHashCode Method

ItemDescriptionTGetHashCode Method
See base class docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescription(T).ToString Method

ItemDescriptionTToString Method
See base class docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ItemDescriptionT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T) Class

ItemDescriptionListT Class
A collection of ItemDescription objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList ItemDescription T
VirtualRadar.WinForms.PortableBindingItemDescriptionListT

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ItemDescriptionList<T> : List<ItemDescription<T>>,
    IDisposable

Public Class ItemDescriptionList(Of T)
    Inherits List(Of ItemDescription(Of T))
    Implements IDisposable
generic<typename T>
public ref class ItemDescriptionList : public List<ItemDescription<T>^>,
    IDisposable
type ItemDescriptionList<'T> =
    class
        inherit List<ItemDescription<'T>>
        interface IDisposable
    end

Type Parameters

T
The type of object in the list.

The ItemDescriptionListT type exposes the following members.

Constructors
 | Name | Description
Public method | ItemDescriptionListT | Creates a new object.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List ItemDescription T.)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List ItemDescription T.)
Public property | GetDescription | Gets or sets a method that returns the description associated with an item.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List ItemDescription T.)
Public property | UnderlyingBindingList | Gets the underlying list as an IBindingList.
Public property | UnderlyingList | Gets the underlying list.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List ItemDescription T.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List ItemDescription T.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List ItemDescription T.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List ItemDescription T.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ItemDescription T.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ItemDescription T.)
Public method | Clear | Removes all elements from the ListT. (Inherited from List ItemDescription T.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List ItemDescription T.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List ItemDescription T.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List ItemDescription T.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ItemDescription T.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ItemDescription T.)
Public method | Dispose | Disposes of the object.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List ItemDescription T.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List ItemDescription T.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List ItemDescription T.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ItemDescription T.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ItemDescription T.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ItemDescription T.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List ItemDescription T.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ItemDescription T.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ItemDescription T.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ItemDescription T.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List ItemDescription T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List ItemDescription T.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List ItemDescription T.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ItemDescription T.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ItemDescription T.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ItemDescription T.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List ItemDescription T.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List ItemDescription T.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ItemDescription T.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ItemDescription T.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ItemDescription T.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Raises Changed.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List ItemDescription T.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List ItemDescription T.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List ItemDescription T.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List ItemDescription T.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List ItemDescription T.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List ItemDescription T.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List ItemDescription T.)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List ItemDescription T.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List ItemDescription T.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List ItemDescription T.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List ItemDescription T.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List ItemDescription T.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List ItemDescription T.)
Top
Events
 | Name | Description
Public event | Changed | Raised when one or more items in the list have changed description or value.
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T) Constructor

ItemDescriptionListT Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ItemDescriptionList(
    IList<T> list,
    Func<T, string> getDescription
)
Public Sub New (
    list As IList(Of T),
    getDescription As Func(Of T, String)
)
public:
ItemDescriptionList(
    IList<T>^ list,
    Func<T, String^>^ getDescription
)
new :
        list : IList<'T> *
        getDescription : Func<'T, string> -> ItemDescriptionList

Parameters

list
Type: System.Collections.GenericIList T
getDescription
Type: SystemFunc T, String
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T) Properties

ItemDescriptionListT Properties

The ItemDescriptionListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List ItemDescription T .)
Public property | Count | Gets the number of elements actually contained in the ListT. (Inherited from List ItemDescription T .)
Public property | GetDescription | Gets or sets a method that returns the description associated with an item.
Public property | Item | Gets or sets the element at the specified index. (Inherited from List ItemDescription T .)
Public property | UnderlyingBindingList | Gets the underlying list as an IBindingList.
Public property | UnderlyingList | Gets the underlying list.
Top
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).GetDescription Property

ItemDescriptionListTGetDescription Property
Gets or sets a method that returns the description associated with an item.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<T, string> GetDescription { get; set; }
Public Property GetDescription As Func(Of T, String)
    Get
    Set
public:
property Func<T, String^>^ GetDescription {
    Func<T, String^>^ get ();
    void set (Func<T, String^>^ value);
}
member GetDescription : Func<'T, string> with get, set

Property Value

Type: Func T, String
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).UnderlyingBindingList Property

ItemDescriptionListTUnderlyingBindingList Property
Gets the underlying list as an IBindingList.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IBindingList UnderlyingBindingList { get; }
Public ReadOnly Property UnderlyingBindingList As IBindingList
    Get
public:
property IBindingList^ UnderlyingBindingList {
    IBindingList^ get ();
}
member UnderlyingBindingList : IBindingList with get

Property Value

Type: IBindingList
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).UnderlyingList Property

ItemDescriptionListTUnderlyingList Property
Gets the underlying list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<T> UnderlyingList { get; }
Public ReadOnly Property UnderlyingList As IList(Of T)
    Get
public:
property IList<T>^ UnderlyingList {
    IList<T>^ get ();
}
member UnderlyingList : IList<'T> with get

Property Value

Type: IList T
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T) Methods

ItemDescriptionListT Methods

The ItemDescriptionListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List ItemDescription T .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List ItemDescription T .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from List ItemDescription T .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List ItemDescription T .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ItemDescription T .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ItemDescription T .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List ItemDescription T .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List ItemDescription T .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List ItemDescription T .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List ItemDescription T .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ItemDescription T .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ItemDescription T .)
Public method | Dispose | Disposes of the object.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List ItemDescription T .)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List ItemDescription T .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List ItemDescription T .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ItemDescription T .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ItemDescription T .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ItemDescription T .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List ItemDescription T .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ItemDescription T .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ItemDescription T .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ItemDescription T .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List ItemDescription T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List ItemDescription T .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List ItemDescription T .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ItemDescription T .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ItemDescription T .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ItemDescription T .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List ItemDescription T .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List ItemDescription T .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ItemDescription T .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ItemDescription T .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ItemDescription T .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Raises Changed.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List ItemDescription T .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List ItemDescription T .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List ItemDescription T .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List ItemDescription T .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List ItemDescription T .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List ItemDescription T .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List ItemDescription T .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List ItemDescription T .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List ItemDescription T .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List ItemDescription T .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List ItemDescription T .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List ItemDescription T .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List ItemDescription T .)
Top
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).Dispose Method

ItemDescriptionListTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Disposes of the object.
Protected method | Dispose(Boolean) | Disposes of or finalises the object.
Top
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).Dispose Method

ItemDescriptionListTDispose Method
Disposes of the object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ItemDescriptionListT Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).Dispose Method (Boolean)

ItemDescriptionListTDispose Method (Boolean)
Disposes of or finalises the object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

ItemDescriptionListT Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).Finalize Method

ItemDescriptionListTFinalize Method
Finalises the object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).OnChanged Method

ItemDescriptionListTOnChanged Method
Raises Changed.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnChanged(
    EventArgs args
)
Protected Overridable Sub OnChanged (
    args As EventArgs
)
protected:
virtual void OnChanged(
    EventArgs^ args
)
abstract OnChanged :
        args : EventArgs -> unit
override OnChanged :
        args : EventArgs -> unit

Parameters

args
Type: SystemEventArgs
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T) Events

ItemDescriptionListT Events

The ItemDescriptionListT generic type exposes the following members.

Events
 | Name | Description
Public event | Changed | Raised when one or more items in the list have changed description or value.
Top
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


ItemDescriptionList(T).Changed Event

ItemDescriptionListTChanged Event
Raised when one or more items in the list have changed description or value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Changed
Public Event Changed As EventHandler
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ItemDescriptionListT Class
VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel) Class

LabelStringBinderTModel Class
Binds a label to a string property.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, Label, String
VirtualRadar.WinForms.PortableBindingLabelStringBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LabelStringBinder<TModel> : ValueBinder<TModel, Label, string>
where TModel : class, INotifyPropertyChanged

Public Class LabelStringBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, Label, String)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class LabelStringBinder : public ValueBinder<TModel, Label^, String^>
type LabelStringBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, Label, string>
    end

Type Parameters

TModel

The LabelStringBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | LabelStringBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel) Constructor

LabelStringBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LabelStringBinder(
    TModel model,
    Label control,
    Expression<Func<TModel, string>> getModelValue,
    Action<TModel, string> setModelValue
)
Public Sub New (
    model As TModel,
    control As Label,
    getModelValue As Expression(Of Func(Of TModel, String)),
    setModelValue As Action(Of TModel, String)
)
public:
LabelStringBinder(
    TModel model,
    Label^ control,
    Expression<Func<TModel, String^>^>^ getModelValue,
    Action<TModel, String^>^ setModelValue
)
new :
        model : 'TModel *
        control : Label *
        getModelValue : Expression<Func<'TModel, string>> *
        setModelValue : Action<'TModel, string> -> LabelStringBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsLabel
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, String
setModelValue
Type: SystemAction TModel, String
See Also

Reference

LabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel) Properties

LabelStringBinderTModel Properties

The LabelStringBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

LabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel) Methods

LabelStringBinderTModel Methods

The LabelStringBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

LabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel).DoHookControlPropertyChanged Method

LabelStringBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

LabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel).DoUnhookControlPropertyChanged Method

LabelStringBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

LabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LabelStringBinder(TModel) Fields

LabelStringBinderTModel Fields

The LabelStringBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

LabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel) Class

LinkLabelStringBinderTModel Class
Binds a link label to a string property.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, Label, String
VirtualRadar.WinForms.PortableBindingLinkLabelStringBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkLabelStringBinder<TModel> : ValueBinder<TModel, Label, string>
where TModel : class, INotifyPropertyChanged

Public Class LinkLabelStringBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, Label, String)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class LinkLabelStringBinder : public ValueBinder<TModel, Label^, String^>
type LinkLabelStringBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, Label, string>
    end

Type Parameters

TModel

The LinkLabelStringBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinkLabelStringBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel) Constructor

LinkLabelStringBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLabelStringBinder(
    TModel model,
    LinkLabel control,
    Expression<Func<TModel, string>> getModelValue,
    Action<TModel, string> setModelValue
)
Public Sub New (
    model As TModel,
    control As LinkLabel,
    getModelValue As Expression(Of Func(Of TModel, String)),
    setModelValue As Action(Of TModel, String)
)
public:
LinkLabelStringBinder(
    TModel model,
    LinkLabel^ control,
    Expression<Func<TModel, String^>^>^ getModelValue,
    Action<TModel, String^>^ setModelValue
)
new :
        model : 'TModel *
        control : LinkLabel *
        getModelValue : Expression<Func<'TModel, string>> *
        setModelValue : Action<'TModel, string> -> LinkLabelStringBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsLinkLabel
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, String
setModelValue
Type: SystemAction TModel, String
See Also

Reference

LinkLabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel) Properties

LinkLabelStringBinderTModel Properties

The LinkLabelStringBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

LinkLabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel) Methods

LinkLabelStringBinderTModel Methods

The LinkLabelStringBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

LinkLabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel).DoHookControlPropertyChanged Method

LinkLabelStringBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

LinkLabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel).DoUnhookControlPropertyChanged Method

LinkLabelStringBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

LinkLabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


LinkLabelStringBinder(TModel) Fields

LinkLabelStringBinderTModel Fields

The LinkLabelStringBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

LinkLabelStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel) Class

MasterListToListBinderTModel, TListModel Class
A binder between a master list control and a list of objects.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingMasterListToListBinderTModel, TListModel
VirtualRadar.WinForms.PortableBindingMasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MasterListToListBinder<TModel, TListModel> : ControlBinder
where TListModel : class

Public Class MasterListToListBinder(Of TModel, TListModel As Class)
    Inherits ControlBinder
generic<typename TModel, typename TListModel>
where TListModel : ref class
public ref class MasterListToListBinder : public ControlBinder
type MasterListToListBinder<'TModel, 'TListModel when 'TListModel : not struct> =
    class
        inherit ControlBinder
    end

Type Parameters

TModel
TListModel

The MasterListToListBinderTModel, TListModel type exposes the following members.

Constructors
 | Name | Description
Public method | MasterListToListBinderTModel, TListModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | AddHandler | Gets or sets the method that handles the adding of new items. Can only be set before initialisation.
Public property | AutoAddEnabled | Gets or sets a value indicating that if AddHandler is null then an automatic add handler should be used.
Public property | AutoDeleteEnabled | Gets or sets a value indicating that if DeleteHandler is null then an automatic delete handler should be used.
Public property | CheckedChangedHandler | Gets or sets the method that handles the change in checked state for an existing item. Can only be set before initialisation.
Public property | Control | Gets the control that is showing the list.
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValueObject | See base docs. (Overrides ControlBinderControlValueObject.)
Public property | DeleteHandler | Gets or sets the method that handles the removal of existing items. Can only be set before initialisation.
Public property | EditHandler | Gets or sets the method that handles the editing of an existing item. Can only be set before initialisation.
Public property | EnableSorting | Gets or sets a value indicating that the rows are to be sorted on display. Can only be set before initialisation.
Public property | FetchColumns | Gets or sets the method that handles the fetching of columns. Can only be set before initialisation.
Public property | GetSortValue | Gets or sets a delegate that returns a comparable value from the list model for a single column.
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model that owns the list.
Public property | ModelList | Gets the list held by the model.
Public property | ModelListBindingList | Gets the ModelList as an IBindingList.
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelValueObject | See base docs. (Overrides ControlBinderModelValueObject.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | AddListModel | Calls the add handler, returns the list model that it creates.
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Protected method | DeleteListModel | Calls the delete handler with the list model passed across.
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Overrides ControlBinderDispose(Boolean).)
Protected method | DoCopyControlToModel | See base docs. (Overrides ControlBinderDoCopyControlToModel.)
Protected method | DoCopyModelToControl | See base docs. (Overrides ControlBinderDoCopyModelToControl.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | Performs the actual work of hooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ControlBinderDoInitialising.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | Performs the actual work of unhooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | EditListModel | Calls the edit handler with the list model passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _CheckedChangedHandler | Protected method that is handles changing the checked state for an item.
Protected field | _FetchColumns | Protected method that fetches the content of the list, split into columns.
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel) Constructor

MasterListToListBinderTModel, TListModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MasterListToListBinder(
    TModel model,
    MasterListView control,
    Expression<Func<TModel, IList<TListModel>>> getModelList
)
Public Sub New (
    model As TModel,
    control As MasterListView,
    getModelList As Expression(Of Func(Of TModel, IList(Of TListModel)))
)
public:
MasterListToListBinder(
    TModel model,
    MasterListView^ control,
    Expression<Func<TModel, IList<TListModel>^>^>^ getModelList
)
new :
        model : 'TModel *
        control : MasterListView *
        getModelList : Expression<Func<'TModel, IList<'TListModel>>> -> MasterListToListBinder

Parameters

model
Type: TModel
control
Type: MasterListView
getModelList
Type: System.Linq.ExpressionsExpression Func TModel, IList TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel) Properties

MasterListToListBinderTModel, TListModel Properties

The MasterListToListBinderTModel, TListModel generic type exposes the following members.

Properties
 | Name | Description
Public property | AddHandler | Gets or sets the method that handles the adding of new items. Can only be set before initialisation.
Public property | AutoAddEnabled | Gets or sets a value indicating that if AddHandler is null then an automatic add handler should be used.
Public property | AutoDeleteEnabled | Gets or sets a value indicating that if DeleteHandler is null then an automatic delete handler should be used.
Public property | CheckedChangedHandler | Gets or sets the method that handles the change in checked state for an existing item. Can only be set before initialisation.
Public property | Control | Gets the control that is showing the list.
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValueObject | See base docs. (Overrides ControlBinderControlValueObject.)
Public property | DeleteHandler | Gets or sets the method that handles the removal of existing items. Can only be set before initialisation.
Public property | EditHandler | Gets or sets the method that handles the editing of an existing item. Can only be set before initialisation.
Public property | EnableSorting | Gets or sets a value indicating that the rows are to be sorted on display. Can only be set before initialisation.
Public property | FetchColumns | Gets or sets the method that handles the fetching of columns. Can only be set before initialisation.
Public property | GetSortValue | Gets or sets a delegate that returns a comparable value from the list model for a single column.
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model that owns the list.
Public property | ModelList | Gets the list held by the model.
Public property | ModelListBindingList | Gets the ModelList as an IBindingList.
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelValueObject | See base docs. (Overrides ControlBinderModelValueObject.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).AddHandler Property

MasterListToListBinderTModel, TListModelAddHandler Property
Gets or sets the method that handles the adding of new items. Can only be set before initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<TListModel> AddHandler { get; set; }
Public Property AddHandler As Func(Of TListModel)
    Get
    Set
public:
property Func<TListModel>^ AddHandler {
    Func<TListModel>^ get ();
    void set (Func<TListModel>^ value);
}
member AddHandler : Func<'TListModel> with get, set

Property Value

Type: Func TListModel
Remarks
The method should return a new object to add to the list. If it returns null then no add is performed. If you want to insert the new object anywhere but the end of the list then insert it yourself in the handler and return null.
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).AutoAddEnabled Property

MasterListToListBinderTModel, TListModelAutoAddEnabled Property
Gets or sets a value indicating that if AddHandler is null then an automatic add handler should be used.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoAddEnabled { get; set; }
Public Property AutoAddEnabled As Boolean
    Get
    Set
public:
property bool AutoAddEnabled {
    bool get ();
    void set (bool value);
}
member AutoAddEnabled : bool with get, set

Property Value

Type: Boolean
Remarks
The auto-add handler creates a new object using the default ctor and adds it to the list.
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).AutoDeleteEnabled Property

MasterListToListBinderTModel, TListModelAutoDeleteEnabled Property
Gets or sets a value indicating that if DeleteHandler is null then an automatic delete handler should be used.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoDeleteEnabled { get; set; }
Public Property AutoDeleteEnabled As Boolean
    Get
    Set
public:
property bool AutoDeleteEnabled {
    bool get ();
    void set (bool value);
}
member AutoDeleteEnabled : bool with get, set

Property Value

Type: Boolean
Remarks
The auto-delete handler simply removes the model from the list.
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).CheckedChangedHandler Property

MasterListToListBinderTModel, TListModelCheckedChangedHandler Property
Gets or sets the method that handles the change in checked state for an existing item. Can only be set before initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Action<TListModel, bool> CheckedChangedHandler { get; set; }
Public Overridable Property CheckedChangedHandler As Action(Of TListModel, Boolean)
    Get
    Set
public:
virtual property Action<TListModel, bool>^ CheckedChangedHandler {
    Action<TListModel, bool>^ get ();
    void set (Action<TListModel, bool>^ value);
}
abstract CheckedChangedHandler : Action<'TListModel, bool> with get, set
override CheckedChangedHandler : Action<'TListModel, bool> with get, set

Property Value

Type: Action TListModel, Boolean
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).Control Property

MasterListToListBinderTModel, TListModelControl Property
Gets the control that is showing the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MasterListView Control { get; }
Public ReadOnly Property Control As MasterListView
    Get
public:
property MasterListView^ Control {
    MasterListView^ get ();
}
member Control : MasterListView with get

Property Value

Type: MasterListView
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).ControlValueObject Property

MasterListToListBinderTModel, TListModelControlValueObject Property
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ControlValueObject { get; protected set; }
Public Overrides Property ControlValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ControlValueObject {
    Object^ get () override;
    protected: void set (Object^ value) override;
}
abstract ControlValueObject : Object with get, set
override ControlValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DeleteHandler Property

MasterListToListBinderTModel, TListModelDeleteHandler Property
Gets or sets the method that handles the removal of existing items. Can only be set before initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<IList<TListModel>> DeleteHandler { get; set; }
Public Property DeleteHandler As Action(Of IList(Of TListModel))
    Get
    Set
public:
property Action<IList<TListModel>^>^ DeleteHandler {
    Action<IList<TListModel>^>^ get ();
    void set (Action<IList<TListModel>^>^ value);
}
member DeleteHandler : Action<IList<'TListModel>> with get, set

Property Value

Type: Action IList TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).EditHandler Property

MasterListToListBinderTModel, TListModelEditHandler Property
Gets or sets the method that handles the editing of an existing item. Can only be set before initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<TListModel> EditHandler { get; set; }
Public Property EditHandler As Action(Of TListModel)
    Get
    Set
public:
property Action<TListModel>^ EditHandler {
    Action<TListModel>^ get ();
    void set (Action<TListModel>^ value);
}
member EditHandler : Action<'TListModel> with get, set

Property Value

Type: Action TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).EnableSorting Property

MasterListToListBinderTModel, TListModelEnableSorting Property
Gets or sets a value indicating that the rows are to be sorted on display. Can only be set before initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableSorting { get; set; }
Public Property EnableSorting As Boolean
    Get
    Set
public:
property bool EnableSorting {
    bool get ();
    void set (bool value);
}
member EnableSorting : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).FetchColumns Property

MasterListToListBinderTModel, TListModelFetchColumns Property
Gets or sets the method that handles the fetching of columns. Can only be set before initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<TListModel, ListContentEventArgs> FetchColumns { get; set; }
Public Property FetchColumns As Action(Of TListModel, ListContentEventArgs)
    Get
    Set
public:
property Action<TListModel, ListContentEventArgs^>^ FetchColumns {
    Action<TListModel, ListContentEventArgs^>^ get ();
    void set (Action<TListModel, ListContentEventArgs^>^ value);
}
member FetchColumns : Action<'TListModel, ListContentEventArgs> with get, set

Property Value

Type: Action TListModel, ListContentEventArgs
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).GetSortValue Property

MasterListToListBinderTModel, TListModelGetSortValue Property
Gets or sets a delegate that returns a comparable value from the list model for a single column.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<TListModel, ColumnHeader, IComparable, IComparable> GetSortValue { get; set; }
Public Property GetSortValue As Func(Of TListModel, ColumnHeader, IComparable, IComparable)
    Get
    Set
public:
property Func<TListModel, ColumnHeader^, IComparable^, IComparable^>^ GetSortValue {
    Func<TListModel, ColumnHeader^, IComparable^, IComparable^>^ get ();
    void set (Func<TListModel, ColumnHeader^, IComparable^, IComparable^>^ value);
}
member GetSortValue : Func<'TListModel, ColumnHeader, IComparable, IComparable> with get, set

Property Value

Type: Func TListModel, ColumnHeader, IComparable, IComparable
Remarks
The parameters are list model, followed by the header for the column that we're sorting on, followed by the default value for the list model (usually the result of ToString). The method should return a comparable. If it doesn't have any special interest in the column then return the comparable that was passed in.
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).Model Property

MasterListToListBinderTModel, TListModelModel Property
Gets the model that owns the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TModel Model { get; }
Public ReadOnly Property Model As TModel
    Get
public:
property TModel Model {
    TModel get ();
}
member Model : 'TModel with get

Property Value

Type: TModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).ModelList Property

MasterListToListBinderTModel, TListModelModelList Property
Gets the list held by the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TListModel> ModelList { get; }
Public ReadOnly Property ModelList As IList(Of TListModel)
    Get
public:
property IList<TListModel>^ ModelList {
    IList<TListModel>^ get ();
}
member ModelList : IList<'TListModel> with get

Property Value

Type: IList TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).ModelListBindingList Property

MasterListToListBinderTModel, TListModelModelListBindingList Property
Gets the ModelList as an IBindingList.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IBindingList ModelListBindingList { get; }
Public ReadOnly Property ModelListBindingList As IBindingList
    Get
public:
property IBindingList^ ModelListBindingList {
    IBindingList^ get ();
}
member ModelListBindingList : IBindingList with get

Property Value

Type: IBindingList
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).ModelValueObject Property

MasterListToListBinderTModel, TListModelModelValueObject Property
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ModelValueObject { get; protected set; }
Public Overrides Property ModelValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ModelValueObject {
    Object^ get () override;
    protected: void set (Object^ value) override;
}
abstract ModelValueObject : Object with get, set
override ModelValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel) Methods

MasterListToListBinderTModel, TListModel Methods

The MasterListToListBinderTModel, TListModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddListModel | Calls the add handler, returns the list model that it creates.
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Protected method | DeleteListModel | Calls the delete handler with the list model passed across.
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Overrides ControlBinderDispose(Boolean).)
Protected method | DoCopyControlToModel | See base docs. (Overrides ControlBinderDoCopyControlToModel.)
Protected method | DoCopyModelToControl | See base docs. (Overrides ControlBinderDoCopyModelToControl.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | Performs the actual work of hooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ControlBinderDoInitialising.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | Performs the actual work of unhooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | EditListModel | Calls the edit handler with the list model passed across.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).AddListModel Method

MasterListToListBinderTModel, TListModelAddListModel Method
Calls the add handler, returns the list model that it creates.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected TListModel AddListModel()
Protected Function AddListModel As TListModel
protected:
TListModel AddListModel()
member AddListModel : unit -> 'TListModel

Return Value

Type: TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DeleteListModel Method

MasterListToListBinderTModel, TListModelDeleteListModel Method
Calls the delete handler with the list model passed across.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void DeleteListModel(
    IList<TListModel> listModels
)
Protected Sub DeleteListModel (
    listModels As IList(Of TListModel)
)
protected:
void DeleteListModel(
    IList<TListModel>^ listModels
)
member DeleteListModel :
        listModels : IList<'TListModel> -> unit

Parameters

listModels
Type: System.Collections.GenericIList TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).Dispose Method

MasterListToListBinderTModel, TListModelDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Overrides ControlBinderDispose(Boolean).)
Top
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).Dispose Method (Boolean)

MasterListToListBinderTModel, TListModelDispose Method (Boolean)
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

MasterListToListBinderTModel, TListModel Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DoCopyControlToModel Method

MasterListToListBinderTModel, TListModelDoCopyControlToModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyControlToModel()
Protected Overrides Sub DoCopyControlToModel
protected:
virtual void DoCopyControlToModel() override
abstract DoCopyControlToModel : unit -> unit
override DoCopyControlToModel : unit -> unit
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DoCopyModelToControl Method

MasterListToListBinderTModel, TListModelDoCopyModelToControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyModelToControl()
Protected Overrides Sub DoCopyModelToControl
protected:
virtual void DoCopyModelToControl() override
abstract DoCopyModelToControl : unit -> unit
override DoCopyModelToControl : unit -> unit
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DoHookControlPropertyChanged Method

MasterListToListBinderTModel, TListModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DoInitialising Method

MasterListToListBinderTModel, TListModelDoInitialising Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialising()
Protected Overrides Sub DoInitialising
protected:
virtual void DoInitialising() override
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).DoUnhookControlPropertyChanged Method

MasterListToListBinderTModel, TListModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel).EditListModel Method

MasterListToListBinderTModel, TListModelEditListModel Method
Calls the edit handler with the list model passed across.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void EditListModel(
    TListModel listModel
)
Protected Sub EditListModel (
    listModel As TListModel
)
protected:
void EditListModel(
    TListModel listModel
)
member EditListModel :
        listModel : 'TListModel -> unit

Parameters

listModel
Type: TListModel
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel) Fields

MasterListToListBinderTModel, TListModel Fields

The MasterListToListBinderTModel, TListModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _CheckedChangedHandler | Protected method that is handles changing the checked state for an item.
Protected field | _FetchColumns | Protected method that fetches the content of the list, split into columns.
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel)._CheckedChangedHandler Field

MasterListToListBinderTModel, TListModel_CheckedChangedHandler Field
Protected method that is handles changing the checked state for an item.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Action<TListModel, bool> _CheckedChangedHandler
Protected _CheckedChangedHandler As Action(Of TListModel, Boolean)
protected:
Action<TListModel, bool>^ _CheckedChangedHandler
val mutable _CheckedChangedHandler: Action<'TListModel, bool>

Field Value

Type: Action TListModel, Boolean
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToListBinder(TModel, TListModel)._FetchColumns Field

MasterListToListBinderTModel, TListModel_FetchColumns Field
Protected method that fetches the content of the list, split into columns.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Action<TListModel, ListContentEventArgs> _FetchColumns
Protected _FetchColumns As Action(Of TListModel, ListContentEventArgs)
protected:
Action<TListModel, ListContentEventArgs^>^ _FetchColumns
val mutable _FetchColumns: Action<'TListModel, ListContentEventArgs>

Field Value

Type: Action TListModel, ListContentEventArgs
See Also

Reference

MasterListToListBinderTModel, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier) Class

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
A binder that binds between a master list and a subset of the master list's rows. Rows are distinguished by an identifier.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingMasterListToListBinder TMasterModel, TListModel
VirtualRadar.WinForms.PortableBindingMasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MasterListToSubsetBinder<TSubsetModel, TMasterModel, TListModel, TIdentifier> : MasterListToListBinder<TMasterModel, TListModel>
where TListModel : class

Public Class MasterListToSubsetBinder(Of TSubsetModel, TMasterModel, TListModel As Class, TIdentifier)
    Inherits MasterListToListBinder(Of TMasterModel, TListModel)
generic<typename TSubsetModel, typename TMasterModel, typename TListModel, typename TIdentifier>
where TListModel : ref class
public ref class MasterListToSubsetBinder : public MasterListToListBinder<TMasterModel, TListModel>
type MasterListToSubsetBinder<'TSubsetModel, 'TMasterModel, 'TListModel, 'TIdentifier when 'TListModel : not struct> =
    class
        inherit MasterListToListBinder<'TMasterModel, 'TListModel>
    end

Type Parameters

TSubsetModel
The type of object that holds the subset list, the list of identifiers.
TMasterModel
The type of object that holds the master list.
TListModel
The type of object in the master list.
TIdentifier
The type of identifier.

The MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier | Creates a new object.
Top
Properties
 | Name | Description
Public property | AddHandler | Gets or sets the method that handles the adding of new items. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | AutoAddEnabled | Gets or sets a value indicating that if AddHandler is null then an automatic add handler should be used. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | AutoDeleteEnabled | Gets or sets a value indicating that if DeleteHandler is null then an automatic delete handler should be used. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | CheckedChangedHandler | See base docs. Throws exception if you try to set it. (Overrides MasterListToListBinderTModel, TListModelCheckedChangedHandler.)
Public property | Control | Gets the control that is showing the list. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValueObject | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | DeleteHandler | Gets or sets the method that handles the removal of existing items. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | EditHandler | Gets or sets the method that handles the editing of an existing item. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | EnableSorting | Gets or sets a value indicating that the rows are to be sorted on display. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | FetchColumns | Gets or sets the method that handles the fetching of columns. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | GetListIdentifierAction | Gets or sets the action that retrieves the identifier from a row list item.
Public property | GetSortValue | Gets or sets a delegate that returns a comparable value from the list model for a single column. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | GetSubsetAction | Gets or sets the action that retrieves the subset list from the subset model.
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model that owns the list. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ModelList | Gets the list held by the model. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ModelListBindingList | Gets the ModelList as an IBindingList. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelSubsetBindingList | Gets the list of subset identitifers as an IBindingList.
Public property | ModelSubsetList | Gets the list of subset identifiers.
Public property | ModelValueObject | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | SubsetModel | Gets or sets the object that holds the subset list of identifiers.
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | AddListModel | Calls the add handler, returns the list model that it creates. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyModelSubsetToControl | Sets the checkmarks on the control to mirror the checkmarks on the model list.
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Protected method | DeleteListModel | Calls the delete handler with the list model passed across. (Inherited from MasterListToListBinderTModel, TListModel.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base class docs. (Overrides MasterListToListBinderTModel, TListModelDispose(Boolean).)
Protected method | DoCopyControlToModel | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | DoCopyModelToControl | See base docs. (Overrides MasterListToListBinderTModel, TListModelDoCopyModelToControl.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | DoHookModel | Performs the actual work of hooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides MasterListToListBinderTModel, TListModelDoInitialising.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | DoUnhookModel | Performs the actual work of unhooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | EditListModel | Calls the edit handler with the list model passed across. (Inherited from MasterListToListBinderTModel, TListModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _BaseFetchColumns | The base method to fetch columns. We chain onto this.
Protected field | _CheckedChangedHandler | Protected method that is handles changing the checked state for an item. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected field | _FetchColumns | Protected method that fetches the content of the list, split into columns. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier) Constructor

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MasterListToSubsetBinder(
    TSubsetModel subsetModel,
    MasterListView control,
    TMasterModel masterModel,
    Expression<Func<TSubsetModel, IList<TIdentifier>>> getSubsetList,
    Expression<Func<TMasterModel, IList<TListModel>>> getMasterList,
    Expression<Func<TListModel, TIdentifier>> getListIdentifier
)
Public Sub New (
    subsetModel As TSubsetModel,
    control As MasterListView,
    masterModel As TMasterModel,
    getSubsetList As Expression(Of Func(Of TSubsetModel, IList(Of TIdentifier))),
    getMasterList As Expression(Of Func(Of TMasterModel, IList(Of TListModel))),
    getListIdentifier As Expression(Of Func(Of TListModel, TIdentifier))
)
public:
MasterListToSubsetBinder(
    TSubsetModel subsetModel,
    MasterListView^ control,
    TMasterModel masterModel,
    Expression<Func<TSubsetModel, IList<TIdentifier>^>^>^ getSubsetList,
    Expression<Func<TMasterModel, IList<TListModel>^>^>^ getMasterList,
    Expression<Func<TListModel, TIdentifier>^>^ getListIdentifier
)
new :
        subsetModel : 'TSubsetModel *
        control : MasterListView *
        masterModel : 'TMasterModel *
        getSubsetList : Expression<Func<'TSubsetModel, IList<'TIdentifier>>> *
        getMasterList : Expression<Func<'TMasterModel, IList<'TListModel>>> *
        getListIdentifier : Expression<Func<'TListModel, 'TIdentifier>> -> MasterListToSubsetBinder

Parameters

subsetModel
Type: TSubsetModel
The object that holds the subset list.
control
Type: MasterListView
The MasterListView control that we'll be binding to.
masterModel
Type: TMasterModel
The object that holds the master list.
getSubsetList
Type: System.Linq.ExpressionsExpression Func TSubsetModel, IList TIdentifier
A delegate that returns the subset list.
getMasterList
Type: System.Linq.ExpressionsExpression Func TMasterModel, IList TListModel
A delegate that returns the master list.
getListIdentifier
Type: System.Linq.ExpressionsExpression Func TListModel, TIdentifier
A delegate that returns the identifier from a list item.
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier) Properties

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Properties

The MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier generic type exposes the following members.

Properties
 | Name | Description
Public property | AddHandler | Gets or sets the method that handles the adding of new items. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | AutoAddEnabled | Gets or sets a value indicating that if AddHandler is null then an automatic add handler should be used. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | AutoDeleteEnabled | Gets or sets a value indicating that if DeleteHandler is null then an automatic delete handler should be used. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | CheckedChangedHandler | See base docs. Throws exception if you try to set it. (Overrides MasterListToListBinderTModel, TListModelCheckedChangedHandler.)
Public property | Control | Gets the control that is showing the list. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValueObject | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | DeleteHandler | Gets or sets the method that handles the removal of existing items. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | EditHandler | Gets or sets the method that handles the editing of an existing item. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | EnableSorting | Gets or sets a value indicating that the rows are to be sorted on display. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | FetchColumns | Gets or sets the method that handles the fetching of columns. Can only be set before initialisation. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | GetListIdentifierAction | Gets or sets the action that retrieves the identifier from a row list item.
Public property | GetSortValue | Gets or sets a delegate that returns a comparable value from the list model for a single column. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | GetSubsetAction | Gets or sets the action that retrieves the subset list from the subset model.
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model that owns the list. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ModelList | Gets the list held by the model. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ModelListBindingList | Gets the ModelList as an IBindingList. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelSubsetBindingList | Gets the list of subset identitifers as an IBindingList.
Public property | ModelSubsetList | Gets the list of subset identifiers.
Public property | ModelValueObject | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Public property | SubsetModel | Gets or sets the object that holds the subset list of identifiers.
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).CheckedChangedHandler Property

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierCheckedChangedHandler Property
See base docs. Throws exception if you try to set it.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Action<TListModel, bool> CheckedChangedHandler { get; set; }
Public Overrides Property CheckedChangedHandler As Action(Of TListModel, Boolean)
    Get
    Set
public:
virtual property Action<TListModel, bool>^ CheckedChangedHandler {
    Action<TListModel, bool>^ get () override;
    void set (Action<TListModel, bool>^ value) override;
}
abstract CheckedChangedHandler : Action<'TListModel, bool> with get, set
override CheckedChangedHandler : Action<'TListModel, bool> with get, set

Property Value

Type: Action TListModel, Boolean
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).GetListIdentifierAction Property

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierGetListIdentifierAction Property
Gets or sets the action that retrieves the identifier from a row list item.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<TListModel, TIdentifier> GetListIdentifierAction { get; set; }
Public Property GetListIdentifierAction As Func(Of TListModel, TIdentifier)
    Get
    Set
public:
property Func<TListModel, TIdentifier>^ GetListIdentifierAction {
    Func<TListModel, TIdentifier>^ get ();
    void set (Func<TListModel, TIdentifier>^ value);
}
member GetListIdentifierAction : Func<'TListModel, 'TIdentifier> with get, set

Property Value

Type: Func TListModel, TIdentifier
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).GetSubsetAction Property

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierGetSubsetAction Property
Gets or sets the action that retrieves the subset list from the subset model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<TSubsetModel, IList<TIdentifier>> GetSubsetAction { get; set; }
Public Property GetSubsetAction As Func(Of TSubsetModel, IList(Of TIdentifier))
    Get
    Set
public:
property Func<TSubsetModel, IList<TIdentifier>^>^ GetSubsetAction {
    Func<TSubsetModel, IList<TIdentifier>^>^ get ();
    void set (Func<TSubsetModel, IList<TIdentifier>^>^ value);
}
member GetSubsetAction : Func<'TSubsetModel, IList<'TIdentifier>> with get, set

Property Value

Type: Func TSubsetModel, IList TIdentifier
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).ModelSubsetBindingList Property

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierModelSubsetBindingList Property
Gets the list of subset identitifers as an IBindingList.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IBindingList ModelSubsetBindingList { get; }
Public ReadOnly Property ModelSubsetBindingList As IBindingList
    Get
public:
property IBindingList^ ModelSubsetBindingList {
    IBindingList^ get ();
}
member ModelSubsetBindingList : IBindingList with get

Property Value

Type: IBindingList
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).ModelSubsetList Property

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierModelSubsetList Property
Gets the list of subset identifiers.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TIdentifier> ModelSubsetList { get; }
Public ReadOnly Property ModelSubsetList As IList(Of TIdentifier)
    Get
public:
property IList<TIdentifier>^ ModelSubsetList {
    IList<TIdentifier>^ get ();
}
member ModelSubsetList : IList<'TIdentifier> with get

Property Value

Type: IList TIdentifier
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).SubsetModel Property

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierSubsetModel Property
Gets or sets the object that holds the subset list of identifiers.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TSubsetModel SubsetModel { get; set; }
Public Property SubsetModel As TSubsetModel
    Get
    Set
public:
property TSubsetModel SubsetModel {
    TSubsetModel get ();
    void set (TSubsetModel value);
}
member SubsetModel : 'TSubsetModel with get, set

Property Value

Type: TSubsetModel
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier) Methods

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Methods

The MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddListModel | Calls the add handler, returns the list model that it creates. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyModelSubsetToControl | Sets the checkmarks on the control to mirror the checkmarks on the model list.
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Protected method | DeleteListModel | Calls the delete handler with the list model passed across. (Inherited from MasterListToListBinderTModel, TListModel.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base class docs. (Overrides MasterListToListBinderTModel, TListModelDispose(Boolean).)
Protected method | DoCopyControlToModel | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | DoCopyModelToControl | See base docs. (Overrides MasterListToListBinderTModel, TListModelDoCopyModelToControl.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | DoHookModel | Performs the actual work of hooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides MasterListToListBinderTModel, TListModelDoInitialising.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected method | DoUnhookModel | Performs the actual work of unhooking the model. Can be overridden. (Inherited from ControlBinder.)
Protected method | EditListModel | Calls the edit handler with the list model passed across. (Inherited from MasterListToListBinderTModel, TListModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).CopyModelSubsetToControl Method

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierCopyModelSubsetToControl Method
Sets the checkmarks on the control to mirror the checkmarks on the model list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void CopyModelSubsetToControl()
Protected Sub CopyModelSubsetToControl
protected:
void CopyModelSubsetToControl()
member CopyModelSubsetToControl : unit -> unit
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).Dispose Method

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base class docs. (Overrides MasterListToListBinderTModel, TListModelDispose(Boolean).)
Top
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).Dispose Method (Boolean)

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierDispose Method (Boolean)
See base class docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).DoCopyModelToControl Method

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierDoCopyModelToControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyModelToControl()
Protected Overrides Sub DoCopyModelToControl
protected:
virtual void DoCopyModelToControl() override
abstract DoCopyModelToControl : unit -> unit
override DoCopyModelToControl : unit -> unit
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier).DoInitialising Method

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifierDoInitialising Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialising()
Protected Overrides Sub DoInitialising
protected:
virtual void DoInitialising() override
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier) Fields

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Fields

The MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier generic type exposes the following members.

Fields
 | Name | Description
Protected field | _BaseFetchColumns | The base method to fetch columns. We chain onto this.
Protected field | _CheckedChangedHandler | Protected method that is handles changing the checked state for an item. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected field | _FetchColumns | Protected method that fetches the content of the list, split into columns. (Inherited from MasterListToListBinderTModel, TListModel.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


MasterListToSubsetBinder(TSubsetModel, TMasterModel, TListModel, TIdentifier)._BaseFetchColumns Field

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier_BaseFetchColumns Field
The base method to fetch columns. We chain onto this.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Action<TListModel, ListContentEventArgs> _BaseFetchColumns
Protected _BaseFetchColumns As Action(Of TListModel, ListContentEventArgs)
protected:
Action<TListModel, ListContentEventArgs^>^ _BaseFetchColumns
val mutable _BaseFetchColumns: Action<'TListModel, ListContentEventArgs>

Field Value

Type: Action TListModel, ListContentEventArgs
See Also

Reference

MasterListToSubsetBinderTSubsetModel, TMasterModel, TListModel, TIdentifier Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel) Class

NumericDoubleBinderTModel Class
Binds an double property on a model to a numeric up-down control.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, NumericUpDown, Double
VirtualRadar.WinForms.PortableBindingNumericDoubleBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumericDoubleBinder<TModel> : ValueBinder<TModel, NumericUpDown, double>
where TModel : class, INotifyPropertyChanged

Public Class NumericDoubleBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, NumericUpDown, Double)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class NumericDoubleBinder : public ValueBinder<TModel, NumericUpDown^, double>
type NumericDoubleBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, NumericUpDown, float>
    end

Type Parameters

TModel

The NumericDoubleBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | NumericDoubleBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | See base docs. (Overrides ControlBinderDoInitialiseControl.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel) Constructor

NumericDoubleBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumericDoubleBinder(
    TModel model,
    NumericUpDown control,
    Expression<Func<TModel, double>> getModelValue,
    Action<TModel, double> setModelValue
)
Public Sub New (
    model As TModel,
    control As NumericUpDown,
    getModelValue As Expression(Of Func(Of TModel, Double)),
    setModelValue As Action(Of TModel, Double)
)
public:
NumericDoubleBinder(
    TModel model,
    NumericUpDown^ control,
    Expression<Func<TModel, double>^>^ getModelValue,
    Action<TModel, double>^ setModelValue
)
new :
        model : 'TModel *
        control : NumericUpDown *
        getModelValue : Expression<Func<'TModel, float>> *
        setModelValue : Action<'TModel, float> -> NumericDoubleBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsNumericUpDown
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, Double
setModelValue
Type: SystemAction TModel, Double
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel) Properties

NumericDoubleBinderTModel Properties

The NumericDoubleBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel) Methods

NumericDoubleBinderTModel Methods

The NumericDoubleBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | See base docs. (Overrides ControlBinderDoInitialiseControl.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel).DoHookControlPropertyChanged Method

NumericDoubleBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel).DoInitialiseControl Method

NumericDoubleBinderTModelDoInitialiseControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialiseControl()
Protected Overrides Sub DoInitialiseControl
protected:
virtual void DoInitialiseControl() override
abstract DoInitialiseControl : unit -> unit
override DoInitialiseControl : unit -> unit
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel).DoUnhookControlPropertyChanged Method

NumericDoubleBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericDoubleBinder(TModel) Fields

NumericDoubleBinderTModel Fields

The NumericDoubleBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

NumericDoubleBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel) Class

NumericIntBinderTModel Class
Binds an intger property on a model to a numeric up-down control.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, NumericUpDown, Int32
VirtualRadar.WinForms.PortableBindingNumericIntBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumericIntBinder<TModel> : ValueBinder<TModel, NumericUpDown, int>
where TModel : class, INotifyPropertyChanged

Public Class NumericIntBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, NumericUpDown, Integer)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class NumericIntBinder : public ValueBinder<TModel, NumericUpDown^, int>
type NumericIntBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, NumericUpDown, int>
    end

Type Parameters

TModel

The NumericIntBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | NumericIntBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | See base docs. (Overrides ControlBinderDoInitialiseControl.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel) Constructor

NumericIntBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumericIntBinder(
    TModel model,
    NumericUpDown control,
    Expression<Func<TModel, int>> getModelValue,
    Action<TModel, int> setModelValue
)
Public Sub New (
    model As TModel,
    control As NumericUpDown,
    getModelValue As Expression(Of Func(Of TModel, Integer)),
    setModelValue As Action(Of TModel, Integer)
)
public:
NumericIntBinder(
    TModel model,
    NumericUpDown^ control,
    Expression<Func<TModel, int>^>^ getModelValue,
    Action<TModel, int>^ setModelValue
)
new :
        model : 'TModel *
        control : NumericUpDown *
        getModelValue : Expression<Func<'TModel, int>> *
        setModelValue : Action<'TModel, int> -> NumericIntBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsNumericUpDown
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, Int32
setModelValue
Type: SystemAction TModel, Int32
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel) Properties

NumericIntBinderTModel Properties

The NumericIntBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel) Methods

NumericIntBinderTModel Methods

The NumericIntBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | See base docs. (Overrides ControlBinderDoInitialiseControl.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel).DoHookControlPropertyChanged Method

NumericIntBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel).DoInitialiseControl Method

NumericIntBinderTModelDoInitialiseControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialiseControl()
Protected Overrides Sub DoInitialiseControl
protected:
virtual void DoInitialiseControl() override
abstract DoInitialiseControl : unit -> unit
override DoInitialiseControl : unit -> unit
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel).DoUnhookControlPropertyChanged Method

NumericIntBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


NumericIntBinder(TModel) Fields

NumericIntBinderTModel Fields

The NumericIntBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

NumericIntBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue) Class

RadioButtonEnumBinderTModel, TValue Class
Binds an enum value to a radio button control
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, RadioButtonPanel, TValue
VirtualRadar.WinForms.PortableBindingRadioButtonEnumBinderTModel, TValue

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RadioButtonEnumBinder<TModel, TValue> : ValueBinder<TModel, RadioButtonPanel, TValue>
where TModel : class, INotifyPropertyChanged

Public Class RadioButtonEnumBinder(Of TModel As {Class, INotifyPropertyChanged}, TValue)
    Inherits ValueBinder(Of TModel, RadioButtonPanel, TValue)
generic<typename TModel, typename TValue>
where TModel : ref class, INotifyPropertyChanged
public ref class RadioButtonEnumBinder : public ValueBinder<TModel, RadioButtonPanel^, TValue>
type RadioButtonEnumBinder<'TModel, 'TValue when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, RadioButtonPanel, 'TValue>
    end

Type Parameters

TModel
TValue

The RadioButtonEnumBinderTModel, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | RadioButtonEnumBinderTModel, TValue | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue) Constructor

RadioButtonEnumBinderTModel, TValue Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RadioButtonEnumBinder(
    TModel model,
    RadioButtonPanel control,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue
)
Public Sub New (
    model As TModel,
    control As RadioButtonPanel,
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue)
)
public:
RadioButtonEnumBinder(
    TModel model,
    RadioButtonPanel^ control,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue
)
new :
        model : 'TModel *
        control : RadioButtonPanel *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> -> RadioButtonEnumBinder

Parameters

model
Type: TModel
control
Type: RadioButtonPanel
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
See Also

Reference

RadioButtonEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue) Properties

RadioButtonEnumBinderTModel, TValue Properties

The RadioButtonEnumBinderTModel, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

RadioButtonEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue) Methods

RadioButtonEnumBinderTModel, TValue Methods

The RadioButtonEnumBinderTModel, TValue generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

RadioButtonEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue).DoHookControlPropertyChanged Method

RadioButtonEnumBinderTModel, TValueDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

RadioButtonEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue).DoUnhookControlPropertyChanged Method

RadioButtonEnumBinderTModel, TValueDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

RadioButtonEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


RadioButtonEnumBinder(TModel, TValue) Fields

RadioButtonEnumBinderTModel, TValue Fields

The RadioButtonEnumBinderTModel, TValue generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

RadioButtonEnumBinderTModel, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel) Class

TextBoxStringBinderTModel Class
Binds a text box to a string property. The text box's content is automatically trimmed before being sent to the model.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, TextBox, String
VirtualRadar.WinForms.PortableBindingTextBoxStringBinderTModel

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextBoxStringBinder<TModel> : ValueBinder<TModel, TextBox, string>
where TModel : class, INotifyPropertyChanged

Public Class TextBoxStringBinder(Of TModel As {Class, INotifyPropertyChanged})
    Inherits ValueBinder(Of TModel, TextBox, String)
generic<typename TModel>
where TModel : ref class, INotifyPropertyChanged
public ref class TextBoxStringBinder : public ValueBinder<TModel, TextBox^, String^>
type TextBoxStringBinder<'TModel when 'TModel : not struct and INotifyPropertyChanged> =
    class
        inherit ValueBinder<'TModel, TextBox, string>
    end

Type Parameters

TModel

The TextBoxStringBinderTModel type exposes the following members.

Constructors
 | Name | Description
Public method | TextBoxStringBinderTModel | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel) Constructor

TextBoxStringBinderTModel Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextBoxStringBinder(
    TModel model,
    TextBox control,
    Expression<Func<TModel, string>> getModelValue,
    Action<TModel, string> setModelValue
)
Public Sub New (
    model As TModel,
    control As TextBox,
    getModelValue As Expression(Of Func(Of TModel, String)),
    setModelValue As Action(Of TModel, String)
)
public:
TextBoxStringBinder(
    TModel model,
    TextBox^ control,
    Expression<Func<TModel, String^>^>^ getModelValue,
    Action<TModel, String^>^ setModelValue
)
new :
        model : 'TModel *
        control : TextBox *
        getModelValue : Expression<Func<'TModel, string>> *
        setModelValue : Action<'TModel, string> -> TextBoxStringBinder

Parameters

model
Type: TModel
control
Type: System.Windows.FormsTextBox
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, String
setModelValue
Type: SystemAction TModel, String
See Also

Reference

TextBoxStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel) Properties

TextBoxStringBinderTModel Properties

The TextBoxStringBinderTModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

TextBoxStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel) Methods

TextBoxStringBinderTModel Methods

The TextBoxStringBinderTModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | See base docs. (Overrides ControlBinderDoHookControlPropertyChanged(EventHandler).)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | See base docs. (Overrides ControlBinderDoUnhookControlPropertyChanged(EventHandler).)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

TextBoxStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel).DoHookControlPropertyChanged Method

TextBoxStringBinderTModelDoHookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoHookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoHookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoHookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

TextBoxStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel).DoUnhookControlPropertyChanged Method

TextBoxStringBinderTModelDoUnhookControlPropertyChanged Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookControlPropertyChanged(
    EventHandler eventHandler
)
Protected Overrides Sub DoUnhookControlPropertyChanged (
    eventHandler As EventHandler
)
protected:
virtual void DoUnhookControlPropertyChanged(
    EventHandler^ eventHandler
) override
abstract DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit
override DoUnhookControlPropertyChanged :
        eventHandler : EventHandler -> unit

Parameters

eventHandler
Type: SystemEventHandler
See Also

Reference

TextBoxStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


TextBoxStringBinder(TModel) Fields

TextBoxStringBinderTModel Fields

The TextBoxStringBinderTModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

TextBoxStringBinderTModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue) Class

ValueBinderTModel, TControl, TValue Class
A layer above ControlBinder that takes care of the common chores involved in binding between a single property on a model that implements INotifyPropertyChanged and a single property on a control.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinderTModel, TControl, TValue
More...

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ValueBinder<TModel, TControl, TValue> : ControlBinder
where TModel : class, INotifyPropertyChanged
where TControl : Control

Public MustInherit Class ValueBinder(Of TModel As {Class, INotifyPropertyChanged}, TControl As Control, TValue)
    Inherits ControlBinder
generic<typename TModel, typename TControl, typename TValue>
where TModel : ref class, INotifyPropertyChanged
where TControl : Control
public ref class ValueBinder abstract : public ControlBinder
[<AbstractClassAttribute>]
type ValueBinder<'TModel, 'TControl, 'TValue when 'TModel : not struct and INotifyPropertyChanged when 'TControl : Control> =
    class
        inherit ControlBinder
    end

Type Parameters

TModel
TControl
TValue

The ValueBinderTModel, TControl, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | ValueBinderTModel, TControl, TValue(TModel, TControl, ExpressionFuncTModel, TValue, ActionTModel, TValue) | Creates a new object.
Public method | ValueBinderTModel, TControl, TValue(TModel, TControl, ExpressionFuncTModel, TValue, ActionTModel, TValue, FuncTControl, TValue, ActionTControl, TValue) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control.
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value.
Public property | ControlValueObject | See base docs. (Overrides ControlBinderControlValueObject.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model.
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised.
Public property | ModelValue | Gets the model's value.
Public property | ModelValueObject | See base docs. (Overrides ControlBinderModelValueObject.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | Overridden to hook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoHookModel | See base docs. (Overrides ControlBinderDoHookModel.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ControlBinderDoInitialising.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | Overridden to unhook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoUnhookModel | See base docs. (Overrides ControlBinderDoUnhookModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value.
Protected field | _SetControlValue | Protected method that writes a control's current value.
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinderTModel, TControl, TValue
VirtualRadar.WinForms.PortableBindingCheckBoxBoolBinderTModel
VirtualRadar.WinForms.PortableBindingFileNameStringBinderTModel
VirtualRadar.WinForms.PortableBindingFolderStringBinderTModel
VirtualRadar.WinForms.PortableBindingLabelStringBinderTModel
VirtualRadar.WinForms.PortableBindingLinkLabelStringBinderTModel
VirtualRadar.WinForms.PortableBindingNumericDoubleBinderTModel
VirtualRadar.WinForms.PortableBindingNumericIntBinderTModel
VirtualRadar.WinForms.PortableBindingRadioButtonEnumBinderTModel, TValue
VirtualRadar.WinForms.PortableBindingTextBoxStringBinderTModel
VirtualRadar.WinForms.PortableBindingValueFromListBinderTModel, TControl, TValue, TListModel


ValueBinder(TModel, TControl, TValue) Constructor

ValueBinderTModel, TControl, TValue Constructor
Overload List
 | Name | Description
Public method | ValueBinderTModel, TControl, TValue(TModel, TControl, ExpressionFuncTModel, TValue, ActionTModel, TValue) | Creates a new object.
Public method | ValueBinderTModel, TControl, TValue(TModel, TControl, ExpressionFuncTModel, TValue, ActionTModel, TValue, FuncTControl, TValue, ActionTControl, TValue) | Creates a new object.
Top
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue) Constructor (TModel, TControl, Expression(Func(TModel, TValue)), Action(TModel, TValue))

ValueBinderTModel, TControl, TValue Constructor (TModel, TControl, ExpressionFuncTModel, TValue, ActionTModel, TValue)
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueBinder(
    TModel model,
    TControl control,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue
)
Public Sub New (
    model As TModel,
    control As TControl,
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue)
)
public:
ValueBinder(
    TModel model,
    TControl control,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue
)
new :
        model : 'TModel *
        control : 'TControl *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> -> ValueBinder

Parameters

model
Type: TModel
control
Type: TControl
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
See Also

Reference

ValueBinderTModel, TControl, TValue Class
ValueBinderTModel, TControl, TValue Overload
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue) Constructor (TModel, TControl, Expression(Func(TModel, TValue)), Action(TModel, TValue), Func(TControl, TValue), Action(TControl, TValue))

ValueBinderTModel, TControl, TValue Constructor (TModel, TControl, ExpressionFuncTModel, TValue, ActionTModel, TValue, FuncTControl, TValue, ActionTControl, TValue)
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueBinder(
    TModel model,
    TControl control,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue,
    Func<TControl, TValue> getControlValue,
    Action<TControl, TValue> setControlValue
)
Public Sub New (
    model As TModel,
    control As TControl,
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue),
    getControlValue As Func(Of TControl, TValue),
    setControlValue As Action(Of TControl, TValue)
)
public:
ValueBinder(
    TModel model,
    TControl control,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue,
    Func<TControl, TValue>^ getControlValue,
    Action<TControl, TValue>^ setControlValue
)
new :
        model : 'TModel *
        control : 'TControl *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> *
        getControlValue : Func<'TControl, 'TValue> *
        setControlValue : Action<'TControl, 'TValue> -> ValueBinder

Parameters

model
Type: TModel
control
Type: TControl
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
getControlValue
Type: SystemFunc TControl, TValue
setControlValue
Type: SystemAction TControl, TValue
See Also

Reference

ValueBinderTModel, TControl, TValue Class
ValueBinderTModel, TControl, TValue Overload
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue) Properties

ValueBinderTModel, TControl, TValue Properties

The ValueBinderTModel, TControl, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control.
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value.
Public property | ControlValueObject | See base docs. (Overrides ControlBinderControlValueObject.)
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Public property | Model | Gets the model.
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised.
Public property | ModelValue | Gets the model's value.
Public property | ModelValueObject | See base docs. (Overrides ControlBinderModelValueObject.)
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).Control Property

ValueBinderTModel, TControl, TValueControl Property
Gets the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TControl Control { get; }
Public ReadOnly Property Control As TControl
    Get
public:
property TControl Control {
    TControl get ();
}
member Control : 'TControl with get

Property Value

Type: TControl
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).ControlValue Property

ValueBinderTModel, TControl, TValueControlValue Property
Gets the control's value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue ControlValue { get; protected set; }
Public Property ControlValue As TValue
    Get
    Protected Set
public:
property TValue ControlValue {
    TValue get ();
    protected: void set (TValue value);
}
member ControlValue : 'TValue with get, set

Property Value

Type: TValue
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).ControlValueObject Property

ValueBinderTModel, TControl, TValueControlValueObject Property
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ControlValueObject { get; protected set; }
Public Overrides Property ControlValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ControlValueObject {
    Object^ get () override;
    protected: void set (Object^ value) override;
}
abstract ControlValueObject : Object with get, set
override ControlValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).Model Property

ValueBinderTModel, TControl, TValueModel Property
Gets the model.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TModel Model { get; set; }
Public Property Model As TModel
    Get
    Set
public:
property TModel Model {
    TModel get ();
    void set (TModel value);
}
member Model : 'TModel with get, set

Property Value

Type: TModel
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).ModelPropertyName Property

ValueBinderTModel, TControl, TValueModelPropertyName Property
Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModelPropertyName { get; set; }
Public Property ModelPropertyName As String
    Get
    Set
public:
property String^ ModelPropertyName {
    String^ get ();
    void set (String^ value);
}
member ModelPropertyName : string with get, set

Property Value

Type: String
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).ModelValue Property

ValueBinderTModel, TControl, TValueModelValue Property
Gets the model's value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TValue ModelValue { get; protected set; }
Public Property ModelValue As TValue
    Get
    Protected Set
public:
property TValue ModelValue {
    TValue get ();
    protected: void set (TValue value);
}
member ModelValue : 'TValue with get, set

Property Value

Type: TValue
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).ModelValueObject Property

ValueBinderTModel, TControl, TValueModelValueObject Property
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object ModelValueObject { get; protected set; }
Public Overrides Property ModelValueObject As Object
    Get
    Protected Set
public:
virtual property Object^ ModelValueObject {
    Object^ get () override;
    protected: void set (Object^ value) override;
}
abstract ModelValueObject : Object with get, set
override ModelValueObject : Object with get, set

Property Value

Type: Object
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue) Methods

ValueBinderTModel, TControl, TValue Methods

The ValueBinderTModel, TControl, TValue generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | Finalises or disposes of the object. (Inherited from ControlBinder.)
Protected method | DoCopyControlToModel | Does the actual work of copying the value from the control to the model. (Inherited from ControlBinder.)
Protected method | DoCopyModelToControl | Does the actual work of copying the value from the model to the control. (Inherited from ControlBinder.)
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | Overridden to hook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoHookModel | See base docs. (Overrides ControlBinderDoHookModel.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ControlBinderDoInitialising.)
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | Overridden to unhook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoUnhookModel | See base docs. (Overrides ControlBinderDoUnhookModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).DoHookModel Method

ValueBinderTModel, TControl, TValueDoHookModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoHookModel()
Protected Overrides Sub DoHookModel
protected:
virtual void DoHookModel() override
abstract DoHookModel : unit -> unit
override DoHookModel : unit -> unit
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).DoInitialising Method

ValueBinderTModel, TControl, TValueDoInitialising Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialising()
Protected Overrides Sub DoInitialising
protected:
virtual void DoInitialising() override
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue).DoUnhookModel Method

ValueBinderTModel, TControl, TValueDoUnhookModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoUnhookModel()
Protected Overrides Sub DoUnhookModel
protected:
virtual void DoUnhookModel() override
abstract DoUnhookModel : unit -> unit
override DoUnhookModel : unit -> unit
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue) Fields

ValueBinderTModel, TControl, TValue Fields

The ValueBinderTModel, TControl, TValue generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value.
Protected field | _SetControlValue | Protected method that writes a control's current value.
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue)._GetControlValue Field

ValueBinderTModel, TControl, TValue_GetControlValue Field
Protected method that reads a control's current value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Func<TControl, TValue> _GetControlValue
Protected _GetControlValue As Func(Of TControl, TValue)
protected:
Func<TControl, TValue>^ _GetControlValue
val mutable _GetControlValue: Func<'TControl, 'TValue>

Field Value

Type: Func TControl, TValue
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueBinder(TModel, TControl, TValue)._SetControlValue Field

ValueBinderTModel, TControl, TValue_SetControlValue Field
Protected method that writes a control's current value.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Action<TControl, TValue> _SetControlValue
Protected _SetControlValue As Action(Of TControl, TValue)
protected:
Action<TControl, TValue>^ _SetControlValue
val mutable _SetControlValue: Action<'TControl, 'TValue>

Field Value

Type: Action TControl, TValue
See Also

Reference

ValueBinderTModel, TControl, TValue Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Class

ValueFromListBinderTModel, TControl, TValue, TListModel Class
The base class for binders that let the user choose a single value from a list of values. If the list implements IBindingList then changes to the list are copied into the control.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.PortableBindingControlBinder
VirtualRadar.WinForms.PortableBindingValueBinder TModel, TControl, TValue
VirtualRadar.WinForms.PortableBindingValueFromListBinderTModel, TControl, TValue, TListModel
VirtualRadar.WinForms.PortableBindingComboBoxBinderTModel, TListModel, TValue

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ValueFromListBinder<TModel, TControl, TValue, TListModel> : ValueBinder<TModel, TControl, TValue>
where TModel : class, INotifyPropertyChanged
where TControl : Control

Public MustInherit Class ValueFromListBinder(Of TModel As {Class, INotifyPropertyChanged}, TControl As Control, TValue, TListModel)
    Inherits ValueBinder(Of TModel, TControl, TValue)
generic<typename TModel, typename TControl, typename TValue, typename TListModel>
where TModel : ref class, INotifyPropertyChanged
where TControl : Control
public ref class ValueFromListBinder abstract : public ValueBinder<TModel, TControl, TValue>
[<AbstractClassAttribute>]
type ValueFromListBinder<'TModel, 'TControl, 'TValue, 'TListModel when 'TModel : not struct and INotifyPropertyChanged when 'TControl : Control> =
    class
        inherit ValueBinder<'TModel, 'TControl, 'TValue>
    end

Type Parameters

TModel
The type of object that holds the value bound to a property on one object in the list of TListModel objects.
TControl
The type of control that renders the list and lets the user choose a single item.
TValue
The type of value to copy from the selected item to the control.
TListModel
The type of value held in the binding list.

The ValueFromListBinderTModel, TControl, TValue, TListModel type exposes the following members.

Constructors
 | Name | Description
Public method | ValueFromListBinderTModel, TControl, TValue, TListModel(TModel, TControl, IListTListModel, ExpressionFuncTModel, TValue, ActionTModel, TValue) | Creates a new object.
Public method | ValueFromListBinderTModel, TControl, TValue, TListModel(TModel, TControl, IListTListModel, ExpressionFuncTModel, TValue, ActionTModel, TValue, FuncTControl, TValue, ActionTControl, TValue) | Creates a new object.
Top
Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation.
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation.
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list.
Public property | List | Gets the list.
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted.
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control.
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Overrides ControlBinderDispose(Boolean).)
Protected method | DoCopyControlToModel | See base docs. (Overrides ControlBinderDoCopyControlToModel.)
Protected method | DoCopyListToControl | Copies the item descriptions to the control.
Protected method | DoCopyModelToControl | See base docs. (Overrides ControlBinderDoCopyModelToControl.)
Protected method | DoGetSelectedListValue | Does the work of getting the selected item from the list.
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | Overridden to hook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ValueBinderTModel, TControl, TValueDoInitialising.)
Protected method | DoSetSelectedListValue | Does the work of setting the value for the selected item in the list.
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | Overridden to unhook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked.
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
Remarks
Changes in the bound property on the model change which item is shown as selected in the list. Changes to the list of models are reflected on the display. The value copied from the row to the model is assumed to be a value that uniquely identifies the row in the list.
See Also

Reference

VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Constructor

ValueFromListBinderTModel, TControl, TValue, TListModel Constructor
Overload List
 | Name | Description
Public method | ValueFromListBinderTModel, TControl, TValue, TListModel(TModel, TControl, IListTListModel, ExpressionFuncTModel, TValue, ActionTModel, TValue) | Creates a new object.
Public method | ValueFromListBinderTModel, TControl, TValue, TListModel(TModel, TControl, IListTListModel, ExpressionFuncTModel, TValue, ActionTModel, TValue, FuncTControl, TValue, ActionTControl, TValue) | Creates a new object.
Top
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Constructor (TModel, TControl, IList(TListModel), Expression(Func(TModel, TValue)), Action(TModel, TValue))

ValueFromListBinderTModel, TControl, TValue, TListModel Constructor (TModel, TControl, IListTListModel, ExpressionFuncTModel, TValue, ActionTModel, TValue)
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueFromListBinder(
    TModel model,
    TControl control,
    IList<TListModel> list,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue
)
Public Sub New (
    model As TModel,
    control As TControl,
    list As IList(Of TListModel),
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue)
)
public:
ValueFromListBinder(
    TModel model,
    TControl control,
    IList<TListModel>^ list,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue
)
new :
        model : 'TModel *
        control : 'TControl *
        list : IList<'TListModel> *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> -> ValueFromListBinder

Parameters

model
Type: TModel
control
Type: TControl
list
Type: System.Collections.GenericIList TListModel
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
ValueFromListBinderTModel, TControl, TValue, TListModel Overload
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Constructor (TModel, TControl, IList(TListModel), Expression(Func(TModel, TValue)), Action(TModel, TValue), Func(TControl, TValue), Action(TControl, TValue))

ValueFromListBinderTModel, TControl, TValue, TListModel Constructor (TModel, TControl, IListTListModel, ExpressionFuncTModel, TValue, ActionTModel, TValue, FuncTControl, TValue, ActionTControl, TValue)
Creates a new object.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueFromListBinder(
    TModel model,
    TControl control,
    IList<TListModel> list,
    Expression<Func<TModel, TValue>> getModelValue,
    Action<TModel, TValue> setModelValue,
    Func<TControl, TValue> getControlValue,
    Action<TControl, TValue> setControlValue
)
Public Sub New (
    model As TModel,
    control As TControl,
    list As IList(Of TListModel),
    getModelValue As Expression(Of Func(Of TModel, TValue)),
    setModelValue As Action(Of TModel, TValue),
    getControlValue As Func(Of TControl, TValue),
    setControlValue As Action(Of TControl, TValue)
)
public:
ValueFromListBinder(
    TModel model,
    TControl control,
    IList<TListModel>^ list,
    Expression<Func<TModel, TValue>^>^ getModelValue,
    Action<TModel, TValue>^ setModelValue,
    Func<TControl, TValue>^ getControlValue,
    Action<TControl, TValue>^ setControlValue
)
new :
        model : 'TModel *
        control : 'TControl *
        list : IList<'TListModel> *
        getModelValue : Expression<Func<'TModel, 'TValue>> *
        setModelValue : Action<'TModel, 'TValue> *
        getControlValue : Func<'TControl, 'TValue> *
        setControlValue : Action<'TControl, 'TValue> -> ValueFromListBinder

Parameters

model
Type: TModel
control
Type: TControl
list
Type: System.Collections.GenericIList TListModel
getModelValue
Type: System.Linq.ExpressionsExpression Func TModel, TValue
setModelValue
Type: SystemAction TModel, TValue
getControlValue
Type: SystemFunc TControl, TValue
setControlValue
Type: SystemAction TControl, TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
ValueFromListBinderTModel, TControl, TValue, TListModel Overload
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Properties

ValueFromListBinderTModel, TControl, TValue, TListModel Properties

The ValueFromListBinderTModel, TControl, TValue, TListModel generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the control. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlObject | Gets the control that has been bound to the model. (Inherited from ControlBinder.)
Public property | ControlValue | Gets the control's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ControlValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | GetListItemDescription | Gets or sets a method that returns a list item's description. Cannot be set after initialisation.
Public property | GetListItemValue | Gets or sets a method that returns the list item's value. Cannot be set after initialisation.
Public property | Initialised | Gets a value indicating that the object has been initialised. (Inherited from ControlBinder.)
Protected property | ItemDescriptions | The list of descriptions that we're going to use for the list.
Public property | List | Gets the list.
Public property | Model | Gets the model. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelObject | Gets the model that has been bound to the control. (Inherited from ControlBinder.)
Public property | ModelPropertyName | Gets or sets the name of the model's property to bind to. Only required if the ctor getModelValue parameter does more than just return a property. Cannot be set once the binder has been initialised. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValue | Gets the model's value. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | ModelValueObject | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public property | SortList | Gets or sets a value indicating that the list should be sorted.
Public property | UpdateMode | Gets or sets an indication of when values are copied from the control to the model. Cannot be modified once the binder has been initialised. (Inherited from ControlBinder.)
Top
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).GetListItemDescription Property

ValueFromListBinderTModel, TControl, TValue, TListModelGetListItemDescription Property
Gets or sets a method that returns a list item's description. Cannot be set after initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<TListModel, string> GetListItemDescription { get; set; }
Public Property GetListItemDescription As Func(Of TListModel, String)
    Get
    Set
public:
property Func<TListModel, String^>^ GetListItemDescription {
    Func<TListModel, String^>^ get ();
    void set (Func<TListModel, String^>^ value);
}
member GetListItemDescription : Func<'TListModel, string> with get, set

Property Value

Type: Func TListModel, String
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).GetListItemValue Property

ValueFromListBinderTModel, TControl, TValue, TListModelGetListItemValue Property
Gets or sets a method that returns the list item's value. Cannot be set after initialisation.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<TListModel, TValue> GetListItemValue { get; set; }
Public Property GetListItemValue As Func(Of TListModel, TValue)
    Get
    Set
public:
property Func<TListModel, TValue>^ GetListItemValue {
    Func<TListModel, TValue>^ get ();
    void set (Func<TListModel, TValue>^ value);
}
member GetListItemValue : Func<'TListModel, 'TValue> with get, set

Property Value

Type: Func TListModel, TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).ItemDescriptions Property

ValueFromListBinderTModel, TControl, TValue, TListModelItemDescriptions Property
The list of descriptions that we're going to use for the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ItemDescriptionList<TListModel> ItemDescriptions { get; }
Protected ReadOnly Property ItemDescriptions As ItemDescriptionList(Of TListModel)
    Get
protected:
property ItemDescriptionList<TListModel>^ ItemDescriptions {
    ItemDescriptionList<TListModel>^ get ();
}
member ItemDescriptions : ItemDescriptionList<'TListModel> with get

Property Value

Type: ItemDescriptionList TListModel
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).List Property

ValueFromListBinderTModel, TControl, TValue, TListModelList Property
Gets the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TListModel> List { get; set; }
Public Property List As IList(Of TListModel)
    Get
    Set
public:
property IList<TListModel>^ List {
    IList<TListModel>^ get ();
    void set (IList<TListModel>^ value);
}
member List : IList<'TListModel> with get, set

Property Value

Type: IList TListModel
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).SortList Property

ValueFromListBinderTModel, TControl, TValue, TListModelSortList Property
Gets or sets a value indicating that the list should be sorted.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SortList { get; set; }
Public Property SortList As Boolean
    Get
    Set
public:
property bool SortList {
    bool get ();
    void set (bool value);
}
member SortList : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Methods

ValueFromListBinderTModel, TControl, TValue, TListModel Methods

The ValueFromListBinderTModel, TControl, TValue, TListModel generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeModelObject | Changes the model object. (Inherited from ControlBinder.)
Public method | CopyControlToModel | Refreshes the model's content with the content of the control. (Inherited from ControlBinder.)
Protected method | CopyListToControl | Copies the list to the control.
Public method | CopyModelToControl | Refreshes the control's content with the content of the model. (Inherited from ControlBinder.)
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Overrides ControlBinderDispose(Boolean).)
Protected method | DoCopyControlToModel | See base docs. (Overrides ControlBinderDoCopyControlToModel.)
Protected method | DoCopyListToControl | Copies the item descriptions to the control.
Protected method | DoCopyModelToControl | See base docs. (Overrides ControlBinderDoCopyModelToControl.)
Protected method | DoGetSelectedListValue | Does the work of getting the selected item from the list.
Protected method | DoHookControl | Performs the actual work of hooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoHookControlPropertyChanged | Overridden to hook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoHookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected method | DoInitialiseControl | Does the work of initialising the control. By default this just calls CopyModelToControl. (Inherited from ControlBinder.)
Protected method | DoInitialising | See base docs. (Overrides ValueBinderTModel, TControl, TValueDoInitialising.)
Protected method | DoSetSelectedListValue | Does the work of setting the value for the selected item in the list.
Protected method | DoUnhookControl | Performs the actual work of unhooking the control. Can be overridden. (Inherited from ControlBinder.)
Protected method | DoUnhookControlPropertyChanged | Overridden to unhook the control event that is raised as soon as the user changes the control's value. (Inherited from ControlBinder.)
Protected method | DoUnhookModel | See base docs. (Inherited from ValueBinderTModel, TControl, TValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Inherited from ControlBinder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetSelectedListValue | Gets the value for the selected item from the list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HookControl | Hooks the events on the control. (Inherited from ControlBinder.)
Protected method | HookModel | Hooks the events on the model. (Inherited from ControlBinder.)
Public method | Initialise | Initialises the binder. Must be called before the binder will start working. (Inherited from ControlBinder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetSelectedListValue | Sets the value for the selected item in the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UnhookControl | Unhooks the events on the control. (Inherited from ControlBinder.)
Protected method | UnhookModel | Unhooks the events on the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).CopyListToControl Method

ValueFromListBinderTModel, TControl, TValue, TListModelCopyListToControl Method
Copies the list to the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void CopyListToControl()
Protected Sub CopyListToControl
protected:
void CopyListToControl()
member CopyListToControl : unit -> unit
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).Dispose Method

ValueFromListBinderTModel, TControl, TValue, TListModelDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs. (Inherited from ControlBinder.)
Protected method | Dispose(Boolean) | See base docs. (Overrides ControlBinderDispose(Boolean).)
Top
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).Dispose Method (Boolean)

ValueFromListBinderTModel, TControl, TValue, TListModelDispose Method (Boolean)
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
Dispose Overload
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).DoCopyControlToModel Method

ValueFromListBinderTModel, TControl, TValue, TListModelDoCopyControlToModel Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyControlToModel()
Protected Overrides Sub DoCopyControlToModel
protected:
virtual void DoCopyControlToModel() override
abstract DoCopyControlToModel : unit -> unit
override DoCopyControlToModel : unit -> unit
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).DoCopyListToControl Method

ValueFromListBinderTModel, TControl, TValue, TListModelDoCopyListToControl Method
Copies the item descriptions to the control.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract void DoCopyListToControl(
    IEnumerable<ItemDescription<TListModel>> itemDescriptions
)
Protected MustOverride Sub DoCopyListToControl (
    itemDescriptions As IEnumerable(Of ItemDescription(Of TListModel))
)
protected:
virtual void DoCopyListToControl(
    IEnumerable<ItemDescription<TListModel>^>^ itemDescriptions
) abstract
abstract DoCopyListToControl :
        itemDescriptions : IEnumerable<ItemDescription<'TListModel>> -> unit

Parameters

itemDescriptions
Type: System.Collections.GenericIEnumerable ItemDescription TListModel
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).DoCopyModelToControl Method

ValueFromListBinderTModel, TControl, TValue, TListModelDoCopyModelToControl Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoCopyModelToControl()
Protected Overrides Sub DoCopyModelToControl
protected:
virtual void DoCopyModelToControl() override
abstract DoCopyModelToControl : unit -> unit
override DoCopyModelToControl : unit -> unit
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).DoGetSelectedListValue Method

ValueFromListBinderTModel, TControl, TValue, TListModelDoGetSelectedListValue Method
Does the work of getting the selected item from the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract TValue DoGetSelectedListValue()
Protected MustOverride Function DoGetSelectedListValue As TValue
protected:
virtual TValue DoGetSelectedListValue() abstract
abstract DoGetSelectedListValue : unit -> 'TValue

Return Value

Type: TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).DoInitialising Method

ValueFromListBinderTModel, TControl, TValue, TListModelDoInitialising Method
See base docs.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void DoInitialising()
Protected Overrides Sub DoInitialising
protected:
virtual void DoInitialising() override
abstract DoInitialising : unit -> unit
override DoInitialising : unit -> unit
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).DoSetSelectedListValue Method

ValueFromListBinderTModel, TControl, TValue, TListModelDoSetSelectedListValue Method
Does the work of setting the value for the selected item in the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract void DoSetSelectedListValue(
    TValue value
)
Protected MustOverride Sub DoSetSelectedListValue (
    value As TValue
)
protected:
virtual void DoSetSelectedListValue(
    TValue value
) abstract
abstract DoSetSelectedListValue :
        value : 'TValue -> unit

Parameters

value
Type: TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).GetSelectedListValue Method

ValueFromListBinderTModel, TControl, TValue, TListModelGetSelectedListValue Method
Gets the value for the selected item from the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected TValue GetSelectedListValue()
Protected Function GetSelectedListValue As TValue
protected:
TValue GetSelectedListValue()
member GetSelectedListValue : unit -> 'TValue

Return Value

Type: TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel).SetSelectedListValue Method

ValueFromListBinderTModel, TControl, TValue, TListModelSetSelectedListValue Method
Sets the value for the selected item in the list.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void SetSelectedListValue(
    TValue value
)
Protected Sub SetSelectedListValue (
    value As TValue
)
protected:
void SetSelectedListValue(
    TValue value
)
member SetSelectedListValue :
        value : 'TValue -> unit

Parameters

value
Type: TValue
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel) Fields

ValueFromListBinderTModel, TControl, TValue, TListModel Fields

The ValueFromListBinderTModel, TControl, TValue, TListModel generic type exposes the following members.

Fields
 | Name | Description
Protected field | _GetControlValue | Protected method that reads a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _ListUpdatesLocked | True if copies between lists are locked.
Protected field | _SetControlValue | Protected method that writes a control's current value. (Inherited from ValueBinderTModel, TControl, TValue.)
Protected field | _UpdatesLocked | True if changes are not to be copied between the control and the model. (Inherited from ControlBinder.)
Top
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


ValueFromListBinder(TModel, TControl, TValue, TListModel)._ListUpdatesLocked Field

ValueFromListBinderTModel, TControl, TValue, TListModel_ListUpdatesLocked Field
True if copies between lists are locked.

Namespace: VirtualRadar.WinForms.PortableBinding
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected bool _ListUpdatesLocked
Protected _ListUpdatesLocked As Boolean
protected:
bool _ListUpdatesLocked
val mutable _ListUpdatesLocked: bool

Field Value

Type: Boolean
See Also

Reference

ValueFromListBinderTModel, TControl, TValue, TListModel Class
VirtualRadar.WinForms.PortableBinding Namespace


VirtualRadar.WinForms.SettingPage Namespace

VirtualRadar.WinForms.SettingPage Namespace

[Missing <summary> documentation for "N:VirtualRadar.WinForms.SettingPage"]

Classes
 | Class | Description
Public class | CombinedFeed | Describes a feed item, which is derived from either a receiver or a merged feed.
Public class | Page | The base class for all setting pages.
Protected class | PageInlineHelp | Describes an article of inline help.
Public class | PageDataSources | Presents the data sources values to the user.
Public class | PageDataSourcesSummary | The page summary object.
Public class | PageGeneral | Displays general / miscellaneous settings to the user for editing.
Public class | PageGeneralSummary | The page summary object.
Public class | PageMergedFeed | Handles the display of a merged feed's settings to the user.
Public class | PageMergedFeedSummary | The page summary object.
Public class | PageMergedFeeds | Shows the full list of merged feeds to the user.
Public class | PageMergedFeedsSummary | The page summary object.
Public class | PageMono | The page that displays, and allows for the editing of, settings that are only used when VRS is running under Mono.
Public class | PageMonoSummary | The page summary object.
Public class | PageRawFeedDecoding | Displays the raw feed decoding settings to the user.
Public class | PageRawFeedDecodingSummary | The page summary object.
Public class | PageRebroadcastServer | Displays the settings for an individual rebroadcast server.
Public class | PageRebroadcastServerSummary | The summary object for rebroadcast server pages.
Public class | PageRebroadcastServers | Shows the user all of the rebroadcast servers currently configured, lets them add new ones, remove existing ones etc.
Public class | PageRebroadcastServersSummary | The page summary object.
Public class | PageReceiver | The options data entry page for a receiver.
Public class | PageReceiverSummary | The summary for receiver pages.
Public class | PageReceiverLocation | Allows data entry for a single receiver location.
Public class | PageReceiverLocationSummary | The summary for receiver location pages.
Public class | PageReceiverLocations | The parent page for all receiver locations.
Public class | PageReceiverLocationsSummary | The page summary object.
Public class | PageReceivers | The parent page for all receivers.
Public class | PageReceiversSummary | The page summary object.
Public class | PageSummary | A class that exposes the summary information for a Page.
Public class | PageUser | Displays a single user's details and accepts edits to them.
Public class | PageUserSummary | Describes the content of the user page.
Public class | PageUsers | Displays and allows for the editing of the list of users.
Public class | PageUsersSummary | The page summary object.
Public class | PageWebServer | Lets the user view and change the web server settings.
Public class | PageWebServerSummary | The page summary object.
Public class | PageWebServerAdministrators | Supports the configuration of the administrators user list for the site.
Public class | PageWebServerAdministratorsSummary | The summary for web server authentication pages.
Public class | PageWebServerUsers | Allows configuration of the valid user list for the web site.
Public class | PageWebServerUsersSummary | The summary for web server authentication pages.
Public class | PageWebSite | Lets the user edit the web site settings.
Public class | PageWebSiteSummary | The page summary object.
Public class | PageWebSiteInitialSettings | Displays the initial settings for the web site to the user and lets them change them.
Public class | PageWebSiteInitialSettingsSummary | Describes the content of the initial site settings page.


CombinedFeed Class

CombinedFeed Class
Describes a feed item, which is derived from either a receiver or a merged feed.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPageCombinedFeed

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CombinedFeed : INotifyPropertyChanged,
    IDisposable
Public Class CombinedFeed
    Implements INotifyPropertyChanged, IDisposable
public ref class CombinedFeed : INotifyPropertyChanged,
    IDisposable
type CombinedFeed =
    class
        interface INotifyPropertyChanged
        interface IDisposable
    end

The CombinedFeed type exposes the following members.

Constructors
 | Name | Description
Public method | CombinedFeed(MergedFeed) | Creates a new object.
Public method | CombinedFeed(Receiver) | Creates a new object.
Top
Properties
 | Name | Description
Public property | MergedFeed | Gets the merged feed that is a part of the combined feed.
Public property | Name | Gets the name of the receiver or merged feed.
Public property | Receiver | Gets the receiver that is a part of the combined feed.
Public property | UniqueId | Gets the unique ID of the receiver or merged feed.
Top
Methods
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes or finalises an object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed Constructor

CombinedFeed Constructor
Overload List
 | Name | Description
Public method | CombinedFeed(MergedFeed) | Creates a new object.
Public method | CombinedFeed(Receiver) | Creates a new object.
Top
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed Constructor (MergedFeed)

CombinedFeed Constructor (MergedFeed)
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CombinedFeed(
    MergedFeed mergedFeed
)
Public Sub New (
    mergedFeed As MergedFeed
)
public:
CombinedFeed(
    MergedFeed^ mergedFeed
)
new :
        mergedFeed : MergedFeed -> CombinedFeed

Parameters

mergedFeed
Type: VirtualRadar.Interface.SettingsMergedFeed
See Also

Reference

CombinedFeed Class
CombinedFeed Overload
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed Constructor (Receiver)

CombinedFeed Constructor (Receiver)
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CombinedFeed(
    Receiver receiver
)
Public Sub New (
    receiver As Receiver
)
public:
CombinedFeed(
    Receiver^ receiver
)
new :
        receiver : Receiver -> CombinedFeed

Parameters

receiver
Type: VirtualRadar.Interface.SettingsReceiver
See Also

Reference

CombinedFeed Class
CombinedFeed Overload
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed Properties

CombinedFeed Properties

The CombinedFeed type exposes the following members.

Properties
 | Name | Description
Public property | MergedFeed | Gets the merged feed that is a part of the combined feed.
Public property | Name | Gets the name of the receiver or merged feed.
Public property | Receiver | Gets the receiver that is a part of the combined feed.
Public property | UniqueId | Gets the unique ID of the receiver or merged feed.
Top
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.MergedFeed Property

CombinedFeedMergedFeed Property
Gets the merged feed that is a part of the combined feed.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MergedFeed MergedFeed { get; }
Public ReadOnly Property MergedFeed As MergedFeed
    Get
public:
property MergedFeed^ MergedFeed {
    MergedFeed^ get ();
}
member MergedFeed : MergedFeed with get

Property Value

Type: MergedFeed
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.Name Property

CombinedFeedName Property
Gets the name of the receiver or merged feed.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.Receiver Property

CombinedFeedReceiver Property
Gets the receiver that is a part of the combined feed.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Receiver Receiver { get; }
Public ReadOnly Property Receiver As Receiver
    Get
public:
property Receiver^ Receiver {
    Receiver^ get ();
}
member Receiver : Receiver with get

Property Value

Type: Receiver
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.UniqueId Property

CombinedFeedUniqueId Property
Gets the unique ID of the receiver or merged feed.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UniqueId { get; }
Public ReadOnly Property UniqueId As Integer
    Get
public:
property int UniqueId {
    int get ();
}
member UniqueId : int with get

Property Value

Type: Int32
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed Methods

CombinedFeed Methods

The CombinedFeed type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes or finalises an object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalises the object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises PropertyChanged.
Public method | ToString | See base docs. (Overrides ObjectToString.)
Top
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.Dispose Method

CombinedFeedDispose Method
Overload List
 | Name | Description
Public method | Dispose | See interface docs.
Protected method | Dispose(Boolean) | Disposes or finalises an object.
Top
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.Dispose Method

CombinedFeedDispose Method
See interface docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CombinedFeed Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.Dispose Method (Boolean)

CombinedFeedDispose Method (Boolean)
Disposes or finalises an object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

CombinedFeed Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.Finalize Method

CombinedFeedFinalize Method
Finalises the object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit

Implements

ObjectFinalize
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.OnPropertyChanged Method

CombinedFeedOnPropertyChanged Method
Raises PropertyChanged.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs args
)
Protected Overridable Sub OnPropertyChanged (
    args As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ args
)
abstract OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        args : PropertyChangedEventArgs -> unit

Parameters

args
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.ToString Method

CombinedFeedToString Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed Events

CombinedFeed Events

The CombinedFeed type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | See interface docs.
Top
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


CombinedFeed.PropertyChanged Event

CombinedFeedPropertyChanged Event
See interface docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CombinedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


Page Class

Page Class
The base class for all setting pages.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
More...

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Page : BaseUserControl
Public Class Page
    Inherits BaseUserControl
public ref class Page : public BaseUserControl
type Page =
    class
        inherit BaseUserControl
    end

The Page type exposes the following members.

Constructors
 | Name | Description
Public method | Page | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView.
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page.
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | When overridden by the derivee this creates bindings between the page and objects on the owning SettingsView.
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page.
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Overrides UserControlOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across.
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls.
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help.
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageDataSources
VirtualRadar.WinForms.SettingPagePageGeneral
VirtualRadar.WinForms.SettingPagePageMergedFeed
VirtualRadar.WinForms.SettingPagePageMergedFeeds
VirtualRadar.WinForms.SettingPagePageMono
VirtualRadar.WinForms.SettingPagePageRawFeedDecoding
VirtualRadar.WinForms.SettingPagePageRebroadcastServer
VirtualRadar.WinForms.SettingPagePageRebroadcastServers
VirtualRadar.WinForms.SettingPagePageReceiver
VirtualRadar.WinForms.SettingPagePageReceiverLocation
VirtualRadar.WinForms.SettingPagePageReceiverLocations
VirtualRadar.WinForms.SettingPagePageReceivers
VirtualRadar.WinForms.SettingPagePageUser
VirtualRadar.WinForms.SettingPagePageUsers
VirtualRadar.WinForms.SettingPagePageWebServer
VirtualRadar.WinForms.SettingPagePageWebServerAdministrators
VirtualRadar.WinForms.SettingPagePageWebServerUsers
VirtualRadar.WinForms.SettingPagePageWebSite
VirtualRadar.WinForms.SettingPagePageWebSiteInitialSettings


Page Constructor

Page Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Page()
Public Sub New
public:
Page()
new : unit -> Page
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page Properties

Page Properties

The Page type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView.
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page.
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.ChildPages Property

PageChildPages Property
Gets a collection of every child page under this page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<Page> ChildPages { get; }
Public ReadOnly Property ChildPages As NotifyList(Of Page)
    Get
public:
property NotifyList<Page^>^ ChildPages {
    NotifyList<Page^>^ get ();
}
member ChildPages : NotifyList<Page> with get

Property Value

Type: NotifyList Page
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.IsInSettingsView Property

PageIsInSettingsView Property
Gets a value indicating that the page is on display in the SettingsView.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInSettingsView { get; }
Public ReadOnly Property IsInSettingsView As Boolean
    Get
public:
property bool IsInSettingsView {
    bool get ();
}
member IsInSettingsView : bool with get

Property Value

Type: Boolean
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.PageSummary Property

PagePageSummary Property
Gets or sets the page summary associated with this page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageSummary PageSummary { get; set; }
Public Property PageSummary As PageSummary
    Get
    Set
public:
property PageSummary^ PageSummary {
    PageSummary^ get ();
    void set (PageSummary^ value);
}
member PageSummary : PageSummary with get, set

Property Value

Type: PageSummary
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.PageUseFullHeight Property

PagePageUseFullHeight Property
If true then the page is stretched vertically to fill the available space.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PageUseFullHeight { get; }
Public Overridable ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get ();
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.SettingsView Property

PageSettingsView Property
Gets the owning settings view.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SettingsView SettingsView { get; }
Public ReadOnly Property SettingsView As SettingsView
    Get
public:
property SettingsView^ SettingsView {
    SettingsView^ get ();
}
member SettingsView : SettingsView with get

Property Value

Type: SettingsView
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page Methods

Page Methods

The Page type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | When overridden by the derivee this creates bindings between the page and objects on the owning SettingsView.
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page.
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Overrides UserControlOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across.
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls.
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.AssociateInlineHelp Method

PageAssociateInlineHelp Method
Associates controls with inline help.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void AssociateInlineHelp()
Protected Overridable Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp()
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.ClearBindings Method

PageClearBindings Method
Removes all bindings from the page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void ClearBindings()
Protected Overridable Sub ClearBindings
protected:
virtual void ClearBindings()
abstract ClearBindings : unit -> unit
override ClearBindings : unit -> unit
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.CreateBindings Method

PageCreateBindings Method
When overridden by the derivee this creates bindings between the page and objects on the owning SettingsView.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void CreateBindings()
Protected Overridable Sub CreateBindings
protected:
virtual void CreateBindings()
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.Dispose Method

PageDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides BaseUserControl.Dispose(Boolean).)
Top
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.Dispose Method (Boolean)

PageDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

Page Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


Page.Initialise Method

PageInitialise Method
Initialises the page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialise()
Public Sub Initialise
public:
void Initialise()
member Initialise : unit -> unit
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.InitialiseControls Method

PageInitialiseControls Method
Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void InitialiseControls()
Protected Overridable Sub InitialiseControls
protected:
virtual void InitialiseControls()
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.OnLoad Method

PageOnLoad Method
Called after the page has been loaded but before it is shown to the user.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
protected:
virtual void OnLoad(
    EventArgs^ e
) override
abstract OnLoad :
        e : EventArgs -> unit
override OnLoad :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.SetInlineHelp Method

PageSetInlineHelp Method
Sets the inline help up for the control passed across.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void SetInlineHelp(
    Control control,
    string title,
    string help
)
Protected Overridable Sub SetInlineHelp (
    control As Control,
    title As String,
    help As String
)
protected:
virtual void SetInlineHelp(
    Control^ control,
    String^ title,
    String^ help
)
abstract SetInlineHelp :
        control : Control *
        title : string *
        help : string -> unit
override SetInlineHelp :
        control : Control *
        title : string *
        help : string -> unit

Parameters

control
Type: System.Windows.FormsControl
title
Type: SystemString
help
Type: SystemString
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.SetValidationFields Method

PageSetValidationFields Method
Associates validation fields with controls.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void SetValidationFields(
    Dictionary<ValidationField, Control> fields
)
Protected Sub SetValidationFields (
    fields As Dictionary(Of ValidationField, Control)
)
protected:
void SetValidationFields(
    Dictionary<ValidationField, Control^>^ fields
)
member SetValidationFields :
        fields : Dictionary<ValidationField, Control> -> unit

Parameters

fields
Type: System.Collections.GenericDictionary ValidationField, Control
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page Events

Page Events

The Page type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page Fields

Page Fields

The Page type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help.
Top
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page._InlineHelpMap Field

Page_InlineHelpMap Field
A map of controls to their inline help.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Dictionary<Control, PageInlineHelp> _InlineHelpMap
Protected _InlineHelpMap As Dictionary(Of Control, PageInlineHelp)
protected:
Dictionary<Control^, PageInlineHelp^>^ _InlineHelpMap
val mutable _InlineHelpMap: Dictionary<Control, PageInlineHelp>

Field Value

Type: Dictionary Control, PageInlineHelp
See Also

Reference

Page Class
VirtualRadar.WinForms.SettingPage Namespace


Page.InlineHelp Class

PageInlineHelp Class
Describes an article of inline help.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageInlineHelp

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected class InlineHelp
Protected Class InlineHelp
protected ref class InlineHelp
type InlineHelp =  class end

The PageInlineHelp type exposes the following members.

Constructors
 | Name | Description
Public method | PageInlineHelp | Creates a new object.
Top
Properties
 | Name | Description
Public property | Help | Gets or sets the help text.
Public property | Title | Gets or sets the help text's title.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


Page.InlineHelp Constructor

PageInlineHelp Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InlineHelp(
    string title,
    string help
)
Public Sub New (
    title As String,
    help As String
)
public:
InlineHelp(
    String^ title,
    String^ help
)
new :
        title : string *
        help : string -> InlineHelp

Parameters

title
Type: SystemString
help
Type: SystemString
See Also

Reference

PageInlineHelp Class
VirtualRadar.WinForms.SettingPage Namespace


InlineHelp Properties

InlineHelp Properties

The PageInlineHelp type exposes the following members.

Properties
 | Name | Description
Public property | Help | Gets or sets the help text.
Public property | Title | Gets or sets the help text's title.
Top
See Also

Reference

PageInlineHelp Class
VirtualRadar.WinForms.SettingPage Namespace


Page.InlineHelp.Help Property

PageInlineHelpHelp Property
Gets or sets the help text.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Help { get; set; }
Public Property Help As String
    Get
    Set
public:
property String^ Help {
    String^ get ();
    void set (String^ value);
}
member Help : string with get, set

Property Value

Type: String
See Also

Reference

PageInlineHelp Class
VirtualRadar.WinForms.SettingPage Namespace


Page.InlineHelp.Title Property

PageInlineHelpTitle Property
Gets or sets the help text's title.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

PageInlineHelp Class
VirtualRadar.WinForms.SettingPage Namespace


InlineHelp Methods

InlineHelp Methods

The PageInlineHelp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageInlineHelp Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources Class

PageDataSources Class
Presents the data sources values to the user.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageDataSources

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageDataSources : Page
Public Class PageDataSources
    Inherits Page
public ref class PageDataSources : public Page
type PageDataSources =
    class
        inherit Page
    end

The PageDataSources type exposes the following members.

Constructors
 | Name | Description
Public method | PageDataSources | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageDataSources Constructor

PageDataSources Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageDataSources()
Public Sub New
public:
PageDataSources()
new : unit -> PageDataSources
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources Properties

PageDataSources Properties

The PageDataSources type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources Methods

PageDataSources Methods

The PageDataSources type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.AssociateInlineHelp Method

PageDataSourcesAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.CreateBindings Method

PageDataSourcesCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Dispose Method

PageDataSourcesDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Dispose Method (Boolean)

PageDataSourcesDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageDataSources Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources Events

PageDataSources Events

The PageDataSources type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources Fields

PageDataSources Fields

The PageDataSources type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageDataSources Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Summary Class

PageDataSourcesSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageDataSourcesSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageDataSourcesSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageDataSourcesSummary | Initializes a new instance of the PageDataSourcesSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Summary Constructor

PageDataSourcesSummary Constructor
Initializes a new instance of the PageDataSourcesSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageDataSourcesSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Summary.PageIcon Property

PageDataSourcesSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Summary.PageTitle Property

PageDataSourcesSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageDataSourcesSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Summary.AssociateValidationFields Method

PageDataSourcesSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageDataSources.Summary.DoCreatePage Method

PageDataSourcesSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageDataSourcesSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageDataSourcesSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral Class

PageGeneral Class
Displays general / miscellaneous settings to the user for editing.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageGeneral

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageGeneral : Page
Public Class PageGeneral
    Inherits Page
public ref class PageGeneral : public Page
type PageGeneral =
    class
        inherit Page
    end

The PageGeneral type exposes the following members.

Constructors
 | Name | Description
Public method | PageGeneral | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | See base docs. (Overrides PageOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageGeneral Constructor

PageGeneral Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageGeneral()
Public Sub New
public:
PageGeneral()
new : unit -> PageGeneral
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral Properties

PageGeneral Properties

The PageGeneral type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral Methods

PageGeneral Methods

The PageGeneral type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | See base docs. (Overrides PageOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.AssociateInlineHelp Method

PageGeneralAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.CreateBindings Method

PageGeneralCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Dispose Method

PageGeneralDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Dispose Method (Boolean)

PageGeneralDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageGeneral Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.OnLoad Method

PageGeneralOnLoad Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
protected:
virtual void OnLoad(
    EventArgs^ e
) override
abstract OnLoad :
        e : EventArgs -> unit
override OnLoad :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral Events

PageGeneral Events

The PageGeneral type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral Fields

PageGeneral Fields

The PageGeneral type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageGeneral Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary Class

PageGeneralSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageGeneralSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageGeneralSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageGeneralSummary | Initializes a new instance of the PageGeneralSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary Constructor

PageGeneralSummary Constructor
Initializes a new instance of the PageGeneralSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageGeneralSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary.PageIcon Property

PageGeneralSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary.PageTitle Property

PageGeneralSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageGeneralSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary.AssociateChildPages Method

PageGeneralSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary.AssociateValidationFields Method

PageGeneralSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageGeneral.Summary.DoCreatePage Method

PageGeneralSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageGeneralSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageGeneralSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed Class

PageMergedFeed Class
Handles the display of a merged feed's settings to the user.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageMergedFeed

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageMergedFeed : Page
Public Class PageMergedFeed
    Inherits Page
public ref class PageMergedFeed : public Page
type PageMergedFeed =
    class
        inherit Page
    end

The PageMergedFeed type exposes the following members.

Constructors
 | Name | Description
Public method | PageMergedFeed | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MergedFeed | See base docs.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed Constructor

PageMergedFeed Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageMergedFeed()
Public Sub New
public:
PageMergedFeed()
new : unit -> PageMergedFeed
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed Properties

PageMergedFeed Properties

The PageMergedFeed type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MergedFeed | See base docs.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.MergedFeed Property

PageMergedFeedMergedFeed Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MergedFeed MergedFeed { get; }
Public ReadOnly Property MergedFeed As MergedFeed
    Get
public:
property MergedFeed^ MergedFeed {
    MergedFeed^ get ();
}
member MergedFeed : MergedFeed with get

Property Value

Type: MergedFeed
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.PageUseFullHeight Property

PageMergedFeedPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed Methods

PageMergedFeed Methods

The PageMergedFeed type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.AssociateInlineHelp Method

PageMergedFeedAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.CreateBindings Method

PageMergedFeedCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Dispose Method

PageMergedFeedDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Dispose Method (Boolean)

PageMergedFeedDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageMergedFeed Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.InitialiseControls Method

PageMergedFeedInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed Events

PageMergedFeed Events

The PageMergedFeed type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed Fields

PageMergedFeed Fields

The PageMergedFeed type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageMergedFeed Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Summary Class

PageMergedFeedSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageMergedFeedSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageMergedFeedSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageMergedFeedSummary | Creates a new object.
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | MergedFeed | See base docs.
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Summary Constructor

PageMergedFeedSummary Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageMergedFeedSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | MergedFeed | See base docs.
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Summary.MergedFeed Property

PageMergedFeedSummaryMergedFeed Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MergedFeed MergedFeed { get; }
Public ReadOnly Property MergedFeed As MergedFeed
    Get
public:
property MergedFeed^ MergedFeed {
    MergedFeed^ get ();
}
member MergedFeed : MergedFeed with get

Property Value

Type: MergedFeed
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Summary.PageIcon Property

PageMergedFeedSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageMergedFeedSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Summary.AssociateValidationFields Method

PageMergedFeedSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeed.Summary.DoCreatePage Method

PageMergedFeedSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageMergedFeedSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageMergedFeedSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds Class

PageMergedFeeds Class
Shows the full list of merged feeds to the user.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageMergedFeeds

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageMergedFeeds : Page
Public Class PageMergedFeeds
    Inherits Page
public ref class PageMergedFeeds : public Page
type PageMergedFeeds =
    class
        inherit Page
    end

The PageMergedFeeds type exposes the following members.

Constructors
 | Name | Description
Public method | PageMergedFeeds | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds Constructor

PageMergedFeeds Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageMergedFeeds()
Public Sub New
public:
PageMergedFeeds()
new : unit -> PageMergedFeeds
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds Properties

PageMergedFeeds Properties

The PageMergedFeeds type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.PageUseFullHeight Property

PageMergedFeedsPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds Methods

PageMergedFeeds Methods

The PageMergedFeeds type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.AssociateInlineHelp Method

PageMergedFeedsAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.CreateBindings Method

PageMergedFeedsCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Dispose Method

PageMergedFeedsDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Dispose Method (Boolean)

PageMergedFeedsDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageMergedFeeds Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds Events

PageMergedFeeds Events

The PageMergedFeeds type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds Fields

PageMergedFeeds Fields

The PageMergedFeeds type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageMergedFeeds Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Summary Class

PageMergedFeedsSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageMergedFeedsSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageMergedFeedsSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageMergedFeedsSummary | Initializes a new instance of the PageMergedFeedsSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | Creates a new object. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Summary Constructor

PageMergedFeedsSummary Constructor
Initializes a new instance of the PageMergedFeedsSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageMergedFeedsSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Summary.PageIcon Property

PageMergedFeedsSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Summary.PageTitle Property

PageMergedFeedsSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageMergedFeedsSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | Creates a new object. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Summary.AssociateChildPages Method

PageMergedFeedsSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMergedFeeds.Summary.DoCreatePage Method

PageMergedFeedsSummaryDoCreatePage Method
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageMergedFeedsSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageMergedFeedsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono Class

PageMono Class
The page that displays, and allows for the editing of, settings that are only used when VRS is running under Mono.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageMono

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageMono : Page
Public Class PageMono
    Inherits Page
public ref class PageMono : public Page
type PageMono =
    class
        inherit Page
    end

The PageMono type exposes the following members.

Constructors
 | Name | Description
Public method | PageMono | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageMono Constructor

PageMono Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageMono()
Public Sub New
public:
PageMono()
new : unit -> PageMono
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono Properties

PageMono Properties

The PageMono type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono Methods

PageMono Methods

The PageMono type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.AssociateInlineHelp Method

PageMonoAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.CreateBindings Method

PageMonoCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Dispose Method

PageMonoDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Dispose Method (Boolean)

PageMonoDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageMono Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageMono Events

PageMono Events

The PageMono type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono Fields

PageMono Fields

The PageMono type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageMono Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Summary Class

PageMonoSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageMonoSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageMonoSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageMonoSummary | Initializes a new instance of the PageMonoSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageMono.Summary Constructor

PageMonoSummary Constructor
Initializes a new instance of the PageMonoSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageMonoSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Summary.PageIcon Property

PageMonoSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Summary.PageTitle Property

PageMonoSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageMonoSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Summary.AssociateValidationFields Method

PageMonoSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageMono.Summary.DoCreatePage Method

PageMonoSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageMonoSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageMonoSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding Class

PageRawFeedDecoding Class
Displays the raw feed decoding settings to the user.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageRawFeedDecoding

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageRawFeedDecoding : Page
Public Class PageRawFeedDecoding
    Inherits Page
public ref class PageRawFeedDecoding : public Page
type PageRawFeedDecoding =
    class
        inherit Page
    end

The PageRawFeedDecoding type exposes the following members.

Constructors
 | Name | Description
Public method | PageRawFeedDecoding | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding Constructor

PageRawFeedDecoding Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageRawFeedDecoding()
Public Sub New
public:
PageRawFeedDecoding()
new : unit -> PageRawFeedDecoding
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding Properties

PageRawFeedDecoding Properties

The PageRawFeedDecoding type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding Methods

PageRawFeedDecoding Methods

The PageRawFeedDecoding type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.AssociateInlineHelp Method

PageRawFeedDecodingAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.CreateBindings Method

PageRawFeedDecodingCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Dispose Method

PageRawFeedDecodingDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Dispose Method (Boolean)

PageRawFeedDecodingDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageRawFeedDecoding Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding Events

PageRawFeedDecoding Events

The PageRawFeedDecoding type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding Fields

PageRawFeedDecoding Fields

The PageRawFeedDecoding type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageRawFeedDecoding Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Summary Class

PageRawFeedDecodingSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageRawFeedDecodingSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageRawFeedDecodingSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageRawFeedDecodingSummary | Initializes a new instance of the PageRawFeedDecodingSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Summary Constructor

PageRawFeedDecodingSummary Constructor
Initializes a new instance of the PageRawFeedDecodingSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageRawFeedDecodingSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Summary.PageIcon Property

PageRawFeedDecodingSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Summary.PageTitle Property

PageRawFeedDecodingSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageRawFeedDecodingSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Summary.AssociateValidationFields Method

PageRawFeedDecodingSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRawFeedDecoding.Summary.DoCreatePage Method

PageRawFeedDecodingSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageRawFeedDecodingSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageRawFeedDecodingSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer Class

PageRebroadcastServer Class
Displays the settings for an individual rebroadcast server.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageRebroadcastServer

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageRebroadcastServer : Page
Public Class PageRebroadcastServer
    Inherits Page
public ref class PageRebroadcastServer : public Page
type PageRebroadcastServer =
    class
        inherit Page
    end

The PageRebroadcastServer type exposes the following members.

Constructors
 | Name | Description
Public method | PageRebroadcastServer | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RebroadcastSettings | See base docs.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | See base docs. (Overrides PageOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer Constructor

PageRebroadcastServer Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageRebroadcastServer()
Public Sub New
public:
PageRebroadcastServer()
new : unit -> PageRebroadcastServer
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer Properties

PageRebroadcastServer Properties

The PageRebroadcastServer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RebroadcastSettings | See base docs.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.PageUseFullHeight Property

PageRebroadcastServerPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.RebroadcastSettings Property

PageRebroadcastServerRebroadcastSettings Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastSettings RebroadcastSettings { get; }
Public ReadOnly Property RebroadcastSettings As RebroadcastSettings
    Get
public:
property RebroadcastSettings^ RebroadcastSettings {
    RebroadcastSettings^ get ();
}
member RebroadcastSettings : RebroadcastSettings with get

Property Value

Type: RebroadcastSettings
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer Methods

PageRebroadcastServer Methods

The PageRebroadcastServer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | See base docs. (Overrides PageOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.AssociateInlineHelp Method

PageRebroadcastServerAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.CreateBindings Method

PageRebroadcastServerCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Dispose Method

PageRebroadcastServerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Dispose Method (Boolean)

PageRebroadcastServerDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageRebroadcastServer Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.InitialiseControls Method

PageRebroadcastServerInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.OnLoad Method

PageRebroadcastServerOnLoad Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
protected:
virtual void OnLoad(
    EventArgs^ e
) override
abstract OnLoad :
        e : EventArgs -> unit
override OnLoad :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer Events

PageRebroadcastServer Events

The PageRebroadcastServer type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer Fields

PageRebroadcastServer Fields

The PageRebroadcastServer type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageRebroadcastServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Summary Class

PageRebroadcastServerSummary Class
The summary object for rebroadcast server pages.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageRebroadcastServerSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageRebroadcastServerSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageRebroadcastServerSummary | Creates a new object.
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | RebroadcastSettings | See base docs.
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Summary Constructor

PageRebroadcastServerSummary Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageRebroadcastServerSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | RebroadcastSettings | See base docs.
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Summary.PageIcon Property

PageRebroadcastServerSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Summary.RebroadcastSettings Property

PageRebroadcastServerSummaryRebroadcastSettings Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RebroadcastSettings RebroadcastSettings { get; }
Public ReadOnly Property RebroadcastSettings As RebroadcastSettings
    Get
public:
property RebroadcastSettings^ RebroadcastSettings {
    RebroadcastSettings^ get ();
}
member RebroadcastSettings : RebroadcastSettings with get

Property Value

Type: RebroadcastSettings
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageRebroadcastServerSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Summary.AssociateValidationFields Method

PageRebroadcastServerSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServer.Summary.DoCreatePage Method

PageRebroadcastServerSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageRebroadcastServerSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageRebroadcastServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers Class

PageRebroadcastServers Class
Shows the user all of the rebroadcast servers currently configured, lets them add new ones, remove existing ones etc.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageRebroadcastServers

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageRebroadcastServers : Page
Public Class PageRebroadcastServers
    Inherits Page
public ref class PageRebroadcastServers : public Page
type PageRebroadcastServers =
    class
        inherit Page
    end

The PageRebroadcastServers type exposes the following members.

Constructors
 | Name | Description
Public method | PageRebroadcastServers | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers Constructor

PageRebroadcastServers Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageRebroadcastServers()
Public Sub New
public:
PageRebroadcastServers()
new : unit -> PageRebroadcastServers
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers Properties

PageRebroadcastServers Properties

The PageRebroadcastServers type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.PageUseFullHeight Property

PageRebroadcastServersPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers Methods

PageRebroadcastServers Methods

The PageRebroadcastServers type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.CreateBindings Method

PageRebroadcastServersCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Dispose Method

PageRebroadcastServersDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Dispose Method (Boolean)

PageRebroadcastServersDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageRebroadcastServers Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers Events

PageRebroadcastServers Events

The PageRebroadcastServers type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers Fields

PageRebroadcastServers Fields

The PageRebroadcastServers type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageRebroadcastServers Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Summary Class

PageRebroadcastServersSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageRebroadcastServersSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageRebroadcastServersSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageRebroadcastServersSummary | Initializes a new instance of the PageRebroadcastServersSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Summary Constructor

PageRebroadcastServersSummary Constructor
Initializes a new instance of the PageRebroadcastServersSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageRebroadcastServersSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Summary.PageIcon Property

PageRebroadcastServersSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Summary.PageTitle Property

PageRebroadcastServersSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageRebroadcastServersSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Summary.AssociateChildPages Method

PageRebroadcastServersSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageRebroadcastServers.Summary.DoCreatePage Method

PageRebroadcastServersSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageRebroadcastServersSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageRebroadcastServersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver Class

PageReceiver Class
The options data entry page for a receiver.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageReceiver

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageReceiver : Page
Public Class PageReceiver
    Inherits Page
public ref class PageReceiver : public Page
type PageReceiver =
    class
        inherit Page
    end

The PageReceiver type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiver | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Receiver | See base docs.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | See base docs. (Overrides PageOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceiver Constructor

PageReceiver Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageReceiver()
Public Sub New
public:
PageReceiver()
new : unit -> PageReceiver
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver Properties

PageReceiver Properties

The PageReceiver type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Receiver | See base docs.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Receiver Property

PageReceiverReceiver Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Receiver Receiver { get; }
Public ReadOnly Property Receiver As Receiver
    Get
public:
property Receiver^ Receiver {
    Receiver^ get ();
}
member Receiver : Receiver with get

Property Value

Type: Receiver
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver Methods

PageReceiver Methods

The PageReceiver type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | See base docs. (Overrides PageOnLoad(EventArgs).)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.AssociateInlineHelp Method

PageReceiverAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.CreateBindings Method

PageReceiverCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Dispose Method

PageReceiverDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Dispose Method (Boolean)

PageReceiverDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageReceiver Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.InitialiseControls Method

PageReceiverInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.OnLoad Method

PageReceiverOnLoad Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
protected:
virtual void OnLoad(
    EventArgs^ e
) override
abstract OnLoad :
        e : EventArgs -> unit
override OnLoad :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver Events

PageReceiver Events

The PageReceiver type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver Fields

PageReceiver Fields

The PageReceiver type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageReceiver Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Summary Class

PageReceiverSummary Class
The summary for receiver pages.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageReceiverSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageReceiverSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiverSummary | Creates a new object.
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | Receiver | See base docs.
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Summary Constructor

PageReceiverSummary Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageReceiverSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | Receiver | See base docs.
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Summary.PageIcon Property

PageReceiverSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Summary.Receiver Property

PageReceiverSummaryReceiver Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Receiver Receiver { get; }
Public ReadOnly Property Receiver As Receiver
    Get
public:
property Receiver^ Receiver {
    Receiver^ get ();
}
member Receiver : Receiver with get

Property Value

Type: Receiver
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageReceiverSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Summary.AssociateValidationFields Method

PageReceiverSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiver.Summary.DoCreatePage Method

PageReceiverSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageReceiverSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiverSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation Class

PageReceiverLocation Class
Allows data entry for a single receiver location.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageReceiverLocation

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageReceiverLocation : Page
Public Class PageReceiverLocation
    Inherits Page
public ref class PageReceiverLocation : public Page
type PageReceiverLocation =
    class
        inherit Page
    end

The PageReceiverLocation type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiverLocation | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReceiverLocation | See base docs.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation Constructor

PageReceiverLocation Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageReceiverLocation()
Public Sub New
public:
PageReceiverLocation()
new : unit -> PageReceiverLocation
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation Properties

PageReceiverLocation Properties

The PageReceiverLocation type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReceiverLocation | See base docs.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.PageUseFullHeight Property

PageReceiverLocationPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.ReceiverLocation Property

PageReceiverLocationReceiverLocation Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverLocation ReceiverLocation { get; }
Public ReadOnly Property ReceiverLocation As ReceiverLocation
    Get
public:
property ReceiverLocation^ ReceiverLocation {
    ReceiverLocation^ get ();
}
member ReceiverLocation : ReceiverLocation with get

Property Value

Type: ReceiverLocation
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation Methods

PageReceiverLocation Methods

The PageReceiverLocation type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.AssociateInlineHelp Method

PageReceiverLocationAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.CreateBindings Method

PageReceiverLocationCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Dispose Method

PageReceiverLocationDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Dispose Method (Boolean)

PageReceiverLocationDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageReceiverLocation Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.InitialiseControls Method

PageReceiverLocationInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation Events

PageReceiverLocation Events

The PageReceiverLocation type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation Fields

PageReceiverLocation Fields

The PageReceiverLocation type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageReceiverLocation Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Summary Class

PageReceiverLocationSummary Class
The summary for receiver location pages.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageReceiverLocationSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageReceiverLocationSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiverLocationSummary | Creates a new object.
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | ReceiverLocation | See base docs.
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Summary Constructor

PageReceiverLocationSummary Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageReceiverLocationSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | ReceiverLocation | See base docs.
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Summary.PageIcon Property

PageReceiverLocationSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Summary.ReceiverLocation Property

PageReceiverLocationSummaryReceiverLocation Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReceiverLocation ReceiverLocation { get; }
Public ReadOnly Property ReceiverLocation As ReceiverLocation
    Get
public:
property ReceiverLocation^ ReceiverLocation {
    ReceiverLocation^ get ();
}
member ReceiverLocation : ReceiverLocation with get

Property Value

Type: ReceiverLocation
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageReceiverLocationSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Summary.AssociateValidationFields Method

PageReceiverLocationSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocation.Summary.DoCreatePage Method

PageReceiverLocationSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageReceiverLocationSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiverLocationSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations Class

PageReceiverLocations Class
The parent page for all receiver locations.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageReceiverLocations

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageReceiverLocations : Page
Public Class PageReceiverLocations
    Inherits Page
public ref class PageReceiverLocations : public Page
type PageReceiverLocations =
    class
        inherit Page
    end

The PageReceiverLocations type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiverLocations | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations Constructor

PageReceiverLocations Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageReceiverLocations()
Public Sub New
public:
PageReceiverLocations()
new : unit -> PageReceiverLocations
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations Properties

PageReceiverLocations Properties

The PageReceiverLocations type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.PageUseFullHeight Property

PageReceiverLocationsPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations Methods

PageReceiverLocations Methods

The PageReceiverLocations type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.AssociateInlineHelp Method

PageReceiverLocationsAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.CreateBindings Method

PageReceiverLocationsCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Dispose Method

PageReceiverLocationsDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Dispose Method (Boolean)

PageReceiverLocationsDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageReceiverLocations Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations Events

PageReceiverLocations Events

The PageReceiverLocations type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations Fields

PageReceiverLocations Fields

The PageReceiverLocations type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageReceiverLocations Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Summary Class

PageReceiverLocationsSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageReceiverLocationsSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageReceiverLocationsSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiverLocationsSummary | Initializes a new instance of the PageReceiverLocationsSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Summary Constructor

PageReceiverLocationsSummary Constructor
Initializes a new instance of the PageReceiverLocationsSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageReceiverLocationsSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Summary.PageIcon Property

PageReceiverLocationsSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Summary.PageTitle Property

PageReceiverLocationsSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageReceiverLocationsSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Summary.AssociateChildPages Method

PageReceiverLocationsSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceiverLocations.Summary.DoCreatePage Method

PageReceiverLocationsSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageReceiverLocationsSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiverLocationsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers Class

PageReceivers Class
The parent page for all receivers.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageReceivers

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageReceivers : Page
Public Class PageReceivers
    Inherits Page
public ref class PageReceivers : public Page
type PageReceivers =
    class
        inherit Page
    end

The PageReceivers type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceivers | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceivers Constructor

PageReceivers Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageReceivers()
Public Sub New
public:
PageReceivers()
new : unit -> PageReceivers
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers Properties

PageReceivers Properties

The PageReceivers type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.PageUseFullHeight Property

PageReceiversPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers Methods

PageReceivers Methods

The PageReceivers type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.AssociateInlineHelp Method

PageReceiversAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.CreateBindings Method

PageReceiversCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Dispose Method

PageReceiversDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Dispose Method (Boolean)

PageReceiversDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageReceivers Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.InitialiseControls Method

PageReceiversInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers Events

PageReceivers Events

The PageReceivers type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers Fields

PageReceivers Fields

The PageReceivers type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageReceivers Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary Class

PageReceiversSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageReceiversSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageReceiversSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageReceiversSummary | Initializes a new instance of the PageReceiversSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary Constructor

PageReceiversSummary Constructor
Initializes a new instance of the PageReceiversSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageReceiversSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary.PageIcon Property

PageReceiversSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary.PageTitle Property

PageReceiversSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageReceiversSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary.AssociateChildPages Method

PageReceiversSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary.AssociateValidationFields Method

PageReceiversSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageReceivers.Summary.DoCreatePage Method

PageReceiversSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageReceiversSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageReceiversSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary Class

PageSummary Class
A class that exposes the summary information for a Page.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
More...

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PageSummary
Public MustInherit Class PageSummary
public ref class PageSummary abstract
[<AbstractClassAttribute>]
type PageSummary =  class end

The PageSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageSummary | Creates a new object.
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries.
Public property | Page | Gets or sets the page associated with the summary.
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages.
Public property | PageIcon | Gets the icon for the page.
Public property | PageObject | Gets the settings object being modified by this page.
Public property | PageTitle | Gets the title for the page.
Public property | SettingsView | Gets or sets the view that owns this summary.
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list.
Public property | TreeNode | Gets or sets the tree node that represents this summary.
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything).
Public method | AssociateValidationFields | Associates controls with validation fields.
Public method | CreatePage | Creates the page for display.
Protected method | DoCreatePage | Creates the page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher.
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher.
Public method | SetValidationFields | Records which controls display which validation fields.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent.
Top
Remarks

In beta testing of the new options screens it was found that the options screen for installations with a large number of feeds were taking a very long time to open. This was because each page is a user control, and all of the user controls had to be created before the screen was shown.

Having pages as user controls is quite attractive for a number of reasons, but a way had to be found to defer the creation of them until the user actually wants them. To this end we have this object. It carries the information that the options screen tree view needs from a page and it also carries the page itself. The page summaries are created by the options screen and associated with tree view nodes. When the user clicks a node, or causes a node to be selected, the code creates the page (if it doesn't already exist) and adds it to the options screen. The options screen opens faster but the drawback is that switching to a new page has some overhead while the page is created.

See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageDataSourcesSummary
VirtualRadar.WinForms.SettingPagePageGeneralSummary
VirtualRadar.WinForms.SettingPagePageMergedFeedSummary
VirtualRadar.WinForms.SettingPagePageMergedFeedsSummary
VirtualRadar.WinForms.SettingPagePageMonoSummary
VirtualRadar.WinForms.SettingPagePageRawFeedDecodingSummary
VirtualRadar.WinForms.SettingPagePageRebroadcastServerSummary
VirtualRadar.WinForms.SettingPagePageRebroadcastServersSummary
VirtualRadar.WinForms.SettingPagePageReceiverSummary
VirtualRadar.WinForms.SettingPagePageReceiverLocationSummary
VirtualRadar.WinForms.SettingPagePageReceiverLocationsSummary
VirtualRadar.WinForms.SettingPagePageReceiversSummary
VirtualRadar.WinForms.SettingPagePageUserSummary
VirtualRadar.WinForms.SettingPagePageUsersSummary
VirtualRadar.WinForms.SettingPagePageWebServerSummary
VirtualRadar.WinForms.SettingPagePageWebServerAdministratorsSummary
VirtualRadar.WinForms.SettingPagePageWebServerUsersSummary
VirtualRadar.WinForms.SettingPagePageWebSiteSummary
VirtualRadar.WinForms.SettingPagePageWebSiteInitialSettingsSummary


PageSummary Constructor

PageSummary Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageSummary()
Public Sub New
public:
PageSummary()
new : unit -> PageSummary
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary Properties

PageSummary Properties

The PageSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries.
Public property | Page | Gets or sets the page associated with the summary.
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages.
Public property | PageIcon | Gets the icon for the page.
Public property | PageObject | Gets the settings object being modified by this page.
Public property | PageTitle | Gets the title for the page.
Public property | SettingsView | Gets or sets the view that owns this summary.
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list.
Public property | TreeNode | Gets or sets the tree node that represents this summary.
Top
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.ChildPages Property

PageSummaryChildPages Property
Gets a list of all child summaries.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyList<PageSummary> ChildPages { get; }
Public ReadOnly Property ChildPages As NotifyList(Of PageSummary)
    Get
public:
property NotifyList<PageSummary^>^ ChildPages {
    NotifyList<PageSummary^>^ get ();
}
member ChildPages : NotifyList<PageSummary> with get

Property Value

Type: NotifyList PageSummary
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.Page Property

PageSummaryPage Property
Gets or sets the page associated with the summary.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Page Page { get; set; }
Public Property Page As Page
    Get
    Set
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}
member Page : Page with get, set

Property Value

Type: Page
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.PageEnabled Property

PageSummaryPageEnabled Property
Gets a value indicating that the page should be shown as enabled in the list of pages.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PageEnabled { get; }
Public Overridable ReadOnly Property PageEnabled As Boolean
    Get
public:
virtual property bool PageEnabled {
    bool get ();
}
abstract PageEnabled : bool with get
override PageEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.PageIcon Property

PageSummaryPageIcon Property
Gets the icon for the page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Image PageIcon { get; }
Public Overridable ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get ();
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.PageObject Property

PageSummaryPageObject Property
Gets the settings object being modified by this page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object PageObject { get; protected set; }
Public Overridable Property PageObject As Object
    Get
    Protected Set
public:
virtual property Object^ PageObject {
    Object^ get ();
    protected: void set (Object^ value);
}
abstract PageObject : Object with get, set
override PageObject : Object with get, set

Property Value

Type: Object
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.PageTitle Property

PageSummaryPageTitle Property
Gets the title for the page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string PageTitle { get; }
Public Overridable ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get ();
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.SettingsView Property

PageSummarySettingsView Property
Gets or sets the view that owns this summary.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SettingsView SettingsView { get; set; }
Public Property SettingsView As SettingsView
    Get
    Set
public:
property SettingsView^ SettingsView {
    SettingsView^ get ();
    void set (SettingsView^ value);
}
member SettingsView : SettingsView with get, set

Property Value

Type: SettingsView
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.ShowChildPagesInAlphabeticalOrder Property

PageSummaryShowChildPagesInAlphabeticalOrder Property
Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowChildPagesInAlphabeticalOrder { get; }
Public Overridable ReadOnly Property ShowChildPagesInAlphabeticalOrder As Boolean
    Get
public:
virtual property bool ShowChildPagesInAlphabeticalOrder {
    bool get ();
}
abstract ShowChildPagesInAlphabeticalOrder : bool with get
override ShowChildPagesInAlphabeticalOrder : bool with get

Property Value

Type: Boolean
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.TreeNode Property

PageSummaryTreeNode Property
Gets or sets the tree node that represents this summary.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeNode TreeNode { get; set; }
Public Property TreeNode As TreeNode
    Get
    Set
public:
property TreeNode^ TreeNode {
    TreeNode^ get ();
    void set (TreeNode^ value);
}
member TreeNode : TreeNode with get, set

Property Value

Type: TreeNode
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary Methods

PageSummary Methods

The PageSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything).
Public method | AssociateValidationFields | Associates controls with validation fields.
Public method | CreatePage | Creates the page for display.
Protected method | DoCreatePage | Creates the page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher.
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher.
Public method | SetValidationFields | Records which controls display which validation fields.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.AssociateChildPages Method

PageSummaryAssociateChildPages Method
Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything).

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void AssociateChildPages()
Protected Overridable Sub AssociateChildPages
protected:
virtual void AssociateChildPages()
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.AssociateValidationFields Method

PageSummaryAssociateValidationFields Method
Associates controls with validation fields.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AssociateValidationFields(
    Page genericPage
)
Public Overridable Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
)
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.CreatePage Method

PageSummaryCreatePage Method
Creates the page for display.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CreatePage()
Public Sub CreatePage
public:
void CreatePage()
member CreatePage : unit -> unit
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.DoCreatePage Method

PageSummaryDoCreatePage Method
Creates the page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract Page DoCreatePage()
Protected MustOverride Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() abstract
abstract DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.GetControlForValidationField Method

PageSummaryGetControlForValidationField Method
Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Control GetControlForValidationField(
    Object pageObject,
    ValidationField validationField,
    bool isClearMessage
)
Public Function GetControlForValidationField (
    pageObject As Object,
    validationField As ValidationField,
    isClearMessage As Boolean
) As Control
public:
Control^ GetControlForValidationField(
    Object^ pageObject,
    ValidationField validationField,
    bool isClearMessage
)
member GetControlForValidationField :
        pageObject : Object *
        validationField : ValidationField *
        isClearMessage : bool -> Control

Parameters

pageObject
Type: SystemObject
validationField
Type: VirtualRadar.Interface.ViewValidationField
isClearMessage
Type: SystemBoolean

Return Value

Type: Control
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.SetPageEnabledProperty(T) Method

PageSummarySetPageEnabledPropertyT Method
Sets up the automatic page enabled fetcher.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void SetPageEnabledProperty<T>(
    Expression<Func<T, Object>> pageEnabledProperty,
    Func<bool> pageEnabledFetcher
)

Protected Sub SetPageEnabledProperty(Of T) (
    pageEnabledProperty As Expression(Of Func(Of T, Object)),
    pageEnabledFetcher As Func(Of Boolean)
)
protected:
generic<typename T>
void SetPageEnabledProperty(
    Expression<Func<T, Object^>^>^ pageEnabledProperty,
    Func<bool>^ pageEnabledFetcher
)
member SetPageEnabledProperty :
        pageEnabledProperty : Expression<Func<'T, Object>> *
        pageEnabledFetcher : Func<bool> -> unit

Parameters

pageEnabledProperty
Type: System.Linq.ExpressionsExpression Func T, Object
A LINQ expression that gives the name of the page enabled property. Set to null if the page enabled state is not held by a single property.
pageEnabledFetcher
Type: SystemFunc Boolean
A function that returns the current value for the page enabled state.

Type Parameters

T
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.SetPageTitleProperty(T) Method

PageSummarySetPageTitlePropertyT Method
Sets up the automatic page title fetcher.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected void SetPageTitleProperty<T>(
    Expression<Func<T, Object>> pageTitleProperty,
    Func<string> pageTitleFetcher
)

Protected Sub SetPageTitleProperty(Of T) (
    pageTitleProperty As Expression(Of Func(Of T, Object)),
    pageTitleFetcher As Func(Of String)
)
protected:
generic<typename T>
void SetPageTitleProperty(
    Expression<Func<T, Object^>^>^ pageTitleProperty,
    Func<String^>^ pageTitleFetcher
)
member SetPageTitleProperty :
        pageTitleProperty : Expression<Func<'T, Object>> *
        pageTitleFetcher : Func<string> -> unit

Parameters

pageTitleProperty
Type: System.Linq.ExpressionsExpression Func T, Object
A LINQ expression that gives the name of the page title property. Set to null if the page title is a composite of many properties.
pageTitleFetcher
Type: SystemFunc String
A function that returns the current value for the page title.

Type Parameters

T
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary.SetValidationFields Method

PageSummarySetValidationFields Method
Records which controls display which validation fields.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValidationFields(
    Dictionary<ValidationField, Control> fields
)
Public Sub SetValidationFields (
    fields As Dictionary(Of ValidationField, Control)
)
public:
void SetValidationFields(
    Dictionary<ValidationField, Control^>^ fields
)
member SetValidationFields :
        fields : Dictionary<ValidationField, Control> -> unit

Parameters

fields
Type: System.Collections.GenericDictionary ValidationField, Control
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary Fields

PageSummary Fields

The PageSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent.
Top
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageSummary._ValidationFieldControlMap Field

PageSummary_ValidationFieldControlMap Field
A map of validation fields to the controls that they represent.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Dictionary<ValidationField, Control> _ValidationFieldControlMap
Protected _ValidationFieldControlMap As Dictionary(Of ValidationField, Control)
protected:
Dictionary<ValidationField, Control^>^ _ValidationFieldControlMap
val mutable _ValidationFieldControlMap: Dictionary<ValidationField, Control>

Field Value

Type: Dictionary ValidationField, Control
See Also

Reference

PageSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser Class

PageUser Class
Displays a single user's details and accepts edits to them.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageUser

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageUser : Page
Public Class PageUser
    Inherits Page
public ref class PageUser : public Page
type PageUser =
    class
        inherit Page
    end

The PageUser type exposes the following members.

Constructors
 | Name | Description
Public method | PageUser | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | User | See base docs.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageUser Constructor

PageUser Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageUser()
Public Sub New
public:
PageUser()
new : unit -> PageUser
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser Properties

PageUser Properties

The PageUser type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | User | See base docs.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.User Property

PageUserUser Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IUser User { get; }
Public ReadOnly Property User As IUser
    Get
public:
property IUser^ User {
    IUser^ get ();
}
member User : IUser with get

Property Value

Type: IUser
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser Methods

PageUser Methods

The PageUser type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.AssociateInlineHelp Method

PageUserAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.CreateBindings Method

PageUserCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Dispose Method

PageUserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Dispose Method (Boolean)

PageUserDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageUser Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageUser.InitialiseControls Method

PageUserInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser Events

PageUser Events

The PageUser type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser Fields

PageUser Fields

The PageUser type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageUser Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Summary Class

PageUserSummary Class
Describes the content of the user page.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageUserSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageUserSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageUserSummary | Creates a new object.
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Public property | User | See base docs.
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageUser.Summary Constructor

PageUserSummary Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageUserSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | Gets the title for the page. (Inherited from PageSummary.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Public property | User | See base docs.
Top
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Summary.PageIcon Property

PageUserSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Summary.User Property

PageUserSummaryUser Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IUser User { get; }
Public ReadOnly Property User As IUser
    Get
public:
property IUser^ User {
    IUser^ get ();
}
member User : IUser with get

Property Value

Type: IUser
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageUserSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Summary.AssociateValidationFields Method

PageUserSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUser.Summary.DoCreatePage Method

PageUserSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageUserSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageUserSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers Class

PageUsers Class
Displays and allows for the editing of the list of users.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageUsers

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageUsers : Page
Public Class PageUsers
    Inherits Page
public ref class PageUsers : public Page
type PageUsers =
    class
        inherit Page
    end

The PageUsers type exposes the following members.

Constructors
 | Name | Description
Public method | PageUsers | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageUsers Constructor

PageUsers Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageUsers()
Public Sub New
public:
PageUsers()
new : unit -> PageUsers
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers Properties

PageUsers Properties

The PageUsers type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.PageUseFullHeight Property

PageUsersPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers Methods

PageUsers Methods

The PageUsers type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.CreateBindings Method

PageUsersCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Dispose Method

PageUsersDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Dispose Method (Boolean)

PageUsersDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageUsers Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageUsers Events

PageUsers Events

The PageUsers type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers Fields

PageUsers Fields

The PageUsers type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Summary Class

PageUsersSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageUsersSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageUsersSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageUsersSummary | Initializes a new instance of the PageUsersSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Summary Constructor

PageUsersSummary Constructor
Initializes a new instance of the PageUsersSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageUsersSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Summary.PageIcon Property

PageUsersSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Summary.PageTitle Property

PageUsersSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageUsersSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Summary.AssociateChildPages Method

PageUsersSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageUsers.Summary.DoCreatePage Method

PageUsersSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageUsersSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer Class

PageWebServer Class
Lets the user view and change the web server settings.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageWebServer

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageWebServer : Page
Public Class PageWebServer
    Inherits Page
public ref class PageWebServer : public Page
type PageWebServer =
    class
        inherit Page
    end

The PageWebServer type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebServer | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebServer Constructor

PageWebServer Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageWebServer()
Public Sub New
public:
PageWebServer()
new : unit -> PageWebServer
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer Properties

PageWebServer Properties

The PageWebServer type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer Methods

PageWebServer Methods

The PageWebServer type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.AssociateInlineHelp Method

PageWebServerAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.CreateBindings Method

PageWebServerCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Dispose Method

PageWebServerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Dispose Method (Boolean)

PageWebServerDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageWebServer Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer Events

PageWebServer Events

The PageWebServer type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer Fields

PageWebServer Fields

The PageWebServer type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageWebServer Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary Class

PageWebServerSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageWebServerSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageWebServerSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebServerSummary | Initializes a new instance of the PageWebServerSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary Constructor

PageWebServerSummary Constructor
Initializes a new instance of the PageWebServerSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageWebServerSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary.PageIcon Property

PageWebServerSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary.PageTitle Property

PageWebServerSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageWebServerSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary.AssociateChildPages Method

PageWebServerSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary.AssociateValidationFields Method

PageWebServerSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServer.Summary.DoCreatePage Method

PageWebServerSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageWebServerSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebServerSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators Class

PageWebServerAdministrators Class
Supports the configuration of the administrators user list for the site.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageWebServerAdministrators

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageWebServerAdministrators : Page
Public Class PageWebServerAdministrators
    Inherits Page
public ref class PageWebServerAdministrators : public Page
type PageWebServerAdministrators =
    class
        inherit Page
    end

The PageWebServerAdministrators type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebServerAdministrators | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators Constructor

PageWebServerAdministrators Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageWebServerAdministrators()
Public Sub New
public:
PageWebServerAdministrators()
new : unit -> PageWebServerAdministrators
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators Properties

PageWebServerAdministrators Properties

The PageWebServerAdministrators type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.PageUseFullHeight Property

PageWebServerAdministratorsPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators Methods

PageWebServerAdministrators Methods

The PageWebServerAdministrators type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.CreateBindings Method

PageWebServerAdministratorsCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Dispose Method

PageWebServerAdministratorsDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Dispose Method (Boolean)

PageWebServerAdministratorsDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageWebServerAdministrators Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators Events

PageWebServerAdministrators Events

The PageWebServerAdministrators type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators Fields

PageWebServerAdministrators Fields

The PageWebServerAdministrators type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageWebServerAdministrators Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Summary Class

PageWebServerAdministratorsSummary Class
The summary for web server authentication pages.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageWebServerAdministratorsSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageWebServerAdministratorsSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebServerAdministratorsSummary | Initializes a new instance of the PageWebServerAdministratorsSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Summary Constructor

PageWebServerAdministratorsSummary Constructor
Initializes a new instance of the PageWebServerAdministratorsSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageWebServerAdministratorsSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Summary.PageIcon Property

PageWebServerAdministratorsSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Summary.PageTitle Property

PageWebServerAdministratorsSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageWebServerAdministratorsSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerAdministrators.Summary.DoCreatePage Method

PageWebServerAdministratorsSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageWebServerAdministratorsSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebServerAdministratorsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers Class

PageWebServerUsers Class
Allows configuration of the valid user list for the web site.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageWebServerUsers

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageWebServerUsers : Page
Public Class PageWebServerUsers
    Inherits Page
public ref class PageWebServerUsers : public Page
type PageWebServerUsers =
    class
        inherit Page
    end

The PageWebServerUsers type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebServerUsers | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers Constructor

PageWebServerUsers Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageWebServerUsers()
Public Sub New
public:
PageWebServerUsers()
new : unit -> PageWebServerUsers
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers Properties

PageWebServerUsers Properties

The PageWebServerUsers type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.PageUseFullHeight Property

PageWebServerUsersPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers Methods

PageWebServerUsers Methods

The PageWebServerUsers type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | Associates controls with inline help. (Inherited from Page.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | Called before anything is bound to the controls - gives the derivee the opportunity to initialise controls that need to be initialised. (Inherited from Page.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.CreateBindings Method

PageWebServerUsersCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Dispose Method

PageWebServerUsersDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Dispose Method (Boolean)

PageWebServerUsersDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageWebServerUsers Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers Events

PageWebServerUsers Events

The PageWebServerUsers type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers Fields

PageWebServerUsers Fields

The PageWebServerUsers type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageWebServerUsers Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Summary Class

PageWebServerUsersSummary Class
The summary for web server authentication pages.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageWebServerUsersSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageWebServerUsersSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebServerUsersSummary | Initializes a new instance of the PageWebServerUsersSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Summary Constructor

PageWebServerUsersSummary Constructor
Initializes a new instance of the PageWebServerUsersSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageWebServerUsersSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Summary.PageIcon Property

PageWebServerUsersSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Summary.PageTitle Property

PageWebServerUsersSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageWebServerUsersSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | Associates controls with validation fields. (Inherited from PageSummary.)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebServerUsers.Summary.DoCreatePage Method

PageWebServerUsersSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageWebServerUsersSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebServerUsersSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite Class

PageWebSite Class
Lets the user edit the web site settings.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageWebSite

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageWebSite : Page
Public Class PageWebSite
    Inherits Page
public ref class PageWebSite : public Page
type PageWebSite =
    class
        inherit Page
    end

The PageWebSite type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebSite | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebSite Constructor

PageWebSite Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageWebSite()
Public Sub New
public:
PageWebSite()
new : unit -> PageWebSite
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite Properties

PageWebSite Properties

The PageWebSite type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | If true then the page is stretched vertically to fill the available space. (Inherited from Page.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite Methods

PageWebSite Methods

The PageWebSite type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.AssociateInlineHelp Method

PageWebSiteAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.CreateBindings Method

PageWebSiteCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Dispose Method

PageWebSiteDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Dispose Method (Boolean)

PageWebSiteDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageWebSite Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.InitialiseControls Method

PageWebSiteInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite Events

PageWebSite Events

The PageWebSite type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite Fields

PageWebSite Fields

The PageWebSite type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageWebSite Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary Class

PageWebSiteSummary Class
The page summary object.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageWebSiteSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageWebSiteSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebSiteSummary | Initializes a new instance of the PageWebSiteSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary Constructor

PageWebSiteSummary Constructor
Initializes a new instance of the PageWebSiteSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageWebSiteSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary.PageIcon Property

PageWebSiteSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary.PageTitle Property

PageWebSiteSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageWebSiteSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | See base docs. (Overrides PageSummaryAssociateChildPages.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary.AssociateChildPages Method

PageWebSiteSummaryAssociateChildPages Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateChildPages()
Protected Overrides Sub AssociateChildPages
protected:
virtual void AssociateChildPages() override
abstract AssociateChildPages : unit -> unit
override AssociateChildPages : unit -> unit
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary.AssociateValidationFields Method

PageWebSiteSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSite.Summary.DoCreatePage Method

PageWebSiteSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageWebSiteSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebSiteSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings Class

PageWebSiteInitialSettings Class
Displays the initial settings for the web site to the user and lets them change them.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
BaseUserControl
VirtualRadar.WinForms.SettingPagePage
VirtualRadar.WinForms.SettingPagePageWebSiteInitialSettings

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageWebSiteInitialSettings : Page
Public Class PageWebSiteInitialSettings
    Inherits Page
public ref class PageWebSiteInitialSettings : public Page
type PageWebSiteInitialSettings =
    class
        inherit Page
    end

The PageWebSiteInitialSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebSiteInitialSettings | Creates a new object.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings Constructor

PageWebSiteInitialSettings Constructor
Creates a new object.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageWebSiteInitialSettings()
Public Sub New
public:
PageWebSiteInitialSettings()
new : unit -> PageWebSiteInitialSettings
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings Properties

PageWebSiteInitialSettings Properties

The PageWebSiteInitialSettings type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ChildPages | Gets a collection of every child page under this page. (Inherited from Page.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsInSettingsView | Gets a value indicating that the page is on display in the SettingsView. (Inherited from Page.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageSummary | Gets or sets the page summary associated with this page. (Inherited from Page.)
Public property | PageUseFullHeight | See base docs. (Overrides PagePageUseFullHeight.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SettingsView | Gets the owning settings view. (Inherited from Page.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.PageUseFullHeight Property

PageWebSiteInitialSettingsPageUseFullHeight Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PageUseFullHeight { get; }
Public Overrides ReadOnly Property PageUseFullHeight As Boolean
    Get
public:
virtual property bool PageUseFullHeight {
    bool get () override;
}
abstract PageUseFullHeight : bool with get
override PageUseFullHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings Methods

PageWebSiteInitialSettings Methods

The PageWebSiteInitialSettings type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Protected method | AdjustFormScrollbars | (Inherited from ContainerControl.)
Protected method | AssociateInlineHelp | See base docs. (Overrides PageAssociateInlineHelp.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | ClearBindings | Removes all bindings from the page. (Inherited from Page.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Protected method | CreateBindings | See base docs. (Overrides PageCreateBindings.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialise | Initialises the page. (Inherited from Page.)
Protected method | InitialiseControls | See base docs. (Overrides PageInitialiseControls.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from ContainerControl.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Called after the page has been loaded but before it is shown to the user. (Inherited from Page.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from UserControl.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | (Inherited from ContainerControl.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from ScrollableControl.)
Protected method | ScaleCore | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetInlineHelp | Sets the inline help up for the control passed across. (Inherited from Page.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetValidationFields | Associates validation fields with controls. (Inherited from Page.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc | (Inherited from UserControl.)
Top
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.AssociateInlineHelp Method

PageWebSiteInitialSettingsAssociateInlineHelp Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void AssociateInlineHelp()
Protected Overrides Sub AssociateInlineHelp
protected:
virtual void AssociateInlineHelp() override
abstract AssociateInlineHelp : unit -> unit
override AssociateInlineHelp : unit -> unit
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.CreateBindings Method

PageWebSiteInitialSettingsCreateBindings Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void CreateBindings()
Protected Overrides Sub CreateBindings
protected:
virtual void CreateBindings() override
abstract CreateBindings : unit -> unit
override CreateBindings : unit -> unit
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Dispose Method

PageWebSiteInitialSettingsDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides PageDispose(Boolean).)
Top
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Dispose Method (Boolean)

PageWebSiteInitialSettingsDispose Method (Boolean)
Clean up any resources being used.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

PageWebSiteInitialSettings Class
Dispose Overload
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.InitialiseControls Method

PageWebSiteInitialSettingsInitialiseControls Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override void InitialiseControls()
Protected Overrides Sub InitialiseControls
protected:
virtual void InitialiseControls() override
abstract InitialiseControls : unit -> unit
override InitialiseControls : unit -> unit
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings Events

PageWebSiteInitialSettings Events

The PageWebSiteInitialSettings type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings Fields

PageWebSiteInitialSettings Fields

The PageWebSiteInitialSettings type exposes the following members.

Fields
 | Name | Description
Protected field | _InlineHelpMap | A map of controls to their inline help. (Inherited from Page.)
Top
See Also

Reference

PageWebSiteInitialSettings Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Summary Class

PageWebSiteInitialSettingsSummary Class
Describes the content of the initial site settings page.
Inheritance Hierarchy
SystemObject
VirtualRadar.WinForms.SettingPagePageSummary
VirtualRadar.WinForms.SettingPagePageWebSiteInitialSettingsSummary

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Summary : PageSummary
Public Class Summary
    Inherits PageSummary
public ref class Summary : public PageSummary
type Summary =
    class
        inherit PageSummary
    end

The PageWebSiteInitialSettingsSummary type exposes the following members.

Constructors
 | Name | Description
Public method | PageWebSiteInitialSettingsSummary | Initializes a new instance of the PageWebSiteInitialSettingsSummary class
Top
Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Summary Constructor

PageWebSiteInitialSettingsSummary Constructor
Initializes a new instance of the PageWebSiteInitialSettingsSummary class

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Summary()
Public Sub New
public:
Summary()
new : unit -> Summary
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Properties

Summary Properties

The PageWebSiteInitialSettingsSummary type exposes the following members.

Properties
 | Name | Description
Public property | ChildPages | Gets a list of all child summaries. (Inherited from PageSummary.)
Public property | Page | Gets or sets the page associated with the summary. (Inherited from PageSummary.)
Public property | PageEnabled | Gets a value indicating that the page should be shown as enabled in the list of pages. (Inherited from PageSummary.)
Public property | PageIcon | See base docs. (Overrides PageSummaryPageIcon.)
Public property | PageObject | Gets the settings object being modified by this page. (Inherited from PageSummary.)
Public property | PageTitle | See base docs. (Overrides PageSummaryPageTitle.)
Public property | SettingsView | Gets or sets the view that owns this summary. (Inherited from PageSummary.)
Public property | ShowChildPagesInAlphabeticalOrder | Gets a value indicating that child pages are to be shown in alphabetical order of PageTitle. False by default unless the child pages are associated with a list. (Inherited from PageSummary.)
Public property | TreeNode | Gets or sets the tree node that represents this summary. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Summary.PageIcon Property

PageWebSiteInitialSettingsSummaryPageIcon Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image PageIcon { get; }
Public Overrides ReadOnly Property PageIcon As Image
    Get
public:
virtual property Image^ PageIcon {
    Image^ get () override;
}
abstract PageIcon : Image with get
override PageIcon : Image with get

Property Value

Type: Image
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Summary.PageTitle Property

PageWebSiteInitialSettingsSummaryPageTitle Property
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string PageTitle { get; }
Public Overrides ReadOnly Property PageTitle As String
    Get
public:
virtual property String^ PageTitle {
    String^ get () override;
}
abstract PageTitle : string with get
override PageTitle : string with get

Property Value

Type: String
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Methods

Summary Methods

The PageWebSiteInitialSettingsSummary type exposes the following members.

Methods
 | Name | Description
Protected method | AssociateChildPages | Gives the derived class the opportunity to synchronise its child pages list with something (or just create them if they're not associated with anything). (Inherited from PageSummary.)
Public method | AssociateValidationFields | See base docs. (Overrides PageSummaryAssociateValidationFields(Page).)
Public method | CreatePage | Creates the page for display. (Inherited from PageSummary.)
Protected method | DoCreatePage | See base docs. (Overrides PageSummaryDoCreatePage.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetControlForValidationField | Returns the control associated with the field passed across. Returns null if the pageObject passed across does not match the pageObject held by the page. (Inherited from PageSummary.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetPageEnabledPropertyT | Sets up the automatic page enabled fetcher. (Inherited from PageSummary.)
Protected method | SetPageTitlePropertyT | Sets up the automatic page title fetcher. (Inherited from PageSummary.)
Public method | SetValidationFields | Records which controls display which validation fields. (Inherited from PageSummary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Summary.AssociateValidationFields Method

PageWebSiteInitialSettingsSummaryAssociateValidationFields Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AssociateValidationFields(
    Page genericPage
)
Public Overrides Sub AssociateValidationFields (
    genericPage As Page
)
public:
virtual void AssociateValidationFields(
    Page^ genericPage
) override
abstract AssociateValidationFields :
        genericPage : Page -> unit
override AssociateValidationFields :
        genericPage : Page -> unit

Parameters

genericPage
Type: VirtualRadar.WinForms.SettingPagePage
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


PageWebSiteInitialSettings.Summary.DoCreatePage Method

PageWebSiteInitialSettingsSummaryDoCreatePage Method
See base docs.

Namespace: VirtualRadar.WinForms.SettingPage
Assembly: VirtualRadar.WinForms (in VirtualRadar.WinForms.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected override Page DoCreatePage()
Protected Overrides Function DoCreatePage As Page
protected:
virtual Page^ DoCreatePage() override
abstract DoCreatePage : unit -> Page
override DoCreatePage : unit -> Page

Return Value

Type: Page
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace


Summary Fields

Summary Fields

The PageWebSiteInitialSettingsSummary type exposes the following members.

Fields
 | Name | Description
Protected field | _ValidationFieldControlMap | A map of validation fields to the controls that they represent. (Inherited from PageSummary.)
Top
See Also

Reference

PageWebSiteInitialSettingsSummary Class
VirtualRadar.WinForms.SettingPage Namespace